<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>New Music: Swizz Beatz ft. Giggs – Come Again</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="http://weuponithiphop.info/xmlrpc.php" />
    <meta property="og:image" content="http://weuponithiphop.info/wp-content/uploads/Swizz-Beatz-ft.-Giggs-Come-Again.jpg" /><meta name="author" content="cyclone">
<link rel="icon" type="image/png" href="http://weuponithiphop.info/wp-content/uploads/weuponitlogoCAP-500x457.png">
<!-- All in One SEO Pack 2.9 by Michael Torbert of Semper Fi Web Design[213,282] -->
<link rel="canonical" href="http://weuponithiphop.info/2018/10/26/new-music-swizz-beatz-ft-giggs-come-again/" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Feed" href="http://weuponithiphop.info/feed/" />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Comments Feed" href="http://weuponithiphop.info/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; New Music: Swizz Beatz ft. Giggs &#8211; Come Again Comments Feed" href="http://weuponithiphop.info/2018/10/26/new-music-swizz-beatz-ft-giggs-come-again/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/weuponithiphop.info\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wpstatistics-css-css'  href='http://weuponithiphop.info/wp-content/plugins/wp-statistics/assets/css/frontend.css?ver=12.4.3' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_open_sans-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_roboto-css'  href='http://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C900%2C500italic%2C400%2C300&#038;ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='http://fonts.googleapis.com/css?family=Roboto+Condensed%3A400%2C700&#038;ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='http://weuponithiphop.info/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=4.12' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='http://weuponithiphop.info/wp-content/themes/Newspaper/style.css?ver=7.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css'  href='http://weuponithiphop.info/wp-content/themes/Newspaper/includes/demos/what/demo_style.css?ver=7.2' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://weuponithiphop.info/wp-content/plugins/jetpack/css/jetpack.css?ver=6.6.1' type='text/css' media='all' />
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1'></script>
<link rel='https://api.w.org/' href='http://weuponithiphop.info/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://weuponithiphop.info/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://weuponithiphop.info/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Album Stream: Apollo Brown &#038; Joell Ortiz &#8211; Mona Lisa' href='http://weuponithiphop.info/2018/10/26/album-stream-apollo-brown-joell-ortiz-mona-lisa/' />
<link rel='next' title='New Music: Takeoff &#8211; The Last Memory' href='http://weuponithiphop.info/2018/10/26/new-music-takeoff-the-last-memory/' />
<meta name="generator" content="WordPress 4.9.8" />
<link rel='shortlink' href='https://wp.me/p9ZprH-45n' />
<link rel="alternate" type="application/json+oembed" href="http://weuponithiphop.info/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fweuponithiphop.info%2F2018%2F10%2F26%2Fnew-music-swizz-beatz-ft-giggs-come-again%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://weuponithiphop.info/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fweuponithiphop.info%2F2018%2F10%2F26%2Fnew-music-swizz-beatz-ft-giggs-come-again%2F&#038;format=xml" />

<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>
<script id="wpcp_disable_selection" type="text/javascript">
//<![CDATA[
var image_save_msg='You Can Not Save images!';
	var no_menu_msg='Context Menu disabled!';
	var smessage = "I\'m good love, Enjoy!! 😘😎🤓😂😂✌️";

function disableEnterKey(e)
{
	if (e.ctrlKey){
     var key;
     if(window.event)
          key = window.event.keyCode;     //IE
     else
          key = e.which;     //firefox (97)
    //if (key != 17) alert(key);
     if (key == 97 || key == 65 || key == 67 || key == 99 || key == 88 || key == 120 || key == 26 || key == 85  || key == 86 || key == 83 || key == 43)
     {
          show_wpcp_message('You are not allowed to copy content or view source');
          return false;
     }else
     	return true;
     }
}

function disable_copy(e)
{	
	var elemtype = e.target.nodeName;
	var isSafari = /Safari/.test(navigator.userAgent) && /Apple Computer/.test(navigator.vendor);
	elemtype = elemtype.toUpperCase();
	var checker_IMG = '';
	if (elemtype == "IMG" && checker_IMG == 'checked' && e.detail >= 2) {show_wpcp_message(alertMsg_IMG);return false;}
	if (elemtype != "TEXT" && elemtype != "TEXTAREA" && elemtype != "INPUT" && elemtype != "PASSWORD" && elemtype != "SELECT" && elemtype != "OPTION" && elemtype != "EMBED")
	{
		if (smessage !== "" && e.detail == 2)
			show_wpcp_message(smessage);
		
		if (isSafari)
			return true;
		else
			return false;
	}	
}
function disable_copy_ie()
{
	var elemtype = window.event.srcElement.nodeName;
	elemtype = elemtype.toUpperCase();
	if (elemtype == "IMG") {show_wpcp_message(alertMsg_IMG);return false;}
	if (elemtype != "TEXT" && elemtype != "TEXTAREA" && elemtype != "INPUT" && elemtype != "PASSWORD" && elemtype != "SELECT" && elemtype != "OPTION" && elemtype != "EMBED")
	{
		//alert(navigator.userAgent.indexOf('MSIE'));
			//if (smessage !== "") show_wpcp_message(smessage);
		return false;
	}
}	
function reEnable()
{
	return true;
}
document.onkeydown = disableEnterKey;
document.onselectstart = disable_copy_ie;
if(navigator.userAgent.indexOf('MSIE')==-1)
{
	document.onmousedown = disable_copy;
	document.onclick = reEnable;
}
function disableSelection(target)
{
    //For IE This code will work
    if (typeof target.onselectstart!="undefined")
    target.onselectstart = disable_copy_ie;
    
    //For Firefox This code will work
    else if (typeof target.style.MozUserSelect!="undefined")
    {target.style.MozUserSelect="none";}
    
    //All other  (ie: Opera) This code will work
    else
    target.onmousedown=function(){return false}
    target.style.cursor = "default";
}
//Calling the JS function directly just after body load
window.onload = function(){disableSelection(document.body);};
//]]>
</script>
	<script id="wpcp_disable_Right_Click" type="text/javascript">
	//<![CDATA[
	document.ondragstart = function() { return false;}
	/* ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
	Disable context menu on images by GreenLava Version 1.0
	^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ */
	    function nocontext(e) {
	       return false;
	    }
	    document.oncontextmenu = nocontext;
	//]]>
	</script>

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]-->
<!-- JS generated by theme -->

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var tds_login_sing_in_widget="show";
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_ajax_url="http:\/\/weuponithiphop.info\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=7.2";
var td_get_template_directory_uri="http:\/\/weuponithiphop.info\/wp-content\/themes\/Newspaper";
var tds_snap_menu="snap";
var tds_logo_on_sticky="show_header_logo";
var tds_header_style="5";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#dd3333";
var tds_smart_sidebar="enabled";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>


<!-- Header style compiled by theme -->

<style>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</style>

<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>

<body class="post-template-default single single-post postid-15709 single-format-standard unselectable new-music-swizz-beatz-ft-giggs-come-again td-what single_template_3 wpb-js-composer js-comp-ver-4.12 vc_responsive td-boxed-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
                    <div class="td-menu-login-section">
                
    <div class="td-guest-wrap">
        <div class="td-menu-avatar"><div class="td-avatar-container"><img alt='' src='http://2.gravatar.com/avatar/?s=80&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo avatar-default' height='80' width='80' /></div></div>
        <div class="td-menu-login"><a id="login-link-mob">Sign in</a></div>
    </div>
            </div>
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-top-menu-container"><ul id="menu-top-menu" class="td-mobile-main-menu"><li id="menu-item-317" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-first menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a></li>
<li id="menu-item-706" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a></li>
<li id="menu-item-314" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a></li>
<li id="menu-item-316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-0" class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></li>
</ul>
</li>
<li id="menu-item-705" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></li>
</ul>
</li>
<li id="menu-item-2515" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2515"><a href="http://weuponithiphop.info/category/editors-picks/">Editor&#8217;s Picks</a></li>
<li id="menu-item-3199" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees/">Shop</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
            <div id="login-form-mobile" class="td-register-section">
            
            <div id="td-login-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-login-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign in</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
	                <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
	                <div class="td-login-info-text"><a href="#" id="forgot-pass-link-mob">Forgot your password?</a></div>
                </div>
            </div>

            

            <div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
                <!-- close button -->
	            <div class="td-forgot-pass-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Password recovery</div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title">Recover your password</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
	                <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
                </div>
            </div>
        </div>
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="http://weuponithiphop.info/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap">
    
        <!--
Header style 5
-->

<div class="td-header-wrap td-header-style-5">

    <div class="td-header-top-menu-full">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div >

                Friday, October 26, 2018
            </div>
        </div>
    <ul class="top-header-menu td_ul_login"><li class="menu-item"><a class="td-login-modal-js menu-item" href="#login-form" data-effect="mpf-td-login-effect">Sign in / Join</a><span class="td-sp-ico-login td_sp_login_ico_style"></span></li></ul><div class="menu-top-container"><ul id="menu-main" class="top-header-menu"><li id="menu-item-79" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-79"><a href="http://weuponithiphop.info">Home</a></li>
<li id="menu-item-81" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-81"><a target="_blank" href="http://weuponitradio.com">Power 105.1 WeUpOnIt Radio</a></li>
<li id="menu-item-80" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-80"><a target="_blank" href="https://shop.spreadshirt.com/freshandcleantees/">Shop</a></li>
</ul></div></div>
        <div class="td-header-sp-top-widget">
    
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div>
    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <ul class="td-login-tabs">
                        <li><a id="login-link" class="td_login_tab_focus">LOG IN</a></li>
                    </ul>



                    <div class="td-login-wrap">
                        <div class="td_display_err"></div>

                        <div id="td-login-div" class="">
                            <div class="td-login-panel-title">Welcome! Log into your account</div>
                            <input class="td-login-input" type="text" name="login_email" id="login_email" placeholder="your username" value="" required>
                            <input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" placeholder="your password" required>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Log In">


                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password?</a></div>


                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-display-none">
                            <div class="td-login-panel-title">Recover your password</div>
                            <input class="td-login-input" type="text" name="forgot_email" id="forgot_email" placeholder="your email" value="" required>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Pass">
                        </div>




                    </div>
                </div>
                        </div>
    </div>

    <div class="td-header-menu-wrap-full">
        <div class="td-header-menu-wrap">
            <div class="td-container td-header-row td-header-main-menu black-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-menu">
        		<a class="td-mobile-logo td-sticky-header" href="http://weuponithiphop.info/">
			<img class="td-retina-data" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-5.png" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-5.png" alt=""/>
		</a>
			<a class="td-header-logo td-sticky-header" href="http://weuponithiphop.info/">
			<img class="td-retina-data" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" alt=""/>
			<span class="td-visual-hidden">WeUpOnIt</span>
		</a>
	    </div>
    <div class="menu-top-menu-container"><ul id="menu-top-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-first td-menu-item td-mega-menu menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_1_5bd33faadff6d_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_1_5bd33faadff6d" ><script>var block_td_uid_1_5bd33faadff6d = new tdBlock();
block_td_uid_1_5bd33faadff6d.id = "td_uid_1_5bd33faadff6d";
block_td_uid_1_5bd33faadff6d.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"43","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_1_5bd33faadff6d_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_1_5bd33faadff6d.td_column_number = "3";
block_td_uid_1_5bd33faadff6d.block_type = "td_block_mega_menu";
block_td_uid_1_5bd33faadff6d.post_count = "5";
block_td_uid_1_5bd33faadff6d.found_posts = "777";
block_td_uid_1_5bd33faadff6d.header_color = "";
block_td_uid_1_5bd33faadff6d.ajax_pagination_infinite_stop = "";
block_td_uid_1_5bd33faadff6d.max_num_pages = "156";
tdBlocksArray.push(block_td_uid_1_5bd33faadff6d);
</script><div id=td_uid_1_5bd33faadff6d class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/26/new-music-takeoff-the-last-memory/" rel="bookmark" title="New Music: Takeoff &#8211; The Last Memory"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Takeoff-The-Last-Memory-218x150.jpg" alt="" title="New Music: Takeoff &#8211; The Last Memory"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/26/new-music-takeoff-the-last-memory/" rel="bookmark" title="New Music: Takeoff &#8211; The Last Memory">New Music: Takeoff &#8211; The Last Memory</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/26/new-music-swizz-beatz-ft-giggs-come-again/" rel="bookmark" title="New Music: Swizz Beatz ft. Giggs &#8211; Come Again"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Swizz-Beatz-ft.-Giggs-Come-Again-218x150.jpg" alt="" title="New Music: Swizz Beatz ft. Giggs &#8211; Come Again"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/26/new-music-swizz-beatz-ft-giggs-come-again/" rel="bookmark" title="New Music: Swizz Beatz ft. Giggs &#8211; Come Again">New Music: Swizz Beatz ft. Giggs &#8211; Come Again</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/26/new-music-rapsody-ft-j-cole-sojourner/" rel="bookmark" title="New Music: Rapsody ft. J. Cole &#8211; Sojourner"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Rapsody-ft.-J.-Cole-Sojourner-218x150.jpg" alt="" title="New Music: Rapsody ft. J. Cole &#8211; Sojourner"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/26/new-music-rapsody-ft-j-cole-sojourner/" rel="bookmark" title="New Music: Rapsody ft. J. Cole &#8211; Sojourner">New Music: Rapsody ft. J. Cole &#8211; Sojourner</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/26/new-music-rob-stone-ft-p-lo-too-faded/" rel="bookmark" title="New Music: Rob Stone ft. P-Lo &#8211; Too Faded"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Rob-Stone-ft.-P-Lo-Too-Faded-218x150.jpg" alt="" title="New Music: Rob Stone ft. P-Lo &#8211; Too Faded"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/26/new-music-rob-stone-ft-p-lo-too-faded/" rel="bookmark" title="New Music: Rob Stone ft. P-Lo &#8211; Too Faded">New Music: Rob Stone ft. P-Lo &#8211; Too Faded</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/26/new-music-riff-raff-tracy-foreign-land/" rel="bookmark" title="New Music: RiFF RAFF &#038; Tracy &#8211; Foreign Land"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/RIFF-RAFF-TRACY-–-FOREIGN-LAND-218x150.jpg" alt="" title="New Music: RiFF RAFF &#038; Tracy &#8211; Foreign Land"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/26/new-music-riff-raff-tracy-foreign-land/" rel="bookmark" title="New Music: RiFF RAFF &#038; Tracy &#8211; Foreign Land">New Music: RiFF RAFF &#038; Tracy &#8211; Foreign Land</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_5bd33faadff6d" data-td_block_id="td_uid_1_5bd33faadff6d"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_1_5bd33faadff6d" data-td_block_id="td_uid_1_5bd33faadff6d"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_2_5bd33faaef196_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_2_5bd33faaef196" ><script>var block_td_uid_2_5bd33faaef196 = new tdBlock();
block_td_uid_2_5bd33faaef196.id = "td_uid_2_5bd33faaef196";
block_td_uid_2_5bd33faaef196.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"97","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_2_5bd33faaef196_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_2_5bd33faaef196.td_column_number = "3";
block_td_uid_2_5bd33faaef196.block_type = "td_block_mega_menu";
block_td_uid_2_5bd33faaef196.post_count = "5";
block_td_uid_2_5bd33faaef196.found_posts = "260";
block_td_uid_2_5bd33faaef196.header_color = "";
block_td_uid_2_5bd33faaef196.ajax_pagination_infinite_stop = "";
block_td_uid_2_5bd33faaef196.max_num_pages = "52";
tdBlocksArray.push(block_td_uid_2_5bd33faaef196);
</script><div id=td_uid_2_5bd33faaef196 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/26/mixtape-tory-lanez-love-me-now/" rel="bookmark" title="Mixtape: Tory Lanez &#8211; LoVE mE NOw"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Tory-Lanez-LoVE-mE-NOw-218x150.jpg" alt="" title="Mixtape: Tory Lanez &#8211; LoVE mE NOw"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/26/mixtape-tory-lanez-love-me-now/" rel="bookmark" title="Mixtape: Tory Lanez &#8211; LoVE mE NOw">Mixtape: Tory Lanez &#8211; LoVE mE NOw</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/26/album-stream-jeremih-ty-dolla-sign-mih-ty/" rel="bookmark" title="Album Stream: Jeremih &#038; Ty Dolla Sign &#8211; MIH-TY"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Jeremih-Ty-Dolla-Sign-MIH-TY-218x150.jpg" alt="" title="Album Stream: Jeremih &#038; Ty Dolla Sign &#8211; MIH-TY"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/26/album-stream-jeremih-ty-dolla-sign-mih-ty/" rel="bookmark" title="Album Stream: Jeremih &#038; Ty Dolla Sign &#8211; MIH-TY">Album Stream: Jeremih &#038; Ty Dolla Sign &#8211; MIH-TY</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/26/album-stream-apollo-brown-joell-ortiz-mona-lisa/" rel="bookmark" title="Album Stream: Apollo Brown &#038; Joell Ortiz &#8211; Mona Lisa"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Apollo-Brown-Joell-Ortiz-Mona-Lisa-218x150.jpg" alt="" title="Album Stream: Apollo Brown &#038; Joell Ortiz &#8211; Mona Lisa"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/26/album-stream-apollo-brown-joell-ortiz-mona-lisa/" rel="bookmark" title="Album Stream: Apollo Brown &#038; Joell Ortiz &#8211; Mona Lisa">Album Stream: Apollo Brown &#038; Joell Ortiz &#8211; Mona Lisa</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/26/album-stream-madeintyo-sincerely-tokyo/" rel="bookmark" title="Album Stream: MadeinTYO &#8211; Sincerely, Tokyo"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/MadeinTYO-Sincerely-Tokyo-218x150.jpg" alt="" title="Album Stream: MadeinTYO &#8211; Sincerely, Tokyo"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/26/album-stream-madeintyo-sincerely-tokyo/" rel="bookmark" title="Album Stream: MadeinTYO &#8211; Sincerely, Tokyo">Album Stream: MadeinTYO &#8211; Sincerely, Tokyo</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/25/ep-stream-leikeli47-pick-a-color/" rel="bookmark" title="EP Stream: Leikeli47 – Pick A Color"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Leikeli47-–-Pick-A-Color-218x150.jpg" alt="" title="EP Stream: Leikeli47 – Pick A Color"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/25/ep-stream-leikeli47-pick-a-color/" rel="bookmark" title="EP Stream: Leikeli47 – Pick A Color">EP Stream: Leikeli47 – Pick A Color</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_5bd33faaef196" data-td_block_id="td_uid_2_5bd33faaef196"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_2_5bd33faaef196" data-td_block_id="td_uid_2_5bd33faaef196"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_3_5bd33fab08867_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_3_5bd33fab08867" ><script>var block_td_uid_3_5bd33fab08867 = new tdBlock();
block_td_uid_3_5bd33fab08867.id = "td_uid_3_5bd33fab08867";
block_td_uid_3_5bd33fab08867.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_3_5bd33fab08867_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_3_5bd33fab08867.td_column_number = "3";
block_td_uid_3_5bd33fab08867.block_type = "td_block_mega_menu";
block_td_uid_3_5bd33fab08867.post_count = "5";
block_td_uid_3_5bd33fab08867.found_posts = "616";
block_td_uid_3_5bd33fab08867.header_color = "";
block_td_uid_3_5bd33fab08867.ajax_pagination_infinite_stop = "";
block_td_uid_3_5bd33fab08867.max_num_pages = "124";
tdBlocksArray.push(block_td_uid_3_5bd33fab08867);
</script><div id=td_uid_3_5bd33fab08867 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/25/music-video-kevo-sabe-fuck-with-me/" rel="bookmark" title="Music Video: Kevo Sabe &#8211; Fuck With Me"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Kevo-Sabe-Fuck-With-Me-1-218x150.jpg" alt="" title="Music Video: Kevo Sabe &#8211; Fuck With Me"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/25/music-video-kevo-sabe-fuck-with-me/" rel="bookmark" title="Music Video: Kevo Sabe &#8211; Fuck With Me">Music Video: Kevo Sabe &#8211; Fuck With Me</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/25/music-video-hardo-my-last/" rel="bookmark" title="Music Video: Hardo &#8211; My Last"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Hardo-My-Last-218x150.jpg" alt="" title="Music Video: Hardo &#8211; My Last"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/25/music-video-hardo-my-last/" rel="bookmark" title="Music Video: Hardo &#8211; My Last">Music Video: Hardo &#8211; My Last</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/25/music-video-yung-lean-happy-feet/" rel="bookmark" title="Music Video: Yung Lean – Happy Feet"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Yung-Lean-–-Happy-Feet-218x150.jpg" alt="" title="Music Video: Yung Lean – Happy Feet"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/25/music-video-yung-lean-happy-feet/" rel="bookmark" title="Music Video: Yung Lean – Happy Feet">Music Video: Yung Lean – Happy Feet</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/25/music-video-wizkid-fever/" rel="bookmark" title="Music Video: Wizkid – Fever"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Wizkid-–-Fever-218x150.jpg" alt="" title="Music Video: Wizkid – Fever"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/25/music-video-wizkid-fever/" rel="bookmark" title="Music Video: Wizkid – Fever">Music Video: Wizkid – Fever</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/25/music-video-the-alchemist-ft-conway-westside-gunn-schoolboy-q-fork-in-the-pot/" rel="bookmark" title="Music Video: The Alchemist ft. Conway, Westside Gunn &#038; ScHoolboy Q – Fork In The Pot"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/The-Alchemist-ft.-Conway-Westside-Gunn-ScHoolboy-Q-–-Fork-In-The-Pot-218x150.jpg" alt="" title="Music Video: The Alchemist ft. Conway, Westside Gunn &#038; ScHoolboy Q – Fork In The Pot"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/25/music-video-the-alchemist-ft-conway-westside-gunn-schoolboy-q-fork-in-the-pot/" rel="bookmark" title="Music Video: The Alchemist ft. Conway, Westside Gunn &#038; ScHoolboy Q – Fork In The Pot">Music Video: The Alchemist ft. Conway, Westside Gunn &#038; ScHoolboy Q&#8230;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_5bd33fab08867" data-td_block_id="td_uid_3_5bd33fab08867"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_3_5bd33fab08867" data-td_block_id="td_uid_3_5bd33fab08867"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_4_5bd33fab15cc5_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_4_5bd33fab15cc5" ><script>var block_td_uid_4_5bd33fab15cc5 = new tdBlock();
block_td_uid_4_5bd33fab15cc5.id = "td_uid_4_5bd33fab15cc5";
block_td_uid_4_5bd33fab15cc5.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"29","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_4_5bd33fab15cc5_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_4_5bd33fab15cc5.td_column_number = "3";
block_td_uid_4_5bd33fab15cc5.block_type = "td_block_mega_menu";
block_td_uid_4_5bd33fab15cc5.post_count = "4";
block_td_uid_4_5bd33fab15cc5.found_posts = "299";
block_td_uid_4_5bd33fab15cc5.header_color = "";
block_td_uid_4_5bd33fab15cc5.ajax_pagination_infinite_stop = "";
block_td_uid_4_5bd33fab15cc5.max_num_pages = "75";
tdBlocksArray.push(block_td_uid_4_5bd33fab15cc5);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_4_5bd33fab15cc5" id="td_uid_5_5bd33fab19673" data-td_block_id="td_uid_4_5bd33fab15cc5" data-td_filter_value="" href="http://weuponithiphop.info/category/latest-news/">All</a><a class="mega-menu-sub-cat-td_uid_4_5bd33fab15cc5"  id="td_uid_6_5bd33fab197b1" data-td_block_id="td_uid_4_5bd33fab15cc5" data-td_filter_value="69" href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a><a class="mega-menu-sub-cat-td_uid_4_5bd33fab15cc5"  id="td_uid_7_5bd33fab1990b" data-td_block_id="td_uid_4_5bd33fab15cc5" data-td_filter_value="80" href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a><a class="mega-menu-sub-cat-td_uid_4_5bd33fab15cc5"  id="td_uid_8_5bd33fab19a58" data-td_block_id="td_uid_4_5bd33fab15cc5" data-td_filter_value="2189" href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a><a class="mega-menu-sub-cat-td_uid_4_5bd33fab15cc5"  id="td_uid_9_5bd33fab19baf" data-td_block_id="td_uid_4_5bd33fab15cc5" data-td_filter_value="10" href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a><a class="mega-menu-sub-cat-td_uid_4_5bd33fab15cc5"  id="td_uid_10_5bd33fab19cf8" data-td_block_id="td_uid_4_5bd33fab15cc5" data-td_filter_value="130" href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></div></div><div id=td_uid_4_5bd33fab15cc5 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/24/curreny-freddie-gibbs-reveal-fetti-tracklist/" rel="bookmark" title="Curren$y &#038; Freddie Gibbs Reveal ‘FETTI’ Tracklist"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Curreny-Freddie-Gibbs-Reveal-FETTI-Tracklist-1-218x150.jpg" alt="" title="Curren$y &#038; Freddie Gibbs Reveal ‘FETTI’ Tracklist"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/24/curreny-freddie-gibbs-reveal-fetti-tracklist/" rel="bookmark" title="Curren$y &#038; Freddie Gibbs Reveal ‘FETTI’ Tracklist">Curren$y &#038; Freddie Gibbs Reveal ‘FETTI’ Tracklist</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/24/takeoff-reveals-the-last-rocket-album-release-date/" rel="bookmark" title="Takeoff Reveals “The Last Rocket” Album Release Date"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Takeoff-Reveals-The-Last-Rocket-Album-Release-Date-218x150.jpg" alt="" title="Takeoff Reveals “The Last Rocket” Album Release Date"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/24/takeoff-reveals-the-last-rocket-album-release-date/" rel="bookmark" title="Takeoff Reveals “The Last Rocket” Album Release Date">Takeoff Reveals “The Last Rocket” Album Release Date</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/23/video-wale-performs-ungrateful-thankful-acapella/" rel="bookmark" title="Video: Wale Performs “Ungrateful &#038; Thankful” Acapella"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Wale-Performs-Ungrateful-Thankful-Acapella-218x150.jpg" alt="" title="Video: Wale Performs “Ungrateful &#038; Thankful” Acapella"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/23/video-wale-performs-ungrateful-thankful-acapella/" rel="bookmark" title="Video: Wale Performs “Ungrateful &#038; Thankful” Acapella">Video: Wale Performs “Ungrateful &#038; Thankful” Acapella</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/23/video-lupe-fiasco-performs-mural-jr-acapella/" rel="bookmark" title="Video: Lupe Fiasco Performs “Mural Jr.” Acapella"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Lupe-Fiasco-Performs-Mural-Jr.-Acapella-218x150.jpg" alt="" title="Video: Lupe Fiasco Performs “Mural Jr.” Acapella"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/23/video-lupe-fiasco-performs-mural-jr-acapella/" rel="bookmark" title="Video: Lupe Fiasco Performs “Mural Jr.” Acapella">Video: Lupe Fiasco Performs “Mural Jr.” Acapella</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_4_5bd33fab15cc5" data-td_block_id="td_uid_4_5bd33fab15cc5"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_4_5bd33fab15cc5" data-td_block_id="td_uid_4_5bd33fab15cc5"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_11_5bd33fab6c9ee_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_11_5bd33fab6c9ee" ><script>var block_td_uid_11_5bd33fab6c9ee = new tdBlock();
block_td_uid_11_5bd33fab6c9ee.id = "td_uid_11_5bd33fab6c9ee";
block_td_uid_11_5bd33fab6c9ee.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"77","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_11_5bd33fab6c9ee_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_11_5bd33fab6c9ee.td_column_number = "3";
block_td_uid_11_5bd33fab6c9ee.block_type = "td_block_mega_menu";
block_td_uid_11_5bd33fab6c9ee.post_count = "4";
block_td_uid_11_5bd33fab6c9ee.found_posts = "124";
block_td_uid_11_5bd33fab6c9ee.header_color = "";
block_td_uid_11_5bd33fab6c9ee.ajax_pagination_infinite_stop = "";
block_td_uid_11_5bd33fab6c9ee.max_num_pages = "31";
tdBlocksArray.push(block_td_uid_11_5bd33fab6c9ee);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_11_5bd33fab6c9ee" id="td_uid_12_5bd33fab6e404" data-td_block_id="td_uid_11_5bd33fab6c9ee" data-td_filter_value="" href="http://weuponithiphop.info/category/fashion/">All</a><a class="mega-menu-sub-cat-td_uid_11_5bd33fab6c9ee"  id="td_uid_13_5bd33fab6fda1" data-td_block_id="td_uid_11_5bd33fab6c9ee" data-td_filter_value="76" href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></div></div><div id=td_uid_11_5bd33fab6c9ee class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/24/adidas-futurecraft-4d-i-5923-1/" rel="bookmark" title="adidas FutureCraft 4D I-5923"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/adidas-FutureCraft-4D-I-5923-1-218x150.jpg" alt="" title="adidas FutureCraft 4D I-5923"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/24/adidas-futurecraft-4d-i-5923-1/" rel="bookmark" title="adidas FutureCraft 4D I-5923">adidas FutureCraft 4D I-5923</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/21/g-shock-full-metal-5000-collection/" rel="bookmark" title="G-SHOCK Full Metal 5000 Collection"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/casio-g-shock-full-metal-5000-collection-new-watches-0-218x150.jpg" alt="" title="G-SHOCK Full Metal 5000 Collection"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/21/g-shock-full-metal-5000-collection/" rel="bookmark" title="G-SHOCK Full Metal 5000 Collection">G-SHOCK Full Metal 5000 Collection</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/15/air-jordan-11-platinum-tint/" rel="bookmark" title="Air Jordan 11 Platinum Tint"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Air-Jordan-11-Platinum-Tint-15-218x150.jpg" alt="" title="Air Jordan 11 Platinum Tint"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/15/air-jordan-11-platinum-tint/" rel="bookmark" title="Air Jordan 11 Platinum Tint">Air Jordan 11 Platinum Tint</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/15/official-look-at-the-nike-wmns-air-vapormax-2019/" rel="bookmark" title="Nike WMNS Air VaporMax 2019"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Nike-WMNS-Air-VaporMax-2019-5-218x150.jpg" alt="" title="Nike WMNS Air VaporMax 2019"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/15/official-look-at-the-nike-wmns-air-vapormax-2019/" rel="bookmark" title="Nike WMNS Air VaporMax 2019">Nike WMNS Air VaporMax 2019</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_11_5bd33fab6c9ee" data-td_block_id="td_uid_11_5bd33fab6c9ee"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_11_5bd33fab6c9ee" data-td_block_id="td_uid_11_5bd33fab6c9ee"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-2515"><a href="http://weuponithiphop.info/category/editors-picks/">Editor&#8217;s Picks</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_14_5bd33fab8b9bd_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_14_5bd33fab8b9bd" ><script>var block_td_uid_14_5bd33fab8b9bd = new tdBlock();
block_td_uid_14_5bd33fab8b9bd.id = "td_uid_14_5bd33fab8b9bd";
block_td_uid_14_5bd33fab8b9bd.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"118","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_14_5bd33fab8b9bd_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_14_5bd33fab8b9bd.td_column_number = "3";
block_td_uid_14_5bd33fab8b9bd.block_type = "td_block_mega_menu";
block_td_uid_14_5bd33fab8b9bd.post_count = "5";
block_td_uid_14_5bd33fab8b9bd.found_posts = "302";
block_td_uid_14_5bd33fab8b9bd.header_color = "";
block_td_uid_14_5bd33fab8b9bd.ajax_pagination_infinite_stop = "";
block_td_uid_14_5bd33fab8b9bd.max_num_pages = "61";
tdBlocksArray.push(block_td_uid_14_5bd33fab8b9bd);
</script><div id=td_uid_14_5bd33fab8b9bd class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/26/album-stream-apollo-brown-joell-ortiz-mona-lisa/" rel="bookmark" title="Album Stream: Apollo Brown &#038; Joell Ortiz &#8211; Mona Lisa"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Apollo-Brown-Joell-Ortiz-Mona-Lisa-218x150.jpg" alt="" title="Album Stream: Apollo Brown &#038; Joell Ortiz &#8211; Mona Lisa"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/26/album-stream-apollo-brown-joell-ortiz-mona-lisa/" rel="bookmark" title="Album Stream: Apollo Brown &#038; Joell Ortiz &#8211; Mona Lisa">Album Stream: Apollo Brown &#038; Joell Ortiz &#8211; Mona Lisa</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/26/new-music-rapsody-ft-j-cole-sojourner/" rel="bookmark" title="New Music: Rapsody ft. J. Cole &#8211; Sojourner"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Rapsody-ft.-J.-Cole-Sojourner-218x150.jpg" alt="" title="New Music: Rapsody ft. J. Cole &#8211; Sojourner"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/26/new-music-rapsody-ft-j-cole-sojourner/" rel="bookmark" title="New Music: Rapsody ft. J. Cole &#8211; Sojourner">New Music: Rapsody ft. J. Cole &#8211; Sojourner</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/25/music-video-hardo-my-last/" rel="bookmark" title="Music Video: Hardo &#8211; My Last"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Hardo-My-Last-218x150.jpg" alt="" title="Music Video: Hardo &#8211; My Last"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/25/music-video-hardo-my-last/" rel="bookmark" title="Music Video: Hardo &#8211; My Last">Music Video: Hardo &#8211; My Last</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/24/music-video-tory-lanez-ft-gunna-miami/" rel="bookmark" title="Music Video: Tory Lanez ft. Gunna – MiAMi"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Tory-Lanez-ft.-Gunna-–-MiAMi-218x150.jpg" alt="" title="Music Video: Tory Lanez ft. Gunna – MiAMi"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/24/music-video-tory-lanez-ft-gunna-miami/" rel="bookmark" title="Music Video: Tory Lanez ft. Gunna – MiAMi">Music Video: Tory Lanez ft. Gunna – MiAMi</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/24/new-music-willie-the-kid-dealer-plates/" rel="bookmark" title="New Music: Willie The Kid – Dealer Plates"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Willie-The-Kid-–-Dealer-Plates-218x150.jpg" alt="" title="New Music: Willie The Kid – Dealer Plates"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/24/new-music-willie-the-kid-dealer-plates/" rel="bookmark" title="New Music: Willie The Kid – Dealer Plates">New Music: Willie The Kid – Dealer Plates</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_14_5bd33fab8b9bd" data-td_block_id="td_uid_14_5bd33fab8b9bd"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_14_5bd33fab8b9bd" data-td_block_id="td_uid_14_5bd33fab8b9bd"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees/">Shop</a></li>
</ul></div></div>


<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form method="get" class="td-search-form" action="http://weuponithiphop.info/">
				<div role="search" class="td-head-form-search-wrap">
					<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>            </div>
        </div>
    </div>

    <div class="td-banner-wrap-full">
        <div class="td-header-container td-header-row td-header-header">
            <div class="td-header-sp-recs">
                <div class="td-header-rec-wrap">
    
</div>            </div>
        </div>
    </div>

</div><article id="post-15709" class="td-post-template-3 post-15709 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-new-music tag-come-again tag-giggs tag-swizz-beatz" itemscope itemtype="http://schema.org/Article">
    <div class="td-post-header td-container">
        <div class="td-crumb-container"><div class="entry-crumbs"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="" class="entry-crumb" itemprop="url" href="http://weuponithiphop.info/"><span itemprop="title">Home</span></a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="View all posts in New Music" class="entry-crumb" itemprop="url" href="http://weuponithiphop.info/category/new-music/"><span itemprop="title">New Music</span></a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last" itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><meta itemprop="title" content = "New Music: Swizz Beatz ft. Giggs &#8211; Come Again"><meta itemprop="url" content = "http://weuponithiphop.info/2018/10/26/new-music-swizz-beatz-ft-giggs-come-again/">New Music: Swizz Beatz ft. Giggs &#8211; Come Again</span></div></div>
        <div class="td-post-header-holder td-image-gradient">
            <div class="td-post-featured-image"><a href="http://weuponithiphop.info/wp-content/uploads/Swizz-Beatz-ft.-Giggs-Come-Again.jpg" data-caption=""><img width="680" height="680" class="entry-thumb td-modal-image" src="http://weuponithiphop.info/wp-content/uploads/Swizz-Beatz-ft.-Giggs-Come-Again.jpg" alt="" title="Swizz Beatz ft. Giggs - Come Again"/></a></div>
            <header class="td-post-title">
                <ul class="td-category"><li class="entry-category"><a  href="http://weuponithiphop.info/category/new-music/">New Music</a></li></ul>                <h1 class="entry-title">New Music: Swizz Beatz ft. Giggs &#8211; Come Again</h1>

                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name">By <a href="http://weuponithiphop.info/author/cyclone/">cyclone</a> - </div>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-10-26T08:49:28+00:00" >October 26, 2018</time></span>                                        <div class="td-post-comments"><a href="http://weuponithiphop.info/2018/10/26/new-music-swizz-beatz-ft-giggs-come-again/#respond"><i class="td-icon-comments"></i>0</a></div>                </div>

            </header>
        </div>
    </div>

    <div class="td-container">
        <div class="td-pb-row">
                                <div class="td-pb-span8 td-main-content" role="main">
                        <div class="td-ss-main-content">
                            
    
    <div class="td-post-content">
        <p><a href="http://weuponithiphop.info/wp-content/uploads/Swizz-Beatz-ft.-Giggs-Come-Again.jpg"><img class="aligncenter size-full wp-image-15710" src="http://weuponithiphop.info/wp-content/uploads/Swizz-Beatz-ft.-Giggs-Come-Again.jpg" alt="" width="680" height="680" srcset="http://weuponithiphop.info/wp-content/uploads/Swizz-Beatz-ft.-Giggs-Come-Again.jpg 680w, http://weuponithiphop.info/wp-content/uploads/Swizz-Beatz-ft.-Giggs-Come-Again-150x150.jpg 150w, http://weuponithiphop.info/wp-content/uploads/Swizz-Beatz-ft.-Giggs-Come-Again-500x500.jpg 500w, http://weuponithiphop.info/wp-content/uploads/Swizz-Beatz-ft.-Giggs-Come-Again-420x420.jpg 420w" sizes="(max-width: 680px) 100vw, 680px" /></a></p>
<p><strong>Swizz Beatz</strong> working his was towards the November 2nd release of his upcoming <strong>J. Cole-</strong>executive produced <a href="http://weuponithiphop.info/tag/album/">album</a> <em><strong><a href="http://weuponithiphop.info/tag/poison/">POISON</a>.</strong></em> He links up with UK vet <strong><a href="http://weuponithiphop.info/tag/giggs/">Giggs</a> </strong>for his latest release titled <strong>“Come Again”.</strong> Pre-order his new album <em><strong>POISON</strong></em> now on <a href="https://geo.itunes.apple.com/us/album/poison/1435842653?mt=1&amp;app=itunes&amp;at=11l4Qg&amp;ct=poison" target="_blank" rel="noopener">iTunes</a>/<a href="https://play.google.com/store/music/album/Swizz_Beatz_POISON?id=Bfe6qfznurbpac2t2alta3h4jkm">Google Play</a>.</p>
<p><iframe src="https://tools.applemusic.com/embed/v1/song/1435842662?country=us&amp;at=11l4Qg&amp;ct=songaboutyou" width="100%" height="110px" frameborder="0" data-mce-fragment="1"></iframe></p>
<p><iframe src="https://open.spotify.com/embed?uri=spotify%3Aalbum%3A1HHY6tWkoYAtr2pGLxtMxp" width="100%" height="110" frameborder="0"><span data-mce-type="bookmark" style="display: inline-block; width: 0px; overflow: hidden; line-height: 0;" class="mce_SELRES_start">﻿</span></iframe></p>
<div class="tidal-embed" data-type="t" data-id="97205025"></div>
<p><script src="https://embed.tidal.com/tidal-embed.js"></script></p>
<div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="http://weuponithiphop.info/2018/10/26/new-music-swizz-beatz-ft-giggs-come-again/" data-a2a-title="New Music: Swizz Beatz ft. Giggs – Come Again"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2018%2F10%2F26%2Fnew-music-swizz-beatz-ft-giggs-come-again%2F&amp;linkname=New%20Music%3A%20Swizz%20Beatz%20ft.%20Giggs%20%E2%80%93%20Come%20Again" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2018%2F10%2F26%2Fnew-music-swizz-beatz-ft-giggs-come-again%2F&amp;linkname=New%20Music%3A%20Swizz%20Beatz%20ft.%20Giggs%20%E2%80%93%20Come%20Again" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_google_plus" href="https://www.addtoany.com/add_to/google_plus?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2018%2F10%2F26%2Fnew-music-swizz-beatz-ft-giggs-come-again%2F&amp;linkname=New%20Music%3A%20Swizz%20Beatz%20ft.%20Giggs%20%E2%80%93%20Come%20Again" title="Google+" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2018%2F10%2F26%2Fnew-music-swizz-beatz-ft-giggs-come-again%2F&amp;linkname=New%20Music%3A%20Swizz%20Beatz%20ft.%20Giggs%20%E2%80%93%20Come%20Again" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2018%2F10%2F26%2Fnew-music-swizz-beatz-ft-giggs-come-again%2F&amp;linkname=New%20Music%3A%20Swizz%20Beatz%20ft.%20Giggs%20%E2%80%93%20Come%20Again" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_tumblr" href="https://www.addtoany.com/add_to/tumblr?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2018%2F10%2F26%2Fnew-music-swizz-beatz-ft-giggs-come-again%2F&amp;linkname=New%20Music%3A%20Swizz%20Beatz%20ft.%20Giggs%20%E2%80%93%20Come%20Again" title="Tumblr" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_reddit" href="https://www.addtoany.com/add_to/reddit?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2018%2F10%2F26%2Fnew-music-swizz-beatz-ft-giggs-come-again%2F&amp;linkname=New%20Music%3A%20Swizz%20Beatz%20ft.%20Giggs%20%E2%80%93%20Come%20Again" title="Reddit" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_flipboard" href="https://www.addtoany.com/add_to/flipboard?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2018%2F10%2F26%2Fnew-music-swizz-beatz-ft-giggs-come-again%2F&amp;linkname=New%20Music%3A%20Swizz%20Beatz%20ft.%20Giggs%20%E2%80%93%20Come%20Again" title="Flipboard" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2018%2F10%2F26%2Fnew-music-swizz-beatz-ft-giggs-come-again%2F&amp;linkname=New%20Music%3A%20Swizz%20Beatz%20ft.%20Giggs%20%E2%80%93%20Come%20Again" title="Copy Link" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div>    </div>


    <footer>
                
        <div class="td-post-source-tags">
                        <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="http://weuponithiphop.info/tag/come-again/">Come Again</a></li><li><a href="http://weuponithiphop.info/tag/giggs/">Giggs</a></li><li><a href="http://weuponithiphop.info/tag/swizz-beatz/">Swizz Beatz</a></li></ul>        </div>

                <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="http://weuponithiphop.info/2018/10/26/album-stream-apollo-brown-joell-ortiz-mona-lisa/">Album Stream: Apollo Brown &#038; Joell Ortiz &#8211; Mona Lisa</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="http://weuponithiphop.info/2018/10/26/new-music-takeoff-the-last-memory/">New Music: Takeoff &#8211; The Last Memory</a></div></div></div>        <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="http://weuponithiphop.info/author/cyclone/">cyclone</a></span></div>        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="cyclone"></span><meta itemprop="datePublished" content="2018-10-26T08:49:28+00:00"><meta itemprop="dateModified" content="2018-10-26T08:49:28+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://weuponithiphop.info/2018/10/26/new-music-swizz-beatz-ft-giggs-come-again/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png"></span><meta itemprop="name" content="WeUpOnIt"></span><meta itemprop="headline " content="New Music: Swizz Beatz ft. Giggs - Come Again"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://weuponithiphop.info/wp-content/uploads/Swizz-Beatz-ft.-Giggs-Come-Again.jpg"><meta itemprop="width" content="680"><meta itemprop="height" content="680"></span>    </footer>

    <div class="td_block_wrap td_block_related_posts td_uid_16_5bd33fac8d1f0_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_16_5bd33fac8d1f0" ><script>var block_td_uid_16_5bd33fac8d1f0 = new tdBlock();
block_td_uid_16_5bd33fac8d1f0.id = "td_uid_16_5bd33fac8d1f0";
block_td_uid_16_5bd33fac8d1f0.atts = '{"limit":6,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_custom_related","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_16_5bd33fac8d1f0_rand","offset":"","css":"","live_filter":"cur_post_same_tags","live_filter_cur_post_id":15709,"live_filter_cur_post_author":"1"}';
block_td_uid_16_5bd33fac8d1f0.td_column_number = "3";
block_td_uid_16_5bd33fac8d1f0.block_type = "td_block_related_posts";
block_td_uid_16_5bd33fac8d1f0.post_count = "6";
block_td_uid_16_5bd33fac8d1f0.found_posts = "10";
block_td_uid_16_5bd33fac8d1f0.header_color = "";
block_td_uid_16_5bd33fac8d1f0.ajax_pagination_infinite_stop = "";
block_td_uid_16_5bd33fac8d1f0.max_num_pages = "2";
tdBlocksArray.push(block_td_uid_16_5bd33fac8d1f0);
</script><h4 class="td-related-title"><a id="td_uid_17_5bd33fac99b9d" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_16_5bd33fac8d1f0" href="#">RELATED ARTICLES</a><a id="td_uid_18_5bd33fac9a000" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_16_5bd33fac8d1f0" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_16_5bd33fac8d1f0 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/19/music-video-lil-wayne-ft-swizz-beatz-uproar/" rel="bookmark" title="Music Video: Lil Wayne ft. Swizz Beatz – Uproar"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Lil-Wayne-ft.-Swizz-Beatz-–-Uproar-218x150.jpg" alt="" title="Music Video: Lil Wayne ft. Swizz Beatz – Uproar"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/19/music-video-lil-wayne-ft-swizz-beatz-uproar/" rel="bookmark" title="Music Video: Lil Wayne ft. Swizz Beatz – Uproar">Music Video: Lil Wayne ft. Swizz Beatz – Uproar</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/16/video-swizz-beatz-french-montana-funkmaster-flex-freestyle/" rel="bookmark" title="Video: Swizz Beatz &#038; French Montana – Funkmaster Flex Freestyle"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Swizz-Beatz-French-Montana-–-Funkmaster-Flex-Freestyle-218x150.jpg" alt="" title="Video: Swizz Beatz &#038; French Montana – Funkmaster Flex Freestyle"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/16/video-swizz-beatz-french-montana-funkmaster-flex-freestyle/" rel="bookmark" title="Video: Swizz Beatz &#038; French Montana – Funkmaster Flex Freestyle">Video: Swizz Beatz &#038; French Montana – Funkmaster Flex Freestyle</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/15/music-video-swizz-beatz-ft-jim-jones-preach/" rel="bookmark" title="Music Video: Swizz Beatz Ft. Jim Jones &#8211; Preach"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Swizz-Beatz-Ft.-Jim-Jones-Preach-218x150.jpg" alt="" title="Music Video: Swizz Beatz Ft. Jim Jones &#8211; Preach"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/15/music-video-swizz-beatz-ft-jim-jones-preach/" rel="bookmark" title="Music Video: Swizz Beatz Ft. Jim Jones &#8211; Preach">Music Video: Swizz Beatz Ft. Jim Jones &#8211; Preach</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid-->

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/13/new-music-swizz-beatz-ft-jim-jones-preach/" rel="bookmark" title="New Music: Swizz Beatz ft. Jim Jones – Preach"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Swizz-Beatz-ft.-Jim-Jones-–-Preach-218x150.jpg" alt="" title="New Music: Swizz Beatz ft. Jim Jones – Preach"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/13/new-music-swizz-beatz-ft-jim-jones-preach/" rel="bookmark" title="New Music: Swizz Beatz ft. Jim Jones – Preach">New Music: Swizz Beatz ft. Jim Jones – Preach</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/03/music-video-swizz-beatz-ft-young-thug-25-soldiers/" rel="bookmark" title="Music Video: Swizz Beatz ft. Young Thug – 25 Soldiers"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Swizz-Beatz-ft.-Young-Thug-–-25-Soldiers-video-218x150.jpg" alt="" title="Music Video: Swizz Beatz ft. Young Thug – 25 Soldiers"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/03/music-video-swizz-beatz-ft-young-thug-25-soldiers/" rel="bookmark" title="Music Video: Swizz Beatz ft. Young Thug – 25 Soldiers">Music Video: Swizz Beatz ft. Young Thug – 25 Soldiers</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/09/28/new-music-swizz-beatz-ft-young-thug-25-soldiers/" rel="bookmark" title="New Music: Swizz Beatz ft. Young Thug – 25 Soldiers"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Swizz-Beatz-ft.-Young-Thug-–-25-Soldiers-218x150.jpg" alt="" title="New Music: Swizz Beatz ft. Young Thug – 25 Soldiers"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/09/28/new-music-swizz-beatz-ft-young-thug-25-soldiers/" rel="bookmark" title="New Music: Swizz Beatz ft. Young Thug – 25 Soldiers">New Music: Swizz Beatz ft. Young Thug – 25 Soldiers</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_16_5bd33fac8d1f0" data-td_block_id="td_uid_16_5bd33fac8d1f0"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_16_5bd33fac8d1f0" data-td_block_id="td_uid_16_5bd33fac8d1f0"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->

	<div class="comments" id="comments">
            </div> <!-- /.content -->
                        </div>
                    </div>
                    <div class="td-pb-span4 td-main-sidebar" role="complementary">
                        <div class="td-ss-main-sidebar">
                            <aside class="widget widget_search"><form method="get" class="td-search-form-widget" action="http://weuponithiphop.info/">
    <div role="search">
        <input class="td-widget-search-input" type="text" value="" name="s" id="s" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit" value="Search" />
    </div>
</form></aside><aside class="widget widget_text">			<div class="textwidget"><h4><strong><span style="color: #8224e3;"><span style="color: #000000;">Listen to</span> <span style="color: #c60000;">WeUpOnItRadio</span> <span style="color: #000000;">Live!</span></span></strong></h4>
<p><span class="cc_streaminfo" data-type="song" data-username="cyclone777">Loading &#8230;</span><br />
<script language="javascript" type="text/javascript" src="https://control.internet-radio.com:2199/system/streaminfo.js"></script><br />
<iframe src="https://tunein.com/embed/player/s292400/" style="width:100%; height:100px;" scrolling="no" frameborder="no"></iframe></p>
</div>
		</aside><aside class="widget widget_text"><div class="block-title"><span>AUDIOTRAFFICKER &#8211; Getting Political</span></div>			<div class="textwidget"><p><iframe style="border: none; overflow: hidden;" src="https://www.facebook.com/plugins/video.php?href=https%3A%2F%2Fwww.facebook.com%2FAudioTrafficker%2Fvideos%2F289669158303397%2F&amp;show_text=0&amp;width=560" frameborder="0" scrolling="no" allowfullscreen="true"></iframe></p>
<p><iframe src="https://www.youtube.com/embed/xNdHGIndNuk" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe></p>
</div>
		</aside>
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-sidebar ">
<script type="text/javascript">
var td_screen_width = document.body.clientWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 

                        </div>
                    </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</article> <!-- /.post -->


<!-- Instagram -->



<!-- Footer -->
<div class="td-footer-wrapper td-footer-template-3">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
			    		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span4">
                <div class="td-footer-info"><div class="footer-logo-wrap"><a href="http://weuponithiphop.info/"><img class="td-retina-data" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" alt="" title=""/></a></div><div class="footer-text-wrap"></div><div class="footer-social-wrap td-social-style-2">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div></div>            </div>

            <div class="td-pb-span4">
                <div class="td_block_wrap td_block_8 td_block_widget td_uid_21_5bd33facdb102_rand td-pb-border-top"  data-td-block-uid="td_uid_21_5bd33facdb102" ><script>var block_td_uid_21_5bd33facdb102 = new tdBlock();
block_td_uid_21_5bd33facdb102.id = "td_uid_21_5bd33facdb102";
block_td_uid_21_5bd33facdb102.atts = '{"limit":"7","sort":"jetpack_popular_2","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"POPULAR POSTS","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"#","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_21_5bd33facdb102_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_21_5bd33facdb102.td_column_number = "1";
block_td_uid_21_5bd33facdb102.block_type = "td_block_8";
block_td_uid_21_5bd33facdb102.post_count = "7";
block_td_uid_21_5bd33facdb102.found_posts = "10";
block_td_uid_21_5bd33facdb102.header_color = "#";
block_td_uid_21_5bd33facdb102.ajax_pagination_infinite_stop = "";
block_td_uid_21_5bd33facdb102.max_num_pages = "2";
tdBlocksArray.push(block_td_uid_21_5bd33facdb102);
</script><h4 class="block-title"><span>POPULAR POSTS</span></h4><div id=td_uid_21_5bd33facdb102 class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_7 td_module_wrap td-animation-stack">
        <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/26/new-music-rapsody-ft-j-cole-sojourner/" rel="bookmark" title="New Music: Rapsody ft. J. Cole &#8211; Sojourner"><img width="100" height="70" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Rapsody-ft.-J.-Cole-Sojourner-100x70.jpg" alt="" title="New Music: Rapsody ft. J. Cole &#8211; Sojourner"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/26/new-music-rapsody-ft-j-cole-sojourner/" rel="bookmark" title="New Music: Rapsody ft. J. Cole &#8211; Sojourner">New Music: Rapsody ft. J. Cole &#8211; Sojourner</a></h3>
            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-10-26T07:55:38+00:00" >October 26, 2018</time></span>                            </div>

        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_7 td_module_wrap td-animation-stack">
        <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/26/new-music-rob-stone-ft-p-lo-too-faded/" rel="bookmark" title="New Music: Rob Stone ft. P-Lo &#8211; Too Faded"><img width="100" height="70" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Rob-Stone-ft.-P-Lo-Too-Faded-100x70.jpg" alt="" title="New Music: Rob Stone ft. P-Lo &#8211; Too Faded"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/26/new-music-rob-stone-ft-p-lo-too-faded/" rel="bookmark" title="New Music: Rob Stone ft. P-Lo &#8211; Too Faded">New Music: Rob Stone ft. P-Lo &#8211; Too Faded</a></h3>
            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-10-26T07:44:11+00:00" >October 26, 2018</time></span>                            </div>

        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_7 td_module_wrap td-animation-stack">
        <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/25/new-music-rich-the-kid-ft-yg-mo-paper/" rel="bookmark" title="New Music: Rich The Kid ft. YG &#8211; Mo Paper"><img width="100" height="70" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/rich-the-kid-mo-paper-680x680-100x70.jpg" alt="" title="New Music: Rich The Kid ft. YG &#8211; Mo Paper"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/25/new-music-rich-the-kid-ft-yg-mo-paper/" rel="bookmark" title="New Music: Rich The Kid ft. YG &#8211; Mo Paper">New Music: Rich The Kid ft. YG &#8211; Mo Paper</a></h3>
            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-10-25T21:00:53+00:00" >October 25, 2018</time></span>                            </div>

        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_7 td_module_wrap td-animation-stack">
        <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/24/new-music-awar-ft-scarface-anthony-hamilton-forty-five-soul/" rel="bookmark" title="New Music: AWAR Ft. Scarface &#038; Anthony Hamilton – Forty Five Soul"><img width="100" height="70" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/AWAR-Ft.-Scarface-Anthony-Hamilton-–-Forty-Five-Soul-100x70.jpg" alt="" title="New Music: AWAR Ft. Scarface &#038; Anthony Hamilton – Forty Five Soul"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/24/new-music-awar-ft-scarface-anthony-hamilton-forty-five-soul/" rel="bookmark" title="New Music: AWAR Ft. Scarface &#038; Anthony Hamilton – Forty Five Soul">New Music: AWAR Ft. Scarface &#038; Anthony Hamilton – Forty Five...</a></h3>
            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-10-24T20:56:05+00:00" >October 24, 2018</time></span>                            </div>

        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_7 td_module_wrap td-animation-stack">
        <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/24/new-music-tyga-swae-lee-shine-zeze-freestyle-1/" rel="bookmark" title="New Music: Tyga &#038; Swae Lee &#8211; Shine"><img width="100" height="70" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/tyga-swae-lee-zeze-680x438-100x70.jpg" alt="" title="New Music: Tyga &#038; Swae Lee &#8211; Shine"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/24/new-music-tyga-swae-lee-shine-zeze-freestyle-1/" rel="bookmark" title="New Music: Tyga &#038; Swae Lee &#8211; Shine">New Music: Tyga &#038; Swae Lee &#8211; Shine</a></h3>
            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-10-24T19:27:11+00:00" >October 24, 2018</time></span>                            </div>

        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_7 td_module_wrap td-animation-stack">
        <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/24/audio-joe-budden-the-joe-podcast-w-rory-mal-episode-190-crummies/" rel="bookmark" title="Audio: Joe Budden &#8211; The Joe Podcast w/ Rory &#038; Mal (Episode 190) &#8220;Crummies&#8221;"><img width="100" height="70" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Joe-Budden-The-Joe-Podcast-w-Rory-Mal-Episode-190-Crummies-100x70.jpg" alt="" title="Audio: Joe Budden &#8211; The Joe Podcast w/ Rory &#038; Mal (Episode 190) &#8220;Crummies&#8221;"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/24/audio-joe-budden-the-joe-podcast-w-rory-mal-episode-190-crummies/" rel="bookmark" title="Audio: Joe Budden &#8211; The Joe Podcast w/ Rory &#038; Mal (Episode 190) &#8220;Crummies&#8221;">Audio: Joe Budden &#8211; The Joe Podcast w/ Rory &#038; Mal...</a></h3>
            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-10-24T09:13:13+00:00" >October 24, 2018</time></span>                            </div>

        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_7 td_module_wrap td-animation-stack">
        <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/08/28/lil-mosey-breaks-down-the-lyrics-for-noticed/" rel="bookmark" title="Video: Lil Mosey Breaks Down The Lyrics For “Noticed” W/ Genius"><img width="100" height="70" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/lil-mosey-breaks-down-the-lyrics-for-noticed-620x350-100x70.jpg" alt="" title="Video: Lil Mosey Breaks Down The Lyrics For “Noticed” W/ Genius"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/08/28/lil-mosey-breaks-down-the-lyrics-for-noticed/" rel="bookmark" title="Video: Lil Mosey Breaks Down The Lyrics For “Noticed” W/ Genius">Video: Lil Mosey Breaks Down The Lyrics For “Noticed” W/ Genius</a></h3>
            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-08-28T08:58:16+00:00" >August 28, 2018</time></span>                            </div>

        </div>

        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block -->            </div>

            <div class="td-pb-span4">
                <aside class="widget widget_tag_cloud"><div class="block-title"><span>Tags</span></div><div class="tagcloud"><a href="http://weuponithiphop.info/tag/6ix9ine/" class="tag-cloud-link tag-link-131 tag-link-position-1" style="font-size: 13.88pt;" aria-label="6ix9ine (20 items)">6ix9ine</a>
<a href="http://weuponithiphop.info/tag/adidas/" class="tag-cloud-link tag-link-158 tag-link-position-2" style="font-size: 9.96pt;" aria-label="adidas (14 items)">adidas</a>
<a href="http://weuponithiphop.info/tag/album/" class="tag-cloud-link tag-link-276 tag-link-position-3" style="font-size: 12.76pt;" aria-label="Album (18 items)">Album</a>
<a href="http://weuponithiphop.info/tag/announces/" class="tag-cloud-link tag-link-132 tag-link-position-4" style="font-size: 18.64pt;" aria-label="Announces (30 items)">Announces</a>
<a href="http://weuponithiphop.info/tag/blocboy-jb/" class="tag-cloud-link tag-link-634 tag-link-position-5" style="font-size: 10.52pt;" aria-label="BlocBoy JB (15 items)">BlocBoy JB</a>
<a href="http://weuponithiphop.info/tag/cardi-b/" class="tag-cloud-link tag-link-752 tag-link-position-6" style="font-size: 8pt;" aria-label="Cardi B (12 items)">Cardi B</a>
<a href="http://weuponithiphop.info/tag/chance-the-rapper/" class="tag-cloud-link tag-link-179 tag-link-position-7" style="font-size: 9.96pt;" aria-label="Chance The Rapper (14 items)">Chance The Rapper</a>
<a href="http://weuponithiphop.info/tag/conway/" class="tag-cloud-link tag-link-1163 tag-link-position-8" style="font-size: 9.12pt;" aria-label="Conway (13 items)">Conway</a>
<a href="http://weuponithiphop.info/tag/curreny/" class="tag-cloud-link tag-link-1038 tag-link-position-9" style="font-size: 11.36pt;" aria-label="Curren$y (16 items)">Curren$y</a>
<a href="http://weuponithiphop.info/tag/dave-east/" class="tag-cloud-link tag-link-1128 tag-link-position-10" style="font-size: 12.2pt;" aria-label="Dave East (17 items)">Dave East</a>
<a href="http://weuponithiphop.info/tag/drake/" class="tag-cloud-link tag-link-145 tag-link-position-11" style="font-size: 18.36pt;" aria-label="Drake (29 items)">Drake</a>
<a href="http://weuponithiphop.info/tag/future/" class="tag-cloud-link tag-link-138 tag-link-position-12" style="font-size: 16.4pt;" aria-label="Future (25 items)">Future</a>
<a href="http://weuponithiphop.info/tag/genius/" class="tag-cloud-link tag-link-92 tag-link-position-13" style="font-size: 11.36pt;" aria-label="Genius (16 items)">Genius</a>
<a href="http://weuponithiphop.info/tag/gucci-mane/" class="tag-cloud-link tag-link-135 tag-link-position-14" style="font-size: 8pt;" aria-label="Gucci Mane (12 items)">Gucci Mane</a>
<a href="http://weuponithiphop.info/tag/gunna/" class="tag-cloud-link tag-link-459 tag-link-position-15" style="font-size: 8pt;" aria-label="Gunna (12 items)">Gunna</a>
<a href="http://weuponithiphop.info/tag/jay-rock/" class="tag-cloud-link tag-link-338 tag-link-position-16" style="font-size: 9.12pt;" aria-label="Jay Rock (13 items)">Jay Rock</a>
<a href="http://weuponithiphop.info/tag/jeremih/" class="tag-cloud-link tag-link-12 tag-link-position-17" style="font-size: 10.52pt;" aria-label="Jeremih (15 items)">Jeremih</a>
<a href="http://weuponithiphop.info/tag/joe-budden/" class="tag-cloud-link tag-link-166 tag-link-position-18" style="font-size: 19.76pt;" aria-label="Joe Budden (33 items)">Joe Budden</a>
<a href="http://weuponithiphop.info/tag/juice-wrld/" class="tag-cloud-link tag-link-194 tag-link-position-19" style="font-size: 9.96pt;" aria-label="Juice WRLD (14 items)">Juice WRLD</a>
<a href="http://weuponithiphop.info/tag/kanye-west/" class="tag-cloud-link tag-link-49 tag-link-position-20" style="font-size: 16.12pt;" aria-label="Kanye West (24 items)">Kanye West</a>
<a href="http://weuponithiphop.info/tag/kevin-gates/" class="tag-cloud-link tag-link-360 tag-link-position-21" style="font-size: 12.2pt;" aria-label="Kevin Gates (17 items)">Kevin Gates</a>
<a href="http://weuponithiphop.info/tag/lil-baby/" class="tag-cloud-link tag-link-18 tag-link-position-22" style="font-size: 9.96pt;" aria-label="Lil Baby (14 items)">Lil Baby</a>
<a href="http://weuponithiphop.info/tag/lil-uzi-vert/" class="tag-cloud-link tag-link-599 tag-link-position-23" style="font-size: 9.96pt;" aria-label="Lil Uzi Vert (14 items)">Lil Uzi Vert</a>
<a href="http://weuponithiphop.info/tag/lil-wayne/" class="tag-cloud-link tag-link-25 tag-link-position-24" style="font-size: 16.4pt;" aria-label="Lil Wayne (25 items)">Lil Wayne</a>
<a href="http://weuponithiphop.info/tag/lil-yachty/" class="tag-cloud-link tag-link-593 tag-link-position-25" style="font-size: 9.12pt;" aria-label="Lil Yachty (13 items)">Lil Yachty</a>
<a href="http://weuponithiphop.info/tag/logic/" class="tag-cloud-link tag-link-302 tag-link-position-26" style="font-size: 9.12pt;" aria-label="Logic (13 items)">Logic</a>
<a href="http://weuponithiphop.info/tag/mal/" class="tag-cloud-link tag-link-241 tag-link-position-27" style="font-size: 13.88pt;" aria-label="Mal (20 items)">Mal</a>
<a href="http://weuponithiphop.info/tag/nicki-minaj/" class="tag-cloud-link tag-link-70 tag-link-position-28" style="font-size: 19.2pt;" aria-label="Nicki Minaj (31 items)">Nicki Minaj</a>
<a href="http://weuponithiphop.info/tag/nike/" class="tag-cloud-link tag-link-154 tag-link-position-29" style="font-size: 22pt;" aria-label="Nike (40 items)">Nike</a>
<a href="http://weuponithiphop.info/tag/pusha-t/" class="tag-cloud-link tag-link-269 tag-link-position-30" style="font-size: 8pt;" aria-label="Pusha T (12 items)">Pusha T</a>
<a href="http://weuponithiphop.info/tag/quavo/" class="tag-cloud-link tag-link-523 tag-link-position-31" style="font-size: 11.36pt;" aria-label="Quavo (16 items)">Quavo</a>
<a href="http://weuponithiphop.info/tag/revealed/" class="tag-cloud-link tag-link-186 tag-link-position-32" style="font-size: 8pt;" aria-label="Revealed (12 items)">Revealed</a>
<a href="http://weuponithiphop.info/tag/rich-the-kid/" class="tag-cloud-link tag-link-103 tag-link-position-33" style="font-size: 13.32pt;" aria-label="Rich The Kid (19 items)">Rich The Kid</a>
<a href="http://weuponithiphop.info/tag/rory/" class="tag-cloud-link tag-link-240 tag-link-position-34" style="font-size: 13.88pt;" aria-label="Rory (20 items)">Rory</a>
<a href="http://weuponithiphop.info/tag/styles-p/" class="tag-cloud-link tag-link-41 tag-link-position-35" style="font-size: 8pt;" aria-label="Styles P (12 items)">Styles P</a>
<a href="http://weuponithiphop.info/tag/talks/" class="tag-cloud-link tag-link-923 tag-link-position-36" style="font-size: 11.36pt;" aria-label="Talks (16 items)">Talks</a>
<a href="http://weuponithiphop.info/tag/the-breakfast-club-interview/" class="tag-cloud-link tag-link-46 tag-link-position-37" style="font-size: 12.76pt;" aria-label="The Breakfast Club Interview (18 items)">The Breakfast Club Interview</a>
<a href="http://weuponithiphop.info/tag/the-joe-budden-podcast/" class="tag-cloud-link tag-link-239 tag-link-position-38" style="font-size: 16.12pt;" aria-label="The Joe Budden Podcast (24 items)">The Joe Budden Podcast</a>
<a href="http://weuponithiphop.info/tag/tory-lanez/" class="tag-cloud-link tag-link-284 tag-link-position-39" style="font-size: 9.12pt;" aria-label="Tory Lanez (13 items)">Tory Lanez</a>
<a href="http://weuponithiphop.info/tag/travis-scott/" class="tag-cloud-link tag-link-779 tag-link-position-40" style="font-size: 13.32pt;" aria-label="Travis Scott (19 items)">Travis Scott</a>
<a href="http://weuponithiphop.info/tag/trippie-redd/" class="tag-cloud-link tag-link-249 tag-link-position-41" style="font-size: 9.96pt;" aria-label="Trippie Redd (14 items)">Trippie Redd</a>
<a href="http://weuponithiphop.info/tag/ty-dolla-sign/" class="tag-cloud-link tag-link-11 tag-link-position-42" style="font-size: 17.52pt;" aria-label="Ty Dolla Sign (27 items)">Ty Dolla Sign</a>
<a href="http://weuponithiphop.info/tag/wiz-khalifa/" class="tag-cloud-link tag-link-274 tag-link-position-43" style="font-size: 15.56pt;" aria-label="Wiz Khalifa (23 items)">Wiz Khalifa</a>
<a href="http://weuponithiphop.info/tag/yg/" class="tag-cloud-link tag-link-489 tag-link-position-44" style="font-size: 8pt;" aria-label="YG (12 items)">YG</a>
<a href="http://weuponithiphop.info/tag/young-thug/" class="tag-cloud-link tag-link-435 tag-link-position-45" style="font-size: 13.32pt;" aria-label="Young Thug (19 items)">Young Thug</a></div>
</aside>            </div>
        </div>
    </div>
</div>

<!-- Sub Footer -->
    <div class="td-sub-footer-container">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span7 td-sub-footer-menu">
                        <div class="menu-top-menu-container"><ul id="menu-top-menu-2" class="td-subfooter-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-first td-menu-item td-mega-menu menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_22_5bd33fad44a02_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_22_5bd33fad44a02" ><script>var block_td_uid_22_5bd33fad44a02 = new tdBlock();
block_td_uid_22_5bd33fad44a02.id = "td_uid_22_5bd33fad44a02";
block_td_uid_22_5bd33fad44a02.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"43","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_22_5bd33fad44a02_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_22_5bd33fad44a02.td_column_number = "3";
block_td_uid_22_5bd33fad44a02.block_type = "td_block_mega_menu";
block_td_uid_22_5bd33fad44a02.post_count = "5";
block_td_uid_22_5bd33fad44a02.found_posts = "777";
block_td_uid_22_5bd33fad44a02.header_color = "";
block_td_uid_22_5bd33fad44a02.ajax_pagination_infinite_stop = "";
block_td_uid_22_5bd33fad44a02.max_num_pages = "156";
tdBlocksArray.push(block_td_uid_22_5bd33fad44a02);
</script><div id=td_uid_22_5bd33fad44a02 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/26/new-music-takeoff-the-last-memory/" rel="bookmark" title="New Music: Takeoff &#8211; The Last Memory"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Takeoff-The-Last-Memory-218x150.jpg" alt="" title="New Music: Takeoff &#8211; The Last Memory"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/26/new-music-takeoff-the-last-memory/" rel="bookmark" title="New Music: Takeoff &#8211; The Last Memory">New Music: Takeoff &#8211; The Last Memory</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/26/new-music-swizz-beatz-ft-giggs-come-again/" rel="bookmark" title="New Music: Swizz Beatz ft. Giggs &#8211; Come Again"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Swizz-Beatz-ft.-Giggs-Come-Again-218x150.jpg" alt="" title="New Music: Swizz Beatz ft. Giggs &#8211; Come Again"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/26/new-music-swizz-beatz-ft-giggs-come-again/" rel="bookmark" title="New Music: Swizz Beatz ft. Giggs &#8211; Come Again">New Music: Swizz Beatz ft. Giggs &#8211; Come Again</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/26/new-music-rapsody-ft-j-cole-sojourner/" rel="bookmark" title="New Music: Rapsody ft. J. Cole &#8211; Sojourner"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Rapsody-ft.-J.-Cole-Sojourner-218x150.jpg" alt="" title="New Music: Rapsody ft. J. Cole &#8211; Sojourner"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/26/new-music-rapsody-ft-j-cole-sojourner/" rel="bookmark" title="New Music: Rapsody ft. J. Cole &#8211; Sojourner">New Music: Rapsody ft. J. Cole &#8211; Sojourner</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/26/new-music-rob-stone-ft-p-lo-too-faded/" rel="bookmark" title="New Music: Rob Stone ft. P-Lo &#8211; Too Faded"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Rob-Stone-ft.-P-Lo-Too-Faded-218x150.jpg" alt="" title="New Music: Rob Stone ft. P-Lo &#8211; Too Faded"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/26/new-music-rob-stone-ft-p-lo-too-faded/" rel="bookmark" title="New Music: Rob Stone ft. P-Lo &#8211; Too Faded">New Music: Rob Stone ft. P-Lo &#8211; Too Faded</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/26/new-music-riff-raff-tracy-foreign-land/" rel="bookmark" title="New Music: RiFF RAFF &#038; Tracy &#8211; Foreign Land"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/RIFF-RAFF-TRACY-–-FOREIGN-LAND-218x150.jpg" alt="" title="New Music: RiFF RAFF &#038; Tracy &#8211; Foreign Land"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/26/new-music-riff-raff-tracy-foreign-land/" rel="bookmark" title="New Music: RiFF RAFF &#038; Tracy &#8211; Foreign Land">New Music: RiFF RAFF &#038; Tracy &#8211; Foreign Land</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_22_5bd33fad44a02" data-td_block_id="td_uid_22_5bd33fad44a02"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_22_5bd33fad44a02" data-td_block_id="td_uid_22_5bd33fad44a02"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_23_5bd33fad66845_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_23_5bd33fad66845" ><script>var block_td_uid_23_5bd33fad66845 = new tdBlock();
block_td_uid_23_5bd33fad66845.id = "td_uid_23_5bd33fad66845";
block_td_uid_23_5bd33fad66845.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"97","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_23_5bd33fad66845_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_23_5bd33fad66845.td_column_number = "3";
block_td_uid_23_5bd33fad66845.block_type = "td_block_mega_menu";
block_td_uid_23_5bd33fad66845.post_count = "5";
block_td_uid_23_5bd33fad66845.found_posts = "260";
block_td_uid_23_5bd33fad66845.header_color = "";
block_td_uid_23_5bd33fad66845.ajax_pagination_infinite_stop = "";
block_td_uid_23_5bd33fad66845.max_num_pages = "52";
tdBlocksArray.push(block_td_uid_23_5bd33fad66845);
</script><div id=td_uid_23_5bd33fad66845 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/26/mixtape-tory-lanez-love-me-now/" rel="bookmark" title="Mixtape: Tory Lanez &#8211; LoVE mE NOw"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Tory-Lanez-LoVE-mE-NOw-218x150.jpg" alt="" title="Mixtape: Tory Lanez &#8211; LoVE mE NOw"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/26/mixtape-tory-lanez-love-me-now/" rel="bookmark" title="Mixtape: Tory Lanez &#8211; LoVE mE NOw">Mixtape: Tory Lanez &#8211; LoVE mE NOw</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/26/album-stream-jeremih-ty-dolla-sign-mih-ty/" rel="bookmark" title="Album Stream: Jeremih &#038; Ty Dolla Sign &#8211; MIH-TY"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Jeremih-Ty-Dolla-Sign-MIH-TY-218x150.jpg" alt="" title="Album Stream: Jeremih &#038; Ty Dolla Sign &#8211; MIH-TY"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/26/album-stream-jeremih-ty-dolla-sign-mih-ty/" rel="bookmark" title="Album Stream: Jeremih &#038; Ty Dolla Sign &#8211; MIH-TY">Album Stream: Jeremih &#038; Ty Dolla Sign &#8211; MIH-TY</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/26/album-stream-apollo-brown-joell-ortiz-mona-lisa/" rel="bookmark" title="Album Stream: Apollo Brown &#038; Joell Ortiz &#8211; Mona Lisa"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Apollo-Brown-Joell-Ortiz-Mona-Lisa-218x150.jpg" alt="" title="Album Stream: Apollo Brown &#038; Joell Ortiz &#8211; Mona Lisa"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/26/album-stream-apollo-brown-joell-ortiz-mona-lisa/" rel="bookmark" title="Album Stream: Apollo Brown &#038; Joell Ortiz &#8211; Mona Lisa">Album Stream: Apollo Brown &#038; Joell Ortiz &#8211; Mona Lisa</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/26/album-stream-madeintyo-sincerely-tokyo/" rel="bookmark" title="Album Stream: MadeinTYO &#8211; Sincerely, Tokyo"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/MadeinTYO-Sincerely-Tokyo-218x150.jpg" alt="" title="Album Stream: MadeinTYO &#8211; Sincerely, Tokyo"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/26/album-stream-madeintyo-sincerely-tokyo/" rel="bookmark" title="Album Stream: MadeinTYO &#8211; Sincerely, Tokyo">Album Stream: MadeinTYO &#8211; Sincerely, Tokyo</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/25/ep-stream-leikeli47-pick-a-color/" rel="bookmark" title="EP Stream: Leikeli47 – Pick A Color"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Leikeli47-–-Pick-A-Color-218x150.jpg" alt="" title="EP Stream: Leikeli47 – Pick A Color"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/25/ep-stream-leikeli47-pick-a-color/" rel="bookmark" title="EP Stream: Leikeli47 – Pick A Color">EP Stream: Leikeli47 – Pick A Color</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_23_5bd33fad66845" data-td_block_id="td_uid_23_5bd33fad66845"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_23_5bd33fad66845" data-td_block_id="td_uid_23_5bd33fad66845"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_24_5bd33fad87e67_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_24_5bd33fad87e67" ><script>var block_td_uid_24_5bd33fad87e67 = new tdBlock();
block_td_uid_24_5bd33fad87e67.id = "td_uid_24_5bd33fad87e67";
block_td_uid_24_5bd33fad87e67.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_24_5bd33fad87e67_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_24_5bd33fad87e67.td_column_number = "3";
block_td_uid_24_5bd33fad87e67.block_type = "td_block_mega_menu";
block_td_uid_24_5bd33fad87e67.post_count = "5";
block_td_uid_24_5bd33fad87e67.found_posts = "616";
block_td_uid_24_5bd33fad87e67.header_color = "";
block_td_uid_24_5bd33fad87e67.ajax_pagination_infinite_stop = "";
block_td_uid_24_5bd33fad87e67.max_num_pages = "124";
tdBlocksArray.push(block_td_uid_24_5bd33fad87e67);
</script><div id=td_uid_24_5bd33fad87e67 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/25/music-video-kevo-sabe-fuck-with-me/" rel="bookmark" title="Music Video: Kevo Sabe &#8211; Fuck With Me"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Kevo-Sabe-Fuck-With-Me-1-218x150.jpg" alt="" title="Music Video: Kevo Sabe &#8211; Fuck With Me"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/25/music-video-kevo-sabe-fuck-with-me/" rel="bookmark" title="Music Video: Kevo Sabe &#8211; Fuck With Me">Music Video: Kevo Sabe &#8211; Fuck With Me</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/25/music-video-hardo-my-last/" rel="bookmark" title="Music Video: Hardo &#8211; My Last"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Hardo-My-Last-218x150.jpg" alt="" title="Music Video: Hardo &#8211; My Last"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/25/music-video-hardo-my-last/" rel="bookmark" title="Music Video: Hardo &#8211; My Last">Music Video: Hardo &#8211; My Last</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/25/music-video-yung-lean-happy-feet/" rel="bookmark" title="Music Video: Yung Lean – Happy Feet"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Yung-Lean-–-Happy-Feet-218x150.jpg" alt="" title="Music Video: Yung Lean – Happy Feet"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/25/music-video-yung-lean-happy-feet/" rel="bookmark" title="Music Video: Yung Lean – Happy Feet">Music Video: Yung Lean – Happy Feet</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/25/music-video-wizkid-fever/" rel="bookmark" title="Music Video: Wizkid – Fever"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Wizkid-–-Fever-218x150.jpg" alt="" title="Music Video: Wizkid – Fever"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/25/music-video-wizkid-fever/" rel="bookmark" title="Music Video: Wizkid – Fever">Music Video: Wizkid – Fever</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/25/music-video-the-alchemist-ft-conway-westside-gunn-schoolboy-q-fork-in-the-pot/" rel="bookmark" title="Music Video: The Alchemist ft. Conway, Westside Gunn &#038; ScHoolboy Q – Fork In The Pot"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/The-Alchemist-ft.-Conway-Westside-Gunn-ScHoolboy-Q-–-Fork-In-The-Pot-218x150.jpg" alt="" title="Music Video: The Alchemist ft. Conway, Westside Gunn &#038; ScHoolboy Q – Fork In The Pot"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/25/music-video-the-alchemist-ft-conway-westside-gunn-schoolboy-q-fork-in-the-pot/" rel="bookmark" title="Music Video: The Alchemist ft. Conway, Westside Gunn &#038; ScHoolboy Q – Fork In The Pot">Music Video: The Alchemist ft. Conway, Westside Gunn &#038; ScHoolboy Q&#8230;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_24_5bd33fad87e67" data-td_block_id="td_uid_24_5bd33fad87e67"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_24_5bd33fad87e67" data-td_block_id="td_uid_24_5bd33fad87e67"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_25_5bd33fada92b3_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_25_5bd33fada92b3" ><script>var block_td_uid_25_5bd33fada92b3 = new tdBlock();
block_td_uid_25_5bd33fada92b3.id = "td_uid_25_5bd33fada92b3";
block_td_uid_25_5bd33fada92b3.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"29","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_25_5bd33fada92b3_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_25_5bd33fada92b3.td_column_number = "3";
block_td_uid_25_5bd33fada92b3.block_type = "td_block_mega_menu";
block_td_uid_25_5bd33fada92b3.post_count = "4";
block_td_uid_25_5bd33fada92b3.found_posts = "299";
block_td_uid_25_5bd33fada92b3.header_color = "";
block_td_uid_25_5bd33fada92b3.ajax_pagination_infinite_stop = "";
block_td_uid_25_5bd33fada92b3.max_num_pages = "75";
tdBlocksArray.push(block_td_uid_25_5bd33fada92b3);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_25_5bd33fada92b3" id="td_uid_26_5bd33fadabd63" data-td_block_id="td_uid_25_5bd33fada92b3" data-td_filter_value="" href="http://weuponithiphop.info/category/latest-news/">All</a><a class="mega-menu-sub-cat-td_uid_25_5bd33fada92b3"  id="td_uid_27_5bd33fadac660" data-td_block_id="td_uid_25_5bd33fada92b3" data-td_filter_value="69" href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a><a class="mega-menu-sub-cat-td_uid_25_5bd33fada92b3"  id="td_uid_28_5bd33fadac989" data-td_block_id="td_uid_25_5bd33fada92b3" data-td_filter_value="80" href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a><a class="mega-menu-sub-cat-td_uid_25_5bd33fada92b3"  id="td_uid_29_5bd33fadacb42" data-td_block_id="td_uid_25_5bd33fada92b3" data-td_filter_value="2189" href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a><a class="mega-menu-sub-cat-td_uid_25_5bd33fada92b3"  id="td_uid_30_5bd33fadaccf2" data-td_block_id="td_uid_25_5bd33fada92b3" data-td_filter_value="10" href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a><a class="mega-menu-sub-cat-td_uid_25_5bd33fada92b3"  id="td_uid_31_5bd33fadae8cb" data-td_block_id="td_uid_25_5bd33fada92b3" data-td_filter_value="130" href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></div></div><div id=td_uid_25_5bd33fada92b3 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/24/curreny-freddie-gibbs-reveal-fetti-tracklist/" rel="bookmark" title="Curren$y &#038; Freddie Gibbs Reveal ‘FETTI’ Tracklist"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Curreny-Freddie-Gibbs-Reveal-FETTI-Tracklist-1-218x150.jpg" alt="" title="Curren$y &#038; Freddie Gibbs Reveal ‘FETTI’ Tracklist"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/24/curreny-freddie-gibbs-reveal-fetti-tracklist/" rel="bookmark" title="Curren$y &#038; Freddie Gibbs Reveal ‘FETTI’ Tracklist">Curren$y &#038; Freddie Gibbs Reveal ‘FETTI’ Tracklist</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/24/takeoff-reveals-the-last-rocket-album-release-date/" rel="bookmark" title="Takeoff Reveals “The Last Rocket” Album Release Date"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Takeoff-Reveals-The-Last-Rocket-Album-Release-Date-218x150.jpg" alt="" title="Takeoff Reveals “The Last Rocket” Album Release Date"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/24/takeoff-reveals-the-last-rocket-album-release-date/" rel="bookmark" title="Takeoff Reveals “The Last Rocket” Album Release Date">Takeoff Reveals “The Last Rocket” Album Release Date</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/23/video-wale-performs-ungrateful-thankful-acapella/" rel="bookmark" title="Video: Wale Performs “Ungrateful &#038; Thankful” Acapella"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Wale-Performs-Ungrateful-Thankful-Acapella-218x150.jpg" alt="" title="Video: Wale Performs “Ungrateful &#038; Thankful” Acapella"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/23/video-wale-performs-ungrateful-thankful-acapella/" rel="bookmark" title="Video: Wale Performs “Ungrateful &#038; Thankful” Acapella">Video: Wale Performs “Ungrateful &#038; Thankful” Acapella</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/23/video-lupe-fiasco-performs-mural-jr-acapella/" rel="bookmark" title="Video: Lupe Fiasco Performs “Mural Jr.” Acapella"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Lupe-Fiasco-Performs-Mural-Jr.-Acapella-218x150.jpg" alt="" title="Video: Lupe Fiasco Performs “Mural Jr.” Acapella"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/23/video-lupe-fiasco-performs-mural-jr-acapella/" rel="bookmark" title="Video: Lupe Fiasco Performs “Mural Jr.” Acapella">Video: Lupe Fiasco Performs “Mural Jr.” Acapella</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_25_5bd33fada92b3" data-td_block_id="td_uid_25_5bd33fada92b3"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_25_5bd33fada92b3" data-td_block_id="td_uid_25_5bd33fada92b3"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_32_5bd33fae6d1f3_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_32_5bd33fae6d1f3" ><script>var block_td_uid_32_5bd33fae6d1f3 = new tdBlock();
block_td_uid_32_5bd33fae6d1f3.id = "td_uid_32_5bd33fae6d1f3";
block_td_uid_32_5bd33fae6d1f3.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"77","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_32_5bd33fae6d1f3_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_32_5bd33fae6d1f3.td_column_number = "3";
block_td_uid_32_5bd33fae6d1f3.block_type = "td_block_mega_menu";
block_td_uid_32_5bd33fae6d1f3.post_count = "4";
block_td_uid_32_5bd33fae6d1f3.found_posts = "124";
block_td_uid_32_5bd33fae6d1f3.header_color = "";
block_td_uid_32_5bd33fae6d1f3.ajax_pagination_infinite_stop = "";
block_td_uid_32_5bd33fae6d1f3.max_num_pages = "31";
tdBlocksArray.push(block_td_uid_32_5bd33fae6d1f3);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_32_5bd33fae6d1f3" id="td_uid_33_5bd33fae72d6f" data-td_block_id="td_uid_32_5bd33fae6d1f3" data-td_filter_value="" href="http://weuponithiphop.info/category/fashion/">All</a><a class="mega-menu-sub-cat-td_uid_32_5bd33fae6d1f3"  id="td_uid_34_5bd33fae73e08" data-td_block_id="td_uid_32_5bd33fae6d1f3" data-td_filter_value="76" href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></div></div><div id=td_uid_32_5bd33fae6d1f3 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/24/adidas-futurecraft-4d-i-5923-1/" rel="bookmark" title="adidas FutureCraft 4D I-5923"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/adidas-FutureCraft-4D-I-5923-1-218x150.jpg" alt="" title="adidas FutureCraft 4D I-5923"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/24/adidas-futurecraft-4d-i-5923-1/" rel="bookmark" title="adidas FutureCraft 4D I-5923">adidas FutureCraft 4D I-5923</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/21/g-shock-full-metal-5000-collection/" rel="bookmark" title="G-SHOCK Full Metal 5000 Collection"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/casio-g-shock-full-metal-5000-collection-new-watches-0-218x150.jpg" alt="" title="G-SHOCK Full Metal 5000 Collection"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/21/g-shock-full-metal-5000-collection/" rel="bookmark" title="G-SHOCK Full Metal 5000 Collection">G-SHOCK Full Metal 5000 Collection</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/15/air-jordan-11-platinum-tint/" rel="bookmark" title="Air Jordan 11 Platinum Tint"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Air-Jordan-11-Platinum-Tint-15-218x150.jpg" alt="" title="Air Jordan 11 Platinum Tint"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/15/air-jordan-11-platinum-tint/" rel="bookmark" title="Air Jordan 11 Platinum Tint">Air Jordan 11 Platinum Tint</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/15/official-look-at-the-nike-wmns-air-vapormax-2019/" rel="bookmark" title="Nike WMNS Air VaporMax 2019"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Nike-WMNS-Air-VaporMax-2019-5-218x150.jpg" alt="" title="Nike WMNS Air VaporMax 2019"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/15/official-look-at-the-nike-wmns-air-vapormax-2019/" rel="bookmark" title="Nike WMNS Air VaporMax 2019">Nike WMNS Air VaporMax 2019</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_32_5bd33fae6d1f3" data-td_block_id="td_uid_32_5bd33fae6d1f3"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_32_5bd33fae6d1f3" data-td_block_id="td_uid_32_5bd33fae6d1f3"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-2515"><a href="http://weuponithiphop.info/category/editors-picks/">Editor&#8217;s Picks</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_35_5bd33faead91e_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_35_5bd33faead91e" ><script>var block_td_uid_35_5bd33faead91e = new tdBlock();
block_td_uid_35_5bd33faead91e.id = "td_uid_35_5bd33faead91e";
block_td_uid_35_5bd33faead91e.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"118","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_35_5bd33faead91e_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_35_5bd33faead91e.td_column_number = "3";
block_td_uid_35_5bd33faead91e.block_type = "td_block_mega_menu";
block_td_uid_35_5bd33faead91e.post_count = "5";
block_td_uid_35_5bd33faead91e.found_posts = "302";
block_td_uid_35_5bd33faead91e.header_color = "";
block_td_uid_35_5bd33faead91e.ajax_pagination_infinite_stop = "";
block_td_uid_35_5bd33faead91e.max_num_pages = "61";
tdBlocksArray.push(block_td_uid_35_5bd33faead91e);
</script><div id=td_uid_35_5bd33faead91e class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/26/album-stream-apollo-brown-joell-ortiz-mona-lisa/" rel="bookmark" title="Album Stream: Apollo Brown &#038; Joell Ortiz &#8211; Mona Lisa"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Apollo-Brown-Joell-Ortiz-Mona-Lisa-218x150.jpg" alt="" title="Album Stream: Apollo Brown &#038; Joell Ortiz &#8211; Mona Lisa"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/26/album-stream-apollo-brown-joell-ortiz-mona-lisa/" rel="bookmark" title="Album Stream: Apollo Brown &#038; Joell Ortiz &#8211; Mona Lisa">Album Stream: Apollo Brown &#038; Joell Ortiz &#8211; Mona Lisa</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/26/new-music-rapsody-ft-j-cole-sojourner/" rel="bookmark" title="New Music: Rapsody ft. J. Cole &#8211; Sojourner"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Rapsody-ft.-J.-Cole-Sojourner-218x150.jpg" alt="" title="New Music: Rapsody ft. J. Cole &#8211; Sojourner"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/26/new-music-rapsody-ft-j-cole-sojourner/" rel="bookmark" title="New Music: Rapsody ft. J. Cole &#8211; Sojourner">New Music: Rapsody ft. J. Cole &#8211; Sojourner</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/25/music-video-hardo-my-last/" rel="bookmark" title="Music Video: Hardo &#8211; My Last"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Hardo-My-Last-218x150.jpg" alt="" title="Music Video: Hardo &#8211; My Last"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/25/music-video-hardo-my-last/" rel="bookmark" title="Music Video: Hardo &#8211; My Last">Music Video: Hardo &#8211; My Last</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/24/music-video-tory-lanez-ft-gunna-miami/" rel="bookmark" title="Music Video: Tory Lanez ft. Gunna – MiAMi"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Tory-Lanez-ft.-Gunna-–-MiAMi-218x150.jpg" alt="" title="Music Video: Tory Lanez ft. Gunna – MiAMi"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/24/music-video-tory-lanez-ft-gunna-miami/" rel="bookmark" title="Music Video: Tory Lanez ft. Gunna – MiAMi">Music Video: Tory Lanez ft. Gunna – MiAMi</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/24/new-music-willie-the-kid-dealer-plates/" rel="bookmark" title="New Music: Willie The Kid – Dealer Plates"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Willie-The-Kid-–-Dealer-Plates-218x150.jpg" alt="" title="New Music: Willie The Kid – Dealer Plates"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/24/new-music-willie-the-kid-dealer-plates/" rel="bookmark" title="New Music: Willie The Kid – Dealer Plates">New Music: Willie The Kid – Dealer Plates</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_35_5bd33faead91e" data-td_block_id="td_uid_35_5bd33faead91e"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_35_5bd33faead91e" data-td_block_id="td_uid_35_5bd33faead91e"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees/">Shop</a></li>
</ul></div>                </div>

                <div class="td-pb-span5 td-sub-footer-copy">
                    &copy; 2018 The Hip Hop Chronicles Media Group                </div>
            </div>
        </div>
    </div>
</div><!--close td-outer-wrap-->

	<div id="wpcp-error-message" class="msgmsg-box-wpcp warning-wpcp hideme"><span>error: </span>I\'m good love, Enjoy!! 😘😎🤓😂😂✌️</div>
	<script>
	var timeout_result;
	function show_wpcp_message(smessage)
	{
		if (smessage !== "")
			{
			var smessage_text = '<span>Alert: </span>'+smessage;
			document.getElementById("wpcp-error-message").innerHTML = smessage_text;
			document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp showme";
			clearTimeout(timeout_result);
			timeout_result = setTimeout(hide_message, 3000);
			}
	}
	function hide_message()
	{
		document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp hideme";
	}
	</script>
	<style type="text/css">
	#wpcp-error-message {
	    direction: ltr;
	    text-align: center;
	    transition: opacity 900ms ease 0s;
	    z-index: 99999999;
	}
	.hideme {
    	opacity:0;
    	visibility: hidden;
	}
	.showme {
    	opacity:1;
    	visibility: visible;
	}
	.msgmsg-box-wpcp {
		border-radius: 10px;
		color: #555;
		font-family: Tahoma;
		font-size: 11px;
		margin: 10px;
		padding: 10px 36px;
		position: fixed;
		width: 255px;
		top: 50%;
  		left: 50%;
  		margin-top: -10px;
  		margin-left: -130px;
  		-webkit-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
		-moz-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
		box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
	}
	.msgmsg-box-wpcp span {
		font-weight:bold;
		text-transform:uppercase;
	}
	.error-wpcp {		background:#ffecec url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/error.png') no-repeat 10px 50%;
		border:1px solid #f5aca6;
	}
	.success {
		background:#e9ffd9 url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/success.png') no-repeat 10px 50%;
		border:1px solid #a6ca8a;
	}
	.warning-wpcp {
		background:#ffecec url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/warning.png') no-repeat 10px 50%;
		border:1px solid #f5aca6;
	}
	.notice {
		background:#e3f7fc url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/notice.png') no-repeat 10px 50%;
		border:1px solid #8ed9f6;
	}
    </style>
	<div style="display:none">
	</div>


    <!--

        Theme: Newspaper by tagDiv 2016
        Version: 7.2 (rara)
        Deploy mode: deploy
        
        uid: 5bd33faed3933
    -->

    <link rel='stylesheet' id='so-css-Newspaper-css'  href='http://weuponithiphop.info/wp-content/uploads/so-css/so-css-Newspaper.css?ver=1528674688' type='text/css' media='all' />
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201843'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2018Octaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/themes/Newspaper/js/tagdiv_theme.js?ver=7.2'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/comment-reply.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/wp-embed.min.js?ver=4.9.8'></script>

<!-- JS generated by theme -->

<script>
    


            

	            // if the theme has tdBackstr support, it means this already uses it
                if ( 'undefined' !== typeof window.tdBackstr ) {

                    (function(){
                        // the site background td-backstretch jquery object is dynamically added in DOM, and after any translation effects are applied over td-backstretch
                        var wrapper_image_jquery_obj = jQuery( '<div class=\'backstretch\'></div>' );
                        var image_jquery_obj = jQuery( '<img class=\'td-backstretch not-parallax\' src=\'http://weuponithiphop.info/wp-content/uploads/offwhite.jpg\'>' );

                        wrapper_image_jquery_obj.append( image_jquery_obj );

                        jQuery( 'body' ).prepend( wrapper_image_jquery_obj );

                        var td_backstr_item = new tdBackstr.item();

                        td_backstr_item.wrapper_image_jquery_obj = wrapper_image_jquery_obj;
                        td_backstr_item.image_jquery_obj = image_jquery_obj;

	                    tdBackstr.add_item( td_backstr_item );

                    })();
                }

            
            

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'http://weuponithiphop.info/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'http://weuponithiphop.info/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>

<script type='text/javascript' src='https://stats.wp.com/e-201843.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.6.1',blog:'147622849',post:'15709',tz:'-4',srv:'weuponithiphop.info'} ]);
	_stq.push([ 'clickTrackerInit', '147622849', '15709' ]);
</script>

</body>
</html>