<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>Music Video: Blueface ft. YG – Thotiana (Remix)</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="http://weuponithiphop.info/xmlrpc.php" />
    <meta property="og:image" content="http://weuponithiphop.info/wp-content/uploads/Blueface-ft.-YG-–-Thotiana-Remix.jpg" /><meta name="author" content="cyclone">
<link rel="icon" type="image/png" href="http://weuponithiphop.info/wp-content/uploads/weuponitlogoCAP-500x457.png">
<!-- All in One SEO Pack 2.9 by Michael Torbert of Semper Fi Web Design[208,273] -->
<link rel="canonical" href="http://weuponithiphop.info/2019/01/26/music-video-blueface-ft-yg-thotiana-remix/" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Feed" href="http://weuponithiphop.info/feed/" />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Comments Feed" href="http://weuponithiphop.info/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Music Video: Blueface ft. YG – Thotiana (Remix) Comments Feed" href="http://weuponithiphop.info/2019/01/26/music-video-blueface-ft-yg-thotiana-remix/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/weuponithiphop.info\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.9"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wpstatistics-css-css'  href='http://weuponithiphop.info/wp-content/plugins/wp-statistics/assets/css/frontend.css?ver=12.4.3' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_open_sans-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_roboto-css'  href='http://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C900%2C500italic%2C400%2C300&#038;ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='http://fonts.googleapis.com/css?family=Roboto+Condensed%3A400%2C700&#038;ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='http://weuponithiphop.info/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=4.12' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='http://weuponithiphop.info/wp-content/themes/Newspaper/style.css?ver=7.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css'  href='http://weuponithiphop.info/wp-content/themes/Newspaper/includes/demos/what/demo_style.css?ver=7.2' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://weuponithiphop.info/wp-content/plugins/jetpack/css/jetpack.css?ver=6.6.1' type='text/css' media='all' />
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1'></script>
<link rel='https://api.w.org/' href='http://weuponithiphop.info/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://weuponithiphop.info/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://weuponithiphop.info/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Music Video: Trippie Redd &#038; Rich The Kid – Icky Vicky' href='http://weuponithiphop.info/2019/01/26/music-video-trippie-redd-rich-the-kid-icky-vicky/' />
<link rel='next' title='Audio: Joe Budden &#8211; The Joe Budden Podcast W/ Rory, Mal &#038; Parks (Episode 216) “Clickbait”' href='http://weuponithiphop.info/2019/01/26/audio-joe-budden-the-joe-budden-podcast-w-rory-mal-parks-episode-216-clickbait/' />
<meta name="generator" content="WordPress 4.9.9" />
<link rel='shortlink' href='https://wp.me/p9ZprH-5SL' />
<link rel="alternate" type="application/json+oembed" href="http://weuponithiphop.info/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fweuponithiphop.info%2F2019%2F01%2F26%2Fmusic-video-blueface-ft-yg-thotiana-remix%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://weuponithiphop.info/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fweuponithiphop.info%2F2019%2F01%2F26%2Fmusic-video-blueface-ft-yg-thotiana-remix%2F&#038;format=xml" />

<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>
<script id="wpcp_disable_selection" type="text/javascript">
//<![CDATA[
var image_save_msg='You Can Not Save images!';
	var no_menu_msg='Context Menu disabled!';
	var smessage = "Not Prohibited. ✌️";

function disableEnterKey(e)
{
	if (e.ctrlKey){
     var key;
     if(window.event)
          key = window.event.keyCode;     //IE
     else
          key = e.which;     //firefox (97)
    //if (key != 17) alert(key);
     if (key == 97 || key == 65 || key == 67 || key == 99 || key == 88 || key == 120 || key == 26 || key == 85  || key == 86 || key == 83 || key == 43)
     {
          show_wpcp_message('You are not allowed to copy content or view source');
          return false;
     }else
     	return true;
     }
}

function disable_copy(e)
{	
	var elemtype = e.target.nodeName;
	var isSafari = /Safari/.test(navigator.userAgent) && /Apple Computer/.test(navigator.vendor);
	elemtype = elemtype.toUpperCase();
	var checker_IMG = '';
	if (elemtype == "IMG" && checker_IMG == 'checked' && e.detail >= 2) {show_wpcp_message(alertMsg_IMG);return false;}
	if (elemtype != "TEXT" && elemtype != "TEXTAREA" && elemtype != "INPUT" && elemtype != "PASSWORD" && elemtype != "SELECT" && elemtype != "OPTION" && elemtype != "EMBED")
	{
		if (smessage !== "" && e.detail == 2)
			show_wpcp_message(smessage);
		
		if (isSafari)
			return true;
		else
			return false;
	}	
}
function disable_copy_ie()
{
	var elemtype = window.event.srcElement.nodeName;
	elemtype = elemtype.toUpperCase();
	if (elemtype == "IMG") {show_wpcp_message(alertMsg_IMG);return false;}
	if (elemtype != "TEXT" && elemtype != "TEXTAREA" && elemtype != "INPUT" && elemtype != "PASSWORD" && elemtype != "SELECT" && elemtype != "OPTION" && elemtype != "EMBED")
	{
		//alert(navigator.userAgent.indexOf('MSIE'));
			//if (smessage !== "") show_wpcp_message(smessage);
		return false;
	}
}	
function reEnable()
{
	return true;
}
document.onkeydown = disableEnterKey;
document.onselectstart = disable_copy_ie;
if(navigator.userAgent.indexOf('MSIE')==-1)
{
	document.onmousedown = disable_copy;
	document.onclick = reEnable;
}
function disableSelection(target)
{
    //For IE This code will work
    if (typeof target.onselectstart!="undefined")
    target.onselectstart = disable_copy_ie;
    
    //For Firefox This code will work
    else if (typeof target.style.MozUserSelect!="undefined")
    {target.style.MozUserSelect="none";}
    
    //All other  (ie: Opera) This code will work
    else
    target.onmousedown=function(){return false}
    target.style.cursor = "default";
}
//Calling the JS function directly just after body load
window.onload = function(){disableSelection(document.body);};
//]]>
</script>
	<script id="wpcp_disable_Right_Click" type="text/javascript">
	//<![CDATA[
	document.ondragstart = function() { return false;}
	/* ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
	Disable context menu on images by GreenLava Version 1.0
	^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ */
	    function nocontext(e) {
	       return false;
	    }
	    document.oncontextmenu = nocontext;
	//]]>
	</script>

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]-->
<!-- JS generated by theme -->

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var tds_login_sing_in_widget="show";
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_ajax_url="http:\/\/weuponithiphop.info\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=7.2";
var td_get_template_directory_uri="http:\/\/weuponithiphop.info\/wp-content\/themes\/Newspaper";
var tds_snap_menu="snap";
var tds_logo_on_sticky="show_header_logo";
var tds_header_style="5";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#dd3333";
var tds_smart_sidebar="enabled";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>


<!-- Header style compiled by theme -->

<style>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</style>

<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>

<body class="post-template-default single single-post postid-22615 single-format-standard unselectable music-video-blueface-ft-yg-thotiana-remix td-what single_template_3 wpb-js-composer js-comp-ver-4.12 vc_responsive td-boxed-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
                    <div class="td-menu-login-section">
                
    <div class="td-guest-wrap">
        <div class="td-menu-avatar"><div class="td-avatar-container"><img alt='' src='http://0.gravatar.com/avatar/?s=80&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo avatar-default' height='80' width='80' /></div></div>
        <div class="td-menu-login"><a id="login-link-mob">Sign in</a></div>
    </div>
            </div>
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-top-menu-container"><ul id="menu-top-menu" class="td-mobile-main-menu"><li id="menu-item-317" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a></li>
<li id="menu-item-706" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a></li>
<li id="menu-item-314" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a></li>
<li id="menu-item-316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-0" class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></li>
</ul>
</li>
<li id="menu-item-705" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></li>
</ul>
</li>
<li id="menu-item-2515" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2515"><a href="http://weuponithiphop.info/category/editors-picks/">Editor&#8217;s Picks</a></li>
<li id="menu-item-3199" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees/">Shop</a></li>
<li id="menu-item-18581" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
            <div id="login-form-mobile" class="td-register-section">
            
            <div id="td-login-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-login-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign in</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
	                <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
	                <div class="td-login-info-text"><a href="#" id="forgot-pass-link-mob">Forgot your password?</a></div>
                </div>
            </div>

            

            <div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
                <!-- close button -->
	            <div class="td-forgot-pass-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Password recovery</div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title">Recover your password</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
	                <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
                </div>
            </div>
        </div>
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="http://weuponithiphop.info/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap">
    
        <!--
Header style 5
-->

<div class="td-header-wrap td-header-style-5">

    <div class="td-header-top-menu-full">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div >

                Saturday, January 26, 2019
            </div>
        </div>
    <ul class="top-header-menu td_ul_login"><li class="menu-item"><a class="td-login-modal-js menu-item" href="#login-form" data-effect="mpf-td-login-effect">Sign in / Join</a><span class="td-sp-ico-login td_sp_login_ico_style"></span></li></ul><div class="menu-top-container"><ul id="menu-main" class="top-header-menu"><li id="menu-item-79" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-79"><a href="http://weuponithiphop.info">Home</a></li>
<li id="menu-item-81" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-81"><a target="_blank" href="http://weuponitradio.com">Power 105.1 WeUpOnIt Radio</a></li>
<li id="menu-item-80" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-80"><a target="_blank" href="https://shop.spreadshirt.com/freshandcleantees/">Shop</a></li>
<li id="menu-item-18582" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18582"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li id="menu-item-18583" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18583"><a href="http://weuponithiphop.info/privacy-policy-2/">Privacy Policy</a></li>
</ul></div></div>
        <div class="td-header-sp-top-widget">
    
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div>
    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <ul class="td-login-tabs">
                        <li><a id="login-link" class="td_login_tab_focus">LOG IN</a></li>
                    </ul>



                    <div class="td-login-wrap">
                        <div class="td_display_err"></div>

                        <div id="td-login-div" class="">
                            <div class="td-login-panel-title">Welcome! Log into your account</div>
                            <input class="td-login-input" type="text" name="login_email" id="login_email" placeholder="your username" value="" required>
                            <input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" placeholder="your password" required>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Log In">


                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password?</a></div>


                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-display-none">
                            <div class="td-login-panel-title">Recover your password</div>
                            <input class="td-login-input" type="text" name="forgot_email" id="forgot_email" placeholder="your email" value="" required>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Pass">
                        </div>




                    </div>
                </div>
                        </div>
    </div>

    <div class="td-header-menu-wrap-full">
        <div class="td-header-menu-wrap">
            <div class="td-container td-header-row td-header-main-menu black-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-menu">
        		<a class="td-mobile-logo td-sticky-header" href="http://weuponithiphop.info/">
			<img class="td-retina-data" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-5.png" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-5.png" alt=""/>
		</a>
			<a class="td-header-logo td-sticky-header" href="http://weuponithiphop.info/">
			<img class="td-retina-data" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" alt=""/>
			<span class="td-visual-hidden">WeUpOnIt</span>
		</a>
	    </div>
    <div class="menu-top-menu-container"><ul id="menu-top-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-mega-menu menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_1_5c4c777fd6ff1_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_1_5c4c777fd6ff1" ><script>var block_td_uid_1_5c4c777fd6ff1 = new tdBlock();
block_td_uid_1_5c4c777fd6ff1.id = "td_uid_1_5c4c777fd6ff1";
block_td_uid_1_5c4c777fd6ff1.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"43","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_1_5c4c777fd6ff1_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_1_5c4c777fd6ff1.td_column_number = "3";
block_td_uid_1_5c4c777fd6ff1.block_type = "td_block_mega_menu";
block_td_uid_1_5c4c777fd6ff1.post_count = "5";
block_td_uid_1_5c4c777fd6ff1.found_posts = "1203";
block_td_uid_1_5c4c777fd6ff1.header_color = "";
block_td_uid_1_5c4c777fd6ff1.ajax_pagination_infinite_stop = "";
block_td_uid_1_5c4c777fd6ff1.max_num_pages = "241";
tdBlocksArray.push(block_td_uid_1_5c4c777fd6ff1);
</script><div id=td_uid_1_5c4c777fd6ff1 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/26/new-music-yo-gotti-ft-lil-baby-put-a-date-on-it/" rel="bookmark" title="New Music: Yo Gotti ft. Lil Baby – Put A Date On It"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Yo-Gotti-ft.-Lil-Baby-–-Put-A-Date-On-It-218x150.jpg" alt="" title="New Music: Yo Gotti ft. Lil Baby – Put A Date On It"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/26/new-music-yo-gotti-ft-lil-baby-put-a-date-on-it/" rel="bookmark" title="New Music: Yo Gotti ft. Lil Baby – Put A Date On It">New Music: Yo Gotti ft. Lil Baby – Put A Date&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/26/new-music-gashi-ft-g-eazy-my-year/" rel="bookmark" title="New Music: GASHI ft. G-Eazy – My Year"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/GASHI-ft.-G-Eazy-–-My-Year-218x150.jpg" alt="" title="New Music: GASHI ft. G-Eazy – My Year"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/26/new-music-gashi-ft-g-eazy-my-year/" rel="bookmark" title="New Music: GASHI ft. G-Eazy – My Year">New Music: GASHI ft. G-Eazy – My Year</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/26/new-music-fredo-bang-ft-kevin-gates-oouuh-remix/" rel="bookmark" title="New Music: Fredo Bang ft. Kevin Gates – Oouuh (Remix)"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Fredo-Bang-ft.-Kevin-Gates-–-Oouuh-Remix-218x150.jpeg" alt="" title="New Music: Fredo Bang ft. Kevin Gates – Oouuh (Remix)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/26/new-music-fredo-bang-ft-kevin-gates-oouuh-remix/" rel="bookmark" title="New Music: Fredo Bang ft. Kevin Gates – Oouuh (Remix)">New Music: Fredo Bang ft. Kevin Gates – Oouuh (Remix)</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/26/new-music-night-lovell-bad-kid/" rel="bookmark" title="New Music: Night Lovell – BAD KID"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Night-Lovell-–-BAD-KID-218x150.jpeg" alt="" title="New Music: Night Lovell – BAD KID"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/26/new-music-night-lovell-bad-kid/" rel="bookmark" title="New Music: Night Lovell – BAD KID">New Music: Night Lovell – BAD KID</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/25/new-music-maxo-kream-meet-again/" rel="bookmark" title="New Music: Maxo Kream – Meet Again"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Maxo-Kream-–-Meet-Again-218x150.jpeg" alt="" title="New Music: Maxo Kream – Meet Again"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/25/new-music-maxo-kream-meet-again/" rel="bookmark" title="New Music: Maxo Kream – Meet Again">New Music: Maxo Kream – Meet Again</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_5c4c777fd6ff1" data-td_block_id="td_uid_1_5c4c777fd6ff1"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_1_5c4c777fd6ff1" data-td_block_id="td_uid_1_5c4c777fd6ff1"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_2_5c4c777fddcc8_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_2_5c4c777fddcc8" ><script>var block_td_uid_2_5c4c777fddcc8 = new tdBlock();
block_td_uid_2_5c4c777fddcc8.id = "td_uid_2_5c4c777fddcc8";
block_td_uid_2_5c4c777fddcc8.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"97","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_2_5c4c777fddcc8_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_2_5c4c777fddcc8.td_column_number = "3";
block_td_uid_2_5c4c777fddcc8.block_type = "td_block_mega_menu";
block_td_uid_2_5c4c777fddcc8.post_count = "5";
block_td_uid_2_5c4c777fddcc8.found_posts = "475";
block_td_uid_2_5c4c777fddcc8.header_color = "";
block_td_uid_2_5c4c777fddcc8.ajax_pagination_infinite_stop = "";
block_td_uid_2_5c4c777fddcc8.max_num_pages = "95";
tdBlocksArray.push(block_td_uid_2_5c4c777fddcc8);
</script><div id=td_uid_2_5c4c777fddcc8 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/26/ep-stream-jay-prince-wonder/" rel="bookmark" title="EP Stream: Jay Prince – WONDER"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Jay-Prince-–-WONDER-218x150.jpeg" alt="" title="EP Stream: Jay Prince – WONDER"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/26/ep-stream-jay-prince-wonder/" rel="bookmark" title="EP Stream: Jay Prince – WONDER">EP Stream: Jay Prince – WONDER</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/26/ep-stream-summer-walker-clear/" rel="bookmark" title="EP Stream: Summer Walker – Clear"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Summer-Walker-–-Clear-218x150.jpg" alt="" title="EP Stream: Summer Walker – Clear"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/26/ep-stream-summer-walker-clear/" rel="bookmark" title="EP Stream: Summer Walker – Clear">EP Stream: Summer Walker – Clear</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/26/mixtape-tdot-illdude-the-vibe-is-heavy-3/" rel="bookmark" title="Mixtape: Tdot Illdude – The Vibe Is Heavy 3"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Tdot-Illdude-–-The-Vibe-Is-Heavy-3-218x150.jpg" alt="" title="Mixtape: Tdot Illdude – The Vibe Is Heavy 3"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/26/mixtape-tdot-illdude-the-vibe-is-heavy-3/" rel="bookmark" title="Mixtape: Tdot Illdude – The Vibe Is Heavy 3">Mixtape: Tdot Illdude – The Vibe Is Heavy 3</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/26/album-stream-og-boo-dirty-the-story-of-og/" rel="bookmark" title="Album Stream: OG Boo Dirty – The Story Of OG"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/OG-Boo-Dirty-–-The-Story-Of-OG-218x150.jpeg" alt="" title="Album Stream: OG Boo Dirty – The Story Of OG"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/26/album-stream-og-boo-dirty-the-story-of-og/" rel="bookmark" title="Album Stream: OG Boo Dirty – The Story Of OG">Album Stream: OG Boo Dirty – The Story Of OG</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/26/album-stream-boogie-everythings-for-sale/" rel="bookmark" title="Album Stream: Boogie – Everything’s For Sale"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Boogie-–-Everythings-For-Sale-218x150.jpg" alt="" title="Album Stream: Boogie – Everything’s For Sale"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/26/album-stream-boogie-everythings-for-sale/" rel="bookmark" title="Album Stream: Boogie – Everything’s For Sale">Album Stream: Boogie – Everything’s For Sale</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_5c4c777fddcc8" data-td_block_id="td_uid_2_5c4c777fddcc8"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_2_5c4c777fddcc8" data-td_block_id="td_uid_2_5c4c777fddcc8"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_3_5c4c777fe32c5_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_3_5c4c777fe32c5" ><script>var block_td_uid_3_5c4c777fe32c5 = new tdBlock();
block_td_uid_3_5c4c777fe32c5.id = "td_uid_3_5c4c777fe32c5";
block_td_uid_3_5c4c777fe32c5.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_3_5c4c777fe32c5_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_3_5c4c777fe32c5.td_column_number = "3";
block_td_uid_3_5c4c777fe32c5.block_type = "td_block_mega_menu";
block_td_uid_3_5c4c777fe32c5.post_count = "5";
block_td_uid_3_5c4c777fe32c5.found_posts = "1104";
block_td_uid_3_5c4c777fe32c5.header_color = "";
block_td_uid_3_5c4c777fe32c5.ajax_pagination_infinite_stop = "";
block_td_uid_3_5c4c777fe32c5.max_num_pages = "221";
tdBlocksArray.push(block_td_uid_3_5c4c777fe32c5);
</script><div id=td_uid_3_5c4c777fe32c5 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/26/music-video-blueface-ft-yg-thotiana-remix/" rel="bookmark" title="Music Video: Blueface ft. YG – Thotiana (Remix)"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Blueface-ft.-YG-–-Thotiana-Remix-218x150.jpg" alt="" title="Music Video: Blueface ft. YG – Thotiana (Remix)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/26/music-video-blueface-ft-yg-thotiana-remix/" rel="bookmark" title="Music Video: Blueface ft. YG – Thotiana (Remix)">Music Video: Blueface ft. YG – Thotiana (Remix)</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/26/music-video-trippie-redd-rich-the-kid-icky-vicky/" rel="bookmark" title="Music Video: Trippie Redd &#038; Rich The Kid – Icky Vicky"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Trippie-Redd-Rich-The-Kid-–-Icky-Vicky-218x150.jpg" alt="" title="Music Video: Trippie Redd &#038; Rich The Kid – Icky Vicky"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/26/music-video-trippie-redd-rich-the-kid-icky-vicky/" rel="bookmark" title="Music Video: Trippie Redd &#038; Rich The Kid – Icky Vicky">Music Video: Trippie Redd &#038; Rich The Kid – Icky Vicky</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/26/music-video-daddy-yankee-snow-con-calma/" rel="bookmark" title="Music Video: Daddy Yankee &#038; Snow – Con Calma"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Daddy-Yankee-Snow-–-Con-Calma-218x150.jpg" alt="" title="Music Video: Daddy Yankee &#038; Snow – Con Calma"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/26/music-video-daddy-yankee-snow-con-calma/" rel="bookmark" title="Music Video: Daddy Yankee &#038; Snow – Con Calma">Music Video: Daddy Yankee &#038; Snow – Con Calma</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/26/new-music-peter-jackson-none-of-you/" rel="bookmark" title="Music Video: Peter Jackson – None Of You"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Peter-Jackson-None-Of-You-218x150.jpeg" alt="" title="Music Video: Peter Jackson – None Of You"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/26/new-music-peter-jackson-none-of-you/" rel="bookmark" title="Music Video: Peter Jackson – None Of You">Music Video: Peter Jackson – None Of You</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/25/music-video-young-buck-unrap/" rel="bookmark" title="Music Video: Young Buck &#8211; UnRap"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Young-Buck-UnRap-218x150.jpg" alt="" title="Music Video: Young Buck &#8211; UnRap"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/25/music-video-young-buck-unrap/" rel="bookmark" title="Music Video: Young Buck &#8211; UnRap">Music Video: Young Buck &#8211; UnRap</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_5c4c777fe32c5" data-td_block_id="td_uid_3_5c4c777fe32c5"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_3_5c4c777fe32c5" data-td_block_id="td_uid_3_5c4c777fe32c5"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_4_5c4c777fe9522_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_4_5c4c777fe9522" ><script>var block_td_uid_4_5c4c777fe9522 = new tdBlock();
block_td_uid_4_5c4c777fe9522.id = "td_uid_4_5c4c777fe9522";
block_td_uid_4_5c4c777fe9522.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"29","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_4_5c4c777fe9522_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_4_5c4c777fe9522.td_column_number = "3";
block_td_uid_4_5c4c777fe9522.block_type = "td_block_mega_menu";
block_td_uid_4_5c4c777fe9522.post_count = "4";
block_td_uid_4_5c4c777fe9522.found_posts = "439";
block_td_uid_4_5c4c777fe9522.header_color = "";
block_td_uid_4_5c4c777fe9522.ajax_pagination_infinite_stop = "";
block_td_uid_4_5c4c777fe9522.max_num_pages = "110";
tdBlocksArray.push(block_td_uid_4_5c4c777fe9522);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_4_5c4c777fe9522" id="td_uid_5_5c4c777feabef" data-td_block_id="td_uid_4_5c4c777fe9522" data-td_filter_value="" href="http://weuponithiphop.info/category/latest-news/">All</a><a class="mega-menu-sub-cat-td_uid_4_5c4c777fe9522"  id="td_uid_6_5c4c777feacfa" data-td_block_id="td_uid_4_5c4c777fe9522" data-td_filter_value="69" href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a><a class="mega-menu-sub-cat-td_uid_4_5c4c777fe9522"  id="td_uid_7_5c4c777feae1d" data-td_block_id="td_uid_4_5c4c777fe9522" data-td_filter_value="80" href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a><a class="mega-menu-sub-cat-td_uid_4_5c4c777fe9522"  id="td_uid_8_5c4c777feaf38" data-td_block_id="td_uid_4_5c4c777fe9522" data-td_filter_value="2189" href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a><a class="mega-menu-sub-cat-td_uid_4_5c4c777fe9522"  id="td_uid_9_5c4c777feb056" data-td_block_id="td_uid_4_5c4c777fe9522" data-td_filter_value="10" href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a><a class="mega-menu-sub-cat-td_uid_4_5c4c777fe9522"  id="td_uid_10_5c4c777feb16d" data-td_block_id="td_uid_4_5c4c777fe9522" data-td_filter_value="130" href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></div></div><div id=td_uid_4_5c4c777fe9522 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/24/video-the-dream-sway-in-the-morning-interview/" rel="bookmark" title="Video: The-Dream &#8211; Sway In The Morning Interview"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/The-Dream-Sway-In-The-Morning-Interview-218x150.jpg" alt="" title="Video: The-Dream &#8211; Sway In The Morning Interview"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/24/video-the-dream-sway-in-the-morning-interview/" rel="bookmark" title="Video: The-Dream &#8211; Sway In The Morning Interview">Video: The-Dream &#8211; Sway In The Morning Interview</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/24/video-soulja-boy-big-boy-tv-interview/" rel="bookmark" title="Video: Soulja Boy &#8211; Big Boy TV Interview"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Soulja-Boy-Big-Boy-TV-Interview-218x150.jpg" alt="" title="Video: Soulja Boy &#8211; Big Boy TV Interview"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/24/video-soulja-boy-big-boy-tv-interview/" rel="bookmark" title="Video: Soulja Boy &#8211; Big Boy TV Interview">Video: Soulja Boy &#8211; Big Boy TV Interview</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/24/cardi-b-signs-las-vegas-residency-deal/" rel="bookmark" title="Cardi B Signs Las Vegas Residency Deal"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Cardi-B-Signs-Las-Vegas-Residency-Deal-218x150.jpg" alt="" title="Cardi B Signs Las Vegas Residency Deal"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/24/cardi-b-signs-las-vegas-residency-deal/" rel="bookmark" title="Cardi B Signs Las Vegas Residency Deal">Cardi B Signs Las Vegas Residency Deal</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/24/murs-announces-over-the-odyssey-tour/" rel="bookmark" title="MURS Announces “Over The Odyssey” Tour"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/MURS-Announces-Over-The-Odyssey-Tour-218x150.jpg" alt="" title="MURS Announces “Over The Odyssey” Tour"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/24/murs-announces-over-the-odyssey-tour/" rel="bookmark" title="MURS Announces “Over The Odyssey” Tour">MURS Announces “Over The Odyssey” Tour</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_4_5c4c777fe9522" data-td_block_id="td_uid_4_5c4c777fe9522"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_4_5c4c777fe9522" data-td_block_id="td_uid_4_5c4c777fe9522"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_11_5c4c778016d55_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_11_5c4c778016d55" ><script>var block_td_uid_11_5c4c778016d55 = new tdBlock();
block_td_uid_11_5c4c778016d55.id = "td_uid_11_5c4c778016d55";
block_td_uid_11_5c4c778016d55.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"77","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_11_5c4c778016d55_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_11_5c4c778016d55.td_column_number = "3";
block_td_uid_11_5c4c778016d55.block_type = "td_block_mega_menu";
block_td_uid_11_5c4c778016d55.post_count = "4";
block_td_uid_11_5c4c778016d55.found_posts = "147";
block_td_uid_11_5c4c778016d55.header_color = "";
block_td_uid_11_5c4c778016d55.ajax_pagination_infinite_stop = "";
block_td_uid_11_5c4c778016d55.max_num_pages = "37";
tdBlocksArray.push(block_td_uid_11_5c4c778016d55);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_11_5c4c778016d55" id="td_uid_12_5c4c77801809d" data-td_block_id="td_uid_11_5c4c778016d55" data-td_filter_value="" href="http://weuponithiphop.info/category/fashion/">All</a><a class="mega-menu-sub-cat-td_uid_11_5c4c778016d55"  id="td_uid_13_5c4c7780181a1" data-td_block_id="td_uid_11_5c4c778016d55" data-td_filter_value="76" href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></div></div><div id=td_uid_11_5c4c778016d55 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/16/nike-zoom-2k-white-black/" rel="bookmark" title="Nike Zoom 2K White / Black"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/AO0269101-S-3-218x150.jpg" alt="" title="Nike Zoom 2K White / Black"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/16/nike-zoom-2k-white-black/" rel="bookmark" title="Nike Zoom 2K White / Black">Nike Zoom 2K White / Black</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/03/nike-air-max-plus-se-bordeaux-perfect-for-winter/" rel="bookmark" title="Nike Air Max Plus SE Bordeaux"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Nike-Air-Max-Plus-SE-4-218x150.jpg" alt="" title="Nike Air Max Plus SE Bordeaux"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/03/nike-air-max-plus-se-bordeaux-perfect-for-winter/" rel="bookmark" title="Nike Air Max Plus SE Bordeaux">Nike Air Max Plus SE Bordeaux</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/12/31/air-jordan-4-se-fiba/" rel="bookmark" title="Air Jordan 4 SE FIBA"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Air-Jordan-4-SE-FIBA-681x393-218x150.jpg" alt="" title="Air Jordan 4 SE FIBA"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/12/31/air-jordan-4-se-fiba/" rel="bookmark" title="Air Jordan 4 SE FIBA">Air Jordan 4 SE FIBA</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/12/31/adidas-yeezy-boost-700-v2-geode-dropping-spring-2019/" rel="bookmark" title="adidas Yeezy Boost 700 V2 Geode"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/adidas-Yeezy-Boost-700-V2-Geode-681x401-218x150.jpg" alt="" title="adidas Yeezy Boost 700 V2 Geode"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/12/31/adidas-yeezy-boost-700-v2-geode-dropping-spring-2019/" rel="bookmark" title="adidas Yeezy Boost 700 V2 Geode">adidas Yeezy Boost 700 V2 Geode</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_11_5c4c778016d55" data-td_block_id="td_uid_11_5c4c778016d55"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_11_5c4c778016d55" data-td_block_id="td_uid_11_5c4c778016d55"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-2515"><a href="http://weuponithiphop.info/category/editors-picks/">Editor&#8217;s Picks</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_14_5c4c778022847_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_14_5c4c778022847" ><script>var block_td_uid_14_5c4c778022847 = new tdBlock();
block_td_uid_14_5c4c778022847.id = "td_uid_14_5c4c778022847";
block_td_uid_14_5c4c778022847.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"118","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_14_5c4c778022847_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_14_5c4c778022847.td_column_number = "3";
block_td_uid_14_5c4c778022847.block_type = "td_block_mega_menu";
block_td_uid_14_5c4c778022847.post_count = "5";
block_td_uid_14_5c4c778022847.found_posts = "453";
block_td_uid_14_5c4c778022847.header_color = "";
block_td_uid_14_5c4c778022847.ajax_pagination_infinite_stop = "";
block_td_uid_14_5c4c778022847.max_num_pages = "91";
tdBlocksArray.push(block_td_uid_14_5c4c778022847);
</script><div id=td_uid_14_5c4c778022847 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/25/music-video-young-buck-unrap/" rel="bookmark" title="Music Video: Young Buck &#8211; UnRap"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Young-Buck-UnRap-218x150.jpg" alt="" title="Music Video: Young Buck &#8211; UnRap"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/25/music-video-young-buck-unrap/" rel="bookmark" title="Music Video: Young Buck &#8211; UnRap">Music Video: Young Buck &#8211; UnRap</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/24/music-video-stunna4vegas-hitn4/" rel="bookmark" title="Music Video: Stunna4Vegas &#8211; Hitn4"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Stunna4Vegas-Hitn4-218x150.jpg" alt="" title="Music Video: Stunna4Vegas &#8211; Hitn4"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/24/music-video-stunna4vegas-hitn4/" rel="bookmark" title="Music Video: Stunna4Vegas &#8211; Hitn4">Music Video: Stunna4Vegas &#8211; Hitn4</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/24/murs-announces-over-the-odyssey-tour/" rel="bookmark" title="MURS Announces “Over The Odyssey” Tour"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/MURS-Announces-Over-The-Odyssey-Tour-218x150.jpg" alt="" title="MURS Announces “Over The Odyssey” Tour"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/24/murs-announces-over-the-odyssey-tour/" rel="bookmark" title="MURS Announces “Over The Odyssey” Tour">MURS Announces “Over The Odyssey” Tour</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/24/video-boogie-everythings-for-sale-short-film/" rel="bookmark" title="Video: Boogie – Everything’s For Sale (Short Film)"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Boogie-–-Everythings-For-Sale-Short-Film-218x150.jpg" alt="" title="Video: Boogie – Everything’s For Sale (Short Film)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/24/video-boogie-everythings-for-sale-short-film/" rel="bookmark" title="Video: Boogie – Everything’s For Sale (Short Film)">Video: Boogie – Everything’s For Sale (Short Film)</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/23/music-video-la-socket-x-asian-doll-hiya/" rel="bookmark" title="Music Video: La Socket x Asian Doll &#8211; HIYA"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/La-Socket-x-Asian-Doll-HIYA-218x150.jpg" alt="" title="Music Video: La Socket x Asian Doll &#8211; HIYA"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/23/music-video-la-socket-x-asian-doll-hiya/" rel="bookmark" title="Music Video: La Socket x Asian Doll &#8211; HIYA">Music Video: La Socket x Asian Doll &#8211; HIYA</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_14_5c4c778022847" data-td_block_id="td_uid_14_5c4c778022847"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_14_5c4c778022847" data-td_block_id="td_uid_14_5c4c778022847"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees/">Shop</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
</ul></div></div>


<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form method="get" class="td-search-form" action="http://weuponithiphop.info/">
				<div role="search" class="td-head-form-search-wrap">
					<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>            </div>
        </div>
    </div>

    <div class="td-banner-wrap-full">
        <div class="td-header-container td-header-row td-header-header">
            <div class="td-header-sp-recs">
                <div class="td-header-rec-wrap">
    
</div>            </div>
        </div>
    </div>

</div><article id="post-22615" class="td-post-template-3 post-22615 post type-post status-publish format-standard has-post-thumbnail hentry category-music-video tag-blueface tag-thotiana-remix tag-yg" itemscope itemtype="http://schema.org/Article">
    <div class="td-post-header td-container">
        <div class="td-crumb-container"><div class="entry-crumbs"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="" class="entry-crumb" itemprop="url" href="http://weuponithiphop.info/"><span itemprop="title">Home</span></a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="View all posts in Music Video" class="entry-crumb" itemprop="url" href="http://weuponithiphop.info/category/music-video/"><span itemprop="title">Music Video</span></a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last" itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><meta itemprop="title" content = "Music Video: Blueface ft. YG – Thotiana (Remix)"><meta itemprop="url" content = "http://weuponithiphop.info/2019/01/26/music-video-blueface-ft-yg-thotiana-remix/">Music Video: Blueface ft. YG – Thotiana (Remix)</span></div></div>
        <div class="td-post-header-holder td-image-gradient">
            <div class="td-post-featured-image"><a href="http://weuponithiphop.info/wp-content/uploads/Blueface-ft.-YG-–-Thotiana-Remix.jpg" data-caption=""><img width="977" height="459" class="entry-thumb td-modal-image" src="http://weuponithiphop.info/wp-content/uploads/Blueface-ft.-YG-–-Thotiana-Remix.jpg" alt="" title="Blueface ft. YG – Thotiana (Remix)"/></a></div>
            <header class="td-post-title">
                <ul class="td-category"><li class="entry-category"><a  href="http://weuponithiphop.info/category/music-video/">Music Video</a></li></ul>                <h1 class="entry-title">Music Video: Blueface ft. YG – Thotiana (Remix)</h1>

                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name">By <a href="http://weuponithiphop.info/author/cyclone/">cyclone</a> - </div>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-01-26T08:25:46+00:00" >January 26, 2019</time></span>                                        <div class="td-post-comments"><a href="http://weuponithiphop.info/2019/01/26/music-video-blueface-ft-yg-thotiana-remix/#respond"><i class="td-icon-comments"></i>0</a></div>                </div>

            </header>
        </div>
    </div>

    <div class="td-container">
        <div class="td-pb-row">
                                <div class="td-pb-span8 td-main-content" role="main">
                        <div class="td-ss-main-content">
                            
    
    <div class="td-post-content">
        <p><img class="aligncenter size-full wp-image-22616" src="http://weuponithiphop.info/wp-content/uploads/Blueface-ft.-YG-–-Thotiana-Remix.jpg" alt="" width="977" height="459" srcset="http://weuponithiphop.info/wp-content/uploads/Blueface-ft.-YG-–-Thotiana-Remix.jpg 977w, http://weuponithiphop.info/wp-content/uploads/Blueface-ft.-YG-–-Thotiana-Remix-500x235.jpg 500w, http://weuponithiphop.info/wp-content/uploads/Blueface-ft.-YG-–-Thotiana-Remix-768x361.jpg 768w, http://weuponithiphop.info/wp-content/uploads/Blueface-ft.-YG-–-Thotiana-Remix-696x327.jpg 696w, http://weuponithiphop.info/wp-content/uploads/Blueface-ft.-YG-–-Thotiana-Remix-894x420.jpg 894w" sizes="(max-width: 977px) 100vw, 977px" /></p>
<p>Buzzing Cali spitta <strong>Blueface</strong> hit the <strong>Billboard <em>Hot 100</em></strong> this week with his popular <a href="http://weuponithiphop.info/tag/single/">single</a> <strong>“Thotiana”</strong>. He celebrates with the official <a href="http://weuponithiphop.info/tag/video/">video</a> for the <a href="http://weuponithiphop.info/tag/remix/">remix</a> featuring <strong>YG</strong>. Directed by <strong>Cole Bennett</strong>.</p>
<p><iframe src="https://www.youtube.com/embed/o5_FzJJj7ZI" width="620" height="350" frameborder="0" allowfullscreen="allowfullscreen" data-mce-fragment="1">&lt;span<br />
data-mce-type=&#8221;bookmark&#8221; style=&#8221;display: inline-block; width: 0px;<br />
overflow: hidden; line-height: 0;&#8221;<br />
class=&#8221;mce_SELRES_start&#8221;&gt;﻿&lt;/span&gt;</iframe></p>
<div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="http://weuponithiphop.info/2019/01/26/music-video-blueface-ft-yg-thotiana-remix/" data-a2a-title="Music Video: Blueface ft. YG – Thotiana (Remix)"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F01%2F26%2Fmusic-video-blueface-ft-yg-thotiana-remix%2F&amp;linkname=Music%20Video%3A%20Blueface%20ft.%20YG%20%E2%80%93%20Thotiana%20%28Remix%29" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F01%2F26%2Fmusic-video-blueface-ft-yg-thotiana-remix%2F&amp;linkname=Music%20Video%3A%20Blueface%20ft.%20YG%20%E2%80%93%20Thotiana%20%28Remix%29" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_google_plus" href="https://www.addtoany.com/add_to/google_plus?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F01%2F26%2Fmusic-video-blueface-ft-yg-thotiana-remix%2F&amp;linkname=Music%20Video%3A%20Blueface%20ft.%20YG%20%E2%80%93%20Thotiana%20%28Remix%29" title="Google+" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F01%2F26%2Fmusic-video-blueface-ft-yg-thotiana-remix%2F&amp;linkname=Music%20Video%3A%20Blueface%20ft.%20YG%20%E2%80%93%20Thotiana%20%28Remix%29" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F01%2F26%2Fmusic-video-blueface-ft-yg-thotiana-remix%2F&amp;linkname=Music%20Video%3A%20Blueface%20ft.%20YG%20%E2%80%93%20Thotiana%20%28Remix%29" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_tumblr" href="https://www.addtoany.com/add_to/tumblr?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F01%2F26%2Fmusic-video-blueface-ft-yg-thotiana-remix%2F&amp;linkname=Music%20Video%3A%20Blueface%20ft.%20YG%20%E2%80%93%20Thotiana%20%28Remix%29" title="Tumblr" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_reddit" href="https://www.addtoany.com/add_to/reddit?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F01%2F26%2Fmusic-video-blueface-ft-yg-thotiana-remix%2F&amp;linkname=Music%20Video%3A%20Blueface%20ft.%20YG%20%E2%80%93%20Thotiana%20%28Remix%29" title="Reddit" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_flipboard" href="https://www.addtoany.com/add_to/flipboard?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F01%2F26%2Fmusic-video-blueface-ft-yg-thotiana-remix%2F&amp;linkname=Music%20Video%3A%20Blueface%20ft.%20YG%20%E2%80%93%20Thotiana%20%28Remix%29" title="Flipboard" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F01%2F26%2Fmusic-video-blueface-ft-yg-thotiana-remix%2F&amp;linkname=Music%20Video%3A%20Blueface%20ft.%20YG%20%E2%80%93%20Thotiana%20%28Remix%29" title="Copy Link" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div>    </div>


    <footer>
                
        <div class="td-post-source-tags">
                        <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="http://weuponithiphop.info/tag/blueface/">Blueface</a></li><li><a href="http://weuponithiphop.info/tag/thotiana-remix/">Thotiana (Remix)</a></li><li><a href="http://weuponithiphop.info/tag/yg/">YG</a></li></ul>        </div>

                <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="http://weuponithiphop.info/2019/01/26/music-video-trippie-redd-rich-the-kid-icky-vicky/">Music Video: Trippie Redd &#038; Rich The Kid – Icky Vicky</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="http://weuponithiphop.info/2019/01/26/audio-joe-budden-the-joe-budden-podcast-w-rory-mal-parks-episode-216-clickbait/">Audio: Joe Budden &#8211; The Joe Budden Podcast W/ Rory, Mal &#038; Parks (Episode 216) “Clickbait”</a></div></div></div>        <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="http://weuponithiphop.info/author/cyclone/">cyclone</a></span></div>        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="cyclone"></span><meta itemprop="datePublished" content="2019-01-26T08:25:46+00:00"><meta itemprop="dateModified" content="2019-01-26T08:25:46+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://weuponithiphop.info/2019/01/26/music-video-blueface-ft-yg-thotiana-remix/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png"></span><meta itemprop="name" content="WeUpOnIt"></span><meta itemprop="headline " content="Music Video: Blueface ft. YG – Thotiana (Remix)"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://weuponithiphop.info/wp-content/uploads/Blueface-ft.-YG-–-Thotiana-Remix.jpg"><meta itemprop="width" content="977"><meta itemprop="height" content="459"></span>    </footer>

    <div class="td_block_wrap td_block_related_posts td_uid_16_5c4c778116e30_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_16_5c4c778116e30" ><script>var block_td_uid_16_5c4c778116e30 = new tdBlock();
block_td_uid_16_5c4c778116e30.id = "td_uid_16_5c4c778116e30";
block_td_uid_16_5c4c778116e30.atts = '{"limit":6,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_custom_related","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_16_5c4c778116e30_rand","offset":"","css":"","live_filter":"cur_post_same_tags","live_filter_cur_post_id":22615,"live_filter_cur_post_author":"1"}';
block_td_uid_16_5c4c778116e30.td_column_number = "3";
block_td_uid_16_5c4c778116e30.block_type = "td_block_related_posts";
block_td_uid_16_5c4c778116e30.post_count = "6";
block_td_uid_16_5c4c778116e30.found_posts = "21";
block_td_uid_16_5c4c778116e30.header_color = "";
block_td_uid_16_5c4c778116e30.ajax_pagination_infinite_stop = "";
block_td_uid_16_5c4c778116e30.max_num_pages = "4";
tdBlocksArray.push(block_td_uid_16_5c4c778116e30);
</script><h4 class="td-related-title"><a id="td_uid_17_5c4c778119527" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_16_5c4c778116e30" href="#">RELATED ARTICLES</a><a id="td_uid_18_5c4c778119568" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_16_5c4c778116e30" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_16_5c4c778116e30 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/12/new-music-jacquees-ft-blueface-you-remix-74784/" rel="bookmark" title="New Music: Jacquees ft. Blueface – You (Remix)"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Jacquees-ft.-Blueface-–-You-Remix-218x150.jpg" alt="" title="New Music: Jacquees ft. Blueface – You (Remix)"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/12/new-music-jacquees-ft-blueface-you-remix-74784/" rel="bookmark" title="New Music: Jacquees ft. Blueface – You (Remix)">New Music: Jacquees ft. Blueface – You (Remix)</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/05/music-video-james-too-cold-ft-blueface-no-witness/" rel="bookmark" title="Music Video: James Too Cold ft. Blueface – No Witness"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/James-Too-Cold-ft.-Blueface-–-No-Witness-218x150.jpg" alt="" title="Music Video: James Too Cold ft. Blueface – No Witness"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/05/music-video-james-too-cold-ft-blueface-no-witness/" rel="bookmark" title="Music Video: James Too Cold ft. Blueface – No Witness">Music Video: James Too Cold ft. Blueface – No Witness</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/12/20/music-video-yg-ft-quavo-slay/" rel="bookmark" title="Music Video: YG ft. Quavo &#8211; Slay"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/YG-ft.-Quavo-Slay-218x150.jpg" alt="" title="Music Video: YG ft. Quavo &#8211; Slay"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/12/20/music-video-yg-ft-quavo-slay/" rel="bookmark" title="Music Video: YG ft. Quavo &#8211; Slay">Music Video: YG ft. Quavo &#8211; Slay</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid-->

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/12/20/music-video-blueface-bleed-it/" rel="bookmark" title="Music Video: Blueface &#8211; Bleed It"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Blueface-Bleed-It-218x150.jpg" alt="" title="Music Video: Blueface &#8211; Bleed It"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/12/20/music-video-blueface-bleed-it/" rel="bookmark" title="Music Video: Blueface &#8211; Bleed It">Music Video: Blueface &#8211; Bleed It</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/12/15/music-video-blueface-studio/" rel="bookmark" title="Music Video: Blueface &#8211; Studio"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Blueface-Studio-218x150.jpg" alt="" title="Music Video: Blueface &#8211; Studio"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/12/15/music-video-blueface-studio/" rel="bookmark" title="Music Video: Blueface &#8211; Studio">Music Video: Blueface &#8211; Studio</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/12/11/music-video-sneakk-ft-tyga-yg-spray/" rel="bookmark" title="Music Video: Sneakk ft. Tyga &#038; YG &#8211; Spray"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Sneakk-ft.-Tyga-YG-Spray-218x150.jpg" alt="" title="Music Video: Sneakk ft. Tyga &#038; YG &#8211; Spray"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/12/11/music-video-sneakk-ft-tyga-yg-spray/" rel="bookmark" title="Music Video: Sneakk ft. Tyga &#038; YG &#8211; Spray">Music Video: Sneakk ft. Tyga &#038; YG &#8211; Spray</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_16_5c4c778116e30" data-td_block_id="td_uid_16_5c4c778116e30"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_16_5c4c778116e30" data-td_block_id="td_uid_16_5c4c778116e30"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->

	<div class="comments" id="comments">
            </div> <!-- /.content -->
                        </div>
                    </div>
                    <div class="td-pb-span4 td-main-sidebar" role="complementary">
                        <div class="td-ss-main-sidebar">
                            <aside class="widget widget_search"><form method="get" class="td-search-form-widget" action="http://weuponithiphop.info/">
    <div role="search">
        <input class="td-widget-search-input" type="text" value="" name="s" id="s" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit" value="Search" />
    </div>
</form></aside><aside class="widget widget_text">			<div class="textwidget"><h4><strong><span style="color: #8224e3;"><span style="color: #000000;">Listen to</span> <span style="color: #c60000;">WeUpOnItRadio</span> <span style="color: #000000;">Live!</span></span></strong></h4>
<p><span class="cc_streaminfo" data-type="song" data-username="cyclone777">Loading &#8230;</span><br />
<script language="javascript" type="text/javascript" src="https://control.internet-radio.com:2199/system/streaminfo.js"></script><br />
<iframe src="https://tunein.com/embed/player/s292400/" style="width:100%; height:100px;" scrolling="no" frameborder="no"></iframe></p>
</div>
		</aside><aside class="widget widget_text"><div class="block-title"><span>AUDIOTRAFFICKER</span></div>			<div class="textwidget"><p><iframe src="https://www.facebook.com/plugins/video.php?href=https%3A%2F%2Fwww.facebook.com%2FAudioTrafficker%2Fvideos%2F515302985543077%2F&#038;show_text=0&#038;width=560" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true" allowFullScreen="true"></iframe></p>
</div>
		</aside><aside class="widget widget_text"><div class="block-title"><span>GMEBE Allo &#8220;From The Heart&#8221;</span></div>			<div class="textwidget"><p><iframe src="https://www.youtube.com/embed/WOaDVP0R_og" frameborder="0" allowfullscreen=""></iframe></p>
</div>
		</aside>
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-sidebar ">
<script type="text/javascript">
var td_screen_width = document.body.clientWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 

                        </div>
                    </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</article> <!-- /.post -->


<!-- Instagram -->



<!-- Footer -->
<div class="td-footer-wrapper td-footer-template-3">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
			    		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span4">
                <div class="td-footer-info"><div class="footer-logo-wrap"><a href="http://weuponithiphop.info/"><img class="td-retina-data" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" alt="" title=""/></a></div><div class="footer-text-wrap"></div><div class="footer-social-wrap td-social-style-2">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div></div>            </div>

            <div class="td-pb-span4">
                <div class="td_block_wrap td_block_8 td_block_widget td_uid_21_5c4c778122e3b_rand td-pb-border-top"  data-td-block-uid="td_uid_21_5c4c778122e3b" ><script>var block_td_uid_21_5c4c778122e3b = new tdBlock();
block_td_uid_21_5c4c778122e3b.id = "td_uid_21_5c4c778122e3b";
block_td_uid_21_5c4c778122e3b.atts = '{"limit":"7","sort":"jetpack_popular_2","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"POPULAR POSTS","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"#","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_21_5c4c778122e3b_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_21_5c4c778122e3b.td_column_number = "1";
block_td_uid_21_5c4c778122e3b.block_type = "td_block_8";
block_td_uid_21_5c4c778122e3b.post_count = "7";
block_td_uid_21_5c4c778122e3b.found_posts = "10";
block_td_uid_21_5c4c778122e3b.header_color = "#";
block_td_uid_21_5c4c778122e3b.ajax_pagination_infinite_stop = "";
block_td_uid_21_5c4c778122e3b.max_num_pages = "2";
tdBlocksArray.push(block_td_uid_21_5c4c778122e3b);
</script><h4 class="block-title"><span>POPULAR POSTS</span></h4><div id=td_uid_21_5c4c778122e3b class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_7 td_module_wrap td-animation-stack">
        <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/26/audio-joe-budden-the-joe-budden-podcast-w-rory-mal-parks-episode-216-clickbait/" rel="bookmark" title="Audio: Joe Budden &#8211; The Joe Budden Podcast W/ Rory, Mal &#038; Parks (Episode 216) “Clickbait”"><img width="100" height="70" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Joe-Budden-The-Joe-Budden-Podcast-W-Rory-Mal-Parks-Episode-216-Clickbait-100x70.jpg" alt="" title="Audio: Joe Budden &#8211; The Joe Budden Podcast W/ Rory, Mal &#038; Parks (Episode 216) “Clickbait”"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/26/audio-joe-budden-the-joe-budden-podcast-w-rory-mal-parks-episode-216-clickbait/" rel="bookmark" title="Audio: Joe Budden &#8211; The Joe Budden Podcast W/ Rory, Mal &#038; Parks (Episode 216) “Clickbait”">Audio: Joe Budden &#8211; The Joe Budden Podcast W/ Rory, Mal...</a></h3>
            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-01-26T08:33:48+00:00" >January 26, 2019</time></span>                            </div>

        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_7 td_module_wrap td-animation-stack">
        <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/25/music-video-young-buck-unrap/" rel="bookmark" title="Music Video: Young Buck &#8211; UnRap"><img width="100" height="70" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Young-Buck-UnRap-100x70.jpg" alt="" title="Music Video: Young Buck &#8211; UnRap"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/25/music-video-young-buck-unrap/" rel="bookmark" title="Music Video: Young Buck &#8211; UnRap">Music Video: Young Buck &#8211; UnRap</a></h3>
            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-01-25T09:51:35+00:00" >January 25, 2019</time></span>                            </div>

        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_7 td_module_wrap td-animation-stack">
        <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/25/new-music-thouxanbanfauni-uno-the-activist-choppa-down/" rel="bookmark" title="New Music: Thouxanbanfauni &#038; Uno The Activist – Choppa Down"><img width="100" height="70" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Thouxanbanfauni-Uno-The-Activist-–-Choppa-Down-100x70.jpeg" alt="" title="New Music: Thouxanbanfauni &#038; Uno The Activist – Choppa Down"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/25/new-music-thouxanbanfauni-uno-the-activist-choppa-down/" rel="bookmark" title="New Music: Thouxanbanfauni &#038; Uno The Activist – Choppa Down">New Music: Thouxanbanfauni &#038; Uno The Activist – Choppa Down</a></h3>
            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-01-25T07:40:35+00:00" >January 25, 2019</time></span>                            </div>

        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_7 td_module_wrap td-animation-stack">
        <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/25/music-video-foolie-ynw-melly-maserati/" rel="bookmark" title="Music Video: Foolie &#038; YNW Melly – Maserati"><img width="100" height="70" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Foolie-YNW-Melly-–-Maserati-100x70.jpg" alt="" title="Music Video: Foolie &#038; YNW Melly – Maserati"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/25/music-video-foolie-ynw-melly-maserati/" rel="bookmark" title="Music Video: Foolie &#038; YNW Melly – Maserati">Music Video: Foolie &#038; YNW Melly – Maserati</a></h3>
            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-01-25T07:01:47+00:00" >January 25, 2019</time></span>                            </div>

        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_7 td_module_wrap td-animation-stack">
        <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/24/music-video-yung-pinch-ft-lil-skies-nightmares/" rel="bookmark" title="Music Video: Yung Pinch ft. Lil Skies – Nightmares"><img width="100" height="70" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Yung-Pinch-ft.-Lil-Skies-–-Nightmares-100x70.jpg" alt="" title="Music Video: Yung Pinch ft. Lil Skies – Nightmares"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/24/music-video-yung-pinch-ft-lil-skies-nightmares/" rel="bookmark" title="Music Video: Yung Pinch ft. Lil Skies – Nightmares">Music Video: Yung Pinch ft. Lil Skies – Nightmares</a></h3>
            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-01-24T14:09:34+00:00" >January 24, 2019</time></span>                            </div>

        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_7 td_module_wrap td-animation-stack">
        <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/23/boogie-everythings-for-sale-album-artwork-tracklist/" rel="bookmark" title="Boogie &#8211; Everything’s For Sale (Album Artwork &#038; Tracklist)"><img width="100" height="70" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Boogie-Everythings-For-Sale-Album-Artwork-Tracklist-100x70.jpg" alt="" title="Boogie &#8211; Everything’s For Sale (Album Artwork &#038; Tracklist)"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/23/boogie-everythings-for-sale-album-artwork-tracklist/" rel="bookmark" title="Boogie &#8211; Everything’s For Sale (Album Artwork &#038; Tracklist)">Boogie &#8211; Everything’s For Sale (Album Artwork &#038; Tracklist)</a></h3>
            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-01-23T07:17:13+00:00" >January 23, 2019</time></span>                            </div>

        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_7 td_module_wrap td-animation-stack">
        <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/22/drake-tory-lanez-announce-assassination-vacation-tour/" rel="bookmark" title="Drake &#038; Tory Lanez Announce &#8216;Assassination Vacation&#8217; Tour"><img width="100" height="70" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Drake-Tory-Lanez-Announce-Assassination-Vacation-Tour-100x70.jpg" alt="" title="Drake &#038; Tory Lanez Announce &#8216;Assassination Vacation&#8217; Tour"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/22/drake-tory-lanez-announce-assassination-vacation-tour/" rel="bookmark" title="Drake &#038; Tory Lanez Announce &#8216;Assassination Vacation&#8217; Tour">Drake &#038; Tory Lanez Announce &#8216;Assassination Vacation&#8217; Tour</a></h3>
            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-01-22T16:34:03+00:00" >January 22, 2019</time></span>                            </div>

        </div>

        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block -->            </div>

            <div class="td-pb-span4">
                <aside class="widget widget_calendar"><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar">
	<caption>January 2019</caption>
	<thead>
	<tr>
		<th scope="col" title="Sunday">S</th>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
	</tr>
	</thead>

	<tfoot>
	<tr>
		<td colspan="3" id="prev"><a href="http://weuponithiphop.info/2018/12/">&laquo; Dec</a></td>
		<td class="pad">&nbsp;</td>
		<td colspan="3" id="next" class="pad">&nbsp;</td>
	</tr>
	</tfoot>

	<tbody>
	<tr>
		<td colspan="2" class="pad">&nbsp;</td><td><a href="http://weuponithiphop.info/2019/01/01/" aria-label="Posts published on January 1, 2019">1</a></td><td><a href="http://weuponithiphop.info/2019/01/02/" aria-label="Posts published on January 2, 2019">2</a></td><td><a href="http://weuponithiphop.info/2019/01/03/" aria-label="Posts published on January 3, 2019">3</a></td><td><a href="http://weuponithiphop.info/2019/01/04/" aria-label="Posts published on January 4, 2019">4</a></td><td><a href="http://weuponithiphop.info/2019/01/05/" aria-label="Posts published on January 5, 2019">5</a></td>
	</tr>
	<tr>
		<td><a href="http://weuponithiphop.info/2019/01/06/" aria-label="Posts published on January 6, 2019">6</a></td><td><a href="http://weuponithiphop.info/2019/01/07/" aria-label="Posts published on January 7, 2019">7</a></td><td><a href="http://weuponithiphop.info/2019/01/08/" aria-label="Posts published on January 8, 2019">8</a></td><td><a href="http://weuponithiphop.info/2019/01/09/" aria-label="Posts published on January 9, 2019">9</a></td><td><a href="http://weuponithiphop.info/2019/01/10/" aria-label="Posts published on January 10, 2019">10</a></td><td><a href="http://weuponithiphop.info/2019/01/11/" aria-label="Posts published on January 11, 2019">11</a></td><td><a href="http://weuponithiphop.info/2019/01/12/" aria-label="Posts published on January 12, 2019">12</a></td>
	</tr>
	<tr>
		<td>13</td><td><a href="http://weuponithiphop.info/2019/01/14/" aria-label="Posts published on January 14, 2019">14</a></td><td><a href="http://weuponithiphop.info/2019/01/15/" aria-label="Posts published on January 15, 2019">15</a></td><td><a href="http://weuponithiphop.info/2019/01/16/" aria-label="Posts published on January 16, 2019">16</a></td><td><a href="http://weuponithiphop.info/2019/01/17/" aria-label="Posts published on January 17, 2019">17</a></td><td><a href="http://weuponithiphop.info/2019/01/18/" aria-label="Posts published on January 18, 2019">18</a></td><td><a href="http://weuponithiphop.info/2019/01/19/" aria-label="Posts published on January 19, 2019">19</a></td>
	</tr>
	<tr>
		<td><a href="http://weuponithiphop.info/2019/01/20/" aria-label="Posts published on January 20, 2019">20</a></td><td><a href="http://weuponithiphop.info/2019/01/21/" aria-label="Posts published on January 21, 2019">21</a></td><td><a href="http://weuponithiphop.info/2019/01/22/" aria-label="Posts published on January 22, 2019">22</a></td><td><a href="http://weuponithiphop.info/2019/01/23/" aria-label="Posts published on January 23, 2019">23</a></td><td><a href="http://weuponithiphop.info/2019/01/24/" aria-label="Posts published on January 24, 2019">24</a></td><td><a href="http://weuponithiphop.info/2019/01/25/" aria-label="Posts published on January 25, 2019">25</a></td><td id="today"><a href="http://weuponithiphop.info/2019/01/26/" aria-label="Posts published on January 26, 2019">26</a></td>
	</tr>
	<tr>
		<td>27</td><td>28</td><td>29</td><td>30</td><td>31</td>
		<td class="pad" colspan="2">&nbsp;</td>
	</tr>
	</tbody>
	</table></div></aside>            </div>
        </div>
    </div>
</div>

<!-- Sub Footer -->
    <div class="td-sub-footer-container">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span7 td-sub-footer-menu">
                        <div class="menu-top-menu-container"><ul id="menu-top-menu-2" class="td-subfooter-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-mega-menu menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_22_5c4c77812e380_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_22_5c4c77812e380" ><script>var block_td_uid_22_5c4c77812e380 = new tdBlock();
block_td_uid_22_5c4c77812e380.id = "td_uid_22_5c4c77812e380";
block_td_uid_22_5c4c77812e380.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"43","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_22_5c4c77812e380_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_22_5c4c77812e380.td_column_number = "3";
block_td_uid_22_5c4c77812e380.block_type = "td_block_mega_menu";
block_td_uid_22_5c4c77812e380.post_count = "5";
block_td_uid_22_5c4c77812e380.found_posts = "1203";
block_td_uid_22_5c4c77812e380.header_color = "";
block_td_uid_22_5c4c77812e380.ajax_pagination_infinite_stop = "";
block_td_uid_22_5c4c77812e380.max_num_pages = "241";
tdBlocksArray.push(block_td_uid_22_5c4c77812e380);
</script><div id=td_uid_22_5c4c77812e380 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/26/new-music-yo-gotti-ft-lil-baby-put-a-date-on-it/" rel="bookmark" title="New Music: Yo Gotti ft. Lil Baby – Put A Date On It"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Yo-Gotti-ft.-Lil-Baby-–-Put-A-Date-On-It-218x150.jpg" alt="" title="New Music: Yo Gotti ft. Lil Baby – Put A Date On It"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/26/new-music-yo-gotti-ft-lil-baby-put-a-date-on-it/" rel="bookmark" title="New Music: Yo Gotti ft. Lil Baby – Put A Date On It">New Music: Yo Gotti ft. Lil Baby – Put A Date&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/26/new-music-gashi-ft-g-eazy-my-year/" rel="bookmark" title="New Music: GASHI ft. G-Eazy – My Year"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/GASHI-ft.-G-Eazy-–-My-Year-218x150.jpg" alt="" title="New Music: GASHI ft. G-Eazy – My Year"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/26/new-music-gashi-ft-g-eazy-my-year/" rel="bookmark" title="New Music: GASHI ft. G-Eazy – My Year">New Music: GASHI ft. G-Eazy – My Year</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/26/new-music-fredo-bang-ft-kevin-gates-oouuh-remix/" rel="bookmark" title="New Music: Fredo Bang ft. Kevin Gates – Oouuh (Remix)"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Fredo-Bang-ft.-Kevin-Gates-–-Oouuh-Remix-218x150.jpeg" alt="" title="New Music: Fredo Bang ft. Kevin Gates – Oouuh (Remix)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/26/new-music-fredo-bang-ft-kevin-gates-oouuh-remix/" rel="bookmark" title="New Music: Fredo Bang ft. Kevin Gates – Oouuh (Remix)">New Music: Fredo Bang ft. Kevin Gates – Oouuh (Remix)</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/26/new-music-night-lovell-bad-kid/" rel="bookmark" title="New Music: Night Lovell – BAD KID"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Night-Lovell-–-BAD-KID-218x150.jpeg" alt="" title="New Music: Night Lovell – BAD KID"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/26/new-music-night-lovell-bad-kid/" rel="bookmark" title="New Music: Night Lovell – BAD KID">New Music: Night Lovell – BAD KID</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/25/new-music-maxo-kream-meet-again/" rel="bookmark" title="New Music: Maxo Kream – Meet Again"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Maxo-Kream-–-Meet-Again-218x150.jpeg" alt="" title="New Music: Maxo Kream – Meet Again"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/25/new-music-maxo-kream-meet-again/" rel="bookmark" title="New Music: Maxo Kream – Meet Again">New Music: Maxo Kream – Meet Again</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_22_5c4c77812e380" data-td_block_id="td_uid_22_5c4c77812e380"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_22_5c4c77812e380" data-td_block_id="td_uid_22_5c4c77812e380"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_23_5c4c778132c40_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_23_5c4c778132c40" ><script>var block_td_uid_23_5c4c778132c40 = new tdBlock();
block_td_uid_23_5c4c778132c40.id = "td_uid_23_5c4c778132c40";
block_td_uid_23_5c4c778132c40.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"97","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_23_5c4c778132c40_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_23_5c4c778132c40.td_column_number = "3";
block_td_uid_23_5c4c778132c40.block_type = "td_block_mega_menu";
block_td_uid_23_5c4c778132c40.post_count = "5";
block_td_uid_23_5c4c778132c40.found_posts = "475";
block_td_uid_23_5c4c778132c40.header_color = "";
block_td_uid_23_5c4c778132c40.ajax_pagination_infinite_stop = "";
block_td_uid_23_5c4c778132c40.max_num_pages = "95";
tdBlocksArray.push(block_td_uid_23_5c4c778132c40);
</script><div id=td_uid_23_5c4c778132c40 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/26/ep-stream-jay-prince-wonder/" rel="bookmark" title="EP Stream: Jay Prince – WONDER"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Jay-Prince-–-WONDER-218x150.jpeg" alt="" title="EP Stream: Jay Prince – WONDER"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/26/ep-stream-jay-prince-wonder/" rel="bookmark" title="EP Stream: Jay Prince – WONDER">EP Stream: Jay Prince – WONDER</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/26/ep-stream-summer-walker-clear/" rel="bookmark" title="EP Stream: Summer Walker – Clear"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Summer-Walker-–-Clear-218x150.jpg" alt="" title="EP Stream: Summer Walker – Clear"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/26/ep-stream-summer-walker-clear/" rel="bookmark" title="EP Stream: Summer Walker – Clear">EP Stream: Summer Walker – Clear</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/26/mixtape-tdot-illdude-the-vibe-is-heavy-3/" rel="bookmark" title="Mixtape: Tdot Illdude – The Vibe Is Heavy 3"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Tdot-Illdude-–-The-Vibe-Is-Heavy-3-218x150.jpg" alt="" title="Mixtape: Tdot Illdude – The Vibe Is Heavy 3"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/26/mixtape-tdot-illdude-the-vibe-is-heavy-3/" rel="bookmark" title="Mixtape: Tdot Illdude – The Vibe Is Heavy 3">Mixtape: Tdot Illdude – The Vibe Is Heavy 3</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/26/album-stream-og-boo-dirty-the-story-of-og/" rel="bookmark" title="Album Stream: OG Boo Dirty – The Story Of OG"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/OG-Boo-Dirty-–-The-Story-Of-OG-218x150.jpeg" alt="" title="Album Stream: OG Boo Dirty – The Story Of OG"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/26/album-stream-og-boo-dirty-the-story-of-og/" rel="bookmark" title="Album Stream: OG Boo Dirty – The Story Of OG">Album Stream: OG Boo Dirty – The Story Of OG</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/26/album-stream-boogie-everythings-for-sale/" rel="bookmark" title="Album Stream: Boogie – Everything’s For Sale"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Boogie-–-Everythings-For-Sale-218x150.jpg" alt="" title="Album Stream: Boogie – Everything’s For Sale"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/26/album-stream-boogie-everythings-for-sale/" rel="bookmark" title="Album Stream: Boogie – Everything’s For Sale">Album Stream: Boogie – Everything’s For Sale</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_23_5c4c778132c40" data-td_block_id="td_uid_23_5c4c778132c40"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_23_5c4c778132c40" data-td_block_id="td_uid_23_5c4c778132c40"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_24_5c4c778137076_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_24_5c4c778137076" ><script>var block_td_uid_24_5c4c778137076 = new tdBlock();
block_td_uid_24_5c4c778137076.id = "td_uid_24_5c4c778137076";
block_td_uid_24_5c4c778137076.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_24_5c4c778137076_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_24_5c4c778137076.td_column_number = "3";
block_td_uid_24_5c4c778137076.block_type = "td_block_mega_menu";
block_td_uid_24_5c4c778137076.post_count = "5";
block_td_uid_24_5c4c778137076.found_posts = "1104";
block_td_uid_24_5c4c778137076.header_color = "";
block_td_uid_24_5c4c778137076.ajax_pagination_infinite_stop = "";
block_td_uid_24_5c4c778137076.max_num_pages = "221";
tdBlocksArray.push(block_td_uid_24_5c4c778137076);
</script><div id=td_uid_24_5c4c778137076 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/26/music-video-blueface-ft-yg-thotiana-remix/" rel="bookmark" title="Music Video: Blueface ft. YG – Thotiana (Remix)"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Blueface-ft.-YG-–-Thotiana-Remix-218x150.jpg" alt="" title="Music Video: Blueface ft. YG – Thotiana (Remix)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/26/music-video-blueface-ft-yg-thotiana-remix/" rel="bookmark" title="Music Video: Blueface ft. YG – Thotiana (Remix)">Music Video: Blueface ft. YG – Thotiana (Remix)</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/26/music-video-trippie-redd-rich-the-kid-icky-vicky/" rel="bookmark" title="Music Video: Trippie Redd &#038; Rich The Kid – Icky Vicky"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Trippie-Redd-Rich-The-Kid-–-Icky-Vicky-218x150.jpg" alt="" title="Music Video: Trippie Redd &#038; Rich The Kid – Icky Vicky"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/26/music-video-trippie-redd-rich-the-kid-icky-vicky/" rel="bookmark" title="Music Video: Trippie Redd &#038; Rich The Kid – Icky Vicky">Music Video: Trippie Redd &#038; Rich The Kid – Icky Vicky</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/26/music-video-daddy-yankee-snow-con-calma/" rel="bookmark" title="Music Video: Daddy Yankee &#038; Snow – Con Calma"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Daddy-Yankee-Snow-–-Con-Calma-218x150.jpg" alt="" title="Music Video: Daddy Yankee &#038; Snow – Con Calma"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/26/music-video-daddy-yankee-snow-con-calma/" rel="bookmark" title="Music Video: Daddy Yankee &#038; Snow – Con Calma">Music Video: Daddy Yankee &#038; Snow – Con Calma</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/26/new-music-peter-jackson-none-of-you/" rel="bookmark" title="Music Video: Peter Jackson – None Of You"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Peter-Jackson-None-Of-You-218x150.jpeg" alt="" title="Music Video: Peter Jackson – None Of You"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/26/new-music-peter-jackson-none-of-you/" rel="bookmark" title="Music Video: Peter Jackson – None Of You">Music Video: Peter Jackson – None Of You</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/25/music-video-young-buck-unrap/" rel="bookmark" title="Music Video: Young Buck &#8211; UnRap"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Young-Buck-UnRap-218x150.jpg" alt="" title="Music Video: Young Buck &#8211; UnRap"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/25/music-video-young-buck-unrap/" rel="bookmark" title="Music Video: Young Buck &#8211; UnRap">Music Video: Young Buck &#8211; UnRap</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_24_5c4c778137076" data-td_block_id="td_uid_24_5c4c778137076"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_24_5c4c778137076" data-td_block_id="td_uid_24_5c4c778137076"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_25_5c4c77813b4f5_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_25_5c4c77813b4f5" ><script>var block_td_uid_25_5c4c77813b4f5 = new tdBlock();
block_td_uid_25_5c4c77813b4f5.id = "td_uid_25_5c4c77813b4f5";
block_td_uid_25_5c4c77813b4f5.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"29","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_25_5c4c77813b4f5_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_25_5c4c77813b4f5.td_column_number = "3";
block_td_uid_25_5c4c77813b4f5.block_type = "td_block_mega_menu";
block_td_uid_25_5c4c77813b4f5.post_count = "4";
block_td_uid_25_5c4c77813b4f5.found_posts = "439";
block_td_uid_25_5c4c77813b4f5.header_color = "";
block_td_uid_25_5c4c77813b4f5.ajax_pagination_infinite_stop = "";
block_td_uid_25_5c4c77813b4f5.max_num_pages = "110";
tdBlocksArray.push(block_td_uid_25_5c4c77813b4f5);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_25_5c4c77813b4f5" id="td_uid_26_5c4c77813c6a2" data-td_block_id="td_uid_25_5c4c77813b4f5" data-td_filter_value="" href="http://weuponithiphop.info/category/latest-news/">All</a><a class="mega-menu-sub-cat-td_uid_25_5c4c77813b4f5"  id="td_uid_27_5c4c77813c83a" data-td_block_id="td_uid_25_5c4c77813b4f5" data-td_filter_value="69" href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a><a class="mega-menu-sub-cat-td_uid_25_5c4c77813b4f5"  id="td_uid_28_5c4c77813ca15" data-td_block_id="td_uid_25_5c4c77813b4f5" data-td_filter_value="80" href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a><a class="mega-menu-sub-cat-td_uid_25_5c4c77813b4f5"  id="td_uid_29_5c4c77813cbae" data-td_block_id="td_uid_25_5c4c77813b4f5" data-td_filter_value="2189" href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a><a class="mega-menu-sub-cat-td_uid_25_5c4c77813b4f5"  id="td_uid_30_5c4c77813cccd" data-td_block_id="td_uid_25_5c4c77813b4f5" data-td_filter_value="10" href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a><a class="mega-menu-sub-cat-td_uid_25_5c4c77813b4f5"  id="td_uid_31_5c4c77813cde7" data-td_block_id="td_uid_25_5c4c77813b4f5" data-td_filter_value="130" href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></div></div><div id=td_uid_25_5c4c77813b4f5 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/24/video-the-dream-sway-in-the-morning-interview/" rel="bookmark" title="Video: The-Dream &#8211; Sway In The Morning Interview"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/The-Dream-Sway-In-The-Morning-Interview-218x150.jpg" alt="" title="Video: The-Dream &#8211; Sway In The Morning Interview"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/24/video-the-dream-sway-in-the-morning-interview/" rel="bookmark" title="Video: The-Dream &#8211; Sway In The Morning Interview">Video: The-Dream &#8211; Sway In The Morning Interview</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/24/video-soulja-boy-big-boy-tv-interview/" rel="bookmark" title="Video: Soulja Boy &#8211; Big Boy TV Interview"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Soulja-Boy-Big-Boy-TV-Interview-218x150.jpg" alt="" title="Video: Soulja Boy &#8211; Big Boy TV Interview"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/24/video-soulja-boy-big-boy-tv-interview/" rel="bookmark" title="Video: Soulja Boy &#8211; Big Boy TV Interview">Video: Soulja Boy &#8211; Big Boy TV Interview</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/24/cardi-b-signs-las-vegas-residency-deal/" rel="bookmark" title="Cardi B Signs Las Vegas Residency Deal"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Cardi-B-Signs-Las-Vegas-Residency-Deal-218x150.jpg" alt="" title="Cardi B Signs Las Vegas Residency Deal"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/24/cardi-b-signs-las-vegas-residency-deal/" rel="bookmark" title="Cardi B Signs Las Vegas Residency Deal">Cardi B Signs Las Vegas Residency Deal</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/24/murs-announces-over-the-odyssey-tour/" rel="bookmark" title="MURS Announces “Over The Odyssey” Tour"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/MURS-Announces-Over-The-Odyssey-Tour-218x150.jpg" alt="" title="MURS Announces “Over The Odyssey” Tour"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/24/murs-announces-over-the-odyssey-tour/" rel="bookmark" title="MURS Announces “Over The Odyssey” Tour">MURS Announces “Over The Odyssey” Tour</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_25_5c4c77813b4f5" data-td_block_id="td_uid_25_5c4c77813b4f5"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_25_5c4c77813b4f5" data-td_block_id="td_uid_25_5c4c77813b4f5"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_32_5c4c77815944a_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_32_5c4c77815944a" ><script>var block_td_uid_32_5c4c77815944a = new tdBlock();
block_td_uid_32_5c4c77815944a.id = "td_uid_32_5c4c77815944a";
block_td_uid_32_5c4c77815944a.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"77","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_32_5c4c77815944a_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_32_5c4c77815944a.td_column_number = "3";
block_td_uid_32_5c4c77815944a.block_type = "td_block_mega_menu";
block_td_uid_32_5c4c77815944a.post_count = "4";
block_td_uid_32_5c4c77815944a.found_posts = "147";
block_td_uid_32_5c4c77815944a.header_color = "";
block_td_uid_32_5c4c77815944a.ajax_pagination_infinite_stop = "";
block_td_uid_32_5c4c77815944a.max_num_pages = "37";
tdBlocksArray.push(block_td_uid_32_5c4c77815944a);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_32_5c4c77815944a" id="td_uid_33_5c4c778159f6a" data-td_block_id="td_uid_32_5c4c77815944a" data-td_filter_value="" href="http://weuponithiphop.info/category/fashion/">All</a><a class="mega-menu-sub-cat-td_uid_32_5c4c77815944a"  id="td_uid_34_5c4c77815a061" data-td_block_id="td_uid_32_5c4c77815944a" data-td_filter_value="76" href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></div></div><div id=td_uid_32_5c4c77815944a class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/16/nike-zoom-2k-white-black/" rel="bookmark" title="Nike Zoom 2K White / Black"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/AO0269101-S-3-218x150.jpg" alt="" title="Nike Zoom 2K White / Black"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/16/nike-zoom-2k-white-black/" rel="bookmark" title="Nike Zoom 2K White / Black">Nike Zoom 2K White / Black</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/03/nike-air-max-plus-se-bordeaux-perfect-for-winter/" rel="bookmark" title="Nike Air Max Plus SE Bordeaux"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Nike-Air-Max-Plus-SE-4-218x150.jpg" alt="" title="Nike Air Max Plus SE Bordeaux"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/03/nike-air-max-plus-se-bordeaux-perfect-for-winter/" rel="bookmark" title="Nike Air Max Plus SE Bordeaux">Nike Air Max Plus SE Bordeaux</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/12/31/air-jordan-4-se-fiba/" rel="bookmark" title="Air Jordan 4 SE FIBA"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Air-Jordan-4-SE-FIBA-681x393-218x150.jpg" alt="" title="Air Jordan 4 SE FIBA"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/12/31/air-jordan-4-se-fiba/" rel="bookmark" title="Air Jordan 4 SE FIBA">Air Jordan 4 SE FIBA</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/12/31/adidas-yeezy-boost-700-v2-geode-dropping-spring-2019/" rel="bookmark" title="adidas Yeezy Boost 700 V2 Geode"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/adidas-Yeezy-Boost-700-V2-Geode-681x401-218x150.jpg" alt="" title="adidas Yeezy Boost 700 V2 Geode"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/12/31/adidas-yeezy-boost-700-v2-geode-dropping-spring-2019/" rel="bookmark" title="adidas Yeezy Boost 700 V2 Geode">adidas Yeezy Boost 700 V2 Geode</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_32_5c4c77815944a" data-td_block_id="td_uid_32_5c4c77815944a"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_32_5c4c77815944a" data-td_block_id="td_uid_32_5c4c77815944a"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-2515"><a href="http://weuponithiphop.info/category/editors-picks/">Editor&#8217;s Picks</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_35_5c4c778163acc_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_35_5c4c778163acc" ><script>var block_td_uid_35_5c4c778163acc = new tdBlock();
block_td_uid_35_5c4c778163acc.id = "td_uid_35_5c4c778163acc";
block_td_uid_35_5c4c778163acc.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"118","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_35_5c4c778163acc_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_35_5c4c778163acc.td_column_number = "3";
block_td_uid_35_5c4c778163acc.block_type = "td_block_mega_menu";
block_td_uid_35_5c4c778163acc.post_count = "5";
block_td_uid_35_5c4c778163acc.found_posts = "453";
block_td_uid_35_5c4c778163acc.header_color = "";
block_td_uid_35_5c4c778163acc.ajax_pagination_infinite_stop = "";
block_td_uid_35_5c4c778163acc.max_num_pages = "91";
tdBlocksArray.push(block_td_uid_35_5c4c778163acc);
</script><div id=td_uid_35_5c4c778163acc class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/25/music-video-young-buck-unrap/" rel="bookmark" title="Music Video: Young Buck &#8211; UnRap"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Young-Buck-UnRap-218x150.jpg" alt="" title="Music Video: Young Buck &#8211; UnRap"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/25/music-video-young-buck-unrap/" rel="bookmark" title="Music Video: Young Buck &#8211; UnRap">Music Video: Young Buck &#8211; UnRap</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/24/music-video-stunna4vegas-hitn4/" rel="bookmark" title="Music Video: Stunna4Vegas &#8211; Hitn4"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Stunna4Vegas-Hitn4-218x150.jpg" alt="" title="Music Video: Stunna4Vegas &#8211; Hitn4"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/24/music-video-stunna4vegas-hitn4/" rel="bookmark" title="Music Video: Stunna4Vegas &#8211; Hitn4">Music Video: Stunna4Vegas &#8211; Hitn4</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/24/murs-announces-over-the-odyssey-tour/" rel="bookmark" title="MURS Announces “Over The Odyssey” Tour"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/MURS-Announces-Over-The-Odyssey-Tour-218x150.jpg" alt="" title="MURS Announces “Over The Odyssey” Tour"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/24/murs-announces-over-the-odyssey-tour/" rel="bookmark" title="MURS Announces “Over The Odyssey” Tour">MURS Announces “Over The Odyssey” Tour</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/24/video-boogie-everythings-for-sale-short-film/" rel="bookmark" title="Video: Boogie – Everything’s For Sale (Short Film)"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Boogie-–-Everythings-For-Sale-Short-Film-218x150.jpg" alt="" title="Video: Boogie – Everything’s For Sale (Short Film)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/24/video-boogie-everythings-for-sale-short-film/" rel="bookmark" title="Video: Boogie – Everything’s For Sale (Short Film)">Video: Boogie – Everything’s For Sale (Short Film)</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/23/music-video-la-socket-x-asian-doll-hiya/" rel="bookmark" title="Music Video: La Socket x Asian Doll &#8211; HIYA"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/La-Socket-x-Asian-Doll-HIYA-218x150.jpg" alt="" title="Music Video: La Socket x Asian Doll &#8211; HIYA"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/23/music-video-la-socket-x-asian-doll-hiya/" rel="bookmark" title="Music Video: La Socket x Asian Doll &#8211; HIYA">Music Video: La Socket x Asian Doll &#8211; HIYA</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_35_5c4c778163acc" data-td_block_id="td_uid_35_5c4c778163acc"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_35_5c4c778163acc" data-td_block_id="td_uid_35_5c4c778163acc"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees/">Shop</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
</ul></div>                </div>

                <div class="td-pb-span5 td-sub-footer-copy">
                    &copy; 2018 The Hip Hop Chronicles Media Group                </div>
            </div>
        </div>
    </div>
</div><!--close td-outer-wrap-->

	<div id="wpcp-error-message" class="msgmsg-box-wpcp warning-wpcp hideme"><span>error: </span>Not Prohibited. ✌️</div>
	<script>
	var timeout_result;
	function show_wpcp_message(smessage)
	{
		if (smessage !== "")
			{
			var smessage_text = '<span>Alert: </span>'+smessage;
			document.getElementById("wpcp-error-message").innerHTML = smessage_text;
			document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp showme";
			clearTimeout(timeout_result);
			timeout_result = setTimeout(hide_message, 3000);
			}
	}
	function hide_message()
	{
		document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp hideme";
	}
	</script>
	<style type="text/css">
	#wpcp-error-message {
	    direction: ltr;
	    text-align: center;
	    transition: opacity 900ms ease 0s;
	    z-index: 99999999;
	}
	.hideme {
    	opacity:0;
    	visibility: hidden;
	}
	.showme {
    	opacity:1;
    	visibility: visible;
	}
	.msgmsg-box-wpcp {
		border-radius: 10px;
		color: #555;
		font-family: Tahoma;
		font-size: 11px;
		margin: 10px;
		padding: 10px 36px;
		position: fixed;
		width: 255px;
		top: 50%;
  		left: 50%;
  		margin-top: -10px;
  		margin-left: -130px;
  		-webkit-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
		-moz-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
		box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
	}
	.msgmsg-box-wpcp span {
		font-weight:bold;
		text-transform:uppercase;
	}
	.error-wpcp {		background:#ffecec url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/error.png') no-repeat 10px 50%;
		border:1px solid #f5aca6;
	}
	.success {
		background:#e9ffd9 url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/success.png') no-repeat 10px 50%;
		border:1px solid #a6ca8a;
	}
	.warning-wpcp {
		background:#ffecec url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/warning.png') no-repeat 10px 50%;
		border:1px solid #f5aca6;
	}
	.notice {
		background:#e3f7fc url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/notice.png') no-repeat 10px 50%;
		border:1px solid #8ed9f6;
	}
    </style>
	<div style="display:none">
	</div>


    <!--

        Theme: Newspaper by tagDiv 2016
        Version: 7.2 (rara)
        Deploy mode: deploy
        
        uid: 5c4c77816b15f
    -->

    <link rel='stylesheet' id='so-css-Newspaper-css'  href='http://weuponithiphop.info/wp-content/uploads/so-css/so-css-Newspaper.css?ver=1528674688' type='text/css' media='all' />
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201904'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2019Janaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.9.9'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/themes/Newspaper/js/tagdiv_theme.js?ver=7.2'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/comment-reply.min.js?ver=4.9.9'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/wp-embed.min.js?ver=4.9.9'></script>

<!-- JS generated by theme -->

<script>
    


            

	            // if the theme has tdBackstr support, it means this already uses it
                if ( 'undefined' !== typeof window.tdBackstr ) {

                    (function(){
                        // the site background td-backstretch jquery object is dynamically added in DOM, and after any translation effects are applied over td-backstretch
                        var wrapper_image_jquery_obj = jQuery( '<div class=\'backstretch\'></div>' );
                        var image_jquery_obj = jQuery( '<img class=\'td-backstretch not-parallax\' src=\'http://weuponithiphop.info/wp-content/uploads/grafitti-3-500x287.jpg\'>' );

                        wrapper_image_jquery_obj.append( image_jquery_obj );

                        jQuery( 'body' ).prepend( wrapper_image_jquery_obj );

                        var td_backstr_item = new tdBackstr.item();

                        td_backstr_item.wrapper_image_jquery_obj = wrapper_image_jquery_obj;
                        td_backstr_item.image_jquery_obj = image_jquery_obj;

	                    tdBackstr.add_item( td_backstr_item );

                    })();
                }

            
            

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'http://weuponithiphop.info/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'http://weuponithiphop.info/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>

<script type='text/javascript' src='https://stats.wp.com/e-201904.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.6.1',blog:'147622849',post:'22615',tz:'-5',srv:'weuponithiphop.info'} ]);
	_stq.push([ 'clickTrackerInit', '147622849', '22615' ]);
</script>

</body>
</html>