<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
<title>Music Video: YNW Melly – Mama Cry</title>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="pingback" href="http://weuponithiphop.info/xmlrpc.php" />
<meta property="og:image" content="https://lh3.googleusercontent.com/ogQw1JIIeXNxzDd9429qrHEsufXukXd1AuhHndWzNfF5sflAXpZsyeryBs-rRYKQ1HL9iN-5G-iijAtIJUpEG7MCa4UOLknl3MNAPuwgteh2LrTkWmvHHvLn9YPnuU2NXc5dqsWuj_KWwYa3Rc_QEzwsJdY4ctVQGpblCNQFdP1kmMmRg9K5qfBVzCWwHxojpP9vqRoWU_VWKWTKinLbj7qDoVZhubscww5PmoCLSzHZJsJqwVUHyyQOGsG3uZl84msh-beVTGUTm-GE6gKsL3oSBi9y5HxB-OP0e5uR2GLSj1uEY6pWr6mMzTupjjibEFH43mQ_l0d4wx5EaxW5-eN0lvUFC7WP6RRWP7g94bx1UxKNp7AlAkey4LgqcOz9-9EqxW0gaGHDh3mFOrR03CjJ4cid6yXTQCs0VhDtizMvNe96VWDAr_vkhhfLK7UHQilTrBzzxj6NLcgWcig1fJxcRmJR9jJvz14bqYP31PSWdkY7Ysh3FwTzcCb6yjhYEotabAeB9lxXdFBbzhTSVHq7BrO-jf9sNM5VFC_PoEzOeSEME45aBi-erK_JYnU4GEsS5l2s5-zX6oJLecNgvvRrPjS62y2qoNDYZuBTmZiLQLVBrV6lI2CgZRy9xdP-gSLZmawcheKvpu2yaDzRdlPCFD1WYUMz=w914-h452-no" /><meta name="author" content="cyclone">
<link rel="icon" type="image/png" href="https://pribitre-cdn.sirv.com/WP_weuponithiphop.info/weuponitlogoCAP.png?scale.width=500&scale.height=500">
<!-- All in One SEO Pack 2.11 by Michael Torbert of Semper Fi Web Designob_start_detected [-1,-1] -->
<link rel="canonical" href="http://weuponithiphop.info/2019/02/16/music-video-ynw-melly-mama-cry/" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Feed" href="http://weuponithiphop.info/feed/" />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Comments Feed" href="http://weuponithiphop.info/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Music Video: YNW Melly &#8211; Mama Cry Comments Feed" href="http://weuponithiphop.info/2019/02/16/music-video-ynw-melly-mama-cry/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"//h2r3t7s9.stackpathcdn.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.9"}};
!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
display: inline !important;
border: none !important;
box-shadow: none !important;
height: 1em !important;
width: 1em !important;
margin: 0 .07em !important;
vertical-align: -0.1em !important;
background: none !important;
padding: 0 !important;
}
</style>
<link rel='stylesheet' id='google_font_open_sans-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_roboto-css'  href='http://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C900%2C500italic%2C400%2C300&#038;ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='http://fonts.googleapis.com/css?family=Roboto+Condensed%3A400%2C700&#038;ver=4.9.9' type='text/css' media='all' />
<!-- <link rel='stylesheet' id='addtoany-css'  href='//h2r3t7s9.stackpathcdn.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='sirv_frontend_style-css'  href='//h2r3t7s9.stackpathcdn.com/wp-content/plugins/sirv/sirv/css/sirv-responsive-frontend.css?ver=4.9.9' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='js_composer_front-css'  href='//h2r3t7s9.stackpathcdn.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=4.12' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='td-theme-css'  href='//h2r3t7s9.stackpathcdn.com/wp-content/themes/Newspaper/style.css?ver=7.2' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='td-theme-demo-style-css'  href='//h2r3t7s9.stackpathcdn.com/wp-content/themes/Newspaper/includes/demos/what/demo_style.css?ver=7.2' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='jetpack_css-css'  href='//h2r3t7s9.stackpathcdn.com/wp-content/plugins/jetpack/css/jetpack.css?ver=7.0' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//h2r3t7s9.stackpathcdn.com/wp-content/cache/wpfc-minified/dgk7e1os/a863y.css" media="all"/>
<script src='//h2r3t7s9.stackpathcdn.com/wp-content/cache/wpfc-minified/dpxujlqw/a863y.js' type="text/javascript"></script>
<!-- <script type='text/javascript' src='//h2r3t7s9.stackpathcdn.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script> -->
<!-- <script type='text/javascript' src='//h2r3t7s9.stackpathcdn.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script> -->
<!-- <script type='text/javascript' src='//h2r3t7s9.stackpathcdn.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1'></script> -->
<link rel='https://api.w.org/' href='http://weuponithiphop.info/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://weuponithiphop.info/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://weuponithiphop.info/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Music Video: Blueface ft. Cardi B &#8211; Thotiana (Remix)' href='http://weuponithiphop.info/2019/02/16/music-video-blueface-ft-cardi-b-thotiana-remix/' />
<link rel='next' title='Music Video: 070 Phi &#8211; Good Contracts' href='http://weuponithiphop.info/2019/02/16/music-video-070-phi-good-contracts/' />
<meta name="generator" content="WordPress 4.9.9" />
<link rel='shortlink' href='https://wp.me/p9ZprH-6ii' />
<link rel="alternate" type="application/json+oembed" href="http://weuponithiphop.info/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fweuponithiphop.info%2F2019%2F02%2F16%2Fmusic-video-ynw-melly-mama-cry%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://weuponithiphop.info/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fweuponithiphop.info%2F2019%2F02%2F16%2Fmusic-video-ynw-melly-mama-cry%2F&#038;format=xml" />
<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>
<link rel="preconnect" href="https://pribitre-cdn.sirv.com" crossorigin/>
<link rel="dns-prefetch" href="https://pribitre-cdn.sirv.com"/>
<link rel="preconnect" href="https://scripts.sirv.com" crossorigin/>
<link rel="dns-prefetch" href="https://scripts.sirv.com"/>
<script id="wpcp_disable_selection" type="text/javascript">
//<![CDATA[
var image_save_msg='You Can Not Save images!';
var no_menu_msg='Context Menu disabled!';
var smessage = "Not Prohibited. ✌️";
function disableEnterKey(e)
{
if (e.ctrlKey){
var key;
if(window.event)
key = window.event.keyCode;     //IE
else
key = e.which;     //firefox (97)
//if (key != 17) alert(key);
if (key == 97 || key == 65 || key == 67 || key == 99 || key == 88 || key == 120 || key == 26 || key == 85  || key == 86 || key == 83 || key == 43)
{
show_wpcp_message('You are not allowed to copy content or view source');
return false;
}else
return true;
}
}
function disable_copy(e)
{	
var elemtype = e.target.nodeName;
var isSafari = /Safari/.test(navigator.userAgent) && /Apple Computer/.test(navigator.vendor);
elemtype = elemtype.toUpperCase();
var checker_IMG = '';
if (elemtype == "IMG" && checker_IMG == 'checked' && e.detail >= 2) {show_wpcp_message(alertMsg_IMG);return false;}
if (elemtype != "TEXT" && elemtype != "TEXTAREA" && elemtype != "INPUT" && elemtype != "PASSWORD" && elemtype != "SELECT" && elemtype != "OPTION" && elemtype != "EMBED")
{
if (smessage !== "" && e.detail == 2)
show_wpcp_message(smessage);
if (isSafari)
return true;
else
return false;
}	
}
function disable_copy_ie()
{
var elemtype = window.event.srcElement.nodeName;
elemtype = elemtype.toUpperCase();
if (elemtype == "IMG") {show_wpcp_message(alertMsg_IMG);return false;}
if (elemtype != "TEXT" && elemtype != "TEXTAREA" && elemtype != "INPUT" && elemtype != "PASSWORD" && elemtype != "SELECT" && elemtype != "OPTION" && elemtype != "EMBED")
{
//alert(navigator.userAgent.indexOf('MSIE'));
//if (smessage !== "") show_wpcp_message(smessage);
return false;
}
}	
function reEnable()
{
return true;
}
document.onkeydown = disableEnterKey;
document.onselectstart = disable_copy_ie;
if(navigator.userAgent.indexOf('MSIE')==-1)
{
document.onmousedown = disable_copy;
document.onclick = reEnable;
}
function disableSelection(target)
{
//For IE This code will work
if (typeof target.onselectstart!="undefined")
target.onselectstart = disable_copy_ie;
//For Firefox This code will work
else if (typeof target.style.MozUserSelect!="undefined")
{target.style.MozUserSelect="none";}
//All other  (ie: Opera) This code will work
else
target.onmousedown=function(){return false}
target.style.cursor = "default";
}
//Calling the JS function directly just after body load
window.onload = function(){disableSelection(document.body);};
//]]>
</script>
<script id="wpcp_disable_Right_Click" type="text/javascript">
//<![CDATA[
document.ondragstart = function() { return false;}
/* ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Disable context menu on images by GreenLava Version 1.0
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ */
function nocontext(e) {
return false;
}
document.oncontextmenu = nocontext;
//]]>
</script>
<!-- Analytics by WP-Statistics v12.5.7 - https://wp-statistics.com/ -->
<script>var WP_Statistics_http = new XMLHttpRequest();WP_Statistics_http.open('POST', 'http://weuponithiphop.info/wp-json/wpstatistics/v1/hit?_=1550362420', true);WP_Statistics_http.setRequestHeader("Content-Type", "application/x-www-form-urlencoded");WP_Statistics_http.send("wp_statistics_hit=" + JSON.stringify({"base":"http://weuponithiphop.info/wp-json","browser":"Unknown","platform":"Unknown","version":"Unknown","referred":"http://weuponithiphop.info/2019/02/16/music-video-ynw-melly-mama-cry/","api":"wp-json","ip":"198.54.126.161","hash_ip":"#hash#78e7436cfe9968df1a41c051a869b09e4522e400","exclude":"1","exclude_reason":"CrawlerDetect","ua":"WP Fastest Cache Preload Bot","track_all":"1","timestamp":"1550344420","is_object_wp_query":"true","current_page_id":"24198","page_uri":"/2019/02/16/music-video-ynw-melly-mama-cry/"}));</script>
<!-- Analytics by WP-Statistics v12.5.7 - https://wp-statistics.com/ -->
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
<meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="//h2r3t7s9.stackpathcdn.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="//h2r3t7s9.stackpathcdn.com/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]-->
<!-- JS generated by theme -->
<script>
var tdBlocksArray = []; //here we store all the items for the current page
//td_block class - each ajax block uses a object of this class for requests
function tdBlock() {
this.id = '';
this.block_type = 1; //block type id (1-234 etc)
this.atts = '';
this.td_column_number = '';
this.td_current_page = 1; //
this.post_count = 0; //from wp
this.found_posts = 0; //from wp
this.max_num_pages = 0; //from wp
this.td_filter_value = ''; //current live filter value
this.is_ajax_running = false;
this.td_user_action = ''; // load more or infinite loader (used by the animation)
this.header_color = '';
this.ajax_pagination_infinite_stop = ''; //show load more at page x
}
// td_js_generator - mini detector
(function(){
var htmlTag = document.getElementsByTagName("html")[0];
if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
htmlTag.className += ' ie10';
}
if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
htmlTag.className += ' ie11';
}
if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
htmlTag.className += ' td-md-is-ios';
}
var user_agent = navigator.userAgent.toLowerCase();
if ( user_agent.indexOf("android") > -1 ) {
htmlTag.className += ' td-md-is-android';
}
if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
htmlTag.className += ' td-md-is-os-x';
}
if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
htmlTag.className += ' td-md-is-chrome';
}
if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
htmlTag.className += ' td-md-is-firefox';
}
if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
htmlTag.className += ' td-md-is-safari';
}
})();
var tdLocalCache = {};
( function () {
"use strict";
tdLocalCache = {
data: {},
remove: function (resource_id) {
delete tdLocalCache.data[resource_id];
},
exist: function (resource_id) {
return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
},
get: function (resource_id) {
return tdLocalCache.data[resource_id];
},
set: function (resource_id, cachedData) {
tdLocalCache.remove(resource_id);
tdLocalCache.data[resource_id] = cachedData;
}
};
})();
var tds_login_sing_in_widget="show";
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_ajax_url="http:\/\/weuponithiphop.info\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=7.2";
var td_get_template_directory_uri="http:\/\/weuponithiphop.info\/wp-content\/themes\/Newspaper";
var tds_snap_menu="snap";
var tds_logo_on_sticky="show_header_logo";
var tds_header_style="5";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#dd3333";
var tds_smart_sidebar="enabled";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>
<!-- Header style compiled by theme -->
<style>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</style>
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>
<body class="post-template-default single single-post postid-24198 single-format-standard unselectable music-video-ynw-melly-mama-cry td-what wpb-js-composer js-comp-ver-4.12 vc_responsive td-boxed-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">
<div class="td-mobile-container">
<!-- mobile menu top section -->
<div class="td-menu-socials-wrap">
<!-- socials -->
<div class="td-menu-socials">
<span class="td-social-icon-wrap">
<a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
<i class="td-icon-font td-icon-pinterest"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span>            </div>
<!-- close button -->
<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
</div>
<!-- login section -->
<div class="td-menu-login-section">
<div class="td-guest-wrap">
<div class="td-menu-avatar"><div class="td-avatar-container"><img alt='' src='http://0.gravatar.com/avatar/?s=80&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo avatar-default' height='80' width='80' /></div></div>
<div class="td-menu-login"><a id="login-link-mob">Sign in</a></div>
</div>
</div>
<!-- menu section -->
<div class="td-mobile-content">
<div class="menu-top-menu-container"><ul id="menu-top-menu" class="td-mobile-main-menu"><li id="menu-item-317" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a></li>
<li id="menu-item-706" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a></li>
<li id="menu-item-314" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a></li>
<li id="menu-item-316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-0" class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a></li>
<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a></li>
<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a></li>
<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a></li>
<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></li>
</ul>
</li>
<li id="menu-item-705" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li class="menu-item-0"><a href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></li>
</ul>
</li>
<li id="menu-item-2515" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2515"><a href="http://weuponithiphop.info/category/editors-picks/">Editor&#8217;s Picks</a></li>
<li id="menu-item-3199" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees/">Shop</a></li>
<li id="menu-item-18581" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
</ul></div>        </div>
</div>
<!-- register/login section -->
<div id="login-form-mobile" class="td-register-section">
<div id="td-login-mob" class="td-login-animation td-login-hide-mob">
<!-- close button -->
<div class="td-login-close">
<a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
<div class="td-login-title">Sign in</div>
<!-- close button -->
<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
</div>
<div class="td-login-form-wrap">
<div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
<div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
<input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
<div class="td-login-info-text"><a href="#" id="forgot-pass-link-mob">Forgot your password?</a></div>
</div>
</div>
<div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
<!-- close button -->
<div class="td-forgot-pass-close">
<a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
<div class="td-login-title">Password recovery</div>
</div>
<div class="td-login-form-wrap">
<div class="td-login-panel-title">Recover your password</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
<input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
</div>
</div>
</div>
</div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="http://weuponithiphop.info/">
<!-- close button -->
<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob"></div>
</div>
</div>    
<div id="td-outer-wrap">
<!--
Header style 5
-->
<div class="td-header-wrap td-header-style-5">
<div class="td-header-top-menu-full">
<div class="td-container td-header-row td-header-top-menu">
<div class="top-bar-style-1">
<div class="td-header-sp-top-menu">
<div class="td_data_time">
<div >
Saturday, February 16, 2019
</div>
</div>
<ul class="top-header-menu td_ul_login"><li class="menu-item"><a class="td-login-modal-js menu-item" href="#login-form" data-effect="mpf-td-login-effect">Sign in / Join</a><span class="td-sp-ico-login td_sp_login_ico_style"></span></li></ul><div class="menu-top-container"><ul id="menu-main" class="top-header-menu"><li id="menu-item-79" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-79"><a href="http://weuponithiphop.info">Home</a></li>
<li id="menu-item-81" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-81"><a target="_blank" href="http://weuponitradio.com">Power 105.1 WeUpOnIt Radio</a></li>
<li id="menu-item-80" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-80"><a target="_blank" href="https://shop.spreadshirt.com/freshandcleantees/">Shop</a></li>
<li id="menu-item-18582" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18582"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li id="menu-item-18583" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18583"><a href="http://weuponithiphop.info/privacy-policy-2/">Privacy Policy</a></li>
</ul></div></div>
<div class="td-header-sp-top-widget">
<span class="td-social-icon-wrap">
<a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
<i class="td-icon-font td-icon-pinterest"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span></div>
</div>
<!-- LOGIN MODAL -->
<div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
<ul class="td-login-tabs">
<li><a id="login-link" class="td_login_tab_focus">LOG IN</a></li>
</ul>
<div class="td-login-wrap">
<div class="td_display_err"></div>
<div id="td-login-div" class="">
<div class="td-login-panel-title">Welcome! Log into your account</div>
<input class="td-login-input" type="text" name="login_email" id="login_email" placeholder="your username" value="" required>
<input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" placeholder="your password" required>
<input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Log In">
<div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password?</a></div>
</div>
<div id="td-forgot-pass-div" class="td-display-none">
<div class="td-login-panel-title">Recover your password</div>
<input class="td-login-input" type="text" name="forgot_email" id="forgot_email" placeholder="your email" value="" required>
<input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Pass">
</div>
</div>
</div>
</div>
</div>
<div class="td-header-menu-wrap-full">
<div class="td-header-menu-wrap">
<div class="td-container td-header-row td-header-main-menu black-menu">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-main-menu-logo td-logo-in-menu">
<a class="td-mobile-logo td-sticky-header" href="http://weuponithiphop.info/">
<img class="td-retina-data" data-retina="https://pribitre-cdn.sirv.com/WP_weuponithiphop.info/weuponit-glow-logo-5.png" src="https://pribitre-cdn.sirv.com/WP_weuponithiphop.info/weuponit-glow-logo-5.png" alt=""/>
</a>
<a class="td-header-logo td-sticky-header" href="http://weuponithiphop.info/">
<img class="td-retina-data" data-retina="https://pribitre-cdn.sirv.com/WP_weuponithiphop.info/weuponit-glow-logo-6.png" src="https://pribitre-cdn.sirv.com/WP_weuponithiphop.info/weuponit-glow-logo-6.png" alt=""/>
<span class="td-visual-hidden">WeUpOnIt</span>
</a>
</div>
<div class="menu-top-menu-container"><ul id="menu-top-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-mega-menu menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_1_5c68a734dee39_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_1_5c68a734dee39" ><script>var block_td_uid_1_5c68a734dee39 = new tdBlock();
block_td_uid_1_5c68a734dee39.id = "td_uid_1_5c68a734dee39";
block_td_uid_1_5c68a734dee39.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"43","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_1_5c68a734dee39_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_1_5c68a734dee39.td_column_number = "3";
block_td_uid_1_5c68a734dee39.block_type = "td_block_mega_menu";
block_td_uid_1_5c68a734dee39.post_count = "5";
block_td_uid_1_5c68a734dee39.found_posts = "1342";
block_td_uid_1_5c68a734dee39.header_color = "";
block_td_uid_1_5c68a734dee39.ajax_pagination_infinite_stop = "";
block_td_uid_1_5c68a734dee39.max_num_pages = "269";
tdBlocksArray.push(block_td_uid_1_5c68a734dee39);
</script><div id=td_uid_1_5c68a734dee39 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/new-music-jag-ft-boogie-nick-grant-dcmbr-stressin-45657557/" rel="bookmark" title="New Music: JAG ft. Boogie, Nick Grant &#038; DCMBR &#8211; Stressin"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/DouMxeHST1KMRjbE14brLVstWOJ_xQ1cWPHd4-NfvkVQrbWIYG-bfbZW7NGzmiR24v2zL0f7ZKq1xS6Ee2Reg7Ya3Q9ZCaIDby038A--qDS0-uMsSlN9x7oKbQr8Ive6IF4JxzNQs-jhCYrzw88oyB8pcvh72qqFxN5vjU2ufxbX_xgEFFotVZIY_VJnb4pjBy6ppR8XWhDjL2Yk_qOZvqoAAvMf2LlqWAPYQt6H-oh3LUjW_w6BpoMapZiGRsYQuFJAYnzRzueT6izfVT4Oz54LxF15v6qJEMq1PS81O6NHMNcdI7qy5XsAQ7StnW_xjkn9b3j2HZW5cF3Vk53YTtz5LI6a0MYQususplTaC0EsyI8x_cV2wWGv8i_m7otd7dn_Hsh5rgZkTKW-gU5GqdqxE7tWX57VjBchnlzkFwwSk0F8pPgKQIrM4DxM0zbqvZnnHlhJi0Ur9JhoGBR2SZvFUBR13y5IZS-ZSUrDmrZEbEOp_nce9_Ge7f7Q_5F7A31gMQveT2RpewNcK5fF4hiGPO1fsvXA3-UO8xEb1I4Em4cm_f9sVJ5llhJi8K7TaKTRkDpjXFZfhbEs4v-Ctris6Sbra5ZV9vy80kKOm_ItPelJl4De8qDDjVH9IT_njUcdh9mEEJSDmQQgE0TreTK1B5IEPb-y=s673-no" alt="" title="New Music: JAG ft. Boogie, Nick Grant &#038; DCMBR &#8211; Stressin"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/new-music-jag-ft-boogie-nick-grant-dcmbr-stressin-45657557/" rel="bookmark" title="New Music: JAG ft. Boogie, Nick Grant &#038; DCMBR &#8211; Stressin">New Music: JAG ft. Boogie, Nick Grant &#038; DCMBR &#8211; Stressin</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/new-music-lil-west-not-sure/" rel="bookmark" title="New Music: Lil West &#8211; Not Sure"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/DpMAuMInSWjNvBbXgU7mxFqgHpwPU2uT8YJPmFp5yeK1SImArLJa_3inMqHjnyc8D1-uW5aRjdDYCOf7usOtjJ7dn-09hShX1AwGMhSmsg12-R1u7l8MIL8bkH7pht4WbbfcfeOQ2HROh6JFVMvHzrUSCrgI_gc2pfjwS6QPv562Yr3oCiA09yHMjN9Fy_9UkKQ3CEZgN8o55giFtiWtXymvQXgoRsvs9-pNBvpmY-PkKSDR23FEExGH_a5Oz0DbIJOTUqCCE3793pYJ0RRHxL8SXfMIAgBO_eU1GTt-fXU95YC-lUaLE746J0TX6mk22GU2L2MHhlxGFBkIUb2tDH8nl3DzbkLRsuN35LQs6EJxuqnNXI4JQWSGzAMi4CRJ10zf2kXIBEPh0fAuDxWqXlXG_kWZLuZ8iYAmYtyUSvEHEBAQzL9CcyBkQMV-OSPh01asz-eID7-0ljkYw23aMNlZipQHSO20D5DzY1TkOPEi4UmbmQKPLI_1qoKmRiqbu4mUs27yXfTKeCtp7ymVgqNLrhzN6DSISaM5k7_bF2_GXT034ZmWfWxckfGUFcWcm_FsvG6-lW_F3MI6Ind5D0QDJwzTZrY5gVolQVa2vwQEQvSdqT4i2V20cl8V-5piQ-Z3nUNfDE9p6CZ6MPvjnsyRgoW-7TfU=s673-no" alt="" title="New Music: Lil West &#8211; Not Sure"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/new-music-lil-west-not-sure/" rel="bookmark" title="New Music: Lil West &#8211; Not Sure">New Music: Lil West &#8211; Not Sure</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/new-music-fetty-wap-history-2/" rel="bookmark" title="New Music: Fetty Wap &#8211; History"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/_HjOUR2DOh7F14mepeQsze9gsx4qWg6QrJ8GreM5Lhbnpjt88ESLOvjg5SYie2bkffeGWizkiQU-ulr-CqyoyvfXhYdMGfqNVsPnn1Zsen8IUxwfKjGR4b9c3uTGODbwZH-qe8kORNuCQvGXAcrLxLV8-vQ59Er7Vr4WJIA7q29Q93uxj1x1au4s2fZvOq9ifIfGFdp-qmZfNSo1m7_xYFcWrHjuWySDWD74mCrhbvqyBsK_jMrEXVM-hkhLVqY4jfY94505m52ttpR7SIe43Ja01GEKOzzr7KAD1T26jebdAus-I3CFcK8PXgTNZKt3-euUYu1tLjqqHyTn0bJJuHrxsCsEf3r07eB3OkTwyCczRSamUlw8l-z_Kz_BCgC7lkip8Y9hoee7LMLmq3NQ6FHSNqssQAh5zuvob3uB267WGL1ksRh1dKzf9FSaLw7LWeDQ6EGc_LMl9y7YPrZNKcu0Hv3Yzais-dkx4Be4RC5Atj4UvaLUBI8uRor-iamoLtlwZfhPlJFe9T0cgFkX_0cLt4whaU_xEaGJ53rWycudMHRLL1Of_bIxd-wikuZC3yE4ICtY_LrpVKrae14hkn9QRq6euyJWG1eKG0oM9T-bt5dk0wBMjsi5G_YuSFrIXQZt0wwNi7KXLJxNdcCsno2ERBGzb1t6=s620-no" alt="" title="New Music: Fetty Wap &#8211; History"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/new-music-fetty-wap-history-2/" rel="bookmark" title="New Music: Fetty Wap &#8211; History">New Music: Fetty Wap &#8211; History</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/new-music-rod-wave-hard-times/" rel="bookmark" title="New Music: Rod Wave &#8211; Hard Times"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/24gfDTm5j6GCymio79wG7eHnhm-DmoxQ0wKfGV0T4Ib-1pNbzeVPgObALMdgN-3ABUV9xOBf0oyoT8OOPkFyx2LfVy4LEnBhSYa3hqzVCZ9avMvQdYxnM03zXw05sL94ulHrvFVZcBaK_pl2zg7ww-9Fjng8zXikitlx7glXUbJMxpR7_UA4Sj8iPSibRQylWQgWOS53eq923cCHKI1Omswlu3ugaOiFm4yQhPLiXudYahcyjpglzS7HhUjS1rhtlanw7eEebtnytBT94mMnHG0SJpfqcD7ZS6wozY6fpyW4F8a2U6OUBrhMeKX3uHBlWl3ML8meOjrbOsnpd4jtdHRbXEmaWhZSrcIdcTdzg4BGGQXXAOcvh3GSDShKBRjgKnaFrgTylY2r7TBXs6x5rbOi7c4Zz7Ummls-kUCZ-GYvkQBMazUHbWyFC85On8LwfYbwHWO5PpHhkWc5hO_rYMMu8GxDJm-wX0TF9wTC0m-KLrVpQCbgSPNjztqfZ5LJ-XZ23XpqV1LKVuKEk0aVRgf9YgS7BG4HlNyyKO8eKCFx74I0aDSVYcM-zjBBCVyIS8xtfne4RFT7-1a2Pq5e0ybuymNiQu7PO6me-lzzFV0E8DJEbguHrrqvNfPNaB4SPwmzxaNOJXPZh3mDRj8dxhtoWGNlf9pn=w620-h349-no" alt="" title="New Music: Rod Wave &#8211; Hard Times"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/new-music-rod-wave-hard-times/" rel="bookmark" title="New Music: Rod Wave &#8211; Hard Times">New Music: Rod Wave &#8211; Hard Times</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/new-music-meyhem-lauren-the-alchemist-still-playing-celo/" rel="bookmark" title="New Music: Meyhem Lauren &#038; The Alchemist &#8211; Still Playing Celo"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/rO_03NZ0s2Ts5EYLM09t8okvjAORCyJadvdxFajxqaoEzsn4BWGTZMr1PDbYXByZeW17ZjsTyls4HPsMeKhomse6mSc4bdEdp9lVfBUn_L_4pwTQbF5m3kjPXCs3HlzEX3T5SO4pIBF0xRxhAq6DsRkR2H-RjthpjIxk_xmB05hGLMXX2JsvHQcrN8IKG4DqTWH5UBt4DYmTs1u8-uymUnA1IYyl-kQ7OOE1AQ1bgjJXeI7x4GQzeQlBEr0KAzZ6hcTOv09pK_pA2gjc4IEItZOoAZ2RHCu7TwXJOIpmqvrmt7WjOqIl3bm6q_H25QmRd0tlIqz637kjWlaCYJYWTCZ5V6pD4P8tqag8WTo2u32CJiW2mY7Qsuv0-jd74EG-n4FJK6LJjgzW7_x6BU03PvMDltv-pF1qoWuLyTRlqtr9LPKaqd6pJ4Rg6G7HtLQKI4ymsUs6WeQUaAgP_ga4pGLb0VvJxkm8P3Icyrsuygry2Jx7Pmk6UpAnG21DnP14x2UlrZp9kwszYT1mcVZlQbNM9zxF8MQozoIHrPzJDhQH6_VrKm9Smm9n9cqNIrx5vvCGPzSTO-GwpXnR-E6nagV9nnw732-r89m_rm3BMhfkorGBWdNbV0ZnXeiRg9z9Xqlaon1pf9lqbjCc9uKERSC33It1lBlQ=s673-no" alt="" title="New Music: Meyhem Lauren &#038; The Alchemist &#8211; Still Playing Celo"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/new-music-meyhem-lauren-the-alchemist-still-playing-celo/" rel="bookmark" title="New Music: Meyhem Lauren &#038; The Alchemist &#8211; Still Playing Celo">New Music: Meyhem Lauren &#038; The Alchemist &#8211; Still Playing Celo</a></h3>            </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_5c68a734dee39" data-td_block_id="td_uid_1_5c68a734dee39"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_1_5c68a734dee39" data-td_block_id="td_uid_1_5c68a734dee39"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_2_5c68a734e6500_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_2_5c68a734e6500" ><script>var block_td_uid_2_5c68a734e6500 = new tdBlock();
block_td_uid_2_5c68a734e6500.id = "td_uid_2_5c68a734e6500";
block_td_uid_2_5c68a734e6500.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"97","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_2_5c68a734e6500_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_2_5c68a734e6500.td_column_number = "3";
block_td_uid_2_5c68a734e6500.block_type = "td_block_mega_menu";
block_td_uid_2_5c68a734e6500.post_count = "5";
block_td_uid_2_5c68a734e6500.found_posts = "517";
block_td_uid_2_5c68a734e6500.header_color = "";
block_td_uid_2_5c68a734e6500.ajax_pagination_infinite_stop = "";
block_td_uid_2_5c68a734e6500.max_num_pages = "104";
tdBlocksArray.push(block_td_uid_2_5c68a734e6500);
</script><div id=td_uid_2_5c68a734e6500 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/ep-stream-qari-operation-hennessy/" rel="bookmark" title="EP Stream: Qari &#8211; Operation Hennessy"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/yde_J-jr_05fmBKadXTKWjLT6gA5HHfif-96VICJkA1KS0hHIQd7Kb_UaGUpdvB2-mGN3J6tfA4v893_PSobVkeWGRXl856vCAcJyQ5h-OD54trbX0hQJDXmX1d5v_2qlgMvsUw7zoWjbAyoLZwZTtJj09T78V-Q3C23W7SI5AxFHl488_tqfExjS3TfM7B8nkg8H2_TrJL2KWASDgKDwyValwExGSGQukRp0fxk92mrkkuvalicjkAgC2z4F4NSieMoFW1F_YzkyRl5g_U167y70v3jLzhaK4xDEqPCHWqCQk0zNc2pJ4CzGlcqY8RFdOEOZqvioG6wujznXu-4GQ02FLHCQy21PKTmzaYYZwnL7Tm3b74QdKgln_H6rKLLROKsLc-WHYJqOGliSWS7Tuf1-GmghUK0fp3PGYp0DT8-US8-bZO3IwdVdCykoxTbAqSPPobRtMM3eGNF68_Ovt0AudrG1uf28PxvE4xjJyuap_EBxg8dJjXS8VAMIkQPbGvzl1yfTuyfyChZfIDKUYrSQy05ZqA0gpCzsZr3fvjzSghs11ST_7u0BgKFMWRu-vs-7VjHYtjBQhgebB2J8xDBGAGYqvwp5N244x4ONZ5CKUgBmmkdWJP-1XsW_FFem4UpsJlShqp9tprC1d7NgSsJdQn9oLAy=s673-no" alt="" title="EP Stream: Qari &#8211; Operation Hennessy"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/ep-stream-qari-operation-hennessy/" rel="bookmark" title="EP Stream: Qari &#8211; Operation Hennessy">EP Stream: Qari &#8211; Operation Hennessy</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/ep-stream-baby-goth-baby-goth/" rel="bookmark" title="EP Stream: Baby Goth &#8211; Baby Goth"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/Z5g8J4Rryv4Xb1eZed3r5qJu34e5vaFdznHDVBAr6VYl0gWQMNMHzd9cmsi0jR-_C4SPOosXRFWEhNOzueF0C8VOr1OGiKXi-Zux-f8CJ4qO8qpA6CzEjT4JManLjwn4HiDRQlvEkg_0dtQkRN4jCIMFMNAIC2fp_tm6qTe2yohzmi5lDPtggpzmoHzua2FSksUbagsCd-btEx4fOb9_IhrhefJvsvFSHyZ5HVxgSKdCVJvPLQTv3_9QS0-LYWYRzPe2a_GZUK1hsqJYfmz6wnBFnfG0Oo6LpUgUYNbSa_Qbrm0PAy84D_OxMfHnEwY9btwZbGDN_tFegvcvwPMhvkbNdPK88s4Au7gdU6e1nVaYqUaibAgZFBI3oMBTuUS3ZtRgmwv-z01Bri3HEsk8J1bV4XygcQOmuAcLgf8iNl9Gxd-KDH5hA114ea3Blzw_Jfl4LEmJxv59YOjlxI7Yav1hnW2uat8NzBDSxsWf0jfW5sDxRL8oIzYAIBTl6bpvp0qTeOJ3M0RTFDZIAcU0qsg8UjPXILxHN0w4PP_d6-mHIXvdnOx_1Iq2_JC9--cid9naFqCXCE2vJgDmFCROb9KTXQxvgC2r7UE7rA1hAp0zaE1RrliFOBErinUt6rjpmjTTbSzkACN1kI9o07Tv-7mvTQQlQjkA=s673-no" alt="" title="EP Stream: Baby Goth &#8211; Baby Goth"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/ep-stream-baby-goth-baby-goth/" rel="bookmark" title="EP Stream: Baby Goth &#8211; Baby Goth">EP Stream: Baby Goth &#8211; Baby Goth</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/15/ep-stream-richie-wess-lost-you/" rel="bookmark" title="EP Stream: Richie Wess &#8211; Lost You"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/PCxxg1beH7n9UWueGrgxTqjjj4nq3qfWiUsxbSmhRPyGH27PWdWYIQdapHMUHeOGUP8n1prJ5R5MIeaFUUi7B3Qvrn_CR8ZRxZvHDfujDz_-IaMN5xbu89kEXw6N2oonPekwEdE5I2JCah587QRRe3lEesN8JXh7AkRnmSTuq9s_10hlDvEr9PiP-H9FSwkqdrvjz0ctWUYRVcjmr5yFUfckBavipjgCULEeGhE3Pj_fcYdnd7Jzj4DoPvG8l9XOiuZ7bqiueQgnQYZ2xL_InJZ5FlSTnOmIMwRuswc1rUmJOzXjqlnRKWAruGWMB0o0knWPAsF9Y_1W7AXI1CAfNcQ1VGtn107oG8mUf7wwtUdU7c9EQmKsav2N-cF2zPU5hsHdgr28_OOIF6wYuq9YRYsr5LWnG-lEqikU6jtijPnR4h9fknWdZa6xb-6_fsotlBpfy-GIBKsQHTu8noscue9qTHhhVg42Wk-3qyt00pfjTv7msiBlbxtFrc175DgVl-2ZCB4SMXO2MYc9AS1Z9YlYqU7XuaqMwYHeasAVbc_nEHXaO6jVu_jti-Kn--LWCkw6gxs_QXkICnoExJ5433s3TAf3gCtmtTIFC4SO1l3IoYgnnRR1Z3lY6oJlfUr8L2O-mTR8Wllksk6sJ7ho20pxHym0wKOZ=s673-no" alt="" title="EP Stream: Richie Wess &#8211; Lost You"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/15/ep-stream-richie-wess-lost-you/" rel="bookmark" title="EP Stream: Richie Wess &#8211; Lost You">EP Stream: Richie Wess &#8211; Lost You</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/15/album-stream-papoose-underrated/" rel="bookmark" title="Album Stream: Papoose &#8211; Underrated"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/g32MFhxBXR2tUsAYANPHD9rHWI5B-YBaDOQbX-IcqU37UsReCBp1Wh7L5Av26ezTyVpJP4PYFJwmvxRLkKOmDbT4977Be-PB1-ZH5Rt1nSCG-_r6Uz__xm2GC32R6_lb3VVNIUAh53Rt6_gucdvutBuwAdusUGqP-pvB1jP9DWLrpo2m47DUZ1DpwH_9rge38I_3WqRBzf4NlP7OTEvRsNVu9V-ga9rwPS97FxyKaNWnYaA13uo9lp0diAfOEzWQJXPrr5QckchXDuukmIGHkG8zGorebwFEnAq_6nY7nxVE7BZZ0XJuTwfRH6eArF_OYDH0bN-NEI1szV7EWgRq91dLv221tt3UL93RyO4fUYxtu4VuS8iuBmXkAYe83T15QnvFTst-96U67-phIZZtbLoLVdFoYZTwNazzG4aqFfE2QDZ32n3vzLwL-RVsC6QnDo-WvkI3Snym-Jyc_4vSRqJ-4mtnGMM785m8j6Vjj94indHWOdTe9Jw9yjwTa2ULa8pjC_p05pNEIcLzVKESL1FDXFQoyWR0xeIhAhH2kA8TNx-5XUUe8IX8PGJ_ATDeznx6VtXjj7LTVLbsVut0tobN3Yy-fTRPIcMF6DCd83iVXJh6kS583-DVjku0IjBI7znMfnxddh6QrGPWuTxbq_XKsbSGw6vb=s673-no" alt="" title="Album Stream: Papoose &#8211; Underrated"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/15/album-stream-papoose-underrated/" rel="bookmark" title="Album Stream: Papoose &#8211; Underrated">Album Stream: Papoose &#8211; Underrated</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/15/ep-stream-yung-bleu-bleu-vandross-2/" rel="bookmark" title="EP Stream: Yung Bleu &#8211; Bleu Vandross 2"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/Ls6PYAzVU2w1dqtxftwpjENt1AJEmGXr8cL6_wSoUF7WUc3BGOA2Ra5idyGgoUAMQxOqtYpkMJNGqdvVOKawDhl2g40129F6jvWSdGMCBuHLbCcA8G4QqZj8vEQ8llBfKglIUDRn1c7MRXfM5NE6Lr82jgJyWV2AO7jTYrWr0BvnasSA9d0vv67bU6NXhrpe16HAKVpPShb6ALh_odBtRlH6BsIzApecJ9xG67w1H4e-yZYWN4BeqTN2rSOKzqOPG1YsiFGLFYYZcpHw65J-Ksy5Ub3QLh-sx3k5_18cebr5P1Gz5gjkGTR32Wa3H1sAG4x-FvLVngLumz4J4jzUWrkJCQtgmRL4kj_h6h0_blOzPw6Prskdxi_zrMuHkDCV4PZEKYNLwTWvqyWunM1i89BtX_wflFkGhpOmV156zHUCzfbRD9aAl6LYopGXBfFWOLo2fM9GSU1W_Deg1ENXQXQY0I6uHjsvB1odG5N0U-HzOZtrd4gl-BS3kmLOJ1MqjeLIr1azvmp5AdIRlw3743c2W2jYFut5cm8XzSP88KmOfZsA43gZeNY-c96bXfaRytUIFM_V-W2hQ8Uc2NauJj31ZKJr6qifQuPpjk-5PUJ355BMLE8uMM9CHoWZMWGgI84xj189If9obPyy04EEYcVNCPz2GfWB=s673-no" alt="" title="EP Stream: Yung Bleu &#8211; Bleu Vandross 2"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/15/ep-stream-yung-bleu-bleu-vandross-2/" rel="bookmark" title="EP Stream: Yung Bleu &#8211; Bleu Vandross 2">EP Stream: Yung Bleu &#8211; Bleu Vandross 2</a></h3>            </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_5c68a734e6500" data-td_block_id="td_uid_2_5c68a734e6500"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_2_5c68a734e6500" data-td_block_id="td_uid_2_5c68a734e6500"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_3_5c68a734ed4be_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_3_5c68a734ed4be" ><script>var block_td_uid_3_5c68a734ed4be = new tdBlock();
block_td_uid_3_5c68a734ed4be.id = "td_uid_3_5c68a734ed4be";
block_td_uid_3_5c68a734ed4be.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_3_5c68a734ed4be_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_3_5c68a734ed4be.td_column_number = "3";
block_td_uid_3_5c68a734ed4be.block_type = "td_block_mega_menu";
block_td_uid_3_5c68a734ed4be.post_count = "5";
block_td_uid_3_5c68a734ed4be.found_posts = "1241";
block_td_uid_3_5c68a734ed4be.header_color = "";
block_td_uid_3_5c68a734ed4be.ajax_pagination_infinite_stop = "";
block_td_uid_3_5c68a734ed4be.max_num_pages = "249";
tdBlocksArray.push(block_td_uid_3_5c68a734ed4be);
</script><div id=td_uid_3_5c68a734ed4be class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/music-video-dizzy-wright-ft-eric-bellinger-picture-perfect/" rel="bookmark" title="Music Video: Dizzy Wright ft. Eric Bellinger &#8211; Picture Perfect"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/nxVARw-JBVf8rO_l2uve6KNCfSIjAarkkbgyS2qqUeEDzGo5KjtfQnkjtJ10yrRonj_bMB2RzaMri0E_8s6vSp7HIa1iI2FFJtvyIAFwfktklyBdR_pw0pDWF2Zd9O-q85DAFCpbHgBrppZ3z5mZBpbeY11h8hsdAdjWSHwMcQJc4k23gKoD6R47pbCWcz0UWVGosUP0xE_k-B4LSRIwspsarGHlvkSCIV-pFcthBxxFZsrNptnhQfEzc6xuRFTZPbm4PWAeyYj_4gCwyBbjnRzBqo5eCzJyFPPv8vO1p6i9fgPwQ6sJ_4RDz22q_4drmWenRmSI3Hrc3LznTbdNiERDq6V3eIkw7ZMfMh3a8Aso6tJd09HLZtzzfBZDPK7NRSxnK8d1gwVR2AtqWXLEG1oAnDudYsK52qIh-VVsMsIgqza_R-mRcOSgL1aAg4s6ZmV_5h4n-FLbbhP23dfxNBHb1jjjAwL5kLK_zZSafXLTNgt_BQJ9-FZOCu1AYBMIL0xxAC3Pfg04gJZbMGv_jEIrnKFdQ2plyNYTRZ4wCr5V696KY-whFdU34YpgsYM8SaoHJZ68XvG2LQcJTCszcXEecyHZkPSls_UdnTLRDYiDX3_LVOkss-_j1MnVinoUCBsXDL_aStd8QG1cSW5KXOHE-lOaZSR8=w954-h452-no" alt="" title="Music Video: Dizzy Wright ft. Eric Bellinger &#8211; Picture Perfect"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/music-video-dizzy-wright-ft-eric-bellinger-picture-perfect/" rel="bookmark" title="Music Video: Dizzy Wright ft. Eric Bellinger &#8211; Picture Perfect">Music Video: Dizzy Wright ft. Eric Bellinger &#8211; Picture Perfect</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/music-video-070-phi-good-contracts/" rel="bookmark" title="Music Video: 070 Phi &#8211; Good Contracts"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/_hGeMUCs88bbhx2vDHiK1QhjUTFwXYfEeH0SSspmK_RmsoLaZ03uOJSYu69ZRInOV8CXjxa2CdGL6VgS7YQh9adhxKpQqLGOGtI-EICN1wkH95gimd0Xm19xuwFapZJPxYK3Yt2-B2fVlu--K2DIWkOjPr-h-7N5z3zDKjtvYT4nSbOK8K4zgV8NHnXkDVYnFoHmmLlNPyOYVUNLnuNX26VY8TAW5zxloyFjlDjZHcezGv2O-mMJXAVhKiWUkeFrlw5vo0RhA85cVSawiMRGAUainKC-3IuphGJ7YJbDp2sh6b4rgX-Z-_NSDo0MHPLJfmABYoXBScfYgZdC6hCu_9ojUNSur8V_pfhMFVrM2oL5iRcrNTldkUflKz_mKHR41_GEZPgUyAvUUKMeGt1w9xkZ9YPFjYIhlB-voQWT9ym6On4sM2BMJN6SktNZt8qifVtiPHxsZZIaz351BuCVbjvOdQV7HGroemFgiYNXIPQzISIK1f18fd5ngQrk5ZoDVXOwlQ2SnFJRnhbXvW7OTSY4W8HDrGxVPya9HYiGC_66hD9haKFRztIWZfMvF5G-cxvbhZbjEnCrAETuKIRQxRjq69RpK8fwLqAnZc4hs3_pONZAFYxmIEBJajaU6IX8P9rUKvUgExLtR_EflOzAx8SWn0t9Y3Wy=w908-h435-no" alt="" title="Music Video: 070 Phi &#8211; Good Contracts"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/music-video-070-phi-good-contracts/" rel="bookmark" title="Music Video: 070 Phi &#8211; Good Contracts">Music Video: 070 Phi &#8211; Good Contracts</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/music-video-ynw-melly-mama-cry/" rel="bookmark" title="Music Video: YNW Melly &#8211; Mama Cry"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/ogQw1JIIeXNxzDd9429qrHEsufXukXd1AuhHndWzNfF5sflAXpZsyeryBs-rRYKQ1HL9iN-5G-iijAtIJUpEG7MCa4UOLknl3MNAPuwgteh2LrTkWmvHHvLn9YPnuU2NXc5dqsWuj_KWwYa3Rc_QEzwsJdY4ctVQGpblCNQFdP1kmMmRg9K5qfBVzCWwHxojpP9vqRoWU_VWKWTKinLbj7qDoVZhubscww5PmoCLSzHZJsJqwVUHyyQOGsG3uZl84msh-beVTGUTm-GE6gKsL3oSBi9y5HxB-OP0e5uR2GLSj1uEY6pWr6mMzTupjjibEFH43mQ_l0d4wx5EaxW5-eN0lvUFC7WP6RRWP7g94bx1UxKNp7AlAkey4LgqcOz9-9EqxW0gaGHDh3mFOrR03CjJ4cid6yXTQCs0VhDtizMvNe96VWDAr_vkhhfLK7UHQilTrBzzxj6NLcgWcig1fJxcRmJR9jJvz14bqYP31PSWdkY7Ysh3FwTzcCb6yjhYEotabAeB9lxXdFBbzhTSVHq7BrO-jf9sNM5VFC_PoEzOeSEME45aBi-erK_JYnU4GEsS5l2s5-zX6oJLecNgvvRrPjS62y2qoNDYZuBTmZiLQLVBrV6lI2CgZRy9xdP-gSLZmawcheKvpu2yaDzRdlPCFD1WYUMz=w914-h452-no" alt="" title="Music Video: YNW Melly &#8211; Mama Cry"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/music-video-ynw-melly-mama-cry/" rel="bookmark" title="Music Video: YNW Melly &#8211; Mama Cry">Music Video: YNW Melly &#8211; Mama Cry</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/music-video-blueface-ft-cardi-b-thotiana-remix/" rel="bookmark" title="Music Video: Blueface ft. Cardi B &#8211; Thotiana (Remix)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/PT8y2Lc1vyX_8yC7nRtUgqz334GegZstCQpHNFp6iDG2qi0NqyPUywrqX2ALfXSaW9t4Xae67wgVyeGAfdRnbPusg87NqCLTW9AVhVKd5LUmy2Z1KIY6mRr_NEGLndCbn-g1GLKjnOqM0vX-89LVNMIvQm5gz4O4keVgdlsXjyxMX9c8rVvQk5SgfhapK6i7DTxtj4QfsIaRUBxBPUOzBwwCjCdrBoSfjfnxQfrPQoFDA69FrewXLmEpiWDaSVgM3f7ifak7zNVc0cBWqVPo0MLHVLUSz1n92jxgac9I4hAJlaHsGtrLY962a8iDB3BNRqjW5ychEJx1nXV9a-SRPpbZZVfZedWj5ZPL4jZR4tiVLIGI_POHbK-reKhL-yFUrzcbubkb23Cd-K-uy7jrLm4hCirruPFJLQieoasvtUiiMv33F_Drw_nurPogDYiJhkCIgtMD5eEI4Jd9ubTCqpZos68M5KnT7B8X_-dfBgkR5DdczYO-NXwLNjlplYQeC_-5o0twmjI6PP9KrII3ktpNXowc7SRC_bzFQ46H8VcaRSiHrfleM5OxvjaGa1P0oZtwmw7sawFohPDqhhw3o0jdC__Agv5CzT5jt4Hl-Tja6JuMetvcvvLk-RG6KeOnTnmt6dlYqBE2_OT2JSzd9s9hpqBHKUsm=w933-h503-no" alt="" title="Music Video: Blueface ft. Cardi B &#8211; Thotiana (Remix)"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/music-video-blueface-ft-cardi-b-thotiana-remix/" rel="bookmark" title="Music Video: Blueface ft. Cardi B &#8211; Thotiana (Remix)">Music Video: Blueface ft. Cardi B &#8211; Thotiana (Remix)</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/music-video-pressa-longway/" rel="bookmark" title="Music Video: Pressa &#8211; Longway"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/1uCizTShglv_cwHOyg-LVWZBWPNqkUES-9yl9613iRjWPW_APDgiBAtDEnAvJPiPSM2Os6L_sUS5eAUc-hM-Rqng6C9Y6EDyuMaGm6SvaRgdCCobsnerndwTXtS0k5nYw-ueMy4ZXc9UgtbTMZMe0TlmXTccCCO175y3TDg_Jdj0fDfyF8aOojxqgiuaw2gbDIBCviQd-vll5Dw6HQUP7NpP66eugKvHF5RLQLhuTMe-LYuBIjlWGR-Br_NqIdwYqY2RwRwa27c40kBSeqxo-F5mzd1AttOmJ_UNFZ7OnDLMHa123dySfXDgVKXA6O2I6lJqQdXhmWjijckWgY1qI7d-wSGLAipZ6PN2vux579pnYTC8EdhWQ5KDsWhH4Lnb91r3zfWj3hmcx9RmmiUDxfNhNU_UBHbYwunwcKNzQxKu-rFSoSarJwPTwZ4jepA6ewQnOKnkG8AGAFeun1ztLlBcs5hXpZZg56rng_yunRCz_DGfDSlEEkXzKdtEb4OMTi5jpsW4XP7QBoHlm9ff-vMXhYoKMo1Y5Y6_250g7fmdU3Zxg8TJqrApquVD0B2PbcHd1bGFOg6a_-GuDZCranDodErt5Lm2x4NYZXLHOP_Ifw26qNmyRHcj_6v3STXvb55QsPko4WpnbTEctXedLD415qxN3V-y=w889-h479-no" alt="" title="Music Video: Pressa &#8211; Longway"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/music-video-pressa-longway/" rel="bookmark" title="Music Video: Pressa &#8211; Longway">Music Video: Pressa &#8211; Longway</a></h3>            </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_5c68a734ed4be" data-td_block_id="td_uid_3_5c68a734ed4be"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_3_5c68a734ed4be" data-td_block_id="td_uid_3_5c68a734ed4be"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_4_5c68a73500f1d_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_4_5c68a73500f1d" ><script>var block_td_uid_4_5c68a73500f1d = new tdBlock();
block_td_uid_4_5c68a73500f1d.id = "td_uid_4_5c68a73500f1d";
block_td_uid_4_5c68a73500f1d.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"29","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_4_5c68a73500f1d_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_4_5c68a73500f1d.td_column_number = "3";
block_td_uid_4_5c68a73500f1d.block_type = "td_block_mega_menu";
block_td_uid_4_5c68a73500f1d.post_count = "4";
block_td_uid_4_5c68a73500f1d.found_posts = "488";
block_td_uid_4_5c68a73500f1d.header_color = "";
block_td_uid_4_5c68a73500f1d.ajax_pagination_infinite_stop = "";
block_td_uid_4_5c68a73500f1d.max_num_pages = "122";
tdBlocksArray.push(block_td_uid_4_5c68a73500f1d);
</script>            <script>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</script>
<div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_4_5c68a73500f1d" id="td_uid_5_5c68a73502fd4" data-td_block_id="td_uid_4_5c68a73500f1d" data-td_filter_value="" href="http://weuponithiphop.info/category/latest-news/">All</a><a class="mega-menu-sub-cat-td_uid_4_5c68a73500f1d"  id="td_uid_6_5c68a73503141" data-td_block_id="td_uid_4_5c68a73500f1d" data-td_filter_value="69" href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a><a class="mega-menu-sub-cat-td_uid_4_5c68a73500f1d"  id="td_uid_7_5c68a73503319" data-td_block_id="td_uid_4_5c68a73500f1d" data-td_filter_value="80" href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a><a class="mega-menu-sub-cat-td_uid_4_5c68a73500f1d"  id="td_uid_8_5c68a735034ea" data-td_block_id="td_uid_4_5c68a73500f1d" data-td_filter_value="2189" href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a><a class="mega-menu-sub-cat-td_uid_4_5c68a73500f1d"  id="td_uid_9_5c68a7350362f" data-td_block_id="td_uid_4_5c68a73500f1d" data-td_filter_value="10" href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a><a class="mega-menu-sub-cat-td_uid_4_5c68a73500f1d"  id="td_uid_10_5c68a73503744" data-td_block_id="td_uid_4_5c68a73500f1d" data-td_filter_value="130" href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></div></div><div id=td_uid_4_5c68a73500f1d class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/21-savage-turns-himself-in-on-theft-warrant/" rel="bookmark" title="21 Savage Turns Himself In On Theft Warrant"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/7XW8K9WxyS-11xg9huUXIHewaNsgKj2TylXndYqqT3HPl3OPLZUs2jEDImOmIWUHABPrYvPyra2WZxBJz-LSOnPcbxfn_TLg36qJITaeRx4pWQJTwr9yjPgDBBY5MR0IlOKSxAy5emPvQx-LX6jmbq37cTZzi6hdFxMrYEpiDIloAus91zXBMWX-fY6umuS6JJygmQ_8w2C7YLPDa7XM2iKAmV1CNzi5jM-SUGbQ5OdARdludojSoL0dV-JlKDiJNZ7YI2gHfua4raF1pR34YxtmYPNvuMtavtA5D7Ad3jpwCV8T6XSIq016_hKWJEFvGOtU-NAmRao_bteeDfs8rPezl97R7H8LQ-94_H8oipEE-NueOqJD5D69Nf8grqpnyrcvEkyCCO89cMxFr1diuyAzzSAB9tfFxg-sBOSiyaWPX2l9u6OwbHO6LPOKTyRTjHjKMthqCA_pT5I_K8_P8oE1eXhoGAWEhiH5QDwEaU62nV3zgGdX96X5mLx8rc-H2AZkZpRVi36rca16ALbJBqP0LgpRPSCh6H-tm3Q1AUH43l8ZzsSCUGipW6xzaG5M4jo70Yes0SSd_QVs4gdYar5gfOPa0VI4r_clpVO54cPDyKtJumCB0oZWWV1jCH5AZwBjFI_pV_ebntPqijwF8aIhpHUPgj-B=w470-h582-no" alt="" title="21 Savage Turns Himself In On Theft Warrant"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/21-savage-turns-himself-in-on-theft-warrant/" rel="bookmark" title="21 Savage Turns Himself In On Theft Warrant">21 Savage Turns Himself In On Theft Warrant</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/video-21-savage-good-morning-america-interview/" rel="bookmark" title="Video: 21 Savage &#8211; Good Morning America Interview"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/O2AQvaG5CCgD-WUwn5zZbvaStEelaIJ8ljtMW1Kas05Dpp6vw0LMCIWggkBK1esH_F3hflo-aQHkjieo5flhJU5GCjTiLKirIkCg7ShznEGdPhIL6gCSmBvBa_UrPIjnd_G7MIGm_uHR5uD40oXGfvD0FTIsVOLGAdbCQgVdqMa9HJwZsQKRevIA8tmizeArDyW2rpm5D4AIDIsxywPqn_7JZT_S9uon31rp-KiGpkh4SdXSfmcqyLFOpbE8KwBbPxRXoQe3mZt8WDtaUqB6XmxZ8iwi7jSk4GvC6EcOPECfkeZQ_DXTeixwuybxjX2yr5OnDQywsczZg9xkVJZfCShH_PQTF02MP96uG_En7D_NwYEvatrVbjmKgYE7b68IlLE_6wFWJOpQoqFtX7H32pSwT5aGDIF81JLQLc2j_DvPCN3eZqoXZcZ2iAMUVsNyZbRsTinaZb-ibTdgaNWmksZyLVRF11ltx3ugSO0djVvAR8MZZDt1AQQaLKL3u6WGDNN2hPt0Ua-rTn_JzS_roEXIoTsiAvOYwj3H0OGVqEEYhDaszJVgZa1WG4KsURD3uC6lvjPIe0QuLHwEQP15umo7rRpnkyxeOLpPAtm24g-BslW6A2j1R-JfouB3xnp6zJzjFLju3oE-Acj-kZgd3eFVSHxAhsK3=w620-h345-no" alt="" title="Video: 21 Savage &#8211; Good Morning America Interview"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/video-21-savage-good-morning-america-interview/" rel="bookmark" title="Video: 21 Savage &#8211; Good Morning America Interview">Video: 21 Savage &#8211; Good Morning America Interview</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/15/video-kanye-west-has-kenny-g-to-play-for-kim-kardashian-for-valentines-day/" rel="bookmark" title="Video: Kanye West Has Kenny G To Play For Kim Kardashian For Valentine’s Day"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/zBO8Dln0tpExLGtUdsttUqXsAIv9jyNzEHieUpqdJ0VRZKV59MuIFrzK8Un5XyB5ieWfYnT0JKJs6yTMBj84scMTK6psXRN_cpcfM-UqOUmYBnDuTMdLO37SYmN9607QmgvCXhCecgSxNdFNlWHgC97fORUH9wW9dWCQaPkh0j96n-rnZ5YOj3Rg2V2ZTa0yEcd2LBw9xB64Mz2kXkSYzTDpIgjuB3nAOT7Xu7JWavOThAfH1GYVyVcguQH7F_Q9wxIf7kj2bP3d03qfIoJl0TwOt2FikA51MNd1Gi_kivwAWAGpojfQka-eQNQ-2ZaQM0j0jmJXl0bFpnzLZL5m1fhPtlINYIcAPIl0-WAf3WUgA4D_v2LQzl3TexuRlcFAwDB7azxsOEmg8bzMGS9RFw5ls-BBpPQ2NtO1uUFeTqD2vsZeCUqWsYZA9IHvB0HH-ou3FTd1r60wCCQZIDeTplbs7zdHzNz47vKJDES3CMuNNf56T8VHGIrVpJgVwEiluM6upc5kJ1wUmSUSYlvxhE9AYW35QXWdZqtWsw6br0sbAEkiM1zHmN5Q89zdXm--ifog4h8Tjm2R-MxdirYgIqxRtUrePRZ0g4uTMNfqWKiioHxSro87-piZwovDDJYr0qF3DfqHJ7v2otRiV6nHRzXVQa1MvC5D=w505-h673-no" alt="" title="Video: Kanye West Has Kenny G To Play For Kim Kardashian For Valentine’s Day"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/15/video-kanye-west-has-kenny-g-to-play-for-kim-kardashian-for-valentines-day/" rel="bookmark" title="Video: Kanye West Has Kenny G To Play For Kim Kardashian For Valentine’s Day">Video: Kanye West Has Kenny G To Play For Kim Kardashian&#8230;</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/15/kodak-black-announces-dying-to-live-tour/" rel="bookmark" title="Kodak Black Announces &#8216;Dying To Live&#8217; Tour"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/UcN7uHdIbkQiJ5XjqNtuho7s6W522OHmXoD1sLSSGnomfdqZXLPm8rJz8Z8LgI1fON4c0Xho1xArRSYuo8cJPYoCUly5HCYzrz1GX5pikdOJYcilcxuoI-Xxj1G2a3bz7glCeWPfqs11dnyF7Zp9TSs_3a7ILaJYDxgQ_YyOVzrT0MCXKTzDV8Y8kwwMy05LnQHLYp_C6rGofpsbKS_V7RmQKa3R-9v9lGfWoDpiv7PVwRt7tck68CgNxcJA2jGjd1AMl6Y_XqXZpiGbOz199kB67hMHez0_fOOpxWJKIMABvU6SxDAneiKCuSr0anwA1xhLVied1ujsAEsIpcZgSOO_Q4xhGUK5veHJaEsx-tt-8_RN_7fHEE18x-nLWwJhbBRiog_1UWGG7_55pB4wwGbhRdg52Od7KRKedhYvDaAKlZ_zm3cg-q2w3Gd_X4f-Z1i3VdptMCUPP_HztV60xQbzMdtWS5iOA8mSk3tx5bUT-EUJHLNRfbQ_QrhnwN-WGag3Gszp357xmp3j6hmZnPv-3ws9yuXX7oGKLGACGjJMgcvhVItmfI6VaxiwK5HoWNsLuhFrJVSp0VWoL3tOx3kgjufYGqLUdPwRyB8WJgMsuMnchG0jRY-bMNaP63c7WgLUZfJ4JQhScWcZkTzrvhft9Yn_4kxN=w620-h535-no" alt="" title="Kodak Black Announces &#8216;Dying To Live&#8217; Tour"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/15/kodak-black-announces-dying-to-live-tour/" rel="bookmark" title="Kodak Black Announces &#8216;Dying To Live&#8217; Tour">Kodak Black Announces &#8216;Dying To Live&#8217; Tour</a></h3>            </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_4_5c68a73500f1d" data-td_block_id="td_uid_4_5c68a73500f1d"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_4_5c68a73500f1d" data-td_block_id="td_uid_4_5c68a73500f1d"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_11_5c68a73531602_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_11_5c68a73531602" ><script>var block_td_uid_11_5c68a73531602 = new tdBlock();
block_td_uid_11_5c68a73531602.id = "td_uid_11_5c68a73531602";
block_td_uid_11_5c68a73531602.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"77","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_11_5c68a73531602_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_11_5c68a73531602.td_column_number = "3";
block_td_uid_11_5c68a73531602.block_type = "td_block_mega_menu";
block_td_uid_11_5c68a73531602.post_count = "4";
block_td_uid_11_5c68a73531602.found_posts = "152";
block_td_uid_11_5c68a73531602.header_color = "";
block_td_uid_11_5c68a73531602.ajax_pagination_infinite_stop = "";
block_td_uid_11_5c68a73531602.max_num_pages = "38";
tdBlocksArray.push(block_td_uid_11_5c68a73531602);
</script>            <script>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</script>
<div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_11_5c68a73531602" id="td_uid_12_5c68a73532af7" data-td_block_id="td_uid_11_5c68a73531602" data-td_filter_value="" href="http://weuponithiphop.info/category/fashion/">All</a><a class="mega-menu-sub-cat-td_uid_11_5c68a73531602"  id="td_uid_13_5c68a73532bef" data-td_block_id="td_uid_11_5c68a73531602" data-td_filter_value="76" href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></div></div><div id=td_uid_11_5c68a73531602 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/04/air-jordan-1-wmns-retro-high-og-unc-blue-chill/" rel="bookmark" title="Air Jordan 1 WMNS Retro High OG UNC (Blue Chill)"><img width="218" height="150" class="entry-thumb" src="https://pribitre-cdn.sirv.com/WP_weuponithiphop.info/Air-Jordan-1-WMNS-Retro-High-OG-UNC-Patent-Blue-Chill.jpg?scale.width=218&#038;scale.height=150&#038;scale.option=fill&#038;cw=218&#038;ch=150&#038;cx=center&#038;cy=center" alt="" title="Air Jordan 1 WMNS Retro High OG UNC (Blue Chill)"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/04/air-jordan-1-wmns-retro-high-og-unc-blue-chill/" rel="bookmark" title="Air Jordan 1 WMNS Retro High OG UNC (Blue Chill)">Air Jordan 1 WMNS Retro High OG UNC (Blue Chill)</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/04/nike-zoom-rookie-galaxy-2019/" rel="bookmark" title="Nike Zoom Rookie Galaxy 2019"><img width="218" height="150" class="entry-thumb" src="https://pribitre-cdn.sirv.com/WP_weuponithiphop.info/Nike-Zoom-Rookie-Galaxy-2019-1.jpg?scale.width=218&#038;scale.height=150&#038;scale.option=fill&#038;cw=218&#038;ch=150&#038;cx=center&#038;cy=center" alt="" title="Nike Zoom Rookie Galaxy 2019"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/04/nike-zoom-rookie-galaxy-2019/" rel="bookmark" title="Nike Zoom Rookie Galaxy 2019">Nike Zoom Rookie Galaxy 2019</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/29/nike-zoom-lebron-3-white-navy/" rel="bookmark" title="Nike Zoom LeBron 3 White Navy"><img width="218" height="150" class="entry-thumb" src="https://pribitre-cdn.sirv.com/WP_weuponithiphop.info/Nike-Zoom-LeBron-3-White-Navy-2.jpg?scale.width=218&#038;scale.height=150&#038;scale.option=fill&#038;cw=218&#038;ch=150&#038;cx=center&#038;cy=center" alt="" title="Nike Zoom LeBron 3 White Navy"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/29/nike-zoom-lebron-3-white-navy/" rel="bookmark" title="Nike Zoom LeBron 3 White Navy">Nike Zoom LeBron 3 White Navy</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/29/release-date-nike-air-max-98-wild-west/" rel="bookmark" title="Nike Air Max 98 Wild West"><img width="218" height="150" class="entry-thumb" src="https://pribitre-cdn.sirv.com/WP_weuponithiphop.info/Nike-Air-Max-98-Wild-West.jpg?scale.width=218&#038;scale.height=150&#038;scale.option=fill&#038;cw=218&#038;ch=150&#038;cx=center&#038;cy=center" alt="" title="Nike Air Max 98 Wild West"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/29/release-date-nike-air-max-98-wild-west/" rel="bookmark" title="Nike Air Max 98 Wild West">Nike Air Max 98 Wild West</a></h3>            </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_11_5c68a73531602" data-td_block_id="td_uid_11_5c68a73531602"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_11_5c68a73531602" data-td_block_id="td_uid_11_5c68a73531602"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-2515"><a href="http://weuponithiphop.info/category/editors-picks/">Editor&#8217;s Picks</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_14_5c68a73543327_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_14_5c68a73543327" ><script>var block_td_uid_14_5c68a73543327 = new tdBlock();
block_td_uid_14_5c68a73543327.id = "td_uid_14_5c68a73543327";
block_td_uid_14_5c68a73543327.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"118","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_14_5c68a73543327_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_14_5c68a73543327.td_column_number = "3";
block_td_uid_14_5c68a73543327.block_type = "td_block_mega_menu";
block_td_uid_14_5c68a73543327.post_count = "5";
block_td_uid_14_5c68a73543327.found_posts = "489";
block_td_uid_14_5c68a73543327.header_color = "";
block_td_uid_14_5c68a73543327.ajax_pagination_infinite_stop = "";
block_td_uid_14_5c68a73543327.max_num_pages = "98";
tdBlocksArray.push(block_td_uid_14_5c68a73543327);
</script><div id=td_uid_14_5c68a73543327 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/music-video-dizzy-wright-ft-eric-bellinger-picture-perfect/" rel="bookmark" title="Music Video: Dizzy Wright ft. Eric Bellinger &#8211; Picture Perfect"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/nxVARw-JBVf8rO_l2uve6KNCfSIjAarkkbgyS2qqUeEDzGo5KjtfQnkjtJ10yrRonj_bMB2RzaMri0E_8s6vSp7HIa1iI2FFJtvyIAFwfktklyBdR_pw0pDWF2Zd9O-q85DAFCpbHgBrppZ3z5mZBpbeY11h8hsdAdjWSHwMcQJc4k23gKoD6R47pbCWcz0UWVGosUP0xE_k-B4LSRIwspsarGHlvkSCIV-pFcthBxxFZsrNptnhQfEzc6xuRFTZPbm4PWAeyYj_4gCwyBbjnRzBqo5eCzJyFPPv8vO1p6i9fgPwQ6sJ_4RDz22q_4drmWenRmSI3Hrc3LznTbdNiERDq6V3eIkw7ZMfMh3a8Aso6tJd09HLZtzzfBZDPK7NRSxnK8d1gwVR2AtqWXLEG1oAnDudYsK52qIh-VVsMsIgqza_R-mRcOSgL1aAg4s6ZmV_5h4n-FLbbhP23dfxNBHb1jjjAwL5kLK_zZSafXLTNgt_BQJ9-FZOCu1AYBMIL0xxAC3Pfg04gJZbMGv_jEIrnKFdQ2plyNYTRZ4wCr5V696KY-whFdU34YpgsYM8SaoHJZ68XvG2LQcJTCszcXEecyHZkPSls_UdnTLRDYiDX3_LVOkss-_j1MnVinoUCBsXDL_aStd8QG1cSW5KXOHE-lOaZSR8=w954-h452-no" alt="" title="Music Video: Dizzy Wright ft. Eric Bellinger &#8211; Picture Perfect"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/music-video-dizzy-wright-ft-eric-bellinger-picture-perfect/" rel="bookmark" title="Music Video: Dizzy Wright ft. Eric Bellinger &#8211; Picture Perfect">Music Video: Dizzy Wright ft. Eric Bellinger &#8211; Picture Perfect</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/music-video-ynw-melly-mama-cry/" rel="bookmark" title="Music Video: YNW Melly &#8211; Mama Cry"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/ogQw1JIIeXNxzDd9429qrHEsufXukXd1AuhHndWzNfF5sflAXpZsyeryBs-rRYKQ1HL9iN-5G-iijAtIJUpEG7MCa4UOLknl3MNAPuwgteh2LrTkWmvHHvLn9YPnuU2NXc5dqsWuj_KWwYa3Rc_QEzwsJdY4ctVQGpblCNQFdP1kmMmRg9K5qfBVzCWwHxojpP9vqRoWU_VWKWTKinLbj7qDoVZhubscww5PmoCLSzHZJsJqwVUHyyQOGsG3uZl84msh-beVTGUTm-GE6gKsL3oSBi9y5HxB-OP0e5uR2GLSj1uEY6pWr6mMzTupjjibEFH43mQ_l0d4wx5EaxW5-eN0lvUFC7WP6RRWP7g94bx1UxKNp7AlAkey4LgqcOz9-9EqxW0gaGHDh3mFOrR03CjJ4cid6yXTQCs0VhDtizMvNe96VWDAr_vkhhfLK7UHQilTrBzzxj6NLcgWcig1fJxcRmJR9jJvz14bqYP31PSWdkY7Ysh3FwTzcCb6yjhYEotabAeB9lxXdFBbzhTSVHq7BrO-jf9sNM5VFC_PoEzOeSEME45aBi-erK_JYnU4GEsS5l2s5-zX6oJLecNgvvRrPjS62y2qoNDYZuBTmZiLQLVBrV6lI2CgZRy9xdP-gSLZmawcheKvpu2yaDzRdlPCFD1WYUMz=w914-h452-no" alt="" title="Music Video: YNW Melly &#8211; Mama Cry"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/music-video-ynw-melly-mama-cry/" rel="bookmark" title="Music Video: YNW Melly &#8211; Mama Cry">Music Video: YNW Melly &#8211; Mama Cry</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/new-music-meyhem-lauren-the-alchemist-still-playing-celo/" rel="bookmark" title="New Music: Meyhem Lauren &#038; The Alchemist &#8211; Still Playing Celo"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/rO_03NZ0s2Ts5EYLM09t8okvjAORCyJadvdxFajxqaoEzsn4BWGTZMr1PDbYXByZeW17ZjsTyls4HPsMeKhomse6mSc4bdEdp9lVfBUn_L_4pwTQbF5m3kjPXCs3HlzEX3T5SO4pIBF0xRxhAq6DsRkR2H-RjthpjIxk_xmB05hGLMXX2JsvHQcrN8IKG4DqTWH5UBt4DYmTs1u8-uymUnA1IYyl-kQ7OOE1AQ1bgjJXeI7x4GQzeQlBEr0KAzZ6hcTOv09pK_pA2gjc4IEItZOoAZ2RHCu7TwXJOIpmqvrmt7WjOqIl3bm6q_H25QmRd0tlIqz637kjWlaCYJYWTCZ5V6pD4P8tqag8WTo2u32CJiW2mY7Qsuv0-jd74EG-n4FJK6LJjgzW7_x6BU03PvMDltv-pF1qoWuLyTRlqtr9LPKaqd6pJ4Rg6G7HtLQKI4ymsUs6WeQUaAgP_ga4pGLb0VvJxkm8P3Icyrsuygry2Jx7Pmk6UpAnG21DnP14x2UlrZp9kwszYT1mcVZlQbNM9zxF8MQozoIHrPzJDhQH6_VrKm9Smm9n9cqNIrx5vvCGPzSTO-GwpXnR-E6nagV9nnw732-r89m_rm3BMhfkorGBWdNbV0ZnXeiRg9z9Xqlaon1pf9lqbjCc9uKERSC33It1lBlQ=s673-no" alt="" title="New Music: Meyhem Lauren &#038; The Alchemist &#8211; Still Playing Celo"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/new-music-meyhem-lauren-the-alchemist-still-playing-celo/" rel="bookmark" title="New Music: Meyhem Lauren &#038; The Alchemist &#8211; Still Playing Celo">New Music: Meyhem Lauren &#038; The Alchemist &#8211; Still Playing Celo</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/15/new-music-international-jones-appreciated-thank-you/" rel="bookmark" title="New Music: International Jones &#8211; Appreciated (Thank You)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/k8MIvN__Fdn-2AdhyeH7fGmowD-shhz-qQVcXq0-UTOhR9QM8cPAYtEU3ob-4ymDLz0vWZ_a5FYb8VoUtnboE_8r3h1DhXV8tAdwO1_cLJxnFoAKHu5y5Je2wC2MsjIYM4hossM8GKesxRWL-iqWCli7a2TwUXH8X71MobSRSaw1oE3uT38OD0dLVO3uATlALULIO2bNH6e2Jnsb-x44F5pb_kGQy8YXFc6x43pSNt2aOm4D6-T1cuz0nl4hrNIJGq0UDzRUlFAO92DwTdRXIEF-5bXOQF33UB0csGAAQY54UDA_pNwYctRN9ISLUz0wBdMHTWEECyKO1AoD22xuSPogNnIPmpRMBqSgN-SF69le7IQXLf1Oc22kQKGXB4ESXjp6gyOrsGskWlz_z-uYPd66wA5c0HCS7Fy4SZlZDt7Nlfrb8vaj4g_3JqEZfh3xt7_GR-jJKzqIbqLtZD6qUycl0EQpHzPCZHf5SMqs9LCBxLphIrTQRJ8jOkizDkW9vfLzmHS2tP25H_qp-juyqhZggrBUyE-MpsjnusLusWBktk1HTC0SsmEqL2lm7vLElJB65hJDWxs5ngrXjdAeh_4eFlrdnoINyMrM0qJS7wWGWmSvjrPQolDv8r-IU7ZhaQvME68NAj5T0la2ipjd_b-LDLP8ge5t=s672-no" alt="" title="New Music: International Jones &#8211; Appreciated (Thank You)"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/15/new-music-international-jones-appreciated-thank-you/" rel="bookmark" title="New Music: International Jones &#8211; Appreciated (Thank You)">New Music: International Jones &#8211; Appreciated (Thank You)</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/15/music-video-chip-tha-ripper-2-much-ass/" rel="bookmark" title="Music Video: Chip Tha Ripper &#8211; 2 Much Ass"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/wFsD5YXgkAMpp3lj88xxVlQ5xPBY5PnZV16rEfzepZgbbB3tR39tgfi8Rq78erYZKjW8fRbf9eSwMDJ_b3bnPMhrXnNIprLhlNfhL3dHTea9W3qs_6gQbjX_ilf4ekhGtZgWx9KVzsgY_uYFPqFojhzn2df3E_2RbE8DqFxOJuycvUyE-rBH8P4wc9gayc6SrKw2pZqte-0Xl5SZcMJBEP0XBPzewMbQjAdn6zTqp4TsBIOvEypYGW0D_NGHcYWJtWS7VvD_q8EpO3PhgFY3DGYy2wK0A6IZMwOVtsbR7UwQqKj9dzEMAmG2bnb3SwoBSN7IZ9efWl-DgvzF3Sc35eu1TsPQQzjN-1cGb33mggrn5YNINTPKk2umZ7rHf-DO6ia02nc8d5NQtbrqF6wcV7u03WDRuuuFM6IRsHlQ4Ni738ndf8WoC3BtiEjAuIhY33498XjzW61rprbOhlpIDve55WmaEAPX82drp_sDIebyeHc03qBh3Ax_G6pRCDgyckHowX-AeDaIkUjw7cOTD8iYyxIQRn9gx1U_BV4OdFNYP-zVouPHLu3rrswk9bhF9Ok8_w2kCuhDTRR_ilGPO53L9H5_P1PnpoZYoVsndkpZEzXCCFQ33723zEO4u1YuOOAiy5J9ZKVHkymgutzJf8pMEG4ZRH4y=w955-h508-no" alt="" title="Music Video: Chip Tha Ripper &#8211; 2 Much Ass"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/15/music-video-chip-tha-ripper-2-much-ass/" rel="bookmark" title="Music Video: Chip Tha Ripper &#8211; 2 Much Ass">Music Video: Chip Tha Ripper &#8211; 2 Much Ass</a></h3>            </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_14_5c68a73543327" data-td_block_id="td_uid_14_5c68a73543327"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_14_5c68a73543327" data-td_block_id="td_uid_14_5c68a73543327"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees/">Shop</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
</ul></div></div>
<div class="td-search-wrapper">
<div id="td-top-search">
<!-- Search -->
<div class="header-search-wrap">
<div class="dropdown header-search">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
<a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
</div>
</div>
</div>
<div class="header-search-wrap">
<div class="dropdown header-search">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="http://weuponithiphop.info/">
<div role="search" class="td-head-form-search-wrap">
<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
</div>
</div>            </div>
</div>
</div>
<div class="td-banner-wrap-full">
<div class="td-header-container td-header-row td-header-header">
<div class="td-header-sp-recs">
<div class="td-header-rec-wrap">
</div>            </div>
</div>
</div>
</div><div class="td-main-content-wrap">
<div class="td-container td-post-template-default ">
<div class="td-crumb-container"><div class="entry-crumbs"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="" class="entry-crumb" itemprop="url" href="http://weuponithiphop.info/"><span itemprop="title">Home</span></a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="View all posts in Editor's Picks" class="entry-crumb" itemprop="url" href="http://weuponithiphop.info/category/editors-picks/"><span itemprop="title">Editor's Picks</span></a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last" itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><meta itemprop="title" content = "Music Video: YNW Melly &#8211; Mama Cry"><meta itemprop="url" content = "http://weuponithiphop.info/2019/02/16/music-video-ynw-melly-mama-cry/">Music Video: YNW Melly &#8211; Mama Cry</span></div></div>
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<article id="post-24198" class="post-24198 post type-post status-publish format-standard has-post-thumbnail hentry category-editors-picks category-music-video tag-mama-cry tag-ynw-melly" itemscope itemtype="http://schema.org/Article">
<div class="td-post-header">
<ul class="td-category"><li class="entry-category"><a  href="http://weuponithiphop.info/category/editors-picks/">Editor's Picks</a></li><li class="entry-category"><a  href="http://weuponithiphop.info/category/music-video/">Music Video</a></li></ul>
<header class="td-post-title">
<h1 class="entry-title">Music Video: YNW Melly &#8211; Mama Cry</h1>
<div class="td-module-meta-info">
<div class="td-post-author-name">By <a href="http://weuponithiphop.info/author/cyclone/">cyclone</a> - </div>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-02-16T18:46:07+00:00" >February 16, 2019</time></span>                    <div class="td-post-comments"><a href="http://weuponithiphop.info/2019/02/16/music-video-ynw-melly-mama-cry/#respond"><i class="td-icon-comments"></i>0</a></div>                                    </div>
</header>
</div>
<div class="td-post-content">
<div class="td-post-featured-image"><a href="https://lh3.googleusercontent.com/ogQw1JIIeXNxzDd9429qrHEsufXukXd1AuhHndWzNfF5sflAXpZsyeryBs-rRYKQ1HL9iN-5G-iijAtIJUpEG7MCa4UOLknl3MNAPuwgteh2LrTkWmvHHvLn9YPnuU2NXc5dqsWuj_KWwYa3Rc_QEzwsJdY4ctVQGpblCNQFdP1kmMmRg9K5qfBVzCWwHxojpP9vqRoWU_VWKWTKinLbj7qDoVZhubscww5PmoCLSzHZJsJqwVUHyyQOGsG3uZl84msh-beVTGUTm-GE6gKsL3oSBi9y5HxB-OP0e5uR2GLSj1uEY6pWr6mMzTupjjibEFH43mQ_l0d4wx5EaxW5-eN0lvUFC7WP6RRWP7g94bx1UxKNp7AlAkey4LgqcOz9-9EqxW0gaGHDh3mFOrR03CjJ4cid6yXTQCs0VhDtizMvNe96VWDAr_vkhhfLK7UHQilTrBzzxj6NLcgWcig1fJxcRmJR9jJvz14bqYP31PSWdkY7Ysh3FwTzcCb6yjhYEotabAeB9lxXdFBbzhTSVHq7BrO-jf9sNM5VFC_PoEzOeSEME45aBi-erK_JYnU4GEsS5l2s5-zX6oJLecNgvvRrPjS62y2qoNDYZuBTmZiLQLVBrV6lI2CgZRy9xdP-gSLZmawcheKvpu2yaDzRdlPCFD1WYUMz=w914-h452-no" data-caption=""><img width="" height="" class="entry-thumb td-modal-image" src="" alt="" title=""/></a></div>
<p><img class="aligncenter size-full" src="https://lh3.googleusercontent.com/ogQw1JIIeXNxzDd9429qrHEsufXukXd1AuhHndWzNfF5sflAXpZsyeryBs-rRYKQ1HL9iN-5G-iijAtIJUpEG7MCa4UOLknl3MNAPuwgteh2LrTkWmvHHvLn9YPnuU2NXc5dqsWuj_KWwYa3Rc_QEzwsJdY4ctVQGpblCNQFdP1kmMmRg9K5qfBVzCWwHxojpP9vqRoWU_VWKWTKinLbj7qDoVZhubscww5PmoCLSzHZJsJqwVUHyyQOGsG3uZl84msh-beVTGUTm-GE6gKsL3oSBi9y5HxB-OP0e5uR2GLSj1uEY6pWr6mMzTupjjibEFH43mQ_l0d4wx5EaxW5-eN0lvUFC7WP6RRWP7g94bx1UxKNp7AlAkey4LgqcOz9-9EqxW0gaGHDh3mFOrR03CjJ4cid6yXTQCs0VhDtizMvNe96VWDAr_vkhhfLK7UHQilTrBzzxj6NLcgWcig1fJxcRmJR9jJvz14bqYP31PSWdkY7Ysh3FwTzcCb6yjhYEotabAeB9lxXdFBbzhTSVHq7BrO-jf9sNM5VFC_PoEzOeSEME45aBi-erK_JYnU4GEsS5l2s5-zX6oJLecNgvvRrPjS62y2qoNDYZuBTmZiLQLVBrV6lI2CgZRy9xdP-gSLZmawcheKvpu2yaDzRdlPCFD1WYUMz=w914-h452-no" alt="YNW Melly - Mama Cry" width="914" height="452" /></p>
<p><strong>YNW Melly</strong> is currently in jail facing double homicide charges and now the official <a href="http://weuponithiphop.info/tag/video/">video</a> for his track <strong>“Mama Cry”</strong> is released. Th video was shot as <strong>Melly</strong> <a href="http://weuponithiphop.info/tag/turns/">turns</a> himself in to authorities and features his mother holding photographs of him as a child. Directed by <strong>Gabriel Hart</strong> and <strong>Kajal</strong>.</p>
<p>You can download <em><strong>I Am You</strong></em> now on <a href="https://geo.itunes.apple.com/us/album/i-am-you/1419601184?mt=1&amp;app=music&amp;at=11l4Qg&amp;ct=iamyou" target="_blank" rel="noopener">iTunes</a>/<a href="https://play.google.com/store/music/album/YNW_Melly_I_AM_YOU?id=Brs5cfww3tr7biuipdvotpdkjre">Google Play</a>.</p>
<p><iframe src="https://www.youtube.com/embed/NGbUsgG_48k" width="620" height="350" frameborder="0" allowfullscreen="allowfullscreen" data-mce-fragment="1"></iframe></p>
<div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="http://weuponithiphop.info/2019/02/16/music-video-ynw-melly-mama-cry/" data-a2a-title="Music Video: YNW Melly – Mama Cry"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F02%2F16%2Fmusic-video-ynw-melly-mama-cry%2F&amp;linkname=Music%20Video%3A%20YNW%20Melly%20%E2%80%93%20Mama%20Cry" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F02%2F16%2Fmusic-video-ynw-melly-mama-cry%2F&amp;linkname=Music%20Video%3A%20YNW%20Melly%20%E2%80%93%20Mama%20Cry" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_google_plus" href="https://www.addtoany.com/add_to/google_plus?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F02%2F16%2Fmusic-video-ynw-melly-mama-cry%2F&amp;linkname=Music%20Video%3A%20YNW%20Melly%20%E2%80%93%20Mama%20Cry" title="Google+" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F02%2F16%2Fmusic-video-ynw-melly-mama-cry%2F&amp;linkname=Music%20Video%3A%20YNW%20Melly%20%E2%80%93%20Mama%20Cry" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F02%2F16%2Fmusic-video-ynw-melly-mama-cry%2F&amp;linkname=Music%20Video%3A%20YNW%20Melly%20%E2%80%93%20Mama%20Cry" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_tumblr" href="https://www.addtoany.com/add_to/tumblr?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F02%2F16%2Fmusic-video-ynw-melly-mama-cry%2F&amp;linkname=Music%20Video%3A%20YNW%20Melly%20%E2%80%93%20Mama%20Cry" title="Tumblr" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_reddit" href="https://www.addtoany.com/add_to/reddit?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F02%2F16%2Fmusic-video-ynw-melly-mama-cry%2F&amp;linkname=Music%20Video%3A%20YNW%20Melly%20%E2%80%93%20Mama%20Cry" title="Reddit" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_flipboard" href="https://www.addtoany.com/add_to/flipboard?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F02%2F16%2Fmusic-video-ynw-melly-mama-cry%2F&amp;linkname=Music%20Video%3A%20YNW%20Melly%20%E2%80%93%20Mama%20Cry" title="Flipboard" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F02%2F16%2Fmusic-video-ynw-melly-mama-cry%2F&amp;linkname=Music%20Video%3A%20YNW%20Melly%20%E2%80%93%20Mama%20Cry" title="Copy Link" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div>        </div>
<footer>
<div class="td-post-source-tags">
<ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="http://weuponithiphop.info/tag/mama-cry/">Mama Cry</a></li><li><a href="http://weuponithiphop.info/tag/ynw-melly/">YNW Melly</a></li></ul>            </div>
<div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="http://weuponithiphop.info/2019/02/16/music-video-blueface-ft-cardi-b-thotiana-remix/">Music Video: Blueface ft. Cardi B &#8211; Thotiana (Remix)</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="http://weuponithiphop.info/2019/02/16/music-video-070-phi-good-contracts/">Music Video: 070 Phi &#8211; Good Contracts</a></div></div></div>            <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="http://weuponithiphop.info/author/cyclone/">cyclone</a></span></div>	        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="cyclone"></span><meta itemprop="datePublished" content="2019-02-16T18:46:07+00:00"><meta itemprop="dateModified" content="2019-02-16T18:46:07+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://weuponithiphop.info/2019/02/16/music-video-ynw-melly-mama-cry/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://pribitre-cdn.sirv.com/WP_weuponithiphop.info/weuponit-glow-logo-6.png"></span><meta itemprop="name" content="WeUpOnIt"></span><meta itemprop="headline " content="Music Video: YNW Melly - Mama Cry"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://lh3.googleusercontent.com/ogQw1JIIeXNxzDd9429qrHEsufXukXd1AuhHndWzNfF5sflAXpZsyeryBs-rRYKQ1HL9iN-5G-iijAtIJUpEG7MCa4UOLknl3MNAPuwgteh2LrTkWmvHHvLn9YPnuU2NXc5dqsWuj_KWwYa3Rc_QEzwsJdY4ctVQGpblCNQFdP1kmMmRg9K5qfBVzCWwHxojpP9vqRoWU_VWKWTKinLbj7qDoVZhubscww5PmoCLSzHZJsJqwVUHyyQOGsG3uZl84msh-beVTGUTm-GE6gKsL3oSBi9y5HxB-OP0e5uR2GLSj1uEY6pWr6mMzTupjjibEFH43mQ_l0d4wx5EaxW5-eN0lvUFC7WP6RRWP7g94bx1UxKNp7AlAkey4LgqcOz9-9EqxW0gaGHDh3mFOrR03CjJ4cid6yXTQCs0VhDtizMvNe96VWDAr_vkhhfLK7UHQilTrBzzxj6NLcgWcig1fJxcRmJR9jJvz14bqYP31PSWdkY7Ysh3FwTzcCb6yjhYEotabAeB9lxXdFBbzhTSVHq7BrO-jf9sNM5VFC_PoEzOeSEME45aBi-erK_JYnU4GEsS5l2s5-zX6oJLecNgvvRrPjS62y2qoNDYZuBTmZiLQLVBrV6lI2CgZRy9xdP-gSLZmawcheKvpu2yaDzRdlPCFD1WYUMz=w914-h452-no"><meta itemprop="width" content="800"><meta itemprop="height" content="600"></span>        </footer>
</article> <!-- /.post -->
<div class="td_block_wrap td_block_related_posts td_uid_16_5c68a7364d3f8_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_16_5c68a7364d3f8" ><script>var block_td_uid_16_5c68a7364d3f8 = new tdBlock();
block_td_uid_16_5c68a7364d3f8.id = "td_uid_16_5c68a7364d3f8";
block_td_uid_16_5c68a7364d3f8.atts = '{"limit":6,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_custom_related","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_16_5c68a7364d3f8_rand","offset":"","css":"","live_filter":"cur_post_same_tags","live_filter_cur_post_id":24198,"live_filter_cur_post_author":"1"}';
block_td_uid_16_5c68a7364d3f8.td_column_number = "3";
block_td_uid_16_5c68a7364d3f8.block_type = "td_block_related_posts";
block_td_uid_16_5c68a7364d3f8.post_count = "6";
block_td_uid_16_5c68a7364d3f8.found_posts = "8";
block_td_uid_16_5c68a7364d3f8.header_color = "";
block_td_uid_16_5c68a7364d3f8.ajax_pagination_infinite_stop = "";
block_td_uid_16_5c68a7364d3f8.max_num_pages = "2";
tdBlocksArray.push(block_td_uid_16_5c68a7364d3f8);
</script><h4 class="td-related-title"><a id="td_uid_17_5c68a7364ed8f" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_16_5c68a7364d3f8" href="#">RELATED ARTICLES</a><a id="td_uid_18_5c68a7364edce" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_16_5c68a7364d3f8" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_16_5c68a7364d3f8 class="td_block_inner">
<div class="td-related-row">
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/10/music-video-ynw-melly-gang-first-day-out/" rel="bookmark" title="Music Video: YNW Melly – Gang (First Day Out)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/gKBIjhvB7wlaTZlMCXotyg1Y3o4oUdGzROLMiJ3WaUxGQ6CFTc8zbybzCvYibCe9qPHGeMk5G-Vw0pnGtwcsAaDMvba4SfGFLkp-Y9jPrZuv1ARxJ66qlCSpzVHMxPFawHR66L29LQF9RKvmDsWPThGLO9vTUI5tCvNnAghKOPFLCFjnMeR3CmTfkXrO8lQMFptnrD51HQoTxgRInPATb14HihP4oeVNZdQ-axssqSwvCwjoBfogW4oOmNpu5V_v_jQp-bam7mZg_8YEsU_peLRfonEk6W8LBuF-cPb6ouUflKjqnfM7slUrfX8sptSfCAfFMiNweH0FR9rniitirzSJZgl4Is9JQZPjxTXsuvqAkcJFc3WbX7bRpGCxccJn4OHgXePv0uSWvXtHuw25PSciFaO9ZJzt-M5BanPUtsl1Fagcs4bsIGEeizrtYhgc_dyxWkSbmLvrBpUhD29wYD7pffnmI5GkyRtY38oCEGjkhJ6yH6jNIQmP-tA6UTcBAqiFMnBnkHVPVyfqPxNXv7NzmPvr5xuiB-0e2A6hLpHdaCjGJj_GfGe0WXaQ1ci5B6ISQOaGPoPLG_jq1DHxr-_x7RtB_BEHiMsTeNfFKBW_juCHv5AkIkMKSDtb3hIT-Je-9K30CiBqIOSxj2BX3KNcRKi7b9EG=w885-h449-no" alt="" title="Music Video: YNW Melly – Gang (First Day Out)"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/10/music-video-ynw-melly-gang-first-day-out/" rel="bookmark" title="Music Video: YNW Melly – Gang (First Day Out)">Music Video: YNW Melly – Gang (First Day Out)</a></h3>            </div>
</div>
</div> <!-- ./td-related-span4 -->
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/07/ynw-melly-announces-we-all-shine-tour-with-asian-doll/" rel="bookmark" title="YNW Melly Announces &#8216;We All Shine&#8217; Tour With Asian Doll"><img width="218" height="150" class="entry-thumb" src="https://pribitre-cdn.sirv.com/YNW%20Melly%20Announces%20We%20All%20Shine%20Tour%20With%20Asian%20Doll.jpg" alt="" title="YNW Melly Announces &#8216;We All Shine&#8217; Tour With Asian Doll"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/07/ynw-melly-announces-we-all-shine-tour-with-asian-doll/" rel="bookmark" title="YNW Melly Announces &#8216;We All Shine&#8217; Tour With Asian Doll">YNW Melly Announces &#8216;We All Shine&#8217; Tour With Asian Doll</a></h3>            </div>
</div>
</div> <!-- ./td-related-span4 -->
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/25/music-video-foolie-ynw-melly-maserati/" rel="bookmark" title="Music Video: Foolie &#038; YNW Melly – Maserati"><img width="218" height="150" class="entry-thumb" src="https://pribitre-cdn.sirv.com/WP_weuponithiphop.info/Foolie-YNW-Melly-–-Maserati.jpg?scale.width=218&scale.height=150&scale.option=fill&cw=218&ch=150&cx=center&cy=center" alt="" title="Music Video: Foolie &#038; YNW Melly – Maserati"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/25/music-video-foolie-ynw-melly-maserati/" rel="bookmark" title="Music Video: Foolie &#038; YNW Melly – Maserati">Music Video: Foolie &#038; YNW Melly – Maserati</a></h3>            </div>
</div>
</div> <!-- ./td-related-span4 --></div><!--./row-fluid-->
<div class="td-related-row">
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/18/album-stream-ynw-melly-we-all-shine/" rel="bookmark" title="Album Stream: YNW Melly – We All Shine"><img width="218" height="150" class="entry-thumb" src="https://pribitre-cdn.sirv.com/WP_weuponithiphop.info/ynw-melly-we-all-shine.jpg?scale.width=218&scale.height=150&scale.option=fill&cw=218&ch=150&cx=center&cy=center" alt="" title="Album Stream: YNW Melly – We All Shine"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/18/album-stream-ynw-melly-we-all-shine/" rel="bookmark" title="Album Stream: YNW Melly – We All Shine">Album Stream: YNW Melly – We All Shine</a></h3>            </div>
</div>
</div> <!-- ./td-related-span4 -->
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/12/14/video-ynw-melly-breaks-down-the-lyrics-for-murder-on-my-mind-w-genius/" rel="bookmark" title="Video: YNW Melly Breaks Down The Lyrics for “Murder On My Mind&#8221; W/ Genius"><img width="218" height="150" class="entry-thumb" src="https://pribitre-cdn.sirv.com/WP_weuponithiphop.info/YNW-Melly-Breaks-Down-The-Lyrics-for-Murder-On-My-Mind-W-Genius.jpg?scale.width=218&scale.height=150&scale.option=fill&cw=218&ch=150&cx=center&cy=center" alt="" title="Video: YNW Melly Breaks Down The Lyrics for “Murder On My Mind&#8221; W/ Genius"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/12/14/video-ynw-melly-breaks-down-the-lyrics-for-murder-on-my-mind-w-genius/" rel="bookmark" title="Video: YNW Melly Breaks Down The Lyrics for “Murder On My Mind&#8221; W/ Genius">Video: YNW Melly Breaks Down The Lyrics for “Murder On My Mind&#8221; W/ Genius</a></h3>            </div>
</div>
</div> <!-- ./td-related-span4 -->
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/11/23/new-music-ynw-melly-ft-tee-grizzley-freddy-krueger/" rel="bookmark" title="New Music: YNW Melly ft. Tee Grizzley &#8211; Freddy Krueger"><img width="218" height="150" class="entry-thumb" src="https://pribitre-cdn.sirv.com/WP_weuponithiphop.info/YNW-Melly-ft.-Tee-Grizzley-Freddy-Krueger.jpg?scale.width=218&scale.height=150&scale.option=fill&cw=218&ch=150&cx=center&cy=center" alt="" title="New Music: YNW Melly ft. Tee Grizzley &#8211; Freddy Krueger"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/11/23/new-music-ynw-melly-ft-tee-grizzley-freddy-krueger/" rel="bookmark" title="New Music: YNW Melly ft. Tee Grizzley &#8211; Freddy Krueger">New Music: YNW Melly ft. Tee Grizzley &#8211; Freddy Krueger</a></h3>            </div>
</div>
</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_16_5c68a7364d3f8" data-td_block_id="td_uid_16_5c68a7364d3f8"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_16_5c68a7364d3f8" data-td_block_id="td_uid_16_5c68a7364d3f8"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
<div class="comments" id="comments">
</div> <!-- /.content -->
</div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<aside class="widget widget_search"><form method="get" class="td-search-form-widget" action="http://weuponithiphop.info/">
<div role="search">
<input class="td-widget-search-input" type="text" value="" name="s" id="s" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit" value="Search" />
</div>
</form></aside><aside class="widget widget_text">			<div class="textwidget"><h4><strong><span style="color: #8224e3;"><span style="color: #000000;">Listen to</span> <span style="color: #c60000;">WeUpOnItRadio</span> <span style="color: #000000;">Live!</span></span></strong></h4>
<p><span class="cc_streaminfo" data-type="song" data-username="cyclone777">Loading &#8230;</span><br />
<script language="javascript" type="text/javascript" src="https://control.internet-radio.com:2199/system/streaminfo.js"></script><br />
<iframe src="https://tunein.com/embed/player/s292400/" style="width:100%; height:100px;" scrolling="no" frameborder="no"></iframe></p>
</div>
</aside><aside class="widget widget_text"><div class="block-title"><span>AUDIOTRAFFICKER</span></div>			<div class="textwidget"><p><iframe src="https://www.facebook.com/plugins/video.php?href=https%3A%2F%2Fwww.facebook.com%2FAudioTrafficker%2Fvideos%2F812357622441153%2F&#038;show_text=0&#038;width=560" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true" allowFullScreen="true"></iframe></p>
</div>
</aside><aside class="widget widget_text"><div class="block-title"><span>Nas-T &#8211; TailorMade</span></div>			<div class="textwidget"><p><iframe src="https://www.youtube.com/embed/U1g-kLtNjdo" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
</div>
</aside>
<!-- A generated by theme --> 
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-sidebar ">
<script type="text/javascript">
var td_screen_width = document.body.clientWidth;
if ( td_screen_width >= 1140 ) {
/* large monitors */
document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
/* landscape tablets */
document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
/* portrait tablets */
document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
if ( td_screen_width < 768 ) {
/* Phones */
document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}
</script>
</div>
<!-- end A --> 
</div>
</div>
</div> <!-- /.td-pb-row -->
</div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->

<!-- Instagram -->
<!-- Footer -->
<div class="td-footer-wrapper td-footer-template-3">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span12">
</div>
</div>
<div class="td-pb-row">
<div class="td-pb-span4">
<div class="td-footer-info"><div class="footer-logo-wrap"><a href="http://weuponithiphop.info/"><img class="td-retina-data" src="https://pribitre-cdn.sirv.com/WP_weuponithiphop.info/weuponit-glow-logo-6.png" data-retina="https://pribitre-cdn.sirv.com/WP_weuponithiphop.info/weuponit-glow-logo-6.png" alt="" title=""/></a></div><div class="footer-text-wrap"></div><div class="footer-social-wrap td-social-style-2">
<span class="td-social-icon-wrap">
<a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
<i class="td-icon-font td-icon-pinterest"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span></div></div>            </div>
<div class="td-pb-span4">
<div class="td_block_wrap td_block_8 td_block_widget td_uid_21_5c68a73658e4a_rand td-pb-border-top"  data-td-block-uid="td_uid_21_5c68a73658e4a" ><script>var block_td_uid_21_5c68a73658e4a = new tdBlock();
block_td_uid_21_5c68a73658e4a.id = "td_uid_21_5c68a73658e4a";
block_td_uid_21_5c68a73658e4a.atts = '{"limit":"7","sort":"jetpack_popular_2","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"POPULAR POSTS","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"#","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_21_5c68a73658e4a_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_21_5c68a73658e4a.td_column_number = "1";
block_td_uid_21_5c68a73658e4a.block_type = "td_block_8";
block_td_uid_21_5c68a73658e4a.post_count = "7";
block_td_uid_21_5c68a73658e4a.found_posts = "10";
block_td_uid_21_5c68a73658e4a.header_color = "#";
block_td_uid_21_5c68a73658e4a.ajax_pagination_infinite_stop = "";
block_td_uid_21_5c68a73658e4a.max_num_pages = "2";
tdBlocksArray.push(block_td_uid_21_5c68a73658e4a);
</script><h4 class="block-title"><span>POPULAR POSTS</span></h4><div id=td_uid_21_5c68a73658e4a class="td_block_inner">
<div class="td-block-span12">
<div class="td_module_7 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/new-music-lil-west-not-sure/" rel="bookmark" title="New Music: Lil West &#8211; Not Sure"><img width="100" height="70" class="entry-thumb" src="https://lh3.googleusercontent.com/DpMAuMInSWjNvBbXgU7mxFqgHpwPU2uT8YJPmFp5yeK1SImArLJa_3inMqHjnyc8D1-uW5aRjdDYCOf7usOtjJ7dn-09hShX1AwGMhSmsg12-R1u7l8MIL8bkH7pht4WbbfcfeOQ2HROh6JFVMvHzrUSCrgI_gc2pfjwS6QPv562Yr3oCiA09yHMjN9Fy_9UkKQ3CEZgN8o55giFtiWtXymvQXgoRsvs9-pNBvpmY-PkKSDR23FEExGH_a5Oz0DbIJOTUqCCE3793pYJ0RRHxL8SXfMIAgBO_eU1GTt-fXU95YC-lUaLE746J0TX6mk22GU2L2MHhlxGFBkIUb2tDH8nl3DzbkLRsuN35LQs6EJxuqnNXI4JQWSGzAMi4CRJ10zf2kXIBEPh0fAuDxWqXlXG_kWZLuZ8iYAmYtyUSvEHEBAQzL9CcyBkQMV-OSPh01asz-eID7-0ljkYw23aMNlZipQHSO20D5DzY1TkOPEi4UmbmQKPLI_1qoKmRiqbu4mUs27yXfTKeCtp7ymVgqNLrhzN6DSISaM5k7_bF2_GXT034ZmWfWxckfGUFcWcm_FsvG6-lW_F3MI6Ind5D0QDJwzTZrY5gVolQVa2vwQEQvSdqT4i2V20cl8V-5piQ-Z3nUNfDE9p6CZ6MPvjnsyRgoW-7TfU=s673-no" alt="" title="New Music: Lil West &#8211; Not Sure"/></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/new-music-lil-west-not-sure/" rel="bookmark" title="New Music: Lil West &#8211; Not Sure">New Music: Lil West &#8211; Not Sure</a></h3>
<div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-02-16T18:20:12+00:00" >February 16, 2019</time></span>                            </div>
</div>
</div>
</div> <!-- ./td-block-span12 -->
<div class="td-block-span12">
<div class="td_module_7 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/audio-joe-budden-the-joe-budden-podcast-w-rory-mal-parks-episode-222-post-hummus/" rel="bookmark" title="Audio: Joe Budden &#8211; The Joe Budden Podcast w/ Rory, Mal &#038; Parks (Episode 222) “Post-Hummus”"><img width="100" height="70" class="entry-thumb" src="https://lh3.googleusercontent.com/0N8XdFDgjvKsBKsXhbaboK7exWjXqCuXQBO9s3vROfD3XOWf86f0OnH65ENfuWTVzbP-_119JPvpqzL4rxQi25vo3vkwF_gL4COv0yBe209rqi-nYMGx55jyfOBwuTbYmu-wDLO-Vq2aWyV__E7iwTBNtUucf4jkCuXRd2fcTuchn9e5XJIDzpDhMWYbUhF771GDCPr5VdGaGD-Nje2hVNA3ZPtptDZ-clmVu5tQjfBP1EVXHReLMZLb3e5cUUHTd1i1xWiH1U80ogS1B1EAlKddbu9GL8tEOA2IO6wxRaSg7jbljPd7kN1rBP24a4PD9vGW77dSV3JUBy8O9ieKrNIg0b9DMKV1Ui2Mls6Icn0cs_95cmavdhqcG_3auJDt3SXG3gTuem8UXiLBQkYryFa00ozVJNir77s8HpZlesNhxuWy2CSSrGVhJEv8LafjG4yRu5VSR0ylZ6UQ3I2q3lEIcxW4OOIs2APdM_htrV13sY_NnlRlQ3bzDja714gxWNdxpAWzNO1uwpoI7OCmdVNXjE80rCadxDoSs-u3LrkHJFI4ejxyLwEPD_XjC84d2nljV5WXHBAAXfcd9i4M7YyX90_r5sccK6Q8zzJMZqkGYKfXIT9CLVXhGPu6ql8uAylWEicwjGQrAKW3_V0E42-YAsOWU4Y2=s672-no" alt="" title="Audio: Joe Budden &#8211; The Joe Budden Podcast w/ Rory, Mal &#038; Parks (Episode 222) “Post-Hummus”"/></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/audio-joe-budden-the-joe-budden-podcast-w-rory-mal-parks-episode-222-post-hummus/" rel="bookmark" title="Audio: Joe Budden &#8211; The Joe Budden Podcast w/ Rory, Mal &#038; Parks (Episode 222) “Post-Hummus”">Audio: Joe Budden &#8211; The Joe Budden Podcast w/ Rory, Mal...</a></h3>
<div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-02-16T09:03:12+00:00" >February 16, 2019</time></span>                            </div>
</div>
</div>
</div> <!-- ./td-block-span12 -->
<div class="td-block-span12">
<div class="td_module_7 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/new-music-meyhem-lauren-the-alchemist-still-playing-celo/" rel="bookmark" title="New Music: Meyhem Lauren &#038; The Alchemist &#8211; Still Playing Celo"><img width="100" height="70" class="entry-thumb" src="https://lh3.googleusercontent.com/rO_03NZ0s2Ts5EYLM09t8okvjAORCyJadvdxFajxqaoEzsn4BWGTZMr1PDbYXByZeW17ZjsTyls4HPsMeKhomse6mSc4bdEdp9lVfBUn_L_4pwTQbF5m3kjPXCs3HlzEX3T5SO4pIBF0xRxhAq6DsRkR2H-RjthpjIxk_xmB05hGLMXX2JsvHQcrN8IKG4DqTWH5UBt4DYmTs1u8-uymUnA1IYyl-kQ7OOE1AQ1bgjJXeI7x4GQzeQlBEr0KAzZ6hcTOv09pK_pA2gjc4IEItZOoAZ2RHCu7TwXJOIpmqvrmt7WjOqIl3bm6q_H25QmRd0tlIqz637kjWlaCYJYWTCZ5V6pD4P8tqag8WTo2u32CJiW2mY7Qsuv0-jd74EG-n4FJK6LJjgzW7_x6BU03PvMDltv-pF1qoWuLyTRlqtr9LPKaqd6pJ4Rg6G7HtLQKI4ymsUs6WeQUaAgP_ga4pGLb0VvJxkm8P3Icyrsuygry2Jx7Pmk6UpAnG21DnP14x2UlrZp9kwszYT1mcVZlQbNM9zxF8MQozoIHrPzJDhQH6_VrKm9Smm9n9cqNIrx5vvCGPzSTO-GwpXnR-E6nagV9nnw732-r89m_rm3BMhfkorGBWdNbV0ZnXeiRg9z9Xqlaon1pf9lqbjCc9uKERSC33It1lBlQ=s673-no" alt="" title="New Music: Meyhem Lauren &#038; The Alchemist &#8211; Still Playing Celo"/></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/new-music-meyhem-lauren-the-alchemist-still-playing-celo/" rel="bookmark" title="New Music: Meyhem Lauren &#038; The Alchemist &#8211; Still Playing Celo">New Music: Meyhem Lauren &#038; The Alchemist &#8211; Still Playing Celo</a></h3>
<div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-02-16T08:19:45+00:00" >February 16, 2019</time></span>                            </div>
</div>
</div>
</div> <!-- ./td-block-span12 -->
<div class="td-block-span12">
<div class="td_module_7 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/music-video-lucki-politics/" rel="bookmark" title="Music Video: Lucki &#8211; Politics"><img width="100" height="70" class="entry-thumb" src="https://lh3.googleusercontent.com/L75hdM36qKdlwoWjtjfb7l53OiJH0Y0A5B6pSJr3l4r_FuYz7VOlwr1H9E4yRQN-Egl5giWqahpfA3KLLd4O6Olzri5SNFCbbefc2K3bJOCZj1zI6JDgfEPmaMc74ptnLfrxfV0lsm2xACfhy-Y9kYKwoWv7n_ZVEh734urMFwnqoU_xlzERgKtgGf2Ewe7ONdQXXyAJ72Y8SEFS3_VUizXMcvYOvawjInX3j6RY1YsaGV4Q-1NrZp9QMbq5i24cTaYZe7J8NF6KMPdaHM8j6ARruashECVBb5O4wltj6VNtW4DIoGYC7jpsKU-8iVLBsasG9fV203xL-3jCBJ26a9B6d-TUdmGFxBonjjnM2kwregcKWjOE5aX35Z_KIUqYN-hwxJI6kvm9RUKXq3vcHdHmUm3Fy5Dv_npefrbWF9LZK4TZQI_HcKeQDHBmIv-2_46Pz78LNO-GqKf1TMgq2Z7nLUeZ584kkts0TYoIN1J2WsRJ0fGI9PZGLcyB0gb_p8qzbt2c5itWthFUcS0fsaBOFRiFJSIFfVGVWpsZ_cYYDBmeD8lxkGkYvIdo_Umi363D7xnjEgWnRlAc84wtSndb2RNjR3twK75QB4NA1PuaeLLeiEGmAJ2MOW4JAGGVzWu1D9NGynew-uUvTeISUgYzPXeTaD-P=w937-h456-no" alt="" title="Music Video: Lucki &#8211; Politics"/></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/music-video-lucki-politics/" rel="bookmark" title="Music Video: Lucki &#8211; Politics">Music Video: Lucki &#8211; Politics</a></h3>
<div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-02-16T07:52:43+00:00" >February 16, 2019</time></span>                            </div>
</div>
</div>
</div> <!-- ./td-block-span12 -->
<div class="td-block-span12">
<div class="td_module_7 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/music-video-xxxtentacion-sauce/" rel="bookmark" title="Music Video: XXXTENTACION &#8211; SAUCE!"><img width="100" height="70" class="entry-thumb" src="https://lh3.googleusercontent.com/dBDQA2-CBLEL7CoFyXnMYy6K3avHrdLzujkVD5ZqNu4Qa4KcY7S9UhcQjGOS_2aLGxCDc-4KA3K4r1vvViqtoi77EhrSRQwtO2ueY3iJUnaP-qv5n43AFaqPwLo9YsYfkqWeIlbLYw3D_s2Fi2OZ0ssPMVXS7OxtFSDE9DUF2Drdql_juflzibzUqmCyybuDcZysWvIKnfKQga-MawOah-jQsBMYimdtQGPf4tyv9C9hrI3qfkWy5JcuCTumruU3TPdMUEg7bB6IGREH629wwly4gXRLOf3fg3xnD2_5R3e81QsVzQZuMi9mYW-Wppe5kYRANzR9wZHySEK5iFPG9GC0y-stsIew6C6r4BZqNVu2bLdMkoOI34_0Hffax_GMDJR6Adm8-_yoQ9e21urMgNI78w60poIS4BQC1Kk5TwKnRY6vbQn3qTTFlmYM4pBHL_dCSjo7xmDYk1k6NCBENDAOp-pPQ23-2wwhwfBo15uraJMVY1_KCnp1DaGPpKTPNNwzuD62AkQrj0tSu8Yi0Wti7AFygAIpds5muGsFAB6G4i0Z3WBEjkRok1zGd0SMAQoZbStlxl-0s7IAbt-qV-w0gdnJKuvBFfppybi6qEiVNN09rumATtO965UiRzMK2-aw9zt3T32s_FuJmFcLKW_-L0kut4hp=w909-h501-no" alt="" title="Music Video: XXXTENTACION &#8211; SAUCE!"/></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/music-video-xxxtentacion-sauce/" rel="bookmark" title="Music Video: XXXTENTACION &#8211; SAUCE!">Music Video: XXXTENTACION &#8211; SAUCE!</a></h3>
<div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-02-16T07:28:25+00:00" >February 16, 2019</time></span>                            </div>
</div>
</div>
</div> <!-- ./td-block-span12 -->
<div class="td-block-span12">
<div class="td_module_7 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/14/album-stream-slim-thug-suga-daddy-slim-on-tha-prowl/" rel="bookmark" title="Album Stream: Slim Thug – Suga Daddy Slim: On Tha Prowl"><img width="100" height="70" class="entry-thumb" src="https://lh3.googleusercontent.com/7YPc7FbKQljV63NQjuZDOYMYzOUgqvmlzg7q7Hyc8VmJikuvHVR2-wb5ivcBYtbhFHCCSzkSFbjPjRnzH479e3sVYdYyx4kQQf6XJ7MlnIw3QeP5wgAHcEr04Au1UBzeiCmBWKKDuCzhIC2QPT7hZbqIP7NokrjUSbBzqr2gsEmRHgseTuiKRVaGigdGoDfFAdwskMuLBG0Y6DjzD0huNJHFonGXJAFSK05b6kktkkZAZASbydZu7MyZ1j5avmkDJSFrbA3tIJG9XF2nHg66fLmhiSz08F-1kGc5uEJa1dwtFMgH5sNjkbP0I92G901I0ZYsp_t1htnvkNqcfQ-pFem8qMS69k_Oz0FNBW3v--ha68C-WfEboIaiU0zP4RoT9E8mMFCHkXYNDYHhve3kMiZMEc34YCG1js3VxeDTPt3yn2n8OeXWXFfA8JZvxTanGtRq-7r8CnWetqx7xEkeCQwz-fzkeCrh9TFHDxsKhWEDs7tSq0RFxREkK3GZ1a40rMdIKh0HQYTiZ3JXd_CzseJkVSmnkDbMaicOORbwPvaF9C-SDX6Vg4Vt_Z5IiSuAqaqdWAx5m9tKmbPHvwoZu7JgaRhmi2VaSGqQ31u7MbhH6qe0-jQt3NbDU8UP1km1OOZdczHORNFNV_3_GoGpFtgfvOlvNXO6=s673-no" alt="" title="Album Stream: Slim Thug – Suga Daddy Slim: On Tha Prowl"/></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/14/album-stream-slim-thug-suga-daddy-slim-on-tha-prowl/" rel="bookmark" title="Album Stream: Slim Thug – Suga Daddy Slim: On Tha Prowl">Album Stream: Slim Thug – Suga Daddy Slim: On Tha Prowl</a></h3>
<div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-02-14T15:43:14+00:00" >February 14, 2019</time></span>                            </div>
</div>
</div>
</div> <!-- ./td-block-span12 -->
<div class="td-block-span12">
<div class="td_module_7 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/24/murs-announces-over-the-odyssey-tour/" rel="bookmark" title="MURS Announces “Over The Odyssey” Tour"><img width="100" height="70" class="entry-thumb" src="https://pribitre-cdn.sirv.com/WP_weuponithiphop.info/MURS-Announces-Over-The-Odyssey-Tour.jpg?scale.width=100&scale.height=70&scale.option=fill&cw=100&ch=70&cx=center&cy=center" alt="" title="MURS Announces “Over The Odyssey” Tour"/></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/24/murs-announces-over-the-odyssey-tour/" rel="bookmark" title="MURS Announces “Over The Odyssey” Tour">MURS Announces “Over The Odyssey” Tour</a></h3>
<div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-01-24T07:48:33+00:00" >January 24, 2019</time></span>                            </div>
</div>
</div>
</div> <!-- ./td-block-span12 --></div></div> <!-- ./block -->            </div>
<div class="td-pb-span4">
<aside class="widget widget_calendar"><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar">
<caption>February 2019</caption>
<thead>
<tr>
<th scope="col" title="Sunday">S</th>
<th scope="col" title="Monday">M</th>
<th scope="col" title="Tuesday">T</th>
<th scope="col" title="Wednesday">W</th>
<th scope="col" title="Thursday">T</th>
<th scope="col" title="Friday">F</th>
<th scope="col" title="Saturday">S</th>
</tr>
</thead>
<tfoot>
<tr>
<td colspan="3" id="prev"><a href="http://weuponithiphop.info/2019/01/">&laquo; Jan</a></td>
<td class="pad">&nbsp;</td>
<td colspan="3" id="next" class="pad">&nbsp;</td>
</tr>
</tfoot>
<tbody>
<tr>
<td colspan="5" class="pad">&nbsp;</td><td><a href="http://weuponithiphop.info/2019/02/01/" aria-label="Posts published on February 1, 2019">1</a></td><td><a href="http://weuponithiphop.info/2019/02/02/" aria-label="Posts published on February 2, 2019">2</a></td>
</tr>
<tr>
<td><a href="http://weuponithiphop.info/2019/02/03/" aria-label="Posts published on February 3, 2019">3</a></td><td><a href="http://weuponithiphop.info/2019/02/04/" aria-label="Posts published on February 4, 2019">4</a></td><td><a href="http://weuponithiphop.info/2019/02/05/" aria-label="Posts published on February 5, 2019">5</a></td><td><a href="http://weuponithiphop.info/2019/02/06/" aria-label="Posts published on February 6, 2019">6</a></td><td><a href="http://weuponithiphop.info/2019/02/07/" aria-label="Posts published on February 7, 2019">7</a></td><td><a href="http://weuponithiphop.info/2019/02/08/" aria-label="Posts published on February 8, 2019">8</a></td><td><a href="http://weuponithiphop.info/2019/02/09/" aria-label="Posts published on February 9, 2019">9</a></td>
</tr>
<tr>
<td><a href="http://weuponithiphop.info/2019/02/10/" aria-label="Posts published on February 10, 2019">10</a></td><td><a href="http://weuponithiphop.info/2019/02/11/" aria-label="Posts published on February 11, 2019">11</a></td><td><a href="http://weuponithiphop.info/2019/02/12/" aria-label="Posts published on February 12, 2019">12</a></td><td><a href="http://weuponithiphop.info/2019/02/13/" aria-label="Posts published on February 13, 2019">13</a></td><td><a href="http://weuponithiphop.info/2019/02/14/" aria-label="Posts published on February 14, 2019">14</a></td><td><a href="http://weuponithiphop.info/2019/02/15/" aria-label="Posts published on February 15, 2019">15</a></td><td id="today"><a href="http://weuponithiphop.info/2019/02/16/" aria-label="Posts published on February 16, 2019">16</a></td>
</tr>
<tr>
<td>17</td><td>18</td><td>19</td><td>20</td><td>21</td><td>22</td><td>23</td>
</tr>
<tr>
<td>24</td><td>25</td><td>26</td><td>27</td><td>28</td>
<td class="pad" colspan="2">&nbsp;</td>
</tr>
</tbody>
</table></div></aside>            </div>
</div>
</div>
</div>
<!-- Sub Footer -->
<div class="td-sub-footer-container">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span7 td-sub-footer-menu">
<div class="menu-top-menu-container"><ul id="menu-top-menu-2" class="td-subfooter-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-mega-menu menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a>
<ul class="sub-menu">
<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_22_5c68a73666b77_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_22_5c68a73666b77" ><script>var block_td_uid_22_5c68a73666b77 = new tdBlock();
block_td_uid_22_5c68a73666b77.id = "td_uid_22_5c68a73666b77";
block_td_uid_22_5c68a73666b77.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"43","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_22_5c68a73666b77_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_22_5c68a73666b77.td_column_number = "3";
block_td_uid_22_5c68a73666b77.block_type = "td_block_mega_menu";
block_td_uid_22_5c68a73666b77.post_count = "5";
block_td_uid_22_5c68a73666b77.found_posts = "1342";
block_td_uid_22_5c68a73666b77.header_color = "";
block_td_uid_22_5c68a73666b77.ajax_pagination_infinite_stop = "";
block_td_uid_22_5c68a73666b77.max_num_pages = "269";
tdBlocksArray.push(block_td_uid_22_5c68a73666b77);
</script><div id=td_uid_22_5c68a73666b77 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/new-music-jag-ft-boogie-nick-grant-dcmbr-stressin-45657557/" rel="bookmark" title="New Music: JAG ft. Boogie, Nick Grant &#038; DCMBR &#8211; Stressin"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/DouMxeHST1KMRjbE14brLVstWOJ_xQ1cWPHd4-NfvkVQrbWIYG-bfbZW7NGzmiR24v2zL0f7ZKq1xS6Ee2Reg7Ya3Q9ZCaIDby038A--qDS0-uMsSlN9x7oKbQr8Ive6IF4JxzNQs-jhCYrzw88oyB8pcvh72qqFxN5vjU2ufxbX_xgEFFotVZIY_VJnb4pjBy6ppR8XWhDjL2Yk_qOZvqoAAvMf2LlqWAPYQt6H-oh3LUjW_w6BpoMapZiGRsYQuFJAYnzRzueT6izfVT4Oz54LxF15v6qJEMq1PS81O6NHMNcdI7qy5XsAQ7StnW_xjkn9b3j2HZW5cF3Vk53YTtz5LI6a0MYQususplTaC0EsyI8x_cV2wWGv8i_m7otd7dn_Hsh5rgZkTKW-gU5GqdqxE7tWX57VjBchnlzkFwwSk0F8pPgKQIrM4DxM0zbqvZnnHlhJi0Ur9JhoGBR2SZvFUBR13y5IZS-ZSUrDmrZEbEOp_nce9_Ge7f7Q_5F7A31gMQveT2RpewNcK5fF4hiGPO1fsvXA3-UO8xEb1I4Em4cm_f9sVJ5llhJi8K7TaKTRkDpjXFZfhbEs4v-Ctris6Sbra5ZV9vy80kKOm_ItPelJl4De8qDDjVH9IT_njUcdh9mEEJSDmQQgE0TreTK1B5IEPb-y=s673-no" alt="" title="New Music: JAG ft. Boogie, Nick Grant &#038; DCMBR &#8211; Stressin"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/new-music-jag-ft-boogie-nick-grant-dcmbr-stressin-45657557/" rel="bookmark" title="New Music: JAG ft. Boogie, Nick Grant &#038; DCMBR &#8211; Stressin">New Music: JAG ft. Boogie, Nick Grant &#038; DCMBR &#8211; Stressin</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/new-music-lil-west-not-sure/" rel="bookmark" title="New Music: Lil West &#8211; Not Sure"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/DpMAuMInSWjNvBbXgU7mxFqgHpwPU2uT8YJPmFp5yeK1SImArLJa_3inMqHjnyc8D1-uW5aRjdDYCOf7usOtjJ7dn-09hShX1AwGMhSmsg12-R1u7l8MIL8bkH7pht4WbbfcfeOQ2HROh6JFVMvHzrUSCrgI_gc2pfjwS6QPv562Yr3oCiA09yHMjN9Fy_9UkKQ3CEZgN8o55giFtiWtXymvQXgoRsvs9-pNBvpmY-PkKSDR23FEExGH_a5Oz0DbIJOTUqCCE3793pYJ0RRHxL8SXfMIAgBO_eU1GTt-fXU95YC-lUaLE746J0TX6mk22GU2L2MHhlxGFBkIUb2tDH8nl3DzbkLRsuN35LQs6EJxuqnNXI4JQWSGzAMi4CRJ10zf2kXIBEPh0fAuDxWqXlXG_kWZLuZ8iYAmYtyUSvEHEBAQzL9CcyBkQMV-OSPh01asz-eID7-0ljkYw23aMNlZipQHSO20D5DzY1TkOPEi4UmbmQKPLI_1qoKmRiqbu4mUs27yXfTKeCtp7ymVgqNLrhzN6DSISaM5k7_bF2_GXT034ZmWfWxckfGUFcWcm_FsvG6-lW_F3MI6Ind5D0QDJwzTZrY5gVolQVa2vwQEQvSdqT4i2V20cl8V-5piQ-Z3nUNfDE9p6CZ6MPvjnsyRgoW-7TfU=s673-no" alt="" title="New Music: Lil West &#8211; Not Sure"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/new-music-lil-west-not-sure/" rel="bookmark" title="New Music: Lil West &#8211; Not Sure">New Music: Lil West &#8211; Not Sure</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/new-music-fetty-wap-history-2/" rel="bookmark" title="New Music: Fetty Wap &#8211; History"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/_HjOUR2DOh7F14mepeQsze9gsx4qWg6QrJ8GreM5Lhbnpjt88ESLOvjg5SYie2bkffeGWizkiQU-ulr-CqyoyvfXhYdMGfqNVsPnn1Zsen8IUxwfKjGR4b9c3uTGODbwZH-qe8kORNuCQvGXAcrLxLV8-vQ59Er7Vr4WJIA7q29Q93uxj1x1au4s2fZvOq9ifIfGFdp-qmZfNSo1m7_xYFcWrHjuWySDWD74mCrhbvqyBsK_jMrEXVM-hkhLVqY4jfY94505m52ttpR7SIe43Ja01GEKOzzr7KAD1T26jebdAus-I3CFcK8PXgTNZKt3-euUYu1tLjqqHyTn0bJJuHrxsCsEf3r07eB3OkTwyCczRSamUlw8l-z_Kz_BCgC7lkip8Y9hoee7LMLmq3NQ6FHSNqssQAh5zuvob3uB267WGL1ksRh1dKzf9FSaLw7LWeDQ6EGc_LMl9y7YPrZNKcu0Hv3Yzais-dkx4Be4RC5Atj4UvaLUBI8uRor-iamoLtlwZfhPlJFe9T0cgFkX_0cLt4whaU_xEaGJ53rWycudMHRLL1Of_bIxd-wikuZC3yE4ICtY_LrpVKrae14hkn9QRq6euyJWG1eKG0oM9T-bt5dk0wBMjsi5G_YuSFrIXQZt0wwNi7KXLJxNdcCsno2ERBGzb1t6=s620-no" alt="" title="New Music: Fetty Wap &#8211; History"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/new-music-fetty-wap-history-2/" rel="bookmark" title="New Music: Fetty Wap &#8211; History">New Music: Fetty Wap &#8211; History</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/new-music-rod-wave-hard-times/" rel="bookmark" title="New Music: Rod Wave &#8211; Hard Times"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/24gfDTm5j6GCymio79wG7eHnhm-DmoxQ0wKfGV0T4Ib-1pNbzeVPgObALMdgN-3ABUV9xOBf0oyoT8OOPkFyx2LfVy4LEnBhSYa3hqzVCZ9avMvQdYxnM03zXw05sL94ulHrvFVZcBaK_pl2zg7ww-9Fjng8zXikitlx7glXUbJMxpR7_UA4Sj8iPSibRQylWQgWOS53eq923cCHKI1Omswlu3ugaOiFm4yQhPLiXudYahcyjpglzS7HhUjS1rhtlanw7eEebtnytBT94mMnHG0SJpfqcD7ZS6wozY6fpyW4F8a2U6OUBrhMeKX3uHBlWl3ML8meOjrbOsnpd4jtdHRbXEmaWhZSrcIdcTdzg4BGGQXXAOcvh3GSDShKBRjgKnaFrgTylY2r7TBXs6x5rbOi7c4Zz7Ummls-kUCZ-GYvkQBMazUHbWyFC85On8LwfYbwHWO5PpHhkWc5hO_rYMMu8GxDJm-wX0TF9wTC0m-KLrVpQCbgSPNjztqfZ5LJ-XZ23XpqV1LKVuKEk0aVRgf9YgS7BG4HlNyyKO8eKCFx74I0aDSVYcM-zjBBCVyIS8xtfne4RFT7-1a2Pq5e0ybuymNiQu7PO6me-lzzFV0E8DJEbguHrrqvNfPNaB4SPwmzxaNOJXPZh3mDRj8dxhtoWGNlf9pn=w620-h349-no" alt="" title="New Music: Rod Wave &#8211; Hard Times"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/new-music-rod-wave-hard-times/" rel="bookmark" title="New Music: Rod Wave &#8211; Hard Times">New Music: Rod Wave &#8211; Hard Times</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/new-music-meyhem-lauren-the-alchemist-still-playing-celo/" rel="bookmark" title="New Music: Meyhem Lauren &#038; The Alchemist &#8211; Still Playing Celo"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/rO_03NZ0s2Ts5EYLM09t8okvjAORCyJadvdxFajxqaoEzsn4BWGTZMr1PDbYXByZeW17ZjsTyls4HPsMeKhomse6mSc4bdEdp9lVfBUn_L_4pwTQbF5m3kjPXCs3HlzEX3T5SO4pIBF0xRxhAq6DsRkR2H-RjthpjIxk_xmB05hGLMXX2JsvHQcrN8IKG4DqTWH5UBt4DYmTs1u8-uymUnA1IYyl-kQ7OOE1AQ1bgjJXeI7x4GQzeQlBEr0KAzZ6hcTOv09pK_pA2gjc4IEItZOoAZ2RHCu7TwXJOIpmqvrmt7WjOqIl3bm6q_H25QmRd0tlIqz637kjWlaCYJYWTCZ5V6pD4P8tqag8WTo2u32CJiW2mY7Qsuv0-jd74EG-n4FJK6LJjgzW7_x6BU03PvMDltv-pF1qoWuLyTRlqtr9LPKaqd6pJ4Rg6G7HtLQKI4ymsUs6WeQUaAgP_ga4pGLb0VvJxkm8P3Icyrsuygry2Jx7Pmk6UpAnG21DnP14x2UlrZp9kwszYT1mcVZlQbNM9zxF8MQozoIHrPzJDhQH6_VrKm9Smm9n9cqNIrx5vvCGPzSTO-GwpXnR-E6nagV9nnw732-r89m_rm3BMhfkorGBWdNbV0ZnXeiRg9z9Xqlaon1pf9lqbjCc9uKERSC33It1lBlQ=s673-no" alt="" title="New Music: Meyhem Lauren &#038; The Alchemist &#8211; Still Playing Celo"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/new-music-meyhem-lauren-the-alchemist-still-playing-celo/" rel="bookmark" title="New Music: Meyhem Lauren &#038; The Alchemist &#8211; Still Playing Celo">New Music: Meyhem Lauren &#038; The Alchemist &#8211; Still Playing Celo</a></h3>            </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_22_5c68a73666b77" data-td_block_id="td_uid_22_5c68a73666b77"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_22_5c68a73666b77" data-td_block_id="td_uid_22_5c68a73666b77"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a>
<ul class="sub-menu">
<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_23_5c68a7366d75b_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_23_5c68a7366d75b" ><script>var block_td_uid_23_5c68a7366d75b = new tdBlock();
block_td_uid_23_5c68a7366d75b.id = "td_uid_23_5c68a7366d75b";
block_td_uid_23_5c68a7366d75b.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"97","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_23_5c68a7366d75b_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_23_5c68a7366d75b.td_column_number = "3";
block_td_uid_23_5c68a7366d75b.block_type = "td_block_mega_menu";
block_td_uid_23_5c68a7366d75b.post_count = "5";
block_td_uid_23_5c68a7366d75b.found_posts = "517";
block_td_uid_23_5c68a7366d75b.header_color = "";
block_td_uid_23_5c68a7366d75b.ajax_pagination_infinite_stop = "";
block_td_uid_23_5c68a7366d75b.max_num_pages = "104";
tdBlocksArray.push(block_td_uid_23_5c68a7366d75b);
</script><div id=td_uid_23_5c68a7366d75b class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/ep-stream-qari-operation-hennessy/" rel="bookmark" title="EP Stream: Qari &#8211; Operation Hennessy"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/yde_J-jr_05fmBKadXTKWjLT6gA5HHfif-96VICJkA1KS0hHIQd7Kb_UaGUpdvB2-mGN3J6tfA4v893_PSobVkeWGRXl856vCAcJyQ5h-OD54trbX0hQJDXmX1d5v_2qlgMvsUw7zoWjbAyoLZwZTtJj09T78V-Q3C23W7SI5AxFHl488_tqfExjS3TfM7B8nkg8H2_TrJL2KWASDgKDwyValwExGSGQukRp0fxk92mrkkuvalicjkAgC2z4F4NSieMoFW1F_YzkyRl5g_U167y70v3jLzhaK4xDEqPCHWqCQk0zNc2pJ4CzGlcqY8RFdOEOZqvioG6wujznXu-4GQ02FLHCQy21PKTmzaYYZwnL7Tm3b74QdKgln_H6rKLLROKsLc-WHYJqOGliSWS7Tuf1-GmghUK0fp3PGYp0DT8-US8-bZO3IwdVdCykoxTbAqSPPobRtMM3eGNF68_Ovt0AudrG1uf28PxvE4xjJyuap_EBxg8dJjXS8VAMIkQPbGvzl1yfTuyfyChZfIDKUYrSQy05ZqA0gpCzsZr3fvjzSghs11ST_7u0BgKFMWRu-vs-7VjHYtjBQhgebB2J8xDBGAGYqvwp5N244x4ONZ5CKUgBmmkdWJP-1XsW_FFem4UpsJlShqp9tprC1d7NgSsJdQn9oLAy=s673-no" alt="" title="EP Stream: Qari &#8211; Operation Hennessy"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/ep-stream-qari-operation-hennessy/" rel="bookmark" title="EP Stream: Qari &#8211; Operation Hennessy">EP Stream: Qari &#8211; Operation Hennessy</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/ep-stream-baby-goth-baby-goth/" rel="bookmark" title="EP Stream: Baby Goth &#8211; Baby Goth"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/Z5g8J4Rryv4Xb1eZed3r5qJu34e5vaFdznHDVBAr6VYl0gWQMNMHzd9cmsi0jR-_C4SPOosXRFWEhNOzueF0C8VOr1OGiKXi-Zux-f8CJ4qO8qpA6CzEjT4JManLjwn4HiDRQlvEkg_0dtQkRN4jCIMFMNAIC2fp_tm6qTe2yohzmi5lDPtggpzmoHzua2FSksUbagsCd-btEx4fOb9_IhrhefJvsvFSHyZ5HVxgSKdCVJvPLQTv3_9QS0-LYWYRzPe2a_GZUK1hsqJYfmz6wnBFnfG0Oo6LpUgUYNbSa_Qbrm0PAy84D_OxMfHnEwY9btwZbGDN_tFegvcvwPMhvkbNdPK88s4Au7gdU6e1nVaYqUaibAgZFBI3oMBTuUS3ZtRgmwv-z01Bri3HEsk8J1bV4XygcQOmuAcLgf8iNl9Gxd-KDH5hA114ea3Blzw_Jfl4LEmJxv59YOjlxI7Yav1hnW2uat8NzBDSxsWf0jfW5sDxRL8oIzYAIBTl6bpvp0qTeOJ3M0RTFDZIAcU0qsg8UjPXILxHN0w4PP_d6-mHIXvdnOx_1Iq2_JC9--cid9naFqCXCE2vJgDmFCROb9KTXQxvgC2r7UE7rA1hAp0zaE1RrliFOBErinUt6rjpmjTTbSzkACN1kI9o07Tv-7mvTQQlQjkA=s673-no" alt="" title="EP Stream: Baby Goth &#8211; Baby Goth"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/ep-stream-baby-goth-baby-goth/" rel="bookmark" title="EP Stream: Baby Goth &#8211; Baby Goth">EP Stream: Baby Goth &#8211; Baby Goth</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/15/ep-stream-richie-wess-lost-you/" rel="bookmark" title="EP Stream: Richie Wess &#8211; Lost You"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/PCxxg1beH7n9UWueGrgxTqjjj4nq3qfWiUsxbSmhRPyGH27PWdWYIQdapHMUHeOGUP8n1prJ5R5MIeaFUUi7B3Qvrn_CR8ZRxZvHDfujDz_-IaMN5xbu89kEXw6N2oonPekwEdE5I2JCah587QRRe3lEesN8JXh7AkRnmSTuq9s_10hlDvEr9PiP-H9FSwkqdrvjz0ctWUYRVcjmr5yFUfckBavipjgCULEeGhE3Pj_fcYdnd7Jzj4DoPvG8l9XOiuZ7bqiueQgnQYZ2xL_InJZ5FlSTnOmIMwRuswc1rUmJOzXjqlnRKWAruGWMB0o0knWPAsF9Y_1W7AXI1CAfNcQ1VGtn107oG8mUf7wwtUdU7c9EQmKsav2N-cF2zPU5hsHdgr28_OOIF6wYuq9YRYsr5LWnG-lEqikU6jtijPnR4h9fknWdZa6xb-6_fsotlBpfy-GIBKsQHTu8noscue9qTHhhVg42Wk-3qyt00pfjTv7msiBlbxtFrc175DgVl-2ZCB4SMXO2MYc9AS1Z9YlYqU7XuaqMwYHeasAVbc_nEHXaO6jVu_jti-Kn--LWCkw6gxs_QXkICnoExJ5433s3TAf3gCtmtTIFC4SO1l3IoYgnnRR1Z3lY6oJlfUr8L2O-mTR8Wllksk6sJ7ho20pxHym0wKOZ=s673-no" alt="" title="EP Stream: Richie Wess &#8211; Lost You"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/15/ep-stream-richie-wess-lost-you/" rel="bookmark" title="EP Stream: Richie Wess &#8211; Lost You">EP Stream: Richie Wess &#8211; Lost You</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/15/album-stream-papoose-underrated/" rel="bookmark" title="Album Stream: Papoose &#8211; Underrated"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/g32MFhxBXR2tUsAYANPHD9rHWI5B-YBaDOQbX-IcqU37UsReCBp1Wh7L5Av26ezTyVpJP4PYFJwmvxRLkKOmDbT4977Be-PB1-ZH5Rt1nSCG-_r6Uz__xm2GC32R6_lb3VVNIUAh53Rt6_gucdvutBuwAdusUGqP-pvB1jP9DWLrpo2m47DUZ1DpwH_9rge38I_3WqRBzf4NlP7OTEvRsNVu9V-ga9rwPS97FxyKaNWnYaA13uo9lp0diAfOEzWQJXPrr5QckchXDuukmIGHkG8zGorebwFEnAq_6nY7nxVE7BZZ0XJuTwfRH6eArF_OYDH0bN-NEI1szV7EWgRq91dLv221tt3UL93RyO4fUYxtu4VuS8iuBmXkAYe83T15QnvFTst-96U67-phIZZtbLoLVdFoYZTwNazzG4aqFfE2QDZ32n3vzLwL-RVsC6QnDo-WvkI3Snym-Jyc_4vSRqJ-4mtnGMM785m8j6Vjj94indHWOdTe9Jw9yjwTa2ULa8pjC_p05pNEIcLzVKESL1FDXFQoyWR0xeIhAhH2kA8TNx-5XUUe8IX8PGJ_ATDeznx6VtXjj7LTVLbsVut0tobN3Yy-fTRPIcMF6DCd83iVXJh6kS583-DVjku0IjBI7znMfnxddh6QrGPWuTxbq_XKsbSGw6vb=s673-no" alt="" title="Album Stream: Papoose &#8211; Underrated"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/15/album-stream-papoose-underrated/" rel="bookmark" title="Album Stream: Papoose &#8211; Underrated">Album Stream: Papoose &#8211; Underrated</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/15/ep-stream-yung-bleu-bleu-vandross-2/" rel="bookmark" title="EP Stream: Yung Bleu &#8211; Bleu Vandross 2"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/Ls6PYAzVU2w1dqtxftwpjENt1AJEmGXr8cL6_wSoUF7WUc3BGOA2Ra5idyGgoUAMQxOqtYpkMJNGqdvVOKawDhl2g40129F6jvWSdGMCBuHLbCcA8G4QqZj8vEQ8llBfKglIUDRn1c7MRXfM5NE6Lr82jgJyWV2AO7jTYrWr0BvnasSA9d0vv67bU6NXhrpe16HAKVpPShb6ALh_odBtRlH6BsIzApecJ9xG67w1H4e-yZYWN4BeqTN2rSOKzqOPG1YsiFGLFYYZcpHw65J-Ksy5Ub3QLh-sx3k5_18cebr5P1Gz5gjkGTR32Wa3H1sAG4x-FvLVngLumz4J4jzUWrkJCQtgmRL4kj_h6h0_blOzPw6Prskdxi_zrMuHkDCV4PZEKYNLwTWvqyWunM1i89BtX_wflFkGhpOmV156zHUCzfbRD9aAl6LYopGXBfFWOLo2fM9GSU1W_Deg1ENXQXQY0I6uHjsvB1odG5N0U-HzOZtrd4gl-BS3kmLOJ1MqjeLIr1azvmp5AdIRlw3743c2W2jYFut5cm8XzSP88KmOfZsA43gZeNY-c96bXfaRytUIFM_V-W2hQ8Uc2NauJj31ZKJr6qifQuPpjk-5PUJ355BMLE8uMM9CHoWZMWGgI84xj189If9obPyy04EEYcVNCPz2GfWB=s673-no" alt="" title="EP Stream: Yung Bleu &#8211; Bleu Vandross 2"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/15/ep-stream-yung-bleu-bleu-vandross-2/" rel="bookmark" title="EP Stream: Yung Bleu &#8211; Bleu Vandross 2">EP Stream: Yung Bleu &#8211; Bleu Vandross 2</a></h3>            </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_23_5c68a7366d75b" data-td_block_id="td_uid_23_5c68a7366d75b"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_23_5c68a7366d75b" data-td_block_id="td_uid_23_5c68a7366d75b"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a>
<ul class="sub-menu">
<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_24_5c68a73673c77_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_24_5c68a73673c77" ><script>var block_td_uid_24_5c68a73673c77 = new tdBlock();
block_td_uid_24_5c68a73673c77.id = "td_uid_24_5c68a73673c77";
block_td_uid_24_5c68a73673c77.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_24_5c68a73673c77_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_24_5c68a73673c77.td_column_number = "3";
block_td_uid_24_5c68a73673c77.block_type = "td_block_mega_menu";
block_td_uid_24_5c68a73673c77.post_count = "5";
block_td_uid_24_5c68a73673c77.found_posts = "1241";
block_td_uid_24_5c68a73673c77.header_color = "";
block_td_uid_24_5c68a73673c77.ajax_pagination_infinite_stop = "";
block_td_uid_24_5c68a73673c77.max_num_pages = "249";
tdBlocksArray.push(block_td_uid_24_5c68a73673c77);
</script><div id=td_uid_24_5c68a73673c77 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/music-video-dizzy-wright-ft-eric-bellinger-picture-perfect/" rel="bookmark" title="Music Video: Dizzy Wright ft. Eric Bellinger &#8211; Picture Perfect"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/nxVARw-JBVf8rO_l2uve6KNCfSIjAarkkbgyS2qqUeEDzGo5KjtfQnkjtJ10yrRonj_bMB2RzaMri0E_8s6vSp7HIa1iI2FFJtvyIAFwfktklyBdR_pw0pDWF2Zd9O-q85DAFCpbHgBrppZ3z5mZBpbeY11h8hsdAdjWSHwMcQJc4k23gKoD6R47pbCWcz0UWVGosUP0xE_k-B4LSRIwspsarGHlvkSCIV-pFcthBxxFZsrNptnhQfEzc6xuRFTZPbm4PWAeyYj_4gCwyBbjnRzBqo5eCzJyFPPv8vO1p6i9fgPwQ6sJ_4RDz22q_4drmWenRmSI3Hrc3LznTbdNiERDq6V3eIkw7ZMfMh3a8Aso6tJd09HLZtzzfBZDPK7NRSxnK8d1gwVR2AtqWXLEG1oAnDudYsK52qIh-VVsMsIgqza_R-mRcOSgL1aAg4s6ZmV_5h4n-FLbbhP23dfxNBHb1jjjAwL5kLK_zZSafXLTNgt_BQJ9-FZOCu1AYBMIL0xxAC3Pfg04gJZbMGv_jEIrnKFdQ2plyNYTRZ4wCr5V696KY-whFdU34YpgsYM8SaoHJZ68XvG2LQcJTCszcXEecyHZkPSls_UdnTLRDYiDX3_LVOkss-_j1MnVinoUCBsXDL_aStd8QG1cSW5KXOHE-lOaZSR8=w954-h452-no" alt="" title="Music Video: Dizzy Wright ft. Eric Bellinger &#8211; Picture Perfect"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/music-video-dizzy-wright-ft-eric-bellinger-picture-perfect/" rel="bookmark" title="Music Video: Dizzy Wright ft. Eric Bellinger &#8211; Picture Perfect">Music Video: Dizzy Wright ft. Eric Bellinger &#8211; Picture Perfect</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/music-video-070-phi-good-contracts/" rel="bookmark" title="Music Video: 070 Phi &#8211; Good Contracts"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/_hGeMUCs88bbhx2vDHiK1QhjUTFwXYfEeH0SSspmK_RmsoLaZ03uOJSYu69ZRInOV8CXjxa2CdGL6VgS7YQh9adhxKpQqLGOGtI-EICN1wkH95gimd0Xm19xuwFapZJPxYK3Yt2-B2fVlu--K2DIWkOjPr-h-7N5z3zDKjtvYT4nSbOK8K4zgV8NHnXkDVYnFoHmmLlNPyOYVUNLnuNX26VY8TAW5zxloyFjlDjZHcezGv2O-mMJXAVhKiWUkeFrlw5vo0RhA85cVSawiMRGAUainKC-3IuphGJ7YJbDp2sh6b4rgX-Z-_NSDo0MHPLJfmABYoXBScfYgZdC6hCu_9ojUNSur8V_pfhMFVrM2oL5iRcrNTldkUflKz_mKHR41_GEZPgUyAvUUKMeGt1w9xkZ9YPFjYIhlB-voQWT9ym6On4sM2BMJN6SktNZt8qifVtiPHxsZZIaz351BuCVbjvOdQV7HGroemFgiYNXIPQzISIK1f18fd5ngQrk5ZoDVXOwlQ2SnFJRnhbXvW7OTSY4W8HDrGxVPya9HYiGC_66hD9haKFRztIWZfMvF5G-cxvbhZbjEnCrAETuKIRQxRjq69RpK8fwLqAnZc4hs3_pONZAFYxmIEBJajaU6IX8P9rUKvUgExLtR_EflOzAx8SWn0t9Y3Wy=w908-h435-no" alt="" title="Music Video: 070 Phi &#8211; Good Contracts"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/music-video-070-phi-good-contracts/" rel="bookmark" title="Music Video: 070 Phi &#8211; Good Contracts">Music Video: 070 Phi &#8211; Good Contracts</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/music-video-ynw-melly-mama-cry/" rel="bookmark" title="Music Video: YNW Melly &#8211; Mama Cry"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/ogQw1JIIeXNxzDd9429qrHEsufXukXd1AuhHndWzNfF5sflAXpZsyeryBs-rRYKQ1HL9iN-5G-iijAtIJUpEG7MCa4UOLknl3MNAPuwgteh2LrTkWmvHHvLn9YPnuU2NXc5dqsWuj_KWwYa3Rc_QEzwsJdY4ctVQGpblCNQFdP1kmMmRg9K5qfBVzCWwHxojpP9vqRoWU_VWKWTKinLbj7qDoVZhubscww5PmoCLSzHZJsJqwVUHyyQOGsG3uZl84msh-beVTGUTm-GE6gKsL3oSBi9y5HxB-OP0e5uR2GLSj1uEY6pWr6mMzTupjjibEFH43mQ_l0d4wx5EaxW5-eN0lvUFC7WP6RRWP7g94bx1UxKNp7AlAkey4LgqcOz9-9EqxW0gaGHDh3mFOrR03CjJ4cid6yXTQCs0VhDtizMvNe96VWDAr_vkhhfLK7UHQilTrBzzxj6NLcgWcig1fJxcRmJR9jJvz14bqYP31PSWdkY7Ysh3FwTzcCb6yjhYEotabAeB9lxXdFBbzhTSVHq7BrO-jf9sNM5VFC_PoEzOeSEME45aBi-erK_JYnU4GEsS5l2s5-zX6oJLecNgvvRrPjS62y2qoNDYZuBTmZiLQLVBrV6lI2CgZRy9xdP-gSLZmawcheKvpu2yaDzRdlPCFD1WYUMz=w914-h452-no" alt="" title="Music Video: YNW Melly &#8211; Mama Cry"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/music-video-ynw-melly-mama-cry/" rel="bookmark" title="Music Video: YNW Melly &#8211; Mama Cry">Music Video: YNW Melly &#8211; Mama Cry</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/music-video-blueface-ft-cardi-b-thotiana-remix/" rel="bookmark" title="Music Video: Blueface ft. Cardi B &#8211; Thotiana (Remix)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/PT8y2Lc1vyX_8yC7nRtUgqz334GegZstCQpHNFp6iDG2qi0NqyPUywrqX2ALfXSaW9t4Xae67wgVyeGAfdRnbPusg87NqCLTW9AVhVKd5LUmy2Z1KIY6mRr_NEGLndCbn-g1GLKjnOqM0vX-89LVNMIvQm5gz4O4keVgdlsXjyxMX9c8rVvQk5SgfhapK6i7DTxtj4QfsIaRUBxBPUOzBwwCjCdrBoSfjfnxQfrPQoFDA69FrewXLmEpiWDaSVgM3f7ifak7zNVc0cBWqVPo0MLHVLUSz1n92jxgac9I4hAJlaHsGtrLY962a8iDB3BNRqjW5ychEJx1nXV9a-SRPpbZZVfZedWj5ZPL4jZR4tiVLIGI_POHbK-reKhL-yFUrzcbubkb23Cd-K-uy7jrLm4hCirruPFJLQieoasvtUiiMv33F_Drw_nurPogDYiJhkCIgtMD5eEI4Jd9ubTCqpZos68M5KnT7B8X_-dfBgkR5DdczYO-NXwLNjlplYQeC_-5o0twmjI6PP9KrII3ktpNXowc7SRC_bzFQ46H8VcaRSiHrfleM5OxvjaGa1P0oZtwmw7sawFohPDqhhw3o0jdC__Agv5CzT5jt4Hl-Tja6JuMetvcvvLk-RG6KeOnTnmt6dlYqBE2_OT2JSzd9s9hpqBHKUsm=w933-h503-no" alt="" title="Music Video: Blueface ft. Cardi B &#8211; Thotiana (Remix)"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/music-video-blueface-ft-cardi-b-thotiana-remix/" rel="bookmark" title="Music Video: Blueface ft. Cardi B &#8211; Thotiana (Remix)">Music Video: Blueface ft. Cardi B &#8211; Thotiana (Remix)</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/music-video-pressa-longway/" rel="bookmark" title="Music Video: Pressa &#8211; Longway"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/1uCizTShglv_cwHOyg-LVWZBWPNqkUES-9yl9613iRjWPW_APDgiBAtDEnAvJPiPSM2Os6L_sUS5eAUc-hM-Rqng6C9Y6EDyuMaGm6SvaRgdCCobsnerndwTXtS0k5nYw-ueMy4ZXc9UgtbTMZMe0TlmXTccCCO175y3TDg_Jdj0fDfyF8aOojxqgiuaw2gbDIBCviQd-vll5Dw6HQUP7NpP66eugKvHF5RLQLhuTMe-LYuBIjlWGR-Br_NqIdwYqY2RwRwa27c40kBSeqxo-F5mzd1AttOmJ_UNFZ7OnDLMHa123dySfXDgVKXA6O2I6lJqQdXhmWjijckWgY1qI7d-wSGLAipZ6PN2vux579pnYTC8EdhWQ5KDsWhH4Lnb91r3zfWj3hmcx9RmmiUDxfNhNU_UBHbYwunwcKNzQxKu-rFSoSarJwPTwZ4jepA6ewQnOKnkG8AGAFeun1ztLlBcs5hXpZZg56rng_yunRCz_DGfDSlEEkXzKdtEb4OMTi5jpsW4XP7QBoHlm9ff-vMXhYoKMo1Y5Y6_250g7fmdU3Zxg8TJqrApquVD0B2PbcHd1bGFOg6a_-GuDZCranDodErt5Lm2x4NYZXLHOP_Ifw26qNmyRHcj_6v3STXvb55QsPko4WpnbTEctXedLD415qxN3V-y=w889-h479-no" alt="" title="Music Video: Pressa &#8211; Longway"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/music-video-pressa-longway/" rel="bookmark" title="Music Video: Pressa &#8211; Longway">Music Video: Pressa &#8211; Longway</a></h3>            </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_24_5c68a73673c77" data-td_block_id="td_uid_24_5c68a73673c77"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_24_5c68a73673c77" data-td_block_id="td_uid_24_5c68a73673c77"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News</a>
<ul class="sub-menu">
<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_25_5c68a73679e89_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_25_5c68a73679e89" ><script>var block_td_uid_25_5c68a73679e89 = new tdBlock();
block_td_uid_25_5c68a73679e89.id = "td_uid_25_5c68a73679e89";
block_td_uid_25_5c68a73679e89.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"29","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_25_5c68a73679e89_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_25_5c68a73679e89.td_column_number = "3";
block_td_uid_25_5c68a73679e89.block_type = "td_block_mega_menu";
block_td_uid_25_5c68a73679e89.post_count = "4";
block_td_uid_25_5c68a73679e89.found_posts = "488";
block_td_uid_25_5c68a73679e89.header_color = "";
block_td_uid_25_5c68a73679e89.ajax_pagination_infinite_stop = "";
block_td_uid_25_5c68a73679e89.max_num_pages = "122";
tdBlocksArray.push(block_td_uid_25_5c68a73679e89);
</script>            <script>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</script>
<div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_25_5c68a73679e89" id="td_uid_26_5c68a7367b37b" data-td_block_id="td_uid_25_5c68a73679e89" data-td_filter_value="" href="http://weuponithiphop.info/category/latest-news/">All</a><a class="mega-menu-sub-cat-td_uid_25_5c68a73679e89"  id="td_uid_27_5c68a7367b47c" data-td_block_id="td_uid_25_5c68a73679e89" data-td_filter_value="69" href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a><a class="mega-menu-sub-cat-td_uid_25_5c68a73679e89"  id="td_uid_28_5c68a7367b5a6" data-td_block_id="td_uid_25_5c68a73679e89" data-td_filter_value="80" href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a><a class="mega-menu-sub-cat-td_uid_25_5c68a73679e89"  id="td_uid_29_5c68a7367b6c0" data-td_block_id="td_uid_25_5c68a73679e89" data-td_filter_value="2189" href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a><a class="mega-menu-sub-cat-td_uid_25_5c68a73679e89"  id="td_uid_30_5c68a7367b868" data-td_block_id="td_uid_25_5c68a73679e89" data-td_filter_value="10" href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a><a class="mega-menu-sub-cat-td_uid_25_5c68a73679e89"  id="td_uid_31_5c68a7367b9f7" data-td_block_id="td_uid_25_5c68a73679e89" data-td_filter_value="130" href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></div></div><div id=td_uid_25_5c68a73679e89 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/21-savage-turns-himself-in-on-theft-warrant/" rel="bookmark" title="21 Savage Turns Himself In On Theft Warrant"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/7XW8K9WxyS-11xg9huUXIHewaNsgKj2TylXndYqqT3HPl3OPLZUs2jEDImOmIWUHABPrYvPyra2WZxBJz-LSOnPcbxfn_TLg36qJITaeRx4pWQJTwr9yjPgDBBY5MR0IlOKSxAy5emPvQx-LX6jmbq37cTZzi6hdFxMrYEpiDIloAus91zXBMWX-fY6umuS6JJygmQ_8w2C7YLPDa7XM2iKAmV1CNzi5jM-SUGbQ5OdARdludojSoL0dV-JlKDiJNZ7YI2gHfua4raF1pR34YxtmYPNvuMtavtA5D7Ad3jpwCV8T6XSIq016_hKWJEFvGOtU-NAmRao_bteeDfs8rPezl97R7H8LQ-94_H8oipEE-NueOqJD5D69Nf8grqpnyrcvEkyCCO89cMxFr1diuyAzzSAB9tfFxg-sBOSiyaWPX2l9u6OwbHO6LPOKTyRTjHjKMthqCA_pT5I_K8_P8oE1eXhoGAWEhiH5QDwEaU62nV3zgGdX96X5mLx8rc-H2AZkZpRVi36rca16ALbJBqP0LgpRPSCh6H-tm3Q1AUH43l8ZzsSCUGipW6xzaG5M4jo70Yes0SSd_QVs4gdYar5gfOPa0VI4r_clpVO54cPDyKtJumCB0oZWWV1jCH5AZwBjFI_pV_ebntPqijwF8aIhpHUPgj-B=w470-h582-no" alt="" title="21 Savage Turns Himself In On Theft Warrant"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/21-savage-turns-himself-in-on-theft-warrant/" rel="bookmark" title="21 Savage Turns Himself In On Theft Warrant">21 Savage Turns Himself In On Theft Warrant</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/video-21-savage-good-morning-america-interview/" rel="bookmark" title="Video: 21 Savage &#8211; Good Morning America Interview"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/O2AQvaG5CCgD-WUwn5zZbvaStEelaIJ8ljtMW1Kas05Dpp6vw0LMCIWggkBK1esH_F3hflo-aQHkjieo5flhJU5GCjTiLKirIkCg7ShznEGdPhIL6gCSmBvBa_UrPIjnd_G7MIGm_uHR5uD40oXGfvD0FTIsVOLGAdbCQgVdqMa9HJwZsQKRevIA8tmizeArDyW2rpm5D4AIDIsxywPqn_7JZT_S9uon31rp-KiGpkh4SdXSfmcqyLFOpbE8KwBbPxRXoQe3mZt8WDtaUqB6XmxZ8iwi7jSk4GvC6EcOPECfkeZQ_DXTeixwuybxjX2yr5OnDQywsczZg9xkVJZfCShH_PQTF02MP96uG_En7D_NwYEvatrVbjmKgYE7b68IlLE_6wFWJOpQoqFtX7H32pSwT5aGDIF81JLQLc2j_DvPCN3eZqoXZcZ2iAMUVsNyZbRsTinaZb-ibTdgaNWmksZyLVRF11ltx3ugSO0djVvAR8MZZDt1AQQaLKL3u6WGDNN2hPt0Ua-rTn_JzS_roEXIoTsiAvOYwj3H0OGVqEEYhDaszJVgZa1WG4KsURD3uC6lvjPIe0QuLHwEQP15umo7rRpnkyxeOLpPAtm24g-BslW6A2j1R-JfouB3xnp6zJzjFLju3oE-Acj-kZgd3eFVSHxAhsK3=w620-h345-no" alt="" title="Video: 21 Savage &#8211; Good Morning America Interview"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/video-21-savage-good-morning-america-interview/" rel="bookmark" title="Video: 21 Savage &#8211; Good Morning America Interview">Video: 21 Savage &#8211; Good Morning America Interview</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/15/video-kanye-west-has-kenny-g-to-play-for-kim-kardashian-for-valentines-day/" rel="bookmark" title="Video: Kanye West Has Kenny G To Play For Kim Kardashian For Valentine’s Day"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/zBO8Dln0tpExLGtUdsttUqXsAIv9jyNzEHieUpqdJ0VRZKV59MuIFrzK8Un5XyB5ieWfYnT0JKJs6yTMBj84scMTK6psXRN_cpcfM-UqOUmYBnDuTMdLO37SYmN9607QmgvCXhCecgSxNdFNlWHgC97fORUH9wW9dWCQaPkh0j96n-rnZ5YOj3Rg2V2ZTa0yEcd2LBw9xB64Mz2kXkSYzTDpIgjuB3nAOT7Xu7JWavOThAfH1GYVyVcguQH7F_Q9wxIf7kj2bP3d03qfIoJl0TwOt2FikA51MNd1Gi_kivwAWAGpojfQka-eQNQ-2ZaQM0j0jmJXl0bFpnzLZL5m1fhPtlINYIcAPIl0-WAf3WUgA4D_v2LQzl3TexuRlcFAwDB7azxsOEmg8bzMGS9RFw5ls-BBpPQ2NtO1uUFeTqD2vsZeCUqWsYZA9IHvB0HH-ou3FTd1r60wCCQZIDeTplbs7zdHzNz47vKJDES3CMuNNf56T8VHGIrVpJgVwEiluM6upc5kJ1wUmSUSYlvxhE9AYW35QXWdZqtWsw6br0sbAEkiM1zHmN5Q89zdXm--ifog4h8Tjm2R-MxdirYgIqxRtUrePRZ0g4uTMNfqWKiioHxSro87-piZwovDDJYr0qF3DfqHJ7v2otRiV6nHRzXVQa1MvC5D=w505-h673-no" alt="" title="Video: Kanye West Has Kenny G To Play For Kim Kardashian For Valentine’s Day"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/15/video-kanye-west-has-kenny-g-to-play-for-kim-kardashian-for-valentines-day/" rel="bookmark" title="Video: Kanye West Has Kenny G To Play For Kim Kardashian For Valentine’s Day">Video: Kanye West Has Kenny G To Play For Kim Kardashian&#8230;</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/15/kodak-black-announces-dying-to-live-tour/" rel="bookmark" title="Kodak Black Announces &#8216;Dying To Live&#8217; Tour"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/UcN7uHdIbkQiJ5XjqNtuho7s6W522OHmXoD1sLSSGnomfdqZXLPm8rJz8Z8LgI1fON4c0Xho1xArRSYuo8cJPYoCUly5HCYzrz1GX5pikdOJYcilcxuoI-Xxj1G2a3bz7glCeWPfqs11dnyF7Zp9TSs_3a7ILaJYDxgQ_YyOVzrT0MCXKTzDV8Y8kwwMy05LnQHLYp_C6rGofpsbKS_V7RmQKa3R-9v9lGfWoDpiv7PVwRt7tck68CgNxcJA2jGjd1AMl6Y_XqXZpiGbOz199kB67hMHez0_fOOpxWJKIMABvU6SxDAneiKCuSr0anwA1xhLVied1ujsAEsIpcZgSOO_Q4xhGUK5veHJaEsx-tt-8_RN_7fHEE18x-nLWwJhbBRiog_1UWGG7_55pB4wwGbhRdg52Od7KRKedhYvDaAKlZ_zm3cg-q2w3Gd_X4f-Z1i3VdptMCUPP_HztV60xQbzMdtWS5iOA8mSk3tx5bUT-EUJHLNRfbQ_QrhnwN-WGag3Gszp357xmp3j6hmZnPv-3ws9yuXX7oGKLGACGjJMgcvhVItmfI6VaxiwK5HoWNsLuhFrJVSp0VWoL3tOx3kgjufYGqLUdPwRyB8WJgMsuMnchG0jRY-bMNaP63c7WgLUZfJ4JQhScWcZkTzrvhft9Yn_4kxN=w620-h535-no" alt="" title="Kodak Black Announces &#8216;Dying To Live&#8217; Tour"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/15/kodak-black-announces-dying-to-live-tour/" rel="bookmark" title="Kodak Black Announces &#8216;Dying To Live&#8217; Tour">Kodak Black Announces &#8216;Dying To Live&#8217; Tour</a></h3>            </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_25_5c68a73679e89" data-td_block_id="td_uid_25_5c68a73679e89"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_25_5c68a73679e89" data-td_block_id="td_uid_25_5c68a73679e89"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion</a>
<ul class="sub-menu">
<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_32_5c68a736aae3b_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_32_5c68a736aae3b" ><script>var block_td_uid_32_5c68a736aae3b = new tdBlock();
block_td_uid_32_5c68a736aae3b.id = "td_uid_32_5c68a736aae3b";
block_td_uid_32_5c68a736aae3b.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"77","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_32_5c68a736aae3b_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_32_5c68a736aae3b.td_column_number = "3";
block_td_uid_32_5c68a736aae3b.block_type = "td_block_mega_menu";
block_td_uid_32_5c68a736aae3b.post_count = "4";
block_td_uid_32_5c68a736aae3b.found_posts = "152";
block_td_uid_32_5c68a736aae3b.header_color = "";
block_td_uid_32_5c68a736aae3b.ajax_pagination_infinite_stop = "";
block_td_uid_32_5c68a736aae3b.max_num_pages = "38";
tdBlocksArray.push(block_td_uid_32_5c68a736aae3b);
</script>            <script>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</script>
<div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_32_5c68a736aae3b" id="td_uid_33_5c68a736abcbd" data-td_block_id="td_uid_32_5c68a736aae3b" data-td_filter_value="" href="http://weuponithiphop.info/category/fashion/">All</a><a class="mega-menu-sub-cat-td_uid_32_5c68a736aae3b"  id="td_uid_34_5c68a736abdb3" data-td_block_id="td_uid_32_5c68a736aae3b" data-td_filter_value="76" href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></div></div><div id=td_uid_32_5c68a736aae3b class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/04/air-jordan-1-wmns-retro-high-og-unc-blue-chill/" rel="bookmark" title="Air Jordan 1 WMNS Retro High OG UNC (Blue Chill)"><img width="218" height="150" class="entry-thumb" src="https://pribitre-cdn.sirv.com/WP_weuponithiphop.info/Air-Jordan-1-WMNS-Retro-High-OG-UNC-Patent-Blue-Chill.jpg?scale.width=218&#038;scale.height=150&#038;scale.option=fill&#038;cw=218&#038;ch=150&#038;cx=center&#038;cy=center" alt="" title="Air Jordan 1 WMNS Retro High OG UNC (Blue Chill)"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/04/air-jordan-1-wmns-retro-high-og-unc-blue-chill/" rel="bookmark" title="Air Jordan 1 WMNS Retro High OG UNC (Blue Chill)">Air Jordan 1 WMNS Retro High OG UNC (Blue Chill)</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/04/nike-zoom-rookie-galaxy-2019/" rel="bookmark" title="Nike Zoom Rookie Galaxy 2019"><img width="218" height="150" class="entry-thumb" src="https://pribitre-cdn.sirv.com/WP_weuponithiphop.info/Nike-Zoom-Rookie-Galaxy-2019-1.jpg?scale.width=218&#038;scale.height=150&#038;scale.option=fill&#038;cw=218&#038;ch=150&#038;cx=center&#038;cy=center" alt="" title="Nike Zoom Rookie Galaxy 2019"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/04/nike-zoom-rookie-galaxy-2019/" rel="bookmark" title="Nike Zoom Rookie Galaxy 2019">Nike Zoom Rookie Galaxy 2019</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/29/nike-zoom-lebron-3-white-navy/" rel="bookmark" title="Nike Zoom LeBron 3 White Navy"><img width="218" height="150" class="entry-thumb" src="https://pribitre-cdn.sirv.com/WP_weuponithiphop.info/Nike-Zoom-LeBron-3-White-Navy-2.jpg?scale.width=218&#038;scale.height=150&#038;scale.option=fill&#038;cw=218&#038;ch=150&#038;cx=center&#038;cy=center" alt="" title="Nike Zoom LeBron 3 White Navy"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/29/nike-zoom-lebron-3-white-navy/" rel="bookmark" title="Nike Zoom LeBron 3 White Navy">Nike Zoom LeBron 3 White Navy</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/29/release-date-nike-air-max-98-wild-west/" rel="bookmark" title="Nike Air Max 98 Wild West"><img width="218" height="150" class="entry-thumb" src="https://pribitre-cdn.sirv.com/WP_weuponithiphop.info/Nike-Air-Max-98-Wild-West.jpg?scale.width=218&#038;scale.height=150&#038;scale.option=fill&#038;cw=218&#038;ch=150&#038;cx=center&#038;cy=center" alt="" title="Nike Air Max 98 Wild West"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/29/release-date-nike-air-max-98-wild-west/" rel="bookmark" title="Nike Air Max 98 Wild West">Nike Air Max 98 Wild West</a></h3>            </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_32_5c68a736aae3b" data-td_block_id="td_uid_32_5c68a736aae3b"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_32_5c68a736aae3b" data-td_block_id="td_uid_32_5c68a736aae3b"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-2515"><a href="http://weuponithiphop.info/category/editors-picks/">Editor&#8217;s Picks</a>
<ul class="sub-menu">
<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_35_5c68a736bdf09_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_35_5c68a736bdf09" ><script>var block_td_uid_35_5c68a736bdf09 = new tdBlock();
block_td_uid_35_5c68a736bdf09.id = "td_uid_35_5c68a736bdf09";
block_td_uid_35_5c68a736bdf09.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"118","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_35_5c68a736bdf09_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_35_5c68a736bdf09.td_column_number = "3";
block_td_uid_35_5c68a736bdf09.block_type = "td_block_mega_menu";
block_td_uid_35_5c68a736bdf09.post_count = "5";
block_td_uid_35_5c68a736bdf09.found_posts = "489";
block_td_uid_35_5c68a736bdf09.header_color = "";
block_td_uid_35_5c68a736bdf09.ajax_pagination_infinite_stop = "";
block_td_uid_35_5c68a736bdf09.max_num_pages = "98";
tdBlocksArray.push(block_td_uid_35_5c68a736bdf09);
</script><div id=td_uid_35_5c68a736bdf09 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/music-video-dizzy-wright-ft-eric-bellinger-picture-perfect/" rel="bookmark" title="Music Video: Dizzy Wright ft. Eric Bellinger &#8211; Picture Perfect"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/nxVARw-JBVf8rO_l2uve6KNCfSIjAarkkbgyS2qqUeEDzGo5KjtfQnkjtJ10yrRonj_bMB2RzaMri0E_8s6vSp7HIa1iI2FFJtvyIAFwfktklyBdR_pw0pDWF2Zd9O-q85DAFCpbHgBrppZ3z5mZBpbeY11h8hsdAdjWSHwMcQJc4k23gKoD6R47pbCWcz0UWVGosUP0xE_k-B4LSRIwspsarGHlvkSCIV-pFcthBxxFZsrNptnhQfEzc6xuRFTZPbm4PWAeyYj_4gCwyBbjnRzBqo5eCzJyFPPv8vO1p6i9fgPwQ6sJ_4RDz22q_4drmWenRmSI3Hrc3LznTbdNiERDq6V3eIkw7ZMfMh3a8Aso6tJd09HLZtzzfBZDPK7NRSxnK8d1gwVR2AtqWXLEG1oAnDudYsK52qIh-VVsMsIgqza_R-mRcOSgL1aAg4s6ZmV_5h4n-FLbbhP23dfxNBHb1jjjAwL5kLK_zZSafXLTNgt_BQJ9-FZOCu1AYBMIL0xxAC3Pfg04gJZbMGv_jEIrnKFdQ2plyNYTRZ4wCr5V696KY-whFdU34YpgsYM8SaoHJZ68XvG2LQcJTCszcXEecyHZkPSls_UdnTLRDYiDX3_LVOkss-_j1MnVinoUCBsXDL_aStd8QG1cSW5KXOHE-lOaZSR8=w954-h452-no" alt="" title="Music Video: Dizzy Wright ft. Eric Bellinger &#8211; Picture Perfect"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/music-video-dizzy-wright-ft-eric-bellinger-picture-perfect/" rel="bookmark" title="Music Video: Dizzy Wright ft. Eric Bellinger &#8211; Picture Perfect">Music Video: Dizzy Wright ft. Eric Bellinger &#8211; Picture Perfect</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/music-video-ynw-melly-mama-cry/" rel="bookmark" title="Music Video: YNW Melly &#8211; Mama Cry"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/ogQw1JIIeXNxzDd9429qrHEsufXukXd1AuhHndWzNfF5sflAXpZsyeryBs-rRYKQ1HL9iN-5G-iijAtIJUpEG7MCa4UOLknl3MNAPuwgteh2LrTkWmvHHvLn9YPnuU2NXc5dqsWuj_KWwYa3Rc_QEzwsJdY4ctVQGpblCNQFdP1kmMmRg9K5qfBVzCWwHxojpP9vqRoWU_VWKWTKinLbj7qDoVZhubscww5PmoCLSzHZJsJqwVUHyyQOGsG3uZl84msh-beVTGUTm-GE6gKsL3oSBi9y5HxB-OP0e5uR2GLSj1uEY6pWr6mMzTupjjibEFH43mQ_l0d4wx5EaxW5-eN0lvUFC7WP6RRWP7g94bx1UxKNp7AlAkey4LgqcOz9-9EqxW0gaGHDh3mFOrR03CjJ4cid6yXTQCs0VhDtizMvNe96VWDAr_vkhhfLK7UHQilTrBzzxj6NLcgWcig1fJxcRmJR9jJvz14bqYP31PSWdkY7Ysh3FwTzcCb6yjhYEotabAeB9lxXdFBbzhTSVHq7BrO-jf9sNM5VFC_PoEzOeSEME45aBi-erK_JYnU4GEsS5l2s5-zX6oJLecNgvvRrPjS62y2qoNDYZuBTmZiLQLVBrV6lI2CgZRy9xdP-gSLZmawcheKvpu2yaDzRdlPCFD1WYUMz=w914-h452-no" alt="" title="Music Video: YNW Melly &#8211; Mama Cry"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/music-video-ynw-melly-mama-cry/" rel="bookmark" title="Music Video: YNW Melly &#8211; Mama Cry">Music Video: YNW Melly &#8211; Mama Cry</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/16/new-music-meyhem-lauren-the-alchemist-still-playing-celo/" rel="bookmark" title="New Music: Meyhem Lauren &#038; The Alchemist &#8211; Still Playing Celo"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/rO_03NZ0s2Ts5EYLM09t8okvjAORCyJadvdxFajxqaoEzsn4BWGTZMr1PDbYXByZeW17ZjsTyls4HPsMeKhomse6mSc4bdEdp9lVfBUn_L_4pwTQbF5m3kjPXCs3HlzEX3T5SO4pIBF0xRxhAq6DsRkR2H-RjthpjIxk_xmB05hGLMXX2JsvHQcrN8IKG4DqTWH5UBt4DYmTs1u8-uymUnA1IYyl-kQ7OOE1AQ1bgjJXeI7x4GQzeQlBEr0KAzZ6hcTOv09pK_pA2gjc4IEItZOoAZ2RHCu7TwXJOIpmqvrmt7WjOqIl3bm6q_H25QmRd0tlIqz637kjWlaCYJYWTCZ5V6pD4P8tqag8WTo2u32CJiW2mY7Qsuv0-jd74EG-n4FJK6LJjgzW7_x6BU03PvMDltv-pF1qoWuLyTRlqtr9LPKaqd6pJ4Rg6G7HtLQKI4ymsUs6WeQUaAgP_ga4pGLb0VvJxkm8P3Icyrsuygry2Jx7Pmk6UpAnG21DnP14x2UlrZp9kwszYT1mcVZlQbNM9zxF8MQozoIHrPzJDhQH6_VrKm9Smm9n9cqNIrx5vvCGPzSTO-GwpXnR-E6nagV9nnw732-r89m_rm3BMhfkorGBWdNbV0ZnXeiRg9z9Xqlaon1pf9lqbjCc9uKERSC33It1lBlQ=s673-no" alt="" title="New Music: Meyhem Lauren &#038; The Alchemist &#8211; Still Playing Celo"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/16/new-music-meyhem-lauren-the-alchemist-still-playing-celo/" rel="bookmark" title="New Music: Meyhem Lauren &#038; The Alchemist &#8211; Still Playing Celo">New Music: Meyhem Lauren &#038; The Alchemist &#8211; Still Playing Celo</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/15/new-music-international-jones-appreciated-thank-you/" rel="bookmark" title="New Music: International Jones &#8211; Appreciated (Thank You)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/k8MIvN__Fdn-2AdhyeH7fGmowD-shhz-qQVcXq0-UTOhR9QM8cPAYtEU3ob-4ymDLz0vWZ_a5FYb8VoUtnboE_8r3h1DhXV8tAdwO1_cLJxnFoAKHu5y5Je2wC2MsjIYM4hossM8GKesxRWL-iqWCli7a2TwUXH8X71MobSRSaw1oE3uT38OD0dLVO3uATlALULIO2bNH6e2Jnsb-x44F5pb_kGQy8YXFc6x43pSNt2aOm4D6-T1cuz0nl4hrNIJGq0UDzRUlFAO92DwTdRXIEF-5bXOQF33UB0csGAAQY54UDA_pNwYctRN9ISLUz0wBdMHTWEECyKO1AoD22xuSPogNnIPmpRMBqSgN-SF69le7IQXLf1Oc22kQKGXB4ESXjp6gyOrsGskWlz_z-uYPd66wA5c0HCS7Fy4SZlZDt7Nlfrb8vaj4g_3JqEZfh3xt7_GR-jJKzqIbqLtZD6qUycl0EQpHzPCZHf5SMqs9LCBxLphIrTQRJ8jOkizDkW9vfLzmHS2tP25H_qp-juyqhZggrBUyE-MpsjnusLusWBktk1HTC0SsmEqL2lm7vLElJB65hJDWxs5ngrXjdAeh_4eFlrdnoINyMrM0qJS7wWGWmSvjrPQolDv8r-IU7ZhaQvME68NAj5T0la2ipjd_b-LDLP8ge5t=s672-no" alt="" title="New Music: International Jones &#8211; Appreciated (Thank You)"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/15/new-music-international-jones-appreciated-thank-you/" rel="bookmark" title="New Music: International Jones &#8211; Appreciated (Thank You)">New Music: International Jones &#8211; Appreciated (Thank You)</a></h3>            </div>
</div>
</div><div class="td-mega-span">
<div class="td_module_mega_menu td_mod_mega_menu">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/15/music-video-chip-tha-ripper-2-much-ass/" rel="bookmark" title="Music Video: Chip Tha Ripper &#8211; 2 Much Ass"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/wFsD5YXgkAMpp3lj88xxVlQ5xPBY5PnZV16rEfzepZgbbB3tR39tgfi8Rq78erYZKjW8fRbf9eSwMDJ_b3bnPMhrXnNIprLhlNfhL3dHTea9W3qs_6gQbjX_ilf4ekhGtZgWx9KVzsgY_uYFPqFojhzn2df3E_2RbE8DqFxOJuycvUyE-rBH8P4wc9gayc6SrKw2pZqte-0Xl5SZcMJBEP0XBPzewMbQjAdn6zTqp4TsBIOvEypYGW0D_NGHcYWJtWS7VvD_q8EpO3PhgFY3DGYy2wK0A6IZMwOVtsbR7UwQqKj9dzEMAmG2bnb3SwoBSN7IZ9efWl-DgvzF3Sc35eu1TsPQQzjN-1cGb33mggrn5YNINTPKk2umZ7rHf-DO6ia02nc8d5NQtbrqF6wcV7u03WDRuuuFM6IRsHlQ4Ni738ndf8WoC3BtiEjAuIhY33498XjzW61rprbOhlpIDve55WmaEAPX82drp_sDIebyeHc03qBh3Ax_G6pRCDgyckHowX-AeDaIkUjw7cOTD8iYyxIQRn9gx1U_BV4OdFNYP-zVouPHLu3rrswk9bhF9Ok8_w2kCuhDTRR_ilGPO53L9H5_P1PnpoZYoVsndkpZEzXCCFQ33723zEO4u1YuOOAiy5J9ZKVHkymgutzJf8pMEG4ZRH4y=w955-h508-no" alt="" title="Music Video: Chip Tha Ripper &#8211; 2 Much Ass"/></a></div>                            </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/15/music-video-chip-tha-ripper-2-much-ass/" rel="bookmark" title="Music Video: Chip Tha Ripper &#8211; 2 Much Ass">Music Video: Chip Tha Ripper &#8211; 2 Much Ass</a></h3>            </div>
</div>
</div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_35_5c68a736bdf09" data-td_block_id="td_uid_35_5c68a736bdf09"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_35_5c68a736bdf09" data-td_block_id="td_uid_35_5c68a736bdf09"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees/">Shop</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
</ul></div>                </div>
<div class="td-pb-span5 td-sub-footer-copy">
&copy; 2018 The Hip Hop Chronicles Media Group                </div>
</div>
</div>
</div>
</div><!--close td-outer-wrap-->
<div id="wpcp-error-message" class="msgmsg-box-wpcp warning-wpcp hideme"><span>error: </span>Not Prohibited. ✌️</div>
<script>
var timeout_result;
function show_wpcp_message(smessage)
{
if (smessage !== "")
{
var smessage_text = '<span>Alert: </span>'+smessage;
document.getElementById("wpcp-error-message").innerHTML = smessage_text;
document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp showme";
clearTimeout(timeout_result);
timeout_result = setTimeout(hide_message, 3000);
}
}
function hide_message()
{
document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp hideme";
}
</script>
<style type="text/css">
#wpcp-error-message {
direction: ltr;
text-align: center;
transition: opacity 900ms ease 0s;
z-index: 99999999;
}
.hideme {
opacity:0;
visibility: hidden;
}
.showme {
opacity:1;
visibility: visible;
}
.msgmsg-box-wpcp {
border-radius: 10px;
color: #555;
font-family: Tahoma;
font-size: 11px;
margin: 10px;
padding: 10px 36px;
position: fixed;
width: 255px;
top: 50%;
left: 50%;
margin-top: -10px;
margin-left: -130px;
-webkit-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
-moz-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
}
.msgmsg-box-wpcp span {
font-weight:bold;
text-transform:uppercase;
}
.error-wpcp {		background:#ffecec url('//h2r3t7s9.stackpathcdn.com/wp-content/plugins/wp-content-copy-protector/images/error.png') no-repeat 10px 50%;
border:1px solid #f5aca6;
}
.success {
background:#e9ffd9 url('//h2r3t7s9.stackpathcdn.com/wp-content/plugins/wp-content-copy-protector/images/success.png') no-repeat 10px 50%;
border:1px solid #a6ca8a;
}
.warning-wpcp {
background:#ffecec url('//h2r3t7s9.stackpathcdn.com/wp-content/plugins/wp-content-copy-protector/images/warning.png') no-repeat 10px 50%;
border:1px solid #f5aca6;
}
.notice {
background:#e3f7fc url('//h2r3t7s9.stackpathcdn.com/wp-content/plugins/wp-content-copy-protector/images/notice.png') no-repeat 10px 50%;
border:1px solid #8ed9f6;
}
</style>
<div style="display:none">
</div>
<!--
Theme: Newspaper by tagDiv 2016
Version: 7.2 (rara)
Deploy mode: deploy
uid: 5c68a736c7ea5
-->
<!-- <link rel='stylesheet' id='so-css-Newspaper-css'  href='//h2r3t7s9.stackpathcdn.com/wp-content/uploads/so-css/so-css-Newspaper.css?ver=1528674688' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//h2r3t7s9.stackpathcdn.com/wp-content/cache/wpfc-minified/eibgk02o/a863y.css" media="all"/>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201907'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2019Febaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='//h2r3t7s9.stackpathcdn.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.9.9'></script>
<script type='text/javascript' src='//h2r3t7s9.stackpathcdn.com/wp-content/themes/Newspaper/js/tagdiv_theme.js?ver=7.2'></script>
<script type='text/javascript' src='//h2r3t7s9.stackpathcdn.com/wp-includes/js/comment-reply.min.js?ver=4.9.9'></script>
<script type='text/javascript' src='//h2r3t7s9.stackpathcdn.com/wp-content/plugins/sirv/sirv/js/wp-sirv-diff.js?ver=1.0.0'></script>
<script type='text/javascript' src='//h2r3t7s9.stackpathcdn.com/wp-includes/js/wp-embed.min.js?ver=4.9.9'></script>
<!-- JS generated by theme -->
<script>
// if the theme has tdBackstr support, it means this already uses it
if ( 'undefined' !== typeof window.tdBackstr ) {
(function(){
// the site background td-backstretch jquery object is dynamically added in DOM, and after any translation effects are applied over td-backstretch
var wrapper_image_jquery_obj = jQuery( '<div class=\'backstretch\'></div>' );
var image_jquery_obj = jQuery( '<img class=\'td-backstretch not-parallax\' src=\'https://pribitre-cdn.sirv.com/WP_weuponithiphop.info/grafitti-3.jpg?scale.width=500&scale.height=500\'>' );
wrapper_image_jquery_obj.append( image_jquery_obj );
jQuery( 'body' ).prepend( wrapper_image_jquery_obj );
var td_backstr_item = new tdBackstr.item();
td_backstr_item.wrapper_image_jquery_obj = wrapper_image_jquery_obj;
td_backstr_item.image_jquery_obj = image_jquery_obj;
tdBackstr.add_item( td_backstr_item );
})();
}
(function(){
var html_jquery_obj = jQuery('html');
if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {
var path = 'http://weuponithiphop.info/wp-content/themes/Newspaper/style.css';
jQuery.get(path, function(data) {
var str_split_separator = '#td_css_split_separator';
var arr_splits = data.split(str_split_separator);
var arr_length = arr_splits.length;
if (arr_length > 1) {
var dir_path = 'http://weuponithiphop.info/wp-content/themes/Newspaper';
var splited_css = '';
for (var i = 0; i < arr_length; i++) {
if (i > 0) {
arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
}
//jQuery('head').append('<style>' + arr_splits[i] + '</style>');
var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
});
splited_css += "<style>" + formated_str + "</style>";
}
var td_theme_css = jQuery('link#td-theme-css');
if (td_theme_css.length) {
td_theme_css.after(splited_css);
}
}
});
}
})();
</script>
<script type='text/javascript' src='https://stats.wp.com/e-201907.js' async='async' defer='defer'></script>
<script type='text/javascript'>
_stq = window._stq || [];
_stq.push([ 'view', {v:'ext',j:'1:7.0',blog:'147622849',post:'24198',tz:'-5',srv:'weuponithiphop.info'} ]);
_stq.push([ 'clickTrackerInit', '147622849', '24198' ]);
</script>
</body>
</html><!-- WP Fastest Cache file was created in 3.1684529781342 seconds, on 16-02-19 19:13:43 -->