<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>Music Video: Diplo ft. Octavian – New Shapes</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="http://weuponithiphop.info/xmlrpc.php" />
    <meta property="og:image" content="https://lh3.googleusercontent.com/EHFKDTrxgrWLYANBBN8xsnYjBjHUQAJQItEkutjwV5tFz58wurUjFnwlHuywNIp0K1CrBlu7DPbGl1HGnYDWKjN7JcertJ152GsJzRgENXBENSYeqXMkyiDLqUlMIe37VAf-KVw34kW6sMrl11Q9PXuiKi68bg6-tU4w7ABOJihyXSHt7CxFYlbx2TcLIjpdoliVPZBrDr22T2oll9mHehdBGu3fs1oejWtJOCWVSZRBNBgmlW2zxQYzKwN-lJCCLAcY_0-1m_99Y-S_dna1aVelD2QSzSuftEoT1OkQ9DBcUZbgkd5EKOBpVW1tCefMhlnOvvCc39-JG2rsMg6-5r4SCQXXbQ_2Dl0tS9AjfI8VqnJbQKEe_40z7upMhigyvFBFk6ijitiuLvyL5zgp8A9zwQmb9dS1o6cx7icKHj8_Z6alhNTkNNhDm1jUKSCLacn165SxofOql21NBPys0TFYB100v-3SoV3Whm6DHprfGuErbShL8UjsHiE0fCaoKABW9F-iniTlrU12i6rTXPn76FozTPeTK61Wb0pa3ewIdglLR2GXdS2HVL7oQzc7pdicw8xk8NOef6zwTXHrAjUE1BvRogpRnVP2QA49H6OSrWW7NSx8VERbmT-UpFOQ4pWzqMg8EEX8rCcmYlI9uNyBzXcoHoVP=w683-h477-no" /><meta name="author" content="cyclone">
<link rel="icon" type="image/png" href="http://weuponithiphop.info/wp-content/uploads/weuponitlogoCAP-500x457.png">
<!-- All in One SEO Pack 2.12.1 by Michael Torbert of Semper Fi Web Design[208,270] -->
<link rel="canonical" href="http://weuponithiphop.info/2019/05/22/music-video-diplo-ft-octavian-new-shapes/" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Feed" href="http://weuponithiphop.info/feed/" />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Comments Feed" href="http://weuponithiphop.info/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Music Video: Diplo ft. Octavian – New Shapes Comments Feed" href="http://weuponithiphop.info/2019/05/22/music-video-diplo-ft-octavian-new-shapes/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/weuponithiphop.info\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.10"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='google_font_open_sans-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_roboto-css'  href='http://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C900%2C500italic%2C400%2C300&#038;ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='http://fonts.googleapis.com/css?family=Roboto+Condensed%3A400%2C700&#038;ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='http://weuponithiphop.info/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=4.12' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='http://weuponithiphop.info/wp-content/themes/Newspaper/style.css?ver=7.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css'  href='http://weuponithiphop.info/wp-content/themes/Newspaper/includes/demos/what/demo_style.css?ver=7.2' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://weuponithiphop.info/wp-content/plugins/jetpack/css/jetpack.css?ver=7.1.1' type='text/css' media='all' />
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1'></script>
<link rel='https://api.w.org/' href='http://weuponithiphop.info/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://weuponithiphop.info/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://weuponithiphop.info/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Music Video: Jacquees – Live Ya Life' href='http://weuponithiphop.info/2019/05/22/music-video-jacquees-live-ya-life/' />
<meta name="generator" content="WordPress 4.9.10" />
<link rel='shortlink' href='https://wp.me/p9ZprH-7Ob' />
<link rel="alternate" type="application/json+oembed" href="http://weuponithiphop.info/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fweuponithiphop.info%2F2019%2F05%2F22%2Fmusic-video-diplo-ft-octavian-new-shapes%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://weuponithiphop.info/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fweuponithiphop.info%2F2019%2F05%2F22%2Fmusic-video-diplo-ft-octavian-new-shapes%2F&#038;format=xml" />

<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>
<script id="wpcp_disable_selection" type="text/javascript">
//<![CDATA[
var image_save_msg='You Can Not Save images!';
	var no_menu_msg='Context Menu disabled!';
	var smessage = "Not Prohibited. ✌️";

function disableEnterKey(e)
{
	if (e.ctrlKey){
     var key;
     if(window.event)
          key = window.event.keyCode;     //IE
     else
          key = e.which;     //firefox (97)
    //if (key != 17) alert(key);
     if (key == 97 || key == 65 || key == 67 || key == 99 || key == 88 || key == 120 || key == 26 || key == 85  || key == 86 || key == 83 || key == 43)
     {
          show_wpcp_message('You are not allowed to copy content or view source');
          return false;
     }else
     	return true;
     }
}

function disable_copy(e)
{	
	var elemtype = e.target.nodeName;
	var isSafari = /Safari/.test(navigator.userAgent) && /Apple Computer/.test(navigator.vendor);
	elemtype = elemtype.toUpperCase();
	var checker_IMG = '';
	if (elemtype == "IMG" && checker_IMG == 'checked' && e.detail >= 2) {show_wpcp_message(alertMsg_IMG);return false;}
	if (elemtype != "TEXT" && elemtype != "TEXTAREA" && elemtype != "INPUT" && elemtype != "PASSWORD" && elemtype != "SELECT" && elemtype != "OPTION" && elemtype != "EMBED")
	{
		if (smessage !== "" && e.detail == 2)
			show_wpcp_message(smessage);
		
		if (isSafari)
			return true;
		else
			return false;
	}	
}
function disable_copy_ie()
{
	var elemtype = window.event.srcElement.nodeName;
	elemtype = elemtype.toUpperCase();
	if (elemtype == "IMG") {show_wpcp_message(alertMsg_IMG);return false;}
	if (elemtype != "TEXT" && elemtype != "TEXTAREA" && elemtype != "INPUT" && elemtype != "PASSWORD" && elemtype != "SELECT" && elemtype != "OPTION" && elemtype != "EMBED")
	{
		//alert(navigator.userAgent.indexOf('MSIE'));
			//if (smessage !== "") show_wpcp_message(smessage);
		return false;
	}
}	
function reEnable()
{
	return true;
}
document.onkeydown = disableEnterKey;
document.onselectstart = disable_copy_ie;
if(navigator.userAgent.indexOf('MSIE')==-1)
{
	document.onmousedown = disable_copy;
	document.onclick = reEnable;
}
function disableSelection(target)
{
    //For IE This code will work
    if (typeof target.onselectstart!="undefined")
    target.onselectstart = disable_copy_ie;
    
    //For Firefox This code will work
    else if (typeof target.style.MozUserSelect!="undefined")
    {target.style.MozUserSelect="none";}
    
    //All other  (ie: Opera) This code will work
    else
    target.onmousedown=function(){return false}
    target.style.cursor = "default";
}
//Calling the JS function directly just after body load
window.onload = function(){disableSelection(document.body);};
//]]>
</script>
	<script id="wpcp_disable_Right_Click" type="text/javascript">
	//<![CDATA[
	document.ondragstart = function() { return false;}
	/* ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
	Disable context menu on images by GreenLava Version 1.0
	^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ */
	    function nocontext(e) {
	       return false;
	    }
	    document.oncontextmenu = nocontext;
	//]]>
	</script>

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]-->
<!-- JS generated by theme -->

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var tds_login_sing_in_widget="show";
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_ajax_url="http:\/\/weuponithiphop.info\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=7.2";
var td_get_template_directory_uri="http:\/\/weuponithiphop.info\/wp-content\/themes\/Newspaper";
var tds_snap_menu="snap";
var tds_logo_on_sticky="show_header_logo";
var tds_header_style="5";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#dd3333";
var tds_smart_sidebar="enabled";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>


<!-- Header style compiled by theme -->

<style>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</style>

<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>

<body class="post-template-default single single-post postid-30019 single-format-standard unselectable music-video-diplo-ft-octavian-new-shapes td-what wpb-js-composer js-comp-ver-4.12 vc_responsive td-boxed-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
                    <div class="td-menu-login-section">
                
    <div class="td-guest-wrap">
        <div class="td-menu-avatar"><div class="td-avatar-container"><img alt='' src='http://2.gravatar.com/avatar/?s=80&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo avatar-default' height='80' width='80' /></div></div>
        <div class="td-menu-login"><a id="login-link-mob">Sign in</a></div>
    </div>
            </div>
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-top-menu-container"><ul id="menu-top-menu" class="td-mobile-main-menu"><li id="menu-item-317" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a></li>
<li id="menu-item-706" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a></li>
<li id="menu-item-314" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a></li>
<li id="menu-item-316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-0" class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></li>
</ul>
</li>
<li id="menu-item-705" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></li>
</ul>
</li>
<li id="menu-item-18581" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li id="menu-item-3199" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
            <div id="login-form-mobile" class="td-register-section">
            
            <div id="td-login-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-login-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign in</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
	                <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
	                <div class="td-login-info-text"><a href="#" id="forgot-pass-link-mob">Forgot your password?</a></div>
                </div>
            </div>

            

            <div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
                <!-- close button -->
	            <div class="td-forgot-pass-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Password recovery</div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title">Recover your password</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
	                <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
                </div>
            </div>
        </div>
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="http://weuponithiphop.info/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap">
    
        <!--
Header style 5
-->

<div class="td-header-wrap td-header-style-5">

    <div class="td-header-top-menu-full">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div >

                Thursday, May 23, 2019
            </div>
        </div>
    <ul class="top-header-menu td_ul_login"><li class="menu-item"><a class="td-login-modal-js menu-item" href="#login-form" data-effect="mpf-td-login-effect">Sign in / Join</a><span class="td-sp-ico-login td_sp_login_ico_style"></span></li></ul><div class="menu-top-container"><ul id="menu-main" class="top-header-menu"><li id="menu-item-79" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-79"><a href="http://weuponithiphop.info">Home</a></li>
<li id="menu-item-81" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-81"><a target="_blank" href="http://weuponitradio.com">Power 105.1 WeUpOnIt Radio</a></li>
<li id="menu-item-80" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-80"><a target="_blank" href="https://shop.spreadshirt.com/freshandcleantees/">Shop</a></li>
<li id="menu-item-18582" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18582"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li id="menu-item-18583" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18583"><a href="http://weuponithiphop.info/privacy-policy-2/">Privacy Policy</a></li>
</ul></div></div>
        <div class="td-header-sp-top-widget">
    
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div>
    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <ul class="td-login-tabs">
                        <li><a id="login-link" class="td_login_tab_focus">LOG IN</a></li>
                    </ul>



                    <div class="td-login-wrap">
                        <div class="td_display_err"></div>

                        <div id="td-login-div" class="">
                            <div class="td-login-panel-title">Welcome! Log into your account</div>
                            <input class="td-login-input" type="text" name="login_email" id="login_email" placeholder="your username" value="" required>
                            <input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" placeholder="your password" required>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Log In">


                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password?</a></div>


                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-display-none">
                            <div class="td-login-panel-title">Recover your password</div>
                            <input class="td-login-input" type="text" name="forgot_email" id="forgot_email" placeholder="your email" value="" required>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Pass">
                        </div>




                    </div>
                </div>
                        </div>
    </div>

    <div class="td-header-menu-wrap-full">
        <div class="td-header-menu-wrap">
            <div class="td-container td-header-row td-header-main-menu black-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-menu">
        		<a class="td-mobile-logo td-sticky-header" href="http://weuponithiphop.info/">
			<img class="td-retina-data" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-5.png" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-5.png" alt=""/>
		</a>
			<a class="td-header-logo td-sticky-header" href="http://weuponithiphop.info/">
			<img class="td-retina-data" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" alt=""/>
			<span class="td-visual-hidden">WeUpOnIt</span>
		</a>
	    </div>
    <div class="menu-top-menu-container"><ul id="menu-top-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-mega-menu menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_1_5ce622460b5fd_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_1_5ce622460b5fd" ><script>var block_td_uid_1_5ce622460b5fd = new tdBlock();
block_td_uid_1_5ce622460b5fd.id = "td_uid_1_5ce622460b5fd";
block_td_uid_1_5ce622460b5fd.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"43","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_1_5ce622460b5fd_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_1_5ce622460b5fd.td_column_number = "3";
block_td_uid_1_5ce622460b5fd.block_type = "td_block_mega_menu";
block_td_uid_1_5ce622460b5fd.post_count = "5";
block_td_uid_1_5ce622460b5fd.found_posts = "1867";
block_td_uid_1_5ce622460b5fd.header_color = "";
block_td_uid_1_5ce622460b5fd.ajax_pagination_infinite_stop = "";
block_td_uid_1_5ce622460b5fd.max_num_pages = "374";
tdBlocksArray.push(block_td_uid_1_5ce622460b5fd);
</script><div id=td_uid_1_5ce622460b5fd class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/22/new-music-beast-coast-snow-in-the-stadium/" rel="bookmark" title="New Music: Beast Coast – Snow In The Stadium"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/tRz-UvveYNzz_jVVketgGnPTm33RYCm5NYCdKYVjSEgb1_GEoYPAi0_EqX9UuEk4cvxx8zbH96Uw2zAzOznilfHxuI1letOW9zFsbXtn2z1GDyiyQYf7QMiT-Dp5O2BPb9lcd4DmHnjUDwKKKQKv56QcR7S8A6LtJtj_H5QTPL0Nr9RGXVRF8l-bwmFX0Lzza51G5m-rcucXluwQ8M3ToKFS6ADMSU3aTpm7vvV81AHvPB09kiLpaWTq1QGj0fsGrpt8FRH5R-skq1-z-AtbDV37EUoI1czl6eiejWVLUyhiAq8cZM6CqgAy3mq4Kp6TdlOgzxP3WsznN7hUgH3gxcxQO9At0mRHzW1o7k9rdnDioLmAmPNI06F6Z6mUe-_qxlUSvsZZSdRg3x569PahKR-0Jc2ohPt_q1Dr1Wa_SOG1Qz8rcCEqMbH8_PuNpE_vgyx22jmGaLOpZVISPtw6gIxlK95Gs37yUj24ywIAJcYCBqR9Gna-7iQeozNnUO8ZG9BJVO3NiW-2UDbE1uN5pECynpN6IwoybN1WZ6LeqwN0iPq5qg6-bMArYQfx_lEj8u4xTrmZomDriKQ6jbrP1Af3ju8gtVKiKu9_2xL8RR65PEUby8Q7qILEAdlMVmlL81QrTMwnsdrTv5zMDkKiqgyD_sV98oQG=s673-no" alt="" title="New Music: Beast Coast – Snow In The Stadium"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/22/new-music-beast-coast-snow-in-the-stadium/" rel="bookmark" title="New Music: Beast Coast – Snow In The Stadium">New Music: Beast Coast – Snow In The Stadium</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_module_no_thumb td_mod_mega_menu">
            <div class="td-module-image">
                                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/22/new-music-sheck-wes-sadio-mane-ynwa/" rel="bookmark" title="New Music: Sheck Wes – Sadio Mane (YNWA)">New Music: Sheck Wes – Sadio Mane (YNWA)</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/22/new-music-denzel-curry-speedboat/" rel="bookmark" title="New Music: Denzel Curry – SPEEDBOAT"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/ZNyQ4dXW9UmRW8o0wrYheQZOgQWR-rtz3m1pkp1NB3snIZN5VnXSGp_qAPWplj0LbnKQ0x3Ouio7gXwRQYNYs--71o_K4E8nkJ771_rqZJVDU132GGlQ-L2e9uxDTsAUIBSSqGk770fXqchGCwb_jrGbFJASonOuJmoDtAa91WReDeqiG8rSnhfZcJ1DtXxMm584tKOf3MKAzKHnbVM68qKZuLfXqOdq6ZRTS0bnIeygwCMmQKTOvbzXdKr3qZBkr9f6YrjPaXDLMmoCz_fxnCyiIj0ae2sjEY2kljTlh95vKdL6RMS9Rdym5E7B5HlqX4hMwcLSFNqA20qRI3oFLW9BKtuPu-MmoQ-TdgY367ngEvCLUf4pZa0Y2QMIBj-egMRZ4GMGrPO6ART987ZYF_EE_pe9kDGJLbPypFhyokVMslHUJCQiPURo7v60V4K0AeVdJ8RDiq1sMe75QGcxTmE4WMTNdQO6GSfygJlO7gT20XgQspqMeSRg29O3fFHYQKVHgYoyenmS7b-A_0CEOEoXXo_xNxyFybdMQ-Yx2kU_zW4fgVlRa4LnCyP2JSOPfHh6nTLUZwR2YRhonEOg5nVo945GveRYFEHOH0AxxG9X_VwchIJCReRyBHGSfvffPQAK3YNk1o5DwFhF0U3L4H_hX-amSWRe=s796-no" alt="" title="New Music: Denzel Curry – SPEEDBOAT"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/22/new-music-denzel-curry-speedboat/" rel="bookmark" title="New Music: Denzel Curry – SPEEDBOAT">New Music: Denzel Curry – SPEEDBOAT</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/22/new-music-xzibit-ft-problem-elevator/" rel="bookmark" title="New Music: Xzibit ft. Problem – Elevator"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/19PQBTS_Jc8tdlt8nIGWP511ZhpzM_aMRr2xsO8xs7N5-vPJ9UkL8HKhEy__kjlBH_2gtoYNPSiCbwndH2mpDyPAcVv1lgU0dAna_VB7pvU805k9ve5WYu_n6vt6gw3tBC7FwlvYrVE6Bbhev--ujYAY1u0I3kVC3hkGWWAhRMtmEs03uVm5x_3XWN9-zAMJlwWLApcbd1NT5DQ6EfAJnmgrUSqYmMwIrVluLKhtxxQE45LasFMhMq5Hsp9pzlUxm9IfcBz3EqvUrQVWZkgVoLiOgkgb7VJhj-aR5kTyRcJnaVqvkUMndd71jQhhSXNxEHtedhLBsZrDnTw0Ck7PJ7KPGgBMNP-1raqXMtUILbx5V3PP3knL30jwlZY2KXrYxE1mhuEcKEus3ic9yUYKGGgkBK7GidHm71yBSM3i10Lhuap0v-we2xiaGHqIeU4gMg1ffKEk6rhQwF5whXn73hGvWLl2xr2OiN_1h1ZLt_Q7vnSBifkGAsZvkfUAqnCHJVSTavjQxuJMyyef6IfXtHWkE56kwN6manlMPJRnLZdbMY57sNUXh8Phk0RS4xP7UdJaFW9mdTBw6F-IjTKJGiTN8O3QBWDpcY62KFVm1Zq12O3pV4lXvPZe8kEHNnFITXTZMKPX-3pRWU6XlOKytcsAJmBRmWVc=s620-no" alt="" title="New Music: Xzibit ft. Problem – Elevator"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/22/new-music-xzibit-ft-problem-elevator/" rel="bookmark" title="New Music: Xzibit ft. Problem – Elevator">New Music: Xzibit ft. Problem – Elevator</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/22/new-music-will-smith-ft-dj-khaled-friend-like-me/" rel="bookmark" title="New Music: Will Smith ft. DJ Khaled &#8211; Friend Like Me"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/S8f_--1COG-W6dXpbWh86GIwt8MevKFQi_7AUxKFPo8KVrwobNlh8xEHPt_qG1PTYvCdco6u7czhmoviH57tzSWkn8qOWtwZRh4D981dughMfqmbAoVC29iKuhfL0iwOUHpfa4yFJP88KpZwfAV-lsl1TjEisjncyJpsF85OzxykOoBeYJjiTZYgcr7EbpLhnvCAfsDKF9DrJLbrUj-tMKkmJsW6nwd2LhTFTGILrZJcyUQn2k_BxP2rP33pH-Re1EK-F4CLdYJRcZAMCkL1U_-udC-anUtJ2nDPWuaGBg0Pu4JoaNed0PSr7XIKavQRYLWwY7DqCkRXj27SW6F_8BQ6ue4aG3px1GeZ5pdRucVu67vw_uU8iy-PYnK-hVXSEUSV-H0qgA-QkpkaOn6HRFJfof9sPt9-VettGvGS9i8rXRADqWqjN8FRqtyNBL8UCS-No1hOi9vabo2o1WcTzLux2r97xPpkUgzo9Q0zT4QNg1tI870u8dzkNbwg3CQbxg7djH4z6qzgCuowNBI7_Ci-QdkGsSwTEdRr_ymsi3GfNOAqu8bUZ0pVXkPpzBll2sHNPeG41qJFPShyfOF9-82fK0Ok3QcZbKNBrLosoxJZirUWvx0ESbniMgYUJakN6oy_cvZyfUsVv-Ge92UsAJ4LfCV64BPT=s500-no" alt="" title="New Music: Will Smith ft. DJ Khaled &#8211; Friend Like Me"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/22/new-music-will-smith-ft-dj-khaled-friend-like-me/" rel="bookmark" title="New Music: Will Smith ft. DJ Khaled &#8211; Friend Like Me">New Music: Will Smith ft. DJ Khaled &#8211; Friend Like Me</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_5ce622460b5fd" data-td_block_id="td_uid_1_5ce622460b5fd"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_1_5ce622460b5fd" data-td_block_id="td_uid_1_5ce622460b5fd"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_2_5ce6224612e2d_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_2_5ce6224612e2d" ><script>var block_td_uid_2_5ce6224612e2d = new tdBlock();
block_td_uid_2_5ce6224612e2d.id = "td_uid_2_5ce6224612e2d";
block_td_uid_2_5ce6224612e2d.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"97","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_2_5ce6224612e2d_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_2_5ce6224612e2d.td_column_number = "3";
block_td_uid_2_5ce6224612e2d.block_type = "td_block_mega_menu";
block_td_uid_2_5ce6224612e2d.post_count = "5";
block_td_uid_2_5ce6224612e2d.found_posts = "708";
block_td_uid_2_5ce6224612e2d.header_color = "";
block_td_uid_2_5ce6224612e2d.ajax_pagination_infinite_stop = "";
block_td_uid_2_5ce6224612e2d.max_num_pages = "142";
tdBlocksArray.push(block_td_uid_2_5ce6224612e2d);
</script><div id=td_uid_2_5ce6224612e2d class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/21/album-stream-montana-of-300-views-from-the-generals-helmet/" rel="bookmark" title="Album Stream: Montana Of 300 – Views From The General’s Helmet"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/Em9cV3rqfJRhyVRfFJ5B0BVModstpiN61Frd4slCF3cUQqVtfG1WoiiHWBCc4-kyvhvsL9i-KtC2a0FZwCpzqeOmV9zfZWr5NuEKfZ7t4ate88f9eU6TF5lbFjJDBCNwH7BMOzu40A05tjmzXT76H0FOn3S-ZjbHOA4SEtnc7AgqqkCR_YjHFbBRlOH5kAyFsUqeP-K-CVRuFJDZdQNhhDCZDNz2R_4qZY-egNmYMN1y32Ktl06i8TQnDX3W-dTh3jjgD3vVtaYp5GTJRNFti5vndGWbadv-Zke1mbbHUmB1ZQTNEryFui9nDvcsLqsjVuxDFXVLfjfITTzuAGO_KtceDHjcdYcXj-amVg3swSKPsvtRO9v44PfiGtl2z00-sSNmUfFZRmhMMHbuqqlD6XdL8K0sD387fbnIpDmLDLEuDy8bTYs6ziRYIXLtj9EwrhlOCpyNrq5o8TjZA_axzlR_K-4NSzJsbnUsiB01Ub1c25H7k86KSbJVi-eGEB7cP-jZQXpuEmMDsj3MpLkpTChzAlEyFGqgVAhg8rwyYSvSgMqVveybe4EmUViQWUndT4EkjR9F0MlErb5QPlUjx5Bz15oqw8GQH5k-YYqWl66yZvhHH5sYsEkzetZ7wDLv7rWmFyJIGeuVRYNPsL2lK9RdSPm_WK5Y=s620-no" alt="" title="Album Stream: Montana Of 300 – Views From The General’s Helmet"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/21/album-stream-montana-of-300-views-from-the-generals-helmet/" rel="bookmark" title="Album Stream: Montana Of 300 – Views From The General’s Helmet">Album Stream: Montana Of 300 – Views From The General’s Helmet</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/19/album-stream-curreny-statik-selektah-gran-turismo/" rel="bookmark" title="Album Stream: Curren$y &#038; Statik Selektah – Gran Turismo"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/5-rMxFeNLY78OFh8WeG_v_7YhVvDyxpgkz-rYZoGbKLU2dP2jBgOT7qFeN10N4Rw_-WD-AlijeHorA0gMrueMeD3S9T6fT0zgiRJKPVcXlzmWeEI5Fl5KLulq0CCeCNViMuWXLr39Xd3dlAo_y1wJ7ZycROJIRRABmfH-8evBSLq1YOyCw7t3CCdG0XN2WTw2zxLof8D6l7dP_4V5a3JgGO6rSRD68Wzbafu2CkQh_Z75ftPz_u7gteDp_QoaDLqzBE7dvwbskyJCho_jPSiYA--P0i5FR5xImSedpI2B_mWvDpsEGnyicY21gkBole7efAXRuhphMwCJYmS3d2sN8SmAUW7_ZWUa0aNYFy_63cRlOjBqDq8WHJfhEciI1EaPabngwHng0vwyIJ9nCx-7S5Z_OmdSWmXcruCZT58-yyPJD4UYK172VtTViFa4NteadlB6Vp9lKrfVUEhg8l4Q8WJEXuQFWUrnVRF_u3WrXelq_XdokURqCyH3IM6RzhL4lKDL3EjEMRLIo4RQD6qO-HWlS4cEX_-Q1Zr3s9dxit9AmT-rKwWlJnT_lrpRemiE8I95_rbmKSonqzj3z0ERUEJaTK8t8yLaSyqmk_cA9Plc9N_-4rfgYqV0OuuxaFIDAH33EHhAyMTnihahKdsyrH4po-Umqw_=s756-no" alt="" title="Album Stream: Curren$y &#038; Statik Selektah – Gran Turismo"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/19/album-stream-curreny-statik-selektah-gran-turismo/" rel="bookmark" title="Album Stream: Curren$y &#038; Statik Selektah – Gran Turismo">Album Stream: Curren$y &#038; Statik Selektah – Gran Turismo</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/19/album-stream-injury-reserve-injury-reserve/" rel="bookmark" title="Album Stream: Injury Reserve – Injury Reserve"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/FtXoW1NsjTEXSRdiQleaoG7sg9sMaPdccmBFsPRvbbJJNtmYP9_zgYj9UtEN6GIW4tkp1B7Hoeg=s328-no" alt="" title="Album Stream: Injury Reserve – Injury Reserve"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/19/album-stream-injury-reserve-injury-reserve/" rel="bookmark" title="Album Stream: Injury Reserve – Injury Reserve">Album Stream: Injury Reserve – Injury Reserve</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/19/ep-stream-sheek-louch-beast-mode-vol-3/" rel="bookmark" title="EP Stream: Sheek Louch – Beast Mode, Vol. 3"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/i_t-88L8zeu1AoC46Ai5Hq5Wy3XbJVhYKfievza4j3AnsoDDcbw2wkicqLO0PjLFzUrJsVESb5bSCT1_DamQlOd6bnp1oiQqcDpgCn1Fbj8iUwqiucjK5YP8qViZzjOqRDz_0cn4z8fWJd8xGy4FXkf2irDSJEyAWu9diyarnt2kWt0UHVslhiU34i4Qr8sCMEkh52oN16t314QdUlY6bHlymW6ZdcaC3KZZ5BOy4PtOezfoq3h-xL0TZCHVrNCVAf5rsvoo1yYp7G4_sjYN9Jt2WQ0sL_a300DMqi6QoC1n5EIYQU_OgPvXvm5j75bc-bkyW6_nl2jRWy0M_P4DPoprHWTcmd9Wpuw3YmMD_YFrN9GquW3hx1jrE6NiuOzgismvEoFof_le8aamvWu-eoHImp5LxKLST2itAAvydLJfCB8hj9t5gvYMHehSkjmupO7DHXK0HnwhTuWoK8tcp8qqWw1a1tCX6EX2e3RFdepZ-yY7p7sqnqWhdkmOd96qqQnzllzIWV2LLbjCLbL20VGWJqW68ppOcHIkCBTbakgo6B5zwjSucJmn_XnpatfplW1A63ndUUw-Wf19jb_qeLCOy8YjZnsC5-sS2svP3-qy9sk4--YTv9MPO504-dqEtjvUDhx02Rtz1DTkJcCogECpYfb1i9hm=s796-no" alt="" title="EP Stream: Sheek Louch – Beast Mode, Vol. 3"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/19/ep-stream-sheek-louch-beast-mode-vol-3/" rel="bookmark" title="EP Stream: Sheek Louch – Beast Mode, Vol. 3">EP Stream: Sheek Louch – Beast Mode, Vol. 3</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/19/mixtape-jaydayoungan-endless-pain/" rel="bookmark" title="Mixtape: JayDaYoungan – Endless Pain"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/FqpdTQ6Ik_ubDL-p7LHDAkcZUmj04boMtUDyMkzy6Qf1onI05ZNsnYqDplfT7hkPBt2i8wQcOn4U1JVjjVvQPj7o5l8-w5eBbtsFlza6k7jjtudoORO3VFfoncmAXabtQ16U38_eDB8BcDyzv0LP5mqAT_1KevdfsH0famdRXvSMcWTwm8LBeTUG_uFrIRnogw_rRbR6te_An_RYY5ElyL0eVp1tDO1b5i3UqzAQgnLzAJUmcRf5rdFNecAFNLeozsezxOp7XKVBGs_QcVKlOEsRN42wWj7AYxBqvTQa2iVF_YEqk3tdT2v98zXHh8yPfxzvRWmN_Mfpaeq7jYEBTZhCk3FqkaRSaDxwvgiclrNVcre8JXSJjmJdpAu7b7Um-A9Pl1UC_n0n-7Y-70pZt6ba24dxVDoR6HYf0EWT7aG0mzbrAs9brBHaVF29bAHGKR08KiYSX1-hWt1p8J-yDL683Z8Zbs7nY46y3sfxKsax7k_Y7jJU9OhOMok_A2TEe6BzrH7VCLAK03ipuVhP2Gu-mdbtUo44Dn96stF2EjnhNAwNTguyW-GRHzsT_WSYrJNZvYg7Fvch-gdHXny1-cX9dufXNoPEc2-yXvHdvfg2ZrdQ-PP0rWlNLiN7Y64xd8CjL5Cck6o5OK6T1CUqRo3LLbxmbKlL=s796-no" alt="" title="Mixtape: JayDaYoungan – Endless Pain"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/19/mixtape-jaydayoungan-endless-pain/" rel="bookmark" title="Mixtape: JayDaYoungan – Endless Pain">Mixtape: JayDaYoungan – Endless Pain</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_5ce6224612e2d" data-td_block_id="td_uid_2_5ce6224612e2d"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_2_5ce6224612e2d" data-td_block_id="td_uid_2_5ce6224612e2d"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_3_5ce622461b056_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_3_5ce622461b056" ><script>var block_td_uid_3_5ce622461b056 = new tdBlock();
block_td_uid_3_5ce622461b056.id = "td_uid_3_5ce622461b056";
block_td_uid_3_5ce622461b056.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_3_5ce622461b056_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_3_5ce622461b056.td_column_number = "3";
block_td_uid_3_5ce622461b056.block_type = "td_block_mega_menu";
block_td_uid_3_5ce622461b056.post_count = "5";
block_td_uid_3_5ce622461b056.found_posts = "1863";
block_td_uid_3_5ce622461b056.header_color = "";
block_td_uid_3_5ce622461b056.ajax_pagination_infinite_stop = "";
block_td_uid_3_5ce622461b056.max_num_pages = "373";
tdBlocksArray.push(block_td_uid_3_5ce622461b056);
</script><div id=td_uid_3_5ce622461b056 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/22/music-video-diplo-ft-octavian-new-shapes/" rel="bookmark" title="Music Video: Diplo ft. Octavian – New Shapes"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/EHFKDTrxgrWLYANBBN8xsnYjBjHUQAJQItEkutjwV5tFz58wurUjFnwlHuywNIp0K1CrBlu7DPbGl1HGnYDWKjN7JcertJ152GsJzRgENXBENSYeqXMkyiDLqUlMIe37VAf-KVw34kW6sMrl11Q9PXuiKi68bg6-tU4w7ABOJihyXSHt7CxFYlbx2TcLIjpdoliVPZBrDr22T2oll9mHehdBGu3fs1oejWtJOCWVSZRBNBgmlW2zxQYzKwN-lJCCLAcY_0-1m_99Y-S_dna1aVelD2QSzSuftEoT1OkQ9DBcUZbgkd5EKOBpVW1tCefMhlnOvvCc39-JG2rsMg6-5r4SCQXXbQ_2Dl0tS9AjfI8VqnJbQKEe_40z7upMhigyvFBFk6ijitiuLvyL5zgp8A9zwQmb9dS1o6cx7icKHj8_Z6alhNTkNNhDm1jUKSCLacn165SxofOql21NBPys0TFYB100v-3SoV3Whm6DHprfGuErbShL8UjsHiE0fCaoKABW9F-iniTlrU12i6rTXPn76FozTPeTK61Wb0pa3ewIdglLR2GXdS2HVL7oQzc7pdicw8xk8NOef6zwTXHrAjUE1BvRogpRnVP2QA49H6OSrWW7NSx8VERbmT-UpFOQ4pWzqMg8EEX8rCcmYlI9uNyBzXcoHoVP=w683-h477-no" alt="" title="Music Video: Diplo ft. Octavian – New Shapes"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/22/music-video-diplo-ft-octavian-new-shapes/" rel="bookmark" title="Music Video: Diplo ft. Octavian – New Shapes">Music Video: Diplo ft. Octavian – New Shapes</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/22/music-video-jacquees-live-ya-life/" rel="bookmark" title="Music Video: Jacquees – Live Ya Life"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/rWC0S931aqosKSfsohyv5nWANeAW51NJHaUfTbhFKpZd-sgH4lQtTBweVwzXB324MH5lNQHp3C70LU0rPqFb1xk9j2CRJOAoVasgaDeMfGU_0V4qwjSZ7hWhp3lWuXw4OlrjVxEG_3I_7k000YPre5SbyudfHaejVfTdU3psL5hDHdd9y94WPGbrK1v_rZaTgUiBrGBjEg6SWO-uCbh8xgGsEY_oDDNm35Z8mv4zn4iwoQsUAifCvzrpA9VUZF06Bt7PqrvP_MMJ_FFfdYqmcZSNSwXcmFCxbTzhyzgl9eQJG5xE_coSr-M9e1EXXqrRP_NiG3jCW1qaRmQvjNCPntm8fK3FkKzl19hlEWMAV91glUHqII_Egs6gnv88LB2T2G3QR0hu0KjJiWWLX9A8mpyZ3GkG-nHyqjwGavLK64jwvzv61qBGjHg3Xj509Q9OX2vTKWpJYapnFgnWY4pMKY1RQFgmISIhADhA3JAV_7OJBMwsUsDrEgL5u9YMje1os1dCkce0MoHWKa8cFOQyG-DfB2YEL2kqUKPrvqkeHn42A0LdibgG9t9DBHqYVzBTz7rjxiwC9Nwo9t1VowlkVHuIxsczZzFoyp_eBZiLxIQ2uoQ3KmGUDFKc4UtZmGch1gJLt1mhT-iDHBO9HMM6Pw5_DxssGaWB=w747-h486-no" alt="" title="Music Video: Jacquees – Live Ya Life"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/22/music-video-jacquees-live-ya-life/" rel="bookmark" title="Music Video: Jacquees – Live Ya Life">Music Video: Jacquees – Live Ya Life</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/22/music-video-lil-donald-ft-ludacris-say-it-twice-remix/" rel="bookmark" title="Music Video: Lil Donald ft. Ludacris – Say It Twice (Remix)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/8SKvOgDhY9kyyq-j9xPKj6MEKij-dzP5luVIT_e5Gbu2udWVlt0ndWGwvClsTNrKX1WOH4yxRMoYwicYlQ58DNAjDieHIjkVR9QSpce-XWb36BjlVuUnDX3NUPc2ltv0LoBT_H130nLpbl3y-skpx7cxrgUUFemvKMX7nmok-7qiTTIdtspOqSxJmDCkoq2VBprT-HPHdHQVpAyBRGhZPaZE36l55oYbp7x2NZSlc__BGV_mspEwgbmwDDontk6vfuzAXyRhG0bPF6CYECb6fLJvO8tna7KwX0BiNdfYv-mneQrfL_2QmvwOBcOtnhwfB3zVR17o-9aqsZZFbnFa1DhxtlQ9iZ4JLRwvZT6oXVkPP4FzAh6Jpkaumg4EseguFA-H8_VggReq1dI2YItDe9lZgAUQFy3oeMFpXd2a832cHSzG7B_0UkTtfKT56bQQD_lAn7J6cVLthB0BF16jvsVo3RsZ5VG6YSd0N1mXteGhSEkU4NlTnRzhGs70wUobOS1uItaoUw4JlHQ1jD0OW3PP1pwhX-SbLpqs6gMmGuc8sK8fLL-S10Fc63Baty4lYRRsj22DlFA_RtL7o4unfLa_URi41SR9Ev3ez4vBzPeOieUHkgKtOX_pNlUqzEzfYR57phvz3SYmEKC7pliaMhaeOWc6mWwb=w883-h386-no" alt="" title="Music Video: Lil Donald ft. Ludacris – Say It Twice (Remix)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/22/music-video-lil-donald-ft-ludacris-say-it-twice-remix/" rel="bookmark" title="Music Video: Lil Donald ft. Ludacris – Say It Twice (Remix)">Music Video: Lil Donald ft. Ludacris – Say It Twice (Remix)</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/22/music-video-blocboy-jb-ric-flair/" rel="bookmark" title="Music Video: BlocBoy JB – Ric Flair"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/tkQK_opVxawO1Ngk6uuU_8fDLXCArqLvIXX5n9RbCJ1wZ7NMfvmC9w8j7czJXZfxojJF3dyH7GVNI-keWN7z-uEPYmBsP4ysgT_u2WVmSvHRkBq7nrimdEOtXBD9bTduSJhOB6DS4Ut-vAyNJy_L62Vfkw8Ou7JWQrL8qzLbJcGiN3Y2uAyuJGdYlOMyVJ-nyQyRIXTX26Cf0bDeuzgSeTCVEF1pVdN27cOWj8JimZ3KXYuK76yBRdDr7tbJmMtpJ6rvvpI2rvo2xOBw8AVmH7OmWoHhYWs6_94jXzM7zzAf6kt1tkSF9zpePUznKB64ykVpqQZ-tfWLi5IFMA-jf_p13gaUR8CdrC-uHTpEvLwVSnYbS_J4uQM2SYlgX9OSAEwiRe18Jpr7tOuhAuVymQxDEVlUfDbw1z5a4WOda_fVQq2qn0XKfNZbcWxDZaZ3noWDWLD9880svDsuSYL27wFvRC040z7qXAmkJKvxRli_1BpZwCSGxv5gwqxHCG7ln5yH2UCRqTth2wTx_-IZqf2Yq78FrtkysZIAm5HjdlBtlpeAZB6Fi4wP9TPGiwiYjCAlQR5bMmVzM2DAWZTVDt4umYYk1IH_H-aMvFZk4riuu4RpnZkrKzvrb5vQMEvZ9Z3dKSCcTCb5I2F-yV-v9xcB8YfgjBE1=w714-h468-no" alt="" title="Music Video: BlocBoy JB – Ric Flair"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/22/music-video-blocboy-jb-ric-flair/" rel="bookmark" title="Music Video: BlocBoy JB – Ric Flair">Music Video: BlocBoy JB – Ric Flair</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/22/music-video-philthy-rich-passing-the-torch/" rel="bookmark" title="Music Video: Philthy Rich – Passing The Torch"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/vOlxPmo1BPNuz9nza-jYwMOr3AboYRyRBBYMXPWjgR2WE7Yh0rgAjkCa6lNXDN8zd932W609vXqHT98QcVzLIf2rIUKjnyJ_ysIHKgmtwlPLl_b8ldujqkwUsr1pLcd_iwi_MLFZgMB7fLf4re0TFLEMjxCB-EEmhJA9WPhX7tm1yIlSsj0Xwd2NihFXAZASPAiK6Fwar5rT26nxyasqW9Oqg6_GGxqIg2Zjn5l5SpeC1eypFJb8i3pU-amVKgd4qR174rs_8pi3M8hdLnnSELhBQYPVugpNv8Yb55IbU9X4mVHENKcqBzLgMsOgxtB3_VH-HnEvQ7sl5if2-0f5twSkhVzR0zNNeK3Y-dxI5K9H6r0rd4b41Lqa6JDJxyXd8AOo2PRrnzJOI7njtOWLHdGBC1Zr-c0EXN9T89uyWYeTLZ5dTJWanr1kPbMmrEP3TyB5IxpKKeUku-R2IZG32kRN_AccEnexDdyvCeiWs2XA6y7Fify-N3ZIXXqKVyYIXChYw_8IY4tGZ11rqJKrRPaB1T5uRpDceWffwjrhKkUMh-lwjwJ_BO39LZyFcloXPWYvUYeX1uIbzDk88GtWQt9yGLnu6XZ7Uwp3kukbSjGOaLuZCBhfzeaSZtpprbi3IMyJ7S_isoEhwdmGDEcfr0nmsW_z_Xio=w706-h452-no" alt="" title="Music Video: Philthy Rich – Passing The Torch"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/22/music-video-philthy-rich-passing-the-torch/" rel="bookmark" title="Music Video: Philthy Rich – Passing The Torch">Music Video: Philthy Rich – Passing The Torch</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_5ce622461b056" data-td_block_id="td_uid_3_5ce622461b056"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_3_5ce622461b056" data-td_block_id="td_uid_3_5ce622461b056"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_4_5ce6224623087_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_4_5ce6224623087" ><script>var block_td_uid_4_5ce6224623087 = new tdBlock();
block_td_uid_4_5ce6224623087.id = "td_uid_4_5ce6224623087";
block_td_uid_4_5ce6224623087.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"29","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_4_5ce6224623087_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_4_5ce6224623087.td_column_number = "3";
block_td_uid_4_5ce6224623087.block_type = "td_block_mega_menu";
block_td_uid_4_5ce6224623087.post_count = "4";
block_td_uid_4_5ce6224623087.found_posts = "682";
block_td_uid_4_5ce6224623087.header_color = "";
block_td_uid_4_5ce6224623087.ajax_pagination_infinite_stop = "";
block_td_uid_4_5ce6224623087.max_num_pages = "171";
tdBlocksArray.push(block_td_uid_4_5ce6224623087);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_4_5ce6224623087" id="td_uid_5_5ce6224624850" data-td_block_id="td_uid_4_5ce6224623087" data-td_filter_value="" href="http://weuponithiphop.info/category/latest-news/">All</a><a class="mega-menu-sub-cat-td_uid_4_5ce6224623087"  id="td_uid_6_5ce622462495b" data-td_block_id="td_uid_4_5ce6224623087" data-td_filter_value="69" href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a><a class="mega-menu-sub-cat-td_uid_4_5ce6224623087"  id="td_uid_7_5ce6224624a84" data-td_block_id="td_uid_4_5ce6224623087" data-td_filter_value="80" href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a><a class="mega-menu-sub-cat-td_uid_4_5ce6224623087"  id="td_uid_8_5ce6224624ba0" data-td_block_id="td_uid_4_5ce6224623087" data-td_filter_value="2189" href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a><a class="mega-menu-sub-cat-td_uid_4_5ce6224623087"  id="td_uid_9_5ce6224624cc5" data-td_block_id="td_uid_4_5ce6224623087" data-td_filter_value="10" href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a><a class="mega-menu-sub-cat-td_uid_4_5ce6224623087"  id="td_uid_10_5ce6224624de1" data-td_block_id="td_uid_4_5ce6224623087" data-td_filter_value="130" href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></div></div><div id=td_uid_4_5ce6224623087 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/21/dj-mustard-perfect-ten-album-artwork-release-date/" rel="bookmark" title="DJ Mustard &#8211; Perfect Ten (Album Artwork &#038; Release Date)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/ESNFv7ux7rjrC3JJj1qOCD6nEujjLoWYyresPmpHNuSc9IZ_P7RRnu_2coEptjUzN_NdIJGOn9KymQDLNnMf1WsBj1qRWjpE8sS2APj2GJav-XyXCaAlzIAJ8ewCSAEbjntmF1qvV_eErxsr_CNAPk0DdeeLny6OVRZz4EpBa6d9NtdwInXRdqKQlzUI_6TtxeZkr4-0yfaAhP8Vla9cCVBHD7HW-hjNOk1bA7706Y-WYbSo0ZlE9_Oy-pBcfWiDIAml8UpjfSdzfqxTb9JD2paT5MY82-PL4HKfAV1xD1VW7j58_oAi0eldxcGg1G8GOGMA1JpUJkfOjJgCQelmsmLnRD2sXnLkW5E8hgO_76L_C5VniPcz3TAPlW7dIZCscSoj6GY9vr_VG9W6P53R-PkWoPxi7erwlMUkHasFtPdvNS1QtzEnjjE0AddHFKa8MU-liMw2aZpLZJPnRk9eijQA0FoQjSmcyDcOKid_UB7MYNi_HkPJxDxveq0ifmQWRK0NS4eyl2HnTxPx6yYiH0pFdLqNOahzKJFvv36vPvQKjJbOcwMWKn9eEbvjVvP3Ip7iu-wY36AYaBbcRsmKzEV8uasGetPkZnaFy1rGT4X-JmzAJYf3Az5fnpiaTkvwyxH8PvbDPSym5JWu72rc1wOvt2TB77rK=w680-h672-no" alt="" title="DJ Mustard &#8211; Perfect Ten (Album Artwork &#038; Release Date)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/21/dj-mustard-perfect-ten-album-artwork-release-date/" rel="bookmark" title="DJ Mustard &#8211; Perfect Ten (Album Artwork &#038; Release Date)">DJ Mustard &#8211; Perfect Ten (Album Artwork &#038; Release Date)</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/20/video-ice-cube-big3-season-3-theme-song/" rel="bookmark" title="Video: Ice Cube &#8211; BIG3 Season 3 Theme Song"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/JDkTQcLdP_l1iOGkXJOHXZp2JOvtzgYR6MwsYnUCTzqI77Dl7HYteHplJEBq1M5CSEhgxEH6MGoMEaedVeEK2FzQ2I4Rz1qOUXPadQzkdHSdYCdZnkyqxMf8w3vYBumh645WgfKl6zoC15K73k62NCsgJAuzIQTCaSc7YBKqXI8tcrpcoP-2-c6fdP7yB9e_JNrJiGrK8pScRGzxCkaMgx0EDjc4ArSUwVEEOJMigJuBhY9KhXUPuJd_PqiTXaACJYFWg9Auz-xSmU2h_TjTIkViE2LHm0pI-dL529DfTFCrsVIrs0lwBZ9QwFud6YatqItxB9EWNDTMYeyR2_HJ-zow-8rAP4d0enLL8TXbIpyMeK5VJpz_to7Csmtyvf68bF5_uN39H7jupQOmHzTbFzVJ2XKyq-MaT0mb8o0jMi5kBL5MTiVr3T3985vI9wgtjkCFwx-EtD8QymEzAUHBXeN_fd5P3-yAl8jFW5k9R40jst-4wlvYRa1guq13bhO3IX3Sy5uiOJ-oiiMCXvCryGGkXEfVEZGLlVec9vS6hK9eqo_vI7aWgFR8q22torH8zel11Y1b6ljvBAvbQ_kYuE1MzJ0UeKq4qRmoGJTV3TBfSZbxdqWZcXxy9giE1Z-KdmCAO1-XLAXtqXUwwZoZvTJf3oJiORa2=w899-h608-no" alt="" title="Video: Ice Cube &#8211; BIG3 Season 3 Theme Song"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/20/video-ice-cube-big3-season-3-theme-song/" rel="bookmark" title="Video: Ice Cube &#8211; BIG3 Season 3 Theme Song">Video: Ice Cube &#8211; BIG3 Season 3 Theme Song</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/20/rihanna-confirms-new-album-more-with-t-magazine/" rel="bookmark" title="Rihanna Confirms New Album &#038; More With T Magazine"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/PUGHhtYdlY7YB7OMobfuvC2tDPiVeKXFvdENHq7Gy0iV4o2BOUEbmjDwa8mSf4_FR1upjLwM8pjP3fUsTd9L7hnwiiKZB8pvyKFgUgFIkajmqU7knWTaUltGRLJS2sOu5XgI88xi64HlwDatPl5HHdR-HV-0Y93JSBrrgpVPSf_HjVxWQYjq9Q-FOUwESW-WVhm05xdGiwQ0zndyCijkco1usSQwqgsJGbHTSKDx81TQIrPTovgPpRnb9iNr8i2RqJlZ81P6tq2MGu1flbe_ytOLWvz_JpgGRvAn40NhkyK5Kvy8ZGOX3EicMJ1-UEaioei5SN9SYYBMZSiaRUSVc__JO4cIxnPtBvEUJJ-VcTFQP6UJz-gnIS4TvUDTr6G2dDiJp5V-RgBBHaZEh-HmSlSeGyVHyaYX9ninlDSgzjlEmiHjg75w1XG6GWRts7zKZbvfX9nke2smWDvUtWgZkw6y40LqCVhYKMk21bHU_vYtNxtq6wgP2u9XhO0b-B0aOe3gDqTuKgrQO2GwUKgkRmgZf8H_PDoXvuj7_GJGSIUM3OSWDbYdvXYkMykS8bb3kjGhn-oRykOjnAdTD6NeUJGET-apUCkkE4afPQPQjLnXR4bWDPXarDo4Ym2DB0AYjX5mSGtZc70wD1dZVZdqFjuZQ4pzJomH=w372-h234-no" alt="" title="Rihanna Confirms New Album &#038; More With T Magazine"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/20/rihanna-confirms-new-album-more-with-t-magazine/" rel="bookmark" title="Rihanna Confirms New Album &#038; More With T Magazine">Rihanna Confirms New Album &#038; More With T Magazine</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/18/video-nardwuar-vs-n-o-r-e/" rel="bookmark" title="Video: Nardwuar vs. N.O.R.E."><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/iJoAgUjyrinmrF5mlz8s3B7xWg0JOihdnj9v4bFqT-Q8L47B915Yu0Stk2p-MWYx06fNFgf7IgJH9OlDxrySKl_IG7pvPcLKOyuv1v6dKoGOkkWUX1UDq_Qq0RBqKJu6moUKQ73V4B-INIeiyBqFOmwu9BOmfcnjl8psDYe-nN45pVhooT9qqvunRYaciKyjUmZNB7-cQxgYKb6OMAHApRq9638Z-H8jxVh0JHcExd1rBkiuSVpoJ2k7Wg9oKtDbgKxonTxLLjP15IiJtP68VTxrGvXe5eJFqNBeOd_oXXuw9UplaRg5YC7z3nuu_AlTufSJvKaUZoABz2eDsn1cR4eVt-ZmaqWidHwDQRBSx4nxpgQcWqNcTiX5JdRC3MOhc8NuliyJsbw76T288omySx31mZnZ2lrq9RO3Ahh3os8zdorTu3qH_a-W-Q0aHNvx587Ic739mdPTZgYR8hWmVDopK2EJENQboBJfpq96ID23ig0MKRWh6zE68J-M4gI4UWNydberNqntSkN2SEbm9efoAls-gNuffcnTPlBLGeSiq8lj8z95wRQSnbhGPCwNCrTUhzdt2bMadtIpmMr_iStFHdUnz635ryGfGicCI5mTe0P9lJUU6n3OUtF5LE97lo_LawQQVf-xrR1gRMP_2dXX-amrCFlm=w630-h378-no" alt="" title="Video: Nardwuar vs. N.O.R.E."/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/18/video-nardwuar-vs-n-o-r-e/" rel="bookmark" title="Video: Nardwuar vs. N.O.R.E.">Video: Nardwuar vs. N.O.R.E.</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_4_5ce6224623087" data-td_block_id="td_uid_4_5ce6224623087"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_4_5ce6224623087" data-td_block_id="td_uid_4_5ce6224623087"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_11_5ce6224651ef6_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_11_5ce6224651ef6" ><script>var block_td_uid_11_5ce6224651ef6 = new tdBlock();
block_td_uid_11_5ce6224651ef6.id = "td_uid_11_5ce6224651ef6";
block_td_uid_11_5ce6224651ef6.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"77","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_11_5ce6224651ef6_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_11_5ce6224651ef6.td_column_number = "3";
block_td_uid_11_5ce6224651ef6.block_type = "td_block_mega_menu";
block_td_uid_11_5ce6224651ef6.post_count = "4";
block_td_uid_11_5ce6224651ef6.found_posts = "158";
block_td_uid_11_5ce6224651ef6.header_color = "";
block_td_uid_11_5ce6224651ef6.ajax_pagination_infinite_stop = "";
block_td_uid_11_5ce6224651ef6.max_num_pages = "40";
tdBlocksArray.push(block_td_uid_11_5ce6224651ef6);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_11_5ce6224651ef6" id="td_uid_12_5ce6224653a6a" data-td_block_id="td_uid_11_5ce6224651ef6" data-td_filter_value="" href="http://weuponithiphop.info/category/fashion/">All</a><a class="mega-menu-sub-cat-td_uid_11_5ce6224651ef6"  id="td_uid_13_5ce6224653b69" data-td_block_id="td_uid_11_5ce6224651ef6" data-td_filter_value="76" href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></div></div><div id=td_uid_11_5ce6224651ef6 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/LVT4Mid8WL4wHUdO9X2OZmZxxgbREs2lVtszOdEBaO6hJB0JS3yQOAyhNSdCyPmv0amBDTgNGpOlRPXPjKCl6yIlo2joyH3rQRI7CUdX09BJtQI1r5jy1_7BQtDhw4AxUhpUwIh35rNS3lTy7uq-FdPff10JN6srr9mwZ7zr04GQFxBVEXwCfC5rNVehXhY_wGCRVsmevYmdkBWEmB8dvOzBHY78NBBjcHNArS_S-2M0FJgDh8v9m9vEh78k_XmZg-AERctsf0bkODuPi1EcNJq_RnJIV6b0GG-VtKjo-OVPmYghWJYf1HiP9c58cQ98oABU8BDFdLqsBtNt4K0NmyHYQlX39W9k_d83wEHZ1-EacQa2o01VrYSn12HnZ1l88fMzu9PKv6EGmcRZNwpepycW7_9EQnhxIPDdVCmRLXUasUED9OXr-zJmnBcnSnLCa06k1ZymQym1LiSFEv1c3aPHnmnD3GY8nL7q5jPJr4HsABR0WCqMebcF3HF_0deNd0zgRBCGMxW-VzlIIHZiHuBeSPEPvUL149GJ5swSSvKm1uGEi1HlLBj9omJSU7mDWzO0p_7l-l7-4_ureEsGsgB8cX1t8t2TQcFeRgqqF1CXlZFYYC2K0iMb4jPsijsw_rtO7pmKvbngqHfgYpGeh_qLmDWeicR7=w1195-h796-no" alt="" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch">Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/fHEwwMf8DoiXlqkfibQS1Z1XXbviORbV9raaI44tOTXrWo7GgqM3gA-vswE10gFtTQUGGwNG7nWAACwHjxPuiubliYBN_dqtBZh2WIpxvumiJ-hSLK0TNWB2cB8Iw2STT5gcp_KqlDh_e4xng1vidI8EXdp_ooh5uDI-JV1HQ9dGnM5nxl_b-v8znqj-Rl_mGB7y4Lu9zsFNWHU7SriqQQJaKrKEEnb9T8zxmGLaL0zq7ilYpnUEhWulDDr9xc82wdr__WzRBm5YEskVpDAnGM2NDZwTZpjbe4QDdxeixWnSXNK_oDzaL7WTbCpkD33OK88BlI5JmFRQ5VmD11UQ2htB7-9WoahHvb4XmBsbLXpEMl1JmEP4sPx06VduzFnBNo-J90WI0n1AEIIcEYVbRywrkGJXbzmH__In9ZIg0EV24OcGGbeKl12HxTdZwucqsNnuZeNjiMHISQ7i8cfzm3N7X7Zenl74zsKIKeKWoIGxh6MTlVADvgHcrHebnjcSgil2vBeFyz_AP45aOv9SOwbzfVLGS0CNfe1s9b2J7qZgjcBk9QPEXCl2kygvzmGXFvU_3xBuW6S0i3Vkh3Ha_3hPBtvIAy3WoTK2yiqS41HzSK7yk3FRAlBtpIEib338fdkTiosBxtdu36SdNUVM75zl6CVIFhTu=w681-h470-no" alt="" title="Air Jordan 14 Rip Hamilton"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton">Air Jordan 14 Rip Hamilton</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/kUjaOYxjEkAh34S-Ub2QSZwdOwHyFnGFLBZULta3_bn1_myPMAwJXiEEsAAtc1ktCQwHCuKhSqSYsWXFBEIZxdfKuykoDEZWwO-dDI3_JeAshbYvyILEHUu0XaUpRn0mj7gOx10V52t8gRGYPCW7QXGImkPGGhvBPzBDVVqh9lKGtkuPeePmTnpRSmwp0LG1WHcIzUWnMqPBWQeHAat6Q-Tq7niXNb96ddEZsMEdHK1nmHVlNaeqFBNtTxk6yYRkFNCvtfBayqy-Rqt4CPU5tThxbTI4AIUCI6JLxJd_VJizrVNDEe2xZ_tiQdkC5ASIoHpX8sfvAB8zRUsMVJ6oMUt5FH_4GBNXDCtFRmr65Qt0JV1h4bBJffu2L272Q_vpD76wn-YNGW8VCtZcheHu_X-A4gdYQEC0HN0BenY-MOuUBqKEjXAc0SxWeP7W9RN55jlqUFK0nzEYydVjec2stdQIngVfg_FvKxvHXfM4XdtMpqeJnp3Pzyk8xjz30sAZd0f2HQ6zfdPjk-OkV2-WrC0_qW0L8Rq3zrUbq52n3BN7gm7sctU_CUlBmoQIgJDQBYk1Siv4tfSq9pL1R4GdaOlWQdxEuhZi8bTYC8GGAgNGl3SMAZGvk7nu6QnnwEZjZ7mZwbcqgyRKa89cOREMUvIkVJ8Q8lZu=w926-h672-no" alt="" title="Jordan Proto React Triple White"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White">Jordan Proto React Triple White</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4cDUjSODZSaXWfHyZKb9q3Fn7FHA4uB0KSBs0MtFHC0dc6AJb1zeAl_X2LOKalK9C7VBFhTqRQ9fw1ESgUr9ZUKFbOzD94i_s96nvkICOqrsYnzrE2nEAQHoEaGOF4O8GAI6T4CGFbgcQhNzjpRlSY60NyPu5Cmq81FRpEOFRzTOtSa_NnWzMmfwO0yxtPbcg5U6YBUsus8shv3SA7CjULLfaP38nZAuWVgq8PMaaeCQ_eSrK8NJSEVQjyyxmqb-1I7zO8Kvvzvwi--ibMr52CF8h-GusBzSq5ZuzvZRCGu_u8CyfoXw7pwWbOmHnLOdcQ9d2PCSW_IxEMGfmEuU7NxMSsW3Ga4r35_wLB7cjvlPC9OjCV50tfekXjZBS_476mzlf4G9jR7Ju1GqgjXah9Uqc_0Y8N-Br8_JCtIlRSuLxAiebwd7AvFVlgWId9MYxBWnRT3cTyD8SH7q5WwO-CIbKAOSKsNcrrTgFxQvqn9yklBU1u5X5fdTlTBk4WSYorsWZAug0z9BOymRLnrhTbnA0vpBPFROWD-aL1glg-eUpFSfgD4xhWsOqJNY9krQ2UbLSGXQ5gYWj0ovLS7Yz3UKFY2qrVWpqkpbfyN98es9NJ-7LTUs2MLq1rX_2FaQmyq5mVndd7VGzQOHy9hDULG-5H-0LvGd=w900-h566-no" alt="" title="adidas Yeezy Boost 350 V2 Hyperspace"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace">adidas Yeezy Boost 350 V2 Hyperspace</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_11_5ce6224651ef6" data-td_block_id="td_uid_11_5ce6224651ef6"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_11_5ce6224651ef6" data-td_block_id="td_uid_11_5ce6224651ef6"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div></div>


<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form method="get" class="td-search-form" action="http://weuponithiphop.info/">
				<div role="search" class="td-head-form-search-wrap">
					<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>            </div>
        </div>
    </div>

    <div class="td-banner-wrap-full">
        <div class="td-header-container td-header-row td-header-header">
            <div class="td-header-sp-recs">
                <div class="td-header-rec-wrap">
    
</div>            </div>
        </div>
    </div>

</div><div class="td-main-content-wrap">

    <div class="td-container td-post-template-default ">
        <div class="td-crumb-container"><div class="entry-crumbs"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="" class="entry-crumb" itemprop="url" href="http://weuponithiphop.info/"><span itemprop="title">Home</span></a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="View all posts in Music Video" class="entry-crumb" itemprop="url" href="http://weuponithiphop.info/category/music-video/"><span itemprop="title">Music Video</span></a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last" itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><meta itemprop="title" content = "Music Video: Diplo ft. Octavian – New Shapes"><meta itemprop="url" content = "http://weuponithiphop.info/2019/05/22/music-video-diplo-ft-octavian-new-shapes/">Music Video: Diplo ft. Octavian – New Shapes</span></div></div>

        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-30019" class="post-30019 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-music-video tag-diplo tag-new-shapes tag-octavian" itemscope itemtype="http://schema.org/Article">
        <div class="td-post-header">

            <ul class="td-category"><li class="entry-category"><a  href="http://weuponithiphop.info/category/music-video/">Music Video</a></li></ul>
            <header class="td-post-title">
                <h1 class="entry-title">Music Video: Diplo ft. Octavian – New Shapes</h1>

                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name">By <a href="http://weuponithiphop.info/author/cyclone/">cyclone</a> - </div>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-05-22T21:04:45+00:00" >May 22, 2019</time></span>                    <div class="td-post-comments"><a href="http://weuponithiphop.info/2019/05/22/music-video-diplo-ft-octavian-new-shapes/#respond"><i class="td-icon-comments"></i>0</a></div>                                    </div>

            </header>

        </div>

        

        <div class="td-post-content">

        
        <p><img class="aligncenter size-full" src="https://lh3.googleusercontent.com/EHFKDTrxgrWLYANBBN8xsnYjBjHUQAJQItEkutjwV5tFz58wurUjFnwlHuywNIp0K1CrBlu7DPbGl1HGnYDWKjN7JcertJ152GsJzRgENXBENSYeqXMkyiDLqUlMIe37VAf-KVw34kW6sMrl11Q9PXuiKi68bg6-tU4w7ABOJihyXSHt7CxFYlbx2TcLIjpdoliVPZBrDr22T2oll9mHehdBGu3fs1oejWtJOCWVSZRBNBgmlW2zxQYzKwN-lJCCLAcY_0-1m_99Y-S_dna1aVelD2QSzSuftEoT1OkQ9DBcUZbgkd5EKOBpVW1tCefMhlnOvvCc39-JG2rsMg6-5r4SCQXXbQ_2Dl0tS9AjfI8VqnJbQKEe_40z7upMhigyvFBFk6ijitiuLvyL5zgp8A9zwQmb9dS1o6cx7icKHj8_Z6alhNTkNNhDm1jUKSCLacn165SxofOql21NBPys0TFYB100v-3SoV3Whm6DHprfGuErbShL8UjsHiE0fCaoKABW9F-iniTlrU12i6rTXPn76FozTPeTK61Wb0pa3ewIdglLR2GXdS2HVL7oQzc7pdicw8xk8NOef6zwTXHrAjUE1BvRogpRnVP2QA49H6OSrWW7NSx8VERbmT-UpFOQ4pWzqMg8EEX8rCcmYlI9uNyBzXcoHoVP=w683-h477-no" alt="Diplo ft. Octavian – New Shapes" width="683" height="477" /></p>
<p>&nbsp;</p>
<p><strong><a href="http://weuponithiphop.info/tag/diplo/">Diplo</a></strong> revisits his single <strong>“New Shapes”</strong> featuring <strong>Octavian</strong> with the official <a href="http://weuponithiphop.info/tag/video/">video</a>. Directed by <strong>Angelo Dominic Sesto</strong>.</p>
<p>Watch <strong>“New Shapes”</strong> below and download it now on <a href="https://music.apple.com/us/album/new-shapes-feat-octavian/1451222807?i=1451222810&amp;mt=1&amp;app=music&amp;at=11l4Qg&amp;ct=newshapes" target="_blank" rel="noopener noreferrer">iTunes</a>/<a href="https://play.google.com/store/music/album?id=Bqhtcn4d53f5wglxtqw6ainvtxq&amp;tid=song-T2oqjajzk527fofozotzra2o76y">Google Play</a>.</p>
<p><iframe src="https://www.youtube.com/embed/eBnXVu0BKjQ" width="620" height="350" frameborder="0" allowfullscreen="allowfullscreen" data-mce-fragment="1">&lt;span<br />
data-mce-type=&#8221;bookmark&#8221; style=&#8221;display: inline-block; width: 0px;<br />
overflow: hidden; line-height: 0;&#8221;<br />
class=&#8221;mce_SELRES_start&#8221;&gt;﻿&lt;/span&gt;</iframe></p>
<div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="http://weuponithiphop.info/2019/05/22/music-video-diplo-ft-octavian-new-shapes/" data-a2a-title="Music Video: Diplo ft. Octavian – New Shapes"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F05%2F22%2Fmusic-video-diplo-ft-octavian-new-shapes%2F&amp;linkname=Music%20Video%3A%20Diplo%20ft.%20Octavian%20%E2%80%93%20New%20Shapes" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F05%2F22%2Fmusic-video-diplo-ft-octavian-new-shapes%2F&amp;linkname=Music%20Video%3A%20Diplo%20ft.%20Octavian%20%E2%80%93%20New%20Shapes" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F05%2F22%2Fmusic-video-diplo-ft-octavian-new-shapes%2F&amp;linkname=Music%20Video%3A%20Diplo%20ft.%20Octavian%20%E2%80%93%20New%20Shapes" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F05%2F22%2Fmusic-video-diplo-ft-octavian-new-shapes%2F&amp;linkname=Music%20Video%3A%20Diplo%20ft.%20Octavian%20%E2%80%93%20New%20Shapes" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_tumblr" href="https://www.addtoany.com/add_to/tumblr?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F05%2F22%2Fmusic-video-diplo-ft-octavian-new-shapes%2F&amp;linkname=Music%20Video%3A%20Diplo%20ft.%20Octavian%20%E2%80%93%20New%20Shapes" title="Tumblr" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_reddit" href="https://www.addtoany.com/add_to/reddit?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F05%2F22%2Fmusic-video-diplo-ft-octavian-new-shapes%2F&amp;linkname=Music%20Video%3A%20Diplo%20ft.%20Octavian%20%E2%80%93%20New%20Shapes" title="Reddit" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_flipboard" href="https://www.addtoany.com/add_to/flipboard?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F05%2F22%2Fmusic-video-diplo-ft-octavian-new-shapes%2F&amp;linkname=Music%20Video%3A%20Diplo%20ft.%20Octavian%20%E2%80%93%20New%20Shapes" title="Flipboard" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F05%2F22%2Fmusic-video-diplo-ft-octavian-new-shapes%2F&amp;linkname=Music%20Video%3A%20Diplo%20ft.%20Octavian%20%E2%80%93%20New%20Shapes" title="Copy Link" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div>        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="http://weuponithiphop.info/tag/diplo/">Diplo</a></li><li><a href="http://weuponithiphop.info/tag/new-shapes/">New Shapes</a></li><li><a href="http://weuponithiphop.info/tag/octavian/">Octavian</a></li></ul>            </div>

                        <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="http://weuponithiphop.info/2019/05/22/music-video-jacquees-live-ya-life/">Music Video: Jacquees – Live Ya Life</a></div></div><div class="td-next-prev-separator"></div></div>            <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="http://weuponithiphop.info/author/cyclone/">cyclone</a></span></div>	        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="cyclone"></span><meta itemprop="datePublished" content="2019-05-22T21:04:45+00:00"><meta itemprop="dateModified" content="2019-05-22T21:04:45+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://weuponithiphop.info/2019/05/22/music-video-diplo-ft-octavian-new-shapes/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png"></span><meta itemprop="name" content="WeUpOnIt"></span><meta itemprop="headline " content="Music Video: Diplo ft. Octavian – New Shapes"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://lh3.googleusercontent.com/EHFKDTrxgrWLYANBBN8xsnYjBjHUQAJQItEkutjwV5tFz58wurUjFnwlHuywNIp0K1CrBlu7DPbGl1HGnYDWKjN7JcertJ152GsJzRgENXBENSYeqXMkyiDLqUlMIe37VAf-KVw34kW6sMrl11Q9PXuiKi68bg6-tU4w7ABOJihyXSHt7CxFYlbx2TcLIjpdoliVPZBrDr22T2oll9mHehdBGu3fs1oejWtJOCWVSZRBNBgmlW2zxQYzKwN-lJCCLAcY_0-1m_99Y-S_dna1aVelD2QSzSuftEoT1OkQ9DBcUZbgkd5EKOBpVW1tCefMhlnOvvCc39-JG2rsMg6-5r4SCQXXbQ_2Dl0tS9AjfI8VqnJbQKEe_40z7upMhigyvFBFk6ijitiuLvyL5zgp8A9zwQmb9dS1o6cx7icKHj8_Z6alhNTkNNhDm1jUKSCLacn165SxofOql21NBPys0TFYB100v-3SoV3Whm6DHprfGuErbShL8UjsHiE0fCaoKABW9F-iniTlrU12i6rTXPn76FozTPeTK61Wb0pa3ewIdglLR2GXdS2HVL7oQzc7pdicw8xk8NOef6zwTXHrAjUE1BvRogpRnVP2QA49H6OSrWW7NSx8VERbmT-UpFOQ4pWzqMg8EEX8rCcmYlI9uNyBzXcoHoVP=w683-h477-no"><meta itemprop="width" content="800"><meta itemprop="height" content="600"></span>        </footer>

    </article> <!-- /.post -->

    <div class="td_block_wrap td_block_related_posts td_uid_15_5ce622479ef76_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_15_5ce622479ef76" ><script>var block_td_uid_15_5ce622479ef76 = new tdBlock();
block_td_uid_15_5ce622479ef76.id = "td_uid_15_5ce622479ef76";
block_td_uid_15_5ce622479ef76.atts = '{"limit":6,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_custom_related","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_15_5ce622479ef76_rand","offset":"","css":"","live_filter":"cur_post_same_tags","live_filter_cur_post_id":30019,"live_filter_cur_post_author":"1"}';
block_td_uid_15_5ce622479ef76.td_column_number = "3";
block_td_uid_15_5ce622479ef76.block_type = "td_block_related_posts";
block_td_uid_15_5ce622479ef76.post_count = "6";
block_td_uid_15_5ce622479ef76.found_posts = "9";
block_td_uid_15_5ce622479ef76.header_color = "";
block_td_uid_15_5ce622479ef76.ajax_pagination_infinite_stop = "";
block_td_uid_15_5ce622479ef76.max_num_pages = "2";
tdBlocksArray.push(block_td_uid_15_5ce622479ef76);
</script><h4 class="td-related-title"><a id="td_uid_16_5ce62247a2cff" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_15_5ce622479ef76" href="#">RELATED ARTICLES</a><a id="td_uid_17_5ce62247a2d47" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_15_5ce622479ef76" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_15_5ce622479ef76 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/12/music-video-diplo-ft-cam-so-long/" rel="bookmark" title="Music Video: Diplo ft. Cam – So Long"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/dCXj-0TP_PnwISFbwnnS6_R6xkq4hfui9fSEbGSW0JvaKYzlS3iYNEOkfakmFZ8TJZ4jb14DInD3O0kU8YdOFo86O73iVAG8FI0j3RJxNThF1otaqxWhLikkopSl1VZaeSm_2I62lp48KdntIVc6VEsx7vduFsdcnLEOZq87yEK3472efopg1e44xENly21vtZw07SBRMVSVsWIKvvzYrMbrIQ2ESR8qJcwO2pZv-OmZ90zxMeRo4yE83Pwx6MxoF7071yMUBPaFvmKX0pvhzycNTr6A0k-xddSTDxiwr2M3KU7xZPVe-2I3DgtHdZtc14aYBPMwdcOiDHWrwEFxtfI-fw1FdrGyN6NO5zoCsQMox1FUBghgbLZ6AFNx9TSOiZM7llLQzf8jrkR62lNX9pbzVMPpeX7YJ7Tl9uP6UJs2i0kngo6RsN9oE41b4hwCvHF-L3oNpxQlQOvREOtwheP_tr0-1mAlybyLLulBEP4sCTbYvnOj6jJ4JikrybcdfkR3zS2TwgY3a8I2x8WmP3ElynBVscaCHweN_pvgTRa3P2NRwkT5PIjRA2--b1aSlMm5sEfKk86dVD9GsY8W2ygYyuw_NQTjf9ldfSKVUo3akp5-t9hLUVZJTxxU71ppS1vlhAu08ewmxnJm7DIXCriIVTTrACEE=w772-h527-no" alt="" title="Music Video: Diplo ft. Cam – So Long"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/12/music-video-diplo-ft-cam-so-long/" rel="bookmark" title="Music Video: Diplo ft. Cam – So Long">Music Video: Diplo ft. Cam – So Long</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/03/ep-stream-diplo-higher-ground/" rel="bookmark" title="EP Stream: Diplo – Higher Ground"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/2JDRxuojEC9F_DVGUAMTLT0sffdhgPkCf8Aw4Kr5G8lX4kfMeyu-2LBGro5u5QYY8nvU7GI0pwM7op1DhXib8rxGWUJfalXoOeYYCWWcb5n9I6waezaqAoBZUkLAUiUbcLe6qVwOUz9MTN9GA8u-U1rfwmkYDf15C09whBUvpVMBeXui9YecD2rNUalSoER_PNKS0gqpQpp3xCtBcALSO2Orxq-bQj-YfWFK6lbR4r66tDvPYiBju0NX6CNec2MNghUqbAKQYwsTUb1K8lqQtN6zwJqTiosHG8RoP3Jjfkl_wmCQ_BzZxmkxDkPE1O0uc4RAAWALN2-ypyrkpOlop3e1lqFPVAlN6nn2S1hWtHyIU6NwicEbdJBENM6oN2wn968_IeHLnCGeCzWoL13luq1tYh0hkiFJrmUuIabSnvC4ZVzRNciPQhkAvS9zMlv2F6Rr4-aKeg__7p92dB4MCaUK4Zb1gj7YdwaAeZQLVqms48nKBlZYvUNGvFQi5znOK1gZAtABXPTFQ6RAMQj2LcJ5ntRfVeFi5xYDYqRh5oCeaftm6pZS6pdIgKNEcEftoE8cCPNZ7uql5zHwY9_H-gechRWCaoXbIapEjG5IyCbpQxGuzeEX7YxIjeRSN5ZoJqgmsBZlU_Rm9y98Z77rSDJwfVauhvIV=s673-no" alt="" title="EP Stream: Diplo – Higher Ground"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/03/ep-stream-diplo-higher-ground/" rel="bookmark" title="EP Stream: Diplo – Higher Ground">EP Stream: Diplo – Higher Ground</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/04/27/music-video-bad-bunny-ft-diplo-200-mph/" rel="bookmark" title="Music Video: Bad Bunny ft. Diplo – 200 MPH"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/Z2Ni_x9M3b6LvzmsVtikswahwSrjYsLLgwD0jitC_BV-CpunzedjXVjp_QfVVSNrc0QIIq_Q7zMMMNjCc5lEN-VFTlLn5xRcmZt0adm3qHK6nbgvMCZtPopUX5ov1xjQjK5tIQcT3LPcp91TqpcyCLt5bLJ7sbJxrbNsi9dbBd6paschTR6XpHbxhmVh9sFr01tCM9Zc-n67jgwhD9ir5ueY8CM8T5MvkgSg1SVzgzbCIvac8dLrA_QYVnvrsF2hVF-mEjl5vfS50cTIVnF2xeDGq_sx8235TwuD81ic5Ogfiak9UJ_AK-_sxIm1jHZ9WohFZ9pkI3TLIoYB9LmF_X-Sk2tDmw7SE1YBSuTJt4-M6cNUDSCPSQhHIY4kYNjItWzuSU-gSvqBHN8RUGbhsJApp7aC3R4leun1bOe5Oy0PHkYnlK0wowcFaeJvhOgp9ZhSDhmcMVhooIlOeps6cHdS2BOC4Zktek_PASLF2uoo_BTom274T_dPPImG8PCxs6SuUPzPK2vOOROZ9aFUYaWp0Hla_3Usr2xE9chcgncmggtM0r84NjzyNem2zxlriDfSOheV22CNRn4BYErlPnokGAc1dYcNhb-NwxMM5_KDfv2yz5TXx9AvBfslFvkhj_iQW85dprL_VGsJYXK2fhca0i2gi4EV=w744-h550-no" alt="" title="Music Video: Bad Bunny ft. Diplo – 200 MPH"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/04/27/music-video-bad-bunny-ft-diplo-200-mph/" rel="bookmark" title="Music Video: Bad Bunny ft. Diplo – 200 MPH">Music Video: Bad Bunny ft. Diplo – 200 MPH</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid-->

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/04/12/album-stream-lsd-labrinth-sia-diplo-present-lsd/" rel="bookmark" title="Album Stream: LSD – Labrinth, Sia &#038; Diplo Present… LSD"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/N4Ym9PcvaTQmyQTTv5xnuUmD379HAV9krtqjpsDvmm21Zhz3gVsqXiONmBILlzBxBNEgNMouCYtSogYhKVFBWPaU2UfkwPhqEmE0M_BmriPRN9by5SqZPKLPHaEzWMcubXLnA77Za0rWUwBdyxiSjt105cUIM34nqv9FNYGoWDhNcFaAVe3EDY6-TxnESPtuTq1wVN7q8H-A_Q8Saz9mTrlfH5PyBvOJMq-C1ZvSYPDkkBf09fKBSf7GsnPTjOevz9Yrfx8-yFuoGs1TWfc65FMkmZtBPlAuSu2DE69ElKdoCPuu81CdVCRMhL92IeS-FOLuWgF56eR0eyqNydJvvPy1bnZZdFXykN3nkgUoKbjQZxyvASln6gOIUDS4iJ4u3YuoH4qG-nTtadOawIdQprPegvDdvTU3HVGhaq71bLSaRp1foQFEUdzsbQkZE-1sVgfeEAjCPcp-f67lfLSUqwzQ4d_cYDaI3pXlwRXvwxfKHhZppPlTVhBNMqkQ-edNM3T0cRUp8mPMztXMAZ-Z7fO1I9KiXomVaPyxJuCslo02Ug2qokWTFEYXp9YrLYSQvYlQzwrKYhipgdaRlvdenG8lVZI2hhH8jdTbL3YukS6qeqrWbaREz7WR6TkkhMJOTzwayjkvj6udEpvgCCaOAbPpkm7fRU-h=s671-no" alt="" title="Album Stream: LSD – Labrinth, Sia &#038; Diplo Present… LSD"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/04/12/album-stream-lsd-labrinth-sia-diplo-present-lsd/" rel="bookmark" title="Album Stream: LSD – Labrinth, Sia &#038; Diplo Present… LSD">Album Stream: LSD – Labrinth, Sia &#038; Diplo Present… LSD</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/02/08/new-music-diplo-ft-octavian-new-shapes/" rel="bookmark" title="New Music: Diplo ft. Octavian – New Shapes"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/-FRMLvOhaFdfhRVOswFodmqruDJfSJOL7dYJ2HELS8llio9GYsMCcWNfIq6CcIwZESOYS7Pp3j6El0W0RRwa3Qmld-KP7WYo_8kw78ZXL6ntUwSHZ9bgGNyiC7gbaPME43DuBYUd2lDQAE4Skvs7n-hiqKqecGMjbz8ATJDV12iEfL4kkpd7MgYQekwiPP865S0rfjih7S8dq73-FXvF-7FboTGp6YmYvNpQqDypiVdXsQUXWSLAYQj6FHkF5IG3hfFPxZdz5aTyHRZv7UwECNckRaB8SMc0ky9Lbhz4L_4hctg3ZV__mMpS-ejeIHyHBeUMkd6ixFeCT0UDciJCwQN8OF9pz7vCm2KHz_T-uws6AV0s7zbEfGlTq6-RsrN9vyYsLTG0sGf4e11SXGE7ZO1wgCxV6ZKqWHYpfYJ13jP3Fr9ySDv3G1Ui3K-y1WHxxZ3BlGaj-c5_AvSz_B-IcxoIdnkypf1IpVPPxtWXczOoY0i0yhlrtSlkonK_lLajdczUXHUejT7cEgOCQBO3W8A1Ft9HRGliqUiVODnCKuxJnod72wRQPlbeFxi1o-Kcf4Osd5kkJnRHLMo1L-DueaBbnHQYCfLfcGRrvsSICUr-ZkB68iYhA42ZFbSQRxh8EhH7_nySxlEVP8uR2JQqOwdOpHYEgvke=s673-no" alt="" title="New Music: Diplo ft. Octavian – New Shapes"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/02/08/new-music-diplo-ft-octavian-new-shapes/" rel="bookmark" title="New Music: Diplo ft. Octavian – New Shapes">New Music: Diplo ft. Octavian – New Shapes</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/15/new-music-take-a-daytrip-octavian-stressed/" rel="bookmark" title="New Music: Take A Daytrip &#038; Octavian – Stressed"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Take-A-Daytrip-_-Octavian-–-Stressed-218x150.jpg" alt="" title="New Music: Take A Daytrip &#038; Octavian – Stressed"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/15/new-music-take-a-daytrip-octavian-stressed/" rel="bookmark" title="New Music: Take A Daytrip &#038; Octavian – Stressed">New Music: Take A Daytrip &#038; Octavian – Stressed</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_15_5ce622479ef76" data-td_block_id="td_uid_15_5ce622479ef76"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_15_5ce622479ef76" data-td_block_id="td_uid_15_5ce622479ef76"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->

	<div class="comments" id="comments">
            </div> <!-- /.content -->
                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <aside class="widget widget_search"><form method="get" class="td-search-form-widget" action="http://weuponithiphop.info/">
    <div role="search">
        <input class="td-widget-search-input" type="text" value="" name="s" id="s" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit" value="Search" />
    </div>
</form></aside><aside class="widget widget_text">			<div class="textwidget"><h4><strong><span style="color: #8224e3;"><span style="color: #000000;">Listen to</span> <span style="color: #c60000;">WeUpOnItRadio</span> <span style="color: #000000;">Live!</span></span></strong></h4>
<p><span class="cc_streaminfo" data-type="song" data-username="cyclone777">Loading &#8230;</span><br />
<script language="javascript" type="text/javascript" src="https://control.internet-radio.com:2199/system/streaminfo.js"></script><br />
<iframe src="https://tunein.com/embed/player/s292400/" style="width:100%; height:100px;" scrolling="no" frameborder="no"></iframe></p>
</div>
		</aside>
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-sidebar ">
<script type="text/javascript">
var td_screen_width = document.body.clientWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 

<aside class="widget widget_text"><div class="block-title"><span>AUDIOTRAFFICKER:</span></div>			<div class="textwidget"><p><iframe src="https://www.facebook.com/plugins/video.php?href=https%3A%2F%2Fwww.facebook.com%2FAudioTrafficker%2Fvideos%2F326277991409372%2F&#038;show_text=0&#038;width=560" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true" allowFullScreen="true"></iframe></p>
</div>
		</aside><aside class="widget widget_text"><div class="block-title"><span>Nas-T ft. Rumy Da Beast &#038; Modoe &#8211; King Of Thrones</span></div>			<div class="textwidget"><p><iframe src="https://www.youtube.com/embed/1UA00_Wppvc" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
</div>
		</aside>                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->


<!-- Instagram -->



<!-- Footer -->
<div class="td-footer-wrapper td-footer-template-3">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
			    		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span4">
                <div class="td-footer-info"><div class="footer-logo-wrap"><a href="http://weuponithiphop.info/"><img class="td-retina-data" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" alt="" title=""/></a></div><div class="footer-text-wrap"></div><div class="footer-social-wrap td-social-style-2">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div></div>            </div>

            <div class="td-pb-span4">
                <div class="td_block_wrap td_block_8 td_block_widget td_uid_20_5ce62247ad6a9_rand td-pb-border-top"  data-td-block-uid="td_uid_20_5ce62247ad6a9" ><script>var block_td_uid_20_5ce62247ad6a9 = new tdBlock();
block_td_uid_20_5ce62247ad6a9.id = "td_uid_20_5ce62247ad6a9";
block_td_uid_20_5ce62247ad6a9.atts = '{"limit":"7","sort":"jetpack_popular_2","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"POPULAR POSTS","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"#","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_20_5ce62247ad6a9_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_20_5ce62247ad6a9.td_column_number = "1";
block_td_uid_20_5ce62247ad6a9.block_type = "td_block_8";
block_td_uid_20_5ce62247ad6a9.post_count = "7";
block_td_uid_20_5ce62247ad6a9.found_posts = "10";
block_td_uid_20_5ce62247ad6a9.header_color = "#";
block_td_uid_20_5ce62247ad6a9.ajax_pagination_infinite_stop = "";
block_td_uid_20_5ce62247ad6a9.max_num_pages = "2";
tdBlocksArray.push(block_td_uid_20_5ce62247ad6a9);
</script><h4 class="block-title"><span>POPULAR POSTS</span></h4><div id=td_uid_20_5ce62247ad6a9 class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_7 td_module_wrap td-animation-stack">
        <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/22/music-video-lil-tecca-ransom/" rel="bookmark" title="Music Video: Lil Tecca – Ransom"><img width="100" height="70" class="entry-thumb" src="https://lh3.googleusercontent.com/0U1ZK_Wj_TIhCev66L3WyIDsT4rXdA5cQell6tcfVIFw9zFEkhwQD2eCD9mn8Yn_J6yfKymztM_zr8mIGQoR-Mwpbm8PWALC6tOrbZgCRzMMHbsSX6Sp9tNJ2TBoMfJWA8wQzArLMkkPl98Eu973mV6h0Rerkn2Xhi9es1YFZjTDtc_wb2SEusYQJQxJys2G6B2vcsSpYCAaoD8I-zfspWBQt2cK7k0WBaLeFZFpeRUshCaozCh64oBOrFPFga2JxZ98pnGH5KwV-FNub1OzxO3Zo0-YEPGVfC2dWd-rYZAHxUE8-bLu13XK7IODHxkmQer46_dwBoAz8UVfJ_dKNuoX2xXXnHbiL5oh2UDF5tsGsoyW_rZAg0CDWu5roe2wjZu5QHSi974ZjgXny-QMkh7YSD7I7sTlnRlobWs5LVKlrnn_dVnc_sOCF8MrZBsEq19FXAX7seNBEToK1E6NvbwhD-U5KMNZcvvsA7_Y1yhTwqNWP6bz9GyZngCvkc-V85b0JsICDHKkL7GQ3qzkk134DCz11Couaksumd4IJDehuYRJE6S5UAUfVKf_UUjtQzy2PWsA1an9JEGmgicLDCNATw39zdDhPj5TD3iIfJ2N2bCIStHXcECi0SUgTvF7UmxhOSsMxE_b-Gv-fVPFVV-0rMclbM9R=w771-h509-no" alt="" title="Music Video: Lil Tecca – Ransom"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/22/music-video-lil-tecca-ransom/" rel="bookmark" title="Music Video: Lil Tecca – Ransom">Music Video: Lil Tecca – Ransom</a></h3>
            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-05-22T19:51:49+00:00" >May 22, 2019</time></span>                            </div>

        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_7 td_module_wrap td-animation-stack">
        <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/22/audio-joe-budden-the-joe-budden-podcast-w-rory-mal-parks-episode-249-act-up/" rel="bookmark" title="Audio: Joe Budden &#8211; The Joe Budden Podcast w/ Rory, Mal &#038; Parks (Episode 249) “Act Up”"><img width="100" height="70" class="entry-thumb" src="https://lh3.googleusercontent.com/ALRescNn9y8NdXr4tbh7Hxgu7JBR1tOUPaZzRHl_2ex5BMfQQyp5RMSoN_z9jfiN7xsS1MnIHFV3hszRxL-VJKgHS6QOkhBFq98FuY838gxbW1R18-XadLS0F4Nyo2Ee6ssKmxcHoHIZvLjXEN7LE-F_-9Ajz9YRIZCJTrgGkByPBBmvANEdE1fqEo60SVap5LNqtoMm2smOk__biGqiTHy0gof5CIv1OQ5fFwhf9Gnjt3gtyVtYjdqrdO6gG6E8jt_xy1ZiHNSQ4oLwXITFOZJEcSNc3HdFxYnTz3gvB1GGgDJe4qdLY8r_a72lqQWGeyUTL8LdP5E6LfY7DYegUlcmlMoTummN0zWK24wiq44QCrcZNcvsY7SV-W0QAcl67Jr_Q_1vCyEStfKE4rezGcTqtfnNrzJowkEby3sYEb-mKjXptKBkIO7eVe9m0YRFudi-D_UpUuBeCULH6OsfcTVH3v20A-t3zNCjmmzcg90S-ImHHkR8r72PWceGDIVbcjjwm3S-Wl68Q9AdStlwhZPNmmke8a0A4JRRxKZrPfQfBjAdEvVesn7cpj_2l6yNyxD6j5uWyFotbzu10ek34xx_PxU4EwjYUXq4EmB53Lthe68PmnWh9uidFgJI29nXjD6XJA7T67OAM-OSOvNW8NVvxFnSaEGC=s796-no" alt="" title="Audio: Joe Budden &#8211; The Joe Budden Podcast w/ Rory, Mal &#038; Parks (Episode 249) “Act Up”"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/22/audio-joe-budden-the-joe-budden-podcast-w-rory-mal-parks-episode-249-act-up/" rel="bookmark" title="Audio: Joe Budden &#8211; The Joe Budden Podcast w/ Rory, Mal &#038; Parks (Episode 249) “Act Up”">Audio: Joe Budden &#8211; The Joe Budden Podcast w/ Rory, Mal...</a></h3>
            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-05-22T10:44:55+00:00" >May 22, 2019</time></span>                            </div>

        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_7 td_module_wrap td-animation-stack">
        <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/22/new-music-denzel-curry-speedboat/" rel="bookmark" title="New Music: Denzel Curry – SPEEDBOAT"><img width="100" height="70" class="entry-thumb" src="https://lh3.googleusercontent.com/ZNyQ4dXW9UmRW8o0wrYheQZOgQWR-rtz3m1pkp1NB3snIZN5VnXSGp_qAPWplj0LbnKQ0x3Ouio7gXwRQYNYs--71o_K4E8nkJ771_rqZJVDU132GGlQ-L2e9uxDTsAUIBSSqGk770fXqchGCwb_jrGbFJASonOuJmoDtAa91WReDeqiG8rSnhfZcJ1DtXxMm584tKOf3MKAzKHnbVM68qKZuLfXqOdq6ZRTS0bnIeygwCMmQKTOvbzXdKr3qZBkr9f6YrjPaXDLMmoCz_fxnCyiIj0ae2sjEY2kljTlh95vKdL6RMS9Rdym5E7B5HlqX4hMwcLSFNqA20qRI3oFLW9BKtuPu-MmoQ-TdgY367ngEvCLUf4pZa0Y2QMIBj-egMRZ4GMGrPO6ART987ZYF_EE_pe9kDGJLbPypFhyokVMslHUJCQiPURo7v60V4K0AeVdJ8RDiq1sMe75QGcxTmE4WMTNdQO6GSfygJlO7gT20XgQspqMeSRg29O3fFHYQKVHgYoyenmS7b-A_0CEOEoXXo_xNxyFybdMQ-Yx2kU_zW4fgVlRa4LnCyP2JSOPfHh6nTLUZwR2YRhonEOg5nVo945GveRYFEHOH0AxxG9X_VwchIJCReRyBHGSfvffPQAK3YNk1o5DwFhF0U3L4H_hX-amSWRe=s796-no" alt="" title="New Music: Denzel Curry – SPEEDBOAT"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/22/new-music-denzel-curry-speedboat/" rel="bookmark" title="New Music: Denzel Curry – SPEEDBOAT">New Music: Denzel Curry – SPEEDBOAT</a></h3>
            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-05-22T07:29:10+00:00" >May 22, 2019</time></span>                            </div>

        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_7 td_module_wrap td-animation-stack">
        <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/22/music-video-king-von-ft-lil-durk-crazy-story-2-0-84764/" rel="bookmark" title="Music Video: King Von ft. Lil Durk – Crazy Story 2.0"><img width="100" height="70" class="entry-thumb" src="https://lh3.googleusercontent.com/Zu6MHXM4iFgaelCN0cKrtZZ8xKPlPjqlFkWpSYPwvPyORx0F3wxphO1MwSsGaP7xvLDisy1ii6DisqOMrZiLVWf2bsmyhIYqLLm7--YtU3IC7gwcU7okuJ0WxLAqUfVSD73nK9t25q2-GUTRDSCVjNlPzwAW2NgoDq4xR-JNDXFGmdI9fMwRzYqizZcZMbz12vIWrZs-1Lpx5e0WW9Zya4koCDQL1Qx22OKdg8mHXggnwTm_pWXdmF_EBM9dQHT67vDBimH9gdMI_jHbfIRWRj0hauM_FzV-agDFw299UE-4wMh6lCjuN1D1XvwGFJLCVDEkGt_Gurc95A7MGXpiZuLJY7CbEbUKwB14tNceeA4lzDfj0WVc1PJcNOjHvp_DpJhVhH_fT0BskqLcV4FKFdBk1RjqTeiIsAkhRb6VrJ2REn-VYDKlPxNiw2Qjmtv5wua2f4aLiUkZSRcgeQ-798o26Ji7qnYKIDIrvpIg6Y7BU65Yf6gbUgxR2X4Tn7gKWluFcQ8r5JNrAnBol60ebyhxk2HoIDn2RRHOdh1cc79lYQewiqESzaUN28fxBnFFhXo3KbqYpMmCnwhq0JsPGujcOTsUB74xIcCg2de582eK0qH05NUBjufIOXmemBMtx31TK7bN1sfF9bjGddBeqy571a5MIlwx=w993-h550-no" alt="" title="Music Video: King Von ft. Lil Durk – Crazy Story 2.0"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/22/music-video-king-von-ft-lil-durk-crazy-story-2-0-84764/" rel="bookmark" title="Music Video: King Von ft. Lil Durk – Crazy Story 2.0">Music Video: King Von ft. Lil Durk – Crazy Story 2.0</a></h3>
            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-05-22T06:39:26+00:00" >May 22, 2019</time></span>                            </div>

        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_7 td_module_wrap td-animation-stack">
        <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/21/new-music-mac-miller-benji-the-dog/" rel="bookmark" title="New Music: Mac Miller &#8211; Benji The Dog"><img width="100" height="70" class="entry-thumb" src="https://lh3.googleusercontent.com/nSiI-TGXEVyYbRmiGzKpYxxyaGbBCsjh5YxiXCaaJ7N4JT1vFiwCS1oqOKlnLpHF8SJsH_k7iEr9Q9bGW6wq8WQSoA1NxMmrSOqcJ65WsW2CHp2NMOPI8Un2-RHwNQG0PVnz4FOOMPNMdEIMV6cAFAZQozbSufI5ViPQrUx7znOKJ5g-nHz6C8mMmx4HvBmPuxB1NglfUfpUHCNj9qWhnsCuCJJozYDswwII3Qb71y5WDdfhc2UQTXv_W3Ht2NPkXkddTL2rD9-rjPDttJUm6Y_ZZiTyu7mHuQeQl8ILa5Gr5TecsrkCHWJT2u0s4IM96sOvU9yrJPk436_9R_nYdl5m7TWjwN-O-M-iit6wrqJTQB9ESnJG5zdba5xv1XYpbzloKfeWXmTVv_urxDDvBW4t-EpPN0u3RbJQPFF7RCXPBzOkpanPdOCQwV7Iy8tqAhNQ60BP_QKieYW4YNUR04Wm3329xSEuNF6jhgThKOb7hxva_P7cqK-xQfabLTz9DeotScjYQq5UNL4EGEO0trZ8ZB2gEd1yY_OenWZj7Qv7ZX2ncYRw-owF1lGtVOEDbO5E2hWT1Qjd0Ukri-CHfZ4geYBIlyYf6O2vZDUhFu6bipyIksEdlvK2EfJDSv1ZXGTP2QMs8VoczANlVF-xlqaz1vAiDDf4=w476-h599-no" alt="" title="New Music: Mac Miller &#8211; Benji The Dog"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/21/new-music-mac-miller-benji-the-dog/" rel="bookmark" title="New Music: Mac Miller &#8211; Benji The Dog">New Music: Mac Miller &#8211; Benji The Dog</a></h3>
            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-05-21T06:45:33+00:00" >May 21, 2019</time></span>                            </div>

        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_7 td_module_wrap td-animation-stack">
        <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/18/music-video-dj-khaled-ft-chris-brown-lil-wayne-big-sean-jealous/" rel="bookmark" title="Music Video: DJ Khaled ft. Chris Brown, Lil Wayne &#038; Big Sean – Jealous"><img width="100" height="70" class="entry-thumb" src="https://lh3.googleusercontent.com/6J__l6AbSx-HQH6jcLzEotdnxS9VnYicRVyqBq3qaqn0inFvagYfjulIOmcHQu5V9XCou_KMnPTPHwoOrDhHAXrbB1cNW4jgoaJMaRPNf1Nnw2NUqN0okUsg2x6PTOdcC-ewqpOHTOUOxMUYMzQFNFZensFjyNan3G7j3LGwcDrWos6JYNzqXPiN8YdY6zq4O7tftH3pfDkymfrbIefDlR0zSUD41dOAo-bv1xnkb1dDAE0X7Jj4_Zv8LFBgLQwjdjZewjbVnBhHUhQEHTTtfCBab_h0cLGpaYqowMy-WQMJZMxv8-2GqfY1kFSalmQFrMC-51_5sTcpVWGAI4zCkw7Wy7x9hu9JDO0eFQxPAgzAy74UEAyKZl0DH5t_71GROYqG3H1RcDzSRHs_6oXAeUkuQqzpbVHyZ6uWzQUKRRNc8LH9nNCvayvYWZMMbpV8oQDeMjTS2eMbYsUIjvjTpX4PqD_W3ahUtTEEnrBwIZcQpSClTzIVObdXOw8NAjtxNU9ZNHmkf6Bizt1SFMUru7mET40aoQnsl6hfc-Ze7BveLelPEiNJxwEF5FpxsG8gVg9jKaKjE8bl-DAtMuu8ZPNRv9tfr_ubtxxYoXxoLrwh7geM4PK3BXzz9B0PcvhrRn6nXJNr0ZLel2lIoSh0Q4ZWwtYlkvj4=w906-h508-no" alt="" title="Music Video: DJ Khaled ft. Chris Brown, Lil Wayne &#038; Big Sean – Jealous"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/18/music-video-dj-khaled-ft-chris-brown-lil-wayne-big-sean-jealous/" rel="bookmark" title="Music Video: DJ Khaled ft. Chris Brown, Lil Wayne &#038; Big Sean – Jealous">Music Video: DJ Khaled ft. Chris Brown, Lil Wayne &#038; Big...</a></h3>
            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-05-18T07:25:36+00:00" >May 18, 2019</time></span>                            </div>

        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_7 td_module_wrap td-animation-stack">
        <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/02/music-video-lil-durk-ft-teyana-taylor-home-body-remix/" rel="bookmark" title="Music Video: Lil Durk ft. Teyana Taylor – Home Body (Remix)"><img width="100" height="70" class="entry-thumb" src="https://lh3.googleusercontent.com/3Csi97lwDvANsp8jG8isx69d6-wcpalWjAPWLcu-x4qeVGLANnqNCLWjjzX9K91B89UN7MblYsqNfV6dwHC1Owvp20ADl2Zgs7yL5XTsrXeYhMalPlGEiDN3sL6yh7lvIuQxzKyaPF5MSerG7UvY_C12-YxEJvNm6csXpFulu2Sd4anmYP73yHh-rMH8ygOvDaEeSTlg9-uoXy0ua1T0_1zK5Olz9Lrm1KxALp_37xSbtb-lUR0WkqkUkkzwOcnLutJjh5XbvbbMD6VwWfTmtKq2z93Le2rSKqdav0c3kjkQx7J_ZNSfdSaKK2ooQ06LRKPXfunPZjhvj5EuFfCv0Vk5mHB4yM6gzAzKuamkhZR3-V8n-GJhJeE53GeuEvWXpYMl7Pu7UambXI85ztxgnvAfV9i6aMhkEVBW_xRJ0N6csXtV51BoQ-2Eqg2IxDt06xKBCQWdKxnTTb8GtBPoM8KJarHvbkFnRhH74ibCrWqUjqzOS-PIWSJ-m6HkhZVdz4n5LNV5fwYKt9ny0SvGDifDoSqkWkh8EPAZd3CYX7_hzt7MLYS_Q_hrVEC7IiPLPjkBX36hESYEmaeE_1NaKWeiQegto1NxNTcF7ZAY1wjtc3sBo_SWI2bdTnd1vjr48r8L7Fr9McWxfq9lN-oi2LnxWiI9EyBC=w886-h502-no" alt="" title="Music Video: Lil Durk ft. Teyana Taylor – Home Body (Remix)"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/02/music-video-lil-durk-ft-teyana-taylor-home-body-remix/" rel="bookmark" title="Music Video: Lil Durk ft. Teyana Taylor – Home Body (Remix)">Music Video: Lil Durk ft. Teyana Taylor – Home Body (Remix)</a></h3>
            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-05-02T07:15:27+00:00" >May 2, 2019</time></span>                            </div>

        </div>

        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block -->            </div>

            <div class="td-pb-span4">
                <aside class="widget widget_calendar"><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar">
	<caption>May 2019</caption>
	<thead>
	<tr>
		<th scope="col" title="Sunday">S</th>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
	</tr>
	</thead>

	<tfoot>
	<tr>
		<td colspan="3" id="prev"><a href="http://weuponithiphop.info/2019/04/">&laquo; Apr</a></td>
		<td class="pad">&nbsp;</td>
		<td colspan="3" id="next" class="pad">&nbsp;</td>
	</tr>
	</tfoot>

	<tbody>
	<tr>
		<td colspan="3" class="pad">&nbsp;</td><td><a href="http://weuponithiphop.info/2019/05/01/" aria-label="Posts published on May 1, 2019">1</a></td><td><a href="http://weuponithiphop.info/2019/05/02/" aria-label="Posts published on May 2, 2019">2</a></td><td><a href="http://weuponithiphop.info/2019/05/03/" aria-label="Posts published on May 3, 2019">3</a></td><td><a href="http://weuponithiphop.info/2019/05/04/" aria-label="Posts published on May 4, 2019">4</a></td>
	</tr>
	<tr>
		<td><a href="http://weuponithiphop.info/2019/05/05/" aria-label="Posts published on May 5, 2019">5</a></td><td><a href="http://weuponithiphop.info/2019/05/06/" aria-label="Posts published on May 6, 2019">6</a></td><td><a href="http://weuponithiphop.info/2019/05/07/" aria-label="Posts published on May 7, 2019">7</a></td><td><a href="http://weuponithiphop.info/2019/05/08/" aria-label="Posts published on May 8, 2019">8</a></td><td><a href="http://weuponithiphop.info/2019/05/09/" aria-label="Posts published on May 9, 2019">9</a></td><td><a href="http://weuponithiphop.info/2019/05/10/" aria-label="Posts published on May 10, 2019">10</a></td><td><a href="http://weuponithiphop.info/2019/05/11/" aria-label="Posts published on May 11, 2019">11</a></td>
	</tr>
	<tr>
		<td><a href="http://weuponithiphop.info/2019/05/12/" aria-label="Posts published on May 12, 2019">12</a></td><td><a href="http://weuponithiphop.info/2019/05/13/" aria-label="Posts published on May 13, 2019">13</a></td><td><a href="http://weuponithiphop.info/2019/05/14/" aria-label="Posts published on May 14, 2019">14</a></td><td><a href="http://weuponithiphop.info/2019/05/15/" aria-label="Posts published on May 15, 2019">15</a></td><td><a href="http://weuponithiphop.info/2019/05/16/" aria-label="Posts published on May 16, 2019">16</a></td><td><a href="http://weuponithiphop.info/2019/05/17/" aria-label="Posts published on May 17, 2019">17</a></td><td><a href="http://weuponithiphop.info/2019/05/18/" aria-label="Posts published on May 18, 2019">18</a></td>
	</tr>
	<tr>
		<td><a href="http://weuponithiphop.info/2019/05/19/" aria-label="Posts published on May 19, 2019">19</a></td><td><a href="http://weuponithiphop.info/2019/05/20/" aria-label="Posts published on May 20, 2019">20</a></td><td><a href="http://weuponithiphop.info/2019/05/21/" aria-label="Posts published on May 21, 2019">21</a></td><td><a href="http://weuponithiphop.info/2019/05/22/" aria-label="Posts published on May 22, 2019">22</a></td><td id="today">23</td><td>24</td><td>25</td>
	</tr>
	<tr>
		<td>26</td><td>27</td><td>28</td><td>29</td><td>30</td><td>31</td>
		<td class="pad" colspan="1">&nbsp;</td>
	</tr>
	</tbody>
	</table></div></aside>            </div>
        </div>
    </div>
</div>

<!-- Sub Footer -->
    <div class="td-sub-footer-container">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span7 td-sub-footer-menu">
                        <div class="menu-top-menu-container"><ul id="menu-top-menu-2" class="td-subfooter-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-mega-menu menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_21_5ce62247bb286_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_21_5ce62247bb286" ><script>var block_td_uid_21_5ce62247bb286 = new tdBlock();
block_td_uid_21_5ce62247bb286.id = "td_uid_21_5ce62247bb286";
block_td_uid_21_5ce62247bb286.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"43","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_21_5ce62247bb286_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_21_5ce62247bb286.td_column_number = "3";
block_td_uid_21_5ce62247bb286.block_type = "td_block_mega_menu";
block_td_uid_21_5ce62247bb286.post_count = "5";
block_td_uid_21_5ce62247bb286.found_posts = "1867";
block_td_uid_21_5ce62247bb286.header_color = "";
block_td_uid_21_5ce62247bb286.ajax_pagination_infinite_stop = "";
block_td_uid_21_5ce62247bb286.max_num_pages = "374";
tdBlocksArray.push(block_td_uid_21_5ce62247bb286);
</script><div id=td_uid_21_5ce62247bb286 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/22/new-music-beast-coast-snow-in-the-stadium/" rel="bookmark" title="New Music: Beast Coast – Snow In The Stadium"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/tRz-UvveYNzz_jVVketgGnPTm33RYCm5NYCdKYVjSEgb1_GEoYPAi0_EqX9UuEk4cvxx8zbH96Uw2zAzOznilfHxuI1letOW9zFsbXtn2z1GDyiyQYf7QMiT-Dp5O2BPb9lcd4DmHnjUDwKKKQKv56QcR7S8A6LtJtj_H5QTPL0Nr9RGXVRF8l-bwmFX0Lzza51G5m-rcucXluwQ8M3ToKFS6ADMSU3aTpm7vvV81AHvPB09kiLpaWTq1QGj0fsGrpt8FRH5R-skq1-z-AtbDV37EUoI1czl6eiejWVLUyhiAq8cZM6CqgAy3mq4Kp6TdlOgzxP3WsznN7hUgH3gxcxQO9At0mRHzW1o7k9rdnDioLmAmPNI06F6Z6mUe-_qxlUSvsZZSdRg3x569PahKR-0Jc2ohPt_q1Dr1Wa_SOG1Qz8rcCEqMbH8_PuNpE_vgyx22jmGaLOpZVISPtw6gIxlK95Gs37yUj24ywIAJcYCBqR9Gna-7iQeozNnUO8ZG9BJVO3NiW-2UDbE1uN5pECynpN6IwoybN1WZ6LeqwN0iPq5qg6-bMArYQfx_lEj8u4xTrmZomDriKQ6jbrP1Af3ju8gtVKiKu9_2xL8RR65PEUby8Q7qILEAdlMVmlL81QrTMwnsdrTv5zMDkKiqgyD_sV98oQG=s673-no" alt="" title="New Music: Beast Coast – Snow In The Stadium"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/22/new-music-beast-coast-snow-in-the-stadium/" rel="bookmark" title="New Music: Beast Coast – Snow In The Stadium">New Music: Beast Coast – Snow In The Stadium</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_module_no_thumb td_mod_mega_menu">
            <div class="td-module-image">
                                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/22/new-music-sheck-wes-sadio-mane-ynwa/" rel="bookmark" title="New Music: Sheck Wes – Sadio Mane (YNWA)">New Music: Sheck Wes – Sadio Mane (YNWA)</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/22/new-music-denzel-curry-speedboat/" rel="bookmark" title="New Music: Denzel Curry – SPEEDBOAT"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/ZNyQ4dXW9UmRW8o0wrYheQZOgQWR-rtz3m1pkp1NB3snIZN5VnXSGp_qAPWplj0LbnKQ0x3Ouio7gXwRQYNYs--71o_K4E8nkJ771_rqZJVDU132GGlQ-L2e9uxDTsAUIBSSqGk770fXqchGCwb_jrGbFJASonOuJmoDtAa91WReDeqiG8rSnhfZcJ1DtXxMm584tKOf3MKAzKHnbVM68qKZuLfXqOdq6ZRTS0bnIeygwCMmQKTOvbzXdKr3qZBkr9f6YrjPaXDLMmoCz_fxnCyiIj0ae2sjEY2kljTlh95vKdL6RMS9Rdym5E7B5HlqX4hMwcLSFNqA20qRI3oFLW9BKtuPu-MmoQ-TdgY367ngEvCLUf4pZa0Y2QMIBj-egMRZ4GMGrPO6ART987ZYF_EE_pe9kDGJLbPypFhyokVMslHUJCQiPURo7v60V4K0AeVdJ8RDiq1sMe75QGcxTmE4WMTNdQO6GSfygJlO7gT20XgQspqMeSRg29O3fFHYQKVHgYoyenmS7b-A_0CEOEoXXo_xNxyFybdMQ-Yx2kU_zW4fgVlRa4LnCyP2JSOPfHh6nTLUZwR2YRhonEOg5nVo945GveRYFEHOH0AxxG9X_VwchIJCReRyBHGSfvffPQAK3YNk1o5DwFhF0U3L4H_hX-amSWRe=s796-no" alt="" title="New Music: Denzel Curry – SPEEDBOAT"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/22/new-music-denzel-curry-speedboat/" rel="bookmark" title="New Music: Denzel Curry – SPEEDBOAT">New Music: Denzel Curry – SPEEDBOAT</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/22/new-music-xzibit-ft-problem-elevator/" rel="bookmark" title="New Music: Xzibit ft. Problem – Elevator"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/19PQBTS_Jc8tdlt8nIGWP511ZhpzM_aMRr2xsO8xs7N5-vPJ9UkL8HKhEy__kjlBH_2gtoYNPSiCbwndH2mpDyPAcVv1lgU0dAna_VB7pvU805k9ve5WYu_n6vt6gw3tBC7FwlvYrVE6Bbhev--ujYAY1u0I3kVC3hkGWWAhRMtmEs03uVm5x_3XWN9-zAMJlwWLApcbd1NT5DQ6EfAJnmgrUSqYmMwIrVluLKhtxxQE45LasFMhMq5Hsp9pzlUxm9IfcBz3EqvUrQVWZkgVoLiOgkgb7VJhj-aR5kTyRcJnaVqvkUMndd71jQhhSXNxEHtedhLBsZrDnTw0Ck7PJ7KPGgBMNP-1raqXMtUILbx5V3PP3knL30jwlZY2KXrYxE1mhuEcKEus3ic9yUYKGGgkBK7GidHm71yBSM3i10Lhuap0v-we2xiaGHqIeU4gMg1ffKEk6rhQwF5whXn73hGvWLl2xr2OiN_1h1ZLt_Q7vnSBifkGAsZvkfUAqnCHJVSTavjQxuJMyyef6IfXtHWkE56kwN6manlMPJRnLZdbMY57sNUXh8Phk0RS4xP7UdJaFW9mdTBw6F-IjTKJGiTN8O3QBWDpcY62KFVm1Zq12O3pV4lXvPZe8kEHNnFITXTZMKPX-3pRWU6XlOKytcsAJmBRmWVc=s620-no" alt="" title="New Music: Xzibit ft. Problem – Elevator"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/22/new-music-xzibit-ft-problem-elevator/" rel="bookmark" title="New Music: Xzibit ft. Problem – Elevator">New Music: Xzibit ft. Problem – Elevator</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/22/new-music-will-smith-ft-dj-khaled-friend-like-me/" rel="bookmark" title="New Music: Will Smith ft. DJ Khaled &#8211; Friend Like Me"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/S8f_--1COG-W6dXpbWh86GIwt8MevKFQi_7AUxKFPo8KVrwobNlh8xEHPt_qG1PTYvCdco6u7czhmoviH57tzSWkn8qOWtwZRh4D981dughMfqmbAoVC29iKuhfL0iwOUHpfa4yFJP88KpZwfAV-lsl1TjEisjncyJpsF85OzxykOoBeYJjiTZYgcr7EbpLhnvCAfsDKF9DrJLbrUj-tMKkmJsW6nwd2LhTFTGILrZJcyUQn2k_BxP2rP33pH-Re1EK-F4CLdYJRcZAMCkL1U_-udC-anUtJ2nDPWuaGBg0Pu4JoaNed0PSr7XIKavQRYLWwY7DqCkRXj27SW6F_8BQ6ue4aG3px1GeZ5pdRucVu67vw_uU8iy-PYnK-hVXSEUSV-H0qgA-QkpkaOn6HRFJfof9sPt9-VettGvGS9i8rXRADqWqjN8FRqtyNBL8UCS-No1hOi9vabo2o1WcTzLux2r97xPpkUgzo9Q0zT4QNg1tI870u8dzkNbwg3CQbxg7djH4z6qzgCuowNBI7_Ci-QdkGsSwTEdRr_ymsi3GfNOAqu8bUZ0pVXkPpzBll2sHNPeG41qJFPShyfOF9-82fK0Ok3QcZbKNBrLosoxJZirUWvx0ESbniMgYUJakN6oy_cvZyfUsVv-Ge92UsAJ4LfCV64BPT=s500-no" alt="" title="New Music: Will Smith ft. DJ Khaled &#8211; Friend Like Me"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/22/new-music-will-smith-ft-dj-khaled-friend-like-me/" rel="bookmark" title="New Music: Will Smith ft. DJ Khaled &#8211; Friend Like Me">New Music: Will Smith ft. DJ Khaled &#8211; Friend Like Me</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_21_5ce62247bb286" data-td_block_id="td_uid_21_5ce62247bb286"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_21_5ce62247bb286" data-td_block_id="td_uid_21_5ce62247bb286"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_22_5ce62247c1c10_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_22_5ce62247c1c10" ><script>var block_td_uid_22_5ce62247c1c10 = new tdBlock();
block_td_uid_22_5ce62247c1c10.id = "td_uid_22_5ce62247c1c10";
block_td_uid_22_5ce62247c1c10.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"97","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_22_5ce62247c1c10_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_22_5ce62247c1c10.td_column_number = "3";
block_td_uid_22_5ce62247c1c10.block_type = "td_block_mega_menu";
block_td_uid_22_5ce62247c1c10.post_count = "5";
block_td_uid_22_5ce62247c1c10.found_posts = "708";
block_td_uid_22_5ce62247c1c10.header_color = "";
block_td_uid_22_5ce62247c1c10.ajax_pagination_infinite_stop = "";
block_td_uid_22_5ce62247c1c10.max_num_pages = "142";
tdBlocksArray.push(block_td_uid_22_5ce62247c1c10);
</script><div id=td_uid_22_5ce62247c1c10 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/21/album-stream-montana-of-300-views-from-the-generals-helmet/" rel="bookmark" title="Album Stream: Montana Of 300 – Views From The General’s Helmet"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/Em9cV3rqfJRhyVRfFJ5B0BVModstpiN61Frd4slCF3cUQqVtfG1WoiiHWBCc4-kyvhvsL9i-KtC2a0FZwCpzqeOmV9zfZWr5NuEKfZ7t4ate88f9eU6TF5lbFjJDBCNwH7BMOzu40A05tjmzXT76H0FOn3S-ZjbHOA4SEtnc7AgqqkCR_YjHFbBRlOH5kAyFsUqeP-K-CVRuFJDZdQNhhDCZDNz2R_4qZY-egNmYMN1y32Ktl06i8TQnDX3W-dTh3jjgD3vVtaYp5GTJRNFti5vndGWbadv-Zke1mbbHUmB1ZQTNEryFui9nDvcsLqsjVuxDFXVLfjfITTzuAGO_KtceDHjcdYcXj-amVg3swSKPsvtRO9v44PfiGtl2z00-sSNmUfFZRmhMMHbuqqlD6XdL8K0sD387fbnIpDmLDLEuDy8bTYs6ziRYIXLtj9EwrhlOCpyNrq5o8TjZA_axzlR_K-4NSzJsbnUsiB01Ub1c25H7k86KSbJVi-eGEB7cP-jZQXpuEmMDsj3MpLkpTChzAlEyFGqgVAhg8rwyYSvSgMqVveybe4EmUViQWUndT4EkjR9F0MlErb5QPlUjx5Bz15oqw8GQH5k-YYqWl66yZvhHH5sYsEkzetZ7wDLv7rWmFyJIGeuVRYNPsL2lK9RdSPm_WK5Y=s620-no" alt="" title="Album Stream: Montana Of 300 – Views From The General’s Helmet"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/21/album-stream-montana-of-300-views-from-the-generals-helmet/" rel="bookmark" title="Album Stream: Montana Of 300 – Views From The General’s Helmet">Album Stream: Montana Of 300 – Views From The General’s Helmet</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/19/album-stream-curreny-statik-selektah-gran-turismo/" rel="bookmark" title="Album Stream: Curren$y &#038; Statik Selektah – Gran Turismo"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/5-rMxFeNLY78OFh8WeG_v_7YhVvDyxpgkz-rYZoGbKLU2dP2jBgOT7qFeN10N4Rw_-WD-AlijeHorA0gMrueMeD3S9T6fT0zgiRJKPVcXlzmWeEI5Fl5KLulq0CCeCNViMuWXLr39Xd3dlAo_y1wJ7ZycROJIRRABmfH-8evBSLq1YOyCw7t3CCdG0XN2WTw2zxLof8D6l7dP_4V5a3JgGO6rSRD68Wzbafu2CkQh_Z75ftPz_u7gteDp_QoaDLqzBE7dvwbskyJCho_jPSiYA--P0i5FR5xImSedpI2B_mWvDpsEGnyicY21gkBole7efAXRuhphMwCJYmS3d2sN8SmAUW7_ZWUa0aNYFy_63cRlOjBqDq8WHJfhEciI1EaPabngwHng0vwyIJ9nCx-7S5Z_OmdSWmXcruCZT58-yyPJD4UYK172VtTViFa4NteadlB6Vp9lKrfVUEhg8l4Q8WJEXuQFWUrnVRF_u3WrXelq_XdokURqCyH3IM6RzhL4lKDL3EjEMRLIo4RQD6qO-HWlS4cEX_-Q1Zr3s9dxit9AmT-rKwWlJnT_lrpRemiE8I95_rbmKSonqzj3z0ERUEJaTK8t8yLaSyqmk_cA9Plc9N_-4rfgYqV0OuuxaFIDAH33EHhAyMTnihahKdsyrH4po-Umqw_=s756-no" alt="" title="Album Stream: Curren$y &#038; Statik Selektah – Gran Turismo"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/19/album-stream-curreny-statik-selektah-gran-turismo/" rel="bookmark" title="Album Stream: Curren$y &#038; Statik Selektah – Gran Turismo">Album Stream: Curren$y &#038; Statik Selektah – Gran Turismo</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/19/album-stream-injury-reserve-injury-reserve/" rel="bookmark" title="Album Stream: Injury Reserve – Injury Reserve"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/FtXoW1NsjTEXSRdiQleaoG7sg9sMaPdccmBFsPRvbbJJNtmYP9_zgYj9UtEN6GIW4tkp1B7Hoeg=s328-no" alt="" title="Album Stream: Injury Reserve – Injury Reserve"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/19/album-stream-injury-reserve-injury-reserve/" rel="bookmark" title="Album Stream: Injury Reserve – Injury Reserve">Album Stream: Injury Reserve – Injury Reserve</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/19/ep-stream-sheek-louch-beast-mode-vol-3/" rel="bookmark" title="EP Stream: Sheek Louch – Beast Mode, Vol. 3"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/i_t-88L8zeu1AoC46Ai5Hq5Wy3XbJVhYKfievza4j3AnsoDDcbw2wkicqLO0PjLFzUrJsVESb5bSCT1_DamQlOd6bnp1oiQqcDpgCn1Fbj8iUwqiucjK5YP8qViZzjOqRDz_0cn4z8fWJd8xGy4FXkf2irDSJEyAWu9diyarnt2kWt0UHVslhiU34i4Qr8sCMEkh52oN16t314QdUlY6bHlymW6ZdcaC3KZZ5BOy4PtOezfoq3h-xL0TZCHVrNCVAf5rsvoo1yYp7G4_sjYN9Jt2WQ0sL_a300DMqi6QoC1n5EIYQU_OgPvXvm5j75bc-bkyW6_nl2jRWy0M_P4DPoprHWTcmd9Wpuw3YmMD_YFrN9GquW3hx1jrE6NiuOzgismvEoFof_le8aamvWu-eoHImp5LxKLST2itAAvydLJfCB8hj9t5gvYMHehSkjmupO7DHXK0HnwhTuWoK8tcp8qqWw1a1tCX6EX2e3RFdepZ-yY7p7sqnqWhdkmOd96qqQnzllzIWV2LLbjCLbL20VGWJqW68ppOcHIkCBTbakgo6B5zwjSucJmn_XnpatfplW1A63ndUUw-Wf19jb_qeLCOy8YjZnsC5-sS2svP3-qy9sk4--YTv9MPO504-dqEtjvUDhx02Rtz1DTkJcCogECpYfb1i9hm=s796-no" alt="" title="EP Stream: Sheek Louch – Beast Mode, Vol. 3"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/19/ep-stream-sheek-louch-beast-mode-vol-3/" rel="bookmark" title="EP Stream: Sheek Louch – Beast Mode, Vol. 3">EP Stream: Sheek Louch – Beast Mode, Vol. 3</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/19/mixtape-jaydayoungan-endless-pain/" rel="bookmark" title="Mixtape: JayDaYoungan – Endless Pain"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/FqpdTQ6Ik_ubDL-p7LHDAkcZUmj04boMtUDyMkzy6Qf1onI05ZNsnYqDplfT7hkPBt2i8wQcOn4U1JVjjVvQPj7o5l8-w5eBbtsFlza6k7jjtudoORO3VFfoncmAXabtQ16U38_eDB8BcDyzv0LP5mqAT_1KevdfsH0famdRXvSMcWTwm8LBeTUG_uFrIRnogw_rRbR6te_An_RYY5ElyL0eVp1tDO1b5i3UqzAQgnLzAJUmcRf5rdFNecAFNLeozsezxOp7XKVBGs_QcVKlOEsRN42wWj7AYxBqvTQa2iVF_YEqk3tdT2v98zXHh8yPfxzvRWmN_Mfpaeq7jYEBTZhCk3FqkaRSaDxwvgiclrNVcre8JXSJjmJdpAu7b7Um-A9Pl1UC_n0n-7Y-70pZt6ba24dxVDoR6HYf0EWT7aG0mzbrAs9brBHaVF29bAHGKR08KiYSX1-hWt1p8J-yDL683Z8Zbs7nY46y3sfxKsax7k_Y7jJU9OhOMok_A2TEe6BzrH7VCLAK03ipuVhP2Gu-mdbtUo44Dn96stF2EjnhNAwNTguyW-GRHzsT_WSYrJNZvYg7Fvch-gdHXny1-cX9dufXNoPEc2-yXvHdvfg2ZrdQ-PP0rWlNLiN7Y64xd8CjL5Cck6o5OK6T1CUqRo3LLbxmbKlL=s796-no" alt="" title="Mixtape: JayDaYoungan – Endless Pain"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/19/mixtape-jaydayoungan-endless-pain/" rel="bookmark" title="Mixtape: JayDaYoungan – Endless Pain">Mixtape: JayDaYoungan – Endless Pain</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_22_5ce62247c1c10" data-td_block_id="td_uid_22_5ce62247c1c10"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_22_5ce62247c1c10" data-td_block_id="td_uid_22_5ce62247c1c10"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_23_5ce62247c7d2d_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_23_5ce62247c7d2d" ><script>var block_td_uid_23_5ce62247c7d2d = new tdBlock();
block_td_uid_23_5ce62247c7d2d.id = "td_uid_23_5ce62247c7d2d";
block_td_uid_23_5ce62247c7d2d.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_23_5ce62247c7d2d_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_23_5ce62247c7d2d.td_column_number = "3";
block_td_uid_23_5ce62247c7d2d.block_type = "td_block_mega_menu";
block_td_uid_23_5ce62247c7d2d.post_count = "5";
block_td_uid_23_5ce62247c7d2d.found_posts = "1863";
block_td_uid_23_5ce62247c7d2d.header_color = "";
block_td_uid_23_5ce62247c7d2d.ajax_pagination_infinite_stop = "";
block_td_uid_23_5ce62247c7d2d.max_num_pages = "373";
tdBlocksArray.push(block_td_uid_23_5ce62247c7d2d);
</script><div id=td_uid_23_5ce62247c7d2d class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/22/music-video-diplo-ft-octavian-new-shapes/" rel="bookmark" title="Music Video: Diplo ft. Octavian – New Shapes"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/EHFKDTrxgrWLYANBBN8xsnYjBjHUQAJQItEkutjwV5tFz58wurUjFnwlHuywNIp0K1CrBlu7DPbGl1HGnYDWKjN7JcertJ152GsJzRgENXBENSYeqXMkyiDLqUlMIe37VAf-KVw34kW6sMrl11Q9PXuiKi68bg6-tU4w7ABOJihyXSHt7CxFYlbx2TcLIjpdoliVPZBrDr22T2oll9mHehdBGu3fs1oejWtJOCWVSZRBNBgmlW2zxQYzKwN-lJCCLAcY_0-1m_99Y-S_dna1aVelD2QSzSuftEoT1OkQ9DBcUZbgkd5EKOBpVW1tCefMhlnOvvCc39-JG2rsMg6-5r4SCQXXbQ_2Dl0tS9AjfI8VqnJbQKEe_40z7upMhigyvFBFk6ijitiuLvyL5zgp8A9zwQmb9dS1o6cx7icKHj8_Z6alhNTkNNhDm1jUKSCLacn165SxofOql21NBPys0TFYB100v-3SoV3Whm6DHprfGuErbShL8UjsHiE0fCaoKABW9F-iniTlrU12i6rTXPn76FozTPeTK61Wb0pa3ewIdglLR2GXdS2HVL7oQzc7pdicw8xk8NOef6zwTXHrAjUE1BvRogpRnVP2QA49H6OSrWW7NSx8VERbmT-UpFOQ4pWzqMg8EEX8rCcmYlI9uNyBzXcoHoVP=w683-h477-no" alt="" title="Music Video: Diplo ft. Octavian – New Shapes"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/22/music-video-diplo-ft-octavian-new-shapes/" rel="bookmark" title="Music Video: Diplo ft. Octavian – New Shapes">Music Video: Diplo ft. Octavian – New Shapes</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/22/music-video-jacquees-live-ya-life/" rel="bookmark" title="Music Video: Jacquees – Live Ya Life"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/rWC0S931aqosKSfsohyv5nWANeAW51NJHaUfTbhFKpZd-sgH4lQtTBweVwzXB324MH5lNQHp3C70LU0rPqFb1xk9j2CRJOAoVasgaDeMfGU_0V4qwjSZ7hWhp3lWuXw4OlrjVxEG_3I_7k000YPre5SbyudfHaejVfTdU3psL5hDHdd9y94WPGbrK1v_rZaTgUiBrGBjEg6SWO-uCbh8xgGsEY_oDDNm35Z8mv4zn4iwoQsUAifCvzrpA9VUZF06Bt7PqrvP_MMJ_FFfdYqmcZSNSwXcmFCxbTzhyzgl9eQJG5xE_coSr-M9e1EXXqrRP_NiG3jCW1qaRmQvjNCPntm8fK3FkKzl19hlEWMAV91glUHqII_Egs6gnv88LB2T2G3QR0hu0KjJiWWLX9A8mpyZ3GkG-nHyqjwGavLK64jwvzv61qBGjHg3Xj509Q9OX2vTKWpJYapnFgnWY4pMKY1RQFgmISIhADhA3JAV_7OJBMwsUsDrEgL5u9YMje1os1dCkce0MoHWKa8cFOQyG-DfB2YEL2kqUKPrvqkeHn42A0LdibgG9t9DBHqYVzBTz7rjxiwC9Nwo9t1VowlkVHuIxsczZzFoyp_eBZiLxIQ2uoQ3KmGUDFKc4UtZmGch1gJLt1mhT-iDHBO9HMM6Pw5_DxssGaWB=w747-h486-no" alt="" title="Music Video: Jacquees – Live Ya Life"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/22/music-video-jacquees-live-ya-life/" rel="bookmark" title="Music Video: Jacquees – Live Ya Life">Music Video: Jacquees – Live Ya Life</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/22/music-video-lil-donald-ft-ludacris-say-it-twice-remix/" rel="bookmark" title="Music Video: Lil Donald ft. Ludacris – Say It Twice (Remix)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/8SKvOgDhY9kyyq-j9xPKj6MEKij-dzP5luVIT_e5Gbu2udWVlt0ndWGwvClsTNrKX1WOH4yxRMoYwicYlQ58DNAjDieHIjkVR9QSpce-XWb36BjlVuUnDX3NUPc2ltv0LoBT_H130nLpbl3y-skpx7cxrgUUFemvKMX7nmok-7qiTTIdtspOqSxJmDCkoq2VBprT-HPHdHQVpAyBRGhZPaZE36l55oYbp7x2NZSlc__BGV_mspEwgbmwDDontk6vfuzAXyRhG0bPF6CYECb6fLJvO8tna7KwX0BiNdfYv-mneQrfL_2QmvwOBcOtnhwfB3zVR17o-9aqsZZFbnFa1DhxtlQ9iZ4JLRwvZT6oXVkPP4FzAh6Jpkaumg4EseguFA-H8_VggReq1dI2YItDe9lZgAUQFy3oeMFpXd2a832cHSzG7B_0UkTtfKT56bQQD_lAn7J6cVLthB0BF16jvsVo3RsZ5VG6YSd0N1mXteGhSEkU4NlTnRzhGs70wUobOS1uItaoUw4JlHQ1jD0OW3PP1pwhX-SbLpqs6gMmGuc8sK8fLL-S10Fc63Baty4lYRRsj22DlFA_RtL7o4unfLa_URi41SR9Ev3ez4vBzPeOieUHkgKtOX_pNlUqzEzfYR57phvz3SYmEKC7pliaMhaeOWc6mWwb=w883-h386-no" alt="" title="Music Video: Lil Donald ft. Ludacris – Say It Twice (Remix)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/22/music-video-lil-donald-ft-ludacris-say-it-twice-remix/" rel="bookmark" title="Music Video: Lil Donald ft. Ludacris – Say It Twice (Remix)">Music Video: Lil Donald ft. Ludacris – Say It Twice (Remix)</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/22/music-video-blocboy-jb-ric-flair/" rel="bookmark" title="Music Video: BlocBoy JB – Ric Flair"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/tkQK_opVxawO1Ngk6uuU_8fDLXCArqLvIXX5n9RbCJ1wZ7NMfvmC9w8j7czJXZfxojJF3dyH7GVNI-keWN7z-uEPYmBsP4ysgT_u2WVmSvHRkBq7nrimdEOtXBD9bTduSJhOB6DS4Ut-vAyNJy_L62Vfkw8Ou7JWQrL8qzLbJcGiN3Y2uAyuJGdYlOMyVJ-nyQyRIXTX26Cf0bDeuzgSeTCVEF1pVdN27cOWj8JimZ3KXYuK76yBRdDr7tbJmMtpJ6rvvpI2rvo2xOBw8AVmH7OmWoHhYWs6_94jXzM7zzAf6kt1tkSF9zpePUznKB64ykVpqQZ-tfWLi5IFMA-jf_p13gaUR8CdrC-uHTpEvLwVSnYbS_J4uQM2SYlgX9OSAEwiRe18Jpr7tOuhAuVymQxDEVlUfDbw1z5a4WOda_fVQq2qn0XKfNZbcWxDZaZ3noWDWLD9880svDsuSYL27wFvRC040z7qXAmkJKvxRli_1BpZwCSGxv5gwqxHCG7ln5yH2UCRqTth2wTx_-IZqf2Yq78FrtkysZIAm5HjdlBtlpeAZB6Fi4wP9TPGiwiYjCAlQR5bMmVzM2DAWZTVDt4umYYk1IH_H-aMvFZk4riuu4RpnZkrKzvrb5vQMEvZ9Z3dKSCcTCb5I2F-yV-v9xcB8YfgjBE1=w714-h468-no" alt="" title="Music Video: BlocBoy JB – Ric Flair"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/22/music-video-blocboy-jb-ric-flair/" rel="bookmark" title="Music Video: BlocBoy JB – Ric Flair">Music Video: BlocBoy JB – Ric Flair</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/22/music-video-philthy-rich-passing-the-torch/" rel="bookmark" title="Music Video: Philthy Rich – Passing The Torch"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/vOlxPmo1BPNuz9nza-jYwMOr3AboYRyRBBYMXPWjgR2WE7Yh0rgAjkCa6lNXDN8zd932W609vXqHT98QcVzLIf2rIUKjnyJ_ysIHKgmtwlPLl_b8ldujqkwUsr1pLcd_iwi_MLFZgMB7fLf4re0TFLEMjxCB-EEmhJA9WPhX7tm1yIlSsj0Xwd2NihFXAZASPAiK6Fwar5rT26nxyasqW9Oqg6_GGxqIg2Zjn5l5SpeC1eypFJb8i3pU-amVKgd4qR174rs_8pi3M8hdLnnSELhBQYPVugpNv8Yb55IbU9X4mVHENKcqBzLgMsOgxtB3_VH-HnEvQ7sl5if2-0f5twSkhVzR0zNNeK3Y-dxI5K9H6r0rd4b41Lqa6JDJxyXd8AOo2PRrnzJOI7njtOWLHdGBC1Zr-c0EXN9T89uyWYeTLZ5dTJWanr1kPbMmrEP3TyB5IxpKKeUku-R2IZG32kRN_AccEnexDdyvCeiWs2XA6y7Fify-N3ZIXXqKVyYIXChYw_8IY4tGZ11rqJKrRPaB1T5uRpDceWffwjrhKkUMh-lwjwJ_BO39LZyFcloXPWYvUYeX1uIbzDk88GtWQt9yGLnu6XZ7Uwp3kukbSjGOaLuZCBhfzeaSZtpprbi3IMyJ7S_isoEhwdmGDEcfr0nmsW_z_Xio=w706-h452-no" alt="" title="Music Video: Philthy Rich – Passing The Torch"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/22/music-video-philthy-rich-passing-the-torch/" rel="bookmark" title="Music Video: Philthy Rich – Passing The Torch">Music Video: Philthy Rich – Passing The Torch</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_23_5ce62247c7d2d" data-td_block_id="td_uid_23_5ce62247c7d2d"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_23_5ce62247c7d2d" data-td_block_id="td_uid_23_5ce62247c7d2d"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_24_5ce62247cdce3_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_24_5ce62247cdce3" ><script>var block_td_uid_24_5ce62247cdce3 = new tdBlock();
block_td_uid_24_5ce62247cdce3.id = "td_uid_24_5ce62247cdce3";
block_td_uid_24_5ce62247cdce3.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"29","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_24_5ce62247cdce3_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_24_5ce62247cdce3.td_column_number = "3";
block_td_uid_24_5ce62247cdce3.block_type = "td_block_mega_menu";
block_td_uid_24_5ce62247cdce3.post_count = "4";
block_td_uid_24_5ce62247cdce3.found_posts = "682";
block_td_uid_24_5ce62247cdce3.header_color = "";
block_td_uid_24_5ce62247cdce3.ajax_pagination_infinite_stop = "";
block_td_uid_24_5ce62247cdce3.max_num_pages = "171";
tdBlocksArray.push(block_td_uid_24_5ce62247cdce3);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_24_5ce62247cdce3" id="td_uid_25_5ce62247ceab5" data-td_block_id="td_uid_24_5ce62247cdce3" data-td_filter_value="" href="http://weuponithiphop.info/category/latest-news/">All</a><a class="mega-menu-sub-cat-td_uid_24_5ce62247cdce3"  id="td_uid_26_5ce62247cec21" data-td_block_id="td_uid_24_5ce62247cdce3" data-td_filter_value="69" href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a><a class="mega-menu-sub-cat-td_uid_24_5ce62247cdce3"  id="td_uid_27_5ce62247ced82" data-td_block_id="td_uid_24_5ce62247cdce3" data-td_filter_value="80" href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a><a class="mega-menu-sub-cat-td_uid_24_5ce62247cdce3"  id="td_uid_28_5ce62247ceef8" data-td_block_id="td_uid_24_5ce62247cdce3" data-td_filter_value="2189" href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a><a class="mega-menu-sub-cat-td_uid_24_5ce62247cdce3"  id="td_uid_29_5ce62247cf09b" data-td_block_id="td_uid_24_5ce62247cdce3" data-td_filter_value="10" href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a><a class="mega-menu-sub-cat-td_uid_24_5ce62247cdce3"  id="td_uid_30_5ce62247cf1bb" data-td_block_id="td_uid_24_5ce62247cdce3" data-td_filter_value="130" href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></div></div><div id=td_uid_24_5ce62247cdce3 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/21/dj-mustard-perfect-ten-album-artwork-release-date/" rel="bookmark" title="DJ Mustard &#8211; Perfect Ten (Album Artwork &#038; Release Date)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/ESNFv7ux7rjrC3JJj1qOCD6nEujjLoWYyresPmpHNuSc9IZ_P7RRnu_2coEptjUzN_NdIJGOn9KymQDLNnMf1WsBj1qRWjpE8sS2APj2GJav-XyXCaAlzIAJ8ewCSAEbjntmF1qvV_eErxsr_CNAPk0DdeeLny6OVRZz4EpBa6d9NtdwInXRdqKQlzUI_6TtxeZkr4-0yfaAhP8Vla9cCVBHD7HW-hjNOk1bA7706Y-WYbSo0ZlE9_Oy-pBcfWiDIAml8UpjfSdzfqxTb9JD2paT5MY82-PL4HKfAV1xD1VW7j58_oAi0eldxcGg1G8GOGMA1JpUJkfOjJgCQelmsmLnRD2sXnLkW5E8hgO_76L_C5VniPcz3TAPlW7dIZCscSoj6GY9vr_VG9W6P53R-PkWoPxi7erwlMUkHasFtPdvNS1QtzEnjjE0AddHFKa8MU-liMw2aZpLZJPnRk9eijQA0FoQjSmcyDcOKid_UB7MYNi_HkPJxDxveq0ifmQWRK0NS4eyl2HnTxPx6yYiH0pFdLqNOahzKJFvv36vPvQKjJbOcwMWKn9eEbvjVvP3Ip7iu-wY36AYaBbcRsmKzEV8uasGetPkZnaFy1rGT4X-JmzAJYf3Az5fnpiaTkvwyxH8PvbDPSym5JWu72rc1wOvt2TB77rK=w680-h672-no" alt="" title="DJ Mustard &#8211; Perfect Ten (Album Artwork &#038; Release Date)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/21/dj-mustard-perfect-ten-album-artwork-release-date/" rel="bookmark" title="DJ Mustard &#8211; Perfect Ten (Album Artwork &#038; Release Date)">DJ Mustard &#8211; Perfect Ten (Album Artwork &#038; Release Date)</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/20/video-ice-cube-big3-season-3-theme-song/" rel="bookmark" title="Video: Ice Cube &#8211; BIG3 Season 3 Theme Song"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/JDkTQcLdP_l1iOGkXJOHXZp2JOvtzgYR6MwsYnUCTzqI77Dl7HYteHplJEBq1M5CSEhgxEH6MGoMEaedVeEK2FzQ2I4Rz1qOUXPadQzkdHSdYCdZnkyqxMf8w3vYBumh645WgfKl6zoC15K73k62NCsgJAuzIQTCaSc7YBKqXI8tcrpcoP-2-c6fdP7yB9e_JNrJiGrK8pScRGzxCkaMgx0EDjc4ArSUwVEEOJMigJuBhY9KhXUPuJd_PqiTXaACJYFWg9Auz-xSmU2h_TjTIkViE2LHm0pI-dL529DfTFCrsVIrs0lwBZ9QwFud6YatqItxB9EWNDTMYeyR2_HJ-zow-8rAP4d0enLL8TXbIpyMeK5VJpz_to7Csmtyvf68bF5_uN39H7jupQOmHzTbFzVJ2XKyq-MaT0mb8o0jMi5kBL5MTiVr3T3985vI9wgtjkCFwx-EtD8QymEzAUHBXeN_fd5P3-yAl8jFW5k9R40jst-4wlvYRa1guq13bhO3IX3Sy5uiOJ-oiiMCXvCryGGkXEfVEZGLlVec9vS6hK9eqo_vI7aWgFR8q22torH8zel11Y1b6ljvBAvbQ_kYuE1MzJ0UeKq4qRmoGJTV3TBfSZbxdqWZcXxy9giE1Z-KdmCAO1-XLAXtqXUwwZoZvTJf3oJiORa2=w899-h608-no" alt="" title="Video: Ice Cube &#8211; BIG3 Season 3 Theme Song"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/20/video-ice-cube-big3-season-3-theme-song/" rel="bookmark" title="Video: Ice Cube &#8211; BIG3 Season 3 Theme Song">Video: Ice Cube &#8211; BIG3 Season 3 Theme Song</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/20/rihanna-confirms-new-album-more-with-t-magazine/" rel="bookmark" title="Rihanna Confirms New Album &#038; More With T Magazine"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/PUGHhtYdlY7YB7OMobfuvC2tDPiVeKXFvdENHq7Gy0iV4o2BOUEbmjDwa8mSf4_FR1upjLwM8pjP3fUsTd9L7hnwiiKZB8pvyKFgUgFIkajmqU7knWTaUltGRLJS2sOu5XgI88xi64HlwDatPl5HHdR-HV-0Y93JSBrrgpVPSf_HjVxWQYjq9Q-FOUwESW-WVhm05xdGiwQ0zndyCijkco1usSQwqgsJGbHTSKDx81TQIrPTovgPpRnb9iNr8i2RqJlZ81P6tq2MGu1flbe_ytOLWvz_JpgGRvAn40NhkyK5Kvy8ZGOX3EicMJ1-UEaioei5SN9SYYBMZSiaRUSVc__JO4cIxnPtBvEUJJ-VcTFQP6UJz-gnIS4TvUDTr6G2dDiJp5V-RgBBHaZEh-HmSlSeGyVHyaYX9ninlDSgzjlEmiHjg75w1XG6GWRts7zKZbvfX9nke2smWDvUtWgZkw6y40LqCVhYKMk21bHU_vYtNxtq6wgP2u9XhO0b-B0aOe3gDqTuKgrQO2GwUKgkRmgZf8H_PDoXvuj7_GJGSIUM3OSWDbYdvXYkMykS8bb3kjGhn-oRykOjnAdTD6NeUJGET-apUCkkE4afPQPQjLnXR4bWDPXarDo4Ym2DB0AYjX5mSGtZc70wD1dZVZdqFjuZQ4pzJomH=w372-h234-no" alt="" title="Rihanna Confirms New Album &#038; More With T Magazine"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/20/rihanna-confirms-new-album-more-with-t-magazine/" rel="bookmark" title="Rihanna Confirms New Album &#038; More With T Magazine">Rihanna Confirms New Album &#038; More With T Magazine</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/18/video-nardwuar-vs-n-o-r-e/" rel="bookmark" title="Video: Nardwuar vs. N.O.R.E."><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/iJoAgUjyrinmrF5mlz8s3B7xWg0JOihdnj9v4bFqT-Q8L47B915Yu0Stk2p-MWYx06fNFgf7IgJH9OlDxrySKl_IG7pvPcLKOyuv1v6dKoGOkkWUX1UDq_Qq0RBqKJu6moUKQ73V4B-INIeiyBqFOmwu9BOmfcnjl8psDYe-nN45pVhooT9qqvunRYaciKyjUmZNB7-cQxgYKb6OMAHApRq9638Z-H8jxVh0JHcExd1rBkiuSVpoJ2k7Wg9oKtDbgKxonTxLLjP15IiJtP68VTxrGvXe5eJFqNBeOd_oXXuw9UplaRg5YC7z3nuu_AlTufSJvKaUZoABz2eDsn1cR4eVt-ZmaqWidHwDQRBSx4nxpgQcWqNcTiX5JdRC3MOhc8NuliyJsbw76T288omySx31mZnZ2lrq9RO3Ahh3os8zdorTu3qH_a-W-Q0aHNvx587Ic739mdPTZgYR8hWmVDopK2EJENQboBJfpq96ID23ig0MKRWh6zE68J-M4gI4UWNydberNqntSkN2SEbm9efoAls-gNuffcnTPlBLGeSiq8lj8z95wRQSnbhGPCwNCrTUhzdt2bMadtIpmMr_iStFHdUnz635ryGfGicCI5mTe0P9lJUU6n3OUtF5LE97lo_LawQQVf-xrR1gRMP_2dXX-amrCFlm=w630-h378-no" alt="" title="Video: Nardwuar vs. N.O.R.E."/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/18/video-nardwuar-vs-n-o-r-e/" rel="bookmark" title="Video: Nardwuar vs. N.O.R.E.">Video: Nardwuar vs. N.O.R.E.</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_24_5ce62247cdce3" data-td_block_id="td_uid_24_5ce62247cdce3"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_24_5ce62247cdce3" data-td_block_id="td_uid_24_5ce62247cdce3"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_31_5ce6224803cca_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_31_5ce6224803cca" ><script>var block_td_uid_31_5ce6224803cca = new tdBlock();
block_td_uid_31_5ce6224803cca.id = "td_uid_31_5ce6224803cca";
block_td_uid_31_5ce6224803cca.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"77","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_31_5ce6224803cca_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_31_5ce6224803cca.td_column_number = "3";
block_td_uid_31_5ce6224803cca.block_type = "td_block_mega_menu";
block_td_uid_31_5ce6224803cca.post_count = "4";
block_td_uid_31_5ce6224803cca.found_posts = "158";
block_td_uid_31_5ce6224803cca.header_color = "";
block_td_uid_31_5ce6224803cca.ajax_pagination_infinite_stop = "";
block_td_uid_31_5ce6224803cca.max_num_pages = "40";
tdBlocksArray.push(block_td_uid_31_5ce6224803cca);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_31_5ce6224803cca" id="td_uid_32_5ce622480501b" data-td_block_id="td_uid_31_5ce6224803cca" data-td_filter_value="" href="http://weuponithiphop.info/category/fashion/">All</a><a class="mega-menu-sub-cat-td_uid_31_5ce6224803cca"  id="td_uid_33_5ce62248051ad" data-td_block_id="td_uid_31_5ce6224803cca" data-td_filter_value="76" href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></div></div><div id=td_uid_31_5ce6224803cca class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/LVT4Mid8WL4wHUdO9X2OZmZxxgbREs2lVtszOdEBaO6hJB0JS3yQOAyhNSdCyPmv0amBDTgNGpOlRPXPjKCl6yIlo2joyH3rQRI7CUdX09BJtQI1r5jy1_7BQtDhw4AxUhpUwIh35rNS3lTy7uq-FdPff10JN6srr9mwZ7zr04GQFxBVEXwCfC5rNVehXhY_wGCRVsmevYmdkBWEmB8dvOzBHY78NBBjcHNArS_S-2M0FJgDh8v9m9vEh78k_XmZg-AERctsf0bkODuPi1EcNJq_RnJIV6b0GG-VtKjo-OVPmYghWJYf1HiP9c58cQ98oABU8BDFdLqsBtNt4K0NmyHYQlX39W9k_d83wEHZ1-EacQa2o01VrYSn12HnZ1l88fMzu9PKv6EGmcRZNwpepycW7_9EQnhxIPDdVCmRLXUasUED9OXr-zJmnBcnSnLCa06k1ZymQym1LiSFEv1c3aPHnmnD3GY8nL7q5jPJr4HsABR0WCqMebcF3HF_0deNd0zgRBCGMxW-VzlIIHZiHuBeSPEPvUL149GJ5swSSvKm1uGEi1HlLBj9omJSU7mDWzO0p_7l-l7-4_ureEsGsgB8cX1t8t2TQcFeRgqqF1CXlZFYYC2K0iMb4jPsijsw_rtO7pmKvbngqHfgYpGeh_qLmDWeicR7=w1195-h796-no" alt="" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch">Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/fHEwwMf8DoiXlqkfibQS1Z1XXbviORbV9raaI44tOTXrWo7GgqM3gA-vswE10gFtTQUGGwNG7nWAACwHjxPuiubliYBN_dqtBZh2WIpxvumiJ-hSLK0TNWB2cB8Iw2STT5gcp_KqlDh_e4xng1vidI8EXdp_ooh5uDI-JV1HQ9dGnM5nxl_b-v8znqj-Rl_mGB7y4Lu9zsFNWHU7SriqQQJaKrKEEnb9T8zxmGLaL0zq7ilYpnUEhWulDDr9xc82wdr__WzRBm5YEskVpDAnGM2NDZwTZpjbe4QDdxeixWnSXNK_oDzaL7WTbCpkD33OK88BlI5JmFRQ5VmD11UQ2htB7-9WoahHvb4XmBsbLXpEMl1JmEP4sPx06VduzFnBNo-J90WI0n1AEIIcEYVbRywrkGJXbzmH__In9ZIg0EV24OcGGbeKl12HxTdZwucqsNnuZeNjiMHISQ7i8cfzm3N7X7Zenl74zsKIKeKWoIGxh6MTlVADvgHcrHebnjcSgil2vBeFyz_AP45aOv9SOwbzfVLGS0CNfe1s9b2J7qZgjcBk9QPEXCl2kygvzmGXFvU_3xBuW6S0i3Vkh3Ha_3hPBtvIAy3WoTK2yiqS41HzSK7yk3FRAlBtpIEib338fdkTiosBxtdu36SdNUVM75zl6CVIFhTu=w681-h470-no" alt="" title="Air Jordan 14 Rip Hamilton"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton">Air Jordan 14 Rip Hamilton</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/kUjaOYxjEkAh34S-Ub2QSZwdOwHyFnGFLBZULta3_bn1_myPMAwJXiEEsAAtc1ktCQwHCuKhSqSYsWXFBEIZxdfKuykoDEZWwO-dDI3_JeAshbYvyILEHUu0XaUpRn0mj7gOx10V52t8gRGYPCW7QXGImkPGGhvBPzBDVVqh9lKGtkuPeePmTnpRSmwp0LG1WHcIzUWnMqPBWQeHAat6Q-Tq7niXNb96ddEZsMEdHK1nmHVlNaeqFBNtTxk6yYRkFNCvtfBayqy-Rqt4CPU5tThxbTI4AIUCI6JLxJd_VJizrVNDEe2xZ_tiQdkC5ASIoHpX8sfvAB8zRUsMVJ6oMUt5FH_4GBNXDCtFRmr65Qt0JV1h4bBJffu2L272Q_vpD76wn-YNGW8VCtZcheHu_X-A4gdYQEC0HN0BenY-MOuUBqKEjXAc0SxWeP7W9RN55jlqUFK0nzEYydVjec2stdQIngVfg_FvKxvHXfM4XdtMpqeJnp3Pzyk8xjz30sAZd0f2HQ6zfdPjk-OkV2-WrC0_qW0L8Rq3zrUbq52n3BN7gm7sctU_CUlBmoQIgJDQBYk1Siv4tfSq9pL1R4GdaOlWQdxEuhZi8bTYC8GGAgNGl3SMAZGvk7nu6QnnwEZjZ7mZwbcqgyRKa89cOREMUvIkVJ8Q8lZu=w926-h672-no" alt="" title="Jordan Proto React Triple White"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White">Jordan Proto React Triple White</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4cDUjSODZSaXWfHyZKb9q3Fn7FHA4uB0KSBs0MtFHC0dc6AJb1zeAl_X2LOKalK9C7VBFhTqRQ9fw1ESgUr9ZUKFbOzD94i_s96nvkICOqrsYnzrE2nEAQHoEaGOF4O8GAI6T4CGFbgcQhNzjpRlSY60NyPu5Cmq81FRpEOFRzTOtSa_NnWzMmfwO0yxtPbcg5U6YBUsus8shv3SA7CjULLfaP38nZAuWVgq8PMaaeCQ_eSrK8NJSEVQjyyxmqb-1I7zO8Kvvzvwi--ibMr52CF8h-GusBzSq5ZuzvZRCGu_u8CyfoXw7pwWbOmHnLOdcQ9d2PCSW_IxEMGfmEuU7NxMSsW3Ga4r35_wLB7cjvlPC9OjCV50tfekXjZBS_476mzlf4G9jR7Ju1GqgjXah9Uqc_0Y8N-Br8_JCtIlRSuLxAiebwd7AvFVlgWId9MYxBWnRT3cTyD8SH7q5WwO-CIbKAOSKsNcrrTgFxQvqn9yklBU1u5X5fdTlTBk4WSYorsWZAug0z9BOymRLnrhTbnA0vpBPFROWD-aL1glg-eUpFSfgD4xhWsOqJNY9krQ2UbLSGXQ5gYWj0ovLS7Yz3UKFY2qrVWpqkpbfyN98es9NJ-7LTUs2MLq1rX_2FaQmyq5mVndd7VGzQOHy9hDULG-5H-0LvGd=w900-h566-no" alt="" title="adidas Yeezy Boost 350 V2 Hyperspace"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace">adidas Yeezy Boost 350 V2 Hyperspace</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_31_5ce6224803cca" data-td_block_id="td_uid_31_5ce6224803cca"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_31_5ce6224803cca" data-td_block_id="td_uid_31_5ce6224803cca"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div>                </div>

                <div class="td-pb-span5 td-sub-footer-copy">
                    &copy; 2018 The Hip Hop Chronicles Media Group                </div>
            </div>
        </div>
    </div>
</div><!--close td-outer-wrap-->

	<div id="wpcp-error-message" class="msgmsg-box-wpcp warning-wpcp hideme"><span>error: </span>Not Prohibited. ✌️</div>
	<script>
	var timeout_result;
	function show_wpcp_message(smessage)
	{
		if (smessage !== "")
			{
			var smessage_text = '<span>Alert: </span>'+smessage;
			document.getElementById("wpcp-error-message").innerHTML = smessage_text;
			document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp showme";
			clearTimeout(timeout_result);
			timeout_result = setTimeout(hide_message, 3000);
			}
	}
	function hide_message()
	{
		document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp hideme";
	}
	</script>
	<style type="text/css">
	#wpcp-error-message {
	    direction: ltr;
	    text-align: center;
	    transition: opacity 900ms ease 0s;
	    z-index: 99999999;
	}
	.hideme {
    	opacity:0;
    	visibility: hidden;
	}
	.showme {
    	opacity:1;
    	visibility: visible;
	}
	.msgmsg-box-wpcp {
		border-radius: 10px;
		color: #555;
		font-family: Tahoma;
		font-size: 11px;
		margin: 10px;
		padding: 10px 36px;
		position: fixed;
		width: 255px;
		top: 50%;
  		left: 50%;
  		margin-top: -10px;
  		margin-left: -130px;
  		-webkit-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
		-moz-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
		box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
	}
	.msgmsg-box-wpcp span {
		font-weight:bold;
		text-transform:uppercase;
	}
	.error-wpcp {		background:#ffecec url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/error.png') no-repeat 10px 50%;
		border:1px solid #f5aca6;
	}
	.success {
		background:#e9ffd9 url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/success.png') no-repeat 10px 50%;
		border:1px solid #a6ca8a;
	}
	.warning-wpcp {
		background:#ffecec url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/warning.png') no-repeat 10px 50%;
		border:1px solid #f5aca6;
	}
	.notice {
		background:#e3f7fc url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/notice.png') no-repeat 10px 50%;
		border:1px solid #8ed9f6;
	}
    </style>
	<div style="display:none">
	</div>


    <!--

        Theme: Newspaper by tagDiv 2016
        Version: 7.2 (rara)
        Deploy mode: deploy
        
        uid: 5ce622481bc03
    -->

    <link rel='stylesheet' id='so-css-Newspaper-css'  href='http://weuponithiphop.info/wp-content/uploads/so-css/so-css-Newspaper.css?ver=1528674688' type='text/css' media='all' />
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201921'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2019Mayaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.9.10'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/themes/Newspaper/js/tagdiv_theme.js?ver=7.2'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/comment-reply.min.js?ver=4.9.10'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/wp-embed.min.js?ver=4.9.10'></script>

<!-- JS generated by theme -->

<script>
    


            

	            // if the theme has tdBackstr support, it means this already uses it
                if ( 'undefined' !== typeof window.tdBackstr ) {

                    (function(){
                        // the site background td-backstretch jquery object is dynamically added in DOM, and after any translation effects are applied over td-backstretch
                        var wrapper_image_jquery_obj = jQuery( '<div class=\'backstretch\'></div>' );
                        var image_jquery_obj = jQuery( '<img class=\'td-backstretch not-parallax\' src=\'http://weuponithiphop.info/wp-content/uploads/grafitti-3-500x287.jpg\'>' );

                        wrapper_image_jquery_obj.append( image_jquery_obj );

                        jQuery( 'body' ).prepend( wrapper_image_jquery_obj );

                        var td_backstr_item = new tdBackstr.item();

                        td_backstr_item.wrapper_image_jquery_obj = wrapper_image_jquery_obj;
                        td_backstr_item.image_jquery_obj = image_jquery_obj;

	                    tdBackstr.add_item( td_backstr_item );

                    })();
                }

            
            

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'http://weuponithiphop.info/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'http://weuponithiphop.info/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>

<script type='text/javascript' src='https://stats.wp.com/e-201921.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.1.1',blog:'147622849',post:'30019',tz:'-4',srv:'weuponithiphop.info'} ]);
	_stq.push([ 'clickTrackerInit', '147622849', '30019' ]);
</script>

</body>
</html>