<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>Music Video: Calboy – Love Me</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="http://weuponithiphop.info/xmlrpc.php" />
    <meta property="og:image" content="https://lh3.googleusercontent.com/vXqCSMOFf--vDgmxa7eYpkr8tz2qRML5mbU0IcCfx19tR5kLbD2JcKzgfaMPwJfRHeFfKt_BUiQwIw1NRom5aO1ALauK_CKht-_uRjdZNwVkAyLMdKn1C1AdnwkcnIHXL2l0scOmm-W7RmQ4IBwltpW1buWVvbBPmbSa8xgr-d95pgsIDGqbV1gdAmi7KRqaYKK53-Q1UIJuWBDIQkA0IoyuOMkZXnzdVp9i0fE1meqsqikYcoo9bo8BFZoYgMbc3Kmp_mZkkpillLaZFpKF7-sLKDiJ0F2J3-50pnkUFyinc_3jldD-Hm2W9yHvko01JFgEWgwm7zWAUiuS2kkCnKbgzq4LM2L1zArHFfb57-85NDEXqXMr5a6tu4whYokxIq2b9INHxXcW7OQ8wQlUECeoGyULSHEROyeuM_A9jNsE1Zc1kdJ427UAeFwLGIqM3JGJJ7errwYkxID2U--JQmp1GgxrJwEJK3idNQJeeAGSuIKxgCsSrJzHy_rbebSfF_-p-hvHNZuM7qZQJ6J0wEAm89Gv1x5QMPERXRjfDaUDO1wZ529zfwozXeEH5HPTIvk-u8n6t-DxCNupdMLPLu4L8snOmkEvqlMuCbKuvRazO1IBJW1DHKVsSPX2QWrsAVhl7tYivkPl-W2Y1B7rKCZpyuo1LUZy=w882-h481-no" /><meta name="author" content="cyclone">
<link rel="icon" type="image/png" href="http://weuponithiphop.info/wp-content/uploads/weuponitlogoCAP-500x457.png">
<!-- All in One SEO Pack 3.0.1 by Michael Torbert of Semper Fi Web Design[208,255] -->
<link rel="canonical" href="http://weuponithiphop.info/2019/06/05/music-video-calboy-love-me-7/" />
<!-- All in One SEO Pack -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Feed" href="http://weuponithiphop.info/feed/" />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Comments Feed" href="http://weuponithiphop.info/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Music Video: Calboy – Love Me Comments Feed" href="http://weuponithiphop.info/2019/06/05/music-video-calboy-love-me-7/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/weuponithiphop.info\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.10"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='google_font_open_sans-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_roboto-css'  href='http://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C900%2C500italic%2C400%2C300&#038;ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='http://fonts.googleapis.com/css?family=Roboto+Condensed%3A400%2C700&#038;ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='http://weuponithiphop.info/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=4.12' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='http://weuponithiphop.info/wp-content/themes/Newspaper/style.css?ver=7.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css'  href='http://weuponithiphop.info/wp-content/themes/Newspaper/includes/demos/what/demo_style.css?ver=7.2' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://weuponithiphop.info/wp-content/plugins/jetpack/css/jetpack.css?ver=7.1.1' type='text/css' media='all' />
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1'></script>
<link rel='https://api.w.org/' href='http://weuponithiphop.info/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://weuponithiphop.info/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://weuponithiphop.info/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Music Video: Kap G – Carlos Slim' href='http://weuponithiphop.info/2019/06/05/music-video-kap-g-carlos-slim-2/' />
<link rel='next' title='Music Video: Meek Mill – Oodles O’Noodles Babies' href='http://weuponithiphop.info/2019/06/05/music-video-meek-mill-oodles-onoodles-babies-9/' />
<meta name="generator" content="WordPress 4.9.10" />
<link rel='shortlink' href='https://wp.me/p9ZprH-80T' />
<link rel="alternate" type="application/json+oembed" href="http://weuponithiphop.info/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fweuponithiphop.info%2F2019%2F06%2F05%2Fmusic-video-calboy-love-me-7%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://weuponithiphop.info/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fweuponithiphop.info%2F2019%2F06%2F05%2Fmusic-video-calboy-love-me-7%2F&#038;format=xml" />

<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>
<script id="wpcp_disable_selection" type="text/javascript">
//<![CDATA[
var image_save_msg='You Can Not Save images!';
	var no_menu_msg='Context Menu disabled!';
	var smessage = "Not Prohibited. ✌️";

function disableEnterKey(e)
{
	if (e.ctrlKey){
     var key;
     if(window.event)
          key = window.event.keyCode;     //IE
     else
          key = e.which;     //firefox (97)
    //if (key != 17) alert(key);
     if (key == 97 || key == 65 || key == 67 || key == 99 || key == 88 || key == 120 || key == 26 || key == 85  || key == 86 || key == 83 || key == 43)
     {
          show_wpcp_message('You are not allowed to copy content or view source');
          return false;
     }else
     	return true;
     }
}

function disable_copy(e)
{	
	var elemtype = e.target.nodeName;
	var isSafari = /Safari/.test(navigator.userAgent) && /Apple Computer/.test(navigator.vendor);
	elemtype = elemtype.toUpperCase();
	var checker_IMG = '';
	if (elemtype == "IMG" && checker_IMG == 'checked' && e.detail >= 2) {show_wpcp_message(alertMsg_IMG);return false;}
	if (elemtype != "TEXT" && elemtype != "TEXTAREA" && elemtype != "INPUT" && elemtype != "PASSWORD" && elemtype != "SELECT" && elemtype != "OPTION" && elemtype != "EMBED")
	{
		if (smessage !== "" && e.detail == 2)
			show_wpcp_message(smessage);
		
		if (isSafari)
			return true;
		else
			return false;
	}	
}
function disable_copy_ie()
{
	var elemtype = window.event.srcElement.nodeName;
	elemtype = elemtype.toUpperCase();
	if (elemtype == "IMG") {show_wpcp_message(alertMsg_IMG);return false;}
	if (elemtype != "TEXT" && elemtype != "TEXTAREA" && elemtype != "INPUT" && elemtype != "PASSWORD" && elemtype != "SELECT" && elemtype != "OPTION" && elemtype != "EMBED")
	{
		//alert(navigator.userAgent.indexOf('MSIE'));
			//if (smessage !== "") show_wpcp_message(smessage);
		return false;
	}
}	
function reEnable()
{
	return true;
}
document.onkeydown = disableEnterKey;
document.onselectstart = disable_copy_ie;
if(navigator.userAgent.indexOf('MSIE')==-1)
{
	document.onmousedown = disable_copy;
	document.onclick = reEnable;
}
function disableSelection(target)
{
    //For IE This code will work
    if (typeof target.onselectstart!="undefined")
    target.onselectstart = disable_copy_ie;
    
    //For Firefox This code will work
    else if (typeof target.style.MozUserSelect!="undefined")
    {target.style.MozUserSelect="none";}
    
    //All other  (ie: Opera) This code will work
    else
    target.onmousedown=function(){return false}
    target.style.cursor = "default";
}
//Calling the JS function directly just after body load
window.onload = function(){disableSelection(document.body);};
//]]>
</script>
	<script id="wpcp_disable_Right_Click" type="text/javascript">
	//<![CDATA[
	document.ondragstart = function() { return false;}
	/* ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
	Disable context menu on images by GreenLava Version 1.0
	^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ */
	    function nocontext(e) {
	       return false;
	    }
	    document.oncontextmenu = nocontext;
	//]]>
	</script>

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]-->
<!-- JS generated by theme -->

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var tds_login_sing_in_widget="show";
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_ajax_url="http:\/\/weuponithiphop.info\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=7.2";
var td_get_template_directory_uri="http:\/\/weuponithiphop.info\/wp-content\/themes\/Newspaper";
var tds_snap_menu="snap";
var tds_logo_on_sticky="show_header_logo";
var tds_header_style="5";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#dd3333";
var tds_smart_sidebar="enabled";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>


<!-- Header style compiled by theme -->

<style>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</style>

<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>

<body class="post-template-default single single-post postid-30807 single-format-standard unselectable music-video-calboy-love-me-7 td-what wpb-js-composer js-comp-ver-4.12 vc_responsive td-boxed-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
                    <div class="td-menu-login-section">
                
    <div class="td-guest-wrap">
        <div class="td-menu-avatar"><div class="td-avatar-container"><img alt='' src='http://1.gravatar.com/avatar/?s=80&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo avatar-default' height='80' width='80' /></div></div>
        <div class="td-menu-login"><a id="login-link-mob">Sign in</a></div>
    </div>
            </div>
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-top-menu-container"><ul id="menu-top-menu" class="td-mobile-main-menu"><li id="menu-item-317" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a></li>
<li id="menu-item-706" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a></li>
<li id="menu-item-314" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a></li>
<li id="menu-item-316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-0" class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></li>
</ul>
</li>
<li id="menu-item-705" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></li>
</ul>
</li>
<li id="menu-item-18581" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li id="menu-item-3199" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
            <div id="login-form-mobile" class="td-register-section">
            
            <div id="td-login-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-login-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign in</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
	                <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
	                <div class="td-login-info-text"><a href="#" id="forgot-pass-link-mob">Forgot your password?</a></div>
                </div>
            </div>

            

            <div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
                <!-- close button -->
	            <div class="td-forgot-pass-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Password recovery</div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title">Recover your password</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
	                <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
                </div>
            </div>
        </div>
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="http://weuponithiphop.info/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap">
    
        <!--
Header style 5
-->

<div class="td-header-wrap td-header-style-5">

    <div class="td-header-top-menu-full">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div >

                Wednesday, June 5, 2019
            </div>
        </div>
    <ul class="top-header-menu td_ul_login"><li class="menu-item"><a class="td-login-modal-js menu-item" href="#login-form" data-effect="mpf-td-login-effect">Sign in / Join</a><span class="td-sp-ico-login td_sp_login_ico_style"></span></li></ul><div class="menu-top-container"><ul id="menu-main" class="top-header-menu"><li id="menu-item-79" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-79"><a href="http://weuponithiphop.info">Home</a></li>
<li id="menu-item-81" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-81"><a target="_blank" href="http://weuponitradio.com">Power 105.1 WeUpOnIt Radio</a></li>
<li id="menu-item-80" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-80"><a target="_blank" href="https://shop.spreadshirt.com/freshandcleantees/">Shop</a></li>
<li id="menu-item-18582" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18582"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li id="menu-item-18583" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18583"><a href="http://weuponithiphop.info/privacy-policy-2/">Privacy Policy</a></li>
</ul></div></div>
        <div class="td-header-sp-top-widget">
    
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div>
    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <ul class="td-login-tabs">
                        <li><a id="login-link" class="td_login_tab_focus">LOG IN</a></li>
                    </ul>



                    <div class="td-login-wrap">
                        <div class="td_display_err"></div>

                        <div id="td-login-div" class="">
                            <div class="td-login-panel-title">Welcome! Log into your account</div>
                            <input class="td-login-input" type="text" name="login_email" id="login_email" placeholder="your username" value="" required>
                            <input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" placeholder="your password" required>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Log In">


                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password?</a></div>


                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-display-none">
                            <div class="td-login-panel-title">Recover your password</div>
                            <input class="td-login-input" type="text" name="forgot_email" id="forgot_email" placeholder="your email" value="" required>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Pass">
                        </div>




                    </div>
                </div>
                        </div>
    </div>

    <div class="td-header-menu-wrap-full">
        <div class="td-header-menu-wrap">
            <div class="td-container td-header-row td-header-main-menu black-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-menu">
        		<a class="td-mobile-logo td-sticky-header" href="http://weuponithiphop.info/">
			<img class="td-retina-data" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-5.png" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-5.png" alt=""/>
		</a>
			<a class="td-header-logo td-sticky-header" href="http://weuponithiphop.info/">
			<img class="td-retina-data" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" alt=""/>
			<span class="td-visual-hidden">WeUpOnIt</span>
		</a>
	    </div>
    <div class="menu-top-menu-container"><ul id="menu-top-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-mega-menu menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_1_5cf83b8704bfa_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_1_5cf83b8704bfa" ><script>var block_td_uid_1_5cf83b8704bfa = new tdBlock();
block_td_uid_1_5cf83b8704bfa.id = "td_uid_1_5cf83b8704bfa";
block_td_uid_1_5cf83b8704bfa.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"43","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_1_5cf83b8704bfa_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_1_5cf83b8704bfa.td_column_number = "3";
block_td_uid_1_5cf83b8704bfa.block_type = "td_block_mega_menu";
block_td_uid_1_5cf83b8704bfa.post_count = "5";
block_td_uid_1_5cf83b8704bfa.found_posts = "1937";
block_td_uid_1_5cf83b8704bfa.header_color = "";
block_td_uid_1_5cf83b8704bfa.ajax_pagination_infinite_stop = "";
block_td_uid_1_5cf83b8704bfa.max_num_pages = "388";
tdBlocksArray.push(block_td_uid_1_5cf83b8704bfa);
</script><div id=td_uid_1_5cf83b8704bfa class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/05/new-music-ozuna-amor-genuino-73/" rel="bookmark" title="New Music: Ozuna – Amor Genuino"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/ThISOA_XYX48rU5cVpVuwkuELpB7z0AYEqmIpg289DHLASWd9bMR7GpVvllNKOB4DhMKFaDA0ddU1N3k_7mw2CzbClPO0pEJNCn5f4u6x7izWHuG3Vjq2SdhoSzNVrwF0R4R-Pb7RX9qXePKFTDqI8DgIgFVG7SwINVFK_JkuBCjR8TPoP8y8ckV-TPM40lZJD6L--ecoCqLS4OIGOojT6HrAnyHXkSJsws9f_6Hr0S6Jh8J9fCueebvrd3av0oX2rXo0sjXwlH-n2oEPvqUPHWN0mbE4M6R2z_6DQuhZUZUMdlf8titQGGGeZZUbzsagyus_icwU9dMTTao9WhC1uJWqiAX5GqU1TElevefSSicxHwOIBk8vK4lWmo_SuhUH-0u-llywBq_M2HyJ0D0t9L1zLZo7y8tw3ikGta3Vd3Svmb9dTJubI4c1Y8qemLlhXuugOPeW8CXl5LCpS0AfgNe0dCqoSbN_86pfThe3sQI0wWus4wnDlOpRhNr0N-V1Q2Dtw3QVKTREge8jBVtBy3jBYMlo3YKErkmr16vMy2bBiAA4n1-t_nBsnKzJE4DxJIGgIvFQUcT6O3wipscvPgYlZue_8lP4p72m1TNvI_yBI4PG_83-6CEJpu3DkTmQysQkf9WT29q_l08Rw6DAfFDmidpHbJs=s673-no" alt="" title="New Music: Ozuna – Amor Genuino"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/05/new-music-ozuna-amor-genuino-73/" rel="bookmark" title="New Music: Ozuna – Amor Genuino">New Music: Ozuna – Amor Genuino</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/05/new-music-aj-tracey-ft-general-levy-novelist-labroke-grove-remix-94/" rel="bookmark" title="New Music: AJ Tracey ft. General Levy &#038; Novelist – Labroke Grove (Remix)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/n5iN_29M1N1nmQgTsLbNUesv3U0U3m7qrtC15EBWY8XN_kWIZay8LWVFzHTfov-64VGTBNgACgU76qmTp70LBNcOiLUzDTcKm43n3dBzFQtCVYVEZq6QBVG7REXtjN5da4U5LUw7415yvgjQZfseT3JH4JQZaeik9LcHkydCtiYor_tj3xOj1NAfaafUZFrTUam7SJ-XGlfxtYqQu9DzXdvFvlxaPVPsqAk6EEdpaiWrE-Q-eDxcQvMwu1wkKy7EGJH_iQPhIbfbLlXJGBGVYH4FXoxC2QkawhiWIcWPU8g6J0KX21bfJNaoFGB1xGm6w5nflfW2CZJmv_VYeWuE9emIFVZ-lYZ6f9rS6DQjBcuHhtgRUi1qv0oFExIppZ2o1pQ16hfqkRb3th_R_BzbITDtzrnKxwP7G48n4lb9MwzEda1HBAZk1OHwWJlT_W2DrdiKD89SHeaT_zBj_Pf7ebUrOEn570P-iDHIkGrjrUQL9_4vVqP0rMRqMxgQVR1JyHSF3jG6zfvhLs6pIIEQRs0_w_YRu1uUdRucni6auOn8sNPgxYAcmIsNOMWWaJKXZkfQSF227BCX37upAs8XOAhRYG05aJOKmL1ObXFIkR1B_kH19oXA9Szw2L98o1vcjNSe6ZggC7PedNbtY_neOVBV2v7Rkb05=s673-no" alt="" title="New Music: AJ Tracey ft. General Levy &#038; Novelist – Labroke Grove (Remix)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/05/new-music-aj-tracey-ft-general-levy-novelist-labroke-grove-remix-94/" rel="bookmark" title="New Music: AJ Tracey ft. General Levy &#038; Novelist – Labroke Grove (Remix)">New Music: AJ Tracey ft. General Levy &#038; Novelist – Labroke&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/05/new-music-casey-veggies-ft-dom-kennedy-stop-playin/" rel="bookmark" title="New Music: Casey Veggies ft. Dom Kennedy – Stop Playin&#8217;"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/yKNj40aC0veJicUQjXzkbbpUc_wkaLUvu0Hdzaam40HHDQ4kDjgabmf-dgrcdKozLoUfI5fBL_VjeAuaENqZYPxQ2trC3ZIUBfhmkV5fee1wDjiw8vojjw_xcKrGyhw78L_rTUhLp13ztHehTpljSiGOzb2s8e6NBQUrmkUT6ify9ohFSusmcoFK4Wwx5aAz8x3YLoqzcyieqLVlQ4cnhCl-Ga6gxCeqTAp2lCFJ6yCI9LiEPpV5gbUA-PApVo59PL_QGiO8UhOGxXdfwakbjiaXjuJKwjPo0wUpheriASlULS37sT7qjF1mtDwSy0t3ftvL4cW3sgidXtfwUfLtFuzDeaMdY9t7QH--05n-FJFj47f-zyf-nQ4R7sHS9bo0hyoHXeA0qIgysbFmqcaGWVYDuH1Rr4CrD0kIwee6LbKq3bov2ElGW1xjZUDdNfyvV0DysoHNLmJRjmDR8y7UZmSFLYiMk5sXuzfucCBUZEwrFmNecn2i4SBFGkA-XP4XvQi26Tgq3RYRCSYOfomiIUi3hxKQHuwu81zqDNZ0WZ1MNOQ7MQKz0G9WzNtlfQ-LWLo6xHiNvQu94QsLK5nVmSRTSpQADntVGji-W0Fmp06bpzWECgXwjTsyyWBYwUWcvB2wPbNgM4ZV0ywp3n7IcSG1U1gBmkYW=s796-no" alt="" title="New Music: Casey Veggies ft. Dom Kennedy – Stop Playin&#8217;"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/05/new-music-casey-veggies-ft-dom-kennedy-stop-playin/" rel="bookmark" title="New Music: Casey Veggies ft. Dom Kennedy – Stop Playin&#8217;">New Music: Casey Veggies ft. Dom Kennedy – Stop Playin&#8217;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/05/new-music-kembe-x-ft-jay-rock-ab-soul-zacari-raised-a-fool/" rel="bookmark" title="New Music: Kembe X ft. Jay Rock, Ab-Soul &#038; Zacari – Raised A Fool"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/vm7gyzvA-KuBLEfw0vCX-Z6WaSXSHaq6g-aCvFZqYaexqjNPOpOcvH-1WJSyknzNQA9zUue3eV0=s328-no" alt="" title="New Music: Kembe X ft. Jay Rock, Ab-Soul &#038; Zacari – Raised A Fool"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/05/new-music-kembe-x-ft-jay-rock-ab-soul-zacari-raised-a-fool/" rel="bookmark" title="New Music: Kembe X ft. Jay Rock, Ab-Soul &#038; Zacari – Raised A Fool">New Music: Kembe X ft. Jay Rock, Ab-Soul &#038; Zacari –&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/05/new-music-t-wayne-icey/" rel="bookmark" title="New Music: T-Wayne – Icey"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/ZYgNpjUA1lOGAmIY4ER81sU-EElSH04UhUNWhcHY9XVxhyp-yCn2xsi63C-ZP_HYdPxUoc1mFTw0TF9J689GoSPfbrzghvzWu5WvLVXfexb7bIVXX44Srw0UezTtvYAJlsR6c2Dn59LcsFyhp2yR1pe-GoclSdvup3eUwpEBwVHeu7C83ldXMAInUwKHrhKG4XR1hMPl1-6hsvO2rtUPasajtUoHZCdMZGr8-tnpmQDcxl3NCMOUOZpRRqXF79190TiU8oc5GM48SX0QrUpoR0M_HEzxY9-hMBo4up4VL0-hklS41va94jqonOibGI73w7xM1wSuvQ0ZTPZk-vTYTOXxsz05HI2NRFbSAWo_FypUbHttbRMlqB-ZGnldOU2pSp6UOR0lfmuQ35Np-Zc4cMAnGMw5iRQMRHnruQEa17iosXy9eYp-75kujra5XqPANy202L9-1TAt-IcsHFn0y4LgvTimaJgGZ26yNWUl7Pgdo3zbdAVz-b0HMX4TZt28SoZzboYrA4A_-5XvZglblSiCl_abL_xjmEIdgCkqV44hKlP-WKcRXJ8mvjoP-6kNwuysSgk9tJIy3AnG49RcmoZmVYzL0ZUMfQu2SVtgl2ZtVIS6gTTZnDLifC4T1clYX5IWlu47TUljU2dxDiYG_2HQhz-90ngc=w620-h619-no" alt="" title="New Music: T-Wayne – Icey"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/05/new-music-t-wayne-icey/" rel="bookmark" title="New Music: T-Wayne – Icey">New Music: T-Wayne – Icey</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_5cf83b8704bfa" data-td_block_id="td_uid_1_5cf83b8704bfa"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_1_5cf83b8704bfa" data-td_block_id="td_uid_1_5cf83b8704bfa"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_2_5cf83b870ee9e_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_2_5cf83b870ee9e" ><script>var block_td_uid_2_5cf83b870ee9e = new tdBlock();
block_td_uid_2_5cf83b870ee9e.id = "td_uid_2_5cf83b870ee9e";
block_td_uid_2_5cf83b870ee9e.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"97","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_2_5cf83b870ee9e_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_2_5cf83b870ee9e.td_column_number = "3";
block_td_uid_2_5cf83b870ee9e.block_type = "td_block_mega_menu";
block_td_uid_2_5cf83b870ee9e.post_count = "5";
block_td_uid_2_5cf83b870ee9e.found_posts = "739";
block_td_uid_2_5cf83b870ee9e.header_color = "";
block_td_uid_2_5cf83b870ee9e.ajax_pagination_infinite_stop = "";
block_td_uid_2_5cf83b870ee9e.max_num_pages = "148";
tdBlocksArray.push(block_td_uid_2_5cf83b870ee9e);
</script><div id=td_uid_2_5cf83b870ee9e class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/05/ep-stream-valee-runnin-rich/" rel="bookmark" title="EP Stream: Valee – Runnin’ Rich"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/BAJeOe4Y3AA3VRyPfASpow3VPPv8YE9lujg6W4BI-OyUTaD3rkSmIMXLYU7mVtVbSqFlOhKEBgtw-DRsKwJ-xHWwP_I6XDfZHrMhBTvYY1BmZU8uC5PMM7I4ZuUyX4l6b5gj7xDDSzrKeN5FG7bJvT5FW7ZkLNrxuU_9PIE5ENV-Dq03u5B6qam-U9UVYFB1i2u6nbWKgHhSrVjjQiuKHqKtR8WFyXaNm54Kr8EJm1xu1oydeNSjh0djf97f1lz5WXMZRvXPwzLP8DwV-Z_9pyO-unuBr8SipFR_PWCvlq08-5kxpUy8w-VPo0bHmT0t3VBmcMOMC8ruVgrjA5Lm0uWUAWLbIJlq_RepCr8VZsy8umzUSoYCthhgnOUqD03f21O4b_vxxoqAgcDou22EPfKWlZycaQoiVknF6wLwR6mG5YhEIQmvNvQ0QLqCiTiiIMNRtd6hnTkZtK4zXDCgfyLxXlhtpBR9iIyuV4u5_fa-GVodBIDnaiQkQ4-ujr5yO55LTP9HMT2rAHgF6FHry9xmTRLW1fFve3BYL1ieAPx6B2SYiXSFcxyEFx86XogbkvXWDwDcsOATraPBAdypjPiH1WhjoI4J0N_OliwI0c4Ii8_WNoAXZosiAiDvpkRFg1J8rLIT8V2cVoJtFEyg64pFB1s7g79o=s620-no" alt="" title="EP Stream: Valee – Runnin’ Rich"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/05/ep-stream-valee-runnin-rich/" rel="bookmark" title="EP Stream: Valee – Runnin’ Rich">EP Stream: Valee – Runnin’ Rich</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/04/album-stream-onyx-100-mad/" rel="bookmark" title="Album Stream: Onyx – 100 MAD"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/82Pe5ze-oQh-YwTxwdiCKj7b5JI1wRNyU4a0LwUrl2vJ79_CbnF8Bvxcdep5hXu3Sq4ag3dsNWGWYVRMG1AXtwOat7sYiKikC-8tGK04_xc6fZ5Q55NgJhEmcC99PzpgWdthuy1tV4MAJMvZVMVCmQ_4-g0sEm2Va4d20Iv8bsCbNdvqgMCipNzswpLrNvcCKZAN9pNC1oG6ehduZ9yeL1tWOnLev2Y6oN_HUPamsYSu6cyODdwPWj78Dq18xN1x6xHMSZFUbCTnHqsf9iGFWsL0xl7r1OkajsnWqMWUJ4MWE_aYUVtY20fzSwajyUrdttw-fCkUzRFhAAQ-rGgLiG4v3aZa9X53HCN6YnAymYOi510wlXc4XuCu8S1qxHqV03JKTJMg7ezhpe5-G6UHfG5l591soR-DAiUHkUxhk1YnY7qxVHfTDzNpq1VTSoQP3A7BhpAK7jli4ZcZz700higqjRYC04J1QL20Jg3K82oTBgLEh9WBeCVgB35Wx3xdbYQtJxjUUL8yj-dKQ0PLvsQP8E7fmYnB_EpTqIguJeXhd3zVW8-KfllBa6GLQEC8gRsjbE3b4p3Odw1ugkqQIhjeF3CrSrA9EnK2gdxt7NUMKFTV2JRmVpMXAV_Q-1V82RjqT9qJ30aiT3rJcGZvzj8eKEW-kbRM=s796-no" alt="" title="Album Stream: Onyx – 100 MAD"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/04/album-stream-onyx-100-mad/" rel="bookmark" title="Album Stream: Onyx – 100 MAD">Album Stream: Onyx – 100 MAD</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/03/ep-stream-elcamino-lot-and-abraham-89496/" rel="bookmark" title="EP Stream: Elcamino – Lot And Abraham"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/EVP7DJtqa_5L0ZXJ_l3Mf1CgiNujKWuoleidNfeadw7l33m61C2ekwOAGqtToRUNcqmBWRJpB8_JpKPWchHUxv_tGQZ2p9Od_udGlwUhR49CYPPZLeOxT-sfHfg8Ljn_VrC1RyECe80G3mw4YgAwudpGtz2D7ThjnMQJoNwEh3h2rhmVv8p8GO1L0YC7k_aAC635Yfld_gkfRGSDpkGGzC4NHgvrn_0_6rDCWrHjDGzgWNyfwtWYm3vNSWx5pWnfG-o3B5CPFwPLtd58xOSS99v2RspF5A6yn5-KmWEX1HAC61qeqQhih2e8SR4youUJYpmWIB9Ioqg5nvoxOpmqmSON7A7JZQemtNU51sfvGfPd2eDvDgdu6LK2QWY9ooKGD7MS6yV-GEf5mBDgfA9WlYLqKxnvLunbwOCO4svEAhTFKMVtvKNTu_EDbgUbqQpxz6epQnbVDXuvb5LvKN0dteSaYGzH2kMqICiXrLVD0a_POmH-EjFrvzh4x3aM3kKtJFtt_wrVWdfnGraJa26vZpQO2-EpSFShxtUM3MvFC5W-Y9as3yUd8gncimtRQcL8FStouAFoW3f6fErVj4Ziv5gQvur03Tfv7O6SndjGFTS14mKu29weqef6zBX56sYyPO4xGOWuZwQ3FvRvTI-QkYJ15XN5CdAI=s796-no" alt="" title="EP Stream: Elcamino – Lot And Abraham"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/03/ep-stream-elcamino-lot-and-abraham-89496/" rel="bookmark" title="EP Stream: Elcamino – Lot And Abraham">EP Stream: Elcamino – Lot And Abraham</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/02/ep-stream-calboy-wildboy/" rel="bookmark" title="EP Stream: Calboy – Wildboy"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/UiMwMZqsmcOX6rq6uURUzbyQDIWWT1jxwYnCqbqSKLp2xThgiOw0NYtUqosu5ybP7r6YVM1YDKDZmEVcbu32sCmjonZAK9VqHyO6UvjgXHjMjzZNgm6OXr5evuleJ6n5CeppUmyL_E99WlC2rkDjjHv1WrX9qV-41sHQrX7uXoJn4LPUK66ic6WigbsvIXOXfw_sGHZp14vy5g41S2dVuXcRUIFWs1XM7kjS9as6Q3BmMZhioP9RQIjpZKUjwTN0idNj62rGI6o21OZLhLRBhHJDqN3BDcMK5_5R4el_67-VG0Bcqz9ETswejM4A_D8PX6VHn4HcFQ_U5C7PfEuJdiQCBW6EpAfMwT9Rs7vzxBKVvL4x8HqSEXL1WO9Lu7z_6c1FbmLToT7zgQFy9N4E9DIn7UYyVafhYFyIhCBf1Tf2UCBYqvGuC8_4K69mMerGrP-wk367jldS2pODWUNYE-SBPAXDBw5xtIJcYyyUdAkkBV6pJKM5BD4VPOw_7--RcmaL8B19lAmObghiLtLK1YIclG6jQBpBkFJdPUX0elwvgxJ-NjPRPcWjGzLe3CiPjHUFBLsLzeF5qF7aqfyjVjxjToRu8ozx_qB4qLvssXH4ARidK8KzbdEfhAWdSD_4VIXoOSd3GvUwR3FHf4DzQ-EtFdylYtHN=s673-no" alt="" title="EP Stream: Calboy – Wildboy"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/02/ep-stream-calboy-wildboy/" rel="bookmark" title="EP Stream: Calboy – Wildboy">EP Stream: Calboy – Wildboy</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/02/music-video-oncue-i-hate-me-too-846746/" rel="bookmark" title="Music Video: OnCue – I Hate Me Too"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/poSi6dzYaXtmyxdk1M5VBb8REpV4zmrT0_8edb2mz3YkBW47APXn9uFY39kGX5kC3FiBQP-XRPM60y0uxgEflcpQZ7nsb3ufK0O3xNAo-p5L2t511vFHxPcWeWxcL3WPPMYhv8ud3rl5i9sa2CbB9DWUqXuPIOXVJxgLX7rmlo4Nr7en41KPHDjnxKBbQqKvztj7JryV_w2FiDq8mAtf1ejtUjsMjp3Du2IhFbBVgoO8gsZZVrgBzfBYqAV30LLtCucdwYAUqROMDHCUPVJt_a6ntWuVLkUlZ3FCVjAhLX6DUBSXwOzXtE1al3oMjZcRQUVZ2A_dKyBR5r2BOm0euGT8gGwLitWBq_ooZ8s6-HRRie5MPMMlK0BGYVNeRhV8608B00EAnhHzP5R26g8G7J9bGkFCdxrZ61shVTCbTgKgfrRtO0prL7__yfMcTWHTUKJpwgMhgSiz_Ul2xPaN8j4Ihuaql9V8WCRL43cipeCCypH2BrTbMZmOMyIDn3XVYEOJ9FffUxc6oGJU_4nsNZ_oT5n7opnpDUJKp03N2N8MT-TK6B8mer58_2r7In1wdPkKUPi6aS_6fHmjLdHmZg_j8UuA02M36XjfkbL45t0mEr9iDaSfYn6FhuIIl6QIU_DLjbJkAmCQrV1MNkEty8hgAcdnou4R=s673-no" alt="" title="Music Video: OnCue – I Hate Me Too"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/02/music-video-oncue-i-hate-me-too-846746/" rel="bookmark" title="Music Video: OnCue – I Hate Me Too">Music Video: OnCue – I Hate Me Too</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_5cf83b870ee9e" data-td_block_id="td_uid_2_5cf83b870ee9e"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_2_5cf83b870ee9e" data-td_block_id="td_uid_2_5cf83b870ee9e"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_3_5cf83b87176c9_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_3_5cf83b87176c9" ><script>var block_td_uid_3_5cf83b87176c9 = new tdBlock();
block_td_uid_3_5cf83b87176c9.id = "td_uid_3_5cf83b87176c9";
block_td_uid_3_5cf83b87176c9.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_3_5cf83b87176c9_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_3_5cf83b87176c9.td_column_number = "3";
block_td_uid_3_5cf83b87176c9.block_type = "td_block_mega_menu";
block_td_uid_3_5cf83b87176c9.post_count = "5";
block_td_uid_3_5cf83b87176c9.found_posts = "1944";
block_td_uid_3_5cf83b87176c9.header_color = "";
block_td_uid_3_5cf83b87176c9.ajax_pagination_infinite_stop = "";
block_td_uid_3_5cf83b87176c9.max_num_pages = "389";
tdBlocksArray.push(block_td_uid_3_5cf83b87176c9);
</script><div id=td_uid_3_5cf83b87176c9 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/05/music-video-tyga-ft-j-balvin-chris-brown-haute/" rel="bookmark" title="Music Video: Tyga ft. J Balvin &#038; Chris Brown – Haute"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/G5zvOPK30-xht9L8Z1jT6OViP0xIwc9GqHAzJRpOAQJCeluicWHH4k6YfEjHA-NpNtFhXZy5ct_QGQ1doGB7wX2m7REo7yeJtbBeY4djPFa07jFL288epFYloB4RhpZoa2LmsFJPDBR4MxWgDSaOHTKCC8LXA_p3D1LJIyxfhXzAr-y-kVHA_5I0epnIWFFUTYn_K8eqSb0nB3VEeqwgtG40xV1wjjDK3uKcwTlA5IjTEEUKjnZFjpB8FW51xKPDHMIHCwZtcF9M3iqTFxFY_U7PguJup8R4ojRM9JqtFQMJcuXl11nzxvtWu8s25bAl5bXmliNAugaAF0jfYeqQDr2nAIUSRsNh7xgcUxEEQA-LxUZTId4WJL3qlH0r-6eBc65TkyYWvECDsQqM5DSKXzEtYbJysNgh80IJl3NWgst-na2Eq2kr_-A8jpeY2wMGQFrXOzr3LhV1EpLzT7Wr1F9e9tQEpcD7oTs6QCp1juuB-8mG68hCvgP-9yF9iQieJZgvz7vjr3xOTGazyfxrSjfaDyw1IXPKuvvv9CQugCojcr-OfR16Q_o9fAbssUX45lXYWwI4-TjKI8YABqTHbk_JJwjuDOzrguOtXCnsMeRK0_-0vESyQjWLGxfQMTQyEqdWPIAIDXpIq3a7gEGwbdZ7mSLCEFM8=w1046-h446-no" alt="" title="Music Video: Tyga ft. J Balvin &#038; Chris Brown – Haute"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/05/music-video-tyga-ft-j-balvin-chris-brown-haute/" rel="bookmark" title="Music Video: Tyga ft. J Balvin &#038; Chris Brown – Haute">Music Video: Tyga ft. J Balvin &#038; Chris Brown – Haute</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/05/music-video-lil-gnar-ft-lil-skies-craig-xen-death-note/" rel="bookmark" title="Music Video: Lil Gnar ft. Lil Skies &#038; Craig Xen – Death Note"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4FyzFdm-RXe-HxnAUtJx6tjLSnZzcaO8Vb5HT31KMRLiWLhuWHpvLREe9GZeCb_kenuHrtqDR_nQbKN9s8EfN8K1-lZ9x1e3RUbwlYLyx8SKxR3Pg6ZFfPOf7opVsyy1VDm0wyYPH5xZoB_uY-tAKzPqt7P4f71tUbQHHX7P5CFrNYN86yBFtf0LlR_tcRelxZwLo1p5NhaTPWgi4jqQoX1vglwNpCRrygoLs3HUhil-B8hMc5egJCixJxNg16uAX2ksn02x5KzstF6CP9mDDQtZ9Cq9rI9zIdfRV3c1a7ughDDZyXgZ_dPc9PYpcEWz2w6DgmxlAjiU-y4NRhgUWuaJnwXTWGwfNC-OrazTZuFJ0fnygyWqbf0KRNatHcRgRHzGTaJW_62l1K7WRjyg6zHQXDA1SkkAp1qQGhosipXKKr3nsRkfKXrTm-a3UazJO6u2ny9-zbKzeCWssevNjE4uix-w8D_SIszxrwM-znjcF-a1W-II4OHpe8CTXvn8nXxcvaxz4Kqj_BQVOapRoc_nabAhg9uY_N8y9435KXCmF6bARdGzCOaZRepdcn_GykRGo9RPyFWho3zcIk1k2s7l7ab8-PYUdRru9R9PiTJwJ2nbTVXAW3dgAhFPDqTuxRzx6q0ZJ5izROU09z3uISjepCMaTLok=w920-h456-no" alt="" title="Music Video: Lil Gnar ft. Lil Skies &#038; Craig Xen – Death Note"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/05/music-video-lil-gnar-ft-lil-skies-craig-xen-death-note/" rel="bookmark" title="Music Video: Lil Gnar ft. Lil Skies &#038; Craig Xen – Death Note">Music Video: Lil Gnar ft. Lil Skies &#038; Craig Xen –&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/05/music-video-locksmith-on-god-519/" rel="bookmark" title="Music Video: Locksmith – On God"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/-JlrhxLJvSeQEAELq0S9fKc8Jl7APrOVk_zFSbiI9UPn8JXFLKLYPlj6ps19To-OvHa9WwXZCZtDZLSt8h3e4a1hLg1VgjJyGht7RF0Ukj8ll42UP_57drWZ5qE_UWyeqWQp45l6cV6C3X66w0GkpjZHyZDaAnIgjsFJkyhFrWnFAw7yUYsQ_fOVvbfFhsaf9dwEeIFTqYMuXrT_SsPOX-960GGpCaA3pRQqnHFeuSbsnLp00paz8yvopDdFcf0Z7ocOsywnxuMtmt9c32wNRrhhae83CzQWVNJoYR92rza_VZz4myFfVjI8nPWDJnmNgx286Wnrdr0y2NsPXuMzuQ7vtXv84X_xjc429FePnrGhIe9gyNEQZSTX4VkJJISDW750YQar9A6Di9ND1TrXSy7TDvgomSC-3HIfHy4XIT2hZ6Iu9YkdgH9Ohn_6X64FXlT46pDeyjuRrvHzXQoxNU933Dx2PXXK9skQf4CAONq4He8qKrvJK-cLvtn345liNmZ1nbCzrPWfA3q3JlIIvIXm30og6b35M8X87dfwd4xqGsWgxMb4GF48YLAZ4jHckNET-q-wB9reh4QQSpvlSxgSicIskFIwBqQJ6ShMBxqT8N5qARPY-aI-Nub3-NUS803d7ysDvzsLjqgQWie0m1TBpAUbruw2=w754-h457-no" alt="" title="Music Video: Locksmith – On God"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/05/music-video-locksmith-on-god-519/" rel="bookmark" title="Music Video: Locksmith – On God">Music Video: Locksmith – On God</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/05/music-video-meek-mill-oodles-onoodles-babies-9/" rel="bookmark" title="Music Video: Meek Mill – Oodles O’Noodles Babies"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/x2P8w6tIjF0NDj-cLK-1OwzMxSQAQVhhIOJqjjhEibReQwZYTj48OJuWq0zLM5u1sLM_bZqimqGv1-4YAt5BfTNnzVu_6c0bbai2NMh5IDs8RGQ6RvmRne70_mIMdd7_LCzVpuEiOWhnOQkgpk4VnmDh6EWhSeeLBHkle4vFZauHavhjMKr-g7UvKZGpq2nGkbfUT6qqoAamUu0OXZIyESEu3L1TxujETar9hiUgOZNNsjz19aTaF_CnHkugIOFc5iWSgVnbXwvgYB1-ddKokhWZ62FyJZiddIA72XheaOUuUehKSZEQydm-5gNFvy_QnSt12HzcutFVDPnA2Ki6AUNoSbQwru_JoyTTNZZlKNcIqX0B7wExy_lCqG6MlgdevWOPEiSZzmprwnlPJJTNpuJcvcgjm4BTg9StO6aGQasZob2K2pp2-nIa5qwwb5Mt7GY5OKP0vgCbfcHKxoFHaha4k4FV8wL5UovyU2L6VHEOYeSamuFQgHlC2EC_k69ZDPKzGdsM0HzwcMtAzzVpU4ooiQKZ8ZKP5qqHyXPgR9ZGGs7D35Yb0QFxQ8Dju5Val9d8VUXdTUtNlTGuqGEqBk4Xsv3nk_yGuxUUQfu2ZshAqO3Aa00geouzCkQK3lPPhEiWzQWX0Sv6OalNWI-Qd0fDu0mumX21=w799-h454-no" alt="" title="Music Video: Meek Mill – Oodles O’Noodles Babies"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/05/music-video-meek-mill-oodles-onoodles-babies-9/" rel="bookmark" title="Music Video: Meek Mill – Oodles O’Noodles Babies">Music Video: Meek Mill – Oodles O’Noodles Babies</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/05/music-video-calboy-love-me-7/" rel="bookmark" title="Music Video: Calboy – Love Me"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/vXqCSMOFf--vDgmxa7eYpkr8tz2qRML5mbU0IcCfx19tR5kLbD2JcKzgfaMPwJfRHeFfKt_BUiQwIw1NRom5aO1ALauK_CKht-_uRjdZNwVkAyLMdKn1C1AdnwkcnIHXL2l0scOmm-W7RmQ4IBwltpW1buWVvbBPmbSa8xgr-d95pgsIDGqbV1gdAmi7KRqaYKK53-Q1UIJuWBDIQkA0IoyuOMkZXnzdVp9i0fE1meqsqikYcoo9bo8BFZoYgMbc3Kmp_mZkkpillLaZFpKF7-sLKDiJ0F2J3-50pnkUFyinc_3jldD-Hm2W9yHvko01JFgEWgwm7zWAUiuS2kkCnKbgzq4LM2L1zArHFfb57-85NDEXqXMr5a6tu4whYokxIq2b9INHxXcW7OQ8wQlUECeoGyULSHEROyeuM_A9jNsE1Zc1kdJ427UAeFwLGIqM3JGJJ7errwYkxID2U--JQmp1GgxrJwEJK3idNQJeeAGSuIKxgCsSrJzHy_rbebSfF_-p-hvHNZuM7qZQJ6J0wEAm89Gv1x5QMPERXRjfDaUDO1wZ529zfwozXeEH5HPTIvk-u8n6t-DxCNupdMLPLu4L8snOmkEvqlMuCbKuvRazO1IBJW1DHKVsSPX2QWrsAVhl7tYivkPl-W2Y1B7rKCZpyuo1LUZy=w882-h481-no" alt="" title="Music Video: Calboy – Love Me"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/05/music-video-calboy-love-me-7/" rel="bookmark" title="Music Video: Calboy – Love Me">Music Video: Calboy – Love Me</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_5cf83b87176c9" data-td_block_id="td_uid_3_5cf83b87176c9"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_3_5cf83b87176c9" data-td_block_id="td_uid_3_5cf83b87176c9"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_4_5cf83b87201f1_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_4_5cf83b87201f1" ><script>var block_td_uid_4_5cf83b87201f1 = new tdBlock();
block_td_uid_4_5cf83b87201f1.id = "td_uid_4_5cf83b87201f1";
block_td_uid_4_5cf83b87201f1.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"29","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_4_5cf83b87201f1_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_4_5cf83b87201f1.td_column_number = "3";
block_td_uid_4_5cf83b87201f1.block_type = "td_block_mega_menu";
block_td_uid_4_5cf83b87201f1.post_count = "4";
block_td_uid_4_5cf83b87201f1.found_posts = "711";
block_td_uid_4_5cf83b87201f1.header_color = "";
block_td_uid_4_5cf83b87201f1.ajax_pagination_infinite_stop = "";
block_td_uid_4_5cf83b87201f1.max_num_pages = "178";
tdBlocksArray.push(block_td_uid_4_5cf83b87201f1);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_4_5cf83b87201f1" id="td_uid_5_5cf83b8721e89" data-td_block_id="td_uid_4_5cf83b87201f1" data-td_filter_value="" href="http://weuponithiphop.info/category/latest-news/">All</a><a class="mega-menu-sub-cat-td_uid_4_5cf83b87201f1"  id="td_uid_6_5cf83b8721fb7" data-td_block_id="td_uid_4_5cf83b87201f1" data-td_filter_value="69" href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a><a class="mega-menu-sub-cat-td_uid_4_5cf83b87201f1"  id="td_uid_7_5cf83b872211d" data-td_block_id="td_uid_4_5cf83b87201f1" data-td_filter_value="80" href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a><a class="mega-menu-sub-cat-td_uid_4_5cf83b87201f1"  id="td_uid_8_5cf83b8722284" data-td_block_id="td_uid_4_5cf83b87201f1" data-td_filter_value="2189" href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a><a class="mega-menu-sub-cat-td_uid_4_5cf83b87201f1"  id="td_uid_9_5cf83b87223db" data-td_block_id="td_uid_4_5cf83b87201f1" data-td_filter_value="10" href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a><a class="mega-menu-sub-cat-td_uid_4_5cf83b87201f1"  id="td_uid_10_5cf83b8722516" data-td_block_id="td_uid_4_5cf83b87201f1" data-td_filter_value="130" href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></div></div><div id=td_uid_4_5cf83b87201f1 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/05/future-announces-save-me-album/" rel="bookmark" title="Future Announces  &#8216;Save Me&#8217; Album"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/LvHt3CR0u6qRkXjGIrbh_Tk_eN5jSa06-QYG60RHvuKAsGkSSBcxy5d3KOHgchZ3MTvFQW92GiuM2-wl9i7VlQQWfHD6ic8HuEXppUMylKDsG70sX4-4zJWrucVA9n7ialWbYPXsfJqfDzSiSuXhMaUmFNw9E3FoCTNuidoKCN4JcIfyR1av73s-_RyHU_TTFitGSdLUTIF9TAIxgedhuAVrvUrmpOLqCde-Tyi2-McnX6hyeQpqcepFZRTOHDmzO_ZdtQF-ZbMrzHjrtbxMo-qy-lmM2x1VSvt_lYhRAqVuwP9rI5iq53-L3iTqEIMvyq4ZTgTHFrcp1A8QoYAjN8yK1mMfJLCng6EjV4aH1isvUQ1dTc43VO6w-IKG534NSS39Od9I_T2iO8YpNOdPTvixzmrJZ9PlU2EQG5Ehzj-rnDjpE_iTVD6IF7s6r2RL9DrYNFFPXiuhAc6kDnvFdrOL-azPVOttzcDLSE-RN2aq1W5gHpTRsHBf3AQ6LG7XVjRqrJdZ8eszEPpGswNJPo1ZnedaGapTO3VmyBu9Y9SG3d5FO0aFN433OWpQ4GOZF8Fi14JVTZf8Zp1a7O3KlCnU0m2jbXaAkolHUqXZWiuG_fe0e1lHYOCLy3V901T9rdQAtek3DzS782CoPu8AfH9uwA8xs_LM=s672-no" alt="" title="Future Announces  &#8216;Save Me&#8217; Album"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/05/future-announces-save-me-album/" rel="bookmark" title="Future Announces  &#8216;Save Me&#8217; Album">Future Announces  &#8216;Save Me&#8217; Album</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/05/video-wiz-khalifa-mike-tyson-hotboxin-interview-8/" rel="bookmark" title="Video: Wiz Khalifa &#8211; Mike Tyson Hotboxin Interview"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/UKZfD0NK0KETB2g5_pYf2ebGtSWK7J29llDpQfbNYZ5tmVf4882SVzNBHKv9ICyHSOzBDnHBjLrHTMvIj_EXXcGkNu_gcbmZRuKLIN7UmglfBgLSr74aFjCVEBvOcagnOpLAzTZSYv-pRP0MsdtUJNf-RC2Ey6qu9wDS1xn5WgStc6Uvn-pb8Kw726UuuXQk18IOo9y7a1u3poQuwFysICJuH18uWB-SvkrVWOxGF2VYAH71YH0yj4uB3mVXRyEUADhdvP9UJRjtvccTeGv4ys66YyWiPP_Zl77qkH_5ZI2ekd-DGxZ3-GMS7fF1QtVHu2knvWeWyjO_rte5xpKRk8-cekQ1o8WFwApH-xgtln7jVBqA9TpXtOgDYlSu06033OjoADgevEB5XC03T2zZlORbXD1d-bJ_NXPFQmajfbuAgMWBhTC5MzefUMtDLC-szMCrE_RomTBhvufvSpMokuHJMkvFwRVFANlbnNCphq-w4pegtIX-8yeAG_65px24Yxek1gvu9RDArr4tD-aVen1yp-deE_KG02i3upVSb6MpVnDSF0o3AGtKG5pgq74T_TjHmuH6M-INARHZ8IqR_mi0nURvFFtHaV1wyM6ES4NRSnuIlEhUesFYOCp3A7JxPnwOGqwutLi0_jhf-y6Vlt6metBCC0_g=w433-h220-no" alt="" title="Video: Wiz Khalifa &#8211; Mike Tyson Hotboxin Interview"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/05/video-wiz-khalifa-mike-tyson-hotboxin-interview-8/" rel="bookmark" title="Video: Wiz Khalifa &#8211; Mike Tyson Hotboxin Interview">Video: Wiz Khalifa &#8211; Mike Tyson Hotboxin Interview</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/04/rihanna-is-crowned-the-richest-female-musician-in-the-world/" rel="bookmark" title="Rihanna Is Crowned The Richest Female Musician in the World"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/HhtFWmgBFwwYsg_EQq-qiL6A98tDq086ht-bGPEewOze6AV24rXqGot-pGBQJSRIQeBEZC7ZKgWoQatIArHzI0rMB38e8NisORZYUFc945OVFM-IN3wbtfmA5XOjKGBEHFjPqO7aZXz--6GX0wPgfbjtby-m8ADcvBju1ZyDEMrAL_9y1dzn5MKxls9bRU221sh8X9nkgm6HmharDjJKu0z2b0SmI-hJV4V28h4egbnEOQU2qtFirSYw1sXqZpZXxGgCxgJXgpseLxZa4p5NVmPHAR70orBGcafNUys3AuGzWnpZrvn2lnoELawDZ5sDorlKYD9CS05MyV5CuCwtxpnMJwjWv3Jr7Z-3t9iUE6n0f7Fl9xKsOnUs29G1Tkd1sJHUJ7GfAHDE8wPjBl_RnZP1kZGiiIA9O5ifGrKFMAZnDE_sb1atNVLzNaLV4tuNM1xGbJlhnA4CpFKcWS5ONxYs0Pk98Gg3kpHixpmNh8wO_wWCBpj1KVs4AQ_EtRO9aIhi3dQyxpdeLj2lw9efj3MPAlUiUJ8FINA9fHsPns_IC27jmgatL98VAANaHfcbMSyPoK0yYaKTh6tRZtq38VAN7X-0xgDAfP0eJncHbz5Qm_EjK_A3NmCD0x4ktPsEJ0A9o83NradQiNJyDf1Ns2jP13Au3JsW=w593-h426-no" alt="" title="Rihanna Is Crowned The Richest Female Musician in the World"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/04/rihanna-is-crowned-the-richest-female-musician-in-the-world/" rel="bookmark" title="Rihanna Is Crowned The Richest Female Musician in the World">Rihanna Is Crowned The Richest Female Musician in the World</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/04/video-westside-gunn-conway-on-bets-rate-the-bars-4/" rel="bookmark" title="Video: Westside Gunn &#038; Conway On BET&#8217;s Rate The Bars"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/_j6hwcf_wp5fhYmCvAo5lQ7DazD0uB3cC0-k8DQe5OF6tLt5wxQmx6DTu-8RvIlaCnanWCXw2gL3Lq6w-8g154ZUXkNOvgTyVfl9VPI4xOinu6ereLh9IcAhymSIo3c3P-dJL2wjwzuywSjoIa8HtqG9V3Skh81itcbnNMdAP7D2F35LclsMbGiHzgzpwwsVq3NFPwO88bQRhbH_ypzWGjnSI5Ac7j-09VSmXhCsd3hWk6-wi_uW3MdZi6OlvMBl2sKhEpjBqqTig_8ALzfJTbN53ACJG3Xtv9YLPsoLS5zj4HChejnZZ_arDhyVLRpQSn2XCDmYKDF09k6JYxoS7YeGa7y89Sf4N82dfDTiqmiLaNQeJyX-071RWYPhlsywF3jE5OPgBW-yv-kNDjuLFi9DEj1R7E7ksiKw6Qu_d9x_NpBPDmTLagiiAFmdZikMDr7-rYMetUce_4B9m2z2Lubd_0x4vMrIL4R8879PUGsm14VfrZcfZbNG83NRuWc-02dlI9U84g33Y2W1zQCk542MJjrXeeD03w1KX_vDKsUWydV9CEhQC2Mau6Z1U2Ms7eVar6PQeTrkWG9EbIn6b5UAPcXcNtWi6JTAjEAdegmY-4XXTax9bdmzLqOsfkATxDfiuxckBRPrPKsX41yfwWperDO0zU7j=w990-h494-no" alt="" title="Video: Westside Gunn &#038; Conway On BET&#8217;s Rate The Bars"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/04/video-westside-gunn-conway-on-bets-rate-the-bars-4/" rel="bookmark" title="Video: Westside Gunn &#038; Conway On BET&#8217;s Rate The Bars">Video: Westside Gunn &#038; Conway On BET&#8217;s Rate The Bars</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_4_5cf83b87201f1" data-td_block_id="td_uid_4_5cf83b87201f1"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_4_5cf83b87201f1" data-td_block_id="td_uid_4_5cf83b87201f1"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_11_5cf83b875017f_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_11_5cf83b875017f" ><script>var block_td_uid_11_5cf83b875017f = new tdBlock();
block_td_uid_11_5cf83b875017f.id = "td_uid_11_5cf83b875017f";
block_td_uid_11_5cf83b875017f.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"77","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_11_5cf83b875017f_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_11_5cf83b875017f.td_column_number = "3";
block_td_uid_11_5cf83b875017f.block_type = "td_block_mega_menu";
block_td_uid_11_5cf83b875017f.post_count = "4";
block_td_uid_11_5cf83b875017f.found_posts = "158";
block_td_uid_11_5cf83b875017f.header_color = "";
block_td_uid_11_5cf83b875017f.ajax_pagination_infinite_stop = "";
block_td_uid_11_5cf83b875017f.max_num_pages = "40";
tdBlocksArray.push(block_td_uid_11_5cf83b875017f);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_11_5cf83b875017f" id="td_uid_12_5cf83b8751cc0" data-td_block_id="td_uid_11_5cf83b875017f" data-td_filter_value="" href="http://weuponithiphop.info/category/fashion/">All</a><a class="mega-menu-sub-cat-td_uid_11_5cf83b875017f"  id="td_uid_13_5cf83b8751dd6" data-td_block_id="td_uid_11_5cf83b875017f" data-td_filter_value="76" href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></div></div><div id=td_uid_11_5cf83b875017f class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/LVT4Mid8WL4wHUdO9X2OZmZxxgbREs2lVtszOdEBaO6hJB0JS3yQOAyhNSdCyPmv0amBDTgNGpOlRPXPjKCl6yIlo2joyH3rQRI7CUdX09BJtQI1r5jy1_7BQtDhw4AxUhpUwIh35rNS3lTy7uq-FdPff10JN6srr9mwZ7zr04GQFxBVEXwCfC5rNVehXhY_wGCRVsmevYmdkBWEmB8dvOzBHY78NBBjcHNArS_S-2M0FJgDh8v9m9vEh78k_XmZg-AERctsf0bkODuPi1EcNJq_RnJIV6b0GG-VtKjo-OVPmYghWJYf1HiP9c58cQ98oABU8BDFdLqsBtNt4K0NmyHYQlX39W9k_d83wEHZ1-EacQa2o01VrYSn12HnZ1l88fMzu9PKv6EGmcRZNwpepycW7_9EQnhxIPDdVCmRLXUasUED9OXr-zJmnBcnSnLCa06k1ZymQym1LiSFEv1c3aPHnmnD3GY8nL7q5jPJr4HsABR0WCqMebcF3HF_0deNd0zgRBCGMxW-VzlIIHZiHuBeSPEPvUL149GJ5swSSvKm1uGEi1HlLBj9omJSU7mDWzO0p_7l-l7-4_ureEsGsgB8cX1t8t2TQcFeRgqqF1CXlZFYYC2K0iMb4jPsijsw_rtO7pmKvbngqHfgYpGeh_qLmDWeicR7=w1195-h796-no" alt="" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch">Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/fHEwwMf8DoiXlqkfibQS1Z1XXbviORbV9raaI44tOTXrWo7GgqM3gA-vswE10gFtTQUGGwNG7nWAACwHjxPuiubliYBN_dqtBZh2WIpxvumiJ-hSLK0TNWB2cB8Iw2STT5gcp_KqlDh_e4xng1vidI8EXdp_ooh5uDI-JV1HQ9dGnM5nxl_b-v8znqj-Rl_mGB7y4Lu9zsFNWHU7SriqQQJaKrKEEnb9T8zxmGLaL0zq7ilYpnUEhWulDDr9xc82wdr__WzRBm5YEskVpDAnGM2NDZwTZpjbe4QDdxeixWnSXNK_oDzaL7WTbCpkD33OK88BlI5JmFRQ5VmD11UQ2htB7-9WoahHvb4XmBsbLXpEMl1JmEP4sPx06VduzFnBNo-J90WI0n1AEIIcEYVbRywrkGJXbzmH__In9ZIg0EV24OcGGbeKl12HxTdZwucqsNnuZeNjiMHISQ7i8cfzm3N7X7Zenl74zsKIKeKWoIGxh6MTlVADvgHcrHebnjcSgil2vBeFyz_AP45aOv9SOwbzfVLGS0CNfe1s9b2J7qZgjcBk9QPEXCl2kygvzmGXFvU_3xBuW6S0i3Vkh3Ha_3hPBtvIAy3WoTK2yiqS41HzSK7yk3FRAlBtpIEib338fdkTiosBxtdu36SdNUVM75zl6CVIFhTu=w681-h470-no" alt="" title="Air Jordan 14 Rip Hamilton"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton">Air Jordan 14 Rip Hamilton</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/kUjaOYxjEkAh34S-Ub2QSZwdOwHyFnGFLBZULta3_bn1_myPMAwJXiEEsAAtc1ktCQwHCuKhSqSYsWXFBEIZxdfKuykoDEZWwO-dDI3_JeAshbYvyILEHUu0XaUpRn0mj7gOx10V52t8gRGYPCW7QXGImkPGGhvBPzBDVVqh9lKGtkuPeePmTnpRSmwp0LG1WHcIzUWnMqPBWQeHAat6Q-Tq7niXNb96ddEZsMEdHK1nmHVlNaeqFBNtTxk6yYRkFNCvtfBayqy-Rqt4CPU5tThxbTI4AIUCI6JLxJd_VJizrVNDEe2xZ_tiQdkC5ASIoHpX8sfvAB8zRUsMVJ6oMUt5FH_4GBNXDCtFRmr65Qt0JV1h4bBJffu2L272Q_vpD76wn-YNGW8VCtZcheHu_X-A4gdYQEC0HN0BenY-MOuUBqKEjXAc0SxWeP7W9RN55jlqUFK0nzEYydVjec2stdQIngVfg_FvKxvHXfM4XdtMpqeJnp3Pzyk8xjz30sAZd0f2HQ6zfdPjk-OkV2-WrC0_qW0L8Rq3zrUbq52n3BN7gm7sctU_CUlBmoQIgJDQBYk1Siv4tfSq9pL1R4GdaOlWQdxEuhZi8bTYC8GGAgNGl3SMAZGvk7nu6QnnwEZjZ7mZwbcqgyRKa89cOREMUvIkVJ8Q8lZu=w926-h672-no" alt="" title="Jordan Proto React Triple White"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White">Jordan Proto React Triple White</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4cDUjSODZSaXWfHyZKb9q3Fn7FHA4uB0KSBs0MtFHC0dc6AJb1zeAl_X2LOKalK9C7VBFhTqRQ9fw1ESgUr9ZUKFbOzD94i_s96nvkICOqrsYnzrE2nEAQHoEaGOF4O8GAI6T4CGFbgcQhNzjpRlSY60NyPu5Cmq81FRpEOFRzTOtSa_NnWzMmfwO0yxtPbcg5U6YBUsus8shv3SA7CjULLfaP38nZAuWVgq8PMaaeCQ_eSrK8NJSEVQjyyxmqb-1I7zO8Kvvzvwi--ibMr52CF8h-GusBzSq5ZuzvZRCGu_u8CyfoXw7pwWbOmHnLOdcQ9d2PCSW_IxEMGfmEuU7NxMSsW3Ga4r35_wLB7cjvlPC9OjCV50tfekXjZBS_476mzlf4G9jR7Ju1GqgjXah9Uqc_0Y8N-Br8_JCtIlRSuLxAiebwd7AvFVlgWId9MYxBWnRT3cTyD8SH7q5WwO-CIbKAOSKsNcrrTgFxQvqn9yklBU1u5X5fdTlTBk4WSYorsWZAug0z9BOymRLnrhTbnA0vpBPFROWD-aL1glg-eUpFSfgD4xhWsOqJNY9krQ2UbLSGXQ5gYWj0ovLS7Yz3UKFY2qrVWpqkpbfyN98es9NJ-7LTUs2MLq1rX_2FaQmyq5mVndd7VGzQOHy9hDULG-5H-0LvGd=w900-h566-no" alt="" title="adidas Yeezy Boost 350 V2 Hyperspace"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace">adidas Yeezy Boost 350 V2 Hyperspace</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_11_5cf83b875017f" data-td_block_id="td_uid_11_5cf83b875017f"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_11_5cf83b875017f" data-td_block_id="td_uid_11_5cf83b875017f"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div></div>


<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form method="get" class="td-search-form" action="http://weuponithiphop.info/">
				<div role="search" class="td-head-form-search-wrap">
					<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>            </div>
        </div>
    </div>

    <div class="td-banner-wrap-full">
        <div class="td-header-container td-header-row td-header-header">
            <div class="td-header-sp-recs">
                <div class="td-header-rec-wrap">
    
</div>            </div>
        </div>
    </div>

</div><div class="td-main-content-wrap">

    <div class="td-container td-post-template-default ">
        <div class="td-crumb-container"><div class="entry-crumbs"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="" class="entry-crumb" itemprop="url" href="http://weuponithiphop.info/"><span itemprop="title">Home</span></a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="View all posts in Music Video" class="entry-crumb" itemprop="url" href="http://weuponithiphop.info/category/music-video/"><span itemprop="title">Music Video</span></a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last" itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><meta itemprop="title" content = "Music Video: Calboy – Love Me"><meta itemprop="url" content = "http://weuponithiphop.info/2019/06/05/music-video-calboy-love-me-7/">Music Video: Calboy – Love Me</span></div></div>

        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-30807" class="post-30807 post type-post status-publish format-standard has-post-thumbnail hentry category-music-video tag-calboy tag-love-me" itemscope itemtype="http://schema.org/Article">
        <div class="td-post-header">

            <ul class="td-category"><li class="entry-category"><a  href="http://weuponithiphop.info/category/music-video/">Music Video</a></li></ul>
            <header class="td-post-title">
                <h1 class="entry-title">Music Video: Calboy – Love Me</h1>

                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name">By <a href="http://weuponithiphop.info/author/cyclone/">cyclone</a> - </div>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-06-05T15:57:16+00:00" >June 5, 2019</time></span>                    <div class="td-post-comments"><a href="http://weuponithiphop.info/2019/06/05/music-video-calboy-love-me-7/#respond"><i class="td-icon-comments"></i>0</a></div>                                    </div>

            </header>

        </div>

        

        <div class="td-post-content">

        
        <p><img class="aligncenter size-full" src="https://lh3.googleusercontent.com/vXqCSMOFf--vDgmxa7eYpkr8tz2qRML5mbU0IcCfx19tR5kLbD2JcKzgfaMPwJfRHeFfKt_BUiQwIw1NRom5aO1ALauK_CKht-_uRjdZNwVkAyLMdKn1C1AdnwkcnIHXL2l0scOmm-W7RmQ4IBwltpW1buWVvbBPmbSa8xgr-d95pgsIDGqbV1gdAmi7KRqaYKK53-Q1UIJuWBDIQkA0IoyuOMkZXnzdVp9i0fE1meqsqikYcoo9bo8BFZoYgMbc3Kmp_mZkkpillLaZFpKF7-sLKDiJ0F2J3-50pnkUFyinc_3jldD-Hm2W9yHvko01JFgEWgwm7zWAUiuS2kkCnKbgzq4LM2L1zArHFfb57-85NDEXqXMr5a6tu4whYokxIq2b9INHxXcW7OQ8wQlUECeoGyULSHEROyeuM_A9jNsE1Zc1kdJ427UAeFwLGIqM3JGJJ7errwYkxID2U--JQmp1GgxrJwEJK3idNQJeeAGSuIKxgCsSrJzHy_rbebSfF_-p-hvHNZuM7qZQJ6J0wEAm89Gv1x5QMPERXRjfDaUDO1wZ529zfwozXeEH5HPTIvk-u8n6t-DxCNupdMLPLu4L8snOmkEvqlMuCbKuvRazO1IBJW1DHKVsSPX2QWrsAVhl7tYivkPl-W2Y1B7rKCZpyuo1LUZy=w882-h481-no" alt="Calboy – Love Me" width="882" height="481" /></p>
<p>&nbsp;</p>
<p>Chicago&#8217;s <strong>Calboy</strong> premiere his <em><strong>Wildboy</strong></em> EP a couple days ago and quickly follows with the visuals for his track <strong>“Love Me”.</strong></p>
<p>You can download <em><strong>Wildboy</strong></em> now on <a href="https://geo.itunes.apple.com/us/album/wildboy/1465008908?mt=1&amp;app=music&amp;at=11l4Qg&amp;ct=wildboy" target="_blank" rel="noopener noreferrer">iTunes</a>/<a href="https://play.google.com/store/music/album/Calboy_Wildboy?id=Bryxr672klauxfvwg4c4xowga64">Google Play</a>.</p>
<p><iframe src="https://www.youtube.com/embed/CePpc2JDFbI" width="620" height="350" frameborder="0" allowfullscreen="allowfullscreen" data-mce-fragment="1"></iframe></p>
<div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="http://weuponithiphop.info/2019/06/05/music-video-calboy-love-me-7/" data-a2a-title="Music Video: Calboy – Love Me"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F06%2F05%2Fmusic-video-calboy-love-me-7%2F&amp;linkname=Music%20Video%3A%20Calboy%20%E2%80%93%20Love%20Me" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F06%2F05%2Fmusic-video-calboy-love-me-7%2F&amp;linkname=Music%20Video%3A%20Calboy%20%E2%80%93%20Love%20Me" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F06%2F05%2Fmusic-video-calboy-love-me-7%2F&amp;linkname=Music%20Video%3A%20Calboy%20%E2%80%93%20Love%20Me" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F06%2F05%2Fmusic-video-calboy-love-me-7%2F&amp;linkname=Music%20Video%3A%20Calboy%20%E2%80%93%20Love%20Me" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_tumblr" href="https://www.addtoany.com/add_to/tumblr?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F06%2F05%2Fmusic-video-calboy-love-me-7%2F&amp;linkname=Music%20Video%3A%20Calboy%20%E2%80%93%20Love%20Me" title="Tumblr" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_reddit" href="https://www.addtoany.com/add_to/reddit?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F06%2F05%2Fmusic-video-calboy-love-me-7%2F&amp;linkname=Music%20Video%3A%20Calboy%20%E2%80%93%20Love%20Me" title="Reddit" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_flipboard" href="https://www.addtoany.com/add_to/flipboard?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F06%2F05%2Fmusic-video-calboy-love-me-7%2F&amp;linkname=Music%20Video%3A%20Calboy%20%E2%80%93%20Love%20Me" title="Flipboard" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F06%2F05%2Fmusic-video-calboy-love-me-7%2F&amp;linkname=Music%20Video%3A%20Calboy%20%E2%80%93%20Love%20Me" title="Copy Link" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div>        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="http://weuponithiphop.info/tag/calboy/">Calboy</a></li><li><a href="http://weuponithiphop.info/tag/love-me/">Love Me</a></li></ul>            </div>

                        <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="http://weuponithiphop.info/2019/06/05/music-video-kap-g-carlos-slim-2/">Music Video: Kap G – Carlos Slim</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="http://weuponithiphop.info/2019/06/05/music-video-meek-mill-oodles-onoodles-babies-9/">Music Video: Meek Mill – Oodles O’Noodles Babies</a></div></div></div>            <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="http://weuponithiphop.info/author/cyclone/">cyclone</a></span></div>	        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="cyclone"></span><meta itemprop="datePublished" content="2019-06-05T15:57:16+00:00"><meta itemprop="dateModified" content="2019-06-05T15:58:38+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://weuponithiphop.info/2019/06/05/music-video-calboy-love-me-7/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png"></span><meta itemprop="name" content="WeUpOnIt"></span><meta itemprop="headline " content="Music Video: Calboy – Love Me"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://lh3.googleusercontent.com/vXqCSMOFf--vDgmxa7eYpkr8tz2qRML5mbU0IcCfx19tR5kLbD2JcKzgfaMPwJfRHeFfKt_BUiQwIw1NRom5aO1ALauK_CKht-_uRjdZNwVkAyLMdKn1C1AdnwkcnIHXL2l0scOmm-W7RmQ4IBwltpW1buWVvbBPmbSa8xgr-d95pgsIDGqbV1gdAmi7KRqaYKK53-Q1UIJuWBDIQkA0IoyuOMkZXnzdVp9i0fE1meqsqikYcoo9bo8BFZoYgMbc3Kmp_mZkkpillLaZFpKF7-sLKDiJ0F2J3-50pnkUFyinc_3jldD-Hm2W9yHvko01JFgEWgwm7zWAUiuS2kkCnKbgzq4LM2L1zArHFfb57-85NDEXqXMr5a6tu4whYokxIq2b9INHxXcW7OQ8wQlUECeoGyULSHEROyeuM_A9jNsE1Zc1kdJ427UAeFwLGIqM3JGJJ7errwYkxID2U--JQmp1GgxrJwEJK3idNQJeeAGSuIKxgCsSrJzHy_rbebSfF_-p-hvHNZuM7qZQJ6J0wEAm89Gv1x5QMPERXRjfDaUDO1wZ529zfwozXeEH5HPTIvk-u8n6t-DxCNupdMLPLu4L8snOmkEvqlMuCbKuvRazO1IBJW1DHKVsSPX2QWrsAVhl7tYivkPl-W2Y1B7rKCZpyuo1LUZy=w882-h481-no"><meta itemprop="width" content="800"><meta itemprop="height" content="600"></span>        </footer>

    </article> <!-- /.post -->

    <div class="td_block_wrap td_block_related_posts td_uid_15_5cf83b8903b41_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_15_5cf83b8903b41" ><script>var block_td_uid_15_5cf83b8903b41 = new tdBlock();
block_td_uid_15_5cf83b8903b41.id = "td_uid_15_5cf83b8903b41";
block_td_uid_15_5cf83b8903b41.atts = '{"limit":6,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_custom_related","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_15_5cf83b8903b41_rand","offset":"","css":"","live_filter":"cur_post_same_tags","live_filter_cur_post_id":30807,"live_filter_cur_post_author":"1"}';
block_td_uid_15_5cf83b8903b41.td_column_number = "3";
block_td_uid_15_5cf83b8903b41.block_type = "td_block_related_posts";
block_td_uid_15_5cf83b8903b41.post_count = "2";
block_td_uid_15_5cf83b8903b41.found_posts = "2";
block_td_uid_15_5cf83b8903b41.header_color = "";
block_td_uid_15_5cf83b8903b41.ajax_pagination_infinite_stop = "";
block_td_uid_15_5cf83b8903b41.max_num_pages = "1";
tdBlocksArray.push(block_td_uid_15_5cf83b8903b41);
</script><h4 class="td-related-title"><a id="td_uid_16_5cf83b8906188" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_15_5cf83b8903b41" href="#">RELATED ARTICLES</a><a id="td_uid_17_5cf83b89061d2" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_15_5cf83b8903b41" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_15_5cf83b8903b41 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/02/ep-stream-calboy-wildboy/" rel="bookmark" title="EP Stream: Calboy – Wildboy"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/UiMwMZqsmcOX6rq6uURUzbyQDIWWT1jxwYnCqbqSKLp2xThgiOw0NYtUqosu5ybP7r6YVM1YDKDZmEVcbu32sCmjonZAK9VqHyO6UvjgXHjMjzZNgm6OXr5evuleJ6n5CeppUmyL_E99WlC2rkDjjHv1WrX9qV-41sHQrX7uXoJn4LPUK66ic6WigbsvIXOXfw_sGHZp14vy5g41S2dVuXcRUIFWs1XM7kjS9as6Q3BmMZhioP9RQIjpZKUjwTN0idNj62rGI6o21OZLhLRBhHJDqN3BDcMK5_5R4el_67-VG0Bcqz9ETswejM4A_D8PX6VHn4HcFQ_U5C7PfEuJdiQCBW6EpAfMwT9Rs7vzxBKVvL4x8HqSEXL1WO9Lu7z_6c1FbmLToT7zgQFy9N4E9DIn7UYyVafhYFyIhCBf1Tf2UCBYqvGuC8_4K69mMerGrP-wk367jldS2pODWUNYE-SBPAXDBw5xtIJcYyyUdAkkBV6pJKM5BD4VPOw_7--RcmaL8B19lAmObghiLtLK1YIclG6jQBpBkFJdPUX0elwvgxJ-NjPRPcWjGzLe3CiPjHUFBLsLzeF5qF7aqfyjVjxjToRu8ozx_qB4qLvssXH4ARidK8KzbdEfhAWdSD_4VIXoOSd3GvUwR3FHf4DzQ-EtFdylYtHN=s673-no" alt="" title="EP Stream: Calboy – Wildboy"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/02/ep-stream-calboy-wildboy/" rel="bookmark" title="EP Stream: Calboy – Wildboy">EP Stream: Calboy – Wildboy</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/19/music-video-calboy-ft-moneybagg-yo-unjudge-me/" rel="bookmark" title="Music Video: Calboy ft. Moneybagg Yo – Unjudge Me"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/-jC_5Y_Xu59wQblWQHMep_Pk-oxcAhtKKrP6JTltQaX5PVMNRqEGO50Z9bkCso1UY9VXfx3kUcw_jP468D4EEprtKUhwOZidLLmGqJCiBZ8tSgDk2pwAsXIOQV-xKnuWa4s_t3NnGRR6mCwSG6eKmMZXiHSVwXYV_aTPim7lp_shgrWRfL9uk9o1FZgTMtwyYb_3brEDA82XnQoQs5AwMHr6VrlPP0i45xTqWUTdx4qXM_zDfayCtYO-i8-MP4fNdSUyoHSvJRc5wfA_jWIav11VhYpEtsIOeTkUb0tPA6_BEpsSlDWOF3_XF2z4v5W5yBPa4uM8xvw06g5YnvkvlKhw3Cbjv-Wif66NADkRVySK_8x46tviHzEA-lCBuovYTZj7LzVftyoaDhqnQNNwYKljQcVcEPUD-SXRgy85hT734U5jCZ5RM6X8bXH3dwxqUfO-EvjRKKfDk51BO7fON8aP_S5flb7rlOiLage7voE7YEUC99pSZ4X2oF_tUY-uVd9Zj1nJKV9saps1g5_xGuOK8rFVBETrG_sGrXyS-V5bQayIGwHv4LDsP2E74YzbPbZzZaav0_LAhbSyKq4fal1O0zCqzw4PGI0Vt63Sh5W8wrDpLwlmkb2le_dAOqsdq6DOQYpFwgqDm2YE6qylocCrOmbUVVY4=w806-h540-no" alt="" title="Music Video: Calboy ft. Moneybagg Yo – Unjudge Me"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/19/music-video-calboy-ft-moneybagg-yo-unjudge-me/" rel="bookmark" title="Music Video: Calboy ft. Moneybagg Yo – Unjudge Me">Music Video: Calboy ft. Moneybagg Yo – Unjudge Me</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_15_5cf83b8903b41" data-td_block_id="td_uid_15_5cf83b8903b41"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page ajax-page-disabled" id="next-page-td_uid_15_5cf83b8903b41" data-td_block_id="td_uid_15_5cf83b8903b41"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->

	<div class="comments" id="comments">
            </div> <!-- /.content -->
                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <aside class="widget widget_search"><form method="get" class="td-search-form-widget" action="http://weuponithiphop.info/">
    <div role="search">
        <input class="td-widget-search-input" type="text" value="" name="s" id="s" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit" value="Search" />
    </div>
</form></aside><aside class="widget widget_text">			<div class="textwidget"><h4><strong><span style="color: #8224e3;"><span style="color: #000000;">Listen to</span> <span style="color: #c60000;">WeUpOnItRadio</span> <span style="color: #000000;">Live!</span></span></strong></h4>
<p><span class="cc_streaminfo" data-type="song" data-username="cyclone777">Loading &#8230;</span><br />
<script language="javascript" type="text/javascript" src="https://control.internet-radio.com:2199/system/streaminfo.js"></script><br />
<iframe src="https://tunein.com/embed/player/s292400/" style="width:100%; height:100px;" scrolling="no" frameborder="no"></iframe></p>
</div>
		</aside>
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-sidebar ">
<script type="text/javascript">
var td_screen_width = document.body.clientWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 

<aside class="widget widget_text"><div class="block-title"><span>AUDIOTRAFFICKER:</span></div>			<div class="textwidget"><p><iframe src="https://www.facebook.com/plugins/video.php?href=https%3A%2F%2Fwww.facebook.com%2FAudioTrafficker%2Fvideos%2F326277991409372%2F&#038;show_text=0&#038;width=560" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true" allowFullScreen="true"></iframe></p>
</div>
		</aside><aside class="widget widget_text"><div class="block-title"><span>Nas-T ft. Rumy Da Beast &#038; Modoe &#8211; King Of Thrones</span></div>			<div class="textwidget"><p><iframe src="https://www.youtube.com/embed/1UA00_Wppvc" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
</div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><div aria-live="polite" id="soliloquy-container-30342" class="soliloquy-container soliloquy-transition-fade  soliloquy-theme-classic" style="max-width:960px;max-height:300px;"><ul id="soliloquy-30342" class="soliloquy-slider soliloquy-slides soliloquy-wrap soliloquy-clear"><li aria-hidden="true" class="soliloquy-item soliloquy-item-1 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109673710?productType=812&#038;appearance=1" class="soliloquy-link" title="Revolt Tee" target="_blank"><img id="soliloquy-image-30349" class="soliloquy-image soliloquy-image-1" src="http://weuponithiphop.info/wp-content/uploads/Revolt-Tee.jpg" alt="Revolt Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-2 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/youngongetthiswork?q=I12154011" class="soliloquy-link" title="You Gon Get This Work" target="_blank"><img id="soliloquy-image-30344" class="soliloquy-image soliloquy-image-2" src="http://weuponithiphop.info/wp-content/uploads/You-Gon-Get-This-Work.jpg" alt="You Gon Get This Work" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-3 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/savage+bloody?q=I1014473415" class="soliloquy-link" title="Savage Bloody" target="_blank"><img id="soliloquy-image-30343" class="soliloquy-image soliloquy-image-3" src="http://weuponithiphop.info/wp-content/uploads/Savage-Bloody.jpg" alt="Savage Bloody" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-4 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/can?q=I1011767996" class="soliloquy-link" title="spray" target="_blank"><img id="soliloquy-image-30345" class="soliloquy-image soliloquy-image-4" src="http://weuponithiphop.info/wp-content/uploads/spray.jpg" alt="spray" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-5 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814012" class="soliloquy-link" title="Good Vibes Only 1" target="_blank"><img id="soliloquy-image-30346" class="soliloquy-image soliloquy-image-5" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-1.jpg" alt="Good Vibes Only 1" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-6 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/blessed?q=I12044252" class="soliloquy-link" title="Blessed Tee" target="_blank"><img id="soliloquy-image-30347" class="soliloquy-image soliloquy-image-6" src="http://weuponithiphop.info/wp-content/uploads/Blessed-Tee.jpg" alt="Blessed Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-7 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/trap?q=I1009984243" class="soliloquy-link" title="Trap Tee" target="_blank"><img id="soliloquy-image-30348" class="soliloquy-image soliloquy-image-7" src="http://weuponithiphop.info/wp-content/uploads/Trap-Tee.jpg" alt="Trap Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-8 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/good+vibes+only+birds?q=I1014476779" class="soliloquy-link" title="Good Vibes Only 2" target="_blank"><img id="soliloquy-image-30350" class="soliloquy-image soliloquy-image-8" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-2.jpg" alt="Good Vibes Only 2" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-9 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/all+seeing+eye?q=I11739019" class="soliloquy-link" title="ILLuminati" target="_blank"><img id="soliloquy-image-30351" class="soliloquy-image soliloquy-image-9" src="http://weuponithiphop.info/wp-content/uploads/ILLuminati.jpg" alt="ILLuminati" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-10 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/diamond_skull_1?q=I12527492" class="soliloquy-link" title="Diamond Skull" target="_blank"><img id="soliloquy-image-30352" class="soliloquy-image soliloquy-image-10" src="http://weuponithiphop.info/wp-content/uploads/Diamond-Skull.jpg" alt="Diamond Skull" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-11 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/donuts+doom-A109792920" class="soliloquy-link" title="donunts" target="_blank"><img id="soliloquy-image-30353" class="soliloquy-image soliloquy-image-11" src="http://weuponithiphop.info/wp-content/uploads/donunts.jpg" alt="donunts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-12 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/crime+pays?q=I12067735" class="soliloquy-link" title="Crime Pays" target="_blank"><img id="soliloquy-image-30434" class="soliloquy-image soliloquy-image-12" src="http://weuponithiphop.info/wp-content/uploads/Crime-Pays.jpg" alt="Crime Pays" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-13 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/fuckyoupayme?q=I11550361" class="soliloquy-link" title="Fuck You Pay Me" target="_blank"><img id="soliloquy-image-30436" class="soliloquy-image soliloquy-image-13" src="http://weuponithiphop.info/wp-content/uploads/Fuck-You-Pay-Me.jpg" alt="Fuck You Pay Me" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-14 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814011" class="soliloquy-link" title="savage gold tee" target="_blank"><img id="soliloquy-image-30354" class="soliloquy-image soliloquy-image-14" src="http://weuponithiphop.info/wp-content/uploads/savage-gold-tee.jpg" alt="savage gold tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-15 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/?page=2" class="soliloquy-link" title="fresh-clean-signature-" target="_blank"><img id="soliloquy-image-30437" class="soliloquy-image soliloquy-image-15" src="http://weuponithiphop.info/wp-content/uploads/fresh-clean-signature-.jpg" alt="fresh-clean-signature-" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-16 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/%24teez?q=I1001415610" class="soliloquy-link" title="gold fronts" target="_blank"><img id="soliloquy-image-30355" class="soliloquy-image soliloquy-image-16" src="http://weuponithiphop.info/wp-content/uploads/gold-fronts.jpg" alt="gold fronts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-17 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/soldier?q=I11611241" class="soliloquy-link" title="Swag Soldier" target="_blank"><img id="soliloquy-image-30435" class="soliloquy-image soliloquy-image-17" src="http://weuponithiphop.info/wp-content/uploads/Swag-Soldier.jpg" alt="Swag Soldier" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-18 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/gamer-A7923028?productType=210&#038;appearance=22" class="soliloquy-link" title="gamer" target="_blank"><img id="soliloquy-image-30438" class="soliloquy-image soliloquy-image-18" src="http://weuponithiphop.info/wp-content/uploads/gamer.jpg" alt="gamer" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-19 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/" class="soliloquy-link" title="freshandlogo Square" target="_blank"><img id="soliloquy-image-30356" class="soliloquy-image soliloquy-image-19" src="http://weuponithiphop.info/wp-content/uploads/freshandlogo-Square.jpg" alt="freshandlogo Square" /></a></li></ul></div><noscript><style type="text/css">#soliloquy-container-30342{opacity:1}</style></noscript>
</div>
		</aside>                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->


<!-- Instagram -->



<!-- Footer -->
<div class="td-footer-wrapper td-footer-template-3">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
			    		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span4">
                <div class="td-footer-info"><div class="footer-logo-wrap"><a href="http://weuponithiphop.info/"><img class="td-retina-data" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" alt="" title=""/></a></div><div class="footer-text-wrap"></div><div class="footer-social-wrap td-social-style-2">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div></div>            </div>

            <div class="td-pb-span4">
                <div class="td_block_wrap td_block_8 td_block_widget td_uid_20_5cf83b8913910_rand td-pb-border-top"  data-td-block-uid="td_uid_20_5cf83b8913910" ><script>var block_td_uid_20_5cf83b8913910 = new tdBlock();
block_td_uid_20_5cf83b8913910.id = "td_uid_20_5cf83b8913910";
block_td_uid_20_5cf83b8913910.atts = '{"limit":"7","sort":"jetpack_popular_2","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"POPULAR POSTS","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"#","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_20_5cf83b8913910_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_20_5cf83b8913910.td_column_number = "1";
block_td_uid_20_5cf83b8913910.block_type = "td_block_8";
block_td_uid_20_5cf83b8913910.post_count = "7";
block_td_uid_20_5cf83b8913910.found_posts = "10";
block_td_uid_20_5cf83b8913910.header_color = "#";
block_td_uid_20_5cf83b8913910.ajax_pagination_infinite_stop = "";
block_td_uid_20_5cf83b8913910.max_num_pages = "2";
tdBlocksArray.push(block_td_uid_20_5cf83b8913910);
</script><h4 class="block-title"><span>POPULAR POSTS</span></h4><div id=td_uid_20_5cf83b8913910 class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_7 td_module_wrap td-animation-stack">
        <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/05/new-music-casey-veggies-ft-dom-kennedy-stop-playin/" rel="bookmark" title="New Music: Casey Veggies ft. Dom Kennedy – Stop Playin&#8217;"><img width="100" height="70" class="entry-thumb" src="https://lh3.googleusercontent.com/yKNj40aC0veJicUQjXzkbbpUc_wkaLUvu0Hdzaam40HHDQ4kDjgabmf-dgrcdKozLoUfI5fBL_VjeAuaENqZYPxQ2trC3ZIUBfhmkV5fee1wDjiw8vojjw_xcKrGyhw78L_rTUhLp13ztHehTpljSiGOzb2s8e6NBQUrmkUT6ify9ohFSusmcoFK4Wwx5aAz8x3YLoqzcyieqLVlQ4cnhCl-Ga6gxCeqTAp2lCFJ6yCI9LiEPpV5gbUA-PApVo59PL_QGiO8UhOGxXdfwakbjiaXjuJKwjPo0wUpheriASlULS37sT7qjF1mtDwSy0t3ftvL4cW3sgidXtfwUfLtFuzDeaMdY9t7QH--05n-FJFj47f-zyf-nQ4R7sHS9bo0hyoHXeA0qIgysbFmqcaGWVYDuH1Rr4CrD0kIwee6LbKq3bov2ElGW1xjZUDdNfyvV0DysoHNLmJRjmDR8y7UZmSFLYiMk5sXuzfucCBUZEwrFmNecn2i4SBFGkA-XP4XvQi26Tgq3RYRCSYOfomiIUi3hxKQHuwu81zqDNZ0WZ1MNOQ7MQKz0G9WzNtlfQ-LWLo6xHiNvQu94QsLK5nVmSRTSpQADntVGji-W0Fmp06bpzWECgXwjTsyyWBYwUWcvB2wPbNgM4ZV0ywp3n7IcSG1U1gBmkYW=s796-no" alt="" title="New Music: Casey Veggies ft. Dom Kennedy – Stop Playin&#8217;"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/05/new-music-casey-veggies-ft-dom-kennedy-stop-playin/" rel="bookmark" title="New Music: Casey Veggies ft. Dom Kennedy – Stop Playin&#8217;">New Music: Casey Veggies ft. Dom Kennedy – Stop Playin&#8217;</a></h3>
            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-06-05T07:35:27+00:00" >June 5, 2019</time></span>                            </div>

        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_7 td_module_wrap td-animation-stack">
        <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/05/new-music-bas-ft-jid-fried-rice-72/" rel="bookmark" title="New Music: Bas ft. JID – Fried Rice"><img width="100" height="70" class="entry-thumb" src="https://lh3.googleusercontent.com/tV5wNQXfPu0pc7eK8AWiAjJ616ZXU2rqYwBmkRAH2IaYLGNscx5BadE3Opac2pjks2Ho3vq3_RPxoy2I_aPrRz2xI0TcnOkCVTaLqzCN1ol-j6O1qsTjxJrBhZqDgZJIIzYiMFWFhzh5P1S3gXGJs_fbxvtxN8TmhVB8Ns-pCocZWzYgpKiB60T0f2o-MJEGEnd2cCwPf_NLxoh6sXfYlb_QPIS1U5e8oQkkTRIINPyLXzUlW_W8XtjphjJLFrGqyGze6vb-pHJBHSedQWKeOctW5DZmKgGPCyUvTGEuViA1D97MhGmI2av-nwzkNr9UiW6NxATQgqumNhK71MWHS3hn03eOM5oVbMAxfzZHjt1J_5zwhNSPBzp39wkbxynZF4P13PDo5lLzdoqXIXIwU8Nbmv6nTB0MJaDlEoKMUffqOSbLyKqKc4lnG0lz5yTJoUUOtjRYTjyiBWd_IEFFb2IMEbgOrotLQgOdiVt-rS_Lc3XYdYOIaa2YkUsdCgBWWiaKvSGVv-lnkixiVCJSH9s-o8BsOJfQl1zsw5QmhcXRbYmDJL_pH3hg2qQs3dQTI2mo4CoY74z9uxQiHFNJZr58B2yKs6Q1fqKHuATXYVrHFL2T4oB91vMOCvos-TBgp3rn7Akx6XuSLJlPRdnvH-M8W06AAKEn=s796-no" alt="" title="New Music: Bas ft. JID – Fried Rice"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/05/new-music-bas-ft-jid-fried-rice-72/" rel="bookmark" title="New Music: Bas ft. JID – Fried Rice">New Music: Bas ft. JID – Fried Rice</a></h3>
            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-06-05T06:53:10+00:00" >June 5, 2019</time></span>                            </div>

        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_7 td_module_wrap td-animation-stack">
        <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/04/new-music-the-black-eyed-peas-ft-snoop-dogg-be-nice/" rel="bookmark" title="New Music: The Black Eyed Peas ft. Snoop Dogg – Be Nice"><img width="100" height="70" class="entry-thumb" src="https://lh3.googleusercontent.com/Yah2A6PwWcGVOa-hpkKeHZKIR4Vj5YXptGu6jL4L_2KV3lzviXMNJ6dDFwaAiBN_w0pyzgbox1O6iyNcpJcW4ThOM6jHMHq7zBabyKpZwHx99pSAVU2tX4Z4YRSuCkorGISf-YolnXBc4-J0lh2gGVlsdx8x72D52BWAkOg_anm4_MCSJV-slpBP1LX4muTgZU8JjEwZtDdHqh8H__NPeu0EJltk_ekun8lXirSTqNkwXGD927tvvX-ZjnZPSMdtz6BIWZF6gmruwZfFl-tE4385vQUiUd107Ot1BcZLn7nLcZQK1t_p9j8ZGqR36KmlVIqSSO6-6XjTB2BEl5iK-8eOID8YclfdhlKTju7hv46lY_H3L5zc8XiQArNIBg4uGTZpRkX8Fex5CUa6tYHOir-ESzA5Ms-LE_3FD9jI0mhvOZjTg4Vay45vUj8aINnpvO_NYsm52c362x2oevD6vKlhEulba6M0MPLRjKnMlNJVkdh39op66v4S-WSp-FH5BKHwelb5u-sBmksb6QhRnN3BaotCXS_UZ7q_JPy_mJ3YrRcrieHdG3nRG76JZ7aa34Mjm0r2UBLSmo9LSIk_1SbbBXt78RgYxaJOBRmiscObDCcqeeIjvkbleR64tFt9ePxOKQOLR9cpob2ZaOT86AniWeiFMrpi=s673-no" alt="" title="New Music: The Black Eyed Peas ft. Snoop Dogg – Be Nice"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/04/new-music-the-black-eyed-peas-ft-snoop-dogg-be-nice/" rel="bookmark" title="New Music: The Black Eyed Peas ft. Snoop Dogg – Be Nice">New Music: The Black Eyed Peas ft. Snoop Dogg – Be...</a></h3>
            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-06-04T19:47:33+00:00" >June 4, 2019</time></span>                            </div>

        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_7 td_module_wrap td-animation-stack">
        <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/03/music-video-saweetie-my-type-claws-remix-8547887/" rel="bookmark" title="Music Video: Saweetie – My Type (Claws Remix)"><img width="100" height="70" class="entry-thumb" src="https://lh3.googleusercontent.com/xM6Ql3WsQbTnBSuNiD36jxZkWmg4U2W-cwtiiB-7zbnJTqsNy_tCKuM9yUF3JHyH9pzduIyleiU=w328-h255-no" alt="" title="Music Video: Saweetie – My Type (Claws Remix)"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/03/music-video-saweetie-my-type-claws-remix-8547887/" rel="bookmark" title="Music Video: Saweetie – My Type (Claws Remix)">Music Video: Saweetie – My Type (Claws Remix)</a></h3>
            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-06-03T21:05:27+00:00" >June 3, 2019</time></span>                            </div>

        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_7 td_module_wrap td-animation-stack">
        <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/03/video-footage-of-lil-reese-getting-jumped-robbed-surfaces-reese-responds-857/" rel="bookmark" title="Video: Footage Of Lil Reese Getting Jumped &#038; Robbed Surfaces, Reese Responds"><img width="100" height="70" class="entry-thumb" src="https://lh3.googleusercontent.com/19tfg6l7_5ljT1tdfHKAUfKEvzLho_iNNDjyVdSTRmQXOdODvz5fvX74fJN-dpbS7p_MBk3yF5eu90goh1TKjBqrxx-YNVoeHNj8KHtZoxSt1zCn5yJ26AeRN8q_Y-KE9GmptiMEuIfPQFqO7bjFBCfv-iVWzoY34CstlQucriPLGMeX5TD8fmLk7yuCkMRNb6eC7ZoSEOEtA8A0TecCWwXNqSI-AoJun7erAw7rrQDLzpXDUksnsxMlrlqmAvp0nae-v6xfQUjWBKNgSE-FX4nS3mz0KrAHog5Qzf6PeKoUjp2WS8FVK3wZrKbptMYEFUgPalQM4qMWu352RXHuYBgf2ukaMR-cSXtrso_bJeKyB28_ht3vWj_gyqWd7Do7WivuY9siPPo3Xx3wu9Rtj41U5IwqaqPpeT7oQH2_ldTjowF7my6Q_DhvDfgSk_s4D0vWL-KUta8lTTxtSSNBoIBXRv-kJkFzXvVf0iCTk6GRSvaG-v7YxPZdLMNPsGoRFytC7YSHZeLRWukmh7hWtdWbT3uaA01U1lN7i7A9rRcA3uCGtVWFpM2DFdwurkrgj3QL6ZBx5vy2kD1S_qdWFifzA7Bpb1UV8uJDRH8ddgNGsB_hSpE4COgOz6SfbRS0B6BzeaTXg-DKy48Eo3EELly0PMlyIhRN=w638-h421-no" alt="" title="Video: Footage Of Lil Reese Getting Jumped &#038; Robbed Surfaces, Reese Responds"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/03/video-footage-of-lil-reese-getting-jumped-robbed-surfaces-reese-responds-857/" rel="bookmark" title="Video: Footage Of Lil Reese Getting Jumped &#038; Robbed Surfaces, Reese Responds">Video: Footage Of Lil Reese Getting Jumped &#038; Robbed Surfaces, Reese...</a></h3>
            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-06-03T20:47:06+00:00" >June 3, 2019</time></span>                            </div>

        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_7 td_module_wrap td-animation-stack">
        <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/03/ep-stream-elcamino-lot-and-abraham-89496/" rel="bookmark" title="EP Stream: Elcamino – Lot And Abraham"><img width="100" height="70" class="entry-thumb" src="https://lh3.googleusercontent.com/EVP7DJtqa_5L0ZXJ_l3Mf1CgiNujKWuoleidNfeadw7l33m61C2ekwOAGqtToRUNcqmBWRJpB8_JpKPWchHUxv_tGQZ2p9Od_udGlwUhR49CYPPZLeOxT-sfHfg8Ljn_VrC1RyECe80G3mw4YgAwudpGtz2D7ThjnMQJoNwEh3h2rhmVv8p8GO1L0YC7k_aAC635Yfld_gkfRGSDpkGGzC4NHgvrn_0_6rDCWrHjDGzgWNyfwtWYm3vNSWx5pWnfG-o3B5CPFwPLtd58xOSS99v2RspF5A6yn5-KmWEX1HAC61qeqQhih2e8SR4youUJYpmWIB9Ioqg5nvoxOpmqmSON7A7JZQemtNU51sfvGfPd2eDvDgdu6LK2QWY9ooKGD7MS6yV-GEf5mBDgfA9WlYLqKxnvLunbwOCO4svEAhTFKMVtvKNTu_EDbgUbqQpxz6epQnbVDXuvb5LvKN0dteSaYGzH2kMqICiXrLVD0a_POmH-EjFrvzh4x3aM3kKtJFtt_wrVWdfnGraJa26vZpQO2-EpSFShxtUM3MvFC5W-Y9as3yUd8gncimtRQcL8FStouAFoW3f6fErVj4Ziv5gQvur03Tfv7O6SndjGFTS14mKu29weqef6zBX56sYyPO4xGOWuZwQ3FvRvTI-QkYJ15XN5CdAI=s796-no" alt="" title="EP Stream: Elcamino – Lot And Abraham"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/03/ep-stream-elcamino-lot-and-abraham-89496/" rel="bookmark" title="EP Stream: Elcamino – Lot And Abraham">EP Stream: Elcamino – Lot And Abraham</a></h3>
            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-06-03T19:06:10+00:00" >June 3, 2019</time></span>                            </div>

        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_7 td_module_wrap td-animation-stack">
        <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/30/mixtape-tsu-surf-seven-25-948693e/" rel="bookmark" title="Mixtape: Tsu Surf – Seven 25"><img width="100" height="70" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/Tsu-Surf-Ft.-Benny-The-Butcher-–-Consignment-Prod.-by-AraabMuzik-100x70.jpg" alt="" title="Mixtape: Tsu Surf – Seven 25"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/30/mixtape-tsu-surf-seven-25-948693e/" rel="bookmark" title="Mixtape: Tsu Surf – Seven 25">Mixtape: Tsu Surf – Seven 25</a></h3>
            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-01-30T16:03:44+00:00" >January 30, 2019</time></span>                            </div>

        </div>

        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block -->            </div>

            <div class="td-pb-span4">
                <aside class="widget widget_calendar"><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar">
	<caption>June 2019</caption>
	<thead>
	<tr>
		<th scope="col" title="Sunday">S</th>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
	</tr>
	</thead>

	<tfoot>
	<tr>
		<td colspan="3" id="prev"><a href="http://weuponithiphop.info/2019/05/">&laquo; May</a></td>
		<td class="pad">&nbsp;</td>
		<td colspan="3" id="next" class="pad">&nbsp;</td>
	</tr>
	</tfoot>

	<tbody>
	<tr>
		<td colspan="6" class="pad">&nbsp;</td><td><a href="http://weuponithiphop.info/2019/06/01/" aria-label="Posts published on June 1, 2019">1</a></td>
	</tr>
	<tr>
		<td><a href="http://weuponithiphop.info/2019/06/02/" aria-label="Posts published on June 2, 2019">2</a></td><td><a href="http://weuponithiphop.info/2019/06/03/" aria-label="Posts published on June 3, 2019">3</a></td><td><a href="http://weuponithiphop.info/2019/06/04/" aria-label="Posts published on June 4, 2019">4</a></td><td id="today"><a href="http://weuponithiphop.info/2019/06/05/" aria-label="Posts published on June 5, 2019">5</a></td><td>6</td><td>7</td><td>8</td>
	</tr>
	<tr>
		<td>9</td><td>10</td><td>11</td><td>12</td><td>13</td><td>14</td><td>15</td>
	</tr>
	<tr>
		<td>16</td><td>17</td><td>18</td><td>19</td><td>20</td><td>21</td><td>22</td>
	</tr>
	<tr>
		<td>23</td><td>24</td><td>25</td><td>26</td><td>27</td><td>28</td><td>29</td>
	</tr>
	<tr>
		<td>30</td>
		<td class="pad" colspan="6">&nbsp;</td>
	</tr>
	</tbody>
	</table></div></aside><aside class="widget widget_text">			<div class="textwidget"><div aria-live="polite" id="soliloquy-container-30342" class="soliloquy-container soliloquy-transition-fade  soliloquy-theme-classic" style="max-width:960px;max-height:300px;"><ul id="soliloquy-30342" class="soliloquy-slider soliloquy-slides soliloquy-wrap soliloquy-clear"><li aria-hidden="true" class="soliloquy-item soliloquy-item-1 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109673710?productType=812&#038;appearance=1" class="soliloquy-link" title="Revolt Tee" target="_blank"><img id="soliloquy-image-30349" class="soliloquy-image soliloquy-image-1" src="http://weuponithiphop.info/wp-content/uploads/Revolt-Tee.jpg" alt="Revolt Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-2 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/youngongetthiswork?q=I12154011" class="soliloquy-link" title="You Gon Get This Work" target="_blank"><img id="soliloquy-image-30344" class="soliloquy-image soliloquy-image-2" src="http://weuponithiphop.info/wp-content/uploads/You-Gon-Get-This-Work.jpg" alt="You Gon Get This Work" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-3 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/savage+bloody?q=I1014473415" class="soliloquy-link" title="Savage Bloody" target="_blank"><img id="soliloquy-image-30343" class="soliloquy-image soliloquy-image-3" src="http://weuponithiphop.info/wp-content/uploads/Savage-Bloody.jpg" alt="Savage Bloody" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-4 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/can?q=I1011767996" class="soliloquy-link" title="spray" target="_blank"><img id="soliloquy-image-30345" class="soliloquy-image soliloquy-image-4" src="http://weuponithiphop.info/wp-content/uploads/spray.jpg" alt="spray" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-5 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814012" class="soliloquy-link" title="Good Vibes Only 1" target="_blank"><img id="soliloquy-image-30346" class="soliloquy-image soliloquy-image-5" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-1.jpg" alt="Good Vibes Only 1" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-6 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/blessed?q=I12044252" class="soliloquy-link" title="Blessed Tee" target="_blank"><img id="soliloquy-image-30347" class="soliloquy-image soliloquy-image-6" src="http://weuponithiphop.info/wp-content/uploads/Blessed-Tee.jpg" alt="Blessed Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-7 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/trap?q=I1009984243" class="soliloquy-link" title="Trap Tee" target="_blank"><img id="soliloquy-image-30348" class="soliloquy-image soliloquy-image-7" src="http://weuponithiphop.info/wp-content/uploads/Trap-Tee.jpg" alt="Trap Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-8 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/good+vibes+only+birds?q=I1014476779" class="soliloquy-link" title="Good Vibes Only 2" target="_blank"><img id="soliloquy-image-30350" class="soliloquy-image soliloquy-image-8" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-2.jpg" alt="Good Vibes Only 2" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-9 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/all+seeing+eye?q=I11739019" class="soliloquy-link" title="ILLuminati" target="_blank"><img id="soliloquy-image-30351" class="soliloquy-image soliloquy-image-9" src="http://weuponithiphop.info/wp-content/uploads/ILLuminati.jpg" alt="ILLuminati" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-10 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/diamond_skull_1?q=I12527492" class="soliloquy-link" title="Diamond Skull" target="_blank"><img id="soliloquy-image-30352" class="soliloquy-image soliloquy-image-10" src="http://weuponithiphop.info/wp-content/uploads/Diamond-Skull.jpg" alt="Diamond Skull" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-11 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/donuts+doom-A109792920" class="soliloquy-link" title="donunts" target="_blank"><img id="soliloquy-image-30353" class="soliloquy-image soliloquy-image-11" src="http://weuponithiphop.info/wp-content/uploads/donunts.jpg" alt="donunts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-12 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/crime+pays?q=I12067735" class="soliloquy-link" title="Crime Pays" target="_blank"><img id="soliloquy-image-30434" class="soliloquy-image soliloquy-image-12" src="http://weuponithiphop.info/wp-content/uploads/Crime-Pays.jpg" alt="Crime Pays" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-13 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/fuckyoupayme?q=I11550361" class="soliloquy-link" title="Fuck You Pay Me" target="_blank"><img id="soliloquy-image-30436" class="soliloquy-image soliloquy-image-13" src="http://weuponithiphop.info/wp-content/uploads/Fuck-You-Pay-Me.jpg" alt="Fuck You Pay Me" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-14 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814011" class="soliloquy-link" title="savage gold tee" target="_blank"><img id="soliloquy-image-30354" class="soliloquy-image soliloquy-image-14" src="http://weuponithiphop.info/wp-content/uploads/savage-gold-tee.jpg" alt="savage gold tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-15 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/?page=2" class="soliloquy-link" title="fresh-clean-signature-" target="_blank"><img id="soliloquy-image-30437" class="soliloquy-image soliloquy-image-15" src="http://weuponithiphop.info/wp-content/uploads/fresh-clean-signature-.jpg" alt="fresh-clean-signature-" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-16 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/%24teez?q=I1001415610" class="soliloquy-link" title="gold fronts" target="_blank"><img id="soliloquy-image-30355" class="soliloquy-image soliloquy-image-16" src="http://weuponithiphop.info/wp-content/uploads/gold-fronts.jpg" alt="gold fronts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-17 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/soldier?q=I11611241" class="soliloquy-link" title="Swag Soldier" target="_blank"><img id="soliloquy-image-30435" class="soliloquy-image soliloquy-image-17" src="http://weuponithiphop.info/wp-content/uploads/Swag-Soldier.jpg" alt="Swag Soldier" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-18 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/gamer-A7923028?productType=210&#038;appearance=22" class="soliloquy-link" title="gamer" target="_blank"><img id="soliloquy-image-30438" class="soliloquy-image soliloquy-image-18" src="http://weuponithiphop.info/wp-content/uploads/gamer.jpg" alt="gamer" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-19 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/" class="soliloquy-link" title="freshandlogo Square" target="_blank"><img id="soliloquy-image-30356" class="soliloquy-image soliloquy-image-19" src="http://weuponithiphop.info/wp-content/uploads/freshandlogo-Square.jpg" alt="freshandlogo Square" /></a></li></ul></div><noscript><style type="text/css">#soliloquy-container-30342{opacity:1}</style></noscript>
</div>
		</aside>            </div>
        </div>
    </div>
</div>

<!-- Sub Footer -->
    <div class="td-sub-footer-container">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span7 td-sub-footer-menu">
                        <div class="menu-top-menu-container"><ul id="menu-top-menu-2" class="td-subfooter-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-mega-menu menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_21_5cf83b892a630_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_21_5cf83b892a630" ><script>var block_td_uid_21_5cf83b892a630 = new tdBlock();
block_td_uid_21_5cf83b892a630.id = "td_uid_21_5cf83b892a630";
block_td_uid_21_5cf83b892a630.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"43","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_21_5cf83b892a630_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_21_5cf83b892a630.td_column_number = "3";
block_td_uid_21_5cf83b892a630.block_type = "td_block_mega_menu";
block_td_uid_21_5cf83b892a630.post_count = "5";
block_td_uid_21_5cf83b892a630.found_posts = "1937";
block_td_uid_21_5cf83b892a630.header_color = "";
block_td_uid_21_5cf83b892a630.ajax_pagination_infinite_stop = "";
block_td_uid_21_5cf83b892a630.max_num_pages = "388";
tdBlocksArray.push(block_td_uid_21_5cf83b892a630);
</script><div id=td_uid_21_5cf83b892a630 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/05/new-music-ozuna-amor-genuino-73/" rel="bookmark" title="New Music: Ozuna – Amor Genuino"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/ThISOA_XYX48rU5cVpVuwkuELpB7z0AYEqmIpg289DHLASWd9bMR7GpVvllNKOB4DhMKFaDA0ddU1N3k_7mw2CzbClPO0pEJNCn5f4u6x7izWHuG3Vjq2SdhoSzNVrwF0R4R-Pb7RX9qXePKFTDqI8DgIgFVG7SwINVFK_JkuBCjR8TPoP8y8ckV-TPM40lZJD6L--ecoCqLS4OIGOojT6HrAnyHXkSJsws9f_6Hr0S6Jh8J9fCueebvrd3av0oX2rXo0sjXwlH-n2oEPvqUPHWN0mbE4M6R2z_6DQuhZUZUMdlf8titQGGGeZZUbzsagyus_icwU9dMTTao9WhC1uJWqiAX5GqU1TElevefSSicxHwOIBk8vK4lWmo_SuhUH-0u-llywBq_M2HyJ0D0t9L1zLZo7y8tw3ikGta3Vd3Svmb9dTJubI4c1Y8qemLlhXuugOPeW8CXl5LCpS0AfgNe0dCqoSbN_86pfThe3sQI0wWus4wnDlOpRhNr0N-V1Q2Dtw3QVKTREge8jBVtBy3jBYMlo3YKErkmr16vMy2bBiAA4n1-t_nBsnKzJE4DxJIGgIvFQUcT6O3wipscvPgYlZue_8lP4p72m1TNvI_yBI4PG_83-6CEJpu3DkTmQysQkf9WT29q_l08Rw6DAfFDmidpHbJs=s673-no" alt="" title="New Music: Ozuna – Amor Genuino"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/05/new-music-ozuna-amor-genuino-73/" rel="bookmark" title="New Music: Ozuna – Amor Genuino">New Music: Ozuna – Amor Genuino</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/05/new-music-aj-tracey-ft-general-levy-novelist-labroke-grove-remix-94/" rel="bookmark" title="New Music: AJ Tracey ft. General Levy &#038; Novelist – Labroke Grove (Remix)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/n5iN_29M1N1nmQgTsLbNUesv3U0U3m7qrtC15EBWY8XN_kWIZay8LWVFzHTfov-64VGTBNgACgU76qmTp70LBNcOiLUzDTcKm43n3dBzFQtCVYVEZq6QBVG7REXtjN5da4U5LUw7415yvgjQZfseT3JH4JQZaeik9LcHkydCtiYor_tj3xOj1NAfaafUZFrTUam7SJ-XGlfxtYqQu9DzXdvFvlxaPVPsqAk6EEdpaiWrE-Q-eDxcQvMwu1wkKy7EGJH_iQPhIbfbLlXJGBGVYH4FXoxC2QkawhiWIcWPU8g6J0KX21bfJNaoFGB1xGm6w5nflfW2CZJmv_VYeWuE9emIFVZ-lYZ6f9rS6DQjBcuHhtgRUi1qv0oFExIppZ2o1pQ16hfqkRb3th_R_BzbITDtzrnKxwP7G48n4lb9MwzEda1HBAZk1OHwWJlT_W2DrdiKD89SHeaT_zBj_Pf7ebUrOEn570P-iDHIkGrjrUQL9_4vVqP0rMRqMxgQVR1JyHSF3jG6zfvhLs6pIIEQRs0_w_YRu1uUdRucni6auOn8sNPgxYAcmIsNOMWWaJKXZkfQSF227BCX37upAs8XOAhRYG05aJOKmL1ObXFIkR1B_kH19oXA9Szw2L98o1vcjNSe6ZggC7PedNbtY_neOVBV2v7Rkb05=s673-no" alt="" title="New Music: AJ Tracey ft. General Levy &#038; Novelist – Labroke Grove (Remix)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/05/new-music-aj-tracey-ft-general-levy-novelist-labroke-grove-remix-94/" rel="bookmark" title="New Music: AJ Tracey ft. General Levy &#038; Novelist – Labroke Grove (Remix)">New Music: AJ Tracey ft. General Levy &#038; Novelist – Labroke&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/05/new-music-casey-veggies-ft-dom-kennedy-stop-playin/" rel="bookmark" title="New Music: Casey Veggies ft. Dom Kennedy – Stop Playin&#8217;"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/yKNj40aC0veJicUQjXzkbbpUc_wkaLUvu0Hdzaam40HHDQ4kDjgabmf-dgrcdKozLoUfI5fBL_VjeAuaENqZYPxQ2trC3ZIUBfhmkV5fee1wDjiw8vojjw_xcKrGyhw78L_rTUhLp13ztHehTpljSiGOzb2s8e6NBQUrmkUT6ify9ohFSusmcoFK4Wwx5aAz8x3YLoqzcyieqLVlQ4cnhCl-Ga6gxCeqTAp2lCFJ6yCI9LiEPpV5gbUA-PApVo59PL_QGiO8UhOGxXdfwakbjiaXjuJKwjPo0wUpheriASlULS37sT7qjF1mtDwSy0t3ftvL4cW3sgidXtfwUfLtFuzDeaMdY9t7QH--05n-FJFj47f-zyf-nQ4R7sHS9bo0hyoHXeA0qIgysbFmqcaGWVYDuH1Rr4CrD0kIwee6LbKq3bov2ElGW1xjZUDdNfyvV0DysoHNLmJRjmDR8y7UZmSFLYiMk5sXuzfucCBUZEwrFmNecn2i4SBFGkA-XP4XvQi26Tgq3RYRCSYOfomiIUi3hxKQHuwu81zqDNZ0WZ1MNOQ7MQKz0G9WzNtlfQ-LWLo6xHiNvQu94QsLK5nVmSRTSpQADntVGji-W0Fmp06bpzWECgXwjTsyyWBYwUWcvB2wPbNgM4ZV0ywp3n7IcSG1U1gBmkYW=s796-no" alt="" title="New Music: Casey Veggies ft. Dom Kennedy – Stop Playin&#8217;"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/05/new-music-casey-veggies-ft-dom-kennedy-stop-playin/" rel="bookmark" title="New Music: Casey Veggies ft. Dom Kennedy – Stop Playin&#8217;">New Music: Casey Veggies ft. Dom Kennedy – Stop Playin&#8217;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/05/new-music-kembe-x-ft-jay-rock-ab-soul-zacari-raised-a-fool/" rel="bookmark" title="New Music: Kembe X ft. Jay Rock, Ab-Soul &#038; Zacari – Raised A Fool"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/vm7gyzvA-KuBLEfw0vCX-Z6WaSXSHaq6g-aCvFZqYaexqjNPOpOcvH-1WJSyknzNQA9zUue3eV0=s328-no" alt="" title="New Music: Kembe X ft. Jay Rock, Ab-Soul &#038; Zacari – Raised A Fool"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/05/new-music-kembe-x-ft-jay-rock-ab-soul-zacari-raised-a-fool/" rel="bookmark" title="New Music: Kembe X ft. Jay Rock, Ab-Soul &#038; Zacari – Raised A Fool">New Music: Kembe X ft. Jay Rock, Ab-Soul &#038; Zacari –&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/05/new-music-t-wayne-icey/" rel="bookmark" title="New Music: T-Wayne – Icey"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/ZYgNpjUA1lOGAmIY4ER81sU-EElSH04UhUNWhcHY9XVxhyp-yCn2xsi63C-ZP_HYdPxUoc1mFTw0TF9J689GoSPfbrzghvzWu5WvLVXfexb7bIVXX44Srw0UezTtvYAJlsR6c2Dn59LcsFyhp2yR1pe-GoclSdvup3eUwpEBwVHeu7C83ldXMAInUwKHrhKG4XR1hMPl1-6hsvO2rtUPasajtUoHZCdMZGr8-tnpmQDcxl3NCMOUOZpRRqXF79190TiU8oc5GM48SX0QrUpoR0M_HEzxY9-hMBo4up4VL0-hklS41va94jqonOibGI73w7xM1wSuvQ0ZTPZk-vTYTOXxsz05HI2NRFbSAWo_FypUbHttbRMlqB-ZGnldOU2pSp6UOR0lfmuQ35Np-Zc4cMAnGMw5iRQMRHnruQEa17iosXy9eYp-75kujra5XqPANy202L9-1TAt-IcsHFn0y4LgvTimaJgGZ26yNWUl7Pgdo3zbdAVz-b0HMX4TZt28SoZzboYrA4A_-5XvZglblSiCl_abL_xjmEIdgCkqV44hKlP-WKcRXJ8mvjoP-6kNwuysSgk9tJIy3AnG49RcmoZmVYzL0ZUMfQu2SVtgl2ZtVIS6gTTZnDLifC4T1clYX5IWlu47TUljU2dxDiYG_2HQhz-90ngc=w620-h619-no" alt="" title="New Music: T-Wayne – Icey"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/05/new-music-t-wayne-icey/" rel="bookmark" title="New Music: T-Wayne – Icey">New Music: T-Wayne – Icey</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_21_5cf83b892a630" data-td_block_id="td_uid_21_5cf83b892a630"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_21_5cf83b892a630" data-td_block_id="td_uid_21_5cf83b892a630"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_22_5cf83b8934742_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_22_5cf83b8934742" ><script>var block_td_uid_22_5cf83b8934742 = new tdBlock();
block_td_uid_22_5cf83b8934742.id = "td_uid_22_5cf83b8934742";
block_td_uid_22_5cf83b8934742.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"97","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_22_5cf83b8934742_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_22_5cf83b8934742.td_column_number = "3";
block_td_uid_22_5cf83b8934742.block_type = "td_block_mega_menu";
block_td_uid_22_5cf83b8934742.post_count = "5";
block_td_uid_22_5cf83b8934742.found_posts = "739";
block_td_uid_22_5cf83b8934742.header_color = "";
block_td_uid_22_5cf83b8934742.ajax_pagination_infinite_stop = "";
block_td_uid_22_5cf83b8934742.max_num_pages = "148";
tdBlocksArray.push(block_td_uid_22_5cf83b8934742);
</script><div id=td_uid_22_5cf83b8934742 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/05/ep-stream-valee-runnin-rich/" rel="bookmark" title="EP Stream: Valee – Runnin’ Rich"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/BAJeOe4Y3AA3VRyPfASpow3VPPv8YE9lujg6W4BI-OyUTaD3rkSmIMXLYU7mVtVbSqFlOhKEBgtw-DRsKwJ-xHWwP_I6XDfZHrMhBTvYY1BmZU8uC5PMM7I4ZuUyX4l6b5gj7xDDSzrKeN5FG7bJvT5FW7ZkLNrxuU_9PIE5ENV-Dq03u5B6qam-U9UVYFB1i2u6nbWKgHhSrVjjQiuKHqKtR8WFyXaNm54Kr8EJm1xu1oydeNSjh0djf97f1lz5WXMZRvXPwzLP8DwV-Z_9pyO-unuBr8SipFR_PWCvlq08-5kxpUy8w-VPo0bHmT0t3VBmcMOMC8ruVgrjA5Lm0uWUAWLbIJlq_RepCr8VZsy8umzUSoYCthhgnOUqD03f21O4b_vxxoqAgcDou22EPfKWlZycaQoiVknF6wLwR6mG5YhEIQmvNvQ0QLqCiTiiIMNRtd6hnTkZtK4zXDCgfyLxXlhtpBR9iIyuV4u5_fa-GVodBIDnaiQkQ4-ujr5yO55LTP9HMT2rAHgF6FHry9xmTRLW1fFve3BYL1ieAPx6B2SYiXSFcxyEFx86XogbkvXWDwDcsOATraPBAdypjPiH1WhjoI4J0N_OliwI0c4Ii8_WNoAXZosiAiDvpkRFg1J8rLIT8V2cVoJtFEyg64pFB1s7g79o=s620-no" alt="" title="EP Stream: Valee – Runnin’ Rich"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/05/ep-stream-valee-runnin-rich/" rel="bookmark" title="EP Stream: Valee – Runnin’ Rich">EP Stream: Valee – Runnin’ Rich</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/04/album-stream-onyx-100-mad/" rel="bookmark" title="Album Stream: Onyx – 100 MAD"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/82Pe5ze-oQh-YwTxwdiCKj7b5JI1wRNyU4a0LwUrl2vJ79_CbnF8Bvxcdep5hXu3Sq4ag3dsNWGWYVRMG1AXtwOat7sYiKikC-8tGK04_xc6fZ5Q55NgJhEmcC99PzpgWdthuy1tV4MAJMvZVMVCmQ_4-g0sEm2Va4d20Iv8bsCbNdvqgMCipNzswpLrNvcCKZAN9pNC1oG6ehduZ9yeL1tWOnLev2Y6oN_HUPamsYSu6cyODdwPWj78Dq18xN1x6xHMSZFUbCTnHqsf9iGFWsL0xl7r1OkajsnWqMWUJ4MWE_aYUVtY20fzSwajyUrdttw-fCkUzRFhAAQ-rGgLiG4v3aZa9X53HCN6YnAymYOi510wlXc4XuCu8S1qxHqV03JKTJMg7ezhpe5-G6UHfG5l591soR-DAiUHkUxhk1YnY7qxVHfTDzNpq1VTSoQP3A7BhpAK7jli4ZcZz700higqjRYC04J1QL20Jg3K82oTBgLEh9WBeCVgB35Wx3xdbYQtJxjUUL8yj-dKQ0PLvsQP8E7fmYnB_EpTqIguJeXhd3zVW8-KfllBa6GLQEC8gRsjbE3b4p3Odw1ugkqQIhjeF3CrSrA9EnK2gdxt7NUMKFTV2JRmVpMXAV_Q-1V82RjqT9qJ30aiT3rJcGZvzj8eKEW-kbRM=s796-no" alt="" title="Album Stream: Onyx – 100 MAD"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/04/album-stream-onyx-100-mad/" rel="bookmark" title="Album Stream: Onyx – 100 MAD">Album Stream: Onyx – 100 MAD</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/03/ep-stream-elcamino-lot-and-abraham-89496/" rel="bookmark" title="EP Stream: Elcamino – Lot And Abraham"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/EVP7DJtqa_5L0ZXJ_l3Mf1CgiNujKWuoleidNfeadw7l33m61C2ekwOAGqtToRUNcqmBWRJpB8_JpKPWchHUxv_tGQZ2p9Od_udGlwUhR49CYPPZLeOxT-sfHfg8Ljn_VrC1RyECe80G3mw4YgAwudpGtz2D7ThjnMQJoNwEh3h2rhmVv8p8GO1L0YC7k_aAC635Yfld_gkfRGSDpkGGzC4NHgvrn_0_6rDCWrHjDGzgWNyfwtWYm3vNSWx5pWnfG-o3B5CPFwPLtd58xOSS99v2RspF5A6yn5-KmWEX1HAC61qeqQhih2e8SR4youUJYpmWIB9Ioqg5nvoxOpmqmSON7A7JZQemtNU51sfvGfPd2eDvDgdu6LK2QWY9ooKGD7MS6yV-GEf5mBDgfA9WlYLqKxnvLunbwOCO4svEAhTFKMVtvKNTu_EDbgUbqQpxz6epQnbVDXuvb5LvKN0dteSaYGzH2kMqICiXrLVD0a_POmH-EjFrvzh4x3aM3kKtJFtt_wrVWdfnGraJa26vZpQO2-EpSFShxtUM3MvFC5W-Y9as3yUd8gncimtRQcL8FStouAFoW3f6fErVj4Ziv5gQvur03Tfv7O6SndjGFTS14mKu29weqef6zBX56sYyPO4xGOWuZwQ3FvRvTI-QkYJ15XN5CdAI=s796-no" alt="" title="EP Stream: Elcamino – Lot And Abraham"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/03/ep-stream-elcamino-lot-and-abraham-89496/" rel="bookmark" title="EP Stream: Elcamino – Lot And Abraham">EP Stream: Elcamino – Lot And Abraham</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/02/ep-stream-calboy-wildboy/" rel="bookmark" title="EP Stream: Calboy – Wildboy"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/UiMwMZqsmcOX6rq6uURUzbyQDIWWT1jxwYnCqbqSKLp2xThgiOw0NYtUqosu5ybP7r6YVM1YDKDZmEVcbu32sCmjonZAK9VqHyO6UvjgXHjMjzZNgm6OXr5evuleJ6n5CeppUmyL_E99WlC2rkDjjHv1WrX9qV-41sHQrX7uXoJn4LPUK66ic6WigbsvIXOXfw_sGHZp14vy5g41S2dVuXcRUIFWs1XM7kjS9as6Q3BmMZhioP9RQIjpZKUjwTN0idNj62rGI6o21OZLhLRBhHJDqN3BDcMK5_5R4el_67-VG0Bcqz9ETswejM4A_D8PX6VHn4HcFQ_U5C7PfEuJdiQCBW6EpAfMwT9Rs7vzxBKVvL4x8HqSEXL1WO9Lu7z_6c1FbmLToT7zgQFy9N4E9DIn7UYyVafhYFyIhCBf1Tf2UCBYqvGuC8_4K69mMerGrP-wk367jldS2pODWUNYE-SBPAXDBw5xtIJcYyyUdAkkBV6pJKM5BD4VPOw_7--RcmaL8B19lAmObghiLtLK1YIclG6jQBpBkFJdPUX0elwvgxJ-NjPRPcWjGzLe3CiPjHUFBLsLzeF5qF7aqfyjVjxjToRu8ozx_qB4qLvssXH4ARidK8KzbdEfhAWdSD_4VIXoOSd3GvUwR3FHf4DzQ-EtFdylYtHN=s673-no" alt="" title="EP Stream: Calboy – Wildboy"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/02/ep-stream-calboy-wildboy/" rel="bookmark" title="EP Stream: Calboy – Wildboy">EP Stream: Calboy – Wildboy</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/02/music-video-oncue-i-hate-me-too-846746/" rel="bookmark" title="Music Video: OnCue – I Hate Me Too"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/poSi6dzYaXtmyxdk1M5VBb8REpV4zmrT0_8edb2mz3YkBW47APXn9uFY39kGX5kC3FiBQP-XRPM60y0uxgEflcpQZ7nsb3ufK0O3xNAo-p5L2t511vFHxPcWeWxcL3WPPMYhv8ud3rl5i9sa2CbB9DWUqXuPIOXVJxgLX7rmlo4Nr7en41KPHDjnxKBbQqKvztj7JryV_w2FiDq8mAtf1ejtUjsMjp3Du2IhFbBVgoO8gsZZVrgBzfBYqAV30LLtCucdwYAUqROMDHCUPVJt_a6ntWuVLkUlZ3FCVjAhLX6DUBSXwOzXtE1al3oMjZcRQUVZ2A_dKyBR5r2BOm0euGT8gGwLitWBq_ooZ8s6-HRRie5MPMMlK0BGYVNeRhV8608B00EAnhHzP5R26g8G7J9bGkFCdxrZ61shVTCbTgKgfrRtO0prL7__yfMcTWHTUKJpwgMhgSiz_Ul2xPaN8j4Ihuaql9V8WCRL43cipeCCypH2BrTbMZmOMyIDn3XVYEOJ9FffUxc6oGJU_4nsNZ_oT5n7opnpDUJKp03N2N8MT-TK6B8mer58_2r7In1wdPkKUPi6aS_6fHmjLdHmZg_j8UuA02M36XjfkbL45t0mEr9iDaSfYn6FhuIIl6QIU_DLjbJkAmCQrV1MNkEty8hgAcdnou4R=s673-no" alt="" title="Music Video: OnCue – I Hate Me Too"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/02/music-video-oncue-i-hate-me-too-846746/" rel="bookmark" title="Music Video: OnCue – I Hate Me Too">Music Video: OnCue – I Hate Me Too</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_22_5cf83b8934742" data-td_block_id="td_uid_22_5cf83b8934742"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_22_5cf83b8934742" data-td_block_id="td_uid_22_5cf83b8934742"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_23_5cf83b893c105_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_23_5cf83b893c105" ><script>var block_td_uid_23_5cf83b893c105 = new tdBlock();
block_td_uid_23_5cf83b893c105.id = "td_uid_23_5cf83b893c105";
block_td_uid_23_5cf83b893c105.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_23_5cf83b893c105_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_23_5cf83b893c105.td_column_number = "3";
block_td_uid_23_5cf83b893c105.block_type = "td_block_mega_menu";
block_td_uid_23_5cf83b893c105.post_count = "5";
block_td_uid_23_5cf83b893c105.found_posts = "1944";
block_td_uid_23_5cf83b893c105.header_color = "";
block_td_uid_23_5cf83b893c105.ajax_pagination_infinite_stop = "";
block_td_uid_23_5cf83b893c105.max_num_pages = "389";
tdBlocksArray.push(block_td_uid_23_5cf83b893c105);
</script><div id=td_uid_23_5cf83b893c105 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/05/music-video-tyga-ft-j-balvin-chris-brown-haute/" rel="bookmark" title="Music Video: Tyga ft. J Balvin &#038; Chris Brown – Haute"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/G5zvOPK30-xht9L8Z1jT6OViP0xIwc9GqHAzJRpOAQJCeluicWHH4k6YfEjHA-NpNtFhXZy5ct_QGQ1doGB7wX2m7REo7yeJtbBeY4djPFa07jFL288epFYloB4RhpZoa2LmsFJPDBR4MxWgDSaOHTKCC8LXA_p3D1LJIyxfhXzAr-y-kVHA_5I0epnIWFFUTYn_K8eqSb0nB3VEeqwgtG40xV1wjjDK3uKcwTlA5IjTEEUKjnZFjpB8FW51xKPDHMIHCwZtcF9M3iqTFxFY_U7PguJup8R4ojRM9JqtFQMJcuXl11nzxvtWu8s25bAl5bXmliNAugaAF0jfYeqQDr2nAIUSRsNh7xgcUxEEQA-LxUZTId4WJL3qlH0r-6eBc65TkyYWvECDsQqM5DSKXzEtYbJysNgh80IJl3NWgst-na2Eq2kr_-A8jpeY2wMGQFrXOzr3LhV1EpLzT7Wr1F9e9tQEpcD7oTs6QCp1juuB-8mG68hCvgP-9yF9iQieJZgvz7vjr3xOTGazyfxrSjfaDyw1IXPKuvvv9CQugCojcr-OfR16Q_o9fAbssUX45lXYWwI4-TjKI8YABqTHbk_JJwjuDOzrguOtXCnsMeRK0_-0vESyQjWLGxfQMTQyEqdWPIAIDXpIq3a7gEGwbdZ7mSLCEFM8=w1046-h446-no" alt="" title="Music Video: Tyga ft. J Balvin &#038; Chris Brown – Haute"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/05/music-video-tyga-ft-j-balvin-chris-brown-haute/" rel="bookmark" title="Music Video: Tyga ft. J Balvin &#038; Chris Brown – Haute">Music Video: Tyga ft. J Balvin &#038; Chris Brown – Haute</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/05/music-video-lil-gnar-ft-lil-skies-craig-xen-death-note/" rel="bookmark" title="Music Video: Lil Gnar ft. Lil Skies &#038; Craig Xen – Death Note"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4FyzFdm-RXe-HxnAUtJx6tjLSnZzcaO8Vb5HT31KMRLiWLhuWHpvLREe9GZeCb_kenuHrtqDR_nQbKN9s8EfN8K1-lZ9x1e3RUbwlYLyx8SKxR3Pg6ZFfPOf7opVsyy1VDm0wyYPH5xZoB_uY-tAKzPqt7P4f71tUbQHHX7P5CFrNYN86yBFtf0LlR_tcRelxZwLo1p5NhaTPWgi4jqQoX1vglwNpCRrygoLs3HUhil-B8hMc5egJCixJxNg16uAX2ksn02x5KzstF6CP9mDDQtZ9Cq9rI9zIdfRV3c1a7ughDDZyXgZ_dPc9PYpcEWz2w6DgmxlAjiU-y4NRhgUWuaJnwXTWGwfNC-OrazTZuFJ0fnygyWqbf0KRNatHcRgRHzGTaJW_62l1K7WRjyg6zHQXDA1SkkAp1qQGhosipXKKr3nsRkfKXrTm-a3UazJO6u2ny9-zbKzeCWssevNjE4uix-w8D_SIszxrwM-znjcF-a1W-II4OHpe8CTXvn8nXxcvaxz4Kqj_BQVOapRoc_nabAhg9uY_N8y9435KXCmF6bARdGzCOaZRepdcn_GykRGo9RPyFWho3zcIk1k2s7l7ab8-PYUdRru9R9PiTJwJ2nbTVXAW3dgAhFPDqTuxRzx6q0ZJ5izROU09z3uISjepCMaTLok=w920-h456-no" alt="" title="Music Video: Lil Gnar ft. Lil Skies &#038; Craig Xen – Death Note"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/05/music-video-lil-gnar-ft-lil-skies-craig-xen-death-note/" rel="bookmark" title="Music Video: Lil Gnar ft. Lil Skies &#038; Craig Xen – Death Note">Music Video: Lil Gnar ft. Lil Skies &#038; Craig Xen –&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/05/music-video-locksmith-on-god-519/" rel="bookmark" title="Music Video: Locksmith – On God"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/-JlrhxLJvSeQEAELq0S9fKc8Jl7APrOVk_zFSbiI9UPn8JXFLKLYPlj6ps19To-OvHa9WwXZCZtDZLSt8h3e4a1hLg1VgjJyGht7RF0Ukj8ll42UP_57drWZ5qE_UWyeqWQp45l6cV6C3X66w0GkpjZHyZDaAnIgjsFJkyhFrWnFAw7yUYsQ_fOVvbfFhsaf9dwEeIFTqYMuXrT_SsPOX-960GGpCaA3pRQqnHFeuSbsnLp00paz8yvopDdFcf0Z7ocOsywnxuMtmt9c32wNRrhhae83CzQWVNJoYR92rza_VZz4myFfVjI8nPWDJnmNgx286Wnrdr0y2NsPXuMzuQ7vtXv84X_xjc429FePnrGhIe9gyNEQZSTX4VkJJISDW750YQar9A6Di9ND1TrXSy7TDvgomSC-3HIfHy4XIT2hZ6Iu9YkdgH9Ohn_6X64FXlT46pDeyjuRrvHzXQoxNU933Dx2PXXK9skQf4CAONq4He8qKrvJK-cLvtn345liNmZ1nbCzrPWfA3q3JlIIvIXm30og6b35M8X87dfwd4xqGsWgxMb4GF48YLAZ4jHckNET-q-wB9reh4QQSpvlSxgSicIskFIwBqQJ6ShMBxqT8N5qARPY-aI-Nub3-NUS803d7ysDvzsLjqgQWie0m1TBpAUbruw2=w754-h457-no" alt="" title="Music Video: Locksmith – On God"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/05/music-video-locksmith-on-god-519/" rel="bookmark" title="Music Video: Locksmith – On God">Music Video: Locksmith – On God</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/05/music-video-meek-mill-oodles-onoodles-babies-9/" rel="bookmark" title="Music Video: Meek Mill – Oodles O’Noodles Babies"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/x2P8w6tIjF0NDj-cLK-1OwzMxSQAQVhhIOJqjjhEibReQwZYTj48OJuWq0zLM5u1sLM_bZqimqGv1-4YAt5BfTNnzVu_6c0bbai2NMh5IDs8RGQ6RvmRne70_mIMdd7_LCzVpuEiOWhnOQkgpk4VnmDh6EWhSeeLBHkle4vFZauHavhjMKr-g7UvKZGpq2nGkbfUT6qqoAamUu0OXZIyESEu3L1TxujETar9hiUgOZNNsjz19aTaF_CnHkugIOFc5iWSgVnbXwvgYB1-ddKokhWZ62FyJZiddIA72XheaOUuUehKSZEQydm-5gNFvy_QnSt12HzcutFVDPnA2Ki6AUNoSbQwru_JoyTTNZZlKNcIqX0B7wExy_lCqG6MlgdevWOPEiSZzmprwnlPJJTNpuJcvcgjm4BTg9StO6aGQasZob2K2pp2-nIa5qwwb5Mt7GY5OKP0vgCbfcHKxoFHaha4k4FV8wL5UovyU2L6VHEOYeSamuFQgHlC2EC_k69ZDPKzGdsM0HzwcMtAzzVpU4ooiQKZ8ZKP5qqHyXPgR9ZGGs7D35Yb0QFxQ8Dju5Val9d8VUXdTUtNlTGuqGEqBk4Xsv3nk_yGuxUUQfu2ZshAqO3Aa00geouzCkQK3lPPhEiWzQWX0Sv6OalNWI-Qd0fDu0mumX21=w799-h454-no" alt="" title="Music Video: Meek Mill – Oodles O’Noodles Babies"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/05/music-video-meek-mill-oodles-onoodles-babies-9/" rel="bookmark" title="Music Video: Meek Mill – Oodles O’Noodles Babies">Music Video: Meek Mill – Oodles O’Noodles Babies</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/05/music-video-calboy-love-me-7/" rel="bookmark" title="Music Video: Calboy – Love Me"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/vXqCSMOFf--vDgmxa7eYpkr8tz2qRML5mbU0IcCfx19tR5kLbD2JcKzgfaMPwJfRHeFfKt_BUiQwIw1NRom5aO1ALauK_CKht-_uRjdZNwVkAyLMdKn1C1AdnwkcnIHXL2l0scOmm-W7RmQ4IBwltpW1buWVvbBPmbSa8xgr-d95pgsIDGqbV1gdAmi7KRqaYKK53-Q1UIJuWBDIQkA0IoyuOMkZXnzdVp9i0fE1meqsqikYcoo9bo8BFZoYgMbc3Kmp_mZkkpillLaZFpKF7-sLKDiJ0F2J3-50pnkUFyinc_3jldD-Hm2W9yHvko01JFgEWgwm7zWAUiuS2kkCnKbgzq4LM2L1zArHFfb57-85NDEXqXMr5a6tu4whYokxIq2b9INHxXcW7OQ8wQlUECeoGyULSHEROyeuM_A9jNsE1Zc1kdJ427UAeFwLGIqM3JGJJ7errwYkxID2U--JQmp1GgxrJwEJK3idNQJeeAGSuIKxgCsSrJzHy_rbebSfF_-p-hvHNZuM7qZQJ6J0wEAm89Gv1x5QMPERXRjfDaUDO1wZ529zfwozXeEH5HPTIvk-u8n6t-DxCNupdMLPLu4L8snOmkEvqlMuCbKuvRazO1IBJW1DHKVsSPX2QWrsAVhl7tYivkPl-W2Y1B7rKCZpyuo1LUZy=w882-h481-no" alt="" title="Music Video: Calboy – Love Me"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/05/music-video-calboy-love-me-7/" rel="bookmark" title="Music Video: Calboy – Love Me">Music Video: Calboy – Love Me</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_23_5cf83b893c105" data-td_block_id="td_uid_23_5cf83b893c105"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_23_5cf83b893c105" data-td_block_id="td_uid_23_5cf83b893c105"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_24_5cf83b8944496_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_24_5cf83b8944496" ><script>var block_td_uid_24_5cf83b8944496 = new tdBlock();
block_td_uid_24_5cf83b8944496.id = "td_uid_24_5cf83b8944496";
block_td_uid_24_5cf83b8944496.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"29","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_24_5cf83b8944496_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_24_5cf83b8944496.td_column_number = "3";
block_td_uid_24_5cf83b8944496.block_type = "td_block_mega_menu";
block_td_uid_24_5cf83b8944496.post_count = "4";
block_td_uid_24_5cf83b8944496.found_posts = "711";
block_td_uid_24_5cf83b8944496.header_color = "";
block_td_uid_24_5cf83b8944496.ajax_pagination_infinite_stop = "";
block_td_uid_24_5cf83b8944496.max_num_pages = "178";
tdBlocksArray.push(block_td_uid_24_5cf83b8944496);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_24_5cf83b8944496" id="td_uid_25_5cf83b8945418" data-td_block_id="td_uid_24_5cf83b8944496" data-td_filter_value="" href="http://weuponithiphop.info/category/latest-news/">All</a><a class="mega-menu-sub-cat-td_uid_24_5cf83b8944496"  id="td_uid_26_5cf83b894552f" data-td_block_id="td_uid_24_5cf83b8944496" data-td_filter_value="69" href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a><a class="mega-menu-sub-cat-td_uid_24_5cf83b8944496"  id="td_uid_27_5cf83b894567c" data-td_block_id="td_uid_24_5cf83b8944496" data-td_filter_value="80" href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a><a class="mega-menu-sub-cat-td_uid_24_5cf83b8944496"  id="td_uid_28_5cf83b894579f" data-td_block_id="td_uid_24_5cf83b8944496" data-td_filter_value="2189" href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a><a class="mega-menu-sub-cat-td_uid_24_5cf83b8944496"  id="td_uid_29_5cf83b89458e9" data-td_block_id="td_uid_24_5cf83b8944496" data-td_filter_value="10" href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a><a class="mega-menu-sub-cat-td_uid_24_5cf83b8944496"  id="td_uid_30_5cf83b8945a25" data-td_block_id="td_uid_24_5cf83b8944496" data-td_filter_value="130" href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></div></div><div id=td_uid_24_5cf83b8944496 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/05/future-announces-save-me-album/" rel="bookmark" title="Future Announces  &#8216;Save Me&#8217; Album"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/LvHt3CR0u6qRkXjGIrbh_Tk_eN5jSa06-QYG60RHvuKAsGkSSBcxy5d3KOHgchZ3MTvFQW92GiuM2-wl9i7VlQQWfHD6ic8HuEXppUMylKDsG70sX4-4zJWrucVA9n7ialWbYPXsfJqfDzSiSuXhMaUmFNw9E3FoCTNuidoKCN4JcIfyR1av73s-_RyHU_TTFitGSdLUTIF9TAIxgedhuAVrvUrmpOLqCde-Tyi2-McnX6hyeQpqcepFZRTOHDmzO_ZdtQF-ZbMrzHjrtbxMo-qy-lmM2x1VSvt_lYhRAqVuwP9rI5iq53-L3iTqEIMvyq4ZTgTHFrcp1A8QoYAjN8yK1mMfJLCng6EjV4aH1isvUQ1dTc43VO6w-IKG534NSS39Od9I_T2iO8YpNOdPTvixzmrJZ9PlU2EQG5Ehzj-rnDjpE_iTVD6IF7s6r2RL9DrYNFFPXiuhAc6kDnvFdrOL-azPVOttzcDLSE-RN2aq1W5gHpTRsHBf3AQ6LG7XVjRqrJdZ8eszEPpGswNJPo1ZnedaGapTO3VmyBu9Y9SG3d5FO0aFN433OWpQ4GOZF8Fi14JVTZf8Zp1a7O3KlCnU0m2jbXaAkolHUqXZWiuG_fe0e1lHYOCLy3V901T9rdQAtek3DzS782CoPu8AfH9uwA8xs_LM=s672-no" alt="" title="Future Announces  &#8216;Save Me&#8217; Album"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/05/future-announces-save-me-album/" rel="bookmark" title="Future Announces  &#8216;Save Me&#8217; Album">Future Announces  &#8216;Save Me&#8217; Album</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/05/video-wiz-khalifa-mike-tyson-hotboxin-interview-8/" rel="bookmark" title="Video: Wiz Khalifa &#8211; Mike Tyson Hotboxin Interview"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/UKZfD0NK0KETB2g5_pYf2ebGtSWK7J29llDpQfbNYZ5tmVf4882SVzNBHKv9ICyHSOzBDnHBjLrHTMvIj_EXXcGkNu_gcbmZRuKLIN7UmglfBgLSr74aFjCVEBvOcagnOpLAzTZSYv-pRP0MsdtUJNf-RC2Ey6qu9wDS1xn5WgStc6Uvn-pb8Kw726UuuXQk18IOo9y7a1u3poQuwFysICJuH18uWB-SvkrVWOxGF2VYAH71YH0yj4uB3mVXRyEUADhdvP9UJRjtvccTeGv4ys66YyWiPP_Zl77qkH_5ZI2ekd-DGxZ3-GMS7fF1QtVHu2knvWeWyjO_rte5xpKRk8-cekQ1o8WFwApH-xgtln7jVBqA9TpXtOgDYlSu06033OjoADgevEB5XC03T2zZlORbXD1d-bJ_NXPFQmajfbuAgMWBhTC5MzefUMtDLC-szMCrE_RomTBhvufvSpMokuHJMkvFwRVFANlbnNCphq-w4pegtIX-8yeAG_65px24Yxek1gvu9RDArr4tD-aVen1yp-deE_KG02i3upVSb6MpVnDSF0o3AGtKG5pgq74T_TjHmuH6M-INARHZ8IqR_mi0nURvFFtHaV1wyM6ES4NRSnuIlEhUesFYOCp3A7JxPnwOGqwutLi0_jhf-y6Vlt6metBCC0_g=w433-h220-no" alt="" title="Video: Wiz Khalifa &#8211; Mike Tyson Hotboxin Interview"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/05/video-wiz-khalifa-mike-tyson-hotboxin-interview-8/" rel="bookmark" title="Video: Wiz Khalifa &#8211; Mike Tyson Hotboxin Interview">Video: Wiz Khalifa &#8211; Mike Tyson Hotboxin Interview</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/04/rihanna-is-crowned-the-richest-female-musician-in-the-world/" rel="bookmark" title="Rihanna Is Crowned The Richest Female Musician in the World"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/HhtFWmgBFwwYsg_EQq-qiL6A98tDq086ht-bGPEewOze6AV24rXqGot-pGBQJSRIQeBEZC7ZKgWoQatIArHzI0rMB38e8NisORZYUFc945OVFM-IN3wbtfmA5XOjKGBEHFjPqO7aZXz--6GX0wPgfbjtby-m8ADcvBju1ZyDEMrAL_9y1dzn5MKxls9bRU221sh8X9nkgm6HmharDjJKu0z2b0SmI-hJV4V28h4egbnEOQU2qtFirSYw1sXqZpZXxGgCxgJXgpseLxZa4p5NVmPHAR70orBGcafNUys3AuGzWnpZrvn2lnoELawDZ5sDorlKYD9CS05MyV5CuCwtxpnMJwjWv3Jr7Z-3t9iUE6n0f7Fl9xKsOnUs29G1Tkd1sJHUJ7GfAHDE8wPjBl_RnZP1kZGiiIA9O5ifGrKFMAZnDE_sb1atNVLzNaLV4tuNM1xGbJlhnA4CpFKcWS5ONxYs0Pk98Gg3kpHixpmNh8wO_wWCBpj1KVs4AQ_EtRO9aIhi3dQyxpdeLj2lw9efj3MPAlUiUJ8FINA9fHsPns_IC27jmgatL98VAANaHfcbMSyPoK0yYaKTh6tRZtq38VAN7X-0xgDAfP0eJncHbz5Qm_EjK_A3NmCD0x4ktPsEJ0A9o83NradQiNJyDf1Ns2jP13Au3JsW=w593-h426-no" alt="" title="Rihanna Is Crowned The Richest Female Musician in the World"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/04/rihanna-is-crowned-the-richest-female-musician-in-the-world/" rel="bookmark" title="Rihanna Is Crowned The Richest Female Musician in the World">Rihanna Is Crowned The Richest Female Musician in the World</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/04/video-westside-gunn-conway-on-bets-rate-the-bars-4/" rel="bookmark" title="Video: Westside Gunn &#038; Conway On BET&#8217;s Rate The Bars"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/_j6hwcf_wp5fhYmCvAo5lQ7DazD0uB3cC0-k8DQe5OF6tLt5wxQmx6DTu-8RvIlaCnanWCXw2gL3Lq6w-8g154ZUXkNOvgTyVfl9VPI4xOinu6ereLh9IcAhymSIo3c3P-dJL2wjwzuywSjoIa8HtqG9V3Skh81itcbnNMdAP7D2F35LclsMbGiHzgzpwwsVq3NFPwO88bQRhbH_ypzWGjnSI5Ac7j-09VSmXhCsd3hWk6-wi_uW3MdZi6OlvMBl2sKhEpjBqqTig_8ALzfJTbN53ACJG3Xtv9YLPsoLS5zj4HChejnZZ_arDhyVLRpQSn2XCDmYKDF09k6JYxoS7YeGa7y89Sf4N82dfDTiqmiLaNQeJyX-071RWYPhlsywF3jE5OPgBW-yv-kNDjuLFi9DEj1R7E7ksiKw6Qu_d9x_NpBPDmTLagiiAFmdZikMDr7-rYMetUce_4B9m2z2Lubd_0x4vMrIL4R8879PUGsm14VfrZcfZbNG83NRuWc-02dlI9U84g33Y2W1zQCk542MJjrXeeD03w1KX_vDKsUWydV9CEhQC2Mau6Z1U2Ms7eVar6PQeTrkWG9EbIn6b5UAPcXcNtWi6JTAjEAdegmY-4XXTax9bdmzLqOsfkATxDfiuxckBRPrPKsX41yfwWperDO0zU7j=w990-h494-no" alt="" title="Video: Westside Gunn &#038; Conway On BET&#8217;s Rate The Bars"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/04/video-westside-gunn-conway-on-bets-rate-the-bars-4/" rel="bookmark" title="Video: Westside Gunn &#038; Conway On BET&#8217;s Rate The Bars">Video: Westside Gunn &#038; Conway On BET&#8217;s Rate The Bars</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_24_5cf83b8944496" data-td_block_id="td_uid_24_5cf83b8944496"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_24_5cf83b8944496" data-td_block_id="td_uid_24_5cf83b8944496"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_31_5cf83b8988b98_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_31_5cf83b8988b98" ><script>var block_td_uid_31_5cf83b8988b98 = new tdBlock();
block_td_uid_31_5cf83b8988b98.id = "td_uid_31_5cf83b8988b98";
block_td_uid_31_5cf83b8988b98.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"77","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_31_5cf83b8988b98_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_31_5cf83b8988b98.td_column_number = "3";
block_td_uid_31_5cf83b8988b98.block_type = "td_block_mega_menu";
block_td_uid_31_5cf83b8988b98.post_count = "4";
block_td_uid_31_5cf83b8988b98.found_posts = "158";
block_td_uid_31_5cf83b8988b98.header_color = "";
block_td_uid_31_5cf83b8988b98.ajax_pagination_infinite_stop = "";
block_td_uid_31_5cf83b8988b98.max_num_pages = "40";
tdBlocksArray.push(block_td_uid_31_5cf83b8988b98);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_31_5cf83b8988b98" id="td_uid_32_5cf83b8989d9b" data-td_block_id="td_uid_31_5cf83b8988b98" data-td_filter_value="" href="http://weuponithiphop.info/category/fashion/">All</a><a class="mega-menu-sub-cat-td_uid_31_5cf83b8988b98"  id="td_uid_33_5cf83b8989f1e" data-td_block_id="td_uid_31_5cf83b8988b98" data-td_filter_value="76" href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></div></div><div id=td_uid_31_5cf83b8988b98 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/LVT4Mid8WL4wHUdO9X2OZmZxxgbREs2lVtszOdEBaO6hJB0JS3yQOAyhNSdCyPmv0amBDTgNGpOlRPXPjKCl6yIlo2joyH3rQRI7CUdX09BJtQI1r5jy1_7BQtDhw4AxUhpUwIh35rNS3lTy7uq-FdPff10JN6srr9mwZ7zr04GQFxBVEXwCfC5rNVehXhY_wGCRVsmevYmdkBWEmB8dvOzBHY78NBBjcHNArS_S-2M0FJgDh8v9m9vEh78k_XmZg-AERctsf0bkODuPi1EcNJq_RnJIV6b0GG-VtKjo-OVPmYghWJYf1HiP9c58cQ98oABU8BDFdLqsBtNt4K0NmyHYQlX39W9k_d83wEHZ1-EacQa2o01VrYSn12HnZ1l88fMzu9PKv6EGmcRZNwpepycW7_9EQnhxIPDdVCmRLXUasUED9OXr-zJmnBcnSnLCa06k1ZymQym1LiSFEv1c3aPHnmnD3GY8nL7q5jPJr4HsABR0WCqMebcF3HF_0deNd0zgRBCGMxW-VzlIIHZiHuBeSPEPvUL149GJ5swSSvKm1uGEi1HlLBj9omJSU7mDWzO0p_7l-l7-4_ureEsGsgB8cX1t8t2TQcFeRgqqF1CXlZFYYC2K0iMb4jPsijsw_rtO7pmKvbngqHfgYpGeh_qLmDWeicR7=w1195-h796-no" alt="" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch">Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/fHEwwMf8DoiXlqkfibQS1Z1XXbviORbV9raaI44tOTXrWo7GgqM3gA-vswE10gFtTQUGGwNG7nWAACwHjxPuiubliYBN_dqtBZh2WIpxvumiJ-hSLK0TNWB2cB8Iw2STT5gcp_KqlDh_e4xng1vidI8EXdp_ooh5uDI-JV1HQ9dGnM5nxl_b-v8znqj-Rl_mGB7y4Lu9zsFNWHU7SriqQQJaKrKEEnb9T8zxmGLaL0zq7ilYpnUEhWulDDr9xc82wdr__WzRBm5YEskVpDAnGM2NDZwTZpjbe4QDdxeixWnSXNK_oDzaL7WTbCpkD33OK88BlI5JmFRQ5VmD11UQ2htB7-9WoahHvb4XmBsbLXpEMl1JmEP4sPx06VduzFnBNo-J90WI0n1AEIIcEYVbRywrkGJXbzmH__In9ZIg0EV24OcGGbeKl12HxTdZwucqsNnuZeNjiMHISQ7i8cfzm3N7X7Zenl74zsKIKeKWoIGxh6MTlVADvgHcrHebnjcSgil2vBeFyz_AP45aOv9SOwbzfVLGS0CNfe1s9b2J7qZgjcBk9QPEXCl2kygvzmGXFvU_3xBuW6S0i3Vkh3Ha_3hPBtvIAy3WoTK2yiqS41HzSK7yk3FRAlBtpIEib338fdkTiosBxtdu36SdNUVM75zl6CVIFhTu=w681-h470-no" alt="" title="Air Jordan 14 Rip Hamilton"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton">Air Jordan 14 Rip Hamilton</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/kUjaOYxjEkAh34S-Ub2QSZwdOwHyFnGFLBZULta3_bn1_myPMAwJXiEEsAAtc1ktCQwHCuKhSqSYsWXFBEIZxdfKuykoDEZWwO-dDI3_JeAshbYvyILEHUu0XaUpRn0mj7gOx10V52t8gRGYPCW7QXGImkPGGhvBPzBDVVqh9lKGtkuPeePmTnpRSmwp0LG1WHcIzUWnMqPBWQeHAat6Q-Tq7niXNb96ddEZsMEdHK1nmHVlNaeqFBNtTxk6yYRkFNCvtfBayqy-Rqt4CPU5tThxbTI4AIUCI6JLxJd_VJizrVNDEe2xZ_tiQdkC5ASIoHpX8sfvAB8zRUsMVJ6oMUt5FH_4GBNXDCtFRmr65Qt0JV1h4bBJffu2L272Q_vpD76wn-YNGW8VCtZcheHu_X-A4gdYQEC0HN0BenY-MOuUBqKEjXAc0SxWeP7W9RN55jlqUFK0nzEYydVjec2stdQIngVfg_FvKxvHXfM4XdtMpqeJnp3Pzyk8xjz30sAZd0f2HQ6zfdPjk-OkV2-WrC0_qW0L8Rq3zrUbq52n3BN7gm7sctU_CUlBmoQIgJDQBYk1Siv4tfSq9pL1R4GdaOlWQdxEuhZi8bTYC8GGAgNGl3SMAZGvk7nu6QnnwEZjZ7mZwbcqgyRKa89cOREMUvIkVJ8Q8lZu=w926-h672-no" alt="" title="Jordan Proto React Triple White"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White">Jordan Proto React Triple White</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4cDUjSODZSaXWfHyZKb9q3Fn7FHA4uB0KSBs0MtFHC0dc6AJb1zeAl_X2LOKalK9C7VBFhTqRQ9fw1ESgUr9ZUKFbOzD94i_s96nvkICOqrsYnzrE2nEAQHoEaGOF4O8GAI6T4CGFbgcQhNzjpRlSY60NyPu5Cmq81FRpEOFRzTOtSa_NnWzMmfwO0yxtPbcg5U6YBUsus8shv3SA7CjULLfaP38nZAuWVgq8PMaaeCQ_eSrK8NJSEVQjyyxmqb-1I7zO8Kvvzvwi--ibMr52CF8h-GusBzSq5ZuzvZRCGu_u8CyfoXw7pwWbOmHnLOdcQ9d2PCSW_IxEMGfmEuU7NxMSsW3Ga4r35_wLB7cjvlPC9OjCV50tfekXjZBS_476mzlf4G9jR7Ju1GqgjXah9Uqc_0Y8N-Br8_JCtIlRSuLxAiebwd7AvFVlgWId9MYxBWnRT3cTyD8SH7q5WwO-CIbKAOSKsNcrrTgFxQvqn9yklBU1u5X5fdTlTBk4WSYorsWZAug0z9BOymRLnrhTbnA0vpBPFROWD-aL1glg-eUpFSfgD4xhWsOqJNY9krQ2UbLSGXQ5gYWj0ovLS7Yz3UKFY2qrVWpqkpbfyN98es9NJ-7LTUs2MLq1rX_2FaQmyq5mVndd7VGzQOHy9hDULG-5H-0LvGd=w900-h566-no" alt="" title="adidas Yeezy Boost 350 V2 Hyperspace"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace">adidas Yeezy Boost 350 V2 Hyperspace</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_31_5cf83b8988b98" data-td_block_id="td_uid_31_5cf83b8988b98"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_31_5cf83b8988b98" data-td_block_id="td_uid_31_5cf83b8988b98"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div>                </div>

                <div class="td-pb-span5 td-sub-footer-copy">
                    &copy; 2018 The Hip Hop Chronicles Media Group                </div>
            </div>
        </div>
    </div>
</div><!--close td-outer-wrap-->

	<div id="wpcp-error-message" class="msgmsg-box-wpcp warning-wpcp hideme"><span>error: </span>Not Prohibited. ✌️</div>
	<script>
	var timeout_result;
	function show_wpcp_message(smessage)
	{
		if (smessage !== "")
			{
			var smessage_text = '<span>Alert: </span>'+smessage;
			document.getElementById("wpcp-error-message").innerHTML = smessage_text;
			document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp showme";
			clearTimeout(timeout_result);
			timeout_result = setTimeout(hide_message, 3000);
			}
	}
	function hide_message()
	{
		document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp hideme";
	}
	</script>
	<style type="text/css">
	#wpcp-error-message {
	    direction: ltr;
	    text-align: center;
	    transition: opacity 900ms ease 0s;
	    z-index: 99999999;
	}
	.hideme {
    	opacity:0;
    	visibility: hidden;
	}
	.showme {
    	opacity:1;
    	visibility: visible;
	}
	.msgmsg-box-wpcp {
		border-radius: 10px;
		color: #555;
		font-family: Tahoma;
		font-size: 11px;
		margin: 10px;
		padding: 10px 36px;
		position: fixed;
		width: 255px;
		top: 50%;
  		left: 50%;
  		margin-top: -10px;
  		margin-left: -130px;
  		-webkit-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
		-moz-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
		box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
	}
	.msgmsg-box-wpcp span {
		font-weight:bold;
		text-transform:uppercase;
	}
	.error-wpcp {		background:#ffecec url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/error.png') no-repeat 10px 50%;
		border:1px solid #f5aca6;
	}
	.success {
		background:#e9ffd9 url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/success.png') no-repeat 10px 50%;
		border:1px solid #a6ca8a;
	}
	.warning-wpcp {
		background:#ffecec url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/warning.png') no-repeat 10px 50%;
		border:1px solid #f5aca6;
	}
	.notice {
		background:#e3f7fc url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/notice.png') no-repeat 10px 50%;
		border:1px solid #8ed9f6;
	}
    </style>
	<div style="display:none">
	</div>


    <!--

        Theme: Newspaper by tagDiv 2016
        Version: 7.2 (rara)
        Deploy mode: deploy
        
        uid: 5cf83b89b73f1
    -->

    <link rel='stylesheet' id='so-css-Newspaper-css'  href='http://weuponithiphop.info/wp-content/uploads/so-css/so-css-Newspaper.css?ver=1528674688' type='text/css' media='all' />
<link rel='stylesheet' id='soliloquy-lite-style-css'  href='http://weuponithiphop.info/wp-content/plugins/soliloquy-lite/assets/css/soliloquy.css?ver=2.5.5' type='text/css' media='all' />
<link rel='stylesheet' id='soliloquy-liteclassic-theme-css'  href='http://weuponithiphop.info/wp-content/plugins/soliloquy-lite/themes/classic/style.css?ver=2.5.5' type='text/css' media='all' />
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201923'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2019Junaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.9.10'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/themes/Newspaper/js/tagdiv_theme.js?ver=7.2'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/comment-reply.min.js?ver=4.9.10'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/wp-embed.min.js?ver=4.9.10'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/plugins/soliloquy-lite/assets/js/min/soliloquy-min.js?ver=2.5.5'></script>

<!-- JS generated by theme -->

<script>
    


            

	            // if the theme has tdBackstr support, it means this already uses it
                if ( 'undefined' !== typeof window.tdBackstr ) {

                    (function(){
                        // the site background td-backstretch jquery object is dynamically added in DOM, and after any translation effects are applied over td-backstretch
                        var wrapper_image_jquery_obj = jQuery( '<div class=\'backstretch\'></div>' );
                        var image_jquery_obj = jQuery( '<img class=\'td-backstretch not-parallax\' src=\'http://weuponithiphop.info/wp-content/uploads/grafitti-3-500x287.jpg\'>' );

                        wrapper_image_jquery_obj.append( image_jquery_obj );

                        jQuery( 'body' ).prepend( wrapper_image_jquery_obj );

                        var td_backstr_item = new tdBackstr.item();

                        td_backstr_item.wrapper_image_jquery_obj = wrapper_image_jquery_obj;
                        td_backstr_item.image_jquery_obj = image_jquery_obj;

	                    tdBackstr.add_item( td_backstr_item );

                    })();
                }

            
            

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'http://weuponithiphop.info/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'http://weuponithiphop.info/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>

<script type='text/javascript' src='https://stats.wp.com/e-201923.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.1.1',blog:'147622849',post:'30807',tz:'-4',srv:'weuponithiphop.info'} ]);
	_stq.push([ 'clickTrackerInit', '147622849', '30807' ]);
</script>
			<script type="text/javascript">
			if ( typeof soliloquy_slider === 'undefined' || false === soliloquy_slider ) {soliloquy_slider = {};}jQuery('#soliloquy-container-30342').css('height', Math.round(jQuery('#soliloquy-container-30342').width()/(960/300)));jQuery(window).load(function(){var $ = jQuery;var soliloquy_container_30342 = $('#soliloquy-container-30342'),soliloquy_30342 = $('#soliloquy-30342');soliloquy_slider['30342'] = soliloquy_30342.soliloquy({slideSelector: '.soliloquy-item',speed: 0,pause: 2000,auto: 1,useCSS: 0,keyboard: true,adaptiveHeight: 1,adaptiveHeightSpeed: 400,infiniteLoop: 1,mode: 'fade',pager: 1,controls: 1,nextText: '',prevText: '',startText: '',stopText: '',onSliderLoad: function(currentIndex){soliloquy_container_30342.find('.soliloquy-active-slide').removeClass('soliloquy-active-slide').attr('aria-hidden','true');soliloquy_container_30342.css({'height':'auto','background-image':'none'});if ( soliloquy_container_30342.find('.soliloquy-slider li').length > 1 ) {soliloquy_container_30342.find('.soliloquy-controls').fadeTo(300, 1);}soliloquy_30342.find('.soliloquy-item:not(.soliloquy-clone):eq(' + currentIndex + ')').addClass('soliloquy-active-slide').attr('aria-hidden','false');soliloquy_container_30342.find('.soliloquy-clone').find('*').removeAttr('id');soliloquy_container_30342.find('.soliloquy-controls-direction').attr('aria-label','carousel buttons').attr('aria-controls', 'soliloquy-container-30342');soliloquy_container_30342.find('.soliloquy-controls-direction a.soliloquy-prev').attr('aria-label','previous');soliloquy_container_30342.find('.soliloquy-controls-direction a.soliloquy-next').attr('aria-label','next');},onSlideBefore: function(element, oldIndex, newIndex){soliloquy_container_30342.find('.soliloquy-active-slide').removeClass('soliloquy-active-slide').attr('aria-hidden','true');$(element).addClass('soliloquy-active-slide').attr('aria-hidden','false');},onSlideAfter: function(element, oldIndex, newIndex){},});});			</script>
			
</body>
</html>