<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>New Music: tobi lou &amp; Tony Bigz – My Party</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="http://weuponithiphop.info/xmlrpc.php" />
    <meta property="og:image" content="https://lh3.googleusercontent.com/505WYwgCjYcg6jFq28W2a1NYbcjm805PO1DhMIFQt3z2MpzCcftfaGFvuRYYhM9JTeNwuPelMhx6tmaUYFwjVRTv7LoXI9RdoFq62n7JfO79YsdC95jeOsivKcBbzxZR0bwXoXWAhu2v9ZetWwrkpfxsDaflopXGqG9IGvfnQyQOGPJ50KieNX08J3vExb7RUkRrU_R7vjLv2YJOSR7wuvIDd6XtEeIwSX24HE2UYHnqaG861VArQ_fB5pTp5_mZNTsKL-TKcTgtHcaGRFWotUoAzZU_d3xX3pAsCCJxlHnB6TJn7gkXc7ULGbvraHwNH0fhlaNOz6nkcxmchYH_nv0RJt-AVQx6bmgdfadYB0ASP76f34yPo8_Ua4L2pxY8xxty9OwU9GWl2_ksJPuBJqaHsPxq060X9dWZdz3cL3uETft9H0qpRF5Uyr07P-gxB8UdhrtLwblX81UbqcyKWtDOB2D5t8jjHE9UXGX8PBbD-UbSu4BuURLFQVL2-1WSx9LQpiCfk_KPrRAQULk3Tborj87M2RCdgPckbW5ncQYYDXZvvQt3HEM3ndnp03qvuXicBh41RUcPpuOekVnSRlD9AIzLi-o2kIeT8Yy6U_2d3oM-CvU1ykUSJrhtaFbk7Tk2UpBCAjMjKmWZcUeHnyFfRiOe0LVX=s774-no" /><meta name="author" content="cyclone">
<link rel="icon" type="image/png" href="http://weuponithiphop.info/wp-content/uploads/weuponitlogoCAP-500x457.png">
<!-- All in One SEO Pack 3.1.1 by Michael Torbert of Semper Fi Web Design[208,273] -->
<link rel="canonical" href="http://weuponithiphop.info/2019/07/15/new-music-tobi-lou-tony-bigz-my-party/" />
<!-- All in One SEO Pack -->
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Feed" href="http://weuponithiphop.info/feed/" />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Comments Feed" href="http://weuponithiphop.info/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; New Music: tobi lou &#038; Tony Bigz – My Party Comments Feed" href="http://weuponithiphop.info/2019/07/15/new-music-tobi-lou-tony-bigz-my-party/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/weuponithiphop.info\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.10"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='google_font_open_sans-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_roboto-css'  href='http://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C900%2C500italic%2C400%2C300&#038;ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='http://fonts.googleapis.com/css?family=Roboto+Condensed%3A400%2C700&#038;ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='http://weuponithiphop.info/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=4.12' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='http://weuponithiphop.info/wp-content/themes/Newspaper/style.css?ver=7.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css'  href='http://weuponithiphop.info/wp-content/themes/Newspaper/includes/demos/what/demo_style.css?ver=7.2' type='text/css' media='all' />
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1'></script>
<link rel='https://api.w.org/' href='http://weuponithiphop.info/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://weuponithiphop.info/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://weuponithiphop.info/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='New Music: Kevin Gates – Neva Land' href='http://weuponithiphop.info/2019/07/15/new-music-kevin-gates-neva-land/' />
<link rel='next' title='New Music: ASAP Ferg ft. MadeinTYO &#8211; Wam' href='http://weuponithiphop.info/2019/07/15/new-music-asap-ferg-ft-madeintyo-wam/' />
<meta name="generator" content="WordPress 4.9.10" />
<link rel='shortlink' href='http://weuponithiphop.info/?p=33122' />
<link rel="alternate" type="application/json+oembed" href="http://weuponithiphop.info/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fweuponithiphop.info%2F2019%2F07%2F15%2Fnew-music-tobi-lou-tony-bigz-my-party%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://weuponithiphop.info/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fweuponithiphop.info%2F2019%2F07%2F15%2Fnew-music-tobi-lou-tony-bigz-my-party%2F&#038;format=xml" />

<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>
<script id="wpcp_disable_selection" type="text/javascript">
//<![CDATA[
var image_save_msg='You Can Not Save images!';
	var no_menu_msg='Context Menu disabled!';
	var smessage = "Not Prohibited. ✌️";

function disableEnterKey(e)
{
	if (e.ctrlKey){
     var key;
     if(window.event)
          key = window.event.keyCode;     //IE
     else
          key = e.which;     //firefox (97)
    //if (key != 17) alert(key);
     if (key == 97 || key == 65 || key == 67 || key == 99 || key == 88 || key == 120 || key == 26 || key == 85  || key == 86 || key == 83 || key == 43)
     {
          show_wpcp_message('You are not allowed to copy content or view source');
          return false;
     }else
     	return true;
     }
}

function disable_copy(e)
{	
	var elemtype = e.target.nodeName;
	var isSafari = /Safari/.test(navigator.userAgent) && /Apple Computer/.test(navigator.vendor);
	elemtype = elemtype.toUpperCase();
	var checker_IMG = '';
	if (elemtype == "IMG" && checker_IMG == 'checked' && e.detail >= 2) {show_wpcp_message(alertMsg_IMG);return false;}
	if (elemtype != "TEXT" && elemtype != "TEXTAREA" && elemtype != "INPUT" && elemtype != "PASSWORD" && elemtype != "SELECT" && elemtype != "OPTION" && elemtype != "EMBED")
	{
		if (smessage !== "" && e.detail == 2)
			show_wpcp_message(smessage);
		
		if (isSafari)
			return true;
		else
			return false;
	}	
}
function disable_copy_ie()
{
	var elemtype = window.event.srcElement.nodeName;
	elemtype = elemtype.toUpperCase();
	if (elemtype == "IMG") {show_wpcp_message(alertMsg_IMG);return false;}
	if (elemtype != "TEXT" && elemtype != "TEXTAREA" && elemtype != "INPUT" && elemtype != "PASSWORD" && elemtype != "SELECT" && elemtype != "OPTION" && elemtype != "EMBED")
	{
		//alert(navigator.userAgent.indexOf('MSIE'));
			//if (smessage !== "") show_wpcp_message(smessage);
		return false;
	}
}	
function reEnable()
{
	return true;
}
document.onkeydown = disableEnterKey;
document.onselectstart = disable_copy_ie;
if(navigator.userAgent.indexOf('MSIE')==-1)
{
	document.onmousedown = disable_copy;
	document.onclick = reEnable;
}
function disableSelection(target)
{
    //For IE This code will work
    if (typeof target.onselectstart!="undefined")
    target.onselectstart = disable_copy_ie;
    
    //For Firefox This code will work
    else if (typeof target.style.MozUserSelect!="undefined")
    {target.style.MozUserSelect="none";}
    
    //All other  (ie: Opera) This code will work
    else
    target.onmousedown=function(){return false}
    target.style.cursor = "default";
}
//Calling the JS function directly just after body load
window.onload = function(){disableSelection(document.body);};
//]]>
</script>
	<script id="wpcp_disable_Right_Click" type="text/javascript">
	//<![CDATA[
	document.ondragstart = function() { return false;}
	/* ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
	Disable context menu on images by GreenLava Version 1.0
	^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ */
	    function nocontext(e) {
	       return false;
	    }
	    document.oncontextmenu = nocontext;
	//]]>
	</script>
<!-- Analytics by WP-Statistics v12.6.6.1 - https://wp-statistics.com/ -->
<!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]-->
<!-- JS generated by theme -->

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var tds_login_sing_in_widget="show";
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_ajax_url="http:\/\/weuponithiphop.info\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=7.2";
var td_get_template_directory_uri="http:\/\/weuponithiphop.info\/wp-content\/themes\/Newspaper";
var tds_snap_menu="snap";
var tds_logo_on_sticky="show_header_logo";
var tds_header_style="5";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#dd3333";
var tds_smart_sidebar="enabled";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>


<!-- Header style compiled by theme -->

<style>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</style>

<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>

<body class="post-template-default single single-post postid-33122 single-format-standard unselectable new-music-tobi-lou-tony-bigz-my-party td-what single_template_7 wpb-js-composer js-comp-ver-4.12 vc_responsive td-boxed-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
                    <div class="td-menu-login-section">
                
    <div class="td-guest-wrap">
        <div class="td-menu-avatar"><div class="td-avatar-container"><img alt='' src='http://2.gravatar.com/avatar/?s=80&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo avatar-default' height='80' width='80' /></div></div>
        <div class="td-menu-login"><a id="login-link-mob">Sign in</a></div>
    </div>
            </div>
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-top-menu-container"><ul id="menu-top-menu" class="td-mobile-main-menu"><li id="menu-item-317" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-first menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a></li>
<li id="menu-item-706" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a></li>
<li id="menu-item-314" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a></li>
<li id="menu-item-316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-0" class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></li>
</ul>
</li>
<li id="menu-item-705" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></li>
</ul>
</li>
<li id="menu-item-18581" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li id="menu-item-3199" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
            <div id="login-form-mobile" class="td-register-section">
            
            <div id="td-login-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-login-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign in</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
	                <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
	                <div class="td-login-info-text"><a href="#" id="forgot-pass-link-mob">Forgot your password?</a></div>
                </div>
            </div>

            

            <div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
                <!-- close button -->
	            <div class="td-forgot-pass-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Password recovery</div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title">Recover your password</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
	                <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
                </div>
            </div>
        </div>
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="http://weuponithiphop.info/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap">
    
        <!--
Header style 5
-->

<div class="td-header-wrap td-header-style-5">

    <div class="td-header-top-menu-full">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div >

                Monday, July 15, 2019
            </div>
        </div>
    <ul class="top-header-menu td_ul_login"><li class="menu-item"><a class="td-login-modal-js menu-item" href="#login-form" data-effect="mpf-td-login-effect">Sign in / Join</a><span class="td-sp-ico-login td_sp_login_ico_style"></span></li></ul><div class="menu-top-container"><ul id="menu-main" class="top-header-menu"><li id="menu-item-79" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-79"><a href="http://weuponithiphop.info">Home</a></li>
<li id="menu-item-81" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-81"><a target="_blank" href="http://weuponitradio.com">Power 105.1 WeUpOnIt Radio</a></li>
<li id="menu-item-80" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-80"><a target="_blank" href="https://shop.spreadshirt.com/freshandcleantees/">Shop</a></li>
<li id="menu-item-18582" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18582"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li id="menu-item-18583" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18583"><a href="http://weuponithiphop.info/privacy-policy-2/">Privacy Policy</a></li>
</ul></div></div>
        <div class="td-header-sp-top-widget">
    
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div>
    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <ul class="td-login-tabs">
                        <li><a id="login-link" class="td_login_tab_focus">LOG IN</a></li>
                    </ul>



                    <div class="td-login-wrap">
                        <div class="td_display_err"></div>

                        <div id="td-login-div" class="">
                            <div class="td-login-panel-title">Welcome! Log into your account</div>
                            <input class="td-login-input" type="text" name="login_email" id="login_email" placeholder="your username" value="" required>
                            <input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" placeholder="your password" required>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Log In">


                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password?</a></div>


                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-display-none">
                            <div class="td-login-panel-title">Recover your password</div>
                            <input class="td-login-input" type="text" name="forgot_email" id="forgot_email" placeholder="your email" value="" required>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Pass">
                        </div>




                    </div>
                </div>
                        </div>
    </div>

    <div class="td-header-menu-wrap-full">
        <div class="td-header-menu-wrap">
            <div class="td-container td-header-row td-header-main-menu black-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-menu">
        		<a class="td-mobile-logo td-sticky-header" href="http://weuponithiphop.info/">
			<img class="td-retina-data" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-5.png" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-5.png" alt=""/>
		</a>
			<a class="td-header-logo td-sticky-header" href="http://weuponithiphop.info/">
			<img class="td-retina-data" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" alt=""/>
			<span class="td-visual-hidden">WeUpOnIt</span>
		</a>
	    </div>
    <div class="menu-top-menu-container"><ul id="menu-top-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-first td-menu-item td-mega-menu menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_1_5d2c749b8afd9_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_1_5d2c749b8afd9" ><script>var block_td_uid_1_5d2c749b8afd9 = new tdBlock();
block_td_uid_1_5d2c749b8afd9.id = "td_uid_1_5d2c749b8afd9";
block_td_uid_1_5d2c749b8afd9.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"43","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_1_5d2c749b8afd9_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_1_5d2c749b8afd9.td_column_number = "3";
block_td_uid_1_5d2c749b8afd9.block_type = "td_block_mega_menu";
block_td_uid_1_5d2c749b8afd9.post_count = "5";
block_td_uid_1_5d2c749b8afd9.found_posts = "2158";
block_td_uid_1_5d2c749b8afd9.header_color = "";
block_td_uid_1_5d2c749b8afd9.ajax_pagination_infinite_stop = "";
block_td_uid_1_5d2c749b8afd9.max_num_pages = "432";
tdBlocksArray.push(block_td_uid_1_5d2c749b8afd9);
</script><div id=td_uid_1_5d2c749b8afd9 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/15/new-music-asap-ferg-ft-madeintyo-wam/" rel="bookmark" title="New Music: ASAP Ferg ft. MadeinTYO &#8211; Wam"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4dp3sf6aH2Lg0zJY09wrzrw-abBk5xIVBXar25riFGiYKiskfQq4C9E_0F6PbFYv2NVXwRI_xgJHk8aVydrz9aWZ37suC5_SWZUVAZ4AgOIcvRI2AxDRjCu3ZpdmkN9L2oEcyLM45pes5P6ASxJQ3cRfFzNBd0eISLusjRHMIsfp9luHWVa3IVIU-waKSlsuMlxomJR5ZuvPQzrS-VMbO5KoylvJMe9Wyak5PozOdrkfcAFIZDpZZARbHsb8p06LRTtWD7ZLlgNo_Lv5b4GLB3vDqmWRFqttFOXd9DZe8T7SM0lA9Ho3leJVrObE_Ic0Iue6QAL7BfLPly1i0xla3hIaRNBprI-mhmh2S09-lyJrMFyPHAMi27p0-MdcuG6zXcZh9Do0-1p-7hz6OH7p6FpGwmrHRQ2wvIgM1ipOSb_OZJDGd8E4DYbQGwKibf9KNJTteKktV4pMWj7VisDqMVVbuqZx1gqzY1jG5KBak2AzplJPTOxzFwcYP7UoCFGe_E5-saYyruYS6uzBHNWOzFNysYOjtXjgZpPAWBul7pzX4E_vWk5bzVxEtt6c1z49EwHA6H9FU6UVntUxresjQHySlQafvpMOWdh4AwuGwqOKG6Efhl0Lv7mvDJi5yT1ZJ9H5srku9bGvkeOFnglDLXeyPYJpYxAC=s448-no" alt="" title="New Music: ASAP Ferg ft. MadeinTYO &#8211; Wam"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/15/new-music-asap-ferg-ft-madeintyo-wam/" rel="bookmark" title="New Music: ASAP Ferg ft. MadeinTYO &#8211; Wam">New Music: ASAP Ferg ft. MadeinTYO &#8211; Wam</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/15/new-music-tobi-lou-tony-bigz-my-party/" rel="bookmark" title="New Music: tobi lou &#038; Tony Bigz – My Party"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/505WYwgCjYcg6jFq28W2a1NYbcjm805PO1DhMIFQt3z2MpzCcftfaGFvuRYYhM9JTeNwuPelMhx6tmaUYFwjVRTv7LoXI9RdoFq62n7JfO79YsdC95jeOsivKcBbzxZR0bwXoXWAhu2v9ZetWwrkpfxsDaflopXGqG9IGvfnQyQOGPJ50KieNX08J3vExb7RUkRrU_R7vjLv2YJOSR7wuvIDd6XtEeIwSX24HE2UYHnqaG861VArQ_fB5pTp5_mZNTsKL-TKcTgtHcaGRFWotUoAzZU_d3xX3pAsCCJxlHnB6TJn7gkXc7ULGbvraHwNH0fhlaNOz6nkcxmchYH_nv0RJt-AVQx6bmgdfadYB0ASP76f34yPo8_Ua4L2pxY8xxty9OwU9GWl2_ksJPuBJqaHsPxq060X9dWZdz3cL3uETft9H0qpRF5Uyr07P-gxB8UdhrtLwblX81UbqcyKWtDOB2D5t8jjHE9UXGX8PBbD-UbSu4BuURLFQVL2-1WSx9LQpiCfk_KPrRAQULk3Tborj87M2RCdgPckbW5ncQYYDXZvvQt3HEM3ndnp03qvuXicBh41RUcPpuOekVnSRlD9AIzLi-o2kIeT8Yy6U_2d3oM-CvU1ykUSJrhtaFbk7Tk2UpBCAjMjKmWZcUeHnyFfRiOe0LVX=s774-no" alt="" title="New Music: tobi lou &#038; Tony Bigz – My Party"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/15/new-music-tobi-lou-tony-bigz-my-party/" rel="bookmark" title="New Music: tobi lou &#038; Tony Bigz – My Party">New Music: tobi lou &#038; Tony Bigz – My Party</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/15/new-music-kevin-gates-neva-land/" rel="bookmark" title="New Music: Kevin Gates – Neva Land"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/KIkVPMqUPgKVb33-d6-dTtrilavLqhVwRYhGcSMhSfUcoNktrYTwSy9i5s1Giv8ecSe6qBWCeTSgRT41H_rvKakilpxf7K0w3JsONH5wXXJ_TnL6hTzzezh01NrkzH3rdXAu2iHCV29aq_E7FMmfaz7BmtUWy2gKeMKok-Ub9KINuEm9g2CULFOOKxnIXoTfQHyY3R36wPAFWd3f4S1vyVUOAa5mZYOfa3T1DAgaWv1DhYs3d4sQny48TK5vgypORZwUpI8OdbsqbOBlhIhLrgr3SczNenPQbFlqq7f4SJ21ysanjdppGfg8-ODwRICQ-EWGePaQtCcghWNPAOUbXO-Upg0g4yxRnEqDd6YcpvYXjtpk1tn4QDlJDPKpHGFjoF9kXODfXb43S34XRcvvovhIPsHHutrXbgKquvECPELnpofrrXiL7gNty7rzuCtZ-SeaZxJb1qpEtQfzVFeCFItgBwMnwqfuAYefzR72G9E3PREi-6Iw0h8We-rbaPPXd2ZDxchoj4_01JFw-lgr2pupg10Skk3-b4WqoLAeEBw59FOdYrZ3sXyIQOX1ftfdo9rKM0xboQy68rCU9WHtanrhd29n5F6ZNNYpZgXtFo9aSJL-8B0R2bpPm2uawlXLRS7vorILewBzdOyoJsdsDqZyAB-QEgXc=s774-no" alt="" title="New Music: Kevin Gates – Neva Land"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/15/new-music-kevin-gates-neva-land/" rel="bookmark" title="New Music: Kevin Gates – Neva Land">New Music: Kevin Gates – Neva Land</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/14/new-music-kevin-gates-sober-state-of-mind/" rel="bookmark" title="New Music: Kevin Gates – Sober State Of Mind"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/VHNqn04EIvsBDFVA89N3Zq55CYrVa0TISJHevTZDWlGXzIP2c4jKuzCuRTxgTmLG1kW1shs3hgX2QBgpOW7KZif3oG7wNk4QRXMOWjwOwWXzrGtjBfrFw5U73lHOH50HJvxwCiIXbHFysP-6Vzh14MKSCbOtOpP5H3MV6boyJqn3YhhSiC1pJzKH5WIvnpu_4353NufC_7zu75agbdH8Gmj0xUyVQKqlVC0vr1Yt2ZVfDyArL1ft2Akq0sQAe-9_NUCdL2qx0_0vLmodpXGa-0Rl-1uoFQUYtLGWpsyu13s3qdn1MOt_BYVPLV4EykCyomXkwAU7NWdsmvroqiIzZkTMZld-YYuuZJdsNtG0oTrCcmcWfw4wgXmU0jcUBUnZlFpYFhHlB3Ddf2C-NwBKCZn18K2tT_rDvhaBjtnJDNBs-XXucpso_VzTnwGNlPgxcEEUyQg1oRj5n2YxZ5kwubNaFiHh_lSC2GOqFypSX-ZxTXnXn6OYm993AUu6ByHUeT9lm49FHF-35ggpXjDe_krj-uIxNd-jGxhfOqxbmhEHS4HVF5RIyun4Wgh88LJ4oRbsRYfyKGStipxxgDQlMqdX5XpoOenQC4LOUiZc_lrudgMLZKUuJZjBdVAr-EDQmhx_CQmKINu5h5JgdxoMW2twlzhsayP2=w620-h616-no" alt="" title="New Music: Kevin Gates – Sober State Of Mind"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/14/new-music-kevin-gates-sober-state-of-mind/" rel="bookmark" title="New Music: Kevin Gates – Sober State Of Mind">New Music: Kevin Gates – Sober State Of Mind</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/14/new-music-baby-keem-france-freestyle-4/" rel="bookmark" title="New Music: Baby Keem &#8211; FRANCE FREESTYLE"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/0RxH-BmDsutyrnAgP9lVIMy7V35ZK0pUM1DIq2bDFCa-_AkQZFTHF791LJ95xDPjZ16LbDe05rQEnrozziPifHx9jXqBp_YBl2NAqy-DnWKf1Ao8r87FUVPpgrCRSGsiyKEsC3ON-jSYLwYKfSpCVwt5YfFjagNjCGexEkIETJAdqBbFKdfhhwsw4jXQ6KD00J7maUm-v2XJ8Q889Mp9lX4kYS2Igv0pK_r5Gf1u9lXkqD889hKrWDz8j-a4E5NWqog5wmp1VusjQJvyE-kb78R6oeCT1m2z3FUSeY4kte8Pmpcho1GQfNTSEj8UIoT1zMGqROdeGgqgzRku_OPMNONHWcmKbHzga6ko_j_ZcF1LdZduyyVDRqVeo5VFWu2EsdFPxamqClyQStx6PdRg8JFmubKC13NMWT3nYoZnuq-uMzg02jYq44EK9MCl6QvDaWuuIZnshiupyEG8FMci4SkgmOxDCV7DiaAzBOyxPkMDoCv9nVZfs_IDB5O3PGR1iHlPHVYASE3ml5Nh0irXmQrJpxTxhFPlUuCZzb1S2ooRQvvkkAkkSPRC0k35MW4Y7hyJQLA5m0HODVJrPatS8yrx0imEANM0X9gBq_4AT4tNZf-XF61rqMvTZ9FSqFuPNq6Ila7JyXsA9kWJTe4CNgfYZ9xw9Hwf=s750-no" alt="" title="New Music: Baby Keem &#8211; FRANCE FREESTYLE"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/14/new-music-baby-keem-france-freestyle-4/" rel="bookmark" title="New Music: Baby Keem &#8211; FRANCE FREESTYLE">New Music: Baby Keem &#8211; FRANCE FREESTYLE</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_5d2c749b8afd9" data-td_block_id="td_uid_1_5d2c749b8afd9"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_1_5d2c749b8afd9" data-td_block_id="td_uid_1_5d2c749b8afd9"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_2_5d2c749b8f82a_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_2_5d2c749b8f82a" ><script>var block_td_uid_2_5d2c749b8f82a = new tdBlock();
block_td_uid_2_5d2c749b8f82a.id = "td_uid_2_5d2c749b8f82a";
block_td_uid_2_5d2c749b8f82a.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"97","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_2_5d2c749b8f82a_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_2_5d2c749b8f82a.td_column_number = "3";
block_td_uid_2_5d2c749b8f82a.block_type = "td_block_mega_menu";
block_td_uid_2_5d2c749b8f82a.post_count = "5";
block_td_uid_2_5d2c749b8f82a.found_posts = "810";
block_td_uid_2_5d2c749b8f82a.header_color = "";
block_td_uid_2_5d2c749b8f82a.ajax_pagination_infinite_stop = "";
block_td_uid_2_5d2c749b8f82a.max_num_pages = "162";
tdBlocksArray.push(block_td_uid_2_5d2c749b8f82a);
</script><div id=td_uid_2_5d2c749b8f82a class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/14/mixtape-ad-by-the-way-2/" rel="bookmark" title="Mixtape: AD &#8211; By The Way 2"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/eSVCwVzcZPdWIRV7kNKSLXIPCliqcyXRPcDM3BZ7izVRskVq6GOiEubOM1bP5RrK8jp28ZgjxSPpJ7z03CeofLUXE08tsOvap8tBiJ8j2w2Mus3XDp1uxxTJHyV3STROeQH9LH47U9k-D37OSiZHxSkh0YZzrINJsok2QGrZElsJJCtebjts4SQK0HEK7-4BuXeyg37-3vtOryGNr32Fy3B0X5_svdSZJBcbPTNehmMHmTI8OG4YnzgupnW-dcF7aWaZdflyL05uDSvFT6gYYQnker7ufBEiC_cBZaAE7RHHTwAIF54FgORDgYybzgnTJewuPRNoHt_egR8570lVyCkiIV3hEd_G_IQszwERnFDnVbK9wyKKRmdkyt2xSrmbbJlPXoLDTT9leYWkRmpjFpCPjr7u3G3TrsAwMWQeLmPU67YEhi7_wG4jsrFEH41ZVItXi_7fbWqqdfhR9O6wx5kMmhVyOaFNMhUId_24dg8rYJ_H9S5z8vMfRG2RnLvXzCR8zZh12m19dU3sXqNhVpxVhLKK1Oekj01bhLX1OwxpylWp-SppgkYwSAeYgmD1AhUVWVyPvIB-Cq1fnYjTWmxjie0GtNNYTd8SRgl_1qiDio3ReZCsCB1VjgXne3gaw-Wrid6Q-cWFbstdaRm6VGRyj7YhDmHO=s774-no" alt="" title="Mixtape: AD &#8211; By The Way 2"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/14/mixtape-ad-by-the-way-2/" rel="bookmark" title="Mixtape: AD &#8211; By The Way 2">Mixtape: AD &#8211; By The Way 2</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/12/album-stream-big-k-r-i-t-k-r-i-t-iz-here/" rel="bookmark" title="Album Stream: Big K.R.I.T. &#8211; K.R.I.T. IZ HERE"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/0GhVL3hG5U9ogcJQCXDcOnTCbpk9sekhPfpIC5X5vx3KjpsPKoSM1hS3-96IiTC-rjPoK0Gw3d8=s328-no" alt="" title="Album Stream: Big K.R.I.T. &#8211; K.R.I.T. IZ HERE"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/12/album-stream-big-k-r-i-t-k-r-i-t-iz-here/" rel="bookmark" title="Album Stream: Big K.R.I.T. &#8211; K.R.I.T. IZ HERE">Album Stream: Big K.R.I.T. &#8211; K.R.I.T. IZ HERE</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/12/album-stream-ed-sheeran-no-6-collaborations-project/" rel="bookmark" title="Album Stream: Ed Sheeran – No. 6 Collaborations Project"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/WfJqyH4JfPufDal98NaPwo8cKByjzsmgiWG15hY2I164Eyr1HC-hv9NTl3PTKE_-Hvzm8j6Eren8_XyGRVq7hel4VySIPzxSNRvyahMIBXvucfD5gOLkAUyD8EpxUoCpZcW782UnXxSitDzIwC2M0W-SqRE6H4htOOCsK2jSt1yKpBuMvO3pSOFcCuaACpyy7CD3TzKZ16S-IgNcre6WFboccVnssWWePC_QMutbArt61CqpGelF8oJ5Qo9EFKQj6dimi9PQtASYEL_fB7oMCL7TvnjFqgL2UrNhb9NFKyfDCVrmIuaMq5FRUIQc38hXWut2ji7frSLuaLZHYwt3e_i-Dmax3gcmlTJzVbPcnGSUH35fF1G2NioTIR0ixrc7LhCWh75F48fbLy_XcSsGXNAKmyDeoVaB0-EfFEJQCNhjmrim9qu8cfMaUZnQcG9MJzoHWnCWB8gbGbHJCzjzUiEIEyuJNybGKs5NxsqZ7ZXLeDyvB1EoOoF4dQnokOhYpcHVucPARUV36AzlXk6OFai2QWfBQP7xKc1hzRYmeZd2kIx51VC8RSNtvgYwv1vBu00f0skZjnVPUHtvzC0Lu2GPEYRe-aTQ7C4XGjzy0Yq1vh0WAglsXpmXGexTaozrJnMAQjbnikvFxjlad9OJFOMiyCf2t8fd=s624-no" alt="" title="Album Stream: Ed Sheeran – No. 6 Collaborations Project"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/12/album-stream-ed-sheeran-no-6-collaborations-project/" rel="bookmark" title="Album Stream: Ed Sheeran – No. 6 Collaborations Project">Album Stream: Ed Sheeran – No. 6 Collaborations Project</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/12/mixtape-lil-duke-blue-devil-2/" rel="bookmark" title="Mixtape: Lil Duke – Blue Devil 2"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/Em2iP-bkx-xssV260_47w33p3GLCijX8WDudqNnh4qpnm6_fbfhlrpy-2itSOlRAeyPWMISmMBOkE5rnHwVa8I3jqXxnt1dVlhoE-E4yYNsmbUoII_SJegHh_o07ykgxD8fhdyXHxpSLLmIDmvPctTM8heHbRZZCxJbHoyEW6OaUD1spJtp-KoOtWVsIl7DcXszxZL08YuzurE6HyKq5pg2eZylsK-1BpUYeJ1lcYBhn1W0-WpH4MEavIuqOg5MPRxCXbi9iKZdW0DtVdSSJuV-gZlHQ47x5vpzzNLkyXA91GVH01-KjLwfW85ILTBCO1EFzcG0PTp1T1EyP-adnVaJc3jUYTDxpzsdcTkL23YfJdKiZPB4MBCz-XvY-DnJ-ZDZhQekhsPJV3-rQ8gBbtuCtIWgBIgXruoo2X0JSlRryrBXWCCCV4NnwxTyZnnwdHU0QI_u056L4G4JvVaQUZKDUydFP_o3Cr1em9J8MrX4xgfWFeI41ETDIqXB1n4-ljUV8MmBdTVyJPM-0lHScmGFLTvWAPz40akgJlhjOFWlTWE2-mu9WofCD0Ah3QbGkcncZALsudIMvVau-374qFiL64QY5xrXzp04OkSLQJLyaTSlBbfYHBN09HzllrB1R8GXhXpFtB8GEMVHWsX4zWgHSBrmMHHOP=s673-no" alt="" title="Mixtape: Lil Duke – Blue Devil 2"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/12/mixtape-lil-duke-blue-devil-2/" rel="bookmark" title="Mixtape: Lil Duke – Blue Devil 2">Mixtape: Lil Duke – Blue Devil 2</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/10/ep-stream-latrell-james-still/" rel="bookmark" title="EP Stream: Latrell James – Still"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/pwDiDQXrmKLS6kPuUfDXsavKPZvOtl9JPBX0KGLPoyLQ4SME8RFeJxlS7aazfbOhH9iIZmmf55d0-45cNGYvYQTAyHqtWIYCSHeoHCG0BXBoSrHbyAkaYy7vIYgwqSut-LSlrZBnBP-DAwKQCYB6tlSXQj86yxc1-nX7hiEqaWA7Y5bz1ZzE85V6l_g42YNZy2VgSTqfJZQZB7Ma8SOCPFBmPv47_1pyc6wtRCjPw73ewetEVQs0DSKn8uUQbTWWAjWryJiQRZVHVTjyXkgpQRpMeyXgCJA7MQEW655k6v3ZgHCvz3ih7BGW4mCA6pFwwiPqB5On_zfPqZ5FfWjugRZ44-3R3QChMpjj_pLoZIWXbmVF1m0_5O1sTTCUxNSe8EZxKCd6I00uKM6_RVprWZzywNdRFdAzvmVdDrW5TQpmc3TtNLmHp8FxRp3wTlXAkApTMpu8Z7y3YG4a607vsi4lFQndwr8zta29k5A0_RQJFAvbYeeCYARyYDNT-14oOUwEM4Wb-M5JnLtDoWFYyadmYbIN9pevR3BFAbzLUI0lMa8LnpNevKIPtnPDf9uJk16ob7HaOlKjCo-mttuCcE5xY1u2n57B81eeGYTYZCEWUqG3uxykL3yvNyNYB5CZsBKWnDPQW27cT49tjSJS2OYOmGjAC_k1=s732-no" alt="" title="EP Stream: Latrell James – Still"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/10/ep-stream-latrell-james-still/" rel="bookmark" title="EP Stream: Latrell James – Still">EP Stream: Latrell James – Still</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_5d2c749b8f82a" data-td_block_id="td_uid_2_5d2c749b8f82a"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_2_5d2c749b8f82a" data-td_block_id="td_uid_2_5d2c749b8f82a"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_3_5d2c749b937ab_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_3_5d2c749b937ab" ><script>var block_td_uid_3_5d2c749b937ab = new tdBlock();
block_td_uid_3_5d2c749b937ab.id = "td_uid_3_5d2c749b937ab";
block_td_uid_3_5d2c749b937ab.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_3_5d2c749b937ab_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_3_5d2c749b937ab.td_column_number = "3";
block_td_uid_3_5d2c749b937ab.block_type = "td_block_mega_menu";
block_td_uid_3_5d2c749b937ab.post_count = "5";
block_td_uid_3_5d2c749b937ab.found_posts = "2179";
block_td_uid_3_5d2c749b937ab.header_color = "";
block_td_uid_3_5d2c749b937ab.ajax_pagination_infinite_stop = "";
block_td_uid_3_5d2c749b937ab.max_num_pages = "436";
tdBlocksArray.push(block_td_uid_3_5d2c749b937ab);
</script><div id=td_uid_3_5d2c749b937ab class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/15/music-video-lucki-glory-boy/" rel="bookmark" title="Music Video: Lucki – Glory Boy"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/D-w03An01VkvwosRXDR9MGWEdPYVGy4Ny9ynZvXr4hAN5iaHWhImYLVLlhquYvcEgUrMlYeRjm8jYDzQ3hiq5oDiGV2AuDiRBS1gNfwwtARng8nAimbvQETJ0jKyEIv-h9qFT1CuiH9seHOmoOJ4PD8z0bMz3fZ7_OgbgZm_ZaSHO-yj2GVaspm-B1BB75JGZH59sl-O_NzqIs9NyZJWw1mpedd78d-rOb4TWFvJkquvUy6iQqJJFTxm2U7y9av40pu2DKYBRaFCG4aAFEG7mEnf3p-_uld9E1cGP5BSpwcB6lhyBm3jOIX99AjRS5hqoLTn7oRtEZbLs0hcEUjLcMjQoDj_8qkJD0doPW1vUF70ojs2OmILlX3cjFn419OGqhNiw7faBLVZ1R8sU6zh8MaJjLu_emjKoi2Rg1z9AHx4jTNBZtPPW-nr1rMwe8Sje-GZIjKQg-sONxfVtVb-oJbhZYmMD6cjJcYoTWtl21NSsX8bGjGhV42miBRp1UWTAYEb0sUG__ZnibevWXwC0oszM0dxlFjNhhh_xnhp3NZ8wsVZhmO0wfyIP8PM5anG1LLYIbyc2F0WLvGP7_MULqXd2gNewKHB4gZIhVEllVdh2A09tiGST4cYYdjn0DYj6sJKG3me0STHTIDCXSvjQl0tkJqhx2x0=w974-h564-no" alt="" title="Music Video: Lucki – Glory Boy"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/15/music-video-lucki-glory-boy/" rel="bookmark" title="Music Video: Lucki – Glory Boy">Music Video: Lucki – Glory Boy</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/15/music-video-mike-posner-ft-ty-dolla-sign-look-what-ive-become/" rel="bookmark" title="Music Video: Mike Posner ft. Ty Dolla Sign – Look What I’ve Become"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/9bCdwznc3nGem_ZsYDNX2IeE2C60Y3VxFeejEC-r0gUwNFn2jqpgBdqv03fHULKjT4LYPUpT5Yg1T2xO_FXYgVSdCrtx7UHE3kC2tv36Exkp7Uh1lW5ds5pQmQiVDikamqEXe6YALtF_EmpFEbeZQ45O5v3PUtX55a88lFSmKXF6djUZKeTxFYy4k4Hl8g1uOzDTw8HQHzSiJxDuTeT0Z1Fqe45tvuAqGPl6gSKcBEbcAlf9kvFpIUBDBbiAmen5XwDQlrIYrxTPHV8jv8GGFbr0KaTy2ESxUKrevJ27Fu7hp0sCXc9X7mkZskxEkX11WEziVztqbz8BwNyuMgiz4ENYKLld6S87tJtJOlNViobY2WI7NAPo6nkJswm809nDXshlhqZ0p7X0QWaHXu3vzuqcZyWMuLCSqoE_mwgHr9WsW2IH621IiNS_JCz0j3luG-POQFwoa3c_p0zaEebwS-HnWSR58i26Uk8ijLDdqjwMnHb76FQXbiIn9UHi8Ih4bogXIurrw0uwkn4mM24w7C0jExNFbAWAb_63X9KYaAywKIgc1B7I1avQ8u9JQhqzn0bGptZDbQSj2pNAHj3U5zVu07U4B3w38rFAt4fRu27JEdOwcC4PuqBEL_aQBDaD3rzEtg4vskJM8AB79kA7Ghi51yE-RzmX=w858-h609-no" alt="" title="Music Video: Mike Posner ft. Ty Dolla Sign – Look What I’ve Become"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/15/music-video-mike-posner-ft-ty-dolla-sign-look-what-ive-become/" rel="bookmark" title="Music Video: Mike Posner ft. Ty Dolla Sign – Look What I’ve Become">Music Video: Mike Posner ft. Ty Dolla Sign – Look What&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/15/music-video-bandhunta-izzy-ft-yfn-lucci-made-me/" rel="bookmark" title="Music Video: Bandhunta Izzy ft. YFN Lucci &#8211; Made Me"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/SMd9vAz75YNVeHLuGik8sSfkrvQSUO4L7YEu4k-njjaNB79qcp09wk7tna4t4G7qEBpJuzj4TUbaxwufWLIC-fyAEtinCiT12_3umsWoH7zkRhoqhBdwCGdjqhoEZ8cz1Iug-qr10hrRqBY1JdOOT9lynMQ7RHLzAaVUwIR05Yt_2GcagfxfBB957OLKmoThUrj0r_BiLT6-rgiuZhg7DuQmgaKMoLOdMbca2SMo3813m7UJgFWoranDg-I6Aj9_fEeKlNjY0Zp-vgHuCy36D20quul_GEuD5THO-Gmqep0PWCfq8LgoJ-nvpHXYmlMTKzEZa-RDnXctyywzd7l9i-nhzE2tsiPsjiA4tNB3bu-w2WDT-Gzd_TrPAlBslN78UoP_nODmFRTAKurREkLQzw7wTdYuIfr5riUKEeCmzR9OhT8gPeFfMrJAhcg6GWa2IaF5Tikuqu_eyU4yV3x0p6mw6gSD2JdifXDErH497lVjud_TGiQyso7HO6egUdroPt7G4ZZ_Y09SQLZ9b3hMHPCTKNSjQVoyh-5PmOZBGH_oPYJm4rAqCXsUiXTJHtEG288wxJ1QUuji_6rPNNj09eII758f9CkWjbIaJj_58O948qczKVg0fGC50hpM11c3ilHfZQ4gnU1H85v0sPRJ_rgYFh3_tw2n=w372-h220-no" alt="" title="Music Video: Bandhunta Izzy ft. YFN Lucci &#8211; Made Me"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/15/music-video-bandhunta-izzy-ft-yfn-lucci-made-me/" rel="bookmark" title="Music Video: Bandhunta Izzy ft. YFN Lucci &#8211; Made Me">Music Video: Bandhunta Izzy ft. YFN Lucci &#8211; Made Me</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/15/music-video-moneybagg-yo-ft-gunna-dior/" rel="bookmark" title="Music Video: Moneybagg Yo ft. Gunna – Dior"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/3oV8HCLEt15f3-FKLIX2g04Yblip3eDALrKNBTE-BYrzW4oixvYMM69SSz91AJJ8fjcK8qzFjAg39d44ZqrMQasHGIs77APcj_5gNJW34-f3LRbEBfEmCS6C2NMVEznRwIsqWyPBceqnSVZTJlMOk-mFp7l6vUi3MnrHWcFLJgNmIFzqv-s0-3JKyFjQA1hZH3rQQsHOdjYJvrKNyI7AP3q4cyFV0GPhrArYJ3V9rnTt_wDTp73T3zIkm_G2ikl1PmBm1CLdz5i01dfgkTA3v9khNctahJtr7yiJ36NL7YJmxTESVJbretFlYyfw7XAANLOPlCavnT4FZrF-xhGdXbZq5Me4LdP5JFvAbLfr1v73RdWn8SIcaABA42HA4SGW6MBKaGdLGgEbq-k6iEj1Hw8WWqTEytM1EHcoFKZiwiK4vQ3oqYfivrSQVU0D1c2mtFO_vORrF6L_VmG5XrzVeMNZ9-qYeJ-w-1_NtPyTOX-oHMRqKBxYxmcSfcwy-nZREd6xuHB3NyBf7expiI0W6MFaWPictl7ImceXS6gLywq3QzCkAdoEt1mnW5XoksVqJ5_YMpqOuLLivrWwNKllsZMK2SQ7IdiKS1CnnSj0Ah3RKt7PPDrcR73csCwiUk6EoToebUs4i2-wYDzYvUyWfLTzcytixfhU=w1049-h592-no" alt="" title="Music Video: Moneybagg Yo ft. Gunna – Dior"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/15/music-video-moneybagg-yo-ft-gunna-dior/" rel="bookmark" title="Music Video: Moneybagg Yo ft. Gunna – Dior">Music Video: Moneybagg Yo ft. Gunna – Dior</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/14/music-video-stunna-4-vegas-ft-moneybagg-yo-tomorrow/" rel="bookmark" title="Music Video: Stunna 4 Vegas ft. Moneybagg Yo &#8211; Tomorrow"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/rGBfH2zyWYEctMQowtqM6kH76S1FGx_cvXJ0YcIIb9PNBo_AfFghX1n0yAPj1YeogovT7aDHqAUgl1U8QuQGFSnKBr1nvUVRoGRCt-h_s_gT0VWD-UxnuoreXevUeQaxTf_AeQ-VlOwRzMFYz27bZYSYxRphueTkKrVuQ7WgosmeLfvdCV65gvdCG9hkqUvIGOFVxtpUu2RbAxHsjmx9WtJlMlr-XhZq1rbjPGNAmHoecZMPOK3qOiFsDEtekM9NzIxdMWqmPb-2Gn2rIP91ocKzusZWxYWYDvrV8ND42QgJ4zMECfhYgYOREWvZT27hRUAIX1fsxawfhniEMByjlx6JiozGBPVoE8NBRJbgFIrkAaOQ_kFnH8Du5oUaiUStRt7xUbdyFkUh7IUSbahthOpWYrHQ3OlHf_bGyOxWQtxxv1qmxrgoQ4gH9TdHtFqgFnKCVcD1M3ltmd8rqk7pRylTVaVC3MDcVW5tyfTPUIcp9IFyNn7XJjZHivVVtXWFWfcwr35OCF2ScsN1xGwcsbWYWp_vagTFg9x1zXCH63qc1No3yqY2s8Nw0jMeDlC6LbxTd0EJnAmBSoG6zHTexLudHRn4VDWhAP0Nir-jdh9h_pfdEYx1nbrpxRXC5i7qG2MlUNrx_DkeEo4hDArp5TDh4f6ncFKL=w335-h195-no" alt="" title="Music Video: Stunna 4 Vegas ft. Moneybagg Yo &#8211; Tomorrow"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/14/music-video-stunna-4-vegas-ft-moneybagg-yo-tomorrow/" rel="bookmark" title="Music Video: Stunna 4 Vegas ft. Moneybagg Yo &#8211; Tomorrow">Music Video: Stunna 4 Vegas ft. Moneybagg Yo &#8211; Tomorrow</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_5d2c749b937ab" data-td_block_id="td_uid_3_5d2c749b937ab"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_3_5d2c749b937ab" data-td_block_id="td_uid_3_5d2c749b937ab"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_4_5d2c749b97c09_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_4_5d2c749b97c09" ><script>var block_td_uid_4_5d2c749b97c09 = new tdBlock();
block_td_uid_4_5d2c749b97c09.id = "td_uid_4_5d2c749b97c09";
block_td_uid_4_5d2c749b97c09.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"29","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_4_5d2c749b97c09_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_4_5d2c749b97c09.td_column_number = "3";
block_td_uid_4_5d2c749b97c09.block_type = "td_block_mega_menu";
block_td_uid_4_5d2c749b97c09.post_count = "4";
block_td_uid_4_5d2c749b97c09.found_posts = "787";
block_td_uid_4_5d2c749b97c09.header_color = "";
block_td_uid_4_5d2c749b97c09.ajax_pagination_infinite_stop = "";
block_td_uid_4_5d2c749b97c09.max_num_pages = "197";
tdBlocksArray.push(block_td_uid_4_5d2c749b97c09);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_4_5d2c749b97c09" id="td_uid_5_5d2c749b98f52" data-td_block_id="td_uid_4_5d2c749b97c09" data-td_filter_value="" href="http://weuponithiphop.info/category/latest-news/">All</a><a class="mega-menu-sub-cat-td_uid_4_5d2c749b97c09"  id="td_uid_6_5d2c749b99075" data-td_block_id="td_uid_4_5d2c749b97c09" data-td_filter_value="69" href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a><a class="mega-menu-sub-cat-td_uid_4_5d2c749b97c09"  id="td_uid_7_5d2c749b99194" data-td_block_id="td_uid_4_5d2c749b97c09" data-td_filter_value="80" href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a><a class="mega-menu-sub-cat-td_uid_4_5d2c749b97c09"  id="td_uid_8_5d2c749b992a7" data-td_block_id="td_uid_4_5d2c749b97c09" data-td_filter_value="2189" href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a><a class="mega-menu-sub-cat-td_uid_4_5d2c749b97c09"  id="td_uid_9_5d2c749b993bd" data-td_block_id="td_uid_4_5d2c749b97c09" data-td_filter_value="10" href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a><a class="mega-menu-sub-cat-td_uid_4_5d2c749b97c09"  id="td_uid_10_5d2c749b994cb" data-td_block_id="td_uid_4_5d2c749b97c09" data-td_filter_value="130" href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></div></div><div id=td_uid_4_5d2c749b97c09 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/15/video-young-thug-no-jumper-interview/" rel="bookmark" title="Video: Young Thug &#8211; No Jumper Interview"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/on24o5-Okm_VMtDTGapVtVOhFpPSXa9ygbfJovZE53wlVpQrdHAmXcotsIOpodI0qNCKC3qnqSpPC_hXjO1RUzDjSKnMZYJbIT_UcMeLn27gRpgFvAhr2-dzOFijB3ESf1EY2NNeT2-mAkF-qayh05FlUbGkryPwpYIL-P6hVqlvBIblwQ38Z6ThxOoliT80Hno91YPyjqNdRK1sFYheCOyCepT5BAcIWZnldNWIp-vA7gCuD2oQBkhIbsU7yZ3r9hW5uLmlp8J_nnnWDa-fQlYV7MfcQcRAR6eTEG1Eh5O_3HtlVUZF2mNcFJ1MASYSUhSlrpdqgHQeNWMmoKd_m5upHNFRNjtvV63XhiJH-M7J2GATBWNuTbVIeNVjt09N8Jxe2RWyTeqZkGgST-JTVxE5HbkrjLfmvpW2S0Xjm4AIOfnx5TBvth1Al0lo0-oLddrAgzbNprc_7Db7lIPWqDtq-MhlkdIHCrk9vXzcmsYIpOp2Iv7XTQQqTd-bIoYmjUnD_eHfzWi1Y8wm9FCDcd8MWI3OuOMplMEqTJHGSjFWbYxzQO_jiaWZxIho3Q6j8kKKMgoCRAmFYfbsLZFULtKT4OD6MGdiHqOzjV5KiLR6YJNk0RPt_4OKgF3eJQHmXvF73iNhobZVEjTqYr-0M0xSz_TG_Obu=w472-h221-no" alt="" title="Video: Young Thug &#8211; No Jumper Interview"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/15/video-young-thug-no-jumper-interview/" rel="bookmark" title="Video: Young Thug &#8211; No Jumper Interview">Video: Young Thug &#8211; No Jumper Interview</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/14/video-zack-fox-kenny-beats-break-down-the-lyrics-of-jesus-is-the-one-i-got-depression/" rel="bookmark" title="Video: Zack Fox &#038; Kenny Beats Break Down The Lyrics Of &#8220;Jesus Is The One (I Got Depression)&#8221;"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/HuYtHWWo8YCAMHaz_Q1tPnxllwCUwZ4HVWSiM4Md9HQaHz-SeqAZtGkAZ6SfO7vGzMAbiznQa6TrynnN_3cm434lsO4ndsy5ix54x94UnK_0Nkgdysy1v9UZyJwtw2UF9O6mVA3rnvG5_TLr7YAFwc8SWvM6MuqQLpQn33OYl0VSIWYRLUJb-YCsCSTUL-NJPpziryoK76bS-godu-dKSKeuLI_kdm_Et9guPDFl0rgwGmois-TfC5WoSrTAO_j4w0qRTdvDzJG30jeWqmYmc-qRhwLNY3O9jpUwXnEUTmBD51RilsPCMIwuPURqTTXttNZqqIV4UIqmOn8spTX1jdpd-CaGyW25VV2As1UG66DP54p3LeI6q_izTCmDJlchj2qmgqyimNrgKBxUPYOVE36US2nPmvedN4f3r7jbHjVgiLa1vCrsAZ0t9QjbLXbhU6EpuJXBR8_PSP-dKjBvfAgNQrOzNajB09OxVQerFNdjtxjDG0MeSfjzrF6YQpkRsohrkSEJBkN8Hwkr4ifG5yaH8BhpeHWDyNncDMHw7hPWZSe8UXVpmx-lcHYdiZVhT7XduzyGNCTCa9S65Xo0Y-SR_7KdC3hI7e8K13-XCDSH8e96HwLO2MFBXBwyZCdg1xkA1Gvg2i5jqZ7OgPv2H5t5DUdGUcnJ=w1109-h592-no" alt="" title="Video: Zack Fox &#038; Kenny Beats Break Down The Lyrics Of &#8220;Jesus Is The One (I Got Depression)&#8221;"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/14/video-zack-fox-kenny-beats-break-down-the-lyrics-of-jesus-is-the-one-i-got-depression/" rel="bookmark" title="Video: Zack Fox &#038; Kenny Beats Break Down The Lyrics Of &#8220;Jesus Is The One (I Got Depression)&#8221;">Video: Zack Fox &#038; Kenny Beats Break Down The Lyrics Of&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/13/video-mya-ebro-in-the-morning-interview-6/" rel="bookmark" title="Video: Mya &#8211; Ebro in the Morning Interview"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/cZeXa6DXoCkhQciC-PD7kEkLBwIHILYPltM6HiFnk3yBp4xb-ZzAG6fwIgB3epdZ9zqdWKD7OJQn-iVfy8_SCLNLUxmNeZQsvyunoVrKgKUexYsBZBbh4TuBbI5Xdn1C82w88p-9vf64YfwaRuMJQvHfc04OAay2Y-c93TKb_Za0jT0PAG1hE_4wY50OYEPiqkxY6NgTQg_TZDNm8leXjZbDNblb5IYQVY-9Nd5apAoKemo8OITigEZmdz_kxB8uT6qpXbWb-Nk_1a2rmDDNG94WWMCMayVpvTuf67aqufCtu9I38F0ja1MDfAOdww4zLDzi7Z9YYDSK5CvASRTpBJU5jwz_hbNpyaB6FXF6Zg5VLfF7UFFU9SqCyypEj9hbmLKklb814ygFjF7AVqLr-Q3W5xySmpvKmXURsQL0Kbx4RTluW-YSM6yw7H5VFclFkBskgSMJZMfQ3iJiRU4jGY64vvaJEh_xkwdMQo6ica6I6qzh4uk_PcWYlZNyxKwQA10NJWdbSyJfRGTpTAeVX9Slll3WEXjI-siH0LUTHYogvxmqkOHr801MaYUDo9wbQt7SlgtfrsbSqcoMr1l6dmMBIiZUjOGQCElkcOnfHCUYXyK7pa7go4a9KHlz2lL3DiXreHZbnEOqO-RqrPPmwxzBnYoIOqbO=w945-h589-no" alt="" title="Video: Mya &#8211; Ebro in the Morning Interview"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/13/video-mya-ebro-in-the-morning-interview-6/" rel="bookmark" title="Video: Mya &#8211; Ebro in the Morning Interview">Video: Mya &#8211; Ebro in the Morning Interview</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/12/video-queen-naija-the-breakfast-club-interview-7/" rel="bookmark" title="Video: Queen Naija &#8211; The Breakfast Club Interview"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/OnkvllH_3G1Pig8xHCNSJBTuhgWZ1K_02hyDP2cOf6p-flukdqo6w2D7CauhGAbv7L7ktX2IY1lTfuuiuPf90tljVv7KSjJYzwTN3aNjw9u8M54C2tcnnG2gqYycKH0kE5w2c2ehpjse2RMrIEvR4BANqwHez5wypsb323HBVXojUgMfR_hKxxU6Ui_tDsHFzqZasm747dMGsO8RTsdkWoidk4gmtUb2cBc5vfVSb8JmvX5SSI92vl-4zRSKYFq3b3h9OpJ54A9gJ7Yzf2mQl-Z-wEXXPfSFFbok9cAlLxmQABzL4yrvSk7_HiQf9jZ2q_5gvQlk-m6gEJpVp8Rk5iovoTkv5ZOeT7UuxnpNScTMREuDmHHbRBvFDXk_-C9xoXHKCflB2nIkkok7k4DRNAULELK33diUJAETjbhCE1EqPgghB4b-ZiLVd2_Qpj7B_WX-GIOMAf0o2cOj6yravK2gfeWurjg5nZ8WTc3jLXpyJF5_BlQX_aTiskFG1Ok_wPri-HZB2Jfqaku-WaiFl2DhmtXv-k1v9U6w9zUAd5xPFrq839xM_tAWhVsA1vsCp7lFGWh6vssgzE7QPLVi9l4WwEuNPtGnw2xjwaBaGvfBYrsdHM_3vJau92qNyOEgwSOBneNAnfqc-5ssQ6mzYkkQ9h91EvCc=w975-h461-no" alt="" title="Video: Queen Naija &#8211; The Breakfast Club Interview"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/12/video-queen-naija-the-breakfast-club-interview-7/" rel="bookmark" title="Video: Queen Naija &#8211; The Breakfast Club Interview">Video: Queen Naija &#8211; The Breakfast Club Interview</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_4_5d2c749b97c09" data-td_block_id="td_uid_4_5d2c749b97c09"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_4_5d2c749b97c09" data-td_block_id="td_uid_4_5d2c749b97c09"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_11_5d2c749bb208f_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_11_5d2c749bb208f" ><script>var block_td_uid_11_5d2c749bb208f = new tdBlock();
block_td_uid_11_5d2c749bb208f.id = "td_uid_11_5d2c749bb208f";
block_td_uid_11_5d2c749bb208f.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"77","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_11_5d2c749bb208f_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_11_5d2c749bb208f.td_column_number = "3";
block_td_uid_11_5d2c749bb208f.block_type = "td_block_mega_menu";
block_td_uid_11_5d2c749bb208f.post_count = "4";
block_td_uid_11_5d2c749bb208f.found_posts = "158";
block_td_uid_11_5d2c749bb208f.header_color = "";
block_td_uid_11_5d2c749bb208f.ajax_pagination_infinite_stop = "";
block_td_uid_11_5d2c749bb208f.max_num_pages = "40";
tdBlocksArray.push(block_td_uid_11_5d2c749bb208f);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_11_5d2c749bb208f" id="td_uid_12_5d2c749bb340f" data-td_block_id="td_uid_11_5d2c749bb208f" data-td_filter_value="" href="http://weuponithiphop.info/category/fashion/">All</a><a class="mega-menu-sub-cat-td_uid_11_5d2c749bb208f"  id="td_uid_13_5d2c749bb34f7" data-td_block_id="td_uid_11_5d2c749bb208f" data-td_filter_value="76" href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></div></div><div id=td_uid_11_5d2c749bb208f class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/LVT4Mid8WL4wHUdO9X2OZmZxxgbREs2lVtszOdEBaO6hJB0JS3yQOAyhNSdCyPmv0amBDTgNGpOlRPXPjKCl6yIlo2joyH3rQRI7CUdX09BJtQI1r5jy1_7BQtDhw4AxUhpUwIh35rNS3lTy7uq-FdPff10JN6srr9mwZ7zr04GQFxBVEXwCfC5rNVehXhY_wGCRVsmevYmdkBWEmB8dvOzBHY78NBBjcHNArS_S-2M0FJgDh8v9m9vEh78k_XmZg-AERctsf0bkODuPi1EcNJq_RnJIV6b0GG-VtKjo-OVPmYghWJYf1HiP9c58cQ98oABU8BDFdLqsBtNt4K0NmyHYQlX39W9k_d83wEHZ1-EacQa2o01VrYSn12HnZ1l88fMzu9PKv6EGmcRZNwpepycW7_9EQnhxIPDdVCmRLXUasUED9OXr-zJmnBcnSnLCa06k1ZymQym1LiSFEv1c3aPHnmnD3GY8nL7q5jPJr4HsABR0WCqMebcF3HF_0deNd0zgRBCGMxW-VzlIIHZiHuBeSPEPvUL149GJ5swSSvKm1uGEi1HlLBj9omJSU7mDWzO0p_7l-l7-4_ureEsGsgB8cX1t8t2TQcFeRgqqF1CXlZFYYC2K0iMb4jPsijsw_rtO7pmKvbngqHfgYpGeh_qLmDWeicR7=w1195-h796-no" alt="" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch">Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/fHEwwMf8DoiXlqkfibQS1Z1XXbviORbV9raaI44tOTXrWo7GgqM3gA-vswE10gFtTQUGGwNG7nWAACwHjxPuiubliYBN_dqtBZh2WIpxvumiJ-hSLK0TNWB2cB8Iw2STT5gcp_KqlDh_e4xng1vidI8EXdp_ooh5uDI-JV1HQ9dGnM5nxl_b-v8znqj-Rl_mGB7y4Lu9zsFNWHU7SriqQQJaKrKEEnb9T8zxmGLaL0zq7ilYpnUEhWulDDr9xc82wdr__WzRBm5YEskVpDAnGM2NDZwTZpjbe4QDdxeixWnSXNK_oDzaL7WTbCpkD33OK88BlI5JmFRQ5VmD11UQ2htB7-9WoahHvb4XmBsbLXpEMl1JmEP4sPx06VduzFnBNo-J90WI0n1AEIIcEYVbRywrkGJXbzmH__In9ZIg0EV24OcGGbeKl12HxTdZwucqsNnuZeNjiMHISQ7i8cfzm3N7X7Zenl74zsKIKeKWoIGxh6MTlVADvgHcrHebnjcSgil2vBeFyz_AP45aOv9SOwbzfVLGS0CNfe1s9b2J7qZgjcBk9QPEXCl2kygvzmGXFvU_3xBuW6S0i3Vkh3Ha_3hPBtvIAy3WoTK2yiqS41HzSK7yk3FRAlBtpIEib338fdkTiosBxtdu36SdNUVM75zl6CVIFhTu=w681-h470-no" alt="" title="Air Jordan 14 Rip Hamilton"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton">Air Jordan 14 Rip Hamilton</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/kUjaOYxjEkAh34S-Ub2QSZwdOwHyFnGFLBZULta3_bn1_myPMAwJXiEEsAAtc1ktCQwHCuKhSqSYsWXFBEIZxdfKuykoDEZWwO-dDI3_JeAshbYvyILEHUu0XaUpRn0mj7gOx10V52t8gRGYPCW7QXGImkPGGhvBPzBDVVqh9lKGtkuPeePmTnpRSmwp0LG1WHcIzUWnMqPBWQeHAat6Q-Tq7niXNb96ddEZsMEdHK1nmHVlNaeqFBNtTxk6yYRkFNCvtfBayqy-Rqt4CPU5tThxbTI4AIUCI6JLxJd_VJizrVNDEe2xZ_tiQdkC5ASIoHpX8sfvAB8zRUsMVJ6oMUt5FH_4GBNXDCtFRmr65Qt0JV1h4bBJffu2L272Q_vpD76wn-YNGW8VCtZcheHu_X-A4gdYQEC0HN0BenY-MOuUBqKEjXAc0SxWeP7W9RN55jlqUFK0nzEYydVjec2stdQIngVfg_FvKxvHXfM4XdtMpqeJnp3Pzyk8xjz30sAZd0f2HQ6zfdPjk-OkV2-WrC0_qW0L8Rq3zrUbq52n3BN7gm7sctU_CUlBmoQIgJDQBYk1Siv4tfSq9pL1R4GdaOlWQdxEuhZi8bTYC8GGAgNGl3SMAZGvk7nu6QnnwEZjZ7mZwbcqgyRKa89cOREMUvIkVJ8Q8lZu=w926-h672-no" alt="" title="Jordan Proto React Triple White"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White">Jordan Proto React Triple White</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4cDUjSODZSaXWfHyZKb9q3Fn7FHA4uB0KSBs0MtFHC0dc6AJb1zeAl_X2LOKalK9C7VBFhTqRQ9fw1ESgUr9ZUKFbOzD94i_s96nvkICOqrsYnzrE2nEAQHoEaGOF4O8GAI6T4CGFbgcQhNzjpRlSY60NyPu5Cmq81FRpEOFRzTOtSa_NnWzMmfwO0yxtPbcg5U6YBUsus8shv3SA7CjULLfaP38nZAuWVgq8PMaaeCQ_eSrK8NJSEVQjyyxmqb-1I7zO8Kvvzvwi--ibMr52CF8h-GusBzSq5ZuzvZRCGu_u8CyfoXw7pwWbOmHnLOdcQ9d2PCSW_IxEMGfmEuU7NxMSsW3Ga4r35_wLB7cjvlPC9OjCV50tfekXjZBS_476mzlf4G9jR7Ju1GqgjXah9Uqc_0Y8N-Br8_JCtIlRSuLxAiebwd7AvFVlgWId9MYxBWnRT3cTyD8SH7q5WwO-CIbKAOSKsNcrrTgFxQvqn9yklBU1u5X5fdTlTBk4WSYorsWZAug0z9BOymRLnrhTbnA0vpBPFROWD-aL1glg-eUpFSfgD4xhWsOqJNY9krQ2UbLSGXQ5gYWj0ovLS7Yz3UKFY2qrVWpqkpbfyN98es9NJ-7LTUs2MLq1rX_2FaQmyq5mVndd7VGzQOHy9hDULG-5H-0LvGd=w900-h566-no" alt="" title="adidas Yeezy Boost 350 V2 Hyperspace"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace">adidas Yeezy Boost 350 V2 Hyperspace</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_11_5d2c749bb208f" data-td_block_id="td_uid_11_5d2c749bb208f"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_11_5d2c749bb208f" data-td_block_id="td_uid_11_5d2c749bb208f"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div></div>


<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form method="get" class="td-search-form" action="http://weuponithiphop.info/">
				<div role="search" class="td-head-form-search-wrap">
					<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>            </div>
        </div>
    </div>

    <div class="td-banner-wrap-full">
        <div class="td-header-container td-header-row td-header-header">
            <div class="td-header-sp-recs">
                <div class="td-header-rec-wrap">
    
</div>            </div>
        </div>
    </div>

</div>
<article id="post-33122" class="td-post-template-7 post-33122 post type-post status-publish format-standard has-post-thumbnail hentry category-new-music tag-my-party tag-tobi-lou tag-tony-bigz" itemscope itemtype="http://schema.org/Article">

    <div class="td-full-screen-header-image-wrap">

        <div class="td-container td-post-header">
            <div class="td-crumb-container"><div class="entry-crumbs"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="" class="entry-crumb" itemprop="url" href="http://weuponithiphop.info/"><span itemprop="title">Home</span></a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="View all posts in New Music" class="entry-crumb" itemprop="url" href="http://weuponithiphop.info/category/new-music/"><span itemprop="title">New Music</span></a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last" itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><meta itemprop="title" content = "New Music: tobi lou &#038; Tony Bigz – My Party"><meta itemprop="url" content = "http://weuponithiphop.info/2019/07/15/new-music-tobi-lou-tony-bigz-my-party/">New Music: tobi lou &#038; Tony Bigz – My Party</span></div></div>

	        <div class="td-post-header-holder">

		        <div class="td-parallax-header">

	                <header class="td-post-title">

	                    <ul class="td-category"><li class="entry-category"><a  href="http://weuponithiphop.info/category/new-music/">New Music</a></li></ul>	                    <h1 class="entry-title">New Music: tobi lou &#038; Tony Bigz – My Party</h1>

	                    
	                    <div class="td-module-meta-info">
	                        <div class="td-post-author-name">By <a href="http://weuponithiphop.info/author/cyclone/">cyclone</a> - </div>	                        <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-07-15T07:09:22+00:00" >July 15, 2019</time></span>	                        	                        <div class="td-post-comments"><a href="http://weuponithiphop.info/2019/07/15/new-music-tobi-lou-tony-bigz-my-party/#respond"><i class="td-icon-comments"></i>0</a></div>	                    </div>

	                </header>

		            <div class="td-read-down"><a href="#"><i class="td-icon-read-down"></i></a></div>
		        </div>
            </div>

        </div>

        <div id="td-full-screen-header-image" class="td-image-gradient-style7">
            <img class="td-backstretch" src="https://lh3.googleusercontent.com/505WYwgCjYcg6jFq28W2a1NYbcjm805PO1DhMIFQt3z2MpzCcftfaGFvuRYYhM9JTeNwuPelMhx6tmaUYFwjVRTv7LoXI9RdoFq62n7JfO79YsdC95jeOsivKcBbzxZR0bwXoXWAhu2v9ZetWwrkpfxsDaflopXGqG9IGvfnQyQOGPJ50KieNX08J3vExb7RUkRrU_R7vjLv2YJOSR7wuvIDd6XtEeIwSX24HE2UYHnqaG861VArQ_fB5pTp5_mZNTsKL-TKcTgtHcaGRFWotUoAzZU_d3xX3pAsCCJxlHnB6TJn7gkXc7ULGbvraHwNH0fhlaNOz6nkcxmchYH_nv0RJt-AVQx6bmgdfadYB0ASP76f34yPo8_Ua4L2pxY8xxty9OwU9GWl2_ksJPuBJqaHsPxq060X9dWZdz3cL3uETft9H0qpRF5Uyr07P-gxB8UdhrtLwblX81UbqcyKWtDOB2D5t8jjHE9UXGX8PBbD-UbSu4BuURLFQVL2-1WSx9LQpiCfk_KPrRAQULk3Tborj87M2RCdgPckbW5ncQYYDXZvvQt3HEM3ndnp03qvuXicBh41RUcPpuOekVnSRlD9AIzLi-o2kIeT8Yy6U_2d3oM-CvU1ykUSJrhtaFbk7Tk2UpBCAjMjKmWZcUeHnyFfRiOe0LVX=s774-no">
        </div>
    </div>

    <div class="td-container">
        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    

    <div class="td-post-content">
        <p>&nbsp;</p>
<p><img class="aligncenter size-full" src="https://lh3.googleusercontent.com/505WYwgCjYcg6jFq28W2a1NYbcjm805PO1DhMIFQt3z2MpzCcftfaGFvuRYYhM9JTeNwuPelMhx6tmaUYFwjVRTv7LoXI9RdoFq62n7JfO79YsdC95jeOsivKcBbzxZR0bwXoXWAhu2v9ZetWwrkpfxsDaflopXGqG9IGvfnQyQOGPJ50KieNX08J3vExb7RUkRrU_R7vjLv2YJOSR7wuvIDd6XtEeIwSX24HE2UYHnqaG861VArQ_fB5pTp5_mZNTsKL-TKcTgtHcaGRFWotUoAzZU_d3xX3pAsCCJxlHnB6TJn7gkXc7ULGbvraHwNH0fhlaNOz6nkcxmchYH_nv0RJt-AVQx6bmgdfadYB0ASP76f34yPo8_Ua4L2pxY8xxty9OwU9GWl2_ksJPuBJqaHsPxq060X9dWZdz3cL3uETft9H0qpRF5Uyr07P-gxB8UdhrtLwblX81UbqcyKWtDOB2D5t8jjHE9UXGX8PBbD-UbSu4BuURLFQVL2-1WSx9LQpiCfk_KPrRAQULk3Tborj87M2RCdgPckbW5ncQYYDXZvvQt3HEM3ndnp03qvuXicBh41RUcPpuOekVnSRlD9AIzLi-o2kIeT8Yy6U_2d3oM-CvU1ykUSJrhtaFbk7Tk2UpBCAjMjKmWZcUeHnyFfRiOe0LVX=s774-no" alt="tobi lou &amp; Tony Bigz – My Party" width="774" height="774" /></p>
<p><strong>tobi lou </strong>follows the visuals for his track<strong> “Waterboy”</strong> with a new collab from himself and <strong>Tony Bigz</strong> titled <strong>“My <a href="http://weuponithiphop.info/tag/party/">Party</a>”. </strong>His new <a href="http://weuponithiphop.info/tag/album/">album</a> <em><strong>Live On Ice</strong></em> is set to his stores on August 2nd.</p>
<p>You can stream <strong>“My Party”</strong> below and pre-<a href="http://weuponithiphop.info/tag/order/">order</a> <em><strong>Live On Ice</strong></em> now on <a href="https://music.apple.com/us/album/1471461888?app=itunes">Apple Music</a>/<a href="https://play.google.com/store/music/album/tobi_lou_Live_on_Ice?id=Bib6vimy4jnugdtm7mbw56ryrpa">Google Play</a>.</p>
<p><iframe src="https://embed.music.apple.com/us/album/my-party/1471461888?i=1471461894&amp;app=music&amp;at=11l4Qg&amp;ct=myparty" height="150" frameborder="0" sandbox="allow-forms allow-popups allow-same-origin allow-scripts allow-storage-access-by-user-activation allow-top-navigation-by-user-activation" data-mce-fragment="1"></iframe></p>
<p><iframe src="https://open.spotify.com/embed?uri=spotify%3Atrack%3A5xVCO7FQFD6e1Ts9So1Fl8" width="100%" height="80" frameborder="0" data-mce-fragment="1"></iframe></p>
<div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="http://weuponithiphop.info/2019/07/15/new-music-tobi-lou-tony-bigz-my-party/" data-a2a-title="New Music: tobi lou &amp; Tony Bigz – My Party"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F07%2F15%2Fnew-music-tobi-lou-tony-bigz-my-party%2F&amp;linkname=New%20Music%3A%20tobi%20lou%20%26%20Tony%20Bigz%20%E2%80%93%20My%20Party" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F07%2F15%2Fnew-music-tobi-lou-tony-bigz-my-party%2F&amp;linkname=New%20Music%3A%20tobi%20lou%20%26%20Tony%20Bigz%20%E2%80%93%20My%20Party" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F07%2F15%2Fnew-music-tobi-lou-tony-bigz-my-party%2F&amp;linkname=New%20Music%3A%20tobi%20lou%20%26%20Tony%20Bigz%20%E2%80%93%20My%20Party" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F07%2F15%2Fnew-music-tobi-lou-tony-bigz-my-party%2F&amp;linkname=New%20Music%3A%20tobi%20lou%20%26%20Tony%20Bigz%20%E2%80%93%20My%20Party" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_tumblr" href="https://www.addtoany.com/add_to/tumblr?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F07%2F15%2Fnew-music-tobi-lou-tony-bigz-my-party%2F&amp;linkname=New%20Music%3A%20tobi%20lou%20%26%20Tony%20Bigz%20%E2%80%93%20My%20Party" title="Tumblr" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_reddit" href="https://www.addtoany.com/add_to/reddit?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F07%2F15%2Fnew-music-tobi-lou-tony-bigz-my-party%2F&amp;linkname=New%20Music%3A%20tobi%20lou%20%26%20Tony%20Bigz%20%E2%80%93%20My%20Party" title="Reddit" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_flipboard" href="https://www.addtoany.com/add_to/flipboard?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F07%2F15%2Fnew-music-tobi-lou-tony-bigz-my-party%2F&amp;linkname=New%20Music%3A%20tobi%20lou%20%26%20Tony%20Bigz%20%E2%80%93%20My%20Party" title="Flipboard" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F07%2F15%2Fnew-music-tobi-lou-tony-bigz-my-party%2F&amp;linkname=New%20Music%3A%20tobi%20lou%20%26%20Tony%20Bigz%20%E2%80%93%20My%20Party" title="Copy Link" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div>    </div>


    <footer>
                
        <div class="td-post-source-tags">
                        <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="http://weuponithiphop.info/tag/my-party/">My Party</a></li><li><a href="http://weuponithiphop.info/tag/tobi-lou/">tobi lou</a></li><li><a href="http://weuponithiphop.info/tag/tony-bigz/">Tony Bigz</a></li></ul>        </div>

                <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="http://weuponithiphop.info/2019/07/15/new-music-kevin-gates-neva-land/">New Music: Kevin Gates – Neva Land</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="http://weuponithiphop.info/2019/07/15/new-music-asap-ferg-ft-madeintyo-wam/">New Music: ASAP Ferg ft. MadeinTYO &#8211; Wam</a></div></div></div>        <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="http://weuponithiphop.info/author/cyclone/">cyclone</a></span></div>        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="cyclone"></span><meta itemprop="datePublished" content="2019-07-15T07:09:22+00:00"><meta itemprop="dateModified" content="2019-07-15T07:09:22+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://weuponithiphop.info/2019/07/15/new-music-tobi-lou-tony-bigz-my-party/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png"></span><meta itemprop="name" content="WeUpOnIt"></span><meta itemprop="headline " content="New Music: tobi lou &amp; Tony Bigz – My Party"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://lh3.googleusercontent.com/505WYwgCjYcg6jFq28W2a1NYbcjm805PO1DhMIFQt3z2MpzCcftfaGFvuRYYhM9JTeNwuPelMhx6tmaUYFwjVRTv7LoXI9RdoFq62n7JfO79YsdC95jeOsivKcBbzxZR0bwXoXWAhu2v9ZetWwrkpfxsDaflopXGqG9IGvfnQyQOGPJ50KieNX08J3vExb7RUkRrU_R7vjLv2YJOSR7wuvIDd6XtEeIwSX24HE2UYHnqaG861VArQ_fB5pTp5_mZNTsKL-TKcTgtHcaGRFWotUoAzZU_d3xX3pAsCCJxlHnB6TJn7gkXc7ULGbvraHwNH0fhlaNOz6nkcxmchYH_nv0RJt-AVQx6bmgdfadYB0ASP76f34yPo8_Ua4L2pxY8xxty9OwU9GWl2_ksJPuBJqaHsPxq060X9dWZdz3cL3uETft9H0qpRF5Uyr07P-gxB8UdhrtLwblX81UbqcyKWtDOB2D5t8jjHE9UXGX8PBbD-UbSu4BuURLFQVL2-1WSx9LQpiCfk_KPrRAQULk3Tborj87M2RCdgPckbW5ncQYYDXZvvQt3HEM3ndnp03qvuXicBh41RUcPpuOekVnSRlD9AIzLi-o2kIeT8Yy6U_2d3oM-CvU1ykUSJrhtaFbk7Tk2UpBCAjMjKmWZcUeHnyFfRiOe0LVX=s774-no"><meta itemprop="width" content="800"><meta itemprop="height" content="600"></span>    </footer>

    <div class="td_block_wrap td_block_related_posts td_uid_15_5d2c749d77f25_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_15_5d2c749d77f25" ><script>var block_td_uid_15_5d2c749d77f25 = new tdBlock();
block_td_uid_15_5d2c749d77f25.id = "td_uid_15_5d2c749d77f25";
block_td_uid_15_5d2c749d77f25.atts = '{"limit":6,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_custom_related","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_15_5d2c749d77f25_rand","offset":"","css":"","live_filter":"cur_post_same_tags","live_filter_cur_post_id":33122,"live_filter_cur_post_author":"1"}';
block_td_uid_15_5d2c749d77f25.td_column_number = "3";
block_td_uid_15_5d2c749d77f25.block_type = "td_block_related_posts";
block_td_uid_15_5d2c749d77f25.post_count = "4";
block_td_uid_15_5d2c749d77f25.found_posts = "4";
block_td_uid_15_5d2c749d77f25.header_color = "";
block_td_uid_15_5d2c749d77f25.ajax_pagination_infinite_stop = "";
block_td_uid_15_5d2c749d77f25.max_num_pages = "1";
tdBlocksArray.push(block_td_uid_15_5d2c749d77f25);
</script><h4 class="td-related-title"><a id="td_uid_16_5d2c749d7a1da" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_15_5d2c749d77f25" href="#">RELATED ARTICLES</a><a id="td_uid_17_5d2c749d7a219" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_15_5d2c749d77f25" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_15_5d2c749d77f25 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/12/music-video-tobi-lou-waterboy/" rel="bookmark" title="Music Video: tobi lou – Waterboy"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/zmGWl8G625y4vCiClttUzmthXwGhMo010HmLTpiO8hAE4d085WOypYGve6sx0Aodc8i9n6yJYFYm6aMNLqFfb0Zn12SWbGOeMbE9jfRllxBWnFWI800H0AO0woxrlZQbdL-ClffQbTd5dHb2h_lOjDpFbychvo-b-gcN6mmaQjg8JlO2i_4DjsV36Lk0Rlbn-FlPYU3OZm6RUMqzwvwtSi5avtk-YEifTRQeqNcG0Dx9kP-4dxUTY-_RquA-GjgLpjVxk_NXiCxLFJjan4GYJWDnxqRQxQegHGVdzBtD1FUJfCxRB4gWfGkH0JCwdV5pv7K2uYrPli2n6L8KACEhqSU4oC97KSAaEGJIZG5srEO6ObRoo9P49QIS_2FDLuZeBLgOrcOrocd7c1Ua2AYU3YeYQUWyhYPxxGEubkL6BPolQrIoGCFTScWmUilaKi79maap-dwxoU6Qg2w819hAYi_TODwHfh4QJ1ffMASgP6PzYn9TSxGAj6pAhU-OURBUDvjB6-V-RqHNOVdSO_S4A367VCeVigkxhR6VAVZ-A0ZlMRoChVO_DXDoyguOCJc1H_XiX-i3wcAALuzCO_YKfHkOTQKfQS9SxBvP98tahcZ_MZUw0KcylJtQK5ST2menQ3EN-d6Wm-qbqf6IM7i2lRNdpxy2I1xI=w1029-h546-no" alt="" title="Music Video: tobi lou – Waterboy"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/12/music-video-tobi-lou-waterboy/" rel="bookmark" title="Music Video: tobi lou – Waterboy">Music Video: tobi lou – Waterboy</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/11/22/music-video-tobi-lou-ft-tomi-adeyemi-knock-knock/" rel="bookmark" title="Music Video: tobi lou ft. Tomi Adeyemi &#8211; KNOCK KNOCK"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/tobi-lou-ft.-Tomi-Adeyemi-KNOCK-KNOCK-218x150.jpg" alt="" title="Music Video: tobi lou ft. Tomi Adeyemi &#8211; KNOCK KNOCK"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/11/22/music-video-tobi-lou-ft-tomi-adeyemi-knock-knock/" rel="bookmark" title="Music Video: tobi lou ft. Tomi Adeyemi &#8211; KNOCK KNOCK">Music Video: tobi lou ft. Tomi Adeyemi &#8211; KNOCK KNOCK</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/10/16/new-music-tobi-lou-orange/" rel="bookmark" title="New Music: tobi lou – Orange"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/tobi-lou-–-Orange-218x150.jpg" alt="" title="New Music: tobi lou – Orange"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/10/16/new-music-tobi-lou-orange/" rel="bookmark" title="New Music: tobi lou – Orange">New Music: tobi lou – Orange</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid-->

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/08/22/music-video-tobi-lou-buff-baby/" rel="bookmark" title="Music Video: tobi lou – Buff Baby"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/tobi-lou-–-Buff-Baby-218x150.jpg" alt="" title="Music Video: tobi lou – Buff Baby"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/08/22/music-video-tobi-lou-buff-baby/" rel="bookmark" title="Music Video: tobi lou – Buff Baby">Music Video: tobi lou – Buff Baby</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_15_5d2c749d77f25" data-td_block_id="td_uid_15_5d2c749d77f25"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page ajax-page-disabled" id="next-page-td_uid_15_5d2c749d77f25" data-td_block_id="td_uid_15_5d2c749d77f25"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->

	<div class="comments" id="comments">
            </div> <!-- /.content -->
                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <aside class="widget widget_search"><form method="get" class="td-search-form-widget" action="http://weuponithiphop.info/">
    <div role="search">
        <input class="td-widget-search-input" type="text" value="" name="s" id="s" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit" value="Search" />
    </div>
</form></aside><aside class="widget widget_text">			<div class="textwidget"><h4><strong><span style="color: #8224e3;"><span style="color: #000000;">Listen to</span> <span style="color: #c60000;">WeUpOnItRadio</span> <span style="color: #000000;">Live!</span></span></strong></h4>
<p><span class="cc_streaminfo" data-type="song" data-username="cyclone777">Loading &#8230;</span><br />
<script language="javascript" type="text/javascript" src="https://control.internet-radio.com:2199/system/streaminfo.js"></script><br />
<iframe src="https://tunein.com/embed/player/s292400/" style="width:100%; height:100px;" scrolling="no" frameborder="no"></iframe></p>
</div>
		</aside>
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-sidebar ">
<script type="text/javascript">
var td_screen_width = document.body.clientWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 

<aside class="widget widget_text"><div class="block-title"><span>AUDIOTRAFFICKER:</span></div>			<div class="textwidget"><p><iframe src="https://www.facebook.com/plugins/video.php?href=https%3A%2F%2Fwww.facebook.com%2FAudioTrafficker%2Fvideos%2F326277991409372%2F&#038;show_text=0&#038;width=560" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true" allowFullScreen="true"></iframe></p>
</div>
		</aside><aside class="widget widget_text"><div class="block-title"><span>Nas-T ft. Shad &#038; Exodus &#8211; Surf&#8217;s Up</span></div>			<div class="textwidget"><p><iframe src="https://www.youtube.com/embed/aq8hzOgMl8I" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
</div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><div aria-live="polite" id="soliloquy-container-30342" class="soliloquy-container soliloquy-transition-fade  soliloquy-theme-classic" style="max-width:960px;max-height:300px;"><ul id="soliloquy-30342" class="soliloquy-slider soliloquy-slides soliloquy-wrap soliloquy-clear"><li aria-hidden="true" class="soliloquy-item soliloquy-item-1 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109673710?productType=812&#038;appearance=1" class="soliloquy-link" title="Revolt Tee" target="_blank"><img id="soliloquy-image-30349" class="soliloquy-image soliloquy-image-1" src="http://weuponithiphop.info/wp-content/uploads/Revolt-Tee.jpg" alt="Revolt Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-2 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/youngongetthiswork?q=I12154011" class="soliloquy-link" title="You Gon Get This Work" target="_blank"><img id="soliloquy-image-30344" class="soliloquy-image soliloquy-image-2" src="http://weuponithiphop.info/wp-content/uploads/You-Gon-Get-This-Work.jpg" alt="You Gon Get This Work" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-3 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/savage+bloody?q=I1014473415" class="soliloquy-link" title="Savage Bloody" target="_blank"><img id="soliloquy-image-30343" class="soliloquy-image soliloquy-image-3" src="http://weuponithiphop.info/wp-content/uploads/Savage-Bloody.jpg" alt="Savage Bloody" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-4 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/can?q=I1011767996" class="soliloquy-link" title="spray" target="_blank"><img id="soliloquy-image-30345" class="soliloquy-image soliloquy-image-4" src="http://weuponithiphop.info/wp-content/uploads/spray.jpg" alt="spray" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-5 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814012" class="soliloquy-link" title="Good Vibes Only 1" target="_blank"><img id="soliloquy-image-30346" class="soliloquy-image soliloquy-image-5" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-1.jpg" alt="Good Vibes Only 1" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-6 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/blessed?q=I12044252" class="soliloquy-link" title="Blessed Tee" target="_blank"><img id="soliloquy-image-30347" class="soliloquy-image soliloquy-image-6" src="http://weuponithiphop.info/wp-content/uploads/Blessed-Tee.jpg" alt="Blessed Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-7 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/trap?q=I1009984243" class="soliloquy-link" title="Trap Tee" target="_blank"><img id="soliloquy-image-30348" class="soliloquy-image soliloquy-image-7" src="http://weuponithiphop.info/wp-content/uploads/Trap-Tee.jpg" alt="Trap Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-8 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/good+vibes+only+birds?q=I1014476779" class="soliloquy-link" title="Good Vibes Only 2" target="_blank"><img id="soliloquy-image-30350" class="soliloquy-image soliloquy-image-8" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-2.jpg" alt="Good Vibes Only 2" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-9 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/all+seeing+eye?q=I11739019" class="soliloquy-link" title="ILLuminati" target="_blank"><img id="soliloquy-image-30351" class="soliloquy-image soliloquy-image-9" src="http://weuponithiphop.info/wp-content/uploads/ILLuminati.jpg" alt="ILLuminati" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-10 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/diamond_skull_1?q=I12527492" class="soliloquy-link" title="Diamond Skull" target="_blank"><img id="soliloquy-image-30352" class="soliloquy-image soliloquy-image-10" src="http://weuponithiphop.info/wp-content/uploads/Diamond-Skull.jpg" alt="Diamond Skull" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-11 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/donuts+doom-A109792920" class="soliloquy-link" title="donunts" target="_blank"><img id="soliloquy-image-30353" class="soliloquy-image soliloquy-image-11" src="http://weuponithiphop.info/wp-content/uploads/donunts.jpg" alt="donunts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-12 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/crime+pays?q=I12067735" class="soliloquy-link" title="Crime Pays" target="_blank"><img id="soliloquy-image-30434" class="soliloquy-image soliloquy-image-12" src="http://weuponithiphop.info/wp-content/uploads/Crime-Pays.jpg" alt="Crime Pays" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-13 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/fuckyoupayme?q=I11550361" class="soliloquy-link" title="Fuck You Pay Me" target="_blank"><img id="soliloquy-image-30436" class="soliloquy-image soliloquy-image-13" src="http://weuponithiphop.info/wp-content/uploads/Fuck-You-Pay-Me.jpg" alt="Fuck You Pay Me" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-14 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814011" class="soliloquy-link" title="savage gold tee" target="_blank"><img id="soliloquy-image-30354" class="soliloquy-image soliloquy-image-14" src="http://weuponithiphop.info/wp-content/uploads/savage-gold-tee.jpg" alt="savage gold tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-15 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/?page=2" class="soliloquy-link" title="fresh-clean-signature-" target="_blank"><img id="soliloquy-image-30437" class="soliloquy-image soliloquy-image-15" src="http://weuponithiphop.info/wp-content/uploads/fresh-clean-signature-.jpg" alt="fresh-clean-signature-" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-16 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/%24teez?q=I1001415610" class="soliloquy-link" title="gold fronts" target="_blank"><img id="soliloquy-image-30355" class="soliloquy-image soliloquy-image-16" src="http://weuponithiphop.info/wp-content/uploads/gold-fronts.jpg" alt="gold fronts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-17 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/soldier?q=I11611241" class="soliloquy-link" title="Swag Soldier" target="_blank"><img id="soliloquy-image-30435" class="soliloquy-image soliloquy-image-17" src="http://weuponithiphop.info/wp-content/uploads/Swag-Soldier.jpg" alt="Swag Soldier" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-18 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/gamer-A7923028?productType=210&#038;appearance=22" class="soliloquy-link" title="gamer" target="_blank"><img id="soliloquy-image-30438" class="soliloquy-image soliloquy-image-18" src="http://weuponithiphop.info/wp-content/uploads/gamer.jpg" alt="gamer" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-19 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/" class="soliloquy-link" title="freshandlogo Square" target="_blank"><img id="soliloquy-image-30356" class="soliloquy-image soliloquy-image-19" src="http://weuponithiphop.info/wp-content/uploads/freshandlogo-Square.jpg" alt="freshandlogo Square" /></a></li></ul></div><noscript><style type="text/css">#soliloquy-container-30342{opacity:1}</style></noscript>
</div>
		</aside>                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</article> <!-- /.post -->


<!-- Instagram -->



<!-- Footer -->
<div class="td-footer-wrapper td-footer-template-3">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
			    		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span4">
                <div class="td-footer-info"><div class="footer-logo-wrap"><a href="http://weuponithiphop.info/"><img class="td-retina-data" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" alt="" title=""/></a></div><div class="footer-text-wrap"></div><div class="footer-social-wrap td-social-style-2">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div></div>            </div>

            <div class="td-pb-span4">
                <aside class="widget widget_calendar"><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar">
	<caption>July 2019</caption>
	<thead>
	<tr>
		<th scope="col" title="Sunday">S</th>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
	</tr>
	</thead>

	<tfoot>
	<tr>
		<td colspan="3" id="prev"><a href="http://weuponithiphop.info/2019/06/">&laquo; Jun</a></td>
		<td class="pad">&nbsp;</td>
		<td colspan="3" id="next" class="pad">&nbsp;</td>
	</tr>
	</tfoot>

	<tbody>
	<tr>
		<td colspan="1" class="pad">&nbsp;</td><td><a href="http://weuponithiphop.info/2019/07/01/" aria-label="Posts published on July 1, 2019">1</a></td><td><a href="http://weuponithiphop.info/2019/07/02/" aria-label="Posts published on July 2, 2019">2</a></td><td><a href="http://weuponithiphop.info/2019/07/03/" aria-label="Posts published on July 3, 2019">3</a></td><td><a href="http://weuponithiphop.info/2019/07/04/" aria-label="Posts published on July 4, 2019">4</a></td><td><a href="http://weuponithiphop.info/2019/07/05/" aria-label="Posts published on July 5, 2019">5</a></td><td><a href="http://weuponithiphop.info/2019/07/06/" aria-label="Posts published on July 6, 2019">6</a></td>
	</tr>
	<tr>
		<td><a href="http://weuponithiphop.info/2019/07/07/" aria-label="Posts published on July 7, 2019">7</a></td><td><a href="http://weuponithiphop.info/2019/07/08/" aria-label="Posts published on July 8, 2019">8</a></td><td><a href="http://weuponithiphop.info/2019/07/09/" aria-label="Posts published on July 9, 2019">9</a></td><td><a href="http://weuponithiphop.info/2019/07/10/" aria-label="Posts published on July 10, 2019">10</a></td><td><a href="http://weuponithiphop.info/2019/07/11/" aria-label="Posts published on July 11, 2019">11</a></td><td><a href="http://weuponithiphop.info/2019/07/12/" aria-label="Posts published on July 12, 2019">12</a></td><td><a href="http://weuponithiphop.info/2019/07/13/" aria-label="Posts published on July 13, 2019">13</a></td>
	</tr>
	<tr>
		<td><a href="http://weuponithiphop.info/2019/07/14/" aria-label="Posts published on July 14, 2019">14</a></td><td id="today"><a href="http://weuponithiphop.info/2019/07/15/" aria-label="Posts published on July 15, 2019">15</a></td><td>16</td><td>17</td><td>18</td><td>19</td><td>20</td>
	</tr>
	<tr>
		<td>21</td><td>22</td><td>23</td><td>24</td><td>25</td><td>26</td><td>27</td>
	</tr>
	<tr>
		<td>28</td><td>29</td><td>30</td><td>31</td>
		<td class="pad" colspan="3">&nbsp;</td>
	</tr>
	</tbody>
	</table></div></aside>            </div>

            <div class="td-pb-span4">
                <aside class="widget widget_text">			<div class="textwidget"><div aria-live="polite" id="soliloquy-container-30342" class="soliloquy-container soliloquy-transition-fade  soliloquy-theme-classic" style="max-width:960px;max-height:300px;"><ul id="soliloquy-30342" class="soliloquy-slider soliloquy-slides soliloquy-wrap soliloquy-clear"><li aria-hidden="true" class="soliloquy-item soliloquy-item-1 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109673710?productType=812&#038;appearance=1" class="soliloquy-link" title="Revolt Tee" target="_blank"><img id="soliloquy-image-30349" class="soliloquy-image soliloquy-image-1" src="http://weuponithiphop.info/wp-content/uploads/Revolt-Tee.jpg" alt="Revolt Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-2 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/youngongetthiswork?q=I12154011" class="soliloquy-link" title="You Gon Get This Work" target="_blank"><img id="soliloquy-image-30344" class="soliloquy-image soliloquy-image-2" src="http://weuponithiphop.info/wp-content/uploads/You-Gon-Get-This-Work.jpg" alt="You Gon Get This Work" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-3 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/savage+bloody?q=I1014473415" class="soliloquy-link" title="Savage Bloody" target="_blank"><img id="soliloquy-image-30343" class="soliloquy-image soliloquy-image-3" src="http://weuponithiphop.info/wp-content/uploads/Savage-Bloody.jpg" alt="Savage Bloody" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-4 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/can?q=I1011767996" class="soliloquy-link" title="spray" target="_blank"><img id="soliloquy-image-30345" class="soliloquy-image soliloquy-image-4" src="http://weuponithiphop.info/wp-content/uploads/spray.jpg" alt="spray" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-5 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814012" class="soliloquy-link" title="Good Vibes Only 1" target="_blank"><img id="soliloquy-image-30346" class="soliloquy-image soliloquy-image-5" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-1.jpg" alt="Good Vibes Only 1" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-6 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/blessed?q=I12044252" class="soliloquy-link" title="Blessed Tee" target="_blank"><img id="soliloquy-image-30347" class="soliloquy-image soliloquy-image-6" src="http://weuponithiphop.info/wp-content/uploads/Blessed-Tee.jpg" alt="Blessed Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-7 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/trap?q=I1009984243" class="soliloquy-link" title="Trap Tee" target="_blank"><img id="soliloquy-image-30348" class="soliloquy-image soliloquy-image-7" src="http://weuponithiphop.info/wp-content/uploads/Trap-Tee.jpg" alt="Trap Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-8 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/good+vibes+only+birds?q=I1014476779" class="soliloquy-link" title="Good Vibes Only 2" target="_blank"><img id="soliloquy-image-30350" class="soliloquy-image soliloquy-image-8" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-2.jpg" alt="Good Vibes Only 2" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-9 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/all+seeing+eye?q=I11739019" class="soliloquy-link" title="ILLuminati" target="_blank"><img id="soliloquy-image-30351" class="soliloquy-image soliloquy-image-9" src="http://weuponithiphop.info/wp-content/uploads/ILLuminati.jpg" alt="ILLuminati" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-10 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/diamond_skull_1?q=I12527492" class="soliloquy-link" title="Diamond Skull" target="_blank"><img id="soliloquy-image-30352" class="soliloquy-image soliloquy-image-10" src="http://weuponithiphop.info/wp-content/uploads/Diamond-Skull.jpg" alt="Diamond Skull" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-11 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/donuts+doom-A109792920" class="soliloquy-link" title="donunts" target="_blank"><img id="soliloquy-image-30353" class="soliloquy-image soliloquy-image-11" src="http://weuponithiphop.info/wp-content/uploads/donunts.jpg" alt="donunts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-12 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/crime+pays?q=I12067735" class="soliloquy-link" title="Crime Pays" target="_blank"><img id="soliloquy-image-30434" class="soliloquy-image soliloquy-image-12" src="http://weuponithiphop.info/wp-content/uploads/Crime-Pays.jpg" alt="Crime Pays" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-13 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/fuckyoupayme?q=I11550361" class="soliloquy-link" title="Fuck You Pay Me" target="_blank"><img id="soliloquy-image-30436" class="soliloquy-image soliloquy-image-13" src="http://weuponithiphop.info/wp-content/uploads/Fuck-You-Pay-Me.jpg" alt="Fuck You Pay Me" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-14 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814011" class="soliloquy-link" title="savage gold tee" target="_blank"><img id="soliloquy-image-30354" class="soliloquy-image soliloquy-image-14" src="http://weuponithiphop.info/wp-content/uploads/savage-gold-tee.jpg" alt="savage gold tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-15 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/?page=2" class="soliloquy-link" title="fresh-clean-signature-" target="_blank"><img id="soliloquy-image-30437" class="soliloquy-image soliloquy-image-15" src="http://weuponithiphop.info/wp-content/uploads/fresh-clean-signature-.jpg" alt="fresh-clean-signature-" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-16 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/%24teez?q=I1001415610" class="soliloquy-link" title="gold fronts" target="_blank"><img id="soliloquy-image-30355" class="soliloquy-image soliloquy-image-16" src="http://weuponithiphop.info/wp-content/uploads/gold-fronts.jpg" alt="gold fronts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-17 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/soldier?q=I11611241" class="soliloquy-link" title="Swag Soldier" target="_blank"><img id="soliloquy-image-30435" class="soliloquy-image soliloquy-image-17" src="http://weuponithiphop.info/wp-content/uploads/Swag-Soldier.jpg" alt="Swag Soldier" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-18 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/gamer-A7923028?productType=210&#038;appearance=22" class="soliloquy-link" title="gamer" target="_blank"><img id="soliloquy-image-30438" class="soliloquy-image soliloquy-image-18" src="http://weuponithiphop.info/wp-content/uploads/gamer.jpg" alt="gamer" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-19 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/" class="soliloquy-link" title="freshandlogo Square" target="_blank"><img id="soliloquy-image-30356" class="soliloquy-image soliloquy-image-19" src="http://weuponithiphop.info/wp-content/uploads/freshandlogo-Square.jpg" alt="freshandlogo Square" /></a></li></ul></div><noscript><style type="text/css">#soliloquy-container-30342{opacity:1}</style></noscript>
</div>
		</aside>            </div>
        </div>
    </div>
</div>

<!-- Sub Footer -->
    <div class="td-sub-footer-container">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span7 td-sub-footer-menu">
                        <div class="menu-top-menu-container"><ul id="menu-top-menu-2" class="td-subfooter-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-first td-menu-item td-mega-menu menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_20_5d2c749d88975_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_20_5d2c749d88975" ><script>var block_td_uid_20_5d2c749d88975 = new tdBlock();
block_td_uid_20_5d2c749d88975.id = "td_uid_20_5d2c749d88975";
block_td_uid_20_5d2c749d88975.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"43","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_20_5d2c749d88975_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_20_5d2c749d88975.td_column_number = "3";
block_td_uid_20_5d2c749d88975.block_type = "td_block_mega_menu";
block_td_uid_20_5d2c749d88975.post_count = "5";
block_td_uid_20_5d2c749d88975.found_posts = "2158";
block_td_uid_20_5d2c749d88975.header_color = "";
block_td_uid_20_5d2c749d88975.ajax_pagination_infinite_stop = "";
block_td_uid_20_5d2c749d88975.max_num_pages = "432";
tdBlocksArray.push(block_td_uid_20_5d2c749d88975);
</script><div id=td_uid_20_5d2c749d88975 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/15/new-music-asap-ferg-ft-madeintyo-wam/" rel="bookmark" title="New Music: ASAP Ferg ft. MadeinTYO &#8211; Wam"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4dp3sf6aH2Lg0zJY09wrzrw-abBk5xIVBXar25riFGiYKiskfQq4C9E_0F6PbFYv2NVXwRI_xgJHk8aVydrz9aWZ37suC5_SWZUVAZ4AgOIcvRI2AxDRjCu3ZpdmkN9L2oEcyLM45pes5P6ASxJQ3cRfFzNBd0eISLusjRHMIsfp9luHWVa3IVIU-waKSlsuMlxomJR5ZuvPQzrS-VMbO5KoylvJMe9Wyak5PozOdrkfcAFIZDpZZARbHsb8p06LRTtWD7ZLlgNo_Lv5b4GLB3vDqmWRFqttFOXd9DZe8T7SM0lA9Ho3leJVrObE_Ic0Iue6QAL7BfLPly1i0xla3hIaRNBprI-mhmh2S09-lyJrMFyPHAMi27p0-MdcuG6zXcZh9Do0-1p-7hz6OH7p6FpGwmrHRQ2wvIgM1ipOSb_OZJDGd8E4DYbQGwKibf9KNJTteKktV4pMWj7VisDqMVVbuqZx1gqzY1jG5KBak2AzplJPTOxzFwcYP7UoCFGe_E5-saYyruYS6uzBHNWOzFNysYOjtXjgZpPAWBul7pzX4E_vWk5bzVxEtt6c1z49EwHA6H9FU6UVntUxresjQHySlQafvpMOWdh4AwuGwqOKG6Efhl0Lv7mvDJi5yT1ZJ9H5srku9bGvkeOFnglDLXeyPYJpYxAC=s448-no" alt="" title="New Music: ASAP Ferg ft. MadeinTYO &#8211; Wam"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/15/new-music-asap-ferg-ft-madeintyo-wam/" rel="bookmark" title="New Music: ASAP Ferg ft. MadeinTYO &#8211; Wam">New Music: ASAP Ferg ft. MadeinTYO &#8211; Wam</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/15/new-music-tobi-lou-tony-bigz-my-party/" rel="bookmark" title="New Music: tobi lou &#038; Tony Bigz – My Party"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/505WYwgCjYcg6jFq28W2a1NYbcjm805PO1DhMIFQt3z2MpzCcftfaGFvuRYYhM9JTeNwuPelMhx6tmaUYFwjVRTv7LoXI9RdoFq62n7JfO79YsdC95jeOsivKcBbzxZR0bwXoXWAhu2v9ZetWwrkpfxsDaflopXGqG9IGvfnQyQOGPJ50KieNX08J3vExb7RUkRrU_R7vjLv2YJOSR7wuvIDd6XtEeIwSX24HE2UYHnqaG861VArQ_fB5pTp5_mZNTsKL-TKcTgtHcaGRFWotUoAzZU_d3xX3pAsCCJxlHnB6TJn7gkXc7ULGbvraHwNH0fhlaNOz6nkcxmchYH_nv0RJt-AVQx6bmgdfadYB0ASP76f34yPo8_Ua4L2pxY8xxty9OwU9GWl2_ksJPuBJqaHsPxq060X9dWZdz3cL3uETft9H0qpRF5Uyr07P-gxB8UdhrtLwblX81UbqcyKWtDOB2D5t8jjHE9UXGX8PBbD-UbSu4BuURLFQVL2-1WSx9LQpiCfk_KPrRAQULk3Tborj87M2RCdgPckbW5ncQYYDXZvvQt3HEM3ndnp03qvuXicBh41RUcPpuOekVnSRlD9AIzLi-o2kIeT8Yy6U_2d3oM-CvU1ykUSJrhtaFbk7Tk2UpBCAjMjKmWZcUeHnyFfRiOe0LVX=s774-no" alt="" title="New Music: tobi lou &#038; Tony Bigz – My Party"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/15/new-music-tobi-lou-tony-bigz-my-party/" rel="bookmark" title="New Music: tobi lou &#038; Tony Bigz – My Party">New Music: tobi lou &#038; Tony Bigz – My Party</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/15/new-music-kevin-gates-neva-land/" rel="bookmark" title="New Music: Kevin Gates – Neva Land"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/KIkVPMqUPgKVb33-d6-dTtrilavLqhVwRYhGcSMhSfUcoNktrYTwSy9i5s1Giv8ecSe6qBWCeTSgRT41H_rvKakilpxf7K0w3JsONH5wXXJ_TnL6hTzzezh01NrkzH3rdXAu2iHCV29aq_E7FMmfaz7BmtUWy2gKeMKok-Ub9KINuEm9g2CULFOOKxnIXoTfQHyY3R36wPAFWd3f4S1vyVUOAa5mZYOfa3T1DAgaWv1DhYs3d4sQny48TK5vgypORZwUpI8OdbsqbOBlhIhLrgr3SczNenPQbFlqq7f4SJ21ysanjdppGfg8-ODwRICQ-EWGePaQtCcghWNPAOUbXO-Upg0g4yxRnEqDd6YcpvYXjtpk1tn4QDlJDPKpHGFjoF9kXODfXb43S34XRcvvovhIPsHHutrXbgKquvECPELnpofrrXiL7gNty7rzuCtZ-SeaZxJb1qpEtQfzVFeCFItgBwMnwqfuAYefzR72G9E3PREi-6Iw0h8We-rbaPPXd2ZDxchoj4_01JFw-lgr2pupg10Skk3-b4WqoLAeEBw59FOdYrZ3sXyIQOX1ftfdo9rKM0xboQy68rCU9WHtanrhd29n5F6ZNNYpZgXtFo9aSJL-8B0R2bpPm2uawlXLRS7vorILewBzdOyoJsdsDqZyAB-QEgXc=s774-no" alt="" title="New Music: Kevin Gates – Neva Land"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/15/new-music-kevin-gates-neva-land/" rel="bookmark" title="New Music: Kevin Gates – Neva Land">New Music: Kevin Gates – Neva Land</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/14/new-music-kevin-gates-sober-state-of-mind/" rel="bookmark" title="New Music: Kevin Gates – Sober State Of Mind"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/VHNqn04EIvsBDFVA89N3Zq55CYrVa0TISJHevTZDWlGXzIP2c4jKuzCuRTxgTmLG1kW1shs3hgX2QBgpOW7KZif3oG7wNk4QRXMOWjwOwWXzrGtjBfrFw5U73lHOH50HJvxwCiIXbHFysP-6Vzh14MKSCbOtOpP5H3MV6boyJqn3YhhSiC1pJzKH5WIvnpu_4353NufC_7zu75agbdH8Gmj0xUyVQKqlVC0vr1Yt2ZVfDyArL1ft2Akq0sQAe-9_NUCdL2qx0_0vLmodpXGa-0Rl-1uoFQUYtLGWpsyu13s3qdn1MOt_BYVPLV4EykCyomXkwAU7NWdsmvroqiIzZkTMZld-YYuuZJdsNtG0oTrCcmcWfw4wgXmU0jcUBUnZlFpYFhHlB3Ddf2C-NwBKCZn18K2tT_rDvhaBjtnJDNBs-XXucpso_VzTnwGNlPgxcEEUyQg1oRj5n2YxZ5kwubNaFiHh_lSC2GOqFypSX-ZxTXnXn6OYm993AUu6ByHUeT9lm49FHF-35ggpXjDe_krj-uIxNd-jGxhfOqxbmhEHS4HVF5RIyun4Wgh88LJ4oRbsRYfyKGStipxxgDQlMqdX5XpoOenQC4LOUiZc_lrudgMLZKUuJZjBdVAr-EDQmhx_CQmKINu5h5JgdxoMW2twlzhsayP2=w620-h616-no" alt="" title="New Music: Kevin Gates – Sober State Of Mind"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/14/new-music-kevin-gates-sober-state-of-mind/" rel="bookmark" title="New Music: Kevin Gates – Sober State Of Mind">New Music: Kevin Gates – Sober State Of Mind</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/14/new-music-baby-keem-france-freestyle-4/" rel="bookmark" title="New Music: Baby Keem &#8211; FRANCE FREESTYLE"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/0RxH-BmDsutyrnAgP9lVIMy7V35ZK0pUM1DIq2bDFCa-_AkQZFTHF791LJ95xDPjZ16LbDe05rQEnrozziPifHx9jXqBp_YBl2NAqy-DnWKf1Ao8r87FUVPpgrCRSGsiyKEsC3ON-jSYLwYKfSpCVwt5YfFjagNjCGexEkIETJAdqBbFKdfhhwsw4jXQ6KD00J7maUm-v2XJ8Q889Mp9lX4kYS2Igv0pK_r5Gf1u9lXkqD889hKrWDz8j-a4E5NWqog5wmp1VusjQJvyE-kb78R6oeCT1m2z3FUSeY4kte8Pmpcho1GQfNTSEj8UIoT1zMGqROdeGgqgzRku_OPMNONHWcmKbHzga6ko_j_ZcF1LdZduyyVDRqVeo5VFWu2EsdFPxamqClyQStx6PdRg8JFmubKC13NMWT3nYoZnuq-uMzg02jYq44EK9MCl6QvDaWuuIZnshiupyEG8FMci4SkgmOxDCV7DiaAzBOyxPkMDoCv9nVZfs_IDB5O3PGR1iHlPHVYASE3ml5Nh0irXmQrJpxTxhFPlUuCZzb1S2ooRQvvkkAkkSPRC0k35MW4Y7hyJQLA5m0HODVJrPatS8yrx0imEANM0X9gBq_4AT4tNZf-XF61rqMvTZ9FSqFuPNq6Ila7JyXsA9kWJTe4CNgfYZ9xw9Hwf=s750-no" alt="" title="New Music: Baby Keem &#8211; FRANCE FREESTYLE"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/14/new-music-baby-keem-france-freestyle-4/" rel="bookmark" title="New Music: Baby Keem &#8211; FRANCE FREESTYLE">New Music: Baby Keem &#8211; FRANCE FREESTYLE</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_20_5d2c749d88975" data-td_block_id="td_uid_20_5d2c749d88975"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_20_5d2c749d88975" data-td_block_id="td_uid_20_5d2c749d88975"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_21_5d2c749d8b645_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_21_5d2c749d8b645" ><script>var block_td_uid_21_5d2c749d8b645 = new tdBlock();
block_td_uid_21_5d2c749d8b645.id = "td_uid_21_5d2c749d8b645";
block_td_uid_21_5d2c749d8b645.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"97","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_21_5d2c749d8b645_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_21_5d2c749d8b645.td_column_number = "3";
block_td_uid_21_5d2c749d8b645.block_type = "td_block_mega_menu";
block_td_uid_21_5d2c749d8b645.post_count = "5";
block_td_uid_21_5d2c749d8b645.found_posts = "810";
block_td_uid_21_5d2c749d8b645.header_color = "";
block_td_uid_21_5d2c749d8b645.ajax_pagination_infinite_stop = "";
block_td_uid_21_5d2c749d8b645.max_num_pages = "162";
tdBlocksArray.push(block_td_uid_21_5d2c749d8b645);
</script><div id=td_uid_21_5d2c749d8b645 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/14/mixtape-ad-by-the-way-2/" rel="bookmark" title="Mixtape: AD &#8211; By The Way 2"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/eSVCwVzcZPdWIRV7kNKSLXIPCliqcyXRPcDM3BZ7izVRskVq6GOiEubOM1bP5RrK8jp28ZgjxSPpJ7z03CeofLUXE08tsOvap8tBiJ8j2w2Mus3XDp1uxxTJHyV3STROeQH9LH47U9k-D37OSiZHxSkh0YZzrINJsok2QGrZElsJJCtebjts4SQK0HEK7-4BuXeyg37-3vtOryGNr32Fy3B0X5_svdSZJBcbPTNehmMHmTI8OG4YnzgupnW-dcF7aWaZdflyL05uDSvFT6gYYQnker7ufBEiC_cBZaAE7RHHTwAIF54FgORDgYybzgnTJewuPRNoHt_egR8570lVyCkiIV3hEd_G_IQszwERnFDnVbK9wyKKRmdkyt2xSrmbbJlPXoLDTT9leYWkRmpjFpCPjr7u3G3TrsAwMWQeLmPU67YEhi7_wG4jsrFEH41ZVItXi_7fbWqqdfhR9O6wx5kMmhVyOaFNMhUId_24dg8rYJ_H9S5z8vMfRG2RnLvXzCR8zZh12m19dU3sXqNhVpxVhLKK1Oekj01bhLX1OwxpylWp-SppgkYwSAeYgmD1AhUVWVyPvIB-Cq1fnYjTWmxjie0GtNNYTd8SRgl_1qiDio3ReZCsCB1VjgXne3gaw-Wrid6Q-cWFbstdaRm6VGRyj7YhDmHO=s774-no" alt="" title="Mixtape: AD &#8211; By The Way 2"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/14/mixtape-ad-by-the-way-2/" rel="bookmark" title="Mixtape: AD &#8211; By The Way 2">Mixtape: AD &#8211; By The Way 2</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/12/album-stream-big-k-r-i-t-k-r-i-t-iz-here/" rel="bookmark" title="Album Stream: Big K.R.I.T. &#8211; K.R.I.T. IZ HERE"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/0GhVL3hG5U9ogcJQCXDcOnTCbpk9sekhPfpIC5X5vx3KjpsPKoSM1hS3-96IiTC-rjPoK0Gw3d8=s328-no" alt="" title="Album Stream: Big K.R.I.T. &#8211; K.R.I.T. IZ HERE"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/12/album-stream-big-k-r-i-t-k-r-i-t-iz-here/" rel="bookmark" title="Album Stream: Big K.R.I.T. &#8211; K.R.I.T. IZ HERE">Album Stream: Big K.R.I.T. &#8211; K.R.I.T. IZ HERE</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/12/album-stream-ed-sheeran-no-6-collaborations-project/" rel="bookmark" title="Album Stream: Ed Sheeran – No. 6 Collaborations Project"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/WfJqyH4JfPufDal98NaPwo8cKByjzsmgiWG15hY2I164Eyr1HC-hv9NTl3PTKE_-Hvzm8j6Eren8_XyGRVq7hel4VySIPzxSNRvyahMIBXvucfD5gOLkAUyD8EpxUoCpZcW782UnXxSitDzIwC2M0W-SqRE6H4htOOCsK2jSt1yKpBuMvO3pSOFcCuaACpyy7CD3TzKZ16S-IgNcre6WFboccVnssWWePC_QMutbArt61CqpGelF8oJ5Qo9EFKQj6dimi9PQtASYEL_fB7oMCL7TvnjFqgL2UrNhb9NFKyfDCVrmIuaMq5FRUIQc38hXWut2ji7frSLuaLZHYwt3e_i-Dmax3gcmlTJzVbPcnGSUH35fF1G2NioTIR0ixrc7LhCWh75F48fbLy_XcSsGXNAKmyDeoVaB0-EfFEJQCNhjmrim9qu8cfMaUZnQcG9MJzoHWnCWB8gbGbHJCzjzUiEIEyuJNybGKs5NxsqZ7ZXLeDyvB1EoOoF4dQnokOhYpcHVucPARUV36AzlXk6OFai2QWfBQP7xKc1hzRYmeZd2kIx51VC8RSNtvgYwv1vBu00f0skZjnVPUHtvzC0Lu2GPEYRe-aTQ7C4XGjzy0Yq1vh0WAglsXpmXGexTaozrJnMAQjbnikvFxjlad9OJFOMiyCf2t8fd=s624-no" alt="" title="Album Stream: Ed Sheeran – No. 6 Collaborations Project"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/12/album-stream-ed-sheeran-no-6-collaborations-project/" rel="bookmark" title="Album Stream: Ed Sheeran – No. 6 Collaborations Project">Album Stream: Ed Sheeran – No. 6 Collaborations Project</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/12/mixtape-lil-duke-blue-devil-2/" rel="bookmark" title="Mixtape: Lil Duke – Blue Devil 2"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/Em2iP-bkx-xssV260_47w33p3GLCijX8WDudqNnh4qpnm6_fbfhlrpy-2itSOlRAeyPWMISmMBOkE5rnHwVa8I3jqXxnt1dVlhoE-E4yYNsmbUoII_SJegHh_o07ykgxD8fhdyXHxpSLLmIDmvPctTM8heHbRZZCxJbHoyEW6OaUD1spJtp-KoOtWVsIl7DcXszxZL08YuzurE6HyKq5pg2eZylsK-1BpUYeJ1lcYBhn1W0-WpH4MEavIuqOg5MPRxCXbi9iKZdW0DtVdSSJuV-gZlHQ47x5vpzzNLkyXA91GVH01-KjLwfW85ILTBCO1EFzcG0PTp1T1EyP-adnVaJc3jUYTDxpzsdcTkL23YfJdKiZPB4MBCz-XvY-DnJ-ZDZhQekhsPJV3-rQ8gBbtuCtIWgBIgXruoo2X0JSlRryrBXWCCCV4NnwxTyZnnwdHU0QI_u056L4G4JvVaQUZKDUydFP_o3Cr1em9J8MrX4xgfWFeI41ETDIqXB1n4-ljUV8MmBdTVyJPM-0lHScmGFLTvWAPz40akgJlhjOFWlTWE2-mu9WofCD0Ah3QbGkcncZALsudIMvVau-374qFiL64QY5xrXzp04OkSLQJLyaTSlBbfYHBN09HzllrB1R8GXhXpFtB8GEMVHWsX4zWgHSBrmMHHOP=s673-no" alt="" title="Mixtape: Lil Duke – Blue Devil 2"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/12/mixtape-lil-duke-blue-devil-2/" rel="bookmark" title="Mixtape: Lil Duke – Blue Devil 2">Mixtape: Lil Duke – Blue Devil 2</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/10/ep-stream-latrell-james-still/" rel="bookmark" title="EP Stream: Latrell James – Still"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/pwDiDQXrmKLS6kPuUfDXsavKPZvOtl9JPBX0KGLPoyLQ4SME8RFeJxlS7aazfbOhH9iIZmmf55d0-45cNGYvYQTAyHqtWIYCSHeoHCG0BXBoSrHbyAkaYy7vIYgwqSut-LSlrZBnBP-DAwKQCYB6tlSXQj86yxc1-nX7hiEqaWA7Y5bz1ZzE85V6l_g42YNZy2VgSTqfJZQZB7Ma8SOCPFBmPv47_1pyc6wtRCjPw73ewetEVQs0DSKn8uUQbTWWAjWryJiQRZVHVTjyXkgpQRpMeyXgCJA7MQEW655k6v3ZgHCvz3ih7BGW4mCA6pFwwiPqB5On_zfPqZ5FfWjugRZ44-3R3QChMpjj_pLoZIWXbmVF1m0_5O1sTTCUxNSe8EZxKCd6I00uKM6_RVprWZzywNdRFdAzvmVdDrW5TQpmc3TtNLmHp8FxRp3wTlXAkApTMpu8Z7y3YG4a607vsi4lFQndwr8zta29k5A0_RQJFAvbYeeCYARyYDNT-14oOUwEM4Wb-M5JnLtDoWFYyadmYbIN9pevR3BFAbzLUI0lMa8LnpNevKIPtnPDf9uJk16ob7HaOlKjCo-mttuCcE5xY1u2n57B81eeGYTYZCEWUqG3uxykL3yvNyNYB5CZsBKWnDPQW27cT49tjSJS2OYOmGjAC_k1=s732-no" alt="" title="EP Stream: Latrell James – Still"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/10/ep-stream-latrell-james-still/" rel="bookmark" title="EP Stream: Latrell James – Still">EP Stream: Latrell James – Still</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_21_5d2c749d8b645" data-td_block_id="td_uid_21_5d2c749d8b645"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_21_5d2c749d8b645" data-td_block_id="td_uid_21_5d2c749d8b645"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_22_5d2c749d8ed7f_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_22_5d2c749d8ed7f" ><script>var block_td_uid_22_5d2c749d8ed7f = new tdBlock();
block_td_uid_22_5d2c749d8ed7f.id = "td_uid_22_5d2c749d8ed7f";
block_td_uid_22_5d2c749d8ed7f.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_22_5d2c749d8ed7f_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_22_5d2c749d8ed7f.td_column_number = "3";
block_td_uid_22_5d2c749d8ed7f.block_type = "td_block_mega_menu";
block_td_uid_22_5d2c749d8ed7f.post_count = "5";
block_td_uid_22_5d2c749d8ed7f.found_posts = "2179";
block_td_uid_22_5d2c749d8ed7f.header_color = "";
block_td_uid_22_5d2c749d8ed7f.ajax_pagination_infinite_stop = "";
block_td_uid_22_5d2c749d8ed7f.max_num_pages = "436";
tdBlocksArray.push(block_td_uid_22_5d2c749d8ed7f);
</script><div id=td_uid_22_5d2c749d8ed7f class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/15/music-video-lucki-glory-boy/" rel="bookmark" title="Music Video: Lucki – Glory Boy"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/D-w03An01VkvwosRXDR9MGWEdPYVGy4Ny9ynZvXr4hAN5iaHWhImYLVLlhquYvcEgUrMlYeRjm8jYDzQ3hiq5oDiGV2AuDiRBS1gNfwwtARng8nAimbvQETJ0jKyEIv-h9qFT1CuiH9seHOmoOJ4PD8z0bMz3fZ7_OgbgZm_ZaSHO-yj2GVaspm-B1BB75JGZH59sl-O_NzqIs9NyZJWw1mpedd78d-rOb4TWFvJkquvUy6iQqJJFTxm2U7y9av40pu2DKYBRaFCG4aAFEG7mEnf3p-_uld9E1cGP5BSpwcB6lhyBm3jOIX99AjRS5hqoLTn7oRtEZbLs0hcEUjLcMjQoDj_8qkJD0doPW1vUF70ojs2OmILlX3cjFn419OGqhNiw7faBLVZ1R8sU6zh8MaJjLu_emjKoi2Rg1z9AHx4jTNBZtPPW-nr1rMwe8Sje-GZIjKQg-sONxfVtVb-oJbhZYmMD6cjJcYoTWtl21NSsX8bGjGhV42miBRp1UWTAYEb0sUG__ZnibevWXwC0oszM0dxlFjNhhh_xnhp3NZ8wsVZhmO0wfyIP8PM5anG1LLYIbyc2F0WLvGP7_MULqXd2gNewKHB4gZIhVEllVdh2A09tiGST4cYYdjn0DYj6sJKG3me0STHTIDCXSvjQl0tkJqhx2x0=w974-h564-no" alt="" title="Music Video: Lucki – Glory Boy"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/15/music-video-lucki-glory-boy/" rel="bookmark" title="Music Video: Lucki – Glory Boy">Music Video: Lucki – Glory Boy</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/15/music-video-mike-posner-ft-ty-dolla-sign-look-what-ive-become/" rel="bookmark" title="Music Video: Mike Posner ft. Ty Dolla Sign – Look What I’ve Become"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/9bCdwznc3nGem_ZsYDNX2IeE2C60Y3VxFeejEC-r0gUwNFn2jqpgBdqv03fHULKjT4LYPUpT5Yg1T2xO_FXYgVSdCrtx7UHE3kC2tv36Exkp7Uh1lW5ds5pQmQiVDikamqEXe6YALtF_EmpFEbeZQ45O5v3PUtX55a88lFSmKXF6djUZKeTxFYy4k4Hl8g1uOzDTw8HQHzSiJxDuTeT0Z1Fqe45tvuAqGPl6gSKcBEbcAlf9kvFpIUBDBbiAmen5XwDQlrIYrxTPHV8jv8GGFbr0KaTy2ESxUKrevJ27Fu7hp0sCXc9X7mkZskxEkX11WEziVztqbz8BwNyuMgiz4ENYKLld6S87tJtJOlNViobY2WI7NAPo6nkJswm809nDXshlhqZ0p7X0QWaHXu3vzuqcZyWMuLCSqoE_mwgHr9WsW2IH621IiNS_JCz0j3luG-POQFwoa3c_p0zaEebwS-HnWSR58i26Uk8ijLDdqjwMnHb76FQXbiIn9UHi8Ih4bogXIurrw0uwkn4mM24w7C0jExNFbAWAb_63X9KYaAywKIgc1B7I1avQ8u9JQhqzn0bGptZDbQSj2pNAHj3U5zVu07U4B3w38rFAt4fRu27JEdOwcC4PuqBEL_aQBDaD3rzEtg4vskJM8AB79kA7Ghi51yE-RzmX=w858-h609-no" alt="" title="Music Video: Mike Posner ft. Ty Dolla Sign – Look What I’ve Become"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/15/music-video-mike-posner-ft-ty-dolla-sign-look-what-ive-become/" rel="bookmark" title="Music Video: Mike Posner ft. Ty Dolla Sign – Look What I’ve Become">Music Video: Mike Posner ft. Ty Dolla Sign – Look What&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/15/music-video-bandhunta-izzy-ft-yfn-lucci-made-me/" rel="bookmark" title="Music Video: Bandhunta Izzy ft. YFN Lucci &#8211; Made Me"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/SMd9vAz75YNVeHLuGik8sSfkrvQSUO4L7YEu4k-njjaNB79qcp09wk7tna4t4G7qEBpJuzj4TUbaxwufWLIC-fyAEtinCiT12_3umsWoH7zkRhoqhBdwCGdjqhoEZ8cz1Iug-qr10hrRqBY1JdOOT9lynMQ7RHLzAaVUwIR05Yt_2GcagfxfBB957OLKmoThUrj0r_BiLT6-rgiuZhg7DuQmgaKMoLOdMbca2SMo3813m7UJgFWoranDg-I6Aj9_fEeKlNjY0Zp-vgHuCy36D20quul_GEuD5THO-Gmqep0PWCfq8LgoJ-nvpHXYmlMTKzEZa-RDnXctyywzd7l9i-nhzE2tsiPsjiA4tNB3bu-w2WDT-Gzd_TrPAlBslN78UoP_nODmFRTAKurREkLQzw7wTdYuIfr5riUKEeCmzR9OhT8gPeFfMrJAhcg6GWa2IaF5Tikuqu_eyU4yV3x0p6mw6gSD2JdifXDErH497lVjud_TGiQyso7HO6egUdroPt7G4ZZ_Y09SQLZ9b3hMHPCTKNSjQVoyh-5PmOZBGH_oPYJm4rAqCXsUiXTJHtEG288wxJ1QUuji_6rPNNj09eII758f9CkWjbIaJj_58O948qczKVg0fGC50hpM11c3ilHfZQ4gnU1H85v0sPRJ_rgYFh3_tw2n=w372-h220-no" alt="" title="Music Video: Bandhunta Izzy ft. YFN Lucci &#8211; Made Me"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/15/music-video-bandhunta-izzy-ft-yfn-lucci-made-me/" rel="bookmark" title="Music Video: Bandhunta Izzy ft. YFN Lucci &#8211; Made Me">Music Video: Bandhunta Izzy ft. YFN Lucci &#8211; Made Me</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/15/music-video-moneybagg-yo-ft-gunna-dior/" rel="bookmark" title="Music Video: Moneybagg Yo ft. Gunna – Dior"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/3oV8HCLEt15f3-FKLIX2g04Yblip3eDALrKNBTE-BYrzW4oixvYMM69SSz91AJJ8fjcK8qzFjAg39d44ZqrMQasHGIs77APcj_5gNJW34-f3LRbEBfEmCS6C2NMVEznRwIsqWyPBceqnSVZTJlMOk-mFp7l6vUi3MnrHWcFLJgNmIFzqv-s0-3JKyFjQA1hZH3rQQsHOdjYJvrKNyI7AP3q4cyFV0GPhrArYJ3V9rnTt_wDTp73T3zIkm_G2ikl1PmBm1CLdz5i01dfgkTA3v9khNctahJtr7yiJ36NL7YJmxTESVJbretFlYyfw7XAANLOPlCavnT4FZrF-xhGdXbZq5Me4LdP5JFvAbLfr1v73RdWn8SIcaABA42HA4SGW6MBKaGdLGgEbq-k6iEj1Hw8WWqTEytM1EHcoFKZiwiK4vQ3oqYfivrSQVU0D1c2mtFO_vORrF6L_VmG5XrzVeMNZ9-qYeJ-w-1_NtPyTOX-oHMRqKBxYxmcSfcwy-nZREd6xuHB3NyBf7expiI0W6MFaWPictl7ImceXS6gLywq3QzCkAdoEt1mnW5XoksVqJ5_YMpqOuLLivrWwNKllsZMK2SQ7IdiKS1CnnSj0Ah3RKt7PPDrcR73csCwiUk6EoToebUs4i2-wYDzYvUyWfLTzcytixfhU=w1049-h592-no" alt="" title="Music Video: Moneybagg Yo ft. Gunna – Dior"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/15/music-video-moneybagg-yo-ft-gunna-dior/" rel="bookmark" title="Music Video: Moneybagg Yo ft. Gunna – Dior">Music Video: Moneybagg Yo ft. Gunna – Dior</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/14/music-video-stunna-4-vegas-ft-moneybagg-yo-tomorrow/" rel="bookmark" title="Music Video: Stunna 4 Vegas ft. Moneybagg Yo &#8211; Tomorrow"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/rGBfH2zyWYEctMQowtqM6kH76S1FGx_cvXJ0YcIIb9PNBo_AfFghX1n0yAPj1YeogovT7aDHqAUgl1U8QuQGFSnKBr1nvUVRoGRCt-h_s_gT0VWD-UxnuoreXevUeQaxTf_AeQ-VlOwRzMFYz27bZYSYxRphueTkKrVuQ7WgosmeLfvdCV65gvdCG9hkqUvIGOFVxtpUu2RbAxHsjmx9WtJlMlr-XhZq1rbjPGNAmHoecZMPOK3qOiFsDEtekM9NzIxdMWqmPb-2Gn2rIP91ocKzusZWxYWYDvrV8ND42QgJ4zMECfhYgYOREWvZT27hRUAIX1fsxawfhniEMByjlx6JiozGBPVoE8NBRJbgFIrkAaOQ_kFnH8Du5oUaiUStRt7xUbdyFkUh7IUSbahthOpWYrHQ3OlHf_bGyOxWQtxxv1qmxrgoQ4gH9TdHtFqgFnKCVcD1M3ltmd8rqk7pRylTVaVC3MDcVW5tyfTPUIcp9IFyNn7XJjZHivVVtXWFWfcwr35OCF2ScsN1xGwcsbWYWp_vagTFg9x1zXCH63qc1No3yqY2s8Nw0jMeDlC6LbxTd0EJnAmBSoG6zHTexLudHRn4VDWhAP0Nir-jdh9h_pfdEYx1nbrpxRXC5i7qG2MlUNrx_DkeEo4hDArp5TDh4f6ncFKL=w335-h195-no" alt="" title="Music Video: Stunna 4 Vegas ft. Moneybagg Yo &#8211; Tomorrow"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/14/music-video-stunna-4-vegas-ft-moneybagg-yo-tomorrow/" rel="bookmark" title="Music Video: Stunna 4 Vegas ft. Moneybagg Yo &#8211; Tomorrow">Music Video: Stunna 4 Vegas ft. Moneybagg Yo &#8211; Tomorrow</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_22_5d2c749d8ed7f" data-td_block_id="td_uid_22_5d2c749d8ed7f"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_22_5d2c749d8ed7f" data-td_block_id="td_uid_22_5d2c749d8ed7f"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_23_5d2c749d926c8_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_23_5d2c749d926c8" ><script>var block_td_uid_23_5d2c749d926c8 = new tdBlock();
block_td_uid_23_5d2c749d926c8.id = "td_uid_23_5d2c749d926c8";
block_td_uid_23_5d2c749d926c8.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"29","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_23_5d2c749d926c8_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_23_5d2c749d926c8.td_column_number = "3";
block_td_uid_23_5d2c749d926c8.block_type = "td_block_mega_menu";
block_td_uid_23_5d2c749d926c8.post_count = "4";
block_td_uid_23_5d2c749d926c8.found_posts = "787";
block_td_uid_23_5d2c749d926c8.header_color = "";
block_td_uid_23_5d2c749d926c8.ajax_pagination_infinite_stop = "";
block_td_uid_23_5d2c749d926c8.max_num_pages = "197";
tdBlocksArray.push(block_td_uid_23_5d2c749d926c8);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_23_5d2c749d926c8" id="td_uid_24_5d2c749d932ba" data-td_block_id="td_uid_23_5d2c749d926c8" data-td_filter_value="" href="http://weuponithiphop.info/category/latest-news/">All</a><a class="mega-menu-sub-cat-td_uid_23_5d2c749d926c8"  id="td_uid_25_5d2c749d933a5" data-td_block_id="td_uid_23_5d2c749d926c8" data-td_filter_value="69" href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a><a class="mega-menu-sub-cat-td_uid_23_5d2c749d926c8"  id="td_uid_26_5d2c749d934c4" data-td_block_id="td_uid_23_5d2c749d926c8" data-td_filter_value="80" href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a><a class="mega-menu-sub-cat-td_uid_23_5d2c749d926c8"  id="td_uid_27_5d2c749d935d8" data-td_block_id="td_uid_23_5d2c749d926c8" data-td_filter_value="2189" href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a><a class="mega-menu-sub-cat-td_uid_23_5d2c749d926c8"  id="td_uid_28_5d2c749d936f1" data-td_block_id="td_uid_23_5d2c749d926c8" data-td_filter_value="10" href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a><a class="mega-menu-sub-cat-td_uid_23_5d2c749d926c8"  id="td_uid_29_5d2c749d93800" data-td_block_id="td_uid_23_5d2c749d926c8" data-td_filter_value="130" href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></div></div><div id=td_uid_23_5d2c749d926c8 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/15/video-young-thug-no-jumper-interview/" rel="bookmark" title="Video: Young Thug &#8211; No Jumper Interview"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/on24o5-Okm_VMtDTGapVtVOhFpPSXa9ygbfJovZE53wlVpQrdHAmXcotsIOpodI0qNCKC3qnqSpPC_hXjO1RUzDjSKnMZYJbIT_UcMeLn27gRpgFvAhr2-dzOFijB3ESf1EY2NNeT2-mAkF-qayh05FlUbGkryPwpYIL-P6hVqlvBIblwQ38Z6ThxOoliT80Hno91YPyjqNdRK1sFYheCOyCepT5BAcIWZnldNWIp-vA7gCuD2oQBkhIbsU7yZ3r9hW5uLmlp8J_nnnWDa-fQlYV7MfcQcRAR6eTEG1Eh5O_3HtlVUZF2mNcFJ1MASYSUhSlrpdqgHQeNWMmoKd_m5upHNFRNjtvV63XhiJH-M7J2GATBWNuTbVIeNVjt09N8Jxe2RWyTeqZkGgST-JTVxE5HbkrjLfmvpW2S0Xjm4AIOfnx5TBvth1Al0lo0-oLddrAgzbNprc_7Db7lIPWqDtq-MhlkdIHCrk9vXzcmsYIpOp2Iv7XTQQqTd-bIoYmjUnD_eHfzWi1Y8wm9FCDcd8MWI3OuOMplMEqTJHGSjFWbYxzQO_jiaWZxIho3Q6j8kKKMgoCRAmFYfbsLZFULtKT4OD6MGdiHqOzjV5KiLR6YJNk0RPt_4OKgF3eJQHmXvF73iNhobZVEjTqYr-0M0xSz_TG_Obu=w472-h221-no" alt="" title="Video: Young Thug &#8211; No Jumper Interview"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/15/video-young-thug-no-jumper-interview/" rel="bookmark" title="Video: Young Thug &#8211; No Jumper Interview">Video: Young Thug &#8211; No Jumper Interview</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/14/video-zack-fox-kenny-beats-break-down-the-lyrics-of-jesus-is-the-one-i-got-depression/" rel="bookmark" title="Video: Zack Fox &#038; Kenny Beats Break Down The Lyrics Of &#8220;Jesus Is The One (I Got Depression)&#8221;"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/HuYtHWWo8YCAMHaz_Q1tPnxllwCUwZ4HVWSiM4Md9HQaHz-SeqAZtGkAZ6SfO7vGzMAbiznQa6TrynnN_3cm434lsO4ndsy5ix54x94UnK_0Nkgdysy1v9UZyJwtw2UF9O6mVA3rnvG5_TLr7YAFwc8SWvM6MuqQLpQn33OYl0VSIWYRLUJb-YCsCSTUL-NJPpziryoK76bS-godu-dKSKeuLI_kdm_Et9guPDFl0rgwGmois-TfC5WoSrTAO_j4w0qRTdvDzJG30jeWqmYmc-qRhwLNY3O9jpUwXnEUTmBD51RilsPCMIwuPURqTTXttNZqqIV4UIqmOn8spTX1jdpd-CaGyW25VV2As1UG66DP54p3LeI6q_izTCmDJlchj2qmgqyimNrgKBxUPYOVE36US2nPmvedN4f3r7jbHjVgiLa1vCrsAZ0t9QjbLXbhU6EpuJXBR8_PSP-dKjBvfAgNQrOzNajB09OxVQerFNdjtxjDG0MeSfjzrF6YQpkRsohrkSEJBkN8Hwkr4ifG5yaH8BhpeHWDyNncDMHw7hPWZSe8UXVpmx-lcHYdiZVhT7XduzyGNCTCa9S65Xo0Y-SR_7KdC3hI7e8K13-XCDSH8e96HwLO2MFBXBwyZCdg1xkA1Gvg2i5jqZ7OgPv2H5t5DUdGUcnJ=w1109-h592-no" alt="" title="Video: Zack Fox &#038; Kenny Beats Break Down The Lyrics Of &#8220;Jesus Is The One (I Got Depression)&#8221;"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/14/video-zack-fox-kenny-beats-break-down-the-lyrics-of-jesus-is-the-one-i-got-depression/" rel="bookmark" title="Video: Zack Fox &#038; Kenny Beats Break Down The Lyrics Of &#8220;Jesus Is The One (I Got Depression)&#8221;">Video: Zack Fox &#038; Kenny Beats Break Down The Lyrics Of&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/13/video-mya-ebro-in-the-morning-interview-6/" rel="bookmark" title="Video: Mya &#8211; Ebro in the Morning Interview"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/cZeXa6DXoCkhQciC-PD7kEkLBwIHILYPltM6HiFnk3yBp4xb-ZzAG6fwIgB3epdZ9zqdWKD7OJQn-iVfy8_SCLNLUxmNeZQsvyunoVrKgKUexYsBZBbh4TuBbI5Xdn1C82w88p-9vf64YfwaRuMJQvHfc04OAay2Y-c93TKb_Za0jT0PAG1hE_4wY50OYEPiqkxY6NgTQg_TZDNm8leXjZbDNblb5IYQVY-9Nd5apAoKemo8OITigEZmdz_kxB8uT6qpXbWb-Nk_1a2rmDDNG94WWMCMayVpvTuf67aqufCtu9I38F0ja1MDfAOdww4zLDzi7Z9YYDSK5CvASRTpBJU5jwz_hbNpyaB6FXF6Zg5VLfF7UFFU9SqCyypEj9hbmLKklb814ygFjF7AVqLr-Q3W5xySmpvKmXURsQL0Kbx4RTluW-YSM6yw7H5VFclFkBskgSMJZMfQ3iJiRU4jGY64vvaJEh_xkwdMQo6ica6I6qzh4uk_PcWYlZNyxKwQA10NJWdbSyJfRGTpTAeVX9Slll3WEXjI-siH0LUTHYogvxmqkOHr801MaYUDo9wbQt7SlgtfrsbSqcoMr1l6dmMBIiZUjOGQCElkcOnfHCUYXyK7pa7go4a9KHlz2lL3DiXreHZbnEOqO-RqrPPmwxzBnYoIOqbO=w945-h589-no" alt="" title="Video: Mya &#8211; Ebro in the Morning Interview"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/13/video-mya-ebro-in-the-morning-interview-6/" rel="bookmark" title="Video: Mya &#8211; Ebro in the Morning Interview">Video: Mya &#8211; Ebro in the Morning Interview</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/12/video-queen-naija-the-breakfast-club-interview-7/" rel="bookmark" title="Video: Queen Naija &#8211; The Breakfast Club Interview"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/OnkvllH_3G1Pig8xHCNSJBTuhgWZ1K_02hyDP2cOf6p-flukdqo6w2D7CauhGAbv7L7ktX2IY1lTfuuiuPf90tljVv7KSjJYzwTN3aNjw9u8M54C2tcnnG2gqYycKH0kE5w2c2ehpjse2RMrIEvR4BANqwHez5wypsb323HBVXojUgMfR_hKxxU6Ui_tDsHFzqZasm747dMGsO8RTsdkWoidk4gmtUb2cBc5vfVSb8JmvX5SSI92vl-4zRSKYFq3b3h9OpJ54A9gJ7Yzf2mQl-Z-wEXXPfSFFbok9cAlLxmQABzL4yrvSk7_HiQf9jZ2q_5gvQlk-m6gEJpVp8Rk5iovoTkv5ZOeT7UuxnpNScTMREuDmHHbRBvFDXk_-C9xoXHKCflB2nIkkok7k4DRNAULELK33diUJAETjbhCE1EqPgghB4b-ZiLVd2_Qpj7B_WX-GIOMAf0o2cOj6yravK2gfeWurjg5nZ8WTc3jLXpyJF5_BlQX_aTiskFG1Ok_wPri-HZB2Jfqaku-WaiFl2DhmtXv-k1v9U6w9zUAd5xPFrq839xM_tAWhVsA1vsCp7lFGWh6vssgzE7QPLVi9l4WwEuNPtGnw2xjwaBaGvfBYrsdHM_3vJau92qNyOEgwSOBneNAnfqc-5ssQ6mzYkkQ9h91EvCc=w975-h461-no" alt="" title="Video: Queen Naija &#8211; The Breakfast Club Interview"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/12/video-queen-naija-the-breakfast-club-interview-7/" rel="bookmark" title="Video: Queen Naija &#8211; The Breakfast Club Interview">Video: Queen Naija &#8211; The Breakfast Club Interview</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_23_5d2c749d926c8" data-td_block_id="td_uid_23_5d2c749d926c8"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_23_5d2c749d926c8" data-td_block_id="td_uid_23_5d2c749d926c8"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_30_5d2c749da68d5_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_30_5d2c749da68d5" ><script>var block_td_uid_30_5d2c749da68d5 = new tdBlock();
block_td_uid_30_5d2c749da68d5.id = "td_uid_30_5d2c749da68d5";
block_td_uid_30_5d2c749da68d5.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"77","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_30_5d2c749da68d5_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_30_5d2c749da68d5.td_column_number = "3";
block_td_uid_30_5d2c749da68d5.block_type = "td_block_mega_menu";
block_td_uid_30_5d2c749da68d5.post_count = "4";
block_td_uid_30_5d2c749da68d5.found_posts = "158";
block_td_uid_30_5d2c749da68d5.header_color = "";
block_td_uid_30_5d2c749da68d5.ajax_pagination_infinite_stop = "";
block_td_uid_30_5d2c749da68d5.max_num_pages = "40";
tdBlocksArray.push(block_td_uid_30_5d2c749da68d5);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_30_5d2c749da68d5" id="td_uid_31_5d2c749da73c7" data-td_block_id="td_uid_30_5d2c749da68d5" data-td_filter_value="" href="http://weuponithiphop.info/category/fashion/">All</a><a class="mega-menu-sub-cat-td_uid_30_5d2c749da68d5"  id="td_uid_32_5d2c749da74b2" data-td_block_id="td_uid_30_5d2c749da68d5" data-td_filter_value="76" href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></div></div><div id=td_uid_30_5d2c749da68d5 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/LVT4Mid8WL4wHUdO9X2OZmZxxgbREs2lVtszOdEBaO6hJB0JS3yQOAyhNSdCyPmv0amBDTgNGpOlRPXPjKCl6yIlo2joyH3rQRI7CUdX09BJtQI1r5jy1_7BQtDhw4AxUhpUwIh35rNS3lTy7uq-FdPff10JN6srr9mwZ7zr04GQFxBVEXwCfC5rNVehXhY_wGCRVsmevYmdkBWEmB8dvOzBHY78NBBjcHNArS_S-2M0FJgDh8v9m9vEh78k_XmZg-AERctsf0bkODuPi1EcNJq_RnJIV6b0GG-VtKjo-OVPmYghWJYf1HiP9c58cQ98oABU8BDFdLqsBtNt4K0NmyHYQlX39W9k_d83wEHZ1-EacQa2o01VrYSn12HnZ1l88fMzu9PKv6EGmcRZNwpepycW7_9EQnhxIPDdVCmRLXUasUED9OXr-zJmnBcnSnLCa06k1ZymQym1LiSFEv1c3aPHnmnD3GY8nL7q5jPJr4HsABR0WCqMebcF3HF_0deNd0zgRBCGMxW-VzlIIHZiHuBeSPEPvUL149GJ5swSSvKm1uGEi1HlLBj9omJSU7mDWzO0p_7l-l7-4_ureEsGsgB8cX1t8t2TQcFeRgqqF1CXlZFYYC2K0iMb4jPsijsw_rtO7pmKvbngqHfgYpGeh_qLmDWeicR7=w1195-h796-no" alt="" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch">Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/fHEwwMf8DoiXlqkfibQS1Z1XXbviORbV9raaI44tOTXrWo7GgqM3gA-vswE10gFtTQUGGwNG7nWAACwHjxPuiubliYBN_dqtBZh2WIpxvumiJ-hSLK0TNWB2cB8Iw2STT5gcp_KqlDh_e4xng1vidI8EXdp_ooh5uDI-JV1HQ9dGnM5nxl_b-v8znqj-Rl_mGB7y4Lu9zsFNWHU7SriqQQJaKrKEEnb9T8zxmGLaL0zq7ilYpnUEhWulDDr9xc82wdr__WzRBm5YEskVpDAnGM2NDZwTZpjbe4QDdxeixWnSXNK_oDzaL7WTbCpkD33OK88BlI5JmFRQ5VmD11UQ2htB7-9WoahHvb4XmBsbLXpEMl1JmEP4sPx06VduzFnBNo-J90WI0n1AEIIcEYVbRywrkGJXbzmH__In9ZIg0EV24OcGGbeKl12HxTdZwucqsNnuZeNjiMHISQ7i8cfzm3N7X7Zenl74zsKIKeKWoIGxh6MTlVADvgHcrHebnjcSgil2vBeFyz_AP45aOv9SOwbzfVLGS0CNfe1s9b2J7qZgjcBk9QPEXCl2kygvzmGXFvU_3xBuW6S0i3Vkh3Ha_3hPBtvIAy3WoTK2yiqS41HzSK7yk3FRAlBtpIEib338fdkTiosBxtdu36SdNUVM75zl6CVIFhTu=w681-h470-no" alt="" title="Air Jordan 14 Rip Hamilton"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton">Air Jordan 14 Rip Hamilton</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/kUjaOYxjEkAh34S-Ub2QSZwdOwHyFnGFLBZULta3_bn1_myPMAwJXiEEsAAtc1ktCQwHCuKhSqSYsWXFBEIZxdfKuykoDEZWwO-dDI3_JeAshbYvyILEHUu0XaUpRn0mj7gOx10V52t8gRGYPCW7QXGImkPGGhvBPzBDVVqh9lKGtkuPeePmTnpRSmwp0LG1WHcIzUWnMqPBWQeHAat6Q-Tq7niXNb96ddEZsMEdHK1nmHVlNaeqFBNtTxk6yYRkFNCvtfBayqy-Rqt4CPU5tThxbTI4AIUCI6JLxJd_VJizrVNDEe2xZ_tiQdkC5ASIoHpX8sfvAB8zRUsMVJ6oMUt5FH_4GBNXDCtFRmr65Qt0JV1h4bBJffu2L272Q_vpD76wn-YNGW8VCtZcheHu_X-A4gdYQEC0HN0BenY-MOuUBqKEjXAc0SxWeP7W9RN55jlqUFK0nzEYydVjec2stdQIngVfg_FvKxvHXfM4XdtMpqeJnp3Pzyk8xjz30sAZd0f2HQ6zfdPjk-OkV2-WrC0_qW0L8Rq3zrUbq52n3BN7gm7sctU_CUlBmoQIgJDQBYk1Siv4tfSq9pL1R4GdaOlWQdxEuhZi8bTYC8GGAgNGl3SMAZGvk7nu6QnnwEZjZ7mZwbcqgyRKa89cOREMUvIkVJ8Q8lZu=w926-h672-no" alt="" title="Jordan Proto React Triple White"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White">Jordan Proto React Triple White</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4cDUjSODZSaXWfHyZKb9q3Fn7FHA4uB0KSBs0MtFHC0dc6AJb1zeAl_X2LOKalK9C7VBFhTqRQ9fw1ESgUr9ZUKFbOzD94i_s96nvkICOqrsYnzrE2nEAQHoEaGOF4O8GAI6T4CGFbgcQhNzjpRlSY60NyPu5Cmq81FRpEOFRzTOtSa_NnWzMmfwO0yxtPbcg5U6YBUsus8shv3SA7CjULLfaP38nZAuWVgq8PMaaeCQ_eSrK8NJSEVQjyyxmqb-1I7zO8Kvvzvwi--ibMr52CF8h-GusBzSq5ZuzvZRCGu_u8CyfoXw7pwWbOmHnLOdcQ9d2PCSW_IxEMGfmEuU7NxMSsW3Ga4r35_wLB7cjvlPC9OjCV50tfekXjZBS_476mzlf4G9jR7Ju1GqgjXah9Uqc_0Y8N-Br8_JCtIlRSuLxAiebwd7AvFVlgWId9MYxBWnRT3cTyD8SH7q5WwO-CIbKAOSKsNcrrTgFxQvqn9yklBU1u5X5fdTlTBk4WSYorsWZAug0z9BOymRLnrhTbnA0vpBPFROWD-aL1glg-eUpFSfgD4xhWsOqJNY9krQ2UbLSGXQ5gYWj0ovLS7Yz3UKFY2qrVWpqkpbfyN98es9NJ-7LTUs2MLq1rX_2FaQmyq5mVndd7VGzQOHy9hDULG-5H-0LvGd=w900-h566-no" alt="" title="adidas Yeezy Boost 350 V2 Hyperspace"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace">adidas Yeezy Boost 350 V2 Hyperspace</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_30_5d2c749da68d5" data-td_block_id="td_uid_30_5d2c749da68d5"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_30_5d2c749da68d5" data-td_block_id="td_uid_30_5d2c749da68d5"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div>                </div>

                <div class="td-pb-span5 td-sub-footer-copy">
                    &copy; 2018 The Hip Hop Chronicles Media Group                </div>
            </div>
        </div>
    </div>
</div><!--close td-outer-wrap-->

	<div id="wpcp-error-message" class="msgmsg-box-wpcp warning-wpcp hideme"><span>error: </span>Not Prohibited. ✌️</div>
	<script>
	var timeout_result;
	function show_wpcp_message(smessage)
	{
		if (smessage !== "")
			{
			var smessage_text = '<span>Alert: </span>'+smessage;
			document.getElementById("wpcp-error-message").innerHTML = smessage_text;
			document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp showme";
			clearTimeout(timeout_result);
			timeout_result = setTimeout(hide_message, 3000);
			}
	}
	function hide_message()
	{
		document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp hideme";
	}
	</script>
	<style type="text/css">
	#wpcp-error-message {
	    direction: ltr;
	    text-align: center;
	    transition: opacity 900ms ease 0s;
	    z-index: 99999999;
	}
	.hideme {
    	opacity:0;
    	visibility: hidden;
	}
	.showme {
    	opacity:1;
    	visibility: visible;
	}
	.msgmsg-box-wpcp {
		border-radius: 10px;
		color: #555;
		font-family: Tahoma;
		font-size: 11px;
		margin: 10px;
		padding: 10px 36px;
		position: fixed;
		width: 255px;
		top: 50%;
  		left: 50%;
  		margin-top: -10px;
  		margin-left: -130px;
  		-webkit-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
		-moz-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
		box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
	}
	.msgmsg-box-wpcp span {
		font-weight:bold;
		text-transform:uppercase;
	}
	.error-wpcp {		background:#ffecec url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/error.png') no-repeat 10px 50%;
		border:1px solid #f5aca6;
	}
	.success {
		background:#e9ffd9 url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/success.png') no-repeat 10px 50%;
		border:1px solid #a6ca8a;
	}
	.warning-wpcp {
		background:#ffecec url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/warning.png') no-repeat 10px 50%;
		border:1px solid #f5aca6;
	}
	.notice {
		background:#e3f7fc url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/notice.png') no-repeat 10px 50%;
		border:1px solid #8ed9f6;
	}
    </style>


    <!--

        Theme: Newspaper by tagDiv 2016
        Version: 7.2 (rara)
        Deploy mode: deploy
        
        uid: 5d2c749db0642
    -->

    <link rel='stylesheet' id='so-css-Newspaper-css'  href='http://weuponithiphop.info/wp-content/uploads/so-css/so-css-Newspaper.css?ver=1528674688' type='text/css' media='all' />
<link rel='stylesheet' id='soliloquy-lite-style-css'  href='http://weuponithiphop.info/wp-content/plugins/soliloquy-lite/assets/css/soliloquy.css?ver=2.5.6' type='text/css' media='all' />
<link rel='stylesheet' id='soliloquy-liteclassic-theme-css'  href='http://weuponithiphop.info/wp-content/plugins/soliloquy-lite/themes/classic/style.css?ver=2.5.6' type='text/css' media='all' />
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/themes/Newspaper/js/tagdiv_theme.js?ver=7.2'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/comment-reply.min.js?ver=4.9.10'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/wp-embed.min.js?ver=4.9.10'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/plugins/soliloquy-lite/assets/js/min/soliloquy-min.js?ver=2.5.6'></script>

<!-- JS generated by theme -->

<script>
    


            

	            // if the theme has tdBackstr support, it means this already uses it
                if ( 'undefined' !== typeof window.tdBackstr ) {

                    (function(){
                        // the site background td-backstretch jquery object is dynamically added in DOM, and after any translation effects are applied over td-backstretch
                        var wrapper_image_jquery_obj = jQuery( '<div class=\'backstretch\'></div>' );
                        var image_jquery_obj = jQuery( '<img class=\'td-backstretch not-parallax\' src=\'http://weuponithiphop.info/wp-content/uploads/grafitti-3-500x287.jpg\'>' );

                        wrapper_image_jquery_obj.append( image_jquery_obj );

                        jQuery( 'body' ).prepend( wrapper_image_jquery_obj );

                        var td_backstr_item = new tdBackstr.item();

                        td_backstr_item.wrapper_image_jquery_obj = wrapper_image_jquery_obj;
                        td_backstr_item.image_jquery_obj = image_jquery_obj;

	                    tdBackstr.add_item( td_backstr_item );

                    })();
                }

            
            
jQuery(window).ready(function() {
(function(){
var td_backstr_item = new tdBackstr.item();
td_backstr_item.wrapper_image_jquery_obj = jQuery( "#td-full-screen-header-image" );
td_backstr_item.image_jquery_obj = td_backstr_item.wrapper_image_jquery_obj.find( 'img:first' );
tdBackstr.add_item( td_backstr_item );
jQuery('.td-read-down a').click(function(event){
event.preventDefault();
var header_wrap = jQuery( '.td-full-screen-header-image-wrap:first' )
if ( 1 === header_wrap.length ) {
tdUtil.scrollToPosition(header_wrap.height() + header_wrap.offset().top, 1200);
}
});
})();
});

                jQuery().ready(function jQuery_ready() {
                    tdAjaxCount.tdGetViewsCountsAjax("post","[33122]");
                });
            

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'http://weuponithiphop.info/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'http://weuponithiphop.info/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>

			<script type="text/javascript">
			if ( typeof soliloquy_slider === 'undefined' || false === soliloquy_slider ) {soliloquy_slider = {};}jQuery('#soliloquy-container-30342').css('height', Math.round(jQuery('#soliloquy-container-30342').width()/(960/300)));jQuery(window).load(function(){var $ = jQuery;var soliloquy_container_30342 = $('#soliloquy-container-30342'),soliloquy_30342 = $('#soliloquy-30342');soliloquy_slider['30342'] = soliloquy_30342.soliloquy({slideSelector: '.soliloquy-item',speed: 0,pause: 2000,auto: 1,useCSS: 0,keyboard: true,adaptiveHeight: 1,adaptiveHeightSpeed: 400,infiniteLoop: 1,mode: 'fade',pager: 1,controls: 1,nextText: '',prevText: '',startText: '',stopText: '',onSliderLoad: function(currentIndex){soliloquy_container_30342.find('.soliloquy-active-slide').removeClass('soliloquy-active-slide').attr('aria-hidden','true');soliloquy_container_30342.css({'height':'auto','background-image':'none'});if ( soliloquy_container_30342.find('.soliloquy-slider li').length > 1 ) {soliloquy_container_30342.find('.soliloquy-controls').fadeTo(300, 1);}soliloquy_30342.find('.soliloquy-item:not(.soliloquy-clone):eq(' + currentIndex + ')').addClass('soliloquy-active-slide').attr('aria-hidden','false');soliloquy_container_30342.find('.soliloquy-clone').find('*').removeAttr('id');soliloquy_container_30342.find('.soliloquy-controls-direction').attr('aria-label','carousel buttons').attr('aria-controls', 'soliloquy-container-30342');soliloquy_container_30342.find('.soliloquy-controls-direction a.soliloquy-prev').attr('aria-label','previous');soliloquy_container_30342.find('.soliloquy-controls-direction a.soliloquy-next').attr('aria-label','next');},onSlideBefore: function(element, oldIndex, newIndex){soliloquy_container_30342.find('.soliloquy-active-slide').removeClass('soliloquy-active-slide').attr('aria-hidden','true');$(element).addClass('soliloquy-active-slide').attr('aria-hidden','false');},onSlideAfter: function(element, oldIndex, newIndex){},});});			</script>
			
</body>
</html>