<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>Album Stream: Murs – The Iliad is Dead and the Odyssey is Over</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="http://weuponithiphop.info/xmlrpc.php" />
    <meta property="og:image" content="https://lh3.googleusercontent.com/pjY7HnG9-IEI4lqhjxutqk9ZTbQWp8dNgf9-zEPRbsoAorWHAk9nIK6yJ1yy1kzWNYlArHyrVpbGO2fSL7opXWemd_zia03SasLg15VSYOQNg_z7ZPy2jTd-BWNC3Ij0v9UARatMWb_GvSZd-L1w88-dpxZoBRIWFG1J8wxbYiJjFxDsjdsitPdlA3soOLuQ3Ot10nKF6rBEO6r31WLbuBtDXobxMQy3wP26FlyD2motMbIIgXk2hYrUq7MiyaJSYpNcBh-yCQDeAzShchsHMBWtHxfkKJb5-1NKpYzyodT9Eit6rYXICkfL9XIfOOm4XSTH6pXXg2IBUT8felfZwZ3oj3Fho58jGNMCm4SPEzSYLRDxFSonTkNhYq1NDHVP1iyM-UA4pVmB-u5YgNMNSp21gPmFSJ8tKuu9ZwmIplsSBWHiBOnuyvdNm2YqSs6839u6iyQ6zJtPTbU4haNpkgFQoswxFZmJqcbBwM0uBZJOwh9jtyWMQ7p43HFtbL8Tton72cvJO7g2F-BnDAQOiEpccsRfwNrip5x8aeLhxG4yY_C9_9oMxGg6zWHJomoGa_xkUvtvOo-bfE_2sX2MUKAp-JU9kJKc3wEB1RpopisFTOKFEBGIwAhbKTCC8AzRp4MELThL8Sf0QaEmpZs911pg5MmZLFwe=s736-no" /><meta name="author" content="cyclone">
<link rel="icon" type="image/png" href="http://weuponithiphop.info/wp-content/uploads/weuponitlogoCAP-500x457.png">
<!-- All in One SEO Pack 3.1.1 by Michael Torbert of Semper Fi Web Design[208,294] -->
<link rel="canonical" href="http://weuponithiphop.info/2019/08/12/album-stream-murs-the-iliad-is-dead-and-the-odyssey-is-over-4/" />
<!-- All in One SEO Pack -->
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Feed" href="http://weuponithiphop.info/feed/" />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Comments Feed" href="http://weuponithiphop.info/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Album Stream: Murs &#8211; The Iliad is Dead and the Odyssey is Over Comments Feed" href="http://weuponithiphop.info/2019/08/12/album-stream-murs-the-iliad-is-dead-and-the-odyssey-is-over-4/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/weuponithiphop.info\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.10"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='google_font_open_sans-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_roboto-css'  href='http://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C900%2C500italic%2C400%2C300&#038;ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='http://fonts.googleapis.com/css?family=Roboto+Condensed%3A400%2C700&#038;ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='http://weuponithiphop.info/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=4.12' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='http://weuponithiphop.info/wp-content/themes/Newspaper/style.css?ver=7.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css'  href='http://weuponithiphop.info/wp-content/themes/Newspaper/includes/demos/what/demo_style.css?ver=7.2' type='text/css' media='all' />
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1'></script>
<link rel='https://api.w.org/' href='http://weuponithiphop.info/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://weuponithiphop.info/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://weuponithiphop.info/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Music Video: O.T. Genasis Ft. G-Eazy, Rich The Kid &#038; E-40 &#8211; Bae (Remix)' href='http://weuponithiphop.info/2019/08/11/music-video-o-t-genasis-ft-g-eazy-rich-the-kid-e-40-bae-remix/' />
<link rel='next' title='New Music: Salaam Remi ft. Busta Rhymes &#038; Mayjah Hype &#8211; Thirsty' href='http://weuponithiphop.info/2019/08/12/new-music-salaam-remi-ft-busta-rhymes-mayjah-hype-thirsty/' />
<meta name="generator" content="WordPress 4.9.10" />
<link rel='shortlink' href='http://weuponithiphop.info/?p=33946' />
<link rel="alternate" type="application/json+oembed" href="http://weuponithiphop.info/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fweuponithiphop.info%2F2019%2F08%2F12%2Falbum-stream-murs-the-iliad-is-dead-and-the-odyssey-is-over-4%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://weuponithiphop.info/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fweuponithiphop.info%2F2019%2F08%2F12%2Falbum-stream-murs-the-iliad-is-dead-and-the-odyssey-is-over-4%2F&#038;format=xml" />

<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>
<script id="wpcp_disable_selection" type="text/javascript">
//<![CDATA[
var image_save_msg='You Can Not Save images!';
	var no_menu_msg='Context Menu disabled!';
	var smessage = "Not Prohibited. ✌️";

function disableEnterKey(e)
{
	if (e.ctrlKey){
     var key;
     if(window.event)
          key = window.event.keyCode;     //IE
     else
          key = e.which;     //firefox (97)
    //if (key != 17) alert(key);
     if (key == 97 || key == 65 || key == 67 || key == 99 || key == 88 || key == 120 || key == 26 || key == 85  || key == 86 || key == 83 || key == 43)
     {
          show_wpcp_message('You are not allowed to copy content or view source');
          return false;
     }else
     	return true;
     }
}

function disable_copy(e)
{	
	var elemtype = e.target.nodeName;
	var isSafari = /Safari/.test(navigator.userAgent) && /Apple Computer/.test(navigator.vendor);
	elemtype = elemtype.toUpperCase();
	var checker_IMG = '';
	if (elemtype == "IMG" && checker_IMG == 'checked' && e.detail >= 2) {show_wpcp_message(alertMsg_IMG);return false;}
	if (elemtype != "TEXT" && elemtype != "TEXTAREA" && elemtype != "INPUT" && elemtype != "PASSWORD" && elemtype != "SELECT" && elemtype != "OPTION" && elemtype != "EMBED")
	{
		if (smessage !== "" && e.detail == 2)
			show_wpcp_message(smessage);
		
		if (isSafari)
			return true;
		else
			return false;
	}	
}
function disable_copy_ie()
{
	var elemtype = window.event.srcElement.nodeName;
	elemtype = elemtype.toUpperCase();
	if (elemtype == "IMG") {show_wpcp_message(alertMsg_IMG);return false;}
	if (elemtype != "TEXT" && elemtype != "TEXTAREA" && elemtype != "INPUT" && elemtype != "PASSWORD" && elemtype != "SELECT" && elemtype != "OPTION" && elemtype != "EMBED")
	{
		//alert(navigator.userAgent.indexOf('MSIE'));
			//if (smessage !== "") show_wpcp_message(smessage);
		return false;
	}
}	
function reEnable()
{
	return true;
}
document.onkeydown = disableEnterKey;
document.onselectstart = disable_copy_ie;
if(navigator.userAgent.indexOf('MSIE')==-1)
{
	document.onmousedown = disable_copy;
	document.onclick = reEnable;
}
function disableSelection(target)
{
    //For IE This code will work
    if (typeof target.onselectstart!="undefined")
    target.onselectstart = disable_copy_ie;
    
    //For Firefox This code will work
    else if (typeof target.style.MozUserSelect!="undefined")
    {target.style.MozUserSelect="none";}
    
    //All other  (ie: Opera) This code will work
    else
    target.onmousedown=function(){return false}
    target.style.cursor = "default";
}
//Calling the JS function directly just after body load
window.onload = function(){disableSelection(document.body);};
//]]>
</script>
	<script id="wpcp_disable_Right_Click" type="text/javascript">
	//<![CDATA[
	document.ondragstart = function() { return false;}
	/* ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
	Disable context menu on images by GreenLava Version 1.0
	^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ */
	    function nocontext(e) {
	       return false;
	    }
	    document.oncontextmenu = nocontext;
	//]]>
	</script>
<!-- Analytics by WP-Statistics v12.6.6.1 - https://wp-statistics.com/ -->
<!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]-->
<!-- JS generated by theme -->

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var tds_login_sing_in_widget="show";
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_ajax_url="http:\/\/weuponithiphop.info\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=7.2";
var td_get_template_directory_uri="http:\/\/weuponithiphop.info\/wp-content\/themes\/Newspaper";
var tds_snap_menu="snap";
var tds_logo_on_sticky="show_header_logo";
var tds_header_style="5";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#dd3333";
var tds_smart_sidebar="enabled";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>


<!-- Header style compiled by theme -->

<style>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</style>

<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>

<body class="post-template-default single single-post postid-33946 single-format-standard unselectable album-stream-murs-the-iliad-is-dead-and-the-odyssey-is-over-4 td-what single_template_7 wpb-js-composer js-comp-ver-4.12 vc_responsive td-boxed-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
                    <div class="td-menu-login-section">
                
    <div class="td-guest-wrap">
        <div class="td-menu-avatar"><div class="td-avatar-container"><img alt='' src='http://2.gravatar.com/avatar/?s=80&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo avatar-default' height='80' width='80' /></div></div>
        <div class="td-menu-login"><a id="login-link-mob">Sign in</a></div>
    </div>
            </div>
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-top-menu-container"><ul id="menu-top-menu" class="td-mobile-main-menu"><li id="menu-item-317" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a></li>
<li id="menu-item-706" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a></li>
<li id="menu-item-314" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a></li>
<li id="menu-item-316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-0" class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></li>
</ul>
</li>
<li id="menu-item-705" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></li>
</ul>
</li>
<li id="menu-item-18581" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li id="menu-item-3199" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
            <div id="login-form-mobile" class="td-register-section">
            
            <div id="td-login-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-login-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign in</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
	                <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
	                <div class="td-login-info-text"><a href="#" id="forgot-pass-link-mob">Forgot your password?</a></div>
                </div>
            </div>

            

            <div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
                <!-- close button -->
	            <div class="td-forgot-pass-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Password recovery</div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title">Recover your password</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
	                <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
                </div>
            </div>
        </div>
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="http://weuponithiphop.info/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap">
    
        <!--
Header style 5
-->

<div class="td-header-wrap td-header-style-5">

    <div class="td-header-top-menu-full">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div >

                Monday, August 12, 2019
            </div>
        </div>
    <ul class="top-header-menu td_ul_login"><li class="menu-item"><a class="td-login-modal-js menu-item" href="#login-form" data-effect="mpf-td-login-effect">Sign in / Join</a><span class="td-sp-ico-login td_sp_login_ico_style"></span></li></ul><div class="menu-top-container"><ul id="menu-main" class="top-header-menu"><li id="menu-item-79" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-79"><a href="http://weuponithiphop.info">Home</a></li>
<li id="menu-item-81" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-81"><a target="_blank" href="http://weuponitradio.com">Power 105.1 WeUpOnIt Radio</a></li>
<li id="menu-item-80" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-80"><a target="_blank" href="https://shop.spreadshirt.com/freshandcleantees/">Shop</a></li>
<li id="menu-item-18582" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18582"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li id="menu-item-18583" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18583"><a href="http://weuponithiphop.info/privacy-policy-2/">Privacy Policy</a></li>
</ul></div></div>
        <div class="td-header-sp-top-widget">
    
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div>
    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <ul class="td-login-tabs">
                        <li><a id="login-link" class="td_login_tab_focus">LOG IN</a></li>
                    </ul>



                    <div class="td-login-wrap">
                        <div class="td_display_err"></div>

                        <div id="td-login-div" class="">
                            <div class="td-login-panel-title">Welcome! Log into your account</div>
                            <input class="td-login-input" type="text" name="login_email" id="login_email" placeholder="your username" value="" required>
                            <input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" placeholder="your password" required>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Log In">


                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password?</a></div>


                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-display-none">
                            <div class="td-login-panel-title">Recover your password</div>
                            <input class="td-login-input" type="text" name="forgot_email" id="forgot_email" placeholder="your email" value="" required>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Pass">
                        </div>




                    </div>
                </div>
                        </div>
    </div>

    <div class="td-header-menu-wrap-full">
        <div class="td-header-menu-wrap">
            <div class="td-container td-header-row td-header-main-menu black-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-menu">
        		<a class="td-mobile-logo td-sticky-header" href="http://weuponithiphop.info/">
			<img class="td-retina-data" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-5.png" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-5.png" alt=""/>
		</a>
			<a class="td-header-logo td-sticky-header" href="http://weuponithiphop.info/">
			<img class="td-retina-data" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" alt=""/>
			<span class="td-visual-hidden">WeUpOnIt</span>
		</a>
	    </div>
    <div class="menu-top-menu-container"><ul id="menu-top-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-mega-menu menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_1_5d514c1c8453c_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_1_5d514c1c8453c" ><script>var block_td_uid_1_5d514c1c8453c = new tdBlock();
block_td_uid_1_5d514c1c8453c.id = "td_uid_1_5d514c1c8453c";
block_td_uid_1_5d514c1c8453c.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"43","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_1_5d514c1c8453c_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_1_5d514c1c8453c.td_column_number = "3";
block_td_uid_1_5d514c1c8453c.block_type = "td_block_mega_menu";
block_td_uid_1_5d514c1c8453c.post_count = "5";
block_td_uid_1_5d514c1c8453c.found_posts = "2291";
block_td_uid_1_5d514c1c8453c.header_color = "";
block_td_uid_1_5d514c1c8453c.ajax_pagination_infinite_stop = "";
block_td_uid_1_5d514c1c8453c.max_num_pages = "459";
tdBlocksArray.push(block_td_uid_1_5d514c1c8453c);
</script><div id=td_uid_1_5d514c1c8453c class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/12/new-music-jidenna-sou-sou/" rel="bookmark" title="New Music: Jidenna &#8211; Sou Sou"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/gylJ7Wnk0ZJlN0REMXfqncEzPMBt5FHbP25SovzF9dqW08Dya-AKF3gO6pcIV0sVv9cR5bG4tnjGOXk26CpyQIZzmXjTEuaFQfXZi1mM111grbOXdXen8JoOA6EaqqrFBmlKCR6f7whPked5PdA8VIf5PCAMSJ0-oLRtRhX_dd1OYWofDoZCvR8d_pk-36BJU3780_A_KbvNguFbV-6vc3wtEwwyS5CqRNHz4Z4rKuPLhIfD5O6TSKW_dxa016SdDYC3EIyZmCu58CSD72K26u6utsKSc8IcDwCCGcsLy2BhMq0xliFIvcAq9SipVBe-DmzvbJVNMWam8k2vgOdG8Dfr5ZcN5Ldf5AHceaUrIeAUP48nmW9qlUubr5HQVvgtZJ5cgRufncD8UIJIQBtRCWRbTJ6jkGfxNPdf8ZxGu8EeqEnwQDkZ6JpENz7kCaqCQbDq8ab5Ywt1_CqpwbPFu5fpQ0IacTXBPrRE25RCAZZZ_hp3_ZUJ-AYNVbBZvM9jncDa1crk8C47eoxuA5NN-z45cg0iuO4KY9kEVwer2XCz_M-oVK-zoZVEkTU7LKxMQBMmq_5VhrMw7t_aSg_EO6a8g86UT7PQADNKQmLV69q1pjibLZTSr0kMnFyH9WVQaiBCwiHN7OmDFy_FUZbjzGH1IkfEC7wt=s736-no" alt="" title="New Music: Jidenna &#8211; Sou Sou"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/12/new-music-jidenna-sou-sou/" rel="bookmark" title="New Music: Jidenna &#8211; Sou Sou">New Music: Jidenna &#8211; Sou Sou</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/12/new-music-salaam-remi-ft-busta-rhymes-mayjah-hype-thirsty/" rel="bookmark" title="New Music: Salaam Remi ft. Busta Rhymes &#038; Mayjah Hype &#8211; Thirsty"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/KCcIHELD90CRrE33fwMaOrgTLmvEJ3ftnrDDDbd1HqtwYbJLBMteNGGkmqzBQI2AbMfMWlXArZ4jYkXNOacD_i3S8cchc8SYAru64VjMHDW_vWto1CaKLxFe8Z3vPGKNdnm-RrM_xJ2Ku75dJL1_gDSl40njuv4jEA7OUqd3CRTMqXGXsfmlQsjYfQmc68qGQ3CwhLDyUlgFkIvU45urXFj2g1ccUKCroqUd8y4Pyxp96fLQiNuhYbMrls2nZVBcU26wNA-gIrv4thhZfct6793qaZoDlW9mm2iC9tb45Qg8G3CkgknxdL5dw9IoKk8i5O8DhTv2wZuF1OZoR5KWAPR5z3Q9XEM_GltAkFkKNdcAiRY5Z4TUzhW8VBW1G5Eq0dedNPU1GNdmHvJP5RldYDDU6fMizb5_Y0Z8_ruhWpNGzNjfXHSn2GBVtCaZse4Vewt0T-_5ByEshjbXkOaFNdfJotQG8BNjab3VUNR-127nwGvnipusAIaORkz9qYAgADD0dmSrxoNEOXSNQIyTze-kgVoQ-gxkY0hFrusE5oZ8jsgmDVqZylF8-Sc9agdR8MIPDS18UA3afN98DBv53I72Ia5H23JSYVk8NCVXauGBbvzqBWEmskUIVqGu9bW2iW8_baZCfs6lUwiRLko7QEKmjpK-vInQ=s630-no" alt="" title="New Music: Salaam Remi ft. Busta Rhymes &#038; Mayjah Hype &#8211; Thirsty"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/12/new-music-salaam-remi-ft-busta-rhymes-mayjah-hype-thirsty/" rel="bookmark" title="New Music: Salaam Remi ft. Busta Rhymes &#038; Mayjah Hype &#8211; Thirsty">New Music: Salaam Remi ft. Busta Rhymes &#038; Mayjah Hype &#8211;&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/11/new-music-kevin-gates-double-dutch-in-amsterdam-witt-it/" rel="bookmark" title="New Music Kevin Gates &#8211; Double Dutch [In Amsterdam Witt It]"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/uJva4Ll7i0Xy7yPK8wBXs8RoH7_TOaBMLM1olINLFNDbEjVVPhGUjqU8tecvDhp2QJDewW3S3UEfPUX_R-aJckdYm5vKMEK7-8TdXdg3ukNOu9lre-l-QwGmuMwMim3p3gYKWsUiWlzZTn3DkPYvcGLsv29SjDU4bsjdflLN0er0nU0cI2oSPVvgQzg-qTganZsI0g1smSmij9lQdF8tugkdp58H5Doqcj2JHeBieggatWSK_NVqUZHStGGkijSd58noRiC6T7t_ENMX0qrDOCrMgUbD6rEW1sStzLeM5W_JH44mgS9N-xMEtMmXLPnBTAY24VXQx3AhngfZxQ-bEyok_HZMGeM4vmf1Fp5oboEMmeyeGlsaVyha8wV9Zl58Nntxy5y3vIiazuv1bkIHIx4WDjy5Nwtd_lHg9Szg9yRjZQn8MkI2oEyRlhLw59I7KrGA2glu4lAxsLHIofYIkEG_QbIepw3SvuWoOKgFND7jOUVd-8xzU3IikIQnVxhKT7-Oq7GV570hzm1kotMy0qSr7bj1NKN-Tp8SLw7YOtF4D81hdWwUUXOvUICMWyhKci5_SCTvbkO1D2xkQIQlRo3-PzS7tgiwX-QxtrrrcRZqX_g90AwqvsJNCxCHL5oplzTmcz1Swlio5R55sczMvQrCz4si4MlH=s736-no" alt="" title="New Music Kevin Gates &#8211; Double Dutch [In Amsterdam Witt It]"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/11/new-music-kevin-gates-double-dutch-in-amsterdam-witt-it/" rel="bookmark" title="New Music Kevin Gates &#8211; Double Dutch [In Amsterdam Witt It]">New Music Kevin Gates &#8211; Double Dutch [In Amsterdam Witt It]</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/11/new-music-slim-400-ft-young-dolph-shake-back/" rel="bookmark" title="New Music: Slim 400 ft. Young Dolph &#8211; Shake Back"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/7lfEx0wIK1kmcmoHv455Ahjx9KRxzQiYhZCDTBkKPherJBYPnSDz481t6btjMaTSTjgx4SiD5EYweY9U32i6oRsXxxeC121JeCmxFbrIYmb0lKfsaktmsvzKML2yehBgEiUuC1fFbdT6tUMfR1oK0zssfF_-Xax3uOjX0dq9Z2INd8XuEyOoORCUKugI-yb1fgjt0NGlfDcsqN-7og8bjMmUnZiNB1ArH0K6ulkW2Ygen_g5PzataPdnTIjc9pMQCeLZoYKt2YSXUTzdJebm1fuZYbDTSfAO1DyVMbJ6ZbXrJ07GJr2PqBaOWlIDKJG06PM_mi9eQ71PPn84YHbXO95NowOCb2H1Of__1ZqptC9Axb2MR_nFBG1nsMmYZQiUc_wRDb5Rrmj9OkQ3MbPMINyPVapboWhoJhHmWdPuo4xW92X1vcBs0E0cXxDezVxJbc5E0oQo9hHbp-wApCl4EwTusL6n4TI0t_psNSRgIcx6YIkhxKW24EFlwZC-fNDm0DmD4TBYdg4-h3TjI6MQSwHqPvcjqUV_O0xeaqhOsLzsBx1g1zj0z3QD78vWPRHkrcCaM0UbaTryqbCzqGzUkU_DSjQ3Pgp3idtdvpjpKB2_mjYqw3Emkj7qqj-tjOOp8bWBpJUY6yDNRiYpRcAnzQSBLwXJxNlW=s736-no" alt="" title="New Music: Slim 400 ft. Young Dolph &#8211; Shake Back"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/11/new-music-slim-400-ft-young-dolph-shake-back/" rel="bookmark" title="New Music: Slim 400 ft. Young Dolph &#8211; Shake Back">New Music: Slim 400 ft. Young Dolph &#8211; Shake Back</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/11/new-music-gnar-cabbage/" rel="bookmark" title="New Music: GNAR &#8211; Cabbage"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/LqmAAJ-UF2uFRO2D_ijZLI0qA6LeRkDjZhnXfS_ntRSZvIMiACyLOLRfW50GjvF70g8cx56IW7skhpSBqr_gEEyJkLGInWHmzn3o7oQjq4D7Db2tiALye9huRjKAwg_LBaNtpq96_GWM8Ydmf3QRqekguEfzyAhgcczytK5B2XTrgMWdm1kAf1eowgP81MR6_-mDDlHfVOz0j15jNGXkjhlhOUZ4ZgGCv3yuge-GiXvSIgLm711dw5-L4KWGGdC5cfAJkDQigq09aSAa75P4v7F8eqkWWMKQ9L78a0r2ZH8Q1mSbWW_sdHdGaXR6pqwjnW9Fd1SZyqrLjQZtLRcGfwhu1aP0434AVafzxWMHILsOQkzKkwH1kz3kzVWqm2VlQHTwn4JGWYTCGKnIp-60cP6sMXVUZv3eFxq4xru6XeNY8n1gwFivKeAaoWS1BPayB27eluhOUMpBEgtSpFaF1TGr2KiX1bgr3xgk6BVBYKD3XaMYuh8cIj1QFVXFVkCVLFSgIxAvc9cc-k7EbOZNJhLZCkSS_4uuGkYTCeaOEwK9WrH4BtKPawKeRdosd-I11eh41KcXlCWjmn8elZX9RFGGyKr9w9bpj5--8ns2nWaQCSVj7uagFjwJUVDXmtiOJWnJLQiqq-NE9BH6faVf5Okq4ROZ4heq=s736-no" alt="" title="New Music: GNAR &#8211; Cabbage"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/11/new-music-gnar-cabbage/" rel="bookmark" title="New Music: GNAR &#8211; Cabbage">New Music: GNAR &#8211; Cabbage</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_5d514c1c8453c" data-td_block_id="td_uid_1_5d514c1c8453c"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_1_5d514c1c8453c" data-td_block_id="td_uid_1_5d514c1c8453c"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_2_5d514c1c89341_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_2_5d514c1c89341" ><script>var block_td_uid_2_5d514c1c89341 = new tdBlock();
block_td_uid_2_5d514c1c89341.id = "td_uid_2_5d514c1c89341";
block_td_uid_2_5d514c1c89341.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"97","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_2_5d514c1c89341_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_2_5d514c1c89341.td_column_number = "3";
block_td_uid_2_5d514c1c89341.block_type = "td_block_mega_menu";
block_td_uid_2_5d514c1c89341.post_count = "5";
block_td_uid_2_5d514c1c89341.found_posts = "850";
block_td_uid_2_5d514c1c89341.header_color = "";
block_td_uid_2_5d514c1c89341.ajax_pagination_infinite_stop = "";
block_td_uid_2_5d514c1c89341.max_num_pages = "170";
tdBlocksArray.push(block_td_uid_2_5d514c1c89341);
</script><div id=td_uid_2_5d514c1c89341 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/12/album-stream-murs-the-iliad-is-dead-and-the-odyssey-is-over-4/" rel="bookmark" title="Album Stream: Murs &#8211; The Iliad is Dead and the Odyssey is Over"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/pjY7HnG9-IEI4lqhjxutqk9ZTbQWp8dNgf9-zEPRbsoAorWHAk9nIK6yJ1yy1kzWNYlArHyrVpbGO2fSL7opXWemd_zia03SasLg15VSYOQNg_z7ZPy2jTd-BWNC3Ij0v9UARatMWb_GvSZd-L1w88-dpxZoBRIWFG1J8wxbYiJjFxDsjdsitPdlA3soOLuQ3Ot10nKF6rBEO6r31WLbuBtDXobxMQy3wP26FlyD2motMbIIgXk2hYrUq7MiyaJSYpNcBh-yCQDeAzShchsHMBWtHxfkKJb5-1NKpYzyodT9Eit6rYXICkfL9XIfOOm4XSTH6pXXg2IBUT8felfZwZ3oj3Fho58jGNMCm4SPEzSYLRDxFSonTkNhYq1NDHVP1iyM-UA4pVmB-u5YgNMNSp21gPmFSJ8tKuu9ZwmIplsSBWHiBOnuyvdNm2YqSs6839u6iyQ6zJtPTbU4haNpkgFQoswxFZmJqcbBwM0uBZJOwh9jtyWMQ7p43HFtbL8Tton72cvJO7g2F-BnDAQOiEpccsRfwNrip5x8aeLhxG4yY_C9_9oMxGg6zWHJomoGa_xkUvtvOo-bfE_2sX2MUKAp-JU9kJKc3wEB1RpopisFTOKFEBGIwAhbKTCC8AzRp4MELThL8Sf0QaEmpZs911pg5MmZLFwe=s736-no" alt="" title="Album Stream: Murs &#8211; The Iliad is Dead and the Odyssey is Over"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/12/album-stream-murs-the-iliad-is-dead-and-the-odyssey-is-over-4/" rel="bookmark" title="Album Stream: Murs &#8211; The Iliad is Dead and the Odyssey is Over">Album Stream: Murs &#8211; The Iliad is Dead and the Odyssey&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/10/album-stream-fokis-oh-no-this-thing-called-life/" rel="bookmark" title="Album Stream: Fokis &#038; Oh No &#8211; This Thing Called Life"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/Oohu8DntgPvoX1VnohDL2grgzxdaaPTHcChQANX7B_rl9J7jSOlSr1riuemBoarD6AmbQ-Vw4-geI9xsPtu2yGZGdgbxca_R9jrVnFZVC5InUVpE70z1NPBJxOttb4g3OWN1kMEOWZfK4eIMIAnVcRlYhycE8cJAhoOsUMzr-k9u9aFzeC5ya8a-d2DcRzpzF6TdmhvCxvz8JgjNs25-8DXyOIvJqILX_oFoLc7HsBfFtITMpDKKKejICQb8wBkphvArV59OD6ragMMqo7dGVUuuf6GPt7Iy9imTiCna8mhhvI4SdrIIAZIpK3SYj_qhHLU2lZ2Td6anqroktR3U224tfPLPh1pZfTzpvufc9wfs5MZz9NtFFAjAjaoH_nGIbXVjZz3E2Np1C7aHlBMh8DcHSjKVKXFAPDs2xSEIduO3csCpJFR6fXytIbddoh9ArR-DLl9jFPq4xXO9TzBdFlUcXCUFDe5_ZDMNboI05jNEguEUUfnf407fHeUGvyqM9ZLSFp54DzXPbEisn33ExMZTlgQcDcvG8Z7HT-wRO_OY4PNkvJ4z4yPiQK5I3_B3x4iOpvjz4iyRuJNijb__GOsfIXSYoAAQGBtJs0UW71b0omFfpemj3vutVl2e1mTTpQReaGVf_0n2u9eH46Jhwlypppf_4ifL=s736-no" alt="" title="Album Stream: Fokis &#038; Oh No &#8211; This Thing Called Life"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/10/album-stream-fokis-oh-no-this-thing-called-life/" rel="bookmark" title="Album Stream: Fokis &#038; Oh No &#8211; This Thing Called Life">Album Stream: Fokis &#038; Oh No &#8211; This Thing Called Life</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/10/ep-stream-lil-tjay-f-n/" rel="bookmark" title="EP Stream: Lil Tjay &#8211; F.N"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/IbiNDldvQpUqrCdBY84e8j_DkPH3miedYL5b3-rMFVe8P4PzOyP6C5AuRBCr8Op-OhrKo70zAz7ZoXz8l9s_vN_bQqvkHEniGeydCpRr_8knToxUVtDbDkhm3bbaUxsrKPISaJmU5qYUWvb-7Y07OzcB9cegGlFA8OpLjVdlPkp9GCTJAn5PQJbSg6hQ7zFX5Sk6svzngvtq7QyB0l9dLYy8kNjAHS6-BWIleUD_5z7zno3np05zRRiG_tLIgIUgM1IkKyZVF97XIcLHU9hrew4_PXXaPHe_gYs48n9P2hH6tjaPQw6Iwwbhg61l2E1ghMcaxLNO1o_ono9Kg6u0owv0uOn4f8PuilDdEGxWdY3cOdDADQmmJA2-_LY6aA7dYKV0AW8r_-O2BPvzKHDfan0EB3hx7v_yYshdpPSQloMTS4K6Pw0jGSm6NGINiH1Oq8ez5a9qVKuQFyxzfbQID25gNpiCiUEM5EORKwgxa33AA_9FFMym6S-poFbe7xdl5xapaCs_Q3cWdEVrFa1-aO4imovfXxzcHPe57YQQelz-Wz1XA3fEuqGCpTlQK4vc0zhOxyu8GeVgNvbFLBgqPE3AcR7Vr-PjTDE-xTBdGsYEm1J1o3B0ebs0qLUuevEuu_kxhO8Dzu2b1K3ZDmb7zot44jN97cMD=s736-no" alt="" title="EP Stream: Lil Tjay &#8211; F.N"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/10/ep-stream-lil-tjay-f-n/" rel="bookmark" title="EP Stream: Lil Tjay &#8211; F.N">EP Stream: Lil Tjay &#8211; F.N</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/10/album-stream-smoke-dza-zour/" rel="bookmark" title="Album Stream: Smoke DZA &#8211; Zour"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/CMb0yyZ4f-CUTWHDWghIBocT19qRCpLLTLkm2wKzPb_uPKYdEwFtZ6ODnZpzMQZQ2fbR0cXCHYNp3Ev7HhPMTWmp16p1M-ZwwmP9-eGlZS1jgGIms48ysfuPOpRqKyDVI4sE17vnSBIU6WiM6AiqnguHpRCsF9Bt7zz5oQs3ZE9GeGCNkPhtMGJNdQzCWWRab9pVj3dIFLr_dUHd1Jkn8m5aVMzT5o8vXMMyw5jjzelfwPMzbHmOeWW0GptjG-tzHGo43zRaQ80jJa0HTKcKdu0FdUhiPO4cZs8ZGetA5of2RvZ1mnG2TaaCyBYMe2IITRbUy2qyMTBIyryX-8wSWSYGaM0FZk9QJ6ceTBhKVUpsrOn8QWKMvVWXnKKJpJi024v7t03EYVq_WBUZQ_zRLCRwJfjKG8cIK61ebl8kwBHwJqlFq337B_60G0aWLR-lnB6038BRspBTm2ETN--LBmrVacAEbGmj1Wn2MTHAMR7vd1yxZ9UGjIU6v64yiV5GySEW1Kg0TWKUUrxEddjOOi2iAaeHynKD3SLj1qkmTUYImvOtz9gTsRZyZ57qkQfgUyhcjcj94wS-ZG5RElm5Y-zZ1iFMeJrq0an3h6qc0aIgcqBochCHymO91BgjuOT_xDb5VVM0nkYeHygnE9eYBYevsIxHawGp=s499-no" alt="" title="Album Stream: Smoke DZA &#8211; Zour"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/10/album-stream-smoke-dza-zour/" rel="bookmark" title="Album Stream: Smoke DZA &#8211; Zour">Album Stream: Smoke DZA &#8211; Zour</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/10/album-stream-bas-spilled-milk-1/" rel="bookmark" title="Album Stream: Bas &#8211; Spilled Milk 1"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/NEWkOeYGJYfDNs8lH0tg5uZAGFaMReKsfs33WoNIt3M6tRRMBhReDCOwf7o0xzNmevNCt16K3bO6qf8-SsoWzbMVgQMRskiW5UpSL5WVxn5MwRjUlQ8mqVEliicomkgE5-XxW_-PRstRZRxPKELrvsB07JrS6oeASpbnDuvKKAR9rSJfPpTvG9rOGZ2ft3PBUR5VW_OCxBaNHT9egiH1cUzHaLGdB-uJcQL-P9xQaJEj6S3u14lEPKVbFDog8OiZZAhv6t6Us9OAckDU8gEosAqsrEAgwZpe8qzVap1bl4TT0Q0s9RoGA2xmHUfznOifA3U5aoxuoPud6T62y-6oF8vl4HxRA8fzFjgKS2EziGYOJxBrIZWN1MNuSUZIc0mfRSjv0xLMsbkTPlY4pSDfBgoOfZLRZo2lPTr76VKAixWvQNyClxCDyh-0yKoWuyXaRFAkcXS6r6V3ACtz0EvZf-c61XZwccWhV92fXpBr3evSIewjxaRHyCM52-_Yes2aU-3ZYLfhf41bSIKSHmpOImySW-w6GYB9m7xYnxtgHdXmzi7dJKbNlIY9yf01TnLDU31sCt8l7XXdz3GdRJ7WJw-taFh0wm2lndz6xqhngg8EUoZ2pu6ZFcDTTw304q3lCjxZhowgoHGesUIFcnNXeuL1OWdLXJY1=s736-no" alt="" title="Album Stream: Bas &#8211; Spilled Milk 1"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/10/album-stream-bas-spilled-milk-1/" rel="bookmark" title="Album Stream: Bas &#8211; Spilled Milk 1">Album Stream: Bas &#8211; Spilled Milk 1</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_5d514c1c89341" data-td_block_id="td_uid_2_5d514c1c89341"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_2_5d514c1c89341" data-td_block_id="td_uid_2_5d514c1c89341"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_3_5d514c1c8d11c_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_3_5d514c1c8d11c" ><script>var block_td_uid_3_5d514c1c8d11c = new tdBlock();
block_td_uid_3_5d514c1c8d11c.id = "td_uid_3_5d514c1c8d11c";
block_td_uid_3_5d514c1c8d11c.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_3_5d514c1c8d11c_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_3_5d514c1c8d11c.td_column_number = "3";
block_td_uid_3_5d514c1c8d11c.block_type = "td_block_mega_menu";
block_td_uid_3_5d514c1c8d11c.post_count = "5";
block_td_uid_3_5d514c1c8d11c.found_posts = "2280";
block_td_uid_3_5d514c1c8d11c.header_color = "";
block_td_uid_3_5d514c1c8d11c.ajax_pagination_infinite_stop = "";
block_td_uid_3_5d514c1c8d11c.max_num_pages = "456";
tdBlocksArray.push(block_td_uid_3_5d514c1c8d11c);
</script><div id=td_uid_3_5d514c1c8d11c class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/11/music-video-o-t-genasis-ft-g-eazy-rich-the-kid-e-40-bae-remix/" rel="bookmark" title="Music Video: O.T. Genasis Ft. G-Eazy, Rich The Kid &#038; E-40 &#8211; Bae (Remix)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/iat6FDtMGVBT75L3hmJmhrK7seHvbLSXOsl9HqhkP-a_wg7cq4EK6TK8xle7x4osuziVm2eq2BqrIuBAxrJm9lYwVuKJIiiLmdjv8aw6lFkrqcTarBJLaM-lH0x5RC493FsiR94hfttygY48fhhK_zw4Nv76KczA_PXkVGc-smDg5tk4gy1tNUrFESispuKKxZqVa_qvqwq6-4T3KAyHljatCxO6vwYYdfzwUV_MkJTLPHJJDpt52t-MuoCrI09iznMUXnnYtD8O3_vW-ViXtfe0Cv0Z9BftZeu5vdlWjwR2SOfK-K6D9OcIMV2xS2bqTNYNt_KCcTSbnfrrmt__HxZuIJZy5llRV4IpKl-ZJslBuoErulMKZyGKQVkIBWe-QLv6cpnA0ICFyOAEAxx-8fmP2_YugsoStQYrRetQI7NQr_yWWXsdsSLBbuAD5ey1G1H2jIZntzntRMrotQhzTTH-TYLx6KaHIeYx6xEHnSrbVNFz96yRyMwwE9okChyKjCc-ythK4dp2o43MtlWstfGxnIQcEl60ScsE4PvERRtnAjQGh58AvwpWWgK4Y_Avo0PwWd5gqZvd7fC56MArXme5NdV3nmm1_LBv4A9HXexCnyU1lIRBmclZyZKWFn9a7cfnyhiYpCh-Mw69chHKC829NRHVkHUc=w1025-h538-no" alt="" title="Music Video: O.T. Genasis Ft. G-Eazy, Rich The Kid &#038; E-40 &#8211; Bae (Remix)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/11/music-video-o-t-genasis-ft-g-eazy-rich-the-kid-e-40-bae-remix/" rel="bookmark" title="Music Video: O.T. Genasis Ft. G-Eazy, Rich The Kid &#038; E-40 &#8211; Bae (Remix)">Music Video: O.T. Genasis Ft. G-Eazy, Rich The Kid &#038; E-40&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/11/music-video-dram-ft-h-e-r-watt-the-lay-down/" rel="bookmark" title="Music Video: DRAM Ft. H.E.R. &#038; watt &#8211; The Lay Down"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/9y0oM48hsUtfUkZFWM2PPd24yRMsxPiwZtCGurG9AJeOSLP0EAgL4Cu6N71rnv3HyXeqrqBQsJvNgyVeRjP3Uv4IgrIcMROWvlNqmLGoiejMxTx-X7aWXQpGYMA6bHHv1KLsN0fzN2kjlJH0EbNsai2P5JGnaaIQ3lNTlH08dz9ukgVNVxBrVq7A3J600zHy_zTGFwu-UmzdlW3adaWpzYjP71tW5qnk-u6Lrry6F7Jp7KNfidnWLlCPrjgKOcL1vjetLhMSm8xmOGd35vLrH4Q0VbKMeQmqGYsGZydAlXsxlUemIjdz6_q--BTkNJdbmdoCJr8mrISmd9lugau_iStxlQui6spJ34EWkS_KyrdVcjAV14Zwt7sjKU2zmWdIth4Q38uAPfa8u4VUGiR_u71J2DV6951qvvGaxdViBp_EYCGsylWb6pVLg2AUXzR1VQD7jOpeqonz72ngPww70CKX3iaRMQL8_wqaDyjJO-uundvresrvrUHT1oKHaiDRS5aOkQm5W7wGea0tNYsuDfGIehIT1ELlD5BznPMB5j1r8EnCG_InrBY0NguqDRzvoNevcCO7qFcB2ZVX8m235RK_aOGOgAVxlBf7BIgNoh9-zD0B5wQZ6pxNX2wH4OKjf58ZbZu4XUWJZSVwH2ZG-A1I0oBr4fzt=w1087-h530-no" alt="" title="Music Video: DRAM Ft. H.E.R. &#038; watt &#8211; The Lay Down"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/11/music-video-dram-ft-h-e-r-watt-the-lay-down/" rel="bookmark" title="Music Video: DRAM Ft. H.E.R. &#038; watt &#8211; The Lay Down">Music Video: DRAM Ft. H.E.R. &#038; watt &#8211; The Lay Down</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/11/music-video-nef-the-pharaoh-ft-shootergang-kony-beat-that-vest-up/" rel="bookmark" title="Music Video: Nef The Pharaoh ft. ShooterGang Kony &#8211; Beat That Vest Up"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/udIEYLBVRW1YLPKSVdgBykWHi_jgSXcD2-DsdWbvTLUKrvM0nnhCo01DyxTtYv246EvJVehDKOBqDQ24hseO8F9TuT4Lk7CcJ9e_qN85XEiKdat0zz4_rFTzVGmMEYR_E2g9Dg1cbBPhkGfYChhIPnVA3YJg1MNhZrbOMYmWtShVOR-klz_R6o0uhhAzQVB1Y5vZEf-amStnREu-LbWkuObp4Ek22T-qRwRjekhm-1V2J5rNrGemdxGx-d6dxz2cdNzYpBgf1GgG2r4wBqMxJdm3EMGxt-JOpYOp7hNBPp4aLWjcCKzSEAvBZTyZgkHm670myDPkf-dGv8g8qqVO_iq8_1uH0mL1daHGzQpBA7MMX9QdZbK9NG-nJ28e_YriYBhURyhupNcZIIMSpUH3QKyoUjCPYaZueg7IF6bchPOcgI4MFW8SQ94vlp7W4QjJN0jtGzapFnBmtvMVf8c2CcKeIpGgt-c4yKEbrz0dKgZA3DgNikaPmWMcVi_TyutIqJbQidjXRfEGc8yS5b57isNolgo2G5G5ILzFUZ_NqnPmB0IUm83KOvHhEEqF25qVeraUMG2yNdLvl3bhwm6Q_uV0meA4FLzt0RINJGPeAWZg95DTsWLs-2DYU_xXwlw_JelJ5MccFV86BQwUbKBBLYbLZjo8DmYx=w412-h232-no" alt="" title="Music Video: Nef The Pharaoh ft. ShooterGang Kony &#8211; Beat That Vest Up"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/11/music-video-nef-the-pharaoh-ft-shootergang-kony-beat-that-vest-up/" rel="bookmark" title="Music Video: Nef The Pharaoh ft. ShooterGang Kony &#8211; Beat That Vest Up">Music Video: Nef The Pharaoh ft. ShooterGang Kony &#8211; Beat That&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/11/music-video-swell-tgr-ft-flipp-dinero-better-days/" rel="bookmark" title="Music Video: Swell (TGR) ft. Flipp Dinero &#8211; Better Days"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/wZEsNl60T5tKSD3kkNYBh_prjo1JQjOc4Zi7RQf9YdV_N378twh0ZDUZXyIH4whsK5C-G2inxiJ9F9P-6vw_TlKZVp-qfviVZTDVv28N-xvx-CZc2wKvw76Fv8-JgrduEJ-UUpOLhcQoM6E7iIPj4pp35oKZa90bqDfOl8V6uV_w7T9aM_FeD7Xrbnwkx8Ox_lb92mnham_j95HpHr2EUllRhZKNvRUerlFDUwQxPuCVcZJXZnzY9Q5hfuDnrNwrObrWkj-P0unqY5nTfPdGFrOQ5Qbec6n6iM4XU5PmANwnmMySHNZs95vra4NesBEucKHhvEMEnTfGwXvNTmNlbTEgrbwCpGoKHI7FubGSJTAoLNMY41rdIC_5yucQTWVJMPIJGH-DZkid7-LqgvsTuhtZ3YNuTEUN-qKclbkwCV9HZEC9m30GyBaAQdADkXJbab1EEAxrnfK0kLg6b2I--fETOOyamywdItKlDgc5Z5se4y4-sgR4nfHjssI30wBc11R8r6rGZPDDqm7nhSYufJ9h0X5LpfNJ8JeD9EkhSx0wXfZSYM1LLbn7hOkgFyCA4EIwiyQgrMgF_fmdwC8zl9_5zdqaWr-ncS_OxSdANCrLQM-N7S1jp_d_y-hsTby91bT0oEEM3RzIFB_oraa3ZSmbsAeN8_Py=w1015-h621-no" alt="" title="Music Video: Swell (TGR) ft. Flipp Dinero &#8211; Better Days"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/11/music-video-swell-tgr-ft-flipp-dinero-better-days/" rel="bookmark" title="Music Video: Swell (TGR) ft. Flipp Dinero &#8211; Better Days">Music Video: Swell (TGR) ft. Flipp Dinero &#8211; Better Days</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/10/music-video-lil-reese-no-face-no-case/" rel="bookmark" title="Music Video: Lil Reese &#8211; No Face No Case"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/iGolKvLIXndOpnpf8v8dsWBx8TddN7jAxvFIIXG68pO88x-vywnEidrh4zaEuRqxWfQ62pbu_zNWN8GcA8JR_RLzTCrOJqLFIfgyinKgaCdHjAAXWmCltSXQz3OBE4f_HhUt2SH3-U3zLbNIJy9Arh_qSNEg2R1D-2vbTzOGnBx1nBixfusYvZ5C41Ot1D05jdpYMn8BxVHIKjofeFQAZXAQ7xrQiPyvDMvcUQjQnU_2QcfgFrbRg1JLeb7B4hCwx4OYlKtc9ljn2lM8V11bFPkSopCEevPk8xiTy3KiJo1sWfQF5hUe4kRG7cUY7pzAUZ0gvdHjrqjb9EVBbHTOhIsduWaYL-o1PqBXIefAkDp7SAXT_6InS0rlocAFMHNjRb_VgE8WxhVytru7J_tFSXqFu_8GmevDLbiV1ZW2Npz6IrM0Xc-XzVLKeVeVegbW_tjxdUyP3NLpHwCFEDUesaC92lAZ7WRYtYSHJoRGyZq0DCLwDuAIio1ijsJNcVGxI3R7adtXkLV0__DcI-cmVJ91xOZa5uQ7JGuRqwEWx0XDGA55AtyRHqzosgqmhqgk1z8yNkpBa-izxztNBOXunCsxioURsQC7ZqR6AbBigWYfb_SOggmk2nxh_SKzoNbUFwXWr47fOugRUh8mfUOZwUPYx3eiIjJZ=w830-h611-no" alt="" title="Music Video: Lil Reese &#8211; No Face No Case"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/10/music-video-lil-reese-no-face-no-case/" rel="bookmark" title="Music Video: Lil Reese &#8211; No Face No Case">Music Video: Lil Reese &#8211; No Face No Case</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_5d514c1c8d11c" data-td_block_id="td_uid_3_5d514c1c8d11c"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_3_5d514c1c8d11c" data-td_block_id="td_uid_3_5d514c1c8d11c"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_4_5d514c1c92359_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_4_5d514c1c92359" ><script>var block_td_uid_4_5d514c1c92359 = new tdBlock();
block_td_uid_4_5d514c1c92359.id = "td_uid_4_5d514c1c92359";
block_td_uid_4_5d514c1c92359.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"29","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_4_5d514c1c92359_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_4_5d514c1c92359.td_column_number = "3";
block_td_uid_4_5d514c1c92359.block_type = "td_block_mega_menu";
block_td_uid_4_5d514c1c92359.post_count = "4";
block_td_uid_4_5d514c1c92359.found_posts = "836";
block_td_uid_4_5d514c1c92359.header_color = "";
block_td_uid_4_5d514c1c92359.ajax_pagination_infinite_stop = "";
block_td_uid_4_5d514c1c92359.max_num_pages = "209";
tdBlocksArray.push(block_td_uid_4_5d514c1c92359);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_4_5d514c1c92359" id="td_uid_5_5d514c1c936b2" data-td_block_id="td_uid_4_5d514c1c92359" data-td_filter_value="" href="http://weuponithiphop.info/category/latest-news/">All</a><a class="mega-menu-sub-cat-td_uid_4_5d514c1c92359"  id="td_uid_6_5d514c1c9379b" data-td_block_id="td_uid_4_5d514c1c92359" data-td_filter_value="69" href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a><a class="mega-menu-sub-cat-td_uid_4_5d514c1c92359"  id="td_uid_7_5d514c1c938b5" data-td_block_id="td_uid_4_5d514c1c92359" data-td_filter_value="80" href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a><a class="mega-menu-sub-cat-td_uid_4_5d514c1c92359"  id="td_uid_8_5d514c1c939bd" data-td_block_id="td_uid_4_5d514c1c92359" data-td_filter_value="2189" href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a><a class="mega-menu-sub-cat-td_uid_4_5d514c1c92359"  id="td_uid_9_5d514c1c93ad3" data-td_block_id="td_uid_4_5d514c1c92359" data-td_filter_value="10" href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a><a class="mega-menu-sub-cat-td_uid_4_5d514c1c92359"  id="td_uid_10_5d514c1c93be2" data-td_block_id="td_uid_4_5d514c1c92359" data-td_filter_value="130" href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></div></div><div id=td_uid_4_5d514c1c92359 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/11/video-t-pain-the-breakfast-club-interview/" rel="bookmark" title="Video: T-Pain &#8211; The Breakfast Club Interview"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/iPC2hdOmlI9yHryW1TaDq_4lFUYF0uPtQ4bwaPiADTMkSyVnrB8aUG20SYQ0lafpEUFmEUtNH14E4Kd84H4nMVqmVZ1fSkSnRZpOu_Bd1R1v6zF98tldTJpFVCC_Cdgkaj_QenRzoG8B4s6O4mM-W5Z5grmyc68tMf6gzviML15hIfH7c0xpYfZ-Tp55algxc7JjOTHHXSyV9p_nqCuU4KtMWEKw4KUwhRHVQLZh5YbUAiGlye1Uej71gruIvDyXp6sKSMwGfNwwTFkXREYKYbR4DvHGakOdfAImwu1ANXPretTy0zq9-Lj8X2JKLbuBvevMFK3NzOYOnjvrWXGL94tJd3FJtAgNEFNzaMVKNI5Kva3X4TfiVCE3jSkm2gAKs1GrIfLTKQ0hrH8Wu8SjSl9p2uKvdSneymOnDijyN6Q6wnzCcbksoScfx02OFWc2Acv5YCkfLBtsTjsmYVKlT6zhv8vC4z2ba1H36J9NZTzTcbRTmhCqa-K0qeO70UdwtMjhxZqt00MPwDFZqEAWHG5pxXdbkMv7cTcPM9q_tf1Qoy2jBItBUVR4pbheOC6Pi92tULXz9CMF6F8x40sjHl9gNNsV6OT_FRj7bAfL5r6alLBbkmsvzW6QaRkjEIqneFd1vbaDiHPMugu2XrCKeS15dcoEU7Ku=w1156-h538-no" alt="" title="Video: T-Pain &#8211; The Breakfast Club Interview"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/11/video-t-pain-the-breakfast-club-interview/" rel="bookmark" title="Video: T-Pain &#8211; The Breakfast Club Interview">Video: T-Pain &#8211; The Breakfast Club Interview</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/10/video-rick-ross-explains-missing-pusha-t-verse-on-maybach-music-vi/" rel="bookmark" title="Video: Rick Ross Explains Missing Pusha T Verse on &#8220;Maybach Music VI&#8221;"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/ziN-GpobEP2fX30SKVYSgWAOUrjbcHw99i33nbJPZoeF-K6o66qR9xdhSyOa6ISUW30Ur4D_6KGYDcAeol7LisHDf_C9545lRCPJ6zwvuo3wLrvsPkCTN7Iv8T_zTPR3NKEmggoaM2thFqLAg6UMMFU6ekBUOQ_0qZJuDk3ZKJWLTlrOUR6ZEoNRMgcM-J09oOCO07sHeL1RbEYB0TIbFFGl9MG0wt87LrsnrsCit7980wKIDL6qNkUO_XtJwVrEqZyfJDKPvjNRP-R7YtjNFpWAx1t0g-qbcrLzoQv6F4WNq3xABX3SKxdq7aHnCJ1fra-E9lyGmmOEeFnHI8V2zcB8an9Us4yDhIuYWGYQnZkYAAJmqS2ivZzCj2tcF-YCESg8SC_ciZoEzgPI80ZZjbP65iWBeSvaLxJ0GtMr6X1ZKD3oeHL1C4IlL_7l8c8xrHI8q8oFuC8q2J9njByVnu2dXpzaWkxROa8HpNUjT35-H12ccZpfQDM-BJnC0x7IBDbcJRcKFicnis_kL_j5vdYvj80uBIhwtIyNluZdhmfi1m0iYERwjHuqY2OnhyZh-zwnTwhp0GYNoeWJBhcwGBCIfBweTKbr9DVH37B5vXHNMOqb-DtvwGPT_DB07_04ZPHyldLvHiwVmSQanGQd8N86OZ0uNyGA=w881-h611-no" alt="" title="Video: Rick Ross Explains Missing Pusha T Verse on &#8220;Maybach Music VI&#8221;"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/10/video-rick-ross-explains-missing-pusha-t-verse-on-maybach-music-vi/" rel="bookmark" title="Video: Rick Ross Explains Missing Pusha T Verse on &#8220;Maybach Music VI&#8221;">Video: Rick Ross Explains Missing Pusha T Verse on &#8220;Maybach Music&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/09/jeezy-tm104-album-artwork/" rel="bookmark" title="Jeezy ‘TM104’ Album Artwork"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/uNZVI8EPeQ5W7oyBM9kXK9WJ-2VbkeNJFCXs2a2wFwhDxAcEpOBEVfRap0nXybUNsuDbiNRpFf2TR2CWKmyCSOhKtZgA9YeXWiFHO8bwdPjdkTOTgf4Vb-iuuOyLVRKOqTJsg5BwV81Ov77bZWhjmwXk7SYtAKIVNBVGpj72L2WBVOUQl2SjWWGpM98OQSSnn8F4oYHRHTlvarBYMANAA29MFqaFO2nWk3-tNZkTjORuFtypzISbpvnVoP5iLpdSLo5k7BemSMaM1ZdYtfOO9MSv3fAqNKMG-NyoR1kDlEH2RTNNVnLbSkm-7xB4yDTODW0bFK__WmoAz2D3speTQpQluirZmxJMzUlsXDwPbGaa5MY0hQoD6rwnfKujA3KFq2C3zCyq27WR-jIWYin321II2pvwyXWQhMm1W3nKU1zzKflIt6JrIFZOA4PvvUxfVo86NAKfDWNsGViVi6hunXVYwzXNPW9AW6Hx2VjHz3BlUJRlDLY42LnvGBEVYifPzaVFmbRTCIxFQkyYFDd_mkz1CB236p87LSdiVDEHRy8bEKewnEKZ1UwXXzXp2lDHZdGHcm7HKwDNS51BDpCa0-2SmK8gR3F3NjjMbh0osW5sWnVQk-JsT5MZkPTytH42QluVdfJVL-t4rg02M3E8D-E2QjyAp8ts=s680-no" alt="" title="Jeezy ‘TM104’ Album Artwork"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/09/jeezy-tm104-album-artwork/" rel="bookmark" title="Jeezy ‘TM104’ Album Artwork">Jeezy ‘TM104’ Album Artwork</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/09/video-idris-elba-hot-ones-interview/" rel="bookmark" title="Video: Idris Elba &#8211; Hot Ones Interview"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/7oGBbOKquFm_2omicNvdPz3PkarOQzOeR_C8tFbpZ1MDjZ9XD198tdXYmYAThjffrmIMQlrxQhdSFRFsIy2QphFJyuIpxrtu9Hl5e40Zq0D6-0FLUYGGru7fl66YZxN5fHH27oGUOYjvwLf19wx8Nf6DL62eacEiSSiPre88AhVhp1GP9MSbadoLX0GkJ-IIxznjJxWQT1XRJMUHJmDDSryrt7EM4W_usJvQ6Pp5jwIaV20u_cNIDduN5l4UWNujOar0L6o46uCa9z4sfqpv8P_sBDPIKY82xl17xC0ruh9aJO6dMO7uzLvufULQi6Lz8_0GNUTfWlJv3-v06USemGiMVACBYYKPxcgzz04nwgCsps-DCm1U1OShrXxjFKn8BTEJw2FZ5JWmidBrev8TQK93n7jUvgwQvW8e8_u2Kz6aVrY7j29lB6iNd_kwo3_u7jZXiHH1xfCMx-b6Y6mU3lqndBKPfdjYQN9V-H-HXed-LVX_IfZsqQESp2ZGLKS8hZK_npHKFg5uLf11Koslrv1g09RFtF1lC2VwWHquxkoSdY1y8XSb2620fvrfrgdVbePgUPalXw6pixi81pUtrKqLe9DEGl1M8w2M7VhmeopjsfpoJ-1T__aDIY_gjQQwll-hx_VU7n3pR8YZtoy-9Es_8K-XYf-0=w1148-h609-no" alt="" title="Video: Idris Elba &#8211; Hot Ones Interview"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/09/video-idris-elba-hot-ones-interview/" rel="bookmark" title="Video: Idris Elba &#8211; Hot Ones Interview">Video: Idris Elba &#8211; Hot Ones Interview</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_4_5d514c1c92359" data-td_block_id="td_uid_4_5d514c1c92359"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_4_5d514c1c92359" data-td_block_id="td_uid_4_5d514c1c92359"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_11_5d514c1ca9f5a_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_11_5d514c1ca9f5a" ><script>var block_td_uid_11_5d514c1ca9f5a = new tdBlock();
block_td_uid_11_5d514c1ca9f5a.id = "td_uid_11_5d514c1ca9f5a";
block_td_uid_11_5d514c1ca9f5a.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"77","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_11_5d514c1ca9f5a_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_11_5d514c1ca9f5a.td_column_number = "3";
block_td_uid_11_5d514c1ca9f5a.block_type = "td_block_mega_menu";
block_td_uid_11_5d514c1ca9f5a.post_count = "4";
block_td_uid_11_5d514c1ca9f5a.found_posts = "158";
block_td_uid_11_5d514c1ca9f5a.header_color = "";
block_td_uid_11_5d514c1ca9f5a.ajax_pagination_infinite_stop = "";
block_td_uid_11_5d514c1ca9f5a.max_num_pages = "40";
tdBlocksArray.push(block_td_uid_11_5d514c1ca9f5a);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_11_5d514c1ca9f5a" id="td_uid_12_5d514c1cab92d" data-td_block_id="td_uid_11_5d514c1ca9f5a" data-td_filter_value="" href="http://weuponithiphop.info/category/fashion/">All</a><a class="mega-menu-sub-cat-td_uid_11_5d514c1ca9f5a"  id="td_uid_13_5d514c1caba16" data-td_block_id="td_uid_11_5d514c1ca9f5a" data-td_filter_value="76" href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></div></div><div id=td_uid_11_5d514c1ca9f5a class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/LVT4Mid8WL4wHUdO9X2OZmZxxgbREs2lVtszOdEBaO6hJB0JS3yQOAyhNSdCyPmv0amBDTgNGpOlRPXPjKCl6yIlo2joyH3rQRI7CUdX09BJtQI1r5jy1_7BQtDhw4AxUhpUwIh35rNS3lTy7uq-FdPff10JN6srr9mwZ7zr04GQFxBVEXwCfC5rNVehXhY_wGCRVsmevYmdkBWEmB8dvOzBHY78NBBjcHNArS_S-2M0FJgDh8v9m9vEh78k_XmZg-AERctsf0bkODuPi1EcNJq_RnJIV6b0GG-VtKjo-OVPmYghWJYf1HiP9c58cQ98oABU8BDFdLqsBtNt4K0NmyHYQlX39W9k_d83wEHZ1-EacQa2o01VrYSn12HnZ1l88fMzu9PKv6EGmcRZNwpepycW7_9EQnhxIPDdVCmRLXUasUED9OXr-zJmnBcnSnLCa06k1ZymQym1LiSFEv1c3aPHnmnD3GY8nL7q5jPJr4HsABR0WCqMebcF3HF_0deNd0zgRBCGMxW-VzlIIHZiHuBeSPEPvUL149GJ5swSSvKm1uGEi1HlLBj9omJSU7mDWzO0p_7l-l7-4_ureEsGsgB8cX1t8t2TQcFeRgqqF1CXlZFYYC2K0iMb4jPsijsw_rtO7pmKvbngqHfgYpGeh_qLmDWeicR7=w1195-h796-no" alt="" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch">Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/fHEwwMf8DoiXlqkfibQS1Z1XXbviORbV9raaI44tOTXrWo7GgqM3gA-vswE10gFtTQUGGwNG7nWAACwHjxPuiubliYBN_dqtBZh2WIpxvumiJ-hSLK0TNWB2cB8Iw2STT5gcp_KqlDh_e4xng1vidI8EXdp_ooh5uDI-JV1HQ9dGnM5nxl_b-v8znqj-Rl_mGB7y4Lu9zsFNWHU7SriqQQJaKrKEEnb9T8zxmGLaL0zq7ilYpnUEhWulDDr9xc82wdr__WzRBm5YEskVpDAnGM2NDZwTZpjbe4QDdxeixWnSXNK_oDzaL7WTbCpkD33OK88BlI5JmFRQ5VmD11UQ2htB7-9WoahHvb4XmBsbLXpEMl1JmEP4sPx06VduzFnBNo-J90WI0n1AEIIcEYVbRywrkGJXbzmH__In9ZIg0EV24OcGGbeKl12HxTdZwucqsNnuZeNjiMHISQ7i8cfzm3N7X7Zenl74zsKIKeKWoIGxh6MTlVADvgHcrHebnjcSgil2vBeFyz_AP45aOv9SOwbzfVLGS0CNfe1s9b2J7qZgjcBk9QPEXCl2kygvzmGXFvU_3xBuW6S0i3Vkh3Ha_3hPBtvIAy3WoTK2yiqS41HzSK7yk3FRAlBtpIEib338fdkTiosBxtdu36SdNUVM75zl6CVIFhTu=w681-h470-no" alt="" title="Air Jordan 14 Rip Hamilton"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton">Air Jordan 14 Rip Hamilton</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/kUjaOYxjEkAh34S-Ub2QSZwdOwHyFnGFLBZULta3_bn1_myPMAwJXiEEsAAtc1ktCQwHCuKhSqSYsWXFBEIZxdfKuykoDEZWwO-dDI3_JeAshbYvyILEHUu0XaUpRn0mj7gOx10V52t8gRGYPCW7QXGImkPGGhvBPzBDVVqh9lKGtkuPeePmTnpRSmwp0LG1WHcIzUWnMqPBWQeHAat6Q-Tq7niXNb96ddEZsMEdHK1nmHVlNaeqFBNtTxk6yYRkFNCvtfBayqy-Rqt4CPU5tThxbTI4AIUCI6JLxJd_VJizrVNDEe2xZ_tiQdkC5ASIoHpX8sfvAB8zRUsMVJ6oMUt5FH_4GBNXDCtFRmr65Qt0JV1h4bBJffu2L272Q_vpD76wn-YNGW8VCtZcheHu_X-A4gdYQEC0HN0BenY-MOuUBqKEjXAc0SxWeP7W9RN55jlqUFK0nzEYydVjec2stdQIngVfg_FvKxvHXfM4XdtMpqeJnp3Pzyk8xjz30sAZd0f2HQ6zfdPjk-OkV2-WrC0_qW0L8Rq3zrUbq52n3BN7gm7sctU_CUlBmoQIgJDQBYk1Siv4tfSq9pL1R4GdaOlWQdxEuhZi8bTYC8GGAgNGl3SMAZGvk7nu6QnnwEZjZ7mZwbcqgyRKa89cOREMUvIkVJ8Q8lZu=w926-h672-no" alt="" title="Jordan Proto React Triple White"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White">Jordan Proto React Triple White</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4cDUjSODZSaXWfHyZKb9q3Fn7FHA4uB0KSBs0MtFHC0dc6AJb1zeAl_X2LOKalK9C7VBFhTqRQ9fw1ESgUr9ZUKFbOzD94i_s96nvkICOqrsYnzrE2nEAQHoEaGOF4O8GAI6T4CGFbgcQhNzjpRlSY60NyPu5Cmq81FRpEOFRzTOtSa_NnWzMmfwO0yxtPbcg5U6YBUsus8shv3SA7CjULLfaP38nZAuWVgq8PMaaeCQ_eSrK8NJSEVQjyyxmqb-1I7zO8Kvvzvwi--ibMr52CF8h-GusBzSq5ZuzvZRCGu_u8CyfoXw7pwWbOmHnLOdcQ9d2PCSW_IxEMGfmEuU7NxMSsW3Ga4r35_wLB7cjvlPC9OjCV50tfekXjZBS_476mzlf4G9jR7Ju1GqgjXah9Uqc_0Y8N-Br8_JCtIlRSuLxAiebwd7AvFVlgWId9MYxBWnRT3cTyD8SH7q5WwO-CIbKAOSKsNcrrTgFxQvqn9yklBU1u5X5fdTlTBk4WSYorsWZAug0z9BOymRLnrhTbnA0vpBPFROWD-aL1glg-eUpFSfgD4xhWsOqJNY9krQ2UbLSGXQ5gYWj0ovLS7Yz3UKFY2qrVWpqkpbfyN98es9NJ-7LTUs2MLq1rX_2FaQmyq5mVndd7VGzQOHy9hDULG-5H-0LvGd=w900-h566-no" alt="" title="adidas Yeezy Boost 350 V2 Hyperspace"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace">adidas Yeezy Boost 350 V2 Hyperspace</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_11_5d514c1ca9f5a" data-td_block_id="td_uid_11_5d514c1ca9f5a"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_11_5d514c1ca9f5a" data-td_block_id="td_uid_11_5d514c1ca9f5a"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div></div>


<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form method="get" class="td-search-form" action="http://weuponithiphop.info/">
				<div role="search" class="td-head-form-search-wrap">
					<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>            </div>
        </div>
    </div>

    <div class="td-banner-wrap-full">
        <div class="td-header-container td-header-row td-header-header">
            <div class="td-header-sp-recs">
                <div class="td-header-rec-wrap">
    
</div>            </div>
        </div>
    </div>

</div>
<article id="post-33946" class="td-post-template-7 post-33946 post type-post status-publish format-standard has-post-thumbnail hentry category-editors-picks category-mixtapes tag-murs tag-tony-robbins-pocketbook" itemscope itemtype="http://schema.org/Article">

    <div class="td-full-screen-header-image-wrap">

        <div class="td-container td-post-header">
            <div class="td-crumb-container"><div class="entry-crumbs"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="" class="entry-crumb" itemprop="url" href="http://weuponithiphop.info/"><span itemprop="title">Home</span></a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="View all posts in Editor's Picks" class="entry-crumb" itemprop="url" href="http://weuponithiphop.info/category/editors-picks/"><span itemprop="title">Editor's Picks</span></a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last" itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><meta itemprop="title" content = "Album Stream: Murs &#8211; The Iliad is Dead and the Odyssey is..."><meta itemprop="url" content = "http://weuponithiphop.info/2019/08/12/album-stream-murs-the-iliad-is-dead-and-the-odyssey-is-over-4/">Album Stream: Murs &#8211; The Iliad is Dead and the Odyssey is...</span></div></div>

	        <div class="td-post-header-holder">

		        <div class="td-parallax-header">

	                <header class="td-post-title">

	                    <ul class="td-category"><li class="entry-category"><a  href="http://weuponithiphop.info/category/editors-picks/">Editor's Picks</a></li><li class="entry-category"><a  href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a></li></ul>	                    <h1 class="entry-title">Album Stream: Murs &#8211; The Iliad is Dead and the Odyssey is Over</h1>

	                    
	                    <div class="td-module-meta-info">
	                        <div class="td-post-author-name">By <a href="http://weuponithiphop.info/author/cyclone/">cyclone</a> - </div>	                        <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-08-12T06:23:01+00:00" >August 12, 2019</time></span>	                        	                        <div class="td-post-comments"><a href="http://weuponithiphop.info/2019/08/12/album-stream-murs-the-iliad-is-dead-and-the-odyssey-is-over-4/#respond"><i class="td-icon-comments"></i>0</a></div>	                    </div>

	                </header>

		            <div class="td-read-down"><a href="#"><i class="td-icon-read-down"></i></a></div>
		        </div>
            </div>

        </div>

        <div id="td-full-screen-header-image" class="td-image-gradient-style7">
            <img class="td-backstretch" src="https://lh3.googleusercontent.com/pjY7HnG9-IEI4lqhjxutqk9ZTbQWp8dNgf9-zEPRbsoAorWHAk9nIK6yJ1yy1kzWNYlArHyrVpbGO2fSL7opXWemd_zia03SasLg15VSYOQNg_z7ZPy2jTd-BWNC3Ij0v9UARatMWb_GvSZd-L1w88-dpxZoBRIWFG1J8wxbYiJjFxDsjdsitPdlA3soOLuQ3Ot10nKF6rBEO6r31WLbuBtDXobxMQy3wP26FlyD2motMbIIgXk2hYrUq7MiyaJSYpNcBh-yCQDeAzShchsHMBWtHxfkKJb5-1NKpYzyodT9Eit6rYXICkfL9XIfOOm4XSTH6pXXg2IBUT8felfZwZ3oj3Fho58jGNMCm4SPEzSYLRDxFSonTkNhYq1NDHVP1iyM-UA4pVmB-u5YgNMNSp21gPmFSJ8tKuu9ZwmIplsSBWHiBOnuyvdNm2YqSs6839u6iyQ6zJtPTbU4haNpkgFQoswxFZmJqcbBwM0uBZJOwh9jtyWMQ7p43HFtbL8Tton72cvJO7g2F-BnDAQOiEpccsRfwNrip5x8aeLhxG4yY_C9_9oMxGg6zWHJomoGa_xkUvtvOo-bfE_2sX2MUKAp-JU9kJKc3wEB1RpopisFTOKFEBGIwAhbKTCC8AzRp4MELThL8Sf0QaEmpZs911pg5MmZLFwe=s736-no">
        </div>
    </div>

    <div class="td-container">
        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    

    <div class="td-post-content">
        <p><img class="aligncenter size-full" src="https://lh3.googleusercontent.com/pjY7HnG9-IEI4lqhjxutqk9ZTbQWp8dNgf9-zEPRbsoAorWHAk9nIK6yJ1yy1kzWNYlArHyrVpbGO2fSL7opXWemd_zia03SasLg15VSYOQNg_z7ZPy2jTd-BWNC3Ij0v9UARatMWb_GvSZd-L1w88-dpxZoBRIWFG1J8wxbYiJjFxDsjdsitPdlA3soOLuQ3Ot10nKF6rBEO6r31WLbuBtDXobxMQy3wP26FlyD2motMbIIgXk2hYrUq7MiyaJSYpNcBh-yCQDeAzShchsHMBWtHxfkKJb5-1NKpYzyodT9Eit6rYXICkfL9XIfOOm4XSTH6pXXg2IBUT8felfZwZ3oj3Fho58jGNMCm4SPEzSYLRDxFSonTkNhYq1NDHVP1iyM-UA4pVmB-u5YgNMNSp21gPmFSJ8tKuu9ZwmIplsSBWHiBOnuyvdNm2YqSs6839u6iyQ6zJtPTbU4haNpkgFQoswxFZmJqcbBwM0uBZJOwh9jtyWMQ7p43HFtbL8Tton72cvJO7g2F-BnDAQOiEpccsRfwNrip5x8aeLhxG4yY_C9_9oMxGg6zWHJomoGa_xkUvtvOo-bfE_2sX2MUKAp-JU9kJKc3wEB1RpopisFTOKFEBGIwAhbKTCC8AzRp4MELThL8Sf0QaEmpZs911pg5MmZLFwe=s736-no" alt="Murs - The Iliad is Dead and the Odyssey is Over" width="736" height="736" /></p>
<p><strong>Murs</strong> delivers his new <a href="http://weuponithiphop.info/tag/album/">album</a> <em><strong>The Iliad is Dead and the Odyssey is Over</strong></em>. Produced entirely by <strong>9th <a href="http://weuponithiphop.info/tag/wonder/">Wonder</a></strong> and <strong>The Soul Council</strong>. The album features twelve new songs and guest appearances by <strong>GQ</strong>, <strong>Rapsody</strong>, <strong>Heather Victoria</strong>, <strong>Reuben Vincent</strong> and more.</p>
<p>You can stream <em><strong>The Iliad is Dead and the Odyssey is Over</strong></em> in its entirety below and download it now on <a href="https://music.apple.com/us/album/the-iliad-is-dead-and-the-odyssey-is-over/1465840619?app=itunes">Apple Music</a>/<a href="https://play.google.com/store/music/album/The_Soul_Council_The_Iliad_is_Dead_and_The_Odyssey?id=Bpi7qu36erg4a32tv7of2z7qpga">Google Play</a>.</p>
<p><iframe style="width: 100%; max-width: 660px; overflow: hidden; background: transparent;" src="https://embed.music.apple.com/us/album/the-iliad-is-dead-and-the-odyssey-is-over/1465840619" height="450" frameborder="0" sandbox="allow-forms allow-popups allow-same-origin allow-scripts allow-storage-access-by-user-activation allow-top-navigation-by-user-activation"></iframe></p>
<p><iframe src="https://open.spotify.com/embed/album/7gY2JVughebK1borXe7h8J" width="100%" height="500" frameborder="0"></iframe></p>
<div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="http://weuponithiphop.info/2019/08/12/album-stream-murs-the-iliad-is-dead-and-the-odyssey-is-over-4/" data-a2a-title="Album Stream: Murs – The Iliad is Dead and the Odyssey is Over"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F08%2F12%2Falbum-stream-murs-the-iliad-is-dead-and-the-odyssey-is-over-4%2F&amp;linkname=Album%20Stream%3A%20Murs%20%E2%80%93%20The%20Iliad%20is%20Dead%20and%20the%20Odyssey%20is%20Over" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F08%2F12%2Falbum-stream-murs-the-iliad-is-dead-and-the-odyssey-is-over-4%2F&amp;linkname=Album%20Stream%3A%20Murs%20%E2%80%93%20The%20Iliad%20is%20Dead%20and%20the%20Odyssey%20is%20Over" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F08%2F12%2Falbum-stream-murs-the-iliad-is-dead-and-the-odyssey-is-over-4%2F&amp;linkname=Album%20Stream%3A%20Murs%20%E2%80%93%20The%20Iliad%20is%20Dead%20and%20the%20Odyssey%20is%20Over" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F08%2F12%2Falbum-stream-murs-the-iliad-is-dead-and-the-odyssey-is-over-4%2F&amp;linkname=Album%20Stream%3A%20Murs%20%E2%80%93%20The%20Iliad%20is%20Dead%20and%20the%20Odyssey%20is%20Over" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_tumblr" href="https://www.addtoany.com/add_to/tumblr?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F08%2F12%2Falbum-stream-murs-the-iliad-is-dead-and-the-odyssey-is-over-4%2F&amp;linkname=Album%20Stream%3A%20Murs%20%E2%80%93%20The%20Iliad%20is%20Dead%20and%20the%20Odyssey%20is%20Over" title="Tumblr" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_reddit" href="https://www.addtoany.com/add_to/reddit?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F08%2F12%2Falbum-stream-murs-the-iliad-is-dead-and-the-odyssey-is-over-4%2F&amp;linkname=Album%20Stream%3A%20Murs%20%E2%80%93%20The%20Iliad%20is%20Dead%20and%20the%20Odyssey%20is%20Over" title="Reddit" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_flipboard" href="https://www.addtoany.com/add_to/flipboard?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F08%2F12%2Falbum-stream-murs-the-iliad-is-dead-and-the-odyssey-is-over-4%2F&amp;linkname=Album%20Stream%3A%20Murs%20%E2%80%93%20The%20Iliad%20is%20Dead%20and%20the%20Odyssey%20is%20Over" title="Flipboard" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F08%2F12%2Falbum-stream-murs-the-iliad-is-dead-and-the-odyssey-is-over-4%2F&amp;linkname=Album%20Stream%3A%20Murs%20%E2%80%93%20The%20Iliad%20is%20Dead%20and%20the%20Odyssey%20is%20Over" title="Copy Link" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div>    </div>


    <footer>
                
        <div class="td-post-source-tags">
                        <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="http://weuponithiphop.info/tag/murs/">MURS</a></li><li><a href="http://weuponithiphop.info/tag/tony-robbins-pocketbook/">Tony Robbins Pocketbook</a></li></ul>        </div>

                <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="http://weuponithiphop.info/2019/08/11/music-video-o-t-genasis-ft-g-eazy-rich-the-kid-e-40-bae-remix/">Music Video: O.T. Genasis Ft. G-Eazy, Rich The Kid &#038; E-40 &#8211; Bae (Remix)</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="http://weuponithiphop.info/2019/08/12/new-music-salaam-remi-ft-busta-rhymes-mayjah-hype-thirsty/">New Music: Salaam Remi ft. Busta Rhymes &#038; Mayjah Hype &#8211; Thirsty</a></div></div></div>        <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="http://weuponithiphop.info/author/cyclone/">cyclone</a></span></div>        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="cyclone"></span><meta itemprop="datePublished" content="2019-08-12T06:23:01+00:00"><meta itemprop="dateModified" content="2019-08-12T06:25:41+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://weuponithiphop.info/2019/08/12/album-stream-murs-the-iliad-is-dead-and-the-odyssey-is-over-4/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png"></span><meta itemprop="name" content="WeUpOnIt"></span><meta itemprop="headline " content="Album Stream: Murs - The Iliad is Dead and the Odyssey is Over"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://lh3.googleusercontent.com/pjY7HnG9-IEI4lqhjxutqk9ZTbQWp8dNgf9-zEPRbsoAorWHAk9nIK6yJ1yy1kzWNYlArHyrVpbGO2fSL7opXWemd_zia03SasLg15VSYOQNg_z7ZPy2jTd-BWNC3Ij0v9UARatMWb_GvSZd-L1w88-dpxZoBRIWFG1J8wxbYiJjFxDsjdsitPdlA3soOLuQ3Ot10nKF6rBEO6r31WLbuBtDXobxMQy3wP26FlyD2motMbIIgXk2hYrUq7MiyaJSYpNcBh-yCQDeAzShchsHMBWtHxfkKJb5-1NKpYzyodT9Eit6rYXICkfL9XIfOOm4XSTH6pXXg2IBUT8felfZwZ3oj3Fho58jGNMCm4SPEzSYLRDxFSonTkNhYq1NDHVP1iyM-UA4pVmB-u5YgNMNSp21gPmFSJ8tKuu9ZwmIplsSBWHiBOnuyvdNm2YqSs6839u6iyQ6zJtPTbU4haNpkgFQoswxFZmJqcbBwM0uBZJOwh9jtyWMQ7p43HFtbL8Tton72cvJO7g2F-BnDAQOiEpccsRfwNrip5x8aeLhxG4yY_C9_9oMxGg6zWHJomoGa_xkUvtvOo-bfE_2sX2MUKAp-JU9kJKc3wEB1RpopisFTOKFEBGIwAhbKTCC8AzRp4MELThL8Sf0QaEmpZs911pg5MmZLFwe=s736-no"><meta itemprop="width" content="800"><meta itemprop="height" content="600"></span>    </footer>

    <div class="td_block_wrap td_block_related_posts td_uid_15_5d514c1f4559d_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_15_5d514c1f4559d" ><script>var block_td_uid_15_5d514c1f4559d = new tdBlock();
block_td_uid_15_5d514c1f4559d.id = "td_uid_15_5d514c1f4559d";
block_td_uid_15_5d514c1f4559d.atts = '{"limit":6,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_custom_related","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_15_5d514c1f4559d_rand","offset":"","css":"","live_filter":"cur_post_same_tags","live_filter_cur_post_id":33946,"live_filter_cur_post_author":"1"}';
block_td_uid_15_5d514c1f4559d.td_column_number = "3";
block_td_uid_15_5d514c1f4559d.block_type = "td_block_related_posts";
block_td_uid_15_5d514c1f4559d.post_count = "6";
block_td_uid_15_5d514c1f4559d.found_posts = "6";
block_td_uid_15_5d514c1f4559d.header_color = "";
block_td_uid_15_5d514c1f4559d.ajax_pagination_infinite_stop = "";
block_td_uid_15_5d514c1f4559d.max_num_pages = "1";
tdBlocksArray.push(block_td_uid_15_5d514c1f4559d);
</script><h4 class="td-related-title"><a id="td_uid_16_5d514c1f4bc57" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_15_5d514c1f4559d" href="#">RELATED ARTICLES</a><a id="td_uid_17_5d514c1f4bc96" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_15_5d514c1f4559d" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_15_5d514c1f4559d class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/07/18/new-music-murs-9th-wonder-ft-rapsody-reuben-vincent-high-noon/" rel="bookmark" title="New Music: Murs &#038; 9th Wonder ft. Rapsody &#038; Reuben Vincent &#8211; High Noon"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/bdYqK8oP_D4tH9UOVXl2k2mU989r5eZojLRfcz95dp9sw8gVv2CRlBBOvEPUcsCwyb4VzP2nmf01NhSSVvqR4DCBRRV26M_F9q6CIWp6G5YrAm3unxJSdaMF0A0oJ85Glb3yq8aXpO3Ma4hGxhGBGx4jMT90fER-haktr8A-sm5n-vVaV-iE4uO_nCPkPineoebeZaHcyDk0AN4OopnEupvt29HUHOi7sTq444tJ0wFITmzTcl--zHGCd6Sw2w33nTvnfPQPOW7duIw8igNxpysvpsNE1ubuJYb35LPIvx3IKHqcxBi7tz-Zwy9hL5LyCOzcbU7RpmElhM8X4Oit7WXCTg7pFMVZw8eCFyQ-C1VohT6E8CcxU3T5CG-tnSw2l56fPEcLAKUd8QCYKcR-5W60Xe7UXEWNpiUnw0c8onbnOc3asuziZnDSRAM0_yUVXraMlp4eAfJVBVYW0AAUDv2H32iMOQ-bQNq9ho9_yLPcCBh5HjKkfU1t_Z9wzUuWwXVks5mLA42Mv-3JQloIOUSGHQjTNDIEV3ZI0ewpR6PM61BhwQ4aWgI_xviPuShcoUWvckBMl03MzNqj5bgHtUnCvacFBZzvn1f1mNqD8rs_CYQB5RAZpVWyrPbNMbvq4sea_Cf92bq8tzYEQYhjHsAhIsl0rNYx=s672-no" alt="" title="New Music: Murs &#038; 9th Wonder ft. Rapsody &#038; Reuben Vincent &#8211; High Noon"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/07/18/new-music-murs-9th-wonder-ft-rapsody-reuben-vincent-high-noon/" rel="bookmark" title="New Music: Murs &#038; 9th Wonder ft. Rapsody &#038; Reuben Vincent &#8211; High Noon">New Music: Murs &#038; 9th Wonder ft. Rapsody &#038; Reuben Vincent &#8211; High Noon</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/19/music-video-murs-9th-wonder-night-shift-9/" rel="bookmark" title="Music Video: MURS &#038; 9th Wonder – Night Shift"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/i7EOIU4tqQwm5T7gES22TehXCblF8s23E0lWYa2nNRGgfkCNiyB81RiztJEmYVtm0B96ks_Zz0RfC97GCxiHrFuDlkcevIxr9wZdmi1Y3EbvhyasRxpkagjJCKOR48dT3UzxT5NqIGt77LJfHMEtm9qs80y5wxm2T_zwxGhgMvG59N-Gh_tkAANPy0BCCfMdzpvGV-gwPtHA_swP-HR79cY1abFiUbp7TMqMH4atQZZKhywFp8AOF-Y6maTzZ5Y3EbnNPKT7APvWcpXts0CDqnbcacVrsD_kRPVn5GZ2QXD5q5bNIvB84JnL9hYrqzmI0YPbop_fK_0ctYLhsJbsPwdZNp1Szlt5D0nvnRsDcJzufQeP39VMrLZqzXamEn0-rLcKZk30nQ5Qw6dlM-GfzPtq6zp_Ro_Y7dQ9Z2FRfjsh3PWFkZ5zKA8BFfwyUPO1VSQms2JTcQ3gQEv1kRtvk28Npn-TC-kSma7YRR_aGSOkRO4QuE-o2ko0bGA_6qjaqsQ54iGS3zZ4lOMGND2DCux73JPY8LPzFInm-5q4bqwOms9o5bKv7yjTQf5fXlLCUas2mp1vDUYfXhIrW0mhNh1TSa097sy23TELFIeeqYPGDO-wrK5GeYjHYtF9O5L1lzEEdrd_aIaVTVrh769yAM_zTEQYQPFG=w882-h581-no" alt="" title="Music Video: MURS &#038; 9th Wonder – Night Shift"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/19/music-video-murs-9th-wonder-night-shift-9/" rel="bookmark" title="Music Video: MURS &#038; 9th Wonder – Night Shift">Music Video: MURS &#038; 9th Wonder – Night Shift</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/30/new-music-murs-night-shift-gas-station-gucci-belt/" rel="bookmark" title="New Music: MURS – Night Shift / Gas Station Gucci Belt"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/a1ohbsplKmc4O75Q4knRJDroPNK7yNqIEAImReunvcK_tX4R3lOzT--aWDZkELOg-Jx6IwyCPEpC2xqsVdPOUX7MvrdGTBub1oLhkv0GAUMQorbwMSRGydSoO8cP0zDDsIUu5LnseHd5ulNvDXLlmmRHMQ7wUxjyCd3vXXyfXq6AEzCEYxtC90-SEcw4J3z-2mIBAAe4hMuJrlHw3tiUCLgmzLV0nFbUJe9nxMNOozSLk_UFsxrPuxYCHdtpS-Bt5JXo0jZoqxL7A_eQ8VN4T4iI6mRFS8_UJfcQNRnGxzfstgF0Pn_M3x4YXo198Pfc4VM6KlMUAgtlqhbQ9n2MGoZuGH2KXYljNnbknqTPQJpHlvdLMXzSBXdpn-dryZ32t8cBq86HBdFfNxD5RAtOPz8-9QOUxkYS8Q4t_N_vWrh2BKzN8s2haWHm9rlMsSWgVIRFO40KwCuh8l5jJ5DrqiwWWsxEsUOsoyApEdJ3p_ZoZq17ZMJDASRZjgVskE2Zd2ANeJE-RbjHj3zb0jBI-CqD9o7zK31u2ZrRFn8pVZGwSsxIww85wvCaeyuLv8e5yHIRmM0ZnzgRgwgEX_XkbvgikrxvYcK-Qa8ENsUjCsdj9NGiiih7kDAN0TA6-6wzBF90Kr5jlReaEGKgqeINXWxjNLwvDXf4=s620-no" alt="" title="New Music: MURS – Night Shift / Gas Station Gucci Belt"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/30/new-music-murs-night-shift-gas-station-gucci-belt/" rel="bookmark" title="New Music: MURS – Night Shift / Gas Station Gucci Belt">New Music: MURS – Night Shift / Gas Station Gucci Belt</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid-->

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/12/music-video-locksmith-ft-murs-stars/" rel="bookmark" title="Music Video: Locksmith ft. MURS &#8211; Stars"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/AK_QyOfrupptbhqyMeAZPzGnh7D2wmAkq11HVHNleMNO1emKQK8Ad2yKxut_Spfra9auP_rVBdiYQ5ivPHf_pY1a5P5AOvcoUeq-HCxmedz5jSyHjekU38Qd6LHSZo5F9tzBHS2w6eAkcbdsIg-evr3IATzjxebsMrpk-t7fr-Xubo3RHHPEJ89BaTL75zrPe5CJs_FaYsRb47uICYTtHsP78AAluPhdbsNdy8_GFBGQBS0ZEchVPZqGJsHaGz6KNM67WBGQ74r5GmAwzBsofSGTq2krFyvz-tpiRevNnCTauN4XSh8BCEiQ-qDtTithZ4cWBZ2iJvbdXBiqJCkB8OnvFvUU0uewvt8hXEqQkjtm7FstKefcsHJtqV4Ri9gnaqbLa6coACaIX78q72bz52vmku_VDsGnqUGzF6iH3Zh4zzfrpHt_hS9BoahSijRy3CnrYUsk23rCCD8U9LYL3YFo6IYi5H9w8enlWoutBJd5fYx-pL0pIV3tfpEAk98QSJKvg7Um8HHlnJmeQxPyaroJCSejevH7PzPafrF32qwPqeDC7AJFGnKV6h1MJpRmRFkK8YvfDxhhgqIKurJ80Q5Hi1Y-Q7Lq96wjgm8uOePUZnANgZv1stwdGcp8pmHS5Kecc4AjcEVCINk9imtsoPChQbBL87Fs=w793-h391-no" alt="" title="Music Video: Locksmith ft. MURS &#8211; Stars"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/12/music-video-locksmith-ft-murs-stars/" rel="bookmark" title="Music Video: Locksmith ft. MURS &#8211; Stars">Music Video: Locksmith ft. MURS &#8211; Stars</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/01/24/murs-announces-over-the-odyssey-tour/" rel="bookmark" title="MURS Announces “Over The Odyssey” Tour"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/MURS-Announces-Over-The-Odyssey-Tour-218x150.jpg" alt="" title="MURS Announces “Over The Odyssey” Tour"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/01/24/murs-announces-over-the-odyssey-tour/" rel="bookmark" title="MURS Announces “Over The Odyssey” Tour">MURS Announces “Over The Odyssey” Tour</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/11/06/music-video-murs-superhero-pool-party/" rel="bookmark" title="Music Video: MURS – Superhero Pool Party"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/MURS-–-Superhero-Pool-Party-218x150.jpg" alt="" title="Music Video: MURS – Superhero Pool Party"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/11/06/music-video-murs-superhero-pool-party/" rel="bookmark" title="Music Video: MURS – Superhero Pool Party">Music Video: MURS – Superhero Pool Party</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_15_5d514c1f4559d" data-td_block_id="td_uid_15_5d514c1f4559d"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page ajax-page-disabled" id="next-page-td_uid_15_5d514c1f4559d" data-td_block_id="td_uid_15_5d514c1f4559d"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->

	<div class="comments" id="comments">
            </div> <!-- /.content -->
                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <aside class="widget widget_search"><form method="get" class="td-search-form-widget" action="http://weuponithiphop.info/">
    <div role="search">
        <input class="td-widget-search-input" type="text" value="" name="s" id="s" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit" value="Search" />
    </div>
</form></aside><aside class="widget widget_text">			<div class="textwidget"><h4><strong><span style="color: #8224e3;"><span style="color: #000000;">Listen to</span> <span style="color: #c60000;">WeUpOnItRadio</span> <span style="color: #000000;">Live!</span></span></strong></h4>
<p><span class="cc_streaminfo" data-type="song" data-username="cyclone777">Loading &#8230;</span><br />
<script language="javascript" type="text/javascript" src="https://control.internet-radio.com:2199/system/streaminfo.js"></script><br />
<iframe src="https://tunein.com/embed/player/s292400/" style="width:100%; height:100px;" scrolling="no" frameborder="no"></iframe></p>
</div>
		</aside>
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-sidebar ">
<script type="text/javascript">
var td_screen_width = document.body.clientWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 

<aside class="widget widget_text"><div class="block-title"><span>AUDIOTRAFFICKER:</span></div>			<div class="textwidget"><p><iframe src="https://www.facebook.com/plugins/video.php?href=https%3A%2F%2Fwww.facebook.com%2FAudioTrafficker%2Fvideos%2F326277991409372%2F&#038;show_text=0&#038;width=560" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true" allowFullScreen="true"></iframe></p>
</div>
		</aside><aside class="widget widget_text"><div class="block-title"><span>Nas-T ft. Shad &#038; Exodus &#8211; Surf&#8217;s Up</span></div>			<div class="textwidget"><p><iframe src="https://www.youtube.com/embed/aq8hzOgMl8I" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
</div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><div aria-live="polite" id="soliloquy-container-30342" class="soliloquy-container soliloquy-transition-fade  soliloquy-theme-classic" style="max-width:960px;max-height:300px;"><ul id="soliloquy-30342" class="soliloquy-slider soliloquy-slides soliloquy-wrap soliloquy-clear"><li aria-hidden="true" class="soliloquy-item soliloquy-item-1 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109673710?productType=812&#038;appearance=1" class="soliloquy-link" title="Revolt Tee" target="_blank"><img id="soliloquy-image-30349" class="soliloquy-image soliloquy-image-1" src="http://weuponithiphop.info/wp-content/uploads/Revolt-Tee.jpg" alt="Revolt Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-2 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/youngongetthiswork?q=I12154011" class="soliloquy-link" title="You Gon Get This Work" target="_blank"><img id="soliloquy-image-30344" class="soliloquy-image soliloquy-image-2" src="http://weuponithiphop.info/wp-content/uploads/You-Gon-Get-This-Work.jpg" alt="You Gon Get This Work" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-3 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/savage+bloody?q=I1014473415" class="soliloquy-link" title="Savage Bloody" target="_blank"><img id="soliloquy-image-30343" class="soliloquy-image soliloquy-image-3" src="http://weuponithiphop.info/wp-content/uploads/Savage-Bloody.jpg" alt="Savage Bloody" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-4 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/can?q=I1011767996" class="soliloquy-link" title="spray" target="_blank"><img id="soliloquy-image-30345" class="soliloquy-image soliloquy-image-4" src="http://weuponithiphop.info/wp-content/uploads/spray.jpg" alt="spray" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-5 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814012" class="soliloquy-link" title="Good Vibes Only 1" target="_blank"><img id="soliloquy-image-30346" class="soliloquy-image soliloquy-image-5" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-1.jpg" alt="Good Vibes Only 1" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-6 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/blessed?q=I12044252" class="soliloquy-link" title="Blessed Tee" target="_blank"><img id="soliloquy-image-30347" class="soliloquy-image soliloquy-image-6" src="http://weuponithiphop.info/wp-content/uploads/Blessed-Tee.jpg" alt="Blessed Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-7 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/trap?q=I1009984243" class="soliloquy-link" title="Trap Tee" target="_blank"><img id="soliloquy-image-30348" class="soliloquy-image soliloquy-image-7" src="http://weuponithiphop.info/wp-content/uploads/Trap-Tee.jpg" alt="Trap Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-8 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/good+vibes+only+birds?q=I1014476779" class="soliloquy-link" title="Good Vibes Only 2" target="_blank"><img id="soliloquy-image-30350" class="soliloquy-image soliloquy-image-8" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-2.jpg" alt="Good Vibes Only 2" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-9 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/all+seeing+eye?q=I11739019" class="soliloquy-link" title="ILLuminati" target="_blank"><img id="soliloquy-image-30351" class="soliloquy-image soliloquy-image-9" src="http://weuponithiphop.info/wp-content/uploads/ILLuminati.jpg" alt="ILLuminati" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-10 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/diamond_skull_1?q=I12527492" class="soliloquy-link" title="Diamond Skull" target="_blank"><img id="soliloquy-image-30352" class="soliloquy-image soliloquy-image-10" src="http://weuponithiphop.info/wp-content/uploads/Diamond-Skull.jpg" alt="Diamond Skull" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-11 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/donuts+doom-A109792920" class="soliloquy-link" title="donunts" target="_blank"><img id="soliloquy-image-30353" class="soliloquy-image soliloquy-image-11" src="http://weuponithiphop.info/wp-content/uploads/donunts.jpg" alt="donunts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-12 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/crime+pays?q=I12067735" class="soliloquy-link" title="Crime Pays" target="_blank"><img id="soliloquy-image-30434" class="soliloquy-image soliloquy-image-12" src="http://weuponithiphop.info/wp-content/uploads/Crime-Pays.jpg" alt="Crime Pays" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-13 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/fuckyoupayme?q=I11550361" class="soliloquy-link" title="Fuck You Pay Me" target="_blank"><img id="soliloquy-image-30436" class="soliloquy-image soliloquy-image-13" src="http://weuponithiphop.info/wp-content/uploads/Fuck-You-Pay-Me.jpg" alt="Fuck You Pay Me" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-14 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814011" class="soliloquy-link" title="savage gold tee" target="_blank"><img id="soliloquy-image-30354" class="soliloquy-image soliloquy-image-14" src="http://weuponithiphop.info/wp-content/uploads/savage-gold-tee.jpg" alt="savage gold tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-15 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/?page=2" class="soliloquy-link" title="fresh-clean-signature-" target="_blank"><img id="soliloquy-image-30437" class="soliloquy-image soliloquy-image-15" src="http://weuponithiphop.info/wp-content/uploads/fresh-clean-signature-.jpg" alt="fresh-clean-signature-" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-16 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/%24teez?q=I1001415610" class="soliloquy-link" title="gold fronts" target="_blank"><img id="soliloquy-image-30355" class="soliloquy-image soliloquy-image-16" src="http://weuponithiphop.info/wp-content/uploads/gold-fronts.jpg" alt="gold fronts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-17 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/soldier?q=I11611241" class="soliloquy-link" title="Swag Soldier" target="_blank"><img id="soliloquy-image-30435" class="soliloquy-image soliloquy-image-17" src="http://weuponithiphop.info/wp-content/uploads/Swag-Soldier.jpg" alt="Swag Soldier" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-18 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/gamer-A7923028?productType=210&#038;appearance=22" class="soliloquy-link" title="gamer" target="_blank"><img id="soliloquy-image-30438" class="soliloquy-image soliloquy-image-18" src="http://weuponithiphop.info/wp-content/uploads/gamer.jpg" alt="gamer" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-19 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/" class="soliloquy-link" title="freshandlogo Square" target="_blank"><img id="soliloquy-image-30356" class="soliloquy-image soliloquy-image-19" src="http://weuponithiphop.info/wp-content/uploads/freshandlogo-Square.jpg" alt="freshandlogo Square" /></a></li></ul></div><noscript><style type="text/css">#soliloquy-container-30342{opacity:1}</style></noscript>
</div>
		</aside>                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</article> <!-- /.post -->


<!-- Instagram -->



<!-- Footer -->
<div class="td-footer-wrapper td-footer-template-3">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
			    		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span4">
                <div class="td-footer-info"><div class="footer-logo-wrap"><a href="http://weuponithiphop.info/"><img class="td-retina-data" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" alt="" title=""/></a></div><div class="footer-text-wrap"></div><div class="footer-social-wrap td-social-style-2">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div></div>            </div>

            <div class="td-pb-span4">
                <aside class="widget widget_calendar"><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar">
	<caption>August 2019</caption>
	<thead>
	<tr>
		<th scope="col" title="Sunday">S</th>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
	</tr>
	</thead>

	<tfoot>
	<tr>
		<td colspan="3" id="prev"><a href="http://weuponithiphop.info/2019/07/">&laquo; Jul</a></td>
		<td class="pad">&nbsp;</td>
		<td colspan="3" id="next" class="pad">&nbsp;</td>
	</tr>
	</tfoot>

	<tbody>
	<tr>
		<td colspan="4" class="pad">&nbsp;</td><td><a href="http://weuponithiphop.info/2019/08/01/" aria-label="Posts published on August 1, 2019">1</a></td><td><a href="http://weuponithiphop.info/2019/08/02/" aria-label="Posts published on August 2, 2019">2</a></td><td><a href="http://weuponithiphop.info/2019/08/03/" aria-label="Posts published on August 3, 2019">3</a></td>
	</tr>
	<tr>
		<td><a href="http://weuponithiphop.info/2019/08/04/" aria-label="Posts published on August 4, 2019">4</a></td><td><a href="http://weuponithiphop.info/2019/08/05/" aria-label="Posts published on August 5, 2019">5</a></td><td><a href="http://weuponithiphop.info/2019/08/06/" aria-label="Posts published on August 6, 2019">6</a></td><td><a href="http://weuponithiphop.info/2019/08/07/" aria-label="Posts published on August 7, 2019">7</a></td><td><a href="http://weuponithiphop.info/2019/08/08/" aria-label="Posts published on August 8, 2019">8</a></td><td><a href="http://weuponithiphop.info/2019/08/09/" aria-label="Posts published on August 9, 2019">9</a></td><td><a href="http://weuponithiphop.info/2019/08/10/" aria-label="Posts published on August 10, 2019">10</a></td>
	</tr>
	<tr>
		<td><a href="http://weuponithiphop.info/2019/08/11/" aria-label="Posts published on August 11, 2019">11</a></td><td id="today"><a href="http://weuponithiphop.info/2019/08/12/" aria-label="Posts published on August 12, 2019">12</a></td><td>13</td><td>14</td><td>15</td><td>16</td><td>17</td>
	</tr>
	<tr>
		<td>18</td><td>19</td><td>20</td><td>21</td><td>22</td><td>23</td><td>24</td>
	</tr>
	<tr>
		<td>25</td><td>26</td><td>27</td><td>28</td><td>29</td><td>30</td><td>31</td>
	</tr>
	</tbody>
	</table></div></aside>            </div>

            <div class="td-pb-span4">
                <aside class="widget widget_text">			<div class="textwidget"><div aria-live="polite" id="soliloquy-container-30342" class="soliloquy-container soliloquy-transition-fade  soliloquy-theme-classic" style="max-width:960px;max-height:300px;"><ul id="soliloquy-30342" class="soliloquy-slider soliloquy-slides soliloquy-wrap soliloquy-clear"><li aria-hidden="true" class="soliloquy-item soliloquy-item-1 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109673710?productType=812&#038;appearance=1" class="soliloquy-link" title="Revolt Tee" target="_blank"><img id="soliloquy-image-30349" class="soliloquy-image soliloquy-image-1" src="http://weuponithiphop.info/wp-content/uploads/Revolt-Tee.jpg" alt="Revolt Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-2 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/youngongetthiswork?q=I12154011" class="soliloquy-link" title="You Gon Get This Work" target="_blank"><img id="soliloquy-image-30344" class="soliloquy-image soliloquy-image-2" src="http://weuponithiphop.info/wp-content/uploads/You-Gon-Get-This-Work.jpg" alt="You Gon Get This Work" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-3 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/savage+bloody?q=I1014473415" class="soliloquy-link" title="Savage Bloody" target="_blank"><img id="soliloquy-image-30343" class="soliloquy-image soliloquy-image-3" src="http://weuponithiphop.info/wp-content/uploads/Savage-Bloody.jpg" alt="Savage Bloody" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-4 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/can?q=I1011767996" class="soliloquy-link" title="spray" target="_blank"><img id="soliloquy-image-30345" class="soliloquy-image soliloquy-image-4" src="http://weuponithiphop.info/wp-content/uploads/spray.jpg" alt="spray" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-5 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814012" class="soliloquy-link" title="Good Vibes Only 1" target="_blank"><img id="soliloquy-image-30346" class="soliloquy-image soliloquy-image-5" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-1.jpg" alt="Good Vibes Only 1" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-6 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/blessed?q=I12044252" class="soliloquy-link" title="Blessed Tee" target="_blank"><img id="soliloquy-image-30347" class="soliloquy-image soliloquy-image-6" src="http://weuponithiphop.info/wp-content/uploads/Blessed-Tee.jpg" alt="Blessed Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-7 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/trap?q=I1009984243" class="soliloquy-link" title="Trap Tee" target="_blank"><img id="soliloquy-image-30348" class="soliloquy-image soliloquy-image-7" src="http://weuponithiphop.info/wp-content/uploads/Trap-Tee.jpg" alt="Trap Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-8 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/good+vibes+only+birds?q=I1014476779" class="soliloquy-link" title="Good Vibes Only 2" target="_blank"><img id="soliloquy-image-30350" class="soliloquy-image soliloquy-image-8" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-2.jpg" alt="Good Vibes Only 2" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-9 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/all+seeing+eye?q=I11739019" class="soliloquy-link" title="ILLuminati" target="_blank"><img id="soliloquy-image-30351" class="soliloquy-image soliloquy-image-9" src="http://weuponithiphop.info/wp-content/uploads/ILLuminati.jpg" alt="ILLuminati" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-10 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/diamond_skull_1?q=I12527492" class="soliloquy-link" title="Diamond Skull" target="_blank"><img id="soliloquy-image-30352" class="soliloquy-image soliloquy-image-10" src="http://weuponithiphop.info/wp-content/uploads/Diamond-Skull.jpg" alt="Diamond Skull" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-11 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/donuts+doom-A109792920" class="soliloquy-link" title="donunts" target="_blank"><img id="soliloquy-image-30353" class="soliloquy-image soliloquy-image-11" src="http://weuponithiphop.info/wp-content/uploads/donunts.jpg" alt="donunts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-12 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/crime+pays?q=I12067735" class="soliloquy-link" title="Crime Pays" target="_blank"><img id="soliloquy-image-30434" class="soliloquy-image soliloquy-image-12" src="http://weuponithiphop.info/wp-content/uploads/Crime-Pays.jpg" alt="Crime Pays" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-13 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/fuckyoupayme?q=I11550361" class="soliloquy-link" title="Fuck You Pay Me" target="_blank"><img id="soliloquy-image-30436" class="soliloquy-image soliloquy-image-13" src="http://weuponithiphop.info/wp-content/uploads/Fuck-You-Pay-Me.jpg" alt="Fuck You Pay Me" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-14 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814011" class="soliloquy-link" title="savage gold tee" target="_blank"><img id="soliloquy-image-30354" class="soliloquy-image soliloquy-image-14" src="http://weuponithiphop.info/wp-content/uploads/savage-gold-tee.jpg" alt="savage gold tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-15 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/?page=2" class="soliloquy-link" title="fresh-clean-signature-" target="_blank"><img id="soliloquy-image-30437" class="soliloquy-image soliloquy-image-15" src="http://weuponithiphop.info/wp-content/uploads/fresh-clean-signature-.jpg" alt="fresh-clean-signature-" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-16 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/%24teez?q=I1001415610" class="soliloquy-link" title="gold fronts" target="_blank"><img id="soliloquy-image-30355" class="soliloquy-image soliloquy-image-16" src="http://weuponithiphop.info/wp-content/uploads/gold-fronts.jpg" alt="gold fronts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-17 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/soldier?q=I11611241" class="soliloquy-link" title="Swag Soldier" target="_blank"><img id="soliloquy-image-30435" class="soliloquy-image soliloquy-image-17" src="http://weuponithiphop.info/wp-content/uploads/Swag-Soldier.jpg" alt="Swag Soldier" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-18 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/gamer-A7923028?productType=210&#038;appearance=22" class="soliloquy-link" title="gamer" target="_blank"><img id="soliloquy-image-30438" class="soliloquy-image soliloquy-image-18" src="http://weuponithiphop.info/wp-content/uploads/gamer.jpg" alt="gamer" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-19 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/" class="soliloquy-link" title="freshandlogo Square" target="_blank"><img id="soliloquy-image-30356" class="soliloquy-image soliloquy-image-19" src="http://weuponithiphop.info/wp-content/uploads/freshandlogo-Square.jpg" alt="freshandlogo Square" /></a></li></ul></div><noscript><style type="text/css">#soliloquy-container-30342{opacity:1}</style></noscript>
</div>
		</aside>            </div>
        </div>
    </div>
</div>

<!-- Sub Footer -->
    <div class="td-sub-footer-container">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span7 td-sub-footer-menu">
                        <div class="menu-top-menu-container"><ul id="menu-top-menu-2" class="td-subfooter-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-mega-menu menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_20_5d514c1f5c32d_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_20_5d514c1f5c32d" ><script>var block_td_uid_20_5d514c1f5c32d = new tdBlock();
block_td_uid_20_5d514c1f5c32d.id = "td_uid_20_5d514c1f5c32d";
block_td_uid_20_5d514c1f5c32d.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"43","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_20_5d514c1f5c32d_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_20_5d514c1f5c32d.td_column_number = "3";
block_td_uid_20_5d514c1f5c32d.block_type = "td_block_mega_menu";
block_td_uid_20_5d514c1f5c32d.post_count = "5";
block_td_uid_20_5d514c1f5c32d.found_posts = "2291";
block_td_uid_20_5d514c1f5c32d.header_color = "";
block_td_uid_20_5d514c1f5c32d.ajax_pagination_infinite_stop = "";
block_td_uid_20_5d514c1f5c32d.max_num_pages = "459";
tdBlocksArray.push(block_td_uid_20_5d514c1f5c32d);
</script><div id=td_uid_20_5d514c1f5c32d class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/12/new-music-jidenna-sou-sou/" rel="bookmark" title="New Music: Jidenna &#8211; Sou Sou"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/gylJ7Wnk0ZJlN0REMXfqncEzPMBt5FHbP25SovzF9dqW08Dya-AKF3gO6pcIV0sVv9cR5bG4tnjGOXk26CpyQIZzmXjTEuaFQfXZi1mM111grbOXdXen8JoOA6EaqqrFBmlKCR6f7whPked5PdA8VIf5PCAMSJ0-oLRtRhX_dd1OYWofDoZCvR8d_pk-36BJU3780_A_KbvNguFbV-6vc3wtEwwyS5CqRNHz4Z4rKuPLhIfD5O6TSKW_dxa016SdDYC3EIyZmCu58CSD72K26u6utsKSc8IcDwCCGcsLy2BhMq0xliFIvcAq9SipVBe-DmzvbJVNMWam8k2vgOdG8Dfr5ZcN5Ldf5AHceaUrIeAUP48nmW9qlUubr5HQVvgtZJ5cgRufncD8UIJIQBtRCWRbTJ6jkGfxNPdf8ZxGu8EeqEnwQDkZ6JpENz7kCaqCQbDq8ab5Ywt1_CqpwbPFu5fpQ0IacTXBPrRE25RCAZZZ_hp3_ZUJ-AYNVbBZvM9jncDa1crk8C47eoxuA5NN-z45cg0iuO4KY9kEVwer2XCz_M-oVK-zoZVEkTU7LKxMQBMmq_5VhrMw7t_aSg_EO6a8g86UT7PQADNKQmLV69q1pjibLZTSr0kMnFyH9WVQaiBCwiHN7OmDFy_FUZbjzGH1IkfEC7wt=s736-no" alt="" title="New Music: Jidenna &#8211; Sou Sou"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/12/new-music-jidenna-sou-sou/" rel="bookmark" title="New Music: Jidenna &#8211; Sou Sou">New Music: Jidenna &#8211; Sou Sou</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/12/new-music-salaam-remi-ft-busta-rhymes-mayjah-hype-thirsty/" rel="bookmark" title="New Music: Salaam Remi ft. Busta Rhymes &#038; Mayjah Hype &#8211; Thirsty"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/KCcIHELD90CRrE33fwMaOrgTLmvEJ3ftnrDDDbd1HqtwYbJLBMteNGGkmqzBQI2AbMfMWlXArZ4jYkXNOacD_i3S8cchc8SYAru64VjMHDW_vWto1CaKLxFe8Z3vPGKNdnm-RrM_xJ2Ku75dJL1_gDSl40njuv4jEA7OUqd3CRTMqXGXsfmlQsjYfQmc68qGQ3CwhLDyUlgFkIvU45urXFj2g1ccUKCroqUd8y4Pyxp96fLQiNuhYbMrls2nZVBcU26wNA-gIrv4thhZfct6793qaZoDlW9mm2iC9tb45Qg8G3CkgknxdL5dw9IoKk8i5O8DhTv2wZuF1OZoR5KWAPR5z3Q9XEM_GltAkFkKNdcAiRY5Z4TUzhW8VBW1G5Eq0dedNPU1GNdmHvJP5RldYDDU6fMizb5_Y0Z8_ruhWpNGzNjfXHSn2GBVtCaZse4Vewt0T-_5ByEshjbXkOaFNdfJotQG8BNjab3VUNR-127nwGvnipusAIaORkz9qYAgADD0dmSrxoNEOXSNQIyTze-kgVoQ-gxkY0hFrusE5oZ8jsgmDVqZylF8-Sc9agdR8MIPDS18UA3afN98DBv53I72Ia5H23JSYVk8NCVXauGBbvzqBWEmskUIVqGu9bW2iW8_baZCfs6lUwiRLko7QEKmjpK-vInQ=s630-no" alt="" title="New Music: Salaam Remi ft. Busta Rhymes &#038; Mayjah Hype &#8211; Thirsty"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/12/new-music-salaam-remi-ft-busta-rhymes-mayjah-hype-thirsty/" rel="bookmark" title="New Music: Salaam Remi ft. Busta Rhymes &#038; Mayjah Hype &#8211; Thirsty">New Music: Salaam Remi ft. Busta Rhymes &#038; Mayjah Hype &#8211;&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/11/new-music-kevin-gates-double-dutch-in-amsterdam-witt-it/" rel="bookmark" title="New Music Kevin Gates &#8211; Double Dutch [In Amsterdam Witt It]"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/uJva4Ll7i0Xy7yPK8wBXs8RoH7_TOaBMLM1olINLFNDbEjVVPhGUjqU8tecvDhp2QJDewW3S3UEfPUX_R-aJckdYm5vKMEK7-8TdXdg3ukNOu9lre-l-QwGmuMwMim3p3gYKWsUiWlzZTn3DkPYvcGLsv29SjDU4bsjdflLN0er0nU0cI2oSPVvgQzg-qTganZsI0g1smSmij9lQdF8tugkdp58H5Doqcj2JHeBieggatWSK_NVqUZHStGGkijSd58noRiC6T7t_ENMX0qrDOCrMgUbD6rEW1sStzLeM5W_JH44mgS9N-xMEtMmXLPnBTAY24VXQx3AhngfZxQ-bEyok_HZMGeM4vmf1Fp5oboEMmeyeGlsaVyha8wV9Zl58Nntxy5y3vIiazuv1bkIHIx4WDjy5Nwtd_lHg9Szg9yRjZQn8MkI2oEyRlhLw59I7KrGA2glu4lAxsLHIofYIkEG_QbIepw3SvuWoOKgFND7jOUVd-8xzU3IikIQnVxhKT7-Oq7GV570hzm1kotMy0qSr7bj1NKN-Tp8SLw7YOtF4D81hdWwUUXOvUICMWyhKci5_SCTvbkO1D2xkQIQlRo3-PzS7tgiwX-QxtrrrcRZqX_g90AwqvsJNCxCHL5oplzTmcz1Swlio5R55sczMvQrCz4si4MlH=s736-no" alt="" title="New Music Kevin Gates &#8211; Double Dutch [In Amsterdam Witt It]"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/11/new-music-kevin-gates-double-dutch-in-amsterdam-witt-it/" rel="bookmark" title="New Music Kevin Gates &#8211; Double Dutch [In Amsterdam Witt It]">New Music Kevin Gates &#8211; Double Dutch [In Amsterdam Witt It]</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/11/new-music-slim-400-ft-young-dolph-shake-back/" rel="bookmark" title="New Music: Slim 400 ft. Young Dolph &#8211; Shake Back"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/7lfEx0wIK1kmcmoHv455Ahjx9KRxzQiYhZCDTBkKPherJBYPnSDz481t6btjMaTSTjgx4SiD5EYweY9U32i6oRsXxxeC121JeCmxFbrIYmb0lKfsaktmsvzKML2yehBgEiUuC1fFbdT6tUMfR1oK0zssfF_-Xax3uOjX0dq9Z2INd8XuEyOoORCUKugI-yb1fgjt0NGlfDcsqN-7og8bjMmUnZiNB1ArH0K6ulkW2Ygen_g5PzataPdnTIjc9pMQCeLZoYKt2YSXUTzdJebm1fuZYbDTSfAO1DyVMbJ6ZbXrJ07GJr2PqBaOWlIDKJG06PM_mi9eQ71PPn84YHbXO95NowOCb2H1Of__1ZqptC9Axb2MR_nFBG1nsMmYZQiUc_wRDb5Rrmj9OkQ3MbPMINyPVapboWhoJhHmWdPuo4xW92X1vcBs0E0cXxDezVxJbc5E0oQo9hHbp-wApCl4EwTusL6n4TI0t_psNSRgIcx6YIkhxKW24EFlwZC-fNDm0DmD4TBYdg4-h3TjI6MQSwHqPvcjqUV_O0xeaqhOsLzsBx1g1zj0z3QD78vWPRHkrcCaM0UbaTryqbCzqGzUkU_DSjQ3Pgp3idtdvpjpKB2_mjYqw3Emkj7qqj-tjOOp8bWBpJUY6yDNRiYpRcAnzQSBLwXJxNlW=s736-no" alt="" title="New Music: Slim 400 ft. Young Dolph &#8211; Shake Back"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/11/new-music-slim-400-ft-young-dolph-shake-back/" rel="bookmark" title="New Music: Slim 400 ft. Young Dolph &#8211; Shake Back">New Music: Slim 400 ft. Young Dolph &#8211; Shake Back</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/11/new-music-gnar-cabbage/" rel="bookmark" title="New Music: GNAR &#8211; Cabbage"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/LqmAAJ-UF2uFRO2D_ijZLI0qA6LeRkDjZhnXfS_ntRSZvIMiACyLOLRfW50GjvF70g8cx56IW7skhpSBqr_gEEyJkLGInWHmzn3o7oQjq4D7Db2tiALye9huRjKAwg_LBaNtpq96_GWM8Ydmf3QRqekguEfzyAhgcczytK5B2XTrgMWdm1kAf1eowgP81MR6_-mDDlHfVOz0j15jNGXkjhlhOUZ4ZgGCv3yuge-GiXvSIgLm711dw5-L4KWGGdC5cfAJkDQigq09aSAa75P4v7F8eqkWWMKQ9L78a0r2ZH8Q1mSbWW_sdHdGaXR6pqwjnW9Fd1SZyqrLjQZtLRcGfwhu1aP0434AVafzxWMHILsOQkzKkwH1kz3kzVWqm2VlQHTwn4JGWYTCGKnIp-60cP6sMXVUZv3eFxq4xru6XeNY8n1gwFivKeAaoWS1BPayB27eluhOUMpBEgtSpFaF1TGr2KiX1bgr3xgk6BVBYKD3XaMYuh8cIj1QFVXFVkCVLFSgIxAvc9cc-k7EbOZNJhLZCkSS_4uuGkYTCeaOEwK9WrH4BtKPawKeRdosd-I11eh41KcXlCWjmn8elZX9RFGGyKr9w9bpj5--8ns2nWaQCSVj7uagFjwJUVDXmtiOJWnJLQiqq-NE9BH6faVf5Okq4ROZ4heq=s736-no" alt="" title="New Music: GNAR &#8211; Cabbage"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/11/new-music-gnar-cabbage/" rel="bookmark" title="New Music: GNAR &#8211; Cabbage">New Music: GNAR &#8211; Cabbage</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_20_5d514c1f5c32d" data-td_block_id="td_uid_20_5d514c1f5c32d"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_20_5d514c1f5c32d" data-td_block_id="td_uid_20_5d514c1f5c32d"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_21_5d514c1f5f8d2_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_21_5d514c1f5f8d2" ><script>var block_td_uid_21_5d514c1f5f8d2 = new tdBlock();
block_td_uid_21_5d514c1f5f8d2.id = "td_uid_21_5d514c1f5f8d2";
block_td_uid_21_5d514c1f5f8d2.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"97","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_21_5d514c1f5f8d2_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_21_5d514c1f5f8d2.td_column_number = "3";
block_td_uid_21_5d514c1f5f8d2.block_type = "td_block_mega_menu";
block_td_uid_21_5d514c1f5f8d2.post_count = "5";
block_td_uid_21_5d514c1f5f8d2.found_posts = "850";
block_td_uid_21_5d514c1f5f8d2.header_color = "";
block_td_uid_21_5d514c1f5f8d2.ajax_pagination_infinite_stop = "";
block_td_uid_21_5d514c1f5f8d2.max_num_pages = "170";
tdBlocksArray.push(block_td_uid_21_5d514c1f5f8d2);
</script><div id=td_uid_21_5d514c1f5f8d2 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/12/album-stream-murs-the-iliad-is-dead-and-the-odyssey-is-over-4/" rel="bookmark" title="Album Stream: Murs &#8211; The Iliad is Dead and the Odyssey is Over"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/pjY7HnG9-IEI4lqhjxutqk9ZTbQWp8dNgf9-zEPRbsoAorWHAk9nIK6yJ1yy1kzWNYlArHyrVpbGO2fSL7opXWemd_zia03SasLg15VSYOQNg_z7ZPy2jTd-BWNC3Ij0v9UARatMWb_GvSZd-L1w88-dpxZoBRIWFG1J8wxbYiJjFxDsjdsitPdlA3soOLuQ3Ot10nKF6rBEO6r31WLbuBtDXobxMQy3wP26FlyD2motMbIIgXk2hYrUq7MiyaJSYpNcBh-yCQDeAzShchsHMBWtHxfkKJb5-1NKpYzyodT9Eit6rYXICkfL9XIfOOm4XSTH6pXXg2IBUT8felfZwZ3oj3Fho58jGNMCm4SPEzSYLRDxFSonTkNhYq1NDHVP1iyM-UA4pVmB-u5YgNMNSp21gPmFSJ8tKuu9ZwmIplsSBWHiBOnuyvdNm2YqSs6839u6iyQ6zJtPTbU4haNpkgFQoswxFZmJqcbBwM0uBZJOwh9jtyWMQ7p43HFtbL8Tton72cvJO7g2F-BnDAQOiEpccsRfwNrip5x8aeLhxG4yY_C9_9oMxGg6zWHJomoGa_xkUvtvOo-bfE_2sX2MUKAp-JU9kJKc3wEB1RpopisFTOKFEBGIwAhbKTCC8AzRp4MELThL8Sf0QaEmpZs911pg5MmZLFwe=s736-no" alt="" title="Album Stream: Murs &#8211; The Iliad is Dead and the Odyssey is Over"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/12/album-stream-murs-the-iliad-is-dead-and-the-odyssey-is-over-4/" rel="bookmark" title="Album Stream: Murs &#8211; The Iliad is Dead and the Odyssey is Over">Album Stream: Murs &#8211; The Iliad is Dead and the Odyssey&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/10/album-stream-fokis-oh-no-this-thing-called-life/" rel="bookmark" title="Album Stream: Fokis &#038; Oh No &#8211; This Thing Called Life"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/Oohu8DntgPvoX1VnohDL2grgzxdaaPTHcChQANX7B_rl9J7jSOlSr1riuemBoarD6AmbQ-Vw4-geI9xsPtu2yGZGdgbxca_R9jrVnFZVC5InUVpE70z1NPBJxOttb4g3OWN1kMEOWZfK4eIMIAnVcRlYhycE8cJAhoOsUMzr-k9u9aFzeC5ya8a-d2DcRzpzF6TdmhvCxvz8JgjNs25-8DXyOIvJqILX_oFoLc7HsBfFtITMpDKKKejICQb8wBkphvArV59OD6ragMMqo7dGVUuuf6GPt7Iy9imTiCna8mhhvI4SdrIIAZIpK3SYj_qhHLU2lZ2Td6anqroktR3U224tfPLPh1pZfTzpvufc9wfs5MZz9NtFFAjAjaoH_nGIbXVjZz3E2Np1C7aHlBMh8DcHSjKVKXFAPDs2xSEIduO3csCpJFR6fXytIbddoh9ArR-DLl9jFPq4xXO9TzBdFlUcXCUFDe5_ZDMNboI05jNEguEUUfnf407fHeUGvyqM9ZLSFp54DzXPbEisn33ExMZTlgQcDcvG8Z7HT-wRO_OY4PNkvJ4z4yPiQK5I3_B3x4iOpvjz4iyRuJNijb__GOsfIXSYoAAQGBtJs0UW71b0omFfpemj3vutVl2e1mTTpQReaGVf_0n2u9eH46Jhwlypppf_4ifL=s736-no" alt="" title="Album Stream: Fokis &#038; Oh No &#8211; This Thing Called Life"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/10/album-stream-fokis-oh-no-this-thing-called-life/" rel="bookmark" title="Album Stream: Fokis &#038; Oh No &#8211; This Thing Called Life">Album Stream: Fokis &#038; Oh No &#8211; This Thing Called Life</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/10/ep-stream-lil-tjay-f-n/" rel="bookmark" title="EP Stream: Lil Tjay &#8211; F.N"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/IbiNDldvQpUqrCdBY84e8j_DkPH3miedYL5b3-rMFVe8P4PzOyP6C5AuRBCr8Op-OhrKo70zAz7ZoXz8l9s_vN_bQqvkHEniGeydCpRr_8knToxUVtDbDkhm3bbaUxsrKPISaJmU5qYUWvb-7Y07OzcB9cegGlFA8OpLjVdlPkp9GCTJAn5PQJbSg6hQ7zFX5Sk6svzngvtq7QyB0l9dLYy8kNjAHS6-BWIleUD_5z7zno3np05zRRiG_tLIgIUgM1IkKyZVF97XIcLHU9hrew4_PXXaPHe_gYs48n9P2hH6tjaPQw6Iwwbhg61l2E1ghMcaxLNO1o_ono9Kg6u0owv0uOn4f8PuilDdEGxWdY3cOdDADQmmJA2-_LY6aA7dYKV0AW8r_-O2BPvzKHDfan0EB3hx7v_yYshdpPSQloMTS4K6Pw0jGSm6NGINiH1Oq8ez5a9qVKuQFyxzfbQID25gNpiCiUEM5EORKwgxa33AA_9FFMym6S-poFbe7xdl5xapaCs_Q3cWdEVrFa1-aO4imovfXxzcHPe57YQQelz-Wz1XA3fEuqGCpTlQK4vc0zhOxyu8GeVgNvbFLBgqPE3AcR7Vr-PjTDE-xTBdGsYEm1J1o3B0ebs0qLUuevEuu_kxhO8Dzu2b1K3ZDmb7zot44jN97cMD=s736-no" alt="" title="EP Stream: Lil Tjay &#8211; F.N"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/10/ep-stream-lil-tjay-f-n/" rel="bookmark" title="EP Stream: Lil Tjay &#8211; F.N">EP Stream: Lil Tjay &#8211; F.N</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/10/album-stream-smoke-dza-zour/" rel="bookmark" title="Album Stream: Smoke DZA &#8211; Zour"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/CMb0yyZ4f-CUTWHDWghIBocT19qRCpLLTLkm2wKzPb_uPKYdEwFtZ6ODnZpzMQZQ2fbR0cXCHYNp3Ev7HhPMTWmp16p1M-ZwwmP9-eGlZS1jgGIms48ysfuPOpRqKyDVI4sE17vnSBIU6WiM6AiqnguHpRCsF9Bt7zz5oQs3ZE9GeGCNkPhtMGJNdQzCWWRab9pVj3dIFLr_dUHd1Jkn8m5aVMzT5o8vXMMyw5jjzelfwPMzbHmOeWW0GptjG-tzHGo43zRaQ80jJa0HTKcKdu0FdUhiPO4cZs8ZGetA5of2RvZ1mnG2TaaCyBYMe2IITRbUy2qyMTBIyryX-8wSWSYGaM0FZk9QJ6ceTBhKVUpsrOn8QWKMvVWXnKKJpJi024v7t03EYVq_WBUZQ_zRLCRwJfjKG8cIK61ebl8kwBHwJqlFq337B_60G0aWLR-lnB6038BRspBTm2ETN--LBmrVacAEbGmj1Wn2MTHAMR7vd1yxZ9UGjIU6v64yiV5GySEW1Kg0TWKUUrxEddjOOi2iAaeHynKD3SLj1qkmTUYImvOtz9gTsRZyZ57qkQfgUyhcjcj94wS-ZG5RElm5Y-zZ1iFMeJrq0an3h6qc0aIgcqBochCHymO91BgjuOT_xDb5VVM0nkYeHygnE9eYBYevsIxHawGp=s499-no" alt="" title="Album Stream: Smoke DZA &#8211; Zour"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/10/album-stream-smoke-dza-zour/" rel="bookmark" title="Album Stream: Smoke DZA &#8211; Zour">Album Stream: Smoke DZA &#8211; Zour</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/10/album-stream-bas-spilled-milk-1/" rel="bookmark" title="Album Stream: Bas &#8211; Spilled Milk 1"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/NEWkOeYGJYfDNs8lH0tg5uZAGFaMReKsfs33WoNIt3M6tRRMBhReDCOwf7o0xzNmevNCt16K3bO6qf8-SsoWzbMVgQMRskiW5UpSL5WVxn5MwRjUlQ8mqVEliicomkgE5-XxW_-PRstRZRxPKELrvsB07JrS6oeASpbnDuvKKAR9rSJfPpTvG9rOGZ2ft3PBUR5VW_OCxBaNHT9egiH1cUzHaLGdB-uJcQL-P9xQaJEj6S3u14lEPKVbFDog8OiZZAhv6t6Us9OAckDU8gEosAqsrEAgwZpe8qzVap1bl4TT0Q0s9RoGA2xmHUfznOifA3U5aoxuoPud6T62y-6oF8vl4HxRA8fzFjgKS2EziGYOJxBrIZWN1MNuSUZIc0mfRSjv0xLMsbkTPlY4pSDfBgoOfZLRZo2lPTr76VKAixWvQNyClxCDyh-0yKoWuyXaRFAkcXS6r6V3ACtz0EvZf-c61XZwccWhV92fXpBr3evSIewjxaRHyCM52-_Yes2aU-3ZYLfhf41bSIKSHmpOImySW-w6GYB9m7xYnxtgHdXmzi7dJKbNlIY9yf01TnLDU31sCt8l7XXdz3GdRJ7WJw-taFh0wm2lndz6xqhngg8EUoZ2pu6ZFcDTTw304q3lCjxZhowgoHGesUIFcnNXeuL1OWdLXJY1=s736-no" alt="" title="Album Stream: Bas &#8211; Spilled Milk 1"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/10/album-stream-bas-spilled-milk-1/" rel="bookmark" title="Album Stream: Bas &#8211; Spilled Milk 1">Album Stream: Bas &#8211; Spilled Milk 1</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_21_5d514c1f5f8d2" data-td_block_id="td_uid_21_5d514c1f5f8d2"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_21_5d514c1f5f8d2" data-td_block_id="td_uid_21_5d514c1f5f8d2"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_22_5d514c1f62bcc_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_22_5d514c1f62bcc" ><script>var block_td_uid_22_5d514c1f62bcc = new tdBlock();
block_td_uid_22_5d514c1f62bcc.id = "td_uid_22_5d514c1f62bcc";
block_td_uid_22_5d514c1f62bcc.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_22_5d514c1f62bcc_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_22_5d514c1f62bcc.td_column_number = "3";
block_td_uid_22_5d514c1f62bcc.block_type = "td_block_mega_menu";
block_td_uid_22_5d514c1f62bcc.post_count = "5";
block_td_uid_22_5d514c1f62bcc.found_posts = "2280";
block_td_uid_22_5d514c1f62bcc.header_color = "";
block_td_uid_22_5d514c1f62bcc.ajax_pagination_infinite_stop = "";
block_td_uid_22_5d514c1f62bcc.max_num_pages = "456";
tdBlocksArray.push(block_td_uid_22_5d514c1f62bcc);
</script><div id=td_uid_22_5d514c1f62bcc class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/11/music-video-o-t-genasis-ft-g-eazy-rich-the-kid-e-40-bae-remix/" rel="bookmark" title="Music Video: O.T. Genasis Ft. G-Eazy, Rich The Kid &#038; E-40 &#8211; Bae (Remix)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/iat6FDtMGVBT75L3hmJmhrK7seHvbLSXOsl9HqhkP-a_wg7cq4EK6TK8xle7x4osuziVm2eq2BqrIuBAxrJm9lYwVuKJIiiLmdjv8aw6lFkrqcTarBJLaM-lH0x5RC493FsiR94hfttygY48fhhK_zw4Nv76KczA_PXkVGc-smDg5tk4gy1tNUrFESispuKKxZqVa_qvqwq6-4T3KAyHljatCxO6vwYYdfzwUV_MkJTLPHJJDpt52t-MuoCrI09iznMUXnnYtD8O3_vW-ViXtfe0Cv0Z9BftZeu5vdlWjwR2SOfK-K6D9OcIMV2xS2bqTNYNt_KCcTSbnfrrmt__HxZuIJZy5llRV4IpKl-ZJslBuoErulMKZyGKQVkIBWe-QLv6cpnA0ICFyOAEAxx-8fmP2_YugsoStQYrRetQI7NQr_yWWXsdsSLBbuAD5ey1G1H2jIZntzntRMrotQhzTTH-TYLx6KaHIeYx6xEHnSrbVNFz96yRyMwwE9okChyKjCc-ythK4dp2o43MtlWstfGxnIQcEl60ScsE4PvERRtnAjQGh58AvwpWWgK4Y_Avo0PwWd5gqZvd7fC56MArXme5NdV3nmm1_LBv4A9HXexCnyU1lIRBmclZyZKWFn9a7cfnyhiYpCh-Mw69chHKC829NRHVkHUc=w1025-h538-no" alt="" title="Music Video: O.T. Genasis Ft. G-Eazy, Rich The Kid &#038; E-40 &#8211; Bae (Remix)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/11/music-video-o-t-genasis-ft-g-eazy-rich-the-kid-e-40-bae-remix/" rel="bookmark" title="Music Video: O.T. Genasis Ft. G-Eazy, Rich The Kid &#038; E-40 &#8211; Bae (Remix)">Music Video: O.T. Genasis Ft. G-Eazy, Rich The Kid &#038; E-40&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/11/music-video-dram-ft-h-e-r-watt-the-lay-down/" rel="bookmark" title="Music Video: DRAM Ft. H.E.R. &#038; watt &#8211; The Lay Down"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/9y0oM48hsUtfUkZFWM2PPd24yRMsxPiwZtCGurG9AJeOSLP0EAgL4Cu6N71rnv3HyXeqrqBQsJvNgyVeRjP3Uv4IgrIcMROWvlNqmLGoiejMxTx-X7aWXQpGYMA6bHHv1KLsN0fzN2kjlJH0EbNsai2P5JGnaaIQ3lNTlH08dz9ukgVNVxBrVq7A3J600zHy_zTGFwu-UmzdlW3adaWpzYjP71tW5qnk-u6Lrry6F7Jp7KNfidnWLlCPrjgKOcL1vjetLhMSm8xmOGd35vLrH4Q0VbKMeQmqGYsGZydAlXsxlUemIjdz6_q--BTkNJdbmdoCJr8mrISmd9lugau_iStxlQui6spJ34EWkS_KyrdVcjAV14Zwt7sjKU2zmWdIth4Q38uAPfa8u4VUGiR_u71J2DV6951qvvGaxdViBp_EYCGsylWb6pVLg2AUXzR1VQD7jOpeqonz72ngPww70CKX3iaRMQL8_wqaDyjJO-uundvresrvrUHT1oKHaiDRS5aOkQm5W7wGea0tNYsuDfGIehIT1ELlD5BznPMB5j1r8EnCG_InrBY0NguqDRzvoNevcCO7qFcB2ZVX8m235RK_aOGOgAVxlBf7BIgNoh9-zD0B5wQZ6pxNX2wH4OKjf58ZbZu4XUWJZSVwH2ZG-A1I0oBr4fzt=w1087-h530-no" alt="" title="Music Video: DRAM Ft. H.E.R. &#038; watt &#8211; The Lay Down"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/11/music-video-dram-ft-h-e-r-watt-the-lay-down/" rel="bookmark" title="Music Video: DRAM Ft. H.E.R. &#038; watt &#8211; The Lay Down">Music Video: DRAM Ft. H.E.R. &#038; watt &#8211; The Lay Down</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/11/music-video-nef-the-pharaoh-ft-shootergang-kony-beat-that-vest-up/" rel="bookmark" title="Music Video: Nef The Pharaoh ft. ShooterGang Kony &#8211; Beat That Vest Up"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/udIEYLBVRW1YLPKSVdgBykWHi_jgSXcD2-DsdWbvTLUKrvM0nnhCo01DyxTtYv246EvJVehDKOBqDQ24hseO8F9TuT4Lk7CcJ9e_qN85XEiKdat0zz4_rFTzVGmMEYR_E2g9Dg1cbBPhkGfYChhIPnVA3YJg1MNhZrbOMYmWtShVOR-klz_R6o0uhhAzQVB1Y5vZEf-amStnREu-LbWkuObp4Ek22T-qRwRjekhm-1V2J5rNrGemdxGx-d6dxz2cdNzYpBgf1GgG2r4wBqMxJdm3EMGxt-JOpYOp7hNBPp4aLWjcCKzSEAvBZTyZgkHm670myDPkf-dGv8g8qqVO_iq8_1uH0mL1daHGzQpBA7MMX9QdZbK9NG-nJ28e_YriYBhURyhupNcZIIMSpUH3QKyoUjCPYaZueg7IF6bchPOcgI4MFW8SQ94vlp7W4QjJN0jtGzapFnBmtvMVf8c2CcKeIpGgt-c4yKEbrz0dKgZA3DgNikaPmWMcVi_TyutIqJbQidjXRfEGc8yS5b57isNolgo2G5G5ILzFUZ_NqnPmB0IUm83KOvHhEEqF25qVeraUMG2yNdLvl3bhwm6Q_uV0meA4FLzt0RINJGPeAWZg95DTsWLs-2DYU_xXwlw_JelJ5MccFV86BQwUbKBBLYbLZjo8DmYx=w412-h232-no" alt="" title="Music Video: Nef The Pharaoh ft. ShooterGang Kony &#8211; Beat That Vest Up"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/11/music-video-nef-the-pharaoh-ft-shootergang-kony-beat-that-vest-up/" rel="bookmark" title="Music Video: Nef The Pharaoh ft. ShooterGang Kony &#8211; Beat That Vest Up">Music Video: Nef The Pharaoh ft. ShooterGang Kony &#8211; Beat That&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/11/music-video-swell-tgr-ft-flipp-dinero-better-days/" rel="bookmark" title="Music Video: Swell (TGR) ft. Flipp Dinero &#8211; Better Days"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/wZEsNl60T5tKSD3kkNYBh_prjo1JQjOc4Zi7RQf9YdV_N378twh0ZDUZXyIH4whsK5C-G2inxiJ9F9P-6vw_TlKZVp-qfviVZTDVv28N-xvx-CZc2wKvw76Fv8-JgrduEJ-UUpOLhcQoM6E7iIPj4pp35oKZa90bqDfOl8V6uV_w7T9aM_FeD7Xrbnwkx8Ox_lb92mnham_j95HpHr2EUllRhZKNvRUerlFDUwQxPuCVcZJXZnzY9Q5hfuDnrNwrObrWkj-P0unqY5nTfPdGFrOQ5Qbec6n6iM4XU5PmANwnmMySHNZs95vra4NesBEucKHhvEMEnTfGwXvNTmNlbTEgrbwCpGoKHI7FubGSJTAoLNMY41rdIC_5yucQTWVJMPIJGH-DZkid7-LqgvsTuhtZ3YNuTEUN-qKclbkwCV9HZEC9m30GyBaAQdADkXJbab1EEAxrnfK0kLg6b2I--fETOOyamywdItKlDgc5Z5se4y4-sgR4nfHjssI30wBc11R8r6rGZPDDqm7nhSYufJ9h0X5LpfNJ8JeD9EkhSx0wXfZSYM1LLbn7hOkgFyCA4EIwiyQgrMgF_fmdwC8zl9_5zdqaWr-ncS_OxSdANCrLQM-N7S1jp_d_y-hsTby91bT0oEEM3RzIFB_oraa3ZSmbsAeN8_Py=w1015-h621-no" alt="" title="Music Video: Swell (TGR) ft. Flipp Dinero &#8211; Better Days"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/11/music-video-swell-tgr-ft-flipp-dinero-better-days/" rel="bookmark" title="Music Video: Swell (TGR) ft. Flipp Dinero &#8211; Better Days">Music Video: Swell (TGR) ft. Flipp Dinero &#8211; Better Days</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/10/music-video-lil-reese-no-face-no-case/" rel="bookmark" title="Music Video: Lil Reese &#8211; No Face No Case"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/iGolKvLIXndOpnpf8v8dsWBx8TddN7jAxvFIIXG68pO88x-vywnEidrh4zaEuRqxWfQ62pbu_zNWN8GcA8JR_RLzTCrOJqLFIfgyinKgaCdHjAAXWmCltSXQz3OBE4f_HhUt2SH3-U3zLbNIJy9Arh_qSNEg2R1D-2vbTzOGnBx1nBixfusYvZ5C41Ot1D05jdpYMn8BxVHIKjofeFQAZXAQ7xrQiPyvDMvcUQjQnU_2QcfgFrbRg1JLeb7B4hCwx4OYlKtc9ljn2lM8V11bFPkSopCEevPk8xiTy3KiJo1sWfQF5hUe4kRG7cUY7pzAUZ0gvdHjrqjb9EVBbHTOhIsduWaYL-o1PqBXIefAkDp7SAXT_6InS0rlocAFMHNjRb_VgE8WxhVytru7J_tFSXqFu_8GmevDLbiV1ZW2Npz6IrM0Xc-XzVLKeVeVegbW_tjxdUyP3NLpHwCFEDUesaC92lAZ7WRYtYSHJoRGyZq0DCLwDuAIio1ijsJNcVGxI3R7adtXkLV0__DcI-cmVJ91xOZa5uQ7JGuRqwEWx0XDGA55AtyRHqzosgqmhqgk1z8yNkpBa-izxztNBOXunCsxioURsQC7ZqR6AbBigWYfb_SOggmk2nxh_SKzoNbUFwXWr47fOugRUh8mfUOZwUPYx3eiIjJZ=w830-h611-no" alt="" title="Music Video: Lil Reese &#8211; No Face No Case"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/10/music-video-lil-reese-no-face-no-case/" rel="bookmark" title="Music Video: Lil Reese &#8211; No Face No Case">Music Video: Lil Reese &#8211; No Face No Case</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_22_5d514c1f62bcc" data-td_block_id="td_uid_22_5d514c1f62bcc"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_22_5d514c1f62bcc" data-td_block_id="td_uid_22_5d514c1f62bcc"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_23_5d514c1f660bd_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_23_5d514c1f660bd" ><script>var block_td_uid_23_5d514c1f660bd = new tdBlock();
block_td_uid_23_5d514c1f660bd.id = "td_uid_23_5d514c1f660bd";
block_td_uid_23_5d514c1f660bd.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"29","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_23_5d514c1f660bd_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_23_5d514c1f660bd.td_column_number = "3";
block_td_uid_23_5d514c1f660bd.block_type = "td_block_mega_menu";
block_td_uid_23_5d514c1f660bd.post_count = "4";
block_td_uid_23_5d514c1f660bd.found_posts = "836";
block_td_uid_23_5d514c1f660bd.header_color = "";
block_td_uid_23_5d514c1f660bd.ajax_pagination_infinite_stop = "";
block_td_uid_23_5d514c1f660bd.max_num_pages = "209";
tdBlocksArray.push(block_td_uid_23_5d514c1f660bd);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_23_5d514c1f660bd" id="td_uid_24_5d514c1f66bfb" data-td_block_id="td_uid_23_5d514c1f660bd" data-td_filter_value="" href="http://weuponithiphop.info/category/latest-news/">All</a><a class="mega-menu-sub-cat-td_uid_23_5d514c1f660bd"  id="td_uid_25_5d514c1f66ce4" data-td_block_id="td_uid_23_5d514c1f660bd" data-td_filter_value="69" href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a><a class="mega-menu-sub-cat-td_uid_23_5d514c1f660bd"  id="td_uid_26_5d514c1f66e00" data-td_block_id="td_uid_23_5d514c1f660bd" data-td_filter_value="80" href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a><a class="mega-menu-sub-cat-td_uid_23_5d514c1f660bd"  id="td_uid_27_5d514c1f66f1a" data-td_block_id="td_uid_23_5d514c1f660bd" data-td_filter_value="2189" href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a><a class="mega-menu-sub-cat-td_uid_23_5d514c1f660bd"  id="td_uid_28_5d514c1f6702e" data-td_block_id="td_uid_23_5d514c1f660bd" data-td_filter_value="10" href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a><a class="mega-menu-sub-cat-td_uid_23_5d514c1f660bd"  id="td_uid_29_5d514c1f6713e" data-td_block_id="td_uid_23_5d514c1f660bd" data-td_filter_value="130" href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></div></div><div id=td_uid_23_5d514c1f660bd class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/11/video-t-pain-the-breakfast-club-interview/" rel="bookmark" title="Video: T-Pain &#8211; The Breakfast Club Interview"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/iPC2hdOmlI9yHryW1TaDq_4lFUYF0uPtQ4bwaPiADTMkSyVnrB8aUG20SYQ0lafpEUFmEUtNH14E4Kd84H4nMVqmVZ1fSkSnRZpOu_Bd1R1v6zF98tldTJpFVCC_Cdgkaj_QenRzoG8B4s6O4mM-W5Z5grmyc68tMf6gzviML15hIfH7c0xpYfZ-Tp55algxc7JjOTHHXSyV9p_nqCuU4KtMWEKw4KUwhRHVQLZh5YbUAiGlye1Uej71gruIvDyXp6sKSMwGfNwwTFkXREYKYbR4DvHGakOdfAImwu1ANXPretTy0zq9-Lj8X2JKLbuBvevMFK3NzOYOnjvrWXGL94tJd3FJtAgNEFNzaMVKNI5Kva3X4TfiVCE3jSkm2gAKs1GrIfLTKQ0hrH8Wu8SjSl9p2uKvdSneymOnDijyN6Q6wnzCcbksoScfx02OFWc2Acv5YCkfLBtsTjsmYVKlT6zhv8vC4z2ba1H36J9NZTzTcbRTmhCqa-K0qeO70UdwtMjhxZqt00MPwDFZqEAWHG5pxXdbkMv7cTcPM9q_tf1Qoy2jBItBUVR4pbheOC6Pi92tULXz9CMF6F8x40sjHl9gNNsV6OT_FRj7bAfL5r6alLBbkmsvzW6QaRkjEIqneFd1vbaDiHPMugu2XrCKeS15dcoEU7Ku=w1156-h538-no" alt="" title="Video: T-Pain &#8211; The Breakfast Club Interview"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/11/video-t-pain-the-breakfast-club-interview/" rel="bookmark" title="Video: T-Pain &#8211; The Breakfast Club Interview">Video: T-Pain &#8211; The Breakfast Club Interview</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/10/video-rick-ross-explains-missing-pusha-t-verse-on-maybach-music-vi/" rel="bookmark" title="Video: Rick Ross Explains Missing Pusha T Verse on &#8220;Maybach Music VI&#8221;"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/ziN-GpobEP2fX30SKVYSgWAOUrjbcHw99i33nbJPZoeF-K6o66qR9xdhSyOa6ISUW30Ur4D_6KGYDcAeol7LisHDf_C9545lRCPJ6zwvuo3wLrvsPkCTN7Iv8T_zTPR3NKEmggoaM2thFqLAg6UMMFU6ekBUOQ_0qZJuDk3ZKJWLTlrOUR6ZEoNRMgcM-J09oOCO07sHeL1RbEYB0TIbFFGl9MG0wt87LrsnrsCit7980wKIDL6qNkUO_XtJwVrEqZyfJDKPvjNRP-R7YtjNFpWAx1t0g-qbcrLzoQv6F4WNq3xABX3SKxdq7aHnCJ1fra-E9lyGmmOEeFnHI8V2zcB8an9Us4yDhIuYWGYQnZkYAAJmqS2ivZzCj2tcF-YCESg8SC_ciZoEzgPI80ZZjbP65iWBeSvaLxJ0GtMr6X1ZKD3oeHL1C4IlL_7l8c8xrHI8q8oFuC8q2J9njByVnu2dXpzaWkxROa8HpNUjT35-H12ccZpfQDM-BJnC0x7IBDbcJRcKFicnis_kL_j5vdYvj80uBIhwtIyNluZdhmfi1m0iYERwjHuqY2OnhyZh-zwnTwhp0GYNoeWJBhcwGBCIfBweTKbr9DVH37B5vXHNMOqb-DtvwGPT_DB07_04ZPHyldLvHiwVmSQanGQd8N86OZ0uNyGA=w881-h611-no" alt="" title="Video: Rick Ross Explains Missing Pusha T Verse on &#8220;Maybach Music VI&#8221;"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/10/video-rick-ross-explains-missing-pusha-t-verse-on-maybach-music-vi/" rel="bookmark" title="Video: Rick Ross Explains Missing Pusha T Verse on &#8220;Maybach Music VI&#8221;">Video: Rick Ross Explains Missing Pusha T Verse on &#8220;Maybach Music&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/09/jeezy-tm104-album-artwork/" rel="bookmark" title="Jeezy ‘TM104’ Album Artwork"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/uNZVI8EPeQ5W7oyBM9kXK9WJ-2VbkeNJFCXs2a2wFwhDxAcEpOBEVfRap0nXybUNsuDbiNRpFf2TR2CWKmyCSOhKtZgA9YeXWiFHO8bwdPjdkTOTgf4Vb-iuuOyLVRKOqTJsg5BwV81Ov77bZWhjmwXk7SYtAKIVNBVGpj72L2WBVOUQl2SjWWGpM98OQSSnn8F4oYHRHTlvarBYMANAA29MFqaFO2nWk3-tNZkTjORuFtypzISbpvnVoP5iLpdSLo5k7BemSMaM1ZdYtfOO9MSv3fAqNKMG-NyoR1kDlEH2RTNNVnLbSkm-7xB4yDTODW0bFK__WmoAz2D3speTQpQluirZmxJMzUlsXDwPbGaa5MY0hQoD6rwnfKujA3KFq2C3zCyq27WR-jIWYin321II2pvwyXWQhMm1W3nKU1zzKflIt6JrIFZOA4PvvUxfVo86NAKfDWNsGViVi6hunXVYwzXNPW9AW6Hx2VjHz3BlUJRlDLY42LnvGBEVYifPzaVFmbRTCIxFQkyYFDd_mkz1CB236p87LSdiVDEHRy8bEKewnEKZ1UwXXzXp2lDHZdGHcm7HKwDNS51BDpCa0-2SmK8gR3F3NjjMbh0osW5sWnVQk-JsT5MZkPTytH42QluVdfJVL-t4rg02M3E8D-E2QjyAp8ts=s680-no" alt="" title="Jeezy ‘TM104’ Album Artwork"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/09/jeezy-tm104-album-artwork/" rel="bookmark" title="Jeezy ‘TM104’ Album Artwork">Jeezy ‘TM104’ Album Artwork</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/09/video-idris-elba-hot-ones-interview/" rel="bookmark" title="Video: Idris Elba &#8211; Hot Ones Interview"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/7oGBbOKquFm_2omicNvdPz3PkarOQzOeR_C8tFbpZ1MDjZ9XD198tdXYmYAThjffrmIMQlrxQhdSFRFsIy2QphFJyuIpxrtu9Hl5e40Zq0D6-0FLUYGGru7fl66YZxN5fHH27oGUOYjvwLf19wx8Nf6DL62eacEiSSiPre88AhVhp1GP9MSbadoLX0GkJ-IIxznjJxWQT1XRJMUHJmDDSryrt7EM4W_usJvQ6Pp5jwIaV20u_cNIDduN5l4UWNujOar0L6o46uCa9z4sfqpv8P_sBDPIKY82xl17xC0ruh9aJO6dMO7uzLvufULQi6Lz8_0GNUTfWlJv3-v06USemGiMVACBYYKPxcgzz04nwgCsps-DCm1U1OShrXxjFKn8BTEJw2FZ5JWmidBrev8TQK93n7jUvgwQvW8e8_u2Kz6aVrY7j29lB6iNd_kwo3_u7jZXiHH1xfCMx-b6Y6mU3lqndBKPfdjYQN9V-H-HXed-LVX_IfZsqQESp2ZGLKS8hZK_npHKFg5uLf11Koslrv1g09RFtF1lC2VwWHquxkoSdY1y8XSb2620fvrfrgdVbePgUPalXw6pixi81pUtrKqLe9DEGl1M8w2M7VhmeopjsfpoJ-1T__aDIY_gjQQwll-hx_VU7n3pR8YZtoy-9Es_8K-XYf-0=w1148-h609-no" alt="" title="Video: Idris Elba &#8211; Hot Ones Interview"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/09/video-idris-elba-hot-ones-interview/" rel="bookmark" title="Video: Idris Elba &#8211; Hot Ones Interview">Video: Idris Elba &#8211; Hot Ones Interview</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_23_5d514c1f660bd" data-td_block_id="td_uid_23_5d514c1f660bd"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_23_5d514c1f660bd" data-td_block_id="td_uid_23_5d514c1f660bd"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_30_5d514c1f79c59_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_30_5d514c1f79c59" ><script>var block_td_uid_30_5d514c1f79c59 = new tdBlock();
block_td_uid_30_5d514c1f79c59.id = "td_uid_30_5d514c1f79c59";
block_td_uid_30_5d514c1f79c59.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"77","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_30_5d514c1f79c59_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_30_5d514c1f79c59.td_column_number = "3";
block_td_uid_30_5d514c1f79c59.block_type = "td_block_mega_menu";
block_td_uid_30_5d514c1f79c59.post_count = "4";
block_td_uid_30_5d514c1f79c59.found_posts = "158";
block_td_uid_30_5d514c1f79c59.header_color = "";
block_td_uid_30_5d514c1f79c59.ajax_pagination_infinite_stop = "";
block_td_uid_30_5d514c1f79c59.max_num_pages = "40";
tdBlocksArray.push(block_td_uid_30_5d514c1f79c59);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_30_5d514c1f79c59" id="td_uid_31_5d514c1f7a71c" data-td_block_id="td_uid_30_5d514c1f79c59" data-td_filter_value="" href="http://weuponithiphop.info/category/fashion/">All</a><a class="mega-menu-sub-cat-td_uid_30_5d514c1f79c59"  id="td_uid_32_5d514c1f7a80f" data-td_block_id="td_uid_30_5d514c1f79c59" data-td_filter_value="76" href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></div></div><div id=td_uid_30_5d514c1f79c59 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/LVT4Mid8WL4wHUdO9X2OZmZxxgbREs2lVtszOdEBaO6hJB0JS3yQOAyhNSdCyPmv0amBDTgNGpOlRPXPjKCl6yIlo2joyH3rQRI7CUdX09BJtQI1r5jy1_7BQtDhw4AxUhpUwIh35rNS3lTy7uq-FdPff10JN6srr9mwZ7zr04GQFxBVEXwCfC5rNVehXhY_wGCRVsmevYmdkBWEmB8dvOzBHY78NBBjcHNArS_S-2M0FJgDh8v9m9vEh78k_XmZg-AERctsf0bkODuPi1EcNJq_RnJIV6b0GG-VtKjo-OVPmYghWJYf1HiP9c58cQ98oABU8BDFdLqsBtNt4K0NmyHYQlX39W9k_d83wEHZ1-EacQa2o01VrYSn12HnZ1l88fMzu9PKv6EGmcRZNwpepycW7_9EQnhxIPDdVCmRLXUasUED9OXr-zJmnBcnSnLCa06k1ZymQym1LiSFEv1c3aPHnmnD3GY8nL7q5jPJr4HsABR0WCqMebcF3HF_0deNd0zgRBCGMxW-VzlIIHZiHuBeSPEPvUL149GJ5swSSvKm1uGEi1HlLBj9omJSU7mDWzO0p_7l-l7-4_ureEsGsgB8cX1t8t2TQcFeRgqqF1CXlZFYYC2K0iMb4jPsijsw_rtO7pmKvbngqHfgYpGeh_qLmDWeicR7=w1195-h796-no" alt="" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch">Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/fHEwwMf8DoiXlqkfibQS1Z1XXbviORbV9raaI44tOTXrWo7GgqM3gA-vswE10gFtTQUGGwNG7nWAACwHjxPuiubliYBN_dqtBZh2WIpxvumiJ-hSLK0TNWB2cB8Iw2STT5gcp_KqlDh_e4xng1vidI8EXdp_ooh5uDI-JV1HQ9dGnM5nxl_b-v8znqj-Rl_mGB7y4Lu9zsFNWHU7SriqQQJaKrKEEnb9T8zxmGLaL0zq7ilYpnUEhWulDDr9xc82wdr__WzRBm5YEskVpDAnGM2NDZwTZpjbe4QDdxeixWnSXNK_oDzaL7WTbCpkD33OK88BlI5JmFRQ5VmD11UQ2htB7-9WoahHvb4XmBsbLXpEMl1JmEP4sPx06VduzFnBNo-J90WI0n1AEIIcEYVbRywrkGJXbzmH__In9ZIg0EV24OcGGbeKl12HxTdZwucqsNnuZeNjiMHISQ7i8cfzm3N7X7Zenl74zsKIKeKWoIGxh6MTlVADvgHcrHebnjcSgil2vBeFyz_AP45aOv9SOwbzfVLGS0CNfe1s9b2J7qZgjcBk9QPEXCl2kygvzmGXFvU_3xBuW6S0i3Vkh3Ha_3hPBtvIAy3WoTK2yiqS41HzSK7yk3FRAlBtpIEib338fdkTiosBxtdu36SdNUVM75zl6CVIFhTu=w681-h470-no" alt="" title="Air Jordan 14 Rip Hamilton"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton">Air Jordan 14 Rip Hamilton</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/kUjaOYxjEkAh34S-Ub2QSZwdOwHyFnGFLBZULta3_bn1_myPMAwJXiEEsAAtc1ktCQwHCuKhSqSYsWXFBEIZxdfKuykoDEZWwO-dDI3_JeAshbYvyILEHUu0XaUpRn0mj7gOx10V52t8gRGYPCW7QXGImkPGGhvBPzBDVVqh9lKGtkuPeePmTnpRSmwp0LG1WHcIzUWnMqPBWQeHAat6Q-Tq7niXNb96ddEZsMEdHK1nmHVlNaeqFBNtTxk6yYRkFNCvtfBayqy-Rqt4CPU5tThxbTI4AIUCI6JLxJd_VJizrVNDEe2xZ_tiQdkC5ASIoHpX8sfvAB8zRUsMVJ6oMUt5FH_4GBNXDCtFRmr65Qt0JV1h4bBJffu2L272Q_vpD76wn-YNGW8VCtZcheHu_X-A4gdYQEC0HN0BenY-MOuUBqKEjXAc0SxWeP7W9RN55jlqUFK0nzEYydVjec2stdQIngVfg_FvKxvHXfM4XdtMpqeJnp3Pzyk8xjz30sAZd0f2HQ6zfdPjk-OkV2-WrC0_qW0L8Rq3zrUbq52n3BN7gm7sctU_CUlBmoQIgJDQBYk1Siv4tfSq9pL1R4GdaOlWQdxEuhZi8bTYC8GGAgNGl3SMAZGvk7nu6QnnwEZjZ7mZwbcqgyRKa89cOREMUvIkVJ8Q8lZu=w926-h672-no" alt="" title="Jordan Proto React Triple White"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White">Jordan Proto React Triple White</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4cDUjSODZSaXWfHyZKb9q3Fn7FHA4uB0KSBs0MtFHC0dc6AJb1zeAl_X2LOKalK9C7VBFhTqRQ9fw1ESgUr9ZUKFbOzD94i_s96nvkICOqrsYnzrE2nEAQHoEaGOF4O8GAI6T4CGFbgcQhNzjpRlSY60NyPu5Cmq81FRpEOFRzTOtSa_NnWzMmfwO0yxtPbcg5U6YBUsus8shv3SA7CjULLfaP38nZAuWVgq8PMaaeCQ_eSrK8NJSEVQjyyxmqb-1I7zO8Kvvzvwi--ibMr52CF8h-GusBzSq5ZuzvZRCGu_u8CyfoXw7pwWbOmHnLOdcQ9d2PCSW_IxEMGfmEuU7NxMSsW3Ga4r35_wLB7cjvlPC9OjCV50tfekXjZBS_476mzlf4G9jR7Ju1GqgjXah9Uqc_0Y8N-Br8_JCtIlRSuLxAiebwd7AvFVlgWId9MYxBWnRT3cTyD8SH7q5WwO-CIbKAOSKsNcrrTgFxQvqn9yklBU1u5X5fdTlTBk4WSYorsWZAug0z9BOymRLnrhTbnA0vpBPFROWD-aL1glg-eUpFSfgD4xhWsOqJNY9krQ2UbLSGXQ5gYWj0ovLS7Yz3UKFY2qrVWpqkpbfyN98es9NJ-7LTUs2MLq1rX_2FaQmyq5mVndd7VGzQOHy9hDULG-5H-0LvGd=w900-h566-no" alt="" title="adidas Yeezy Boost 350 V2 Hyperspace"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace">adidas Yeezy Boost 350 V2 Hyperspace</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_30_5d514c1f79c59" data-td_block_id="td_uid_30_5d514c1f79c59"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_30_5d514c1f79c59" data-td_block_id="td_uid_30_5d514c1f79c59"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div>                </div>

                <div class="td-pb-span5 td-sub-footer-copy">
                    &copy; 2018 The Hip Hop Chronicles Media Group                </div>
            </div>
        </div>
    </div>
</div><!--close td-outer-wrap-->

	<div id="wpcp-error-message" class="msgmsg-box-wpcp warning-wpcp hideme"><span>error: </span>Not Prohibited. ✌️</div>
	<script>
	var timeout_result;
	function show_wpcp_message(smessage)
	{
		if (smessage !== "")
			{
			var smessage_text = '<span>Alert: </span>'+smessage;
			document.getElementById("wpcp-error-message").innerHTML = smessage_text;
			document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp showme";
			clearTimeout(timeout_result);
			timeout_result = setTimeout(hide_message, 3000);
			}
	}
	function hide_message()
	{
		document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp hideme";
	}
	</script>
	<style type="text/css">
	#wpcp-error-message {
	    direction: ltr;
	    text-align: center;
	    transition: opacity 900ms ease 0s;
	    z-index: 99999999;
	}
	.hideme {
    	opacity:0;
    	visibility: hidden;
	}
	.showme {
    	opacity:1;
    	visibility: visible;
	}
	.msgmsg-box-wpcp {
		border-radius: 10px;
		color: #555;
		font-family: Tahoma;
		font-size: 11px;
		margin: 10px;
		padding: 10px 36px;
		position: fixed;
		width: 255px;
		top: 50%;
  		left: 50%;
  		margin-top: -10px;
  		margin-left: -130px;
  		-webkit-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
		-moz-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
		box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
	}
	.msgmsg-box-wpcp span {
		font-weight:bold;
		text-transform:uppercase;
	}
	.error-wpcp {		background:#ffecec url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/error.png') no-repeat 10px 50%;
		border:1px solid #f5aca6;
	}
	.success {
		background:#e9ffd9 url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/success.png') no-repeat 10px 50%;
		border:1px solid #a6ca8a;
	}
	.warning-wpcp {
		background:#ffecec url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/warning.png') no-repeat 10px 50%;
		border:1px solid #f5aca6;
	}
	.notice {
		background:#e3f7fc url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/notice.png') no-repeat 10px 50%;
		border:1px solid #8ed9f6;
	}
    </style>


    <!--

        Theme: Newspaper by tagDiv 2016
        Version: 7.2 (rara)
        Deploy mode: deploy
        
        uid: 5d514c1f85b55
    -->

    <link rel='stylesheet' id='so-css-Newspaper-css'  href='http://weuponithiphop.info/wp-content/uploads/so-css/so-css-Newspaper.css?ver=1528674688' type='text/css' media='all' />
<link rel='stylesheet' id='soliloquy-lite-style-css'  href='http://weuponithiphop.info/wp-content/plugins/soliloquy-lite/assets/css/soliloquy.css?ver=2.5.6' type='text/css' media='all' />
<link rel='stylesheet' id='soliloquy-liteclassic-theme-css'  href='http://weuponithiphop.info/wp-content/plugins/soliloquy-lite/themes/classic/style.css?ver=2.5.6' type='text/css' media='all' />
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/themes/Newspaper/js/tagdiv_theme.js?ver=7.2'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/comment-reply.min.js?ver=4.9.10'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/wp-embed.min.js?ver=4.9.10'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/plugins/soliloquy-lite/assets/js/min/soliloquy-min.js?ver=2.5.6'></script>

<!-- JS generated by theme -->

<script>
    


            

	            // if the theme has tdBackstr support, it means this already uses it
                if ( 'undefined' !== typeof window.tdBackstr ) {

                    (function(){
                        // the site background td-backstretch jquery object is dynamically added in DOM, and after any translation effects are applied over td-backstretch
                        var wrapper_image_jquery_obj = jQuery( '<div class=\'backstretch\'></div>' );
                        var image_jquery_obj = jQuery( '<img class=\'td-backstretch not-parallax\' src=\'http://weuponithiphop.info/wp-content/uploads/city-skyline-1.png\'>' );

                        wrapper_image_jquery_obj.append( image_jquery_obj );

                        jQuery( 'body' ).prepend( wrapper_image_jquery_obj );

                        var td_backstr_item = new tdBackstr.item();

                        td_backstr_item.wrapper_image_jquery_obj = wrapper_image_jquery_obj;
                        td_backstr_item.image_jquery_obj = image_jquery_obj;

	                    tdBackstr.add_item( td_backstr_item );

                    })();
                }

            
            
jQuery(window).ready(function() {
(function(){
var td_backstr_item = new tdBackstr.item();
td_backstr_item.wrapper_image_jquery_obj = jQuery( "#td-full-screen-header-image" );
td_backstr_item.image_jquery_obj = td_backstr_item.wrapper_image_jquery_obj.find( 'img:first' );
tdBackstr.add_item( td_backstr_item );
jQuery('.td-read-down a').click(function(event){
event.preventDefault();
var header_wrap = jQuery( '.td-full-screen-header-image-wrap:first' )
if ( 1 === header_wrap.length ) {
tdUtil.scrollToPosition(header_wrap.height() + header_wrap.offset().top, 1200);
}
});
})();
});

                jQuery().ready(function jQuery_ready() {
                    tdAjaxCount.tdGetViewsCountsAjax("post","[33946]");
                });
            

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'http://weuponithiphop.info/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'http://weuponithiphop.info/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>

			<script type="text/javascript">
			if ( typeof soliloquy_slider === 'undefined' || false === soliloquy_slider ) {soliloquy_slider = {};}jQuery('#soliloquy-container-30342').css('height', Math.round(jQuery('#soliloquy-container-30342').width()/(960/300)));jQuery(window).load(function(){var $ = jQuery;var soliloquy_container_30342 = $('#soliloquy-container-30342'),soliloquy_30342 = $('#soliloquy-30342');soliloquy_slider['30342'] = soliloquy_30342.soliloquy({slideSelector: '.soliloquy-item',speed: 0,pause: 2000,auto: 1,useCSS: 0,keyboard: true,adaptiveHeight: 1,adaptiveHeightSpeed: 400,infiniteLoop: 1,mode: 'fade',pager: 1,controls: 1,nextText: '',prevText: '',startText: '',stopText: '',onSliderLoad: function(currentIndex){soliloquy_container_30342.find('.soliloquy-active-slide').removeClass('soliloquy-active-slide').attr('aria-hidden','true');soliloquy_container_30342.css({'height':'auto','background-image':'none'});if ( soliloquy_container_30342.find('.soliloquy-slider li').length > 1 ) {soliloquy_container_30342.find('.soliloquy-controls').fadeTo(300, 1);}soliloquy_30342.find('.soliloquy-item:not(.soliloquy-clone):eq(' + currentIndex + ')').addClass('soliloquy-active-slide').attr('aria-hidden','false');soliloquy_container_30342.find('.soliloquy-clone').find('*').removeAttr('id');soliloquy_container_30342.find('.soliloquy-controls-direction').attr('aria-label','carousel buttons').attr('aria-controls', 'soliloquy-container-30342');soliloquy_container_30342.find('.soliloquy-controls-direction a.soliloquy-prev').attr('aria-label','previous');soliloquy_container_30342.find('.soliloquy-controls-direction a.soliloquy-next').attr('aria-label','next');},onSlideBefore: function(element, oldIndex, newIndex){soliloquy_container_30342.find('.soliloquy-active-slide').removeClass('soliloquy-active-slide').attr('aria-hidden','true');$(element).addClass('soliloquy-active-slide').attr('aria-hidden','false');},onSlideAfter: function(element, oldIndex, newIndex){},});});			</script>
			
</body>
</html>