<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>New Music: Statik Selektah &amp; Paul Wall ft. Benny the Butcher – Overcame</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="http://weuponithiphop.info/xmlrpc.php" />
    <meta property="og:image" content="https://lh3.googleusercontent.com/lI1WF9Jox-Ur34h4mAdXTSxvDHKW71zTpSyanmcg32csynI_uhzYKpKeXG-KkCxyj1nasJvcGoUl2wD2ekfEP_dr_OKmjxLrboF_fK8yxlhog86giQ69eJ0VYfBFuFnrUHeSQ-7Gy96QA-PNM0XoXYTfCK_QxQSHUZolKKPa5Ym5pKIrslvgyX72_xnkNlHCNlFZGeJH4g6uQYpiNGNIRODE246RtKvn8txFhb-jzRfCfR6c01WpFpVeE-0NwzEgsmVIZqPOYf4C5mvQ9CiwTiqnfDKprXHbInGLDOvaa6EGjGWPRBJO6Eum-9FbHmBbwGyPF3MfwsrrUjdHk9MRsJJvbpKjSMSg8glCTDjpNcs9WNVk7sVECIFUkdYcJQWrBN9_6ecSjGB73_VA8BBtSCVWbimNL6mnO8dgoWn4Huel-WvQnzZxn-l_O4VU_EbrFGo6NvGudww6Fsuc5Ynn0XNufziHZL7gSg-PXa0LIatoPwCWESaEZYysAKB73tDEgAyKIqlmimT4-6QK4wI2We7xb689tKaMTqXfcGPs48gtgKqIK8RkUuaWqtXwH9qnyqkJYolvZdsJYBH1WGPNkuQy6ENORZEA8rrs2ju3JrhwkxuI-LAVLKAQvh_o86M5KCwZEhzM8hd24lkxu8LRxW50m4nIPfQ8mCe5UrQQrjq3e1Rb6tb3H_cx=s500-no" /><meta name="author" content="cyclone">
<link rel="icon" type="image/png" href="http://weuponithiphop.info/wp-content/uploads/weuponitlogoCAP-500x457.png">
<!-- All in One SEO Pack 3.2.7 by Michael Torbert of Semper Fi Web Design[208,308] -->
<script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"http://weuponithiphop.info/#organization","url":"http://weuponithiphop.info/","name":"WeUpOnIt","sameAs":[]},{"@type":"WebSite","@id":"http://weuponithiphop.info/#website","url":"http://weuponithiphop.info/","name":"WeUpOnIt","publisher":{"@id":"http://weuponithiphop.info/#organization"}},{"@type":"WebPage","@id":"http://weuponithiphop.info/2019/11/21/new-music-statik-selektah-paul-wall-ft-benny-the-butcher-overcame/#webpage","url":"http://weuponithiphop.info/2019/11/21/new-music-statik-selektah-paul-wall-ft-benny-the-butcher-overcame/","inLanguage":"en-US","name":"New Music: Statik Selektah &#038; Paul Wall ft. Benny the Butcher &#8211; Overcame","isPartOf":{"@id":"http://weuponithiphop.info/#website"},"datePublished":"2019-11-22T00:25:15+00:00","dateModified":"2019-11-22T00:25:15+00:00"},{"@type":"Article","@id":"http://weuponithiphop.info/2019/11/21/new-music-statik-selektah-paul-wall-ft-benny-the-butcher-overcame/#article","isPartOf":{"@id":"http://weuponithiphop.info/2019/11/21/new-music-statik-selektah-paul-wall-ft-benny-the-butcher-overcame/#webpage"},"author":{"@id":"http://weuponithiphop.info/author/cyclone/#author"},"headline":"New Music: Statik Selektah &#038; Paul Wall ft. Benny the Butcher &#8211; Overcame","datePublished":"2019-11-22T00:25:15+00:00","dateModified":"2019-11-22T00:25:15+00:00","commentCount":0,"mainEntityOfPage":{"@id":"http://weuponithiphop.info/2019/11/21/new-music-statik-selektah-paul-wall-ft-benny-the-butcher-overcame/#webpage"},"publisher":{"@id":"http://weuponithiphop.info/#organization"},"articleSection":"New Music, Benny the Butcher, Paul Wall, Statik Selektah"},{"@type":"Person","@id":"http://weuponithiphop.info/author/cyclone/#author","name":"cyclone","sameAs":[],"image":{"@type":"ImageObject","@id":"http://weuponithiphop.info/#personlogo","url":"http://0.gravatar.com/avatar/6a747aaba64ebc36f309e25ac7e460e6?s=96&d=mm&r=g","width":96,"height":96,"caption":"cyclone"}}]}</script>
<link rel="canonical" href="http://weuponithiphop.info/2019/11/21/new-music-statik-selektah-paul-wall-ft-benny-the-butcher-overcame/" />
<!-- All in One SEO Pack -->
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Feed" href="http://weuponithiphop.info/feed/" />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Comments Feed" href="http://weuponithiphop.info/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; New Music: Statik Selektah &#038; Paul Wall ft. Benny the Butcher &#8211; Overcame Comments Feed" href="http://weuponithiphop.info/2019/11/21/new-music-statik-selektah-paul-wall-ft-benny-the-butcher-overcame/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/weuponithiphop.info\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.12"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='google_font_open_sans-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;ver=4.9.12' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_roboto-css'  href='http://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C900%2C500italic%2C400%2C300&#038;ver=4.9.12' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='http://fonts.googleapis.com/css?family=Roboto+Condensed%3A400%2C700&#038;ver=4.9.12' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='http://weuponithiphop.info/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=4.12' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='http://weuponithiphop.info/wp-content/themes/Newspaper/style.css?ver=7.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css'  href='http://weuponithiphop.info/wp-content/themes/Newspaper/includes/demos/what/demo_style.css?ver=7.2' type='text/css' media='all' />
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1'></script>
<link rel='https://api.w.org/' href='http://weuponithiphop.info/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://weuponithiphop.info/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://weuponithiphop.info/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Video: Rapsody &#8211; Funk Flex Freestyle' href='http://weuponithiphop.info/2019/11/21/video-rapsody-funk-flex-freestyle-7/' />
<link rel='next' title='Album Stream: Tinashe &#8211; Songs For You' href='http://weuponithiphop.info/2019/11/21/album-stream-tinashe-songs-for-you/' />
<meta name="generator" content="WordPress 4.9.12" />
<link rel='shortlink' href='http://weuponithiphop.info/?p=35861' />
<link rel="alternate" type="application/json+oembed" href="http://weuponithiphop.info/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fweuponithiphop.info%2F2019%2F11%2F21%2Fnew-music-statik-selektah-paul-wall-ft-benny-the-butcher-overcame%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://weuponithiphop.info/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fweuponithiphop.info%2F2019%2F11%2F21%2Fnew-music-statik-selektah-paul-wall-ft-benny-the-butcher-overcame%2F&#038;format=xml" />

<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>
<script id="wpcp_disable_selection" type="text/javascript">
//<![CDATA[
var image_save_msg='You Can Not Save images!';
	var no_menu_msg='Context Menu disabled!';
	var smessage = "Not Prohibited. ✌️";

function disableEnterKey(e)
{
	if (e.ctrlKey){
     var key;
     if(window.event)
          key = window.event.keyCode;     //IE
     else
          key = e.which;     //firefox (97)
    //if (key != 17) alert(key);
     if (key == 97 || key == 65 || key == 67 || key == 99 || key == 88 || key == 120 || key == 26 || key == 85  || key == 86 || key == 83 || key == 43)
     {
          show_wpcp_message('You are not allowed to copy content or view source');
          return false;
     }else
     	return true;
     }
}

function disable_copy(e)
{	
	var elemtype = e.target.nodeName;
	var isSafari = /Safari/.test(navigator.userAgent) && /Apple Computer/.test(navigator.vendor);
	elemtype = elemtype.toUpperCase();
	var checker_IMG = '';
	if (elemtype == "IMG" && checker_IMG == 'checked' && e.detail >= 2) {show_wpcp_message(alertMsg_IMG);return false;}
	if (elemtype != "TEXT" && elemtype != "TEXTAREA" && elemtype != "INPUT" && elemtype != "PASSWORD" && elemtype != "SELECT" && elemtype != "OPTION" && elemtype != "EMBED")
	{
		if (smessage !== "" && e.detail == 2)
			show_wpcp_message(smessage);
		
		if (isSafari)
			return true;
		else
			return false;
	}	
}
function disable_copy_ie()
{
	var elemtype = window.event.srcElement.nodeName;
	elemtype = elemtype.toUpperCase();
	if (elemtype == "IMG") {show_wpcp_message(alertMsg_IMG);return false;}
	if (elemtype != "TEXT" && elemtype != "TEXTAREA" && elemtype != "INPUT" && elemtype != "PASSWORD" && elemtype != "SELECT" && elemtype != "OPTION" && elemtype != "EMBED")
	{
		//alert(navigator.userAgent.indexOf('MSIE'));
			//if (smessage !== "") show_wpcp_message(smessage);
		return false;
	}
}	
function reEnable()
{
	return true;
}
document.onkeydown = disableEnterKey;
document.onselectstart = disable_copy_ie;
if(navigator.userAgent.indexOf('MSIE')==-1)
{
	document.onmousedown = disable_copy;
	document.onclick = reEnable;
}
function disableSelection(target)
{
    //For IE This code will work
    if (typeof target.onselectstart!="undefined")
    target.onselectstart = disable_copy_ie;
    
    //For Firefox This code will work
    else if (typeof target.style.MozUserSelect!="undefined")
    {target.style.MozUserSelect="none";}
    
    //All other  (ie: Opera) This code will work
    else
    target.onmousedown=function(){return false}
    target.style.cursor = "default";
}
//Calling the JS function directly just after body load
window.onload = function(){disableSelection(document.body);};
//]]>
</script>
	<script id="wpcp_disable_Right_Click" type="text/javascript">
	//<![CDATA[
	document.ondragstart = function() { return false;}
	/* ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
	Disable context menu on images by GreenLava Version 1.0
	^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ */
	    function nocontext(e) {
	       return false;
	    }
	    document.oncontextmenu = nocontext;
	//]]>
	</script>
<!-- Analytics by WP-Statistics v12.6.9 - https://wp-statistics.com/ -->
<!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]-->
<!-- JS generated by theme -->

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var tds_login_sing_in_widget="show";
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_ajax_url="http:\/\/weuponithiphop.info\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=7.2";
var td_get_template_directory_uri="http:\/\/weuponithiphop.info\/wp-content\/themes\/Newspaper";
var tds_snap_menu="snap";
var tds_logo_on_sticky="show_header_logo";
var tds_header_style="5";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#dd3333";
var tds_smart_sidebar="enabled";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>


<!-- Header style compiled by theme -->

<style>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</style>

<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>

<body class="post-template-default single single-post postid-35861 single-format-standard unselectable new-music-statik-selektah-paul-wall-ft-benny-the-butcher-overcame td-what single_template_7 wpb-js-composer js-comp-ver-4.12 vc_responsive td-boxed-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
                    <div class="td-menu-login-section">
                
    <div class="td-guest-wrap">
        <div class="td-menu-avatar"><div class="td-avatar-container"><img alt='' src='http://2.gravatar.com/avatar/?s=80&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo avatar-default' height='80' width='80' /></div></div>
        <div class="td-menu-login"><a id="login-link-mob">Sign in</a></div>
    </div>
            </div>
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-top-menu-container"><ul id="menu-top-menu" class="td-mobile-main-menu"><li id="menu-item-317" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-first menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a></li>
<li id="menu-item-706" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a></li>
<li id="menu-item-314" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a></li>
<li id="menu-item-316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-0" class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></li>
</ul>
</li>
<li id="menu-item-705" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></li>
</ul>
</li>
<li id="menu-item-18581" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li id="menu-item-3199" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
            <div id="login-form-mobile" class="td-register-section">
            
            <div id="td-login-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-login-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign in</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
	                <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
	                <div class="td-login-info-text"><a href="#" id="forgot-pass-link-mob">Forgot your password?</a></div>
                </div>
            </div>

            

            <div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
                <!-- close button -->
	            <div class="td-forgot-pass-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Password recovery</div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title">Recover your password</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
	                <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
                </div>
            </div>
        </div>
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="http://weuponithiphop.info/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap">
    
        <!--
Header style 5
-->

<div class="td-header-wrap td-header-style-5">

    <div class="td-header-top-menu-full">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div >

                Thursday, November 21, 2019
            </div>
        </div>
    <ul class="top-header-menu td_ul_login"><li class="menu-item"><a class="td-login-modal-js menu-item" href="#login-form" data-effect="mpf-td-login-effect">Sign in / Join</a><span class="td-sp-ico-login td_sp_login_ico_style"></span></li></ul><div class="menu-top-container"><ul id="menu-main" class="top-header-menu"><li id="menu-item-79" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-79"><a href="http://weuponithiphop.info">Home</a></li>
<li id="menu-item-81" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-81"><a target="_blank" href="http://weuponitradio.com">Power 105.1 WeUpOnIt Radio</a></li>
<li id="menu-item-80" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-80"><a target="_blank" href="https://shop.spreadshirt.com/freshandcleantees/">Shop</a></li>
<li id="menu-item-18582" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18582"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li id="menu-item-18583" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18583"><a href="http://weuponithiphop.info/privacy-policy-2/">Privacy Policy</a></li>
</ul></div></div>
        <div class="td-header-sp-top-widget">
    
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div>
    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <ul class="td-login-tabs">
                        <li><a id="login-link" class="td_login_tab_focus">LOG IN</a></li>
                    </ul>



                    <div class="td-login-wrap">
                        <div class="td_display_err"></div>

                        <div id="td-login-div" class="">
                            <div class="td-login-panel-title">Welcome! Log into your account</div>
                            <input class="td-login-input" type="text" name="login_email" id="login_email" placeholder="your username" value="" required>
                            <input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" placeholder="your password" required>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Log In">


                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password?</a></div>


                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-display-none">
                            <div class="td-login-panel-title">Recover your password</div>
                            <input class="td-login-input" type="text" name="forgot_email" id="forgot_email" placeholder="your email" value="" required>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Pass">
                        </div>




                    </div>
                </div>
                        </div>
    </div>

    <div class="td-header-menu-wrap-full">
        <div class="td-header-menu-wrap">
            <div class="td-container td-header-row td-header-main-menu black-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-menu">
        		<a class="td-mobile-logo td-sticky-header" href="http://weuponithiphop.info/">
			<img class="td-retina-data" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-5.png" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-5.png" alt=""/>
		</a>
			<a class="td-header-logo td-sticky-header" href="http://weuponithiphop.info/">
			<img class="td-retina-data" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" alt=""/>
			<span class="td-visual-hidden">WeUpOnIt</span>
		</a>
	    </div>
    <div class="menu-top-menu-container"><ul id="menu-top-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-first td-menu-item td-mega-menu menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_1_5dd73c227ab1a_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_1_5dd73c227ab1a" ><script>var block_td_uid_1_5dd73c227ab1a = new tdBlock();
block_td_uid_1_5dd73c227ab1a.id = "td_uid_1_5dd73c227ab1a";
block_td_uid_1_5dd73c227ab1a.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"43","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_1_5dd73c227ab1a_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_1_5dd73c227ab1a.td_column_number = "3";
block_td_uid_1_5dd73c227ab1a.block_type = "td_block_mega_menu";
block_td_uid_1_5dd73c227ab1a.post_count = "5";
block_td_uid_1_5dd73c227ab1a.found_posts = "2610";
block_td_uid_1_5dd73c227ab1a.header_color = "";
block_td_uid_1_5dd73c227ab1a.ajax_pagination_infinite_stop = "";
block_td_uid_1_5dd73c227ab1a.max_num_pages = "522";
tdBlocksArray.push(block_td_uid_1_5dd73c227ab1a);
</script><div id=td_uid_1_5dd73c227ab1a class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/21/new-music-statik-selektah-paul-wall-ft-benny-the-butcher-overcame/" rel="bookmark" title="New Music: Statik Selektah &#038; Paul Wall ft. Benny the Butcher &#8211; Overcame"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/lI1WF9Jox-Ur34h4mAdXTSxvDHKW71zTpSyanmcg32csynI_uhzYKpKeXG-KkCxyj1nasJvcGoUl2wD2ekfEP_dr_OKmjxLrboF_fK8yxlhog86giQ69eJ0VYfBFuFnrUHeSQ-7Gy96QA-PNM0XoXYTfCK_QxQSHUZolKKPa5Ym5pKIrslvgyX72_xnkNlHCNlFZGeJH4g6uQYpiNGNIRODE246RtKvn8txFhb-jzRfCfR6c01WpFpVeE-0NwzEgsmVIZqPOYf4C5mvQ9CiwTiqnfDKprXHbInGLDOvaa6EGjGWPRBJO6Eum-9FbHmBbwGyPF3MfwsrrUjdHk9MRsJJvbpKjSMSg8glCTDjpNcs9WNVk7sVECIFUkdYcJQWrBN9_6ecSjGB73_VA8BBtSCVWbimNL6mnO8dgoWn4Huel-WvQnzZxn-l_O4VU_EbrFGo6NvGudww6Fsuc5Ynn0XNufziHZL7gSg-PXa0LIatoPwCWESaEZYysAKB73tDEgAyKIqlmimT4-6QK4wI2We7xb689tKaMTqXfcGPs48gtgKqIK8RkUuaWqtXwH9qnyqkJYolvZdsJYBH1WGPNkuQy6ENORZEA8rrs2ju3JrhwkxuI-LAVLKAQvh_o86M5KCwZEhzM8hd24lkxu8LRxW50m4nIPfQ8mCe5UrQQrjq3e1Rb6tb3H_cx=s500-no" alt="" title="New Music: Statik Selektah &#038; Paul Wall ft. Benny the Butcher &#8211; Overcame"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/21/new-music-statik-selektah-paul-wall-ft-benny-the-butcher-overcame/" rel="bookmark" title="New Music: Statik Selektah &#038; Paul Wall ft. Benny the Butcher &#8211; Overcame">New Music: Statik Selektah &#038; Paul Wall ft. Benny the Butcher&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/20/new-music-kxng-crooked-bronze-nazareth-i-can-still-remember-5/" rel="bookmark" title="New Music: KXNG Crooked &#038; Bronze Nazareth &#8211; I Can Still Remember"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/S4wuuuWwyLp3iibb0Pk1o_AyZokCWjOsvGqaak8VkDAxJFiU_BYg4UZdcgOzjEyJfBXuKYNGo7M131Q8qpXW2vf4tp7kWYgrlQMdOYqdvDLPdgyMTLYg1mc6xSszx_hnsOcl5CB7noj4tzvf4ml0ewBoX8St_fMFB-8NiXwcTsO5K0rlp2EK1BuHifF0HD26S5-7zjkeh6wlImAb5z6KSNugKMi6D45EqwkyEWoy06SbA9NlZo6kIAXC-sMCDilO47taMXa-759gy8R7uHoeuDfvMXkpn3qF415LDmTHwKXSOu9Ox5Rs_FCzfCUuaJZGFBiLNh30udpMPtuN1jxfC1CjdL99OQd2tH2vAt-P3vXhw6mVwtpPtslHhUD5WalMr0_50wi8SCOCQ74OtF1ze-3qugGiCEtTqxJafc84t5-jvOJjXuVAvJ-71nSOfZrOg21HtWfNo4HKw-SpM5xwWxPpqbzvJMHbvL2r4WX9nkzPT4PT6Lj0rpxRJFkpIoGc-rn3uEeEDnp1NqG3Bj0eSjiVygN-CnVQpTv6sJAX3bWOSVLUUvxiKdLokvKFXdZ1idZzB5yqjqlHB31XaVIq-pRuhvaHSCVX_wEoh3pv2DtGgrxw4dOFoUV7ujXT6zKftYVRr6QwLLQjaDY_kQdSdW-AqnbC5FB9zjBrRMG6EM0G_el9JLUfQHh6=s700-no" alt="" title="New Music: KXNG Crooked &#038; Bronze Nazareth &#8211; I Can Still Remember"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/20/new-music-kxng-crooked-bronze-nazareth-i-can-still-remember-5/" rel="bookmark" title="New Music: KXNG Crooked &#038; Bronze Nazareth &#8211; I Can Still Remember">New Music: KXNG Crooked &#038; Bronze Nazareth &#8211; I Can Still&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/20/new-music-take-a-daytrip-ft-rico-nasty-slowthai-icecoldbishop-lighthouse/" rel="bookmark" title="New Music: Take A Daytrip ft. Rico Nasty, Slowthai &#038; ICECOLDBISHOP &#8211; Lighthouse"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/wrtG0SbI8-JyKQ1lmknxxsaEFtEzv5ZJ_RTeryzKRfEMgBG8GBVMUmb_IDsK4pWgEo3tmQYiYfPCACt8qSco83v969c_y4z9zrYrlREM54eVvh-lbjTWL1s6AXgnx1c7qlc-hTKS_5bYq6Ll5XCI7MGB0PZfdcZaBAjgKqMNUUh7MgIIinXcYxnzGJ9ZtE07lUsC0OhU_zSomz2mfwaRt0166d829w4g8532-qPY3z763h-kT6ynk0c0fgx-fRUaKergUyiWUYQjaE8ep0p2vD1uZz8rhCtEdMCXkmyv4PvNuyIjXylO1DA4_nzQNnYnn99qjJy-7XSFfv8xj9d0X9BNt0xD4vpWbhUcEe2WU83S4Llq3GTZOp58BaFs4p7ohwQRX3y5dNQW5_GyG4ut6zawiGBDdhXUUEbVHrADfTWifeTm9FZf5_Kl71FH7V12-AtMMaLNSC1FXRqXEN6pnZj3FPw12InBfXAeIIxJInHvCa-oJoiXZJh45FkaL02Rpb7zslN0pzNfmSIvR8ZolfDQ0r7I3tYe0lNYbdYFV9qDpLY1Y5oN3J_aGiZxvNr2m78vG1ZtRgqm13236dGB3JDQR7gSR7o4WsHtpVR47KLKRfpRbG5kE0Ie4PE5PeG86sgii30pSMfbaKi5oGIKK3vbD6vNZFMO2GRPhul_wXpq9ILh2A5-d0ZS=s700-no" alt="" title="New Music: Take A Daytrip ft. Rico Nasty, Slowthai &#038; ICECOLDBISHOP &#8211; Lighthouse"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/20/new-music-take-a-daytrip-ft-rico-nasty-slowthai-icecoldbishop-lighthouse/" rel="bookmark" title="New Music: Take A Daytrip ft. Rico Nasty, Slowthai &#038; ICECOLDBISHOP &#8211; Lighthouse">New Music: Take A Daytrip ft. Rico Nasty, Slowthai &#038; ICECOLDBISHOP&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/20/new-music-trippie-redd-who-need-love/" rel="bookmark" title="New Music: Trippie Redd &#8211; Who Need Love"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/CfMrCSwUvAVGe8x7lkXJPBlgvvolzgfe6OXU6hrUnViYUFAs8QB9Vnb2shBKZuPtOg3J5gzrK6nqNyU-8qaErrzNOl5CK00sE7MSGUKVlnAhtVeS_HgZdsXXkrprns17kGPC2VWyYq-Ph_4d1v1J3RFtC9td46nYbDliD_-aAGZhW7qGHrrpHsbJgXk_hj9Camt5i8HtxlT_80KiJryTsrU5VyUYzBxvbxGIfEiv6YGp6cN7hLGXYjTJE-z8f_pUo-QXMWquLSdbZaP4CHrnngQEX5GPFHySEJTJcX_zOEaIrBgmmrSGyMlZJQtHatIIX_REzKrEsD_wA4kqP2JyWht0LLZN9yAkJu2l9GtNAEwQJ9HEyJe-aeGMd7eb_zyuK3oD__rHPYtf8nIP2b6KjOwf4m3Y-zQovX1DQpbrhsuyRcKqr2vh5K7VwpTWSdP-Aio67_c9ZZN_FbNWHi8lRoekVGo8XagV2PIHomRQBAFzTNoJnwTFzvb89Jbl75ZKO8yfjvx2f_meU0J5lFuYZzM51MoLg24a_yblzEQoFBW-sQSqaaDAlhXNKBq5EhvzOwCw7dGvD-tB39XDPs57IyjSZfiQ3Q2ax0RosWZ5i2VNJeY3o0CsBB-7nKcd-_E4auUbnzdQQ4fXr1I_cNXFTDwexAVj3SjgoC20u0LBaGMYNv4ixl7QnAtt=s700-no" alt="" title="New Music: Trippie Redd &#8211; Who Need Love"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/20/new-music-trippie-redd-who-need-love/" rel="bookmark" title="New Music: Trippie Redd &#8211; Who Need Love">New Music: Trippie Redd &#8211; Who Need Love</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/20/new-music-dram-litmas/" rel="bookmark" title="New Music: DRAM &#8211; Litmas"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/SGFZVbp--DxIQJL9ogmBtF3AVk9p66XzRfDz35qed_LruNG2Oun8904ypCU6oCq9fm0Ai3u7PdWHN0nWm1ZGY_2wGHH5TltEKOaCmhtGmsu5zVxdCtzBnzm4n1FjoHcurg8xgyi_nYq5jnZjxdk9meWC766uXsXPG8TaCfqLsJhaiwPs9Ed8PKAELwKy7K2HA6Ggrpr2IwKtQVOGYin7D_anoaBonI4_fcWytzI6UoCb4NQMPCeWnsA131B_vKLuvej8eXtZna_ItBxXDZe7P1kbRi9gCl5RigaYQq8_8PXpoq5_BC9a12AYEPTOV7Pr0Ge9-7e-9rp3RMQXHW46ejZ-nnzlI5a5JB-mv-d5jmJX03mP8Hnerz9JJ3EEahh-ft7Cw03dqKVpPVfcCzXUBDRoy-X6XFDwyMzlJSXnObGrdfarw1HHcOncA4SnsxpKR-6qG1JqFitFeDaHnlX8gjWkwOcOvQaXTxVy7QSl6dgxJEID9IzpCBhUK4u7BSlmqUluH_HR_f4CP1BMbMxM7kvEgv_QbuAqRp88LkaclNQUwex4JiVsH2RjN9IrBKnB2dg0609MdBIYA0RRvtcMaAC7BCpBznIXLLOSwAfIA3UOMIPVbd8S9DN-cjyttv3sqqGhCeFw1ZHwBYUEnJewI52_cSwi_oAitiorIczVR4OhT0KybcmZzZf-=s558-no" alt="" title="New Music: DRAM &#8211; Litmas"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/20/new-music-dram-litmas/" rel="bookmark" title="New Music: DRAM &#8211; Litmas">New Music: DRAM &#8211; Litmas</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_5dd73c227ab1a" data-td_block_id="td_uid_1_5dd73c227ab1a"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_1_5dd73c227ab1a" data-td_block_id="td_uid_1_5dd73c227ab1a"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_2_5dd73c227f411_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_2_5dd73c227f411" ><script>var block_td_uid_2_5dd73c227f411 = new tdBlock();
block_td_uid_2_5dd73c227f411.id = "td_uid_2_5dd73c227f411";
block_td_uid_2_5dd73c227f411.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"97","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_2_5dd73c227f411_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_2_5dd73c227f411.td_column_number = "3";
block_td_uid_2_5dd73c227f411.block_type = "td_block_mega_menu";
block_td_uid_2_5dd73c227f411.post_count = "5";
block_td_uid_2_5dd73c227f411.found_posts = "929";
block_td_uid_2_5dd73c227f411.header_color = "";
block_td_uid_2_5dd73c227f411.ajax_pagination_infinite_stop = "";
block_td_uid_2_5dd73c227f411.max_num_pages = "186";
tdBlocksArray.push(block_td_uid_2_5dd73c227f411);
</script><div id=td_uid_2_5dd73c227f411 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/21/album-stream-tinashe-songs-for-you/" rel="bookmark" title="Album Stream: Tinashe &#8211; Songs For You"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/Mq7Ohuzc4V_q3LnUvRumGzDkHwLjN1H-bCfPGpdTHd3_EhBldVNT9XGSabS1hZHrpxLZPD6l-9zdFVNBQ7bG3HvEHJEkT9O8sYKeI-x7K-Lf9ysg3D2E2O7xNjrAbDaJkfqTQbM1GC4BPJkPSTps1UuRALNRurT863ogPiBcjit1phlt3fOTl5amStA_BeHMiQTXgUj0-RdR-w9Cxea7RiIcmB5RRtwd04fkqbUqGR0Q9wm4iTtoyi8wncO74gNRZnCLWCy_Lg9qCrEVtaBLDQLUneHioMDuzu4kJo-w9xansLtITogLjNCrrXEQMCFIN18Ey-xSaGWbev36xNw8pXg24uAbh1hONQyXepL884POzeTRDr6KMx3XBZIk2qeZkK_h4VLX7K7h6YBWTTFjHfesrfAGPHPmOy615G7Hlfrc_f1pRJh3Waq9SRZBuH-u83sy_vWbzAPqQ0QBar1SPtoayFpsZAhfz1QcxYGqsptXYOauxTBcx9CbwjVxWdC_6IQX4446E7dP-wmlUgjFSdik5tf_2rHjLOCwSGEJbbw-qfeTvttQe4Y7LJAoIr1dO6p0SJYUVYbngJ27VoUd2mQ_lU8nn6c54Dk0wA0ii1D9AW7ABg860m-wOEn0CoDTAkOTtRGH_Tysa1AeEkV8pF63NqSc8dqxVA8cHEhi7Gy-cpDD4F3mZAbk=w589-h736-no" alt="" title="Album Stream: Tinashe &#8211; Songs For You"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/21/album-stream-tinashe-songs-for-you/" rel="bookmark" title="Album Stream: Tinashe &#8211; Songs For You">Album Stream: Tinashe &#8211; Songs For You</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/21/album-stream-mozzy-tsu-surf-blood-cuzzins/" rel="bookmark" title="Album Stream: Mozzy &#038; Tsu Surf &#8211; Blood Cuzzins"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/MQC9-CT4B-RvuTNxqWPKROC1H_J6LrcJGA8GteVHRtCzVkil1oVIV4ezsumfLUtcKJa6v0n0qqooDwpCE8BbZNjUlm3hIvU5Skx_TvqnSIyXmg0DDk60ltRcrs16jr8Dq3ayWPz0XRxqgtS40NrRfZ6rrrUvMpgTJYtng2pDC6TtcSrIVQ_xQfzNiDwGjT1OzahyPUAVG17sk9dIxcMYnNzfoiI6kbBvdPjNTLG6dJ9wCSCt0KRgp8WXYRGQVcNEz0BH3n7t9WMAbwZALRqGcm_p2aqXI0zqZ-PLZYxIwnt_d2xxFGhR9iuu9ZldwMiU1F1nDKoIoY6cgaFJw9_jQeiT2FMvD83hNmobJfD-EdNNvUrlwxma5ikeOtib0-c3KLyyqCohtbyfXd0krp6M_1R607FRzt-tzQgP_hgIy-vBz3whCrINzZwLY4rxSQX3Gyvce-RxRmX61PTI9ZdL4IvoPzoHxzLtUV7hSJreFhbaFXAPmBNB3CnSaEFuzNBUB7wnzoexarq7vr6WtvdLC3uBEoPLRxsiY3L1-Zh4XYvEC3iJVwDEMMxheAdtl5x0KTau7Akb6g951q33cvn7YMv1hr6XmdT3Ro2jzrymjWsc-0tevRS5UJbvZ5C_p3Xk9B_IIoGNYILQid3_XzjlWlu2FJR8ei6J68LEdv0Dg0chT8qnYZAJ2vTT=s700-no" alt="" title="Album Stream: Mozzy &#038; Tsu Surf &#8211; Blood Cuzzins"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/21/album-stream-mozzy-tsu-surf-blood-cuzzins/" rel="bookmark" title="Album Stream: Mozzy &#038; Tsu Surf &#8211; Blood Cuzzins">Album Stream: Mozzy &#038; Tsu Surf &#8211; Blood Cuzzins</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/19/mixtape-evidence-squirrel-tape-instrumentals-vol-1/" rel="bookmark" title="Mixtape: Evidence &#8211; Squirrel Tape Instrumentals Vol. 1"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/72QWxWxGsF1WqCyW3Q_KBV0i3zIo3ROYdNEGB-tnhkuWff8_1k2yAUZ2_YhrGDnmcW9V9l0vTgJz7nHQHPiDJqF-ZGr9lBRhetIPXJw9Vi7PW2s3avPV0rfQoT2UVxQy44yfmtqC-K-Eu1gkDl3zFnr3vHg_M67d1sLQ5MJc3bOFe1YF_x6yT7Oa5cbOyZxpTHL5qdSm9w7Si-aj-zm7SezppLjYLZuz-37akD4fg-rMBHNZaAMllIJs_1-TzQeiKZlQII5g6Z0AQcnHXX2Ricu33nf38Iirvqik8JUTnR9zd1eXPjwGP5jfuxu9oyY16FoAh3959-IRJpldbSKxHww6YeSSGFcjwb22ohMjdRUr5nF7nOTqsHhxTBUwrBBPc7qWFv5EYN45ITTuVjp_obirNVPSIM0eePvIL41KL40rO1sU4EpkcjsQES_kML3G5Eu-bjY04lL_dnajnyQdvA1V2J491IcPYdSXD1zGeyRrAYbGYn8_o5E1hCYRrSwQf3uoa1o8e3o9bhoIr98GxWd5VWyHSrCQpHZa1L1LCvQSpYSG5VHStqv335xdfJ0Q-9v62MRuauoPbxxOoqp8YW9jk1D_YL43Hq28_LfX4piTNb04A-AyWNBFyVyJPq3vpwHPCiWzTkGrBZ_LAuTgKPMvfUQVad84dheVXcTo-62fs3JPen7iUZh5=s700-no" alt="" title="Mixtape: Evidence &#8211; Squirrel Tape Instrumentals Vol. 1"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/19/mixtape-evidence-squirrel-tape-instrumentals-vol-1/" rel="bookmark" title="Mixtape: Evidence &#8211; Squirrel Tape Instrumentals Vol. 1">Mixtape: Evidence &#8211; Squirrel Tape Instrumentals Vol. 1</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/17/album-stream-queen-slim-soundtrack/" rel="bookmark" title="Album Stream: Queen &#038; Slim Soundtrack"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/HwGFOIUxgRQYgu3CPOMq7ucLeBCdW5cEDpvvxUsoUtZxIZekd4k8TmY41LGwLuuDWQHRrET-uA4gau3ygYt45j_EZbHpll0IkVo_QBTJeDjjCWEurdkzrzcMFMZRZHE6IGuaSTascms3dy48M661Qz-u28fOF9filQH0IX6mblwPGBEkOiUdnv-Btf7oDnqIJ7pZwUGGIIaoLDZLLGcxNn8cq0TD_ddwuPQAj0JBei3BhlD2AMGR-p_u2xp1-YaRiXTAutnV99490FgED9Sdrq87CCdItu4FNqSJi4-h9dZpoEcaocBo0NDWFUpORWnVCMn3OKiRX8FJrppl4yHTnDSzZhAP3HMFXTQQ7uXMvNWU5rcZThHdafwDH-sYNW8RGeQvU_CjoOFW5CXaIsldxNguzkRlPYK2IU06clrYNsNt2DelU6N0y3Ke4gDjiZxZvRQ1Zu26OEX34B6Llbu99NrRAQ4j2cP6bJjxictqXbzzsP0EmDBLjJCGWhnVRQmQ_IL9AYyHFQvzgcq2MuoTRQhwTXyCGh9l1pe6q5IxzBy37LT0frcqeGkVsgQZdpBlwKSTbPBf5HfNRkEjAWN6wl2AhQZ9vTlywzroUhEBU6jg1gSxyB8Z_3mPuHIioRBUJmSl4zpbg_OL5DZmqbmTWUkb_E96VD0SnjFGJF8nhAbVYZMc-eYUTPGM=s736-no" alt="" title="Album Stream: Queen &#038; Slim Soundtrack"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/17/album-stream-queen-slim-soundtrack/" rel="bookmark" title="Album Stream: Queen &#038; Slim Soundtrack">Album Stream: Queen &#038; Slim Soundtrack</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/17/album-stream-fred-the-godson-god-level-439/" rel="bookmark" title="Album Stream: Fred the Godson &#8211; God Level"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/DT0FakNVCC0LBsSEDm7y4ow5HIwq_cZAFsq09Y7F2VNaOUostVJVxhIG3Hht5aQpWRzKSAA0q043iqcQKsPELu7KNQuDBkfAH8crlBkQEr2uczCgCLVv6tZ0mnhAM2YEq78_deOb3m6ihOtIyjPljuddNUVKAgCYTiQO48Hw5pqmHAmOXnV8g5Kcw9TsWtQoeQYYoRttng1QgVkd29L2IratUQi6U9lakzxlstvzc8_ETOgWpJsxSksLRaoFVn1_qlcnHDoJ3kVkjnn-Znds6YNvRT-ZG_SvWoBdqdmSoCmwHrSEKoz7Qxi1BPXkzGnJx-psfPh3hJH6tVvkNw-iXwdhck446Oja8sOc9URbTtnWvp6uqph-YW4DXABHuUPWh-P2l-OBdL1ie-BjkYFCC5AfYm_JJZokWYRzKX65-_is9lS4NCKFo6LwJJpRNoP1s_Picc16-zntVkuqiB-f3Wad3jULjrgfTZVqnQXlyhxcptXAPxE_XsqBTJSbdqmoqCZsfdxkx75ZG6SphvZcIC6C1_vJHtQZQkbVZjHvo0Vtsz7kmnlclCF1jXbHhvZIIYUR6lBKRJW5qQDJTGPV-fVns8DJoOIpEZ-oOb8vQ00VNHv4Sk0kNbUTIvKEBuh84QOv2nykdSxwyNrMTq9Fqrwjn8bsgKF6xHmVmOz2KuLJTkoOAJ_1iley=s560-no" alt="" title="Album Stream: Fred the Godson &#8211; God Level"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/17/album-stream-fred-the-godson-god-level-439/" rel="bookmark" title="Album Stream: Fred the Godson &#8211; God Level">Album Stream: Fred the Godson &#8211; God Level</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_5dd73c227f411" data-td_block_id="td_uid_2_5dd73c227f411"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_2_5dd73c227f411" data-td_block_id="td_uid_2_5dd73c227f411"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_3_5dd73c2283bd9_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_3_5dd73c2283bd9" ><script>var block_td_uid_3_5dd73c2283bd9 = new tdBlock();
block_td_uid_3_5dd73c2283bd9.id = "td_uid_3_5dd73c2283bd9";
block_td_uid_3_5dd73c2283bd9.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_3_5dd73c2283bd9_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_3_5dd73c2283bd9.td_column_number = "3";
block_td_uid_3_5dd73c2283bd9.block_type = "td_block_mega_menu";
block_td_uid_3_5dd73c2283bd9.post_count = "5";
block_td_uid_3_5dd73c2283bd9.found_posts = "2539";
block_td_uid_3_5dd73c2283bd9.header_color = "";
block_td_uid_3_5dd73c2283bd9.ajax_pagination_infinite_stop = "";
block_td_uid_3_5dd73c2283bd9.max_num_pages = "508";
tdBlocksArray.push(block_td_uid_3_5dd73c2283bd9);
</script><div id=td_uid_3_5dd73c2283bd9 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/21/music-video-alicia-keys-time-machine/" rel="bookmark" title="Music Video: Alicia Keys &#8211; Time Machine"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/Q9nmAbQTToWrrh7HwA6dMpUo_1nhnCNujuilc9OHyIeuD_TPen1LJmEfF8lAXDKQOxyP4BKhIE2k3TJAIXgKZO96aToehNj05axUAEuTFIaKFMkyweROZ9EldPKFqDHwrIvEesi3J2jzU04aH1m8SVcUuigujXFYpdxgUUvwd6D4dnAlSBqRZLQ0HSRMnfnNgNpiOL2tNB2stRtLKbMnQn9mg7BKbGsBS19HZbEo3oFHcM6O3QHMfuvGuQqztODn_u6AYgoNqit523tb6SKmEkS4BZaIeeMo5s2765OnffmuTNBj9qDXe-W-h1rppQ49mLobPN0dNvIpqv3qNdYpuXGWkjt2js-7Qr6v709zLtcnkwKtUXL1V9AgyPKPJZ8pRMDmqdwIeM4bA3EG-sWOBhlZI9W9e8g7a9-6WrEJLPOdMbqbwjG5TNICs_sJYTb0s3N0I-S4kIeE3a4ijiSFXZyMGnM5369ZrQJf2UGuFO7JRd-yhBtt-owCLKZ0E0VuvUWXV6HTKkd4Bedix6sgAYf9nSCTYjExMkt4inulUeuCzmxskfTAOpN34BIRDe96CWh7zhZpm_GdWz0mz4y5NyaR0ENs9wTARo3cLvAVV3nP7AkM1LgN2hZHxpK5Y2gbMe-X7dArE24pPg1mj9DGOhMOLsenoLlV3QdUVV9dgHsHpoGOavoHZ5f6=w350-h220-no" alt="" title="Music Video: Alicia Keys &#8211; Time Machine"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/21/music-video-alicia-keys-time-machine/" rel="bookmark" title="Music Video: Alicia Keys &#8211; Time Machine">Music Video: Alicia Keys &#8211; Time Machine</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/21/music-video-denzel-curry-speedboat-84/" rel="bookmark" title="Music Video: Denzel Curry &#8211; SPEEDBOAT"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4oPeDhD6ArmNmJgHy3ybrBjkGi9Yr9pNm0CTtKl_66veHzkC3vFucFwNa4MVLwYuKzN4SdIhHO9jC3CQ827-SJXCZEhR5FZKNoS4kao5Yh_nTM4pzwZ2CvUHKEE5xERcek5amjruu_u4RkRdmWPIl-Eg6QbCYa_cEyT6flDydHlo6YKZSWqeDtr1yMRFJRWEytowvfSjzCH6OTFLDWOwh02v9YXC-W3o6tFDBKO63FAFS2s0PJtvsWcNsMeqyj3tICok3V8_QWOEQj1adtzjPilBdb4myV42ENlFecpXbV9PLhhBfHFOOZ4S0Y_OCQmMtpUdW79FC4qv-6HQirF4Vp9W5qX3OBDrzrmHwTstE3GLyIvWDgOfI7CZE5Zg3wfhXmA1mmVlmctTfNGOCmbTIK4y5gBPuVGsXOQx9w3phKNLYcpnReKDZq5KgKuMUbaPm-g3q-v2_1Hmb9cKdXv0yWlAKHpgWZTDRbj6NodCGXkY6dSqIORSI_w6RnFk-ZeApdFWlnhLMj2TfpazGODYiFtz30jiFn48xCzFA4cajrmObs_VHUkMq02r9FW-8ogaMVUP-xudUB0PoJEGxbKQt1lZJuKii2-sw_HQyETmzimd2xoq7nHznPB8UptsLz0o1d2efVNkHS4ZxM8-bM7hGz_eqKPmCXqoYfUcqK-DT9Qm8qXS8RJfQr1b=w842-h476-no" alt="" title="Music Video: Denzel Curry &#8211; SPEEDBOAT"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/21/music-video-denzel-curry-speedboat-84/" rel="bookmark" title="Music Video: Denzel Curry &#8211; SPEEDBOAT">Music Video: Denzel Curry &#8211; SPEEDBOAT</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/20/music-video-aap-twelvyy-bill-collector-3/" rel="bookmark" title="Music Video: A$AP Twelvyy &#8211; Bill Collector"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/mkGagyossHxaaCzG_f2zlYbIXyDYvLzLaFGI8w8-KUzxOgZnir8RSZnVndh__L6L5FpKj3QGOECIzR0teY_IfRLdP1TeYGCiK1Zslv7VvGPBuFPBU3_Esvi_qgpBqrVr4nf61fkN6mlw8gQjT44xmo028dRDqYk22IUc2v131BKbCFpelQ2NlXUdgerfh3U7Ip6k05YSOB5yCEJYV239u9FA9XJee4y053h9Xh88l47LnbCdPOrI5PgNm2Upi4vTJTmrj2UERf5oSwCDin56xWMLoO0qEaKHcHTB7RVFhSZjSYIhDvx0udUFFnzPqtRkfVmO7xfeGj0w_mJxcfynQNoW1Cfu6j3E9DBlo6B5Naz2gtDA3EkqLa86xHaSE4Z0ofyZcmAbPIr9kKJ041vggC0jCh83fgp2RNQaJiwkmOcwW7v99BkH-9IqEpbu7LeBctBJisOcPD6CwuNl_leHxP7LYDMoGz-lceXdnKZebmTYMV7vHQXI6In62083YQIBY4fb2NXF7ngQaOin9x8TkGvuByE_M1jRvc5Rh13OY20ayovZwizFgKLJUWHO51b6pymUf2YOccCDooKRrwcL9LApAadzEjbmYAfQVMNWeIVrI_ZysTknlIDzmLXMsaFjTinTv-PZI8sk7r-D0biaeHNkIF6-M2hhgN0hga4o2yv_X0Mupc024Dfl=w780-h474-no" alt="" title="Music Video: A$AP Twelvyy &#8211; Bill Collector"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/20/music-video-aap-twelvyy-bill-collector-3/" rel="bookmark" title="Music Video: A$AP Twelvyy &#8211; Bill Collector">Music Video: A$AP Twelvyy &#8211; Bill Collector</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/19/new-music-freddie-gibbs-gat-damn/" rel="bookmark" title="New Music: Freddie Gibbs &#8211; Gat Damn"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/HECVeS7qc9Q3ceo5rY__KZkfKCs1wCT1zL68FW7vDeHEn0_X8F1J5JFmS5GG9FneD3v3-j2nICkIvlpdw3Kkn_jCr_lAW7RZNzzD-U-84WcScbNnx1XuTiuzKFuworWbYJZTCgcEPdEV5KsD9jyl6ZGJd4TvEg4kfz1r-C4ewIxonn4zVblFGhjA06iuLSuPSDbwmN7naqOlZlBOBcqw0iPtydwtLJ4UOdUo9W581Q_mw-Ftioz6MyHXK25LzBsUT6E2q0S2grMyEW8a9tSowS6VPOO-TE-t1hgTsOtK87wNT2dkNqdXlz-14Jst1TnsolgLJD5QB-Hlgrv321toS3PbJwY4PfelFH3htl0ciXvbC4aUJCe5oR386-73SqQeORMQSrZrbJGB4lvjWogNFlU49eYcV6khzXWYdNxIBE0WzFu_pURNWfeWyPF5mbCh9ecgx-D_xedGOhgoELABtiVfcqinuw5JB7dzvwCkN89mfzk_z-94ekpqYYEPWMkdgpfVgPbEyewJcPalbrcRPO030oP1L8jHcm26f8-5LlFC3p29YJ-wTayXMo7dPmNVkS_pVmRmUgLg0Vql0ncrfWucNhcq9zvQ6TXg8zkgs9QR2juCgKuzV3CaQ30frGNu6xAOKUHS1-bE4O9J8NqOcYRO2Ob3z-Qn011Qd3n234i75rQEeuT2U9mu=w700-h394-no" alt="" title="New Music: Freddie Gibbs &#8211; Gat Damn"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/19/new-music-freddie-gibbs-gat-damn/" rel="bookmark" title="New Music: Freddie Gibbs &#8211; Gat Damn">New Music: Freddie Gibbs &#8211; Gat Damn</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/19/music-video-lucky-daye-karma-8/" rel="bookmark" title="Music Video: Lucky Daye &#8211; Karma"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/9hyMZFoDtITKQxjYEtiSnTUi30zV_IUmo_V7Jr829SFjH2WeOQg-LWjCwIUXJu-TgOcwb4B6iDZz1H-gdNd4a7t8xCIsReezlx_J2fDSGjDvG-UUZUZtGXzZZsmbx--MbxClRCIAO0p7QnWZ5wLuUdF2zu4eT1SSQUciK5UIycezOPtjQnxuQDcsfp-tTzbevrj8yhBLwc_1bDMNHCMUuIhdL5TA2jjg0IMnHORY7eyOEtV5AlEpU_I0WawQCy5QQ1ndcXpac_SrggtuBoOzlkveq1OVXn_IjqyQrM5SWQ3V6QipvgMGZ8NQ_HU7UtHXtzIrIEdGsp8cYCUZP1z7efDNZKw0LvAkPN4yFs-jVnY_CkuG7P7FhMHLMB00to04REYcHbtQNkPyJJ2gjKcw4NvnY29yK5B8z9zEYy90F86BeXbp0lC-xopKHVWZUjueCTK8ouN094C62WQ0gEq3cW98evsfm7pljsSDpKWGkhbf3bxDwnLfz2hK9KOer5ji837vw0uensBKpxSyIk0bl0bG5znmWnfvEEaB-C8SC72a0gz3w8l9jyCN5t7-pFq9_HGIiMiZwiLeR4TZKlWE0pPKTS-0QFsHIrdD5CPXAzUrahi0Fq84ee-XbeuTA7WtfvIe4BJbOgb1WulEEUUKUDtcU5T9KJmt5rsCS7ohPRP5looCofNi1TF_=w690-h524-no" alt="" title="Music Video: Lucky Daye &#8211; Karma"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/19/music-video-lucky-daye-karma-8/" rel="bookmark" title="Music Video: Lucky Daye &#8211; Karma">Music Video: Lucky Daye &#8211; Karma</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_5dd73c2283bd9" data-td_block_id="td_uid_3_5dd73c2283bd9"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_3_5dd73c2283bd9" data-td_block_id="td_uid_3_5dd73c2283bd9"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_4_5dd73c2287de8_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_4_5dd73c2287de8" ><script>var block_td_uid_4_5dd73c2287de8 = new tdBlock();
block_td_uid_4_5dd73c2287de8.id = "td_uid_4_5dd73c2287de8";
block_td_uid_4_5dd73c2287de8.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"29","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_4_5dd73c2287de8_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_4_5dd73c2287de8.td_column_number = "3";
block_td_uid_4_5dd73c2287de8.block_type = "td_block_mega_menu";
block_td_uid_4_5dd73c2287de8.post_count = "4";
block_td_uid_4_5dd73c2287de8.found_posts = "946";
block_td_uid_4_5dd73c2287de8.header_color = "";
block_td_uid_4_5dd73c2287de8.ajax_pagination_infinite_stop = "";
block_td_uid_4_5dd73c2287de8.max_num_pages = "237";
tdBlocksArray.push(block_td_uid_4_5dd73c2287de8);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_4_5dd73c2287de8" id="td_uid_5_5dd73c228a1a0" data-td_block_id="td_uid_4_5dd73c2287de8" data-td_filter_value="" href="http://weuponithiphop.info/category/latest-news/">All</a><a class="mega-menu-sub-cat-td_uid_4_5dd73c2287de8"  id="td_uid_6_5dd73c228a28e" data-td_block_id="td_uid_4_5dd73c2287de8" data-td_filter_value="69" href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a><a class="mega-menu-sub-cat-td_uid_4_5dd73c2287de8"  id="td_uid_7_5dd73c228a3ab" data-td_block_id="td_uid_4_5dd73c2287de8" data-td_filter_value="80" href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a><a class="mega-menu-sub-cat-td_uid_4_5dd73c2287de8"  id="td_uid_8_5dd73c228a4bd" data-td_block_id="td_uid_4_5dd73c2287de8" data-td_filter_value="2189" href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a><a class="mega-menu-sub-cat-td_uid_4_5dd73c2287de8"  id="td_uid_9_5dd73c228a5d6" data-td_block_id="td_uid_4_5dd73c2287de8" data-td_filter_value="10" href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a><a class="mega-menu-sub-cat-td_uid_4_5dd73c2287de8"  id="td_uid_10_5dd73c228a6e8" data-td_block_id="td_uid_4_5dd73c2287de8" data-td_filter_value="130" href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></div></div><div id=td_uid_4_5dd73c2287de8 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/21/video-rapsody-funk-flex-freestyle-7/" rel="bookmark" title="Video: Rapsody &#8211; Funk Flex Freestyle"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4Gmebuwu1nNbedKtt1Khp72nr4EYg8FRqvQjYTFGMwXYxwqEbApRFvVLasxUGGWV7rXfTvI01jID_26Uc8nH70EySrh_tYwm9C6xwsosRbe5IUHGE795D9rBnv0cD_PdAU0FYnEHJNmPyWZmYWiDI2ic1RqB4Qgt136MPLZNCw3nfBQGpLGDVd4Wf0hE-JrETf6SuXrW_-xG5-XdXMNW0hg9MVK_r0_7kLHG_LGlnhDbgLNkJ1VFM3DmKamw6A1ElqSr-fnBFxdpWRyL8kZmEwxNg_ugcr04kLtOtVem15oj1S31QUIj8omV1U_yBrmZ1fL7X6xcr8taBdHw6giOSIQN870qqWWHjK1s04U1ixb-IOgj6558Ixy3AO8xXtuzvGvnwG3Aia71wbGMdcb-UlZC9mDNVvCqCkSHm7zyK6nbtRcx-_Es_XLhycMTmmbiOdb7xQn7O_LjsfTsz-MXGqvL7GuFP7OB6fsrN3k3wCbzT02x8jO2oVDFry_uEs0G4oHJ7zNKfaE0_mXNbt4zBvybGl6k-VzDDzkQ8gnwvyBavV3ikAXFnuJphp7F53MnIfQXTmYUSNA9WNWI6hr62tPD8B1CLAgXb_1evTCZ5u0S-uS2uestsv6MzwydeKGeC1r15vwXL9LxplebVHKY4Fe8fuu9ObvOD5vpzYJ3Pv9wAHRjAa6TwnBz=s328-no" alt="" title="Video: Rapsody &#8211; Funk Flex Freestyle"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/21/video-rapsody-funk-flex-freestyle-7/" rel="bookmark" title="Video: Rapsody &#8211; Funk Flex Freestyle">Video: Rapsody &#8211; Funk Flex Freestyle</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/20/2020-grammy-nominees/" rel="bookmark" title="2020 GRAMMY Nominees"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/iJjbZI0OwM8O8EXxzUEo3VCZZOSRrCNoiUsq7ZdR5doxrfa3CS3MEyO_jcJ_2IMmlBqjawx38GBIbQc2AuDcBSdeHux4RvoA-xW_L0Vux7Ivzt17AvM5UkNGlnSTv2SsUz_OAU_kU0rpXR5E8f2N4lVJ97Nni2KNrpQIFDhPFOe9BZPIrLu8xCnR4vXivRC5qYEkFjyD2mP2iibtPxIo-XhOthEwWvopol_biDzUUUvbmjKgvmPak4fU6PlhsSshtLNUZ7nxh-RLQmBVOywdcKeDHK8PRCvqsHNSLDGyymUEh2-gDHBCkh7JytKZnWhzfCm3BM5o_5Np6LmrIrOYRH7F1w5DyFJtfxeDp-nfnai5J1GWTgUYEjVicLqVA2zqVaTlPaZ3V0o3eoga293ewxjtvTOtMK3tJkrta-B8rgmqiT0Bu5pFchVzoZNL7VI4_3pKvyVW15Keh9kjujMa_o2fcvbB3oYIolYZ1yk9jrpuoACeCeuKJBNxnFbCmS6KfPmBzAGERY8DIX0wa9X8QThtNVH8xd0kV-oMVNJJz_QCqG3IkpCE48CbsPKopSVGHMhGptaHvEpwclN91X0PNyROgr3DxP_VdJ-U7BUhpKl2IaXNc721bkNvtu6TjEmr981_2g1N0j3jvLe8rxJdefanW95wFzkRwxmA21AJP_uJ_XRaKhcA1luT=s500-no" alt="" title="2020 GRAMMY Nominees"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/20/2020-grammy-nominees/" rel="bookmark" title="2020 GRAMMY Nominees">2020 GRAMMY Nominees</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/19/the-game-born-2-rap-artwork-tracklist-revealed-49/" rel="bookmark" title="The Game &#8211; Born 2 Rap (Artwork &#038; Tracklist Revealed)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/L6Rs_Tn7PVDBz_JZpMNyBK5fSM6eGLWXOTwt3mzG7cdky_4ja8u58AUeF97Fqor22NyhIlsa-gQDTeqZnyA4-k9xdcd99hqGI_pqeoxdYHQKaDCGK-3NtbNbEyig2oYOYiGWF2ozGj7JEEWL2TgLs3w0fNxGrFGlhjX9Hcb7DqIHJ_cJrBvlFCQ7P0nedNvlSo4F3U4UIgEeFCl1Pw7zuqkRM5ULNkqlxB4YV4193SxCJ6xmc4O0Cqng_nx69Ys5eFBI8lx2x8T93mTDmfiQUNI4996Uq31HOl4PExKExxNRLQzBVwI6k1U-jmFPGDizLgRpHCi1bMwSD5KHji9KeBQFNFZ6o4YWQwHmSdDOVFzLfaHp1P5iqr7Tcm3CvmBTmA_-uWop_YHwKyLheYqfMdfxIDSO24g9H8EKXt255HWdJBbnNrZQ5FSxAqkg3EoLS5_o1WIAMtj8ACBS73g-DE6MlI6GQQ0GwjKzmwgxkjVzz2KwSiApWasHJCIOK8_XF4UlZjLTPVkhhEm7Dx1o0x5ncekhBPhp1atXmp8I86UooEq68dRC6ID6tqe_5PcChiMz8cslSIbfyZx4eSVm7Rj4esLuH3FRWUy3GMTqsnJaxss-ifCngoK7rSx12QluQThgPrE6achPP0HDU8AAqFb-nYVa2lj7uvJQjrMOaXO8tT2iWqrkNxEp=w597-h596-no" alt="" title="The Game &#8211; Born 2 Rap (Artwork &#038; Tracklist Revealed)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/19/the-game-born-2-rap-artwork-tracklist-revealed-49/" rel="bookmark" title="The Game &#8211; Born 2 Rap (Artwork &#038; Tracklist Revealed)">The Game &#8211; Born 2 Rap (Artwork &#038; Tracklist Revealed)</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/19/video-dave-east-funk-flex-freestyle/" rel="bookmark" title="Video: Dave East &#8211; Funk Flex Freestyle"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/uo_FC7BTYXGCUOE7pE-AhCa4pZqXLbZMqsjhrxIbBEhNHvo0BBj6wBxaJb20wuykl85UxSWhcXlIZXfYdH8jS3bu5BV0RGjXVKd5DlBxCzmTwzKu_hrJZL_cqXFEYxeY1G2qEVjhxxs1CijUXVPVf0mX3ZivVgwPX5pxI2rfDu-FuiuY-PpBoR3lNHAMjMLvHyk2VmcLRX_pJM7U-YXzl0RJx2fw3xOZyzphr9ZMSo2VMagLjWGlvblep_lGW485X_tdhHTppH31HrKrjCb6ckC8RUn4xWwfhpJDdi5bcTC_3VZmJ0YMx2OkmfUX54X3FCfS05ZlOiNHiPCg5ooqACUu7htuYugq1b1zONrmT1L09dcXYpkwzF-LFnd_ATFHWOCxYgv01RNq4m16pfhmAsHhP8Pkmc8H1evp85b5zNArCOEYjuHtsmWblMjtau_x-q1TYBRzWhh1j6M44z9NR1JU6SvZd8sOTL0oCUp4TeKZad7zw8UwNLphbgTwxs0vWIX7clIf7ed9cZiEGyWkmljpkTljxBYwU2GOnRz0PENhB3hTNJOztTKSsL3Vx94LOxGrdKCt0XVuUBufbZ7MKeLdZ-CXJt9JRB4BsPd3RziEE-i0Him0UA5ygsaiyZaOTKtzZDYfGn4wJ9dNmzX3_5itPFmu9GprtloA9bzhJXX_36_RF8yQU6a-=w826-h547-no" alt="" title="Video: Dave East &#8211; Funk Flex Freestyle"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/19/video-dave-east-funk-flex-freestyle/" rel="bookmark" title="Video: Dave East &#8211; Funk Flex Freestyle">Video: Dave East &#8211; Funk Flex Freestyle</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_4_5dd73c2287de8" data-td_block_id="td_uid_4_5dd73c2287de8"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_4_5dd73c2287de8" data-td_block_id="td_uid_4_5dd73c2287de8"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_11_5dd73c22a26dc_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_11_5dd73c22a26dc" ><script>var block_td_uid_11_5dd73c22a26dc = new tdBlock();
block_td_uid_11_5dd73c22a26dc.id = "td_uid_11_5dd73c22a26dc";
block_td_uid_11_5dd73c22a26dc.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"77","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_11_5dd73c22a26dc_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_11_5dd73c22a26dc.td_column_number = "3";
block_td_uid_11_5dd73c22a26dc.block_type = "td_block_mega_menu";
block_td_uid_11_5dd73c22a26dc.post_count = "4";
block_td_uid_11_5dd73c22a26dc.found_posts = "158";
block_td_uid_11_5dd73c22a26dc.header_color = "";
block_td_uid_11_5dd73c22a26dc.ajax_pagination_infinite_stop = "";
block_td_uid_11_5dd73c22a26dc.max_num_pages = "40";
tdBlocksArray.push(block_td_uid_11_5dd73c22a26dc);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_11_5dd73c22a26dc" id="td_uid_12_5dd73c22a411b" data-td_block_id="td_uid_11_5dd73c22a26dc" data-td_filter_value="" href="http://weuponithiphop.info/category/fashion/">All</a><a class="mega-menu-sub-cat-td_uid_11_5dd73c22a26dc"  id="td_uid_13_5dd73c22a420c" data-td_block_id="td_uid_11_5dd73c22a26dc" data-td_filter_value="76" href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></div></div><div id=td_uid_11_5dd73c22a26dc class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/LVT4Mid8WL4wHUdO9X2OZmZxxgbREs2lVtszOdEBaO6hJB0JS3yQOAyhNSdCyPmv0amBDTgNGpOlRPXPjKCl6yIlo2joyH3rQRI7CUdX09BJtQI1r5jy1_7BQtDhw4AxUhpUwIh35rNS3lTy7uq-FdPff10JN6srr9mwZ7zr04GQFxBVEXwCfC5rNVehXhY_wGCRVsmevYmdkBWEmB8dvOzBHY78NBBjcHNArS_S-2M0FJgDh8v9m9vEh78k_XmZg-AERctsf0bkODuPi1EcNJq_RnJIV6b0GG-VtKjo-OVPmYghWJYf1HiP9c58cQ98oABU8BDFdLqsBtNt4K0NmyHYQlX39W9k_d83wEHZ1-EacQa2o01VrYSn12HnZ1l88fMzu9PKv6EGmcRZNwpepycW7_9EQnhxIPDdVCmRLXUasUED9OXr-zJmnBcnSnLCa06k1ZymQym1LiSFEv1c3aPHnmnD3GY8nL7q5jPJr4HsABR0WCqMebcF3HF_0deNd0zgRBCGMxW-VzlIIHZiHuBeSPEPvUL149GJ5swSSvKm1uGEi1HlLBj9omJSU7mDWzO0p_7l-l7-4_ureEsGsgB8cX1t8t2TQcFeRgqqF1CXlZFYYC2K0iMb4jPsijsw_rtO7pmKvbngqHfgYpGeh_qLmDWeicR7=w1195-h796-no" alt="" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch">Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/fHEwwMf8DoiXlqkfibQS1Z1XXbviORbV9raaI44tOTXrWo7GgqM3gA-vswE10gFtTQUGGwNG7nWAACwHjxPuiubliYBN_dqtBZh2WIpxvumiJ-hSLK0TNWB2cB8Iw2STT5gcp_KqlDh_e4xng1vidI8EXdp_ooh5uDI-JV1HQ9dGnM5nxl_b-v8znqj-Rl_mGB7y4Lu9zsFNWHU7SriqQQJaKrKEEnb9T8zxmGLaL0zq7ilYpnUEhWulDDr9xc82wdr__WzRBm5YEskVpDAnGM2NDZwTZpjbe4QDdxeixWnSXNK_oDzaL7WTbCpkD33OK88BlI5JmFRQ5VmD11UQ2htB7-9WoahHvb4XmBsbLXpEMl1JmEP4sPx06VduzFnBNo-J90WI0n1AEIIcEYVbRywrkGJXbzmH__In9ZIg0EV24OcGGbeKl12HxTdZwucqsNnuZeNjiMHISQ7i8cfzm3N7X7Zenl74zsKIKeKWoIGxh6MTlVADvgHcrHebnjcSgil2vBeFyz_AP45aOv9SOwbzfVLGS0CNfe1s9b2J7qZgjcBk9QPEXCl2kygvzmGXFvU_3xBuW6S0i3Vkh3Ha_3hPBtvIAy3WoTK2yiqS41HzSK7yk3FRAlBtpIEib338fdkTiosBxtdu36SdNUVM75zl6CVIFhTu=w681-h470-no" alt="" title="Air Jordan 14 Rip Hamilton"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton">Air Jordan 14 Rip Hamilton</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/kUjaOYxjEkAh34S-Ub2QSZwdOwHyFnGFLBZULta3_bn1_myPMAwJXiEEsAAtc1ktCQwHCuKhSqSYsWXFBEIZxdfKuykoDEZWwO-dDI3_JeAshbYvyILEHUu0XaUpRn0mj7gOx10V52t8gRGYPCW7QXGImkPGGhvBPzBDVVqh9lKGtkuPeePmTnpRSmwp0LG1WHcIzUWnMqPBWQeHAat6Q-Tq7niXNb96ddEZsMEdHK1nmHVlNaeqFBNtTxk6yYRkFNCvtfBayqy-Rqt4CPU5tThxbTI4AIUCI6JLxJd_VJizrVNDEe2xZ_tiQdkC5ASIoHpX8sfvAB8zRUsMVJ6oMUt5FH_4GBNXDCtFRmr65Qt0JV1h4bBJffu2L272Q_vpD76wn-YNGW8VCtZcheHu_X-A4gdYQEC0HN0BenY-MOuUBqKEjXAc0SxWeP7W9RN55jlqUFK0nzEYydVjec2stdQIngVfg_FvKxvHXfM4XdtMpqeJnp3Pzyk8xjz30sAZd0f2HQ6zfdPjk-OkV2-WrC0_qW0L8Rq3zrUbq52n3BN7gm7sctU_CUlBmoQIgJDQBYk1Siv4tfSq9pL1R4GdaOlWQdxEuhZi8bTYC8GGAgNGl3SMAZGvk7nu6QnnwEZjZ7mZwbcqgyRKa89cOREMUvIkVJ8Q8lZu=w926-h672-no" alt="" title="Jordan Proto React Triple White"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White">Jordan Proto React Triple White</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4cDUjSODZSaXWfHyZKb9q3Fn7FHA4uB0KSBs0MtFHC0dc6AJb1zeAl_X2LOKalK9C7VBFhTqRQ9fw1ESgUr9ZUKFbOzD94i_s96nvkICOqrsYnzrE2nEAQHoEaGOF4O8GAI6T4CGFbgcQhNzjpRlSY60NyPu5Cmq81FRpEOFRzTOtSa_NnWzMmfwO0yxtPbcg5U6YBUsus8shv3SA7CjULLfaP38nZAuWVgq8PMaaeCQ_eSrK8NJSEVQjyyxmqb-1I7zO8Kvvzvwi--ibMr52CF8h-GusBzSq5ZuzvZRCGu_u8CyfoXw7pwWbOmHnLOdcQ9d2PCSW_IxEMGfmEuU7NxMSsW3Ga4r35_wLB7cjvlPC9OjCV50tfekXjZBS_476mzlf4G9jR7Ju1GqgjXah9Uqc_0Y8N-Br8_JCtIlRSuLxAiebwd7AvFVlgWId9MYxBWnRT3cTyD8SH7q5WwO-CIbKAOSKsNcrrTgFxQvqn9yklBU1u5X5fdTlTBk4WSYorsWZAug0z9BOymRLnrhTbnA0vpBPFROWD-aL1glg-eUpFSfgD4xhWsOqJNY9krQ2UbLSGXQ5gYWj0ovLS7Yz3UKFY2qrVWpqkpbfyN98es9NJ-7LTUs2MLq1rX_2FaQmyq5mVndd7VGzQOHy9hDULG-5H-0LvGd=w900-h566-no" alt="" title="adidas Yeezy Boost 350 V2 Hyperspace"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace">adidas Yeezy Boost 350 V2 Hyperspace</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_11_5dd73c22a26dc" data-td_block_id="td_uid_11_5dd73c22a26dc"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_11_5dd73c22a26dc" data-td_block_id="td_uid_11_5dd73c22a26dc"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div></div>


<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form method="get" class="td-search-form" action="http://weuponithiphop.info/">
				<div role="search" class="td-head-form-search-wrap">
					<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>            </div>
        </div>
    </div>

    <div class="td-banner-wrap-full">
        <div class="td-header-container td-header-row td-header-header">
            <div class="td-header-sp-recs">
                <div class="td-header-rec-wrap">
    
</div>            </div>
        </div>
    </div>

</div>
<article id="post-35861" class="td-post-template-7 post-35861 post type-post status-publish format-standard has-post-thumbnail hentry category-new-music tag-benny-the-butcher tag-paul-wall tag-statik-selektah" itemscope itemtype="http://schema.org/Article">

    <div class="td-full-screen-header-image-wrap">

        <div class="td-container td-post-header">
            <div class="td-crumb-container"><div class="entry-crumbs"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="" class="entry-crumb" itemprop="url" href="http://weuponithiphop.info/"><span itemprop="title">Home</span></a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="View all posts in New Music" class="entry-crumb" itemprop="url" href="http://weuponithiphop.info/category/new-music/"><span itemprop="title">New Music</span></a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last" itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><meta itemprop="title" content = "New Music: Statik Selektah &#038; Paul Wall ft. Benny the Butcher &#8211;..."><meta itemprop="url" content = "http://weuponithiphop.info/2019/11/21/new-music-statik-selektah-paul-wall-ft-benny-the-butcher-overcame/">New Music: Statik Selektah &#038; Paul Wall ft. Benny the Butcher &#8211;...</span></div></div>

	        <div class="td-post-header-holder">

		        <div class="td-parallax-header">

	                <header class="td-post-title">

	                    <ul class="td-category"><li class="entry-category"><a  href="http://weuponithiphop.info/category/new-music/">New Music</a></li></ul>	                    <h1 class="entry-title">New Music: Statik Selektah &#038; Paul Wall ft. Benny the Butcher &#8211; Overcame</h1>

	                    
	                    <div class="td-module-meta-info">
	                        <div class="td-post-author-name">By <a href="http://weuponithiphop.info/author/cyclone/">cyclone</a> - </div>	                        <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-11-21T19:25:15+00:00" >November 21, 2019</time></span>	                        	                        <div class="td-post-comments"><a href="http://weuponithiphop.info/2019/11/21/new-music-statik-selektah-paul-wall-ft-benny-the-butcher-overcame/#respond"><i class="td-icon-comments"></i>0</a></div>	                    </div>

	                </header>

		            <div class="td-read-down"><a href="#"><i class="td-icon-read-down"></i></a></div>
		        </div>
            </div>

        </div>

        <div id="td-full-screen-header-image" class="td-image-gradient-style7">
            <img class="td-backstretch" src="https://lh3.googleusercontent.com/lI1WF9Jox-Ur34h4mAdXTSxvDHKW71zTpSyanmcg32csynI_uhzYKpKeXG-KkCxyj1nasJvcGoUl2wD2ekfEP_dr_OKmjxLrboF_fK8yxlhog86giQ69eJ0VYfBFuFnrUHeSQ-7Gy96QA-PNM0XoXYTfCK_QxQSHUZolKKPa5Ym5pKIrslvgyX72_xnkNlHCNlFZGeJH4g6uQYpiNGNIRODE246RtKvn8txFhb-jzRfCfR6c01WpFpVeE-0NwzEgsmVIZqPOYf4C5mvQ9CiwTiqnfDKprXHbInGLDOvaa6EGjGWPRBJO6Eum-9FbHmBbwGyPF3MfwsrrUjdHk9MRsJJvbpKjSMSg8glCTDjpNcs9WNVk7sVECIFUkdYcJQWrBN9_6ecSjGB73_VA8BBtSCVWbimNL6mnO8dgoWn4Huel-WvQnzZxn-l_O4VU_EbrFGo6NvGudww6Fsuc5Ynn0XNufziHZL7gSg-PXa0LIatoPwCWESaEZYysAKB73tDEgAyKIqlmimT4-6QK4wI2We7xb689tKaMTqXfcGPs48gtgKqIK8RkUuaWqtXwH9qnyqkJYolvZdsJYBH1WGPNkuQy6ENORZEA8rrs2ju3JrhwkxuI-LAVLKAQvh_o86M5KCwZEhzM8hd24lkxu8LRxW50m4nIPfQ8mCe5UrQQrjq3e1Rb6tb3H_cx=s500-no">
        </div>
    </div>

    <div class="td-container">
        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    

    <div class="td-post-content">
        <p><img class="size-full aligncenter" src="https://lh3.googleusercontent.com/lI1WF9Jox-Ur34h4mAdXTSxvDHKW71zTpSyanmcg32csynI_uhzYKpKeXG-KkCxyj1nasJvcGoUl2wD2ekfEP_dr_OKmjxLrboF_fK8yxlhog86giQ69eJ0VYfBFuFnrUHeSQ-7Gy96QA-PNM0XoXYTfCK_QxQSHUZolKKPa5Ym5pKIrslvgyX72_xnkNlHCNlFZGeJH4g6uQYpiNGNIRODE246RtKvn8txFhb-jzRfCfR6c01WpFpVeE-0NwzEgsmVIZqPOYf4C5mvQ9CiwTiqnfDKprXHbInGLDOvaa6EGjGWPRBJO6Eum-9FbHmBbwGyPF3MfwsrrUjdHk9MRsJJvbpKjSMSg8glCTDjpNcs9WNVk7sVECIFUkdYcJQWrBN9_6ecSjGB73_VA8BBtSCVWbimNL6mnO8dgoWn4Huel-WvQnzZxn-l_O4VU_EbrFGo6NvGudww6Fsuc5Ynn0XNufziHZL7gSg-PXa0LIatoPwCWESaEZYysAKB73tDEgAyKIqlmimT4-6QK4wI2We7xb689tKaMTqXfcGPs48gtgKqIK8RkUuaWqtXwH9qnyqkJYolvZdsJYBH1WGPNkuQy6ENORZEA8rrs2ju3JrhwkxuI-LAVLKAQvh_o86M5KCwZEhzM8hd24lkxu8LRxW50m4nIPfQ8mCe5UrQQrjq3e1Rb6tb3H_cx=s500-no" width="500" height="500" /></p>
<p><strong>Statik Selektah</strong> and <strong>Paul Wall</strong> will be releasing a new <a href="http://weuponithiphop.info/tag/joint/">joint</a> project titled <em><strong>Give Thanks</strong></em>, which drops on November 28. The <a href="http://weuponithiphop.info/tag/first/">first</a> release is a collab with <strong><a href="http://weuponithiphop.info/tag/benny/">Benny</a> the Butcher</strong> titled <strong>“Overcame”</strong>.</p>
<p>Give Thanks feature seven new track and guest appearances by<strong> CJ Fly</strong>, <strong>B-Real</strong>, <strong>Termanology</strong>, <strong>NEMS</strong>, and <strong>Haile Supreme</strong>.</p>
<p>You can stream <strong>“Overcame”</strong> below.</p>
<p><iframe src="https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/716457748&amp;color=%23ee0c0c&amp;auto_play=false&amp;hide_related=false&amp;show_comments=true&amp;show_user=true&amp;show_reposts=false&amp;show_teaser=true" width="100%" height="166" frameborder="no" scrolling="no"></iframe></p>
<div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="http://weuponithiphop.info/2019/11/21/new-music-statik-selektah-paul-wall-ft-benny-the-butcher-overcame/" data-a2a-title="New Music: Statik Selektah &amp; Paul Wall ft. Benny the Butcher – Overcame"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F11%2F21%2Fnew-music-statik-selektah-paul-wall-ft-benny-the-butcher-overcame%2F&amp;linkname=New%20Music%3A%20Statik%20Selektah%20%26%20Paul%20Wall%20ft.%20Benny%20the%20Butcher%20%E2%80%93%20Overcame" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F11%2F21%2Fnew-music-statik-selektah-paul-wall-ft-benny-the-butcher-overcame%2F&amp;linkname=New%20Music%3A%20Statik%20Selektah%20%26%20Paul%20Wall%20ft.%20Benny%20the%20Butcher%20%E2%80%93%20Overcame" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F11%2F21%2Fnew-music-statik-selektah-paul-wall-ft-benny-the-butcher-overcame%2F&amp;linkname=New%20Music%3A%20Statik%20Selektah%20%26%20Paul%20Wall%20ft.%20Benny%20the%20Butcher%20%E2%80%93%20Overcame" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F11%2F21%2Fnew-music-statik-selektah-paul-wall-ft-benny-the-butcher-overcame%2F&amp;linkname=New%20Music%3A%20Statik%20Selektah%20%26%20Paul%20Wall%20ft.%20Benny%20the%20Butcher%20%E2%80%93%20Overcame" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_tumblr" href="https://www.addtoany.com/add_to/tumblr?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F11%2F21%2Fnew-music-statik-selektah-paul-wall-ft-benny-the-butcher-overcame%2F&amp;linkname=New%20Music%3A%20Statik%20Selektah%20%26%20Paul%20Wall%20ft.%20Benny%20the%20Butcher%20%E2%80%93%20Overcame" title="Tumblr" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_reddit" href="https://www.addtoany.com/add_to/reddit?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F11%2F21%2Fnew-music-statik-selektah-paul-wall-ft-benny-the-butcher-overcame%2F&amp;linkname=New%20Music%3A%20Statik%20Selektah%20%26%20Paul%20Wall%20ft.%20Benny%20the%20Butcher%20%E2%80%93%20Overcame" title="Reddit" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_flipboard" href="https://www.addtoany.com/add_to/flipboard?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F11%2F21%2Fnew-music-statik-selektah-paul-wall-ft-benny-the-butcher-overcame%2F&amp;linkname=New%20Music%3A%20Statik%20Selektah%20%26%20Paul%20Wall%20ft.%20Benny%20the%20Butcher%20%E2%80%93%20Overcame" title="Flipboard" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F11%2F21%2Fnew-music-statik-selektah-paul-wall-ft-benny-the-butcher-overcame%2F&amp;linkname=New%20Music%3A%20Statik%20Selektah%20%26%20Paul%20Wall%20ft.%20Benny%20the%20Butcher%20%E2%80%93%20Overcame" title="Copy Link" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div>    </div>


    <footer>
                
        <div class="td-post-source-tags">
                        <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="http://weuponithiphop.info/tag/benny-the-butcher/">Benny the Butcher</a></li><li><a href="http://weuponithiphop.info/tag/paul-wall/">Paul Wall</a></li><li><a href="http://weuponithiphop.info/tag/statik-selektah/">Statik Selektah</a></li></ul>        </div>

                <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="http://weuponithiphop.info/2019/11/21/video-rapsody-funk-flex-freestyle-7/">Video: Rapsody &#8211; Funk Flex Freestyle</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="http://weuponithiphop.info/2019/11/21/album-stream-tinashe-songs-for-you/">Album Stream: Tinashe &#8211; Songs For You</a></div></div></div>        <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="http://weuponithiphop.info/author/cyclone/">cyclone</a></span></div>        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="cyclone"></span><meta itemprop="datePublished" content="2019-11-21T19:25:15+00:00"><meta itemprop="dateModified" content="2019-11-21T19:25:15+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://weuponithiphop.info/2019/11/21/new-music-statik-selektah-paul-wall-ft-benny-the-butcher-overcame/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png"></span><meta itemprop="name" content="WeUpOnIt"></span><meta itemprop="headline " content="New Music: Statik Selektah &amp; Paul Wall ft. Benny the Butcher - Overcame"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://lh3.googleusercontent.com/lI1WF9Jox-Ur34h4mAdXTSxvDHKW71zTpSyanmcg32csynI_uhzYKpKeXG-KkCxyj1nasJvcGoUl2wD2ekfEP_dr_OKmjxLrboF_fK8yxlhog86giQ69eJ0VYfBFuFnrUHeSQ-7Gy96QA-PNM0XoXYTfCK_QxQSHUZolKKPa5Ym5pKIrslvgyX72_xnkNlHCNlFZGeJH4g6uQYpiNGNIRODE246RtKvn8txFhb-jzRfCfR6c01WpFpVeE-0NwzEgsmVIZqPOYf4C5mvQ9CiwTiqnfDKprXHbInGLDOvaa6EGjGWPRBJO6Eum-9FbHmBbwGyPF3MfwsrrUjdHk9MRsJJvbpKjSMSg8glCTDjpNcs9WNVk7sVECIFUkdYcJQWrBN9_6ecSjGB73_VA8BBtSCVWbimNL6mnO8dgoWn4Huel-WvQnzZxn-l_O4VU_EbrFGo6NvGudww6Fsuc5Ynn0XNufziHZL7gSg-PXa0LIatoPwCWESaEZYysAKB73tDEgAyKIqlmimT4-6QK4wI2We7xb689tKaMTqXfcGPs48gtgKqIK8RkUuaWqtXwH9qnyqkJYolvZdsJYBH1WGPNkuQy6ENORZEA8rrs2ju3JrhwkxuI-LAVLKAQvh_o86M5KCwZEhzM8hd24lkxu8LRxW50m4nIPfQ8mCe5UrQQrjq3e1Rb6tb3H_cx=s500-no"><meta itemprop="width" content="800"><meta itemprop="height" content="600"></span>    </footer>

    <div class="td_block_wrap td_block_related_posts td_uid_15_5dd73c2503650_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_15_5dd73c2503650" ><script>var block_td_uid_15_5dd73c2503650 = new tdBlock();
block_td_uid_15_5dd73c2503650.id = "td_uid_15_5dd73c2503650";
block_td_uid_15_5dd73c2503650.atts = '{"limit":6,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_custom_related","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_15_5dd73c2503650_rand","offset":"","css":"","live_filter":"cur_post_same_tags","live_filter_cur_post_id":35861,"live_filter_cur_post_author":"1"}';
block_td_uid_15_5dd73c2503650.td_column_number = "3";
block_td_uid_15_5dd73c2503650.block_type = "td_block_related_posts";
block_td_uid_15_5dd73c2503650.post_count = "6";
block_td_uid_15_5dd73c2503650.found_posts = "53";
block_td_uid_15_5dd73c2503650.header_color = "";
block_td_uid_15_5dd73c2503650.ajax_pagination_infinite_stop = "";
block_td_uid_15_5dd73c2503650.max_num_pages = "9";
tdBlocksArray.push(block_td_uid_15_5dd73c2503650);
</script><h4 class="td-related-title"><a id="td_uid_16_5dd73c250a45c" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_15_5dd73c2503650" href="#">RELATED ARTICLES</a><a id="td_uid_17_5dd73c250a49f" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_15_5dd73c2503650" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_15_5dd73c2503650 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/18/new-music-styles-p-ft-conway-the-machine-benny-the-butcher-blam-blam-blam/" rel="bookmark" title="New Music: Styles P ft. Conway The Machine &#038; Benny The Butcher &#8211; Blam, Blam, Blam"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/ssJiDkAMFIanwqcrhbj_D4bc3YTtCjYZazj8SGiseeT0SCDFKLP0qEEBR7Ph5RFd1nBWqLcGygXNcnbw64D_cfCElJXMgaIdGz3QXjDFdtJipQGNd8Dn3RYWE0qCBShgAqWR_C9hk9Rdoq7GVxEQKI-fD7gx-bvPQPJAFMPLjvxSHpR9KQOHiQzIBBy5hzOarpGOnAfVBYqYBCIv8NeiKz-KMVs0H1nXdtHqWwSOXaDG9ZzGv4OKCzmJiUhnODG_6NJO2Oo_52E4FCIAqoO9kev1G7cWXUbRxpg4emEX-0IhAWV8eS3jELlZhzbDYuT00ritJoDF_-Tugfjr3rdbxRE01m7ifMEa19_v7qi6hRQBLM-sw1WKjFub4lk7kyCCk4XXlNjsK0laekbIDnhaoGZJQ9IozT6IsgIib63Io4Xdb9AVRhz4xU7XIAkesQB9srL3N8RqENcYb899jBPdK_VyAKvdTGsm45JxWcgvwtsQXFI5mlzevzlQJLPt8nyv7QBazB-hkX_L0ofwwODldlOIMt3mffDnuETjvzXgg_DdQQmMTiSLsAEV8bD793JrzVq2ftQpcO2FoTm9CZ-dgEjc0uXj18hoT_DtoTfPRuuBd04fZ-kuFYMewAV6ZA7uFseabWviI4BOMul-6i43KJZrElBvf8GWNh0PaoWVlayP6Y95j3cvjnoS=s640-no" alt="" title="New Music: Styles P ft. Conway The Machine &#038; Benny The Butcher &#8211; Blam, Blam, Blam"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/18/new-music-styles-p-ft-conway-the-machine-benny-the-butcher-blam-blam-blam/" rel="bookmark" title="New Music: Styles P ft. Conway The Machine &#038; Benny The Butcher &#8211; Blam, Blam, Blam">New Music: Styles P ft. Conway The Machine &#038; Benny The Butcher &#8211; Blam, Blam, Blam</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/14/new-music-fred-the-godson-ft-benny-the-butcher-38-spesh-nokia/" rel="bookmark" title="New Music: Fred the Godson ft. Benny the Butcher &#038; 38 Spesh &#8211; Nokia"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/mfAvooXkfNw4uLfrk04djzQSKy5eojyB75lO_DeVR8LlcW0r9ijP7-10s2yEz8-G_QjRzLt63zk8gTQZHKkBfzHX5jzCWWcJ4NL-HUoy-lkyOKxnFAk34XkqJFXgtF7n1G1S3fMK1rHnoCf_17fE_ZNbty41STLoKINhG6iXMK0SbfwWO1S9klkPFUChmvzergtSgQ21CLkUCRpbG90FHXXt4phUni2CMRbM8KYrsAoF-EdxAdBen8lbxasL-8cS6BZLgOvPIPgMCNlJ30U2kuLlYSm4WxSjmGkPHTX42srXpShiyS6YZ1cIkzume2KCeR-uTGF3vfdhw8Yw8jTSrdCRbjXJ1t0QB1HnrJH4pe3Ab2KI83JtTLAqAcat0_oyH0v2CcmtMwZUm_Pg1s6bcnAVCkGggqF9__oZCaVa337SxRvrgHawNDhIvvFe2VePLpFLPCklxlG-MDDEJlnQh0bPqIB-exyystH9ADyxGvCDV-G_1lbfqP8atNTtqHQUTUqSg0YjqH843_stSf2BrDJSAs0_JOL2ERzJ1cdWGl04XJS6ohtl7FstzTFp7hZLXw4E59gIFasLN7HEiOT3x7oB6cxrqGsbWv8RAqDRHnA3nNGaOmm4A4J0xfYZHbDPNR4iFGd2PxwmalRYEnSyJ9P_wzepFgsqngJxfESedDqAHP1IQzdrsKY7=s700-no" alt="" title="New Music: Fred the Godson ft. Benny the Butcher &#038; 38 Spesh &#8211; Nokia"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/14/new-music-fred-the-godson-ft-benny-the-butcher-38-spesh-nokia/" rel="bookmark" title="New Music: Fred the Godson ft. Benny the Butcher &#038; 38 Spesh &#8211; Nokia">New Music: Fred the Godson ft. Benny the Butcher &#038; 38 Spesh &#8211; Nokia</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/08/new-music-westside-gunn-benny-the-butcher-conway-the-machine-chef-dreds/" rel="bookmark" title="New Music: Westside Gunn, Benny The Butcher &#038; Conway The Machine &#8211; Chef Dreds"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/wc2xYLnZAz67FKKyQuDXULTgujgK2Vkm-RtdHNtvD4ypZrDdkcPDTVFifUcBM1K6dK8RuKqNU3g4mHYldBT4IeKbTap4-TM1ohMY9lTjSAvGzx2XCyyObulQGnuic0yB5HpfpaVTaTEizED_YcMkvAaNKHjBXNclqCbq4qDYFMQb6rGuYy25AXBfwJX5kvte8FOJTHKOTsZPgs0S6i86kks_ATtqGIG_K30KmoOS59VCURetv5BBXKHuF1DhHKiCd_N1JxuTiaSJGbCis-4nZzsM4l6BI1xBVcsXBTZH4Cj83emYCEJ4jaFw1-vitqXBjb1lNr1RgDNO0kBLeCyWiGkbI0bcN5aUvsvUaSudjuJoOZwk3sFJSI2sQ07wyVxSzqEq3KkvJ9AYUAv4bPfAznDzSNH72x6WecyTyLEh2IecgcNfktkAGA5DArUePTvFJH13o_54ttZ9tm76qSWUioEQTG4q15gxw1JiJEArwOzhNO6EFCHJFI2cZja7MMb2ra-xL0r2o6a8ltZrVTZ1pmFKOVJkWqYUqlvB7pd99lI7dGRk8-_gwlPx27a5w9M3JG5zGlXUoGSVpQ4IbPEGcP-ExaISr2w9BG3-fJccStWiqfzd8Si_6WflPORbhBfNYgJdLNZ97t3iQ2cWYkRtdfoL2wfIvnlM3SpFrR9iy1lqkjAprSt7F3lr=s736-no" alt="" title="New Music: Westside Gunn, Benny The Butcher &#038; Conway The Machine &#8211; Chef Dreds"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/08/new-music-westside-gunn-benny-the-butcher-conway-the-machine-chef-dreds/" rel="bookmark" title="New Music: Westside Gunn, Benny The Butcher &#038; Conway The Machine &#8211; Chef Dreds">New Music: Westside Gunn, Benny The Butcher &#038; Conway The Machine &#8211; Chef Dreds</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid-->

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/10/30/new-music-westside-gunn-ft-conway-benny-the-butcher-kool-g/" rel="bookmark" title="New Music: Westside Gunn ft. Conway &#038; Benny The Butcher &#8211; Kool G"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/xA6X6FD38-vrANVrltgAyDAEdiOspQwArxfdPPbam4VF3E7LKHAeD4sRqent8xbW68c-BVCLpWT3iHu1-TsyIxDCd8fx-EEA0h-EcwOP0HvkRSHwdgMFqbd4miugfpqCcXRJpVRnweqDrRsqS4mv5BNi_eZiJh4GAuvVWHxLtIDEVDof0lsXpaUaP-brOdxspaP7UiBucSpVTVoMBMC1cP9S-E5Jf5W0x3J_t4wLWyTcl_Xb-r4XkM93_XACje3s-Me4d-hNo2th-veKrnuomPYG9Lhk1F2i-WcRSw0AUWRNXGcmY1M4MVtjrTQ_cuCXddumQvmfrp8mCW0BgydKeBUy0DTiec5PiwzweDZYXAuMVObiru8GeoIAHb5OsAgryssUapx-l2CVW9GWgeJcNOnlQqgx7baeMDmdWWu9i69JihIxjaPksKe09HOwqgB805Zb94DaDiqbwiDT7n0phTfIbkST9BDG1OT_NxeKj_L1_R17kmP6gKT44XgJ2tn2XZbDmpc1khGilvvinjM7kH_fk0EJUzTk1F1zC_j4ioWdo0w9dBkdTsWJJ3fWXgUWGY6qEt1QFf0iUjl_NWchvzy1uBKhBDw1h63zDqwWhAldXgHZiJqKhfmBfk6JT6jdZd78_9GaslMotwcUrESdhLW1vW-u1FoH-WquVDfY9iok9NniMC8uYJQG=s700-no" alt="" title="New Music: Westside Gunn ft. Conway &#038; Benny The Butcher &#8211; Kool G"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/10/30/new-music-westside-gunn-ft-conway-benny-the-butcher-kool-g/" rel="bookmark" title="New Music: Westside Gunn ft. Conway &#038; Benny The Butcher &#8211; Kool G">New Music: Westside Gunn ft. Conway &#038; Benny The Butcher &#8211; Kool G</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/10/21/music-video-smoke-dza-benny-the-butcher-pete-rock-ft-westside-gunn-730-6/" rel="bookmark" title="Music Video: Smoke DZA, Benny the Butcher &#038; Pete Rock ft. Westside Gunn &#8211; 7:30"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4Pc6QF4BFqaA14cAPmhvM7T9zUfLEYJ8hcELZjTyB7q6xnZLVTsuO0jDxou30RQat89CdA4P0L1MD79jETz-Gv1PzeImNJr64G9jL_6BT0JyifesWOkKAcRxynDtSOcvD7yTHz5R5AGP50g3yXhkguwLgPjKeBUJHCpWBkRLXzAIi3uJ2TeEAFmBxfA5BH_VUpEZzGlYk6Z9p-OAg_ganjMhSCLtlxmXZONxr_bCB-knunlwasIqveLyFbnNvmrgxcyAfHQCk2abKNhPUREKK9NfTT2HdLvoi7w4gKb386MlnOww8NHVh_xg26re4vX7IHizHc55kNTDPVSFFv2XSYFwEY-b1gCZLYGB1fM_oSPG0uM8q2rWLogMBqhCYXxv_4NNNUmNzT0zLEvHnvtKD7nrdj4wJ0GzZKr_gsOIP2ylwF__nmf8G1Ye2nRQx-BiOCIWceN2vhkgAxKoblC8vz5KbdXO-SPopkLL8cLqjIsK7IrN21bdetisonooRZjSiPTeWXEpD6i2kEYltyv9ZbTa3XqFj_edaP-g1dbTuZ6h5hOYXlhSZMSKYofQ00Me8P24Hsn0pS62nv5gzkIR9ihlGB0dS08ruK9UjG5WAq1nr1WzJ-C5wWiwIR7oCFt3MRaY9udej0TsB3BAkGXzRlo2jVhKXhjHfX1T1N14BNuHVImhujNBR_3e=w938-h508-no" alt="" title="Music Video: Smoke DZA, Benny the Butcher &#038; Pete Rock ft. Westside Gunn &#8211; 7:30"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/10/21/music-video-smoke-dza-benny-the-butcher-pete-rock-ft-westside-gunn-730-6/" rel="bookmark" title="Music Video: Smoke DZA, Benny the Butcher &#038; Pete Rock ft. Westside Gunn &#8211; 7:30">Music Video: Smoke DZA, Benny the Butcher &#038; Pete Rock ft. Westside Gunn &#8211; 7:30</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/10/18/new-music-westside-gunn-conway-benny-the-butcher-dr-birds/" rel="bookmark" title="New Music: Westside Gunn, Conway &#038; Benny The Butcher &#8211; Dr. Bird’s"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/KkFdcp7NqN3RjNtvWKHkqApctpe8gh5Gy4G_-NxbVxIkx7NF5FvdGcoGXDEEDh6aMuuHY4YeBZyH4qWBEidlqCOClc8jMlODrUgCD6NV-Kz7IaLCi6XiaIbW674a3-_CkJY90Tw_2KzKf2wP-06aQV6j1uFGYE11dNUiPmh9WAc_7zTt4TPunZZwS5K5Xkm2npPjh5eaahfzrpindgKzX2LheGGgPEgEnlRxtBx2hrZcAPA1wQuWMnkd_VX-3QSQzdVTda_Xh5HxlXVCfyPnUcUIboL-pQc5ZwRhgyc7IsjVhYsM9HJw0hmQbwkrLqtRd2fVb_wakwDHFoeIG4BQsN5dEv6sqPEi5koQolE-mz0rESDtKRWE3WVvETvqHtQM9A2eScW_ORPqoleV8ub2-E_mCbEnFf6Mq7SWs2U5gYXiWs04ydMonfC0ELg5CTEK8O7AEyNxILkIuiFBIConXLMrmEyzmzOFbfiLI3DWfLEcuWIgkgb-VtPLNAhWUJOP6-VfSmZV-Ov191pJS41186iaW5XWH6LFkYKyPOFCI3r4GXM1ZH5669q9gWUaNiZG1cV3gh3kzpuYAciEZhwURS0c4-A-l9gIA5aEjArxj2LXAuxO9hcnWWV4n0S53z_wNYc-rEm7WPlWsYip8nXVYuKeH6Fyr13zPU97xJb_l9x6i_vu_INLsrA_=s600-no" alt="" title="New Music: Westside Gunn, Conway &#038; Benny The Butcher &#8211; Dr. Bird’s"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/10/18/new-music-westside-gunn-conway-benny-the-butcher-dr-birds/" rel="bookmark" title="New Music: Westside Gunn, Conway &#038; Benny The Butcher &#8211; Dr. Bird’s">New Music: Westside Gunn, Conway &#038; Benny The Butcher &#8211; Dr. Bird’s</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_15_5dd73c2503650" data-td_block_id="td_uid_15_5dd73c2503650"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_15_5dd73c2503650" data-td_block_id="td_uid_15_5dd73c2503650"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->

	<div class="comments" id="comments">
            </div> <!-- /.content -->
                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <aside class="widget widget_search"><form method="get" class="td-search-form-widget" action="http://weuponithiphop.info/">
    <div role="search">
        <input class="td-widget-search-input" type="text" value="" name="s" id="s" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit" value="Search" />
    </div>
</form></aside><aside class="widget widget_text">			<div class="textwidget"><h4><strong><span style="color: #8224e3;"><span style="color: #000000;">Listen to</span> <span style="color: #c60000;">WeUpOnItRadio</span> <span style="color: #000000;">Live!</span></span></strong></h4>
<p><span class="cc_streaminfo" data-type="song" data-username="cyclone777">Loading &#8230;</span><br />
<script language="javascript" type="text/javascript" src="https://control.internet-radio.com:2199/system/streaminfo.js"></script><br />
<iframe src="https://tunein.com/embed/player/s292400/" style="width:100%; height:100px;" scrolling="no" frameborder="no"></iframe></p>
</div>
		</aside>
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-sidebar ">
<script type="text/javascript">
var td_screen_width = document.body.clientWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 

<aside class="widget widget_text"><div class="block-title"><span>AUDIOTRAFFICKER:</span></div>			<div class="textwidget"><p><iframe src="https://www.facebook.com/plugins/video.php?href=https%3A%2F%2Fwww.facebook.com%2FAudioTrafficker%2Fvideos%2F326277991409372%2F&#038;show_text=0&#038;width=560" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true" allowFullScreen="true"></iframe></p>
</div>
		</aside><aside class="widget widget_text"><div class="block-title"><span>&#8220;Stop the Violence Vol 1&#8221;</span></div>			<div class="textwidget"><p><a href="http://weuponithiphop.info/2019/11/12/new-music-aim-high-lil-mecca-lady-loe-nuwajah-sankola-miss-saigon-the-rapper-stop-the-violence-vol-1/"><img src="https://lh3.googleusercontent.com/peDVQmVjq963Vrk2Xb1rO296JuSewJPza87w3jFVpue5mwlFVn2XKbC_oj-XTEMIAsyaxJP1jqVhqnNYSUz1TjEgdExPOFQzkUt_jziDAWsTOTRmXhSkt3-x0ukohXmiYG8Er52fDOvmwEULJE3q1x5xrb_W-Ld2gHEOKSO07tN6EsKyobYL0i9S72Gx1xHtuRg4zFOGpD2gTm-FZryx7Oc4o9UwVTqvf6xnbMIBgM8GbMK7kWzJ-X5B5m-3bNQ_vexJjXQrf9qTp6JaMSQHd4lGIO6m7n5eL8HsOdWytc5ZHr9agXUK1lJGAcjuZNQVNNeALBdaUDRWDnS_tP0TF6WpgqdjvhPz3MpBO9A1W2ZX5kzlBJyDoGjOe6M7lYF1gjFSxKiBTyQ3O8CvGc1_BOPpxNQLrF_GFAzNi8styU6Moh8r9vgOWYdjNCAn0U6esMYnSmYRYx1SrSjbupkhhhAQEnEquOL49Kd1ZPcwwz4y0ikkjeO9TrYWcRSCjMq_zRKpJwIPhh2wFI_IBzAPx_yHzVj3OpDvi0teZBHiYOxWfSQNtgA0zvaAofKWxAsWYRKtZdAXOo9mFTYB_4p2TdZF7NKa20Bn3mMjF-TxnAAfoy7Sn5NsyQHvt5d_Hwmu2fkJw3Tw90wRz1Gh_f8BmpjGj0Qfz16KEMOhn8Tn0SWUovvvRGPsorDp=s500-no" width="500" height="500" class="aligncenter size-full" /></a></p>
</div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><div aria-live="polite" id="soliloquy-container-30342" class="soliloquy-container soliloquy-transition-fade  soliloquy-theme-classic" style="max-width:960px;max-height:300px;"><ul id="soliloquy-30342" class="soliloquy-slider soliloquy-slides soliloquy-wrap soliloquy-clear"><li aria-hidden="true" class="soliloquy-item soliloquy-item-1 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109673710?productType=812&#038;appearance=1" class="soliloquy-link" title="Revolt Tee" target="_blank"><img id="soliloquy-image-30349" class="soliloquy-image soliloquy-image-1" src="http://weuponithiphop.info/wp-content/uploads/Revolt-Tee.jpg" alt="Revolt Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-2 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/youngongetthiswork?q=I12154011" class="soliloquy-link" title="You Gon Get This Work" target="_blank"><img id="soliloquy-image-30344" class="soliloquy-image soliloquy-image-2" src="http://weuponithiphop.info/wp-content/uploads/You-Gon-Get-This-Work.jpg" alt="You Gon Get This Work" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-3 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/savage+bloody?q=I1014473415" class="soliloquy-link" title="Savage Bloody" target="_blank"><img id="soliloquy-image-30343" class="soliloquy-image soliloquy-image-3" src="http://weuponithiphop.info/wp-content/uploads/Savage-Bloody.jpg" alt="Savage Bloody" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-4 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/can?q=I1011767996" class="soliloquy-link" title="spray" target="_blank"><img id="soliloquy-image-30345" class="soliloquy-image soliloquy-image-4" src="http://weuponithiphop.info/wp-content/uploads/spray.jpg" alt="spray" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-5 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814012" class="soliloquy-link" title="Good Vibes Only 1" target="_blank"><img id="soliloquy-image-30346" class="soliloquy-image soliloquy-image-5" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-1.jpg" alt="Good Vibes Only 1" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-6 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/blessed?q=I12044252" class="soliloquy-link" title="Blessed Tee" target="_blank"><img id="soliloquy-image-30347" class="soliloquy-image soliloquy-image-6" src="http://weuponithiphop.info/wp-content/uploads/Blessed-Tee.jpg" alt="Blessed Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-7 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/trap?q=I1009984243" class="soliloquy-link" title="Trap Tee" target="_blank"><img id="soliloquy-image-30348" class="soliloquy-image soliloquy-image-7" src="http://weuponithiphop.info/wp-content/uploads/Trap-Tee.jpg" alt="Trap Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-8 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/good+vibes+only+birds?q=I1014476779" class="soliloquy-link" title="Good Vibes Only 2" target="_blank"><img id="soliloquy-image-30350" class="soliloquy-image soliloquy-image-8" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-2.jpg" alt="Good Vibes Only 2" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-9 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/all+seeing+eye?q=I11739019" class="soliloquy-link" title="ILLuminati" target="_blank"><img id="soliloquy-image-30351" class="soliloquy-image soliloquy-image-9" src="http://weuponithiphop.info/wp-content/uploads/ILLuminati.jpg" alt="ILLuminati" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-10 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/diamond_skull_1?q=I12527492" class="soliloquy-link" title="Diamond Skull" target="_blank"><img id="soliloquy-image-30352" class="soliloquy-image soliloquy-image-10" src="http://weuponithiphop.info/wp-content/uploads/Diamond-Skull.jpg" alt="Diamond Skull" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-11 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/donuts+doom-A109792920" class="soliloquy-link" title="donunts" target="_blank"><img id="soliloquy-image-30353" class="soliloquy-image soliloquy-image-11" src="http://weuponithiphop.info/wp-content/uploads/donunts.jpg" alt="donunts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-12 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/crime+pays?q=I12067735" class="soliloquy-link" title="Crime Pays" target="_blank"><img id="soliloquy-image-30434" class="soliloquy-image soliloquy-image-12" src="http://weuponithiphop.info/wp-content/uploads/Crime-Pays.jpg" alt="Crime Pays" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-13 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/fuckyoupayme?q=I11550361" class="soliloquy-link" title="Fuck You Pay Me" target="_blank"><img id="soliloquy-image-30436" class="soliloquy-image soliloquy-image-13" src="http://weuponithiphop.info/wp-content/uploads/Fuck-You-Pay-Me.jpg" alt="Fuck You Pay Me" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-14 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814011" class="soliloquy-link" title="savage gold tee" target="_blank"><img id="soliloquy-image-30354" class="soliloquy-image soliloquy-image-14" src="http://weuponithiphop.info/wp-content/uploads/savage-gold-tee.jpg" alt="savage gold tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-15 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/?page=2" class="soliloquy-link" title="fresh-clean-signature-" target="_blank"><img id="soliloquy-image-30437" class="soliloquy-image soliloquy-image-15" src="http://weuponithiphop.info/wp-content/uploads/fresh-clean-signature-.jpg" alt="fresh-clean-signature-" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-16 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/%24teez?q=I1001415610" class="soliloquy-link" title="gold fronts" target="_blank"><img id="soliloquy-image-30355" class="soliloquy-image soliloquy-image-16" src="http://weuponithiphop.info/wp-content/uploads/gold-fronts.jpg" alt="gold fronts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-17 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/soldier?q=I11611241" class="soliloquy-link" title="Swag Soldier" target="_blank"><img id="soliloquy-image-30435" class="soliloquy-image soliloquy-image-17" src="http://weuponithiphop.info/wp-content/uploads/Swag-Soldier.jpg" alt="Swag Soldier" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-18 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/gamer-A7923028?productType=210&#038;appearance=22" class="soliloquy-link" title="gamer" target="_blank"><img id="soliloquy-image-30438" class="soliloquy-image soliloquy-image-18" src="http://weuponithiphop.info/wp-content/uploads/gamer.jpg" alt="gamer" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-19 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/" class="soliloquy-link" title="freshandlogo Square" target="_blank"><img id="soliloquy-image-30356" class="soliloquy-image soliloquy-image-19" src="http://weuponithiphop.info/wp-content/uploads/freshandlogo-Square.jpg" alt="freshandlogo Square" /></a></li></ul></div><noscript><style type="text/css">#soliloquy-container-30342{opacity:1}</style></noscript>
</div>
		</aside>                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</article> <!-- /.post -->


<!-- Instagram -->



<!-- Footer -->
<div class="td-footer-wrapper td-footer-template-3">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
			    		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span4">
                <div class="td-footer-info"><div class="footer-logo-wrap"><a href="http://weuponithiphop.info/"><img class="td-retina-data" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" alt="" title=""/></a></div><div class="footer-text-wrap"></div><div class="footer-social-wrap td-social-style-2">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div></div>            </div>

            <div class="td-pb-span4">
                <aside class="widget widget_calendar"><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar">
	<caption>November 2019</caption>
	<thead>
	<tr>
		<th scope="col" title="Sunday">S</th>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
	</tr>
	</thead>

	<tfoot>
	<tr>
		<td colspan="3" id="prev"><a href="http://weuponithiphop.info/2019/10/">&laquo; Oct</a></td>
		<td class="pad">&nbsp;</td>
		<td colspan="3" id="next" class="pad">&nbsp;</td>
	</tr>
	</tfoot>

	<tbody>
	<tr>
		<td colspan="5" class="pad">&nbsp;</td><td><a href="http://weuponithiphop.info/2019/11/01/" aria-label="Posts published on November 1, 2019">1</a></td><td><a href="http://weuponithiphop.info/2019/11/02/" aria-label="Posts published on November 2, 2019">2</a></td>
	</tr>
	<tr>
		<td><a href="http://weuponithiphop.info/2019/11/03/" aria-label="Posts published on November 3, 2019">3</a></td><td><a href="http://weuponithiphop.info/2019/11/04/" aria-label="Posts published on November 4, 2019">4</a></td><td><a href="http://weuponithiphop.info/2019/11/05/" aria-label="Posts published on November 5, 2019">5</a></td><td><a href="http://weuponithiphop.info/2019/11/06/" aria-label="Posts published on November 6, 2019">6</a></td><td><a href="http://weuponithiphop.info/2019/11/07/" aria-label="Posts published on November 7, 2019">7</a></td><td><a href="http://weuponithiphop.info/2019/11/08/" aria-label="Posts published on November 8, 2019">8</a></td><td><a href="http://weuponithiphop.info/2019/11/09/" aria-label="Posts published on November 9, 2019">9</a></td>
	</tr>
	<tr>
		<td><a href="http://weuponithiphop.info/2019/11/10/" aria-label="Posts published on November 10, 2019">10</a></td><td><a href="http://weuponithiphop.info/2019/11/11/" aria-label="Posts published on November 11, 2019">11</a></td><td><a href="http://weuponithiphop.info/2019/11/12/" aria-label="Posts published on November 12, 2019">12</a></td><td><a href="http://weuponithiphop.info/2019/11/13/" aria-label="Posts published on November 13, 2019">13</a></td><td><a href="http://weuponithiphop.info/2019/11/14/" aria-label="Posts published on November 14, 2019">14</a></td><td><a href="http://weuponithiphop.info/2019/11/15/" aria-label="Posts published on November 15, 2019">15</a></td><td><a href="http://weuponithiphop.info/2019/11/16/" aria-label="Posts published on November 16, 2019">16</a></td>
	</tr>
	<tr>
		<td><a href="http://weuponithiphop.info/2019/11/17/" aria-label="Posts published on November 17, 2019">17</a></td><td><a href="http://weuponithiphop.info/2019/11/18/" aria-label="Posts published on November 18, 2019">18</a></td><td><a href="http://weuponithiphop.info/2019/11/19/" aria-label="Posts published on November 19, 2019">19</a></td><td><a href="http://weuponithiphop.info/2019/11/20/" aria-label="Posts published on November 20, 2019">20</a></td><td id="today"><a href="http://weuponithiphop.info/2019/11/21/" aria-label="Posts published on November 21, 2019">21</a></td><td>22</td><td>23</td>
	</tr>
	<tr>
		<td>24</td><td>25</td><td>26</td><td>27</td><td>28</td><td>29</td><td>30</td>
	</tr>
	</tbody>
	</table></div></aside>            </div>

            <div class="td-pb-span4">
                <aside class="widget widget_text">			<div class="textwidget"><div aria-live="polite" id="soliloquy-container-30342" class="soliloquy-container soliloquy-transition-fade  soliloquy-theme-classic" style="max-width:960px;max-height:300px;"><ul id="soliloquy-30342" class="soliloquy-slider soliloquy-slides soliloquy-wrap soliloquy-clear"><li aria-hidden="true" class="soliloquy-item soliloquy-item-1 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109673710?productType=812&#038;appearance=1" class="soliloquy-link" title="Revolt Tee" target="_blank"><img id="soliloquy-image-30349" class="soliloquy-image soliloquy-image-1" src="http://weuponithiphop.info/wp-content/uploads/Revolt-Tee.jpg" alt="Revolt Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-2 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/youngongetthiswork?q=I12154011" class="soliloquy-link" title="You Gon Get This Work" target="_blank"><img id="soliloquy-image-30344" class="soliloquy-image soliloquy-image-2" src="http://weuponithiphop.info/wp-content/uploads/You-Gon-Get-This-Work.jpg" alt="You Gon Get This Work" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-3 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/savage+bloody?q=I1014473415" class="soliloquy-link" title="Savage Bloody" target="_blank"><img id="soliloquy-image-30343" class="soliloquy-image soliloquy-image-3" src="http://weuponithiphop.info/wp-content/uploads/Savage-Bloody.jpg" alt="Savage Bloody" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-4 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/can?q=I1011767996" class="soliloquy-link" title="spray" target="_blank"><img id="soliloquy-image-30345" class="soliloquy-image soliloquy-image-4" src="http://weuponithiphop.info/wp-content/uploads/spray.jpg" alt="spray" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-5 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814012" class="soliloquy-link" title="Good Vibes Only 1" target="_blank"><img id="soliloquy-image-30346" class="soliloquy-image soliloquy-image-5" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-1.jpg" alt="Good Vibes Only 1" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-6 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/blessed?q=I12044252" class="soliloquy-link" title="Blessed Tee" target="_blank"><img id="soliloquy-image-30347" class="soliloquy-image soliloquy-image-6" src="http://weuponithiphop.info/wp-content/uploads/Blessed-Tee.jpg" alt="Blessed Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-7 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/trap?q=I1009984243" class="soliloquy-link" title="Trap Tee" target="_blank"><img id="soliloquy-image-30348" class="soliloquy-image soliloquy-image-7" src="http://weuponithiphop.info/wp-content/uploads/Trap-Tee.jpg" alt="Trap Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-8 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/good+vibes+only+birds?q=I1014476779" class="soliloquy-link" title="Good Vibes Only 2" target="_blank"><img id="soliloquy-image-30350" class="soliloquy-image soliloquy-image-8" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-2.jpg" alt="Good Vibes Only 2" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-9 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/all+seeing+eye?q=I11739019" class="soliloquy-link" title="ILLuminati" target="_blank"><img id="soliloquy-image-30351" class="soliloquy-image soliloquy-image-9" src="http://weuponithiphop.info/wp-content/uploads/ILLuminati.jpg" alt="ILLuminati" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-10 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/diamond_skull_1?q=I12527492" class="soliloquy-link" title="Diamond Skull" target="_blank"><img id="soliloquy-image-30352" class="soliloquy-image soliloquy-image-10" src="http://weuponithiphop.info/wp-content/uploads/Diamond-Skull.jpg" alt="Diamond Skull" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-11 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/donuts+doom-A109792920" class="soliloquy-link" title="donunts" target="_blank"><img id="soliloquy-image-30353" class="soliloquy-image soliloquy-image-11" src="http://weuponithiphop.info/wp-content/uploads/donunts.jpg" alt="donunts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-12 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/crime+pays?q=I12067735" class="soliloquy-link" title="Crime Pays" target="_blank"><img id="soliloquy-image-30434" class="soliloquy-image soliloquy-image-12" src="http://weuponithiphop.info/wp-content/uploads/Crime-Pays.jpg" alt="Crime Pays" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-13 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/fuckyoupayme?q=I11550361" class="soliloquy-link" title="Fuck You Pay Me" target="_blank"><img id="soliloquy-image-30436" class="soliloquy-image soliloquy-image-13" src="http://weuponithiphop.info/wp-content/uploads/Fuck-You-Pay-Me.jpg" alt="Fuck You Pay Me" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-14 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814011" class="soliloquy-link" title="savage gold tee" target="_blank"><img id="soliloquy-image-30354" class="soliloquy-image soliloquy-image-14" src="http://weuponithiphop.info/wp-content/uploads/savage-gold-tee.jpg" alt="savage gold tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-15 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/?page=2" class="soliloquy-link" title="fresh-clean-signature-" target="_blank"><img id="soliloquy-image-30437" class="soliloquy-image soliloquy-image-15" src="http://weuponithiphop.info/wp-content/uploads/fresh-clean-signature-.jpg" alt="fresh-clean-signature-" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-16 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/%24teez?q=I1001415610" class="soliloquy-link" title="gold fronts" target="_blank"><img id="soliloquy-image-30355" class="soliloquy-image soliloquy-image-16" src="http://weuponithiphop.info/wp-content/uploads/gold-fronts.jpg" alt="gold fronts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-17 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/soldier?q=I11611241" class="soliloquy-link" title="Swag Soldier" target="_blank"><img id="soliloquy-image-30435" class="soliloquy-image soliloquy-image-17" src="http://weuponithiphop.info/wp-content/uploads/Swag-Soldier.jpg" alt="Swag Soldier" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-18 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/gamer-A7923028?productType=210&#038;appearance=22" class="soliloquy-link" title="gamer" target="_blank"><img id="soliloquy-image-30438" class="soliloquy-image soliloquy-image-18" src="http://weuponithiphop.info/wp-content/uploads/gamer.jpg" alt="gamer" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-19 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/" class="soliloquy-link" title="freshandlogo Square" target="_blank"><img id="soliloquy-image-30356" class="soliloquy-image soliloquy-image-19" src="http://weuponithiphop.info/wp-content/uploads/freshandlogo-Square.jpg" alt="freshandlogo Square" /></a></li></ul></div><noscript><style type="text/css">#soliloquy-container-30342{opacity:1}</style></noscript>
</div>
		</aside>            </div>
        </div>
    </div>
</div>

<!-- Sub Footer -->
    <div class="td-sub-footer-container">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span7 td-sub-footer-menu">
                        <div class="menu-top-menu-container"><ul id="menu-top-menu-2" class="td-subfooter-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-first td-menu-item td-mega-menu menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_20_5dd73c2520ed1_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_20_5dd73c2520ed1" ><script>var block_td_uid_20_5dd73c2520ed1 = new tdBlock();
block_td_uid_20_5dd73c2520ed1.id = "td_uid_20_5dd73c2520ed1";
block_td_uid_20_5dd73c2520ed1.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"43","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_20_5dd73c2520ed1_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_20_5dd73c2520ed1.td_column_number = "3";
block_td_uid_20_5dd73c2520ed1.block_type = "td_block_mega_menu";
block_td_uid_20_5dd73c2520ed1.post_count = "5";
block_td_uid_20_5dd73c2520ed1.found_posts = "2610";
block_td_uid_20_5dd73c2520ed1.header_color = "";
block_td_uid_20_5dd73c2520ed1.ajax_pagination_infinite_stop = "";
block_td_uid_20_5dd73c2520ed1.max_num_pages = "522";
tdBlocksArray.push(block_td_uid_20_5dd73c2520ed1);
</script><div id=td_uid_20_5dd73c2520ed1 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/21/new-music-statik-selektah-paul-wall-ft-benny-the-butcher-overcame/" rel="bookmark" title="New Music: Statik Selektah &#038; Paul Wall ft. Benny the Butcher &#8211; Overcame"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/lI1WF9Jox-Ur34h4mAdXTSxvDHKW71zTpSyanmcg32csynI_uhzYKpKeXG-KkCxyj1nasJvcGoUl2wD2ekfEP_dr_OKmjxLrboF_fK8yxlhog86giQ69eJ0VYfBFuFnrUHeSQ-7Gy96QA-PNM0XoXYTfCK_QxQSHUZolKKPa5Ym5pKIrslvgyX72_xnkNlHCNlFZGeJH4g6uQYpiNGNIRODE246RtKvn8txFhb-jzRfCfR6c01WpFpVeE-0NwzEgsmVIZqPOYf4C5mvQ9CiwTiqnfDKprXHbInGLDOvaa6EGjGWPRBJO6Eum-9FbHmBbwGyPF3MfwsrrUjdHk9MRsJJvbpKjSMSg8glCTDjpNcs9WNVk7sVECIFUkdYcJQWrBN9_6ecSjGB73_VA8BBtSCVWbimNL6mnO8dgoWn4Huel-WvQnzZxn-l_O4VU_EbrFGo6NvGudww6Fsuc5Ynn0XNufziHZL7gSg-PXa0LIatoPwCWESaEZYysAKB73tDEgAyKIqlmimT4-6QK4wI2We7xb689tKaMTqXfcGPs48gtgKqIK8RkUuaWqtXwH9qnyqkJYolvZdsJYBH1WGPNkuQy6ENORZEA8rrs2ju3JrhwkxuI-LAVLKAQvh_o86M5KCwZEhzM8hd24lkxu8LRxW50m4nIPfQ8mCe5UrQQrjq3e1Rb6tb3H_cx=s500-no" alt="" title="New Music: Statik Selektah &#038; Paul Wall ft. Benny the Butcher &#8211; Overcame"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/21/new-music-statik-selektah-paul-wall-ft-benny-the-butcher-overcame/" rel="bookmark" title="New Music: Statik Selektah &#038; Paul Wall ft. Benny the Butcher &#8211; Overcame">New Music: Statik Selektah &#038; Paul Wall ft. Benny the Butcher&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/20/new-music-kxng-crooked-bronze-nazareth-i-can-still-remember-5/" rel="bookmark" title="New Music: KXNG Crooked &#038; Bronze Nazareth &#8211; I Can Still Remember"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/S4wuuuWwyLp3iibb0Pk1o_AyZokCWjOsvGqaak8VkDAxJFiU_BYg4UZdcgOzjEyJfBXuKYNGo7M131Q8qpXW2vf4tp7kWYgrlQMdOYqdvDLPdgyMTLYg1mc6xSszx_hnsOcl5CB7noj4tzvf4ml0ewBoX8St_fMFB-8NiXwcTsO5K0rlp2EK1BuHifF0HD26S5-7zjkeh6wlImAb5z6KSNugKMi6D45EqwkyEWoy06SbA9NlZo6kIAXC-sMCDilO47taMXa-759gy8R7uHoeuDfvMXkpn3qF415LDmTHwKXSOu9Ox5Rs_FCzfCUuaJZGFBiLNh30udpMPtuN1jxfC1CjdL99OQd2tH2vAt-P3vXhw6mVwtpPtslHhUD5WalMr0_50wi8SCOCQ74OtF1ze-3qugGiCEtTqxJafc84t5-jvOJjXuVAvJ-71nSOfZrOg21HtWfNo4HKw-SpM5xwWxPpqbzvJMHbvL2r4WX9nkzPT4PT6Lj0rpxRJFkpIoGc-rn3uEeEDnp1NqG3Bj0eSjiVygN-CnVQpTv6sJAX3bWOSVLUUvxiKdLokvKFXdZ1idZzB5yqjqlHB31XaVIq-pRuhvaHSCVX_wEoh3pv2DtGgrxw4dOFoUV7ujXT6zKftYVRr6QwLLQjaDY_kQdSdW-AqnbC5FB9zjBrRMG6EM0G_el9JLUfQHh6=s700-no" alt="" title="New Music: KXNG Crooked &#038; Bronze Nazareth &#8211; I Can Still Remember"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/20/new-music-kxng-crooked-bronze-nazareth-i-can-still-remember-5/" rel="bookmark" title="New Music: KXNG Crooked &#038; Bronze Nazareth &#8211; I Can Still Remember">New Music: KXNG Crooked &#038; Bronze Nazareth &#8211; I Can Still&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/20/new-music-take-a-daytrip-ft-rico-nasty-slowthai-icecoldbishop-lighthouse/" rel="bookmark" title="New Music: Take A Daytrip ft. Rico Nasty, Slowthai &#038; ICECOLDBISHOP &#8211; Lighthouse"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/wrtG0SbI8-JyKQ1lmknxxsaEFtEzv5ZJ_RTeryzKRfEMgBG8GBVMUmb_IDsK4pWgEo3tmQYiYfPCACt8qSco83v969c_y4z9zrYrlREM54eVvh-lbjTWL1s6AXgnx1c7qlc-hTKS_5bYq6Ll5XCI7MGB0PZfdcZaBAjgKqMNUUh7MgIIinXcYxnzGJ9ZtE07lUsC0OhU_zSomz2mfwaRt0166d829w4g8532-qPY3z763h-kT6ynk0c0fgx-fRUaKergUyiWUYQjaE8ep0p2vD1uZz8rhCtEdMCXkmyv4PvNuyIjXylO1DA4_nzQNnYnn99qjJy-7XSFfv8xj9d0X9BNt0xD4vpWbhUcEe2WU83S4Llq3GTZOp58BaFs4p7ohwQRX3y5dNQW5_GyG4ut6zawiGBDdhXUUEbVHrADfTWifeTm9FZf5_Kl71FH7V12-AtMMaLNSC1FXRqXEN6pnZj3FPw12InBfXAeIIxJInHvCa-oJoiXZJh45FkaL02Rpb7zslN0pzNfmSIvR8ZolfDQ0r7I3tYe0lNYbdYFV9qDpLY1Y5oN3J_aGiZxvNr2m78vG1ZtRgqm13236dGB3JDQR7gSR7o4WsHtpVR47KLKRfpRbG5kE0Ie4PE5PeG86sgii30pSMfbaKi5oGIKK3vbD6vNZFMO2GRPhul_wXpq9ILh2A5-d0ZS=s700-no" alt="" title="New Music: Take A Daytrip ft. Rico Nasty, Slowthai &#038; ICECOLDBISHOP &#8211; Lighthouse"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/20/new-music-take-a-daytrip-ft-rico-nasty-slowthai-icecoldbishop-lighthouse/" rel="bookmark" title="New Music: Take A Daytrip ft. Rico Nasty, Slowthai &#038; ICECOLDBISHOP &#8211; Lighthouse">New Music: Take A Daytrip ft. Rico Nasty, Slowthai &#038; ICECOLDBISHOP&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/20/new-music-trippie-redd-who-need-love/" rel="bookmark" title="New Music: Trippie Redd &#8211; Who Need Love"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/CfMrCSwUvAVGe8x7lkXJPBlgvvolzgfe6OXU6hrUnViYUFAs8QB9Vnb2shBKZuPtOg3J5gzrK6nqNyU-8qaErrzNOl5CK00sE7MSGUKVlnAhtVeS_HgZdsXXkrprns17kGPC2VWyYq-Ph_4d1v1J3RFtC9td46nYbDliD_-aAGZhW7qGHrrpHsbJgXk_hj9Camt5i8HtxlT_80KiJryTsrU5VyUYzBxvbxGIfEiv6YGp6cN7hLGXYjTJE-z8f_pUo-QXMWquLSdbZaP4CHrnngQEX5GPFHySEJTJcX_zOEaIrBgmmrSGyMlZJQtHatIIX_REzKrEsD_wA4kqP2JyWht0LLZN9yAkJu2l9GtNAEwQJ9HEyJe-aeGMd7eb_zyuK3oD__rHPYtf8nIP2b6KjOwf4m3Y-zQovX1DQpbrhsuyRcKqr2vh5K7VwpTWSdP-Aio67_c9ZZN_FbNWHi8lRoekVGo8XagV2PIHomRQBAFzTNoJnwTFzvb89Jbl75ZKO8yfjvx2f_meU0J5lFuYZzM51MoLg24a_yblzEQoFBW-sQSqaaDAlhXNKBq5EhvzOwCw7dGvD-tB39XDPs57IyjSZfiQ3Q2ax0RosWZ5i2VNJeY3o0CsBB-7nKcd-_E4auUbnzdQQ4fXr1I_cNXFTDwexAVj3SjgoC20u0LBaGMYNv4ixl7QnAtt=s700-no" alt="" title="New Music: Trippie Redd &#8211; Who Need Love"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/20/new-music-trippie-redd-who-need-love/" rel="bookmark" title="New Music: Trippie Redd &#8211; Who Need Love">New Music: Trippie Redd &#8211; Who Need Love</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/20/new-music-dram-litmas/" rel="bookmark" title="New Music: DRAM &#8211; Litmas"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/SGFZVbp--DxIQJL9ogmBtF3AVk9p66XzRfDz35qed_LruNG2Oun8904ypCU6oCq9fm0Ai3u7PdWHN0nWm1ZGY_2wGHH5TltEKOaCmhtGmsu5zVxdCtzBnzm4n1FjoHcurg8xgyi_nYq5jnZjxdk9meWC766uXsXPG8TaCfqLsJhaiwPs9Ed8PKAELwKy7K2HA6Ggrpr2IwKtQVOGYin7D_anoaBonI4_fcWytzI6UoCb4NQMPCeWnsA131B_vKLuvej8eXtZna_ItBxXDZe7P1kbRi9gCl5RigaYQq8_8PXpoq5_BC9a12AYEPTOV7Pr0Ge9-7e-9rp3RMQXHW46ejZ-nnzlI5a5JB-mv-d5jmJX03mP8Hnerz9JJ3EEahh-ft7Cw03dqKVpPVfcCzXUBDRoy-X6XFDwyMzlJSXnObGrdfarw1HHcOncA4SnsxpKR-6qG1JqFitFeDaHnlX8gjWkwOcOvQaXTxVy7QSl6dgxJEID9IzpCBhUK4u7BSlmqUluH_HR_f4CP1BMbMxM7kvEgv_QbuAqRp88LkaclNQUwex4JiVsH2RjN9IrBKnB2dg0609MdBIYA0RRvtcMaAC7BCpBznIXLLOSwAfIA3UOMIPVbd8S9DN-cjyttv3sqqGhCeFw1ZHwBYUEnJewI52_cSwi_oAitiorIczVR4OhT0KybcmZzZf-=s558-no" alt="" title="New Music: DRAM &#8211; Litmas"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/20/new-music-dram-litmas/" rel="bookmark" title="New Music: DRAM &#8211; Litmas">New Music: DRAM &#8211; Litmas</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_20_5dd73c2520ed1" data-td_block_id="td_uid_20_5dd73c2520ed1"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_20_5dd73c2520ed1" data-td_block_id="td_uid_20_5dd73c2520ed1"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_21_5dd73c252446a_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_21_5dd73c252446a" ><script>var block_td_uid_21_5dd73c252446a = new tdBlock();
block_td_uid_21_5dd73c252446a.id = "td_uid_21_5dd73c252446a";
block_td_uid_21_5dd73c252446a.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"97","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_21_5dd73c252446a_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_21_5dd73c252446a.td_column_number = "3";
block_td_uid_21_5dd73c252446a.block_type = "td_block_mega_menu";
block_td_uid_21_5dd73c252446a.post_count = "5";
block_td_uid_21_5dd73c252446a.found_posts = "929";
block_td_uid_21_5dd73c252446a.header_color = "";
block_td_uid_21_5dd73c252446a.ajax_pagination_infinite_stop = "";
block_td_uid_21_5dd73c252446a.max_num_pages = "186";
tdBlocksArray.push(block_td_uid_21_5dd73c252446a);
</script><div id=td_uid_21_5dd73c252446a class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/21/album-stream-tinashe-songs-for-you/" rel="bookmark" title="Album Stream: Tinashe &#8211; Songs For You"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/Mq7Ohuzc4V_q3LnUvRumGzDkHwLjN1H-bCfPGpdTHd3_EhBldVNT9XGSabS1hZHrpxLZPD6l-9zdFVNBQ7bG3HvEHJEkT9O8sYKeI-x7K-Lf9ysg3D2E2O7xNjrAbDaJkfqTQbM1GC4BPJkPSTps1UuRALNRurT863ogPiBcjit1phlt3fOTl5amStA_BeHMiQTXgUj0-RdR-w9Cxea7RiIcmB5RRtwd04fkqbUqGR0Q9wm4iTtoyi8wncO74gNRZnCLWCy_Lg9qCrEVtaBLDQLUneHioMDuzu4kJo-w9xansLtITogLjNCrrXEQMCFIN18Ey-xSaGWbev36xNw8pXg24uAbh1hONQyXepL884POzeTRDr6KMx3XBZIk2qeZkK_h4VLX7K7h6YBWTTFjHfesrfAGPHPmOy615G7Hlfrc_f1pRJh3Waq9SRZBuH-u83sy_vWbzAPqQ0QBar1SPtoayFpsZAhfz1QcxYGqsptXYOauxTBcx9CbwjVxWdC_6IQX4446E7dP-wmlUgjFSdik5tf_2rHjLOCwSGEJbbw-qfeTvttQe4Y7LJAoIr1dO6p0SJYUVYbngJ27VoUd2mQ_lU8nn6c54Dk0wA0ii1D9AW7ABg860m-wOEn0CoDTAkOTtRGH_Tysa1AeEkV8pF63NqSc8dqxVA8cHEhi7Gy-cpDD4F3mZAbk=w589-h736-no" alt="" title="Album Stream: Tinashe &#8211; Songs For You"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/21/album-stream-tinashe-songs-for-you/" rel="bookmark" title="Album Stream: Tinashe &#8211; Songs For You">Album Stream: Tinashe &#8211; Songs For You</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/21/album-stream-mozzy-tsu-surf-blood-cuzzins/" rel="bookmark" title="Album Stream: Mozzy &#038; Tsu Surf &#8211; Blood Cuzzins"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/MQC9-CT4B-RvuTNxqWPKROC1H_J6LrcJGA8GteVHRtCzVkil1oVIV4ezsumfLUtcKJa6v0n0qqooDwpCE8BbZNjUlm3hIvU5Skx_TvqnSIyXmg0DDk60ltRcrs16jr8Dq3ayWPz0XRxqgtS40NrRfZ6rrrUvMpgTJYtng2pDC6TtcSrIVQ_xQfzNiDwGjT1OzahyPUAVG17sk9dIxcMYnNzfoiI6kbBvdPjNTLG6dJ9wCSCt0KRgp8WXYRGQVcNEz0BH3n7t9WMAbwZALRqGcm_p2aqXI0zqZ-PLZYxIwnt_d2xxFGhR9iuu9ZldwMiU1F1nDKoIoY6cgaFJw9_jQeiT2FMvD83hNmobJfD-EdNNvUrlwxma5ikeOtib0-c3KLyyqCohtbyfXd0krp6M_1R607FRzt-tzQgP_hgIy-vBz3whCrINzZwLY4rxSQX3Gyvce-RxRmX61PTI9ZdL4IvoPzoHxzLtUV7hSJreFhbaFXAPmBNB3CnSaEFuzNBUB7wnzoexarq7vr6WtvdLC3uBEoPLRxsiY3L1-Zh4XYvEC3iJVwDEMMxheAdtl5x0KTau7Akb6g951q33cvn7YMv1hr6XmdT3Ro2jzrymjWsc-0tevRS5UJbvZ5C_p3Xk9B_IIoGNYILQid3_XzjlWlu2FJR8ei6J68LEdv0Dg0chT8qnYZAJ2vTT=s700-no" alt="" title="Album Stream: Mozzy &#038; Tsu Surf &#8211; Blood Cuzzins"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/21/album-stream-mozzy-tsu-surf-blood-cuzzins/" rel="bookmark" title="Album Stream: Mozzy &#038; Tsu Surf &#8211; Blood Cuzzins">Album Stream: Mozzy &#038; Tsu Surf &#8211; Blood Cuzzins</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/19/mixtape-evidence-squirrel-tape-instrumentals-vol-1/" rel="bookmark" title="Mixtape: Evidence &#8211; Squirrel Tape Instrumentals Vol. 1"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/72QWxWxGsF1WqCyW3Q_KBV0i3zIo3ROYdNEGB-tnhkuWff8_1k2yAUZ2_YhrGDnmcW9V9l0vTgJz7nHQHPiDJqF-ZGr9lBRhetIPXJw9Vi7PW2s3avPV0rfQoT2UVxQy44yfmtqC-K-Eu1gkDl3zFnr3vHg_M67d1sLQ5MJc3bOFe1YF_x6yT7Oa5cbOyZxpTHL5qdSm9w7Si-aj-zm7SezppLjYLZuz-37akD4fg-rMBHNZaAMllIJs_1-TzQeiKZlQII5g6Z0AQcnHXX2Ricu33nf38Iirvqik8JUTnR9zd1eXPjwGP5jfuxu9oyY16FoAh3959-IRJpldbSKxHww6YeSSGFcjwb22ohMjdRUr5nF7nOTqsHhxTBUwrBBPc7qWFv5EYN45ITTuVjp_obirNVPSIM0eePvIL41KL40rO1sU4EpkcjsQES_kML3G5Eu-bjY04lL_dnajnyQdvA1V2J491IcPYdSXD1zGeyRrAYbGYn8_o5E1hCYRrSwQf3uoa1o8e3o9bhoIr98GxWd5VWyHSrCQpHZa1L1LCvQSpYSG5VHStqv335xdfJ0Q-9v62MRuauoPbxxOoqp8YW9jk1D_YL43Hq28_LfX4piTNb04A-AyWNBFyVyJPq3vpwHPCiWzTkGrBZ_LAuTgKPMvfUQVad84dheVXcTo-62fs3JPen7iUZh5=s700-no" alt="" title="Mixtape: Evidence &#8211; Squirrel Tape Instrumentals Vol. 1"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/19/mixtape-evidence-squirrel-tape-instrumentals-vol-1/" rel="bookmark" title="Mixtape: Evidence &#8211; Squirrel Tape Instrumentals Vol. 1">Mixtape: Evidence &#8211; Squirrel Tape Instrumentals Vol. 1</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/17/album-stream-queen-slim-soundtrack/" rel="bookmark" title="Album Stream: Queen &#038; Slim Soundtrack"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/HwGFOIUxgRQYgu3CPOMq7ucLeBCdW5cEDpvvxUsoUtZxIZekd4k8TmY41LGwLuuDWQHRrET-uA4gau3ygYt45j_EZbHpll0IkVo_QBTJeDjjCWEurdkzrzcMFMZRZHE6IGuaSTascms3dy48M661Qz-u28fOF9filQH0IX6mblwPGBEkOiUdnv-Btf7oDnqIJ7pZwUGGIIaoLDZLLGcxNn8cq0TD_ddwuPQAj0JBei3BhlD2AMGR-p_u2xp1-YaRiXTAutnV99490FgED9Sdrq87CCdItu4FNqSJi4-h9dZpoEcaocBo0NDWFUpORWnVCMn3OKiRX8FJrppl4yHTnDSzZhAP3HMFXTQQ7uXMvNWU5rcZThHdafwDH-sYNW8RGeQvU_CjoOFW5CXaIsldxNguzkRlPYK2IU06clrYNsNt2DelU6N0y3Ke4gDjiZxZvRQ1Zu26OEX34B6Llbu99NrRAQ4j2cP6bJjxictqXbzzsP0EmDBLjJCGWhnVRQmQ_IL9AYyHFQvzgcq2MuoTRQhwTXyCGh9l1pe6q5IxzBy37LT0frcqeGkVsgQZdpBlwKSTbPBf5HfNRkEjAWN6wl2AhQZ9vTlywzroUhEBU6jg1gSxyB8Z_3mPuHIioRBUJmSl4zpbg_OL5DZmqbmTWUkb_E96VD0SnjFGJF8nhAbVYZMc-eYUTPGM=s736-no" alt="" title="Album Stream: Queen &#038; Slim Soundtrack"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/17/album-stream-queen-slim-soundtrack/" rel="bookmark" title="Album Stream: Queen &#038; Slim Soundtrack">Album Stream: Queen &#038; Slim Soundtrack</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/17/album-stream-fred-the-godson-god-level-439/" rel="bookmark" title="Album Stream: Fred the Godson &#8211; God Level"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/DT0FakNVCC0LBsSEDm7y4ow5HIwq_cZAFsq09Y7F2VNaOUostVJVxhIG3Hht5aQpWRzKSAA0q043iqcQKsPELu7KNQuDBkfAH8crlBkQEr2uczCgCLVv6tZ0mnhAM2YEq78_deOb3m6ihOtIyjPljuddNUVKAgCYTiQO48Hw5pqmHAmOXnV8g5Kcw9TsWtQoeQYYoRttng1QgVkd29L2IratUQi6U9lakzxlstvzc8_ETOgWpJsxSksLRaoFVn1_qlcnHDoJ3kVkjnn-Znds6YNvRT-ZG_SvWoBdqdmSoCmwHrSEKoz7Qxi1BPXkzGnJx-psfPh3hJH6tVvkNw-iXwdhck446Oja8sOc9URbTtnWvp6uqph-YW4DXABHuUPWh-P2l-OBdL1ie-BjkYFCC5AfYm_JJZokWYRzKX65-_is9lS4NCKFo6LwJJpRNoP1s_Picc16-zntVkuqiB-f3Wad3jULjrgfTZVqnQXlyhxcptXAPxE_XsqBTJSbdqmoqCZsfdxkx75ZG6SphvZcIC6C1_vJHtQZQkbVZjHvo0Vtsz7kmnlclCF1jXbHhvZIIYUR6lBKRJW5qQDJTGPV-fVns8DJoOIpEZ-oOb8vQ00VNHv4Sk0kNbUTIvKEBuh84QOv2nykdSxwyNrMTq9Fqrwjn8bsgKF6xHmVmOz2KuLJTkoOAJ_1iley=s560-no" alt="" title="Album Stream: Fred the Godson &#8211; God Level"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/17/album-stream-fred-the-godson-god-level-439/" rel="bookmark" title="Album Stream: Fred the Godson &#8211; God Level">Album Stream: Fred the Godson &#8211; God Level</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_21_5dd73c252446a" data-td_block_id="td_uid_21_5dd73c252446a"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_21_5dd73c252446a" data-td_block_id="td_uid_21_5dd73c252446a"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_22_5dd73c2527734_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_22_5dd73c2527734" ><script>var block_td_uid_22_5dd73c2527734 = new tdBlock();
block_td_uid_22_5dd73c2527734.id = "td_uid_22_5dd73c2527734";
block_td_uid_22_5dd73c2527734.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_22_5dd73c2527734_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_22_5dd73c2527734.td_column_number = "3";
block_td_uid_22_5dd73c2527734.block_type = "td_block_mega_menu";
block_td_uid_22_5dd73c2527734.post_count = "5";
block_td_uid_22_5dd73c2527734.found_posts = "2539";
block_td_uid_22_5dd73c2527734.header_color = "";
block_td_uid_22_5dd73c2527734.ajax_pagination_infinite_stop = "";
block_td_uid_22_5dd73c2527734.max_num_pages = "508";
tdBlocksArray.push(block_td_uid_22_5dd73c2527734);
</script><div id=td_uid_22_5dd73c2527734 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/21/music-video-alicia-keys-time-machine/" rel="bookmark" title="Music Video: Alicia Keys &#8211; Time Machine"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/Q9nmAbQTToWrrh7HwA6dMpUo_1nhnCNujuilc9OHyIeuD_TPen1LJmEfF8lAXDKQOxyP4BKhIE2k3TJAIXgKZO96aToehNj05axUAEuTFIaKFMkyweROZ9EldPKFqDHwrIvEesi3J2jzU04aH1m8SVcUuigujXFYpdxgUUvwd6D4dnAlSBqRZLQ0HSRMnfnNgNpiOL2tNB2stRtLKbMnQn9mg7BKbGsBS19HZbEo3oFHcM6O3QHMfuvGuQqztODn_u6AYgoNqit523tb6SKmEkS4BZaIeeMo5s2765OnffmuTNBj9qDXe-W-h1rppQ49mLobPN0dNvIpqv3qNdYpuXGWkjt2js-7Qr6v709zLtcnkwKtUXL1V9AgyPKPJZ8pRMDmqdwIeM4bA3EG-sWOBhlZI9W9e8g7a9-6WrEJLPOdMbqbwjG5TNICs_sJYTb0s3N0I-S4kIeE3a4ijiSFXZyMGnM5369ZrQJf2UGuFO7JRd-yhBtt-owCLKZ0E0VuvUWXV6HTKkd4Bedix6sgAYf9nSCTYjExMkt4inulUeuCzmxskfTAOpN34BIRDe96CWh7zhZpm_GdWz0mz4y5NyaR0ENs9wTARo3cLvAVV3nP7AkM1LgN2hZHxpK5Y2gbMe-X7dArE24pPg1mj9DGOhMOLsenoLlV3QdUVV9dgHsHpoGOavoHZ5f6=w350-h220-no" alt="" title="Music Video: Alicia Keys &#8211; Time Machine"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/21/music-video-alicia-keys-time-machine/" rel="bookmark" title="Music Video: Alicia Keys &#8211; Time Machine">Music Video: Alicia Keys &#8211; Time Machine</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/21/music-video-denzel-curry-speedboat-84/" rel="bookmark" title="Music Video: Denzel Curry &#8211; SPEEDBOAT"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4oPeDhD6ArmNmJgHy3ybrBjkGi9Yr9pNm0CTtKl_66veHzkC3vFucFwNa4MVLwYuKzN4SdIhHO9jC3CQ827-SJXCZEhR5FZKNoS4kao5Yh_nTM4pzwZ2CvUHKEE5xERcek5amjruu_u4RkRdmWPIl-Eg6QbCYa_cEyT6flDydHlo6YKZSWqeDtr1yMRFJRWEytowvfSjzCH6OTFLDWOwh02v9YXC-W3o6tFDBKO63FAFS2s0PJtvsWcNsMeqyj3tICok3V8_QWOEQj1adtzjPilBdb4myV42ENlFecpXbV9PLhhBfHFOOZ4S0Y_OCQmMtpUdW79FC4qv-6HQirF4Vp9W5qX3OBDrzrmHwTstE3GLyIvWDgOfI7CZE5Zg3wfhXmA1mmVlmctTfNGOCmbTIK4y5gBPuVGsXOQx9w3phKNLYcpnReKDZq5KgKuMUbaPm-g3q-v2_1Hmb9cKdXv0yWlAKHpgWZTDRbj6NodCGXkY6dSqIORSI_w6RnFk-ZeApdFWlnhLMj2TfpazGODYiFtz30jiFn48xCzFA4cajrmObs_VHUkMq02r9FW-8ogaMVUP-xudUB0PoJEGxbKQt1lZJuKii2-sw_HQyETmzimd2xoq7nHznPB8UptsLz0o1d2efVNkHS4ZxM8-bM7hGz_eqKPmCXqoYfUcqK-DT9Qm8qXS8RJfQr1b=w842-h476-no" alt="" title="Music Video: Denzel Curry &#8211; SPEEDBOAT"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/21/music-video-denzel-curry-speedboat-84/" rel="bookmark" title="Music Video: Denzel Curry &#8211; SPEEDBOAT">Music Video: Denzel Curry &#8211; SPEEDBOAT</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/20/music-video-aap-twelvyy-bill-collector-3/" rel="bookmark" title="Music Video: A$AP Twelvyy &#8211; Bill Collector"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/mkGagyossHxaaCzG_f2zlYbIXyDYvLzLaFGI8w8-KUzxOgZnir8RSZnVndh__L6L5FpKj3QGOECIzR0teY_IfRLdP1TeYGCiK1Zslv7VvGPBuFPBU3_Esvi_qgpBqrVr4nf61fkN6mlw8gQjT44xmo028dRDqYk22IUc2v131BKbCFpelQ2NlXUdgerfh3U7Ip6k05YSOB5yCEJYV239u9FA9XJee4y053h9Xh88l47LnbCdPOrI5PgNm2Upi4vTJTmrj2UERf5oSwCDin56xWMLoO0qEaKHcHTB7RVFhSZjSYIhDvx0udUFFnzPqtRkfVmO7xfeGj0w_mJxcfynQNoW1Cfu6j3E9DBlo6B5Naz2gtDA3EkqLa86xHaSE4Z0ofyZcmAbPIr9kKJ041vggC0jCh83fgp2RNQaJiwkmOcwW7v99BkH-9IqEpbu7LeBctBJisOcPD6CwuNl_leHxP7LYDMoGz-lceXdnKZebmTYMV7vHQXI6In62083YQIBY4fb2NXF7ngQaOin9x8TkGvuByE_M1jRvc5Rh13OY20ayovZwizFgKLJUWHO51b6pymUf2YOccCDooKRrwcL9LApAadzEjbmYAfQVMNWeIVrI_ZysTknlIDzmLXMsaFjTinTv-PZI8sk7r-D0biaeHNkIF6-M2hhgN0hga4o2yv_X0Mupc024Dfl=w780-h474-no" alt="" title="Music Video: A$AP Twelvyy &#8211; Bill Collector"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/20/music-video-aap-twelvyy-bill-collector-3/" rel="bookmark" title="Music Video: A$AP Twelvyy &#8211; Bill Collector">Music Video: A$AP Twelvyy &#8211; Bill Collector</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/19/new-music-freddie-gibbs-gat-damn/" rel="bookmark" title="New Music: Freddie Gibbs &#8211; Gat Damn"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/HECVeS7qc9Q3ceo5rY__KZkfKCs1wCT1zL68FW7vDeHEn0_X8F1J5JFmS5GG9FneD3v3-j2nICkIvlpdw3Kkn_jCr_lAW7RZNzzD-U-84WcScbNnx1XuTiuzKFuworWbYJZTCgcEPdEV5KsD9jyl6ZGJd4TvEg4kfz1r-C4ewIxonn4zVblFGhjA06iuLSuPSDbwmN7naqOlZlBOBcqw0iPtydwtLJ4UOdUo9W581Q_mw-Ftioz6MyHXK25LzBsUT6E2q0S2grMyEW8a9tSowS6VPOO-TE-t1hgTsOtK87wNT2dkNqdXlz-14Jst1TnsolgLJD5QB-Hlgrv321toS3PbJwY4PfelFH3htl0ciXvbC4aUJCe5oR386-73SqQeORMQSrZrbJGB4lvjWogNFlU49eYcV6khzXWYdNxIBE0WzFu_pURNWfeWyPF5mbCh9ecgx-D_xedGOhgoELABtiVfcqinuw5JB7dzvwCkN89mfzk_z-94ekpqYYEPWMkdgpfVgPbEyewJcPalbrcRPO030oP1L8jHcm26f8-5LlFC3p29YJ-wTayXMo7dPmNVkS_pVmRmUgLg0Vql0ncrfWucNhcq9zvQ6TXg8zkgs9QR2juCgKuzV3CaQ30frGNu6xAOKUHS1-bE4O9J8NqOcYRO2Ob3z-Qn011Qd3n234i75rQEeuT2U9mu=w700-h394-no" alt="" title="New Music: Freddie Gibbs &#8211; Gat Damn"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/19/new-music-freddie-gibbs-gat-damn/" rel="bookmark" title="New Music: Freddie Gibbs &#8211; Gat Damn">New Music: Freddie Gibbs &#8211; Gat Damn</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/19/music-video-lucky-daye-karma-8/" rel="bookmark" title="Music Video: Lucky Daye &#8211; Karma"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/9hyMZFoDtITKQxjYEtiSnTUi30zV_IUmo_V7Jr829SFjH2WeOQg-LWjCwIUXJu-TgOcwb4B6iDZz1H-gdNd4a7t8xCIsReezlx_J2fDSGjDvG-UUZUZtGXzZZsmbx--MbxClRCIAO0p7QnWZ5wLuUdF2zu4eT1SSQUciK5UIycezOPtjQnxuQDcsfp-tTzbevrj8yhBLwc_1bDMNHCMUuIhdL5TA2jjg0IMnHORY7eyOEtV5AlEpU_I0WawQCy5QQ1ndcXpac_SrggtuBoOzlkveq1OVXn_IjqyQrM5SWQ3V6QipvgMGZ8NQ_HU7UtHXtzIrIEdGsp8cYCUZP1z7efDNZKw0LvAkPN4yFs-jVnY_CkuG7P7FhMHLMB00to04REYcHbtQNkPyJJ2gjKcw4NvnY29yK5B8z9zEYy90F86BeXbp0lC-xopKHVWZUjueCTK8ouN094C62WQ0gEq3cW98evsfm7pljsSDpKWGkhbf3bxDwnLfz2hK9KOer5ji837vw0uensBKpxSyIk0bl0bG5znmWnfvEEaB-C8SC72a0gz3w8l9jyCN5t7-pFq9_HGIiMiZwiLeR4TZKlWE0pPKTS-0QFsHIrdD5CPXAzUrahi0Fq84ee-XbeuTA7WtfvIe4BJbOgb1WulEEUUKUDtcU5T9KJmt5rsCS7ohPRP5looCofNi1TF_=w690-h524-no" alt="" title="Music Video: Lucky Daye &#8211; Karma"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/19/music-video-lucky-daye-karma-8/" rel="bookmark" title="Music Video: Lucky Daye &#8211; Karma">Music Video: Lucky Daye &#8211; Karma</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_22_5dd73c2527734" data-td_block_id="td_uid_22_5dd73c2527734"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_22_5dd73c2527734" data-td_block_id="td_uid_22_5dd73c2527734"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_23_5dd73c252b1cc_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_23_5dd73c252b1cc" ><script>var block_td_uid_23_5dd73c252b1cc = new tdBlock();
block_td_uid_23_5dd73c252b1cc.id = "td_uid_23_5dd73c252b1cc";
block_td_uid_23_5dd73c252b1cc.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"29","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_23_5dd73c252b1cc_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_23_5dd73c252b1cc.td_column_number = "3";
block_td_uid_23_5dd73c252b1cc.block_type = "td_block_mega_menu";
block_td_uid_23_5dd73c252b1cc.post_count = "4";
block_td_uid_23_5dd73c252b1cc.found_posts = "946";
block_td_uid_23_5dd73c252b1cc.header_color = "";
block_td_uid_23_5dd73c252b1cc.ajax_pagination_infinite_stop = "";
block_td_uid_23_5dd73c252b1cc.max_num_pages = "237";
tdBlocksArray.push(block_td_uid_23_5dd73c252b1cc);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_23_5dd73c252b1cc" id="td_uid_24_5dd73c252c13a" data-td_block_id="td_uid_23_5dd73c252b1cc" data-td_filter_value="" href="http://weuponithiphop.info/category/latest-news/">All</a><a class="mega-menu-sub-cat-td_uid_23_5dd73c252b1cc"  id="td_uid_25_5dd73c252c255" data-td_block_id="td_uid_23_5dd73c252b1cc" data-td_filter_value="69" href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a><a class="mega-menu-sub-cat-td_uid_23_5dd73c252b1cc"  id="td_uid_26_5dd73c252c374" data-td_block_id="td_uid_23_5dd73c252b1cc" data-td_filter_value="80" href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a><a class="mega-menu-sub-cat-td_uid_23_5dd73c252b1cc"  id="td_uid_27_5dd73c252c488" data-td_block_id="td_uid_23_5dd73c252b1cc" data-td_filter_value="2189" href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a><a class="mega-menu-sub-cat-td_uid_23_5dd73c252b1cc"  id="td_uid_28_5dd73c252cc87" data-td_block_id="td_uid_23_5dd73c252b1cc" data-td_filter_value="10" href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a><a class="mega-menu-sub-cat-td_uid_23_5dd73c252b1cc"  id="td_uid_29_5dd73c252d31b" data-td_block_id="td_uid_23_5dd73c252b1cc" data-td_filter_value="130" href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></div></div><div id=td_uid_23_5dd73c252b1cc class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/21/video-rapsody-funk-flex-freestyle-7/" rel="bookmark" title="Video: Rapsody &#8211; Funk Flex Freestyle"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4Gmebuwu1nNbedKtt1Khp72nr4EYg8FRqvQjYTFGMwXYxwqEbApRFvVLasxUGGWV7rXfTvI01jID_26Uc8nH70EySrh_tYwm9C6xwsosRbe5IUHGE795D9rBnv0cD_PdAU0FYnEHJNmPyWZmYWiDI2ic1RqB4Qgt136MPLZNCw3nfBQGpLGDVd4Wf0hE-JrETf6SuXrW_-xG5-XdXMNW0hg9MVK_r0_7kLHG_LGlnhDbgLNkJ1VFM3DmKamw6A1ElqSr-fnBFxdpWRyL8kZmEwxNg_ugcr04kLtOtVem15oj1S31QUIj8omV1U_yBrmZ1fL7X6xcr8taBdHw6giOSIQN870qqWWHjK1s04U1ixb-IOgj6558Ixy3AO8xXtuzvGvnwG3Aia71wbGMdcb-UlZC9mDNVvCqCkSHm7zyK6nbtRcx-_Es_XLhycMTmmbiOdb7xQn7O_LjsfTsz-MXGqvL7GuFP7OB6fsrN3k3wCbzT02x8jO2oVDFry_uEs0G4oHJ7zNKfaE0_mXNbt4zBvybGl6k-VzDDzkQ8gnwvyBavV3ikAXFnuJphp7F53MnIfQXTmYUSNA9WNWI6hr62tPD8B1CLAgXb_1evTCZ5u0S-uS2uestsv6MzwydeKGeC1r15vwXL9LxplebVHKY4Fe8fuu9ObvOD5vpzYJ3Pv9wAHRjAa6TwnBz=s328-no" alt="" title="Video: Rapsody &#8211; Funk Flex Freestyle"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/21/video-rapsody-funk-flex-freestyle-7/" rel="bookmark" title="Video: Rapsody &#8211; Funk Flex Freestyle">Video: Rapsody &#8211; Funk Flex Freestyle</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/20/2020-grammy-nominees/" rel="bookmark" title="2020 GRAMMY Nominees"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/iJjbZI0OwM8O8EXxzUEo3VCZZOSRrCNoiUsq7ZdR5doxrfa3CS3MEyO_jcJ_2IMmlBqjawx38GBIbQc2AuDcBSdeHux4RvoA-xW_L0Vux7Ivzt17AvM5UkNGlnSTv2SsUz_OAU_kU0rpXR5E8f2N4lVJ97Nni2KNrpQIFDhPFOe9BZPIrLu8xCnR4vXivRC5qYEkFjyD2mP2iibtPxIo-XhOthEwWvopol_biDzUUUvbmjKgvmPak4fU6PlhsSshtLNUZ7nxh-RLQmBVOywdcKeDHK8PRCvqsHNSLDGyymUEh2-gDHBCkh7JytKZnWhzfCm3BM5o_5Np6LmrIrOYRH7F1w5DyFJtfxeDp-nfnai5J1GWTgUYEjVicLqVA2zqVaTlPaZ3V0o3eoga293ewxjtvTOtMK3tJkrta-B8rgmqiT0Bu5pFchVzoZNL7VI4_3pKvyVW15Keh9kjujMa_o2fcvbB3oYIolYZ1yk9jrpuoACeCeuKJBNxnFbCmS6KfPmBzAGERY8DIX0wa9X8QThtNVH8xd0kV-oMVNJJz_QCqG3IkpCE48CbsPKopSVGHMhGptaHvEpwclN91X0PNyROgr3DxP_VdJ-U7BUhpKl2IaXNc721bkNvtu6TjEmr981_2g1N0j3jvLe8rxJdefanW95wFzkRwxmA21AJP_uJ_XRaKhcA1luT=s500-no" alt="" title="2020 GRAMMY Nominees"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/20/2020-grammy-nominees/" rel="bookmark" title="2020 GRAMMY Nominees">2020 GRAMMY Nominees</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/19/the-game-born-2-rap-artwork-tracklist-revealed-49/" rel="bookmark" title="The Game &#8211; Born 2 Rap (Artwork &#038; Tracklist Revealed)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/L6Rs_Tn7PVDBz_JZpMNyBK5fSM6eGLWXOTwt3mzG7cdky_4ja8u58AUeF97Fqor22NyhIlsa-gQDTeqZnyA4-k9xdcd99hqGI_pqeoxdYHQKaDCGK-3NtbNbEyig2oYOYiGWF2ozGj7JEEWL2TgLs3w0fNxGrFGlhjX9Hcb7DqIHJ_cJrBvlFCQ7P0nedNvlSo4F3U4UIgEeFCl1Pw7zuqkRM5ULNkqlxB4YV4193SxCJ6xmc4O0Cqng_nx69Ys5eFBI8lx2x8T93mTDmfiQUNI4996Uq31HOl4PExKExxNRLQzBVwI6k1U-jmFPGDizLgRpHCi1bMwSD5KHji9KeBQFNFZ6o4YWQwHmSdDOVFzLfaHp1P5iqr7Tcm3CvmBTmA_-uWop_YHwKyLheYqfMdfxIDSO24g9H8EKXt255HWdJBbnNrZQ5FSxAqkg3EoLS5_o1WIAMtj8ACBS73g-DE6MlI6GQQ0GwjKzmwgxkjVzz2KwSiApWasHJCIOK8_XF4UlZjLTPVkhhEm7Dx1o0x5ncekhBPhp1atXmp8I86UooEq68dRC6ID6tqe_5PcChiMz8cslSIbfyZx4eSVm7Rj4esLuH3FRWUy3GMTqsnJaxss-ifCngoK7rSx12QluQThgPrE6achPP0HDU8AAqFb-nYVa2lj7uvJQjrMOaXO8tT2iWqrkNxEp=w597-h596-no" alt="" title="The Game &#8211; Born 2 Rap (Artwork &#038; Tracklist Revealed)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/19/the-game-born-2-rap-artwork-tracklist-revealed-49/" rel="bookmark" title="The Game &#8211; Born 2 Rap (Artwork &#038; Tracklist Revealed)">The Game &#8211; Born 2 Rap (Artwork &#038; Tracklist Revealed)</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/19/video-dave-east-funk-flex-freestyle/" rel="bookmark" title="Video: Dave East &#8211; Funk Flex Freestyle"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/uo_FC7BTYXGCUOE7pE-AhCa4pZqXLbZMqsjhrxIbBEhNHvo0BBj6wBxaJb20wuykl85UxSWhcXlIZXfYdH8jS3bu5BV0RGjXVKd5DlBxCzmTwzKu_hrJZL_cqXFEYxeY1G2qEVjhxxs1CijUXVPVf0mX3ZivVgwPX5pxI2rfDu-FuiuY-PpBoR3lNHAMjMLvHyk2VmcLRX_pJM7U-YXzl0RJx2fw3xOZyzphr9ZMSo2VMagLjWGlvblep_lGW485X_tdhHTppH31HrKrjCb6ckC8RUn4xWwfhpJDdi5bcTC_3VZmJ0YMx2OkmfUX54X3FCfS05ZlOiNHiPCg5ooqACUu7htuYugq1b1zONrmT1L09dcXYpkwzF-LFnd_ATFHWOCxYgv01RNq4m16pfhmAsHhP8Pkmc8H1evp85b5zNArCOEYjuHtsmWblMjtau_x-q1TYBRzWhh1j6M44z9NR1JU6SvZd8sOTL0oCUp4TeKZad7zw8UwNLphbgTwxs0vWIX7clIf7ed9cZiEGyWkmljpkTljxBYwU2GOnRz0PENhB3hTNJOztTKSsL3Vx94LOxGrdKCt0XVuUBufbZ7MKeLdZ-CXJt9JRB4BsPd3RziEE-i0Him0UA5ygsaiyZaOTKtzZDYfGn4wJ9dNmzX3_5itPFmu9GprtloA9bzhJXX_36_RF8yQU6a-=w826-h547-no" alt="" title="Video: Dave East &#8211; Funk Flex Freestyle"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/19/video-dave-east-funk-flex-freestyle/" rel="bookmark" title="Video: Dave East &#8211; Funk Flex Freestyle">Video: Dave East &#8211; Funk Flex Freestyle</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_23_5dd73c252b1cc" data-td_block_id="td_uid_23_5dd73c252b1cc"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_23_5dd73c252b1cc" data-td_block_id="td_uid_23_5dd73c252b1cc"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_30_5dd73c2548dd9_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_30_5dd73c2548dd9" ><script>var block_td_uid_30_5dd73c2548dd9 = new tdBlock();
block_td_uid_30_5dd73c2548dd9.id = "td_uid_30_5dd73c2548dd9";
block_td_uid_30_5dd73c2548dd9.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"77","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_30_5dd73c2548dd9_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_30_5dd73c2548dd9.td_column_number = "3";
block_td_uid_30_5dd73c2548dd9.block_type = "td_block_mega_menu";
block_td_uid_30_5dd73c2548dd9.post_count = "4";
block_td_uid_30_5dd73c2548dd9.found_posts = "158";
block_td_uid_30_5dd73c2548dd9.header_color = "";
block_td_uid_30_5dd73c2548dd9.ajax_pagination_infinite_stop = "";
block_td_uid_30_5dd73c2548dd9.max_num_pages = "40";
tdBlocksArray.push(block_td_uid_30_5dd73c2548dd9);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_30_5dd73c2548dd9" id="td_uid_31_5dd73c2549b58" data-td_block_id="td_uid_30_5dd73c2548dd9" data-td_filter_value="" href="http://weuponithiphop.info/category/fashion/">All</a><a class="mega-menu-sub-cat-td_uid_30_5dd73c2548dd9"  id="td_uid_32_5dd73c2549cba" data-td_block_id="td_uid_30_5dd73c2548dd9" data-td_filter_value="76" href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></div></div><div id=td_uid_30_5dd73c2548dd9 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/LVT4Mid8WL4wHUdO9X2OZmZxxgbREs2lVtszOdEBaO6hJB0JS3yQOAyhNSdCyPmv0amBDTgNGpOlRPXPjKCl6yIlo2joyH3rQRI7CUdX09BJtQI1r5jy1_7BQtDhw4AxUhpUwIh35rNS3lTy7uq-FdPff10JN6srr9mwZ7zr04GQFxBVEXwCfC5rNVehXhY_wGCRVsmevYmdkBWEmB8dvOzBHY78NBBjcHNArS_S-2M0FJgDh8v9m9vEh78k_XmZg-AERctsf0bkODuPi1EcNJq_RnJIV6b0GG-VtKjo-OVPmYghWJYf1HiP9c58cQ98oABU8BDFdLqsBtNt4K0NmyHYQlX39W9k_d83wEHZ1-EacQa2o01VrYSn12HnZ1l88fMzu9PKv6EGmcRZNwpepycW7_9EQnhxIPDdVCmRLXUasUED9OXr-zJmnBcnSnLCa06k1ZymQym1LiSFEv1c3aPHnmnD3GY8nL7q5jPJr4HsABR0WCqMebcF3HF_0deNd0zgRBCGMxW-VzlIIHZiHuBeSPEPvUL149GJ5swSSvKm1uGEi1HlLBj9omJSU7mDWzO0p_7l-l7-4_ureEsGsgB8cX1t8t2TQcFeRgqqF1CXlZFYYC2K0iMb4jPsijsw_rtO7pmKvbngqHfgYpGeh_qLmDWeicR7=w1195-h796-no" alt="" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch">Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/fHEwwMf8DoiXlqkfibQS1Z1XXbviORbV9raaI44tOTXrWo7GgqM3gA-vswE10gFtTQUGGwNG7nWAACwHjxPuiubliYBN_dqtBZh2WIpxvumiJ-hSLK0TNWB2cB8Iw2STT5gcp_KqlDh_e4xng1vidI8EXdp_ooh5uDI-JV1HQ9dGnM5nxl_b-v8znqj-Rl_mGB7y4Lu9zsFNWHU7SriqQQJaKrKEEnb9T8zxmGLaL0zq7ilYpnUEhWulDDr9xc82wdr__WzRBm5YEskVpDAnGM2NDZwTZpjbe4QDdxeixWnSXNK_oDzaL7WTbCpkD33OK88BlI5JmFRQ5VmD11UQ2htB7-9WoahHvb4XmBsbLXpEMl1JmEP4sPx06VduzFnBNo-J90WI0n1AEIIcEYVbRywrkGJXbzmH__In9ZIg0EV24OcGGbeKl12HxTdZwucqsNnuZeNjiMHISQ7i8cfzm3N7X7Zenl74zsKIKeKWoIGxh6MTlVADvgHcrHebnjcSgil2vBeFyz_AP45aOv9SOwbzfVLGS0CNfe1s9b2J7qZgjcBk9QPEXCl2kygvzmGXFvU_3xBuW6S0i3Vkh3Ha_3hPBtvIAy3WoTK2yiqS41HzSK7yk3FRAlBtpIEib338fdkTiosBxtdu36SdNUVM75zl6CVIFhTu=w681-h470-no" alt="" title="Air Jordan 14 Rip Hamilton"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton">Air Jordan 14 Rip Hamilton</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/kUjaOYxjEkAh34S-Ub2QSZwdOwHyFnGFLBZULta3_bn1_myPMAwJXiEEsAAtc1ktCQwHCuKhSqSYsWXFBEIZxdfKuykoDEZWwO-dDI3_JeAshbYvyILEHUu0XaUpRn0mj7gOx10V52t8gRGYPCW7QXGImkPGGhvBPzBDVVqh9lKGtkuPeePmTnpRSmwp0LG1WHcIzUWnMqPBWQeHAat6Q-Tq7niXNb96ddEZsMEdHK1nmHVlNaeqFBNtTxk6yYRkFNCvtfBayqy-Rqt4CPU5tThxbTI4AIUCI6JLxJd_VJizrVNDEe2xZ_tiQdkC5ASIoHpX8sfvAB8zRUsMVJ6oMUt5FH_4GBNXDCtFRmr65Qt0JV1h4bBJffu2L272Q_vpD76wn-YNGW8VCtZcheHu_X-A4gdYQEC0HN0BenY-MOuUBqKEjXAc0SxWeP7W9RN55jlqUFK0nzEYydVjec2stdQIngVfg_FvKxvHXfM4XdtMpqeJnp3Pzyk8xjz30sAZd0f2HQ6zfdPjk-OkV2-WrC0_qW0L8Rq3zrUbq52n3BN7gm7sctU_CUlBmoQIgJDQBYk1Siv4tfSq9pL1R4GdaOlWQdxEuhZi8bTYC8GGAgNGl3SMAZGvk7nu6QnnwEZjZ7mZwbcqgyRKa89cOREMUvIkVJ8Q8lZu=w926-h672-no" alt="" title="Jordan Proto React Triple White"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White">Jordan Proto React Triple White</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4cDUjSODZSaXWfHyZKb9q3Fn7FHA4uB0KSBs0MtFHC0dc6AJb1zeAl_X2LOKalK9C7VBFhTqRQ9fw1ESgUr9ZUKFbOzD94i_s96nvkICOqrsYnzrE2nEAQHoEaGOF4O8GAI6T4CGFbgcQhNzjpRlSY60NyPu5Cmq81FRpEOFRzTOtSa_NnWzMmfwO0yxtPbcg5U6YBUsus8shv3SA7CjULLfaP38nZAuWVgq8PMaaeCQ_eSrK8NJSEVQjyyxmqb-1I7zO8Kvvzvwi--ibMr52CF8h-GusBzSq5ZuzvZRCGu_u8CyfoXw7pwWbOmHnLOdcQ9d2PCSW_IxEMGfmEuU7NxMSsW3Ga4r35_wLB7cjvlPC9OjCV50tfekXjZBS_476mzlf4G9jR7Ju1GqgjXah9Uqc_0Y8N-Br8_JCtIlRSuLxAiebwd7AvFVlgWId9MYxBWnRT3cTyD8SH7q5WwO-CIbKAOSKsNcrrTgFxQvqn9yklBU1u5X5fdTlTBk4WSYorsWZAug0z9BOymRLnrhTbnA0vpBPFROWD-aL1glg-eUpFSfgD4xhWsOqJNY9krQ2UbLSGXQ5gYWj0ovLS7Yz3UKFY2qrVWpqkpbfyN98es9NJ-7LTUs2MLq1rX_2FaQmyq5mVndd7VGzQOHy9hDULG-5H-0LvGd=w900-h566-no" alt="" title="adidas Yeezy Boost 350 V2 Hyperspace"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace">adidas Yeezy Boost 350 V2 Hyperspace</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_30_5dd73c2548dd9" data-td_block_id="td_uid_30_5dd73c2548dd9"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_30_5dd73c2548dd9" data-td_block_id="td_uid_30_5dd73c2548dd9"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div>                </div>

                <div class="td-pb-span5 td-sub-footer-copy">
                    &copy; 2018 The Hip Hop Chronicles Media Group                </div>
            </div>
        </div>
    </div>
</div><!--close td-outer-wrap-->

	<div id="wpcp-error-message" class="msgmsg-box-wpcp warning-wpcp hideme"><span>error: </span>Not Prohibited. ✌️</div>
	<script>
	var timeout_result;
	function show_wpcp_message(smessage)
	{
		if (smessage !== "")
			{
			var smessage_text = '<span>Alert: </span>'+smessage;
			document.getElementById("wpcp-error-message").innerHTML = smessage_text;
			document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp showme";
			clearTimeout(timeout_result);
			timeout_result = setTimeout(hide_message, 3000);
			}
	}
	function hide_message()
	{
		document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp hideme";
	}
	</script>
	<style type="text/css">
	#wpcp-error-message {
	    direction: ltr;
	    text-align: center;
	    transition: opacity 900ms ease 0s;
	    z-index: 99999999;
	}
	.hideme {
    	opacity:0;
    	visibility: hidden;
	}
	.showme {
    	opacity:1;
    	visibility: visible;
	}
	.msgmsg-box-wpcp {
		border-radius: 10px;
		color: #555;
		font-family: Tahoma;
		font-size: 11px;
		margin: 10px;
		padding: 10px 36px;
		position: fixed;
		width: 255px;
		top: 50%;
  		left: 50%;
  		margin-top: -10px;
  		margin-left: -130px;
  		-webkit-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
		-moz-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
		box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
	}
	.msgmsg-box-wpcp span {
		font-weight:bold;
		text-transform:uppercase;
	}
	.error-wpcp {		background:#ffecec url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/error.png') no-repeat 10px 50%;
		border:1px solid #f5aca6;
	}
	.success {
		background:#e9ffd9 url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/success.png') no-repeat 10px 50%;
		border:1px solid #a6ca8a;
	}
	.warning-wpcp {
		background:#ffecec url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/warning.png') no-repeat 10px 50%;
		border:1px solid #f5aca6;
	}
	.notice {
		background:#e3f7fc url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/notice.png') no-repeat 10px 50%;
		border:1px solid #8ed9f6;
	}
    </style>


    <!--

        Theme: Newspaper by tagDiv 2016
        Version: 7.2 (rara)
        Deploy mode: deploy
        
        uid: 5dd73c2556c05
    -->

    <link rel='stylesheet' id='so-css-Newspaper-css'  href='http://weuponithiphop.info/wp-content/uploads/so-css/so-css-Newspaper.css?ver=1528674688' type='text/css' media='all' />
<link rel='stylesheet' id='soliloquy-lite-style-css'  href='http://weuponithiphop.info/wp-content/plugins/soliloquy-lite/assets/css/soliloquy.css?ver=2.5.6' type='text/css' media='all' />
<link rel='stylesheet' id='soliloquy-liteclassic-theme-css'  href='http://weuponithiphop.info/wp-content/plugins/soliloquy-lite/themes/classic/style.css?ver=2.5.6' type='text/css' media='all' />
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/themes/Newspaper/js/tagdiv_theme.js?ver=7.2'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/comment-reply.min.js?ver=4.9.12'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/wp-embed.min.js?ver=4.9.12'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/plugins/soliloquy-lite/assets/js/min/soliloquy-min.js?ver=2.5.6'></script>

<!-- JS generated by theme -->

<script>
    


            

	            // if the theme has tdBackstr support, it means this already uses it
                if ( 'undefined' !== typeof window.tdBackstr ) {

                    (function(){
                        // the site background td-backstretch jquery object is dynamically added in DOM, and after any translation effects are applied over td-backstretch
                        var wrapper_image_jquery_obj = jQuery( '<div class=\'backstretch\'></div>' );
                        var image_jquery_obj = jQuery( '<img class=\'td-backstretch not-parallax\' src=\'http://weuponithiphop.info/wp-content/uploads/city-skyline-1.png\'>' );

                        wrapper_image_jquery_obj.append( image_jquery_obj );

                        jQuery( 'body' ).prepend( wrapper_image_jquery_obj );

                        var td_backstr_item = new tdBackstr.item();

                        td_backstr_item.wrapper_image_jquery_obj = wrapper_image_jquery_obj;
                        td_backstr_item.image_jquery_obj = image_jquery_obj;

	                    tdBackstr.add_item( td_backstr_item );

                    })();
                }

            
            
jQuery(window).ready(function() {
(function(){
var td_backstr_item = new tdBackstr.item();
td_backstr_item.wrapper_image_jquery_obj = jQuery( "#td-full-screen-header-image" );
td_backstr_item.image_jquery_obj = td_backstr_item.wrapper_image_jquery_obj.find( 'img:first' );
tdBackstr.add_item( td_backstr_item );
jQuery('.td-read-down a').click(function(event){
event.preventDefault();
var header_wrap = jQuery( '.td-full-screen-header-image-wrap:first' )
if ( 1 === header_wrap.length ) {
tdUtil.scrollToPosition(header_wrap.height() + header_wrap.offset().top, 1200);
}
});
})();
});

                jQuery().ready(function jQuery_ready() {
                    tdAjaxCount.tdGetViewsCountsAjax("post","[35861]");
                });
            

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'http://weuponithiphop.info/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'http://weuponithiphop.info/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>

			<script type="text/javascript">
			if ( typeof soliloquy_slider === 'undefined' || false === soliloquy_slider ) {soliloquy_slider = {};}jQuery('#soliloquy-container-30342').css('height', Math.round(jQuery('#soliloquy-container-30342').width()/(960/300)));jQuery(window).load(function(){var $ = jQuery;var soliloquy_container_30342 = $('#soliloquy-container-30342'),soliloquy_30342 = $('#soliloquy-30342');soliloquy_slider['30342'] = soliloquy_30342.soliloquy({slideSelector: '.soliloquy-item',speed: 0,pause: 2000,auto: 1,useCSS: 0,keyboard: true,adaptiveHeight: 1,adaptiveHeightSpeed: 400,infiniteLoop: 1,mode: 'fade',pager: 1,controls: 1,nextText: '',prevText: '',startText: '',stopText: '',onSliderLoad: function(currentIndex){soliloquy_container_30342.find('.soliloquy-active-slide').removeClass('soliloquy-active-slide').attr('aria-hidden','true');soliloquy_container_30342.css({'height':'auto','background-image':'none'});if ( soliloquy_container_30342.find('.soliloquy-slider li').length > 1 ) {soliloquy_container_30342.find('.soliloquy-controls').fadeTo(300, 1);}soliloquy_30342.find('.soliloquy-item:not(.soliloquy-clone):eq(' + currentIndex + ')').addClass('soliloquy-active-slide').attr('aria-hidden','false');soliloquy_container_30342.find('.soliloquy-clone').find('*').removeAttr('id');soliloquy_container_30342.find('.soliloquy-controls-direction').attr('aria-label','carousel buttons').attr('aria-controls', 'soliloquy-container-30342');soliloquy_container_30342.find('.soliloquy-controls-direction a.soliloquy-prev').attr('aria-label','previous');soliloquy_container_30342.find('.soliloquy-controls-direction a.soliloquy-next').attr('aria-label','next');},onSlideBefore: function(element, oldIndex, newIndex){soliloquy_container_30342.find('.soliloquy-active-slide').removeClass('soliloquy-active-slide').attr('aria-hidden','true');$(element).addClass('soliloquy-active-slide').attr('aria-hidden','false');},onSlideAfter: function(element, oldIndex, newIndex){},});});			</script>
			
</body>
</html>