<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>New Music: Cam&#039;ron – Big Deal</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="http://weuponithiphop.info/xmlrpc.php" />
    <meta property="og:image" content="https://lh3.googleusercontent.com/aGalCcqGTIvaozKSFJGlqJtr1VW-tOa7ncWK988f0iijDRUT-rmFsGb05ot_e7P2sPbQDKdlURMzQYOGAEHFZgnro4sQp_ZCnp_1w5aqzZRmdIiNrji_Uyz36OZl1xxr8KU4CKz7YKlSSKJ8bCM80DO1Gcjbkamcy_JyTmFZhRWvK12XD_8CIzcafmDBYqBr9cS3RXlQcxoN_n8uPmvwucCvBBWaQbuv6k3NyI2igtH_myCOZvNoxeQPhVtZtS-FZiJDm_OtQXh1LEF29l0KZaB31jXxYicxalIeqHgWcXpLsnobn_6VfrEQ7U2mv5jEfkc6xP4sRu18_YKhIxs9TkYbSUwQ_9SKlFAOEHRLERu2kUDlnYblQmkfWspAyoZIC6G9IV2QUi1NFv9QGsSWlZohiUXuSARdc1XnLUPzrczaT6AZ7KJZi3mMJVNnPzlHJ4x55m8EWjQUWLFjOxXfS0phhtvlGJYvkiW9G0YASqwp8NegyC9Yxvlf3Y2u7VX4TvsTwS36kxkvk0geRnlRB6-dAPeTB6aig6m9jBODL5tlYbKYWI5TBOSjzv7cb7YC3K-p-7TSUHdIIUDd25YWxyCXLO8OK-u_BgNNCDtP9NhYQ6tDYUEcn7hkF83Z6f3hFvL0OFB5KbdukzmIxK6e_M4K2ZplYxcm_gMEZL3TFC-B2pZuhtYLyemW=s600-no" /><meta name="author" content="cyclone">
<link rel="icon" type="image/png" href="http://weuponithiphop.info/wp-content/uploads/weuponitlogoCAP-500x457.png">
<!-- All in One SEO Pack 3.2.7 by Michael Torbert of Semper Fi Web Design[208,261] -->
<script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"http://weuponithiphop.info/#organization","url":"http://weuponithiphop.info/","name":"WeUpOnIt","sameAs":[]},{"@type":"WebSite","@id":"http://weuponithiphop.info/#website","url":"http://weuponithiphop.info/","name":"WeUpOnIt","publisher":{"@id":"http://weuponithiphop.info/#organization"}},{"@type":"WebPage","@id":"http://weuponithiphop.info/2019/12/10/new-music-camron-big-deal/#webpage","url":"http://weuponithiphop.info/2019/12/10/new-music-camron-big-deal/","inLanguage":"en-US","name":"New Music: Cam\u2019ron &#8211; Big Deal","isPartOf":{"@id":"http://weuponithiphop.info/#website"},"datePublished":"2019-12-10T10:50:56+00:00","dateModified":"2019-12-10T10:50:56+00:00"},{"@type":"Article","@id":"http://weuponithiphop.info/2019/12/10/new-music-camron-big-deal/#article","isPartOf":{"@id":"http://weuponithiphop.info/2019/12/10/new-music-camron-big-deal/#webpage"},"author":{"@id":"http://weuponithiphop.info/author/cyclone/#author"},"headline":"New Music: Cam\u2019ron &#8211; Big Deal","datePublished":"2019-12-10T10:50:56+00:00","dateModified":"2019-12-10T10:50:56+00:00","commentCount":0,"mainEntityOfPage":{"@id":"http://weuponithiphop.info/2019/12/10/new-music-camron-big-deal/#webpage"},"publisher":{"@id":"http://weuponithiphop.info/#organization"},"articleSection":"New Music, Cam'Ron"},{"@type":"Person","@id":"http://weuponithiphop.info/author/cyclone/#author","name":"cyclone","sameAs":[],"image":{"@type":"ImageObject","@id":"http://weuponithiphop.info/#personlogo","url":"http://0.gravatar.com/avatar/6a747aaba64ebc36f309e25ac7e460e6?s=96&d=mm&r=g","width":96,"height":96,"caption":"cyclone"}}]}</script>
<link rel="canonical" href="http://weuponithiphop.info/2019/12/10/new-music-camron-big-deal/" />
<!-- All in One SEO Pack -->
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Feed" href="http://weuponithiphop.info/feed/" />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Comments Feed" href="http://weuponithiphop.info/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; New Music: Cam’ron &#8211; Big Deal Comments Feed" href="http://weuponithiphop.info/2019/12/10/new-music-camron-big-deal/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/weuponithiphop.info\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.12"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='google_font_open_sans-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;ver=4.9.12' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_roboto-css'  href='http://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C900%2C500italic%2C400%2C300&#038;ver=4.9.12' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='http://fonts.googleapis.com/css?family=Roboto+Condensed%3A400%2C700&#038;ver=4.9.12' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='http://weuponithiphop.info/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=4.12' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='http://weuponithiphop.info/wp-content/themes/Newspaper/style.css?ver=7.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css'  href='http://weuponithiphop.info/wp-content/themes/Newspaper/includes/demos/what/demo_style.css?ver=7.2' type='text/css' media='all' />
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1'></script>
<link rel='https://api.w.org/' href='http://weuponithiphop.info/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://weuponithiphop.info/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://weuponithiphop.info/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='New Music: Terrace Martin &#8211; The Deuce' href='http://weuponithiphop.info/2019/12/10/new-music-terrace-martin-the-deuce-4/' />
<meta name="generator" content="WordPress 4.9.12" />
<link rel='shortlink' href='http://weuponithiphop.info/?p=36098' />
<link rel="alternate" type="application/json+oembed" href="http://weuponithiphop.info/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fweuponithiphop.info%2F2019%2F12%2F10%2Fnew-music-camron-big-deal%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://weuponithiphop.info/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fweuponithiphop.info%2F2019%2F12%2F10%2Fnew-music-camron-big-deal%2F&#038;format=xml" />

<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>
<script id="wpcp_disable_selection" type="text/javascript">
//<![CDATA[
var image_save_msg='You Can Not Save images!';
	var no_menu_msg='Context Menu disabled!';
	var smessage = "Not Prohibited. ✌️";

function disableEnterKey(e)
{
	if (e.ctrlKey){
     var key;
     if(window.event)
          key = window.event.keyCode;     //IE
     else
          key = e.which;     //firefox (97)
    //if (key != 17) alert(key);
     if (key == 97 || key == 65 || key == 67 || key == 99 || key == 88 || key == 120 || key == 26 || key == 85  || key == 86 || key == 83 || key == 43)
     {
          show_wpcp_message('You are not allowed to copy content or view source');
          return false;
     }else
     	return true;
     }
}

function disable_copy(e)
{	
	var elemtype = e.target.nodeName;
	var isSafari = /Safari/.test(navigator.userAgent) && /Apple Computer/.test(navigator.vendor);
	elemtype = elemtype.toUpperCase();
	var checker_IMG = '';
	if (elemtype == "IMG" && checker_IMG == 'checked' && e.detail >= 2) {show_wpcp_message(alertMsg_IMG);return false;}
	if (elemtype != "TEXT" && elemtype != "TEXTAREA" && elemtype != "INPUT" && elemtype != "PASSWORD" && elemtype != "SELECT" && elemtype != "OPTION" && elemtype != "EMBED")
	{
		if (smessage !== "" && e.detail == 2)
			show_wpcp_message(smessage);
		
		if (isSafari)
			return true;
		else
			return false;
	}	
}
function disable_copy_ie()
{
	var elemtype = window.event.srcElement.nodeName;
	elemtype = elemtype.toUpperCase();
	if (elemtype == "IMG") {show_wpcp_message(alertMsg_IMG);return false;}
	if (elemtype != "TEXT" && elemtype != "TEXTAREA" && elemtype != "INPUT" && elemtype != "PASSWORD" && elemtype != "SELECT" && elemtype != "OPTION" && elemtype != "EMBED")
	{
		//alert(navigator.userAgent.indexOf('MSIE'));
			//if (smessage !== "") show_wpcp_message(smessage);
		return false;
	}
}	
function reEnable()
{
	return true;
}
document.onkeydown = disableEnterKey;
document.onselectstart = disable_copy_ie;
if(navigator.userAgent.indexOf('MSIE')==-1)
{
	document.onmousedown = disable_copy;
	document.onclick = reEnable;
}
function disableSelection(target)
{
    //For IE This code will work
    if (typeof target.onselectstart!="undefined")
    target.onselectstart = disable_copy_ie;
    
    //For Firefox This code will work
    else if (typeof target.style.MozUserSelect!="undefined")
    {target.style.MozUserSelect="none";}
    
    //All other  (ie: Opera) This code will work
    else
    target.onmousedown=function(){return false}
    target.style.cursor = "default";
}
//Calling the JS function directly just after body load
window.onload = function(){disableSelection(document.body);};
//]]>
</script>
	<script id="wpcp_disable_Right_Click" type="text/javascript">
	//<![CDATA[
	document.ondragstart = function() { return false;}
	/* ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
	Disable context menu on images by GreenLava Version 1.0
	^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ */
	    function nocontext(e) {
	       return false;
	    }
	    document.oncontextmenu = nocontext;
	//]]>
	</script>
<!-- Analytics by WP-Statistics v12.6.9 - https://wp-statistics.com/ -->
<!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]-->
<!-- JS generated by theme -->

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var tds_login_sing_in_widget="show";
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_ajax_url="http:\/\/weuponithiphop.info\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=7.2";
var td_get_template_directory_uri="http:\/\/weuponithiphop.info\/wp-content\/themes\/Newspaper";
var tds_snap_menu="snap";
var tds_logo_on_sticky="show_header_logo";
var tds_header_style="5";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#dd3333";
var tds_smart_sidebar="enabled";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>


<!-- Header style compiled by theme -->

<style>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</style>

<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>

<body class="post-template-default single single-post postid-36098 single-format-standard unselectable new-music-camron-big-deal td-what single_template_7 wpb-js-composer js-comp-ver-4.12 vc_responsive td-boxed-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
                    <div class="td-menu-login-section">
                
    <div class="td-guest-wrap">
        <div class="td-menu-avatar"><div class="td-avatar-container"><img alt='' src='http://2.gravatar.com/avatar/?s=80&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo avatar-default' height='80' width='80' /></div></div>
        <div class="td-menu-login"><a id="login-link-mob">Sign in</a></div>
    </div>
            </div>
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-top-menu-container"><ul id="menu-top-menu" class="td-mobile-main-menu"><li id="menu-item-317" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-first menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a></li>
<li id="menu-item-706" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a></li>
<li id="menu-item-314" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a></li>
<li id="menu-item-316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-0" class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></li>
</ul>
</li>
<li id="menu-item-705" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></li>
</ul>
</li>
<li id="menu-item-18581" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li id="menu-item-3199" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
            <div id="login-form-mobile" class="td-register-section">
            
            <div id="td-login-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-login-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign in</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
	                <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
	                <div class="td-login-info-text"><a href="#" id="forgot-pass-link-mob">Forgot your password?</a></div>
                </div>
            </div>

            

            <div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
                <!-- close button -->
	            <div class="td-forgot-pass-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Password recovery</div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title">Recover your password</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
	                <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
                </div>
            </div>
        </div>
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="http://weuponithiphop.info/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap">
    
        <!--
Header style 5
-->

<div class="td-header-wrap td-header-style-5">

    <div class="td-header-top-menu-full">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div >

                Tuesday, December 10, 2019
            </div>
        </div>
    <ul class="top-header-menu td_ul_login"><li class="menu-item"><a class="td-login-modal-js menu-item" href="#login-form" data-effect="mpf-td-login-effect">Sign in / Join</a><span class="td-sp-ico-login td_sp_login_ico_style"></span></li></ul><div class="menu-top-container"><ul id="menu-main" class="top-header-menu"><li id="menu-item-79" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-79"><a href="http://weuponithiphop.info">Home</a></li>
<li id="menu-item-81" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-81"><a target="_blank" href="http://weuponitradio.com">Power 105.1 WeUpOnIt Radio</a></li>
<li id="menu-item-80" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-80"><a target="_blank" href="https://shop.spreadshirt.com/freshandcleantees/">Shop</a></li>
<li id="menu-item-18582" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18582"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li id="menu-item-18583" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18583"><a href="http://weuponithiphop.info/privacy-policy-2/">Privacy Policy</a></li>
</ul></div></div>
        <div class="td-header-sp-top-widget">
    
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div>
    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <ul class="td-login-tabs">
                        <li><a id="login-link" class="td_login_tab_focus">LOG IN</a></li>
                    </ul>



                    <div class="td-login-wrap">
                        <div class="td_display_err"></div>

                        <div id="td-login-div" class="">
                            <div class="td-login-panel-title">Welcome! Log into your account</div>
                            <input class="td-login-input" type="text" name="login_email" id="login_email" placeholder="your username" value="" required>
                            <input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" placeholder="your password" required>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Log In">


                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password?</a></div>


                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-display-none">
                            <div class="td-login-panel-title">Recover your password</div>
                            <input class="td-login-input" type="text" name="forgot_email" id="forgot_email" placeholder="your email" value="" required>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Pass">
                        </div>




                    </div>
                </div>
                        </div>
    </div>

    <div class="td-header-menu-wrap-full">
        <div class="td-header-menu-wrap">
            <div class="td-container td-header-row td-header-main-menu black-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-menu">
        		<a class="td-mobile-logo td-sticky-header" href="http://weuponithiphop.info/">
			<img class="td-retina-data" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-5.png" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-5.png" alt=""/>
		</a>
			<a class="td-header-logo td-sticky-header" href="http://weuponithiphop.info/">
			<img class="td-retina-data" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" alt=""/>
			<span class="td-visual-hidden">WeUpOnIt</span>
		</a>
	    </div>
    <div class="menu-top-menu-container"><ul id="menu-top-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-first td-menu-item td-mega-menu menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_1_5defd76554751_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_1_5defd76554751" ><script>var block_td_uid_1_5defd76554751 = new tdBlock();
block_td_uid_1_5defd76554751.id = "td_uid_1_5defd76554751";
block_td_uid_1_5defd76554751.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"43","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_1_5defd76554751_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_1_5defd76554751.td_column_number = "3";
block_td_uid_1_5defd76554751.block_type = "td_block_mega_menu";
block_td_uid_1_5defd76554751.post_count = "5";
block_td_uid_1_5defd76554751.found_posts = "2648";
block_td_uid_1_5defd76554751.header_color = "";
block_td_uid_1_5defd76554751.ajax_pagination_infinite_stop = "";
block_td_uid_1_5defd76554751.max_num_pages = "530";
tdBlocksArray.push(block_td_uid_1_5defd76554751);
</script><div id=td_uid_1_5defd76554751 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/10/new-music-camron-big-deal/" rel="bookmark" title="New Music: Cam’ron &#8211; Big Deal"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/aGalCcqGTIvaozKSFJGlqJtr1VW-tOa7ncWK988f0iijDRUT-rmFsGb05ot_e7P2sPbQDKdlURMzQYOGAEHFZgnro4sQp_ZCnp_1w5aqzZRmdIiNrji_Uyz36OZl1xxr8KU4CKz7YKlSSKJ8bCM80DO1Gcjbkamcy_JyTmFZhRWvK12XD_8CIzcafmDBYqBr9cS3RXlQcxoN_n8uPmvwucCvBBWaQbuv6k3NyI2igtH_myCOZvNoxeQPhVtZtS-FZiJDm_OtQXh1LEF29l0KZaB31jXxYicxalIeqHgWcXpLsnobn_6VfrEQ7U2mv5jEfkc6xP4sRu18_YKhIxs9TkYbSUwQ_9SKlFAOEHRLERu2kUDlnYblQmkfWspAyoZIC6G9IV2QUi1NFv9QGsSWlZohiUXuSARdc1XnLUPzrczaT6AZ7KJZi3mMJVNnPzlHJ4x55m8EWjQUWLFjOxXfS0phhtvlGJYvkiW9G0YASqwp8NegyC9Yxvlf3Y2u7VX4TvsTwS36kxkvk0geRnlRB6-dAPeTB6aig6m9jBODL5tlYbKYWI5TBOSjzv7cb7YC3K-p-7TSUHdIIUDd25YWxyCXLO8OK-u_BgNNCDtP9NhYQ6tDYUEcn7hkF83Z6f3hFvL0OFB5KbdukzmIxK6e_M4K2ZplYxcm_gMEZL3TFC-B2pZuhtYLyemW=s600-no" alt="" title="New Music: Cam’ron &#8211; Big Deal"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/10/new-music-camron-big-deal/" rel="bookmark" title="New Music: Cam’ron &#8211; Big Deal">New Music: Cam’ron &#8211; Big Deal</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/10/new-music-terrace-martin-the-deuce-4/" rel="bookmark" title="New Music: Terrace Martin &#8211; The Deuce"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/rO3-2jSprEBWYUMIGU8sECnRvBUezh2-DkwS1j-xQQMFElAA7mhQUz_7UBMrgitdChZxPZ_TbYFh3orO6fhRC4QEvO_AwVkqulCWTK4Xb0_xZ3aHBbktv0VEMt1t6-QMmXwVqOX8sfq7PD1DQdHCNHEUi0S7-7RSe1W0T1QnQvDCNggnpqp-OAcITPgCowMI9G4mVz3Mgd-TuuxGVENmJ4WcMvaqd-m3YWwK5xeFWF1OJcsbSjrj1uS5O8L5g_nMjJk4BLTS53u0SrVapoxZcbN_Sxzz_fC0FC59VbBHB3SfUdhSVGXoXwO9RqYKwYtEnJu8GIU72urKAjSdWsG4OoLWssFd2pf7N0AOAU0ao0DjjzuOn4z846NMYSteWdcyE0IkxW4RkGb5oPgwfLKyYDTdVekwpup6j_61P8KdRDSHcUZM9B-_Kwl0DubJQq8lbUzaJZF8z0y_fLsxuGJxFEtxhOBBVgmJo7asLGOHq-POjZ7Ce1_FLQTFsEjx3DZ_7AF3m2byVgMviMbgDwo66JOK46CqbY3g2Rh3Is9y5rHdwAReeIpbudtu8p3WdHdMChyPdFV6Cf6TdilXneIBGok9U3LSwmZdhcB1Z4PaLqR_oXAqhaL1MxPjH4T42dquSiPrcVC7M902GkqMSD-uFYg05Q2bAMDdwqd1e0Bfxvsc2BAhVT0ebqAv=s328-no" alt="" title="New Music: Terrace Martin &#8211; The Deuce"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/10/new-music-terrace-martin-the-deuce-4/" rel="bookmark" title="New Music: Terrace Martin &#8211; The Deuce">New Music: Terrace Martin &#8211; The Deuce</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/09/new-music-rich-the-kid-ft-quavo-thats-tuff/" rel="bookmark" title="New Music: Rich the Kid ft. Quavo &#8211; That’s Tuff"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/p5wtJ1qC0cDE4dGwXatEU1X1g-IARVN9K2QtgA28iaKSh7J2vJdutJd-T6MZm0qFpPQn5mUvC6POcAD-K5-NkMtG5ivRVuPeBkKpvEDu7W4Ig3k13ui5L8iE0OCzBf6_Bte7CoVUKBOrvhHon35NhalxL-Y-cig2wl7HFlwgj5aAYIcLXUgZMz6NDD0e_bQ7jLIKs0YyrimiFFPIuqxQvTLiItVfsZG56vTuSYOwMHx2Il7gFQoMhIxinUCZpqclJYoREeNGvZnayEb-lsLYz9vi4zf4NXOXQNvmBw1DfVEcpjvbjhaQ9CZrgCghxxMpZTPXFH1hn4iax6B9CiOvOpiNGpVfYRrlQZJAw1d9Yi_tFL1rv5ApVE_XfnKwPJrzCeMomoxSaFLcAJNRV8LnS26epzKuG9zvG6k_riVo-9ZgKUJz-jFUa7TsKMOm6rGs2G7RyUsfMGdZdJymQnPN76A1JWj5rwSqoYii2zq9R_sg5mPpfZyv2v2cN1uI7HqhoxtzSBHUL5PX1CrOp-EIGS0PS7rCYkakzO93GwcYwNMupdbsS3Z8iXPowxJ2O2OAkSi7y6zw7JBvNu9Tar9V-7xBhO8218YvOn8qjOl8OORkwCrKa5Pi9UThkJ3Zu7C2zyAsdtNQ3P-Sd1Lzoi-NusbKTCcIXU9IKhLVJFo6Z3RB0Dktdd6ngCq2=s500-no" alt="" title="New Music: Rich the Kid ft. Quavo &#8211; That’s Tuff"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/09/new-music-rich-the-kid-ft-quavo-thats-tuff/" rel="bookmark" title="New Music: Rich the Kid ft. Quavo &#8211; That’s Tuff">New Music: Rich the Kid ft. Quavo &#8211; That’s Tuff</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/09/new-music-sauce-walka-ft-mozzy-mama/" rel="bookmark" title="New Music: Sauce Walka ft.Mozzy &#8211; Mama"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/P50E9cP1kYpcDupUHGV9VzwTQgvFJ2NKMvybBqX83rhL_OdeHfaI22jgwnevd8R0QsPiioXMck7hr7QT6tUOylFNoSCRXlzEhw78DnKT52T9AbReP860G0TxdyA-WplNUDnKy1FGMNLUdrJustWJfN3Xl_qVHrMbp41XoZ8O-zoZj3X4LOEOufj8m9oqRBu9tu34qbrQCyPz8BdB2RcaIB24t_8C4C8kiMu5CuhE-qKTtxK41VAEFyFyendELEeFN3p7WY9i9bLJ2wH8p6svZ-tKm3tl7HswdjrHkLTcz0ksff6B0MDxxeQDkk3cv-Rms58aSF1RJ7JuBSRgDJ19vS2iuG8pzg3ctmRTvUceJCH4yw0T8pVjq0BLIf5L_lZvMY7HOXKNZmGe3a2R3-y74B_SI0qs9cOZ8owzwK_iLfMEIXj7_yp5clfBF02tFv_j0fVkAMhEf1vWJK19SFJmc1vrb3AohLe3_Ska_Emo8Yafg7rGpWBXrFWx4UkGt8ODwJ7P59biKLxJbGweTkyLmHK7i14H_jG4XEsdJopbBfT_fPFcnCJ0ekMFrpL8jvOS8wEeCN-1MnalE2VfFyYUjIdCWZdGs5j2FeMannbs594PW4Kw2TC0BvbwuKAGDD8RSHjLLOef3IISgWqJq1DJNpocsuuOi4giKzV1Yc248PixoP--r5V-Ycw=s750-no" alt="" title="New Music: Sauce Walka ft.Mozzy &#8211; Mama"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/09/new-music-sauce-walka-ft-mozzy-mama/" rel="bookmark" title="New Music: Sauce Walka ft.Mozzy &#8211; Mama">New Music: Sauce Walka ft.Mozzy &#8211; Mama</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/08/new-music-august-alsina-today-9/" rel="bookmark" title="New Music: August Alsina &#8211; Today"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/np-kE-QnU9NtU83iu0dLv01WfzUfMiH7wRRR4hE9F975HXAl51_dhxiNoWNL8OFjYdsAMmDeOs1NAjMnVQaXK0DErgsQRLaZzoFnJ11mB8oVIQL_q_q01rRuifJy-PYpTpaJYHpXlRP11CrfUTQwNyHO_yq7AVqGlP39x9-jtgC1wvLRLwumJwMLL4O1VEMjWS4PZrBzRC2AiQSl0mQ8OPuu1_Qj3kr9ubudRagHZ9Sc2h5gWAdobeJ2bKO5tWqn4ipzliUZ-ENBLQV_WhAX_HjnEmiq1_vyLuYmTzdrTy2TaJ8AWS-etikR2qzuGZaXficg4RHk-gKhVPvBUpaV1EXmdejbGE4wQtx5KYK55dvXi64is5fyrcLPA22JAq4WEQ1bfiGg6JXzwBLlvWU2RUkrqFFhqo_k46jbxWZSYde4rnmbRWbM7CW0Y4FLe2-wRTujpaNeb0dVpfaZGN-xBRiSUQKtJFpyqz6pP0x_54kYoLYXh5mOSfTDChYhRDkh71dmziFeHF2ZbB5OdjdWBQKD8hIz6ENwZ8AmP558Dmd54PhBD0Uo-hpkpzbKE8L_jQ9rNGBRfLNONa86kGpxDvHoAnywvBQ-WmLFEQoqCGFrI0CGxtqtW75Wr2jrm3F5g1l_kpFMly7IcprHu_pJr5lO7I4MpCryzJcdEDAxbqecaRE5eCRBx7k=s500-no" alt="" title="New Music: August Alsina &#8211; Today"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/08/new-music-august-alsina-today-9/" rel="bookmark" title="New Music: August Alsina &#8211; Today">New Music: August Alsina &#8211; Today</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_5defd76554751" data-td_block_id="td_uid_1_5defd76554751"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_1_5defd76554751" data-td_block_id="td_uid_1_5defd76554751"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_2_5defd7655afeb_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_2_5defd7655afeb" ><script>var block_td_uid_2_5defd7655afeb = new tdBlock();
block_td_uid_2_5defd7655afeb.id = "td_uid_2_5defd7655afeb";
block_td_uid_2_5defd7655afeb.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"97","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_2_5defd7655afeb_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_2_5defd7655afeb.td_column_number = "3";
block_td_uid_2_5defd7655afeb.block_type = "td_block_mega_menu";
block_td_uid_2_5defd7655afeb.post_count = "5";
block_td_uid_2_5defd7655afeb.found_posts = "943";
block_td_uid_2_5defd7655afeb.header_color = "";
block_td_uid_2_5defd7655afeb.ajax_pagination_infinite_stop = "";
block_td_uid_2_5defd7655afeb.max_num_pages = "189";
tdBlocksArray.push(block_td_uid_2_5defd7655afeb);
</script><div id=td_uid_2_5defd7655afeb class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/09/ep-stream-max-b-house-money/" rel="bookmark" title="EP Stream: Max B &#8211; House Money"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/8Ol9vwwbWwdm303LB23V4tCgPTrQSXml2qdb5AVfQivFcGTwc1AWFRFL8jKtJB2Ikb0UEQjGWzAMHSb1LR-HlMdQNexrEl2DQ8vcaW_Rnip7SXI-IduxJyaAI64NbyDUNwtfUmCPWjtudRVFZSDMcekL5Ev2znuW0nf_70dbtBcZLEI3joG9jX7AxXLt0T1HYlW03dvvqDbr8yLzK3FWP0Kcvv6eifOyhkW_2otzho9gibv6RkqhNb6QET6AIzE08_J7n9Ri8Wt9lwnw2bnEPdUe8kS6coX0TAmHm0-g3G45NovrP0SQU1cC9CfnGFuS1Tt7OwB4QOMJjtqPO_DAOpokUCLYGGF-ac4cIkW2IEFWDRueVp7c9a0qhDZUoD9VRvMni4CV27gBw65vI5qOkfvYt10A-Qvhn29Fqd8BCDnMPnCZllHSx0NflPC9nnODDsvPTbDaHHqpb7aUkEXKNeQl1ZNlygkLBE-tLUlB6Fz6Q4ZkgXF1szLFho0N9IpUxdvYeON7xgnS2-oURwEqNUABsrTKqUJ7ffLBgjMu7taYWcEZzyAsJRIDQs8MBFUJuqwSokqLstd5o6-V7f5LQi1KmnwJtaCuq3DsO_nHu4jxhLUedhJ-BbPj0-Cp2CkDR_M6HqUMUmA_qq3si3XSmHkn3MHYKpbjv7loP1M_G2EPhCm0rgnmsVUw=s500-no" alt="" title="EP Stream: Max B &#8211; House Money"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/09/ep-stream-max-b-house-money/" rel="bookmark" title="EP Stream: Max B &#8211; House Money">EP Stream: Max B &#8211; House Money</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/08/album-stream-french-montana-montana/" rel="bookmark" title="Album Stream: French Montana &#8211; Montana"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/iDIiq2SiFkd90aA-rWT6vGv8VjLOh5jXGB9ZOohYTzeyV67Mz6YURuvUrkn60ckhweAhB3lqUc5V-Au8RLX66KntZz5x85eR9z-1Ti87ST_iiYJ2A3NA07P65tZr7gsp7OKv5Dsvam-u6L6YevwM0hVSEO2IB6y09hq7Mnv_0oAVKrC8IcrB2UGGBwdruBi9LcZ3RMeiV-jytMmC3tTyMcCg5NIBxictjpxvEQkmTvcMviwS4ISRF02DZP0mRf3e3OqZ5HjAPQhVgT-lzFrSvAq0giBcKo8V-jfyM4S2BkbHy4MjEy8wLe_5No92oEokoFzrlz9Fi0RU7m9HprigCr-F66LWMnsM3Vr_mNyMkkLBC4Q0XS83quKZlSZQl1Pr5u1XC3heI-wfpK6wkICvGuv9vUoTQgMKqR3rcAqBVVbqaLndtNLjjLWyUm9LIHrebHUsyBW02DVbAkkzkDsow2BONvsyQdi49jHfFyiLCAK231r0EeE8DqjlMoo6QLRNZTvObqFXYyQg5xk869IUm4HPjuMxbqEi3n6nwPZBuld-SGur0Ql_8yRre4hVO2ieBeRM6AX_srimsG8pHRJGIArQWvXkE482XKLp9nWZe9V26dgAHitkeQQrrt9yMfiRV6RJOwRGFYEUC3qQns5tEIE7ujLH82BJMc66iQwQ2pnmPmNW2LsgrNk=s500-no" alt="" title="Album Stream: French Montana &#8211; Montana"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/08/album-stream-french-montana-montana/" rel="bookmark" title="Album Stream: French Montana &#8211; Montana">Album Stream: French Montana &#8211; Montana</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/08/album-stream-roddy-ricch-please-excuse-me-for-being-antisocial-63/" rel="bookmark" title="Album Stream: Roddy Ricch &#8211; Please Excuse Me For Being Antisocial"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/OMRT-RVvI24rWb0cEmCH3YihlstomcOYfQPIFUqy59fgS-FZtfeOdwq31ROLPu_bBzNxX92mfMWQqqkKc6TYaAVZzJ5sZPDaX-wUH5PLzNXI8noozlaX8dzTCLXAW89fa7T2Go9jxrrTY1eDnOpKz2xRDCjY59MQu5G5Q5eebN-UXi761aohjtmbdMh6t9B2e71juzV4_URJ_8mwaKOphshCwl_XPyo61PS67fiwKBx7lVtrhxnMFbcqd_HN5lYmeO6k5a3ezQ1BgHrCfAGe79jSNUHYjGtEyUv4O9n_5UhXfAVfP0u4ta3XYJM9XTPKzMaItav-6yzbpa5HJuqBlygFO8Vm1p-sYdlo-WhksG6stykbjrv_AFGKTIlz0KhyB2OmU0gdg69sh__zqCDhD7QX-hhPhbo6AF5vyEjysil0iMvETjQQQIw5ZlW81kJWMKf8VVXkWKrSjik7r84ZXvppUtiKhEvn27-7JQJcVzkJOhimAimjhJRqKtbV9iVEJkU3gws1YkRhxQT-DYYRn48eYFnk7hg_1gsFSBrp8PPVAsT2spQtBU4ngO8NyPcQnqq320FhLqSaTnduAuhafhC7zth_nFQVLWINTWQjE-KiRjuWujmeCZhtv03gAnL4MjX1x8x6zx6XYjWJDNshqvoY-9pR34Jz8-ofwIYi7WpDMfofvp42ad4=s500-no" alt="" title="Album Stream: Roddy Ricch &#8211; Please Excuse Me For Being Antisocial"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/08/album-stream-roddy-ricch-please-excuse-me-for-being-antisocial-63/" rel="bookmark" title="Album Stream: Roddy Ricch &#8211; Please Excuse Me For Being Antisocial">Album Stream: Roddy Ricch &#8211; Please Excuse Me For Being Antisocial</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/01/album-stream-the-game-born-2-rap/" rel="bookmark" title="Album Stream: The Game &#8211; Born 2 Rap"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/9tgqzzFHuvtZbwB5HPJIMDfa-wg5T2TS0PV_zMeIe9BWi5gHw6buQkWy3-kc3aB1x34zY6s3p7-rYssXXtCwfYZYmyd-ecLkBxngbY8-cbXD9wd1iTZ93VHhIP3WXaCfEi5i1lwrqo_SQ_Gjy6ET_agXuczM1hbCvajWxBJWRkHqvDi5bZu0uYnHIyAwcQYb7W8lk42KClZrHkx2j25JsYOxb-IzNNNjQ5xKTXrZLaudpim86uqC3GDHlXOvO4s-mqHGsE-PqWbzgEd5hdnHsLjXsfjR2c0Z6VG2C4rYGSfBNCSRMsMHbbxPtIDQ2VrdL9p0ykNhNg99SsjOYkKQ4oqWp-42Yqog-3mAML__SkSSuMX65rBT_72b5Hr_Xsgd4_ZLkBlYXadPmNpVtFs70LCBaKTgwysA9xgPxKuCutOBW6Ntys3g5h5lwIpc_K-4Ui6kxAJNSwGrm-ZEnvfl2AbHHP5vZm3pLr8-T56qgIZwhv6mMLWWPt-ltradWsLm7zqqcAPYfmPUOzDtYPADr4tMnD37apbxiJVk9A7CKmb0O8lA6eCbLy3AzeuvAlbp-GxfT2Uh0I3RyjiKa_VivEayb8QmZd5cvcqs3JyOzJc0FAsjNwle_owjTnMiUjFmR1NzdnIMAoBG6uAxc8faK6q9MFpzyBdYcytMNG_osr8Bf2pwn3cosDxL=s700-no" alt="" title="Album Stream: The Game &#8211; Born 2 Rap"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/01/album-stream-the-game-born-2-rap/" rel="bookmark" title="Album Stream: The Game &#8211; Born 2 Rap">Album Stream: The Game &#8211; Born 2 Rap</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/30/album-stream-blac-youngsta-church-on-sunday/" rel="bookmark" title="Album Stream: Blac Youngsta &#8211; Church On Sunday"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/RShK3qrtklG5LejgFJwhFYSdKdmjjoAKY91H-WiI3KxmJpGM3zftQAPTnJ0iO0pFsXCw6D1k-nDahpo5TOvrU6utfxo-oyECuuhToWp8TH1QfSK2BTokTzX7jeJVp9qVWpJxMRnokUMt01vO0Jmy-Oquc0D35Utmr0eoxmBIX8Yqv1ldYqOG9NL02tYIa54QFYcSMtrZWoD2kYSgRz1plCOhYB7iVea3nUURldYr96bBsY5Kn3DrsKZgTfsYKW2M7Sd4cN5Kn5NM_pybn1VcXHG6j2gfu1QrxbJfLZmPwWXSFo1jELw0TpClPzuE5caXSlmPMZ11V9iRQ6dGt8EhJ5R2Eg_lw1pG6UI7t2INFDDp0jdQ4sC6ExMxzMd31x3BKD5mNYkMWjlSSuY5NEyUzHMiR7dhxNjnc4DcVBAskZP45GgT0UTdQKgqhob_xCkoLGVRPu4_kCOdkDeYta57C9mEPa1KTfo94EUt3J9FccajsirbeQOBPNgth--kqhhkHQyMWZAqobx7fuAsI-ipoAFQFscALbU6LwYJLsb6azSH7wagssRMNIfKO5yani4xeFLdGL7gLwJLYJZCMrWfI5P-OH0x6BZKr0ajQV1KAGgi1Ivzgvf8BuXWJ8vFMwcDENwdFyHCXsEIVciEv60yAGWR98azw0jjtYhilXKMPU7fg4QhYzmLGiq5=s500-no" alt="" title="Album Stream: Blac Youngsta &#8211; Church On Sunday"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/30/album-stream-blac-youngsta-church-on-sunday/" rel="bookmark" title="Album Stream: Blac Youngsta &#8211; Church On Sunday">Album Stream: Blac Youngsta &#8211; Church On Sunday</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_5defd7655afeb" data-td_block_id="td_uid_2_5defd7655afeb"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_2_5defd7655afeb" data-td_block_id="td_uid_2_5defd7655afeb"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_3_5defd76563b6a_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_3_5defd76563b6a" ><script>var block_td_uid_3_5defd76563b6a = new tdBlock();
block_td_uid_3_5defd76563b6a.id = "td_uid_3_5defd76563b6a";
block_td_uid_3_5defd76563b6a.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_3_5defd76563b6a_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_3_5defd76563b6a.td_column_number = "3";
block_td_uid_3_5defd76563b6a.block_type = "td_block_mega_menu";
block_td_uid_3_5defd76563b6a.post_count = "5";
block_td_uid_3_5defd76563b6a.found_posts = "2574";
block_td_uid_3_5defd76563b6a.header_color = "";
block_td_uid_3_5defd76563b6a.ajax_pagination_infinite_stop = "";
block_td_uid_3_5defd76563b6a.max_num_pages = "515";
tdBlocksArray.push(block_td_uid_3_5defd76563b6a);
</script><div id=td_uid_3_5defd76563b6a class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/09/music-video-camron-believe-in-flee/" rel="bookmark" title="Music Video: Cam&#8217;ron &#8211; Believe In Flee"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/cuqrv0XHJkA_m0MAIkerzEIKxlqBnVRpsyX8JeydkSizxqx1bdXE1FHKw89DPC9FELnwwjXC-CbXKCQ8ZFFqkNy_47fARs-MFBNknSCTqbFMwY40QomnAbiu52R0V4XjQuQxhtrb5kGE3_UTaEQqA1fYz9VSdWhbULqdrV9pubt3JVDyF2gTIZbwzdc8AYQbVjay7lTM9M9CF0IYg9MdFifWJM6GueF2cXmARi8nZ7HHcT52fo8o4ftBSDztufUhL8xK5X04CtLgQXnurZKp2OXE-gG94_ay3boJLEUQgGXjfgVNRBqCk5mRyv6dbD_Xd7-NMedOvzdPPsS--1R3HFwC9Deq1hWvx7E4TZMRD2zyux-jVutLVglDsrrIpmwQKhefks9yvnWf7GoxdnxsTqOza-WrftB70lVVoxeyeMgcdFBhVp_tjI_XfgPYzMSLA2Yj_TF3O-q18rwvBD_961ED_2BGE_lT5r2QmW5LoRhxkUWTUDPlmewad_M9HQWAgl8o9CTUlhisQumSXlBic3gV0VE7yeVDzLprfr7M4zC5DLdvShtRkxNqYBze0fnbRYT8-L71evGGFgAFki8uFUZ08sP2N6xXlcvQosjs54Cf1J6wdkOZYoxfa9sn9VunlS9exwJ2BFFaDepEFOz7pQ3ZZHSJCTtfnPCXro6XS6capL9a4OOB_uHU=w1005-h471-no" alt="" title="Music Video: Cam&#8217;ron &#8211; Believe In Flee"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/09/music-video-camron-believe-in-flee/" rel="bookmark" title="Music Video: Cam&#8217;ron &#8211; Believe In Flee">Music Video: Cam&#8217;ron &#8211; Believe In Flee</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/09/music-video-french-montana-what-it-look-like/" rel="bookmark" title="Music Video: French Montana &#8211; What It Look Like"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/NV8PHdbRABJJacSXR5R3OeHPXa7K64uYXzdAFiSrR_67dR4S2ZBIHo7oIaSDYk6dPOaOA7K9bjJZi7XNbHdQZWERJmCNzTta2Il3WRFVuwTG9xKaUbxptl-OIJ4nM5csvnCENp5F17lmodwSCheyDHzcSTkHfmt-Or-hya0C8GstKLwUfNy6GhDxSKj_naM_AN-WnRNnE19fAlo5H0evPl3_VAtwRTup1vO9fbxB7uR_BwP4QwPz84a-fgjIGel2-Le_tHbD5MCzlJMIMjudIsr-iuJwa9RVTdRHZ-yvp1a3VM22w0nvVYib6nekyJnuuiodZDDTngB0_9ZuPObEO9J-tTIO2OvrA_h_8JxSL0G701jvYdR8CnhE1m4gvDfNXCFc_8D5dnfjRrl0oUjPY_aiDvPg_o1P871Ua394naQSvU6jEeFm2LXtI6j_RR1HRRsW_9nf-MxJMb4DBBfQ-efck-DGeJCVMqdU3ivmOf1woCWKJcjXOndJOo-XZUgKWQFaY5Nef1G4keANfqr6vFpt9rlvOhupGQTzpuwfkpS5P20mw-EHm5KjWDnWKfrpr-CxM-aTU6MyZ4eI6zvUlxZAwox-NwjFbIPo7nnlGLvgydSGbwugcpgcu1h_sbSnb0GND-gd35DYTCzSEPcJD69dkuL6_nWPvK8P7UV4yKEc9uXV9LAGPqDv=w824-h459-no" alt="" title="Music Video: French Montana &#8211; What It Look Like"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/09/music-video-french-montana-what-it-look-like/" rel="bookmark" title="Music Video: French Montana &#8211; What It Look Like">Music Video: French Montana &#8211; What It Look Like</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/09/music-video-lil-baby-woah/" rel="bookmark" title="Music Video: Lil Baby &#8211; Woah"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/lVQnVbPqIKi2zXEPfsLvsc0FsFMXdM1v0hKu9k4JtUb3P66C1yuP0rQ3VlshPC_TRKKW9C51BpeV1Rz_sjSQYUoZp8flOHgvqgyiHla5Ba-DcSw9PnJyM819wY83NRNn5SrR1QWtnLirQiVs7Sa9SM9VYiqqziQUeJfPTCXk1ZIpa2keypyrPg8UgVo9Ql-2QIKy9gsvPCdLcZDuD_LsAHvPP2tmZ3XdpZOA_-To6WyBHiHTteyJHKVE39u04zwVo5toNh_-X2aDhmCioC9Xyj0rsKYbJRwbE7REBRzVHLIAgPCeNuvBi0qoimUuVLtDH2C8hNrywVjwaGTSAPixgxZJqUZAPDulGP_0NYTE0Bsy2OVnBmDDDzipIQ9V0ftCI41TcqqHb-9PiMiA6tG-wScMrxJo09hxeQNdP9w4qlFR_VK84--36J-DdPATe5ny9JLJbsXhJ4WXdEIaQseSAunmIFOQCP9nu333R-Pxt281DB7UKwGlKOfjlWee0LASAP-yMuIymJ6giF828XatwwxqxMzkLTNmzXjbwmxCLgeBI5QuVHjSTHQkXSCzbYXtPjInHgJJ7mqEd_jL4APoSwJEq_UytgFVF1pjpjmdCL6q8Y3pypiPgQPVGhE12ArSa7SEfc9FBN2Eg3vl0d_oyW1TSNBN41jieK3ddkv2hdwG_wCs49e_m2E7=w895-h535-no" alt="" title="Music Video: Lil Baby &#8211; Woah"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/09/music-video-lil-baby-woah/" rel="bookmark" title="Music Video: Lil Baby &#8211; Woah">Music Video: Lil Baby &#8211; Woah</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/05/music-video-flying-lotus-ft-denzel-curry-black-balloons-reprise/" rel="bookmark" title="Music Video: Flying Lotus ft. Denzel Curry &#8211; Black Balloons Reprise"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/w56KBIC3XDjB2xghrGRBDi7HpKNIQCtJq3fTrYEMn0tdqf75jGZ8EmNZQ0LVORWjZHWAyg0-ixNCkfec4Ranw0yApjN3EYn9R4wsDzOiNpkmZDiVcVzEv6t9AW4EnDCyf6hz4gl5tCEIYjsiFolIEg_AMXj1nw9P0YyyHQsjtnus865nJillKqwtKxzC83Ks-2RmBivYE2zJbgaYGinHsXZoKbJd6XMsakMRgALvrF3K_GMs8va5uudFU2AA6bd3BD3_Xokit-wLQWS8zKMB2MNAx1atrsP7vt9-R0As-QZ1lMKXRg-VEg2p4Tssxx1uaKqTqKC-Ow9KvboTwM_SLrOZXv5qsNULLHMw4YkHCTwuhdUyeEIz56tYuFDkj4NdteVZbsKUZuNCo72-wfaHY5EkpO_qBCOZhAgERICeenmhuhpId6K23m2eLh2f8rIvp7Iua42xpYGfp9dy7NSNKh7bO6Qd6qYOTNTTwKHdz174lZeMjpNzM1Cf8YWCADe3x2M9Byg4Wfxh2rzKUBSy_G-MZi-YPpIOU7CfbiX2Bj2dMGVZArNyqDdihY4QKe6vHp-hxwk5NE1Y7wks_0qQDqPIo7ER76E3lULvc3KtXtehR5BNekZu1fEKaiQoiV4pPvfwG5BieWgY02htnS9VxSKWigcXwZwF5xT_X3S3AWS_zNS3K6LF_Ck=w773-h548-no" alt="" title="Music Video: Flying Lotus ft. Denzel Curry &#8211; Black Balloons Reprise"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/05/music-video-flying-lotus-ft-denzel-curry-black-balloons-reprise/" rel="bookmark" title="Music Video: Flying Lotus ft. Denzel Curry &#8211; Black Balloons Reprise">Music Video: Flying Lotus ft. Denzel Curry &#8211; Black Balloons Reprise</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/05/music-video-kevin-gates-bags/" rel="bookmark" title="Music Video: Kevin Gates &#8211; Bags"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/-yr_zT-XvYSJOBWRmZz1s9jbg-1XBPqpzqAlvYGZjDvVtbpLNRMU3V5r1jDyHZk4MI9tRMr1Pt1t5wlo52SlR7ISckP8vFecXE7LDpsQHWjcPVjW46yzodQC0YGvSM_SphujmvwpIGNtyES_fIortUdCSSxIB_AuPwfI0PFBW21ZjX_q-kXbGlAfV8eQ78T8o04pqnfI-vFAuv4iY-CJGBaSMCgNWGz6F4LJxe32A9tliDjitYVZJ4y-bJwNgWNq6-RVfb_RXEFgfiZXB94ZtByYmkzIA9F7MsKGRtYDvEhJDK2Q-6sJk33uFeHZEb57n9q48El3rn6VOjGg3hCmwKO_yvfnrlp31wK-remHfID0kr0ZykUCI7icgQ27anE65y6HKuT7qdEHh8BAK7IN7SEqbnKqj-B7KRo08UkQZXApbtz3ffQzmI4FEPZ1yTaV457-KC3NCja4P835m5m2mTGt7QAIDoo16Tv4ZK79uqZcBjx4zu3qyfRrAbWrT_uFltN8kFzF4iEO1u6QfEpmsfCaRydydi3Bhv5r8evk35hqg-gN1CH2s5huMTUTUPBF3O8pgCSn3aWBIEGOxNTxpBuPfNtXup0axPIeaajoBdzg5q3w2Lb-pFFU_ExCfDpAoE4RGfItqP2r71RNESTuQuCz2auMBOgQEmy90jV_Ulr06sAGMTb_C-w=w999-h466-no" alt="" title="Music Video: Kevin Gates &#8211; Bags"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/05/music-video-kevin-gates-bags/" rel="bookmark" title="Music Video: Kevin Gates &#8211; Bags">Music Video: Kevin Gates &#8211; Bags</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_5defd76563b6a" data-td_block_id="td_uid_3_5defd76563b6a"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_3_5defd76563b6a" data-td_block_id="td_uid_3_5defd76563b6a"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_4_5defd7656af0f_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_4_5defd7656af0f" ><script>var block_td_uid_4_5defd7656af0f = new tdBlock();
block_td_uid_4_5defd7656af0f.id = "td_uid_4_5defd7656af0f";
block_td_uid_4_5defd7656af0f.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"29","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_4_5defd7656af0f_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_4_5defd7656af0f.td_column_number = "3";
block_td_uid_4_5defd7656af0f.block_type = "td_block_mega_menu";
block_td_uid_4_5defd7656af0f.post_count = "4";
block_td_uid_4_5defd7656af0f.found_posts = "952";
block_td_uid_4_5defd7656af0f.header_color = "";
block_td_uid_4_5defd7656af0f.ajax_pagination_infinite_stop = "";
block_td_uid_4_5defd7656af0f.max_num_pages = "238";
tdBlocksArray.push(block_td_uid_4_5defd7656af0f);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_4_5defd7656af0f" id="td_uid_5_5defd7656d044" data-td_block_id="td_uid_4_5defd7656af0f" data-td_filter_value="" href="http://weuponithiphop.info/category/latest-news/">All</a><a class="mega-menu-sub-cat-td_uid_4_5defd7656af0f"  id="td_uid_6_5defd7656d1c4" data-td_block_id="td_uid_4_5defd7656af0f" data-td_filter_value="69" href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a><a class="mega-menu-sub-cat-td_uid_4_5defd7656af0f"  id="td_uid_7_5defd7656d390" data-td_block_id="td_uid_4_5defd7656af0f" data-td_filter_value="80" href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a><a class="mega-menu-sub-cat-td_uid_4_5defd7656af0f"  id="td_uid_8_5defd7656d567" data-td_block_id="td_uid_4_5defd7656af0f" data-td_filter_value="2189" href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a><a class="mega-menu-sub-cat-td_uid_4_5defd7656af0f"  id="td_uid_9_5defd7656d738" data-td_block_id="td_uid_4_5defd7656af0f" data-td_filter_value="10" href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a><a class="mega-menu-sub-cat-td_uid_4_5defd7656af0f"  id="td_uid_10_5defd7656d8da" data-td_block_id="td_uid_4_5defd7656af0f" data-td_filter_value="130" href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></div></div><div id=td_uid_4_5defd7656af0f class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/08/video-conway-benny-the-butcher-ctrl-live-session/" rel="bookmark" title="Video: Conway &#038; Benny the Butcher &#8211; Ctrl. Live Session"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/JtymWQykqvK7a263kYhyCUblPEVfXp5H2Agi_rj27lYB8jO6UE9DoD_BppAWMPKq3u34JENXOGwPBunA2Rvcid6xTqD-lu2NOcpoy3ufVjL_HkqFpLTIjDuW9NsK1rGplryFhxNXowIo5aa1Y1XWxkj5xxH-fVFydKYYxjLw9BtT4bD_QWAz8YBGwA1o4q3FUrkQV3WRwenzya_V5jdDhcXzWE0dPQIDd6x9w-RP5Lvr4m5bCj50qNPJ1E7ekrsl3PTyFyUDFNB-FE2kEPYAK7oP-edWDdwaB9HRkddc2T9gJHHmfs74VhUIYhqkHzAs1Sku5nf86yeGfsey6YSnfCsfS-cS0AJOoQV4uRcs8nBTqQUTzgRCjOSahP6GwCJRiR3BM-ydfxTYN4sl2gqU2uKBKNU8AdyjNNA0tUiJOLWuMcwSBxfq5yCkta_OCTUHUm3E2iWD9FMzEQSqei1s0peWfvtUIKNnlNCnq7x7IFnfCLOVQXrXjehGWtkWYIxjXLgDk5YfjxDr5rgWp5EtRUIasFfQ6oDs0a5BJ7riIBSaIRYQfhL0mh_oayGbbpUfc-3NCFncWeo4dZzavZgmbcw_OB2Bhj2cj9nQpCRMQaThpsP-x0rEHpysLpd_QRpQCIz30dM3vAvp2KY_IJ5s8vS_2xLR6gPKxtE507YLV3PZiAb1w5K2cjg=w349-h233-no" alt="" title="Video: Conway &#038; Benny the Butcher &#8211; Ctrl. Live Session"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/08/video-conway-benny-the-butcher-ctrl-live-session/" rel="bookmark" title="Video: Conway &#038; Benny the Butcher &#8211; Ctrl. Live Session">Video: Conway &#038; Benny the Butcher &#8211; Ctrl. Live Session</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/05/video-griseldas-wwcd-documentary-part-2-daringer-348-sanders-road/" rel="bookmark" title="Video: Griselda’s WWCD Documentary Part 2 &#8211; Daringer “348 Sanders Road”"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/13S5HFfa_yex425TvWTAT3LPQt9vjhCndpheCa75fzFlXP5r2xZpKD_4-qoXaujrCQdlFnHo-lm2odpSWqqBF_BCHrSjM2zIPwzJ6dzIepSqI5618O-WaAJAkSFWshSnjyOAR_lL1YqapfMrBYdej9s9eqRqSax0eL8O3o0QkbtIY_gIWD29W80SOwYoGQlQ0jfAxsWVngVpGfI8e9uwl0pjUdqZPc2Dsp4Thhdo_Hixrfz5lOPx2sQ-XrqgjHaTgewFKyMJVMsv8vMh_tekCMWNP-vK2wCIX5ucXvaItac_BdJ_ZdYyUuev0mPkwP2tR6h4oJC52sEj_5qaeB6kCliiMTFWheZRCeTOsITVE3i9OJAKohfE7bSQXTxw7-rCRzSgcxEwihuhc5mYOs5Z_4WVlZt6C3OQB7Sh4HERWn9c4lpOe9hiHQ5yZGJ5i7deo0-fgItF9Bdo-L7Pyuu5G-ydxciJdwtLBbn_LuZqHhTNFDmqyefUFFUsE-50C00hFPQSvTUzK1l1zPJaNt-iIOpLVkZ768JzD8xcHgO9nm1TeVM8B6OrqwVKV6IOYbYx8CN_vPmFogxqJ96Mid40B-CnkL5apMs8m6mlMbLGcCF7jq-3lb9me9mqZIvYwQtVPBuQmSX6wDnThUmwVKYohbLTvCUN8SlDK1gYDkjsGnVkrH6tvTilp6Y=w814-h512-no" alt="" title="Video: Griselda’s WWCD Documentary Part 2 &#8211; Daringer “348 Sanders Road”"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/05/video-griseldas-wwcd-documentary-part-2-daringer-348-sanders-road/" rel="bookmark" title="Video: Griselda’s WWCD Documentary Part 2 &#8211; Daringer “348 Sanders Road”">Video: Griselda’s WWCD Documentary Part 2 &#8211; Daringer “348 Sanders Road”</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/03/video-wolftyla-breaks-down-the-lyrics-for-all-tinted/" rel="bookmark" title="Video: Wolftyla Breaks Down The Lyrics For &#8216;All Tinted&#8217;"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/IW61DwHa2TWjfZUj2RrQT6pDG6S-NHrzjhUxbbxkCuguADjH0VYdzvbUAhj7JIa8RHupZrWYDIQv5lc945Snegzpm2ZuqQuUNOtlaY4w-NgBGLLxpkbvTDfK9M2YmG8XKHdh2Vu3R9VBzQbWPej6YkkzjWw8jZuA-pVgF9dgblSMfSUMemJarAuRYK9RxYULNlbL5gpioaMZd780Ye2TMUZLiTtBXQxQri0-fKEL75VZuG-5CMNTEe3S4ekFgpzU-yAiQqXNBr-Kw3_Hn03jYjXlr4Iv4MlQMoQRmcn0vH8YC_En1vvet6dobZdy2yaz6fPndzY6lYL_0uK5B1KHjn3b1P18A8HLODBP0tayNWIsDKdvgKPkpQh-ALOZbaHWwWK_jvyacIoeUBKs-_YKYuh3ljtwpBywW8i8VnBJgiU_k2er4SYmGxQHtGqpp7yGcfolAPVebboYXBqJsoo2nWDM-yp_LlIy0E0Hfa5DeDMn5SaYoRhp8WDVC-IF8K4ur-hZ0dd2pnqCN4_RvtdMeQsbu5Bax6psmb53PL2N7vEkfOU0afGmQvz4XR_tWTw0GtBxStmRXOissMae79-6WBm8zcZwoSeppt91C2j_Y7EafjZBbRpKfBox_kM_dF5wEo_mqzwZlAtVOwIoWjAtNBFW1isNIrPKJQrQCt1K9dAmBjTqvrqDSjON=w548-h513-no" alt="" title="Video: Wolftyla Breaks Down The Lyrics For &#8216;All Tinted&#8217;"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/03/video-wolftyla-breaks-down-the-lyrics-for-all-tinted/" rel="bookmark" title="Video: Wolftyla Breaks Down The Lyrics For &#8216;All Tinted&#8217;">Video: Wolftyla Breaks Down The Lyrics For &#8216;All Tinted&#8217;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/26/video-h-e-r-breaks-down-the-lyrics-for-slide/" rel="bookmark" title="Video: H.E.R. Breaks Down The Lyrics For &#8216;Slide&#8217;"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/MQ8K4ELdhD12UKG2AL25bFvA_Mr6OV1PlhdtuyuxXsIJCK0Jab9VY9J-zy-l3t0Tl_BPubYDfw_0W51L7QjxcWQzcRHbfjI9CAC3YTztR18ZxAqaZ_hOG4-hEI_yuLTAqry46Qt-AZ5MM3tDNFfpwtSTv1ykdaOtAYVoWb1K4S3y-nOmmA7_dtWn7VM6XyilX6t0EtCieXbVyQGfYRyD09MPqiSrG2VboqK3TYgwPKKgkoMOxuZeGSHv_KSVWP4w3zL50qbIEuhPnHlntIqvNUJ2Kfn_aCf9Po8Wd9Z_i26AszwaUHOzBLY61aYVzW3VJ17mpOSFvU8ua-OOSXOtg-84tgFVBPhkz1I-H7tJN4Vz1AtRQjeB2t5BQ1I2-NYv0oXW8c2kRi8zEYj4WqkU-dEZAvit7tASdeNmZQ19OG7UUGKVY4r6AeBbRbiBVn3ANqwuv7SFLn1xbN5bZf1SzT8_xZTlyuL15EyQME4Z83BzrYeSPkQcjW_0jAWJNL3n_gi91L2_9gFLTmwmuWKN8Ndc37bZcoR62kXa1nNBK5zwgyHH56nw5xZPHHCQ04xFxM_SXWLzgA_kTnihwNcgVzT0bTjPLc1Qc8ruZDsmcqVsWwE7NnzVA5lwMCBuwuPFBZvvMKlEy9PFhr0UpV30D8L58s9pIM_3ACybFUlt-p-H-cZ5MJgCc8_4=w829-h525-no" alt="" title="Video: H.E.R. Breaks Down The Lyrics For &#8216;Slide&#8217;"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/26/video-h-e-r-breaks-down-the-lyrics-for-slide/" rel="bookmark" title="Video: H.E.R. Breaks Down The Lyrics For &#8216;Slide&#8217;">Video: H.E.R. Breaks Down The Lyrics For &#8216;Slide&#8217;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_4_5defd7656af0f" data-td_block_id="td_uid_4_5defd7656af0f"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_4_5defd7656af0f" data-td_block_id="td_uid_4_5defd7656af0f"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_11_5defd7658fe2a_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_11_5defd7658fe2a" ><script>var block_td_uid_11_5defd7658fe2a = new tdBlock();
block_td_uid_11_5defd7658fe2a.id = "td_uid_11_5defd7658fe2a";
block_td_uid_11_5defd7658fe2a.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"77","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_11_5defd7658fe2a_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_11_5defd7658fe2a.td_column_number = "3";
block_td_uid_11_5defd7658fe2a.block_type = "td_block_mega_menu";
block_td_uid_11_5defd7658fe2a.post_count = "4";
block_td_uid_11_5defd7658fe2a.found_posts = "158";
block_td_uid_11_5defd7658fe2a.header_color = "";
block_td_uid_11_5defd7658fe2a.ajax_pagination_infinite_stop = "";
block_td_uid_11_5defd7658fe2a.max_num_pages = "40";
tdBlocksArray.push(block_td_uid_11_5defd7658fe2a);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_11_5defd7658fe2a" id="td_uid_12_5defd76592713" data-td_block_id="td_uid_11_5defd7658fe2a" data-td_filter_value="" href="http://weuponithiphop.info/category/fashion/">All</a><a class="mega-menu-sub-cat-td_uid_11_5defd7658fe2a"  id="td_uid_13_5defd765928a3" data-td_block_id="td_uid_11_5defd7658fe2a" data-td_filter_value="76" href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></div></div><div id=td_uid_11_5defd7658fe2a class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/LVT4Mid8WL4wHUdO9X2OZmZxxgbREs2lVtszOdEBaO6hJB0JS3yQOAyhNSdCyPmv0amBDTgNGpOlRPXPjKCl6yIlo2joyH3rQRI7CUdX09BJtQI1r5jy1_7BQtDhw4AxUhpUwIh35rNS3lTy7uq-FdPff10JN6srr9mwZ7zr04GQFxBVEXwCfC5rNVehXhY_wGCRVsmevYmdkBWEmB8dvOzBHY78NBBjcHNArS_S-2M0FJgDh8v9m9vEh78k_XmZg-AERctsf0bkODuPi1EcNJq_RnJIV6b0GG-VtKjo-OVPmYghWJYf1HiP9c58cQ98oABU8BDFdLqsBtNt4K0NmyHYQlX39W9k_d83wEHZ1-EacQa2o01VrYSn12HnZ1l88fMzu9PKv6EGmcRZNwpepycW7_9EQnhxIPDdVCmRLXUasUED9OXr-zJmnBcnSnLCa06k1ZymQym1LiSFEv1c3aPHnmnD3GY8nL7q5jPJr4HsABR0WCqMebcF3HF_0deNd0zgRBCGMxW-VzlIIHZiHuBeSPEPvUL149GJ5swSSvKm1uGEi1HlLBj9omJSU7mDWzO0p_7l-l7-4_ureEsGsgB8cX1t8t2TQcFeRgqqF1CXlZFYYC2K0iMb4jPsijsw_rtO7pmKvbngqHfgYpGeh_qLmDWeicR7=w1195-h796-no" alt="" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch">Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/fHEwwMf8DoiXlqkfibQS1Z1XXbviORbV9raaI44tOTXrWo7GgqM3gA-vswE10gFtTQUGGwNG7nWAACwHjxPuiubliYBN_dqtBZh2WIpxvumiJ-hSLK0TNWB2cB8Iw2STT5gcp_KqlDh_e4xng1vidI8EXdp_ooh5uDI-JV1HQ9dGnM5nxl_b-v8znqj-Rl_mGB7y4Lu9zsFNWHU7SriqQQJaKrKEEnb9T8zxmGLaL0zq7ilYpnUEhWulDDr9xc82wdr__WzRBm5YEskVpDAnGM2NDZwTZpjbe4QDdxeixWnSXNK_oDzaL7WTbCpkD33OK88BlI5JmFRQ5VmD11UQ2htB7-9WoahHvb4XmBsbLXpEMl1JmEP4sPx06VduzFnBNo-J90WI0n1AEIIcEYVbRywrkGJXbzmH__In9ZIg0EV24OcGGbeKl12HxTdZwucqsNnuZeNjiMHISQ7i8cfzm3N7X7Zenl74zsKIKeKWoIGxh6MTlVADvgHcrHebnjcSgil2vBeFyz_AP45aOv9SOwbzfVLGS0CNfe1s9b2J7qZgjcBk9QPEXCl2kygvzmGXFvU_3xBuW6S0i3Vkh3Ha_3hPBtvIAy3WoTK2yiqS41HzSK7yk3FRAlBtpIEib338fdkTiosBxtdu36SdNUVM75zl6CVIFhTu=w681-h470-no" alt="" title="Air Jordan 14 Rip Hamilton"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton">Air Jordan 14 Rip Hamilton</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/kUjaOYxjEkAh34S-Ub2QSZwdOwHyFnGFLBZULta3_bn1_myPMAwJXiEEsAAtc1ktCQwHCuKhSqSYsWXFBEIZxdfKuykoDEZWwO-dDI3_JeAshbYvyILEHUu0XaUpRn0mj7gOx10V52t8gRGYPCW7QXGImkPGGhvBPzBDVVqh9lKGtkuPeePmTnpRSmwp0LG1WHcIzUWnMqPBWQeHAat6Q-Tq7niXNb96ddEZsMEdHK1nmHVlNaeqFBNtTxk6yYRkFNCvtfBayqy-Rqt4CPU5tThxbTI4AIUCI6JLxJd_VJizrVNDEe2xZ_tiQdkC5ASIoHpX8sfvAB8zRUsMVJ6oMUt5FH_4GBNXDCtFRmr65Qt0JV1h4bBJffu2L272Q_vpD76wn-YNGW8VCtZcheHu_X-A4gdYQEC0HN0BenY-MOuUBqKEjXAc0SxWeP7W9RN55jlqUFK0nzEYydVjec2stdQIngVfg_FvKxvHXfM4XdtMpqeJnp3Pzyk8xjz30sAZd0f2HQ6zfdPjk-OkV2-WrC0_qW0L8Rq3zrUbq52n3BN7gm7sctU_CUlBmoQIgJDQBYk1Siv4tfSq9pL1R4GdaOlWQdxEuhZi8bTYC8GGAgNGl3SMAZGvk7nu6QnnwEZjZ7mZwbcqgyRKa89cOREMUvIkVJ8Q8lZu=w926-h672-no" alt="" title="Jordan Proto React Triple White"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White">Jordan Proto React Triple White</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4cDUjSODZSaXWfHyZKb9q3Fn7FHA4uB0KSBs0MtFHC0dc6AJb1zeAl_X2LOKalK9C7VBFhTqRQ9fw1ESgUr9ZUKFbOzD94i_s96nvkICOqrsYnzrE2nEAQHoEaGOF4O8GAI6T4CGFbgcQhNzjpRlSY60NyPu5Cmq81FRpEOFRzTOtSa_NnWzMmfwO0yxtPbcg5U6YBUsus8shv3SA7CjULLfaP38nZAuWVgq8PMaaeCQ_eSrK8NJSEVQjyyxmqb-1I7zO8Kvvzvwi--ibMr52CF8h-GusBzSq5ZuzvZRCGu_u8CyfoXw7pwWbOmHnLOdcQ9d2PCSW_IxEMGfmEuU7NxMSsW3Ga4r35_wLB7cjvlPC9OjCV50tfekXjZBS_476mzlf4G9jR7Ju1GqgjXah9Uqc_0Y8N-Br8_JCtIlRSuLxAiebwd7AvFVlgWId9MYxBWnRT3cTyD8SH7q5WwO-CIbKAOSKsNcrrTgFxQvqn9yklBU1u5X5fdTlTBk4WSYorsWZAug0z9BOymRLnrhTbnA0vpBPFROWD-aL1glg-eUpFSfgD4xhWsOqJNY9krQ2UbLSGXQ5gYWj0ovLS7Yz3UKFY2qrVWpqkpbfyN98es9NJ-7LTUs2MLq1rX_2FaQmyq5mVndd7VGzQOHy9hDULG-5H-0LvGd=w900-h566-no" alt="" title="adidas Yeezy Boost 350 V2 Hyperspace"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace">adidas Yeezy Boost 350 V2 Hyperspace</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_11_5defd7658fe2a" data-td_block_id="td_uid_11_5defd7658fe2a"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_11_5defd7658fe2a" data-td_block_id="td_uid_11_5defd7658fe2a"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div></div>


<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form method="get" class="td-search-form" action="http://weuponithiphop.info/">
				<div role="search" class="td-head-form-search-wrap">
					<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>            </div>
        </div>
    </div>

    <div class="td-banner-wrap-full">
        <div class="td-header-container td-header-row td-header-header">
            <div class="td-header-sp-recs">
                <div class="td-header-rec-wrap">
    
</div>            </div>
        </div>
    </div>

</div>
<article id="post-36098" class="td-post-template-7 post-36098 post type-post status-publish format-standard has-post-thumbnail hentry category-new-music tag-camron" itemscope itemtype="http://schema.org/Article">

    <div class="td-full-screen-header-image-wrap">

        <div class="td-container td-post-header">
            <div class="td-crumb-container"><div class="entry-crumbs"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="" class="entry-crumb" itemprop="url" href="http://weuponithiphop.info/"><span itemprop="title">Home</span></a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="View all posts in New Music" class="entry-crumb" itemprop="url" href="http://weuponithiphop.info/category/new-music/"><span itemprop="title">New Music</span></a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last" itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><meta itemprop="title" content = "New Music: Cam’ron &#8211; Big Deal"><meta itemprop="url" content = "http://weuponithiphop.info/2019/12/10/new-music-camron-big-deal/">New Music: Cam’ron &#8211; Big Deal</span></div></div>

	        <div class="td-post-header-holder">

		        <div class="td-parallax-header">

	                <header class="td-post-title">

	                    <ul class="td-category"><li class="entry-category"><a  href="http://weuponithiphop.info/category/new-music/">New Music</a></li></ul>	                    <h1 class="entry-title">New Music: Cam’ron &#8211; Big Deal</h1>

	                    
	                    <div class="td-module-meta-info">
	                        <div class="td-post-author-name">By <a href="http://weuponithiphop.info/author/cyclone/">cyclone</a> - </div>	                        <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-12-10T05:50:56+00:00" >December 10, 2019</time></span>	                        	                        <div class="td-post-comments"><a href="http://weuponithiphop.info/2019/12/10/new-music-camron-big-deal/#respond"><i class="td-icon-comments"></i>0</a></div>	                    </div>

	                </header>

		            <div class="td-read-down"><a href="#"><i class="td-icon-read-down"></i></a></div>
		        </div>
            </div>

        </div>

        <div id="td-full-screen-header-image" class="td-image-gradient-style7">
            <img class="td-backstretch" src="https://lh3.googleusercontent.com/aGalCcqGTIvaozKSFJGlqJtr1VW-tOa7ncWK988f0iijDRUT-rmFsGb05ot_e7P2sPbQDKdlURMzQYOGAEHFZgnro4sQp_ZCnp_1w5aqzZRmdIiNrji_Uyz36OZl1xxr8KU4CKz7YKlSSKJ8bCM80DO1Gcjbkamcy_JyTmFZhRWvK12XD_8CIzcafmDBYqBr9cS3RXlQcxoN_n8uPmvwucCvBBWaQbuv6k3NyI2igtH_myCOZvNoxeQPhVtZtS-FZiJDm_OtQXh1LEF29l0KZaB31jXxYicxalIeqHgWcXpLsnobn_6VfrEQ7U2mv5jEfkc6xP4sRu18_YKhIxs9TkYbSUwQ_9SKlFAOEHRLERu2kUDlnYblQmkfWspAyoZIC6G9IV2QUi1NFv9QGsSWlZohiUXuSARdc1XnLUPzrczaT6AZ7KJZi3mMJVNnPzlHJ4x55m8EWjQUWLFjOxXfS0phhtvlGJYvkiW9G0YASqwp8NegyC9Yxvlf3Y2u7VX4TvsTwS36kxkvk0geRnlRB6-dAPeTB6aig6m9jBODL5tlYbKYWI5TBOSjzv7cb7YC3K-p-7TSUHdIIUDd25YWxyCXLO8OK-u_BgNNCDtP9NhYQ6tDYUEcn7hkF83Z6f3hFvL0OFB5KbdukzmIxK6e_M4K2ZplYxcm_gMEZL3TFC-B2pZuhtYLyemW=s600-no">
        </div>
    </div>

    <div class="td-container">
        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    

    <div class="td-post-content">
        <p><img class="alignnone size-full" src="https://lh3.googleusercontent.com/aGalCcqGTIvaozKSFJGlqJtr1VW-tOa7ncWK988f0iijDRUT-rmFsGb05ot_e7P2sPbQDKdlURMzQYOGAEHFZgnro4sQp_ZCnp_1w5aqzZRmdIiNrji_Uyz36OZl1xxr8KU4CKz7YKlSSKJ8bCM80DO1Gcjbkamcy_JyTmFZhRWvK12XD_8CIzcafmDBYqBr9cS3RXlQcxoN_n8uPmvwucCvBBWaQbuv6k3NyI2igtH_myCOZvNoxeQPhVtZtS-FZiJDm_OtQXh1LEF29l0KZaB31jXxYicxalIeqHgWcXpLsnobn_6VfrEQ7U2mv5jEfkc6xP4sRu18_YKhIxs9TkYbSUwQ_9SKlFAOEHRLERu2kUDlnYblQmkfWspAyoZIC6G9IV2QUi1NFv9QGsSWlZohiUXuSARdc1XnLUPzrczaT6AZ7KJZi3mMJVNnPzlHJ4x55m8EWjQUWLFjOxXfS0phhtvlGJYvkiW9G0YASqwp8NegyC9Yxvlf3Y2u7VX4TvsTwS36kxkvk0geRnlRB6-dAPeTB6aig6m9jBODL5tlYbKYWI5TBOSjzv7cb7YC3K-p-7TSUHdIIUDd25YWxyCXLO8OK-u_BgNNCDtP9NhYQ6tDYUEcn7hkF83Z6f3hFvL0OFB5KbdukzmIxK6e_M4K2ZplYxcm_gMEZL3TFC-B2pZuhtYLyemW=s600-no" width="600" height="600" /></p>
<p>After dropping the <a href="http://weuponithiphop.info/tag/video/">video</a> for <strong>&#8220;Believe In Flee&#8221;</strong> yesterday, <strong>Cam&#8217;ron</strong> quickly follows with another <em><strong>Purple Haze 2</strong></em> release titled <strong>“Big Deal”</strong>.<br />
<iframe src="https://audiomack.com/embed/song/camronmusic/big-deal?background=1&amp;color=ff0000" width="100%" height="252" frameborder="0" scrolling="no"></iframe></p>
<div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="http://weuponithiphop.info/2019/12/10/new-music-camron-big-deal/" data-a2a-title="New Music: Cam’ron – Big Deal"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F12%2F10%2Fnew-music-camron-big-deal%2F&amp;linkname=New%20Music%3A%20Cam%E2%80%99ron%20%E2%80%93%20Big%20Deal" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F12%2F10%2Fnew-music-camron-big-deal%2F&amp;linkname=New%20Music%3A%20Cam%E2%80%99ron%20%E2%80%93%20Big%20Deal" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F12%2F10%2Fnew-music-camron-big-deal%2F&amp;linkname=New%20Music%3A%20Cam%E2%80%99ron%20%E2%80%93%20Big%20Deal" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F12%2F10%2Fnew-music-camron-big-deal%2F&amp;linkname=New%20Music%3A%20Cam%E2%80%99ron%20%E2%80%93%20Big%20Deal" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_tumblr" href="https://www.addtoany.com/add_to/tumblr?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F12%2F10%2Fnew-music-camron-big-deal%2F&amp;linkname=New%20Music%3A%20Cam%E2%80%99ron%20%E2%80%93%20Big%20Deal" title="Tumblr" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_reddit" href="https://www.addtoany.com/add_to/reddit?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F12%2F10%2Fnew-music-camron-big-deal%2F&amp;linkname=New%20Music%3A%20Cam%E2%80%99ron%20%E2%80%93%20Big%20Deal" title="Reddit" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_flipboard" href="https://www.addtoany.com/add_to/flipboard?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F12%2F10%2Fnew-music-camron-big-deal%2F&amp;linkname=New%20Music%3A%20Cam%E2%80%99ron%20%E2%80%93%20Big%20Deal" title="Flipboard" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2019%2F12%2F10%2Fnew-music-camron-big-deal%2F&amp;linkname=New%20Music%3A%20Cam%E2%80%99ron%20%E2%80%93%20Big%20Deal" title="Copy Link" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div>    </div>


    <footer>
                
        <div class="td-post-source-tags">
                        <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="http://weuponithiphop.info/tag/camron/">Cam'Ron</a></li></ul>        </div>

                <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="http://weuponithiphop.info/2019/12/10/new-music-terrace-martin-the-deuce-4/">New Music: Terrace Martin &#8211; The Deuce</a></div></div><div class="td-next-prev-separator"></div></div>        <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="http://weuponithiphop.info/author/cyclone/">cyclone</a></span></div>        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="cyclone"></span><meta itemprop="datePublished" content="2019-12-10T05:50:56+00:00"><meta itemprop="dateModified" content="2019-12-10T05:50:56+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://weuponithiphop.info/2019/12/10/new-music-camron-big-deal/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png"></span><meta itemprop="name" content="WeUpOnIt"></span><meta itemprop="headline " content="New Music: Cam’ron - Big Deal"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://lh3.googleusercontent.com/aGalCcqGTIvaozKSFJGlqJtr1VW-tOa7ncWK988f0iijDRUT-rmFsGb05ot_e7P2sPbQDKdlURMzQYOGAEHFZgnro4sQp_ZCnp_1w5aqzZRmdIiNrji_Uyz36OZl1xxr8KU4CKz7YKlSSKJ8bCM80DO1Gcjbkamcy_JyTmFZhRWvK12XD_8CIzcafmDBYqBr9cS3RXlQcxoN_n8uPmvwucCvBBWaQbuv6k3NyI2igtH_myCOZvNoxeQPhVtZtS-FZiJDm_OtQXh1LEF29l0KZaB31jXxYicxalIeqHgWcXpLsnobn_6VfrEQ7U2mv5jEfkc6xP4sRu18_YKhIxs9TkYbSUwQ_9SKlFAOEHRLERu2kUDlnYblQmkfWspAyoZIC6G9IV2QUi1NFv9QGsSWlZohiUXuSARdc1XnLUPzrczaT6AZ7KJZi3mMJVNnPzlHJ4x55m8EWjQUWLFjOxXfS0phhtvlGJYvkiW9G0YASqwp8NegyC9Yxvlf3Y2u7VX4TvsTwS36kxkvk0geRnlRB6-dAPeTB6aig6m9jBODL5tlYbKYWI5TBOSjzv7cb7YC3K-p-7TSUHdIIUDd25YWxyCXLO8OK-u_BgNNCDtP9NhYQ6tDYUEcn7hkF83Z6f3hFvL0OFB5KbdukzmIxK6e_M4K2ZplYxcm_gMEZL3TFC-B2pZuhtYLyemW=s600-no"><meta itemprop="width" content="800"><meta itemprop="height" content="600"></span>    </footer>

    <div class="td_block_wrap td_block_related_posts td_uid_15_5defd767b1433_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_15_5defd767b1433" ><script>var block_td_uid_15_5defd767b1433 = new tdBlock();
block_td_uid_15_5defd767b1433.id = "td_uid_15_5defd767b1433";
block_td_uid_15_5defd767b1433.atts = '{"limit":6,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_custom_related","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_15_5defd767b1433_rand","offset":"","css":"","live_filter":"cur_post_same_tags","live_filter_cur_post_id":36098,"live_filter_cur_post_author":"1"}';
block_td_uid_15_5defd767b1433.td_column_number = "3";
block_td_uid_15_5defd767b1433.block_type = "td_block_related_posts";
block_td_uid_15_5defd767b1433.post_count = "6";
block_td_uid_15_5defd767b1433.found_posts = "6";
block_td_uid_15_5defd767b1433.header_color = "";
block_td_uid_15_5defd767b1433.ajax_pagination_infinite_stop = "";
block_td_uid_15_5defd767b1433.max_num_pages = "1";
tdBlocksArray.push(block_td_uid_15_5defd767b1433);
</script><h4 class="td-related-title"><a id="td_uid_16_5defd767b409f" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_15_5defd767b1433" href="#">RELATED ARTICLES</a><a id="td_uid_17_5defd767b40dd" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_15_5defd767b1433" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_15_5defd767b1433 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/09/music-video-camron-believe-in-flee/" rel="bookmark" title="Music Video: Cam&#8217;ron &#8211; Believe In Flee"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/cuqrv0XHJkA_m0MAIkerzEIKxlqBnVRpsyX8JeydkSizxqx1bdXE1FHKw89DPC9FELnwwjXC-CbXKCQ8ZFFqkNy_47fARs-MFBNknSCTqbFMwY40QomnAbiu52R0V4XjQuQxhtrb5kGE3_UTaEQqA1fYz9VSdWhbULqdrV9pubt3JVDyF2gTIZbwzdc8AYQbVjay7lTM9M9CF0IYg9MdFifWJM6GueF2cXmARi8nZ7HHcT52fo8o4ftBSDztufUhL8xK5X04CtLgQXnurZKp2OXE-gG94_ay3boJLEUQgGXjfgVNRBqCk5mRyv6dbD_Xd7-NMedOvzdPPsS--1R3HFwC9Deq1hWvx7E4TZMRD2zyux-jVutLVglDsrrIpmwQKhefks9yvnWf7GoxdnxsTqOza-WrftB70lVVoxeyeMgcdFBhVp_tjI_XfgPYzMSLA2Yj_TF3O-q18rwvBD_961ED_2BGE_lT5r2QmW5LoRhxkUWTUDPlmewad_M9HQWAgl8o9CTUlhisQumSXlBic3gV0VE7yeVDzLprfr7M4zC5DLdvShtRkxNqYBze0fnbRYT8-L71evGGFgAFki8uFUZ08sP2N6xXlcvQosjs54Cf1J6wdkOZYoxfa9sn9VunlS9exwJ2BFFaDepEFOz7pQ3ZZHSJCTtfnPCXro6XS6capL9a4OOB_uHU=w1005-h471-no" alt="" title="Music Video: Cam&#8217;ron &#8211; Believe In Flee"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/09/music-video-camron-believe-in-flee/" rel="bookmark" title="Music Video: Cam&#8217;ron &#8211; Believe In Flee">Music Video: Cam&#8217;ron &#8211; Believe In Flee</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/10/02/new-music-camron-believe-in-flee-3/" rel="bookmark" title="New Music: Cam’ron &#8211; Believe In Flee"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/K51JETAPnZ49JqDhZRZ0HaKugH_3jZg2aB2PXfU7cGnxwDRTJVEGVWL1PtGVbbC2T5D_ec7qf5sGwfsVlJF-TYoRqhOc-agrYwxDV0e0HPPo-ZhNhb4DT4in_laL1faSkcdhg7bqBHfMnkIjZxQ4Le-VKQEC6mxDbunkIzEYD6rAZOYVt8rZOGIcuRH43Z1v0ggjK3mGtcGWcPgXy-DCPjsGXj2PouBXcBWv4e1wm0BnWmSrFqi0CPrJqMh6mmdfMjO70t2wgGBhXCtNdSso20V8G_L1SKPh2MNdlHC4yithixukrcPbOEA98lJrYXpDsCMPnPJsHcU1d8lThtqLP4q8sys1aXK1ZX1RE0CwOdNAylARY6GL0qKPVBMd_1ROcU7ASGbX3R4BYnncyIJiryeunK2wBN3yAEXdxksFytNqLXhAQMRjuaQ2q_V6t6ssaUZe8MBCxp5k3szKIFtyClenhqjsuqi9xWwkTqI8wX-tWsqX4gBWHy16TTbiSIgG1YVx4IMmpVjjK8lQstmtoqlJ1VpdvQXLQLFUxFws-0oIJr4dxnrXc5d_bSGVohvBywN3Nc2X0rgpXUKtLjMLtsHg2UfGTViWR4CVbT-eHlu1wpL0U4vOsslPbwv7hnoR-j0cD49pgPW79p5qnLFAhDiUjd_SFRyr-EQWOhWp7dFe3Nla9XoEwrLb=s700-no" alt="" title="New Music: Cam’ron &#8211; Believe In Flee"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/10/02/new-music-camron-believe-in-flee-3/" rel="bookmark" title="New Music: Cam’ron &#8211; Believe In Flee">New Music: Cam’ron &#8211; Believe In Flee</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/04/27/video-jay-z-brings-out-nas-camron-jim-jones-during-b-sides-2-concert/" rel="bookmark" title="Video: JAY Z Brings Out Nas, Cam’Ron &#038; Jim Jones During B-Sides 2 Concert"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/SOoAuJcDa3mzZ88XBs8J_pxsFmZJmCYTDy1KVadq_XiK53v8WdRO2BgXejGt-ehupmT8XfgiQSgb5XGRiQ5L9mPmHBQywpiRN9lbKOwl4zxUU-Oyj8BOHmwAaO376fRo6fK-RUnDp3uQ3v0KoDseufDwERQqcw3zNnXWhaPI_iv1pOE3fqgKqdeJtWCa4j-Ak51-fskzN8-Bhd4bz8GpVPXIANt6DJ0EBfWY_3Sfu40rrFv_v8ZLhf0Kz8x234rqG4w12WMupl3xUMFVkZkALDBQhReKQ6Gg_wUozGd-sT3d0TQHbD1b64l8fXTtpZ4lyD-JMOnmCyIdjM_RTwog1QvTtU8QVQEtO9IIZE8SLIyD1iLMAvsSq1JlLy2ziJK326CYy3zCwL5fxEn_9tM3pmEaY_TQs8bLta9mdqyEzVcajJCwpTzMVwb9hM2znRJNIwXe14RnUdw1P9WygZ3x-UAIBoLQRhTb0LUIU2pkb2yS88yIgsPAiYJtaKlB-gi8Xe6TooJY8qZ31fP9xhlQLwQqYQ7RrChectFklg-7U9KUX_w4zOYVmdVyEKiuvfMBJFCsadFtJpGCmtjFk0lTO8y0CmNH-co1Qg0Ub8aIKhPzZZiCSC4yeiUWhvD4wcjGmvMW-CW-zu_f-imeDNBrsAH54_Bp4gV2=w476-h590-no" alt="" title="Video: JAY Z Brings Out Nas, Cam’Ron &#038; Jim Jones During B-Sides 2 Concert"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/04/27/video-jay-z-brings-out-nas-camron-jim-jones-during-b-sides-2-concert/" rel="bookmark" title="Video: JAY Z Brings Out Nas, Cam’Ron &#038; Jim Jones During B-Sides 2 Concert">Video: JAY Z Brings Out Nas, Cam’Ron &#038; Jim Jones During B-Sides 2 Concert</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid-->

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/04/27/new-music-jim-jones-ft-camron-mama-i-made-it/" rel="bookmark" title="New Music: Jim Jones ft. Cam’ron – Mama I Made It"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/Tuf0uZOhB42eA0Kr5e4c-iACRvd2RXIvY_4UuebcUmyiokndyDRO0kDTivlj8i5OmeR8pRoEpXm9SDEYE_gJVEGTlmcXc2VIm3YnqzI4UaObUnRnAFeTuZmie5RtiHNZ6bf6KdX036XAzZwfEPsuVJO47bAjxomdYrRDCqTBZGk3QllMEQtmLGTkkrxl0jM8CFT2Ttf3hI_lPxs2qCGXXBecOM9Dlq6i7-HMkxl7iPTH-nokjvWPr3aTNg_mUfMm77zM-JKD5qD6wruKlx8jh0N3s7pXBv-AOSh51cHIfO29dQS9KdWQU0zqiR3YFDKy2fI7bE4jLDkQCdx1snBJqvNDg8vnXI_eU9303Mn_gGfYDLjqajZgfUf195Acis6bI-GkO19vKkHs2yjOaV79HTuFWgGTUyiXI7Kz2LZHYFXgNkQ4-0RB7SN9G-RPKZK3piwfJ2XLQYjg-sHG2zO-V6yPnZ44eSOuDp45RegEVN-nCTj2yPf1w6eZfswcgnxwJg0rDUUNGGbbF6sc8yty5QVi1pCr5aU3tCtZ1qmnoEClnGXH-Nzwj819gQRGwflH_M7zmXMNhR_mdFPv9dfihlLKGbdJeIVDMh8sNsW3zuiXUbpi68YoXeyVXWkswB8_XKbM8wlrN4mf-hCSCCBbyowNsym4d3u7=s796-no" alt="" title="New Music: Jim Jones ft. Cam’ron – Mama I Made It"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/04/27/new-music-jim-jones-ft-camron-mama-i-made-it/" rel="bookmark" title="New Music: Jim Jones ft. Cam’ron – Mama I Made It">New Music: Jim Jones ft. Cam’ron – Mama I Made It</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/04/20/music-video-camron-ft-disco-black-vellz-choppers/" rel="bookmark" title="Music Video: Cam’ron ft. Disco Black &#038; Vellz – Choppers"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/NkWiFrft-uwuW0eXpgPu4hSzYvPrWSM17bxXAPfgTz4-o14r_QxNTOJy8ONSCZNt_WMPLZ6w9ChVLK3zyQk6x9ygPaet9qzbclsSBkr_BhyFFMT-SPU-LlJBo1n21d-aqRQjdPEN3FrBabZGZ2-Yf-8MisXBFlsD0QAjsbnnUI3UOw3TAYtjZJrDrwChjsyBD3EofZEhqfhFdT_dl3lE8xacSpsabNeuEVMmCP1fYRR7qHr9HuszRI11W_mm6-Qqfo3q-otEiTo52CNFSeOfO3kk0uDJVMQcj7CphwFXlwRc0zWxXN0IGmaCBGuQ6hkk_jYI0wkNJ1-zFuSQT7ebrw4-eZ9G7wXA8sqHiRw7KxfnDEyRGI6Df-iF30xDkmIRFbAi-h5h_GfEetRlWVvBQDCrkmumlAx5wgHaf_QmfBgTuXH4yI7TZs-0xQ57droeKs3J2703pIGMvLbj8wy7BDYALm7pkL7vhCRhTFuVP3aWqTpaBcLdi1uv7_YJFtB_cvqdhNzMWJ6-a7feBEIZJc4rZVBL3nri3CqCwfO0ZVq3Vy-xWqUe7wJwsanUNUwln3gtE6R67Kfq0BuXdfLpLjTKUOdRiJwIwVwPsdT1Y4AeX3IUbwGKSocRf-MHIysA4_CiKADj1cBJScY85seem_hlAHCzbYUT=w591-h452-no" alt="" title="Music Video: Cam’ron ft. Disco Black &#038; Vellz – Choppers"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/04/20/music-video-camron-ft-disco-black-vellz-choppers/" rel="bookmark" title="Music Video: Cam’ron ft. Disco Black &#038; Vellz – Choppers">Music Video: Cam’ron ft. Disco Black &#038; Vellz – Choppers</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2018/11/22/music-video-the-diplomats-ft-belly-on-god/" rel="bookmark" title="Music Video: The Diplomats ft. Belly &#8211; On God"><img width="218" height="150" class="entry-thumb" src="http://weuponithiphop.info/wp-content/uploads/The-Diplomats-ft.-Belly-On-God-video-218x150.jpg" alt="" title="Music Video: The Diplomats ft. Belly &#8211; On God"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2018/11/22/music-video-the-diplomats-ft-belly-on-god/" rel="bookmark" title="Music Video: The Diplomats ft. Belly &#8211; On God">Music Video: The Diplomats ft. Belly &#8211; On God</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_15_5defd767b1433" data-td_block_id="td_uid_15_5defd767b1433"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page ajax-page-disabled" id="next-page-td_uid_15_5defd767b1433" data-td_block_id="td_uid_15_5defd767b1433"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->

	<div class="comments" id="comments">
            </div> <!-- /.content -->
                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <aside class="widget widget_search"><form method="get" class="td-search-form-widget" action="http://weuponithiphop.info/">
    <div role="search">
        <input class="td-widget-search-input" type="text" value="" name="s" id="s" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit" value="Search" />
    </div>
</form></aside><aside class="widget widget_text">			<div class="textwidget"><h4><strong><span style="color: #8224e3;"><span style="color: #000000;">Listen to</span> <span style="color: #c60000;">WeUpOnItRadio</span> <span style="color: #000000;">Live!</span></span></strong></h4>
<p><span class="cc_streaminfo" data-type="song" data-username="cyclone777">Loading &#8230;</span><br />
<script language="javascript" type="text/javascript" src="https://control.internet-radio.com:2199/system/streaminfo.js"></script><br />
<iframe src="https://tunein.com/embed/player/s292400/" style="width:100%; height:100px;" scrolling="no" frameborder="no"></iframe></p>
</div>
		</aside>
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-sidebar ">
<script type="text/javascript">
var td_screen_width = document.body.clientWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 

<aside class="widget widget_text"><div class="block-title"><span>AUDIOTRAFFICKER:</span></div>			<div class="textwidget"><p><iframe src="https://www.facebook.com/plugins/video.php?href=https%3A%2F%2Fwww.facebook.com%2FAudioTrafficker%2Fvideos%2F326277991409372%2F&#038;show_text=0&#038;width=560" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true" allowFullScreen="true"></iframe></p>
</div>
		</aside><aside class="widget widget_text"><div class="block-title"><span>ethemadassassin &#038; Celinski ft. Illpo -Hardbody</span></div>			<div class="textwidget"><p><iframe src="https://www.youtube.com/embed/3gn2e0gaP9o" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
</div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><div aria-live="polite" id="soliloquy-container-30342" class="soliloquy-container soliloquy-transition-fade  soliloquy-theme-classic" style="max-width:960px;max-height:300px;"><ul id="soliloquy-30342" class="soliloquy-slider soliloquy-slides soliloquy-wrap soliloquy-clear"><li aria-hidden="true" class="soliloquy-item soliloquy-item-1 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109673710?productType=812&#038;appearance=1" class="soliloquy-link" title="Revolt Tee" target="_blank"><img id="soliloquy-image-30349" class="soliloquy-image soliloquy-image-1" src="http://weuponithiphop.info/wp-content/uploads/Revolt-Tee.jpg" alt="Revolt Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-2 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/youngongetthiswork?q=I12154011" class="soliloquy-link" title="You Gon Get This Work" target="_blank"><img id="soliloquy-image-30344" class="soliloquy-image soliloquy-image-2" src="http://weuponithiphop.info/wp-content/uploads/You-Gon-Get-This-Work.jpg" alt="You Gon Get This Work" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-3 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/savage+bloody?q=I1014473415" class="soliloquy-link" title="Savage Bloody" target="_blank"><img id="soliloquy-image-30343" class="soliloquy-image soliloquy-image-3" src="http://weuponithiphop.info/wp-content/uploads/Savage-Bloody.jpg" alt="Savage Bloody" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-4 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/can?q=I1011767996" class="soliloquy-link" title="spray" target="_blank"><img id="soliloquy-image-30345" class="soliloquy-image soliloquy-image-4" src="http://weuponithiphop.info/wp-content/uploads/spray.jpg" alt="spray" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-5 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814012" class="soliloquy-link" title="Good Vibes Only 1" target="_blank"><img id="soliloquy-image-30346" class="soliloquy-image soliloquy-image-5" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-1.jpg" alt="Good Vibes Only 1" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-6 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/blessed?q=I12044252" class="soliloquy-link" title="Blessed Tee" target="_blank"><img id="soliloquy-image-30347" class="soliloquy-image soliloquy-image-6" src="http://weuponithiphop.info/wp-content/uploads/Blessed-Tee.jpg" alt="Blessed Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-7 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/trap?q=I1009984243" class="soliloquy-link" title="Trap Tee" target="_blank"><img id="soliloquy-image-30348" class="soliloquy-image soliloquy-image-7" src="http://weuponithiphop.info/wp-content/uploads/Trap-Tee.jpg" alt="Trap Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-8 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/good+vibes+only+birds?q=I1014476779" class="soliloquy-link" title="Good Vibes Only 2" target="_blank"><img id="soliloquy-image-30350" class="soliloquy-image soliloquy-image-8" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-2.jpg" alt="Good Vibes Only 2" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-9 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/all+seeing+eye?q=I11739019" class="soliloquy-link" title="ILLuminati" target="_blank"><img id="soliloquy-image-30351" class="soliloquy-image soliloquy-image-9" src="http://weuponithiphop.info/wp-content/uploads/ILLuminati.jpg" alt="ILLuminati" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-10 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/diamond_skull_1?q=I12527492" class="soliloquy-link" title="Diamond Skull" target="_blank"><img id="soliloquy-image-30352" class="soliloquy-image soliloquy-image-10" src="http://weuponithiphop.info/wp-content/uploads/Diamond-Skull.jpg" alt="Diamond Skull" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-11 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/donuts+doom-A109792920" class="soliloquy-link" title="donunts" target="_blank"><img id="soliloquy-image-30353" class="soliloquy-image soliloquy-image-11" src="http://weuponithiphop.info/wp-content/uploads/donunts.jpg" alt="donunts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-12 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/crime+pays?q=I12067735" class="soliloquy-link" title="Crime Pays" target="_blank"><img id="soliloquy-image-30434" class="soliloquy-image soliloquy-image-12" src="http://weuponithiphop.info/wp-content/uploads/Crime-Pays.jpg" alt="Crime Pays" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-13 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/fuckyoupayme?q=I11550361" class="soliloquy-link" title="Fuck You Pay Me" target="_blank"><img id="soliloquy-image-30436" class="soliloquy-image soliloquy-image-13" src="http://weuponithiphop.info/wp-content/uploads/Fuck-You-Pay-Me.jpg" alt="Fuck You Pay Me" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-14 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814011" class="soliloquy-link" title="savage gold tee" target="_blank"><img id="soliloquy-image-30354" class="soliloquy-image soliloquy-image-14" src="http://weuponithiphop.info/wp-content/uploads/savage-gold-tee.jpg" alt="savage gold tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-15 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/?page=2" class="soliloquy-link" title="fresh-clean-signature-" target="_blank"><img id="soliloquy-image-30437" class="soliloquy-image soliloquy-image-15" src="http://weuponithiphop.info/wp-content/uploads/fresh-clean-signature-.jpg" alt="fresh-clean-signature-" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-16 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/%24teez?q=I1001415610" class="soliloquy-link" title="gold fronts" target="_blank"><img id="soliloquy-image-30355" class="soliloquy-image soliloquy-image-16" src="http://weuponithiphop.info/wp-content/uploads/gold-fronts.jpg" alt="gold fronts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-17 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/soldier?q=I11611241" class="soliloquy-link" title="Swag Soldier" target="_blank"><img id="soliloquy-image-30435" class="soliloquy-image soliloquy-image-17" src="http://weuponithiphop.info/wp-content/uploads/Swag-Soldier.jpg" alt="Swag Soldier" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-18 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/gamer-A7923028?productType=210&#038;appearance=22" class="soliloquy-link" title="gamer" target="_blank"><img id="soliloquy-image-30438" class="soliloquy-image soliloquy-image-18" src="http://weuponithiphop.info/wp-content/uploads/gamer.jpg" alt="gamer" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-19 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/" class="soliloquy-link" title="freshandlogo Square" target="_blank"><img id="soliloquy-image-30356" class="soliloquy-image soliloquy-image-19" src="http://weuponithiphop.info/wp-content/uploads/freshandlogo-Square.jpg" alt="freshandlogo Square" /></a></li></ul></div><noscript><style type="text/css">#soliloquy-container-30342{opacity:1}</style></noscript>
</div>
		</aside>                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</article> <!-- /.post -->


<!-- Instagram -->



<!-- Footer -->
<div class="td-footer-wrapper td-footer-template-3">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
			    		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span4">
                <div class="td-footer-info"><div class="footer-logo-wrap"><a href="http://weuponithiphop.info/"><img class="td-retina-data" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" alt="" title=""/></a></div><div class="footer-text-wrap"></div><div class="footer-social-wrap td-social-style-2">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div></div>            </div>

            <div class="td-pb-span4">
                <aside class="widget widget_calendar"><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar">
	<caption>December 2019</caption>
	<thead>
	<tr>
		<th scope="col" title="Sunday">S</th>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
	</tr>
	</thead>

	<tfoot>
	<tr>
		<td colspan="3" id="prev"><a href="http://weuponithiphop.info/2019/11/">&laquo; Nov</a></td>
		<td class="pad">&nbsp;</td>
		<td colspan="3" id="next" class="pad">&nbsp;</td>
	</tr>
	</tfoot>

	<tbody>
	<tr><td><a href="http://weuponithiphop.info/2019/12/01/" aria-label="Posts published on December 1, 2019">1</a></td><td><a href="http://weuponithiphop.info/2019/12/02/" aria-label="Posts published on December 2, 2019">2</a></td><td><a href="http://weuponithiphop.info/2019/12/03/" aria-label="Posts published on December 3, 2019">3</a></td><td><a href="http://weuponithiphop.info/2019/12/04/" aria-label="Posts published on December 4, 2019">4</a></td><td><a href="http://weuponithiphop.info/2019/12/05/" aria-label="Posts published on December 5, 2019">5</a></td><td><a href="http://weuponithiphop.info/2019/12/06/" aria-label="Posts published on December 6, 2019">6</a></td><td><a href="http://weuponithiphop.info/2019/12/07/" aria-label="Posts published on December 7, 2019">7</a></td>
	</tr>
	<tr>
		<td><a href="http://weuponithiphop.info/2019/12/08/" aria-label="Posts published on December 8, 2019">8</a></td><td><a href="http://weuponithiphop.info/2019/12/09/" aria-label="Posts published on December 9, 2019">9</a></td><td id="today"><a href="http://weuponithiphop.info/2019/12/10/" aria-label="Posts published on December 10, 2019">10</a></td><td>11</td><td>12</td><td>13</td><td>14</td>
	</tr>
	<tr>
		<td>15</td><td>16</td><td>17</td><td>18</td><td>19</td><td>20</td><td>21</td>
	</tr>
	<tr>
		<td>22</td><td>23</td><td>24</td><td>25</td><td>26</td><td>27</td><td>28</td>
	</tr>
	<tr>
		<td>29</td><td>30</td><td>31</td>
		<td class="pad" colspan="4">&nbsp;</td>
	</tr>
	</tbody>
	</table></div></aside>            </div>

            <div class="td-pb-span4">
                <aside class="widget widget_text">			<div class="textwidget"><div aria-live="polite" id="soliloquy-container-30342" class="soliloquy-container soliloquy-transition-fade  soliloquy-theme-classic" style="max-width:960px;max-height:300px;"><ul id="soliloquy-30342" class="soliloquy-slider soliloquy-slides soliloquy-wrap soliloquy-clear"><li aria-hidden="true" class="soliloquy-item soliloquy-item-1 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109673710?productType=812&#038;appearance=1" class="soliloquy-link" title="Revolt Tee" target="_blank"><img id="soliloquy-image-30349" class="soliloquy-image soliloquy-image-1" src="http://weuponithiphop.info/wp-content/uploads/Revolt-Tee.jpg" alt="Revolt Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-2 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/youngongetthiswork?q=I12154011" class="soliloquy-link" title="You Gon Get This Work" target="_blank"><img id="soliloquy-image-30344" class="soliloquy-image soliloquy-image-2" src="http://weuponithiphop.info/wp-content/uploads/You-Gon-Get-This-Work.jpg" alt="You Gon Get This Work" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-3 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/savage+bloody?q=I1014473415" class="soliloquy-link" title="Savage Bloody" target="_blank"><img id="soliloquy-image-30343" class="soliloquy-image soliloquy-image-3" src="http://weuponithiphop.info/wp-content/uploads/Savage-Bloody.jpg" alt="Savage Bloody" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-4 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/can?q=I1011767996" class="soliloquy-link" title="spray" target="_blank"><img id="soliloquy-image-30345" class="soliloquy-image soliloquy-image-4" src="http://weuponithiphop.info/wp-content/uploads/spray.jpg" alt="spray" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-5 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814012" class="soliloquy-link" title="Good Vibes Only 1" target="_blank"><img id="soliloquy-image-30346" class="soliloquy-image soliloquy-image-5" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-1.jpg" alt="Good Vibes Only 1" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-6 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/blessed?q=I12044252" class="soliloquy-link" title="Blessed Tee" target="_blank"><img id="soliloquy-image-30347" class="soliloquy-image soliloquy-image-6" src="http://weuponithiphop.info/wp-content/uploads/Blessed-Tee.jpg" alt="Blessed Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-7 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/trap?q=I1009984243" class="soliloquy-link" title="Trap Tee" target="_blank"><img id="soliloquy-image-30348" class="soliloquy-image soliloquy-image-7" src="http://weuponithiphop.info/wp-content/uploads/Trap-Tee.jpg" alt="Trap Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-8 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/good+vibes+only+birds?q=I1014476779" class="soliloquy-link" title="Good Vibes Only 2" target="_blank"><img id="soliloquy-image-30350" class="soliloquy-image soliloquy-image-8" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-2.jpg" alt="Good Vibes Only 2" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-9 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/all+seeing+eye?q=I11739019" class="soliloquy-link" title="ILLuminati" target="_blank"><img id="soliloquy-image-30351" class="soliloquy-image soliloquy-image-9" src="http://weuponithiphop.info/wp-content/uploads/ILLuminati.jpg" alt="ILLuminati" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-10 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/diamond_skull_1?q=I12527492" class="soliloquy-link" title="Diamond Skull" target="_blank"><img id="soliloquy-image-30352" class="soliloquy-image soliloquy-image-10" src="http://weuponithiphop.info/wp-content/uploads/Diamond-Skull.jpg" alt="Diamond Skull" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-11 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/donuts+doom-A109792920" class="soliloquy-link" title="donunts" target="_blank"><img id="soliloquy-image-30353" class="soliloquy-image soliloquy-image-11" src="http://weuponithiphop.info/wp-content/uploads/donunts.jpg" alt="donunts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-12 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/crime+pays?q=I12067735" class="soliloquy-link" title="Crime Pays" target="_blank"><img id="soliloquy-image-30434" class="soliloquy-image soliloquy-image-12" src="http://weuponithiphop.info/wp-content/uploads/Crime-Pays.jpg" alt="Crime Pays" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-13 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/fuckyoupayme?q=I11550361" class="soliloquy-link" title="Fuck You Pay Me" target="_blank"><img id="soliloquy-image-30436" class="soliloquy-image soliloquy-image-13" src="http://weuponithiphop.info/wp-content/uploads/Fuck-You-Pay-Me.jpg" alt="Fuck You Pay Me" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-14 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814011" class="soliloquy-link" title="savage gold tee" target="_blank"><img id="soliloquy-image-30354" class="soliloquy-image soliloquy-image-14" src="http://weuponithiphop.info/wp-content/uploads/savage-gold-tee.jpg" alt="savage gold tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-15 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/?page=2" class="soliloquy-link" title="fresh-clean-signature-" target="_blank"><img id="soliloquy-image-30437" class="soliloquy-image soliloquy-image-15" src="http://weuponithiphop.info/wp-content/uploads/fresh-clean-signature-.jpg" alt="fresh-clean-signature-" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-16 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/%24teez?q=I1001415610" class="soliloquy-link" title="gold fronts" target="_blank"><img id="soliloquy-image-30355" class="soliloquy-image soliloquy-image-16" src="http://weuponithiphop.info/wp-content/uploads/gold-fronts.jpg" alt="gold fronts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-17 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/soldier?q=I11611241" class="soliloquy-link" title="Swag Soldier" target="_blank"><img id="soliloquy-image-30435" class="soliloquy-image soliloquy-image-17" src="http://weuponithiphop.info/wp-content/uploads/Swag-Soldier.jpg" alt="Swag Soldier" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-18 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/gamer-A7923028?productType=210&#038;appearance=22" class="soliloquy-link" title="gamer" target="_blank"><img id="soliloquy-image-30438" class="soliloquy-image soliloquy-image-18" src="http://weuponithiphop.info/wp-content/uploads/gamer.jpg" alt="gamer" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-19 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/" class="soliloquy-link" title="freshandlogo Square" target="_blank"><img id="soliloquy-image-30356" class="soliloquy-image soliloquy-image-19" src="http://weuponithiphop.info/wp-content/uploads/freshandlogo-Square.jpg" alt="freshandlogo Square" /></a></li></ul></div><noscript><style type="text/css">#soliloquy-container-30342{opacity:1}</style></noscript>
</div>
		</aside>            </div>
        </div>
    </div>
</div>

<!-- Sub Footer -->
    <div class="td-sub-footer-container">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span7 td-sub-footer-menu">
                        <div class="menu-top-menu-container"><ul id="menu-top-menu-2" class="td-subfooter-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-first td-menu-item td-mega-menu menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_20_5defd767cafe7_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_20_5defd767cafe7" ><script>var block_td_uid_20_5defd767cafe7 = new tdBlock();
block_td_uid_20_5defd767cafe7.id = "td_uid_20_5defd767cafe7";
block_td_uid_20_5defd767cafe7.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"43","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_20_5defd767cafe7_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_20_5defd767cafe7.td_column_number = "3";
block_td_uid_20_5defd767cafe7.block_type = "td_block_mega_menu";
block_td_uid_20_5defd767cafe7.post_count = "5";
block_td_uid_20_5defd767cafe7.found_posts = "2648";
block_td_uid_20_5defd767cafe7.header_color = "";
block_td_uid_20_5defd767cafe7.ajax_pagination_infinite_stop = "";
block_td_uid_20_5defd767cafe7.max_num_pages = "530";
tdBlocksArray.push(block_td_uid_20_5defd767cafe7);
</script><div id=td_uid_20_5defd767cafe7 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/10/new-music-camron-big-deal/" rel="bookmark" title="New Music: Cam’ron &#8211; Big Deal"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/aGalCcqGTIvaozKSFJGlqJtr1VW-tOa7ncWK988f0iijDRUT-rmFsGb05ot_e7P2sPbQDKdlURMzQYOGAEHFZgnro4sQp_ZCnp_1w5aqzZRmdIiNrji_Uyz36OZl1xxr8KU4CKz7YKlSSKJ8bCM80DO1Gcjbkamcy_JyTmFZhRWvK12XD_8CIzcafmDBYqBr9cS3RXlQcxoN_n8uPmvwucCvBBWaQbuv6k3NyI2igtH_myCOZvNoxeQPhVtZtS-FZiJDm_OtQXh1LEF29l0KZaB31jXxYicxalIeqHgWcXpLsnobn_6VfrEQ7U2mv5jEfkc6xP4sRu18_YKhIxs9TkYbSUwQ_9SKlFAOEHRLERu2kUDlnYblQmkfWspAyoZIC6G9IV2QUi1NFv9QGsSWlZohiUXuSARdc1XnLUPzrczaT6AZ7KJZi3mMJVNnPzlHJ4x55m8EWjQUWLFjOxXfS0phhtvlGJYvkiW9G0YASqwp8NegyC9Yxvlf3Y2u7VX4TvsTwS36kxkvk0geRnlRB6-dAPeTB6aig6m9jBODL5tlYbKYWI5TBOSjzv7cb7YC3K-p-7TSUHdIIUDd25YWxyCXLO8OK-u_BgNNCDtP9NhYQ6tDYUEcn7hkF83Z6f3hFvL0OFB5KbdukzmIxK6e_M4K2ZplYxcm_gMEZL3TFC-B2pZuhtYLyemW=s600-no" alt="" title="New Music: Cam’ron &#8211; Big Deal"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/10/new-music-camron-big-deal/" rel="bookmark" title="New Music: Cam’ron &#8211; Big Deal">New Music: Cam’ron &#8211; Big Deal</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/10/new-music-terrace-martin-the-deuce-4/" rel="bookmark" title="New Music: Terrace Martin &#8211; The Deuce"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/rO3-2jSprEBWYUMIGU8sECnRvBUezh2-DkwS1j-xQQMFElAA7mhQUz_7UBMrgitdChZxPZ_TbYFh3orO6fhRC4QEvO_AwVkqulCWTK4Xb0_xZ3aHBbktv0VEMt1t6-QMmXwVqOX8sfq7PD1DQdHCNHEUi0S7-7RSe1W0T1QnQvDCNggnpqp-OAcITPgCowMI9G4mVz3Mgd-TuuxGVENmJ4WcMvaqd-m3YWwK5xeFWF1OJcsbSjrj1uS5O8L5g_nMjJk4BLTS53u0SrVapoxZcbN_Sxzz_fC0FC59VbBHB3SfUdhSVGXoXwO9RqYKwYtEnJu8GIU72urKAjSdWsG4OoLWssFd2pf7N0AOAU0ao0DjjzuOn4z846NMYSteWdcyE0IkxW4RkGb5oPgwfLKyYDTdVekwpup6j_61P8KdRDSHcUZM9B-_Kwl0DubJQq8lbUzaJZF8z0y_fLsxuGJxFEtxhOBBVgmJo7asLGOHq-POjZ7Ce1_FLQTFsEjx3DZ_7AF3m2byVgMviMbgDwo66JOK46CqbY3g2Rh3Is9y5rHdwAReeIpbudtu8p3WdHdMChyPdFV6Cf6TdilXneIBGok9U3LSwmZdhcB1Z4PaLqR_oXAqhaL1MxPjH4T42dquSiPrcVC7M902GkqMSD-uFYg05Q2bAMDdwqd1e0Bfxvsc2BAhVT0ebqAv=s328-no" alt="" title="New Music: Terrace Martin &#8211; The Deuce"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/10/new-music-terrace-martin-the-deuce-4/" rel="bookmark" title="New Music: Terrace Martin &#8211; The Deuce">New Music: Terrace Martin &#8211; The Deuce</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/09/new-music-rich-the-kid-ft-quavo-thats-tuff/" rel="bookmark" title="New Music: Rich the Kid ft. Quavo &#8211; That’s Tuff"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/p5wtJ1qC0cDE4dGwXatEU1X1g-IARVN9K2QtgA28iaKSh7J2vJdutJd-T6MZm0qFpPQn5mUvC6POcAD-K5-NkMtG5ivRVuPeBkKpvEDu7W4Ig3k13ui5L8iE0OCzBf6_Bte7CoVUKBOrvhHon35NhalxL-Y-cig2wl7HFlwgj5aAYIcLXUgZMz6NDD0e_bQ7jLIKs0YyrimiFFPIuqxQvTLiItVfsZG56vTuSYOwMHx2Il7gFQoMhIxinUCZpqclJYoREeNGvZnayEb-lsLYz9vi4zf4NXOXQNvmBw1DfVEcpjvbjhaQ9CZrgCghxxMpZTPXFH1hn4iax6B9CiOvOpiNGpVfYRrlQZJAw1d9Yi_tFL1rv5ApVE_XfnKwPJrzCeMomoxSaFLcAJNRV8LnS26epzKuG9zvG6k_riVo-9ZgKUJz-jFUa7TsKMOm6rGs2G7RyUsfMGdZdJymQnPN76A1JWj5rwSqoYii2zq9R_sg5mPpfZyv2v2cN1uI7HqhoxtzSBHUL5PX1CrOp-EIGS0PS7rCYkakzO93GwcYwNMupdbsS3Z8iXPowxJ2O2OAkSi7y6zw7JBvNu9Tar9V-7xBhO8218YvOn8qjOl8OORkwCrKa5Pi9UThkJ3Zu7C2zyAsdtNQ3P-Sd1Lzoi-NusbKTCcIXU9IKhLVJFo6Z3RB0Dktdd6ngCq2=s500-no" alt="" title="New Music: Rich the Kid ft. Quavo &#8211; That’s Tuff"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/09/new-music-rich-the-kid-ft-quavo-thats-tuff/" rel="bookmark" title="New Music: Rich the Kid ft. Quavo &#8211; That’s Tuff">New Music: Rich the Kid ft. Quavo &#8211; That’s Tuff</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/09/new-music-sauce-walka-ft-mozzy-mama/" rel="bookmark" title="New Music: Sauce Walka ft.Mozzy &#8211; Mama"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/P50E9cP1kYpcDupUHGV9VzwTQgvFJ2NKMvybBqX83rhL_OdeHfaI22jgwnevd8R0QsPiioXMck7hr7QT6tUOylFNoSCRXlzEhw78DnKT52T9AbReP860G0TxdyA-WplNUDnKy1FGMNLUdrJustWJfN3Xl_qVHrMbp41XoZ8O-zoZj3X4LOEOufj8m9oqRBu9tu34qbrQCyPz8BdB2RcaIB24t_8C4C8kiMu5CuhE-qKTtxK41VAEFyFyendELEeFN3p7WY9i9bLJ2wH8p6svZ-tKm3tl7HswdjrHkLTcz0ksff6B0MDxxeQDkk3cv-Rms58aSF1RJ7JuBSRgDJ19vS2iuG8pzg3ctmRTvUceJCH4yw0T8pVjq0BLIf5L_lZvMY7HOXKNZmGe3a2R3-y74B_SI0qs9cOZ8owzwK_iLfMEIXj7_yp5clfBF02tFv_j0fVkAMhEf1vWJK19SFJmc1vrb3AohLe3_Ska_Emo8Yafg7rGpWBXrFWx4UkGt8ODwJ7P59biKLxJbGweTkyLmHK7i14H_jG4XEsdJopbBfT_fPFcnCJ0ekMFrpL8jvOS8wEeCN-1MnalE2VfFyYUjIdCWZdGs5j2FeMannbs594PW4Kw2TC0BvbwuKAGDD8RSHjLLOef3IISgWqJq1DJNpocsuuOi4giKzV1Yc248PixoP--r5V-Ycw=s750-no" alt="" title="New Music: Sauce Walka ft.Mozzy &#8211; Mama"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/09/new-music-sauce-walka-ft-mozzy-mama/" rel="bookmark" title="New Music: Sauce Walka ft.Mozzy &#8211; Mama">New Music: Sauce Walka ft.Mozzy &#8211; Mama</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/08/new-music-august-alsina-today-9/" rel="bookmark" title="New Music: August Alsina &#8211; Today"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/np-kE-QnU9NtU83iu0dLv01WfzUfMiH7wRRR4hE9F975HXAl51_dhxiNoWNL8OFjYdsAMmDeOs1NAjMnVQaXK0DErgsQRLaZzoFnJ11mB8oVIQL_q_q01rRuifJy-PYpTpaJYHpXlRP11CrfUTQwNyHO_yq7AVqGlP39x9-jtgC1wvLRLwumJwMLL4O1VEMjWS4PZrBzRC2AiQSl0mQ8OPuu1_Qj3kr9ubudRagHZ9Sc2h5gWAdobeJ2bKO5tWqn4ipzliUZ-ENBLQV_WhAX_HjnEmiq1_vyLuYmTzdrTy2TaJ8AWS-etikR2qzuGZaXficg4RHk-gKhVPvBUpaV1EXmdejbGE4wQtx5KYK55dvXi64is5fyrcLPA22JAq4WEQ1bfiGg6JXzwBLlvWU2RUkrqFFhqo_k46jbxWZSYde4rnmbRWbM7CW0Y4FLe2-wRTujpaNeb0dVpfaZGN-xBRiSUQKtJFpyqz6pP0x_54kYoLYXh5mOSfTDChYhRDkh71dmziFeHF2ZbB5OdjdWBQKD8hIz6ENwZ8AmP558Dmd54PhBD0Uo-hpkpzbKE8L_jQ9rNGBRfLNONa86kGpxDvHoAnywvBQ-WmLFEQoqCGFrI0CGxtqtW75Wr2jrm3F5g1l_kpFMly7IcprHu_pJr5lO7I4MpCryzJcdEDAxbqecaRE5eCRBx7k=s500-no" alt="" title="New Music: August Alsina &#8211; Today"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/08/new-music-august-alsina-today-9/" rel="bookmark" title="New Music: August Alsina &#8211; Today">New Music: August Alsina &#8211; Today</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_20_5defd767cafe7" data-td_block_id="td_uid_20_5defd767cafe7"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_20_5defd767cafe7" data-td_block_id="td_uid_20_5defd767cafe7"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_21_5defd767ce56b_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_21_5defd767ce56b" ><script>var block_td_uid_21_5defd767ce56b = new tdBlock();
block_td_uid_21_5defd767ce56b.id = "td_uid_21_5defd767ce56b";
block_td_uid_21_5defd767ce56b.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"97","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_21_5defd767ce56b_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_21_5defd767ce56b.td_column_number = "3";
block_td_uid_21_5defd767ce56b.block_type = "td_block_mega_menu";
block_td_uid_21_5defd767ce56b.post_count = "5";
block_td_uid_21_5defd767ce56b.found_posts = "943";
block_td_uid_21_5defd767ce56b.header_color = "";
block_td_uid_21_5defd767ce56b.ajax_pagination_infinite_stop = "";
block_td_uid_21_5defd767ce56b.max_num_pages = "189";
tdBlocksArray.push(block_td_uid_21_5defd767ce56b);
</script><div id=td_uid_21_5defd767ce56b class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/09/ep-stream-max-b-house-money/" rel="bookmark" title="EP Stream: Max B &#8211; House Money"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/8Ol9vwwbWwdm303LB23V4tCgPTrQSXml2qdb5AVfQivFcGTwc1AWFRFL8jKtJB2Ikb0UEQjGWzAMHSb1LR-HlMdQNexrEl2DQ8vcaW_Rnip7SXI-IduxJyaAI64NbyDUNwtfUmCPWjtudRVFZSDMcekL5Ev2znuW0nf_70dbtBcZLEI3joG9jX7AxXLt0T1HYlW03dvvqDbr8yLzK3FWP0Kcvv6eifOyhkW_2otzho9gibv6RkqhNb6QET6AIzE08_J7n9Ri8Wt9lwnw2bnEPdUe8kS6coX0TAmHm0-g3G45NovrP0SQU1cC9CfnGFuS1Tt7OwB4QOMJjtqPO_DAOpokUCLYGGF-ac4cIkW2IEFWDRueVp7c9a0qhDZUoD9VRvMni4CV27gBw65vI5qOkfvYt10A-Qvhn29Fqd8BCDnMPnCZllHSx0NflPC9nnODDsvPTbDaHHqpb7aUkEXKNeQl1ZNlygkLBE-tLUlB6Fz6Q4ZkgXF1szLFho0N9IpUxdvYeON7xgnS2-oURwEqNUABsrTKqUJ7ffLBgjMu7taYWcEZzyAsJRIDQs8MBFUJuqwSokqLstd5o6-V7f5LQi1KmnwJtaCuq3DsO_nHu4jxhLUedhJ-BbPj0-Cp2CkDR_M6HqUMUmA_qq3si3XSmHkn3MHYKpbjv7loP1M_G2EPhCm0rgnmsVUw=s500-no" alt="" title="EP Stream: Max B &#8211; House Money"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/09/ep-stream-max-b-house-money/" rel="bookmark" title="EP Stream: Max B &#8211; House Money">EP Stream: Max B &#8211; House Money</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/08/album-stream-french-montana-montana/" rel="bookmark" title="Album Stream: French Montana &#8211; Montana"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/iDIiq2SiFkd90aA-rWT6vGv8VjLOh5jXGB9ZOohYTzeyV67Mz6YURuvUrkn60ckhweAhB3lqUc5V-Au8RLX66KntZz5x85eR9z-1Ti87ST_iiYJ2A3NA07P65tZr7gsp7OKv5Dsvam-u6L6YevwM0hVSEO2IB6y09hq7Mnv_0oAVKrC8IcrB2UGGBwdruBi9LcZ3RMeiV-jytMmC3tTyMcCg5NIBxictjpxvEQkmTvcMviwS4ISRF02DZP0mRf3e3OqZ5HjAPQhVgT-lzFrSvAq0giBcKo8V-jfyM4S2BkbHy4MjEy8wLe_5No92oEokoFzrlz9Fi0RU7m9HprigCr-F66LWMnsM3Vr_mNyMkkLBC4Q0XS83quKZlSZQl1Pr5u1XC3heI-wfpK6wkICvGuv9vUoTQgMKqR3rcAqBVVbqaLndtNLjjLWyUm9LIHrebHUsyBW02DVbAkkzkDsow2BONvsyQdi49jHfFyiLCAK231r0EeE8DqjlMoo6QLRNZTvObqFXYyQg5xk869IUm4HPjuMxbqEi3n6nwPZBuld-SGur0Ql_8yRre4hVO2ieBeRM6AX_srimsG8pHRJGIArQWvXkE482XKLp9nWZe9V26dgAHitkeQQrrt9yMfiRV6RJOwRGFYEUC3qQns5tEIE7ujLH82BJMc66iQwQ2pnmPmNW2LsgrNk=s500-no" alt="" title="Album Stream: French Montana &#8211; Montana"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/08/album-stream-french-montana-montana/" rel="bookmark" title="Album Stream: French Montana &#8211; Montana">Album Stream: French Montana &#8211; Montana</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/08/album-stream-roddy-ricch-please-excuse-me-for-being-antisocial-63/" rel="bookmark" title="Album Stream: Roddy Ricch &#8211; Please Excuse Me For Being Antisocial"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/OMRT-RVvI24rWb0cEmCH3YihlstomcOYfQPIFUqy59fgS-FZtfeOdwq31ROLPu_bBzNxX92mfMWQqqkKc6TYaAVZzJ5sZPDaX-wUH5PLzNXI8noozlaX8dzTCLXAW89fa7T2Go9jxrrTY1eDnOpKz2xRDCjY59MQu5G5Q5eebN-UXi761aohjtmbdMh6t9B2e71juzV4_URJ_8mwaKOphshCwl_XPyo61PS67fiwKBx7lVtrhxnMFbcqd_HN5lYmeO6k5a3ezQ1BgHrCfAGe79jSNUHYjGtEyUv4O9n_5UhXfAVfP0u4ta3XYJM9XTPKzMaItav-6yzbpa5HJuqBlygFO8Vm1p-sYdlo-WhksG6stykbjrv_AFGKTIlz0KhyB2OmU0gdg69sh__zqCDhD7QX-hhPhbo6AF5vyEjysil0iMvETjQQQIw5ZlW81kJWMKf8VVXkWKrSjik7r84ZXvppUtiKhEvn27-7JQJcVzkJOhimAimjhJRqKtbV9iVEJkU3gws1YkRhxQT-DYYRn48eYFnk7hg_1gsFSBrp8PPVAsT2spQtBU4ngO8NyPcQnqq320FhLqSaTnduAuhafhC7zth_nFQVLWINTWQjE-KiRjuWujmeCZhtv03gAnL4MjX1x8x6zx6XYjWJDNshqvoY-9pR34Jz8-ofwIYi7WpDMfofvp42ad4=s500-no" alt="" title="Album Stream: Roddy Ricch &#8211; Please Excuse Me For Being Antisocial"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/08/album-stream-roddy-ricch-please-excuse-me-for-being-antisocial-63/" rel="bookmark" title="Album Stream: Roddy Ricch &#8211; Please Excuse Me For Being Antisocial">Album Stream: Roddy Ricch &#8211; Please Excuse Me For Being Antisocial</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/01/album-stream-the-game-born-2-rap/" rel="bookmark" title="Album Stream: The Game &#8211; Born 2 Rap"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/9tgqzzFHuvtZbwB5HPJIMDfa-wg5T2TS0PV_zMeIe9BWi5gHw6buQkWy3-kc3aB1x34zY6s3p7-rYssXXtCwfYZYmyd-ecLkBxngbY8-cbXD9wd1iTZ93VHhIP3WXaCfEi5i1lwrqo_SQ_Gjy6ET_agXuczM1hbCvajWxBJWRkHqvDi5bZu0uYnHIyAwcQYb7W8lk42KClZrHkx2j25JsYOxb-IzNNNjQ5xKTXrZLaudpim86uqC3GDHlXOvO4s-mqHGsE-PqWbzgEd5hdnHsLjXsfjR2c0Z6VG2C4rYGSfBNCSRMsMHbbxPtIDQ2VrdL9p0ykNhNg99SsjOYkKQ4oqWp-42Yqog-3mAML__SkSSuMX65rBT_72b5Hr_Xsgd4_ZLkBlYXadPmNpVtFs70LCBaKTgwysA9xgPxKuCutOBW6Ntys3g5h5lwIpc_K-4Ui6kxAJNSwGrm-ZEnvfl2AbHHP5vZm3pLr8-T56qgIZwhv6mMLWWPt-ltradWsLm7zqqcAPYfmPUOzDtYPADr4tMnD37apbxiJVk9A7CKmb0O8lA6eCbLy3AzeuvAlbp-GxfT2Uh0I3RyjiKa_VivEayb8QmZd5cvcqs3JyOzJc0FAsjNwle_owjTnMiUjFmR1NzdnIMAoBG6uAxc8faK6q9MFpzyBdYcytMNG_osr8Bf2pwn3cosDxL=s700-no" alt="" title="Album Stream: The Game &#8211; Born 2 Rap"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/01/album-stream-the-game-born-2-rap/" rel="bookmark" title="Album Stream: The Game &#8211; Born 2 Rap">Album Stream: The Game &#8211; Born 2 Rap</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/30/album-stream-blac-youngsta-church-on-sunday/" rel="bookmark" title="Album Stream: Blac Youngsta &#8211; Church On Sunday"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/RShK3qrtklG5LejgFJwhFYSdKdmjjoAKY91H-WiI3KxmJpGM3zftQAPTnJ0iO0pFsXCw6D1k-nDahpo5TOvrU6utfxo-oyECuuhToWp8TH1QfSK2BTokTzX7jeJVp9qVWpJxMRnokUMt01vO0Jmy-Oquc0D35Utmr0eoxmBIX8Yqv1ldYqOG9NL02tYIa54QFYcSMtrZWoD2kYSgRz1plCOhYB7iVea3nUURldYr96bBsY5Kn3DrsKZgTfsYKW2M7Sd4cN5Kn5NM_pybn1VcXHG6j2gfu1QrxbJfLZmPwWXSFo1jELw0TpClPzuE5caXSlmPMZ11V9iRQ6dGt8EhJ5R2Eg_lw1pG6UI7t2INFDDp0jdQ4sC6ExMxzMd31x3BKD5mNYkMWjlSSuY5NEyUzHMiR7dhxNjnc4DcVBAskZP45GgT0UTdQKgqhob_xCkoLGVRPu4_kCOdkDeYta57C9mEPa1KTfo94EUt3J9FccajsirbeQOBPNgth--kqhhkHQyMWZAqobx7fuAsI-ipoAFQFscALbU6LwYJLsb6azSH7wagssRMNIfKO5yani4xeFLdGL7gLwJLYJZCMrWfI5P-OH0x6BZKr0ajQV1KAGgi1Ivzgvf8BuXWJ8vFMwcDENwdFyHCXsEIVciEv60yAGWR98azw0jjtYhilXKMPU7fg4QhYzmLGiq5=s500-no" alt="" title="Album Stream: Blac Youngsta &#8211; Church On Sunday"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/30/album-stream-blac-youngsta-church-on-sunday/" rel="bookmark" title="Album Stream: Blac Youngsta &#8211; Church On Sunday">Album Stream: Blac Youngsta &#8211; Church On Sunday</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_21_5defd767ce56b" data-td_block_id="td_uid_21_5defd767ce56b"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_21_5defd767ce56b" data-td_block_id="td_uid_21_5defd767ce56b"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_22_5defd767d2053_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_22_5defd767d2053" ><script>var block_td_uid_22_5defd767d2053 = new tdBlock();
block_td_uid_22_5defd767d2053.id = "td_uid_22_5defd767d2053";
block_td_uid_22_5defd767d2053.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_22_5defd767d2053_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_22_5defd767d2053.td_column_number = "3";
block_td_uid_22_5defd767d2053.block_type = "td_block_mega_menu";
block_td_uid_22_5defd767d2053.post_count = "5";
block_td_uid_22_5defd767d2053.found_posts = "2574";
block_td_uid_22_5defd767d2053.header_color = "";
block_td_uid_22_5defd767d2053.ajax_pagination_infinite_stop = "";
block_td_uid_22_5defd767d2053.max_num_pages = "515";
tdBlocksArray.push(block_td_uid_22_5defd767d2053);
</script><div id=td_uid_22_5defd767d2053 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/09/music-video-camron-believe-in-flee/" rel="bookmark" title="Music Video: Cam&#8217;ron &#8211; Believe In Flee"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/cuqrv0XHJkA_m0MAIkerzEIKxlqBnVRpsyX8JeydkSizxqx1bdXE1FHKw89DPC9FELnwwjXC-CbXKCQ8ZFFqkNy_47fARs-MFBNknSCTqbFMwY40QomnAbiu52R0V4XjQuQxhtrb5kGE3_UTaEQqA1fYz9VSdWhbULqdrV9pubt3JVDyF2gTIZbwzdc8AYQbVjay7lTM9M9CF0IYg9MdFifWJM6GueF2cXmARi8nZ7HHcT52fo8o4ftBSDztufUhL8xK5X04CtLgQXnurZKp2OXE-gG94_ay3boJLEUQgGXjfgVNRBqCk5mRyv6dbD_Xd7-NMedOvzdPPsS--1R3HFwC9Deq1hWvx7E4TZMRD2zyux-jVutLVglDsrrIpmwQKhefks9yvnWf7GoxdnxsTqOza-WrftB70lVVoxeyeMgcdFBhVp_tjI_XfgPYzMSLA2Yj_TF3O-q18rwvBD_961ED_2BGE_lT5r2QmW5LoRhxkUWTUDPlmewad_M9HQWAgl8o9CTUlhisQumSXlBic3gV0VE7yeVDzLprfr7M4zC5DLdvShtRkxNqYBze0fnbRYT8-L71evGGFgAFki8uFUZ08sP2N6xXlcvQosjs54Cf1J6wdkOZYoxfa9sn9VunlS9exwJ2BFFaDepEFOz7pQ3ZZHSJCTtfnPCXro6XS6capL9a4OOB_uHU=w1005-h471-no" alt="" title="Music Video: Cam&#8217;ron &#8211; Believe In Flee"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/09/music-video-camron-believe-in-flee/" rel="bookmark" title="Music Video: Cam&#8217;ron &#8211; Believe In Flee">Music Video: Cam&#8217;ron &#8211; Believe In Flee</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/09/music-video-french-montana-what-it-look-like/" rel="bookmark" title="Music Video: French Montana &#8211; What It Look Like"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/NV8PHdbRABJJacSXR5R3OeHPXa7K64uYXzdAFiSrR_67dR4S2ZBIHo7oIaSDYk6dPOaOA7K9bjJZi7XNbHdQZWERJmCNzTta2Il3WRFVuwTG9xKaUbxptl-OIJ4nM5csvnCENp5F17lmodwSCheyDHzcSTkHfmt-Or-hya0C8GstKLwUfNy6GhDxSKj_naM_AN-WnRNnE19fAlo5H0evPl3_VAtwRTup1vO9fbxB7uR_BwP4QwPz84a-fgjIGel2-Le_tHbD5MCzlJMIMjudIsr-iuJwa9RVTdRHZ-yvp1a3VM22w0nvVYib6nekyJnuuiodZDDTngB0_9ZuPObEO9J-tTIO2OvrA_h_8JxSL0G701jvYdR8CnhE1m4gvDfNXCFc_8D5dnfjRrl0oUjPY_aiDvPg_o1P871Ua394naQSvU6jEeFm2LXtI6j_RR1HRRsW_9nf-MxJMb4DBBfQ-efck-DGeJCVMqdU3ivmOf1woCWKJcjXOndJOo-XZUgKWQFaY5Nef1G4keANfqr6vFpt9rlvOhupGQTzpuwfkpS5P20mw-EHm5KjWDnWKfrpr-CxM-aTU6MyZ4eI6zvUlxZAwox-NwjFbIPo7nnlGLvgydSGbwugcpgcu1h_sbSnb0GND-gd35DYTCzSEPcJD69dkuL6_nWPvK8P7UV4yKEc9uXV9LAGPqDv=w824-h459-no" alt="" title="Music Video: French Montana &#8211; What It Look Like"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/09/music-video-french-montana-what-it-look-like/" rel="bookmark" title="Music Video: French Montana &#8211; What It Look Like">Music Video: French Montana &#8211; What It Look Like</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/09/music-video-lil-baby-woah/" rel="bookmark" title="Music Video: Lil Baby &#8211; Woah"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/lVQnVbPqIKi2zXEPfsLvsc0FsFMXdM1v0hKu9k4JtUb3P66C1yuP0rQ3VlshPC_TRKKW9C51BpeV1Rz_sjSQYUoZp8flOHgvqgyiHla5Ba-DcSw9PnJyM819wY83NRNn5SrR1QWtnLirQiVs7Sa9SM9VYiqqziQUeJfPTCXk1ZIpa2keypyrPg8UgVo9Ql-2QIKy9gsvPCdLcZDuD_LsAHvPP2tmZ3XdpZOA_-To6WyBHiHTteyJHKVE39u04zwVo5toNh_-X2aDhmCioC9Xyj0rsKYbJRwbE7REBRzVHLIAgPCeNuvBi0qoimUuVLtDH2C8hNrywVjwaGTSAPixgxZJqUZAPDulGP_0NYTE0Bsy2OVnBmDDDzipIQ9V0ftCI41TcqqHb-9PiMiA6tG-wScMrxJo09hxeQNdP9w4qlFR_VK84--36J-DdPATe5ny9JLJbsXhJ4WXdEIaQseSAunmIFOQCP9nu333R-Pxt281DB7UKwGlKOfjlWee0LASAP-yMuIymJ6giF828XatwwxqxMzkLTNmzXjbwmxCLgeBI5QuVHjSTHQkXSCzbYXtPjInHgJJ7mqEd_jL4APoSwJEq_UytgFVF1pjpjmdCL6q8Y3pypiPgQPVGhE12ArSa7SEfc9FBN2Eg3vl0d_oyW1TSNBN41jieK3ddkv2hdwG_wCs49e_m2E7=w895-h535-no" alt="" title="Music Video: Lil Baby &#8211; Woah"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/09/music-video-lil-baby-woah/" rel="bookmark" title="Music Video: Lil Baby &#8211; Woah">Music Video: Lil Baby &#8211; Woah</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/05/music-video-flying-lotus-ft-denzel-curry-black-balloons-reprise/" rel="bookmark" title="Music Video: Flying Lotus ft. Denzel Curry &#8211; Black Balloons Reprise"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/w56KBIC3XDjB2xghrGRBDi7HpKNIQCtJq3fTrYEMn0tdqf75jGZ8EmNZQ0LVORWjZHWAyg0-ixNCkfec4Ranw0yApjN3EYn9R4wsDzOiNpkmZDiVcVzEv6t9AW4EnDCyf6hz4gl5tCEIYjsiFolIEg_AMXj1nw9P0YyyHQsjtnus865nJillKqwtKxzC83Ks-2RmBivYE2zJbgaYGinHsXZoKbJd6XMsakMRgALvrF3K_GMs8va5uudFU2AA6bd3BD3_Xokit-wLQWS8zKMB2MNAx1atrsP7vt9-R0As-QZ1lMKXRg-VEg2p4Tssxx1uaKqTqKC-Ow9KvboTwM_SLrOZXv5qsNULLHMw4YkHCTwuhdUyeEIz56tYuFDkj4NdteVZbsKUZuNCo72-wfaHY5EkpO_qBCOZhAgERICeenmhuhpId6K23m2eLh2f8rIvp7Iua42xpYGfp9dy7NSNKh7bO6Qd6qYOTNTTwKHdz174lZeMjpNzM1Cf8YWCADe3x2M9Byg4Wfxh2rzKUBSy_G-MZi-YPpIOU7CfbiX2Bj2dMGVZArNyqDdihY4QKe6vHp-hxwk5NE1Y7wks_0qQDqPIo7ER76E3lULvc3KtXtehR5BNekZu1fEKaiQoiV4pPvfwG5BieWgY02htnS9VxSKWigcXwZwF5xT_X3S3AWS_zNS3K6LF_Ck=w773-h548-no" alt="" title="Music Video: Flying Lotus ft. Denzel Curry &#8211; Black Balloons Reprise"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/05/music-video-flying-lotus-ft-denzel-curry-black-balloons-reprise/" rel="bookmark" title="Music Video: Flying Lotus ft. Denzel Curry &#8211; Black Balloons Reprise">Music Video: Flying Lotus ft. Denzel Curry &#8211; Black Balloons Reprise</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/05/music-video-kevin-gates-bags/" rel="bookmark" title="Music Video: Kevin Gates &#8211; Bags"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/-yr_zT-XvYSJOBWRmZz1s9jbg-1XBPqpzqAlvYGZjDvVtbpLNRMU3V5r1jDyHZk4MI9tRMr1Pt1t5wlo52SlR7ISckP8vFecXE7LDpsQHWjcPVjW46yzodQC0YGvSM_SphujmvwpIGNtyES_fIortUdCSSxIB_AuPwfI0PFBW21ZjX_q-kXbGlAfV8eQ78T8o04pqnfI-vFAuv4iY-CJGBaSMCgNWGz6F4LJxe32A9tliDjitYVZJ4y-bJwNgWNq6-RVfb_RXEFgfiZXB94ZtByYmkzIA9F7MsKGRtYDvEhJDK2Q-6sJk33uFeHZEb57n9q48El3rn6VOjGg3hCmwKO_yvfnrlp31wK-remHfID0kr0ZykUCI7icgQ27anE65y6HKuT7qdEHh8BAK7IN7SEqbnKqj-B7KRo08UkQZXApbtz3ffQzmI4FEPZ1yTaV457-KC3NCja4P835m5m2mTGt7QAIDoo16Tv4ZK79uqZcBjx4zu3qyfRrAbWrT_uFltN8kFzF4iEO1u6QfEpmsfCaRydydi3Bhv5r8evk35hqg-gN1CH2s5huMTUTUPBF3O8pgCSn3aWBIEGOxNTxpBuPfNtXup0axPIeaajoBdzg5q3w2Lb-pFFU_ExCfDpAoE4RGfItqP2r71RNESTuQuCz2auMBOgQEmy90jV_Ulr06sAGMTb_C-w=w999-h466-no" alt="" title="Music Video: Kevin Gates &#8211; Bags"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/05/music-video-kevin-gates-bags/" rel="bookmark" title="Music Video: Kevin Gates &#8211; Bags">Music Video: Kevin Gates &#8211; Bags</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_22_5defd767d2053" data-td_block_id="td_uid_22_5defd767d2053"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_22_5defd767d2053" data-td_block_id="td_uid_22_5defd767d2053"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_23_5defd767d5cce_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_23_5defd767d5cce" ><script>var block_td_uid_23_5defd767d5cce = new tdBlock();
block_td_uid_23_5defd767d5cce.id = "td_uid_23_5defd767d5cce";
block_td_uid_23_5defd767d5cce.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"29","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_23_5defd767d5cce_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_23_5defd767d5cce.td_column_number = "3";
block_td_uid_23_5defd767d5cce.block_type = "td_block_mega_menu";
block_td_uid_23_5defd767d5cce.post_count = "4";
block_td_uid_23_5defd767d5cce.found_posts = "952";
block_td_uid_23_5defd767d5cce.header_color = "";
block_td_uid_23_5defd767d5cce.ajax_pagination_infinite_stop = "";
block_td_uid_23_5defd767d5cce.max_num_pages = "238";
tdBlocksArray.push(block_td_uid_23_5defd767d5cce);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_23_5defd767d5cce" id="td_uid_24_5defd767d6aba" data-td_block_id="td_uid_23_5defd767d5cce" data-td_filter_value="" href="http://weuponithiphop.info/category/latest-news/">All</a><a class="mega-menu-sub-cat-td_uid_23_5defd767d5cce"  id="td_uid_25_5defd767d6bc0" data-td_block_id="td_uid_23_5defd767d5cce" data-td_filter_value="69" href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a><a class="mega-menu-sub-cat-td_uid_23_5defd767d5cce"  id="td_uid_26_5defd767d6cf3" data-td_block_id="td_uid_23_5defd767d5cce" data-td_filter_value="80" href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a><a class="mega-menu-sub-cat-td_uid_23_5defd767d5cce"  id="td_uid_27_5defd767d6e0f" data-td_block_id="td_uid_23_5defd767d5cce" data-td_filter_value="2189" href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a><a class="mega-menu-sub-cat-td_uid_23_5defd767d5cce"  id="td_uid_28_5defd767d6f2a" data-td_block_id="td_uid_23_5defd767d5cce" data-td_filter_value="10" href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a><a class="mega-menu-sub-cat-td_uid_23_5defd767d5cce"  id="td_uid_29_5defd767d7092" data-td_block_id="td_uid_23_5defd767d5cce" data-td_filter_value="130" href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></div></div><div id=td_uid_23_5defd767d5cce class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/08/video-conway-benny-the-butcher-ctrl-live-session/" rel="bookmark" title="Video: Conway &#038; Benny the Butcher &#8211; Ctrl. Live Session"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/JtymWQykqvK7a263kYhyCUblPEVfXp5H2Agi_rj27lYB8jO6UE9DoD_BppAWMPKq3u34JENXOGwPBunA2Rvcid6xTqD-lu2NOcpoy3ufVjL_HkqFpLTIjDuW9NsK1rGplryFhxNXowIo5aa1Y1XWxkj5xxH-fVFydKYYxjLw9BtT4bD_QWAz8YBGwA1o4q3FUrkQV3WRwenzya_V5jdDhcXzWE0dPQIDd6x9w-RP5Lvr4m5bCj50qNPJ1E7ekrsl3PTyFyUDFNB-FE2kEPYAK7oP-edWDdwaB9HRkddc2T9gJHHmfs74VhUIYhqkHzAs1Sku5nf86yeGfsey6YSnfCsfS-cS0AJOoQV4uRcs8nBTqQUTzgRCjOSahP6GwCJRiR3BM-ydfxTYN4sl2gqU2uKBKNU8AdyjNNA0tUiJOLWuMcwSBxfq5yCkta_OCTUHUm3E2iWD9FMzEQSqei1s0peWfvtUIKNnlNCnq7x7IFnfCLOVQXrXjehGWtkWYIxjXLgDk5YfjxDr5rgWp5EtRUIasFfQ6oDs0a5BJ7riIBSaIRYQfhL0mh_oayGbbpUfc-3NCFncWeo4dZzavZgmbcw_OB2Bhj2cj9nQpCRMQaThpsP-x0rEHpysLpd_QRpQCIz30dM3vAvp2KY_IJ5s8vS_2xLR6gPKxtE507YLV3PZiAb1w5K2cjg=w349-h233-no" alt="" title="Video: Conway &#038; Benny the Butcher &#8211; Ctrl. Live Session"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/08/video-conway-benny-the-butcher-ctrl-live-session/" rel="bookmark" title="Video: Conway &#038; Benny the Butcher &#8211; Ctrl. Live Session">Video: Conway &#038; Benny the Butcher &#8211; Ctrl. Live Session</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/05/video-griseldas-wwcd-documentary-part-2-daringer-348-sanders-road/" rel="bookmark" title="Video: Griselda’s WWCD Documentary Part 2 &#8211; Daringer “348 Sanders Road”"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/13S5HFfa_yex425TvWTAT3LPQt9vjhCndpheCa75fzFlXP5r2xZpKD_4-qoXaujrCQdlFnHo-lm2odpSWqqBF_BCHrSjM2zIPwzJ6dzIepSqI5618O-WaAJAkSFWshSnjyOAR_lL1YqapfMrBYdej9s9eqRqSax0eL8O3o0QkbtIY_gIWD29W80SOwYoGQlQ0jfAxsWVngVpGfI8e9uwl0pjUdqZPc2Dsp4Thhdo_Hixrfz5lOPx2sQ-XrqgjHaTgewFKyMJVMsv8vMh_tekCMWNP-vK2wCIX5ucXvaItac_BdJ_ZdYyUuev0mPkwP2tR6h4oJC52sEj_5qaeB6kCliiMTFWheZRCeTOsITVE3i9OJAKohfE7bSQXTxw7-rCRzSgcxEwihuhc5mYOs5Z_4WVlZt6C3OQB7Sh4HERWn9c4lpOe9hiHQ5yZGJ5i7deo0-fgItF9Bdo-L7Pyuu5G-ydxciJdwtLBbn_LuZqHhTNFDmqyefUFFUsE-50C00hFPQSvTUzK1l1zPJaNt-iIOpLVkZ768JzD8xcHgO9nm1TeVM8B6OrqwVKV6IOYbYx8CN_vPmFogxqJ96Mid40B-CnkL5apMs8m6mlMbLGcCF7jq-3lb9me9mqZIvYwQtVPBuQmSX6wDnThUmwVKYohbLTvCUN8SlDK1gYDkjsGnVkrH6tvTilp6Y=w814-h512-no" alt="" title="Video: Griselda’s WWCD Documentary Part 2 &#8211; Daringer “348 Sanders Road”"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/05/video-griseldas-wwcd-documentary-part-2-daringer-348-sanders-road/" rel="bookmark" title="Video: Griselda’s WWCD Documentary Part 2 &#8211; Daringer “348 Sanders Road”">Video: Griselda’s WWCD Documentary Part 2 &#8211; Daringer “348 Sanders Road”</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/03/video-wolftyla-breaks-down-the-lyrics-for-all-tinted/" rel="bookmark" title="Video: Wolftyla Breaks Down The Lyrics For &#8216;All Tinted&#8217;"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/IW61DwHa2TWjfZUj2RrQT6pDG6S-NHrzjhUxbbxkCuguADjH0VYdzvbUAhj7JIa8RHupZrWYDIQv5lc945Snegzpm2ZuqQuUNOtlaY4w-NgBGLLxpkbvTDfK9M2YmG8XKHdh2Vu3R9VBzQbWPej6YkkzjWw8jZuA-pVgF9dgblSMfSUMemJarAuRYK9RxYULNlbL5gpioaMZd780Ye2TMUZLiTtBXQxQri0-fKEL75VZuG-5CMNTEe3S4ekFgpzU-yAiQqXNBr-Kw3_Hn03jYjXlr4Iv4MlQMoQRmcn0vH8YC_En1vvet6dobZdy2yaz6fPndzY6lYL_0uK5B1KHjn3b1P18A8HLODBP0tayNWIsDKdvgKPkpQh-ALOZbaHWwWK_jvyacIoeUBKs-_YKYuh3ljtwpBywW8i8VnBJgiU_k2er4SYmGxQHtGqpp7yGcfolAPVebboYXBqJsoo2nWDM-yp_LlIy0E0Hfa5DeDMn5SaYoRhp8WDVC-IF8K4ur-hZ0dd2pnqCN4_RvtdMeQsbu5Bax6psmb53PL2N7vEkfOU0afGmQvz4XR_tWTw0GtBxStmRXOissMae79-6WBm8zcZwoSeppt91C2j_Y7EafjZBbRpKfBox_kM_dF5wEo_mqzwZlAtVOwIoWjAtNBFW1isNIrPKJQrQCt1K9dAmBjTqvrqDSjON=w548-h513-no" alt="" title="Video: Wolftyla Breaks Down The Lyrics For &#8216;All Tinted&#8217;"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/03/video-wolftyla-breaks-down-the-lyrics-for-all-tinted/" rel="bookmark" title="Video: Wolftyla Breaks Down The Lyrics For &#8216;All Tinted&#8217;">Video: Wolftyla Breaks Down The Lyrics For &#8216;All Tinted&#8217;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/26/video-h-e-r-breaks-down-the-lyrics-for-slide/" rel="bookmark" title="Video: H.E.R. Breaks Down The Lyrics For &#8216;Slide&#8217;"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/MQ8K4ELdhD12UKG2AL25bFvA_Mr6OV1PlhdtuyuxXsIJCK0Jab9VY9J-zy-l3t0Tl_BPubYDfw_0W51L7QjxcWQzcRHbfjI9CAC3YTztR18ZxAqaZ_hOG4-hEI_yuLTAqry46Qt-AZ5MM3tDNFfpwtSTv1ykdaOtAYVoWb1K4S3y-nOmmA7_dtWn7VM6XyilX6t0EtCieXbVyQGfYRyD09MPqiSrG2VboqK3TYgwPKKgkoMOxuZeGSHv_KSVWP4w3zL50qbIEuhPnHlntIqvNUJ2Kfn_aCf9Po8Wd9Z_i26AszwaUHOzBLY61aYVzW3VJ17mpOSFvU8ua-OOSXOtg-84tgFVBPhkz1I-H7tJN4Vz1AtRQjeB2t5BQ1I2-NYv0oXW8c2kRi8zEYj4WqkU-dEZAvit7tASdeNmZQ19OG7UUGKVY4r6AeBbRbiBVn3ANqwuv7SFLn1xbN5bZf1SzT8_xZTlyuL15EyQME4Z83BzrYeSPkQcjW_0jAWJNL3n_gi91L2_9gFLTmwmuWKN8Ndc37bZcoR62kXa1nNBK5zwgyHH56nw5xZPHHCQ04xFxM_SXWLzgA_kTnihwNcgVzT0bTjPLc1Qc8ruZDsmcqVsWwE7NnzVA5lwMCBuwuPFBZvvMKlEy9PFhr0UpV30D8L58s9pIM_3ACybFUlt-p-H-cZ5MJgCc8_4=w829-h525-no" alt="" title="Video: H.E.R. Breaks Down The Lyrics For &#8216;Slide&#8217;"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/26/video-h-e-r-breaks-down-the-lyrics-for-slide/" rel="bookmark" title="Video: H.E.R. Breaks Down The Lyrics For &#8216;Slide&#8217;">Video: H.E.R. Breaks Down The Lyrics For &#8216;Slide&#8217;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_23_5defd767d5cce" data-td_block_id="td_uid_23_5defd767d5cce"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_23_5defd767d5cce" data-td_block_id="td_uid_23_5defd767d5cce"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_30_5defd767eb3c4_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_30_5defd767eb3c4" ><script>var block_td_uid_30_5defd767eb3c4 = new tdBlock();
block_td_uid_30_5defd767eb3c4.id = "td_uid_30_5defd767eb3c4";
block_td_uid_30_5defd767eb3c4.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"77","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_30_5defd767eb3c4_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_30_5defd767eb3c4.td_column_number = "3";
block_td_uid_30_5defd767eb3c4.block_type = "td_block_mega_menu";
block_td_uid_30_5defd767eb3c4.post_count = "4";
block_td_uid_30_5defd767eb3c4.found_posts = "158";
block_td_uid_30_5defd767eb3c4.header_color = "";
block_td_uid_30_5defd767eb3c4.ajax_pagination_infinite_stop = "";
block_td_uid_30_5defd767eb3c4.max_num_pages = "40";
tdBlocksArray.push(block_td_uid_30_5defd767eb3c4);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_30_5defd767eb3c4" id="td_uid_31_5defd767ec0d2" data-td_block_id="td_uid_30_5defd767eb3c4" data-td_filter_value="" href="http://weuponithiphop.info/category/fashion/">All</a><a class="mega-menu-sub-cat-td_uid_30_5defd767eb3c4"  id="td_uid_32_5defd767ec1d3" data-td_block_id="td_uid_30_5defd767eb3c4" data-td_filter_value="76" href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></div></div><div id=td_uid_30_5defd767eb3c4 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/LVT4Mid8WL4wHUdO9X2OZmZxxgbREs2lVtszOdEBaO6hJB0JS3yQOAyhNSdCyPmv0amBDTgNGpOlRPXPjKCl6yIlo2joyH3rQRI7CUdX09BJtQI1r5jy1_7BQtDhw4AxUhpUwIh35rNS3lTy7uq-FdPff10JN6srr9mwZ7zr04GQFxBVEXwCfC5rNVehXhY_wGCRVsmevYmdkBWEmB8dvOzBHY78NBBjcHNArS_S-2M0FJgDh8v9m9vEh78k_XmZg-AERctsf0bkODuPi1EcNJq_RnJIV6b0GG-VtKjo-OVPmYghWJYf1HiP9c58cQ98oABU8BDFdLqsBtNt4K0NmyHYQlX39W9k_d83wEHZ1-EacQa2o01VrYSn12HnZ1l88fMzu9PKv6EGmcRZNwpepycW7_9EQnhxIPDdVCmRLXUasUED9OXr-zJmnBcnSnLCa06k1ZymQym1LiSFEv1c3aPHnmnD3GY8nL7q5jPJr4HsABR0WCqMebcF3HF_0deNd0zgRBCGMxW-VzlIIHZiHuBeSPEPvUL149GJ5swSSvKm1uGEi1HlLBj9omJSU7mDWzO0p_7l-l7-4_ureEsGsgB8cX1t8t2TQcFeRgqqF1CXlZFYYC2K0iMb4jPsijsw_rtO7pmKvbngqHfgYpGeh_qLmDWeicR7=w1195-h796-no" alt="" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch">Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/fHEwwMf8DoiXlqkfibQS1Z1XXbviORbV9raaI44tOTXrWo7GgqM3gA-vswE10gFtTQUGGwNG7nWAACwHjxPuiubliYBN_dqtBZh2WIpxvumiJ-hSLK0TNWB2cB8Iw2STT5gcp_KqlDh_e4xng1vidI8EXdp_ooh5uDI-JV1HQ9dGnM5nxl_b-v8znqj-Rl_mGB7y4Lu9zsFNWHU7SriqQQJaKrKEEnb9T8zxmGLaL0zq7ilYpnUEhWulDDr9xc82wdr__WzRBm5YEskVpDAnGM2NDZwTZpjbe4QDdxeixWnSXNK_oDzaL7WTbCpkD33OK88BlI5JmFRQ5VmD11UQ2htB7-9WoahHvb4XmBsbLXpEMl1JmEP4sPx06VduzFnBNo-J90WI0n1AEIIcEYVbRywrkGJXbzmH__In9ZIg0EV24OcGGbeKl12HxTdZwucqsNnuZeNjiMHISQ7i8cfzm3N7X7Zenl74zsKIKeKWoIGxh6MTlVADvgHcrHebnjcSgil2vBeFyz_AP45aOv9SOwbzfVLGS0CNfe1s9b2J7qZgjcBk9QPEXCl2kygvzmGXFvU_3xBuW6S0i3Vkh3Ha_3hPBtvIAy3WoTK2yiqS41HzSK7yk3FRAlBtpIEib338fdkTiosBxtdu36SdNUVM75zl6CVIFhTu=w681-h470-no" alt="" title="Air Jordan 14 Rip Hamilton"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton">Air Jordan 14 Rip Hamilton</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/kUjaOYxjEkAh34S-Ub2QSZwdOwHyFnGFLBZULta3_bn1_myPMAwJXiEEsAAtc1ktCQwHCuKhSqSYsWXFBEIZxdfKuykoDEZWwO-dDI3_JeAshbYvyILEHUu0XaUpRn0mj7gOx10V52t8gRGYPCW7QXGImkPGGhvBPzBDVVqh9lKGtkuPeePmTnpRSmwp0LG1WHcIzUWnMqPBWQeHAat6Q-Tq7niXNb96ddEZsMEdHK1nmHVlNaeqFBNtTxk6yYRkFNCvtfBayqy-Rqt4CPU5tThxbTI4AIUCI6JLxJd_VJizrVNDEe2xZ_tiQdkC5ASIoHpX8sfvAB8zRUsMVJ6oMUt5FH_4GBNXDCtFRmr65Qt0JV1h4bBJffu2L272Q_vpD76wn-YNGW8VCtZcheHu_X-A4gdYQEC0HN0BenY-MOuUBqKEjXAc0SxWeP7W9RN55jlqUFK0nzEYydVjec2stdQIngVfg_FvKxvHXfM4XdtMpqeJnp3Pzyk8xjz30sAZd0f2HQ6zfdPjk-OkV2-WrC0_qW0L8Rq3zrUbq52n3BN7gm7sctU_CUlBmoQIgJDQBYk1Siv4tfSq9pL1R4GdaOlWQdxEuhZi8bTYC8GGAgNGl3SMAZGvk7nu6QnnwEZjZ7mZwbcqgyRKa89cOREMUvIkVJ8Q8lZu=w926-h672-no" alt="" title="Jordan Proto React Triple White"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White">Jordan Proto React Triple White</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4cDUjSODZSaXWfHyZKb9q3Fn7FHA4uB0KSBs0MtFHC0dc6AJb1zeAl_X2LOKalK9C7VBFhTqRQ9fw1ESgUr9ZUKFbOzD94i_s96nvkICOqrsYnzrE2nEAQHoEaGOF4O8GAI6T4CGFbgcQhNzjpRlSY60NyPu5Cmq81FRpEOFRzTOtSa_NnWzMmfwO0yxtPbcg5U6YBUsus8shv3SA7CjULLfaP38nZAuWVgq8PMaaeCQ_eSrK8NJSEVQjyyxmqb-1I7zO8Kvvzvwi--ibMr52CF8h-GusBzSq5ZuzvZRCGu_u8CyfoXw7pwWbOmHnLOdcQ9d2PCSW_IxEMGfmEuU7NxMSsW3Ga4r35_wLB7cjvlPC9OjCV50tfekXjZBS_476mzlf4G9jR7Ju1GqgjXah9Uqc_0Y8N-Br8_JCtIlRSuLxAiebwd7AvFVlgWId9MYxBWnRT3cTyD8SH7q5WwO-CIbKAOSKsNcrrTgFxQvqn9yklBU1u5X5fdTlTBk4WSYorsWZAug0z9BOymRLnrhTbnA0vpBPFROWD-aL1glg-eUpFSfgD4xhWsOqJNY9krQ2UbLSGXQ5gYWj0ovLS7Yz3UKFY2qrVWpqkpbfyN98es9NJ-7LTUs2MLq1rX_2FaQmyq5mVndd7VGzQOHy9hDULG-5H-0LvGd=w900-h566-no" alt="" title="adidas Yeezy Boost 350 V2 Hyperspace"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace">adidas Yeezy Boost 350 V2 Hyperspace</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_30_5defd767eb3c4" data-td_block_id="td_uid_30_5defd767eb3c4"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_30_5defd767eb3c4" data-td_block_id="td_uid_30_5defd767eb3c4"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div>                </div>

                <div class="td-pb-span5 td-sub-footer-copy">
                    &copy; 2018 The Hip Hop Chronicles Media Group                </div>
            </div>
        </div>
    </div>
</div><!--close td-outer-wrap-->

	<div id="wpcp-error-message" class="msgmsg-box-wpcp warning-wpcp hideme"><span>error: </span>Not Prohibited. ✌️</div>
	<script>
	var timeout_result;
	function show_wpcp_message(smessage)
	{
		if (smessage !== "")
			{
			var smessage_text = '<span>Alert: </span>'+smessage;
			document.getElementById("wpcp-error-message").innerHTML = smessage_text;
			document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp showme";
			clearTimeout(timeout_result);
			timeout_result = setTimeout(hide_message, 3000);
			}
	}
	function hide_message()
	{
		document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp hideme";
	}
	</script>
	<style type="text/css">
	#wpcp-error-message {
	    direction: ltr;
	    text-align: center;
	    transition: opacity 900ms ease 0s;
	    z-index: 99999999;
	}
	.hideme {
    	opacity:0;
    	visibility: hidden;
	}
	.showme {
    	opacity:1;
    	visibility: visible;
	}
	.msgmsg-box-wpcp {
		border-radius: 10px;
		color: #555;
		font-family: Tahoma;
		font-size: 11px;
		margin: 10px;
		padding: 10px 36px;
		position: fixed;
		width: 255px;
		top: 50%;
  		left: 50%;
  		margin-top: -10px;
  		margin-left: -130px;
  		-webkit-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
		-moz-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
		box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
	}
	.msgmsg-box-wpcp span {
		font-weight:bold;
		text-transform:uppercase;
	}
	.error-wpcp {		background:#ffecec url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/error.png') no-repeat 10px 50%;
		border:1px solid #f5aca6;
	}
	.success {
		background:#e9ffd9 url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/success.png') no-repeat 10px 50%;
		border:1px solid #a6ca8a;
	}
	.warning-wpcp {
		background:#ffecec url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/warning.png') no-repeat 10px 50%;
		border:1px solid #f5aca6;
	}
	.notice {
		background:#e3f7fc url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/notice.png') no-repeat 10px 50%;
		border:1px solid #8ed9f6;
	}
    </style>


    <!--

        Theme: Newspaper by tagDiv 2016
        Version: 7.2 (rara)
        Deploy mode: deploy
        
        uid: 5defd76802338
    -->

    <link rel='stylesheet' id='so-css-Newspaper-css'  href='http://weuponithiphop.info/wp-content/uploads/so-css/so-css-Newspaper.css?ver=1528674688' type='text/css' media='all' />
<link rel='stylesheet' id='soliloquy-lite-style-css'  href='http://weuponithiphop.info/wp-content/plugins/soliloquy-lite/assets/css/soliloquy.css?ver=2.5.6' type='text/css' media='all' />
<link rel='stylesheet' id='soliloquy-liteclassic-theme-css'  href='http://weuponithiphop.info/wp-content/plugins/soliloquy-lite/themes/classic/style.css?ver=2.5.6' type='text/css' media='all' />
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/themes/Newspaper/js/tagdiv_theme.js?ver=7.2'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/comment-reply.min.js?ver=4.9.12'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/wp-embed.min.js?ver=4.9.12'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/plugins/soliloquy-lite/assets/js/min/soliloquy-min.js?ver=2.5.6'></script>

<!-- JS generated by theme -->

<script>
    


            

	            // if the theme has tdBackstr support, it means this already uses it
                if ( 'undefined' !== typeof window.tdBackstr ) {

                    (function(){
                        // the site background td-backstretch jquery object is dynamically added in DOM, and after any translation effects are applied over td-backstretch
                        var wrapper_image_jquery_obj = jQuery( '<div class=\'backstretch\'></div>' );
                        var image_jquery_obj = jQuery( '<img class=\'td-backstretch not-parallax\' src=\'http://weuponithiphop.info/wp-content/uploads/city-skyline-1.png\'>' );

                        wrapper_image_jquery_obj.append( image_jquery_obj );

                        jQuery( 'body' ).prepend( wrapper_image_jquery_obj );

                        var td_backstr_item = new tdBackstr.item();

                        td_backstr_item.wrapper_image_jquery_obj = wrapper_image_jquery_obj;
                        td_backstr_item.image_jquery_obj = image_jquery_obj;

	                    tdBackstr.add_item( td_backstr_item );

                    })();
                }

            
            
jQuery(window).ready(function() {
(function(){
var td_backstr_item = new tdBackstr.item();
td_backstr_item.wrapper_image_jquery_obj = jQuery( "#td-full-screen-header-image" );
td_backstr_item.image_jquery_obj = td_backstr_item.wrapper_image_jquery_obj.find( 'img:first' );
tdBackstr.add_item( td_backstr_item );
jQuery('.td-read-down a').click(function(event){
event.preventDefault();
var header_wrap = jQuery( '.td-full-screen-header-image-wrap:first' )
if ( 1 === header_wrap.length ) {
tdUtil.scrollToPosition(header_wrap.height() + header_wrap.offset().top, 1200);
}
});
})();
});

                jQuery().ready(function jQuery_ready() {
                    tdAjaxCount.tdGetViewsCountsAjax("post","[36098]");
                });
            

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'http://weuponithiphop.info/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'http://weuponithiphop.info/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>

			<script type="text/javascript">
			if ( typeof soliloquy_slider === 'undefined' || false === soliloquy_slider ) {soliloquy_slider = {};}jQuery('#soliloquy-container-30342').css('height', Math.round(jQuery('#soliloquy-container-30342').width()/(960/300)));jQuery(window).load(function(){var $ = jQuery;var soliloquy_container_30342 = $('#soliloquy-container-30342'),soliloquy_30342 = $('#soliloquy-30342');soliloquy_slider['30342'] = soliloquy_30342.soliloquy({slideSelector: '.soliloquy-item',speed: 0,pause: 2000,auto: 1,useCSS: 0,keyboard: true,adaptiveHeight: 1,adaptiveHeightSpeed: 400,infiniteLoop: 1,mode: 'fade',pager: 1,controls: 1,nextText: '',prevText: '',startText: '',stopText: '',onSliderLoad: function(currentIndex){soliloquy_container_30342.find('.soliloquy-active-slide').removeClass('soliloquy-active-slide').attr('aria-hidden','true');soliloquy_container_30342.css({'height':'auto','background-image':'none'});if ( soliloquy_container_30342.find('.soliloquy-slider li').length > 1 ) {soliloquy_container_30342.find('.soliloquy-controls').fadeTo(300, 1);}soliloquy_30342.find('.soliloquy-item:not(.soliloquy-clone):eq(' + currentIndex + ')').addClass('soliloquy-active-slide').attr('aria-hidden','false');soliloquy_container_30342.find('.soliloquy-clone').find('*').removeAttr('id');soliloquy_container_30342.find('.soliloquy-controls-direction').attr('aria-label','carousel buttons').attr('aria-controls', 'soliloquy-container-30342');soliloquy_container_30342.find('.soliloquy-controls-direction a.soliloquy-prev').attr('aria-label','previous');soliloquy_container_30342.find('.soliloquy-controls-direction a.soliloquy-next').attr('aria-label','next');},onSlideBefore: function(element, oldIndex, newIndex){soliloquy_container_30342.find('.soliloquy-active-slide').removeClass('soliloquy-active-slide').attr('aria-hidden','true');$(element).addClass('soliloquy-active-slide').attr('aria-hidden','false');},onSlideAfter: function(element, oldIndex, newIndex){},});});			</script>
			
</body>
</html>