<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>Music Video: H.E.R. x Skip Marley – Slow Down</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="http://weuponithiphop.info/xmlrpc.php" />
    <meta property="og:image" content="https://lh3.googleusercontent.com/GbdlvcvoTXMl1SBBSrAQz3C0KCV8F7trnMcExUSJZEGQyBkbV2_kYLWTbrOJOEoAmxbPxNgSiGOnusEIxFVdq4ejkuscv5w8NDFVkrb8nlgBUsZ90CvhnnH5qjs8sE04YhRRZ-2uIgtozQb0534SqxY6A7miOrsMf_FniMhNKD9VJV6orxF30Os-tAOgciRTMvscyLvUuPl7k4eg4bMiRu3pAKV8f6y1gkvkoapcGf3_trteszTLh0FsndCvT1HkaryHSpxxJFoh0fKos_kG_kcjtA4MxeRH7ZEHIaYWsaReVZY_qTCVC90TAfe01f1aI6hxjXYd74B_cX3JPK5DWnWCfCG1YOmCkCulJ0PlF4eCdj6g88rCd7M2a8kWGuCiazbMsU9vmKr6ZuH-bKrCb_m0R_2bDtsmNaqv9gDfqHXatFWXOpCymyVp2dckluEqzkfXxLuUvaE06oWyP_3p-ZqhCCu_A_YcZPVCAtGbAi5oxU0VZsut3Y1yaJLzS_hNzBmtSsBQ3eMtopcgJT54hVOtBicw9h6Taszqtm1gZTakz0Nu9TOvOGIHEMoBzCPpknTcpp2w6IuTo02rLQnRiLCLBs0vVU8OR4BndvHuh-OFBRXOrQ347yHFkIs8z4gCqIr1UDqGo6sYJ47ZzrmQ1KXaNotgMmE_qm3GtrRuN0luoaH_jp0fD26U=w966-h535-no" /><meta name="author" content="cyclone">
<link rel="icon" type="image/png" href="http://weuponithiphop.info/wp-content/uploads/weuponitlogoCAP-500x457.png">
<!-- All in One SEO Pack 3.3.3 by Michael Torbert of Semper Fi Web Design[208,277] -->
<script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"http://weuponithiphop.info/#organization","url":"http://weuponithiphop.info/","name":"WeUpOnIt","sameAs":[]},{"@type":"WebSite","@id":"http://weuponithiphop.info/#website","url":"http://weuponithiphop.info/","name":"WeUpOnIt","publisher":{"@id":"http://weuponithiphop.info/#organization"}},{"@type":"WebPage","@id":"http://weuponithiphop.info/2020/01/06/music-video-h-e-r-x-skip-marley-slow-down/#webpage","url":"http://weuponithiphop.info/2020/01/06/music-video-h-e-r-x-skip-marley-slow-down/","inLanguage":"en-US","name":"Music Video: H.E.R. x Skip Marley &#8211; Slow Down","isPartOf":{"@id":"http://weuponithiphop.info/#website"},"datePublished":"2020-01-06T10:51:50+00:00","dateModified":"2020-01-06T10:56:22+00:00"},{"@type":"Article","@id":"http://weuponithiphop.info/2020/01/06/music-video-h-e-r-x-skip-marley-slow-down/#article","isPartOf":{"@id":"http://weuponithiphop.info/2020/01/06/music-video-h-e-r-x-skip-marley-slow-down/#webpage"},"author":{"@id":"http://weuponithiphop.info/author/cyclone/#author"},"headline":"Music Video: H.E.R. x Skip Marley &#8211; Slow Down","datePublished":"2020-01-06T10:51:50+00:00","dateModified":"2020-01-06T10:56:22+00:00","commentCount":0,"mainEntityOfPage":{"@id":"http://weuponithiphop.info/2020/01/06/music-video-h-e-r-x-skip-marley-slow-down/#webpage"},"publisher":{"@id":"http://weuponithiphop.info/#organization"},"articleSection":"Editor's Picks, Music Video, H.E.R, Skip Marley"},{"@type":"Person","@id":"http://weuponithiphop.info/author/cyclone/#author","name":"cyclone","sameAs":[],"image":{"@type":"ImageObject","@id":"http://weuponithiphop.info/#personlogo","url":"http://0.gravatar.com/avatar/6a747aaba64ebc36f309e25ac7e460e6?s=96&d=mm&r=g","width":96,"height":96,"caption":"cyclone"}}]}</script>
<link rel="canonical" href="http://weuponithiphop.info/2020/01/06/music-video-h-e-r-x-skip-marley-slow-down/" />
<!-- All in One SEO Pack -->
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Feed" href="http://weuponithiphop.info/feed/" />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Comments Feed" href="http://weuponithiphop.info/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Music Video: H.E.R. x Skip Marley &#8211; Slow Down Comments Feed" href="http://weuponithiphop.info/2020/01/06/music-video-h-e-r-x-skip-marley-slow-down/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/weuponithiphop.info\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.13"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='google_font_open_sans-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;ver=4.9.13' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_roboto-css'  href='http://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C900%2C500italic%2C400%2C300&#038;ver=4.9.13' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='http://fonts.googleapis.com/css?family=Roboto+Condensed%3A400%2C700&#038;ver=4.9.13' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='http://weuponithiphop.info/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=4.12' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='http://weuponithiphop.info/wp-content/themes/Newspaper/style.css?ver=7.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css'  href='http://weuponithiphop.info/wp-content/themes/Newspaper/includes/demos/what/demo_style.css?ver=7.2' type='text/css' media='all' />
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1'></script>
<link rel='https://api.w.org/' href='http://weuponithiphop.info/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://weuponithiphop.info/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://weuponithiphop.info/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='New Music: Sada Baby ft, G Herbo &#8211; Baklava' href='http://weuponithiphop.info/2020/01/06/new-music-sada-baby-ft-g-herbo-baklava/' />
<meta name="generator" content="WordPress 4.9.13" />
<link rel='shortlink' href='http://weuponithiphop.info/?p=36391' />
<link rel="alternate" type="application/json+oembed" href="http://weuponithiphop.info/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fweuponithiphop.info%2F2020%2F01%2F06%2Fmusic-video-h-e-r-x-skip-marley-slow-down%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://weuponithiphop.info/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fweuponithiphop.info%2F2020%2F01%2F06%2Fmusic-video-h-e-r-x-skip-marley-slow-down%2F&#038;format=xml" />

<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>
<script id="wpcp_disable_selection" type="text/javascript">
//<![CDATA[
var image_save_msg='You Can Not Save images!';
	var no_menu_msg='Context Menu disabled!';
	var smessage = "Not Prohibited. ✌️";

function disableEnterKey(e)
{
	if (e.ctrlKey){
     var key;
     if(window.event)
          key = window.event.keyCode;     //IE
     else
          key = e.which;     //firefox (97)
    //if (key != 17) alert(key);
     if (key == 97 || key == 65 || key == 67 || key == 99 || key == 88 || key == 120 || key == 26 || key == 85  || key == 86 || key == 83 || key == 43)
     {
          show_wpcp_message('You are not allowed to copy content or view source');
          return false;
     }else
     	return true;
     }
}

function disable_copy(e)
{	
	var elemtype = e.target.nodeName;
	var isSafari = /Safari/.test(navigator.userAgent) && /Apple Computer/.test(navigator.vendor);
	elemtype = elemtype.toUpperCase();
	var checker_IMG = '';
	if (elemtype == "IMG" && checker_IMG == 'checked' && e.detail >= 2) {show_wpcp_message(alertMsg_IMG);return false;}
	if (elemtype != "TEXT" && elemtype != "TEXTAREA" && elemtype != "INPUT" && elemtype != "PASSWORD" && elemtype != "SELECT" && elemtype != "OPTION" && elemtype != "EMBED")
	{
		if (smessage !== "" && e.detail == 2)
			show_wpcp_message(smessage);
		
		if (isSafari)
			return true;
		else
			return false;
	}	
}
function disable_copy_ie()
{
	var elemtype = window.event.srcElement.nodeName;
	elemtype = elemtype.toUpperCase();
	if (elemtype == "IMG") {show_wpcp_message(alertMsg_IMG);return false;}
	if (elemtype != "TEXT" && elemtype != "TEXTAREA" && elemtype != "INPUT" && elemtype != "PASSWORD" && elemtype != "SELECT" && elemtype != "OPTION" && elemtype != "EMBED")
	{
		//alert(navigator.userAgent.indexOf('MSIE'));
			//if (smessage !== "") show_wpcp_message(smessage);
		return false;
	}
}	
function reEnable()
{
	return true;
}
document.onkeydown = disableEnterKey;
document.onselectstart = disable_copy_ie;
if(navigator.userAgent.indexOf('MSIE')==-1)
{
	document.onmousedown = disable_copy;
	document.onclick = reEnable;
}
function disableSelection(target)
{
    //For IE This code will work
    if (typeof target.onselectstart!="undefined")
    target.onselectstart = disable_copy_ie;
    
    //For Firefox This code will work
    else if (typeof target.style.MozUserSelect!="undefined")
    {target.style.MozUserSelect="none";}
    
    //All other  (ie: Opera) This code will work
    else
    target.onmousedown=function(){return false}
    target.style.cursor = "default";
}
//Calling the JS function directly just after body load
window.onload = function(){disableSelection(document.body);};
//]]>
</script>
	<script id="wpcp_disable_Right_Click" type="text/javascript">
	//<![CDATA[
	document.ondragstart = function() { return false;}
	/* ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
	Disable context menu on images by GreenLava Version 1.0
	^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ */
	    function nocontext(e) {
	       return false;
	    }
	    document.oncontextmenu = nocontext;
	//]]>
	</script>
<!-- Analytics by WP-Statistics v12.6.12 - https://wp-statistics.com/ -->
<!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]-->
<!-- JS generated by theme -->

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var tds_login_sing_in_widget="show";
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_ajax_url="http:\/\/weuponithiphop.info\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=7.2";
var td_get_template_directory_uri="http:\/\/weuponithiphop.info\/wp-content\/themes\/Newspaper";
var tds_snap_menu="snap";
var tds_logo_on_sticky="show_header_logo";
var tds_header_style="5";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#dd3333";
var tds_smart_sidebar="enabled";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>


<!-- Header style compiled by theme -->

<style>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</style>

<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>

<body class="post-template-default single single-post postid-36391 single-format-standard unselectable music-video-h-e-r-x-skip-marley-slow-down td-what single_template_7 wpb-js-composer js-comp-ver-4.12 vc_responsive td-boxed-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
                    <div class="td-menu-login-section">
                
    <div class="td-guest-wrap">
        <div class="td-menu-avatar"><div class="td-avatar-container"><img alt='' src='http://0.gravatar.com/avatar/?s=80&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo avatar-default' height='80' width='80' /></div></div>
        <div class="td-menu-login"><a id="login-link-mob">Sign in</a></div>
    </div>
            </div>
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-top-menu-container"><ul id="menu-top-menu" class="td-mobile-main-menu"><li id="menu-item-317" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a></li>
<li id="menu-item-706" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a></li>
<li id="menu-item-314" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a></li>
<li id="menu-item-316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-0" class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></li>
</ul>
</li>
<li id="menu-item-705" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></li>
</ul>
</li>
<li id="menu-item-18581" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li id="menu-item-3199" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
            <div id="login-form-mobile" class="td-register-section">
            
            <div id="td-login-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-login-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign in</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
	                <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
	                <div class="td-login-info-text"><a href="#" id="forgot-pass-link-mob">Forgot your password?</a></div>
                </div>
            </div>

            

            <div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
                <!-- close button -->
	            <div class="td-forgot-pass-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Password recovery</div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title">Recover your password</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
	                <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
                </div>
            </div>
        </div>
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="http://weuponithiphop.info/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap">
    
        <!--
Header style 5
-->

<div class="td-header-wrap td-header-style-5">

    <div class="td-header-top-menu-full">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div >

                Monday, January 6, 2020
            </div>
        </div>
    <ul class="top-header-menu td_ul_login"><li class="menu-item"><a class="td-login-modal-js menu-item" href="#login-form" data-effect="mpf-td-login-effect">Sign in / Join</a><span class="td-sp-ico-login td_sp_login_ico_style"></span></li></ul><div class="menu-top-container"><ul id="menu-main" class="top-header-menu"><li id="menu-item-79" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-79"><a href="http://weuponithiphop.info">Home</a></li>
<li id="menu-item-81" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-81"><a target="_blank" href="http://weuponitradio.com">Power 105.1 WeUpOnIt Radio</a></li>
<li id="menu-item-80" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-80"><a target="_blank" href="https://shop.spreadshirt.com/freshandcleantees/">Shop</a></li>
<li id="menu-item-18582" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18582"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li id="menu-item-18583" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18583"><a href="http://weuponithiphop.info/privacy-policy-2/">Privacy Policy</a></li>
</ul></div></div>
        <div class="td-header-sp-top-widget">
    
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div>
    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <ul class="td-login-tabs">
                        <li><a id="login-link" class="td_login_tab_focus">LOG IN</a></li>
                    </ul>



                    <div class="td-login-wrap">
                        <div class="td_display_err"></div>

                        <div id="td-login-div" class="">
                            <div class="td-login-panel-title">Welcome! Log into your account</div>
                            <input class="td-login-input" type="text" name="login_email" id="login_email" placeholder="your username" value="" required>
                            <input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" placeholder="your password" required>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Log In">


                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password?</a></div>


                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-display-none">
                            <div class="td-login-panel-title">Recover your password</div>
                            <input class="td-login-input" type="text" name="forgot_email" id="forgot_email" placeholder="your email" value="" required>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Pass">
                        </div>




                    </div>
                </div>
                        </div>
    </div>

    <div class="td-header-menu-wrap-full">
        <div class="td-header-menu-wrap">
            <div class="td-container td-header-row td-header-main-menu black-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-menu">
        		<a class="td-mobile-logo td-sticky-header" href="http://weuponithiphop.info/">
			<img class="td-retina-data" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-5.png" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-5.png" alt=""/>
		</a>
			<a class="td-header-logo td-sticky-header" href="http://weuponithiphop.info/">
			<img class="td-retina-data" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" alt=""/>
			<span class="td-visual-hidden">WeUpOnIt</span>
		</a>
	    </div>
    <div class="menu-top-menu-container"><ul id="menu-top-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-mega-menu menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_1_5e134235c1870_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_1_5e134235c1870" ><script>var block_td_uid_1_5e134235c1870 = new tdBlock();
block_td_uid_1_5e134235c1870.id = "td_uid_1_5e134235c1870";
block_td_uid_1_5e134235c1870.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"43","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_1_5e134235c1870_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_1_5e134235c1870.td_column_number = "3";
block_td_uid_1_5e134235c1870.block_type = "td_block_mega_menu";
block_td_uid_1_5e134235c1870.post_count = "5";
block_td_uid_1_5e134235c1870.found_posts = "2698";
block_td_uid_1_5e134235c1870.header_color = "";
block_td_uid_1_5e134235c1870.ajax_pagination_infinite_stop = "";
block_td_uid_1_5e134235c1870.max_num_pages = "540";
tdBlocksArray.push(block_td_uid_1_5e134235c1870);
</script><div id=td_uid_1_5e134235c1870 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/01/06/new-music-sada-baby-ft-g-herbo-baklava/" rel="bookmark" title="New Music: Sada Baby ft, G Herbo &#8211; Baklava"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/WLtkfbB50kKcLEx3k9vPJPDXXLwt2SG5mmzf2FAXNY7fNOEjpwy8f5_NkNlMQpI4Ecc67YbLAnn1O9ioshrtN0QCMOw_gZFz2740DZlo7c73cCW0h1oSKf4XkeHkpiC780AvIR8RDknD38fnWbm6ARaXzeYP3heNRSW58tsKRC3t546woH_T9HSNtK3K9sM1PrbxDug3Kxn6kXeE6JaVr_ZxNWqxLZvK_nKNoaHHFMX9tF_gPxxvOdca7KyrxNa609l_mz3yGMI2KvWks7id6c5gHzRLHzIsQwjQawAaibvBTV0P_OLMpz5v0qtt3B5jH-tznjAb3tcsygqY3vKydoXvs3q0EfSZ1SnyqUg82i4tVAcE7__y0oSUodDEEmtJ6PQlFexTWrkXpKKxIuLAkIjExadFG19LtQSfev86fAahbuEwY3cPebTtqNdCIbbCJApNeAsPMj-cpWelyODPKcLS7MV00G4V6eSa6uzZaJxZTEhu60RW7s1eg-Q9WfwF8v9SqxWY9TWp0LcleJyBkvcW0Ew09fIhRrBwZ9pglTZugOVkD3u4lkKg6w8hCqAefFAKZpv4r8nsXiRwGOrJtIV9iU6SoclBOTU5tpqlnTIWVgw-MAUzTlA5dxNldRP7htv2IkmY3J6YH3SGPR464C6tkqjHAVsUADo8ixNgG88efRPuwSW58ZVP=s750-no" alt="" title="New Music: Sada Baby ft, G Herbo &#8211; Baklava"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/01/06/new-music-sada-baby-ft-g-herbo-baklava/" rel="bookmark" title="New Music: Sada Baby ft, G Herbo &#8211; Baklava">New Music: Sada Baby ft, G Herbo &#8211; Baklava</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/01/05/new-music-illpo-aint-rockin-8/" rel="bookmark" title="New Music: ILLPO &#8211; Ain&#8217;t Rockin"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/xUvZNGrXLhPKFbDSOPFU_BZIzn0fJWdn3sR6OyNYi3nR_JT5bpfTVRqzcxdgyoKUmNWBzU6vEZdL70zZStxiH5HCOXa6G2RrRiVxFl1WG9A6bxWpF9XEYGmf1qN3Gtih2W-u-EOyRmkJxdhRRCDS0WasWkXC8C-ugXerDaqPHV7b9qZqZUJ8K7s87uRu1Z467W57WxBJkmZrJtdowKUABSCMOj7IjfQlZOHYX4g6smtM8Y8zy763pcbvxJI7c3xaAr8ggj8w6ZRObRC5QHZ17Wcsx2tkewbzIOrcvIgwGsbDgqShu0kJE_-zOwqe9ROgOdVvyFGNKFwxWC_qwKS9OcHbNnNB57Rq5LJ9OJE81RZUILkpQ5JJsm8kVAZxWfUXWG4JIVn8mtg26cCphMyswSdPNzUfUadHTQpGqU9M12y7-5h0guztQvhlMLhgmqhNOldhagxihzDZ1DsPrzy-LGEfFoYue92acNAKzAgf13uopezYk3ygPCmphLwQSIX5o3_yxsnzFPsLd3NZGhK2HMTCCzB3ckdmXkHYkbUPS6yxF8UygUcEb-YbDL1sDLFiSrdtC8gqHYbRymvV031foMP1rBKvyFNsGTLLz5ZY4yp3h-Z-3WXZSX6lmzAm2kr53aaZ2llI0ejj5FXLkWhg79PB1oSLhVXDTlGNhfEhRPapDhkbB2GwWcnc=s758-no" alt="" title="New Music: ILLPO &#8211; Ain&#8217;t Rockin"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/01/05/new-music-illpo-aint-rockin-8/" rel="bookmark" title="New Music: ILLPO &#8211; Ain&#8217;t Rockin">New Music: ILLPO &#8211; Ain&#8217;t Rockin</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/01/05/new-music-eric-bellinger-build-something-3/" rel="bookmark" title="New Music: Eric Bellinger &#8211; Build Something"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/ZGWzqNtocGuvTyjWaWjXgwXWho5UhqWg5dR2QJh_jlorKHnHc23NPlfja-6WMw6YBZ13dqFIntA3y8CtRcw9kp_dVEKPPvWRoJx0-bYHvzFwS4-sESMlMLZwp9cqrnvOvCsunR_tUMuu51k2wODuE6jjO-XQJtnRWroQenZspgUIW-_SQuoVjdh-Bk9ACJPiEC_rtTygvD10T9kEp9Ob5CoPpJrvSbVsqsT1QYonDPETK23EvYfdTukRlqQrklM-hjlu_D0k8H-t1ZfMuIJr514kEzk_tUMObkJwFAiahcx3RgzHNv0l1HCwiYXzXu0ggmMrQphGINqfb8NgaSjpG3aWHnZpvKvQYVZpekQGPd6hXYdwRmc4FwmvjdcVkT2Rl2pLdBNVpgFkz39khmOt4FRt6-DR4qq6_2JhrkQnb_J6r4jCYLtLmlBrRZSXqOpi9N8TBqeEmdV_WkUQ8KZok9x6sY0xd-qt-jCalWG_b35bihj1ixiuAjIso78zlfaFsShvVpVBxd-1wrmBaUcumUdlEh7cGn-BJNp4bp9yt6A1IUhWN_oWhdFHgPS_WNARNzcXJkxE8wbZB4aqikktyzjD-XOpmZmpOkosGaHp9TkvFm8HuUgB0Bu5fXQP1DYiTqXtfZz_T7ruCj5verl_YcTLA1-7djpU2rByP410WDyCkcLNG5N3jxUD=s750-no" alt="" title="New Music: Eric Bellinger &#8211; Build Something"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/01/05/new-music-eric-bellinger-build-something-3/" rel="bookmark" title="New Music: Eric Bellinger &#8211; Build Something">New Music: Eric Bellinger &#8211; Build Something</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/01/05/music-video-justin-bieber-yummy-9437/" rel="bookmark" title="Music Video: Justin Bieber &#8211; Yummy"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/1XNJu-TYv19STdLCPTyYTcFpoYmnV-XelU22Js9ucI8eyuUDySGEcQDpXtfraxxbYLzK0rntBIMweQLFm7K3AhIM9lwsiOFIM8fyTR6TjoiLTX4tAKZETCokszbkzScIcRjwV9gLXFkq_xgNemDWROBM_oFIKibGQVIq0SHZyItdWufd6jMuH1RLHfMYXX1tjV8R-4EpN5MwZe8nPb6Fy78ptrXO8XGEZC0NbjWMsocswVrvcEOk84H6AA_4bAljsV8qGNRR1IIOrYvH-6zTApLeE8zIfm7txYezi3JEdJyxFB1SgLiS6Z4cozJM6occbS-nlU00yN5FTKq1t4GzMub7Vy70D8HxWVXMtZ7ZXQcB1KV4PLY1eOx-m-E2levNDEQ6bm9WYmVpKy3fYFBADFwDqDSh8Dfn5CvufCeH0WpBVp9j457TA1zquv3GoMx6WJZqR9R-2WAWhFUZX4m5PITRAyWe5CUuXwPTPh8ossuAFfnUMuFCBbU5Q7U9XSh3bSglneMBMAYW6Xfx-Ip18GuKWuScdPzc-w8NEYDUjciXl-O-XdZdK8zmlbVL1ZdJP23cXsSzmYaA1EhAk4tplzu0gJ0l7d7CKrzv3ZHXhTZnfVku-FiiYln-D2mvxjT0gwR0m-ZTWJm_i63jry-kSPvc8-3Zc2zHOBdvS33jCdQMo3SpAo2ZcvFX=w357-h203-no" alt="" title="Music Video: Justin Bieber &#8211; Yummy"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/01/05/music-video-justin-bieber-yummy-9437/" rel="bookmark" title="Music Video: Justin Bieber &#8211; Yummy">Music Video: Justin Bieber &#8211; Yummy</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/01/04/new-music-reason-ft-bas-junii-jah-the-great-flick-it-up-remix-8/" rel="bookmark" title="New Music: REASON ft. Bas, Junii &#038; Jah The Great &#8211; Flick It Up (Remix)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/dOD6HsEg6ip1nnmztGx-kY6HB8pa8j7y0P28-u5dXmlGBAUD4wVDwdO3dcBCspKoAEb5HnPQL72hH8QaO30cLWvbEHjIMLiV8lAIVDRGeWM9cFrQCYYC1-FLudO7V0fdEKlUGNsJU6UpWh90cw7iaWKCkfktytoSvzHemYEaQIWmg97ueUWbBzifH8XP-cOYRAUtFCKmkqD-6rdx-aQZqzDGgpJnnKz9Bi8rn5hw0dadPSn9MS_r05ZmumWbwoTiuXrJn5RErvq3TwAR1R9EI4WwQ70i_FWuD5v5ECh5xBoJYNJJZgjalR--wKMFuHLPIbRXsgWzkib3m4Sj4HB9x8a_ma3fiOLAWXqMU3XpiJ1KXeJt00xKVdphPn0wpkWxkOdp5su3tA_wi2th_yrtiqbKtaAMYF0GMb2FWV4p-gNsCR3eRQsbVR5utMlC3efAVwCc6vdcnElNznqT3ER-V0pFPgZ-aI7pjNaDl_a4BUHfbrimv7b2N9iEx87jvFzckV2bKvykBhSdQK2H137pFFaxELu9BsVqcksP1JEyyWFnz0wsE18bFf-qIlYrTIEQ3BZHe0sndCmXDaxV5wfkmovZB_QtEKMDR-wSm8-BFnq1tA2mTqyuDAmWHpZSyYA1dplHZ4LF3o_puSpM6vwaJMJ42Gmn8j2LJcBXG9imkNgJOFRoNUcYHnjn=s500-no" alt="" title="New Music: REASON ft. Bas, Junii &#038; Jah The Great &#8211; Flick It Up (Remix)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/01/04/new-music-reason-ft-bas-junii-jah-the-great-flick-it-up-remix-8/" rel="bookmark" title="New Music: REASON ft. Bas, Junii &#038; Jah The Great &#8211; Flick It Up (Remix)">New Music: REASON ft. Bas, Junii &#038; Jah The Great &#8211;&#8230;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_5e134235c1870" data-td_block_id="td_uid_1_5e134235c1870"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_1_5e134235c1870" data-td_block_id="td_uid_1_5e134235c1870"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_2_5e134235cc7e0_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_2_5e134235cc7e0" ><script>var block_td_uid_2_5e134235cc7e0 = new tdBlock();
block_td_uid_2_5e134235cc7e0.id = "td_uid_2_5e134235cc7e0";
block_td_uid_2_5e134235cc7e0.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"97","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_2_5e134235cc7e0_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_2_5e134235cc7e0.td_column_number = "3";
block_td_uid_2_5e134235cc7e0.block_type = "td_block_mega_menu";
block_td_uid_2_5e134235cc7e0.post_count = "5";
block_td_uid_2_5e134235cc7e0.found_posts = "959";
block_td_uid_2_5e134235cc7e0.header_color = "";
block_td_uid_2_5e134235cc7e0.ajax_pagination_infinite_stop = "";
block_td_uid_2_5e134235cc7e0.max_num_pages = "192";
tdBlocksArray.push(block_td_uid_2_5e134235cc7e0);
</script><div id=td_uid_2_5e134235cc7e0 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/01/05/mixtape-westside-gunn-flyest-nig-in-charge-mixtape-vol-1-3184/" rel="bookmark" title="Mixtape: Westside Gunn &#8211; Flyest Nig@@ In Charge, Mixtape Vol. 1"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/l1sG3vXfd1x1lVCfCHmTlv-4KlUz5Tnsf42mGZAPVxh8I44UqLbKhRBvrXgUqDICzrg2BXYAE1Hof0KWPunc1zMm-Xhs1hdhzr-x6qC8bqK8SX7DAHZEqIziYUqDCWa_JywaFuZUtd-sZ-PCTcsy-GO5Up60_og82jnehJiADO3faOMz4ORH_eneIvOlnsoLnC0cv1t92fTJxkWYOulD5iXInT-4MQj-NrDZwGDM68yfUpcFLr79_eW85s4daTc7UO4PJ5unXeCmfiLKHXyH04NV2QmtO6BC9vUYphSj4MZWY397LPvXYzULDY1skpVXVHFYpYF80clFp6zZlUnEE7fX1S1u7gJFE-1Q6FumlnN7p4wOOy2mcYAE83D3l1Yd1z7lalrvGd4AjWziKxCQPNwiw9rOj9xVKJLLYJjtQZjgJRQb2cY91UosHcGZsja9V-xo_bdt5l7T1HnpEw4_zK4AjUOejFFJvEauu-zHodgTpIND9OlgYhowXV2pe20M5NNpRrotoI5y9sJKmQgWetzdZOkdiGTBmE0L3rieMbhU10OnE_b1Dkv_s0lI4ek71M9V-5mIQXHaZ9XZneXOO6dl2xUH99Lsp_R1vNeHPhnh-0mBq0YdVCTJ_EZI6qAoT2crAHUhwXhp7GbqEwxltrWQvJoWkaCARihPotsMnlM1L8xLgRA8EdLu=s600-no" alt="" title="Mixtape: Westside Gunn &#8211; Flyest Nig@@ In Charge, Mixtape Vol. 1"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/01/05/mixtape-westside-gunn-flyest-nig-in-charge-mixtape-vol-1-3184/" rel="bookmark" title="Mixtape: Westside Gunn &#8211; Flyest Nig@@ In Charge, Mixtape Vol. 1">Mixtape: Westside Gunn &#8211; Flyest Nig@@ In Charge, Mixtape Vol. 1</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/28/album-stream-g-herbo-sessions/" rel="bookmark" title="Album Stream: G Herbo &#8211; Sessions"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/3JNltI58zXnz7s3y4AcT_XnVdFn2y-Q-WxWEeCX-q8Y6vq-aoD2TMUeHR_or_NeyaiNsZJg4wl8Xy-mFPTvjDzPG3Qzo7rDuY5qC9c2A53b-MZweLjc5i2KHDsmBUthnlC8opZki_0gr9nLIGLDgwymYDk8fgw-sz-0T8kCasFv4kNAonJPWoYzRsItPHoId7wx0t2WKg2siqBOQtcF8_hsNbG79X4Sc3eeF52ktGu6N9tsRD27QmDjIOcCVfrNL094R3Ta5gwP5GKZJ-DJtB9j2LjZ_V9H4vLoeLe6fjcXdpfRFmR1O1IUs9XQlSk6J3LY9W0u9pfDGeJQqmhSPqcDWqF7Xa-75wjjDMRgqQVhPz91xO6_YP0g2ClSHILk4s4_qG0--h6iV-4u1SQet5ASy3d_dRLVS75_BtP8q85QNmDa_zjN3iJs4XqKL-KeUYXZ1JBFbu-eNiyhXn3JtC3OCv3oUtXLRCJf4H5lYz6dPsb1bsUiVjmYqyLUH11Bd3hwz69mCMaqlgJgVqyPktrAUvX3rGDxo7P7Mw1e-pOfsjuJnJK0iWtMvbJWF0rexWPSYvA9qHLTuvxaVZNTKwVRRRGG6dDh04DLKUnlI2FRek7Zmc2uC7oshYWff7_3Qc6z3sMHy_79CcWJn3X9THWYsrKRVncBM3zpARWRjg6p6On18Ohjch4L7=s500-no" alt="" title="Album Stream: G Herbo &#8211; Sessions"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/28/album-stream-g-herbo-sessions/" rel="bookmark" title="Album Stream: G Herbo &#8211; Sessions">Album Stream: G Herbo &#8211; Sessions</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/27/album-stream-travis-scott-jackboys-compilation/" rel="bookmark" title="Album Stream: Travis Scott &#8211; JACKBOYS Compilation"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/SLKIXTrDfCVgK5rGFex9BWNrp3S27C-lf_Zlz-khRtemfRSZ3FTBAEzVD0EL_O2n_0Jiu8xQ11YWQn0LohR_pebjONuQJQIJDkbZfk3bcSvBq2qZuCo-XJOPxk2XkQSQ3KsjiIeGAcok9AozfKBIDK9GkD5OCLd1gK3I9Acfv4j5Dq_Vu6SRBr3_7Ba6hy6wtSoOxd4jwW04DG7EZUfpuqr30Q4lAml6fClUWbtFDl1DuvLpeARsHntjcvVB6F2KZprMQSoeeE1P9btCRKczhSS6q70cyFpU2QfDqjnpkdeMw_xoS91CV7r-KYi7kt3B6zJxF2VVlC7s0C0q2GPEOMVyXYtNw6Dyc7aVbNku8gfYcH8qP_2gQe8P2FhYnwk5D4mhhaFYj9c7ysCRc9eism2Z8BBnY5rx_LO1nrU9exwA-kbv_11B9Hbbj4eA8DzVlWrmkrt6SmbuwQqPqEN_E2UyPfkbiJxFEJRV6Hx7M6n77ukTJ87veUK2Smn_M3B_O3-tHaHBVBOQzo2JS1_wePdrsghEfd3ekWGJRJ-8FJ7fyuQcY0wlrZJ2R37_DuD5ff9jeo4jF14Pidx-qfU4gYXYNGmKh3L4yoiB_17z4b7lqrhIvFUiesro5MXn0o96RrDdBJZj3GIgFkz5COuuMoXRCDuSdtToN0QpRoSE7LOIMHsgdKecCgDf=s500-no" alt="" title="Album Stream: Travis Scott &#8211; JACKBOYS Compilation"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/27/album-stream-travis-scott-jackboys-compilation/" rel="bookmark" title="Album Stream: Travis Scott &#8211; JACKBOYS Compilation">Album Stream: Travis Scott &#8211; JACKBOYS Compilation</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/23/album-stream-flee-lord-grafh-dirty-restaurant/" rel="bookmark" title="Album Stream: Flee Lord &#038; Grafh &#8211; Dirty Restaurant"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/grV1ianOLAMJ5ltjj9oU4_6CwY7O5Ge_aCux2mqlVr457YGoRFe7N5w4ii5MZx-YrF3fes1t7-t2a95TI5K96lhwonxg56xI5YvyXe-9AA3eWM7DEF-VjBh2ZEFB4m9G7uvCrmfkpINqf-oJAr28yRgtYDIDFfzjw4jeqB4NSw9eza_Bq05Ka4l5wIeOY5XhEUBpoN6cIqttLcM8d_bQ5JPyMvEOiSS5mTIf8CljFcrZimxwqUPmE8dLZPyuAfuCsWGLxwDzJdRSlqWKZtWivkw7cF22Bz8GjCXQexZmyfsNLUBH-pc4p5eK-OZd8XP2OvzzMVFLoy-oghN1zlSx_rEho4h3F4I_XDbt39jWyHvC8ut7YAHJiD09sMAMYNHwYDWdpXj9u_-Ilf21DlbaCzhF0oOkcC1FHjb-_ZYHO6qklPUhM_e4vfOT0DB73Rzzfa5wVGjwxoZIyWl3C590-d6cCd_JMNwAeg5XZubCzcUoBe8x9zfO7SnTnYBoMMFpy3LTpaiGAO7RrQT3eSdShJr_1UKQd3eGv2kfERXSWTcs3XHefEmykpY22-qaXyId0XaGDB1CnXuGannVI5Fv9TufBqtC-6RAPubhN8RXgcg63veH1oWxlGogFO1HLTWMTbRcvCuTh3qm7TuAKJ9SstVTFz219Ya_AGHTGWgkLXvTx4pE94gTLDTi=s700-no" alt="" title="Album Stream: Flee Lord &#038; Grafh &#8211; Dirty Restaurant"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/23/album-stream-flee-lord-grafh-dirty-restaurant/" rel="bookmark" title="Album Stream: Flee Lord &#038; Grafh &#8211; Dirty Restaurant">Album Stream: Flee Lord &#038; Grafh &#8211; Dirty Restaurant</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/23/ep-stream-danileigh-my-present/" rel="bookmark" title="EP Stream: DaniLeigh &#8211; My Present"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/sqd9LUTsTOYHpAs0ya1Yqlmv40sdgc74rmOHFrcrOAdaslrRN6AinBmnOr4Rckr8rDhTSTLSMvybiWcFganlcK29iqJ0Vk-TlomI8J_Es99w12Zpj32fbRDsZdPyAojZqA6dPyi0loIk7diTkv9lJXMfIkonLQ2vmqEDlg_ygdsWvpPet9do13XEvV-P1fW2zM5UAlgGGxIXn8VWweTYzMYVJWUSqPKTIwGFXDdaGDcSD9IGhklkiWOCkAgyUZ6Q2MuFHhxPgJwpOdwf-y7oC_htXnlkbv42Qfmm7xQcvzTVxhqDFWuZcskTvcNkqeLFgcKbpWQ2-WZJfdR9N1c5YlS7CTOI9X--uxXFUgTQQWg8-qJaCC4axs2pEvasGevK3VT3w9GMIDgnYI6PBopCzgA614l9Ml8wYplt1RexO5XlI2y0sHQqRud3HrgbCTkksPRFoiI9SYFtdZmzhvTybw2_lBJaFzn-IzvxkwGNqovUwYfUUUZ8fB9Trj9FYJRPjwsD7JtTPCfc8UW9h1tV0D63zWPS1pCvlFk4S-6XrDpJCiCBqYWFbJtXFY4oZS7Q7ZajX0Y4WfySc1u8VhGTau3Ey9ClSG8uFLQFZSrwh2KR3eLcO7QMVC0zeVjiVoJa-tBG9XYpRGp72U62HpDtcIgKU7BYBcEi6xnTY0KlVL75sRrnibAtiEXo=s500-no" alt="" title="EP Stream: DaniLeigh &#8211; My Present"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/23/ep-stream-danileigh-my-present/" rel="bookmark" title="EP Stream: DaniLeigh &#8211; My Present">EP Stream: DaniLeigh &#8211; My Present</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_5e134235cc7e0" data-td_block_id="td_uid_2_5e134235cc7e0"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_2_5e134235cc7e0" data-td_block_id="td_uid_2_5e134235cc7e0"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_3_5e134235d9a81_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_3_5e134235d9a81" ><script>var block_td_uid_3_5e134235d9a81 = new tdBlock();
block_td_uid_3_5e134235d9a81.id = "td_uid_3_5e134235d9a81";
block_td_uid_3_5e134235d9a81.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_3_5e134235d9a81_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_3_5e134235d9a81.td_column_number = "3";
block_td_uid_3_5e134235d9a81.block_type = "td_block_mega_menu";
block_td_uid_3_5e134235d9a81.post_count = "5";
block_td_uid_3_5e134235d9a81.found_posts = "2616";
block_td_uid_3_5e134235d9a81.header_color = "";
block_td_uid_3_5e134235d9a81.ajax_pagination_infinite_stop = "";
block_td_uid_3_5e134235d9a81.max_num_pages = "524";
tdBlocksArray.push(block_td_uid_3_5e134235d9a81);
</script><div id=td_uid_3_5e134235d9a81 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/01/06/music-video-h-e-r-x-skip-marley-slow-down/" rel="bookmark" title="Music Video: H.E.R. x Skip Marley &#8211; Slow Down"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/GbdlvcvoTXMl1SBBSrAQz3C0KCV8F7trnMcExUSJZEGQyBkbV2_kYLWTbrOJOEoAmxbPxNgSiGOnusEIxFVdq4ejkuscv5w8NDFVkrb8nlgBUsZ90CvhnnH5qjs8sE04YhRRZ-2uIgtozQb0534SqxY6A7miOrsMf_FniMhNKD9VJV6orxF30Os-tAOgciRTMvscyLvUuPl7k4eg4bMiRu3pAKV8f6y1gkvkoapcGf3_trteszTLh0FsndCvT1HkaryHSpxxJFoh0fKos_kG_kcjtA4MxeRH7ZEHIaYWsaReVZY_qTCVC90TAfe01f1aI6hxjXYd74B_cX3JPK5DWnWCfCG1YOmCkCulJ0PlF4eCdj6g88rCd7M2a8kWGuCiazbMsU9vmKr6ZuH-bKrCb_m0R_2bDtsmNaqv9gDfqHXatFWXOpCymyVp2dckluEqzkfXxLuUvaE06oWyP_3p-ZqhCCu_A_YcZPVCAtGbAi5oxU0VZsut3Y1yaJLzS_hNzBmtSsBQ3eMtopcgJT54hVOtBicw9h6Taszqtm1gZTakz0Nu9TOvOGIHEMoBzCPpknTcpp2w6IuTo02rLQnRiLCLBs0vVU8OR4BndvHuh-OFBRXOrQ347yHFkIs8z4gCqIr1UDqGo6sYJ47ZzrmQ1KXaNotgMmE_qm3GtrRuN0luoaH_jp0fD26U=w966-h535-no" alt="" title="Music Video: H.E.R. x Skip Marley &#8211; Slow Down"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/01/06/music-video-h-e-r-x-skip-marley-slow-down/" rel="bookmark" title="Music Video: H.E.R. x Skip Marley &#8211; Slow Down">Music Video: H.E.R. x Skip Marley &#8211; Slow Down</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/01/04/music-video-2-chainz-falcons-hawks-braves/" rel="bookmark" title="Music Video: 2 Chainz &#8211; Falcons Hawks Braves"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/iGcMXcKvlVnjlV4xkWv60ogcVDb_jAaEo-JjZmeN9V3UP4diNEX_Bbhfpc1MEeXdsNdKsFkJWVEEvhI9VYliMMbxQ4oqtHjGu74kOHkgFgaDiDl5GmkYfAZwAgWj4fCUf2Ghp2nvL7_3Lt5ItjohVE48Ga6f17NGaDCVHCVDGbXZzf2isR86hL2C1DmCADFqhfsGF-_9opMlNoY5dmb7zIp6FsCEDMbsjfoaxF-wAVVUEz6MQM9ijCn50804nFxsenm_4kfeBrwElfJS1BtKaJyxeJdMKjRvsE5lmrp8MTiv7HJ7QwQdmobac2EJUhqznZCrooo-HgXZEas6yIquQBMnSaoFTwIh_5tA1B0ZxFMfWMyKJ52haGNzIkqSClJmEdTIgHCJvcYq5yb_V_1ygiCQTLVvs9VWZvffDZnD_7lSS1mcFwwbtkZDlcg6wM_b92MrnNgE5VmX_mFTniPX_FqMZ6PpMRZjAnLII5SHnSNyvd6v8cxB0kL454tP73UxsbT0_DKubmwR7zIZVzVnn7754qDc5XS2r_4quA72cD--P0U6hf1KSgnv1dHcomNfWeN5FhCSZ4KXeLy4gcv4s1Ob1PFBjV0zJXcqYavNboEqdobt7TTS8pwZvn2EgN8YQGYfQd3ho6_h83TDlRODzzkhCB8SijSWCZzgC3lHB7J1r6GLCfGrRxgT=w756-h478-no" alt="" title="Music Video: 2 Chainz &#8211; Falcons Hawks Braves"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/01/04/music-video-2-chainz-falcons-hawks-braves/" rel="bookmark" title="Music Video: 2 Chainz &#8211; Falcons Hawks Braves">Music Video: 2 Chainz &#8211; Falcons Hawks Braves</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/01/01/music-video-ruste-juxx-deadly-stylez/" rel="bookmark" title="Music Video: Ruste Juxx &#8211; Deadly Stylez"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/QalBKABi4Nru-eW_IoLwXSve7l18xW6TJfK1gWNI7ujSt7Gmxl-_wvIszq3UHhYw_XIB4S5BZ1rUOKQ-U9juqAEXj1FNzSYMueD93171YQvTRI3R6g5R0nqhYmsd8j-h6NFMdE4K-qB4cnzGVAWn6xL2PDszLKJhGk-N34WuHpPBDSwEfSM5qvPORsSAG1tXEr04U2E3gyLKSDNjgAWGypqkZAOTUuJLO3Z2DGAFgua7alABdt2zNMyiPKnBSfnxXXHf-bIVxNQ6gv3wQSQHljhyVlWTO6KeqMFOGPBnZzWBAyOj04cu1REzV40fSXxx4pTRI4epQl0iDXhj1e_l_JePYOvSM2I8-Nab5cm2dCLN0_4EKBB9V704vjFXkcctIw1uRgNspsbEYOkVn5swjKel25OVMmxUkzTbvcKPLsro6z9VEWIdMtsaxQmwenqoXUhsarSsBRtYiSb3u2K9vBtwJX9QfSI5nBZ1jb2RrVmn3oLr9HuscQK69onJ4T5kD3tcjnmrXxAKgj0j95Zo_k8nKYEOMcowCIrzaumqS3witYD3c2grn57OX8EVrCahYKqsDbR79Pje4XTJwELFxCU1g9flQbYFxyg-pDysZyFgykjZUedsQJalpxDs9fAWYtcR-OA3pLKhNZSHpLuFtzjr2O4VS87gFY2MaaxlQKOf1w-AEl1NLNHr=w833-h496-no" alt="" title="Music Video: Ruste Juxx &#8211; Deadly Stylez"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/01/01/music-video-ruste-juxx-deadly-stylez/" rel="bookmark" title="Music Video: Ruste Juxx &#8211; Deadly Stylez">Music Video: Ruste Juxx &#8211; Deadly Stylez</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/31/music-video-trippie-redd-moon-walker/" rel="bookmark" title="Music Video: Trippie Redd &#8211; Moon Walker"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/XWeuHhNMPQ11FsNX5Nh7QBkdbMMP5xad9pIFdGbNUlhOB0XDHghAaBiyy-AdtoDNZgCBdjDS_xKP1vVUh1-xWo4P8fuEoM7zBlH0EXqHfC9wWwT3CPGG8HIM5dYhzaA6Tr26solfwXXKBrmrk6b65oo_K4qnp51y1E9ammHg-BTdxSUz_LtlA-8mtDynNsnFKh33aTFYgDEuwQYSYJl1ZwmhXFe33thx9Xra0aOb-YFMr6fv86FC3-1nvEplFFj9j5OoG1dAK3bqqvJNCkGWTmuq631KoThxx1RBTAKY9b4g8e0mVrr0NcX6BKjzC1_TI_gn4Y9D02_vHEsZNyfW-eEnERkrhbzeEC_tg-6fqevjN23Xj1WksAowoCLM9ZIN5sAG821xBeoW5GdFd_8xAQQwYirP44-duc3zO6ys9_lBPY6IUrOPFQH1n2aSaGY1qk38KdmFr5OdYaKjOGWx8cRQ9arQu6ns9j4zVIYd0wQhHUhuJ3XgrdxIxU-iG1EMaUw2Kk88xOK_V6JjCSX1FhpEVl6TpjzMzLmYm9D-9VSPGW4eBdmTiA41111Qob5-RxHG71vu-VZw_J1NfTkVqWRAmiwfb4QIAK6ipIo--BTnYI_OKVrgHu17QqvgRvkwOGPN56tipi6VS0P1QbpFxnCQxTSsC8LUcVIMEqKhJLSXA09antgLD8PP=w806-h592-no" alt="" title="Music Video: Trippie Redd &#8211; Moon Walker"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/31/music-video-trippie-redd-moon-walker/" rel="bookmark" title="Music Video: Trippie Redd &#8211; Moon Walker">Music Video: Trippie Redd &#8211; Moon Walker</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/30/music-video-d-smoke-honey-jack/" rel="bookmark" title="Music Video: D Smoke &#8211; Honey Jack"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/leohvtrG2LG4qe-mstQp5LJd08fAgoQNbH3xR_qMrwiRP_-W3-eiDJPjifcR0Bg_xJq_PtSXJlHvzHYK--dPbWO2LgdKTWKKFlopr5_f5K9LS-5hn9GwgWAbWbdhUnpswgqlLaYOJL2mIO7tFqvDs2DYxZkxJ8-BWw5-Z7_4ahewdCUM0kY32Byjb2FLG3Av0PS0LG_Y0SfPDiX72gvqtiTPKo2yXCXbUuiqlRIpvVH47o898pQ9vagRPtXw5TOaRXw90ds-LpktlnQBAxwNAmkvvIWCo0DBeNUQc1Hj0Dvt8o3ztEd9hOoDotIdCII6FOP14R-mvde0RkLKsVWZb1BlUqOkGKSuXnX4ub2rgD3QXDuQN5LYPQ5FGIzI2szGKbrIsg0UjDQSkNNJa3VS7X0-NIloeUlkt68tfOOPklTx2dHUWzvVTsfXmnbS2sFz-Z3HxpAgaXeRYUciB0k9stuVtjbSGYF5Up4_UGLaqGH4IH5EV9UPtYS21QnL6HqlxI1SRFM53XKh_wg0x2nhsC2Avw57qvhxXs2AOZeFJt2gb4-A6Xkk_TYRQ-3Rckr5t78LlupAEFhMICLm5SkeTTHYBnC-sd8YyKhvRlYH7zDDBjOiPbieSgXH2AlMNtrjWRlKd_GD53H5y18egokGNDwTSU4eYDmGZ0AAWlZPycS8xkY43oD3u9U2=w374-h229-no" alt="" title="Music Video: D Smoke &#8211; Honey Jack"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/30/music-video-d-smoke-honey-jack/" rel="bookmark" title="Music Video: D Smoke &#8211; Honey Jack">Music Video: D Smoke &#8211; Honey Jack</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_5e134235d9a81" data-td_block_id="td_uid_3_5e134235d9a81"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_3_5e134235d9a81" data-td_block_id="td_uid_3_5e134235d9a81"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_4_5e134235e9ca5_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_4_5e134235e9ca5" ><script>var block_td_uid_4_5e134235e9ca5 = new tdBlock();
block_td_uid_4_5e134235e9ca5.id = "td_uid_4_5e134235e9ca5";
block_td_uid_4_5e134235e9ca5.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"29","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_4_5e134235e9ca5_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_4_5e134235e9ca5.td_column_number = "3";
block_td_uid_4_5e134235e9ca5.block_type = "td_block_mega_menu";
block_td_uid_4_5e134235e9ca5.post_count = "4";
block_td_uid_4_5e134235e9ca5.found_posts = "961";
block_td_uid_4_5e134235e9ca5.header_color = "";
block_td_uid_4_5e134235e9ca5.ajax_pagination_infinite_stop = "";
block_td_uid_4_5e134235e9ca5.max_num_pages = "241";
tdBlocksArray.push(block_td_uid_4_5e134235e9ca5);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_4_5e134235e9ca5" id="td_uid_5_5e134235edbc6" data-td_block_id="td_uid_4_5e134235e9ca5" data-td_filter_value="" href="http://weuponithiphop.info/category/latest-news/">All</a><a class="mega-menu-sub-cat-td_uid_4_5e134235e9ca5"  id="td_uid_6_5e134235edd11" data-td_block_id="td_uid_4_5e134235e9ca5" data-td_filter_value="69" href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a><a class="mega-menu-sub-cat-td_uid_4_5e134235e9ca5"  id="td_uid_7_5e134235edff3" data-td_block_id="td_uid_4_5e134235e9ca5" data-td_filter_value="80" href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a><a class="mega-menu-sub-cat-td_uid_4_5e134235e9ca5"  id="td_uid_8_5e134235ee305" data-td_block_id="td_uid_4_5e134235e9ca5" data-td_filter_value="2189" href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a><a class="mega-menu-sub-cat-td_uid_4_5e134235e9ca5"  id="td_uid_9_5e134235ee7ff" data-td_block_id="td_uid_4_5e134235e9ca5" data-td_filter_value="10" href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a><a class="mega-menu-sub-cat-td_uid_4_5e134235e9ca5"  id="td_uid_10_5e134235ee972" data-td_block_id="td_uid_4_5e134235e9ca5" data-td_filter_value="130" href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></div></div><div id=td_uid_4_5e134235e9ca5 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/01/03/frank-ocean-travis-scott-rage-against-the-machine-to-headline-2020-coachella-92/" rel="bookmark" title="Frank Ocean, Travis Scott &#038; Rage Against The Machine To Headline 2020 Coachella"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/6J6CMzTAAUE6m0NGIeTsq2LU-UbsWujJDmfPaQvNXlnBLfdiLF00jbwMACwAS02Oh9D1HzcMWgT2_CM8Q_s3IahH5ICoMv7EOZaxF6hu-uA6t_qCKoBqCndRwovSiWSQcT5vOKpsB9_YzqZQtIawpTqt2Gw_KIO55eSlUX80dAsDWO7S85DkR2i19VZMPDejrrBQi7yyyu5v4T8mid8XjJU8HLa2mEWPgWsRn6tb0msuDx1nAYMpBOON7ugnxPBPIkvu1yB3gHBVIa6P14qzNMlW0c-cH_Xf95N1Qo0NAdW6YG3yPv10TkpXmTCWV3ZbcHc-vChVthEWIkCafCyM4ykIXFvw9Ev3khaYzpRfh5U2LlVG_s4soEvkPfs6GfWwMeXWxFCKelezzOz49DhDZrrjE4ZnK9iMrNEEjh1aB4TD-kRktsJqotoR_CrN6LDpVxNbphO-emiWxbpfArj-jBvj4k94-w7vdXVwNLlcpbEcdBqiRy4-uq2GP_ocWwE-WUwkcd5EcMVrxsAmHNrgfcG1KJIZHUL7Pr3wpJOTF6lB1JT1xmJWw0g6BmEFQ22hGzIzTOn45KqiXzwoEUVi0Gf-I5OAPTjVkI-QH1Gr9AGtLN5Vvr_bwcgTvNYoc_7GLJnbzC-QZ2T0tKtk0SP4cmFucnsEB5RqIsc-zGiY_WXV21jC3jTqS-QC=w500-h506-no" alt="" title="Frank Ocean, Travis Scott &#038; Rage Against The Machine To Headline 2020 Coachella"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/01/03/frank-ocean-travis-scott-rage-against-the-machine-to-headline-2020-coachella-92/" rel="bookmark" title="Frank Ocean, Travis Scott &#038; Rage Against The Machine To Headline 2020 Coachella">Frank Ocean, Travis Scott &#038; Rage Against The Machine To Headline&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/01/02/freddie-gibbs-madlib-will-release-an-instrumental-version-of-bandana/" rel="bookmark" title="Freddie Gibbs &#038; Madlib Will Release An Instrumental Version of ‘Bandana’"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/2VgtBKgZFMdJnPRcD_XQUT6si9iNoETs9We0s-h0Z8mUrCaysp2a4o8oaDs5ZwKI4jfPM0y-uT8HGyRKFgvBHEMTreELU-3qZOQnMW48dOu7Al2sRj9MHr4XcoHJQOF0s7rx_oZEM34Gbr2vKk3tdP_6oXSjHJ3xOkA9CcUwJw2n2chWBIwPwcjwKHwzOG4OSiuxd_JD1P6SjsctcHLif6dhxb0m-qFtGQGyh0Qm25IYqJwo_q7E_xPfkuNiltP-t4drOOnOiIILD_beSCMGW-v1KzjrMoQIxTjUR19EpnU1SAub9kL9kYFW05uGvMbiPBM5wXa6WaPoU0Qr3Ct5LBs1JhOAh6Hhu_IkCMmczWc8yWxk2LaxGYZ5zgtsVN794hQScGvStABGN7jkHAtFaKQNKypW5ob9ggCFcL4VS5sCxhH2rt1VqI9vGpSgTjqYthF9mIvxbF21AIuDN0NIep384qVM_6yIzazRh2T-XuoAAk8ynsk6xC7wVk5O8NT4k7mdC0_fFTzm4SyZa35YYKZ0K3tejD3VtC1zeCf_eE7lw4U0gT2sGMPQ18BlWTRhHxOApJvIWz02phKz0-j-2yhS7g-zKeiS1xWqDLllXEzO7zbz-5wItZFrbGItOb22zk_v12xmoBBT81V_Ah6WMZ21ybKg212Z890PrLPAwql7lOHOIlwo-KDr=s328-no" alt="" title="Freddie Gibbs &#038; Madlib Will Release An Instrumental Version of ‘Bandana’"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/01/02/freddie-gibbs-madlib-will-release-an-instrumental-version-of-bandana/" rel="bookmark" title="Freddie Gibbs &#038; Madlib Will Release An Instrumental Version of ‘Bandana’">Freddie Gibbs &#038; Madlib Will Release An Instrumental Version of ‘Bandana’</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/01/01/video-smino-breaks-down-the-lyrics-for-trina/" rel="bookmark" title="Video: Smino Breaks Down The Lyrics For &#8216;Trina&#8217;"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/647dhLUcrg0SjjivItx9GQjzLrZjInjxuHefEQ6m_mt9CmcgPt68xm7fgPispM37rzIpgUtLdtP3f7Thjjodg5XAdOsiTOWCG4jcaEidErrS4nCirxRg4YUQydy903sPeb9I6cSkKs5a23W1DKwLxDoBuSwwsTF7UUbCKfEgTP_Gs1Vg2oEmw0o1cxJZsRXsVqsv8-YHxt8kydCTn-EJsvRhOwO__xhZhFI6v7LnwnedUDlx5S35FqJQnvY0azZm2V8Z4r1gsEZFT2wxb7yxUF_AqUNSerZASplXbBosPo8zdNGPERWib0jaPjlXXAse1wxjK-n4J2rxsYt8Osm6im6LOL_sn1_VRAATZ584OqfI95NscwX8FkR2CROsrHoBaliy3XvG0Zrhc3FA1uIq3MqMTLZwlYTs1h3rHV9mUvoF1Q5A8TqpAWsB2XOpwp0ykODP8UjLQLWTsLl3hFJ-YRbG_YGqMKseb15glDJeBMj_O_PN8_EbSllZogpPzMKWON4aLaayO7NGcrqzSB7KJvt4pd8cgBWF2gHhJl95VHtD6f7iYLdM5jPpwc6Ij1QpOe4QJXJTiKiKQvKrglySjfM-fHocF5M2icxiUPgShTxW0Jg6qGr28A3F-zYNCNAPpKhXgUUKzBRHUdOzLgWabOLlJ9ZR3rCU0CTQXQEBVbfMJJKggFYDy_tY=w731-h523-no" alt="" title="Video: Smino Breaks Down The Lyrics For &#8216;Trina&#8217;"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/01/01/video-smino-breaks-down-the-lyrics-for-trina/" rel="bookmark" title="Video: Smino Breaks Down The Lyrics For &#8216;Trina&#8217;">Video: Smino Breaks Down The Lyrics For &#8216;Trina&#8217;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/25/video-juice-wrld-fire-in-the-booth-freestyle/" rel="bookmark" title="Video: Juice WRLD &#8211; Fire In The Booth Freestyle"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/gNvG-U759eS6grana24cRxwkyLDr8CqwD21KUiCyvGi2nFRJkFSXsNe4IYwBNVp9RW8kuFUOnb6Q5o1nL6aIiOz_PCPkH9apQf4vpUk5yl9zw4_kzGC14t0m47-rtTZ7KssjymiHSw96cikE9fklTbvTloanXPfzGoqvEKP7KsOQ1rxVVUNCgOAUldjYzQej7mKekIaMpggAmsj9PrNWvCGCxPzavPZuXoeAoDDjRMaE0_XLBwWoHohUYDCWNAj6Xrf7YYstOoXYWdzbW0MCnBa_gHsjJK1-N06nJkvo_05R6vhpS_mE13Xd6paPZGKyo0QXuscMYS5Du6Pn0W5dgdBE0bYijq5nh2lycIbjT3-VOTBw07GQy3zIUxJBIcZrWhrynyBxO0wkqDJT2yhbs-tI4KoHnILstFC1nDiXUxlaf0a0dLQj6U4-cL-kuqQjyOrUWgM2RbcGhDelLQ77haSfjyk4L3Bm7l0RfdMWQ0U-mY56TmF51drOTM2bVCBEMu1R0HR3PUgWVKq5_FsSBnAL50C-b2UV68MBNePscjeZkS-L2KKaBoP45Q0QOxpjLi5lE9TfhUe4_XSD7AzIzkVGD3Bkkn2w-VWE9Ti0kagZsx5wBMEVjOz7DtziFn7ES8DL2gRBZWK2_VB7Y3v9s84yswLNhz7ZPDkvDr_3PuS0HQG0khLONrAx=s758-no" alt="" title="Video: Juice WRLD &#8211; Fire In The Booth Freestyle"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/25/video-juice-wrld-fire-in-the-booth-freestyle/" rel="bookmark" title="Video: Juice WRLD &#8211; Fire In The Booth Freestyle">Video: Juice WRLD &#8211; Fire In The Booth Freestyle</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_4_5e134235e9ca5" data-td_block_id="td_uid_4_5e134235e9ca5"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_4_5e134235e9ca5" data-td_block_id="td_uid_4_5e134235e9ca5"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_11_5e1342367b91f_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_11_5e1342367b91f" ><script>var block_td_uid_11_5e1342367b91f = new tdBlock();
block_td_uid_11_5e1342367b91f.id = "td_uid_11_5e1342367b91f";
block_td_uid_11_5e1342367b91f.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"77","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_11_5e1342367b91f_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_11_5e1342367b91f.td_column_number = "3";
block_td_uid_11_5e1342367b91f.block_type = "td_block_mega_menu";
block_td_uid_11_5e1342367b91f.post_count = "4";
block_td_uid_11_5e1342367b91f.found_posts = "158";
block_td_uid_11_5e1342367b91f.header_color = "";
block_td_uid_11_5e1342367b91f.ajax_pagination_infinite_stop = "";
block_td_uid_11_5e1342367b91f.max_num_pages = "40";
tdBlocksArray.push(block_td_uid_11_5e1342367b91f);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_11_5e1342367b91f" id="td_uid_12_5e1342367f8da" data-td_block_id="td_uid_11_5e1342367b91f" data-td_filter_value="" href="http://weuponithiphop.info/category/fashion/">All</a><a class="mega-menu-sub-cat-td_uid_11_5e1342367b91f"  id="td_uid_13_5e1342367f9f4" data-td_block_id="td_uid_11_5e1342367b91f" data-td_filter_value="76" href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></div></div><div id=td_uid_11_5e1342367b91f class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/LVT4Mid8WL4wHUdO9X2OZmZxxgbREs2lVtszOdEBaO6hJB0JS3yQOAyhNSdCyPmv0amBDTgNGpOlRPXPjKCl6yIlo2joyH3rQRI7CUdX09BJtQI1r5jy1_7BQtDhw4AxUhpUwIh35rNS3lTy7uq-FdPff10JN6srr9mwZ7zr04GQFxBVEXwCfC5rNVehXhY_wGCRVsmevYmdkBWEmB8dvOzBHY78NBBjcHNArS_S-2M0FJgDh8v9m9vEh78k_XmZg-AERctsf0bkODuPi1EcNJq_RnJIV6b0GG-VtKjo-OVPmYghWJYf1HiP9c58cQ98oABU8BDFdLqsBtNt4K0NmyHYQlX39W9k_d83wEHZ1-EacQa2o01VrYSn12HnZ1l88fMzu9PKv6EGmcRZNwpepycW7_9EQnhxIPDdVCmRLXUasUED9OXr-zJmnBcnSnLCa06k1ZymQym1LiSFEv1c3aPHnmnD3GY8nL7q5jPJr4HsABR0WCqMebcF3HF_0deNd0zgRBCGMxW-VzlIIHZiHuBeSPEPvUL149GJ5swSSvKm1uGEi1HlLBj9omJSU7mDWzO0p_7l-l7-4_ureEsGsgB8cX1t8t2TQcFeRgqqF1CXlZFYYC2K0iMb4jPsijsw_rtO7pmKvbngqHfgYpGeh_qLmDWeicR7=w1195-h796-no" alt="" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch">Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/fHEwwMf8DoiXlqkfibQS1Z1XXbviORbV9raaI44tOTXrWo7GgqM3gA-vswE10gFtTQUGGwNG7nWAACwHjxPuiubliYBN_dqtBZh2WIpxvumiJ-hSLK0TNWB2cB8Iw2STT5gcp_KqlDh_e4xng1vidI8EXdp_ooh5uDI-JV1HQ9dGnM5nxl_b-v8znqj-Rl_mGB7y4Lu9zsFNWHU7SriqQQJaKrKEEnb9T8zxmGLaL0zq7ilYpnUEhWulDDr9xc82wdr__WzRBm5YEskVpDAnGM2NDZwTZpjbe4QDdxeixWnSXNK_oDzaL7WTbCpkD33OK88BlI5JmFRQ5VmD11UQ2htB7-9WoahHvb4XmBsbLXpEMl1JmEP4sPx06VduzFnBNo-J90WI0n1AEIIcEYVbRywrkGJXbzmH__In9ZIg0EV24OcGGbeKl12HxTdZwucqsNnuZeNjiMHISQ7i8cfzm3N7X7Zenl74zsKIKeKWoIGxh6MTlVADvgHcrHebnjcSgil2vBeFyz_AP45aOv9SOwbzfVLGS0CNfe1s9b2J7qZgjcBk9QPEXCl2kygvzmGXFvU_3xBuW6S0i3Vkh3Ha_3hPBtvIAy3WoTK2yiqS41HzSK7yk3FRAlBtpIEib338fdkTiosBxtdu36SdNUVM75zl6CVIFhTu=w681-h470-no" alt="" title="Air Jordan 14 Rip Hamilton"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton">Air Jordan 14 Rip Hamilton</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/kUjaOYxjEkAh34S-Ub2QSZwdOwHyFnGFLBZULta3_bn1_myPMAwJXiEEsAAtc1ktCQwHCuKhSqSYsWXFBEIZxdfKuykoDEZWwO-dDI3_JeAshbYvyILEHUu0XaUpRn0mj7gOx10V52t8gRGYPCW7QXGImkPGGhvBPzBDVVqh9lKGtkuPeePmTnpRSmwp0LG1WHcIzUWnMqPBWQeHAat6Q-Tq7niXNb96ddEZsMEdHK1nmHVlNaeqFBNtTxk6yYRkFNCvtfBayqy-Rqt4CPU5tThxbTI4AIUCI6JLxJd_VJizrVNDEe2xZ_tiQdkC5ASIoHpX8sfvAB8zRUsMVJ6oMUt5FH_4GBNXDCtFRmr65Qt0JV1h4bBJffu2L272Q_vpD76wn-YNGW8VCtZcheHu_X-A4gdYQEC0HN0BenY-MOuUBqKEjXAc0SxWeP7W9RN55jlqUFK0nzEYydVjec2stdQIngVfg_FvKxvHXfM4XdtMpqeJnp3Pzyk8xjz30sAZd0f2HQ6zfdPjk-OkV2-WrC0_qW0L8Rq3zrUbq52n3BN7gm7sctU_CUlBmoQIgJDQBYk1Siv4tfSq9pL1R4GdaOlWQdxEuhZi8bTYC8GGAgNGl3SMAZGvk7nu6QnnwEZjZ7mZwbcqgyRKa89cOREMUvIkVJ8Q8lZu=w926-h672-no" alt="" title="Jordan Proto React Triple White"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White">Jordan Proto React Triple White</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4cDUjSODZSaXWfHyZKb9q3Fn7FHA4uB0KSBs0MtFHC0dc6AJb1zeAl_X2LOKalK9C7VBFhTqRQ9fw1ESgUr9ZUKFbOzD94i_s96nvkICOqrsYnzrE2nEAQHoEaGOF4O8GAI6T4CGFbgcQhNzjpRlSY60NyPu5Cmq81FRpEOFRzTOtSa_NnWzMmfwO0yxtPbcg5U6YBUsus8shv3SA7CjULLfaP38nZAuWVgq8PMaaeCQ_eSrK8NJSEVQjyyxmqb-1I7zO8Kvvzvwi--ibMr52CF8h-GusBzSq5ZuzvZRCGu_u8CyfoXw7pwWbOmHnLOdcQ9d2PCSW_IxEMGfmEuU7NxMSsW3Ga4r35_wLB7cjvlPC9OjCV50tfekXjZBS_476mzlf4G9jR7Ju1GqgjXah9Uqc_0Y8N-Br8_JCtIlRSuLxAiebwd7AvFVlgWId9MYxBWnRT3cTyD8SH7q5WwO-CIbKAOSKsNcrrTgFxQvqn9yklBU1u5X5fdTlTBk4WSYorsWZAug0z9BOymRLnrhTbnA0vpBPFROWD-aL1glg-eUpFSfgD4xhWsOqJNY9krQ2UbLSGXQ5gYWj0ovLS7Yz3UKFY2qrVWpqkpbfyN98es9NJ-7LTUs2MLq1rX_2FaQmyq5mVndd7VGzQOHy9hDULG-5H-0LvGd=w900-h566-no" alt="" title="adidas Yeezy Boost 350 V2 Hyperspace"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace">adidas Yeezy Boost 350 V2 Hyperspace</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_11_5e1342367b91f" data-td_block_id="td_uid_11_5e1342367b91f"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_11_5e1342367b91f" data-td_block_id="td_uid_11_5e1342367b91f"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div></div>


<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form method="get" class="td-search-form" action="http://weuponithiphop.info/">
				<div role="search" class="td-head-form-search-wrap">
					<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>            </div>
        </div>
    </div>

    <div class="td-banner-wrap-full">
        <div class="td-header-container td-header-row td-header-header">
            <div class="td-header-sp-recs">
                <div class="td-header-rec-wrap">
    
</div>            </div>
        </div>
    </div>

</div>
<article id="post-36391" class="td-post-template-7 post-36391 post type-post status-publish format-standard has-post-thumbnail hentry category-editors-picks category-music-video tag-h-e-r tag-skip-marley" itemscope itemtype="http://schema.org/Article">

    <div class="td-full-screen-header-image-wrap">

        <div class="td-container td-post-header">
            <div class="td-crumb-container"><div class="entry-crumbs"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="" class="entry-crumb" itemprop="url" href="http://weuponithiphop.info/"><span itemprop="title">Home</span></a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="View all posts in Editor's Picks" class="entry-crumb" itemprop="url" href="http://weuponithiphop.info/category/editors-picks/"><span itemprop="title">Editor's Picks</span></a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last" itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><meta itemprop="title" content = "Music Video: H.E.R. x Skip Marley &#8211; Slow Down"><meta itemprop="url" content = "http://weuponithiphop.info/2020/01/06/music-video-h-e-r-x-skip-marley-slow-down/">Music Video: H.E.R. x Skip Marley &#8211; Slow Down</span></div></div>

	        <div class="td-post-header-holder">

		        <div class="td-parallax-header">

	                <header class="td-post-title">

	                    <ul class="td-category"><li class="entry-category"><a  href="http://weuponithiphop.info/category/editors-picks/">Editor's Picks</a></li><li class="entry-category"><a  href="http://weuponithiphop.info/category/music-video/">Music Video</a></li></ul>	                    <h1 class="entry-title">Music Video: H.E.R. x Skip Marley &#8211; Slow Down</h1>

	                    
	                    <div class="td-module-meta-info">
	                        <div class="td-post-author-name">By <a href="http://weuponithiphop.info/author/cyclone/">cyclone</a> - </div>	                        <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-01-06T05:51:50+00:00" >January 6, 2020</time></span>	                        	                        <div class="td-post-comments"><a href="http://weuponithiphop.info/2020/01/06/music-video-h-e-r-x-skip-marley-slow-down/#respond"><i class="td-icon-comments"></i>0</a></div>	                    </div>

	                </header>

		            <div class="td-read-down"><a href="#"><i class="td-icon-read-down"></i></a></div>
		        </div>
            </div>

        </div>

        <div id="td-full-screen-header-image" class="td-image-gradient-style7">
            <img class="td-backstretch" src="https://lh3.googleusercontent.com/GbdlvcvoTXMl1SBBSrAQz3C0KCV8F7trnMcExUSJZEGQyBkbV2_kYLWTbrOJOEoAmxbPxNgSiGOnusEIxFVdq4ejkuscv5w8NDFVkrb8nlgBUsZ90CvhnnH5qjs8sE04YhRRZ-2uIgtozQb0534SqxY6A7miOrsMf_FniMhNKD9VJV6orxF30Os-tAOgciRTMvscyLvUuPl7k4eg4bMiRu3pAKV8f6y1gkvkoapcGf3_trteszTLh0FsndCvT1HkaryHSpxxJFoh0fKos_kG_kcjtA4MxeRH7ZEHIaYWsaReVZY_qTCVC90TAfe01f1aI6hxjXYd74B_cX3JPK5DWnWCfCG1YOmCkCulJ0PlF4eCdj6g88rCd7M2a8kWGuCiazbMsU9vmKr6ZuH-bKrCb_m0R_2bDtsmNaqv9gDfqHXatFWXOpCymyVp2dckluEqzkfXxLuUvaE06oWyP_3p-ZqhCCu_A_YcZPVCAtGbAi5oxU0VZsut3Y1yaJLzS_hNzBmtSsBQ3eMtopcgJT54hVOtBicw9h6Taszqtm1gZTakz0Nu9TOvOGIHEMoBzCPpknTcpp2w6IuTo02rLQnRiLCLBs0vVU8OR4BndvHuh-OFBRXOrQ347yHFkIs8z4gCqIr1UDqGo6sYJ47ZzrmQ1KXaNotgMmE_qm3GtrRuN0luoaH_jp0fD26U=w966-h535-no">
        </div>
    </div>

    <div class="td-container">
        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    

    <div class="td-post-content">
        <p><img class="alignnone size-full" src="https://lh3.googleusercontent.com/GbdlvcvoTXMl1SBBSrAQz3C0KCV8F7trnMcExUSJZEGQyBkbV2_kYLWTbrOJOEoAmxbPxNgSiGOnusEIxFVdq4ejkuscv5w8NDFVkrb8nlgBUsZ90CvhnnH5qjs8sE04YhRRZ-2uIgtozQb0534SqxY6A7miOrsMf_FniMhNKD9VJV6orxF30Os-tAOgciRTMvscyLvUuPl7k4eg4bMiRu3pAKV8f6y1gkvkoapcGf3_trteszTLh0FsndCvT1HkaryHSpxxJFoh0fKos_kG_kcjtA4MxeRH7ZEHIaYWsaReVZY_qTCVC90TAfe01f1aI6hxjXYd74B_cX3JPK5DWnWCfCG1YOmCkCulJ0PlF4eCdj6g88rCd7M2a8kWGuCiazbMsU9vmKr6ZuH-bKrCb_m0R_2bDtsmNaqv9gDfqHXatFWXOpCymyVp2dckluEqzkfXxLuUvaE06oWyP_3p-ZqhCCu_A_YcZPVCAtGbAi5oxU0VZsut3Y1yaJLzS_hNzBmtSsBQ3eMtopcgJT54hVOtBicw9h6Taszqtm1gZTakz0Nu9TOvOGIHEMoBzCPpknTcpp2w6IuTo02rLQnRiLCLBs0vVU8OR4BndvHuh-OFBRXOrQ347yHFkIs8z4gCqIr1UDqGo6sYJ47ZzrmQ1KXaNotgMmE_qm3GtrRuN0luoaH_jp0fD26U=w966-h535-no" width="966" height="535" /></p>
<p><strong>Skip Marley</strong> and <strong><a href="http://weuponithiphop.info/tag/h-e-r/">H.E.R</a>.</strong> premiere the official <a href="http://weuponithiphop.info/tag/video/">video</a> for their collab titled <strong>&#8220;Slow Down&#8221;</strong>. Directed by L<strong>acey Duke</strong>. <strong>Skip</strong> recently spoke about the record</p>
<p><em>“When I made the song, I was looking and wondering who could be a feature and then I thought of H.E.R. because I love her vibe and her energy really. As soon as I heard the [completed] track I was in love.&#8221;</em></p>
<p>Watch the visual below and download <strong>&#8220;Slow Down&#8221;</strong> now on <a href="https://itunes.apple.com/us/album/1485597415?uo=4&amp;app=itunes&amp;at=1000lIN3&amp;lId=1779292&amp;cId=none&amp;src=Linkfire&amp;sr=5&amp;ct=LFV_a677488ef422c0dd2addfd9da573d480&amp;itscg=30440&amp;itsct=catchall_p5">Apple Music</a>/<a href="https://play.google.com/store/music/album?id=B5iwpi4ikecjoooa6rud7hqpz2a&amp;PAffiliateID=1l3varQ&amp;PCamRefID=LFV_a677488ef422c0dd2addfd9da573d480">Google Play</a>.</p>
<p><iframe src="https://www.youtube.com/embed/p4jZKM5Y6-0" width="854" height="480" frameborder="0" allowfullscreen="allowfullscreen"></iframe></p>
<div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="http://weuponithiphop.info/2020/01/06/music-video-h-e-r-x-skip-marley-slow-down/" data-a2a-title="Music Video: H.E.R. x Skip Marley – Slow Down"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2020%2F01%2F06%2Fmusic-video-h-e-r-x-skip-marley-slow-down%2F&amp;linkname=Music%20Video%3A%20H.E.R.%20x%20Skip%20Marley%20%E2%80%93%20Slow%20Down" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2020%2F01%2F06%2Fmusic-video-h-e-r-x-skip-marley-slow-down%2F&amp;linkname=Music%20Video%3A%20H.E.R.%20x%20Skip%20Marley%20%E2%80%93%20Slow%20Down" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2020%2F01%2F06%2Fmusic-video-h-e-r-x-skip-marley-slow-down%2F&amp;linkname=Music%20Video%3A%20H.E.R.%20x%20Skip%20Marley%20%E2%80%93%20Slow%20Down" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2020%2F01%2F06%2Fmusic-video-h-e-r-x-skip-marley-slow-down%2F&amp;linkname=Music%20Video%3A%20H.E.R.%20x%20Skip%20Marley%20%E2%80%93%20Slow%20Down" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_tumblr" href="https://www.addtoany.com/add_to/tumblr?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2020%2F01%2F06%2Fmusic-video-h-e-r-x-skip-marley-slow-down%2F&amp;linkname=Music%20Video%3A%20H.E.R.%20x%20Skip%20Marley%20%E2%80%93%20Slow%20Down" title="Tumblr" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_reddit" href="https://www.addtoany.com/add_to/reddit?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2020%2F01%2F06%2Fmusic-video-h-e-r-x-skip-marley-slow-down%2F&amp;linkname=Music%20Video%3A%20H.E.R.%20x%20Skip%20Marley%20%E2%80%93%20Slow%20Down" title="Reddit" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_flipboard" href="https://www.addtoany.com/add_to/flipboard?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2020%2F01%2F06%2Fmusic-video-h-e-r-x-skip-marley-slow-down%2F&amp;linkname=Music%20Video%3A%20H.E.R.%20x%20Skip%20Marley%20%E2%80%93%20Slow%20Down" title="Flipboard" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2020%2F01%2F06%2Fmusic-video-h-e-r-x-skip-marley-slow-down%2F&amp;linkname=Music%20Video%3A%20H.E.R.%20x%20Skip%20Marley%20%E2%80%93%20Slow%20Down" title="Copy Link" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div>    </div>


    <footer>
                
        <div class="td-post-source-tags">
                        <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="http://weuponithiphop.info/tag/h-e-r/">H.E.R</a></li><li><a href="http://weuponithiphop.info/tag/skip-marley/">Skip Marley</a></li></ul>        </div>

                <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="http://weuponithiphop.info/2020/01/06/new-music-sada-baby-ft-g-herbo-baklava/">New Music: Sada Baby ft, G Herbo &#8211; Baklava</a></div></div><div class="td-next-prev-separator"></div></div>        <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="http://weuponithiphop.info/author/cyclone/">cyclone</a></span></div>        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="cyclone"></span><meta itemprop="datePublished" content="2020-01-06T05:51:50+00:00"><meta itemprop="dateModified" content="2020-01-06T05:56:22+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://weuponithiphop.info/2020/01/06/music-video-h-e-r-x-skip-marley-slow-down/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png"></span><meta itemprop="name" content="WeUpOnIt"></span><meta itemprop="headline " content="Music Video: H.E.R. x Skip Marley - Slow Down"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://lh3.googleusercontent.com/GbdlvcvoTXMl1SBBSrAQz3C0KCV8F7trnMcExUSJZEGQyBkbV2_kYLWTbrOJOEoAmxbPxNgSiGOnusEIxFVdq4ejkuscv5w8NDFVkrb8nlgBUsZ90CvhnnH5qjs8sE04YhRRZ-2uIgtozQb0534SqxY6A7miOrsMf_FniMhNKD9VJV6orxF30Os-tAOgciRTMvscyLvUuPl7k4eg4bMiRu3pAKV8f6y1gkvkoapcGf3_trteszTLh0FsndCvT1HkaryHSpxxJFoh0fKos_kG_kcjtA4MxeRH7ZEHIaYWsaReVZY_qTCVC90TAfe01f1aI6hxjXYd74B_cX3JPK5DWnWCfCG1YOmCkCulJ0PlF4eCdj6g88rCd7M2a8kWGuCiazbMsU9vmKr6ZuH-bKrCb_m0R_2bDtsmNaqv9gDfqHXatFWXOpCymyVp2dckluEqzkfXxLuUvaE06oWyP_3p-ZqhCCu_A_YcZPVCAtGbAi5oxU0VZsut3Y1yaJLzS_hNzBmtSsBQ3eMtopcgJT54hVOtBicw9h6Taszqtm1gZTakz0Nu9TOvOGIHEMoBzCPpknTcpp2w6IuTo02rLQnRiLCLBs0vVU8OR4BndvHuh-OFBRXOrQ347yHFkIs8z4gCqIr1UDqGo6sYJ47ZzrmQ1KXaNotgMmE_qm3GtrRuN0luoaH_jp0fD26U=w966-h535-no"><meta itemprop="width" content="800"><meta itemprop="height" content="600"></span>    </footer>

    <div class="td_block_wrap td_block_related_posts td_uid_15_5e13424486d91_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_15_5e13424486d91" ><script>var block_td_uid_15_5e13424486d91 = new tdBlock();
block_td_uid_15_5e13424486d91.id = "td_uid_15_5e13424486d91";
block_td_uid_15_5e13424486d91.atts = '{"limit":6,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_custom_related","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_15_5e13424486d91_rand","offset":"","css":"","live_filter":"cur_post_same_tags","live_filter_cur_post_id":36391,"live_filter_cur_post_author":"1"}';
block_td_uid_15_5e13424486d91.td_column_number = "3";
block_td_uid_15_5e13424486d91.block_type = "td_block_related_posts";
block_td_uid_15_5e13424486d91.post_count = "6";
block_td_uid_15_5e13424486d91.found_posts = "28";
block_td_uid_15_5e13424486d91.header_color = "";
block_td_uid_15_5e13424486d91.ajax_pagination_infinite_stop = "";
block_td_uid_15_5e13424486d91.max_num_pages = "5";
tdBlocksArray.push(block_td_uid_15_5e13424486d91);
</script><h4 class="td-related-title"><a id="td_uid_16_5e134244891a3" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_15_5e13424486d91" href="#">RELATED ARTICLES</a><a id="td_uid_17_5e134244891e0" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_15_5e13424486d91" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_15_5e13424486d91 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/04/new-music-h-e-r-christmas-time-is-here/" rel="bookmark" title="New Music: H.E.R. &#8211; Christmas Time Is Here"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/oSdcOfFY2aKNNI7Pe07Dfe9ZITtD5TArxwIelOI9u9lWTQsqR3KNbuTZNoWEnXM9ddbOwpy5qow8m58viwCHwhIYgkANrp7Ylw-loy83z2qwfQoqBp2g_0DUioMekLUYuwtTe-CBH1za0qUPBx6PTSqEKg3FBa6-05xwPeE-s6qmDcBRzMtAT7eVXqAkIbi5bLpX0dsVYBRgjXjGEfwF0YutT5uQigk6nJy_3-om7T7AKm734HfVUereMKQdg3PGuwalFBNxYHMeLY2aPej8wluB9F6t0a3o3LDEdylwCRFq3liXOHbJMHwCrRrNTnhm_X3PoR2kSH7JqfrdpmKgBHXH-y5ulW95w0fUfh4GtbEMkkCfQiO7BE6N1Orm3zxPJKUYcjYZaRpZHjG-tgwMnVpdh9nGjsOXy__fWxzz2ugUNo-JGCzL1miWYMh_DtykSP-6Z07kwISyITK_9jM3K1b29LLkco1d4nzYaLS3UiZvKoXbxhMCcGDr_Jf62wSbWLoRZAo7wIWKFfI7VcQPtRuvuouinDRBw5VmD9SFgAiwy70lpngKDlF1BlQ4lZvCrkBwimPaBATSPJTxhY0LCnPU8dP49ltXYonZ5I3_xEDZcj1kZwKhk_GXpCjWMLSRJsdOdIN94ly6gdDaqxGP4v23xthLFQpNkhqmn3EYqit3jirv1nWgE9Mr=s328-no" alt="" title="New Music: H.E.R. &#8211; Christmas Time Is Here"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/04/new-music-h-e-r-christmas-time-is-here/" rel="bookmark" title="New Music: H.E.R. &#8211; Christmas Time Is Here">New Music: H.E.R. &#8211; Christmas Time Is Here</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/26/video-h-e-r-breaks-down-the-lyrics-for-slide/" rel="bookmark" title="Video: H.E.R. Breaks Down The Lyrics For &#8216;Slide&#8217;"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/MQ8K4ELdhD12UKG2AL25bFvA_Mr6OV1PlhdtuyuxXsIJCK0Jab9VY9J-zy-l3t0Tl_BPubYDfw_0W51L7QjxcWQzcRHbfjI9CAC3YTztR18ZxAqaZ_hOG4-hEI_yuLTAqry46Qt-AZ5MM3tDNFfpwtSTv1ykdaOtAYVoWb1K4S3y-nOmmA7_dtWn7VM6XyilX6t0EtCieXbVyQGfYRyD09MPqiSrG2VboqK3TYgwPKKgkoMOxuZeGSHv_KSVWP4w3zL50qbIEuhPnHlntIqvNUJ2Kfn_aCf9Po8Wd9Z_i26AszwaUHOzBLY61aYVzW3VJ17mpOSFvU8ua-OOSXOtg-84tgFVBPhkz1I-H7tJN4Vz1AtRQjeB2t5BQ1I2-NYv0oXW8c2kRi8zEYj4WqkU-dEZAvit7tASdeNmZQ19OG7UUGKVY4r6AeBbRbiBVn3ANqwuv7SFLn1xbN5bZf1SzT8_xZTlyuL15EyQME4Z83BzrYeSPkQcjW_0jAWJNL3n_gi91L2_9gFLTmwmuWKN8Ndc37bZcoR62kXa1nNBK5zwgyHH56nw5xZPHHCQ04xFxM_SXWLzgA_kTnihwNcgVzT0bTjPLc1Qc8ruZDsmcqVsWwE7NnzVA5lwMCBuwuPFBZvvMKlEy9PFhr0UpV30D8L58s9pIM_3ACybFUlt-p-H-cZ5MJgCc8_4=w829-h525-no" alt="" title="Video: H.E.R. Breaks Down The Lyrics For &#8216;Slide&#8217;"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/26/video-h-e-r-breaks-down-the-lyrics-for-slide/" rel="bookmark" title="Video: H.E.R. Breaks Down The Lyrics For &#8216;Slide&#8217;">Video: H.E.R. Breaks Down The Lyrics For &#8216;Slide&#8217;</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/11/16/new-music-skip-marley-ft-h-e-r-slow-down/" rel="bookmark" title="New Music: Skip Marley ft. H.E.R. &#8211; Slow Down"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/OjyXVnFFkTFYtm0Ghtq3RtMmDK7I_EZa10HZUwxlrEWpz25sQL4Ft0iTGI-vLSoJSGDOutIwLrLjfYuafZj_tozMbhvv41bo63gZqAB9mAuZvy6Ad2M91OG1E8W6FpeokRTyYUDHytIlqjfnBPyc7P63B2nPg96ZGuEXCy1pRt17e3SUy_RwPz3dtaWZNQtVzpnQXrCgaaRdjxC1DuukClb_PnuClJNLwu1ms8-INx_AJkOAfwVue233ZA7b5JH-mFdDqe1dZuiJPwF0D2-HaFWl-MbMmNKML4zFvfEVKG9YdxFW2a2qwGFBkmSetYs8jCCuTZgIYEWEMDPpzB2UZmYCCP_BawKHO1G1hw2yXWvqdgL-MWjx2FNPwGv0LyVPpnTODuvCByjQO2GsGF7SMBw1YnPzW20yzyc_D2H3Op2H9tEoJU9lCZTMCZxyiHGE6GopdwRr9me0_3H_Kb9EflKMCJX5ZWBIy7A4ODp7ZwN-KvLf2tvYvGzbzrLxhQcuhjFXatka1eGzMhnTjGhSXxOmHAydb0nOeFyaCTo4G-JBSgUWSzPxV9PawRIg_EzAq0kCowlIm7E-P1bk91xA9yqrs2ZUQrbxeA8GxBvkP2awhFJ7h_MvyArXSWIeYk3AP9rZLsgCtM0F3_uRjB92Ih1SWQmMtuiCON9dkngs1ICGwsHNgqxuclxA=s736-no" alt="" title="New Music: Skip Marley ft. H.E.R. &#8211; Slow Down"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/11/16/new-music-skip-marley-ft-h-e-r-slow-down/" rel="bookmark" title="New Music: Skip Marley ft. H.E.R. &#8211; Slow Down">New Music: Skip Marley ft. H.E.R. &#8211; Slow Down</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid-->

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/10/17/music-video-h-e-r-ft-yg-slide/" rel="bookmark" title="Music Video: H.E.R. ft. YG &#8211; Slide"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/cAbrXsQoPMuPDX4Z0zIa-RtLiVhjKtzrJdnSmbAUIx9pWAVCpRyB99dTDIHK_aVPGetVitvY8xGl7Cn0vQIy43BuCGKCcYY3dvlLZ3gHkBNTinfMRLLhE1rGJKCVMM4jxXeqvchOaZYou9TDIzONNQorKrBZqXXCdB_9OP-ljwJn-iC1cWZTfKYv5L16kx8f9zwsAidC_F5f0KpHPaEwKH34LGXrIal0cbsJ37rCKPu97XJECKtKvgxfdSS16dPlp9mE2xqSTVlU2zYJZG6PWNy9x_jECmKh54URy01X2eJN4pSm8q5-wOPZPR9xbYz53T3A1OQ_o1-WbYOroTYXNyZ2L-XDmsJ5d7RNpS5k-hqMfB2MqeU21XdIC4JVd8VbQxAOQgtLk0iuCUTlCsvUoirMwctoWI-o9w-mezmNuduKJv31CB_DwsXwH0m8TLdRvcTj5duPTgBE1eIt2aLwtCn7KI675XnmAEpwLg5b8xbTI3MfQztaw16k8MCVAIacC_Qh4oquknh1Cng8h1VSsPPzGmWB-GV4bXpUChAJo1K0vlwPoBF86rL_n5yyISmPj9bQBSdxLXY3oHT3klYJ_cFXj4u3_PTIhIYSWzo99YvJrtfiuamP-i75VWGsA5b9B1-mAVayBcMcBDvfulIFM4dIJ5mFr8dMp249-afNMC7V29wBfqAK36eo=w886-h367-no" alt="" title="Music Video: H.E.R. ft. YG &#8211; Slide"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/10/17/music-video-h-e-r-ft-yg-slide/" rel="bookmark" title="Music Video: H.E.R. ft. YG &#8211; Slide">Music Video: H.E.R. ft. YG &#8211; Slide</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/09/29/new-music-h-e-r-ft-yg-slide/" rel="bookmark" title="New Music: H.E.R. ft. YG &#8211; Slide"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/nGP1Xm6LyZY4Mey8e5hEierO3vcwR0cCYKRHdqGi0IQrjbWt7FCBAXlFYQ4Mg-snS0owjwq6uV0h3PeS4xEBQiXyeDPw4pm_JOHbbPZy8E8XiO82kJtvRphHEybXhu85xvPXL_vnnJXozCQNQkOBL4JyNpkDXh2Tx-2eVJYeY1Qc3oJdJWled30BYyUjwUwrvw5RHkLmk4PRBhkEVOwLetVNLZRz4vGZexPijNeS6E9zBf8eU7TuAb5XHSabmHWf8A3inQvoy6u08a2K13K25e9p9G_1fm21NsO2wQEA2-XY_0D_gKpCKYdGcUFDwFqgfF08j3Z9AZwvhyc5J6dRxih-wqIJLET4vek8ut4GCpu3SEWgUJnazzGjAwCWSMFEg9-HScpbhpqUPdLbZxNeLd94p5Az2_lPNPHjMU8vMPr4LI-xxvIA72yGsxIjXVr-J37-FauUcixjR9lVw2FeWYxPe7G7GStO1V57vWRMteDf-NdzCOk7wtelt1eD2oHERQbm6lfNRKQPZbW4Xfz3VubkQz8nVGSNKXgUIb_RgAsmC82wiXpjO4FbStT-GOO3V14N4_bxeLVuddsWBQfNAi1KeRwnFMRs60C6QpUaiTpnXdU8nBXu5doHd6dtNvG36n_ZynrGC_FKQHf4NT7GBoJUqxWTq83F2lZf-L0ETuUlpb5C2nmZAY7t=s680-no" alt="" title="New Music: H.E.R. ft. YG &#8211; Slide"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/09/29/new-music-h-e-r-ft-yg-slide/" rel="bookmark" title="New Music: H.E.R. ft. YG &#8211; Slide">New Music: H.E.R. ft. YG &#8211; Slide</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/08/11/music-video-dram-ft-h-e-r-watt-the-lay-down/" rel="bookmark" title="Music Video: DRAM Ft. H.E.R. &#038; watt &#8211; The Lay Down"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/9y0oM48hsUtfUkZFWM2PPd24yRMsxPiwZtCGurG9AJeOSLP0EAgL4Cu6N71rnv3HyXeqrqBQsJvNgyVeRjP3Uv4IgrIcMROWvlNqmLGoiejMxTx-X7aWXQpGYMA6bHHv1KLsN0fzN2kjlJH0EbNsai2P5JGnaaIQ3lNTlH08dz9ukgVNVxBrVq7A3J600zHy_zTGFwu-UmzdlW3adaWpzYjP71tW5qnk-u6Lrry6F7Jp7KNfidnWLlCPrjgKOcL1vjetLhMSm8xmOGd35vLrH4Q0VbKMeQmqGYsGZydAlXsxlUemIjdz6_q--BTkNJdbmdoCJr8mrISmd9lugau_iStxlQui6spJ34EWkS_KyrdVcjAV14Zwt7sjKU2zmWdIth4Q38uAPfa8u4VUGiR_u71J2DV6951qvvGaxdViBp_EYCGsylWb6pVLg2AUXzR1VQD7jOpeqonz72ngPww70CKX3iaRMQL8_wqaDyjJO-uundvresrvrUHT1oKHaiDRS5aOkQm5W7wGea0tNYsuDfGIehIT1ELlD5BznPMB5j1r8EnCG_InrBY0NguqDRzvoNevcCO7qFcB2ZVX8m235RK_aOGOgAVxlBf7BIgNoh9-zD0B5wQZ6pxNX2wH4OKjf58ZbZu4XUWJZSVwH2ZG-A1I0oBr4fzt=w1087-h530-no" alt="" title="Music Video: DRAM Ft. H.E.R. &#038; watt &#8211; The Lay Down"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/08/11/music-video-dram-ft-h-e-r-watt-the-lay-down/" rel="bookmark" title="Music Video: DRAM Ft. H.E.R. &#038; watt &#8211; The Lay Down">Music Video: DRAM Ft. H.E.R. &#038; watt &#8211; The Lay Down</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_15_5e13424486d91" data-td_block_id="td_uid_15_5e13424486d91"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_15_5e13424486d91" data-td_block_id="td_uid_15_5e13424486d91"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->

	<div class="comments" id="comments">
            </div> <!-- /.content -->
                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <aside class="widget widget_search"><form method="get" class="td-search-form-widget" action="http://weuponithiphop.info/">
    <div role="search">
        <input class="td-widget-search-input" type="text" value="" name="s" id="s" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit" value="Search" />
    </div>
</form></aside><aside class="widget widget_text">			<div class="textwidget"><h4><strong><span style="color: #8224e3;"><span style="color: #000000;">Listen to</span> <span style="color: #c60000;">WeUpOnItRadio</span> <span style="color: #000000;">Live!</span></span></strong></h4>
<p><span class="cc_streaminfo" data-type="song" data-username="cyclone777">Loading &#8230;</span><br />
<script language="javascript" type="text/javascript" src="https://control.internet-radio.com:2199/system/streaminfo.js"></script><br />
<iframe src="https://tunein.com/embed/player/s292400/" style="width:100%; height:100px;" scrolling="no" frameborder="no"></iframe></p>
</div>
		</aside>
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-sidebar ">
<script type="text/javascript">
var td_screen_width = document.body.clientWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 

<aside class="widget widget_text"><div class="block-title"><span>AUDIOTRAFFICKER:</span></div>			<div class="textwidget"><p><iframe src="https://www.facebook.com/plugins/video.php?href=https%3A%2F%2Fwww.facebook.com%2FAudioTrafficker%2Fvideos%2F326277991409372%2F&#038;show_text=0&#038;width=560" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true" allowFullScreen="true"></iframe></p>
</div>
		</aside><aside class="widget widget_text"><div class="block-title"><span>ethemadassassin &#038; Celinski ft. Illpo -Hardbody</span></div>			<div class="textwidget"><p><iframe src="https://www.youtube.com/embed/3gn2e0gaP9o" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
</div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><div aria-live="polite" id="soliloquy-container-30342" class="soliloquy-container soliloquy-transition-fade  soliloquy-theme-classic" style="max-width:960px;max-height:300px;"><ul id="soliloquy-30342" class="soliloquy-slider soliloquy-slides soliloquy-wrap soliloquy-clear"><li aria-hidden="true" class="soliloquy-item soliloquy-item-1 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109673710?productType=812&#038;appearance=1" class="soliloquy-link" title="Revolt Tee" target="_blank"><img id="soliloquy-image-30349" class="soliloquy-image soliloquy-image-1" src="http://weuponithiphop.info/wp-content/uploads/Revolt-Tee.jpg" alt="Revolt Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-2 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/youngongetthiswork?q=I12154011" class="soliloquy-link" title="You Gon Get This Work" target="_blank"><img id="soliloquy-image-30344" class="soliloquy-image soliloquy-image-2" src="http://weuponithiphop.info/wp-content/uploads/You-Gon-Get-This-Work.jpg" alt="You Gon Get This Work" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-3 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/savage+bloody?q=I1014473415" class="soliloquy-link" title="Savage Bloody" target="_blank"><img id="soliloquy-image-30343" class="soliloquy-image soliloquy-image-3" src="http://weuponithiphop.info/wp-content/uploads/Savage-Bloody.jpg" alt="Savage Bloody" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-4 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/can?q=I1011767996" class="soliloquy-link" title="spray" target="_blank"><img id="soliloquy-image-30345" class="soliloquy-image soliloquy-image-4" src="http://weuponithiphop.info/wp-content/uploads/spray.jpg" alt="spray" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-5 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814012" class="soliloquy-link" title="Good Vibes Only 1" target="_blank"><img id="soliloquy-image-30346" class="soliloquy-image soliloquy-image-5" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-1.jpg" alt="Good Vibes Only 1" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-6 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/blessed?q=I12044252" class="soliloquy-link" title="Blessed Tee" target="_blank"><img id="soliloquy-image-30347" class="soliloquy-image soliloquy-image-6" src="http://weuponithiphop.info/wp-content/uploads/Blessed-Tee.jpg" alt="Blessed Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-7 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/trap?q=I1009984243" class="soliloquy-link" title="Trap Tee" target="_blank"><img id="soliloquy-image-30348" class="soliloquy-image soliloquy-image-7" src="http://weuponithiphop.info/wp-content/uploads/Trap-Tee.jpg" alt="Trap Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-8 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/good+vibes+only+birds?q=I1014476779" class="soliloquy-link" title="Good Vibes Only 2" target="_blank"><img id="soliloquy-image-30350" class="soliloquy-image soliloquy-image-8" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-2.jpg" alt="Good Vibes Only 2" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-9 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/all+seeing+eye?q=I11739019" class="soliloquy-link" title="ILLuminati" target="_blank"><img id="soliloquy-image-30351" class="soliloquy-image soliloquy-image-9" src="http://weuponithiphop.info/wp-content/uploads/ILLuminati.jpg" alt="ILLuminati" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-10 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/diamond_skull_1?q=I12527492" class="soliloquy-link" title="Diamond Skull" target="_blank"><img id="soliloquy-image-30352" class="soliloquy-image soliloquy-image-10" src="http://weuponithiphop.info/wp-content/uploads/Diamond-Skull.jpg" alt="Diamond Skull" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-11 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/donuts+doom-A109792920" class="soliloquy-link" title="donunts" target="_blank"><img id="soliloquy-image-30353" class="soliloquy-image soliloquy-image-11" src="http://weuponithiphop.info/wp-content/uploads/donunts.jpg" alt="donunts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-12 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/crime+pays?q=I12067735" class="soliloquy-link" title="Crime Pays" target="_blank"><img id="soliloquy-image-30434" class="soliloquy-image soliloquy-image-12" src="http://weuponithiphop.info/wp-content/uploads/Crime-Pays.jpg" alt="Crime Pays" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-13 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/fuckyoupayme?q=I11550361" class="soliloquy-link" title="Fuck You Pay Me" target="_blank"><img id="soliloquy-image-30436" class="soliloquy-image soliloquy-image-13" src="http://weuponithiphop.info/wp-content/uploads/Fuck-You-Pay-Me.jpg" alt="Fuck You Pay Me" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-14 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814011" class="soliloquy-link" title="savage gold tee" target="_blank"><img id="soliloquy-image-30354" class="soliloquy-image soliloquy-image-14" src="http://weuponithiphop.info/wp-content/uploads/savage-gold-tee.jpg" alt="savage gold tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-15 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/?page=2" class="soliloquy-link" title="fresh-clean-signature-" target="_blank"><img id="soliloquy-image-30437" class="soliloquy-image soliloquy-image-15" src="http://weuponithiphop.info/wp-content/uploads/fresh-clean-signature-.jpg" alt="fresh-clean-signature-" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-16 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/%24teez?q=I1001415610" class="soliloquy-link" title="gold fronts" target="_blank"><img id="soliloquy-image-30355" class="soliloquy-image soliloquy-image-16" src="http://weuponithiphop.info/wp-content/uploads/gold-fronts.jpg" alt="gold fronts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-17 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/soldier?q=I11611241" class="soliloquy-link" title="Swag Soldier" target="_blank"><img id="soliloquy-image-30435" class="soliloquy-image soliloquy-image-17" src="http://weuponithiphop.info/wp-content/uploads/Swag-Soldier.jpg" alt="Swag Soldier" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-18 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/gamer-A7923028?productType=210&#038;appearance=22" class="soliloquy-link" title="gamer" target="_blank"><img id="soliloquy-image-30438" class="soliloquy-image soliloquy-image-18" src="http://weuponithiphop.info/wp-content/uploads/gamer.jpg" alt="gamer" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-19 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/" class="soliloquy-link" title="freshandlogo Square" target="_blank"><img id="soliloquy-image-30356" class="soliloquy-image soliloquy-image-19" src="http://weuponithiphop.info/wp-content/uploads/freshandlogo-Square.jpg" alt="freshandlogo Square" /></a></li></ul></div><noscript><style type="text/css">#soliloquy-container-30342{opacity:1}</style></noscript>
</div>
		</aside>                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</article> <!-- /.post -->


<!-- Instagram -->



<!-- Footer -->
<div class="td-footer-wrapper td-footer-template-3">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
			    		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span4">
                <div class="td-footer-info"><div class="footer-logo-wrap"><a href="http://weuponithiphop.info/"><img class="td-retina-data" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" alt="" title=""/></a></div><div class="footer-text-wrap"></div><div class="footer-social-wrap td-social-style-2">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div></div>            </div>

            <div class="td-pb-span4">
                <aside class="widget widget_calendar"><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar">
	<caption>January 2020</caption>
	<thead>
	<tr>
		<th scope="col" title="Sunday">S</th>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
	</tr>
	</thead>

	<tfoot>
	<tr>
		<td colspan="3" id="prev"><a href="http://weuponithiphop.info/2019/12/">&laquo; Dec</a></td>
		<td class="pad">&nbsp;</td>
		<td colspan="3" id="next" class="pad">&nbsp;</td>
	</tr>
	</tfoot>

	<tbody>
	<tr>
		<td colspan="3" class="pad">&nbsp;</td><td><a href="http://weuponithiphop.info/2020/01/01/" aria-label="Posts published on January 1, 2020">1</a></td><td><a href="http://weuponithiphop.info/2020/01/02/" aria-label="Posts published on January 2, 2020">2</a></td><td><a href="http://weuponithiphop.info/2020/01/03/" aria-label="Posts published on January 3, 2020">3</a></td><td><a href="http://weuponithiphop.info/2020/01/04/" aria-label="Posts published on January 4, 2020">4</a></td>
	</tr>
	<tr>
		<td><a href="http://weuponithiphop.info/2020/01/05/" aria-label="Posts published on January 5, 2020">5</a></td><td id="today"><a href="http://weuponithiphop.info/2020/01/06/" aria-label="Posts published on January 6, 2020">6</a></td><td>7</td><td>8</td><td>9</td><td>10</td><td>11</td>
	</tr>
	<tr>
		<td>12</td><td>13</td><td>14</td><td>15</td><td>16</td><td>17</td><td>18</td>
	</tr>
	<tr>
		<td>19</td><td>20</td><td>21</td><td>22</td><td>23</td><td>24</td><td>25</td>
	</tr>
	<tr>
		<td>26</td><td>27</td><td>28</td><td>29</td><td>30</td><td>31</td>
		<td class="pad" colspan="1">&nbsp;</td>
	</tr>
	</tbody>
	</table></div></aside>            </div>

            <div class="td-pb-span4">
                <aside class="widget widget_text">			<div class="textwidget"><div aria-live="polite" id="soliloquy-container-30342" class="soliloquy-container soliloquy-transition-fade  soliloquy-theme-classic" style="max-width:960px;max-height:300px;"><ul id="soliloquy-30342" class="soliloquy-slider soliloquy-slides soliloquy-wrap soliloquy-clear"><li aria-hidden="true" class="soliloquy-item soliloquy-item-1 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109673710?productType=812&#038;appearance=1" class="soliloquy-link" title="Revolt Tee" target="_blank"><img id="soliloquy-image-30349" class="soliloquy-image soliloquy-image-1" src="http://weuponithiphop.info/wp-content/uploads/Revolt-Tee.jpg" alt="Revolt Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-2 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/youngongetthiswork?q=I12154011" class="soliloquy-link" title="You Gon Get This Work" target="_blank"><img id="soliloquy-image-30344" class="soliloquy-image soliloquy-image-2" src="http://weuponithiphop.info/wp-content/uploads/You-Gon-Get-This-Work.jpg" alt="You Gon Get This Work" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-3 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/savage+bloody?q=I1014473415" class="soliloquy-link" title="Savage Bloody" target="_blank"><img id="soliloquy-image-30343" class="soliloquy-image soliloquy-image-3" src="http://weuponithiphop.info/wp-content/uploads/Savage-Bloody.jpg" alt="Savage Bloody" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-4 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/can?q=I1011767996" class="soliloquy-link" title="spray" target="_blank"><img id="soliloquy-image-30345" class="soliloquy-image soliloquy-image-4" src="http://weuponithiphop.info/wp-content/uploads/spray.jpg" alt="spray" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-5 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814012" class="soliloquy-link" title="Good Vibes Only 1" target="_blank"><img id="soliloquy-image-30346" class="soliloquy-image soliloquy-image-5" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-1.jpg" alt="Good Vibes Only 1" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-6 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/blessed?q=I12044252" class="soliloquy-link" title="Blessed Tee" target="_blank"><img id="soliloquy-image-30347" class="soliloquy-image soliloquy-image-6" src="http://weuponithiphop.info/wp-content/uploads/Blessed-Tee.jpg" alt="Blessed Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-7 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/trap?q=I1009984243" class="soliloquy-link" title="Trap Tee" target="_blank"><img id="soliloquy-image-30348" class="soliloquy-image soliloquy-image-7" src="http://weuponithiphop.info/wp-content/uploads/Trap-Tee.jpg" alt="Trap Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-8 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/good+vibes+only+birds?q=I1014476779" class="soliloquy-link" title="Good Vibes Only 2" target="_blank"><img id="soliloquy-image-30350" class="soliloquy-image soliloquy-image-8" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-2.jpg" alt="Good Vibes Only 2" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-9 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/all+seeing+eye?q=I11739019" class="soliloquy-link" title="ILLuminati" target="_blank"><img id="soliloquy-image-30351" class="soliloquy-image soliloquy-image-9" src="http://weuponithiphop.info/wp-content/uploads/ILLuminati.jpg" alt="ILLuminati" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-10 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/diamond_skull_1?q=I12527492" class="soliloquy-link" title="Diamond Skull" target="_blank"><img id="soliloquy-image-30352" class="soliloquy-image soliloquy-image-10" src="http://weuponithiphop.info/wp-content/uploads/Diamond-Skull.jpg" alt="Diamond Skull" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-11 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/donuts+doom-A109792920" class="soliloquy-link" title="donunts" target="_blank"><img id="soliloquy-image-30353" class="soliloquy-image soliloquy-image-11" src="http://weuponithiphop.info/wp-content/uploads/donunts.jpg" alt="donunts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-12 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/crime+pays?q=I12067735" class="soliloquy-link" title="Crime Pays" target="_blank"><img id="soliloquy-image-30434" class="soliloquy-image soliloquy-image-12" src="http://weuponithiphop.info/wp-content/uploads/Crime-Pays.jpg" alt="Crime Pays" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-13 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/fuckyoupayme?q=I11550361" class="soliloquy-link" title="Fuck You Pay Me" target="_blank"><img id="soliloquy-image-30436" class="soliloquy-image soliloquy-image-13" src="http://weuponithiphop.info/wp-content/uploads/Fuck-You-Pay-Me.jpg" alt="Fuck You Pay Me" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-14 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814011" class="soliloquy-link" title="savage gold tee" target="_blank"><img id="soliloquy-image-30354" class="soliloquy-image soliloquy-image-14" src="http://weuponithiphop.info/wp-content/uploads/savage-gold-tee.jpg" alt="savage gold tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-15 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/?page=2" class="soliloquy-link" title="fresh-clean-signature-" target="_blank"><img id="soliloquy-image-30437" class="soliloquy-image soliloquy-image-15" src="http://weuponithiphop.info/wp-content/uploads/fresh-clean-signature-.jpg" alt="fresh-clean-signature-" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-16 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/%24teez?q=I1001415610" class="soliloquy-link" title="gold fronts" target="_blank"><img id="soliloquy-image-30355" class="soliloquy-image soliloquy-image-16" src="http://weuponithiphop.info/wp-content/uploads/gold-fronts.jpg" alt="gold fronts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-17 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/soldier?q=I11611241" class="soliloquy-link" title="Swag Soldier" target="_blank"><img id="soliloquy-image-30435" class="soliloquy-image soliloquy-image-17" src="http://weuponithiphop.info/wp-content/uploads/Swag-Soldier.jpg" alt="Swag Soldier" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-18 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/gamer-A7923028?productType=210&#038;appearance=22" class="soliloquy-link" title="gamer" target="_blank"><img id="soliloquy-image-30438" class="soliloquy-image soliloquy-image-18" src="http://weuponithiphop.info/wp-content/uploads/gamer.jpg" alt="gamer" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-19 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/" class="soliloquy-link" title="freshandlogo Square" target="_blank"><img id="soliloquy-image-30356" class="soliloquy-image soliloquy-image-19" src="http://weuponithiphop.info/wp-content/uploads/freshandlogo-Square.jpg" alt="freshandlogo Square" /></a></li></ul></div><noscript><style type="text/css">#soliloquy-container-30342{opacity:1}</style></noscript>
</div>
		</aside>            </div>
        </div>
    </div>
</div>

<!-- Sub Footer -->
    <div class="td-sub-footer-container">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span7 td-sub-footer-menu">
                        <div class="menu-top-menu-container"><ul id="menu-top-menu-2" class="td-subfooter-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-mega-menu menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_20_5e1342449826a_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_20_5e1342449826a" ><script>var block_td_uid_20_5e1342449826a = new tdBlock();
block_td_uid_20_5e1342449826a.id = "td_uid_20_5e1342449826a";
block_td_uid_20_5e1342449826a.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"43","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_20_5e1342449826a_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_20_5e1342449826a.td_column_number = "3";
block_td_uid_20_5e1342449826a.block_type = "td_block_mega_menu";
block_td_uid_20_5e1342449826a.post_count = "5";
block_td_uid_20_5e1342449826a.found_posts = "2698";
block_td_uid_20_5e1342449826a.header_color = "";
block_td_uid_20_5e1342449826a.ajax_pagination_infinite_stop = "";
block_td_uid_20_5e1342449826a.max_num_pages = "540";
tdBlocksArray.push(block_td_uid_20_5e1342449826a);
</script><div id=td_uid_20_5e1342449826a class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/01/06/new-music-sada-baby-ft-g-herbo-baklava/" rel="bookmark" title="New Music: Sada Baby ft, G Herbo &#8211; Baklava"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/WLtkfbB50kKcLEx3k9vPJPDXXLwt2SG5mmzf2FAXNY7fNOEjpwy8f5_NkNlMQpI4Ecc67YbLAnn1O9ioshrtN0QCMOw_gZFz2740DZlo7c73cCW0h1oSKf4XkeHkpiC780AvIR8RDknD38fnWbm6ARaXzeYP3heNRSW58tsKRC3t546woH_T9HSNtK3K9sM1PrbxDug3Kxn6kXeE6JaVr_ZxNWqxLZvK_nKNoaHHFMX9tF_gPxxvOdca7KyrxNa609l_mz3yGMI2KvWks7id6c5gHzRLHzIsQwjQawAaibvBTV0P_OLMpz5v0qtt3B5jH-tznjAb3tcsygqY3vKydoXvs3q0EfSZ1SnyqUg82i4tVAcE7__y0oSUodDEEmtJ6PQlFexTWrkXpKKxIuLAkIjExadFG19LtQSfev86fAahbuEwY3cPebTtqNdCIbbCJApNeAsPMj-cpWelyODPKcLS7MV00G4V6eSa6uzZaJxZTEhu60RW7s1eg-Q9WfwF8v9SqxWY9TWp0LcleJyBkvcW0Ew09fIhRrBwZ9pglTZugOVkD3u4lkKg6w8hCqAefFAKZpv4r8nsXiRwGOrJtIV9iU6SoclBOTU5tpqlnTIWVgw-MAUzTlA5dxNldRP7htv2IkmY3J6YH3SGPR464C6tkqjHAVsUADo8ixNgG88efRPuwSW58ZVP=s750-no" alt="" title="New Music: Sada Baby ft, G Herbo &#8211; Baklava"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/01/06/new-music-sada-baby-ft-g-herbo-baklava/" rel="bookmark" title="New Music: Sada Baby ft, G Herbo &#8211; Baklava">New Music: Sada Baby ft, G Herbo &#8211; Baklava</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/01/05/new-music-illpo-aint-rockin-8/" rel="bookmark" title="New Music: ILLPO &#8211; Ain&#8217;t Rockin"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/xUvZNGrXLhPKFbDSOPFU_BZIzn0fJWdn3sR6OyNYi3nR_JT5bpfTVRqzcxdgyoKUmNWBzU6vEZdL70zZStxiH5HCOXa6G2RrRiVxFl1WG9A6bxWpF9XEYGmf1qN3Gtih2W-u-EOyRmkJxdhRRCDS0WasWkXC8C-ugXerDaqPHV7b9qZqZUJ8K7s87uRu1Z467W57WxBJkmZrJtdowKUABSCMOj7IjfQlZOHYX4g6smtM8Y8zy763pcbvxJI7c3xaAr8ggj8w6ZRObRC5QHZ17Wcsx2tkewbzIOrcvIgwGsbDgqShu0kJE_-zOwqe9ROgOdVvyFGNKFwxWC_qwKS9OcHbNnNB57Rq5LJ9OJE81RZUILkpQ5JJsm8kVAZxWfUXWG4JIVn8mtg26cCphMyswSdPNzUfUadHTQpGqU9M12y7-5h0guztQvhlMLhgmqhNOldhagxihzDZ1DsPrzy-LGEfFoYue92acNAKzAgf13uopezYk3ygPCmphLwQSIX5o3_yxsnzFPsLd3NZGhK2HMTCCzB3ckdmXkHYkbUPS6yxF8UygUcEb-YbDL1sDLFiSrdtC8gqHYbRymvV031foMP1rBKvyFNsGTLLz5ZY4yp3h-Z-3WXZSX6lmzAm2kr53aaZ2llI0ejj5FXLkWhg79PB1oSLhVXDTlGNhfEhRPapDhkbB2GwWcnc=s758-no" alt="" title="New Music: ILLPO &#8211; Ain&#8217;t Rockin"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/01/05/new-music-illpo-aint-rockin-8/" rel="bookmark" title="New Music: ILLPO &#8211; Ain&#8217;t Rockin">New Music: ILLPO &#8211; Ain&#8217;t Rockin</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/01/05/new-music-eric-bellinger-build-something-3/" rel="bookmark" title="New Music: Eric Bellinger &#8211; Build Something"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/ZGWzqNtocGuvTyjWaWjXgwXWho5UhqWg5dR2QJh_jlorKHnHc23NPlfja-6WMw6YBZ13dqFIntA3y8CtRcw9kp_dVEKPPvWRoJx0-bYHvzFwS4-sESMlMLZwp9cqrnvOvCsunR_tUMuu51k2wODuE6jjO-XQJtnRWroQenZspgUIW-_SQuoVjdh-Bk9ACJPiEC_rtTygvD10T9kEp9Ob5CoPpJrvSbVsqsT1QYonDPETK23EvYfdTukRlqQrklM-hjlu_D0k8H-t1ZfMuIJr514kEzk_tUMObkJwFAiahcx3RgzHNv0l1HCwiYXzXu0ggmMrQphGINqfb8NgaSjpG3aWHnZpvKvQYVZpekQGPd6hXYdwRmc4FwmvjdcVkT2Rl2pLdBNVpgFkz39khmOt4FRt6-DR4qq6_2JhrkQnb_J6r4jCYLtLmlBrRZSXqOpi9N8TBqeEmdV_WkUQ8KZok9x6sY0xd-qt-jCalWG_b35bihj1ixiuAjIso78zlfaFsShvVpVBxd-1wrmBaUcumUdlEh7cGn-BJNp4bp9yt6A1IUhWN_oWhdFHgPS_WNARNzcXJkxE8wbZB4aqikktyzjD-XOpmZmpOkosGaHp9TkvFm8HuUgB0Bu5fXQP1DYiTqXtfZz_T7ruCj5verl_YcTLA1-7djpU2rByP410WDyCkcLNG5N3jxUD=s750-no" alt="" title="New Music: Eric Bellinger &#8211; Build Something"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/01/05/new-music-eric-bellinger-build-something-3/" rel="bookmark" title="New Music: Eric Bellinger &#8211; Build Something">New Music: Eric Bellinger &#8211; Build Something</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/01/05/music-video-justin-bieber-yummy-9437/" rel="bookmark" title="Music Video: Justin Bieber &#8211; Yummy"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/1XNJu-TYv19STdLCPTyYTcFpoYmnV-XelU22Js9ucI8eyuUDySGEcQDpXtfraxxbYLzK0rntBIMweQLFm7K3AhIM9lwsiOFIM8fyTR6TjoiLTX4tAKZETCokszbkzScIcRjwV9gLXFkq_xgNemDWROBM_oFIKibGQVIq0SHZyItdWufd6jMuH1RLHfMYXX1tjV8R-4EpN5MwZe8nPb6Fy78ptrXO8XGEZC0NbjWMsocswVrvcEOk84H6AA_4bAljsV8qGNRR1IIOrYvH-6zTApLeE8zIfm7txYezi3JEdJyxFB1SgLiS6Z4cozJM6occbS-nlU00yN5FTKq1t4GzMub7Vy70D8HxWVXMtZ7ZXQcB1KV4PLY1eOx-m-E2levNDEQ6bm9WYmVpKy3fYFBADFwDqDSh8Dfn5CvufCeH0WpBVp9j457TA1zquv3GoMx6WJZqR9R-2WAWhFUZX4m5PITRAyWe5CUuXwPTPh8ossuAFfnUMuFCBbU5Q7U9XSh3bSglneMBMAYW6Xfx-Ip18GuKWuScdPzc-w8NEYDUjciXl-O-XdZdK8zmlbVL1ZdJP23cXsSzmYaA1EhAk4tplzu0gJ0l7d7CKrzv3ZHXhTZnfVku-FiiYln-D2mvxjT0gwR0m-ZTWJm_i63jry-kSPvc8-3Zc2zHOBdvS33jCdQMo3SpAo2ZcvFX=w357-h203-no" alt="" title="Music Video: Justin Bieber &#8211; Yummy"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/01/05/music-video-justin-bieber-yummy-9437/" rel="bookmark" title="Music Video: Justin Bieber &#8211; Yummy">Music Video: Justin Bieber &#8211; Yummy</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/01/04/new-music-reason-ft-bas-junii-jah-the-great-flick-it-up-remix-8/" rel="bookmark" title="New Music: REASON ft. Bas, Junii &#038; Jah The Great &#8211; Flick It Up (Remix)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/dOD6HsEg6ip1nnmztGx-kY6HB8pa8j7y0P28-u5dXmlGBAUD4wVDwdO3dcBCspKoAEb5HnPQL72hH8QaO30cLWvbEHjIMLiV8lAIVDRGeWM9cFrQCYYC1-FLudO7V0fdEKlUGNsJU6UpWh90cw7iaWKCkfktytoSvzHemYEaQIWmg97ueUWbBzifH8XP-cOYRAUtFCKmkqD-6rdx-aQZqzDGgpJnnKz9Bi8rn5hw0dadPSn9MS_r05ZmumWbwoTiuXrJn5RErvq3TwAR1R9EI4WwQ70i_FWuD5v5ECh5xBoJYNJJZgjalR--wKMFuHLPIbRXsgWzkib3m4Sj4HB9x8a_ma3fiOLAWXqMU3XpiJ1KXeJt00xKVdphPn0wpkWxkOdp5su3tA_wi2th_yrtiqbKtaAMYF0GMb2FWV4p-gNsCR3eRQsbVR5utMlC3efAVwCc6vdcnElNznqT3ER-V0pFPgZ-aI7pjNaDl_a4BUHfbrimv7b2N9iEx87jvFzckV2bKvykBhSdQK2H137pFFaxELu9BsVqcksP1JEyyWFnz0wsE18bFf-qIlYrTIEQ3BZHe0sndCmXDaxV5wfkmovZB_QtEKMDR-wSm8-BFnq1tA2mTqyuDAmWHpZSyYA1dplHZ4LF3o_puSpM6vwaJMJ42Gmn8j2LJcBXG9imkNgJOFRoNUcYHnjn=s500-no" alt="" title="New Music: REASON ft. Bas, Junii &#038; Jah The Great &#8211; Flick It Up (Remix)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/01/04/new-music-reason-ft-bas-junii-jah-the-great-flick-it-up-remix-8/" rel="bookmark" title="New Music: REASON ft. Bas, Junii &#038; Jah The Great &#8211; Flick It Up (Remix)">New Music: REASON ft. Bas, Junii &#038; Jah The Great &#8211;&#8230;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_20_5e1342449826a" data-td_block_id="td_uid_20_5e1342449826a"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_20_5e1342449826a" data-td_block_id="td_uid_20_5e1342449826a"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_21_5e1342449b756_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_21_5e1342449b756" ><script>var block_td_uid_21_5e1342449b756 = new tdBlock();
block_td_uid_21_5e1342449b756.id = "td_uid_21_5e1342449b756";
block_td_uid_21_5e1342449b756.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"97","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_21_5e1342449b756_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_21_5e1342449b756.td_column_number = "3";
block_td_uid_21_5e1342449b756.block_type = "td_block_mega_menu";
block_td_uid_21_5e1342449b756.post_count = "5";
block_td_uid_21_5e1342449b756.found_posts = "959";
block_td_uid_21_5e1342449b756.header_color = "";
block_td_uid_21_5e1342449b756.ajax_pagination_infinite_stop = "";
block_td_uid_21_5e1342449b756.max_num_pages = "192";
tdBlocksArray.push(block_td_uid_21_5e1342449b756);
</script><div id=td_uid_21_5e1342449b756 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/01/05/mixtape-westside-gunn-flyest-nig-in-charge-mixtape-vol-1-3184/" rel="bookmark" title="Mixtape: Westside Gunn &#8211; Flyest Nig@@ In Charge, Mixtape Vol. 1"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/l1sG3vXfd1x1lVCfCHmTlv-4KlUz5Tnsf42mGZAPVxh8I44UqLbKhRBvrXgUqDICzrg2BXYAE1Hof0KWPunc1zMm-Xhs1hdhzr-x6qC8bqK8SX7DAHZEqIziYUqDCWa_JywaFuZUtd-sZ-PCTcsy-GO5Up60_og82jnehJiADO3faOMz4ORH_eneIvOlnsoLnC0cv1t92fTJxkWYOulD5iXInT-4MQj-NrDZwGDM68yfUpcFLr79_eW85s4daTc7UO4PJ5unXeCmfiLKHXyH04NV2QmtO6BC9vUYphSj4MZWY397LPvXYzULDY1skpVXVHFYpYF80clFp6zZlUnEE7fX1S1u7gJFE-1Q6FumlnN7p4wOOy2mcYAE83D3l1Yd1z7lalrvGd4AjWziKxCQPNwiw9rOj9xVKJLLYJjtQZjgJRQb2cY91UosHcGZsja9V-xo_bdt5l7T1HnpEw4_zK4AjUOejFFJvEauu-zHodgTpIND9OlgYhowXV2pe20M5NNpRrotoI5y9sJKmQgWetzdZOkdiGTBmE0L3rieMbhU10OnE_b1Dkv_s0lI4ek71M9V-5mIQXHaZ9XZneXOO6dl2xUH99Lsp_R1vNeHPhnh-0mBq0YdVCTJ_EZI6qAoT2crAHUhwXhp7GbqEwxltrWQvJoWkaCARihPotsMnlM1L8xLgRA8EdLu=s600-no" alt="" title="Mixtape: Westside Gunn &#8211; Flyest Nig@@ In Charge, Mixtape Vol. 1"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/01/05/mixtape-westside-gunn-flyest-nig-in-charge-mixtape-vol-1-3184/" rel="bookmark" title="Mixtape: Westside Gunn &#8211; Flyest Nig@@ In Charge, Mixtape Vol. 1">Mixtape: Westside Gunn &#8211; Flyest Nig@@ In Charge, Mixtape Vol. 1</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/28/album-stream-g-herbo-sessions/" rel="bookmark" title="Album Stream: G Herbo &#8211; Sessions"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/3JNltI58zXnz7s3y4AcT_XnVdFn2y-Q-WxWEeCX-q8Y6vq-aoD2TMUeHR_or_NeyaiNsZJg4wl8Xy-mFPTvjDzPG3Qzo7rDuY5qC9c2A53b-MZweLjc5i2KHDsmBUthnlC8opZki_0gr9nLIGLDgwymYDk8fgw-sz-0T8kCasFv4kNAonJPWoYzRsItPHoId7wx0t2WKg2siqBOQtcF8_hsNbG79X4Sc3eeF52ktGu6N9tsRD27QmDjIOcCVfrNL094R3Ta5gwP5GKZJ-DJtB9j2LjZ_V9H4vLoeLe6fjcXdpfRFmR1O1IUs9XQlSk6J3LY9W0u9pfDGeJQqmhSPqcDWqF7Xa-75wjjDMRgqQVhPz91xO6_YP0g2ClSHILk4s4_qG0--h6iV-4u1SQet5ASy3d_dRLVS75_BtP8q85QNmDa_zjN3iJs4XqKL-KeUYXZ1JBFbu-eNiyhXn3JtC3OCv3oUtXLRCJf4H5lYz6dPsb1bsUiVjmYqyLUH11Bd3hwz69mCMaqlgJgVqyPktrAUvX3rGDxo7P7Mw1e-pOfsjuJnJK0iWtMvbJWF0rexWPSYvA9qHLTuvxaVZNTKwVRRRGG6dDh04DLKUnlI2FRek7Zmc2uC7oshYWff7_3Qc6z3sMHy_79CcWJn3X9THWYsrKRVncBM3zpARWRjg6p6On18Ohjch4L7=s500-no" alt="" title="Album Stream: G Herbo &#8211; Sessions"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/28/album-stream-g-herbo-sessions/" rel="bookmark" title="Album Stream: G Herbo &#8211; Sessions">Album Stream: G Herbo &#8211; Sessions</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/27/album-stream-travis-scott-jackboys-compilation/" rel="bookmark" title="Album Stream: Travis Scott &#8211; JACKBOYS Compilation"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/SLKIXTrDfCVgK5rGFex9BWNrp3S27C-lf_Zlz-khRtemfRSZ3FTBAEzVD0EL_O2n_0Jiu8xQ11YWQn0LohR_pebjONuQJQIJDkbZfk3bcSvBq2qZuCo-XJOPxk2XkQSQ3KsjiIeGAcok9AozfKBIDK9GkD5OCLd1gK3I9Acfv4j5Dq_Vu6SRBr3_7Ba6hy6wtSoOxd4jwW04DG7EZUfpuqr30Q4lAml6fClUWbtFDl1DuvLpeARsHntjcvVB6F2KZprMQSoeeE1P9btCRKczhSS6q70cyFpU2QfDqjnpkdeMw_xoS91CV7r-KYi7kt3B6zJxF2VVlC7s0C0q2GPEOMVyXYtNw6Dyc7aVbNku8gfYcH8qP_2gQe8P2FhYnwk5D4mhhaFYj9c7ysCRc9eism2Z8BBnY5rx_LO1nrU9exwA-kbv_11B9Hbbj4eA8DzVlWrmkrt6SmbuwQqPqEN_E2UyPfkbiJxFEJRV6Hx7M6n77ukTJ87veUK2Smn_M3B_O3-tHaHBVBOQzo2JS1_wePdrsghEfd3ekWGJRJ-8FJ7fyuQcY0wlrZJ2R37_DuD5ff9jeo4jF14Pidx-qfU4gYXYNGmKh3L4yoiB_17z4b7lqrhIvFUiesro5MXn0o96RrDdBJZj3GIgFkz5COuuMoXRCDuSdtToN0QpRoSE7LOIMHsgdKecCgDf=s500-no" alt="" title="Album Stream: Travis Scott &#8211; JACKBOYS Compilation"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/27/album-stream-travis-scott-jackboys-compilation/" rel="bookmark" title="Album Stream: Travis Scott &#8211; JACKBOYS Compilation">Album Stream: Travis Scott &#8211; JACKBOYS Compilation</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/23/album-stream-flee-lord-grafh-dirty-restaurant/" rel="bookmark" title="Album Stream: Flee Lord &#038; Grafh &#8211; Dirty Restaurant"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/grV1ianOLAMJ5ltjj9oU4_6CwY7O5Ge_aCux2mqlVr457YGoRFe7N5w4ii5MZx-YrF3fes1t7-t2a95TI5K96lhwonxg56xI5YvyXe-9AA3eWM7DEF-VjBh2ZEFB4m9G7uvCrmfkpINqf-oJAr28yRgtYDIDFfzjw4jeqB4NSw9eza_Bq05Ka4l5wIeOY5XhEUBpoN6cIqttLcM8d_bQ5JPyMvEOiSS5mTIf8CljFcrZimxwqUPmE8dLZPyuAfuCsWGLxwDzJdRSlqWKZtWivkw7cF22Bz8GjCXQexZmyfsNLUBH-pc4p5eK-OZd8XP2OvzzMVFLoy-oghN1zlSx_rEho4h3F4I_XDbt39jWyHvC8ut7YAHJiD09sMAMYNHwYDWdpXj9u_-Ilf21DlbaCzhF0oOkcC1FHjb-_ZYHO6qklPUhM_e4vfOT0DB73Rzzfa5wVGjwxoZIyWl3C590-d6cCd_JMNwAeg5XZubCzcUoBe8x9zfO7SnTnYBoMMFpy3LTpaiGAO7RrQT3eSdShJr_1UKQd3eGv2kfERXSWTcs3XHefEmykpY22-qaXyId0XaGDB1CnXuGannVI5Fv9TufBqtC-6RAPubhN8RXgcg63veH1oWxlGogFO1HLTWMTbRcvCuTh3qm7TuAKJ9SstVTFz219Ya_AGHTGWgkLXvTx4pE94gTLDTi=s700-no" alt="" title="Album Stream: Flee Lord &#038; Grafh &#8211; Dirty Restaurant"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/23/album-stream-flee-lord-grafh-dirty-restaurant/" rel="bookmark" title="Album Stream: Flee Lord &#038; Grafh &#8211; Dirty Restaurant">Album Stream: Flee Lord &#038; Grafh &#8211; Dirty Restaurant</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/23/ep-stream-danileigh-my-present/" rel="bookmark" title="EP Stream: DaniLeigh &#8211; My Present"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/sqd9LUTsTOYHpAs0ya1Yqlmv40sdgc74rmOHFrcrOAdaslrRN6AinBmnOr4Rckr8rDhTSTLSMvybiWcFganlcK29iqJ0Vk-TlomI8J_Es99w12Zpj32fbRDsZdPyAojZqA6dPyi0loIk7diTkv9lJXMfIkonLQ2vmqEDlg_ygdsWvpPet9do13XEvV-P1fW2zM5UAlgGGxIXn8VWweTYzMYVJWUSqPKTIwGFXDdaGDcSD9IGhklkiWOCkAgyUZ6Q2MuFHhxPgJwpOdwf-y7oC_htXnlkbv42Qfmm7xQcvzTVxhqDFWuZcskTvcNkqeLFgcKbpWQ2-WZJfdR9N1c5YlS7CTOI9X--uxXFUgTQQWg8-qJaCC4axs2pEvasGevK3VT3w9GMIDgnYI6PBopCzgA614l9Ml8wYplt1RexO5XlI2y0sHQqRud3HrgbCTkksPRFoiI9SYFtdZmzhvTybw2_lBJaFzn-IzvxkwGNqovUwYfUUUZ8fB9Trj9FYJRPjwsD7JtTPCfc8UW9h1tV0D63zWPS1pCvlFk4S-6XrDpJCiCBqYWFbJtXFY4oZS7Q7ZajX0Y4WfySc1u8VhGTau3Ey9ClSG8uFLQFZSrwh2KR3eLcO7QMVC0zeVjiVoJa-tBG9XYpRGp72U62HpDtcIgKU7BYBcEi6xnTY0KlVL75sRrnibAtiEXo=s500-no" alt="" title="EP Stream: DaniLeigh &#8211; My Present"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/23/ep-stream-danileigh-my-present/" rel="bookmark" title="EP Stream: DaniLeigh &#8211; My Present">EP Stream: DaniLeigh &#8211; My Present</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_21_5e1342449b756" data-td_block_id="td_uid_21_5e1342449b756"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_21_5e1342449b756" data-td_block_id="td_uid_21_5e1342449b756"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_22_5e1342449ef94_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_22_5e1342449ef94" ><script>var block_td_uid_22_5e1342449ef94 = new tdBlock();
block_td_uid_22_5e1342449ef94.id = "td_uid_22_5e1342449ef94";
block_td_uid_22_5e1342449ef94.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_22_5e1342449ef94_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_22_5e1342449ef94.td_column_number = "3";
block_td_uid_22_5e1342449ef94.block_type = "td_block_mega_menu";
block_td_uid_22_5e1342449ef94.post_count = "5";
block_td_uid_22_5e1342449ef94.found_posts = "2616";
block_td_uid_22_5e1342449ef94.header_color = "";
block_td_uid_22_5e1342449ef94.ajax_pagination_infinite_stop = "";
block_td_uid_22_5e1342449ef94.max_num_pages = "524";
tdBlocksArray.push(block_td_uid_22_5e1342449ef94);
</script><div id=td_uid_22_5e1342449ef94 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/01/06/music-video-h-e-r-x-skip-marley-slow-down/" rel="bookmark" title="Music Video: H.E.R. x Skip Marley &#8211; Slow Down"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/GbdlvcvoTXMl1SBBSrAQz3C0KCV8F7trnMcExUSJZEGQyBkbV2_kYLWTbrOJOEoAmxbPxNgSiGOnusEIxFVdq4ejkuscv5w8NDFVkrb8nlgBUsZ90CvhnnH5qjs8sE04YhRRZ-2uIgtozQb0534SqxY6A7miOrsMf_FniMhNKD9VJV6orxF30Os-tAOgciRTMvscyLvUuPl7k4eg4bMiRu3pAKV8f6y1gkvkoapcGf3_trteszTLh0FsndCvT1HkaryHSpxxJFoh0fKos_kG_kcjtA4MxeRH7ZEHIaYWsaReVZY_qTCVC90TAfe01f1aI6hxjXYd74B_cX3JPK5DWnWCfCG1YOmCkCulJ0PlF4eCdj6g88rCd7M2a8kWGuCiazbMsU9vmKr6ZuH-bKrCb_m0R_2bDtsmNaqv9gDfqHXatFWXOpCymyVp2dckluEqzkfXxLuUvaE06oWyP_3p-ZqhCCu_A_YcZPVCAtGbAi5oxU0VZsut3Y1yaJLzS_hNzBmtSsBQ3eMtopcgJT54hVOtBicw9h6Taszqtm1gZTakz0Nu9TOvOGIHEMoBzCPpknTcpp2w6IuTo02rLQnRiLCLBs0vVU8OR4BndvHuh-OFBRXOrQ347yHFkIs8z4gCqIr1UDqGo6sYJ47ZzrmQ1KXaNotgMmE_qm3GtrRuN0luoaH_jp0fD26U=w966-h535-no" alt="" title="Music Video: H.E.R. x Skip Marley &#8211; Slow Down"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/01/06/music-video-h-e-r-x-skip-marley-slow-down/" rel="bookmark" title="Music Video: H.E.R. x Skip Marley &#8211; Slow Down">Music Video: H.E.R. x Skip Marley &#8211; Slow Down</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/01/04/music-video-2-chainz-falcons-hawks-braves/" rel="bookmark" title="Music Video: 2 Chainz &#8211; Falcons Hawks Braves"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/iGcMXcKvlVnjlV4xkWv60ogcVDb_jAaEo-JjZmeN9V3UP4diNEX_Bbhfpc1MEeXdsNdKsFkJWVEEvhI9VYliMMbxQ4oqtHjGu74kOHkgFgaDiDl5GmkYfAZwAgWj4fCUf2Ghp2nvL7_3Lt5ItjohVE48Ga6f17NGaDCVHCVDGbXZzf2isR86hL2C1DmCADFqhfsGF-_9opMlNoY5dmb7zIp6FsCEDMbsjfoaxF-wAVVUEz6MQM9ijCn50804nFxsenm_4kfeBrwElfJS1BtKaJyxeJdMKjRvsE5lmrp8MTiv7HJ7QwQdmobac2EJUhqznZCrooo-HgXZEas6yIquQBMnSaoFTwIh_5tA1B0ZxFMfWMyKJ52haGNzIkqSClJmEdTIgHCJvcYq5yb_V_1ygiCQTLVvs9VWZvffDZnD_7lSS1mcFwwbtkZDlcg6wM_b92MrnNgE5VmX_mFTniPX_FqMZ6PpMRZjAnLII5SHnSNyvd6v8cxB0kL454tP73UxsbT0_DKubmwR7zIZVzVnn7754qDc5XS2r_4quA72cD--P0U6hf1KSgnv1dHcomNfWeN5FhCSZ4KXeLy4gcv4s1Ob1PFBjV0zJXcqYavNboEqdobt7TTS8pwZvn2EgN8YQGYfQd3ho6_h83TDlRODzzkhCB8SijSWCZzgC3lHB7J1r6GLCfGrRxgT=w756-h478-no" alt="" title="Music Video: 2 Chainz &#8211; Falcons Hawks Braves"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/01/04/music-video-2-chainz-falcons-hawks-braves/" rel="bookmark" title="Music Video: 2 Chainz &#8211; Falcons Hawks Braves">Music Video: 2 Chainz &#8211; Falcons Hawks Braves</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/01/01/music-video-ruste-juxx-deadly-stylez/" rel="bookmark" title="Music Video: Ruste Juxx &#8211; Deadly Stylez"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/QalBKABi4Nru-eW_IoLwXSve7l18xW6TJfK1gWNI7ujSt7Gmxl-_wvIszq3UHhYw_XIB4S5BZ1rUOKQ-U9juqAEXj1FNzSYMueD93171YQvTRI3R6g5R0nqhYmsd8j-h6NFMdE4K-qB4cnzGVAWn6xL2PDszLKJhGk-N34WuHpPBDSwEfSM5qvPORsSAG1tXEr04U2E3gyLKSDNjgAWGypqkZAOTUuJLO3Z2DGAFgua7alABdt2zNMyiPKnBSfnxXXHf-bIVxNQ6gv3wQSQHljhyVlWTO6KeqMFOGPBnZzWBAyOj04cu1REzV40fSXxx4pTRI4epQl0iDXhj1e_l_JePYOvSM2I8-Nab5cm2dCLN0_4EKBB9V704vjFXkcctIw1uRgNspsbEYOkVn5swjKel25OVMmxUkzTbvcKPLsro6z9VEWIdMtsaxQmwenqoXUhsarSsBRtYiSb3u2K9vBtwJX9QfSI5nBZ1jb2RrVmn3oLr9HuscQK69onJ4T5kD3tcjnmrXxAKgj0j95Zo_k8nKYEOMcowCIrzaumqS3witYD3c2grn57OX8EVrCahYKqsDbR79Pje4XTJwELFxCU1g9flQbYFxyg-pDysZyFgykjZUedsQJalpxDs9fAWYtcR-OA3pLKhNZSHpLuFtzjr2O4VS87gFY2MaaxlQKOf1w-AEl1NLNHr=w833-h496-no" alt="" title="Music Video: Ruste Juxx &#8211; Deadly Stylez"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/01/01/music-video-ruste-juxx-deadly-stylez/" rel="bookmark" title="Music Video: Ruste Juxx &#8211; Deadly Stylez">Music Video: Ruste Juxx &#8211; Deadly Stylez</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/31/music-video-trippie-redd-moon-walker/" rel="bookmark" title="Music Video: Trippie Redd &#8211; Moon Walker"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/XWeuHhNMPQ11FsNX5Nh7QBkdbMMP5xad9pIFdGbNUlhOB0XDHghAaBiyy-AdtoDNZgCBdjDS_xKP1vVUh1-xWo4P8fuEoM7zBlH0EXqHfC9wWwT3CPGG8HIM5dYhzaA6Tr26solfwXXKBrmrk6b65oo_K4qnp51y1E9ammHg-BTdxSUz_LtlA-8mtDynNsnFKh33aTFYgDEuwQYSYJl1ZwmhXFe33thx9Xra0aOb-YFMr6fv86FC3-1nvEplFFj9j5OoG1dAK3bqqvJNCkGWTmuq631KoThxx1RBTAKY9b4g8e0mVrr0NcX6BKjzC1_TI_gn4Y9D02_vHEsZNyfW-eEnERkrhbzeEC_tg-6fqevjN23Xj1WksAowoCLM9ZIN5sAG821xBeoW5GdFd_8xAQQwYirP44-duc3zO6ys9_lBPY6IUrOPFQH1n2aSaGY1qk38KdmFr5OdYaKjOGWx8cRQ9arQu6ns9j4zVIYd0wQhHUhuJ3XgrdxIxU-iG1EMaUw2Kk88xOK_V6JjCSX1FhpEVl6TpjzMzLmYm9D-9VSPGW4eBdmTiA41111Qob5-RxHG71vu-VZw_J1NfTkVqWRAmiwfb4QIAK6ipIo--BTnYI_OKVrgHu17QqvgRvkwOGPN56tipi6VS0P1QbpFxnCQxTSsC8LUcVIMEqKhJLSXA09antgLD8PP=w806-h592-no" alt="" title="Music Video: Trippie Redd &#8211; Moon Walker"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/31/music-video-trippie-redd-moon-walker/" rel="bookmark" title="Music Video: Trippie Redd &#8211; Moon Walker">Music Video: Trippie Redd &#8211; Moon Walker</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/30/music-video-d-smoke-honey-jack/" rel="bookmark" title="Music Video: D Smoke &#8211; Honey Jack"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/leohvtrG2LG4qe-mstQp5LJd08fAgoQNbH3xR_qMrwiRP_-W3-eiDJPjifcR0Bg_xJq_PtSXJlHvzHYK--dPbWO2LgdKTWKKFlopr5_f5K9LS-5hn9GwgWAbWbdhUnpswgqlLaYOJL2mIO7tFqvDs2DYxZkxJ8-BWw5-Z7_4ahewdCUM0kY32Byjb2FLG3Av0PS0LG_Y0SfPDiX72gvqtiTPKo2yXCXbUuiqlRIpvVH47o898pQ9vagRPtXw5TOaRXw90ds-LpktlnQBAxwNAmkvvIWCo0DBeNUQc1Hj0Dvt8o3ztEd9hOoDotIdCII6FOP14R-mvde0RkLKsVWZb1BlUqOkGKSuXnX4ub2rgD3QXDuQN5LYPQ5FGIzI2szGKbrIsg0UjDQSkNNJa3VS7X0-NIloeUlkt68tfOOPklTx2dHUWzvVTsfXmnbS2sFz-Z3HxpAgaXeRYUciB0k9stuVtjbSGYF5Up4_UGLaqGH4IH5EV9UPtYS21QnL6HqlxI1SRFM53XKh_wg0x2nhsC2Avw57qvhxXs2AOZeFJt2gb4-A6Xkk_TYRQ-3Rckr5t78LlupAEFhMICLm5SkeTTHYBnC-sd8YyKhvRlYH7zDDBjOiPbieSgXH2AlMNtrjWRlKd_GD53H5y18egokGNDwTSU4eYDmGZ0AAWlZPycS8xkY43oD3u9U2=w374-h229-no" alt="" title="Music Video: D Smoke &#8211; Honey Jack"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/30/music-video-d-smoke-honey-jack/" rel="bookmark" title="Music Video: D Smoke &#8211; Honey Jack">Music Video: D Smoke &#8211; Honey Jack</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_22_5e1342449ef94" data-td_block_id="td_uid_22_5e1342449ef94"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_22_5e1342449ef94" data-td_block_id="td_uid_22_5e1342449ef94"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_23_5e134244a23e8_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_23_5e134244a23e8" ><script>var block_td_uid_23_5e134244a23e8 = new tdBlock();
block_td_uid_23_5e134244a23e8.id = "td_uid_23_5e134244a23e8";
block_td_uid_23_5e134244a23e8.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"29","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_23_5e134244a23e8_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_23_5e134244a23e8.td_column_number = "3";
block_td_uid_23_5e134244a23e8.block_type = "td_block_mega_menu";
block_td_uid_23_5e134244a23e8.post_count = "4";
block_td_uid_23_5e134244a23e8.found_posts = "961";
block_td_uid_23_5e134244a23e8.header_color = "";
block_td_uid_23_5e134244a23e8.ajax_pagination_infinite_stop = "";
block_td_uid_23_5e134244a23e8.max_num_pages = "241";
tdBlocksArray.push(block_td_uid_23_5e134244a23e8);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_23_5e134244a23e8" id="td_uid_24_5e134244a309d" data-td_block_id="td_uid_23_5e134244a23e8" data-td_filter_value="" href="http://weuponithiphop.info/category/latest-news/">All</a><a class="mega-menu-sub-cat-td_uid_23_5e134244a23e8"  id="td_uid_25_5e134244a318c" data-td_block_id="td_uid_23_5e134244a23e8" data-td_filter_value="69" href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a><a class="mega-menu-sub-cat-td_uid_23_5e134244a23e8"  id="td_uid_26_5e134244a32a9" data-td_block_id="td_uid_23_5e134244a23e8" data-td_filter_value="80" href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a><a class="mega-menu-sub-cat-td_uid_23_5e134244a23e8"  id="td_uid_27_5e134244a338e" data-td_block_id="td_uid_23_5e134244a23e8" data-td_filter_value="2189" href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a><a class="mega-menu-sub-cat-td_uid_23_5e134244a23e8"  id="td_uid_28_5e134244a34a2" data-td_block_id="td_uid_23_5e134244a23e8" data-td_filter_value="10" href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a><a class="mega-menu-sub-cat-td_uid_23_5e134244a23e8"  id="td_uid_29_5e134244a35b2" data-td_block_id="td_uid_23_5e134244a23e8" data-td_filter_value="130" href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></div></div><div id=td_uid_23_5e134244a23e8 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/01/03/frank-ocean-travis-scott-rage-against-the-machine-to-headline-2020-coachella-92/" rel="bookmark" title="Frank Ocean, Travis Scott &#038; Rage Against The Machine To Headline 2020 Coachella"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/6J6CMzTAAUE6m0NGIeTsq2LU-UbsWujJDmfPaQvNXlnBLfdiLF00jbwMACwAS02Oh9D1HzcMWgT2_CM8Q_s3IahH5ICoMv7EOZaxF6hu-uA6t_qCKoBqCndRwovSiWSQcT5vOKpsB9_YzqZQtIawpTqt2Gw_KIO55eSlUX80dAsDWO7S85DkR2i19VZMPDejrrBQi7yyyu5v4T8mid8XjJU8HLa2mEWPgWsRn6tb0msuDx1nAYMpBOON7ugnxPBPIkvu1yB3gHBVIa6P14qzNMlW0c-cH_Xf95N1Qo0NAdW6YG3yPv10TkpXmTCWV3ZbcHc-vChVthEWIkCafCyM4ykIXFvw9Ev3khaYzpRfh5U2LlVG_s4soEvkPfs6GfWwMeXWxFCKelezzOz49DhDZrrjE4ZnK9iMrNEEjh1aB4TD-kRktsJqotoR_CrN6LDpVxNbphO-emiWxbpfArj-jBvj4k94-w7vdXVwNLlcpbEcdBqiRy4-uq2GP_ocWwE-WUwkcd5EcMVrxsAmHNrgfcG1KJIZHUL7Pr3wpJOTF6lB1JT1xmJWw0g6BmEFQ22hGzIzTOn45KqiXzwoEUVi0Gf-I5OAPTjVkI-QH1Gr9AGtLN5Vvr_bwcgTvNYoc_7GLJnbzC-QZ2T0tKtk0SP4cmFucnsEB5RqIsc-zGiY_WXV21jC3jTqS-QC=w500-h506-no" alt="" title="Frank Ocean, Travis Scott &#038; Rage Against The Machine To Headline 2020 Coachella"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/01/03/frank-ocean-travis-scott-rage-against-the-machine-to-headline-2020-coachella-92/" rel="bookmark" title="Frank Ocean, Travis Scott &#038; Rage Against The Machine To Headline 2020 Coachella">Frank Ocean, Travis Scott &#038; Rage Against The Machine To Headline&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/01/02/freddie-gibbs-madlib-will-release-an-instrumental-version-of-bandana/" rel="bookmark" title="Freddie Gibbs &#038; Madlib Will Release An Instrumental Version of ‘Bandana’"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/2VgtBKgZFMdJnPRcD_XQUT6si9iNoETs9We0s-h0Z8mUrCaysp2a4o8oaDs5ZwKI4jfPM0y-uT8HGyRKFgvBHEMTreELU-3qZOQnMW48dOu7Al2sRj9MHr4XcoHJQOF0s7rx_oZEM34Gbr2vKk3tdP_6oXSjHJ3xOkA9CcUwJw2n2chWBIwPwcjwKHwzOG4OSiuxd_JD1P6SjsctcHLif6dhxb0m-qFtGQGyh0Qm25IYqJwo_q7E_xPfkuNiltP-t4drOOnOiIILD_beSCMGW-v1KzjrMoQIxTjUR19EpnU1SAub9kL9kYFW05uGvMbiPBM5wXa6WaPoU0Qr3Ct5LBs1JhOAh6Hhu_IkCMmczWc8yWxk2LaxGYZ5zgtsVN794hQScGvStABGN7jkHAtFaKQNKypW5ob9ggCFcL4VS5sCxhH2rt1VqI9vGpSgTjqYthF9mIvxbF21AIuDN0NIep384qVM_6yIzazRh2T-XuoAAk8ynsk6xC7wVk5O8NT4k7mdC0_fFTzm4SyZa35YYKZ0K3tejD3VtC1zeCf_eE7lw4U0gT2sGMPQ18BlWTRhHxOApJvIWz02phKz0-j-2yhS7g-zKeiS1xWqDLllXEzO7zbz-5wItZFrbGItOb22zk_v12xmoBBT81V_Ah6WMZ21ybKg212Z890PrLPAwql7lOHOIlwo-KDr=s328-no" alt="" title="Freddie Gibbs &#038; Madlib Will Release An Instrumental Version of ‘Bandana’"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/01/02/freddie-gibbs-madlib-will-release-an-instrumental-version-of-bandana/" rel="bookmark" title="Freddie Gibbs &#038; Madlib Will Release An Instrumental Version of ‘Bandana’">Freddie Gibbs &#038; Madlib Will Release An Instrumental Version of ‘Bandana’</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/01/01/video-smino-breaks-down-the-lyrics-for-trina/" rel="bookmark" title="Video: Smino Breaks Down The Lyrics For &#8216;Trina&#8217;"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/647dhLUcrg0SjjivItx9GQjzLrZjInjxuHefEQ6m_mt9CmcgPt68xm7fgPispM37rzIpgUtLdtP3f7Thjjodg5XAdOsiTOWCG4jcaEidErrS4nCirxRg4YUQydy903sPeb9I6cSkKs5a23W1DKwLxDoBuSwwsTF7UUbCKfEgTP_Gs1Vg2oEmw0o1cxJZsRXsVqsv8-YHxt8kydCTn-EJsvRhOwO__xhZhFI6v7LnwnedUDlx5S35FqJQnvY0azZm2V8Z4r1gsEZFT2wxb7yxUF_AqUNSerZASplXbBosPo8zdNGPERWib0jaPjlXXAse1wxjK-n4J2rxsYt8Osm6im6LOL_sn1_VRAATZ584OqfI95NscwX8FkR2CROsrHoBaliy3XvG0Zrhc3FA1uIq3MqMTLZwlYTs1h3rHV9mUvoF1Q5A8TqpAWsB2XOpwp0ykODP8UjLQLWTsLl3hFJ-YRbG_YGqMKseb15glDJeBMj_O_PN8_EbSllZogpPzMKWON4aLaayO7NGcrqzSB7KJvt4pd8cgBWF2gHhJl95VHtD6f7iYLdM5jPpwc6Ij1QpOe4QJXJTiKiKQvKrglySjfM-fHocF5M2icxiUPgShTxW0Jg6qGr28A3F-zYNCNAPpKhXgUUKzBRHUdOzLgWabOLlJ9ZR3rCU0CTQXQEBVbfMJJKggFYDy_tY=w731-h523-no" alt="" title="Video: Smino Breaks Down The Lyrics For &#8216;Trina&#8217;"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/01/01/video-smino-breaks-down-the-lyrics-for-trina/" rel="bookmark" title="Video: Smino Breaks Down The Lyrics For &#8216;Trina&#8217;">Video: Smino Breaks Down The Lyrics For &#8216;Trina&#8217;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/12/25/video-juice-wrld-fire-in-the-booth-freestyle/" rel="bookmark" title="Video: Juice WRLD &#8211; Fire In The Booth Freestyle"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/gNvG-U759eS6grana24cRxwkyLDr8CqwD21KUiCyvGi2nFRJkFSXsNe4IYwBNVp9RW8kuFUOnb6Q5o1nL6aIiOz_PCPkH9apQf4vpUk5yl9zw4_kzGC14t0m47-rtTZ7KssjymiHSw96cikE9fklTbvTloanXPfzGoqvEKP7KsOQ1rxVVUNCgOAUldjYzQej7mKekIaMpggAmsj9PrNWvCGCxPzavPZuXoeAoDDjRMaE0_XLBwWoHohUYDCWNAj6Xrf7YYstOoXYWdzbW0MCnBa_gHsjJK1-N06nJkvo_05R6vhpS_mE13Xd6paPZGKyo0QXuscMYS5Du6Pn0W5dgdBE0bYijq5nh2lycIbjT3-VOTBw07GQy3zIUxJBIcZrWhrynyBxO0wkqDJT2yhbs-tI4KoHnILstFC1nDiXUxlaf0a0dLQj6U4-cL-kuqQjyOrUWgM2RbcGhDelLQ77haSfjyk4L3Bm7l0RfdMWQ0U-mY56TmF51drOTM2bVCBEMu1R0HR3PUgWVKq5_FsSBnAL50C-b2UV68MBNePscjeZkS-L2KKaBoP45Q0QOxpjLi5lE9TfhUe4_XSD7AzIzkVGD3Bkkn2w-VWE9Ti0kagZsx5wBMEVjOz7DtziFn7ES8DL2gRBZWK2_VB7Y3v9s84yswLNhz7ZPDkvDr_3PuS0HQG0khLONrAx=s758-no" alt="" title="Video: Juice WRLD &#8211; Fire In The Booth Freestyle"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/12/25/video-juice-wrld-fire-in-the-booth-freestyle/" rel="bookmark" title="Video: Juice WRLD &#8211; Fire In The Booth Freestyle">Video: Juice WRLD &#8211; Fire In The Booth Freestyle</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_23_5e134244a23e8" data-td_block_id="td_uid_23_5e134244a23e8"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_23_5e134244a23e8" data-td_block_id="td_uid_23_5e134244a23e8"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_30_5e134244b612a_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_30_5e134244b612a" ><script>var block_td_uid_30_5e134244b612a = new tdBlock();
block_td_uid_30_5e134244b612a.id = "td_uid_30_5e134244b612a";
block_td_uid_30_5e134244b612a.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"77","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_30_5e134244b612a_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_30_5e134244b612a.td_column_number = "3";
block_td_uid_30_5e134244b612a.block_type = "td_block_mega_menu";
block_td_uid_30_5e134244b612a.post_count = "4";
block_td_uid_30_5e134244b612a.found_posts = "158";
block_td_uid_30_5e134244b612a.header_color = "";
block_td_uid_30_5e134244b612a.ajax_pagination_infinite_stop = "";
block_td_uid_30_5e134244b612a.max_num_pages = "40";
tdBlocksArray.push(block_td_uid_30_5e134244b612a);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_30_5e134244b612a" id="td_uid_31_5e134244b6e90" data-td_block_id="td_uid_30_5e134244b612a" data-td_filter_value="" href="http://weuponithiphop.info/category/fashion/">All</a><a class="mega-menu-sub-cat-td_uid_30_5e134244b612a"  id="td_uid_32_5e134244b6f7e" data-td_block_id="td_uid_30_5e134244b612a" data-td_filter_value="76" href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></div></div><div id=td_uid_30_5e134244b612a class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/LVT4Mid8WL4wHUdO9X2OZmZxxgbREs2lVtszOdEBaO6hJB0JS3yQOAyhNSdCyPmv0amBDTgNGpOlRPXPjKCl6yIlo2joyH3rQRI7CUdX09BJtQI1r5jy1_7BQtDhw4AxUhpUwIh35rNS3lTy7uq-FdPff10JN6srr9mwZ7zr04GQFxBVEXwCfC5rNVehXhY_wGCRVsmevYmdkBWEmB8dvOzBHY78NBBjcHNArS_S-2M0FJgDh8v9m9vEh78k_XmZg-AERctsf0bkODuPi1EcNJq_RnJIV6b0GG-VtKjo-OVPmYghWJYf1HiP9c58cQ98oABU8BDFdLqsBtNt4K0NmyHYQlX39W9k_d83wEHZ1-EacQa2o01VrYSn12HnZ1l88fMzu9PKv6EGmcRZNwpepycW7_9EQnhxIPDdVCmRLXUasUED9OXr-zJmnBcnSnLCa06k1ZymQym1LiSFEv1c3aPHnmnD3GY8nL7q5jPJr4HsABR0WCqMebcF3HF_0deNd0zgRBCGMxW-VzlIIHZiHuBeSPEPvUL149GJ5swSSvKm1uGEi1HlLBj9omJSU7mDWzO0p_7l-l7-4_ureEsGsgB8cX1t8t2TQcFeRgqqF1CXlZFYYC2K0iMb4jPsijsw_rtO7pmKvbngqHfgYpGeh_qLmDWeicR7=w1195-h796-no" alt="" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch">Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/fHEwwMf8DoiXlqkfibQS1Z1XXbviORbV9raaI44tOTXrWo7GgqM3gA-vswE10gFtTQUGGwNG7nWAACwHjxPuiubliYBN_dqtBZh2WIpxvumiJ-hSLK0TNWB2cB8Iw2STT5gcp_KqlDh_e4xng1vidI8EXdp_ooh5uDI-JV1HQ9dGnM5nxl_b-v8znqj-Rl_mGB7y4Lu9zsFNWHU7SriqQQJaKrKEEnb9T8zxmGLaL0zq7ilYpnUEhWulDDr9xc82wdr__WzRBm5YEskVpDAnGM2NDZwTZpjbe4QDdxeixWnSXNK_oDzaL7WTbCpkD33OK88BlI5JmFRQ5VmD11UQ2htB7-9WoahHvb4XmBsbLXpEMl1JmEP4sPx06VduzFnBNo-J90WI0n1AEIIcEYVbRywrkGJXbzmH__In9ZIg0EV24OcGGbeKl12HxTdZwucqsNnuZeNjiMHISQ7i8cfzm3N7X7Zenl74zsKIKeKWoIGxh6MTlVADvgHcrHebnjcSgil2vBeFyz_AP45aOv9SOwbzfVLGS0CNfe1s9b2J7qZgjcBk9QPEXCl2kygvzmGXFvU_3xBuW6S0i3Vkh3Ha_3hPBtvIAy3WoTK2yiqS41HzSK7yk3FRAlBtpIEib338fdkTiosBxtdu36SdNUVM75zl6CVIFhTu=w681-h470-no" alt="" title="Air Jordan 14 Rip Hamilton"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton">Air Jordan 14 Rip Hamilton</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/kUjaOYxjEkAh34S-Ub2QSZwdOwHyFnGFLBZULta3_bn1_myPMAwJXiEEsAAtc1ktCQwHCuKhSqSYsWXFBEIZxdfKuykoDEZWwO-dDI3_JeAshbYvyILEHUu0XaUpRn0mj7gOx10V52t8gRGYPCW7QXGImkPGGhvBPzBDVVqh9lKGtkuPeePmTnpRSmwp0LG1WHcIzUWnMqPBWQeHAat6Q-Tq7niXNb96ddEZsMEdHK1nmHVlNaeqFBNtTxk6yYRkFNCvtfBayqy-Rqt4CPU5tThxbTI4AIUCI6JLxJd_VJizrVNDEe2xZ_tiQdkC5ASIoHpX8sfvAB8zRUsMVJ6oMUt5FH_4GBNXDCtFRmr65Qt0JV1h4bBJffu2L272Q_vpD76wn-YNGW8VCtZcheHu_X-A4gdYQEC0HN0BenY-MOuUBqKEjXAc0SxWeP7W9RN55jlqUFK0nzEYydVjec2stdQIngVfg_FvKxvHXfM4XdtMpqeJnp3Pzyk8xjz30sAZd0f2HQ6zfdPjk-OkV2-WrC0_qW0L8Rq3zrUbq52n3BN7gm7sctU_CUlBmoQIgJDQBYk1Siv4tfSq9pL1R4GdaOlWQdxEuhZi8bTYC8GGAgNGl3SMAZGvk7nu6QnnwEZjZ7mZwbcqgyRKa89cOREMUvIkVJ8Q8lZu=w926-h672-no" alt="" title="Jordan Proto React Triple White"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White">Jordan Proto React Triple White</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4cDUjSODZSaXWfHyZKb9q3Fn7FHA4uB0KSBs0MtFHC0dc6AJb1zeAl_X2LOKalK9C7VBFhTqRQ9fw1ESgUr9ZUKFbOzD94i_s96nvkICOqrsYnzrE2nEAQHoEaGOF4O8GAI6T4CGFbgcQhNzjpRlSY60NyPu5Cmq81FRpEOFRzTOtSa_NnWzMmfwO0yxtPbcg5U6YBUsus8shv3SA7CjULLfaP38nZAuWVgq8PMaaeCQ_eSrK8NJSEVQjyyxmqb-1I7zO8Kvvzvwi--ibMr52CF8h-GusBzSq5ZuzvZRCGu_u8CyfoXw7pwWbOmHnLOdcQ9d2PCSW_IxEMGfmEuU7NxMSsW3Ga4r35_wLB7cjvlPC9OjCV50tfekXjZBS_476mzlf4G9jR7Ju1GqgjXah9Uqc_0Y8N-Br8_JCtIlRSuLxAiebwd7AvFVlgWId9MYxBWnRT3cTyD8SH7q5WwO-CIbKAOSKsNcrrTgFxQvqn9yklBU1u5X5fdTlTBk4WSYorsWZAug0z9BOymRLnrhTbnA0vpBPFROWD-aL1glg-eUpFSfgD4xhWsOqJNY9krQ2UbLSGXQ5gYWj0ovLS7Yz3UKFY2qrVWpqkpbfyN98es9NJ-7LTUs2MLq1rX_2FaQmyq5mVndd7VGzQOHy9hDULG-5H-0LvGd=w900-h566-no" alt="" title="adidas Yeezy Boost 350 V2 Hyperspace"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace">adidas Yeezy Boost 350 V2 Hyperspace</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_30_5e134244b612a" data-td_block_id="td_uid_30_5e134244b612a"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_30_5e134244b612a" data-td_block_id="td_uid_30_5e134244b612a"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div>                </div>

                <div class="td-pb-span5 td-sub-footer-copy">
                    &copy; 2018 The Hip Hop Chronicles Media Group                </div>
            </div>
        </div>
    </div>
</div><!--close td-outer-wrap-->

	<div id="wpcp-error-message" class="msgmsg-box-wpcp warning-wpcp hideme"><span>error: </span>Not Prohibited. ✌️</div>
	<script>
	var timeout_result;
	function show_wpcp_message(smessage)
	{
		if (smessage !== "")
			{
			var smessage_text = '<span>Alert: </span>'+smessage;
			document.getElementById("wpcp-error-message").innerHTML = smessage_text;
			document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp showme";
			clearTimeout(timeout_result);
			timeout_result = setTimeout(hide_message, 3000);
			}
	}
	function hide_message()
	{
		document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp hideme";
	}
	</script>
		<style type="text/css">
	#wpcp-error-message {
	    direction: ltr;
	    text-align: center;
	    transition: opacity 900ms ease 0s;
	    z-index: 99999999;
	}
	.hideme {
    	opacity:0;
    	visibility: hidden;
	}
	.showme {
    	opacity:1;
    	visibility: visible;
	}
	.msgmsg-box-wpcp {
		border-radius: 10px;
		color: #555;
		font-family: Tahoma;
		font-size: 11px;
		margin: 10px;
		padding: 10px 36px;
		position: fixed;
		width: 255px;
		top: 50%;
  		left: 50%;
  		margin-top: -10px;
  		margin-left: -130px;
  		-webkit-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
		-moz-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
		box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
	}
	.msgmsg-box-wpcp span {
		font-weight:bold;
		text-transform:uppercase;
	}
	.error-wpcp {		background:#ffecec url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/error.png') no-repeat 10px 50%;
		border:1px solid #f5aca6;
	}
	.success {
		background:#e9ffd9 url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/success.png') no-repeat 10px 50%;
		border:1px solid #a6ca8a;
	}
	.warning-wpcp {
		background:#ffecec url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/warning.png') no-repeat 10px 50%;
		border:1px solid #f5aca6;
	}
	.notice {
		background:#e3f7fc url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/notice.png') no-repeat 10px 50%;
		border:1px solid #8ed9f6;
	}
    </style>


    <!--

        Theme: Newspaper by tagDiv 2016
        Version: 7.2 (rara)
        Deploy mode: deploy
        
        uid: 5e134244c01e9
    -->

    <link rel='stylesheet' id='so-css-Newspaper-css'  href='http://weuponithiphop.info/wp-content/uploads/so-css/so-css-Newspaper.css?ver=1528674688' type='text/css' media='all' />
<link rel='stylesheet' id='soliloquy-lite-style-css'  href='http://weuponithiphop.info/wp-content/plugins/soliloquy-lite/assets/css/soliloquy.css?ver=2.5.7' type='text/css' media='all' />
<link rel='stylesheet' id='soliloquy-liteclassic-theme-css'  href='http://weuponithiphop.info/wp-content/plugins/soliloquy-lite/themes/classic/style.css?ver=2.5.7' type='text/css' media='all' />
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/themes/Newspaper/js/tagdiv_theme.js?ver=7.2'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/comment-reply.min.js?ver=4.9.13'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/wp-embed.min.js?ver=4.9.13'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/plugins/soliloquy-lite/assets/js/min/soliloquy-min.js?ver=2.5.7'></script>

<!-- JS generated by theme -->

<script>
    


            

	            // if the theme has tdBackstr support, it means this already uses it
                if ( 'undefined' !== typeof window.tdBackstr ) {

                    (function(){
                        // the site background td-backstretch jquery object is dynamically added in DOM, and after any translation effects are applied over td-backstretch
                        var wrapper_image_jquery_obj = jQuery( '<div class=\'backstretch\'></div>' );
                        var image_jquery_obj = jQuery( '<img class=\'td-backstretch not-parallax\' src=\'http://weuponithiphop.info/wp-content/uploads/city-skyline-1.png\'>' );

                        wrapper_image_jquery_obj.append( image_jquery_obj );

                        jQuery( 'body' ).prepend( wrapper_image_jquery_obj );

                        var td_backstr_item = new tdBackstr.item();

                        td_backstr_item.wrapper_image_jquery_obj = wrapper_image_jquery_obj;
                        td_backstr_item.image_jquery_obj = image_jquery_obj;

	                    tdBackstr.add_item( td_backstr_item );

                    })();
                }

            
            
jQuery(window).ready(function() {
(function(){
var td_backstr_item = new tdBackstr.item();
td_backstr_item.wrapper_image_jquery_obj = jQuery( "#td-full-screen-header-image" );
td_backstr_item.image_jquery_obj = td_backstr_item.wrapper_image_jquery_obj.find( 'img:first' );
tdBackstr.add_item( td_backstr_item );
jQuery('.td-read-down a').click(function(event){
event.preventDefault();
var header_wrap = jQuery( '.td-full-screen-header-image-wrap:first' )
if ( 1 === header_wrap.length ) {
tdUtil.scrollToPosition(header_wrap.height() + header_wrap.offset().top, 1200);
}
});
})();
});

                jQuery().ready(function jQuery_ready() {
                    tdAjaxCount.tdGetViewsCountsAjax("post","[36391]");
                });
            

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'http://weuponithiphop.info/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'http://weuponithiphop.info/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>

			<script type="text/javascript">
			if ( typeof soliloquy_slider === 'undefined' || false === soliloquy_slider ) {soliloquy_slider = {};}jQuery('#soliloquy-container-30342').css('height', Math.round(jQuery('#soliloquy-container-30342').width()/(960/300)));jQuery(window).load(function(){var $ = jQuery;var soliloquy_container_30342 = $('#soliloquy-container-30342'),soliloquy_30342 = $('#soliloquy-30342');soliloquy_slider['30342'] = soliloquy_30342.soliloquy({slideSelector: '.soliloquy-item',speed: 0,pause: 2000,auto: 1,useCSS: 0,keyboard: true,adaptiveHeight: 1,adaptiveHeightSpeed: 400,infiniteLoop: 1,mode: 'fade',pager: 1,controls: 1,nextText: '',prevText: '',startText: '',stopText: '',onSliderLoad: function(currentIndex){soliloquy_container_30342.find('.soliloquy-active-slide').removeClass('soliloquy-active-slide').attr('aria-hidden','true');soliloquy_container_30342.css({'height':'auto','background-image':'none'});if ( soliloquy_container_30342.find('.soliloquy-slider li').length > 1 ) {soliloquy_container_30342.find('.soliloquy-controls').fadeTo(300, 1);}soliloquy_30342.find('.soliloquy-item:not(.soliloquy-clone):eq(' + currentIndex + ')').addClass('soliloquy-active-slide').attr('aria-hidden','false');soliloquy_container_30342.find('.soliloquy-clone').find('*').removeAttr('id');soliloquy_container_30342.find('.soliloquy-controls-direction').attr('aria-label','carousel buttons').attr('aria-controls', 'soliloquy-container-30342');soliloquy_container_30342.find('.soliloquy-controls-direction a.soliloquy-prev').attr('aria-label','previous');soliloquy_container_30342.find('.soliloquy-controls-direction a.soliloquy-next').attr('aria-label','next');},onSlideBefore: function(element, oldIndex, newIndex){soliloquy_container_30342.find('.soliloquy-active-slide').removeClass('soliloquy-active-slide').attr('aria-hidden','true');$(element).addClass('soliloquy-active-slide').attr('aria-hidden','false');},onSlideAfter: function(element, oldIndex, newIndex){},});});			</script>
			
</body>
</html>