<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>Music Video: Jhené Aiko ft. Future &amp; Miguel – Happiness Over Everything (H.O.E.)</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="http://weuponithiphop.info/xmlrpc.php" />
    <meta property="og:image" content="https://lh3.googleusercontent.com/YBkMcHo-YVBrmF6_KiwWJS6jY6WdMmcxpOvEUegwJOCxtOvRjDt6NcCLMhqRPTG5kPQaLzCgaePKiUuVcZ6LUljvRRR9UFdqUqn9H10gXPxdBLgoxkqhfEFPoSe280ZoyBSoqSAs3g-UlrgaGH9PRbmyIGVGEy7uwpyIRBytpVqEqlcUsFZ-ARfTWaFEUo1YPi6nddHhMr6luvemMhAy4IFzb1XwNS__u9az5RzJ9gOWBUZ8f19VI8LKCpKYtY_hCqUh8W1hOhUwRMCTF9SsA2nBxMmHpwAWUSHmSIjMDVtq7aR3H9kEOsNw29jrhw_EE04Lu3EH-F9NbRRRdNH6LAzMB7ALtTlRrd9Sca4F1KYK_TjVJaZUqSRHcDJO4Chj0WIfbX8_mGue3MlWh4F4DHaxPZfS0tucBq8OyVmOuBMtsT_3e5cLD3t2pUcpOy34ftauAOcjIpE4eZqAffd9__OAspu-a8EqFmuYtkjLW6dEzxEfRcScYZOvmZrV4L1zXcNtw9gtuff3EO6N5SvLZhDReBvxAOX3WvhJewT02SnXNh00sECQVYzA9dsG9lb-EL2jBJko-KZS11HlxSzbZDIAcZSTIf9UrExnrehLFfil-S59C7b0O_ZukOeurfsBig0XDKx78bunZ47EA9mEcSNNyIiQo64E3_fZx92-CC9S8-5Q-_yYzirr=w754-h535-no" /><meta name="author" content="cyclone">
<link rel="icon" type="image/png" href="http://weuponithiphop.info/wp-content/uploads/weuponitlogoCAP-500x457.png">
<!-- All in One SEO Pack 3.3.4 by Michael Torbert of Semper Fi Web Design[208,317] -->
<script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"http://weuponithiphop.info/#organization","url":"http://weuponithiphop.info/","name":"WeUpOnIt","sameAs":[]},{"@type":"WebSite","@id":"http://weuponithiphop.info/#website","url":"http://weuponithiphop.info/","name":"WeUpOnIt","publisher":{"@id":"http://weuponithiphop.info/#organization"}},{"@type":"WebPage","@id":"http://weuponithiphop.info/2020/02/28/music-video-jhene-aiko-ft-future-miguel-happiness-over-everything-h-o-e/#webpage","url":"http://weuponithiphop.info/2020/02/28/music-video-jhene-aiko-ft-future-miguel-happiness-over-everything-h-o-e/","inLanguage":"en-US","name":"Music Video: Jhen\u00e9 Aiko ft. Future &#038; Miguel &#8211; Happiness Over Everything (H.O.E.)","isPartOf":{"@id":"http://weuponithiphop.info/#website"},"datePublished":"2020-02-28T10:57:55+00:00","dateModified":"2020-02-28T10:57:55+00:00"},{"@type":"Article","@id":"http://weuponithiphop.info/2020/02/28/music-video-jhene-aiko-ft-future-miguel-happiness-over-everything-h-o-e/#article","isPartOf":{"@id":"http://weuponithiphop.info/2020/02/28/music-video-jhene-aiko-ft-future-miguel-happiness-over-everything-h-o-e/#webpage"},"author":{"@id":"http://weuponithiphop.info/author/cyclone/#author"},"headline":"Music Video: Jhen\u00e9 Aiko ft. Future &#038; Miguel &#8211; Happiness Over Everything (H.O.E.)","datePublished":"2020-02-28T10:57:55+00:00","dateModified":"2020-02-28T10:57:55+00:00","commentCount":0,"mainEntityOfPage":{"@id":"http://weuponithiphop.info/2020/02/28/music-video-jhene-aiko-ft-future-miguel-happiness-over-everything-h-o-e/#webpage"},"publisher":{"@id":"http://weuponithiphop.info/#organization"},"articleSection":"Music Video, Future, Jhen\u00e9 Aiko, Miguel"},{"@type":"Person","@id":"http://weuponithiphop.info/author/cyclone/#author","name":"cyclone","sameAs":[],"image":{"@type":"ImageObject","@id":"http://weuponithiphop.info/#personlogo","url":"http://0.gravatar.com/avatar/6a747aaba64ebc36f309e25ac7e460e6?s=96&d=mm&r=g","width":96,"height":96,"caption":"cyclone"}}]}</script>
<link rel="canonical" href="http://weuponithiphop.info/2020/02/28/music-video-jhene-aiko-ft-future-miguel-happiness-over-everything-h-o-e/" />
<!-- All in One SEO Pack -->
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Feed" href="http://weuponithiphop.info/feed/" />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Comments Feed" href="http://weuponithiphop.info/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Music Video: Jhené Aiko ft. Future &#038; Miguel &#8211; Happiness Over Everything (H.O.E.) Comments Feed" href="http://weuponithiphop.info/2020/02/28/music-video-jhene-aiko-ft-future-miguel-happiness-over-everything-h-o-e/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/weuponithiphop.info\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.13"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='google_font_open_sans-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;ver=4.9.13' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_roboto-css'  href='http://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C900%2C500italic%2C400%2C300&#038;ver=4.9.13' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='http://fonts.googleapis.com/css?family=Roboto+Condensed%3A400%2C700&#038;ver=4.9.13' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='http://weuponithiphop.info/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=4.12' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='http://weuponithiphop.info/wp-content/themes/Newspaper/style.css?ver=7.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css'  href='http://weuponithiphop.info/wp-content/themes/Newspaper/includes/demos/what/demo_style.css?ver=7.2' type='text/css' media='all' />
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1'></script>
<link rel='https://api.w.org/' href='http://weuponithiphop.info/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://weuponithiphop.info/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://weuponithiphop.info/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Music Video: DJ Drama ft. Westside Gunn, Lule, &#038; Rick Ross &#8211; 350' href='http://weuponithiphop.info/2020/02/28/music-video-dj-drama-ft-westside-gunn-rick-ross-350/' />
<meta name="generator" content="WordPress 4.9.13" />
<link rel='shortlink' href='http://weuponithiphop.info/?p=37119' />
<link rel="alternate" type="application/json+oembed" href="http://weuponithiphop.info/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fweuponithiphop.info%2F2020%2F02%2F28%2Fmusic-video-jhene-aiko-ft-future-miguel-happiness-over-everything-h-o-e%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://weuponithiphop.info/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fweuponithiphop.info%2F2020%2F02%2F28%2Fmusic-video-jhene-aiko-ft-future-miguel-happiness-over-everything-h-o-e%2F&#038;format=xml" />

<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>
<script id="wpcp_disable_selection" type="text/javascript">
//<![CDATA[
var image_save_msg='You Can Not Save images!';
	var no_menu_msg='Context Menu disabled!';
	var smessage = "Not Prohibited. ✌️";

function disableEnterKey(e)
{
	if (e.ctrlKey){
     var key;
     if(window.event)
          key = window.event.keyCode;     //IE
     else
          key = e.which;     //firefox (97)
    //if (key != 17) alert(key);
     if (key == 97 || key == 65 || key == 67 || key == 99 || key == 88 || key == 120 || key == 26 || key == 85  || key == 86 || key == 83 || key == 43)
     {
          show_wpcp_message('You are not allowed to copy content or view source');
          return false;
     }else
     	return true;
     }
}

function disable_copy(e)
{	
	var elemtype = e.target.nodeName;
	var isSafari = /Safari/.test(navigator.userAgent) && /Apple Computer/.test(navigator.vendor);
	elemtype = elemtype.toUpperCase();
	var checker_IMG = '';
	if (elemtype == "IMG" && checker_IMG == 'checked' && e.detail >= 2) {show_wpcp_message(alertMsg_IMG);return false;}
	if (elemtype != "TEXT" && elemtype != "TEXTAREA" && elemtype != "INPUT" && elemtype != "PASSWORD" && elemtype != "SELECT" && elemtype != "OPTION" && elemtype != "EMBED")
	{
		if (smessage !== "" && e.detail == 2)
			show_wpcp_message(smessage);
		
		if (isSafari)
			return true;
		else
			return false;
	}	
}
function disable_copy_ie()
{
	var elemtype = window.event.srcElement.nodeName;
	elemtype = elemtype.toUpperCase();
	if (elemtype == "IMG") {show_wpcp_message(alertMsg_IMG);return false;}
	if (elemtype != "TEXT" && elemtype != "TEXTAREA" && elemtype != "INPUT" && elemtype != "PASSWORD" && elemtype != "SELECT" && elemtype != "OPTION" && elemtype != "EMBED")
	{
		//alert(navigator.userAgent.indexOf('MSIE'));
			//if (smessage !== "") show_wpcp_message(smessage);
		return false;
	}
}	
function reEnable()
{
	return true;
}
document.onkeydown = disableEnterKey;
document.onselectstart = disable_copy_ie;
if(navigator.userAgent.indexOf('MSIE')==-1)
{
	document.onmousedown = disable_copy;
	document.onclick = reEnable;
}
function disableSelection(target)
{
    //For IE This code will work
    if (typeof target.onselectstart!="undefined")
    target.onselectstart = disable_copy_ie;
    
    //For Firefox This code will work
    else if (typeof target.style.MozUserSelect!="undefined")
    {target.style.MozUserSelect="none";}
    
    //All other  (ie: Opera) This code will work
    else
    target.onmousedown=function(){return false}
    target.style.cursor = "default";
}
//Calling the JS function directly just after body load
window.onload = function(){disableSelection(document.body);};
//]]>
</script>
	<script id="wpcp_disable_Right_Click" type="text/javascript">
	//<![CDATA[
	document.ondragstart = function() { return false;}
	/* ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
	Disable context menu on images by GreenLava Version 1.0
	^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ */
	    function nocontext(e) {
	       return false;
	    }
	    document.oncontextmenu = nocontext;
	//]]>
	</script>
<!-- Analytics by WP-Statistics v12.6.12 - https://wp-statistics.com/ -->
<!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]-->
<!-- JS generated by theme -->

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var tds_login_sing_in_widget="show";
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_ajax_url="http:\/\/weuponithiphop.info\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=7.2";
var td_get_template_directory_uri="http:\/\/weuponithiphop.info\/wp-content\/themes\/Newspaper";
var tds_snap_menu="snap";
var tds_logo_on_sticky="show_header_logo";
var tds_header_style="5";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#dd3333";
var tds_smart_sidebar="enabled";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>


<!-- Header style compiled by theme -->

<style>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</style>

<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>

<body class="post-template-default single single-post postid-37119 single-format-standard unselectable music-video-jhene-aiko-ft-future-miguel-happiness-over-everything-h-o-e td-what single_template_7 wpb-js-composer js-comp-ver-4.12 vc_responsive td-boxed-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
                    <div class="td-menu-login-section">
                
    <div class="td-guest-wrap">
        <div class="td-menu-avatar"><div class="td-avatar-container"><img alt='' src='http://1.gravatar.com/avatar/?s=80&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo avatar-default' height='80' width='80' /></div></div>
        <div class="td-menu-login"><a id="login-link-mob">Sign in</a></div>
    </div>
            </div>
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-top-menu-container"><ul id="menu-top-menu" class="td-mobile-main-menu"><li id="menu-item-317" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a></li>
<li id="menu-item-706" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a></li>
<li id="menu-item-314" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a></li>
<li id="menu-item-316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-0" class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></li>
</ul>
</li>
<li id="menu-item-705" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></li>
</ul>
</li>
<li id="menu-item-18581" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li id="menu-item-3199" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
            <div id="login-form-mobile" class="td-register-section">
            
            <div id="td-login-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-login-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign in</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
	                <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
	                <div class="td-login-info-text"><a href="#" id="forgot-pass-link-mob">Forgot your password?</a></div>
                </div>
            </div>

            

            <div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
                <!-- close button -->
	            <div class="td-forgot-pass-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Password recovery</div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title">Recover your password</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
	                <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
                </div>
            </div>
        </div>
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="http://weuponithiphop.info/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap">
    
        <!--
Header style 5
-->

<div class="td-header-wrap td-header-style-5">

    <div class="td-header-top-menu-full">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div >

                Friday, February 28, 2020
            </div>
        </div>
    <ul class="top-header-menu td_ul_login"><li class="menu-item"><a class="td-login-modal-js menu-item" href="#login-form" data-effect="mpf-td-login-effect">Sign in / Join</a><span class="td-sp-ico-login td_sp_login_ico_style"></span></li></ul><div class="menu-top-container"><ul id="menu-main" class="top-header-menu"><li id="menu-item-79" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-79"><a href="http://weuponithiphop.info">Home</a></li>
<li id="menu-item-81" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-81"><a target="_blank" href="http://weuponitradio.com">Power 105.1 WeUpOnIt Radio</a></li>
<li id="menu-item-80" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-80"><a target="_blank" href="https://shop.spreadshirt.com/freshandcleantees/">Shop</a></li>
<li id="menu-item-18582" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18582"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li id="menu-item-18583" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18583"><a href="http://weuponithiphop.info/privacy-policy-2/">Privacy Policy</a></li>
</ul></div></div>
        <div class="td-header-sp-top-widget">
    
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div>
    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <ul class="td-login-tabs">
                        <li><a id="login-link" class="td_login_tab_focus">LOG IN</a></li>
                    </ul>



                    <div class="td-login-wrap">
                        <div class="td_display_err"></div>

                        <div id="td-login-div" class="">
                            <div class="td-login-panel-title">Welcome! Log into your account</div>
                            <input class="td-login-input" type="text" name="login_email" id="login_email" placeholder="your username" value="" required>
                            <input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" placeholder="your password" required>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Log In">


                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password?</a></div>


                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-display-none">
                            <div class="td-login-panel-title">Recover your password</div>
                            <input class="td-login-input" type="text" name="forgot_email" id="forgot_email" placeholder="your email" value="" required>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Pass">
                        </div>




                    </div>
                </div>
                        </div>
    </div>

    <div class="td-header-menu-wrap-full">
        <div class="td-header-menu-wrap">
            <div class="td-container td-header-row td-header-main-menu black-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-menu">
        		<a class="td-mobile-logo td-sticky-header" href="http://weuponithiphop.info/">
			<img class="td-retina-data" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-5.png" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-5.png" alt=""/>
		</a>
			<a class="td-header-logo td-sticky-header" href="http://weuponithiphop.info/">
			<img class="td-retina-data" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" alt=""/>
			<span class="td-visual-hidden">WeUpOnIt</span>
		</a>
	    </div>
    <div class="menu-top-menu-container"><ul id="menu-top-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-mega-menu menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_1_5e591c2da2e79_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_1_5e591c2da2e79" ><script>var block_td_uid_1_5e591c2da2e79 = new tdBlock();
block_td_uid_1_5e591c2da2e79.id = "td_uid_1_5e591c2da2e79";
block_td_uid_1_5e591c2da2e79.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"43","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_1_5e591c2da2e79_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_1_5e591c2da2e79.td_column_number = "3";
block_td_uid_1_5e591c2da2e79.block_type = "td_block_mega_menu";
block_td_uid_1_5e591c2da2e79.post_count = "5";
block_td_uid_1_5e591c2da2e79.found_posts = "2810";
block_td_uid_1_5e591c2da2e79.header_color = "";
block_td_uid_1_5e591c2da2e79.ajax_pagination_infinite_stop = "";
block_td_uid_1_5e591c2da2e79.max_num_pages = "562";
tdBlocksArray.push(block_td_uid_1_5e591c2da2e79);
</script><div id=td_uid_1_5e591c2da2e79 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/27/new-music-swae-lee-someone-said/" rel="bookmark" title="New Music: Swae Lee &#8211; Someone Said"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/AC89OJ2O7MoIM4tot9V2mKy4X2xmzZwlA63K-l3xrIZP-Md6a0wADsIlC3utTeHNWqdg2ctZVfsJJgsxr-gsRAOEG9ZeNQV0QNrcrJuBqD4xiAsrOu8QrK8Volw2lRk8DhYslVg3H5mZRIrvfaJ2ZxC0hWvKS7FO74QsszPbbCasQlHzuFjlNfSQ1pXgM-XS7XVkvJ6OHUkpjfwJUSZOiEU5Nmk9OAaF9Vt4Q8SFXCo9pUR1pyszX6tII5ynALuzJcJHGWjnkzNriPKk0LdZXkB94qZMG41oFK7vjU_Qii1aRXGQyKGOOs861gejOJJ88cFpC2ElcR_7lml5PQwsjY2BDEDXGA1CYScZZjtA_a21Z6Kt141Im0ru0paIc1aVXuf4ccsNrercDzpNQ-ZTX3_nqmj-l4WO5Z0RiSyaWTe3EbeR5p9pgCzNq746hj4ibv2GrSBm25FpL6JFwZ89SR6CupVYbT1ihAGA79OdG7ZBWSp8ZfpmtcPit_-qirLyanniTwWw-63-8oItriDqFabARs53Jm70M2fpvbSTQPL-jKhXjqQppNRpKliwbLucKFG3XFW_BYtZ7HGIRIaE6v0h4KzDuSRtGobDrK264IAZq3gn3fWvZm5spjpDootNVfQPUNcEKiagROVJzluGC7D-Ec1par6RafzIe8qzC7vsTehe3guFiNrQ=s758-no" alt="" title="New Music: Swae Lee &#8211; Someone Said"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/27/new-music-swae-lee-someone-said/" rel="bookmark" title="New Music: Swae Lee &#8211; Someone Said">New Music: Swae Lee &#8211; Someone Said</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/25/new-music-injury-reserve-hoodwinked/" rel="bookmark" title="New Music: Injury Reserve &#8211; Hoodwinked"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/d7_er6cqkVycz7vKPZDk7DAxZxDJi3GksGyr7jDJKb0JJw67fIwivvim6_DI10XJpdLTNeNY7lkjz-3Hrc5q7Pk7qKk4dth_SnpQZYiWB72hBPepiwkVC0NofP4igRbb5s1oZts-dBCmZjl3C4S0b4hDdtd07ivcxy1ymlG3t8a4r4oHvO44Y3vbtuGbVul5Y9u4QI5H7izaAaNPtcJbW_oiVFiwijXq-LxaZcavEuvJiG558PiBhtXnHpcup-zH0vqK98sQfiyjQ_G2LXpYEh2-wB4quGO5H9rrUf8hLYgXIlYZ1wdVYbknXnqTDEWr-IehS4Y1g0BCZ_P5aI-RxqFoIwoUVpvU3ckmwoTxpQVJo6nNJTsiK95sKSvHpgFhrCstFrY_ch2OROHi_S2cS_1_tiSHGvkeZ6vXmVgrYDoTRhfeV3Jci8BVTzOr8zP3lbcHuQzScA4SccV7bxCPNsKO3IDHCt5IUGxvY0eg8h2PyymsYAmV22ml-fNncyCbLxePStciezD-t-76-kXdszFfyL4IEerwvuveSLzzgLJc8nYFmr8sRg22SZlUSrIQEH94YqrZhjPiS1aToVqo2fRfLSnLF-EjYfTLJEzN-G3DGcbMC3oIcFjoIAuY3TBhMOgzR8Rzv1h11g1wTh0FG3RruFGc_jfTxU-eovqNMtUMAziiQ7Ky_V0I=s700-no" alt="" title="New Music: Injury Reserve &#8211; Hoodwinked"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/25/new-music-injury-reserve-hoodwinked/" rel="bookmark" title="New Music: Injury Reserve &#8211; Hoodwinked">New Music: Injury Reserve &#8211; Hoodwinked</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/25/new-music-m-dot-the-atonement-prod-by-pete-rock/" rel="bookmark" title="New Music: M-Dot &#8211; The Atonement (Prod. By Pete Rock)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/ZTXRSzhejV4E9kel3YxTQ5LdeGXguXCAcnb4iRCo4wrGFpgY2WkQvDafNJeyW8pbBuyVb24hMsZGtL04WRf4RpKXhXLy_T_EJ9kzph5GnyKdkanVPRfz-C7VDZJXg1nKWZJXJKYyfJ9mDro_t4NXX8UmnQA9YBK7VN55IoNf8lqPMGLe8cpr4kL7sEiSFeQ7Kve-RzfwU4BEFF0t5B4NASwMr2inHu4HBEgE312sh7MgbaF1hOR39FMpOjAHqK9OSrQeD50gZgiPhtAL8IlmiEkMCjczCrjWEthjjz5PYSCFbdKjvJ6hSR3a78QMJfH7Ynv8Y5klZsWEqRnXG-AZnrQM-lh62rgJnjFNwnGCwyPAMu6ndg8LSjTV-ujN2Mq33sVa7LyVi-nCcl842TnRtkeMPAnOONlJdLQlfQ01zM7D4lGvqVYo_UipncGNMn1U46U3siVNrk3TDzCnBT_87cgJ0Cvpl5-g5k3ZLecanOfPCM16XTx3SSi885czbv-FTYyvnhCEwV9jhhpbKpIQG3guG5Xt1uIhDFtv-yEbh_9P1kvjbs1xyKfahivX5f14GnQXnJ9pwbBEjDR3Ak8cU1VqTl4-5CxRZTpQX2jckXyvtJoiLjOWJ_FH9_ADngW6fOPGXdwOH6lv1YvOonrK8B2tbdwS2_p-DXLfGbVZXpOSev5oITMpSLj4=s650-no" alt="" title="New Music: M-Dot &#8211; The Atonement (Prod. By Pete Rock)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/25/new-music-m-dot-the-atonement-prod-by-pete-rock/" rel="bookmark" title="New Music: M-Dot &#8211; The Atonement (Prod. By Pete Rock)">New Music: M-Dot &#8211; The Atonement (Prod. By Pete Rock)</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/25/new-music-thurz-two-on-the-ten/" rel="bookmark" title="New Music: THURZ &#8211; Two On The Ten"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/MvaiDaBbEw9gQSNncaPxIoqAW-KgctYJfTmOA4zVrDmPQOT4oC6WR9AKkhm_CCnSfTnljZBMOPi_N4h-92uJMSwL1y60HVlpOV4UtzPwsFnuegBNV4ZDuCbRfIWq3vcaEyAmd1L2hWhvEP16qBWCYt6oYd6dQNY46pFtXcGSu7vYTVlb1RUmcw7XdjJN83T0oQ23CPBoTf4W9Wpcl3Tm8bKrDnP1HjmDvO78WLFjmy6_3o_Xt54ytC5KAIgI_BIDfgWaWlzvk_l-YV1yHs4j1grIVa-3Jg7v9DtMr2WofqVVQ-bRdcHHQ8d20ZgMZ9jg_y9InYwcWxjQNm4MlyIPZjYCfSYp98VLtzxvqDZw3Q6-eOmU9C6kGyWfkAmXpIX1lXfvKfR4NaMwXG6_z8J3DtRNnxAfiVDjt0FfD9FDnuX-uRWOd338gkn2taylEX9jSSESeUroXjZlUsy6XPqzIbDj_aRuNZqX3MdeKCihArCMtEavrEbMPd_U57c9VNbJgCtDa4JF5n2SF8CYcSrFR5cQydpCWCAoNEJyygglJHCNGBrbDjSYp0G--yw0_5sNG0r-J5y90Ve81MkSTVmQ8tLTp0gwisCUaEQmbzNAnYhp0ezjK-pdnQ0CcyrUWI90QGbLaSbFNJ4N3zUg0d4vRuA5UfoQ-_DnIEV-7gWhxCWdm1fFneKKM1un=s500-no" alt="" title="New Music: THURZ &#8211; Two On The Ten"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/25/new-music-thurz-two-on-the-ten/" rel="bookmark" title="New Music: THURZ &#8211; Two On The Ten">New Music: THURZ &#8211; Two On The Ten</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/24/new-music-yfn-lucci-ft-jackboy-fuk-it/" rel="bookmark" title="New Music: YFN Lucci ft. JackBoy &#8211; Fu*k It"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/HJil6cRRCBLuTaYqeY6Q5br0p-WgYrgMdOLdEhxdfiJVIusLLxsAcni3N6pcbRAIj4ZH2ne0iQys7nZe7loEMFvDPx4GOG_MdfTeFVdMVkYIHKkYJWvOhUPWqiAKoVztoBRvbXzeHYzvytwnUmxhhMtBdhx7JWcu9hwFVpKgH0x3rNb50EGlI48rYc3HKQC6MRq8jeArW-VT-_vEDC4YzJWKdHEX-53BFTFV4PbiXrOc7uGEXTMV0qA4NMGpXSDVkFwJ8MNLdKLPmRo3qZ0haMv5XxkP8rn91wzHNIBfZudbz5VlTrF2FaONTt63dB_luzs4zV4gP8NBUl-ZTJY-__g10g0YLtvTBnK2_Rd2apLZsjlhSjiwISjQneZzqPBjYgc5Mz4H0Sl_5tLZMLDA-zQCSnixK-UheKButA4X8u8h8yG6AZu0HNZs-ke2BT0HKr8akxLTjHIvrGo_LTBtQo9pnkYxrBrBFqTnGNlF3Ze2PuVwabqsYisCGKRoXcLIzC23KaH1jtS5LvodKBo6CcikTpdbrRN26Y03Jtk06WvzhKszTIG9Q1L_f1veQfU_hxfcvGmWG3IU3EFQ54dqd1Bx0Gieg9w-3iuHNdDCDNX-IG1Bh7jKmTrvz1cu1Zvz2EeMZNW_J4fWoq47AbpVcfkn_FCcL-F48WWYbCvq57y2JpdesjGWG8Il=s758-no" alt="" title="New Music: YFN Lucci ft. JackBoy &#8211; Fu*k It"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/24/new-music-yfn-lucci-ft-jackboy-fuk-it/" rel="bookmark" title="New Music: YFN Lucci ft. JackBoy &#8211; Fu*k It">New Music: YFN Lucci ft. JackBoy &#8211; Fu*k It</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_5e591c2da2e79" data-td_block_id="td_uid_1_5e591c2da2e79"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_1_5e591c2da2e79" data-td_block_id="td_uid_1_5e591c2da2e79"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_2_5e591c2da6f61_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_2_5e591c2da6f61" ><script>var block_td_uid_2_5e591c2da6f61 = new tdBlock();
block_td_uid_2_5e591c2da6f61.id = "td_uid_2_5e591c2da6f61";
block_td_uid_2_5e591c2da6f61.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"97","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_2_5e591c2da6f61_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_2_5e591c2da6f61.td_column_number = "3";
block_td_uid_2_5e591c2da6f61.block_type = "td_block_mega_menu";
block_td_uid_2_5e591c2da6f61.post_count = "5";
block_td_uid_2_5e591c2da6f61.found_posts = "986";
block_td_uid_2_5e591c2da6f61.header_color = "";
block_td_uid_2_5e591c2da6f61.ajax_pagination_infinite_stop = "";
block_td_uid_2_5e591c2da6f61.max_num_pages = "198";
tdBlocksArray.push(block_td_uid_2_5e591c2da6f61);
</script><div id=td_uid_2_5e591c2da6f61 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/28/album-stream-lil-baby-my-turn/" rel="bookmark" title="Album Stream: Lil Baby &#8211; My Turn"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/MofR_oL3_qmfuCntuZJbSgoHmz9Lh7vlOxLDzjeZuWDguqe31xUpnWXB-JBH9pZBC_NC_gupWXaDCa6S2JCoclf6PwAy5j8JMC7dYiPHklOzY17AplvYDpIABoDomjoM46kJrNnXc23F4VwoBMyccW8uLvdq-MWUVykzE6e_bh59Jb_nXQfhjM7QDfCmnuUGXoGkcafS1sTvd-piHngUtNES_wPQwmZNhjJO77AlRwm4jo8OFdTezaa54E3ZVprgpFuwA3VJh2G3ck3uT6KaCALHb7pDJWtJt4oHDjOWWTrSr6qz5A7ewxzmnZgYXkIcZRvf9ID38rcRDuHwKQFEOoyAvkQUXae5BsMpoxlIYIiAcyJ4eSKofbD_cZh40nqdaPXU3286nA5I05FrsDKTM384pvOs9ti0XJJgCrwjuVlnj9j2GcPDUDuNAez5Wjds_oxA7_ri_5y2dj6ONA7Lo5rXyZau8lg9zYzW9-XA_fyA5mQ2qgAY_9gO8o9oSzQrCASttKXFaibEdrS23oICj0EIZua9k3eA3NEYQ_sYA_Bu7JZYD-jXBUZty9S7PL8cJnPrEaEJoCz9ZQOy3SE-ukwWzOE43qfjsfZbOfXUNKobWmBCd9ovqrQo8P1zUUfS3TiPA2L4DMvTtudWsKt4jDO33UiCv3whJZ6x4z8zD-WzXnzs_WU58Oxe=s500-no" alt="" title="Album Stream: Lil Baby &#8211; My Turn"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/28/album-stream-lil-baby-my-turn/" rel="bookmark" title="Album Stream: Lil Baby &#8211; My Turn">Album Stream: Lil Baby &#8211; My Turn</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/24/ep-stream-deniro-farrar-sole-food/" rel="bookmark" title="EP Stream: Deniro Farrar &#8211; Sole Food"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/EFv-vhjCINN7VJmQjaAvv8RCrlVYsgwf21X66fH2PdHAly4Zo_uUOPJ1fxEN3oMztmFdKUkc6JqlfXT_0hb-MukaOktuZ0fzOzSROaqinyPJFzrQQAdio-_BoCpVacdj6oJPB41282qttDqS9JpDlpKI5LuZTHrNx4PhJtG7hV3MAF5D4ACG3z9vCNG3X1uJYnTUYUqscImJi36ylBOc55uzTJIc0xGDtW2N3c8Zp5PicFzGZtWe1hS1pcq86xYHp6tXD8sirlyJDIZTKSq1xyeyWjapjwMYZCaZdEGxo3pq4FO1FnOrUQioSbI1rdA9lTTn4gpQyhJJdI79UyZea6ffQIjWqLnyvqWJ-O25pexjCaENsTFZU9XeV7Obs-PHiaImlnpGffAjL7CXVCUBFRB3fKn5dui6HMJhA5-FLfkGpGRlRy2aqoOMo1Ob9-XsP9tlnXXW9hVgzTClWmhKz90ZvYBPAyN13jsDuOrgY9wdac3y9JYXFeaj-oUMERxfs5wLvFNrKaFzeNxATAuF2_V1BTs5OYOF6Gu0ThJ-TWukngT0S2tiGtR_Wv-P0F4Bid5Ft4DmrcSQrXZMb7inbcquv-dv6SDw6S65BxURuBGwfTnjgvYXPabsZjisNaIArPeSbHmJVJaeiN9fT30ydU2kIJ4d5HNjzN_DEfEwrkcyzu8FiuiWSfn3=s500-no" alt="" title="EP Stream: Deniro Farrar &#8211; Sole Food"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/24/ep-stream-deniro-farrar-sole-food/" rel="bookmark" title="EP Stream: Deniro Farrar &#8211; Sole Food">EP Stream: Deniro Farrar &#8211; Sole Food</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/23/album-stream-elcamino-38-spesh-martyrs-prayer/" rel="bookmark" title="Album Stream: ElCamino &#038; 38 Spesh &#8211; Martyr’s Prayer"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/gQl44Ura44x-Dy8mzRVjv_DpCE8U_FaRl6klOTQDMt-vc5cgM-aS1zfbQBImNqv9ysZiiucEZaAU1LzWd5ZEaFsgtrFm5FHETUdHwjqH1OXdd8iKB_MfqJpEZtGuzLmsBWfYbjQko1kaYZe_--kClaGK5vqDdnVXnxm9nqgudIr11jEPQEtPkx2xtcLCw825Bvblck9a1t6JPMwcQ88Uea-0RVEiXDhC2p6SetQAZ0qAQ81vqaI9xdZvGjN84bZP8oi-KXlTVbkkGh1vet0J2BpY_kirUjUR_QNU1mGErPwjHzFX85jBqlFfJ76j8ajOSMJwVCZ5F0HBsB-DjMkjvherj-Mcxu8KPx5hjhIcIMArKOwcdfaCqmyBu33H953BHS0uP6iF8y1-WxVBDqKeDS0TvYdGi2dL4L9FuM3sv42rId9LyUVXIinwkjro6KikkyLkmk2DkOoyP8MtLyG-HzM0mDKIO29g1TK7MOryosry8MeAXdUH0T6loHqOrQ7kLpBbloW1vjfBmwVfAq3AFom5TQfy5LNnlNHYwtAbqAtgsklmdPX-mSFr_RLqzJ_EL4LPR7sIuqzsOFQQkbC3vdBAqcZq_jT0UudPF5siysID7yUenk1nSQIJRR5_KOOUg314t2VKcXWclMrrEA6bnDJVkccecbwsbXAXrdrPklU1o4bgxoyX48FH=s220-no" alt="" title="Album Stream: ElCamino &#038; 38 Spesh &#8211; Martyr’s Prayer"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/23/album-stream-elcamino-38-spesh-martyrs-prayer/" rel="bookmark" title="Album Stream: ElCamino &#038; 38 Spesh &#8211; Martyr’s Prayer">Album Stream: ElCamino &#038; 38 Spesh &#8211; Martyr’s Prayer</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/23/album-stream-curreny-thelonious-martin-3-piece-set/" rel="bookmark" title="Album Stream: Curren$y &#038; Thelonious Martin &#8211; 3 Piece Set"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/7xEwqXJ9F0Mlq3QxAA5a-h_AyGV2gayuECKtPW4QAAgR9BbKERv8LsBtnuPiE3HFykEcYHLH2Zxn4sVdnPr72b-cIDVoPumipY7LxFRxrSgFdzeuDYl-fRPZHpMiB2syMez4U8AJvYH-AW02T4q2h8Z0phoGaUtFS7-IeDB4-algAlBsRmurq3S49Sjmp4WqntyWo4fNEd3cdxz0pEeBBlrC2c-N9RMqo_UWpu5PQu_XXkpkCzzoK4AmIXCDzuMoCzMTSW6dRfzU44qOdziql3ldgK6OEw0fHvOu2anj4Umm5pE477F_SV3XTLZDfSejxg5giCdzk8-vx4OMhBSOATAOyGkFAyheConrIGm0Lzt-h3_Ud-I2FYx8hgIyzh0OiWohMIcyyIDpyh7hXh1P0FNJfVjzq04PQz7uJsRbOr-Fu7lofuaSg1P5Jh1Efpc0PLG-Qh2f770M5SkXXXqnhmgMBplrsbHNY5eKsbnOXJyK1kzdDiI8jRB31HmgEeyCXuY1h5n44L8JEceY2VhE1Ts9F19OzJ66XtpkLf4pVpsgtpdh-B-JJsH6n7bcVK4WsEwXKtwcpvpyAuG8tMyS5Y_AixMj18c_Z62BAW3a7gDTw_moVCz4Ly-TgEwfj6eF4JunwlkRQgrjYBhXcJd3gxR3KciSo2XDxHPD2zMWjr6C7dw8B8kco7vl=s500-no" alt="" title="Album Stream: Curren$y &#038; Thelonious Martin &#8211; 3 Piece Set"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/23/album-stream-curreny-thelonious-martin-3-piece-set/" rel="bookmark" title="Album Stream: Curren$y &#038; Thelonious Martin &#8211; 3 Piece Set">Album Stream: Curren$y &#038; Thelonious Martin &#8211; 3 Piece Set</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/22/album-stream-royce-da-59-the-allegory/" rel="bookmark" title="Album Stream: Royce 5’9 &#8211; The Allegory"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/zRfXEgznnL0icLOYd4nPAh0VAunLPEYK4nIa4C7zki-B9UKMdN9PcZ9pVZfKvq2g8bw4azyDrYNrWsEvIf3jH5lxZgcOXVkq8zooAvgFwTMQxztK3utCPv37FaceypEtOQpvmPou1exTXaUOiTX4TGa_s_PviQktEVI-F-pS1rLrr9SpfhfmkRRgl9BGQISjFAVvf4sFYUqQKTlgyp_GFBOCnu9mGwVobZCbI6_-q6ZqghSo5SqUxHavKOdRKBM96vPM-uldN5t6cw73d2KThOu4r-cElYVPMwsG4_R9Lw-sM6fTDf3-47PVoK1ieS2SyghPsdaIjs1SLZc4RUTHwJUqWerhy9SwOUiGMAOyLUyNCzH8R_ova34N033d3KM8fb5TGuZFwjt6Y65ylWJSat_EDzL2-8XEsxdoZLCYIZz5p7OCurVxwnnogx8TKuoYqtxldDFfg-RzpUHfn0DUvpkatOs2qlB3VOJEa4XE0gK26EdYXQnUpkhcM_3DpYtRbtmfq9cuakfukGQTWTACv_4Icq03xkPdUl33yXajDOnTzYYhV1eBmXT4gZYynAcheNzOmR9rL3piaI-dfcKPiTuao7zx4WgiioGfHaPL9oXipQZ8R5YOrKazshCUg8LOWbJtL-b38WLgV4B3HhXnywgvGrHIBACKqeHEBxwXv0OcML5DmXH5ddm4=s700-no" alt="" title="Album Stream: Royce 5’9 &#8211; The Allegory"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/22/album-stream-royce-da-59-the-allegory/" rel="bookmark" title="Album Stream: Royce 5’9 &#8211; The Allegory">Album Stream: Royce 5’9 &#8211; The Allegory</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_5e591c2da6f61" data-td_block_id="td_uid_2_5e591c2da6f61"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_2_5e591c2da6f61" data-td_block_id="td_uid_2_5e591c2da6f61"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_3_5e591c2daaff5_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_3_5e591c2daaff5" ><script>var block_td_uid_3_5e591c2daaff5 = new tdBlock();
block_td_uid_3_5e591c2daaff5.id = "td_uid_3_5e591c2daaff5";
block_td_uid_3_5e591c2daaff5.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_3_5e591c2daaff5_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_3_5e591c2daaff5.td_column_number = "3";
block_td_uid_3_5e591c2daaff5.block_type = "td_block_mega_menu";
block_td_uid_3_5e591c2daaff5.post_count = "5";
block_td_uid_3_5e591c2daaff5.found_posts = "2737";
block_td_uid_3_5e591c2daaff5.header_color = "";
block_td_uid_3_5e591c2daaff5.ajax_pagination_infinite_stop = "";
block_td_uid_3_5e591c2daaff5.max_num_pages = "548";
tdBlocksArray.push(block_td_uid_3_5e591c2daaff5);
</script><div id=td_uid_3_5e591c2daaff5 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/28/music-video-jhene-aiko-ft-future-miguel-happiness-over-everything-h-o-e/" rel="bookmark" title="Music Video: Jhené Aiko ft. Future &#038; Miguel &#8211; Happiness Over Everything (H.O.E.)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/YBkMcHo-YVBrmF6_KiwWJS6jY6WdMmcxpOvEUegwJOCxtOvRjDt6NcCLMhqRPTG5kPQaLzCgaePKiUuVcZ6LUljvRRR9UFdqUqn9H10gXPxdBLgoxkqhfEFPoSe280ZoyBSoqSAs3g-UlrgaGH9PRbmyIGVGEy7uwpyIRBytpVqEqlcUsFZ-ARfTWaFEUo1YPi6nddHhMr6luvemMhAy4IFzb1XwNS__u9az5RzJ9gOWBUZ8f19VI8LKCpKYtY_hCqUh8W1hOhUwRMCTF9SsA2nBxMmHpwAWUSHmSIjMDVtq7aR3H9kEOsNw29jrhw_EE04Lu3EH-F9NbRRRdNH6LAzMB7ALtTlRrd9Sca4F1KYK_TjVJaZUqSRHcDJO4Chj0WIfbX8_mGue3MlWh4F4DHaxPZfS0tucBq8OyVmOuBMtsT_3e5cLD3t2pUcpOy34ftauAOcjIpE4eZqAffd9__OAspu-a8EqFmuYtkjLW6dEzxEfRcScYZOvmZrV4L1zXcNtw9gtuff3EO6N5SvLZhDReBvxAOX3WvhJewT02SnXNh00sECQVYzA9dsG9lb-EL2jBJko-KZS11HlxSzbZDIAcZSTIf9UrExnrehLFfil-S59C7b0O_ZukOeurfsBig0XDKx78bunZ47EA9mEcSNNyIiQo64E3_fZx92-CC9S8-5Q-_yYzirr=w754-h535-no" alt="" title="Music Video: Jhené Aiko ft. Future &#038; Miguel &#8211; Happiness Over Everything (H.O.E.)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/28/music-video-jhene-aiko-ft-future-miguel-happiness-over-everything-h-o-e/" rel="bookmark" title="Music Video: Jhené Aiko ft. Future &#038; Miguel &#8211; Happiness Over Everything (H.O.E.)">Music Video: Jhené Aiko ft. Future &#038; Miguel &#8211; Happiness Over&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/28/music-video-dj-drama-ft-westside-gunn-rick-ross-350/" rel="bookmark" title="Music Video: DJ Drama ft. Westside Gunn, Lule, &#038; Rick Ross &#8211; 350"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/2_qfApw_QNy1LUjinnHhMeqsG0RfQEroQqw2Xf-4G_2RbOS5PqyQ2g7-cOSbcx9Bd4zsUTEz_kUnywg6XfFFe2sA3sfrJs_6UtrMoT5_sUB31XkE1u6LKn6SEC52M5rS_9dPSLGfzvWpXTB_tp5rkCfCMzjORoS7Inlreo5Rp7wgc1f9QMT6C5nwShKHWhl9UjKiNCkDshr0w_Z-bWBTQNIktf0F0pOtYEZ99sh6QuUX2FOaoH6D61e0Mp9k112b5iMuB-WXgp8qcorqbWwRq4QdUuANZQEO2fo1AAAc1aG0cmgoNAzeNv1HlU_Zbak6FBE8lDH7W8_IvouwQvk5ncwsGDetggXGnwkqkqzAtceuotZ5BBw0I8kIWzjP2yMZjZ8GY8ZcOOXTUCE4qlbNx3CtriVcnGVoeu9YlLn6dTPZAAu2eaujIemBeCWoKL14n4KrkqGd9kjHypsRug-16t_RRK21R_VOCJsLZeCEjCINUK2DJ37Efwf3DwyDB_WRP4owoZorihl7YOdY-5fwNyhmUO_hMBwl75aKRWgLPuTmM9ScZnWO0HoIROrrM4n7yVUh2TStEpsE9eLOtZ2vndprzuDZCaBMolVpKy7Fjw97QpXU_eOgMAiaygy7O4uTj5R3eiE7htuD461VJD3kq-vJCrI8fbTzOpZ-GWo33LHIfbT8U1I1pmez=w859-h464-no" alt="" title="Music Video: DJ Drama ft. Westside Gunn, Lule, &#038; Rick Ross &#8211; 350"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/28/music-video-dj-drama-ft-westside-gunn-rick-ross-350/" rel="bookmark" title="Music Video: DJ Drama ft. Westside Gunn, Lule, &#038; Rick Ross &#8211; 350">Music Video: DJ Drama ft. Westside Gunn, Lule, &#038; Rick Ross&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/27/music-video-v-don-ft-dah-whitey-bulger/" rel="bookmark" title="Music Video: V Don ft. Da$H &#8211; Whitey Bulger"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/e2L0ynZmKGKwkB0xWFgbKwm8FldmmqQa0y0NuUNtguH5SyQvvbapO3nga9UHZOUWoJU8_TTeNLDVNXAj7oI7ySll3jYC3h4COxHVQkJwKI4BwMtuLjDQdLiYybsc7GVOiNuAJgsfERkq4BzcWkB0ixAgHgbK1ynZqYz_IhtacbNHv0IyAhYdWu8IQ8HtWsiNEMqCfXEdg6Kb6ZGBQMwHRbCcC1aJ3RSnc_PWZqDv6J4K3tLatAQje4zT6OOrJc-d8pr0C-2SmzO64_yOo1MPX2-NaWRmphZlmbTA-OU91dKI1eyIfRe5epZdWqtlwpWbnr9uKp_bVRHVH9-yEszARRQO4-01Q3RyzsxrcKa_klvrB1KQkFTkdTAlGqARv0CqVUbx8ur2EluiQdhSQmezo34ru9-h2nPLmzG9P42hTBU6z2YaEA7T_e3o78z87egYOEZUu8R9BvlHEg7-YMLzo4-xyUT0bNgjaXlGHdZPY5p5VhQEC0K_-COHTWpOF6pfss7LLzJc7RksuuUafGYyykB-p1cQjHEuV5ClDersDnsvfxRer6B5SCfdKOBH449wfG5aCcN04GCTukcHhvRBixWoZF9JmJ9aq77RKKz3pi21Ofku3RTW13i_TtjJ1FN3DegQaI9ULpqsr3q2uRf3H-byG59oPLZc808nPzDb341b_1mVzPE4bVoZ=w771-h473-no" alt="" title="Music Video: V Don ft. Da$H &#8211; Whitey Bulger"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/27/music-video-v-don-ft-dah-whitey-bulger/" rel="bookmark" title="Music Video: V Don ft. Da$H &#8211; Whitey Bulger">Music Video: V Don ft. Da$H &#8211; Whitey Bulger</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/27/music-video-doja-cat-say-so/" rel="bookmark" title="Music Video: Doja Cat &#8211; Say So"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/m4R-giACibUB70hG5EawFZSovFpB7k-9TgjdCwfzo2ohPZkfhYsmFgY3HwK6QTvQPVwURz2ixStOo0dKQAHloEVOpeysj9jcr3Fwkp53eFIoGPcDT1TUKqbgat7Ay-t5ecxKKu9_xvNn0NNk3JR-_63v8kH2_OEt-TRelP6JZKwueEHOM2xpnI4x1fahk1tgRL_Kt_OLhhfTR0Ge2MnKXMxFYe2PAjOBpPRdRkRZLC0B_uPvf9vpHZvejcs_k5X2KInbI3qgj5b8-SOxlt8D15y0FTskDLZAOPLJ2VSwNfCXON4SOkhzHqugQ-HCN-mhAAFlCgxDOQbG0G8c9R_y16t0zi-b4aiYQ2JMbn8MuTeaXzpMtBG0MEvLsYtmmNb8Eu87K5uWHthxgnfXUmmV07gFCyjVGB1LaW4_hwCazIWdmIELfbV50akSIq5U2O8GECxFVAKiKfrMJPvEkBPgiuPcYzZHZt-yOlefBFvhRexhvuWNzwg4swji1pOrP1kedvVblhPIneXLNoYska-ybM5v1lnNBjQuyqnutzR00Avm4dgetCxHMfGPvkKeyLRFGWZAGn2dl6vapnYmuiDttw04Birevy7q1V3Cf0knsJH8GMOncgtDuzEeQcAFnzuk2gTL8gtxbbclgQvxXSzWjkUwYcYjq6ASRKwKeME7xRWSdr2VsL_7b6of=w695-h539-no" alt="" title="Music Video: Doja Cat &#8211; Say So"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/27/music-video-doja-cat-say-so/" rel="bookmark" title="Music Video: Doja Cat &#8211; Say So">Music Video: Doja Cat &#8211; Say So</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/27/music-video-royce-59-ft-kxng-crooked-tricked/" rel="bookmark" title="Music Video: Royce 5’9 ft. KXNG Crooked &#8211; Tricked"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/vLNIOjWgiDhwNU4VSn7VpDbLBV-WFj12Mg2xJX5_ADIj5z9wawoXN0RfOqfDlkghuJXffKAtm1AZKGFIah2hl9zkXzjw9E9YeuBeMKMNOqld_qn_0niyL7s6P-KC4VfxOw4u7X0mgI67y2zx1QCevp1sfI3g74otHK5UyogHgrFvciCO8__C0-n-9REppMWgtk7zoYJlU87-c6myrGjRGlnWy_T3r-cEumYnPyhdiPLQnsrnWCOxeB2QhlSkQhAP0YdbZPBInbKdiXzCatKwixbJVK2G15q2wi3My58xHt0dCfaKraNL58QCuupa-332Ms6rZNY8txWALVsrLX3qKSahzdlLR6dULUjyYFVwcgfgaWcab_Wti0QvREcOav8WXqVJCalDc6hs4eX2oY3w2Y2q9lROiyqjfcLQHdHJQtSx6xgx1TpLkgn2_zF6d4uJzg9ptDUYKbfXJ--SKbf3uD8bOGaAQLLxrqCHwB61HHwBcRhl75nQjOCbVIs8mIbrAj66miFmTix869bptSU_ocahlqfw_7zRo5u1TwjqOTkwQVfZiWTu3HrDMs_DReD6W3BSOrBOIlNzcS7JIhfpVd49hOpq31Ovag3bLfg1QIXM0FvNox19eyw_5EnvlddkmVT0jKF-WBTGudQXvYZIVIXyW6JQLrinvclqu7iw7Ogcw3bX_PdF1tpg=w690-h470-no" alt="" title="Music Video: Royce 5’9 ft. KXNG Crooked &#8211; Tricked"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/27/music-video-royce-59-ft-kxng-crooked-tricked/" rel="bookmark" title="Music Video: Royce 5’9 ft. KXNG Crooked &#8211; Tricked">Music Video: Royce 5’9 ft. KXNG Crooked &#8211; Tricked</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_5e591c2daaff5" data-td_block_id="td_uid_3_5e591c2daaff5"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_3_5e591c2daaff5" data-td_block_id="td_uid_3_5e591c2daaff5"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_4_5e591c2daee0d_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_4_5e591c2daee0d" ><script>var block_td_uid_4_5e591c2daee0d = new tdBlock();
block_td_uid_4_5e591c2daee0d.id = "td_uid_4_5e591c2daee0d";
block_td_uid_4_5e591c2daee0d.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"29","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_4_5e591c2daee0d_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_4_5e591c2daee0d.td_column_number = "3";
block_td_uid_4_5e591c2daee0d.block_type = "td_block_mega_menu";
block_td_uid_4_5e591c2daee0d.post_count = "4";
block_td_uid_4_5e591c2daee0d.found_posts = "979";
block_td_uid_4_5e591c2daee0d.header_color = "";
block_td_uid_4_5e591c2daee0d.ajax_pagination_infinite_stop = "";
block_td_uid_4_5e591c2daee0d.max_num_pages = "245";
tdBlocksArray.push(block_td_uid_4_5e591c2daee0d);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_4_5e591c2daee0d" id="td_uid_5_5e591c2db071d" data-td_block_id="td_uid_4_5e591c2daee0d" data-td_filter_value="" href="http://weuponithiphop.info/category/latest-news/">All</a><a class="mega-menu-sub-cat-td_uid_4_5e591c2daee0d"  id="td_uid_6_5e591c2db081a" data-td_block_id="td_uid_4_5e591c2daee0d" data-td_filter_value="69" href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a><a class="mega-menu-sub-cat-td_uid_4_5e591c2daee0d"  id="td_uid_7_5e591c2db093d" data-td_block_id="td_uid_4_5e591c2daee0d" data-td_filter_value="80" href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a><a class="mega-menu-sub-cat-td_uid_4_5e591c2daee0d"  id="td_uid_8_5e591c2db0a57" data-td_block_id="td_uid_4_5e591c2daee0d" data-td_filter_value="2189" href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a><a class="mega-menu-sub-cat-td_uid_4_5e591c2daee0d"  id="td_uid_9_5e591c2db0b76" data-td_block_id="td_uid_4_5e591c2daee0d" data-td_filter_value="10" href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a><a class="mega-menu-sub-cat-td_uid_4_5e591c2daee0d"  id="td_uid_10_5e591c2db0c8a" data-td_block_id="td_uid_4_5e591c2daee0d" data-td_filter_value="130" href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></div></div><div id=td_uid_4_5e591c2daee0d class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/26/jhene-aiko-reveals-chilombo-tracklist/" rel="bookmark" title="Jhené Aiko Reveals ‘Chilombo’ Tracklist"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/8TdCpQakuJKCP4dNy1rXBYWjLtNsjGrqmhfD0zj1GYiMmu_bke99U3REtwolUC8o0cuAWTJL5IWB4FspohGhv8uhaK0ab1pd6YJjzxrRqe4ohbckTNDUzsKSx37kfQRVsdri75X1kcvRPyrW_T4Y3zcWerqKAzfF5tduTypMSTTRxXmkwxTV8BcVrFU98d3fD4AAMXll8cHdzTqlANM3lBvs7LLVBauumAZxhs6aykVPPg5Zj0O8sV3Y7CPGMMjdDBVPBt0Vmg5gPFvok9mCWfd_bGdDEhUrFeJzq4psG7TQUQ8sNVm1P-3iqxXppsb1WhbBkYR2fCvkSGBUqtnWxdj9xv_02Be-6yoXR7aUg5e6EPyeFz57k3ySsIL2JKH2bPRmjypuTlANq7pyLU7f6npVloBiG7TNXnAiLzVnQyU_PPRiq8NHKW-FmlTzQHwWFBO8RWMBhKqKs2XzxufSH0i3KGyMiX0NlI-U1TJxeQ6RzCwCv6Zv7nDMK8auz-nhBmtbhidZdNPDAQqnr22Z2IuEqQQGo7OEnvwBmgqLl94MddplzYL_wadj7gLE8WgWOEGPGIlamfpdGiN3FHIkQSK_tiuLZUbEn640jsy5h9Oq6tDVVtZ995mRpQuGNbjWcWB2plSfGTfdOz_ThTuw26LKmgAL3B1ovtn1Oxlc9ZlycQzmnbbjtig7=w596-h597-no" alt="" title="Jhené Aiko Reveals ‘Chilombo’ Tracklist"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/26/jhene-aiko-reveals-chilombo-tracklist/" rel="bookmark" title="Jhené Aiko Reveals ‘Chilombo’ Tracklist">Jhené Aiko Reveals ‘Chilombo’ Tracklist</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/25/video-royce-59-l-a-leakers-freestyle/" rel="bookmark" title="Video: Royce 5’9 &#8211; L.A. Leakers Freestyle"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/xIiYty3TF4CexaBYswNuETDKyoZMMRoLt3vTZlF_AT-6QxWC26GnrLoyIYf06YPr39qKhAxGe3BRppbv_OWVqGb4GOLI4ouG9PoIzO8Coymgg0ilgVQ9shTVY49d7UzzcSRvvUXLFz6cpk7sdpflOLgxK91xz_NOruP0GcDkEeX7BLCdY74vnhaCR8nxqo6jHCcbwBQYccsU1SauaT1rSdGg0pPPGqhpkbNhpLiDnoVxhx8RhrC-SQBMYqnufi965balxmMzllpZZZ68k9FFHCU0qCsRxqxBqZwlXqW5Cn4rRtgRvutmmaAopSQDKfFeYqltL3-ci1waJ0TKVL9rEeCfPby24nhDkACCjBtC9xCEAZtr2OiljDxWpbTgVu3Rp9o8HWNW1-vXuWLVwL8YdMZiJKCiaGajraWaGNB8JCRhrBBsQvsO-kdRYAQbx74zD_SFXBz2bdBVDR22z-hn-CnnlkYD2-YeGZejwLpW2H3pqFQJyr1HgUHpdr1sDer4oyQMdvqUdV6HiQOV6dHDOOLOhrpHc0Um5brvRV__yNPxtFZ75FVICfC5O9Gr1MajlodrDg-Ihz0JgPpd5xmA1uS04PeDg-LAQWEGqrKn_rPY0Oc-FGL6-PtW1DkLhvfRbCd6m9tkT1yiO7sA-anq1xWk3JpmB3T6vMwjqBDk_F91UdUtDNErZQZn=w741-h538-no" alt="" title="Video: Royce 5’9 &#8211; L.A. Leakers Freestyle"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/25/video-royce-59-l-a-leakers-freestyle/" rel="bookmark" title="Video: Royce 5’9 &#8211; L.A. Leakers Freestyle">Video: Royce 5’9 &#8211; L.A. Leakers Freestyle</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/23/video-joe-budden-pull-up-season-3-episode-2-featuring-wale/" rel="bookmark" title="Video: Joe Budden &#8211; Pull Up (Season 3 Episode 2) Featuring Wale"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/QTMlPT3Lo9-Obiq5g64kjGrfC4XMKL2hKgl46JKerK9lG9SyYypkAsXoipYzyxl_RoEv3LdIBdR2c1hpqu6GxJv5P2kT3P2fJzkgcrOdZzAK3NcPa5r-h0dW2TiSlRy5tzyfUTTAzpluBI4aPIfeADUZSsRpizq9KQTKi2ICng0XnMQw4H2k7374_fxulq4BaJi2St6CyFm1jAcjb3ptVVkw6vQPFo-z-R1X_w22R5NQ61f4hNN_9m0wDsI_tsT4BCNUrE1-qSsct6-6PMRZRYDgAgjySQvFPfzzBhagARfSbuB4kwrc49k82W19NSTKeuLwHnP3RUeA6CuGIWyko-oxxMEzjIHU3WwsvsF3nbTPFZ_FfYLrCoOr_bYB6rD7MvBtcCk47IpEk--dr6sfMvaxCBD22qdovLEtR58wBz7Rxg8oqd2KApKvQ18jTO6a2h8GR0N0Bcf1tfOjaOczzL-Y3bUY6x_hpEKsQY9cF_lKWQP7YOXZWu1uVAlVqXssuM2oi2VgRNG0PF0jOgMKnGkDkGGzTZ-B4lMWnzY0mhWoJYeFAsjn4p_nBV1pVIYWfeWBD5dortyLCzLWcPrO_jMhx5YB33FpwcsB15ul0Rl_4lSXFYnEI5owM3iREeDy5FJg7eVX9u3i_od1_8xgM8FHBPifBEDSaYJCBNHCRL_2_BnMI-nvXm2R=w1173-h530-no" alt="" title="Video: Joe Budden &#8211; Pull Up (Season 3 Episode 2) Featuring Wale"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/23/video-joe-budden-pull-up-season-3-episode-2-featuring-wale/" rel="bookmark" title="Video: Joe Budden &#8211; Pull Up (Season 3 Episode 2) Featuring Wale">Video: Joe Budden &#8211; Pull Up (Season 3 Episode 2) Featuring&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/20/the-weeknd-announces-after-hours-tour-w-sabrina-claudio-don-toliver-88glam/" rel="bookmark" title="The Weeknd Announces ‘After Hours’ Tour w/ Sabrina Claudio, Don Toliver &#038; 88GLAM"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/8kKcFmOiw_cKzOC1YiFCRmpAqyMaw-ut0L0nHlQoWLxOKgrCS4ig-MsEeigAaUTgeHY21vJod2TQlO3Lf-q447aYAh5kMO5h6dt2siL41kTpCVOUkiRUjTYXd5_BlSyshkYDSlvDJ1gzYcNkFzNxXFJkJr33MV8rem8Om7QCYffbZ5ESv91xZUNN4gALsZ_msi7ordDne4GJ09e3tQ16DWFhWNMCebB0VztxVqClMzd1D34HVMSCSnKE4u3qFO6mbKKEw_oN-8VCPPrwTvoCWygkHqtMdpWsWZk5QmapUChsjrcGVeyujHNJjyFaRtRbHcD4euqivPu2NUNHeyzee_TbbIsHi6ACP8xdTn16u8FUPpqLHQwCmomkYMYkJD4FgHx4aO3-3_d4GR1lRrk0V2fq_bxaHUJuNpnD_7ixH8chEzfhc4zC8t4loZ50ggQ-PTRpY9y1q70nIXbOudT_doxPgJLzWADYZSYstVkc_U0yFwj9Y7n4mrwaIQ4-ZiweOusGGZQpVvJI0xsZkDRiJ0PqcyeqYnZvD5uCxWyOwAOnjD90dZkqwoVwmFB5my6ErXqiDZEW1jtrwr1JNoPSnL6m1GFexqvso97C3t9UJJYoJG2rl64VoobdgKYTuHE766GwWOEdXsoXlZQm9VQZV_kjnfFD2I8diozSKmtquIfru_Iqh9Y5JSbp=w700-h875-no" alt="" title="The Weeknd Announces ‘After Hours’ Tour w/ Sabrina Claudio, Don Toliver &#038; 88GLAM"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/20/the-weeknd-announces-after-hours-tour-w-sabrina-claudio-don-toliver-88glam/" rel="bookmark" title="The Weeknd Announces ‘After Hours’ Tour w/ Sabrina Claudio, Don Toliver &#038; 88GLAM">The Weeknd Announces ‘After Hours’ Tour w/ Sabrina Claudio, Don Toliver&#8230;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_4_5e591c2daee0d" data-td_block_id="td_uid_4_5e591c2daee0d"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_4_5e591c2daee0d" data-td_block_id="td_uid_4_5e591c2daee0d"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_11_5e591c2dc805d_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_11_5e591c2dc805d" ><script>var block_td_uid_11_5e591c2dc805d = new tdBlock();
block_td_uid_11_5e591c2dc805d.id = "td_uid_11_5e591c2dc805d";
block_td_uid_11_5e591c2dc805d.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"77","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_11_5e591c2dc805d_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_11_5e591c2dc805d.td_column_number = "3";
block_td_uid_11_5e591c2dc805d.block_type = "td_block_mega_menu";
block_td_uid_11_5e591c2dc805d.post_count = "4";
block_td_uid_11_5e591c2dc805d.found_posts = "158";
block_td_uid_11_5e591c2dc805d.header_color = "";
block_td_uid_11_5e591c2dc805d.ajax_pagination_infinite_stop = "";
block_td_uid_11_5e591c2dc805d.max_num_pages = "40";
tdBlocksArray.push(block_td_uid_11_5e591c2dc805d);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_11_5e591c2dc805d" id="td_uid_12_5e591c2dc97b9" data-td_block_id="td_uid_11_5e591c2dc805d" data-td_filter_value="" href="http://weuponithiphop.info/category/fashion/">All</a><a class="mega-menu-sub-cat-td_uid_11_5e591c2dc805d"  id="td_uid_13_5e591c2dc98b5" data-td_block_id="td_uid_11_5e591c2dc805d" data-td_filter_value="76" href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></div></div><div id=td_uid_11_5e591c2dc805d class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/LVT4Mid8WL4wHUdO9X2OZmZxxgbREs2lVtszOdEBaO6hJB0JS3yQOAyhNSdCyPmv0amBDTgNGpOlRPXPjKCl6yIlo2joyH3rQRI7CUdX09BJtQI1r5jy1_7BQtDhw4AxUhpUwIh35rNS3lTy7uq-FdPff10JN6srr9mwZ7zr04GQFxBVEXwCfC5rNVehXhY_wGCRVsmevYmdkBWEmB8dvOzBHY78NBBjcHNArS_S-2M0FJgDh8v9m9vEh78k_XmZg-AERctsf0bkODuPi1EcNJq_RnJIV6b0GG-VtKjo-OVPmYghWJYf1HiP9c58cQ98oABU8BDFdLqsBtNt4K0NmyHYQlX39W9k_d83wEHZ1-EacQa2o01VrYSn12HnZ1l88fMzu9PKv6EGmcRZNwpepycW7_9EQnhxIPDdVCmRLXUasUED9OXr-zJmnBcnSnLCa06k1ZymQym1LiSFEv1c3aPHnmnD3GY8nL7q5jPJr4HsABR0WCqMebcF3HF_0deNd0zgRBCGMxW-VzlIIHZiHuBeSPEPvUL149GJ5swSSvKm1uGEi1HlLBj9omJSU7mDWzO0p_7l-l7-4_ureEsGsgB8cX1t8t2TQcFeRgqqF1CXlZFYYC2K0iMb4jPsijsw_rtO7pmKvbngqHfgYpGeh_qLmDWeicR7=w1195-h796-no" alt="" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch">Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/fHEwwMf8DoiXlqkfibQS1Z1XXbviORbV9raaI44tOTXrWo7GgqM3gA-vswE10gFtTQUGGwNG7nWAACwHjxPuiubliYBN_dqtBZh2WIpxvumiJ-hSLK0TNWB2cB8Iw2STT5gcp_KqlDh_e4xng1vidI8EXdp_ooh5uDI-JV1HQ9dGnM5nxl_b-v8znqj-Rl_mGB7y4Lu9zsFNWHU7SriqQQJaKrKEEnb9T8zxmGLaL0zq7ilYpnUEhWulDDr9xc82wdr__WzRBm5YEskVpDAnGM2NDZwTZpjbe4QDdxeixWnSXNK_oDzaL7WTbCpkD33OK88BlI5JmFRQ5VmD11UQ2htB7-9WoahHvb4XmBsbLXpEMl1JmEP4sPx06VduzFnBNo-J90WI0n1AEIIcEYVbRywrkGJXbzmH__In9ZIg0EV24OcGGbeKl12HxTdZwucqsNnuZeNjiMHISQ7i8cfzm3N7X7Zenl74zsKIKeKWoIGxh6MTlVADvgHcrHebnjcSgil2vBeFyz_AP45aOv9SOwbzfVLGS0CNfe1s9b2J7qZgjcBk9QPEXCl2kygvzmGXFvU_3xBuW6S0i3Vkh3Ha_3hPBtvIAy3WoTK2yiqS41HzSK7yk3FRAlBtpIEib338fdkTiosBxtdu36SdNUVM75zl6CVIFhTu=w681-h470-no" alt="" title="Air Jordan 14 Rip Hamilton"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton">Air Jordan 14 Rip Hamilton</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/kUjaOYxjEkAh34S-Ub2QSZwdOwHyFnGFLBZULta3_bn1_myPMAwJXiEEsAAtc1ktCQwHCuKhSqSYsWXFBEIZxdfKuykoDEZWwO-dDI3_JeAshbYvyILEHUu0XaUpRn0mj7gOx10V52t8gRGYPCW7QXGImkPGGhvBPzBDVVqh9lKGtkuPeePmTnpRSmwp0LG1WHcIzUWnMqPBWQeHAat6Q-Tq7niXNb96ddEZsMEdHK1nmHVlNaeqFBNtTxk6yYRkFNCvtfBayqy-Rqt4CPU5tThxbTI4AIUCI6JLxJd_VJizrVNDEe2xZ_tiQdkC5ASIoHpX8sfvAB8zRUsMVJ6oMUt5FH_4GBNXDCtFRmr65Qt0JV1h4bBJffu2L272Q_vpD76wn-YNGW8VCtZcheHu_X-A4gdYQEC0HN0BenY-MOuUBqKEjXAc0SxWeP7W9RN55jlqUFK0nzEYydVjec2stdQIngVfg_FvKxvHXfM4XdtMpqeJnp3Pzyk8xjz30sAZd0f2HQ6zfdPjk-OkV2-WrC0_qW0L8Rq3zrUbq52n3BN7gm7sctU_CUlBmoQIgJDQBYk1Siv4tfSq9pL1R4GdaOlWQdxEuhZi8bTYC8GGAgNGl3SMAZGvk7nu6QnnwEZjZ7mZwbcqgyRKa89cOREMUvIkVJ8Q8lZu=w926-h672-no" alt="" title="Jordan Proto React Triple White"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White">Jordan Proto React Triple White</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4cDUjSODZSaXWfHyZKb9q3Fn7FHA4uB0KSBs0MtFHC0dc6AJb1zeAl_X2LOKalK9C7VBFhTqRQ9fw1ESgUr9ZUKFbOzD94i_s96nvkICOqrsYnzrE2nEAQHoEaGOF4O8GAI6T4CGFbgcQhNzjpRlSY60NyPu5Cmq81FRpEOFRzTOtSa_NnWzMmfwO0yxtPbcg5U6YBUsus8shv3SA7CjULLfaP38nZAuWVgq8PMaaeCQ_eSrK8NJSEVQjyyxmqb-1I7zO8Kvvzvwi--ibMr52CF8h-GusBzSq5ZuzvZRCGu_u8CyfoXw7pwWbOmHnLOdcQ9d2PCSW_IxEMGfmEuU7NxMSsW3Ga4r35_wLB7cjvlPC9OjCV50tfekXjZBS_476mzlf4G9jR7Ju1GqgjXah9Uqc_0Y8N-Br8_JCtIlRSuLxAiebwd7AvFVlgWId9MYxBWnRT3cTyD8SH7q5WwO-CIbKAOSKsNcrrTgFxQvqn9yklBU1u5X5fdTlTBk4WSYorsWZAug0z9BOymRLnrhTbnA0vpBPFROWD-aL1glg-eUpFSfgD4xhWsOqJNY9krQ2UbLSGXQ5gYWj0ovLS7Yz3UKFY2qrVWpqkpbfyN98es9NJ-7LTUs2MLq1rX_2FaQmyq5mVndd7VGzQOHy9hDULG-5H-0LvGd=w900-h566-no" alt="" title="adidas Yeezy Boost 350 V2 Hyperspace"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace">adidas Yeezy Boost 350 V2 Hyperspace</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_11_5e591c2dc805d" data-td_block_id="td_uid_11_5e591c2dc805d"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_11_5e591c2dc805d" data-td_block_id="td_uid_11_5e591c2dc805d"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div></div>


<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form method="get" class="td-search-form" action="http://weuponithiphop.info/">
				<div role="search" class="td-head-form-search-wrap">
					<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>            </div>
        </div>
    </div>

    <div class="td-banner-wrap-full">
        <div class="td-header-container td-header-row td-header-header">
            <div class="td-header-sp-recs">
                <div class="td-header-rec-wrap">
    
</div>            </div>
        </div>
    </div>

</div>
<article id="post-37119" class="td-post-template-7 post-37119 post type-post status-publish format-standard has-post-thumbnail hentry category-music-video tag-future tag-jhene-aiko tag-miguel" itemscope itemtype="http://schema.org/Article">

    <div class="td-full-screen-header-image-wrap">

        <div class="td-container td-post-header">
            <div class="td-crumb-container"><div class="entry-crumbs"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="" class="entry-crumb" itemprop="url" href="http://weuponithiphop.info/"><span itemprop="title">Home</span></a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="View all posts in Music Video" class="entry-crumb" itemprop="url" href="http://weuponithiphop.info/category/music-video/"><span itemprop="title">Music Video</span></a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last" itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><meta itemprop="title" content = "Music Video: Jhené Aiko ft. Future &#038; Miguel &#8211; Happiness Over Everything..."><meta itemprop="url" content = "http://weuponithiphop.info/2020/02/28/music-video-jhene-aiko-ft-future-miguel-happiness-over-everything-h-o-e/">Music Video: Jhené Aiko ft. Future &#038; Miguel &#8211; Happiness Over Everything...</span></div></div>

	        <div class="td-post-header-holder">

		        <div class="td-parallax-header">

	                <header class="td-post-title">

	                    <ul class="td-category"><li class="entry-category"><a  href="http://weuponithiphop.info/category/music-video/">Music Video</a></li></ul>	                    <h1 class="entry-title">Music Video: Jhené Aiko ft. Future &#038; Miguel &#8211; Happiness Over Everything (H.O.E.)</h1>

	                    
	                    <div class="td-module-meta-info">
	                        <div class="td-post-author-name">By <a href="http://weuponithiphop.info/author/cyclone/">cyclone</a> - </div>	                        <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-02-28T05:57:55+00:00" >February 28, 2020</time></span>	                        	                        <div class="td-post-comments"><a href="http://weuponithiphop.info/2020/02/28/music-video-jhene-aiko-ft-future-miguel-happiness-over-everything-h-o-e/#respond"><i class="td-icon-comments"></i>0</a></div>	                    </div>

	                </header>

		            <div class="td-read-down"><a href="#"><i class="td-icon-read-down"></i></a></div>
		        </div>
            </div>

        </div>

        <div id="td-full-screen-header-image" class="td-image-gradient-style7">
            <img class="td-backstretch" src="https://lh3.googleusercontent.com/YBkMcHo-YVBrmF6_KiwWJS6jY6WdMmcxpOvEUegwJOCxtOvRjDt6NcCLMhqRPTG5kPQaLzCgaePKiUuVcZ6LUljvRRR9UFdqUqn9H10gXPxdBLgoxkqhfEFPoSe280ZoyBSoqSAs3g-UlrgaGH9PRbmyIGVGEy7uwpyIRBytpVqEqlcUsFZ-ARfTWaFEUo1YPi6nddHhMr6luvemMhAy4IFzb1XwNS__u9az5RzJ9gOWBUZ8f19VI8LKCpKYtY_hCqUh8W1hOhUwRMCTF9SsA2nBxMmHpwAWUSHmSIjMDVtq7aR3H9kEOsNw29jrhw_EE04Lu3EH-F9NbRRRdNH6LAzMB7ALtTlRrd9Sca4F1KYK_TjVJaZUqSRHcDJO4Chj0WIfbX8_mGue3MlWh4F4DHaxPZfS0tucBq8OyVmOuBMtsT_3e5cLD3t2pUcpOy34ftauAOcjIpE4eZqAffd9__OAspu-a8EqFmuYtkjLW6dEzxEfRcScYZOvmZrV4L1zXcNtw9gtuff3EO6N5SvLZhDReBvxAOX3WvhJewT02SnXNh00sECQVYzA9dsG9lb-EL2jBJko-KZS11HlxSzbZDIAcZSTIf9UrExnrehLFfil-S59C7b0O_ZukOeurfsBig0XDKx78bunZ47EA9mEcSNNyIiQo64E3_fZx92-CC9S8-5Q-_yYzirr=w754-h535-no">
        </div>
    </div>

    <div class="td-container">
        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    

    <div class="td-post-content">
        <p><img class="alignnone size-full" src="https://lh3.googleusercontent.com/YBkMcHo-YVBrmF6_KiwWJS6jY6WdMmcxpOvEUegwJOCxtOvRjDt6NcCLMhqRPTG5kPQaLzCgaePKiUuVcZ6LUljvRRR9UFdqUqn9H10gXPxdBLgoxkqhfEFPoSe280ZoyBSoqSAs3g-UlrgaGH9PRbmyIGVGEy7uwpyIRBytpVqEqlcUsFZ-ARfTWaFEUo1YPi6nddHhMr6luvemMhAy4IFzb1XwNS__u9az5RzJ9gOWBUZ8f19VI8LKCpKYtY_hCqUh8W1hOhUwRMCTF9SsA2nBxMmHpwAWUSHmSIjMDVtq7aR3H9kEOsNw29jrhw_EE04Lu3EH-F9NbRRRdNH6LAzMB7ALtTlRrd9Sca4F1KYK_TjVJaZUqSRHcDJO4Chj0WIfbX8_mGue3MlWh4F4DHaxPZfS0tucBq8OyVmOuBMtsT_3e5cLD3t2pUcpOy34ftauAOcjIpE4eZqAffd9__OAspu-a8EqFmuYtkjLW6dEzxEfRcScYZOvmZrV4L1zXcNtw9gtuff3EO6N5SvLZhDReBvxAOX3WvhJewT02SnXNh00sECQVYzA9dsG9lb-EL2jBJko-KZS11HlxSzbZDIAcZSTIf9UrExnrehLFfil-S59C7b0O_ZukOeurfsBig0XDKx78bunZ47EA9mEcSNNyIiQo64E3_fZx92-CC9S8-5Q-_yYzirr=w754-h535-no" width="754" height="535" /></p>
<p><strong>Jhené Aiko </strong>will be releasing her new album, <em><strong>CHILOMBO</strong> </em>on March 6th. She returns with the official video for her new single <strong>“Happiness Over Everything (H.O.E.)”</strong> featuring <strong>Future</strong> &amp; <strong>Miguel</strong>.</p>
<p>Watch the  <strong>“Happiness Over Everything (H.O.E.)”</strong> and download it now on <a href="https://itunes.apple.com/us/album/1500519759?uo=4&amp;app=itunes&amp;at=1000lLce&amp;lId=1832702&amp;cId=none&amp;src=Linkfire&amp;sr=7&amp;ct=LFV_87993644e15d257292023de8d846a83a&amp;itscg=30440&amp;itsct=catchall_p7">Apple Music</a>/<a href="https://play.google.com/store/music/album/Jhen%C3%A9_Aiko_Happiness_Over_Everything_H_O_E?id=Bjc5p6scgemhngjmvd4f7i5vrg4&amp;PAffiliateID=110l4Mt&amp;PCamRefID=LFV_87993644e15d257292023de8d846a83a">Google Play</a>.<br />
<iframe src="https://www.youtube.com/embed/xVfddViugYQ" width="700" height="400" frameborder="0" allowfullscreen="allowfullscreen"></iframe></p>
<div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="http://weuponithiphop.info/2020/02/28/music-video-jhene-aiko-ft-future-miguel-happiness-over-everything-h-o-e/" data-a2a-title="Music Video: Jhené Aiko ft. Future &amp; Miguel – Happiness Over Everything (H.O.E.)"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2020%2F02%2F28%2Fmusic-video-jhene-aiko-ft-future-miguel-happiness-over-everything-h-o-e%2F&amp;linkname=Music%20Video%3A%20Jhen%C3%A9%20Aiko%20ft.%20Future%20%26%20Miguel%20%E2%80%93%20Happiness%20Over%20Everything%20%28H.O.E.%29" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2020%2F02%2F28%2Fmusic-video-jhene-aiko-ft-future-miguel-happiness-over-everything-h-o-e%2F&amp;linkname=Music%20Video%3A%20Jhen%C3%A9%20Aiko%20ft.%20Future%20%26%20Miguel%20%E2%80%93%20Happiness%20Over%20Everything%20%28H.O.E.%29" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2020%2F02%2F28%2Fmusic-video-jhene-aiko-ft-future-miguel-happiness-over-everything-h-o-e%2F&amp;linkname=Music%20Video%3A%20Jhen%C3%A9%20Aiko%20ft.%20Future%20%26%20Miguel%20%E2%80%93%20Happiness%20Over%20Everything%20%28H.O.E.%29" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2020%2F02%2F28%2Fmusic-video-jhene-aiko-ft-future-miguel-happiness-over-everything-h-o-e%2F&amp;linkname=Music%20Video%3A%20Jhen%C3%A9%20Aiko%20ft.%20Future%20%26%20Miguel%20%E2%80%93%20Happiness%20Over%20Everything%20%28H.O.E.%29" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_tumblr" href="https://www.addtoany.com/add_to/tumblr?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2020%2F02%2F28%2Fmusic-video-jhene-aiko-ft-future-miguel-happiness-over-everything-h-o-e%2F&amp;linkname=Music%20Video%3A%20Jhen%C3%A9%20Aiko%20ft.%20Future%20%26%20Miguel%20%E2%80%93%20Happiness%20Over%20Everything%20%28H.O.E.%29" title="Tumblr" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_reddit" href="https://www.addtoany.com/add_to/reddit?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2020%2F02%2F28%2Fmusic-video-jhene-aiko-ft-future-miguel-happiness-over-everything-h-o-e%2F&amp;linkname=Music%20Video%3A%20Jhen%C3%A9%20Aiko%20ft.%20Future%20%26%20Miguel%20%E2%80%93%20Happiness%20Over%20Everything%20%28H.O.E.%29" title="Reddit" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_flipboard" href="https://www.addtoany.com/add_to/flipboard?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2020%2F02%2F28%2Fmusic-video-jhene-aiko-ft-future-miguel-happiness-over-everything-h-o-e%2F&amp;linkname=Music%20Video%3A%20Jhen%C3%A9%20Aiko%20ft.%20Future%20%26%20Miguel%20%E2%80%93%20Happiness%20Over%20Everything%20%28H.O.E.%29" title="Flipboard" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2020%2F02%2F28%2Fmusic-video-jhene-aiko-ft-future-miguel-happiness-over-everything-h-o-e%2F&amp;linkname=Music%20Video%3A%20Jhen%C3%A9%20Aiko%20ft.%20Future%20%26%20Miguel%20%E2%80%93%20Happiness%20Over%20Everything%20%28H.O.E.%29" title="Copy Link" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div>    </div>


    <footer>
                
        <div class="td-post-source-tags">
                        <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="http://weuponithiphop.info/tag/future/">Future</a></li><li><a href="http://weuponithiphop.info/tag/jhene-aiko/">Jhené Aiko</a></li><li><a href="http://weuponithiphop.info/tag/miguel/">Miguel</a></li></ul>        </div>

                <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="http://weuponithiphop.info/2020/02/28/music-video-dj-drama-ft-westside-gunn-rick-ross-350/">Music Video: DJ Drama ft. Westside Gunn, Lule, &#038; Rick Ross &#8211; 350</a></div></div><div class="td-next-prev-separator"></div></div>        <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="http://weuponithiphop.info/author/cyclone/">cyclone</a></span></div>        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="cyclone"></span><meta itemprop="datePublished" content="2020-02-28T05:57:55+00:00"><meta itemprop="dateModified" content="2020-02-28T05:57:55+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://weuponithiphop.info/2020/02/28/music-video-jhene-aiko-ft-future-miguel-happiness-over-everything-h-o-e/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png"></span><meta itemprop="name" content="WeUpOnIt"></span><meta itemprop="headline " content="Music Video: Jhené Aiko ft. Future &amp; Miguel - Happiness Over Everything (H.O.E.)"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://lh3.googleusercontent.com/YBkMcHo-YVBrmF6_KiwWJS6jY6WdMmcxpOvEUegwJOCxtOvRjDt6NcCLMhqRPTG5kPQaLzCgaePKiUuVcZ6LUljvRRR9UFdqUqn9H10gXPxdBLgoxkqhfEFPoSe280ZoyBSoqSAs3g-UlrgaGH9PRbmyIGVGEy7uwpyIRBytpVqEqlcUsFZ-ARfTWaFEUo1YPi6nddHhMr6luvemMhAy4IFzb1XwNS__u9az5RzJ9gOWBUZ8f19VI8LKCpKYtY_hCqUh8W1hOhUwRMCTF9SsA2nBxMmHpwAWUSHmSIjMDVtq7aR3H9kEOsNw29jrhw_EE04Lu3EH-F9NbRRRdNH6LAzMB7ALtTlRrd9Sca4F1KYK_TjVJaZUqSRHcDJO4Chj0WIfbX8_mGue3MlWh4F4DHaxPZfS0tucBq8OyVmOuBMtsT_3e5cLD3t2pUcpOy34ftauAOcjIpE4eZqAffd9__OAspu-a8EqFmuYtkjLW6dEzxEfRcScYZOvmZrV4L1zXcNtw9gtuff3EO6N5SvLZhDReBvxAOX3WvhJewT02SnXNh00sECQVYzA9dsG9lb-EL2jBJko-KZS11HlxSzbZDIAcZSTIf9UrExnrehLFfil-S59C7b0O_ZukOeurfsBig0XDKx78bunZ47EA9mEcSNNyIiQo64E3_fZx92-CC9S8-5Q-_yYzirr=w754-h535-no"><meta itemprop="width" content="800"><meta itemprop="height" content="600"></span>    </footer>

    <div class="td_block_wrap td_block_related_posts td_uid_15_5e591c2dd6556_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_15_5e591c2dd6556" ><script>var block_td_uid_15_5e591c2dd6556 = new tdBlock();
block_td_uid_15_5e591c2dd6556.id = "td_uid_15_5e591c2dd6556";
block_td_uid_15_5e591c2dd6556.atts = '{"limit":6,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_custom_related","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_15_5e591c2dd6556_rand","offset":"","css":"","live_filter":"cur_post_same_tags","live_filter_cur_post_id":37119,"live_filter_cur_post_author":"1"}';
block_td_uid_15_5e591c2dd6556.td_column_number = "3";
block_td_uid_15_5e591c2dd6556.block_type = "td_block_related_posts";
block_td_uid_15_5e591c2dd6556.post_count = "6";
block_td_uid_15_5e591c2dd6556.found_posts = "99";
block_td_uid_15_5e591c2dd6556.header_color = "";
block_td_uid_15_5e591c2dd6556.ajax_pagination_infinite_stop = "";
block_td_uid_15_5e591c2dd6556.max_num_pages = "17";
tdBlocksArray.push(block_td_uid_15_5e591c2dd6556);
</script><h4 class="td-related-title"><a id="td_uid_16_5e591c2dda247" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_15_5e591c2dd6556" href="#">RELATED ARTICLES</a><a id="td_uid_17_5e591c2dda290" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_15_5e591c2dd6556" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_15_5e591c2dd6556 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/26/jhene-aiko-reveals-chilombo-tracklist/" rel="bookmark" title="Jhené Aiko Reveals ‘Chilombo’ Tracklist"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/8TdCpQakuJKCP4dNy1rXBYWjLtNsjGrqmhfD0zj1GYiMmu_bke99U3REtwolUC8o0cuAWTJL5IWB4FspohGhv8uhaK0ab1pd6YJjzxrRqe4ohbckTNDUzsKSx37kfQRVsdri75X1kcvRPyrW_T4Y3zcWerqKAzfF5tduTypMSTTRxXmkwxTV8BcVrFU98d3fD4AAMXll8cHdzTqlANM3lBvs7LLVBauumAZxhs6aykVPPg5Zj0O8sV3Y7CPGMMjdDBVPBt0Vmg5gPFvok9mCWfd_bGdDEhUrFeJzq4psG7TQUQ8sNVm1P-3iqxXppsb1WhbBkYR2fCvkSGBUqtnWxdj9xv_02Be-6yoXR7aUg5e6EPyeFz57k3ySsIL2JKH2bPRmjypuTlANq7pyLU7f6npVloBiG7TNXnAiLzVnQyU_PPRiq8NHKW-FmlTzQHwWFBO8RWMBhKqKs2XzxufSH0i3KGyMiX0NlI-U1TJxeQ6RzCwCv6Zv7nDMK8auz-nhBmtbhidZdNPDAQqnr22Z2IuEqQQGo7OEnvwBmgqLl94MddplzYL_wadj7gLE8WgWOEGPGIlamfpdGiN3FHIkQSK_tiuLZUbEn640jsy5h9Oq6tDVVtZ995mRpQuGNbjWcWB2plSfGTfdOz_ThTuw26LKmgAL3B1ovtn1Oxlc9ZlycQzmnbbjtig7=w596-h597-no" alt="" title="Jhené Aiko Reveals ‘Chilombo’ Tracklist"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/26/jhene-aiko-reveals-chilombo-tracklist/" rel="bookmark" title="Jhené Aiko Reveals ‘Chilombo’ Tracklist">Jhené Aiko Reveals ‘Chilombo’ Tracklist</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/15/new-music-future-drake-ft-dababy-lil-baby-life-is-good-remix/" rel="bookmark" title="New Music: Future &#038; Drake ft. DaBaby &#038; Lil Baby &#8211; Life Is Good (Remix)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/rk1jco0BhIjT9jJ4IBFNtEs75ADsRx98ELl9MvpwNFfvNUNS9gLRF5BdmnULnFZyFmPYS1RM1yN_FRGPNTTVG9gcYukSNwAYFSk-6YflSUpMfBkp-9dfhmgJCGcbq2A1Ojfv7UbExd4avO1yfkPNmzn9oeEGTRbTkdjb3yQFWFw3p_oGrFLnTrA-KyR_7domHJxgCQ7lWjG7z3WmFa0oplYPUrfBMFI17IjvhqmgQP-OWXvwX6XT3HfXhUbtWTSqiVi4iv32E1zphdVYuHd7JiaaP2qC5ddfnzDVy-3herEOEKTvytO_-5nJQbCZAblS-WqbMpu-WOfbaHyK9Fuq1YFZwEOQZpcM6ewmcH8wEjYir9tFFeyA-A3GmiARcqhdYgaRgsm8D02gAp9dObww-0cRFV4AiPjxe1_Wy3wJ0EgurfbyEONFqzbiV8zIpsd_6guOGiVyMwuoFPuxgoHYNXNBIq753Z590sxq4tmlLgZvZQ8QM6zqItee2yCuU0CQ0n3x5zs3tq-HjuJ2Cn_egwtEV6kVXW9xWi6aqg8_vNt0g7I5cDJSUl3M4B1sQD9r6voK6vg4LJn4vOk1AgiEd_EMt-h4UhVpENXhNThxOkFOLkFfeX9WMq-5vwqhIDoxt4o23r3h0Dv7U2B9Vc2Z9cefgG84LV2mhocpLX_0ZhEDM9ol-R6GeZsb=w970-h547-no" alt="" title="New Music: Future &#038; Drake ft. DaBaby &#038; Lil Baby &#8211; Life Is Good (Remix)"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/15/new-music-future-drake-ft-dababy-lil-baby-life-is-good-remix/" rel="bookmark" title="New Music: Future &#038; Drake ft. DaBaby &#038; Lil Baby &#8211; Life Is Good (Remix)">New Music: Future &#038; Drake ft. DaBaby &#038; Lil Baby &#8211; Life Is Good (Remix)</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/01/24/music-video-marlo-ft-lil-baby-future-1st-n-3rd/" rel="bookmark" title="Music Video: Marlo Ft. Lil Baby &#038; Future &#8211; 1st N 3rd"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/AWgaSygeZj9IiQXJCUuwBXDr8g9oVOknk91nZdf9_7LNhVHWP-a2iTjPR3DfUyOy9e_99jwCmLjySbVXAFOfMGHWJikHJuW7UGxGhKWTzQ_NPWlvvpA6Nm9sZPoJglV8H4XTTCr_zePLHw-lD37lz75YIlx_JusXpOi3blJLXyVb9Ln7MwgsKl4uVcvxS5pTLKRbAcX1wgK_dwdHVcoN4SLJhtSGkgwTRUbl3ozelfNrdTeVkzM5h0rTNSE2yJQsjrgPYiocKmT3nyUmfVo7ZaX6WTVZFmKd1yzYe8KLD9FHDl4jsIPwzOlmtVZV2gkmoiVJmut2JfeVNNXKtkbboeQoblkTaz7CrVlVc3YiA2Oid7E9gmbJOP1itYe4LwyY5MoWxq8K6RoACxbatIWTbA8ZBoHZ6dmSTfbaw-Bjju6x_HOHM0v7YC3XNHCz4ORleLrk17xqTRAFx_qMXelvaCph46DaRWKBBnOAQ7gvBVli6L8Afwj2Dmcq6rHNjZpdK7uKa1lhXpeWPGXdHIsedvaXaIRjNn6OzTwDILwGXjIEKSfQ4o20-ffC2CDR9kNXAOYxVxB7t_98OXtN28QZDnXg8VCBc_ER2_j_u3_dMBW1N1DcQWuM0TMrrBCmbd-vUaORYGDPV5Dru2Qtt8eqpXLEnvATt_raneCwBNClDY24RpQViAyOOtxt=w648-h580-no" alt="" title="Music Video: Marlo Ft. Lil Baby &#038; Future &#8211; 1st N 3rd"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/01/24/music-video-marlo-ft-lil-baby-future-1st-n-3rd/" rel="bookmark" title="Music Video: Marlo Ft. Lil Baby &#038; Future &#8211; 1st N 3rd">Music Video: Marlo Ft. Lil Baby &#038; Future &#8211; 1st N 3rd</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid-->

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/01/21/music-video-2-chainz-ft-future-dead-man-walking/" rel="bookmark" title="Music Video: 2 Chainz ft. Future &#8211; Dead Man Walking"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/I_fG-HxxoI8KaWnXZwbw0Vpf9cRSq-YULuRCnnTsGb8l9OdCU2GyoKtbS6wqOAND2lP5DJPboOcJBNEXQtGqdhF02a-7Ms2viCBY603FDWTQGwjFVrwNt1vfvLPk4MVDrjJQzThzyfhYhOc0IOUIsucItU1PpTuUuvaalEEFFhYnn9hCnV_bL7bplLf78tcY7D9zHsGCMCz_FkIyf__we3sZgXHGGb2T4Ss0kUAU1xSdbM8SD9Q6Dr9DeTtzSyC5coIBsXuarXoj8CVXYtbimOYOW6iexo5556aneFFduc9buYDpfSQv7GKnYWP8vR7QsMLoQYyOKtCQ_jOyrEILEbQXujB4zmmwoMdIBMVHpTgnar3bLhR0_e1xgUp-ikR2mmpctdcbeJxnbXrNtap1PsWQ_mFoV2h3XHl9cVUK9gf8tOYoyYSa7hhc5fEw2Qeg0FTzeBVt1SGW1-MxlHPPRFTembe9hQ3RI9lq0Nx0ws5fdfmZHJQtLCmHvICVpn9s93-nwbg2KEU27s6iLMXEsK-pT-pxn4Ozy8LMP1YOxRqji1zGp7B0_SBX3DtZScC_yIgvvmd6T4n4P43vUjEQvV64titYFjUbbuUDKdg2obFnGhK3gF4LwNmkWNA49agV7U6jQ8hfkdgPu0qH0yEXKPx59m1Wj9foIhNxmIwFaC-NwmMIz34ZFoxg=w900-h553-no" alt="" title="Music Video: 2 Chainz ft. Future &#8211; Dead Man Walking"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/01/21/music-video-2-chainz-ft-future-dead-man-walking/" rel="bookmark" title="Music Video: 2 Chainz ft. Future &#8211; Dead Man Walking">Music Video: 2 Chainz ft. Future &#8211; Dead Man Walking</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/01/19/new-music-jhene-aiko-py-fairy/" rel="bookmark" title="New Music: Jhené Aiko &#8211; P***y Fairy"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/ys4eKWmaanmTPFuO-XLdxy7pReCLmstTtlESzUXR2TINixTagZgrYNb8XxBuCyAUJ_d7mpYFiIeKV0U9gHD-7b_M1EA_2fSVvFJzmwn62jlcnn3VyuxOkJro1HB2EK-BlRFWy6Or95z_5w5kkM5IYo2ZM5_jatDml1Q9qJITChQdQpkmgfHDsfDZioFk9JKzjuG_V0RxSrsYrLuw82e7CicU03KZawn888y9RZ2SnawNayQaOHFmjH38L3J7x5zXS3QaSr9yrZ_ZzStj-D2hVFILnavoZlQqMTgA26NblDiDzwh4021cBdcxeU4blEb6tjez5HwJal9FP4mFsRtsbuA7z8uK9kBNAoN-A3djRjH8RTYZmch9RsTB4iB17YPXXIQRt2uyi9-Kh-emp2zolbZVxZHN2Fvu6OqvAsrycod11hbnZADLH_0drNpwW8W66epMpdZUjOG6uNOfekToxLAA2lD-juoOjtifQsKih5CNW4N5BauunUGfZQnqjidQJgmiGIxZrYoGtALFnRJtDqljzN2pms2GMnYYDf0kIrAVopRgmnpDYYsSsdba1ifvhZtwY0rJrvTqgVzJgLG15pdGQwMt9t1WbB7Oa2AsrXNWbV3uL_WHUfiZpLZe-fiJbBava65XR_U0oXEq7tjVa3Nq_ChyPKtK50eMVBIn0lvDQjuebwXBl0tq=s500-no" alt="" title="New Music: Jhené Aiko &#8211; P***y Fairy"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/01/19/new-music-jhene-aiko-py-fairy/" rel="bookmark" title="New Music: Jhené Aiko &#8211; P***y Fairy">New Music: Jhené Aiko &#8211; P***y Fairy</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/01/10/music-video-drake-future-life-is-good/" rel="bookmark" title="Music Video: Drake &#038; Future &#8211; Life Is Good"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/mkwGjZZDM6YlZEo84JbSWzRwyCU_sSc8pFPnlizbUG8wsDkFViWXb4DUjHHabkVqCdOLrZFnIz4SlSVwvCKvou9-eX9etJafX5GCI3P69qfUuPtELT6gUFTr3ibmwrbb7oId3E0uKTc9qnpziCofyaRouQtcl8tGHbspkqoLkuhpRbgX9Zqbqmmtt_DQ-FEiBgGuLsiMRg43uy_Be9VRBy1O2du1Cy4Dz4-0MdFNlbTcR8JeBpaMXIgGI39pQuAT7gGGYI7-1swzFsZZhGylSVSpqLeCI-QHU8PBHxd3KQqYLQCyGvAP-hA9-mOOCcUlznGSj4bEb6lxU4mSt5H-wjiyYMIYvHwJXTLcQiuErCw1Ao2KHnuo9u4-WJ0T-QyzmScCFiUny4L0iFIGbkR0rOe4sFKJfByGqZQurDz8RWxuffynkJ_8bxuKqu4tEbat1vOvXDD8w2wjppLZHbk1FIUdiXqmEqzoydnHHvT4z1HiIBZrlKpO4IxJMPWik1BipGoYkMAgwuVx0-VLfZKxKz2DjsjD-LxL7j0WbU5yazw3autbTMZSco7P7-mbrds-03DUGTdwhtiH1vCcAJ1wen3LsOOUXGQv4kgwjTex09D0yX4E7wc5TERbDvAGRD9YtGXLqZHfq-dMEq9ARul8Xi7JkFDbl55wr8p6ShUoeSUdKbIpkkBl18XR=w804-h465-no" alt="" title="Music Video: Drake &#038; Future &#8211; Life Is Good"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/01/10/music-video-drake-future-life-is-good/" rel="bookmark" title="Music Video: Drake &#038; Future &#8211; Life Is Good">Music Video: Drake &#038; Future &#8211; Life Is Good</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_15_5e591c2dd6556" data-td_block_id="td_uid_15_5e591c2dd6556"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_15_5e591c2dd6556" data-td_block_id="td_uid_15_5e591c2dd6556"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->

	<div class="comments" id="comments">
            </div> <!-- /.content -->
                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <aside class="widget widget_search"><form method="get" class="td-search-form-widget" action="http://weuponithiphop.info/">
    <div role="search">
        <input class="td-widget-search-input" type="text" value="" name="s" id="s" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit" value="Search" />
    </div>
</form></aside><aside class="widget widget_text">			<div class="textwidget"><h4><strong><span style="color: #8224e3;"><span style="color: #000000;">Listen to</span> <span style="color: #c60000;">WeUpOnItRadio</span> <span style="color: #000000;">Live!</span></span></strong></h4>
<p><span class="cc_streaminfo" data-type="song" data-username="cyclone777">Loading &#8230;</span><br />
<script language="javascript" type="text/javascript" src="https://control.internet-radio.com:2199/system/streaminfo.js"></script><br />
<iframe src="https://tunein.com/embed/player/s292400/" style="width:100%; height:100px;" scrolling="no" frameborder="no"></iframe></p>
</div>
		</aside>
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-sidebar ">
<script type="text/javascript">
var td_screen_width = document.body.clientWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 

<aside class="widget widget_text"><div class="block-title"><span>AUDIOTRAFFICKER:</span></div>			<div class="textwidget"><p><iframe src="https://www.facebook.com/plugins/video.php?href=https%3A%2F%2Fwww.facebook.com%2FAudioTrafficker%2Fvideos%2F326277991409372%2F&#038;show_text=0&#038;width=560" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true" allowFullScreen="true"></iframe></p>
</div>
		</aside><aside class="widget widget_text"><div class="block-title"><span>Kaeyel ft. Martease &#8211; For My Dogs</span></div>			<div class="textwidget"><p><iframe src="https://open.spotify.com/embed/track/21SM8X1m50HOUwbvH8i1Z7" frameborder="0" allowtransparency="true" allow="encrypted-media"></iframe></p>
</div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><div aria-live="polite" id="soliloquy-container-30342" class="soliloquy-container soliloquy-transition-fade  soliloquy-theme-classic" style="max-width:960px;max-height:300px;"><ul id="soliloquy-30342" class="soliloquy-slider soliloquy-slides soliloquy-wrap soliloquy-clear"><li aria-hidden="true" class="soliloquy-item soliloquy-item-1 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109673710?productType=812&#038;appearance=1" class="soliloquy-link" title="Revolt Tee" target="_blank"><img id="soliloquy-image-30349" class="soliloquy-image soliloquy-image-1" src="http://weuponithiphop.info/wp-content/uploads/Revolt-Tee.jpg" alt="Revolt Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-2 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/youngongetthiswork?q=I12154011" class="soliloquy-link" title="You Gon Get This Work" target="_blank"><img id="soliloquy-image-30344" class="soliloquy-image soliloquy-image-2" src="http://weuponithiphop.info/wp-content/uploads/You-Gon-Get-This-Work.jpg" alt="You Gon Get This Work" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-3 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/savage+bloody?q=I1014473415" class="soliloquy-link" title="Savage Bloody" target="_blank"><img id="soliloquy-image-30343" class="soliloquy-image soliloquy-image-3" src="http://weuponithiphop.info/wp-content/uploads/Savage-Bloody.jpg" alt="Savage Bloody" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-4 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/can?q=I1011767996" class="soliloquy-link" title="spray" target="_blank"><img id="soliloquy-image-30345" class="soliloquy-image soliloquy-image-4" src="http://weuponithiphop.info/wp-content/uploads/spray.jpg" alt="spray" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-5 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814012" class="soliloquy-link" title="Good Vibes Only 1" target="_blank"><img id="soliloquy-image-30346" class="soliloquy-image soliloquy-image-5" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-1.jpg" alt="Good Vibes Only 1" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-6 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/blessed?q=I12044252" class="soliloquy-link" title="Blessed Tee" target="_blank"><img id="soliloquy-image-30347" class="soliloquy-image soliloquy-image-6" src="http://weuponithiphop.info/wp-content/uploads/Blessed-Tee.jpg" alt="Blessed Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-7 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/trap?q=I1009984243" class="soliloquy-link" title="Trap Tee" target="_blank"><img id="soliloquy-image-30348" class="soliloquy-image soliloquy-image-7" src="http://weuponithiphop.info/wp-content/uploads/Trap-Tee.jpg" alt="Trap Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-8 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/good+vibes+only+birds?q=I1014476779" class="soliloquy-link" title="Good Vibes Only 2" target="_blank"><img id="soliloquy-image-30350" class="soliloquy-image soliloquy-image-8" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-2.jpg" alt="Good Vibes Only 2" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-9 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/all+seeing+eye?q=I11739019" class="soliloquy-link" title="ILLuminati" target="_blank"><img id="soliloquy-image-30351" class="soliloquy-image soliloquy-image-9" src="http://weuponithiphop.info/wp-content/uploads/ILLuminati.jpg" alt="ILLuminati" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-10 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/diamond_skull_1?q=I12527492" class="soliloquy-link" title="Diamond Skull" target="_blank"><img id="soliloquy-image-30352" class="soliloquy-image soliloquy-image-10" src="http://weuponithiphop.info/wp-content/uploads/Diamond-Skull.jpg" alt="Diamond Skull" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-11 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/donuts+doom-A109792920" class="soliloquy-link" title="donunts" target="_blank"><img id="soliloquy-image-30353" class="soliloquy-image soliloquy-image-11" src="http://weuponithiphop.info/wp-content/uploads/donunts.jpg" alt="donunts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-12 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/crime+pays?q=I12067735" class="soliloquy-link" title="Crime Pays" target="_blank"><img id="soliloquy-image-30434" class="soliloquy-image soliloquy-image-12" src="http://weuponithiphop.info/wp-content/uploads/Crime-Pays.jpg" alt="Crime Pays" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-13 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/fuckyoupayme?q=I11550361" class="soliloquy-link" title="Fuck You Pay Me" target="_blank"><img id="soliloquy-image-30436" class="soliloquy-image soliloquy-image-13" src="http://weuponithiphop.info/wp-content/uploads/Fuck-You-Pay-Me.jpg" alt="Fuck You Pay Me" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-14 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814011" class="soliloquy-link" title="savage gold tee" target="_blank"><img id="soliloquy-image-30354" class="soliloquy-image soliloquy-image-14" src="http://weuponithiphop.info/wp-content/uploads/savage-gold-tee.jpg" alt="savage gold tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-15 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/?page=2" class="soliloquy-link" title="fresh-clean-signature-" target="_blank"><img id="soliloquy-image-30437" class="soliloquy-image soliloquy-image-15" src="http://weuponithiphop.info/wp-content/uploads/fresh-clean-signature-.jpg" alt="fresh-clean-signature-" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-16 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/%24teez?q=I1001415610" class="soliloquy-link" title="gold fronts" target="_blank"><img id="soliloquy-image-30355" class="soliloquy-image soliloquy-image-16" src="http://weuponithiphop.info/wp-content/uploads/gold-fronts.jpg" alt="gold fronts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-17 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/soldier?q=I11611241" class="soliloquy-link" title="Swag Soldier" target="_blank"><img id="soliloquy-image-30435" class="soliloquy-image soliloquy-image-17" src="http://weuponithiphop.info/wp-content/uploads/Swag-Soldier.jpg" alt="Swag Soldier" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-18 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/gamer-A7923028?productType=210&#038;appearance=22" class="soliloquy-link" title="gamer" target="_blank"><img id="soliloquy-image-30438" class="soliloquy-image soliloquy-image-18" src="http://weuponithiphop.info/wp-content/uploads/gamer.jpg" alt="gamer" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-19 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/" class="soliloquy-link" title="freshandlogo Square" target="_blank"><img id="soliloquy-image-30356" class="soliloquy-image soliloquy-image-19" src="http://weuponithiphop.info/wp-content/uploads/freshandlogo-Square.jpg" alt="freshandlogo Square" /></a></li></ul></div><noscript><style type="text/css">#soliloquy-container-30342{opacity:1}</style></noscript>
</div>
		</aside>                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</article> <!-- /.post -->


<!-- Instagram -->



<!-- Footer -->
<div class="td-footer-wrapper td-footer-template-3">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
			    		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span4">
                <div class="td-footer-info"><div class="footer-logo-wrap"><a href="http://weuponithiphop.info/"><img class="td-retina-data" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" alt="" title=""/></a></div><div class="footer-text-wrap"></div><div class="footer-social-wrap td-social-style-2">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div></div>            </div>

            <div class="td-pb-span4">
                <aside class="widget widget_calendar"><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar">
	<caption>February 2020</caption>
	<thead>
	<tr>
		<th scope="col" title="Sunday">S</th>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
	</tr>
	</thead>

	<tfoot>
	<tr>
		<td colspan="3" id="prev"><a href="http://weuponithiphop.info/2020/01/">&laquo; Jan</a></td>
		<td class="pad">&nbsp;</td>
		<td colspan="3" id="next" class="pad">&nbsp;</td>
	</tr>
	</tfoot>

	<tbody>
	<tr>
		<td colspan="6" class="pad">&nbsp;</td><td><a href="http://weuponithiphop.info/2020/02/01/" aria-label="Posts published on February 1, 2020">1</a></td>
	</tr>
	<tr>
		<td><a href="http://weuponithiphop.info/2020/02/02/" aria-label="Posts published on February 2, 2020">2</a></td><td><a href="http://weuponithiphop.info/2020/02/03/" aria-label="Posts published on February 3, 2020">3</a></td><td><a href="http://weuponithiphop.info/2020/02/04/" aria-label="Posts published on February 4, 2020">4</a></td><td><a href="http://weuponithiphop.info/2020/02/05/" aria-label="Posts published on February 5, 2020">5</a></td><td><a href="http://weuponithiphop.info/2020/02/06/" aria-label="Posts published on February 6, 2020">6</a></td><td><a href="http://weuponithiphop.info/2020/02/07/" aria-label="Posts published on February 7, 2020">7</a></td><td><a href="http://weuponithiphop.info/2020/02/08/" aria-label="Posts published on February 8, 2020">8</a></td>
	</tr>
	<tr>
		<td><a href="http://weuponithiphop.info/2020/02/09/" aria-label="Posts published on February 9, 2020">9</a></td><td><a href="http://weuponithiphop.info/2020/02/10/" aria-label="Posts published on February 10, 2020">10</a></td><td><a href="http://weuponithiphop.info/2020/02/11/" aria-label="Posts published on February 11, 2020">11</a></td><td><a href="http://weuponithiphop.info/2020/02/12/" aria-label="Posts published on February 12, 2020">12</a></td><td><a href="http://weuponithiphop.info/2020/02/13/" aria-label="Posts published on February 13, 2020">13</a></td><td><a href="http://weuponithiphop.info/2020/02/14/" aria-label="Posts published on February 14, 2020">14</a></td><td><a href="http://weuponithiphop.info/2020/02/15/" aria-label="Posts published on February 15, 2020">15</a></td>
	</tr>
	<tr>
		<td><a href="http://weuponithiphop.info/2020/02/16/" aria-label="Posts published on February 16, 2020">16</a></td><td><a href="http://weuponithiphop.info/2020/02/17/" aria-label="Posts published on February 17, 2020">17</a></td><td><a href="http://weuponithiphop.info/2020/02/18/" aria-label="Posts published on February 18, 2020">18</a></td><td><a href="http://weuponithiphop.info/2020/02/19/" aria-label="Posts published on February 19, 2020">19</a></td><td><a href="http://weuponithiphop.info/2020/02/20/" aria-label="Posts published on February 20, 2020">20</a></td><td><a href="http://weuponithiphop.info/2020/02/21/" aria-label="Posts published on February 21, 2020">21</a></td><td><a href="http://weuponithiphop.info/2020/02/22/" aria-label="Posts published on February 22, 2020">22</a></td>
	</tr>
	<tr>
		<td><a href="http://weuponithiphop.info/2020/02/23/" aria-label="Posts published on February 23, 2020">23</a></td><td><a href="http://weuponithiphop.info/2020/02/24/" aria-label="Posts published on February 24, 2020">24</a></td><td><a href="http://weuponithiphop.info/2020/02/25/" aria-label="Posts published on February 25, 2020">25</a></td><td><a href="http://weuponithiphop.info/2020/02/26/" aria-label="Posts published on February 26, 2020">26</a></td><td><a href="http://weuponithiphop.info/2020/02/27/" aria-label="Posts published on February 27, 2020">27</a></td><td id="today"><a href="http://weuponithiphop.info/2020/02/28/" aria-label="Posts published on February 28, 2020">28</a></td><td>29</td>
	</tr>
	</tbody>
	</table></div></aside>            </div>

            <div class="td-pb-span4">
                <aside class="widget widget_text">			<div class="textwidget"><div aria-live="polite" id="soliloquy-container-30342" class="soliloquy-container soliloquy-transition-fade  soliloquy-theme-classic" style="max-width:960px;max-height:300px;"><ul id="soliloquy-30342" class="soliloquy-slider soliloquy-slides soliloquy-wrap soliloquy-clear"><li aria-hidden="true" class="soliloquy-item soliloquy-item-1 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109673710?productType=812&#038;appearance=1" class="soliloquy-link" title="Revolt Tee" target="_blank"><img id="soliloquy-image-30349" class="soliloquy-image soliloquy-image-1" src="http://weuponithiphop.info/wp-content/uploads/Revolt-Tee.jpg" alt="Revolt Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-2 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/youngongetthiswork?q=I12154011" class="soliloquy-link" title="You Gon Get This Work" target="_blank"><img id="soliloquy-image-30344" class="soliloquy-image soliloquy-image-2" src="http://weuponithiphop.info/wp-content/uploads/You-Gon-Get-This-Work.jpg" alt="You Gon Get This Work" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-3 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/savage+bloody?q=I1014473415" class="soliloquy-link" title="Savage Bloody" target="_blank"><img id="soliloquy-image-30343" class="soliloquy-image soliloquy-image-3" src="http://weuponithiphop.info/wp-content/uploads/Savage-Bloody.jpg" alt="Savage Bloody" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-4 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/can?q=I1011767996" class="soliloquy-link" title="spray" target="_blank"><img id="soliloquy-image-30345" class="soliloquy-image soliloquy-image-4" src="http://weuponithiphop.info/wp-content/uploads/spray.jpg" alt="spray" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-5 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814012" class="soliloquy-link" title="Good Vibes Only 1" target="_blank"><img id="soliloquy-image-30346" class="soliloquy-image soliloquy-image-5" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-1.jpg" alt="Good Vibes Only 1" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-6 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/blessed?q=I12044252" class="soliloquy-link" title="Blessed Tee" target="_blank"><img id="soliloquy-image-30347" class="soliloquy-image soliloquy-image-6" src="http://weuponithiphop.info/wp-content/uploads/Blessed-Tee.jpg" alt="Blessed Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-7 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/trap?q=I1009984243" class="soliloquy-link" title="Trap Tee" target="_blank"><img id="soliloquy-image-30348" class="soliloquy-image soliloquy-image-7" src="http://weuponithiphop.info/wp-content/uploads/Trap-Tee.jpg" alt="Trap Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-8 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/good+vibes+only+birds?q=I1014476779" class="soliloquy-link" title="Good Vibes Only 2" target="_blank"><img id="soliloquy-image-30350" class="soliloquy-image soliloquy-image-8" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-2.jpg" alt="Good Vibes Only 2" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-9 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/all+seeing+eye?q=I11739019" class="soliloquy-link" title="ILLuminati" target="_blank"><img id="soliloquy-image-30351" class="soliloquy-image soliloquy-image-9" src="http://weuponithiphop.info/wp-content/uploads/ILLuminati.jpg" alt="ILLuminati" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-10 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/diamond_skull_1?q=I12527492" class="soliloquy-link" title="Diamond Skull" target="_blank"><img id="soliloquy-image-30352" class="soliloquy-image soliloquy-image-10" src="http://weuponithiphop.info/wp-content/uploads/Diamond-Skull.jpg" alt="Diamond Skull" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-11 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/donuts+doom-A109792920" class="soliloquy-link" title="donunts" target="_blank"><img id="soliloquy-image-30353" class="soliloquy-image soliloquy-image-11" src="http://weuponithiphop.info/wp-content/uploads/donunts.jpg" alt="donunts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-12 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/crime+pays?q=I12067735" class="soliloquy-link" title="Crime Pays" target="_blank"><img id="soliloquy-image-30434" class="soliloquy-image soliloquy-image-12" src="http://weuponithiphop.info/wp-content/uploads/Crime-Pays.jpg" alt="Crime Pays" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-13 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/fuckyoupayme?q=I11550361" class="soliloquy-link" title="Fuck You Pay Me" target="_blank"><img id="soliloquy-image-30436" class="soliloquy-image soliloquy-image-13" src="http://weuponithiphop.info/wp-content/uploads/Fuck-You-Pay-Me.jpg" alt="Fuck You Pay Me" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-14 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814011" class="soliloquy-link" title="savage gold tee" target="_blank"><img id="soliloquy-image-30354" class="soliloquy-image soliloquy-image-14" src="http://weuponithiphop.info/wp-content/uploads/savage-gold-tee.jpg" alt="savage gold tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-15 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/?page=2" class="soliloquy-link" title="fresh-clean-signature-" target="_blank"><img id="soliloquy-image-30437" class="soliloquy-image soliloquy-image-15" src="http://weuponithiphop.info/wp-content/uploads/fresh-clean-signature-.jpg" alt="fresh-clean-signature-" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-16 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/%24teez?q=I1001415610" class="soliloquy-link" title="gold fronts" target="_blank"><img id="soliloquy-image-30355" class="soliloquy-image soliloquy-image-16" src="http://weuponithiphop.info/wp-content/uploads/gold-fronts.jpg" alt="gold fronts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-17 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/soldier?q=I11611241" class="soliloquy-link" title="Swag Soldier" target="_blank"><img id="soliloquy-image-30435" class="soliloquy-image soliloquy-image-17" src="http://weuponithiphop.info/wp-content/uploads/Swag-Soldier.jpg" alt="Swag Soldier" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-18 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/gamer-A7923028?productType=210&#038;appearance=22" class="soliloquy-link" title="gamer" target="_blank"><img id="soliloquy-image-30438" class="soliloquy-image soliloquy-image-18" src="http://weuponithiphop.info/wp-content/uploads/gamer.jpg" alt="gamer" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-19 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/" class="soliloquy-link" title="freshandlogo Square" target="_blank"><img id="soliloquy-image-30356" class="soliloquy-image soliloquy-image-19" src="http://weuponithiphop.info/wp-content/uploads/freshandlogo-Square.jpg" alt="freshandlogo Square" /></a></li></ul></div><noscript><style type="text/css">#soliloquy-container-30342{opacity:1}</style></noscript>
</div>
		</aside>            </div>
        </div>
    </div>
</div>

<!-- Sub Footer -->
    <div class="td-sub-footer-container">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span7 td-sub-footer-menu">
                        <div class="menu-top-menu-container"><ul id="menu-top-menu-2" class="td-subfooter-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-mega-menu menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_20_5e591c2de8e5c_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_20_5e591c2de8e5c" ><script>var block_td_uid_20_5e591c2de8e5c = new tdBlock();
block_td_uid_20_5e591c2de8e5c.id = "td_uid_20_5e591c2de8e5c";
block_td_uid_20_5e591c2de8e5c.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"43","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_20_5e591c2de8e5c_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_20_5e591c2de8e5c.td_column_number = "3";
block_td_uid_20_5e591c2de8e5c.block_type = "td_block_mega_menu";
block_td_uid_20_5e591c2de8e5c.post_count = "5";
block_td_uid_20_5e591c2de8e5c.found_posts = "2810";
block_td_uid_20_5e591c2de8e5c.header_color = "";
block_td_uid_20_5e591c2de8e5c.ajax_pagination_infinite_stop = "";
block_td_uid_20_5e591c2de8e5c.max_num_pages = "562";
tdBlocksArray.push(block_td_uid_20_5e591c2de8e5c);
</script><div id=td_uid_20_5e591c2de8e5c class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/27/new-music-swae-lee-someone-said/" rel="bookmark" title="New Music: Swae Lee &#8211; Someone Said"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/AC89OJ2O7MoIM4tot9V2mKy4X2xmzZwlA63K-l3xrIZP-Md6a0wADsIlC3utTeHNWqdg2ctZVfsJJgsxr-gsRAOEG9ZeNQV0QNrcrJuBqD4xiAsrOu8QrK8Volw2lRk8DhYslVg3H5mZRIrvfaJ2ZxC0hWvKS7FO74QsszPbbCasQlHzuFjlNfSQ1pXgM-XS7XVkvJ6OHUkpjfwJUSZOiEU5Nmk9OAaF9Vt4Q8SFXCo9pUR1pyszX6tII5ynALuzJcJHGWjnkzNriPKk0LdZXkB94qZMG41oFK7vjU_Qii1aRXGQyKGOOs861gejOJJ88cFpC2ElcR_7lml5PQwsjY2BDEDXGA1CYScZZjtA_a21Z6Kt141Im0ru0paIc1aVXuf4ccsNrercDzpNQ-ZTX3_nqmj-l4WO5Z0RiSyaWTe3EbeR5p9pgCzNq746hj4ibv2GrSBm25FpL6JFwZ89SR6CupVYbT1ihAGA79OdG7ZBWSp8ZfpmtcPit_-qirLyanniTwWw-63-8oItriDqFabARs53Jm70M2fpvbSTQPL-jKhXjqQppNRpKliwbLucKFG3XFW_BYtZ7HGIRIaE6v0h4KzDuSRtGobDrK264IAZq3gn3fWvZm5spjpDootNVfQPUNcEKiagROVJzluGC7D-Ec1par6RafzIe8qzC7vsTehe3guFiNrQ=s758-no" alt="" title="New Music: Swae Lee &#8211; Someone Said"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/27/new-music-swae-lee-someone-said/" rel="bookmark" title="New Music: Swae Lee &#8211; Someone Said">New Music: Swae Lee &#8211; Someone Said</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/25/new-music-injury-reserve-hoodwinked/" rel="bookmark" title="New Music: Injury Reserve &#8211; Hoodwinked"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/d7_er6cqkVycz7vKPZDk7DAxZxDJi3GksGyr7jDJKb0JJw67fIwivvim6_DI10XJpdLTNeNY7lkjz-3Hrc5q7Pk7qKk4dth_SnpQZYiWB72hBPepiwkVC0NofP4igRbb5s1oZts-dBCmZjl3C4S0b4hDdtd07ivcxy1ymlG3t8a4r4oHvO44Y3vbtuGbVul5Y9u4QI5H7izaAaNPtcJbW_oiVFiwijXq-LxaZcavEuvJiG558PiBhtXnHpcup-zH0vqK98sQfiyjQ_G2LXpYEh2-wB4quGO5H9rrUf8hLYgXIlYZ1wdVYbknXnqTDEWr-IehS4Y1g0BCZ_P5aI-RxqFoIwoUVpvU3ckmwoTxpQVJo6nNJTsiK95sKSvHpgFhrCstFrY_ch2OROHi_S2cS_1_tiSHGvkeZ6vXmVgrYDoTRhfeV3Jci8BVTzOr8zP3lbcHuQzScA4SccV7bxCPNsKO3IDHCt5IUGxvY0eg8h2PyymsYAmV22ml-fNncyCbLxePStciezD-t-76-kXdszFfyL4IEerwvuveSLzzgLJc8nYFmr8sRg22SZlUSrIQEH94YqrZhjPiS1aToVqo2fRfLSnLF-EjYfTLJEzN-G3DGcbMC3oIcFjoIAuY3TBhMOgzR8Rzv1h11g1wTh0FG3RruFGc_jfTxU-eovqNMtUMAziiQ7Ky_V0I=s700-no" alt="" title="New Music: Injury Reserve &#8211; Hoodwinked"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/25/new-music-injury-reserve-hoodwinked/" rel="bookmark" title="New Music: Injury Reserve &#8211; Hoodwinked">New Music: Injury Reserve &#8211; Hoodwinked</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/25/new-music-m-dot-the-atonement-prod-by-pete-rock/" rel="bookmark" title="New Music: M-Dot &#8211; The Atonement (Prod. By Pete Rock)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/ZTXRSzhejV4E9kel3YxTQ5LdeGXguXCAcnb4iRCo4wrGFpgY2WkQvDafNJeyW8pbBuyVb24hMsZGtL04WRf4RpKXhXLy_T_EJ9kzph5GnyKdkanVPRfz-C7VDZJXg1nKWZJXJKYyfJ9mDro_t4NXX8UmnQA9YBK7VN55IoNf8lqPMGLe8cpr4kL7sEiSFeQ7Kve-RzfwU4BEFF0t5B4NASwMr2inHu4HBEgE312sh7MgbaF1hOR39FMpOjAHqK9OSrQeD50gZgiPhtAL8IlmiEkMCjczCrjWEthjjz5PYSCFbdKjvJ6hSR3a78QMJfH7Ynv8Y5klZsWEqRnXG-AZnrQM-lh62rgJnjFNwnGCwyPAMu6ndg8LSjTV-ujN2Mq33sVa7LyVi-nCcl842TnRtkeMPAnOONlJdLQlfQ01zM7D4lGvqVYo_UipncGNMn1U46U3siVNrk3TDzCnBT_87cgJ0Cvpl5-g5k3ZLecanOfPCM16XTx3SSi885czbv-FTYyvnhCEwV9jhhpbKpIQG3guG5Xt1uIhDFtv-yEbh_9P1kvjbs1xyKfahivX5f14GnQXnJ9pwbBEjDR3Ak8cU1VqTl4-5CxRZTpQX2jckXyvtJoiLjOWJ_FH9_ADngW6fOPGXdwOH6lv1YvOonrK8B2tbdwS2_p-DXLfGbVZXpOSev5oITMpSLj4=s650-no" alt="" title="New Music: M-Dot &#8211; The Atonement (Prod. By Pete Rock)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/25/new-music-m-dot-the-atonement-prod-by-pete-rock/" rel="bookmark" title="New Music: M-Dot &#8211; The Atonement (Prod. By Pete Rock)">New Music: M-Dot &#8211; The Atonement (Prod. By Pete Rock)</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/25/new-music-thurz-two-on-the-ten/" rel="bookmark" title="New Music: THURZ &#8211; Two On The Ten"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/MvaiDaBbEw9gQSNncaPxIoqAW-KgctYJfTmOA4zVrDmPQOT4oC6WR9AKkhm_CCnSfTnljZBMOPi_N4h-92uJMSwL1y60HVlpOV4UtzPwsFnuegBNV4ZDuCbRfIWq3vcaEyAmd1L2hWhvEP16qBWCYt6oYd6dQNY46pFtXcGSu7vYTVlb1RUmcw7XdjJN83T0oQ23CPBoTf4W9Wpcl3Tm8bKrDnP1HjmDvO78WLFjmy6_3o_Xt54ytC5KAIgI_BIDfgWaWlzvk_l-YV1yHs4j1grIVa-3Jg7v9DtMr2WofqVVQ-bRdcHHQ8d20ZgMZ9jg_y9InYwcWxjQNm4MlyIPZjYCfSYp98VLtzxvqDZw3Q6-eOmU9C6kGyWfkAmXpIX1lXfvKfR4NaMwXG6_z8J3DtRNnxAfiVDjt0FfD9FDnuX-uRWOd338gkn2taylEX9jSSESeUroXjZlUsy6XPqzIbDj_aRuNZqX3MdeKCihArCMtEavrEbMPd_U57c9VNbJgCtDa4JF5n2SF8CYcSrFR5cQydpCWCAoNEJyygglJHCNGBrbDjSYp0G--yw0_5sNG0r-J5y90Ve81MkSTVmQ8tLTp0gwisCUaEQmbzNAnYhp0ezjK-pdnQ0CcyrUWI90QGbLaSbFNJ4N3zUg0d4vRuA5UfoQ-_DnIEV-7gWhxCWdm1fFneKKM1un=s500-no" alt="" title="New Music: THURZ &#8211; Two On The Ten"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/25/new-music-thurz-two-on-the-ten/" rel="bookmark" title="New Music: THURZ &#8211; Two On The Ten">New Music: THURZ &#8211; Two On The Ten</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/24/new-music-yfn-lucci-ft-jackboy-fuk-it/" rel="bookmark" title="New Music: YFN Lucci ft. JackBoy &#8211; Fu*k It"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/HJil6cRRCBLuTaYqeY6Q5br0p-WgYrgMdOLdEhxdfiJVIusLLxsAcni3N6pcbRAIj4ZH2ne0iQys7nZe7loEMFvDPx4GOG_MdfTeFVdMVkYIHKkYJWvOhUPWqiAKoVztoBRvbXzeHYzvytwnUmxhhMtBdhx7JWcu9hwFVpKgH0x3rNb50EGlI48rYc3HKQC6MRq8jeArW-VT-_vEDC4YzJWKdHEX-53BFTFV4PbiXrOc7uGEXTMV0qA4NMGpXSDVkFwJ8MNLdKLPmRo3qZ0haMv5XxkP8rn91wzHNIBfZudbz5VlTrF2FaONTt63dB_luzs4zV4gP8NBUl-ZTJY-__g10g0YLtvTBnK2_Rd2apLZsjlhSjiwISjQneZzqPBjYgc5Mz4H0Sl_5tLZMLDA-zQCSnixK-UheKButA4X8u8h8yG6AZu0HNZs-ke2BT0HKr8akxLTjHIvrGo_LTBtQo9pnkYxrBrBFqTnGNlF3Ze2PuVwabqsYisCGKRoXcLIzC23KaH1jtS5LvodKBo6CcikTpdbrRN26Y03Jtk06WvzhKszTIG9Q1L_f1veQfU_hxfcvGmWG3IU3EFQ54dqd1Bx0Gieg9w-3iuHNdDCDNX-IG1Bh7jKmTrvz1cu1Zvz2EeMZNW_J4fWoq47AbpVcfkn_FCcL-F48WWYbCvq57y2JpdesjGWG8Il=s758-no" alt="" title="New Music: YFN Lucci ft. JackBoy &#8211; Fu*k It"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/24/new-music-yfn-lucci-ft-jackboy-fuk-it/" rel="bookmark" title="New Music: YFN Lucci ft. JackBoy &#8211; Fu*k It">New Music: YFN Lucci ft. JackBoy &#8211; Fu*k It</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_20_5e591c2de8e5c" data-td_block_id="td_uid_20_5e591c2de8e5c"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_20_5e591c2de8e5c" data-td_block_id="td_uid_20_5e591c2de8e5c"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_21_5e591c2decd3d_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_21_5e591c2decd3d" ><script>var block_td_uid_21_5e591c2decd3d = new tdBlock();
block_td_uid_21_5e591c2decd3d.id = "td_uid_21_5e591c2decd3d";
block_td_uid_21_5e591c2decd3d.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"97","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_21_5e591c2decd3d_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_21_5e591c2decd3d.td_column_number = "3";
block_td_uid_21_5e591c2decd3d.block_type = "td_block_mega_menu";
block_td_uid_21_5e591c2decd3d.post_count = "5";
block_td_uid_21_5e591c2decd3d.found_posts = "986";
block_td_uid_21_5e591c2decd3d.header_color = "";
block_td_uid_21_5e591c2decd3d.ajax_pagination_infinite_stop = "";
block_td_uid_21_5e591c2decd3d.max_num_pages = "198";
tdBlocksArray.push(block_td_uid_21_5e591c2decd3d);
</script><div id=td_uid_21_5e591c2decd3d class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/28/album-stream-lil-baby-my-turn/" rel="bookmark" title="Album Stream: Lil Baby &#8211; My Turn"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/MofR_oL3_qmfuCntuZJbSgoHmz9Lh7vlOxLDzjeZuWDguqe31xUpnWXB-JBH9pZBC_NC_gupWXaDCa6S2JCoclf6PwAy5j8JMC7dYiPHklOzY17AplvYDpIABoDomjoM46kJrNnXc23F4VwoBMyccW8uLvdq-MWUVykzE6e_bh59Jb_nXQfhjM7QDfCmnuUGXoGkcafS1sTvd-piHngUtNES_wPQwmZNhjJO77AlRwm4jo8OFdTezaa54E3ZVprgpFuwA3VJh2G3ck3uT6KaCALHb7pDJWtJt4oHDjOWWTrSr6qz5A7ewxzmnZgYXkIcZRvf9ID38rcRDuHwKQFEOoyAvkQUXae5BsMpoxlIYIiAcyJ4eSKofbD_cZh40nqdaPXU3286nA5I05FrsDKTM384pvOs9ti0XJJgCrwjuVlnj9j2GcPDUDuNAez5Wjds_oxA7_ri_5y2dj6ONA7Lo5rXyZau8lg9zYzW9-XA_fyA5mQ2qgAY_9gO8o9oSzQrCASttKXFaibEdrS23oICj0EIZua9k3eA3NEYQ_sYA_Bu7JZYD-jXBUZty9S7PL8cJnPrEaEJoCz9ZQOy3SE-ukwWzOE43qfjsfZbOfXUNKobWmBCd9ovqrQo8P1zUUfS3TiPA2L4DMvTtudWsKt4jDO33UiCv3whJZ6x4z8zD-WzXnzs_WU58Oxe=s500-no" alt="" title="Album Stream: Lil Baby &#8211; My Turn"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/28/album-stream-lil-baby-my-turn/" rel="bookmark" title="Album Stream: Lil Baby &#8211; My Turn">Album Stream: Lil Baby &#8211; My Turn</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/24/ep-stream-deniro-farrar-sole-food/" rel="bookmark" title="EP Stream: Deniro Farrar &#8211; Sole Food"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/EFv-vhjCINN7VJmQjaAvv8RCrlVYsgwf21X66fH2PdHAly4Zo_uUOPJ1fxEN3oMztmFdKUkc6JqlfXT_0hb-MukaOktuZ0fzOzSROaqinyPJFzrQQAdio-_BoCpVacdj6oJPB41282qttDqS9JpDlpKI5LuZTHrNx4PhJtG7hV3MAF5D4ACG3z9vCNG3X1uJYnTUYUqscImJi36ylBOc55uzTJIc0xGDtW2N3c8Zp5PicFzGZtWe1hS1pcq86xYHp6tXD8sirlyJDIZTKSq1xyeyWjapjwMYZCaZdEGxo3pq4FO1FnOrUQioSbI1rdA9lTTn4gpQyhJJdI79UyZea6ffQIjWqLnyvqWJ-O25pexjCaENsTFZU9XeV7Obs-PHiaImlnpGffAjL7CXVCUBFRB3fKn5dui6HMJhA5-FLfkGpGRlRy2aqoOMo1Ob9-XsP9tlnXXW9hVgzTClWmhKz90ZvYBPAyN13jsDuOrgY9wdac3y9JYXFeaj-oUMERxfs5wLvFNrKaFzeNxATAuF2_V1BTs5OYOF6Gu0ThJ-TWukngT0S2tiGtR_Wv-P0F4Bid5Ft4DmrcSQrXZMb7inbcquv-dv6SDw6S65BxURuBGwfTnjgvYXPabsZjisNaIArPeSbHmJVJaeiN9fT30ydU2kIJ4d5HNjzN_DEfEwrkcyzu8FiuiWSfn3=s500-no" alt="" title="EP Stream: Deniro Farrar &#8211; Sole Food"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/24/ep-stream-deniro-farrar-sole-food/" rel="bookmark" title="EP Stream: Deniro Farrar &#8211; Sole Food">EP Stream: Deniro Farrar &#8211; Sole Food</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/23/album-stream-elcamino-38-spesh-martyrs-prayer/" rel="bookmark" title="Album Stream: ElCamino &#038; 38 Spesh &#8211; Martyr’s Prayer"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/gQl44Ura44x-Dy8mzRVjv_DpCE8U_FaRl6klOTQDMt-vc5cgM-aS1zfbQBImNqv9ysZiiucEZaAU1LzWd5ZEaFsgtrFm5FHETUdHwjqH1OXdd8iKB_MfqJpEZtGuzLmsBWfYbjQko1kaYZe_--kClaGK5vqDdnVXnxm9nqgudIr11jEPQEtPkx2xtcLCw825Bvblck9a1t6JPMwcQ88Uea-0RVEiXDhC2p6SetQAZ0qAQ81vqaI9xdZvGjN84bZP8oi-KXlTVbkkGh1vet0J2BpY_kirUjUR_QNU1mGErPwjHzFX85jBqlFfJ76j8ajOSMJwVCZ5F0HBsB-DjMkjvherj-Mcxu8KPx5hjhIcIMArKOwcdfaCqmyBu33H953BHS0uP6iF8y1-WxVBDqKeDS0TvYdGi2dL4L9FuM3sv42rId9LyUVXIinwkjro6KikkyLkmk2DkOoyP8MtLyG-HzM0mDKIO29g1TK7MOryosry8MeAXdUH0T6loHqOrQ7kLpBbloW1vjfBmwVfAq3AFom5TQfy5LNnlNHYwtAbqAtgsklmdPX-mSFr_RLqzJ_EL4LPR7sIuqzsOFQQkbC3vdBAqcZq_jT0UudPF5siysID7yUenk1nSQIJRR5_KOOUg314t2VKcXWclMrrEA6bnDJVkccecbwsbXAXrdrPklU1o4bgxoyX48FH=s220-no" alt="" title="Album Stream: ElCamino &#038; 38 Spesh &#8211; Martyr’s Prayer"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/23/album-stream-elcamino-38-spesh-martyrs-prayer/" rel="bookmark" title="Album Stream: ElCamino &#038; 38 Spesh &#8211; Martyr’s Prayer">Album Stream: ElCamino &#038; 38 Spesh &#8211; Martyr’s Prayer</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/23/album-stream-curreny-thelonious-martin-3-piece-set/" rel="bookmark" title="Album Stream: Curren$y &#038; Thelonious Martin &#8211; 3 Piece Set"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/7xEwqXJ9F0Mlq3QxAA5a-h_AyGV2gayuECKtPW4QAAgR9BbKERv8LsBtnuPiE3HFykEcYHLH2Zxn4sVdnPr72b-cIDVoPumipY7LxFRxrSgFdzeuDYl-fRPZHpMiB2syMez4U8AJvYH-AW02T4q2h8Z0phoGaUtFS7-IeDB4-algAlBsRmurq3S49Sjmp4WqntyWo4fNEd3cdxz0pEeBBlrC2c-N9RMqo_UWpu5PQu_XXkpkCzzoK4AmIXCDzuMoCzMTSW6dRfzU44qOdziql3ldgK6OEw0fHvOu2anj4Umm5pE477F_SV3XTLZDfSejxg5giCdzk8-vx4OMhBSOATAOyGkFAyheConrIGm0Lzt-h3_Ud-I2FYx8hgIyzh0OiWohMIcyyIDpyh7hXh1P0FNJfVjzq04PQz7uJsRbOr-Fu7lofuaSg1P5Jh1Efpc0PLG-Qh2f770M5SkXXXqnhmgMBplrsbHNY5eKsbnOXJyK1kzdDiI8jRB31HmgEeyCXuY1h5n44L8JEceY2VhE1Ts9F19OzJ66XtpkLf4pVpsgtpdh-B-JJsH6n7bcVK4WsEwXKtwcpvpyAuG8tMyS5Y_AixMj18c_Z62BAW3a7gDTw_moVCz4Ly-TgEwfj6eF4JunwlkRQgrjYBhXcJd3gxR3KciSo2XDxHPD2zMWjr6C7dw8B8kco7vl=s500-no" alt="" title="Album Stream: Curren$y &#038; Thelonious Martin &#8211; 3 Piece Set"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/23/album-stream-curreny-thelonious-martin-3-piece-set/" rel="bookmark" title="Album Stream: Curren$y &#038; Thelonious Martin &#8211; 3 Piece Set">Album Stream: Curren$y &#038; Thelonious Martin &#8211; 3 Piece Set</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/22/album-stream-royce-da-59-the-allegory/" rel="bookmark" title="Album Stream: Royce 5’9 &#8211; The Allegory"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/zRfXEgznnL0icLOYd4nPAh0VAunLPEYK4nIa4C7zki-B9UKMdN9PcZ9pVZfKvq2g8bw4azyDrYNrWsEvIf3jH5lxZgcOXVkq8zooAvgFwTMQxztK3utCPv37FaceypEtOQpvmPou1exTXaUOiTX4TGa_s_PviQktEVI-F-pS1rLrr9SpfhfmkRRgl9BGQISjFAVvf4sFYUqQKTlgyp_GFBOCnu9mGwVobZCbI6_-q6ZqghSo5SqUxHavKOdRKBM96vPM-uldN5t6cw73d2KThOu4r-cElYVPMwsG4_R9Lw-sM6fTDf3-47PVoK1ieS2SyghPsdaIjs1SLZc4RUTHwJUqWerhy9SwOUiGMAOyLUyNCzH8R_ova34N033d3KM8fb5TGuZFwjt6Y65ylWJSat_EDzL2-8XEsxdoZLCYIZz5p7OCurVxwnnogx8TKuoYqtxldDFfg-RzpUHfn0DUvpkatOs2qlB3VOJEa4XE0gK26EdYXQnUpkhcM_3DpYtRbtmfq9cuakfukGQTWTACv_4Icq03xkPdUl33yXajDOnTzYYhV1eBmXT4gZYynAcheNzOmR9rL3piaI-dfcKPiTuao7zx4WgiioGfHaPL9oXipQZ8R5YOrKazshCUg8LOWbJtL-b38WLgV4B3HhXnywgvGrHIBACKqeHEBxwXv0OcML5DmXH5ddm4=s700-no" alt="" title="Album Stream: Royce 5’9 &#8211; The Allegory"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/22/album-stream-royce-da-59-the-allegory/" rel="bookmark" title="Album Stream: Royce 5’9 &#8211; The Allegory">Album Stream: Royce 5’9 &#8211; The Allegory</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_21_5e591c2decd3d" data-td_block_id="td_uid_21_5e591c2decd3d"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_21_5e591c2decd3d" data-td_block_id="td_uid_21_5e591c2decd3d"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_22_5e591c2df0aec_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_22_5e591c2df0aec" ><script>var block_td_uid_22_5e591c2df0aec = new tdBlock();
block_td_uid_22_5e591c2df0aec.id = "td_uid_22_5e591c2df0aec";
block_td_uid_22_5e591c2df0aec.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_22_5e591c2df0aec_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_22_5e591c2df0aec.td_column_number = "3";
block_td_uid_22_5e591c2df0aec.block_type = "td_block_mega_menu";
block_td_uid_22_5e591c2df0aec.post_count = "5";
block_td_uid_22_5e591c2df0aec.found_posts = "2737";
block_td_uid_22_5e591c2df0aec.header_color = "";
block_td_uid_22_5e591c2df0aec.ajax_pagination_infinite_stop = "";
block_td_uid_22_5e591c2df0aec.max_num_pages = "548";
tdBlocksArray.push(block_td_uid_22_5e591c2df0aec);
</script><div id=td_uid_22_5e591c2df0aec class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/28/music-video-jhene-aiko-ft-future-miguel-happiness-over-everything-h-o-e/" rel="bookmark" title="Music Video: Jhené Aiko ft. Future &#038; Miguel &#8211; Happiness Over Everything (H.O.E.)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/YBkMcHo-YVBrmF6_KiwWJS6jY6WdMmcxpOvEUegwJOCxtOvRjDt6NcCLMhqRPTG5kPQaLzCgaePKiUuVcZ6LUljvRRR9UFdqUqn9H10gXPxdBLgoxkqhfEFPoSe280ZoyBSoqSAs3g-UlrgaGH9PRbmyIGVGEy7uwpyIRBytpVqEqlcUsFZ-ARfTWaFEUo1YPi6nddHhMr6luvemMhAy4IFzb1XwNS__u9az5RzJ9gOWBUZ8f19VI8LKCpKYtY_hCqUh8W1hOhUwRMCTF9SsA2nBxMmHpwAWUSHmSIjMDVtq7aR3H9kEOsNw29jrhw_EE04Lu3EH-F9NbRRRdNH6LAzMB7ALtTlRrd9Sca4F1KYK_TjVJaZUqSRHcDJO4Chj0WIfbX8_mGue3MlWh4F4DHaxPZfS0tucBq8OyVmOuBMtsT_3e5cLD3t2pUcpOy34ftauAOcjIpE4eZqAffd9__OAspu-a8EqFmuYtkjLW6dEzxEfRcScYZOvmZrV4L1zXcNtw9gtuff3EO6N5SvLZhDReBvxAOX3WvhJewT02SnXNh00sECQVYzA9dsG9lb-EL2jBJko-KZS11HlxSzbZDIAcZSTIf9UrExnrehLFfil-S59C7b0O_ZukOeurfsBig0XDKx78bunZ47EA9mEcSNNyIiQo64E3_fZx92-CC9S8-5Q-_yYzirr=w754-h535-no" alt="" title="Music Video: Jhené Aiko ft. Future &#038; Miguel &#8211; Happiness Over Everything (H.O.E.)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/28/music-video-jhene-aiko-ft-future-miguel-happiness-over-everything-h-o-e/" rel="bookmark" title="Music Video: Jhené Aiko ft. Future &#038; Miguel &#8211; Happiness Over Everything (H.O.E.)">Music Video: Jhené Aiko ft. Future &#038; Miguel &#8211; Happiness Over&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/28/music-video-dj-drama-ft-westside-gunn-rick-ross-350/" rel="bookmark" title="Music Video: DJ Drama ft. Westside Gunn, Lule, &#038; Rick Ross &#8211; 350"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/2_qfApw_QNy1LUjinnHhMeqsG0RfQEroQqw2Xf-4G_2RbOS5PqyQ2g7-cOSbcx9Bd4zsUTEz_kUnywg6XfFFe2sA3sfrJs_6UtrMoT5_sUB31XkE1u6LKn6SEC52M5rS_9dPSLGfzvWpXTB_tp5rkCfCMzjORoS7Inlreo5Rp7wgc1f9QMT6C5nwShKHWhl9UjKiNCkDshr0w_Z-bWBTQNIktf0F0pOtYEZ99sh6QuUX2FOaoH6D61e0Mp9k112b5iMuB-WXgp8qcorqbWwRq4QdUuANZQEO2fo1AAAc1aG0cmgoNAzeNv1HlU_Zbak6FBE8lDH7W8_IvouwQvk5ncwsGDetggXGnwkqkqzAtceuotZ5BBw0I8kIWzjP2yMZjZ8GY8ZcOOXTUCE4qlbNx3CtriVcnGVoeu9YlLn6dTPZAAu2eaujIemBeCWoKL14n4KrkqGd9kjHypsRug-16t_RRK21R_VOCJsLZeCEjCINUK2DJ37Efwf3DwyDB_WRP4owoZorihl7YOdY-5fwNyhmUO_hMBwl75aKRWgLPuTmM9ScZnWO0HoIROrrM4n7yVUh2TStEpsE9eLOtZ2vndprzuDZCaBMolVpKy7Fjw97QpXU_eOgMAiaygy7O4uTj5R3eiE7htuD461VJD3kq-vJCrI8fbTzOpZ-GWo33LHIfbT8U1I1pmez=w859-h464-no" alt="" title="Music Video: DJ Drama ft. Westside Gunn, Lule, &#038; Rick Ross &#8211; 350"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/28/music-video-dj-drama-ft-westside-gunn-rick-ross-350/" rel="bookmark" title="Music Video: DJ Drama ft. Westside Gunn, Lule, &#038; Rick Ross &#8211; 350">Music Video: DJ Drama ft. Westside Gunn, Lule, &#038; Rick Ross&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/27/music-video-v-don-ft-dah-whitey-bulger/" rel="bookmark" title="Music Video: V Don ft. Da$H &#8211; Whitey Bulger"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/e2L0ynZmKGKwkB0xWFgbKwm8FldmmqQa0y0NuUNtguH5SyQvvbapO3nga9UHZOUWoJU8_TTeNLDVNXAj7oI7ySll3jYC3h4COxHVQkJwKI4BwMtuLjDQdLiYybsc7GVOiNuAJgsfERkq4BzcWkB0ixAgHgbK1ynZqYz_IhtacbNHv0IyAhYdWu8IQ8HtWsiNEMqCfXEdg6Kb6ZGBQMwHRbCcC1aJ3RSnc_PWZqDv6J4K3tLatAQje4zT6OOrJc-d8pr0C-2SmzO64_yOo1MPX2-NaWRmphZlmbTA-OU91dKI1eyIfRe5epZdWqtlwpWbnr9uKp_bVRHVH9-yEszARRQO4-01Q3RyzsxrcKa_klvrB1KQkFTkdTAlGqARv0CqVUbx8ur2EluiQdhSQmezo34ru9-h2nPLmzG9P42hTBU6z2YaEA7T_e3o78z87egYOEZUu8R9BvlHEg7-YMLzo4-xyUT0bNgjaXlGHdZPY5p5VhQEC0K_-COHTWpOF6pfss7LLzJc7RksuuUafGYyykB-p1cQjHEuV5ClDersDnsvfxRer6B5SCfdKOBH449wfG5aCcN04GCTukcHhvRBixWoZF9JmJ9aq77RKKz3pi21Ofku3RTW13i_TtjJ1FN3DegQaI9ULpqsr3q2uRf3H-byG59oPLZc808nPzDb341b_1mVzPE4bVoZ=w771-h473-no" alt="" title="Music Video: V Don ft. Da$H &#8211; Whitey Bulger"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/27/music-video-v-don-ft-dah-whitey-bulger/" rel="bookmark" title="Music Video: V Don ft. Da$H &#8211; Whitey Bulger">Music Video: V Don ft. Da$H &#8211; Whitey Bulger</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/27/music-video-doja-cat-say-so/" rel="bookmark" title="Music Video: Doja Cat &#8211; Say So"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/m4R-giACibUB70hG5EawFZSovFpB7k-9TgjdCwfzo2ohPZkfhYsmFgY3HwK6QTvQPVwURz2ixStOo0dKQAHloEVOpeysj9jcr3Fwkp53eFIoGPcDT1TUKqbgat7Ay-t5ecxKKu9_xvNn0NNk3JR-_63v8kH2_OEt-TRelP6JZKwueEHOM2xpnI4x1fahk1tgRL_Kt_OLhhfTR0Ge2MnKXMxFYe2PAjOBpPRdRkRZLC0B_uPvf9vpHZvejcs_k5X2KInbI3qgj5b8-SOxlt8D15y0FTskDLZAOPLJ2VSwNfCXON4SOkhzHqugQ-HCN-mhAAFlCgxDOQbG0G8c9R_y16t0zi-b4aiYQ2JMbn8MuTeaXzpMtBG0MEvLsYtmmNb8Eu87K5uWHthxgnfXUmmV07gFCyjVGB1LaW4_hwCazIWdmIELfbV50akSIq5U2O8GECxFVAKiKfrMJPvEkBPgiuPcYzZHZt-yOlefBFvhRexhvuWNzwg4swji1pOrP1kedvVblhPIneXLNoYska-ybM5v1lnNBjQuyqnutzR00Avm4dgetCxHMfGPvkKeyLRFGWZAGn2dl6vapnYmuiDttw04Birevy7q1V3Cf0knsJH8GMOncgtDuzEeQcAFnzuk2gTL8gtxbbclgQvxXSzWjkUwYcYjq6ASRKwKeME7xRWSdr2VsL_7b6of=w695-h539-no" alt="" title="Music Video: Doja Cat &#8211; Say So"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/27/music-video-doja-cat-say-so/" rel="bookmark" title="Music Video: Doja Cat &#8211; Say So">Music Video: Doja Cat &#8211; Say So</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/27/music-video-royce-59-ft-kxng-crooked-tricked/" rel="bookmark" title="Music Video: Royce 5’9 ft. KXNG Crooked &#8211; Tricked"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/vLNIOjWgiDhwNU4VSn7VpDbLBV-WFj12Mg2xJX5_ADIj5z9wawoXN0RfOqfDlkghuJXffKAtm1AZKGFIah2hl9zkXzjw9E9YeuBeMKMNOqld_qn_0niyL7s6P-KC4VfxOw4u7X0mgI67y2zx1QCevp1sfI3g74otHK5UyogHgrFvciCO8__C0-n-9REppMWgtk7zoYJlU87-c6myrGjRGlnWy_T3r-cEumYnPyhdiPLQnsrnWCOxeB2QhlSkQhAP0YdbZPBInbKdiXzCatKwixbJVK2G15q2wi3My58xHt0dCfaKraNL58QCuupa-332Ms6rZNY8txWALVsrLX3qKSahzdlLR6dULUjyYFVwcgfgaWcab_Wti0QvREcOav8WXqVJCalDc6hs4eX2oY3w2Y2q9lROiyqjfcLQHdHJQtSx6xgx1TpLkgn2_zF6d4uJzg9ptDUYKbfXJ--SKbf3uD8bOGaAQLLxrqCHwB61HHwBcRhl75nQjOCbVIs8mIbrAj66miFmTix869bptSU_ocahlqfw_7zRo5u1TwjqOTkwQVfZiWTu3HrDMs_DReD6W3BSOrBOIlNzcS7JIhfpVd49hOpq31Ovag3bLfg1QIXM0FvNox19eyw_5EnvlddkmVT0jKF-WBTGudQXvYZIVIXyW6JQLrinvclqu7iw7Ogcw3bX_PdF1tpg=w690-h470-no" alt="" title="Music Video: Royce 5’9 ft. KXNG Crooked &#8211; Tricked"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/27/music-video-royce-59-ft-kxng-crooked-tricked/" rel="bookmark" title="Music Video: Royce 5’9 ft. KXNG Crooked &#8211; Tricked">Music Video: Royce 5’9 ft. KXNG Crooked &#8211; Tricked</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_22_5e591c2df0aec" data-td_block_id="td_uid_22_5e591c2df0aec"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_22_5e591c2df0aec" data-td_block_id="td_uid_22_5e591c2df0aec"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_23_5e591c2e001e2_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_23_5e591c2e001e2" ><script>var block_td_uid_23_5e591c2e001e2 = new tdBlock();
block_td_uid_23_5e591c2e001e2.id = "td_uid_23_5e591c2e001e2";
block_td_uid_23_5e591c2e001e2.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"29","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_23_5e591c2e001e2_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_23_5e591c2e001e2.td_column_number = "3";
block_td_uid_23_5e591c2e001e2.block_type = "td_block_mega_menu";
block_td_uid_23_5e591c2e001e2.post_count = "4";
block_td_uid_23_5e591c2e001e2.found_posts = "979";
block_td_uid_23_5e591c2e001e2.header_color = "";
block_td_uid_23_5e591c2e001e2.ajax_pagination_infinite_stop = "";
block_td_uid_23_5e591c2e001e2.max_num_pages = "245";
tdBlocksArray.push(block_td_uid_23_5e591c2e001e2);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_23_5e591c2e001e2" id="td_uid_24_5e591c2e0130a" data-td_block_id="td_uid_23_5e591c2e001e2" data-td_filter_value="" href="http://weuponithiphop.info/category/latest-news/">All</a><a class="mega-menu-sub-cat-td_uid_23_5e591c2e001e2"  id="td_uid_25_5e591c2e01433" data-td_block_id="td_uid_23_5e591c2e001e2" data-td_filter_value="69" href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a><a class="mega-menu-sub-cat-td_uid_23_5e591c2e001e2"  id="td_uid_26_5e591c2e0155d" data-td_block_id="td_uid_23_5e591c2e001e2" data-td_filter_value="80" href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a><a class="mega-menu-sub-cat-td_uid_23_5e591c2e001e2"  id="td_uid_27_5e591c2e01692" data-td_block_id="td_uid_23_5e591c2e001e2" data-td_filter_value="2189" href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a><a class="mega-menu-sub-cat-td_uid_23_5e591c2e001e2"  id="td_uid_28_5e591c2e017f8" data-td_block_id="td_uid_23_5e591c2e001e2" data-td_filter_value="10" href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a><a class="mega-menu-sub-cat-td_uid_23_5e591c2e001e2"  id="td_uid_29_5e591c2e01977" data-td_block_id="td_uid_23_5e591c2e001e2" data-td_filter_value="130" href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></div></div><div id=td_uid_23_5e591c2e001e2 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/26/jhene-aiko-reveals-chilombo-tracklist/" rel="bookmark" title="Jhené Aiko Reveals ‘Chilombo’ Tracklist"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/8TdCpQakuJKCP4dNy1rXBYWjLtNsjGrqmhfD0zj1GYiMmu_bke99U3REtwolUC8o0cuAWTJL5IWB4FspohGhv8uhaK0ab1pd6YJjzxrRqe4ohbckTNDUzsKSx37kfQRVsdri75X1kcvRPyrW_T4Y3zcWerqKAzfF5tduTypMSTTRxXmkwxTV8BcVrFU98d3fD4AAMXll8cHdzTqlANM3lBvs7LLVBauumAZxhs6aykVPPg5Zj0O8sV3Y7CPGMMjdDBVPBt0Vmg5gPFvok9mCWfd_bGdDEhUrFeJzq4psG7TQUQ8sNVm1P-3iqxXppsb1WhbBkYR2fCvkSGBUqtnWxdj9xv_02Be-6yoXR7aUg5e6EPyeFz57k3ySsIL2JKH2bPRmjypuTlANq7pyLU7f6npVloBiG7TNXnAiLzVnQyU_PPRiq8NHKW-FmlTzQHwWFBO8RWMBhKqKs2XzxufSH0i3KGyMiX0NlI-U1TJxeQ6RzCwCv6Zv7nDMK8auz-nhBmtbhidZdNPDAQqnr22Z2IuEqQQGo7OEnvwBmgqLl94MddplzYL_wadj7gLE8WgWOEGPGIlamfpdGiN3FHIkQSK_tiuLZUbEn640jsy5h9Oq6tDVVtZ995mRpQuGNbjWcWB2plSfGTfdOz_ThTuw26LKmgAL3B1ovtn1Oxlc9ZlycQzmnbbjtig7=w596-h597-no" alt="" title="Jhené Aiko Reveals ‘Chilombo’ Tracklist"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/26/jhene-aiko-reveals-chilombo-tracklist/" rel="bookmark" title="Jhené Aiko Reveals ‘Chilombo’ Tracklist">Jhené Aiko Reveals ‘Chilombo’ Tracklist</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/25/video-royce-59-l-a-leakers-freestyle/" rel="bookmark" title="Video: Royce 5’9 &#8211; L.A. Leakers Freestyle"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/xIiYty3TF4CexaBYswNuETDKyoZMMRoLt3vTZlF_AT-6QxWC26GnrLoyIYf06YPr39qKhAxGe3BRppbv_OWVqGb4GOLI4ouG9PoIzO8Coymgg0ilgVQ9shTVY49d7UzzcSRvvUXLFz6cpk7sdpflOLgxK91xz_NOruP0GcDkEeX7BLCdY74vnhaCR8nxqo6jHCcbwBQYccsU1SauaT1rSdGg0pPPGqhpkbNhpLiDnoVxhx8RhrC-SQBMYqnufi965balxmMzllpZZZ68k9FFHCU0qCsRxqxBqZwlXqW5Cn4rRtgRvutmmaAopSQDKfFeYqltL3-ci1waJ0TKVL9rEeCfPby24nhDkACCjBtC9xCEAZtr2OiljDxWpbTgVu3Rp9o8HWNW1-vXuWLVwL8YdMZiJKCiaGajraWaGNB8JCRhrBBsQvsO-kdRYAQbx74zD_SFXBz2bdBVDR22z-hn-CnnlkYD2-YeGZejwLpW2H3pqFQJyr1HgUHpdr1sDer4oyQMdvqUdV6HiQOV6dHDOOLOhrpHc0Um5brvRV__yNPxtFZ75FVICfC5O9Gr1MajlodrDg-Ihz0JgPpd5xmA1uS04PeDg-LAQWEGqrKn_rPY0Oc-FGL6-PtW1DkLhvfRbCd6m9tkT1yiO7sA-anq1xWk3JpmB3T6vMwjqBDk_F91UdUtDNErZQZn=w741-h538-no" alt="" title="Video: Royce 5’9 &#8211; L.A. Leakers Freestyle"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/25/video-royce-59-l-a-leakers-freestyle/" rel="bookmark" title="Video: Royce 5’9 &#8211; L.A. Leakers Freestyle">Video: Royce 5’9 &#8211; L.A. Leakers Freestyle</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/23/video-joe-budden-pull-up-season-3-episode-2-featuring-wale/" rel="bookmark" title="Video: Joe Budden &#8211; Pull Up (Season 3 Episode 2) Featuring Wale"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/QTMlPT3Lo9-Obiq5g64kjGrfC4XMKL2hKgl46JKerK9lG9SyYypkAsXoipYzyxl_RoEv3LdIBdR2c1hpqu6GxJv5P2kT3P2fJzkgcrOdZzAK3NcPa5r-h0dW2TiSlRy5tzyfUTTAzpluBI4aPIfeADUZSsRpizq9KQTKi2ICng0XnMQw4H2k7374_fxulq4BaJi2St6CyFm1jAcjb3ptVVkw6vQPFo-z-R1X_w22R5NQ61f4hNN_9m0wDsI_tsT4BCNUrE1-qSsct6-6PMRZRYDgAgjySQvFPfzzBhagARfSbuB4kwrc49k82W19NSTKeuLwHnP3RUeA6CuGIWyko-oxxMEzjIHU3WwsvsF3nbTPFZ_FfYLrCoOr_bYB6rD7MvBtcCk47IpEk--dr6sfMvaxCBD22qdovLEtR58wBz7Rxg8oqd2KApKvQ18jTO6a2h8GR0N0Bcf1tfOjaOczzL-Y3bUY6x_hpEKsQY9cF_lKWQP7YOXZWu1uVAlVqXssuM2oi2VgRNG0PF0jOgMKnGkDkGGzTZ-B4lMWnzY0mhWoJYeFAsjn4p_nBV1pVIYWfeWBD5dortyLCzLWcPrO_jMhx5YB33FpwcsB15ul0Rl_4lSXFYnEI5owM3iREeDy5FJg7eVX9u3i_od1_8xgM8FHBPifBEDSaYJCBNHCRL_2_BnMI-nvXm2R=w1173-h530-no" alt="" title="Video: Joe Budden &#8211; Pull Up (Season 3 Episode 2) Featuring Wale"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/23/video-joe-budden-pull-up-season-3-episode-2-featuring-wale/" rel="bookmark" title="Video: Joe Budden &#8211; Pull Up (Season 3 Episode 2) Featuring Wale">Video: Joe Budden &#8211; Pull Up (Season 3 Episode 2) Featuring&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/02/20/the-weeknd-announces-after-hours-tour-w-sabrina-claudio-don-toliver-88glam/" rel="bookmark" title="The Weeknd Announces ‘After Hours’ Tour w/ Sabrina Claudio, Don Toliver &#038; 88GLAM"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/8kKcFmOiw_cKzOC1YiFCRmpAqyMaw-ut0L0nHlQoWLxOKgrCS4ig-MsEeigAaUTgeHY21vJod2TQlO3Lf-q447aYAh5kMO5h6dt2siL41kTpCVOUkiRUjTYXd5_BlSyshkYDSlvDJ1gzYcNkFzNxXFJkJr33MV8rem8Om7QCYffbZ5ESv91xZUNN4gALsZ_msi7ordDne4GJ09e3tQ16DWFhWNMCebB0VztxVqClMzd1D34HVMSCSnKE4u3qFO6mbKKEw_oN-8VCPPrwTvoCWygkHqtMdpWsWZk5QmapUChsjrcGVeyujHNJjyFaRtRbHcD4euqivPu2NUNHeyzee_TbbIsHi6ACP8xdTn16u8FUPpqLHQwCmomkYMYkJD4FgHx4aO3-3_d4GR1lRrk0V2fq_bxaHUJuNpnD_7ixH8chEzfhc4zC8t4loZ50ggQ-PTRpY9y1q70nIXbOudT_doxPgJLzWADYZSYstVkc_U0yFwj9Y7n4mrwaIQ4-ZiweOusGGZQpVvJI0xsZkDRiJ0PqcyeqYnZvD5uCxWyOwAOnjD90dZkqwoVwmFB5my6ErXqiDZEW1jtrwr1JNoPSnL6m1GFexqvso97C3t9UJJYoJG2rl64VoobdgKYTuHE766GwWOEdXsoXlZQm9VQZV_kjnfFD2I8diozSKmtquIfru_Iqh9Y5JSbp=w700-h875-no" alt="" title="The Weeknd Announces ‘After Hours’ Tour w/ Sabrina Claudio, Don Toliver &#038; 88GLAM"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/02/20/the-weeknd-announces-after-hours-tour-w-sabrina-claudio-don-toliver-88glam/" rel="bookmark" title="The Weeknd Announces ‘After Hours’ Tour w/ Sabrina Claudio, Don Toliver &#038; 88GLAM">The Weeknd Announces ‘After Hours’ Tour w/ Sabrina Claudio, Don Toliver&#8230;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_23_5e591c2e001e2" data-td_block_id="td_uid_23_5e591c2e001e2"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_23_5e591c2e001e2" data-td_block_id="td_uid_23_5e591c2e001e2"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_30_5e591c2e15759_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_30_5e591c2e15759" ><script>var block_td_uid_30_5e591c2e15759 = new tdBlock();
block_td_uid_30_5e591c2e15759.id = "td_uid_30_5e591c2e15759";
block_td_uid_30_5e591c2e15759.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"77","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_30_5e591c2e15759_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_30_5e591c2e15759.td_column_number = "3";
block_td_uid_30_5e591c2e15759.block_type = "td_block_mega_menu";
block_td_uid_30_5e591c2e15759.post_count = "4";
block_td_uid_30_5e591c2e15759.found_posts = "158";
block_td_uid_30_5e591c2e15759.header_color = "";
block_td_uid_30_5e591c2e15759.ajax_pagination_infinite_stop = "";
block_td_uid_30_5e591c2e15759.max_num_pages = "40";
tdBlocksArray.push(block_td_uid_30_5e591c2e15759);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_30_5e591c2e15759" id="td_uid_31_5e591c2e16292" data-td_block_id="td_uid_30_5e591c2e15759" data-td_filter_value="" href="http://weuponithiphop.info/category/fashion/">All</a><a class="mega-menu-sub-cat-td_uid_30_5e591c2e15759"  id="td_uid_32_5e591c2e1637f" data-td_block_id="td_uid_30_5e591c2e15759" data-td_filter_value="76" href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></div></div><div id=td_uid_30_5e591c2e15759 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/LVT4Mid8WL4wHUdO9X2OZmZxxgbREs2lVtszOdEBaO6hJB0JS3yQOAyhNSdCyPmv0amBDTgNGpOlRPXPjKCl6yIlo2joyH3rQRI7CUdX09BJtQI1r5jy1_7BQtDhw4AxUhpUwIh35rNS3lTy7uq-FdPff10JN6srr9mwZ7zr04GQFxBVEXwCfC5rNVehXhY_wGCRVsmevYmdkBWEmB8dvOzBHY78NBBjcHNArS_S-2M0FJgDh8v9m9vEh78k_XmZg-AERctsf0bkODuPi1EcNJq_RnJIV6b0GG-VtKjo-OVPmYghWJYf1HiP9c58cQ98oABU8BDFdLqsBtNt4K0NmyHYQlX39W9k_d83wEHZ1-EacQa2o01VrYSn12HnZ1l88fMzu9PKv6EGmcRZNwpepycW7_9EQnhxIPDdVCmRLXUasUED9OXr-zJmnBcnSnLCa06k1ZymQym1LiSFEv1c3aPHnmnD3GY8nL7q5jPJr4HsABR0WCqMebcF3HF_0deNd0zgRBCGMxW-VzlIIHZiHuBeSPEPvUL149GJ5swSSvKm1uGEi1HlLBj9omJSU7mDWzO0p_7l-l7-4_ureEsGsgB8cX1t8t2TQcFeRgqqF1CXlZFYYC2K0iMb4jPsijsw_rtO7pmKvbngqHfgYpGeh_qLmDWeicR7=w1195-h796-no" alt="" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch">Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/fHEwwMf8DoiXlqkfibQS1Z1XXbviORbV9raaI44tOTXrWo7GgqM3gA-vswE10gFtTQUGGwNG7nWAACwHjxPuiubliYBN_dqtBZh2WIpxvumiJ-hSLK0TNWB2cB8Iw2STT5gcp_KqlDh_e4xng1vidI8EXdp_ooh5uDI-JV1HQ9dGnM5nxl_b-v8znqj-Rl_mGB7y4Lu9zsFNWHU7SriqQQJaKrKEEnb9T8zxmGLaL0zq7ilYpnUEhWulDDr9xc82wdr__WzRBm5YEskVpDAnGM2NDZwTZpjbe4QDdxeixWnSXNK_oDzaL7WTbCpkD33OK88BlI5JmFRQ5VmD11UQ2htB7-9WoahHvb4XmBsbLXpEMl1JmEP4sPx06VduzFnBNo-J90WI0n1AEIIcEYVbRywrkGJXbzmH__In9ZIg0EV24OcGGbeKl12HxTdZwucqsNnuZeNjiMHISQ7i8cfzm3N7X7Zenl74zsKIKeKWoIGxh6MTlVADvgHcrHebnjcSgil2vBeFyz_AP45aOv9SOwbzfVLGS0CNfe1s9b2J7qZgjcBk9QPEXCl2kygvzmGXFvU_3xBuW6S0i3Vkh3Ha_3hPBtvIAy3WoTK2yiqS41HzSK7yk3FRAlBtpIEib338fdkTiosBxtdu36SdNUVM75zl6CVIFhTu=w681-h470-no" alt="" title="Air Jordan 14 Rip Hamilton"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton">Air Jordan 14 Rip Hamilton</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/kUjaOYxjEkAh34S-Ub2QSZwdOwHyFnGFLBZULta3_bn1_myPMAwJXiEEsAAtc1ktCQwHCuKhSqSYsWXFBEIZxdfKuykoDEZWwO-dDI3_JeAshbYvyILEHUu0XaUpRn0mj7gOx10V52t8gRGYPCW7QXGImkPGGhvBPzBDVVqh9lKGtkuPeePmTnpRSmwp0LG1WHcIzUWnMqPBWQeHAat6Q-Tq7niXNb96ddEZsMEdHK1nmHVlNaeqFBNtTxk6yYRkFNCvtfBayqy-Rqt4CPU5tThxbTI4AIUCI6JLxJd_VJizrVNDEe2xZ_tiQdkC5ASIoHpX8sfvAB8zRUsMVJ6oMUt5FH_4GBNXDCtFRmr65Qt0JV1h4bBJffu2L272Q_vpD76wn-YNGW8VCtZcheHu_X-A4gdYQEC0HN0BenY-MOuUBqKEjXAc0SxWeP7W9RN55jlqUFK0nzEYydVjec2stdQIngVfg_FvKxvHXfM4XdtMpqeJnp3Pzyk8xjz30sAZd0f2HQ6zfdPjk-OkV2-WrC0_qW0L8Rq3zrUbq52n3BN7gm7sctU_CUlBmoQIgJDQBYk1Siv4tfSq9pL1R4GdaOlWQdxEuhZi8bTYC8GGAgNGl3SMAZGvk7nu6QnnwEZjZ7mZwbcqgyRKa89cOREMUvIkVJ8Q8lZu=w926-h672-no" alt="" title="Jordan Proto React Triple White"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White">Jordan Proto React Triple White</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4cDUjSODZSaXWfHyZKb9q3Fn7FHA4uB0KSBs0MtFHC0dc6AJb1zeAl_X2LOKalK9C7VBFhTqRQ9fw1ESgUr9ZUKFbOzD94i_s96nvkICOqrsYnzrE2nEAQHoEaGOF4O8GAI6T4CGFbgcQhNzjpRlSY60NyPu5Cmq81FRpEOFRzTOtSa_NnWzMmfwO0yxtPbcg5U6YBUsus8shv3SA7CjULLfaP38nZAuWVgq8PMaaeCQ_eSrK8NJSEVQjyyxmqb-1I7zO8Kvvzvwi--ibMr52CF8h-GusBzSq5ZuzvZRCGu_u8CyfoXw7pwWbOmHnLOdcQ9d2PCSW_IxEMGfmEuU7NxMSsW3Ga4r35_wLB7cjvlPC9OjCV50tfekXjZBS_476mzlf4G9jR7Ju1GqgjXah9Uqc_0Y8N-Br8_JCtIlRSuLxAiebwd7AvFVlgWId9MYxBWnRT3cTyD8SH7q5WwO-CIbKAOSKsNcrrTgFxQvqn9yklBU1u5X5fdTlTBk4WSYorsWZAug0z9BOymRLnrhTbnA0vpBPFROWD-aL1glg-eUpFSfgD4xhWsOqJNY9krQ2UbLSGXQ5gYWj0ovLS7Yz3UKFY2qrVWpqkpbfyN98es9NJ-7LTUs2MLq1rX_2FaQmyq5mVndd7VGzQOHy9hDULG-5H-0LvGd=w900-h566-no" alt="" title="adidas Yeezy Boost 350 V2 Hyperspace"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace">adidas Yeezy Boost 350 V2 Hyperspace</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_30_5e591c2e15759" data-td_block_id="td_uid_30_5e591c2e15759"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_30_5e591c2e15759" data-td_block_id="td_uid_30_5e591c2e15759"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div>                </div>

                <div class="td-pb-span5 td-sub-footer-copy">
                    &copy; 2018 The Hip Hop Chronicles Media Group                </div>
            </div>
        </div>
    </div>
</div><!--close td-outer-wrap-->

	<div id="wpcp-error-message" class="msgmsg-box-wpcp warning-wpcp hideme"><span>error: </span>Not Prohibited. ✌️</div>
	<script>
	var timeout_result;
	function show_wpcp_message(smessage)
	{
		if (smessage !== "")
			{
			var smessage_text = '<span>Alert: </span>'+smessage;
			document.getElementById("wpcp-error-message").innerHTML = smessage_text;
			document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp showme";
			clearTimeout(timeout_result);
			timeout_result = setTimeout(hide_message, 3000);
			}
	}
	function hide_message()
	{
		document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp hideme";
	}
	</script>
		<style type="text/css">
	#wpcp-error-message {
	    direction: ltr;
	    text-align: center;
	    transition: opacity 900ms ease 0s;
	    z-index: 99999999;
	}
	.hideme {
    	opacity:0;
    	visibility: hidden;
	}
	.showme {
    	opacity:1;
    	visibility: visible;
	}
	.msgmsg-box-wpcp {
		border-radius: 10px;
		color: #555;
		font-family: Tahoma;
		font-size: 11px;
		margin: 10px;
		padding: 10px 36px;
		position: fixed;
		width: 255px;
		top: 50%;
  		left: 50%;
  		margin-top: -10px;
  		margin-left: -130px;
  		-webkit-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
		-moz-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
		box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
	}
	.msgmsg-box-wpcp span {
		font-weight:bold;
		text-transform:uppercase;
	}
	.error-wpcp {		background:#ffecec url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/error.png') no-repeat 10px 50%;
		border:1px solid #f5aca6;
	}
	.success {
		background:#e9ffd9 url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/success.png') no-repeat 10px 50%;
		border:1px solid #a6ca8a;
	}
	.warning-wpcp {
		background:#ffecec url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/warning.png') no-repeat 10px 50%;
		border:1px solid #f5aca6;
	}
	.notice {
		background:#e3f7fc url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/notice.png') no-repeat 10px 50%;
		border:1px solid #8ed9f6;
	}
    </style>


    <!--

        Theme: Newspaper by tagDiv 2016
        Version: 7.2 (rara)
        Deploy mode: deploy
        
        uid: 5e591c2e217ed
    -->

    <link rel='stylesheet' id='so-css-Newspaper-css'  href='http://weuponithiphop.info/wp-content/uploads/so-css/so-css-Newspaper.css?ver=1528674688' type='text/css' media='all' />
<link rel='stylesheet' id='soliloquy-lite-style-css'  href='http://weuponithiphop.info/wp-content/plugins/soliloquy-lite/assets/css/soliloquy.css?ver=2.5.7' type='text/css' media='all' />
<link rel='stylesheet' id='soliloquy-liteclassic-theme-css'  href='http://weuponithiphop.info/wp-content/plugins/soliloquy-lite/themes/classic/style.css?ver=2.5.7' type='text/css' media='all' />
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/themes/Newspaper/js/tagdiv_theme.js?ver=7.2'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/comment-reply.min.js?ver=4.9.13'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/wp-embed.min.js?ver=4.9.13'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/plugins/soliloquy-lite/assets/js/min/soliloquy-min.js?ver=2.5.7'></script>

<!-- JS generated by theme -->

<script>
    


            

	            // if the theme has tdBackstr support, it means this already uses it
                if ( 'undefined' !== typeof window.tdBackstr ) {

                    (function(){
                        // the site background td-backstretch jquery object is dynamically added in DOM, and after any translation effects are applied over td-backstretch
                        var wrapper_image_jquery_obj = jQuery( '<div class=\'backstretch\'></div>' );
                        var image_jquery_obj = jQuery( '<img class=\'td-backstretch not-parallax\' src=\'http://weuponithiphop.info/wp-content/uploads/20-black-paper-different-texture-types-a4-sandgrain-.jpg\'>' );

                        wrapper_image_jquery_obj.append( image_jquery_obj );

                        jQuery( 'body' ).prepend( wrapper_image_jquery_obj );

                        var td_backstr_item = new tdBackstr.item();

                        td_backstr_item.wrapper_image_jquery_obj = wrapper_image_jquery_obj;
                        td_backstr_item.image_jquery_obj = image_jquery_obj;

	                    tdBackstr.add_item( td_backstr_item );

                    })();
                }

            
            
jQuery(window).ready(function() {
(function(){
var td_backstr_item = new tdBackstr.item();
td_backstr_item.wrapper_image_jquery_obj = jQuery( "#td-full-screen-header-image" );
td_backstr_item.image_jquery_obj = td_backstr_item.wrapper_image_jquery_obj.find( 'img:first' );
tdBackstr.add_item( td_backstr_item );
jQuery('.td-read-down a').click(function(event){
event.preventDefault();
var header_wrap = jQuery( '.td-full-screen-header-image-wrap:first' )
if ( 1 === header_wrap.length ) {
tdUtil.scrollToPosition(header_wrap.height() + header_wrap.offset().top, 1200);
}
});
})();
});

                jQuery().ready(function jQuery_ready() {
                    tdAjaxCount.tdGetViewsCountsAjax("post","[37119]");
                });
            

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'http://weuponithiphop.info/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'http://weuponithiphop.info/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>

			<script type="text/javascript">
			if ( typeof soliloquy_slider === 'undefined' || false === soliloquy_slider ) {soliloquy_slider = {};}jQuery('#soliloquy-container-30342').css('height', Math.round(jQuery('#soliloquy-container-30342').width()/(960/300)));jQuery(window).load(function(){var $ = jQuery;var soliloquy_container_30342 = $('#soliloquy-container-30342'),soliloquy_30342 = $('#soliloquy-30342');soliloquy_slider['30342'] = soliloquy_30342.soliloquy({slideSelector: '.soliloquy-item',speed: 0,pause: 2000,auto: 1,useCSS: 0,keyboard: true,adaptiveHeight: 1,adaptiveHeightSpeed: 400,infiniteLoop: 1,mode: 'fade',pager: 1,controls: 1,nextText: '',prevText: '',startText: '',stopText: '',onSliderLoad: function(currentIndex){soliloquy_container_30342.find('.soliloquy-active-slide').removeClass('soliloquy-active-slide').attr('aria-hidden','true');soliloquy_container_30342.css({'height':'auto','background-image':'none'});if ( soliloquy_container_30342.find('.soliloquy-slider li').length > 1 ) {soliloquy_container_30342.find('.soliloquy-controls').fadeTo(300, 1);}soliloquy_30342.find('.soliloquy-item:not(.soliloquy-clone):eq(' + currentIndex + ')').addClass('soliloquy-active-slide').attr('aria-hidden','false');soliloquy_container_30342.find('.soliloquy-clone').find('*').removeAttr('id');soliloquy_container_30342.find('.soliloquy-controls-direction').attr('aria-label','carousel buttons').attr('aria-controls', 'soliloquy-container-30342');soliloquy_container_30342.find('.soliloquy-controls-direction a.soliloquy-prev').attr('aria-label','previous');soliloquy_container_30342.find('.soliloquy-controls-direction a.soliloquy-next').attr('aria-label','next');},onSlideBefore: function(element, oldIndex, newIndex){soliloquy_container_30342.find('.soliloquy-active-slide').removeClass('soliloquy-active-slide').attr('aria-hidden','true');$(element).addClass('soliloquy-active-slide').attr('aria-hidden','false');},onSlideAfter: function(element, oldIndex, newIndex){},});});			</script>
			
</body>
</html>