<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>New Music: Marlon Craft ft. Kota the Friend – Mom&#039;s Whiskey</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="http://weuponithiphop.info/xmlrpc.php" />
    <meta property="og:image" content="https://lh3.googleusercontent.com/KlBJhollqGWaimmQSP7Zym42ZJJleWcdVSPXzChreFC8wDs-uPCVG3DKNWOPwOVxqmDQNNALonMBWWnO-PuK7AYEcI2-NYvs7RYJi_TscAF04CPVtGPmrHI4JcFyRESP6zBVB87wsnzz53kiSrScGN2RrDMF7CbsuImDngWTFwYzNzUXN6fbKuutdje_8X0JUg5_M8jGFXdA2tm8_CM2dw6D4R3qbglpXOl-IApooMEL4vSUwPETGN4kSK4aMQFi6ca_Rumz3xY6DnSyMF6EUZYK9AV3FRF1Mbt4mqX3AGiCC2kb1fJmB_nnllLFdGuAtb8XGwE5kQ0tuvUtK6IGvUTuswGIb3XaLErCD8eyDoSbZqFLg6q1Pj5S1l5paS-NTYnmdhmGAD6-eaGKZsvsuDJS5fT9qZl1IZsTjUx3uBcI1mBDpZk0k73Upt8O1BYHxHdQ1OuUKalMfib_codY9jOWlfxHVeqsVFzT50gijW6erN_6g01wlJRVbJPY8JOwTZBFXCf4YEsEBZb0wiDWUge55j2B1tAipTqikgpx_kJK91bs--xScmAwjuAytexC_1MGhO09Z0Kb0Ef-nEJEkYGTyQM2nEzWB_yG7XXyF63-LmHW2iSoAjKgnu1wo4aVTqOK8OgtQZBYGwh3DJvwsvI2YVu7N3YHJNSj7fWonTEaWOUcyV9tVLGgltOcqA=w1080-h607-no" /><meta name="author" content="cyclone">
<link rel="icon" type="image/png" href="http://weuponithiphop.info/wp-content/uploads/weuponitlogoCAP-500x457.png">
<!-- All in One SEO Pack 3.3.4 by Michael Torbert of Semper Fi Web Design[208,291] -->
<script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"http://weuponithiphop.info/#organization","url":"http://weuponithiphop.info/","name":"WeUpOnIt","sameAs":[]},{"@type":"WebSite","@id":"http://weuponithiphop.info/#website","url":"http://weuponithiphop.info/","name":"WeUpOnIt","publisher":{"@id":"http://weuponithiphop.info/#organization"}},{"@type":"WebPage","@id":"http://weuponithiphop.info/2020/03/26/new-music-marlon-craft-ft-kota-the-friend-moms-whiskey/#webpage","url":"http://weuponithiphop.info/2020/03/26/new-music-marlon-craft-ft-kota-the-friend-moms-whiskey/","inLanguage":"en-US","name":"New Music: Marlon Craft ft. Kota the Friend &#8211; Mom\u2019s Whiskey","isPartOf":{"@id":"http://weuponithiphop.info/#website"},"datePublished":"2020-03-26T21:03:27+00:00","dateModified":"2020-03-26T21:03:27+00:00"},{"@type":"Article","@id":"http://weuponithiphop.info/2020/03/26/new-music-marlon-craft-ft-kota-the-friend-moms-whiskey/#article","isPartOf":{"@id":"http://weuponithiphop.info/2020/03/26/new-music-marlon-craft-ft-kota-the-friend-moms-whiskey/#webpage"},"author":{"@id":"http://weuponithiphop.info/author/cyclone/#author"},"headline":"New Music: Marlon Craft ft. Kota the Friend &#8211; Mom\u2019s Whiskey","datePublished":"2020-03-26T21:03:27+00:00","dateModified":"2020-03-26T21:03:27+00:00","commentCount":0,"mainEntityOfPage":{"@id":"http://weuponithiphop.info/2020/03/26/new-music-marlon-craft-ft-kota-the-friend-moms-whiskey/#webpage"},"publisher":{"@id":"http://weuponithiphop.info/#organization"},"articleSection":"New Music, Kota The Friend, Marlon Craft"},{"@type":"Person","@id":"http://weuponithiphop.info/author/cyclone/#author","name":"cyclone","sameAs":[],"image":{"@type":"ImageObject","@id":"http://weuponithiphop.info/#personlogo","url":"http://0.gravatar.com/avatar/6a747aaba64ebc36f309e25ac7e460e6?s=96&d=mm&r=g","width":96,"height":96,"caption":"cyclone"}}]}</script>
<link rel="canonical" href="http://weuponithiphop.info/2020/03/26/new-music-marlon-craft-ft-kota-the-friend-moms-whiskey/" />
<!-- All in One SEO Pack -->
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Feed" href="http://weuponithiphop.info/feed/" />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Comments Feed" href="http://weuponithiphop.info/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; New Music: Marlon Craft ft. Kota the Friend &#8211; Mom’s Whiskey Comments Feed" href="http://weuponithiphop.info/2020/03/26/new-music-marlon-craft-ft-kota-the-friend-moms-whiskey/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/weuponithiphop.info\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.13"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='google_font_open_sans-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;ver=4.9.13' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_roboto-css'  href='http://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C900%2C500italic%2C400%2C300&#038;ver=4.9.13' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='http://fonts.googleapis.com/css?family=Roboto+Condensed%3A400%2C700&#038;ver=4.9.13' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='http://weuponithiphop.info/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=4.12' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='http://weuponithiphop.info/wp-content/themes/Newspaper/style.css?ver=7.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css'  href='http://weuponithiphop.info/wp-content/themes/Newspaper/includes/demos/what/demo_style.css?ver=7.2' type='text/css' media='all' />
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1'></script>
<link rel='https://api.w.org/' href='http://weuponithiphop.info/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://weuponithiphop.info/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://weuponithiphop.info/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='New Music: Trav Ft. Tory Lanez &#8211; You Choose' href='http://weuponithiphop.info/2020/03/26/new-music-trav-ft-tory-lanez-you-choose/' />
<link rel='next' title='Music Video: Mozzy ft. Blxst &#8211; I Ain’t Perfect' href='http://weuponithiphop.info/2020/03/26/music-video-mozzy-ft-blxst-i-aint-perfect/' />
<meta name="generator" content="WordPress 4.9.13" />
<link rel='shortlink' href='http://weuponithiphop.info/?p=37520' />
<link rel="alternate" type="application/json+oembed" href="http://weuponithiphop.info/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fweuponithiphop.info%2F2020%2F03%2F26%2Fnew-music-marlon-craft-ft-kota-the-friend-moms-whiskey%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://weuponithiphop.info/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fweuponithiphop.info%2F2020%2F03%2F26%2Fnew-music-marlon-craft-ft-kota-the-friend-moms-whiskey%2F&#038;format=xml" />

<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>
<script id="wpcp_disable_selection" type="text/javascript">
//<![CDATA[
var image_save_msg='You Can Not Save images!';
	var no_menu_msg='Context Menu disabled!';
	var smessage = "Not Prohibited. ✌️";

function disableEnterKey(e)
{
	if (e.ctrlKey){
     var key;
     if(window.event)
          key = window.event.keyCode;     //IE
     else
          key = e.which;     //firefox (97)
    //if (key != 17) alert(key);
     if (key == 97 || key == 65 || key == 67 || key == 99 || key == 88 || key == 120 || key == 26 || key == 85  || key == 86 || key == 83 || key == 43)
     {
          show_wpcp_message('You are not allowed to copy content or view source');
          return false;
     }else
     	return true;
     }
}

function disable_copy(e)
{	
	var elemtype = e.target.nodeName;
	var isSafari = /Safari/.test(navigator.userAgent) && /Apple Computer/.test(navigator.vendor);
	elemtype = elemtype.toUpperCase();
	var checker_IMG = '';
	if (elemtype == "IMG" && checker_IMG == 'checked' && e.detail >= 2) {show_wpcp_message(alertMsg_IMG);return false;}
	if (elemtype != "TEXT" && elemtype != "TEXTAREA" && elemtype != "INPUT" && elemtype != "PASSWORD" && elemtype != "SELECT" && elemtype != "OPTION" && elemtype != "EMBED")
	{
		if (smessage !== "" && e.detail == 2)
			show_wpcp_message(smessage);
		
		if (isSafari)
			return true;
		else
			return false;
	}	
}
function disable_copy_ie()
{
	var elemtype = window.event.srcElement.nodeName;
	elemtype = elemtype.toUpperCase();
	if (elemtype == "IMG") {show_wpcp_message(alertMsg_IMG);return false;}
	if (elemtype != "TEXT" && elemtype != "TEXTAREA" && elemtype != "INPUT" && elemtype != "PASSWORD" && elemtype != "SELECT" && elemtype != "OPTION" && elemtype != "EMBED")
	{
		//alert(navigator.userAgent.indexOf('MSIE'));
			//if (smessage !== "") show_wpcp_message(smessage);
		return false;
	}
}	
function reEnable()
{
	return true;
}
document.onkeydown = disableEnterKey;
document.onselectstart = disable_copy_ie;
if(navigator.userAgent.indexOf('MSIE')==-1)
{
	document.onmousedown = disable_copy;
	document.onclick = reEnable;
}
function disableSelection(target)
{
    //For IE This code will work
    if (typeof target.onselectstart!="undefined")
    target.onselectstart = disable_copy_ie;
    
    //For Firefox This code will work
    else if (typeof target.style.MozUserSelect!="undefined")
    {target.style.MozUserSelect="none";}
    
    //All other  (ie: Opera) This code will work
    else
    target.onmousedown=function(){return false}
    target.style.cursor = "default";
}
//Calling the JS function directly just after body load
window.onload = function(){disableSelection(document.body);};
//]]>
</script>
	<script id="wpcp_disable_Right_Click" type="text/javascript">
	//<![CDATA[
	document.ondragstart = function() { return false;}
	/* ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
	Disable context menu on images by GreenLava Version 1.0
	^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ */
	    function nocontext(e) {
	       return false;
	    }
	    document.oncontextmenu = nocontext;
	//]]>
	</script>
<!-- Analytics by WP-Statistics v12.6.12 - https://wp-statistics.com/ -->
<!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]-->
<!-- JS generated by theme -->

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var tds_login_sing_in_widget="show";
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_ajax_url="http:\/\/weuponithiphop.info\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=7.2";
var td_get_template_directory_uri="http:\/\/weuponithiphop.info\/wp-content\/themes\/Newspaper";
var tds_snap_menu="snap";
var tds_logo_on_sticky="show_header_logo";
var tds_header_style="5";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#dd3333";
var tds_smart_sidebar="enabled";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>


<!-- Header style compiled by theme -->

<style>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</style>

<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>

<body class="post-template-default single single-post postid-37520 single-format-standard unselectable new-music-marlon-craft-ft-kota-the-friend-moms-whiskey td-what single_template_7 wpb-js-composer js-comp-ver-4.12 vc_responsive td-boxed-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
                    <div class="td-menu-login-section">
                
    <div class="td-guest-wrap">
        <div class="td-menu-avatar"><div class="td-avatar-container"><img alt='' src='http://1.gravatar.com/avatar/?s=80&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo avatar-default' height='80' width='80' /></div></div>
        <div class="td-menu-login"><a id="login-link-mob">Sign in</a></div>
    </div>
            </div>
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-top-menu-container"><ul id="menu-top-menu" class="td-mobile-main-menu"><li id="menu-item-317" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-first menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a></li>
<li id="menu-item-706" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a></li>
<li id="menu-item-314" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a></li>
<li id="menu-item-316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-0" class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></li>
</ul>
</li>
<li id="menu-item-705" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></li>
</ul>
</li>
<li id="menu-item-18581" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li id="menu-item-3199" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
            <div id="login-form-mobile" class="td-register-section">
            
            <div id="td-login-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-login-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign in</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
	                <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
	                <div class="td-login-info-text"><a href="#" id="forgot-pass-link-mob">Forgot your password?</a></div>
                </div>
            </div>

            

            <div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
                <!-- close button -->
	            <div class="td-forgot-pass-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Password recovery</div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title">Recover your password</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
	                <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
                </div>
            </div>
        </div>
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="http://weuponithiphop.info/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap">
    
        <!--
Header style 5
-->

<div class="td-header-wrap td-header-style-5">

    <div class="td-header-top-menu-full">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div >

                Thursday, March 26, 2020
            </div>
        </div>
    <ul class="top-header-menu td_ul_login"><li class="menu-item"><a class="td-login-modal-js menu-item" href="#login-form" data-effect="mpf-td-login-effect">Sign in / Join</a><span class="td-sp-ico-login td_sp_login_ico_style"></span></li></ul><div class="menu-top-container"><ul id="menu-main" class="top-header-menu"><li id="menu-item-79" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-79"><a href="http://weuponithiphop.info">Home</a></li>
<li id="menu-item-81" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-81"><a target="_blank" href="http://weuponitradio.com">Power 105.1 WeUpOnIt Radio</a></li>
<li id="menu-item-80" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-80"><a target="_blank" href="https://shop.spreadshirt.com/freshandcleantees/">Shop</a></li>
<li id="menu-item-18582" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18582"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li id="menu-item-18583" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18583"><a href="http://weuponithiphop.info/privacy-policy-2/">Privacy Policy</a></li>
</ul></div></div>
        <div class="td-header-sp-top-widget">
    
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div>
    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <ul class="td-login-tabs">
                        <li><a id="login-link" class="td_login_tab_focus">LOG IN</a></li>
                    </ul>



                    <div class="td-login-wrap">
                        <div class="td_display_err"></div>

                        <div id="td-login-div" class="">
                            <div class="td-login-panel-title">Welcome! Log into your account</div>
                            <input class="td-login-input" type="text" name="login_email" id="login_email" placeholder="your username" value="" required>
                            <input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" placeholder="your password" required>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Log In">


                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password?</a></div>


                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-display-none">
                            <div class="td-login-panel-title">Recover your password</div>
                            <input class="td-login-input" type="text" name="forgot_email" id="forgot_email" placeholder="your email" value="" required>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Pass">
                        </div>




                    </div>
                </div>
                        </div>
    </div>

    <div class="td-header-menu-wrap-full">
        <div class="td-header-menu-wrap">
            <div class="td-container td-header-row td-header-main-menu black-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-menu">
        		<a class="td-mobile-logo td-sticky-header" href="http://weuponithiphop.info/">
			<img class="td-retina-data" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-5.png" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-5.png" alt=""/>
		</a>
			<a class="td-header-logo td-sticky-header" href="http://weuponithiphop.info/">
			<img class="td-retina-data" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" alt=""/>
			<span class="td-visual-hidden">WeUpOnIt</span>
		</a>
	    </div>
    <div class="menu-top-menu-container"><ul id="menu-top-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-first td-menu-item td-mega-menu menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_1_5e7d6c3f5e9e1_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_1_5e7d6c3f5e9e1" ><script>var block_td_uid_1_5e7d6c3f5e9e1 = new tdBlock();
block_td_uid_1_5e7d6c3f5e9e1.id = "td_uid_1_5e7d6c3f5e9e1";
block_td_uid_1_5e7d6c3f5e9e1.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"43","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_1_5e7d6c3f5e9e1_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_1_5e7d6c3f5e9e1.td_column_number = "3";
block_td_uid_1_5e7d6c3f5e9e1.block_type = "td_block_mega_menu";
block_td_uid_1_5e7d6c3f5e9e1.post_count = "5";
block_td_uid_1_5e7d6c3f5e9e1.found_posts = "2871";
block_td_uid_1_5e7d6c3f5e9e1.header_color = "";
block_td_uid_1_5e7d6c3f5e9e1.ajax_pagination_infinite_stop = "";
block_td_uid_1_5e7d6c3f5e9e1.max_num_pages = "575";
tdBlocksArray.push(block_td_uid_1_5e7d6c3f5e9e1);
</script><div id=td_uid_1_5e7d6c3f5e9e1 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/26/new-music-alina-baraz-more-than-enough/" rel="bookmark" title="New Music: Alina Baraz &#8211; More Than Enough"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/j6FZY2kXU7s0G2SF9erAUTvJAkopLb8ottw1Ztq7VO6ZDutBDw4tFc7WHvBnxT6zUR9xlrzem-mQHrpNY9xiWmmXTiiTWnqKbWYk6yZf6IIt_zuXInrn8dHBjQeqRzR-DKWmLQ1-UkTDxNv0E74iDYMCeQn-_Ukr3V1ECn_9a1US0hHxso4WYXnXmM_4HXocbWgugal1PDwnJo8O-Sy_kwMCWDWPa6QNJs5b2wuL1dXHd3My3gqaSY1gqHFh_zjKCVkDqGmzIAoT6jL8WfGbsp6acYgeqv5cVebtg9jtLUrqg9N_ygJa3ftQPXpVH6__kctquCnX6oYEY1j41uzSzt8oCBVBD5Xvu2Wm_52c-mkt1t-6O6U7aIWIZFB8ckrD9iEE6OeY3vBafXDFlgo0sQsiXRkNH7cIDGu4ovSdKWpgraE3hMT_dR7ALvUm0O1wg8KQzFOBQ634p8ZkoKXTw63yoqHdD1kTjKvzMhJgn8dtsC5eyoHFFwpq9Vdfo7u582340QIGa1NwWL7xN48MoI28Aekbe7t-qDhO_k2Qsrv_Ps4uPzKL_czy93Gj984Ro7FzfxF3hqHN-yAGf2Xhdmnls7XUdkCxbQf2rlC6SdKBUUoUTTqhnY8EbACapo1OcfySicPtunDuoymSjUHNtjXTbUi9zLJuBqMjA-wJ1xN0R1uqU6XHpHeS-KGHtQ=w779-h758-no" alt="" title="New Music: Alina Baraz &#8211; More Than Enough"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/26/new-music-alina-baraz-more-than-enough/" rel="bookmark" title="New Music: Alina Baraz &#8211; More Than Enough">New Music: Alina Baraz &#8211; More Than Enough</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/26/new-music-destructo-ft-kevin-gates-yo-gotti-denzel-curry-bandz/" rel="bookmark" title="New Music: Destructo ft. Kevin Gates, Yo Gotti &#038; Denzel Curry &#8211; Bandz"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/wWXmK9Mi3ODR_MnzeljPi_iIN9GvjrM7vjUNfdBsKzH8HNQxwFLaDXD9xzjtU5i8haWBzNWFLWEpiJE8-jVtAEkK8JkLMNEjYn149OIF7bX7stCSXXWB3uWw_MV2CmvftIW0woDDl_A9FLj--fKxhsgvHaJj7vKis08lJL30Mf2nYFdULVet3EI0lVOPstSbJWP-L9GXv8mpXu3eCZkGhw5EHXx1RY6XmusePiBxbU-ApbcNWbKTWGB-IQqBHlJlAA5ghqZVcDL6h8NiSXVEWXwSbvmrSvqD7AvwVnyNipgtnqwPnd9chBUoIhVB23H0Ax0D3DyMh5AuG3N3BrOqYUpjgRLvDiegULpNj5dFtYGOvH3gNtpt1Hnj9nZjU0BeYzkiTImwtJRU4w0j_pXdO2vcyvq0OdJUp0aZtH0KKggi9LjZqYfUuJdEcdwzVEZjbO-nrGu_H_-A46IPe1hfhypNwE8v8bfZ4J9gfx7zDOTLJDUbpyXOOyKFQuGdzzQZ9tKpKVRrKGl661utDQjGbnHm1pQBRJaP9teDQG_GATxhE5gMTzLiJzthJw_i7CkQtkH2fL4gJEGKLYqJT997dV1RXDXYLiRP9QjWsG4IZ-XP6VLp_1CA6glXsVdQNNu8L5_Kz6OdvUjkOpfHu-TGeljgMFe9cp4SSIzB6g1tNvx-w_yrIt6lcm2tXRWqnw=w750-h758-no" alt="" title="New Music: Destructo ft. Kevin Gates, Yo Gotti &#038; Denzel Curry &#8211; Bandz"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/26/new-music-destructo-ft-kevin-gates-yo-gotti-denzel-curry-bandz/" rel="bookmark" title="New Music: Destructo ft. Kevin Gates, Yo Gotti &#038; Denzel Curry &#8211; Bandz">New Music: Destructo ft. Kevin Gates, Yo Gotti &#038; Denzel Curry&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/26/new-music-marlon-craft-ft-kota-the-friend-moms-whiskey/" rel="bookmark" title="New Music: Marlon Craft ft. Kota the Friend &#8211; Mom’s Whiskey"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/KlBJhollqGWaimmQSP7Zym42ZJJleWcdVSPXzChreFC8wDs-uPCVG3DKNWOPwOVxqmDQNNALonMBWWnO-PuK7AYEcI2-NYvs7RYJi_TscAF04CPVtGPmrHI4JcFyRESP6zBVB87wsnzz53kiSrScGN2RrDMF7CbsuImDngWTFwYzNzUXN6fbKuutdje_8X0JUg5_M8jGFXdA2tm8_CM2dw6D4R3qbglpXOl-IApooMEL4vSUwPETGN4kSK4aMQFi6ca_Rumz3xY6DnSyMF6EUZYK9AV3FRF1Mbt4mqX3AGiCC2kb1fJmB_nnllLFdGuAtb8XGwE5kQ0tuvUtK6IGvUTuswGIb3XaLErCD8eyDoSbZqFLg6q1Pj5S1l5paS-NTYnmdhmGAD6-eaGKZsvsuDJS5fT9qZl1IZsTjUx3uBcI1mBDpZk0k73Upt8O1BYHxHdQ1OuUKalMfib_codY9jOWlfxHVeqsVFzT50gijW6erN_6g01wlJRVbJPY8JOwTZBFXCf4YEsEBZb0wiDWUge55j2B1tAipTqikgpx_kJK91bs--xScmAwjuAytexC_1MGhO09Z0Kb0Ef-nEJEkYGTyQM2nEzWB_yG7XXyF63-LmHW2iSoAjKgnu1wo4aVTqOK8OgtQZBYGwh3DJvwsvI2YVu7N3YHJNSj7fWonTEaWOUcyV9tVLGgltOcqA=w1080-h607-no" alt="" title="New Music: Marlon Craft ft. Kota the Friend &#8211; Mom’s Whiskey"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/26/new-music-marlon-craft-ft-kota-the-friend-moms-whiskey/" rel="bookmark" title="New Music: Marlon Craft ft. Kota the Friend &#8211; Mom’s Whiskey">New Music: Marlon Craft ft. Kota the Friend &#8211; Mom’s Whiskey</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/26/new-music-trav-ft-tory-lanez-you-choose/" rel="bookmark" title="New Music: Trav Ft. Tory Lanez &#8211; You Choose"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/b1xZwsShjFhLRaVTzEOe55WVPNAmYZu-A-PSiX0z9i9s8eWjR19hpJjn3DqAoQwkWoT_ncmHoA1StvpwxQDYLxSv2dVoyXmdVvOZvY_ivw38prFesZJ4bU8z2iAoso8EA9mqfp_FZeZo6OH1rm3-wEysZw31ciFC5z4n4FDeiFUUBLCobMqgO22vgjLxpqxcPtmWiE8dCzDnMOiqs8ZtDbfX6OkcnOt30R6t4nF6KGf-FODrQUHPGSc1fgstD_ciwd7OrjeVa9CPRBtoCg7tbtWzoZVq_JAFoHvXGd7thj5pTpxGuxh7QLGA7m3phhwcBWndG8k-trnBTLxUb-ayizRQKGJxiSicvLhRoMPXJOlLiNIbQWivHALX9oCXCpY328T86F5WFnfkCPOArJHWoYsAOgy2QyK0sx_SMyR9YMWbomdLJ4XwUKWG-pFccJNtZD1oQlc_rvhsDUGqxtqG5aSHhinmDV2BW6mvzaCT1sVRxKMttCgFUbtXSRKmC03T9ED5gKdD4e3EwFsLuSF629QXbanDMIYA4CP86rQ9OnwyPdQNY4Be9WHUGVmSbSiSWyNE--XV7YlxK7LMu7r6WzD_RmexvvScj3sCdD5vi6psvbod81bb919qCO-BpJPbw2TG6nVvV96O3jyji5tj09w18159b25RDrtDI8-lYtABqE9sXGL-EveVf0vfmg=w760-h758-no" alt="" title="New Music: Trav Ft. Tory Lanez &#8211; You Choose"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/26/new-music-trav-ft-tory-lanez-you-choose/" rel="bookmark" title="New Music: Trav Ft. Tory Lanez &#8211; You Choose">New Music: Trav Ft. Tory Lanez &#8211; You Choose</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/25/music-video-ybn-nahmir-ft-g-eazy-offset-2-seater/" rel="bookmark" title="Music Video: YBN Nahmir ft. G-Eazy &#038; Offset &#8211; 2 Seater"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/yOzamruDO2rEDn5CyA6Z9SIeCWLXxCRhXrZbVVoF_WIqoZgs7jcBH-eXIbGHnal7XuXCJ8nEGKurtPAkDOwzsC0heNa082dsQLHyesdOdaDS1g9p5xbPFv6t8gz9bXEb0miJVjrQztA4CGwupuef-EDu1aMlGBGq3_u7_XqbZmMhqpwufvghJhsR2S-DntdhDwt8b4boMJfhUnfZ3BrdygqCcTp7jWOv2j_ljvy3NAVmiNu3KDzu27dLIYnFyDZloMA8guRwmrLpXHTSRAWJ2BOoRN1yjj1wMtEMWMQSf9AAGBXWZ_zh55_NqMUsvz06DtCl_UepZ6KClc-2ga06WDyjJxoriHUvCo-oMbMT6voSYXyTs-0QDUZX-Z3Yb9QjUOCeTQNY7cWERfl4HWZ7h4-KoiFx544eO5bglzvqvgIp24EKNCwIAbnqFfEB-zE4k69aqsvwpSUyn8Gj3iq7ne7RFoK5qSFzBr7k_zdSaC1TC-TO2Oa5dzkDtViiqhQyiHgx5aCpcxus1-cpv5kiOx8V-zXjCHCOYt8kE-qwfnFmv6uoewiV9M0Md1zgEtBWb6dO71x7VsbIB--iyMjoViqHLoYmb-dkv1vH0mxKvQWHv-lb8LvZpnRrSyHTaNNy40HHrByPvAykv15lLrX97FqoKMK-5TlB3qmlIkN_JbgJYhdpjvt1TfI8Man7eA=w1078-h684-no" alt="" title="Music Video: YBN Nahmir ft. G-Eazy &#038; Offset &#8211; 2 Seater"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/25/music-video-ybn-nahmir-ft-g-eazy-offset-2-seater/" rel="bookmark" title="Music Video: YBN Nahmir ft. G-Eazy &#038; Offset &#8211; 2 Seater">Music Video: YBN Nahmir ft. G-Eazy &#038; Offset &#8211; 2 Seater</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_5e7d6c3f5e9e1" data-td_block_id="td_uid_1_5e7d6c3f5e9e1"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_1_5e7d6c3f5e9e1" data-td_block_id="td_uid_1_5e7d6c3f5e9e1"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_2_5e7d6c3f62bcb_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_2_5e7d6c3f62bcb" ><script>var block_td_uid_2_5e7d6c3f62bcb = new tdBlock();
block_td_uid_2_5e7d6c3f62bcb.id = "td_uid_2_5e7d6c3f62bcb";
block_td_uid_2_5e7d6c3f62bcb.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"97","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_2_5e7d6c3f62bcb_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_2_5e7d6c3f62bcb.td_column_number = "3";
block_td_uid_2_5e7d6c3f62bcb.block_type = "td_block_mega_menu";
block_td_uid_2_5e7d6c3f62bcb.post_count = "5";
block_td_uid_2_5e7d6c3f62bcb.found_posts = "1008";
block_td_uid_2_5e7d6c3f62bcb.header_color = "";
block_td_uid_2_5e7d6c3f62bcb.ajax_pagination_infinite_stop = "";
block_td_uid_2_5e7d6c3f62bcb.max_num_pages = "202";
tdBlocksArray.push(block_td_uid_2_5e7d6c3f62bcb);
</script><div id=td_uid_2_5e7d6c3f62bcb class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/22/album-stream-childish-gambino-3-15-20/" rel="bookmark" title="Album Stream: Childish Gambino &#8211; 3.15.20"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/cyzUf4VFFDVizn4QL0AmFV9MCnvKGUY5UDXcORky0ah78vWR8GaYgEQK6-c7-1yoPCGVcpYNqddqWUlGWYtxxmyz8b0daaLB7KjrePZsH_-DXsiMlGj7be2xs6dgS7wvzM_7bV10gDxdDFNe5kSATF4WgZfvb4Gl4AUhP9Co6mREgpvIKdfJ9WV7Brcsz4s-r5zdJuel-HD3VMB6YDZzoRM6DRJrzpVpEHodjYTLh0Je7KYc1IRfPsOUGwjQ16dgkvLGDkIsJco-YW28U7a2araFh5k07JH05-OiKBKeFDeaTRE5T4h29QqeKmWIvsv2-WRe-lNK6DnceDuhCo3bt1hSkuJSCituu2T-g9Zl6jlHBISjXIkehxKeR84xup7IvZKtXkhFYy5UGbVkcRY_QpJtHfTc5HWH_foG2ppu1qqcY6A4P-H5Ad3ZeuwPQ9a_kb-hw3lf9D65cOZprDA4oLqAOET2zsw6Ey0r19y0o3iMddc1UgvEgY7dumIxMEOXfpT4qTUZG5gjQe49eKOIf8j3st6utPXnpCEXOZh3fB3i-NB6dDbsBkLu4pE1TqPXK1ZV-aak-XQofioZMGLDvFBMBCOhidbd2yzrt2mc20c36YkpqRUO2MK5DFQ1iXraZneuOxjmt4T6K7KuKgI6312qWrXQ7LI-oVvQxCFOHgmbpMHn_CmvwNF-LUD3V3I=s600-no" alt="" title="Album Stream: Childish Gambino &#8211; 3.15.20"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/22/album-stream-childish-gambino-3-15-20/" rel="bookmark" title="Album Stream: Childish Gambino &#8211; 3.15.20">Album Stream: Childish Gambino &#8211; 3.15.20</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/22/album-stream-estee-nack-superior-baladas/" rel="bookmark" title="Album Stream: Estee Nack &#038; Superior &#8211; BALADAS"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/F5bQLxzmteTWgGRPq4lTBB2cwZ5VcI6mnLE9W_4XQZGESh3X41egleYCVK6qlt7bELppkiaCVmUyPfxPUCmdGfABd7z5YtZ-YpDxKNF8iGnHgamQeP37nGGDuXP_omI4fcwxro4zw3ohbiubWjoEzfiq3X16J9STsKeaKoROd3JSHm0OKFQ_3qb0vFtrhbbO6m6JpD8nXU-Ihx2ER8yiLvyn_sNd9LIlQFC-guRQBYzvbktKtjuRDWApE5slkBnJGmuVXUupfa9rt-Y8q0FPiM9IqNZa45Yt1GtLnbXnvlFbn4DBCY-K-R3VjCFNEkH7MH9OwiUcbZ4PbAksTFWE1YZxWUeGG2TUawPqUx5Gq0s1hhDxAnigTwxQmxaUfxi6KvxdITz2hX4lAZK-MiwwKm5Rd02LC_wRPSy5wgla_q8DjWXxNM458qgsjEExjzgzs5yIlVTOxeE8CPhLWrmW-BRvFocXzrublhbV4radI11kRLBre5r1BchObFGr-OiDCtNzqKpHnIcp6b3lOx0JFIfOTag2KBuuQXobDexZfNU8f52pVqRSg75Mnf-t_pZzjg-eWIzWSX7bMe6nhqwqNU26yiiAftQiOnoOww40yysRRml_aLHJUUEiq_qnn2Pzpod0Rkv3DXTdpuIRAARmXie-MGDuFT9TH7KG80xlwjHC8EMmKASbUNRWATpOp38=s758-no" alt="" title="Album Stream: Estee Nack &#038; Superior &#8211; BALADAS"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/22/album-stream-estee-nack-superior-baladas/" rel="bookmark" title="Album Stream: Estee Nack &#038; Superior &#8211; BALADAS">Album Stream: Estee Nack &#038; Superior &#8211; BALADAS</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/20/album-stream-fred-the-godson-payback/" rel="bookmark" title="Album Stream: Fred the Godson &#8211; Payback"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/7-3RJAMItkIJ39x5kihg56UJ_Byt8OAr9Dntx6AHJyMOsPgSdRXcdaFw0O5A0a-VhEMr5V6sXif2uQttLgtfb2VzG18_Js4_r211MJLcYSy1om_Yzd0mBU44fVBFeZBwy0LYCf2IFFaF9n_0uoiRmQcE8_x_g4SKVWSOxQ_P-UhR_o9YV0pGZFsgZr1rkbsPf5hW70AMgXiDR9fYDs0KxKmDMBagLmANeOcW9v52or79vR_DIkhFGg8U4o0206mc1USgt52z3ipkU2nyl1b6vfFnneESY4bb0PA9gpRio4bQoTEIgBbZ_ChhWmfQNEs5aIuIWfUfyA5OXDjRI_qxb6t8_FCd0s7y2gwbb5j91Qm0Y8Eh1TpM--kU7AIrWXqMT5TEfk9zDmJmFDpuvT16YRNKb52zUn6XmmJCrq5hDRb7a1KSVGwtpkn8rn5WVqTulkBxHn4J8Uwr6V0M1nr4utXshVyoK1znuCqRn-OdYmFc-je08ULV-nhiaZXEsGcd4V8U0oqzgsyP6yHbyZoWiOEYzJtAbBzKd7PQScsLBK5o7YyP4Qz56ZDu8toCcKSKCiz5ct7Oq0asVZlHUU1Ez_tYiUlbQlDG37h0Mc_giUJ-lFE3OrtWVKuGUGm0JqM-mLsk-TWwum9cQhpD4lK37N_k3fY4UQjLv55_L1DxH4U_OZTxwHUGwJKxovNEVHs=s500-no" alt="" title="Album Stream: Fred the Godson &#8211; Payback"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/20/album-stream-fred-the-godson-payback/" rel="bookmark" title="Album Stream: Fred the Godson &#8211; Payback">Album Stream: Fred the Godson &#8211; Payback</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/20/album-stream-adrian-younge-ali-shaheed-muhammad-jazz-is-dead-001/" rel="bookmark" title="Album Stream: Adrian Younge &#038; Ali Shaheed Muhammad &#8211; Jazz Is Dead 001"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/WuqXivhsNjH6cKUxdJWwHG8TOsuZ8AGFSjk9N7IJPC5MBVvmM4QAbwCq48Tu2Sqg8X8vUxbIKI89ESL2rkQM9gTnexTxG31dJbZHSHmZBnYpnkTvim4wQg3zRt-u96MV2Hj4hVYF8peMyIXUMpkgvpC9dK7U5qONNCW85kxbWxjQJ-DmeXe0f2rRg5ACXKmNcH6nQnF8YMDWaQlvT3nlc1EjXuXOK0gY9MO_wMKh5X_b76xzKdC75zbWpwG9HBPPf9boWSMXWASQFg4QPOvKBWZeYol737U2ELmiRCR6XOgUxd8mQ60fL4EmkVfee4tlesH11iEq6c4k0hZ8_oRQI8zJBj3jDRQcoCwfxtVgeN_nrzbRSBxsOva8PXr0ug-viPrcg24Fq0EwoggLarD_gBwFquBTNq1TPvk3U7sKpPEAFrzDPLbyAf86kyiTWfrzEhuzuI153ZFvqHTdYGvAyjp96CLQmWb7RPE9piBdN9dMMi1sXoQ7u987wQED2h0cYb0A9hsKK-D97gSXcvG5n67Yf0qLkM7lqkDxrMN3L2IC8ox60Kp6TABIAekQqxlLe1LwYDLJO3fPl6_zRPzG87kf9YFgdjzndV5xaJ_sRnC5xVKWrDjeoW0Sm_gL45cKGNDrIBdW9PAw1M3u-skWvi9dq25tMurTuvgC5LhaVgWTnkarKRZwKGiVTn4elzw=s500-no" alt="" title="Album Stream: Adrian Younge &#038; Ali Shaheed Muhammad &#8211; Jazz Is Dead 001"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/20/album-stream-adrian-younge-ali-shaheed-muhammad-jazz-is-dead-001/" rel="bookmark" title="Album Stream: Adrian Younge &#038; Ali Shaheed Muhammad &#8211; Jazz Is Dead 001">Album Stream: Adrian Younge &#038; Ali Shaheed Muhammad &#8211; Jazz Is&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/20/album-stream-the-weeknd-after-hours/" rel="bookmark" title="Album Stream: The Weeknd &#8211; After Hours"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/Hc-rzm_SIYOYbW0I9qFGc44hLRY2g789cTw-eNw-k6WI_AifFEbsn_qz5cR6p9yo-0A6D2MoDO6ZHgVSAHQmPmSEXgE7BK2L-fxwpQI6Au0vFOXX1-HuK6mNh0hiQmxfsWhjJ3LfKzO7estZteBIcrc7F_ojNzegLlekhUv_RK-MFHsWluC-BY0WtjFHzPOHTqVmJVedBTy0z580-V-5lkxDXa_lmNzcFKgI74H7qaeNAoUInf7o0ux-QQl-Tl8GJw4UP24ovX8rxiEvmuVSzi2mHE40pJZJncScHhgozVXC1BFbuZU3x9GRQ0AdV47x0g429b8ZPZQkdwF5p4n_R0lDBG9lcYkNibTDgc2HZ59Ss871AZNJJ79CQLDcEEFUnPOa7qqhSgkftRf6nOSyXDtk6drCV5RbuwjcfCkN-Pky-1IaA86UrE9uJsiCkR2qyj2EkgcUiETmKHJVZbdPfXhpsV7JRgyjc02WcY_N9YRLWntjHAUR3TXMKApwFlzXdoIMiwtH54MCmIPFoanCrn-N3ii1vxFX0Riv2OR6CBsmTw1XrG6rLrmuGTDrpkPuHXiLoJeUYZSlNv2WBHMCcagIS-G21krQOGBUUpo8pvKl6FSs80BtaPeRebBj70ulBHVZ1gHevM_KiL8ipzEJsLU4uAywnWRf2mJ13LzYjBFOc7pd4Flmlx0h6YU1lTo=s328-no" alt="" title="Album Stream: The Weeknd &#8211; After Hours"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/20/album-stream-the-weeknd-after-hours/" rel="bookmark" title="Album Stream: The Weeknd &#8211; After Hours">Album Stream: The Weeknd &#8211; After Hours</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_5e7d6c3f62bcb" data-td_block_id="td_uid_2_5e7d6c3f62bcb"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_2_5e7d6c3f62bcb" data-td_block_id="td_uid_2_5e7d6c3f62bcb"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_3_5e7d6c3f66aa2_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_3_5e7d6c3f66aa2" ><script>var block_td_uid_3_5e7d6c3f66aa2 = new tdBlock();
block_td_uid_3_5e7d6c3f66aa2.id = "td_uid_3_5e7d6c3f66aa2";
block_td_uid_3_5e7d6c3f66aa2.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_3_5e7d6c3f66aa2_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_3_5e7d6c3f66aa2.td_column_number = "3";
block_td_uid_3_5e7d6c3f66aa2.block_type = "td_block_mega_menu";
block_td_uid_3_5e7d6c3f66aa2.post_count = "5";
block_td_uid_3_5e7d6c3f66aa2.found_posts = "2812";
block_td_uid_3_5e7d6c3f66aa2.header_color = "";
block_td_uid_3_5e7d6c3f66aa2.ajax_pagination_infinite_stop = "";
block_td_uid_3_5e7d6c3f66aa2.max_num_pages = "563";
tdBlocksArray.push(block_td_uid_3_5e7d6c3f66aa2);
</script><div id=td_uid_3_5e7d6c3f66aa2 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/26/music-video-casanova-ft-jeremih-woah/" rel="bookmark" title="Music Video: Casanova ft. Jeremih &#8211; Woah"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/kAp1pL4xIM6ztUUXVMzQP0tWI-cCmLiDZIDn14i9kn_CsLsR2D9Rd_AM0XTOmVbgE1-Uf6zC9YAVBCM4TqEnzyDWW5AvQLDWPtkagjZn1zyo0nLDO49fDjBOr2I8dqr73EmycTm7pcP74Ck0sgMdA4Nsu6-l3lls7Vw2LQAyKr-iBrSmoywzCMW7F64M5T0fxD_9O6vYVhnG3SFBXSzWPKWXPKaK8cxVTeeDZ8zFY-BGKD5wmtjmoMG9hMYJWpYr7pT3B9-453LvS5GHXLytr7HpXx3coEttnK7eI5ginYVDOAAxiG_YKLqw_2_TzzRF8gx8458oW3bHN6v43n3HYCYvGMzgprAA1xM_IIVIHKA3G-Ecftsu_bt3MyUNhVhRMLuuLCCehXSFZEqF6-ZUlE0KUXTQ7kq1x-gEivPWlOYsCGT5-E4F5_tmtl3m4lcDIhzQNnRQLVw3hZbWa81U08Z37yLImCWY8hpD8uZjm9vwtr9SkLWNy00IaB07FsMYSjj1u57bigGvaxkTuzwfVch9y2he49vAokNsx1xZ4-X_cvVi-iQZ1ld_CfcOeSnem3ReCHIe9DX7CSYt8hgCW1gxvPq797Ewp35XHZIed8FoAxKHMPDETPBYVVljIZ5vlHbjRziMEDQJHldGX7Fa77b3F4wAQqj7AVL05BdVfuO8JKNnbIEq8OsMT4MaqA=w1078-h618-no" alt="" title="Music Video: Casanova ft. Jeremih &#8211; Woah"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/26/music-video-casanova-ft-jeremih-woah/" rel="bookmark" title="Music Video: Casanova ft. Jeremih &#8211; Woah">Music Video: Casanova ft. Jeremih &#8211; Woah</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/26/music-video-sir-you-cant-save-me/" rel="bookmark" title="Music Video: SiR &#8211; You Can’t Save Me"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/3mkXRPfbRK8GRUZC5-T83L9CHy99C894CtB0XnaA-gJxmUTJaI3B2tEmLJhIK3_GAMbnmEefgy4c5u4_d1Bve6iiOJaPkFWODryVFLH00nojr3wqibSU_FRprygFEkbic82NuP5opS4CwYpcqli-8e-RUh98-hssiuGZVROl5GLKqhJLalbUs4urRG2dQwn3AiossKXgKG4Ryf2xyjzxCl-kH-TJFf39UcCv7VJtw0TIUvLmL9h7U8YpUujm65YYdBYZL-4cp4w-tbQOE8jIDEAm7m4XAunIX8U9cfACCr0HZdScTcS4Q65-XzlgY5Sau3AsYTkj4IjUoyJf3JOEyZ6P89-_m2LCRybs6Hb8H6eMG8tCyZQlLoTtKo0_XJRVYUHftw8J9ivFfuB6rMl5hl5QWYOr2IZK-18HX0c5SX_uRj56CQ8hmYaT4is_aPek_IZ0li1upm_84N5yfV9CCDQ_r0Qc5eoQ3LmO6ViMUW0lf2CamLxIzXiDfhsRm4qT-MqiNgkylpZApxQK763WpUBuRvwLQ48vMj_0l8I0J0mnkuawd-OHowpg2o1mlIsA4uhjQYfDQWhcXV7vKKrqQPp7ct0tzDOejZ8lW_KD_YXZXaaiik4aLWT16-kp1KPlkkGvqZwLaKY7CDUO0G9Bbdd9hZyyzhEBxWaL72uiB4vZ5MYlQjRlkhr5JI9WPg=w1078-h527-no" alt="" title="Music Video: SiR &#8211; You Can’t Save Me"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/26/music-video-sir-you-cant-save-me/" rel="bookmark" title="Music Video: SiR &#8211; You Can’t Save Me">Music Video: SiR &#8211; You Can’t Save Me</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/26/music-video-wiz-khalifa-tyga-contact/" rel="bookmark" title="Music Video: Wiz Khalifa &#038; Tyga &#8211; Contact"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/LNpxoiMfRW1W-K0vPyzYu66bi45KlL0Noyyrdh11cE-y5OdI_XldXharb35QOiaZT8iy8GxAxvvNCydbJT0mK8bes2eUUEDrDhPgBMWLxul2v50-wu4MZWAKszpAuZQbo1o25yCw-Hsxb220feld_72VWdvqgfXyylCU5_8z_XQe3ODi3top1NhC8wZKRi3pGAz5ilLNMURghSwSny4mAKmtUyuVgRKGc86Ha--Myrd0vyyvC3fcq2iAwMegtiYjaPKQW5aj3hiw3Y6pLEsqwFnPMmzsp1Szvhww4wdC-KFff6mQcMUMJUes0IZ1huRU5dL78L7tuXGD5yxuTqvHGk2xX1Tv96NlEk-yAwk6DTRHQqP0BKyqYxTMhJoon6RpnzCLU74qAFLxsehoStkNWSXuhnagk0egGtxfozdzPAxk936lT2NpIA41XdH7WiNuzimYc9extD0m7mKggt9iLWdxV6BZZ7ls1nOByTOon36cB0T8DZB1E5deUOH5YafRrAK_YWho5PeGclc7vzh1yxP1d4kx_O69j7-J8lFyWUV0ubQwE5ENQVXbaXsdpH9xv96SXIrYZiBTII0mPQa_P8VRX90Qv2_zOsf8sPxd-6kT8_Q4UV_B1qBE2-ub4xvK6P30VLJqhKOR1oEwtCvypguRLj59y6G765MlDbLeUG0_YYzGoCe6QKyZL5x6xg=w1078-h616-no" alt="" title="Music Video: Wiz Khalifa &#038; Tyga &#8211; Contact"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/26/music-video-wiz-khalifa-tyga-contact/" rel="bookmark" title="Music Video: Wiz Khalifa &#038; Tyga &#8211; Contact">Music Video: Wiz Khalifa &#038; Tyga &#8211; Contact</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/26/music-video-mozzy-ft-blxst-i-aint-perfect/" rel="bookmark" title="Music Video: Mozzy ft. Blxst &#8211; I Ain’t Perfect"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/X0h-0yCk0kXWz3KzdGbWlILVMUSjcL-dRbEDbujdfr4Cn70k9n1kWQHJZf1AVWdjZ2g99yjfq2vfPVLBJdklJ6RZYBIr8iLfZz9hHQN2ffwL6LEVoaKrvodK0aENcYVhaRJ4hd111TZ4se4-lvEWbiVL2rOLrVFIQsww6Le4kpjruvGKi812V2Uq_6M09V0XmeFQAE5UW1rueIuWkNBkaXnzFjhc_X0ir7F1CWtCUi64_VPWFUtWqoXGfMbWKu4KSuG8xlvLLvlEu28CabBksTzX5sjoG2SDtBiXpFkkPVgi1cPUcRTidXPPf_anJRWfa51x1BD53Td-asMoPV8Ejxb_ahEwHnP-HLlmIc5E_0kylbqYuRcVhIErGqE_AHC04B5RCnzXIROzbVtGPmBibY3EOD1yZ8z-cOcEMib2i0yXtaUaM7xRg6SPZPgd8qVUjrt2NHKwTVKnerS6OvbiCFi9yBflcSEGzWbSODfwf1rDctc77J96sT5a8KyTFEdtCE9YIPwYAUapbPMoT_deZ4mb9HTTap-g_m11f5YDe6ZnTRBxtTFqknyqWaOwVEyjvKdMvF8s7RxixKGFem7gh4kSFwPY8rZ-DGpSOn74r26316_sXGXN0IYBqoXp95dPiaG-zTd4ZvsR4APGBMo_FN5iaIg3JBFm5qqEAGNtxg7NINXIJ6zewDBRzlLCjQ=w1078-h615-no" alt="" title="Music Video: Mozzy ft. Blxst &#8211; I Ain’t Perfect"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/26/music-video-mozzy-ft-blxst-i-aint-perfect/" rel="bookmark" title="Music Video: Mozzy ft. Blxst &#8211; I Ain’t Perfect">Music Video: Mozzy ft. Blxst &#8211; I Ain’t Perfect</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/26/music-video-kirko-bangz-no-call-no-clothes/" rel="bookmark" title="Music Video: Kirko Bangz &#8211; No Call/No Clothes"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/cT6J6AIw3NEafRrB_CgwLLsyw56bDjrcyKF-JROvrTwWWuYfVS00YzfhAAHS14vDDwabzNWKAX4b0XZ15hLDQhJlyJMA0YWblkIgg3q9zyFP-c6pZZh1Km0EV5Yt-omPJiy69IAW4P4mHCBELzG8IPbuokb778YvZ4_TTP1x5G-cED9KVbRjPovvQx_ip6bV7P_PxE0C259bi7jC4Rqyki1i6y5l39JvfJscN8ksg5z_tKyZLOZ-1wllgpTn5wE-UQ_RQqNsymUYhk7_4YBrkQHdWi0vL0EOAohw8SX7Qp51pYRu4faPlE67r0zgm6gezBDCZuHPLDiHLCrCcKeINKpDQQ65NYIVrDdCS3IPG1KZ4gmg-b_jecH3shbFlENxVDzBUKjfy-01PrrGGs5XyCM5gO3Jnx1UexT-9dnYc_eodMggR-aScTwAAWipSi4fUoKsSnrkAcWZB8Wcw44QPKepneeAZgeC1JjH0DolXhDzQm338BT2CLUZIYrTz5h6ZO_kYC6QNrejqANpP4paCjvYUqyPz3r3CGQFUbppf88H0PS0gGDZfGcu9bzd0NaLQfOxVhEBTAAOzpD4wuQxhqfC6YW4NATWju2s_KEv03uy7Lf64zbr8X2IHVmeC6rkISS8TmcvMhwzt-s4x_vGfL96GpGLm6uMnPojmR6zu1rpX0Rl-OtveXAopHWoHw=w1078-h711-no" alt="" title="Music Video: Kirko Bangz &#8211; No Call/No Clothes"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/26/music-video-kirko-bangz-no-call-no-clothes/" rel="bookmark" title="Music Video: Kirko Bangz &#8211; No Call/No Clothes">Music Video: Kirko Bangz &#8211; No Call/No Clothes</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_5e7d6c3f66aa2" data-td_block_id="td_uid_3_5e7d6c3f66aa2"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_3_5e7d6c3f66aa2" data-td_block_id="td_uid_3_5e7d6c3f66aa2"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_4_5e7d6c3f6b2de_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_4_5e7d6c3f6b2de" ><script>var block_td_uid_4_5e7d6c3f6b2de = new tdBlock();
block_td_uid_4_5e7d6c3f6b2de.id = "td_uid_4_5e7d6c3f6b2de";
block_td_uid_4_5e7d6c3f6b2de.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"29","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_4_5e7d6c3f6b2de_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_4_5e7d6c3f6b2de.td_column_number = "3";
block_td_uid_4_5e7d6c3f6b2de.block_type = "td_block_mega_menu";
block_td_uid_4_5e7d6c3f6b2de.post_count = "4";
block_td_uid_4_5e7d6c3f6b2de.found_posts = "990";
block_td_uid_4_5e7d6c3f6b2de.header_color = "";
block_td_uid_4_5e7d6c3f6b2de.ajax_pagination_infinite_stop = "";
block_td_uid_4_5e7d6c3f6b2de.max_num_pages = "248";
tdBlocksArray.push(block_td_uid_4_5e7d6c3f6b2de);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_4_5e7d6c3f6b2de" id="td_uid_5_5e7d6c3f6c677" data-td_block_id="td_uid_4_5e7d6c3f6b2de" data-td_filter_value="" href="http://weuponithiphop.info/category/latest-news/">All</a><a class="mega-menu-sub-cat-td_uid_4_5e7d6c3f6b2de"  id="td_uid_6_5e7d6c3f6c760" data-td_block_id="td_uid_4_5e7d6c3f6b2de" data-td_filter_value="69" href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a><a class="mega-menu-sub-cat-td_uid_4_5e7d6c3f6b2de"  id="td_uid_7_5e7d6c3f6c87e" data-td_block_id="td_uid_4_5e7d6c3f6b2de" data-td_filter_value="80" href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a><a class="mega-menu-sub-cat-td_uid_4_5e7d6c3f6b2de"  id="td_uid_8_5e7d6c3f6c999" data-td_block_id="td_uid_4_5e7d6c3f6b2de" data-td_filter_value="2189" href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a><a class="mega-menu-sub-cat-td_uid_4_5e7d6c3f6b2de"  id="td_uid_9_5e7d6c3f6caab" data-td_block_id="td_uid_4_5e7d6c3f6b2de" data-td_filter_value="10" href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a><a class="mega-menu-sub-cat-td_uid_4_5e7d6c3f6b2de"  id="td_uid_10_5e7d6c3f6cbba" data-td_block_id="td_uid_4_5e7d6c3f6b2de" data-td_filter_value="130" href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></div></div><div id=td_uid_4_5e7d6c3f6b2de class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/26/partynextdoor-partymobile-album-tracklist/" rel="bookmark" title="PARTYNEXTDOOR &#8211; PARTYMOBILE (Album Tracklist)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/ATFbNLolvOrPG1qYbnvMXeYaK5bzGbS1Rwa-R_8maqZDUfuK67vT-OL2sP-wSBwDQmECIG5kD82wrDKA43hqkeQYksadSNB9687tlDbdA4BRXH-6BO78np_iTyAkLQVxh-LReEG1RaFBlqwdXa3SExlpJXhwHHVZAX7K46hmEP49oQlKXPjlxVt4xehKIwQA6bSkal6I9atLw6HFlNt-Adl6fbM5haRWvnjrTc6dpf040DOrsCfGRdRJUcOMV8BFg6KoiaK-dsgWx_T42siw8lE2nXexXOqDtSqDP-7t1zHQqTbM0hPy26DCyiaP-t5bin7s2l9IBo7Rerj2IEZIC0TZ8g1dJLWbB8pME7gfI7MjYfUwTK2TBC2w6S8bAb7oBWUPhU410tsDZRbOCiBDtlDHLMMNMA901J9SiIbfQ7Ct8gS-Y7o9e_jyun5m0HxShEqT57y1JCXeptqPV3BpE40HBpsSdQ2NF2Z-Y-Hcd_JZz0enNkp1X0R4vadT-aYtElPhc7JsoZSReL_QjE5TCEBKv81-wqB59tLRhbEa-D7w9JuPd76fHscFsh5lw1z9BJZ4u9oXY8N7On_07srn7PCOlia7peVzmGUqwTslDrpl0nuIvXgR_dhWA-DvpNFzD3_ORR6BoZw3BuewYJQAhHhnsK3KG-0TeKE8-NoVxANPzmyRCxccgoOIgnHYhg=w753-h759-no" alt="" title="PARTYNEXTDOOR &#8211; PARTYMOBILE (Album Tracklist)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/26/partynextdoor-partymobile-album-tracklist/" rel="bookmark" title="PARTYNEXTDOOR &#8211; PARTYMOBILE (Album Tracklist)">PARTYNEXTDOOR &#8211; PARTYMOBILE (Album Tracklist)</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/25/big-sean-announces-new-album-detroit-2/" rel="bookmark" title="Big Sean Announces New Album, ‘Detroit 2&#8242;"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/6ouC7inMjbjmbHm1a-VjaVylTJycIlC42gxWMiMrru-yaqg6MIubTrufmtRKDtP2IOOh574wJKuJn7wcV9REGI9pYNvzLUF0mVfA7srqp3fR7CiFCYYsyGfiCXf-jyKVNuK_PdckN16c-dJzmBNF10gg3ZGcg_C8iebzyJ2JGlHBVjkGDwmNvHAVUVhPZUdaalBa2g1Wlhmg08sYFcQi91AXZtE-3PRMVe5moGycIAsrvw0DJh64878Vzu6agNq336cVYIvqRPQiYZqsMCZ-bL4onQHMx7kvOcRf5vnSgsuFRUUCOXKf9ZIiunxC5CgNLAdPQii47KQN0NJ2hbAiuvNG2oFlfX3jnmUAaaDvzrB_yPcPhUdyPrNNX6uJ7JD5wHOTVLuCbHROvmnk_sGd29q65beT_ruONSVQhhcJWe0msu1dBVwAmRI-AZkfp6ae6BSYU5_W1o-Z_3pZ6U0ZZ-ItGS9IP_cOw16dcVTvFYAI9ObSM0zz32_-78xMGMMp3mZvRJwnfvJQGQTwK-zfQ-fDdM1UFj6jNuv5qAyhiMuUAEVMi6_CYCDOpFcJJGwfSnVKstw6JPStuQzaatfcpurfeYxd8hldfCVGMhlHUWxOzk1vbzviq4rWqMBwfBKYdEXQ_4d4dhHcEe0OZceXrNtVZJ8-i-FICAaNfyOF9Vw2G8Vl9c3bPG9CGQDcdw=w1078-h612-no" alt="" title="Big Sean Announces New Album, ‘Detroit 2&#8242;"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/25/big-sean-announces-new-album-detroit-2/" rel="bookmark" title="Big Sean Announces New Album, ‘Detroit 2&#8242;">Big Sean Announces New Album, ‘Detroit 2&#8242;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/20/video-eminem-hotboxin-with-mike-tyson/" rel="bookmark" title="Video: Eminem: Hotboxin’ with Mike Tyson"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/ReDIiaf-gVyB4NU6XVIUf-A8eD8A_CSUHBy8F-7SpS0f2sqUluOIOgGCEzxmVHzUW32FCwQAx-wPyoDvqlL2EhOO8nBiBg9-HvDuZhPjFMcsARau6tXdv5ax7Oyimgmy1P34N6RO6_KFWnaZH-ViK397iJ8EmJIzz52kpbDapcL1TSBsITxBKE2Jut-uNU0mjnv7SSMtuLt0PH90wL0zdTUGB-Iaup0stmIbw9-lspUMe1i9V8CLrHLod0G9EahnNHQ5vkX4vjftHjQsva4MlkqZl25pCwM7Sc3MwxIMYAQOG3qKvXI4QJjmj-W1mcM_2mza8w8rsX8vA_ZkYeGDBqoeJIAVsWFBV-8z-m3DwRwIDT2cesTLGd_c5NiSXID04xbPa4Omv2TUuVs79TEc-hcfi1LgUbqfWmupnLQre3WeHITK1f3pic8IQ6iZhbwnVPLwpDrBQQRnOjj2bvBw1MKGD0MrPN4p_R05ifMOYAj99qZIyWBasVozZK0JK3W0ipp4cGv9LqgfwTEeiSbWdFsPTzoxCtxBjRsYe-agYa3Gftg5vNhQpFO9C4kOECcT7vAVC7eUle2SHNJaa7u_gunSgJLqp9Q1Y_xZsEyoRCf5kZyxDhLeN3B8WW46oUqvbdhSdpwt1p7Wepl0iJmc-gW1Elz1_YcWOsG6BS_WjMREIbPhKxR7oMtYvbGF1uw=w700-h385-no" alt="" title="Video: Eminem: Hotboxin’ with Mike Tyson"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/20/video-eminem-hotboxin-with-mike-tyson/" rel="bookmark" title="Video: Eminem: Hotboxin’ with Mike Tyson">Video: Eminem: Hotboxin’ with Mike Tyson</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/19/video-freddie-gibbs-soul-right-cataracts-live-on-vevos-ctrl/" rel="bookmark" title="Video: Freddie Gibbs &#8211; Soul Right / Cataracts (Live On Vevo’s CTRL)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/PD5T6jG6wBLaK0HFwt5JXiyZ4S4WdQUJ2PxIJao2NNY1oHuNaOccSb1ywx_lt_YVUw3vyyKyhha3srL0Pi9zFUS5aO4SGDq2JTkWB_x_QZEosEZa2wW-vL_CxpRUBuvQ6UEeIC48x8abonUixZ5Sld_WlbvQBQoFQkbbOHK4U7mB4k9vQrGrVyU8U9LWEmjm13HRQJtWASOXiC0IADyRYIavD75LiLen4bLN_ILFK9gB_0kgo3lXnnX55nPBpmpVIXs-fdnvR18cYlckTLJLMHRyiRBJ6SEgu33Z-aN5atH_3Sw0yHyYaIzTSdcFn49mAM6um0HzMF9YNOwK5ATZt9L_9Ol9MUsiCUN1lBG7MgJg2AeutArl4BvCNLn11s44RxTK7vs9j1eO13VMB22G8J5uxj9HcRUPxLhinC-LnsEZP7iqvQ5nFeUdGchRyqGtl7nqeH8t7H70GdvOcZ8PtxHw1EtPneDmM7qBxsUTsrOiBzg0p_hTuwsDnYnzD4e5HFpPZhqQ-ZIB8E609nlqfGLQMnsbegP3ScO_df8uDTlZIN0BUgG9hMPGydydIN8o0lOf2_XL3TMzgSl45-5FBspXhHmq7X0EOw7coo60qKFLep4Cc1w5saOrirTzYgAJjpGeN_ZhD9BQOyiBAklzS5mIDl8NY-4KE9Vn7AV03xmUG5NJUVCAOR_D7bUiaEE=w713-h510-no" alt="" title="Video: Freddie Gibbs &#8211; Soul Right / Cataracts (Live On Vevo’s CTRL)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/19/video-freddie-gibbs-soul-right-cataracts-live-on-vevos-ctrl/" rel="bookmark" title="Video: Freddie Gibbs &#8211; Soul Right / Cataracts (Live On Vevo’s CTRL)">Video: Freddie Gibbs &#8211; Soul Right / Cataracts (Live On Vevo’s&#8230;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_4_5e7d6c3f6b2de" data-td_block_id="td_uid_4_5e7d6c3f6b2de"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_4_5e7d6c3f6b2de" data-td_block_id="td_uid_4_5e7d6c3f6b2de"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_11_5e7d6c3f82c68_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_11_5e7d6c3f82c68" ><script>var block_td_uid_11_5e7d6c3f82c68 = new tdBlock();
block_td_uid_11_5e7d6c3f82c68.id = "td_uid_11_5e7d6c3f82c68";
block_td_uid_11_5e7d6c3f82c68.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"77","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_11_5e7d6c3f82c68_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_11_5e7d6c3f82c68.td_column_number = "3";
block_td_uid_11_5e7d6c3f82c68.block_type = "td_block_mega_menu";
block_td_uid_11_5e7d6c3f82c68.post_count = "4";
block_td_uid_11_5e7d6c3f82c68.found_posts = "158";
block_td_uid_11_5e7d6c3f82c68.header_color = "";
block_td_uid_11_5e7d6c3f82c68.ajax_pagination_infinite_stop = "";
block_td_uid_11_5e7d6c3f82c68.max_num_pages = "40";
tdBlocksArray.push(block_td_uid_11_5e7d6c3f82c68);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_11_5e7d6c3f82c68" id="td_uid_12_5e7d6c3f8416a" data-td_block_id="td_uid_11_5e7d6c3f82c68" data-td_filter_value="" href="http://weuponithiphop.info/category/fashion/">All</a><a class="mega-menu-sub-cat-td_uid_11_5e7d6c3f82c68"  id="td_uid_13_5e7d6c3f84253" data-td_block_id="td_uid_11_5e7d6c3f82c68" data-td_filter_value="76" href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></div></div><div id=td_uid_11_5e7d6c3f82c68 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/LVT4Mid8WL4wHUdO9X2OZmZxxgbREs2lVtszOdEBaO6hJB0JS3yQOAyhNSdCyPmv0amBDTgNGpOlRPXPjKCl6yIlo2joyH3rQRI7CUdX09BJtQI1r5jy1_7BQtDhw4AxUhpUwIh35rNS3lTy7uq-FdPff10JN6srr9mwZ7zr04GQFxBVEXwCfC5rNVehXhY_wGCRVsmevYmdkBWEmB8dvOzBHY78NBBjcHNArS_S-2M0FJgDh8v9m9vEh78k_XmZg-AERctsf0bkODuPi1EcNJq_RnJIV6b0GG-VtKjo-OVPmYghWJYf1HiP9c58cQ98oABU8BDFdLqsBtNt4K0NmyHYQlX39W9k_d83wEHZ1-EacQa2o01VrYSn12HnZ1l88fMzu9PKv6EGmcRZNwpepycW7_9EQnhxIPDdVCmRLXUasUED9OXr-zJmnBcnSnLCa06k1ZymQym1LiSFEv1c3aPHnmnD3GY8nL7q5jPJr4HsABR0WCqMebcF3HF_0deNd0zgRBCGMxW-VzlIIHZiHuBeSPEPvUL149GJ5swSSvKm1uGEi1HlLBj9omJSU7mDWzO0p_7l-l7-4_ureEsGsgB8cX1t8t2TQcFeRgqqF1CXlZFYYC2K0iMb4jPsijsw_rtO7pmKvbngqHfgYpGeh_qLmDWeicR7=w1195-h796-no" alt="" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch">Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/fHEwwMf8DoiXlqkfibQS1Z1XXbviORbV9raaI44tOTXrWo7GgqM3gA-vswE10gFtTQUGGwNG7nWAACwHjxPuiubliYBN_dqtBZh2WIpxvumiJ-hSLK0TNWB2cB8Iw2STT5gcp_KqlDh_e4xng1vidI8EXdp_ooh5uDI-JV1HQ9dGnM5nxl_b-v8znqj-Rl_mGB7y4Lu9zsFNWHU7SriqQQJaKrKEEnb9T8zxmGLaL0zq7ilYpnUEhWulDDr9xc82wdr__WzRBm5YEskVpDAnGM2NDZwTZpjbe4QDdxeixWnSXNK_oDzaL7WTbCpkD33OK88BlI5JmFRQ5VmD11UQ2htB7-9WoahHvb4XmBsbLXpEMl1JmEP4sPx06VduzFnBNo-J90WI0n1AEIIcEYVbRywrkGJXbzmH__In9ZIg0EV24OcGGbeKl12HxTdZwucqsNnuZeNjiMHISQ7i8cfzm3N7X7Zenl74zsKIKeKWoIGxh6MTlVADvgHcrHebnjcSgil2vBeFyz_AP45aOv9SOwbzfVLGS0CNfe1s9b2J7qZgjcBk9QPEXCl2kygvzmGXFvU_3xBuW6S0i3Vkh3Ha_3hPBtvIAy3WoTK2yiqS41HzSK7yk3FRAlBtpIEib338fdkTiosBxtdu36SdNUVM75zl6CVIFhTu=w681-h470-no" alt="" title="Air Jordan 14 Rip Hamilton"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton">Air Jordan 14 Rip Hamilton</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/kUjaOYxjEkAh34S-Ub2QSZwdOwHyFnGFLBZULta3_bn1_myPMAwJXiEEsAAtc1ktCQwHCuKhSqSYsWXFBEIZxdfKuykoDEZWwO-dDI3_JeAshbYvyILEHUu0XaUpRn0mj7gOx10V52t8gRGYPCW7QXGImkPGGhvBPzBDVVqh9lKGtkuPeePmTnpRSmwp0LG1WHcIzUWnMqPBWQeHAat6Q-Tq7niXNb96ddEZsMEdHK1nmHVlNaeqFBNtTxk6yYRkFNCvtfBayqy-Rqt4CPU5tThxbTI4AIUCI6JLxJd_VJizrVNDEe2xZ_tiQdkC5ASIoHpX8sfvAB8zRUsMVJ6oMUt5FH_4GBNXDCtFRmr65Qt0JV1h4bBJffu2L272Q_vpD76wn-YNGW8VCtZcheHu_X-A4gdYQEC0HN0BenY-MOuUBqKEjXAc0SxWeP7W9RN55jlqUFK0nzEYydVjec2stdQIngVfg_FvKxvHXfM4XdtMpqeJnp3Pzyk8xjz30sAZd0f2HQ6zfdPjk-OkV2-WrC0_qW0L8Rq3zrUbq52n3BN7gm7sctU_CUlBmoQIgJDQBYk1Siv4tfSq9pL1R4GdaOlWQdxEuhZi8bTYC8GGAgNGl3SMAZGvk7nu6QnnwEZjZ7mZwbcqgyRKa89cOREMUvIkVJ8Q8lZu=w926-h672-no" alt="" title="Jordan Proto React Triple White"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White">Jordan Proto React Triple White</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4cDUjSODZSaXWfHyZKb9q3Fn7FHA4uB0KSBs0MtFHC0dc6AJb1zeAl_X2LOKalK9C7VBFhTqRQ9fw1ESgUr9ZUKFbOzD94i_s96nvkICOqrsYnzrE2nEAQHoEaGOF4O8GAI6T4CGFbgcQhNzjpRlSY60NyPu5Cmq81FRpEOFRzTOtSa_NnWzMmfwO0yxtPbcg5U6YBUsus8shv3SA7CjULLfaP38nZAuWVgq8PMaaeCQ_eSrK8NJSEVQjyyxmqb-1I7zO8Kvvzvwi--ibMr52CF8h-GusBzSq5ZuzvZRCGu_u8CyfoXw7pwWbOmHnLOdcQ9d2PCSW_IxEMGfmEuU7NxMSsW3Ga4r35_wLB7cjvlPC9OjCV50tfekXjZBS_476mzlf4G9jR7Ju1GqgjXah9Uqc_0Y8N-Br8_JCtIlRSuLxAiebwd7AvFVlgWId9MYxBWnRT3cTyD8SH7q5WwO-CIbKAOSKsNcrrTgFxQvqn9yklBU1u5X5fdTlTBk4WSYorsWZAug0z9BOymRLnrhTbnA0vpBPFROWD-aL1glg-eUpFSfgD4xhWsOqJNY9krQ2UbLSGXQ5gYWj0ovLS7Yz3UKFY2qrVWpqkpbfyN98es9NJ-7LTUs2MLq1rX_2FaQmyq5mVndd7VGzQOHy9hDULG-5H-0LvGd=w900-h566-no" alt="" title="adidas Yeezy Boost 350 V2 Hyperspace"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace">adidas Yeezy Boost 350 V2 Hyperspace</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_11_5e7d6c3f82c68" data-td_block_id="td_uid_11_5e7d6c3f82c68"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_11_5e7d6c3f82c68" data-td_block_id="td_uid_11_5e7d6c3f82c68"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div></div>


<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form method="get" class="td-search-form" action="http://weuponithiphop.info/">
				<div role="search" class="td-head-form-search-wrap">
					<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>            </div>
        </div>
    </div>

    <div class="td-banner-wrap-full">
        <div class="td-header-container td-header-row td-header-header">
            <div class="td-header-sp-recs">
                <div class="td-header-rec-wrap">
    
</div>            </div>
        </div>
    </div>

</div>
<article id="post-37520" class="td-post-template-7 post-37520 post type-post status-publish format-standard has-post-thumbnail hentry category-new-music tag-kota-the-friend tag-marlon-craft" itemscope itemtype="http://schema.org/Article">

    <div class="td-full-screen-header-image-wrap">

        <div class="td-container td-post-header">
            <div class="td-crumb-container"><div class="entry-crumbs"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="" class="entry-crumb" itemprop="url" href="http://weuponithiphop.info/"><span itemprop="title">Home</span></a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="View all posts in New Music" class="entry-crumb" itemprop="url" href="http://weuponithiphop.info/category/new-music/"><span itemprop="title">New Music</span></a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last" itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><meta itemprop="title" content = "New Music: Marlon Craft ft. Kota the Friend &#8211; Mom’s Whiskey"><meta itemprop="url" content = "http://weuponithiphop.info/2020/03/26/new-music-marlon-craft-ft-kota-the-friend-moms-whiskey/">New Music: Marlon Craft ft. Kota the Friend &#8211; Mom’s Whiskey</span></div></div>

	        <div class="td-post-header-holder">

		        <div class="td-parallax-header">

	                <header class="td-post-title">

	                    <ul class="td-category"><li class="entry-category"><a  href="http://weuponithiphop.info/category/new-music/">New Music</a></li></ul>	                    <h1 class="entry-title">New Music: Marlon Craft ft. Kota the Friend &#8211; Mom’s Whiskey</h1>

	                    
	                    <div class="td-module-meta-info">
	                        <div class="td-post-author-name">By <a href="http://weuponithiphop.info/author/cyclone/">cyclone</a> - </div>	                        <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-26T17:03:27+00:00" >March 26, 2020</time></span>	                        	                        <div class="td-post-comments"><a href="http://weuponithiphop.info/2020/03/26/new-music-marlon-craft-ft-kota-the-friend-moms-whiskey/#respond"><i class="td-icon-comments"></i>0</a></div>	                    </div>

	                </header>

		            <div class="td-read-down"><a href="#"><i class="td-icon-read-down"></i></a></div>
		        </div>
            </div>

        </div>

        <div id="td-full-screen-header-image" class="td-image-gradient-style7">
            <img class="td-backstretch" src="https://lh3.googleusercontent.com/KlBJhollqGWaimmQSP7Zym42ZJJleWcdVSPXzChreFC8wDs-uPCVG3DKNWOPwOVxqmDQNNALonMBWWnO-PuK7AYEcI2-NYvs7RYJi_TscAF04CPVtGPmrHI4JcFyRESP6zBVB87wsnzz53kiSrScGN2RrDMF7CbsuImDngWTFwYzNzUXN6fbKuutdje_8X0JUg5_M8jGFXdA2tm8_CM2dw6D4R3qbglpXOl-IApooMEL4vSUwPETGN4kSK4aMQFi6ca_Rumz3xY6DnSyMF6EUZYK9AV3FRF1Mbt4mqX3AGiCC2kb1fJmB_nnllLFdGuAtb8XGwE5kQ0tuvUtK6IGvUTuswGIb3XaLErCD8eyDoSbZqFLg6q1Pj5S1l5paS-NTYnmdhmGAD6-eaGKZsvsuDJS5fT9qZl1IZsTjUx3uBcI1mBDpZk0k73Upt8O1BYHxHdQ1OuUKalMfib_codY9jOWlfxHVeqsVFzT50gijW6erN_6g01wlJRVbJPY8JOwTZBFXCf4YEsEBZb0wiDWUge55j2B1tAipTqikgpx_kJK91bs--xScmAwjuAytexC_1MGhO09Z0Kb0Ef-nEJEkYGTyQM2nEzWB_yG7XXyF63-LmHW2iSoAjKgnu1wo4aVTqOK8OgtQZBYGwh3DJvwsvI2YVu7N3YHJNSj7fWonTEaWOUcyV9tVLGgltOcqA=w1080-h607-no">
        </div>
    </div>

    <div class="td-container">
        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    

    <div class="td-post-content">
        <p><img class="aligncenter size-full" src="https://lh3.googleusercontent.com/KlBJhollqGWaimmQSP7Zym42ZJJleWcdVSPXzChreFC8wDs-uPCVG3DKNWOPwOVxqmDQNNALonMBWWnO-PuK7AYEcI2-NYvs7RYJi_TscAF04CPVtGPmrHI4JcFyRESP6zBVB87wsnzz53kiSrScGN2RrDMF7CbsuImDngWTFwYzNzUXN6fbKuutdje_8X0JUg5_M8jGFXdA2tm8_CM2dw6D4R3qbglpXOl-IApooMEL4vSUwPETGN4kSK4aMQFi6ca_Rumz3xY6DnSyMF6EUZYK9AV3FRF1Mbt4mqX3AGiCC2kb1fJmB_nnllLFdGuAtb8XGwE5kQ0tuvUtK6IGvUTuswGIb3XaLErCD8eyDoSbZqFLg6q1Pj5S1l5paS-NTYnmdhmGAD6-eaGKZsvsuDJS5fT9qZl1IZsTjUx3uBcI1mBDpZk0k73Upt8O1BYHxHdQ1OuUKalMfib_codY9jOWlfxHVeqsVFzT50gijW6erN_6g01wlJRVbJPY8JOwTZBFXCf4YEsEBZb0wiDWUge55j2B1tAipTqikgpx_kJK91bs--xScmAwjuAytexC_1MGhO09Z0Kb0Ef-nEJEkYGTyQM2nEzWB_yG7XXyF63-LmHW2iSoAjKgnu1wo4aVTqOK8OgtQZBYGwh3DJvwsvI2YVu7N3YHJNSj7fWonTEaWOUcyV9tVLGgltOcqA=w1080-h607-no" width="1080" height="607" /></p>
<p><strong>Marlon Craft‘s</strong> dropped the first version of his single <strong>“Mom’s Whiskey”</strong> during his Flavors freestyle series. He adds a new verse from Brooklyn&#8217;s <strong>Kota The Friend</strong> for an updated version. <strong>Craft</strong> says about the record:</p>
<p><em>“I wrote ‘Mom’s Whiskey’ mad late one night, completely broke, waiting for the album to drop, and I literally found a stashed bottle of my mom’s whiskey that she had hidden when I was looking for a pen. I found that beat on YouTube and it all just spilled out.”</em></p>
<p>Stream <strong>“Mom’s Whiskey”</strong> below.<br />
<iframe src="https://www.youtube.com/embed/EftGm-JUZm0" width="700" height="400" frameborder="0" allowfullscreen="allowfullscreen"></iframe></p>
<div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="http://weuponithiphop.info/2020/03/26/new-music-marlon-craft-ft-kota-the-friend-moms-whiskey/" data-a2a-title="New Music: Marlon Craft ft. Kota the Friend – Mom’s Whiskey"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2020%2F03%2F26%2Fnew-music-marlon-craft-ft-kota-the-friend-moms-whiskey%2F&amp;linkname=New%20Music%3A%20Marlon%20Craft%20ft.%20Kota%20the%20Friend%20%E2%80%93%20Mom%E2%80%99s%20Whiskey" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2020%2F03%2F26%2Fnew-music-marlon-craft-ft-kota-the-friend-moms-whiskey%2F&amp;linkname=New%20Music%3A%20Marlon%20Craft%20ft.%20Kota%20the%20Friend%20%E2%80%93%20Mom%E2%80%99s%20Whiskey" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2020%2F03%2F26%2Fnew-music-marlon-craft-ft-kota-the-friend-moms-whiskey%2F&amp;linkname=New%20Music%3A%20Marlon%20Craft%20ft.%20Kota%20the%20Friend%20%E2%80%93%20Mom%E2%80%99s%20Whiskey" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2020%2F03%2F26%2Fnew-music-marlon-craft-ft-kota-the-friend-moms-whiskey%2F&amp;linkname=New%20Music%3A%20Marlon%20Craft%20ft.%20Kota%20the%20Friend%20%E2%80%93%20Mom%E2%80%99s%20Whiskey" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_tumblr" href="https://www.addtoany.com/add_to/tumblr?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2020%2F03%2F26%2Fnew-music-marlon-craft-ft-kota-the-friend-moms-whiskey%2F&amp;linkname=New%20Music%3A%20Marlon%20Craft%20ft.%20Kota%20the%20Friend%20%E2%80%93%20Mom%E2%80%99s%20Whiskey" title="Tumblr" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_reddit" href="https://www.addtoany.com/add_to/reddit?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2020%2F03%2F26%2Fnew-music-marlon-craft-ft-kota-the-friend-moms-whiskey%2F&amp;linkname=New%20Music%3A%20Marlon%20Craft%20ft.%20Kota%20the%20Friend%20%E2%80%93%20Mom%E2%80%99s%20Whiskey" title="Reddit" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_flipboard" href="https://www.addtoany.com/add_to/flipboard?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2020%2F03%2F26%2Fnew-music-marlon-craft-ft-kota-the-friend-moms-whiskey%2F&amp;linkname=New%20Music%3A%20Marlon%20Craft%20ft.%20Kota%20the%20Friend%20%E2%80%93%20Mom%E2%80%99s%20Whiskey" title="Flipboard" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2020%2F03%2F26%2Fnew-music-marlon-craft-ft-kota-the-friend-moms-whiskey%2F&amp;linkname=New%20Music%3A%20Marlon%20Craft%20ft.%20Kota%20the%20Friend%20%E2%80%93%20Mom%E2%80%99s%20Whiskey" title="Copy Link" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div>    </div>


    <footer>
                
        <div class="td-post-source-tags">
                        <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="http://weuponithiphop.info/tag/kota-the-friend/">Kota The Friend</a></li><li><a href="http://weuponithiphop.info/tag/marlon-craft/">Marlon Craft</a></li></ul>        </div>

                <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="http://weuponithiphop.info/2020/03/26/new-music-trav-ft-tory-lanez-you-choose/">New Music: Trav Ft. Tory Lanez &#8211; You Choose</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="http://weuponithiphop.info/2020/03/26/music-video-mozzy-ft-blxst-i-aint-perfect/">Music Video: Mozzy ft. Blxst &#8211; I Ain’t Perfect</a></div></div></div>        <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="http://weuponithiphop.info/author/cyclone/">cyclone</a></span></div>        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="cyclone"></span><meta itemprop="datePublished" content="2020-03-26T17:03:27+00:00"><meta itemprop="dateModified" content="2020-03-26T17:03:27+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://weuponithiphop.info/2020/03/26/new-music-marlon-craft-ft-kota-the-friend-moms-whiskey/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png"></span><meta itemprop="name" content="WeUpOnIt"></span><meta itemprop="headline " content="New Music: Marlon Craft ft. Kota the Friend - Mom’s Whiskey"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://lh3.googleusercontent.com/KlBJhollqGWaimmQSP7Zym42ZJJleWcdVSPXzChreFC8wDs-uPCVG3DKNWOPwOVxqmDQNNALonMBWWnO-PuK7AYEcI2-NYvs7RYJi_TscAF04CPVtGPmrHI4JcFyRESP6zBVB87wsnzz53kiSrScGN2RrDMF7CbsuImDngWTFwYzNzUXN6fbKuutdje_8X0JUg5_M8jGFXdA2tm8_CM2dw6D4R3qbglpXOl-IApooMEL4vSUwPETGN4kSK4aMQFi6ca_Rumz3xY6DnSyMF6EUZYK9AV3FRF1Mbt4mqX3AGiCC2kb1fJmB_nnllLFdGuAtb8XGwE5kQ0tuvUtK6IGvUTuswGIb3XaLErCD8eyDoSbZqFLg6q1Pj5S1l5paS-NTYnmdhmGAD6-eaGKZsvsuDJS5fT9qZl1IZsTjUx3uBcI1mBDpZk0k73Upt8O1BYHxHdQ1OuUKalMfib_codY9jOWlfxHVeqsVFzT50gijW6erN_6g01wlJRVbJPY8JOwTZBFXCf4YEsEBZb0wiDWUge55j2B1tAipTqikgpx_kJK91bs--xScmAwjuAytexC_1MGhO09Z0Kb0Ef-nEJEkYGTyQM2nEzWB_yG7XXyF63-LmHW2iSoAjKgnu1wo4aVTqOK8OgtQZBYGwh3DJvwsvI2YVu7N3YHJNSj7fWonTEaWOUcyV9tVLGgltOcqA=w1080-h607-no"><meta itemprop="width" content="800"><meta itemprop="height" content="600"></span>    </footer>

    <div class="td_block_wrap td_block_related_posts td_uid_15_5e7d6c3f903f9_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_15_5e7d6c3f903f9" ><script>var block_td_uid_15_5e7d6c3f903f9 = new tdBlock();
block_td_uid_15_5e7d6c3f903f9.id = "td_uid_15_5e7d6c3f903f9";
block_td_uid_15_5e7d6c3f903f9.atts = '{"limit":6,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_custom_related","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_15_5e7d6c3f903f9_rand","offset":"","css":"","live_filter":"cur_post_same_tags","live_filter_cur_post_id":37520,"live_filter_cur_post_author":"1"}';
block_td_uid_15_5e7d6c3f903f9.td_column_number = "3";
block_td_uid_15_5e7d6c3f903f9.block_type = "td_block_related_posts";
block_td_uid_15_5e7d6c3f903f9.post_count = "6";
block_td_uid_15_5e7d6c3f903f9.found_posts = "7";
block_td_uid_15_5e7d6c3f903f9.header_color = "";
block_td_uid_15_5e7d6c3f903f9.ajax_pagination_infinite_stop = "";
block_td_uid_15_5e7d6c3f903f9.max_num_pages = "2";
tdBlocksArray.push(block_td_uid_15_5e7d6c3f903f9);
</script><h4 class="td-related-title"><a id="td_uid_16_5e7d6c3f92887" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_15_5e7d6c3f903f9" href="#">RELATED ARTICLES</a><a id="td_uid_17_5e7d6c3f928c5" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_15_5e7d6c3f903f9" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_15_5e7d6c3f903f9 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/18/new-music-statik-selektah-termanology-ft-ufo-fev-marlon-craft-another-day/" rel="bookmark" title="New Music: Statik Selektah &#038; Termanology ft. UFO Fev &#038; Marlon Craft &#8211; Another Day"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/ssRB9HM2KpOXo62k5aH6sR5Ajd6SdlLe0mkdChHQL9w8mjtlXDpw-SbnPRQfy8xz--MoCCieD3VzSkaAn-n0d2CdW-aqV-wWZ8eQTmXRtBQryCzn_EDiDZf34DdjOg0_wnpFsXcsqtmGrpp9viPm0zgGA4G0Yo-KqR4b-cBa-Ryf6AgrQSrE3LYaZRCmAATRlYiuoE5HJRMOwBulOJ5sx19apvEFb-G8GE9NxMHXxKtCyKZNdnYTkMIo9cOGKaqIqvcelrC4YfgoS547v4ckpubQ3H3xG5kNZ7IWNUklSU2_Rtr2zc5IcWqobXfdJOPqfVM66d0KB68oJZ9Bo0fgFfSrdpgUbKCAFwhM-38jM9HJGQV_5HnwSfXcX0zv3vzMyYm6BFWtyxdiDebPQw7Sm9iEOwf6x8jlyOxPMeD4uiAFraTk71fCKAj1e-u1Kg5jFYgG4zeCwLRthxQznWZB8ycUxdRrmuFdEZs0KUxDqwR3wDFChfFlK6xIwNVrB-Rnm5H0Uz69_t0pLc36ezQV98TkIeVFzOqXVm5mlt1fC9q3wtxV5Lakmf7G5EgHHroBBBxRamn7nAMMGRJe67W_3jcKeJrJLFq1Xl0Rk60Eu7XtDUhMAyxi3Okm-XxiWUqbWXmjJGMb5iZiqPq7JrQrIgy9CIxoBoYTDsJiKf1nvjMpJAATunIrj_8rDyWCvvI=w328-h327-no" alt="" title="New Music: Statik Selektah &#038; Termanology ft. UFO Fev &#038; Marlon Craft &#8211; Another Day"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/18/new-music-statik-selektah-termanology-ft-ufo-fev-marlon-craft-another-day/" rel="bookmark" title="New Music: Statik Selektah &#038; Termanology ft. UFO Fev &#038; Marlon Craft &#8211; Another Day">New Music: Statik Selektah &#038; Termanology ft. UFO Fev &#038; Marlon Craft &#8211; Another Day</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/16/new-music-1982-statik-selektah-termanology-ft-kota-the-friend-cj-fly-relatable/" rel="bookmark" title="New Music: 1982 (Statik Selektah &#038; Termanology) ft. Kota The Friend &#038; CJ Fly &#8211; Relatable"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/XP6Jtq4wrBzRCwHC1kT-mJDp56lvsxNuNl6LK_rMFKTjsJIDnGdm88G23TXmKvwSHpM0WiBxmqVwei3ny4VoofNxHInmB0nSCNAB49Z6wYrH2ohobscloyg5a0L2ZI7Cd1PhzOQzAbgL5D2QYEu_qt4qkKTBIwkNLFaWFipqxMGIeqo3AEToCNiUlgqkHyluoeffngI6FY6UdNWSGz9VKOKoriJEOHz-MmmU12jhw1BAkdJps61WGTzQZ5-MlC5TA-QyNpZ9h6LPCpqH0cLPFL9FB32oT8FwSAahrMPFaRQEuorkV-2Ihy3bn_7Pg8G8x3yK9TUbPU7i6pyo7lTRK04q6xOHoy8gO3lHcZGCrcAKxU5TWXBiYUFRqHHXAbTs9Cml-stOwGAu09xMLFEElPPPyeRelDEbPE89kqnNZwj84H2Y35PSPvWrsnMszkEsU73TlPrWjFMiVFZ2ObHluhr3Tz_nPFkP_l_wKFs9JCGK4FaplveiYaau9gyWVFk28X1zVtREZNFsMCIDl2xAYPS7o8mwV9BYfucXQPECeo8ZgMm4BcgIgHer-A_xec1Ak29kLRots-00_kN_QYppFHF712rQEkri9iB2za3AOqUIHg0NNdA4boPq5w8hUM97WYL4YQTnjn2UfLa41WttHANnTgqLjSUi148V_g8HrvmZITix11UtofBhWtLCyBg=w761-h758-no" alt="" title="New Music: 1982 (Statik Selektah &#038; Termanology) ft. Kota The Friend &#038; CJ Fly &#8211; Relatable"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/16/new-music-1982-statik-selektah-termanology-ft-kota-the-friend-cj-fly-relatable/" rel="bookmark" title="New Music: 1982 (Statik Selektah &#038; Termanology) ft. Kota The Friend &#038; CJ Fly &#8211; Relatable">New Music: 1982 (Statik Selektah &#038; Termanology) ft. Kota The Friend &#038; CJ Fly &#8211; Relatable</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/06/08/music-video-marlon-craft-gang-shit/" rel="bookmark" title="Music Video: Marlon Craft – Gang Shit"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/IBsCdwdd6z0t59NWgWto3YOevqg7o03pvwGGPMdUv7u9naIQ5iKdg9L3OErPebdEc_8YndovhIsX2eZ9fGBprtsDaCpW1D00nbNgeFTFbravREhcFYAmEPYMDYABS69Yv3uZgRBZHTaiyfnkGQgY1nJrt824g387vFC-yOgHmuUcWGv_dagNl_VL0YidMB8uL7JrxteWaL0mia2zJJvq3uDd3mcXJdAuJIxN91eBbhsUo0-SElz-kk_cUMD_Ppxh4JUgjDzn5OtCGu3lu_QlOK7HzRFb69wPqTk9QSSUrFMCfmicz3uI3mqCrEba3OCo4gGngOCNx8ZXW4kWf2l-1jgSlIfWl180c1BrX_b3MSJENHIrc3lYKxsDnjBSFm9KdGE8Fuxr6yUNuN4WTMeZxlYshmjjFqAwdbhT8ah5Zec-AE2ADljd-9h9N-CQcehOj2DodK8XBTfXPcQylTbTAN3ttsjK5QzERvTVx6_An2_jl5lXrD5q1oePtx8By3MlsH94Yd48RwJ4Cp5RZt2o4W7YD2jIrVTZZFqp70FAcQ71uHBIiMxx1x8IVcPLVO7WLouWP3XGg-pt4JoZ60DOrugGdw5rKgZfTK-NLWdPPWM2CfHkf3ovyUyTs8EmQernqOUYctPTK-K_F2X32rXxb_LbATAIkaAb=w833-h477-no" alt="" title="Music Video: Marlon Craft – Gang Shit"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/06/08/music-video-marlon-craft-gang-shit/" rel="bookmark" title="Music Video: Marlon Craft – Gang Shit">Music Video: Marlon Craft – Gang Shit</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid-->

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/18/album-stream-kota-the-friend-foto/" rel="bookmark" title="Album Stream: Kota The Friend – FOTO"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/IjZnVgWDe-qpoRleeNOXWmVQmu7mb7Vb5fyBlMZL1BhRKbLKSisaSRL4qhEx8zKtd615xEvNjoyHML2bWEpJIAcc-TeH550cK7kDobSmvP-hLPaOaP-PyqJEykmYc52Z_4zdRDQ1WJFgnPew_I1afwGPf2J7ecAhtG7Ut97O_xrt98443trzx4YW4HVRm_zfYRbk8p0-xMX671a1KtKUrBnLVcEv6MjxTg9Ggb8WVD4gdmxrEAPX2Z1KLHNrKkEBb_TX9tz2Yt2fPecELXwyZgUikW2EyvqYZXoWli_RzYeBhie79LoOqdoT1XXqCkjqtxkyZMkOfZr5_bdraRXn1LqddvCzzbxvudPZvlvX0bq2UR71e15dKynLN_kNm8em03GUg5QdMdJDWhHtScWpOv-RQKSQ0gN51M5RmfstTf3JoPxI2LDttTN73NUibKT_4rH923kQ6_4T8gswrvycr-sFsrsFmmD624oMQ11rIJQSChdtFP7dPuPt9FlkrZgTRyyu3K3FnE36zAE1C-NnbMzyfgnwefvnx08WURlvNL4ThJvf4sySRDAfseZ_5wgiN7MHJF_0UIkuuYTo5JeuQtC3njy7tS-LlgzYMo73Fo-sn6erbn9WTo5QlIw_9RJpeq1IPFw5e3QhSwZKbTZb5DMOj0aQxMLm=s796-no" alt="" title="Album Stream: Kota The Friend – FOTO"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/18/album-stream-kota-the-friend-foto/" rel="bookmark" title="Album Stream: Kota The Friend – FOTO">Album Stream: Kota The Friend – FOTO</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/16/new-music-marlon-craft-ft-dizzy-wright-shallow/" rel="bookmark" title="New Music: Marlon Craft ft. Dizzy Wright – Shallow"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4RVNgWguIE3j8ttbDjEYQmvB6UUBL4jDNpvSJyMFrwDpGZYoB1TRXmhOdkmevntx1kMc3IqosGI=s328-no" alt="" title="New Music: Marlon Craft ft. Dizzy Wright – Shallow"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/16/new-music-marlon-craft-ft-dizzy-wright-shallow/" rel="bookmark" title="New Music: Marlon Craft ft. Dizzy Wright – Shallow">New Music: Marlon Craft ft. Dizzy Wright – Shallow</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/13/music-video-marlon-craft-do-the-work/" rel="bookmark" title="Music Video: Marlon Craft &#8211; Do The Work"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/YhekrZJByYiB9ukGAM9PWftyRoW-QC3lN_TZftRUEIBjWjjkXNNefEhaIrxmO-rCz-DNlNC2_BrvE2Dv6ft6_KGTlv4rYcqm93m4cvQffoKjefwmO_JEuAvGDogjW_bQTRMgyaPcgOP4SbjDvl6mYmbKzn0vNIp1RPR828gkgoKzNfzx_ImfND55Isme995-j6brhQ5AR-Dlh0oaFpt6IjCQA1mpvPMV6STvJPE0Hev0Hhx8MK4pjmbYVcMq4fHW5JunV8w9pAAT1Vvzz4x5zRnCFp3nyjyzEjOvckrRA05JIrluDXjB_afYW17PskeoDFSK_rAdNOn1ATU2TTUR35ik5rnBFvfjOU7GEtri2JTnVtx2Kxlh9bmTxB1BLAkNvhNGc3byTxQiVzYYyWDTLWuKfoN3DuFOmCWT_6DbbvhCY490oTnIf6uYfAc57NkZ4bagzJwJ0uFkzTP5fO3GSTVfqjzBjDAf05__iB5ubIQ5BKd1AYVtVFwFqw_fTOxTyOF-WLu3spLeuka6X1P07soBK12yASQSrXWq_F5yS3GIUl2A0hrvJ6PwNSu_6LLLzWK5SVweK2OXoiqL-ndYFJmN-CIm5pptNZoqmHhUJz-pd5OrRLPgA3xfszCCzTErWwJ05GOeBzubH8AGFH7bYwlw1vQb1ShC=w888-h505-no" alt="" title="Music Video: Marlon Craft &#8211; Do The Work"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/13/music-video-marlon-craft-do-the-work/" rel="bookmark" title="Music Video: Marlon Craft &#8211; Do The Work">Music Video: Marlon Craft &#8211; Do The Work</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_15_5e7d6c3f903f9" data-td_block_id="td_uid_15_5e7d6c3f903f9"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_15_5e7d6c3f903f9" data-td_block_id="td_uid_15_5e7d6c3f903f9"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->

	<div class="comments" id="comments">
            </div> <!-- /.content -->
                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <aside class="widget widget_search"><form method="get" class="td-search-form-widget" action="http://weuponithiphop.info/">
    <div role="search">
        <input class="td-widget-search-input" type="text" value="" name="s" id="s" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit" value="Search" />
    </div>
</form></aside><aside class="widget widget_text">			<div class="textwidget"><h4><strong><span style="color: #8224e3;"><span style="color: #000000;">Listen to</span> <span style="color: #c60000;">WeUpOnItRadio</span> <span style="color: #000000;">Live!</span></span></strong></h4>
<p><span class="cc_streaminfo" data-type="song" data-username="cyclone777">Loading &#8230;</span><br />
<script language="javascript" type="text/javascript" src="https://control.internet-radio.com:2199/system/streaminfo.js"></script><br />
<iframe src="https://tunein.com/embed/player/s292400/" style="width:100%; height:100px;" scrolling="no" frameborder="no"></iframe></p>
</div>
		</aside>
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-sidebar ">
<script type="text/javascript">
var td_screen_width = document.body.clientWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 

<aside class="widget widget_text"><div class="block-title"><span>AUDIOTRAFFICKER:</span></div>			<div class="textwidget"><p><iframe src="https://www.facebook.com/plugins/video.php?href=https%3A%2F%2Fwww.facebook.com%2FAudioTrafficker%2Fvideos%2F326277991409372%2F&#038;show_text=0&#038;width=560" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true" allowFullScreen="true"></iframe></p>
</div>
		</aside><aside class="widget widget_text"><div class="block-title"><span>Kaeyel ft. Martease &#8211; For My Dogs</span></div>			<div class="textwidget"><p><iframe src="https://open.spotify.com/embed/track/21SM8X1m50HOUwbvH8i1Z7" frameborder="0" allowtransparency="true" allow="encrypted-media"></iframe></p>
</div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><div aria-live="polite" id="soliloquy-container-30342" class="soliloquy-container soliloquy-transition-fade  soliloquy-theme-classic" style="max-width:960px;max-height:300px;"><ul id="soliloquy-30342" class="soliloquy-slider soliloquy-slides soliloquy-wrap soliloquy-clear"><li aria-hidden="true" class="soliloquy-item soliloquy-item-1 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109673710?productType=812&#038;appearance=1" class="soliloquy-link" title="Revolt Tee" target="_blank"><img id="soliloquy-image-30349" class="soliloquy-image soliloquy-image-1" src="http://weuponithiphop.info/wp-content/uploads/Revolt-Tee.jpg" alt="Revolt Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-2 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/youngongetthiswork?q=I12154011" class="soliloquy-link" title="You Gon Get This Work" target="_blank"><img id="soliloquy-image-30344" class="soliloquy-image soliloquy-image-2" src="http://weuponithiphop.info/wp-content/uploads/You-Gon-Get-This-Work.jpg" alt="You Gon Get This Work" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-3 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/savage+bloody?q=I1014473415" class="soliloquy-link" title="Savage Bloody" target="_blank"><img id="soliloquy-image-30343" class="soliloquy-image soliloquy-image-3" src="http://weuponithiphop.info/wp-content/uploads/Savage-Bloody.jpg" alt="Savage Bloody" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-4 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/can?q=I1011767996" class="soliloquy-link" title="spray" target="_blank"><img id="soliloquy-image-30345" class="soliloquy-image soliloquy-image-4" src="http://weuponithiphop.info/wp-content/uploads/spray.jpg" alt="spray" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-5 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814012" class="soliloquy-link" title="Good Vibes Only 1" target="_blank"><img id="soliloquy-image-30346" class="soliloquy-image soliloquy-image-5" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-1.jpg" alt="Good Vibes Only 1" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-6 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/blessed?q=I12044252" class="soliloquy-link" title="Blessed Tee" target="_blank"><img id="soliloquy-image-30347" class="soliloquy-image soliloquy-image-6" src="http://weuponithiphop.info/wp-content/uploads/Blessed-Tee.jpg" alt="Blessed Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-7 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/trap?q=I1009984243" class="soliloquy-link" title="Trap Tee" target="_blank"><img id="soliloquy-image-30348" class="soliloquy-image soliloquy-image-7" src="http://weuponithiphop.info/wp-content/uploads/Trap-Tee.jpg" alt="Trap Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-8 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/good+vibes+only+birds?q=I1014476779" class="soliloquy-link" title="Good Vibes Only 2" target="_blank"><img id="soliloquy-image-30350" class="soliloquy-image soliloquy-image-8" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-2.jpg" alt="Good Vibes Only 2" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-9 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/all+seeing+eye?q=I11739019" class="soliloquy-link" title="ILLuminati" target="_blank"><img id="soliloquy-image-30351" class="soliloquy-image soliloquy-image-9" src="http://weuponithiphop.info/wp-content/uploads/ILLuminati.jpg" alt="ILLuminati" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-10 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/diamond_skull_1?q=I12527492" class="soliloquy-link" title="Diamond Skull" target="_blank"><img id="soliloquy-image-30352" class="soliloquy-image soliloquy-image-10" src="http://weuponithiphop.info/wp-content/uploads/Diamond-Skull.jpg" alt="Diamond Skull" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-11 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/donuts+doom-A109792920" class="soliloquy-link" title="donunts" target="_blank"><img id="soliloquy-image-30353" class="soliloquy-image soliloquy-image-11" src="http://weuponithiphop.info/wp-content/uploads/donunts.jpg" alt="donunts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-12 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/crime+pays?q=I12067735" class="soliloquy-link" title="Crime Pays" target="_blank"><img id="soliloquy-image-30434" class="soliloquy-image soliloquy-image-12" src="http://weuponithiphop.info/wp-content/uploads/Crime-Pays.jpg" alt="Crime Pays" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-13 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/fuckyoupayme?q=I11550361" class="soliloquy-link" title="Fuck You Pay Me" target="_blank"><img id="soliloquy-image-30436" class="soliloquy-image soliloquy-image-13" src="http://weuponithiphop.info/wp-content/uploads/Fuck-You-Pay-Me.jpg" alt="Fuck You Pay Me" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-14 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814011" class="soliloquy-link" title="savage gold tee" target="_blank"><img id="soliloquy-image-30354" class="soliloquy-image soliloquy-image-14" src="http://weuponithiphop.info/wp-content/uploads/savage-gold-tee.jpg" alt="savage gold tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-15 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/?page=2" class="soliloquy-link" title="fresh-clean-signature-" target="_blank"><img id="soliloquy-image-30437" class="soliloquy-image soliloquy-image-15" src="http://weuponithiphop.info/wp-content/uploads/fresh-clean-signature-.jpg" alt="fresh-clean-signature-" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-16 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/%24teez?q=I1001415610" class="soliloquy-link" title="gold fronts" target="_blank"><img id="soliloquy-image-30355" class="soliloquy-image soliloquy-image-16" src="http://weuponithiphop.info/wp-content/uploads/gold-fronts.jpg" alt="gold fronts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-17 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/soldier?q=I11611241" class="soliloquy-link" title="Swag Soldier" target="_blank"><img id="soliloquy-image-30435" class="soliloquy-image soliloquy-image-17" src="http://weuponithiphop.info/wp-content/uploads/Swag-Soldier.jpg" alt="Swag Soldier" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-18 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/gamer-A7923028?productType=210&#038;appearance=22" class="soliloquy-link" title="gamer" target="_blank"><img id="soliloquy-image-30438" class="soliloquy-image soliloquy-image-18" src="http://weuponithiphop.info/wp-content/uploads/gamer.jpg" alt="gamer" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-19 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/" class="soliloquy-link" title="freshandlogo Square" target="_blank"><img id="soliloquy-image-30356" class="soliloquy-image soliloquy-image-19" src="http://weuponithiphop.info/wp-content/uploads/freshandlogo-Square.jpg" alt="freshandlogo Square" /></a></li></ul></div><noscript><style type="text/css">#soliloquy-container-30342{opacity:1}</style></noscript>
</div>
		</aside>                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</article> <!-- /.post -->


<!-- Instagram -->



<!-- Footer -->
<div class="td-footer-wrapper td-footer-template-3">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
			    		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span4">
                <div class="td-footer-info"><div class="footer-logo-wrap"><a href="http://weuponithiphop.info/"><img class="td-retina-data" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" alt="" title=""/></a></div><div class="footer-text-wrap"></div><div class="footer-social-wrap td-social-style-2">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div></div>            </div>

            <div class="td-pb-span4">
                <aside class="widget widget_calendar"><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar">
	<caption>March 2020</caption>
	<thead>
	<tr>
		<th scope="col" title="Sunday">S</th>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
	</tr>
	</thead>

	<tfoot>
	<tr>
		<td colspan="3" id="prev"><a href="http://weuponithiphop.info/2020/02/">&laquo; Feb</a></td>
		<td class="pad">&nbsp;</td>
		<td colspan="3" id="next" class="pad">&nbsp;</td>
	</tr>
	</tfoot>

	<tbody>
	<tr><td><a href="http://weuponithiphop.info/2020/03/01/" aria-label="Posts published on March 1, 2020">1</a></td><td><a href="http://weuponithiphop.info/2020/03/02/" aria-label="Posts published on March 2, 2020">2</a></td><td><a href="http://weuponithiphop.info/2020/03/03/" aria-label="Posts published on March 3, 2020">3</a></td><td><a href="http://weuponithiphop.info/2020/03/04/" aria-label="Posts published on March 4, 2020">4</a></td><td><a href="http://weuponithiphop.info/2020/03/05/" aria-label="Posts published on March 5, 2020">5</a></td><td><a href="http://weuponithiphop.info/2020/03/06/" aria-label="Posts published on March 6, 2020">6</a></td><td><a href="http://weuponithiphop.info/2020/03/07/" aria-label="Posts published on March 7, 2020">7</a></td>
	</tr>
	<tr>
		<td><a href="http://weuponithiphop.info/2020/03/08/" aria-label="Posts published on March 8, 2020">8</a></td><td><a href="http://weuponithiphop.info/2020/03/09/" aria-label="Posts published on March 9, 2020">9</a></td><td><a href="http://weuponithiphop.info/2020/03/10/" aria-label="Posts published on March 10, 2020">10</a></td><td><a href="http://weuponithiphop.info/2020/03/11/" aria-label="Posts published on March 11, 2020">11</a></td><td><a href="http://weuponithiphop.info/2020/03/12/" aria-label="Posts published on March 12, 2020">12</a></td><td><a href="http://weuponithiphop.info/2020/03/13/" aria-label="Posts published on March 13, 2020">13</a></td><td><a href="http://weuponithiphop.info/2020/03/14/" aria-label="Posts published on March 14, 2020">14</a></td>
	</tr>
	<tr>
		<td><a href="http://weuponithiphop.info/2020/03/15/" aria-label="Posts published on March 15, 2020">15</a></td><td><a href="http://weuponithiphop.info/2020/03/16/" aria-label="Posts published on March 16, 2020">16</a></td><td><a href="http://weuponithiphop.info/2020/03/17/" aria-label="Posts published on March 17, 2020">17</a></td><td><a href="http://weuponithiphop.info/2020/03/18/" aria-label="Posts published on March 18, 2020">18</a></td><td><a href="http://weuponithiphop.info/2020/03/19/" aria-label="Posts published on March 19, 2020">19</a></td><td><a href="http://weuponithiphop.info/2020/03/20/" aria-label="Posts published on March 20, 2020">20</a></td><td><a href="http://weuponithiphop.info/2020/03/21/" aria-label="Posts published on March 21, 2020">21</a></td>
	</tr>
	<tr>
		<td><a href="http://weuponithiphop.info/2020/03/22/" aria-label="Posts published on March 22, 2020">22</a></td><td><a href="http://weuponithiphop.info/2020/03/23/" aria-label="Posts published on March 23, 2020">23</a></td><td><a href="http://weuponithiphop.info/2020/03/24/" aria-label="Posts published on March 24, 2020">24</a></td><td><a href="http://weuponithiphop.info/2020/03/25/" aria-label="Posts published on March 25, 2020">25</a></td><td id="today"><a href="http://weuponithiphop.info/2020/03/26/" aria-label="Posts published on March 26, 2020">26</a></td><td>27</td><td>28</td>
	</tr>
	<tr>
		<td>29</td><td>30</td><td>31</td>
		<td class="pad" colspan="4">&nbsp;</td>
	</tr>
	</tbody>
	</table></div></aside>            </div>

            <div class="td-pb-span4">
                <aside class="widget widget_text">			<div class="textwidget"><div aria-live="polite" id="soliloquy-container-30342" class="soliloquy-container soliloquy-transition-fade  soliloquy-theme-classic" style="max-width:960px;max-height:300px;"><ul id="soliloquy-30342" class="soliloquy-slider soliloquy-slides soliloquy-wrap soliloquy-clear"><li aria-hidden="true" class="soliloquy-item soliloquy-item-1 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109673710?productType=812&#038;appearance=1" class="soliloquy-link" title="Revolt Tee" target="_blank"><img id="soliloquy-image-30349" class="soliloquy-image soliloquy-image-1" src="http://weuponithiphop.info/wp-content/uploads/Revolt-Tee.jpg" alt="Revolt Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-2 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/youngongetthiswork?q=I12154011" class="soliloquy-link" title="You Gon Get This Work" target="_blank"><img id="soliloquy-image-30344" class="soliloquy-image soliloquy-image-2" src="http://weuponithiphop.info/wp-content/uploads/You-Gon-Get-This-Work.jpg" alt="You Gon Get This Work" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-3 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/savage+bloody?q=I1014473415" class="soliloquy-link" title="Savage Bloody" target="_blank"><img id="soliloquy-image-30343" class="soliloquy-image soliloquy-image-3" src="http://weuponithiphop.info/wp-content/uploads/Savage-Bloody.jpg" alt="Savage Bloody" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-4 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/can?q=I1011767996" class="soliloquy-link" title="spray" target="_blank"><img id="soliloquy-image-30345" class="soliloquy-image soliloquy-image-4" src="http://weuponithiphop.info/wp-content/uploads/spray.jpg" alt="spray" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-5 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814012" class="soliloquy-link" title="Good Vibes Only 1" target="_blank"><img id="soliloquy-image-30346" class="soliloquy-image soliloquy-image-5" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-1.jpg" alt="Good Vibes Only 1" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-6 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/blessed?q=I12044252" class="soliloquy-link" title="Blessed Tee" target="_blank"><img id="soliloquy-image-30347" class="soliloquy-image soliloquy-image-6" src="http://weuponithiphop.info/wp-content/uploads/Blessed-Tee.jpg" alt="Blessed Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-7 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/trap?q=I1009984243" class="soliloquy-link" title="Trap Tee" target="_blank"><img id="soliloquy-image-30348" class="soliloquy-image soliloquy-image-7" src="http://weuponithiphop.info/wp-content/uploads/Trap-Tee.jpg" alt="Trap Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-8 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/good+vibes+only+birds?q=I1014476779" class="soliloquy-link" title="Good Vibes Only 2" target="_blank"><img id="soliloquy-image-30350" class="soliloquy-image soliloquy-image-8" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-2.jpg" alt="Good Vibes Only 2" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-9 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/all+seeing+eye?q=I11739019" class="soliloquy-link" title="ILLuminati" target="_blank"><img id="soliloquy-image-30351" class="soliloquy-image soliloquy-image-9" src="http://weuponithiphop.info/wp-content/uploads/ILLuminati.jpg" alt="ILLuminati" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-10 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/diamond_skull_1?q=I12527492" class="soliloquy-link" title="Diamond Skull" target="_blank"><img id="soliloquy-image-30352" class="soliloquy-image soliloquy-image-10" src="http://weuponithiphop.info/wp-content/uploads/Diamond-Skull.jpg" alt="Diamond Skull" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-11 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/donuts+doom-A109792920" class="soliloquy-link" title="donunts" target="_blank"><img id="soliloquy-image-30353" class="soliloquy-image soliloquy-image-11" src="http://weuponithiphop.info/wp-content/uploads/donunts.jpg" alt="donunts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-12 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/crime+pays?q=I12067735" class="soliloquy-link" title="Crime Pays" target="_blank"><img id="soliloquy-image-30434" class="soliloquy-image soliloquy-image-12" src="http://weuponithiphop.info/wp-content/uploads/Crime-Pays.jpg" alt="Crime Pays" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-13 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/fuckyoupayme?q=I11550361" class="soliloquy-link" title="Fuck You Pay Me" target="_blank"><img id="soliloquy-image-30436" class="soliloquy-image soliloquy-image-13" src="http://weuponithiphop.info/wp-content/uploads/Fuck-You-Pay-Me.jpg" alt="Fuck You Pay Me" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-14 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814011" class="soliloquy-link" title="savage gold tee" target="_blank"><img id="soliloquy-image-30354" class="soliloquy-image soliloquy-image-14" src="http://weuponithiphop.info/wp-content/uploads/savage-gold-tee.jpg" alt="savage gold tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-15 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/?page=2" class="soliloquy-link" title="fresh-clean-signature-" target="_blank"><img id="soliloquy-image-30437" class="soliloquy-image soliloquy-image-15" src="http://weuponithiphop.info/wp-content/uploads/fresh-clean-signature-.jpg" alt="fresh-clean-signature-" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-16 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/%24teez?q=I1001415610" class="soliloquy-link" title="gold fronts" target="_blank"><img id="soliloquy-image-30355" class="soliloquy-image soliloquy-image-16" src="http://weuponithiphop.info/wp-content/uploads/gold-fronts.jpg" alt="gold fronts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-17 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/soldier?q=I11611241" class="soliloquy-link" title="Swag Soldier" target="_blank"><img id="soliloquy-image-30435" class="soliloquy-image soliloquy-image-17" src="http://weuponithiphop.info/wp-content/uploads/Swag-Soldier.jpg" alt="Swag Soldier" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-18 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/gamer-A7923028?productType=210&#038;appearance=22" class="soliloquy-link" title="gamer" target="_blank"><img id="soliloquy-image-30438" class="soliloquy-image soliloquy-image-18" src="http://weuponithiphop.info/wp-content/uploads/gamer.jpg" alt="gamer" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-19 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/" class="soliloquy-link" title="freshandlogo Square" target="_blank"><img id="soliloquy-image-30356" class="soliloquy-image soliloquy-image-19" src="http://weuponithiphop.info/wp-content/uploads/freshandlogo-Square.jpg" alt="freshandlogo Square" /></a></li></ul></div><noscript><style type="text/css">#soliloquy-container-30342{opacity:1}</style></noscript>
</div>
		</aside>            </div>
        </div>
    </div>
</div>

<!-- Sub Footer -->
    <div class="td-sub-footer-container">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span7 td-sub-footer-menu">
                        <div class="menu-top-menu-container"><ul id="menu-top-menu-2" class="td-subfooter-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-first td-menu-item td-mega-menu menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_20_5e7d6c3fa09a1_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_20_5e7d6c3fa09a1" ><script>var block_td_uid_20_5e7d6c3fa09a1 = new tdBlock();
block_td_uid_20_5e7d6c3fa09a1.id = "td_uid_20_5e7d6c3fa09a1";
block_td_uid_20_5e7d6c3fa09a1.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"43","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_20_5e7d6c3fa09a1_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_20_5e7d6c3fa09a1.td_column_number = "3";
block_td_uid_20_5e7d6c3fa09a1.block_type = "td_block_mega_menu";
block_td_uid_20_5e7d6c3fa09a1.post_count = "5";
block_td_uid_20_5e7d6c3fa09a1.found_posts = "2871";
block_td_uid_20_5e7d6c3fa09a1.header_color = "";
block_td_uid_20_5e7d6c3fa09a1.ajax_pagination_infinite_stop = "";
block_td_uid_20_5e7d6c3fa09a1.max_num_pages = "575";
tdBlocksArray.push(block_td_uid_20_5e7d6c3fa09a1);
</script><div id=td_uid_20_5e7d6c3fa09a1 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/26/new-music-alina-baraz-more-than-enough/" rel="bookmark" title="New Music: Alina Baraz &#8211; More Than Enough"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/j6FZY2kXU7s0G2SF9erAUTvJAkopLb8ottw1Ztq7VO6ZDutBDw4tFc7WHvBnxT6zUR9xlrzem-mQHrpNY9xiWmmXTiiTWnqKbWYk6yZf6IIt_zuXInrn8dHBjQeqRzR-DKWmLQ1-UkTDxNv0E74iDYMCeQn-_Ukr3V1ECn_9a1US0hHxso4WYXnXmM_4HXocbWgugal1PDwnJo8O-Sy_kwMCWDWPa6QNJs5b2wuL1dXHd3My3gqaSY1gqHFh_zjKCVkDqGmzIAoT6jL8WfGbsp6acYgeqv5cVebtg9jtLUrqg9N_ygJa3ftQPXpVH6__kctquCnX6oYEY1j41uzSzt8oCBVBD5Xvu2Wm_52c-mkt1t-6O6U7aIWIZFB8ckrD9iEE6OeY3vBafXDFlgo0sQsiXRkNH7cIDGu4ovSdKWpgraE3hMT_dR7ALvUm0O1wg8KQzFOBQ634p8ZkoKXTw63yoqHdD1kTjKvzMhJgn8dtsC5eyoHFFwpq9Vdfo7u582340QIGa1NwWL7xN48MoI28Aekbe7t-qDhO_k2Qsrv_Ps4uPzKL_czy93Gj984Ro7FzfxF3hqHN-yAGf2Xhdmnls7XUdkCxbQf2rlC6SdKBUUoUTTqhnY8EbACapo1OcfySicPtunDuoymSjUHNtjXTbUi9zLJuBqMjA-wJ1xN0R1uqU6XHpHeS-KGHtQ=w779-h758-no" alt="" title="New Music: Alina Baraz &#8211; More Than Enough"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/26/new-music-alina-baraz-more-than-enough/" rel="bookmark" title="New Music: Alina Baraz &#8211; More Than Enough">New Music: Alina Baraz &#8211; More Than Enough</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/26/new-music-destructo-ft-kevin-gates-yo-gotti-denzel-curry-bandz/" rel="bookmark" title="New Music: Destructo ft. Kevin Gates, Yo Gotti &#038; Denzel Curry &#8211; Bandz"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/wWXmK9Mi3ODR_MnzeljPi_iIN9GvjrM7vjUNfdBsKzH8HNQxwFLaDXD9xzjtU5i8haWBzNWFLWEpiJE8-jVtAEkK8JkLMNEjYn149OIF7bX7stCSXXWB3uWw_MV2CmvftIW0woDDl_A9FLj--fKxhsgvHaJj7vKis08lJL30Mf2nYFdULVet3EI0lVOPstSbJWP-L9GXv8mpXu3eCZkGhw5EHXx1RY6XmusePiBxbU-ApbcNWbKTWGB-IQqBHlJlAA5ghqZVcDL6h8NiSXVEWXwSbvmrSvqD7AvwVnyNipgtnqwPnd9chBUoIhVB23H0Ax0D3DyMh5AuG3N3BrOqYUpjgRLvDiegULpNj5dFtYGOvH3gNtpt1Hnj9nZjU0BeYzkiTImwtJRU4w0j_pXdO2vcyvq0OdJUp0aZtH0KKggi9LjZqYfUuJdEcdwzVEZjbO-nrGu_H_-A46IPe1hfhypNwE8v8bfZ4J9gfx7zDOTLJDUbpyXOOyKFQuGdzzQZ9tKpKVRrKGl661utDQjGbnHm1pQBRJaP9teDQG_GATxhE5gMTzLiJzthJw_i7CkQtkH2fL4gJEGKLYqJT997dV1RXDXYLiRP9QjWsG4IZ-XP6VLp_1CA6glXsVdQNNu8L5_Kz6OdvUjkOpfHu-TGeljgMFe9cp4SSIzB6g1tNvx-w_yrIt6lcm2tXRWqnw=w750-h758-no" alt="" title="New Music: Destructo ft. Kevin Gates, Yo Gotti &#038; Denzel Curry &#8211; Bandz"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/26/new-music-destructo-ft-kevin-gates-yo-gotti-denzel-curry-bandz/" rel="bookmark" title="New Music: Destructo ft. Kevin Gates, Yo Gotti &#038; Denzel Curry &#8211; Bandz">New Music: Destructo ft. Kevin Gates, Yo Gotti &#038; Denzel Curry&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/26/new-music-marlon-craft-ft-kota-the-friend-moms-whiskey/" rel="bookmark" title="New Music: Marlon Craft ft. Kota the Friend &#8211; Mom’s Whiskey"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/KlBJhollqGWaimmQSP7Zym42ZJJleWcdVSPXzChreFC8wDs-uPCVG3DKNWOPwOVxqmDQNNALonMBWWnO-PuK7AYEcI2-NYvs7RYJi_TscAF04CPVtGPmrHI4JcFyRESP6zBVB87wsnzz53kiSrScGN2RrDMF7CbsuImDngWTFwYzNzUXN6fbKuutdje_8X0JUg5_M8jGFXdA2tm8_CM2dw6D4R3qbglpXOl-IApooMEL4vSUwPETGN4kSK4aMQFi6ca_Rumz3xY6DnSyMF6EUZYK9AV3FRF1Mbt4mqX3AGiCC2kb1fJmB_nnllLFdGuAtb8XGwE5kQ0tuvUtK6IGvUTuswGIb3XaLErCD8eyDoSbZqFLg6q1Pj5S1l5paS-NTYnmdhmGAD6-eaGKZsvsuDJS5fT9qZl1IZsTjUx3uBcI1mBDpZk0k73Upt8O1BYHxHdQ1OuUKalMfib_codY9jOWlfxHVeqsVFzT50gijW6erN_6g01wlJRVbJPY8JOwTZBFXCf4YEsEBZb0wiDWUge55j2B1tAipTqikgpx_kJK91bs--xScmAwjuAytexC_1MGhO09Z0Kb0Ef-nEJEkYGTyQM2nEzWB_yG7XXyF63-LmHW2iSoAjKgnu1wo4aVTqOK8OgtQZBYGwh3DJvwsvI2YVu7N3YHJNSj7fWonTEaWOUcyV9tVLGgltOcqA=w1080-h607-no" alt="" title="New Music: Marlon Craft ft. Kota the Friend &#8211; Mom’s Whiskey"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/26/new-music-marlon-craft-ft-kota-the-friend-moms-whiskey/" rel="bookmark" title="New Music: Marlon Craft ft. Kota the Friend &#8211; Mom’s Whiskey">New Music: Marlon Craft ft. Kota the Friend &#8211; Mom’s Whiskey</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/26/new-music-trav-ft-tory-lanez-you-choose/" rel="bookmark" title="New Music: Trav Ft. Tory Lanez &#8211; You Choose"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/b1xZwsShjFhLRaVTzEOe55WVPNAmYZu-A-PSiX0z9i9s8eWjR19hpJjn3DqAoQwkWoT_ncmHoA1StvpwxQDYLxSv2dVoyXmdVvOZvY_ivw38prFesZJ4bU8z2iAoso8EA9mqfp_FZeZo6OH1rm3-wEysZw31ciFC5z4n4FDeiFUUBLCobMqgO22vgjLxpqxcPtmWiE8dCzDnMOiqs8ZtDbfX6OkcnOt30R6t4nF6KGf-FODrQUHPGSc1fgstD_ciwd7OrjeVa9CPRBtoCg7tbtWzoZVq_JAFoHvXGd7thj5pTpxGuxh7QLGA7m3phhwcBWndG8k-trnBTLxUb-ayizRQKGJxiSicvLhRoMPXJOlLiNIbQWivHALX9oCXCpY328T86F5WFnfkCPOArJHWoYsAOgy2QyK0sx_SMyR9YMWbomdLJ4XwUKWG-pFccJNtZD1oQlc_rvhsDUGqxtqG5aSHhinmDV2BW6mvzaCT1sVRxKMttCgFUbtXSRKmC03T9ED5gKdD4e3EwFsLuSF629QXbanDMIYA4CP86rQ9OnwyPdQNY4Be9WHUGVmSbSiSWyNE--XV7YlxK7LMu7r6WzD_RmexvvScj3sCdD5vi6psvbod81bb919qCO-BpJPbw2TG6nVvV96O3jyji5tj09w18159b25RDrtDI8-lYtABqE9sXGL-EveVf0vfmg=w760-h758-no" alt="" title="New Music: Trav Ft. Tory Lanez &#8211; You Choose"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/26/new-music-trav-ft-tory-lanez-you-choose/" rel="bookmark" title="New Music: Trav Ft. Tory Lanez &#8211; You Choose">New Music: Trav Ft. Tory Lanez &#8211; You Choose</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/25/music-video-ybn-nahmir-ft-g-eazy-offset-2-seater/" rel="bookmark" title="Music Video: YBN Nahmir ft. G-Eazy &#038; Offset &#8211; 2 Seater"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/yOzamruDO2rEDn5CyA6Z9SIeCWLXxCRhXrZbVVoF_WIqoZgs7jcBH-eXIbGHnal7XuXCJ8nEGKurtPAkDOwzsC0heNa082dsQLHyesdOdaDS1g9p5xbPFv6t8gz9bXEb0miJVjrQztA4CGwupuef-EDu1aMlGBGq3_u7_XqbZmMhqpwufvghJhsR2S-DntdhDwt8b4boMJfhUnfZ3BrdygqCcTp7jWOv2j_ljvy3NAVmiNu3KDzu27dLIYnFyDZloMA8guRwmrLpXHTSRAWJ2BOoRN1yjj1wMtEMWMQSf9AAGBXWZ_zh55_NqMUsvz06DtCl_UepZ6KClc-2ga06WDyjJxoriHUvCo-oMbMT6voSYXyTs-0QDUZX-Z3Yb9QjUOCeTQNY7cWERfl4HWZ7h4-KoiFx544eO5bglzvqvgIp24EKNCwIAbnqFfEB-zE4k69aqsvwpSUyn8Gj3iq7ne7RFoK5qSFzBr7k_zdSaC1TC-TO2Oa5dzkDtViiqhQyiHgx5aCpcxus1-cpv5kiOx8V-zXjCHCOYt8kE-qwfnFmv6uoewiV9M0Md1zgEtBWb6dO71x7VsbIB--iyMjoViqHLoYmb-dkv1vH0mxKvQWHv-lb8LvZpnRrSyHTaNNy40HHrByPvAykv15lLrX97FqoKMK-5TlB3qmlIkN_JbgJYhdpjvt1TfI8Man7eA=w1078-h684-no" alt="" title="Music Video: YBN Nahmir ft. G-Eazy &#038; Offset &#8211; 2 Seater"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/25/music-video-ybn-nahmir-ft-g-eazy-offset-2-seater/" rel="bookmark" title="Music Video: YBN Nahmir ft. G-Eazy &#038; Offset &#8211; 2 Seater">Music Video: YBN Nahmir ft. G-Eazy &#038; Offset &#8211; 2 Seater</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_20_5e7d6c3fa09a1" data-td_block_id="td_uid_20_5e7d6c3fa09a1"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_20_5e7d6c3fa09a1" data-td_block_id="td_uid_20_5e7d6c3fa09a1"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_21_5e7d6c3fa3a36_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_21_5e7d6c3fa3a36" ><script>var block_td_uid_21_5e7d6c3fa3a36 = new tdBlock();
block_td_uid_21_5e7d6c3fa3a36.id = "td_uid_21_5e7d6c3fa3a36";
block_td_uid_21_5e7d6c3fa3a36.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"97","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_21_5e7d6c3fa3a36_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_21_5e7d6c3fa3a36.td_column_number = "3";
block_td_uid_21_5e7d6c3fa3a36.block_type = "td_block_mega_menu";
block_td_uid_21_5e7d6c3fa3a36.post_count = "5";
block_td_uid_21_5e7d6c3fa3a36.found_posts = "1008";
block_td_uid_21_5e7d6c3fa3a36.header_color = "";
block_td_uid_21_5e7d6c3fa3a36.ajax_pagination_infinite_stop = "";
block_td_uid_21_5e7d6c3fa3a36.max_num_pages = "202";
tdBlocksArray.push(block_td_uid_21_5e7d6c3fa3a36);
</script><div id=td_uid_21_5e7d6c3fa3a36 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/22/album-stream-childish-gambino-3-15-20/" rel="bookmark" title="Album Stream: Childish Gambino &#8211; 3.15.20"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/cyzUf4VFFDVizn4QL0AmFV9MCnvKGUY5UDXcORky0ah78vWR8GaYgEQK6-c7-1yoPCGVcpYNqddqWUlGWYtxxmyz8b0daaLB7KjrePZsH_-DXsiMlGj7be2xs6dgS7wvzM_7bV10gDxdDFNe5kSATF4WgZfvb4Gl4AUhP9Co6mREgpvIKdfJ9WV7Brcsz4s-r5zdJuel-HD3VMB6YDZzoRM6DRJrzpVpEHodjYTLh0Je7KYc1IRfPsOUGwjQ16dgkvLGDkIsJco-YW28U7a2araFh5k07JH05-OiKBKeFDeaTRE5T4h29QqeKmWIvsv2-WRe-lNK6DnceDuhCo3bt1hSkuJSCituu2T-g9Zl6jlHBISjXIkehxKeR84xup7IvZKtXkhFYy5UGbVkcRY_QpJtHfTc5HWH_foG2ppu1qqcY6A4P-H5Ad3ZeuwPQ9a_kb-hw3lf9D65cOZprDA4oLqAOET2zsw6Ey0r19y0o3iMddc1UgvEgY7dumIxMEOXfpT4qTUZG5gjQe49eKOIf8j3st6utPXnpCEXOZh3fB3i-NB6dDbsBkLu4pE1TqPXK1ZV-aak-XQofioZMGLDvFBMBCOhidbd2yzrt2mc20c36YkpqRUO2MK5DFQ1iXraZneuOxjmt4T6K7KuKgI6312qWrXQ7LI-oVvQxCFOHgmbpMHn_CmvwNF-LUD3V3I=s600-no" alt="" title="Album Stream: Childish Gambino &#8211; 3.15.20"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/22/album-stream-childish-gambino-3-15-20/" rel="bookmark" title="Album Stream: Childish Gambino &#8211; 3.15.20">Album Stream: Childish Gambino &#8211; 3.15.20</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/22/album-stream-estee-nack-superior-baladas/" rel="bookmark" title="Album Stream: Estee Nack &#038; Superior &#8211; BALADAS"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/F5bQLxzmteTWgGRPq4lTBB2cwZ5VcI6mnLE9W_4XQZGESh3X41egleYCVK6qlt7bELppkiaCVmUyPfxPUCmdGfABd7z5YtZ-YpDxKNF8iGnHgamQeP37nGGDuXP_omI4fcwxro4zw3ohbiubWjoEzfiq3X16J9STsKeaKoROd3JSHm0OKFQ_3qb0vFtrhbbO6m6JpD8nXU-Ihx2ER8yiLvyn_sNd9LIlQFC-guRQBYzvbktKtjuRDWApE5slkBnJGmuVXUupfa9rt-Y8q0FPiM9IqNZa45Yt1GtLnbXnvlFbn4DBCY-K-R3VjCFNEkH7MH9OwiUcbZ4PbAksTFWE1YZxWUeGG2TUawPqUx5Gq0s1hhDxAnigTwxQmxaUfxi6KvxdITz2hX4lAZK-MiwwKm5Rd02LC_wRPSy5wgla_q8DjWXxNM458qgsjEExjzgzs5yIlVTOxeE8CPhLWrmW-BRvFocXzrublhbV4radI11kRLBre5r1BchObFGr-OiDCtNzqKpHnIcp6b3lOx0JFIfOTag2KBuuQXobDexZfNU8f52pVqRSg75Mnf-t_pZzjg-eWIzWSX7bMe6nhqwqNU26yiiAftQiOnoOww40yysRRml_aLHJUUEiq_qnn2Pzpod0Rkv3DXTdpuIRAARmXie-MGDuFT9TH7KG80xlwjHC8EMmKASbUNRWATpOp38=s758-no" alt="" title="Album Stream: Estee Nack &#038; Superior &#8211; BALADAS"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/22/album-stream-estee-nack-superior-baladas/" rel="bookmark" title="Album Stream: Estee Nack &#038; Superior &#8211; BALADAS">Album Stream: Estee Nack &#038; Superior &#8211; BALADAS</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/20/album-stream-fred-the-godson-payback/" rel="bookmark" title="Album Stream: Fred the Godson &#8211; Payback"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/7-3RJAMItkIJ39x5kihg56UJ_Byt8OAr9Dntx6AHJyMOsPgSdRXcdaFw0O5A0a-VhEMr5V6sXif2uQttLgtfb2VzG18_Js4_r211MJLcYSy1om_Yzd0mBU44fVBFeZBwy0LYCf2IFFaF9n_0uoiRmQcE8_x_g4SKVWSOxQ_P-UhR_o9YV0pGZFsgZr1rkbsPf5hW70AMgXiDR9fYDs0KxKmDMBagLmANeOcW9v52or79vR_DIkhFGg8U4o0206mc1USgt52z3ipkU2nyl1b6vfFnneESY4bb0PA9gpRio4bQoTEIgBbZ_ChhWmfQNEs5aIuIWfUfyA5OXDjRI_qxb6t8_FCd0s7y2gwbb5j91Qm0Y8Eh1TpM--kU7AIrWXqMT5TEfk9zDmJmFDpuvT16YRNKb52zUn6XmmJCrq5hDRb7a1KSVGwtpkn8rn5WVqTulkBxHn4J8Uwr6V0M1nr4utXshVyoK1znuCqRn-OdYmFc-je08ULV-nhiaZXEsGcd4V8U0oqzgsyP6yHbyZoWiOEYzJtAbBzKd7PQScsLBK5o7YyP4Qz56ZDu8toCcKSKCiz5ct7Oq0asVZlHUU1Ez_tYiUlbQlDG37h0Mc_giUJ-lFE3OrtWVKuGUGm0JqM-mLsk-TWwum9cQhpD4lK37N_k3fY4UQjLv55_L1DxH4U_OZTxwHUGwJKxovNEVHs=s500-no" alt="" title="Album Stream: Fred the Godson &#8211; Payback"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/20/album-stream-fred-the-godson-payback/" rel="bookmark" title="Album Stream: Fred the Godson &#8211; Payback">Album Stream: Fred the Godson &#8211; Payback</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/20/album-stream-adrian-younge-ali-shaheed-muhammad-jazz-is-dead-001/" rel="bookmark" title="Album Stream: Adrian Younge &#038; Ali Shaheed Muhammad &#8211; Jazz Is Dead 001"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/WuqXivhsNjH6cKUxdJWwHG8TOsuZ8AGFSjk9N7IJPC5MBVvmM4QAbwCq48Tu2Sqg8X8vUxbIKI89ESL2rkQM9gTnexTxG31dJbZHSHmZBnYpnkTvim4wQg3zRt-u96MV2Hj4hVYF8peMyIXUMpkgvpC9dK7U5qONNCW85kxbWxjQJ-DmeXe0f2rRg5ACXKmNcH6nQnF8YMDWaQlvT3nlc1EjXuXOK0gY9MO_wMKh5X_b76xzKdC75zbWpwG9HBPPf9boWSMXWASQFg4QPOvKBWZeYol737U2ELmiRCR6XOgUxd8mQ60fL4EmkVfee4tlesH11iEq6c4k0hZ8_oRQI8zJBj3jDRQcoCwfxtVgeN_nrzbRSBxsOva8PXr0ug-viPrcg24Fq0EwoggLarD_gBwFquBTNq1TPvk3U7sKpPEAFrzDPLbyAf86kyiTWfrzEhuzuI153ZFvqHTdYGvAyjp96CLQmWb7RPE9piBdN9dMMi1sXoQ7u987wQED2h0cYb0A9hsKK-D97gSXcvG5n67Yf0qLkM7lqkDxrMN3L2IC8ox60Kp6TABIAekQqxlLe1LwYDLJO3fPl6_zRPzG87kf9YFgdjzndV5xaJ_sRnC5xVKWrDjeoW0Sm_gL45cKGNDrIBdW9PAw1M3u-skWvi9dq25tMurTuvgC5LhaVgWTnkarKRZwKGiVTn4elzw=s500-no" alt="" title="Album Stream: Adrian Younge &#038; Ali Shaheed Muhammad &#8211; Jazz Is Dead 001"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/20/album-stream-adrian-younge-ali-shaheed-muhammad-jazz-is-dead-001/" rel="bookmark" title="Album Stream: Adrian Younge &#038; Ali Shaheed Muhammad &#8211; Jazz Is Dead 001">Album Stream: Adrian Younge &#038; Ali Shaheed Muhammad &#8211; Jazz Is&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/20/album-stream-the-weeknd-after-hours/" rel="bookmark" title="Album Stream: The Weeknd &#8211; After Hours"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/Hc-rzm_SIYOYbW0I9qFGc44hLRY2g789cTw-eNw-k6WI_AifFEbsn_qz5cR6p9yo-0A6D2MoDO6ZHgVSAHQmPmSEXgE7BK2L-fxwpQI6Au0vFOXX1-HuK6mNh0hiQmxfsWhjJ3LfKzO7estZteBIcrc7F_ojNzegLlekhUv_RK-MFHsWluC-BY0WtjFHzPOHTqVmJVedBTy0z580-V-5lkxDXa_lmNzcFKgI74H7qaeNAoUInf7o0ux-QQl-Tl8GJw4UP24ovX8rxiEvmuVSzi2mHE40pJZJncScHhgozVXC1BFbuZU3x9GRQ0AdV47x0g429b8ZPZQkdwF5p4n_R0lDBG9lcYkNibTDgc2HZ59Ss871AZNJJ79CQLDcEEFUnPOa7qqhSgkftRf6nOSyXDtk6drCV5RbuwjcfCkN-Pky-1IaA86UrE9uJsiCkR2qyj2EkgcUiETmKHJVZbdPfXhpsV7JRgyjc02WcY_N9YRLWntjHAUR3TXMKApwFlzXdoIMiwtH54MCmIPFoanCrn-N3ii1vxFX0Riv2OR6CBsmTw1XrG6rLrmuGTDrpkPuHXiLoJeUYZSlNv2WBHMCcagIS-G21krQOGBUUpo8pvKl6FSs80BtaPeRebBj70ulBHVZ1gHevM_KiL8ipzEJsLU4uAywnWRf2mJ13LzYjBFOc7pd4Flmlx0h6YU1lTo=s328-no" alt="" title="Album Stream: The Weeknd &#8211; After Hours"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/20/album-stream-the-weeknd-after-hours/" rel="bookmark" title="Album Stream: The Weeknd &#8211; After Hours">Album Stream: The Weeknd &#8211; After Hours</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_21_5e7d6c3fa3a36" data-td_block_id="td_uid_21_5e7d6c3fa3a36"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_21_5e7d6c3fa3a36" data-td_block_id="td_uid_21_5e7d6c3fa3a36"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_22_5e7d6c3fa728c_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_22_5e7d6c3fa728c" ><script>var block_td_uid_22_5e7d6c3fa728c = new tdBlock();
block_td_uid_22_5e7d6c3fa728c.id = "td_uid_22_5e7d6c3fa728c";
block_td_uid_22_5e7d6c3fa728c.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_22_5e7d6c3fa728c_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_22_5e7d6c3fa728c.td_column_number = "3";
block_td_uid_22_5e7d6c3fa728c.block_type = "td_block_mega_menu";
block_td_uid_22_5e7d6c3fa728c.post_count = "5";
block_td_uid_22_5e7d6c3fa728c.found_posts = "2812";
block_td_uid_22_5e7d6c3fa728c.header_color = "";
block_td_uid_22_5e7d6c3fa728c.ajax_pagination_infinite_stop = "";
block_td_uid_22_5e7d6c3fa728c.max_num_pages = "563";
tdBlocksArray.push(block_td_uid_22_5e7d6c3fa728c);
</script><div id=td_uid_22_5e7d6c3fa728c class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/26/music-video-casanova-ft-jeremih-woah/" rel="bookmark" title="Music Video: Casanova ft. Jeremih &#8211; Woah"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/kAp1pL4xIM6ztUUXVMzQP0tWI-cCmLiDZIDn14i9kn_CsLsR2D9Rd_AM0XTOmVbgE1-Uf6zC9YAVBCM4TqEnzyDWW5AvQLDWPtkagjZn1zyo0nLDO49fDjBOr2I8dqr73EmycTm7pcP74Ck0sgMdA4Nsu6-l3lls7Vw2LQAyKr-iBrSmoywzCMW7F64M5T0fxD_9O6vYVhnG3SFBXSzWPKWXPKaK8cxVTeeDZ8zFY-BGKD5wmtjmoMG9hMYJWpYr7pT3B9-453LvS5GHXLytr7HpXx3coEttnK7eI5ginYVDOAAxiG_YKLqw_2_TzzRF8gx8458oW3bHN6v43n3HYCYvGMzgprAA1xM_IIVIHKA3G-Ecftsu_bt3MyUNhVhRMLuuLCCehXSFZEqF6-ZUlE0KUXTQ7kq1x-gEivPWlOYsCGT5-E4F5_tmtl3m4lcDIhzQNnRQLVw3hZbWa81U08Z37yLImCWY8hpD8uZjm9vwtr9SkLWNy00IaB07FsMYSjj1u57bigGvaxkTuzwfVch9y2he49vAokNsx1xZ4-X_cvVi-iQZ1ld_CfcOeSnem3ReCHIe9DX7CSYt8hgCW1gxvPq797Ewp35XHZIed8FoAxKHMPDETPBYVVljIZ5vlHbjRziMEDQJHldGX7Fa77b3F4wAQqj7AVL05BdVfuO8JKNnbIEq8OsMT4MaqA=w1078-h618-no" alt="" title="Music Video: Casanova ft. Jeremih &#8211; Woah"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/26/music-video-casanova-ft-jeremih-woah/" rel="bookmark" title="Music Video: Casanova ft. Jeremih &#8211; Woah">Music Video: Casanova ft. Jeremih &#8211; Woah</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/26/music-video-sir-you-cant-save-me/" rel="bookmark" title="Music Video: SiR &#8211; You Can’t Save Me"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/3mkXRPfbRK8GRUZC5-T83L9CHy99C894CtB0XnaA-gJxmUTJaI3B2tEmLJhIK3_GAMbnmEefgy4c5u4_d1Bve6iiOJaPkFWODryVFLH00nojr3wqibSU_FRprygFEkbic82NuP5opS4CwYpcqli-8e-RUh98-hssiuGZVROl5GLKqhJLalbUs4urRG2dQwn3AiossKXgKG4Ryf2xyjzxCl-kH-TJFf39UcCv7VJtw0TIUvLmL9h7U8YpUujm65YYdBYZL-4cp4w-tbQOE8jIDEAm7m4XAunIX8U9cfACCr0HZdScTcS4Q65-XzlgY5Sau3AsYTkj4IjUoyJf3JOEyZ6P89-_m2LCRybs6Hb8H6eMG8tCyZQlLoTtKo0_XJRVYUHftw8J9ivFfuB6rMl5hl5QWYOr2IZK-18HX0c5SX_uRj56CQ8hmYaT4is_aPek_IZ0li1upm_84N5yfV9CCDQ_r0Qc5eoQ3LmO6ViMUW0lf2CamLxIzXiDfhsRm4qT-MqiNgkylpZApxQK763WpUBuRvwLQ48vMj_0l8I0J0mnkuawd-OHowpg2o1mlIsA4uhjQYfDQWhcXV7vKKrqQPp7ct0tzDOejZ8lW_KD_YXZXaaiik4aLWT16-kp1KPlkkGvqZwLaKY7CDUO0G9Bbdd9hZyyzhEBxWaL72uiB4vZ5MYlQjRlkhr5JI9WPg=w1078-h527-no" alt="" title="Music Video: SiR &#8211; You Can’t Save Me"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/26/music-video-sir-you-cant-save-me/" rel="bookmark" title="Music Video: SiR &#8211; You Can’t Save Me">Music Video: SiR &#8211; You Can’t Save Me</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/26/music-video-wiz-khalifa-tyga-contact/" rel="bookmark" title="Music Video: Wiz Khalifa &#038; Tyga &#8211; Contact"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/LNpxoiMfRW1W-K0vPyzYu66bi45KlL0Noyyrdh11cE-y5OdI_XldXharb35QOiaZT8iy8GxAxvvNCydbJT0mK8bes2eUUEDrDhPgBMWLxul2v50-wu4MZWAKszpAuZQbo1o25yCw-Hsxb220feld_72VWdvqgfXyylCU5_8z_XQe3ODi3top1NhC8wZKRi3pGAz5ilLNMURghSwSny4mAKmtUyuVgRKGc86Ha--Myrd0vyyvC3fcq2iAwMegtiYjaPKQW5aj3hiw3Y6pLEsqwFnPMmzsp1Szvhww4wdC-KFff6mQcMUMJUes0IZ1huRU5dL78L7tuXGD5yxuTqvHGk2xX1Tv96NlEk-yAwk6DTRHQqP0BKyqYxTMhJoon6RpnzCLU74qAFLxsehoStkNWSXuhnagk0egGtxfozdzPAxk936lT2NpIA41XdH7WiNuzimYc9extD0m7mKggt9iLWdxV6BZZ7ls1nOByTOon36cB0T8DZB1E5deUOH5YafRrAK_YWho5PeGclc7vzh1yxP1d4kx_O69j7-J8lFyWUV0ubQwE5ENQVXbaXsdpH9xv96SXIrYZiBTII0mPQa_P8VRX90Qv2_zOsf8sPxd-6kT8_Q4UV_B1qBE2-ub4xvK6P30VLJqhKOR1oEwtCvypguRLj59y6G765MlDbLeUG0_YYzGoCe6QKyZL5x6xg=w1078-h616-no" alt="" title="Music Video: Wiz Khalifa &#038; Tyga &#8211; Contact"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/26/music-video-wiz-khalifa-tyga-contact/" rel="bookmark" title="Music Video: Wiz Khalifa &#038; Tyga &#8211; Contact">Music Video: Wiz Khalifa &#038; Tyga &#8211; Contact</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/26/music-video-mozzy-ft-blxst-i-aint-perfect/" rel="bookmark" title="Music Video: Mozzy ft. Blxst &#8211; I Ain’t Perfect"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/X0h-0yCk0kXWz3KzdGbWlILVMUSjcL-dRbEDbujdfr4Cn70k9n1kWQHJZf1AVWdjZ2g99yjfq2vfPVLBJdklJ6RZYBIr8iLfZz9hHQN2ffwL6LEVoaKrvodK0aENcYVhaRJ4hd111TZ4se4-lvEWbiVL2rOLrVFIQsww6Le4kpjruvGKi812V2Uq_6M09V0XmeFQAE5UW1rueIuWkNBkaXnzFjhc_X0ir7F1CWtCUi64_VPWFUtWqoXGfMbWKu4KSuG8xlvLLvlEu28CabBksTzX5sjoG2SDtBiXpFkkPVgi1cPUcRTidXPPf_anJRWfa51x1BD53Td-asMoPV8Ejxb_ahEwHnP-HLlmIc5E_0kylbqYuRcVhIErGqE_AHC04B5RCnzXIROzbVtGPmBibY3EOD1yZ8z-cOcEMib2i0yXtaUaM7xRg6SPZPgd8qVUjrt2NHKwTVKnerS6OvbiCFi9yBflcSEGzWbSODfwf1rDctc77J96sT5a8KyTFEdtCE9YIPwYAUapbPMoT_deZ4mb9HTTap-g_m11f5YDe6ZnTRBxtTFqknyqWaOwVEyjvKdMvF8s7RxixKGFem7gh4kSFwPY8rZ-DGpSOn74r26316_sXGXN0IYBqoXp95dPiaG-zTd4ZvsR4APGBMo_FN5iaIg3JBFm5qqEAGNtxg7NINXIJ6zewDBRzlLCjQ=w1078-h615-no" alt="" title="Music Video: Mozzy ft. Blxst &#8211; I Ain’t Perfect"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/26/music-video-mozzy-ft-blxst-i-aint-perfect/" rel="bookmark" title="Music Video: Mozzy ft. Blxst &#8211; I Ain’t Perfect">Music Video: Mozzy ft. Blxst &#8211; I Ain’t Perfect</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/26/music-video-kirko-bangz-no-call-no-clothes/" rel="bookmark" title="Music Video: Kirko Bangz &#8211; No Call/No Clothes"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/cT6J6AIw3NEafRrB_CgwLLsyw56bDjrcyKF-JROvrTwWWuYfVS00YzfhAAHS14vDDwabzNWKAX4b0XZ15hLDQhJlyJMA0YWblkIgg3q9zyFP-c6pZZh1Km0EV5Yt-omPJiy69IAW4P4mHCBELzG8IPbuokb778YvZ4_TTP1x5G-cED9KVbRjPovvQx_ip6bV7P_PxE0C259bi7jC4Rqyki1i6y5l39JvfJscN8ksg5z_tKyZLOZ-1wllgpTn5wE-UQ_RQqNsymUYhk7_4YBrkQHdWi0vL0EOAohw8SX7Qp51pYRu4faPlE67r0zgm6gezBDCZuHPLDiHLCrCcKeINKpDQQ65NYIVrDdCS3IPG1KZ4gmg-b_jecH3shbFlENxVDzBUKjfy-01PrrGGs5XyCM5gO3Jnx1UexT-9dnYc_eodMggR-aScTwAAWipSi4fUoKsSnrkAcWZB8Wcw44QPKepneeAZgeC1JjH0DolXhDzQm338BT2CLUZIYrTz5h6ZO_kYC6QNrejqANpP4paCjvYUqyPz3r3CGQFUbppf88H0PS0gGDZfGcu9bzd0NaLQfOxVhEBTAAOzpD4wuQxhqfC6YW4NATWju2s_KEv03uy7Lf64zbr8X2IHVmeC6rkISS8TmcvMhwzt-s4x_vGfL96GpGLm6uMnPojmR6zu1rpX0Rl-OtveXAopHWoHw=w1078-h711-no" alt="" title="Music Video: Kirko Bangz &#8211; No Call/No Clothes"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/26/music-video-kirko-bangz-no-call-no-clothes/" rel="bookmark" title="Music Video: Kirko Bangz &#8211; No Call/No Clothes">Music Video: Kirko Bangz &#8211; No Call/No Clothes</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_22_5e7d6c3fa728c" data-td_block_id="td_uid_22_5e7d6c3fa728c"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_22_5e7d6c3fa728c" data-td_block_id="td_uid_22_5e7d6c3fa728c"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_23_5e7d6c3faa762_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_23_5e7d6c3faa762" ><script>var block_td_uid_23_5e7d6c3faa762 = new tdBlock();
block_td_uid_23_5e7d6c3faa762.id = "td_uid_23_5e7d6c3faa762";
block_td_uid_23_5e7d6c3faa762.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"29","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_23_5e7d6c3faa762_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_23_5e7d6c3faa762.td_column_number = "3";
block_td_uid_23_5e7d6c3faa762.block_type = "td_block_mega_menu";
block_td_uid_23_5e7d6c3faa762.post_count = "4";
block_td_uid_23_5e7d6c3faa762.found_posts = "990";
block_td_uid_23_5e7d6c3faa762.header_color = "";
block_td_uid_23_5e7d6c3faa762.ajax_pagination_infinite_stop = "";
block_td_uid_23_5e7d6c3faa762.max_num_pages = "248";
tdBlocksArray.push(block_td_uid_23_5e7d6c3faa762);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_23_5e7d6c3faa762" id="td_uid_24_5e7d6c3fab363" data-td_block_id="td_uid_23_5e7d6c3faa762" data-td_filter_value="" href="http://weuponithiphop.info/category/latest-news/">All</a><a class="mega-menu-sub-cat-td_uid_23_5e7d6c3faa762"  id="td_uid_25_5e7d6c3fab44c" data-td_block_id="td_uid_23_5e7d6c3faa762" data-td_filter_value="69" href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a><a class="mega-menu-sub-cat-td_uid_23_5e7d6c3faa762"  id="td_uid_26_5e7d6c3fab574" data-td_block_id="td_uid_23_5e7d6c3faa762" data-td_filter_value="80" href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a><a class="mega-menu-sub-cat-td_uid_23_5e7d6c3faa762"  id="td_uid_27_5e7d6c3fab68b" data-td_block_id="td_uid_23_5e7d6c3faa762" data-td_filter_value="2189" href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a><a class="mega-menu-sub-cat-td_uid_23_5e7d6c3faa762"  id="td_uid_28_5e7d6c3fab79f" data-td_block_id="td_uid_23_5e7d6c3faa762" data-td_filter_value="10" href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a><a class="mega-menu-sub-cat-td_uid_23_5e7d6c3faa762"  id="td_uid_29_5e7d6c3fab880" data-td_block_id="td_uid_23_5e7d6c3faa762" data-td_filter_value="130" href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></div></div><div id=td_uid_23_5e7d6c3faa762 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/26/partynextdoor-partymobile-album-tracklist/" rel="bookmark" title="PARTYNEXTDOOR &#8211; PARTYMOBILE (Album Tracklist)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/ATFbNLolvOrPG1qYbnvMXeYaK5bzGbS1Rwa-R_8maqZDUfuK67vT-OL2sP-wSBwDQmECIG5kD82wrDKA43hqkeQYksadSNB9687tlDbdA4BRXH-6BO78np_iTyAkLQVxh-LReEG1RaFBlqwdXa3SExlpJXhwHHVZAX7K46hmEP49oQlKXPjlxVt4xehKIwQA6bSkal6I9atLw6HFlNt-Adl6fbM5haRWvnjrTc6dpf040DOrsCfGRdRJUcOMV8BFg6KoiaK-dsgWx_T42siw8lE2nXexXOqDtSqDP-7t1zHQqTbM0hPy26DCyiaP-t5bin7s2l9IBo7Rerj2IEZIC0TZ8g1dJLWbB8pME7gfI7MjYfUwTK2TBC2w6S8bAb7oBWUPhU410tsDZRbOCiBDtlDHLMMNMA901J9SiIbfQ7Ct8gS-Y7o9e_jyun5m0HxShEqT57y1JCXeptqPV3BpE40HBpsSdQ2NF2Z-Y-Hcd_JZz0enNkp1X0R4vadT-aYtElPhc7JsoZSReL_QjE5TCEBKv81-wqB59tLRhbEa-D7w9JuPd76fHscFsh5lw1z9BJZ4u9oXY8N7On_07srn7PCOlia7peVzmGUqwTslDrpl0nuIvXgR_dhWA-DvpNFzD3_ORR6BoZw3BuewYJQAhHhnsK3KG-0TeKE8-NoVxANPzmyRCxccgoOIgnHYhg=w753-h759-no" alt="" title="PARTYNEXTDOOR &#8211; PARTYMOBILE (Album Tracklist)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/26/partynextdoor-partymobile-album-tracklist/" rel="bookmark" title="PARTYNEXTDOOR &#8211; PARTYMOBILE (Album Tracklist)">PARTYNEXTDOOR &#8211; PARTYMOBILE (Album Tracklist)</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/25/big-sean-announces-new-album-detroit-2/" rel="bookmark" title="Big Sean Announces New Album, ‘Detroit 2&#8242;"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/6ouC7inMjbjmbHm1a-VjaVylTJycIlC42gxWMiMrru-yaqg6MIubTrufmtRKDtP2IOOh574wJKuJn7wcV9REGI9pYNvzLUF0mVfA7srqp3fR7CiFCYYsyGfiCXf-jyKVNuK_PdckN16c-dJzmBNF10gg3ZGcg_C8iebzyJ2JGlHBVjkGDwmNvHAVUVhPZUdaalBa2g1Wlhmg08sYFcQi91AXZtE-3PRMVe5moGycIAsrvw0DJh64878Vzu6agNq336cVYIvqRPQiYZqsMCZ-bL4onQHMx7kvOcRf5vnSgsuFRUUCOXKf9ZIiunxC5CgNLAdPQii47KQN0NJ2hbAiuvNG2oFlfX3jnmUAaaDvzrB_yPcPhUdyPrNNX6uJ7JD5wHOTVLuCbHROvmnk_sGd29q65beT_ruONSVQhhcJWe0msu1dBVwAmRI-AZkfp6ae6BSYU5_W1o-Z_3pZ6U0ZZ-ItGS9IP_cOw16dcVTvFYAI9ObSM0zz32_-78xMGMMp3mZvRJwnfvJQGQTwK-zfQ-fDdM1UFj6jNuv5qAyhiMuUAEVMi6_CYCDOpFcJJGwfSnVKstw6JPStuQzaatfcpurfeYxd8hldfCVGMhlHUWxOzk1vbzviq4rWqMBwfBKYdEXQ_4d4dhHcEe0OZceXrNtVZJ8-i-FICAaNfyOF9Vw2G8Vl9c3bPG9CGQDcdw=w1078-h612-no" alt="" title="Big Sean Announces New Album, ‘Detroit 2&#8242;"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/25/big-sean-announces-new-album-detroit-2/" rel="bookmark" title="Big Sean Announces New Album, ‘Detroit 2&#8242;">Big Sean Announces New Album, ‘Detroit 2&#8242;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/20/video-eminem-hotboxin-with-mike-tyson/" rel="bookmark" title="Video: Eminem: Hotboxin’ with Mike Tyson"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/ReDIiaf-gVyB4NU6XVIUf-A8eD8A_CSUHBy8F-7SpS0f2sqUluOIOgGCEzxmVHzUW32FCwQAx-wPyoDvqlL2EhOO8nBiBg9-HvDuZhPjFMcsARau6tXdv5ax7Oyimgmy1P34N6RO6_KFWnaZH-ViK397iJ8EmJIzz52kpbDapcL1TSBsITxBKE2Jut-uNU0mjnv7SSMtuLt0PH90wL0zdTUGB-Iaup0stmIbw9-lspUMe1i9V8CLrHLod0G9EahnNHQ5vkX4vjftHjQsva4MlkqZl25pCwM7Sc3MwxIMYAQOG3qKvXI4QJjmj-W1mcM_2mza8w8rsX8vA_ZkYeGDBqoeJIAVsWFBV-8z-m3DwRwIDT2cesTLGd_c5NiSXID04xbPa4Omv2TUuVs79TEc-hcfi1LgUbqfWmupnLQre3WeHITK1f3pic8IQ6iZhbwnVPLwpDrBQQRnOjj2bvBw1MKGD0MrPN4p_R05ifMOYAj99qZIyWBasVozZK0JK3W0ipp4cGv9LqgfwTEeiSbWdFsPTzoxCtxBjRsYe-agYa3Gftg5vNhQpFO9C4kOECcT7vAVC7eUle2SHNJaa7u_gunSgJLqp9Q1Y_xZsEyoRCf5kZyxDhLeN3B8WW46oUqvbdhSdpwt1p7Wepl0iJmc-gW1Elz1_YcWOsG6BS_WjMREIbPhKxR7oMtYvbGF1uw=w700-h385-no" alt="" title="Video: Eminem: Hotboxin’ with Mike Tyson"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/20/video-eminem-hotboxin-with-mike-tyson/" rel="bookmark" title="Video: Eminem: Hotboxin’ with Mike Tyson">Video: Eminem: Hotboxin’ with Mike Tyson</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/19/video-freddie-gibbs-soul-right-cataracts-live-on-vevos-ctrl/" rel="bookmark" title="Video: Freddie Gibbs &#8211; Soul Right / Cataracts (Live On Vevo’s CTRL)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/PD5T6jG6wBLaK0HFwt5JXiyZ4S4WdQUJ2PxIJao2NNY1oHuNaOccSb1ywx_lt_YVUw3vyyKyhha3srL0Pi9zFUS5aO4SGDq2JTkWB_x_QZEosEZa2wW-vL_CxpRUBuvQ6UEeIC48x8abonUixZ5Sld_WlbvQBQoFQkbbOHK4U7mB4k9vQrGrVyU8U9LWEmjm13HRQJtWASOXiC0IADyRYIavD75LiLen4bLN_ILFK9gB_0kgo3lXnnX55nPBpmpVIXs-fdnvR18cYlckTLJLMHRyiRBJ6SEgu33Z-aN5atH_3Sw0yHyYaIzTSdcFn49mAM6um0HzMF9YNOwK5ATZt9L_9Ol9MUsiCUN1lBG7MgJg2AeutArl4BvCNLn11s44RxTK7vs9j1eO13VMB22G8J5uxj9HcRUPxLhinC-LnsEZP7iqvQ5nFeUdGchRyqGtl7nqeH8t7H70GdvOcZ8PtxHw1EtPneDmM7qBxsUTsrOiBzg0p_hTuwsDnYnzD4e5HFpPZhqQ-ZIB8E609nlqfGLQMnsbegP3ScO_df8uDTlZIN0BUgG9hMPGydydIN8o0lOf2_XL3TMzgSl45-5FBspXhHmq7X0EOw7coo60qKFLep4Cc1w5saOrirTzYgAJjpGeN_ZhD9BQOyiBAklzS5mIDl8NY-4KE9Vn7AV03xmUG5NJUVCAOR_D7bUiaEE=w713-h510-no" alt="" title="Video: Freddie Gibbs &#8211; Soul Right / Cataracts (Live On Vevo’s CTRL)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/19/video-freddie-gibbs-soul-right-cataracts-live-on-vevos-ctrl/" rel="bookmark" title="Video: Freddie Gibbs &#8211; Soul Right / Cataracts (Live On Vevo’s CTRL)">Video: Freddie Gibbs &#8211; Soul Right / Cataracts (Live On Vevo’s&#8230;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_23_5e7d6c3faa762" data-td_block_id="td_uid_23_5e7d6c3faa762"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_23_5e7d6c3faa762" data-td_block_id="td_uid_23_5e7d6c3faa762"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_30_5e7d6c3fbe163_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_30_5e7d6c3fbe163" ><script>var block_td_uid_30_5e7d6c3fbe163 = new tdBlock();
block_td_uid_30_5e7d6c3fbe163.id = "td_uid_30_5e7d6c3fbe163";
block_td_uid_30_5e7d6c3fbe163.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"77","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_30_5e7d6c3fbe163_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_30_5e7d6c3fbe163.td_column_number = "3";
block_td_uid_30_5e7d6c3fbe163.block_type = "td_block_mega_menu";
block_td_uid_30_5e7d6c3fbe163.post_count = "4";
block_td_uid_30_5e7d6c3fbe163.found_posts = "158";
block_td_uid_30_5e7d6c3fbe163.header_color = "";
block_td_uid_30_5e7d6c3fbe163.ajax_pagination_infinite_stop = "";
block_td_uid_30_5e7d6c3fbe163.max_num_pages = "40";
tdBlocksArray.push(block_td_uid_30_5e7d6c3fbe163);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_30_5e7d6c3fbe163" id="td_uid_31_5e7d6c3fbed1a" data-td_block_id="td_uid_30_5e7d6c3fbe163" data-td_filter_value="" href="http://weuponithiphop.info/category/fashion/">All</a><a class="mega-menu-sub-cat-td_uid_30_5e7d6c3fbe163"  id="td_uid_32_5e7d6c3fbee0a" data-td_block_id="td_uid_30_5e7d6c3fbe163" data-td_filter_value="76" href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></div></div><div id=td_uid_30_5e7d6c3fbe163 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/LVT4Mid8WL4wHUdO9X2OZmZxxgbREs2lVtszOdEBaO6hJB0JS3yQOAyhNSdCyPmv0amBDTgNGpOlRPXPjKCl6yIlo2joyH3rQRI7CUdX09BJtQI1r5jy1_7BQtDhw4AxUhpUwIh35rNS3lTy7uq-FdPff10JN6srr9mwZ7zr04GQFxBVEXwCfC5rNVehXhY_wGCRVsmevYmdkBWEmB8dvOzBHY78NBBjcHNArS_S-2M0FJgDh8v9m9vEh78k_XmZg-AERctsf0bkODuPi1EcNJq_RnJIV6b0GG-VtKjo-OVPmYghWJYf1HiP9c58cQ98oABU8BDFdLqsBtNt4K0NmyHYQlX39W9k_d83wEHZ1-EacQa2o01VrYSn12HnZ1l88fMzu9PKv6EGmcRZNwpepycW7_9EQnhxIPDdVCmRLXUasUED9OXr-zJmnBcnSnLCa06k1ZymQym1LiSFEv1c3aPHnmnD3GY8nL7q5jPJr4HsABR0WCqMebcF3HF_0deNd0zgRBCGMxW-VzlIIHZiHuBeSPEPvUL149GJ5swSSvKm1uGEi1HlLBj9omJSU7mDWzO0p_7l-l7-4_ureEsGsgB8cX1t8t2TQcFeRgqqF1CXlZFYYC2K0iMb4jPsijsw_rtO7pmKvbngqHfgYpGeh_qLmDWeicR7=w1195-h796-no" alt="" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch">Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/fHEwwMf8DoiXlqkfibQS1Z1XXbviORbV9raaI44tOTXrWo7GgqM3gA-vswE10gFtTQUGGwNG7nWAACwHjxPuiubliYBN_dqtBZh2WIpxvumiJ-hSLK0TNWB2cB8Iw2STT5gcp_KqlDh_e4xng1vidI8EXdp_ooh5uDI-JV1HQ9dGnM5nxl_b-v8znqj-Rl_mGB7y4Lu9zsFNWHU7SriqQQJaKrKEEnb9T8zxmGLaL0zq7ilYpnUEhWulDDr9xc82wdr__WzRBm5YEskVpDAnGM2NDZwTZpjbe4QDdxeixWnSXNK_oDzaL7WTbCpkD33OK88BlI5JmFRQ5VmD11UQ2htB7-9WoahHvb4XmBsbLXpEMl1JmEP4sPx06VduzFnBNo-J90WI0n1AEIIcEYVbRywrkGJXbzmH__In9ZIg0EV24OcGGbeKl12HxTdZwucqsNnuZeNjiMHISQ7i8cfzm3N7X7Zenl74zsKIKeKWoIGxh6MTlVADvgHcrHebnjcSgil2vBeFyz_AP45aOv9SOwbzfVLGS0CNfe1s9b2J7qZgjcBk9QPEXCl2kygvzmGXFvU_3xBuW6S0i3Vkh3Ha_3hPBtvIAy3WoTK2yiqS41HzSK7yk3FRAlBtpIEib338fdkTiosBxtdu36SdNUVM75zl6CVIFhTu=w681-h470-no" alt="" title="Air Jordan 14 Rip Hamilton"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton">Air Jordan 14 Rip Hamilton</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/kUjaOYxjEkAh34S-Ub2QSZwdOwHyFnGFLBZULta3_bn1_myPMAwJXiEEsAAtc1ktCQwHCuKhSqSYsWXFBEIZxdfKuykoDEZWwO-dDI3_JeAshbYvyILEHUu0XaUpRn0mj7gOx10V52t8gRGYPCW7QXGImkPGGhvBPzBDVVqh9lKGtkuPeePmTnpRSmwp0LG1WHcIzUWnMqPBWQeHAat6Q-Tq7niXNb96ddEZsMEdHK1nmHVlNaeqFBNtTxk6yYRkFNCvtfBayqy-Rqt4CPU5tThxbTI4AIUCI6JLxJd_VJizrVNDEe2xZ_tiQdkC5ASIoHpX8sfvAB8zRUsMVJ6oMUt5FH_4GBNXDCtFRmr65Qt0JV1h4bBJffu2L272Q_vpD76wn-YNGW8VCtZcheHu_X-A4gdYQEC0HN0BenY-MOuUBqKEjXAc0SxWeP7W9RN55jlqUFK0nzEYydVjec2stdQIngVfg_FvKxvHXfM4XdtMpqeJnp3Pzyk8xjz30sAZd0f2HQ6zfdPjk-OkV2-WrC0_qW0L8Rq3zrUbq52n3BN7gm7sctU_CUlBmoQIgJDQBYk1Siv4tfSq9pL1R4GdaOlWQdxEuhZi8bTYC8GGAgNGl3SMAZGvk7nu6QnnwEZjZ7mZwbcqgyRKa89cOREMUvIkVJ8Q8lZu=w926-h672-no" alt="" title="Jordan Proto React Triple White"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White">Jordan Proto React Triple White</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4cDUjSODZSaXWfHyZKb9q3Fn7FHA4uB0KSBs0MtFHC0dc6AJb1zeAl_X2LOKalK9C7VBFhTqRQ9fw1ESgUr9ZUKFbOzD94i_s96nvkICOqrsYnzrE2nEAQHoEaGOF4O8GAI6T4CGFbgcQhNzjpRlSY60NyPu5Cmq81FRpEOFRzTOtSa_NnWzMmfwO0yxtPbcg5U6YBUsus8shv3SA7CjULLfaP38nZAuWVgq8PMaaeCQ_eSrK8NJSEVQjyyxmqb-1I7zO8Kvvzvwi--ibMr52CF8h-GusBzSq5ZuzvZRCGu_u8CyfoXw7pwWbOmHnLOdcQ9d2PCSW_IxEMGfmEuU7NxMSsW3Ga4r35_wLB7cjvlPC9OjCV50tfekXjZBS_476mzlf4G9jR7Ju1GqgjXah9Uqc_0Y8N-Br8_JCtIlRSuLxAiebwd7AvFVlgWId9MYxBWnRT3cTyD8SH7q5WwO-CIbKAOSKsNcrrTgFxQvqn9yklBU1u5X5fdTlTBk4WSYorsWZAug0z9BOymRLnrhTbnA0vpBPFROWD-aL1glg-eUpFSfgD4xhWsOqJNY9krQ2UbLSGXQ5gYWj0ovLS7Yz3UKFY2qrVWpqkpbfyN98es9NJ-7LTUs2MLq1rX_2FaQmyq5mVndd7VGzQOHy9hDULG-5H-0LvGd=w900-h566-no" alt="" title="adidas Yeezy Boost 350 V2 Hyperspace"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace">adidas Yeezy Boost 350 V2 Hyperspace</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_30_5e7d6c3fbe163" data-td_block_id="td_uid_30_5e7d6c3fbe163"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_30_5e7d6c3fbe163" data-td_block_id="td_uid_30_5e7d6c3fbe163"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div>                </div>

                <div class="td-pb-span5 td-sub-footer-copy">
                    &copy; 2018 The Hip Hop Chronicles Media Group                </div>
            </div>
        </div>
    </div>
</div><!--close td-outer-wrap-->

	<div id="wpcp-error-message" class="msgmsg-box-wpcp warning-wpcp hideme"><span>error: </span>Not Prohibited. ✌️</div>
	<script>
	var timeout_result;
	function show_wpcp_message(smessage)
	{
		if (smessage !== "")
			{
			var smessage_text = '<span>Alert: </span>'+smessage;
			document.getElementById("wpcp-error-message").innerHTML = smessage_text;
			document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp showme";
			clearTimeout(timeout_result);
			timeout_result = setTimeout(hide_message, 3000);
			}
	}
	function hide_message()
	{
		document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp hideme";
	}
	</script>
		<style type="text/css">
	#wpcp-error-message {
	    direction: ltr;
	    text-align: center;
	    transition: opacity 900ms ease 0s;
	    z-index: 99999999;
	}
	.hideme {
    	opacity:0;
    	visibility: hidden;
	}
	.showme {
    	opacity:1;
    	visibility: visible;
	}
	.msgmsg-box-wpcp {
		border-radius: 10px;
		color: #555;
		font-family: Tahoma;
		font-size: 11px;
		margin: 10px;
		padding: 10px 36px;
		position: fixed;
		width: 255px;
		top: 50%;
  		left: 50%;
  		margin-top: -10px;
  		margin-left: -130px;
  		-webkit-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
		-moz-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
		box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
	}
	.msgmsg-box-wpcp span {
		font-weight:bold;
		text-transform:uppercase;
	}
	.error-wpcp {		background:#ffecec url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/error.png') no-repeat 10px 50%;
		border:1px solid #f5aca6;
	}
	.success {
		background:#e9ffd9 url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/success.png') no-repeat 10px 50%;
		border:1px solid #a6ca8a;
	}
	.warning-wpcp {
		background:#ffecec url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/warning.png') no-repeat 10px 50%;
		border:1px solid #f5aca6;
	}
	.notice {
		background:#e3f7fc url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/notice.png') no-repeat 10px 50%;
		border:1px solid #8ed9f6;
	}
    </style>


    <!--

        Theme: Newspaper by tagDiv 2016
        Version: 7.2 (rara)
        Deploy mode: deploy
        
        uid: 5e7d6c3fc7d6d
    -->

    <link rel='stylesheet' id='so-css-Newspaper-css'  href='http://weuponithiphop.info/wp-content/uploads/so-css/so-css-Newspaper.css?ver=1528674688' type='text/css' media='all' />
<link rel='stylesheet' id='soliloquy-lite-style-css'  href='http://weuponithiphop.info/wp-content/plugins/soliloquy-lite/assets/css/soliloquy.css?ver=2.5.7' type='text/css' media='all' />
<link rel='stylesheet' id='soliloquy-liteclassic-theme-css'  href='http://weuponithiphop.info/wp-content/plugins/soliloquy-lite/themes/classic/style.css?ver=2.5.7' type='text/css' media='all' />
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/themes/Newspaper/js/tagdiv_theme.js?ver=7.2'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/comment-reply.min.js?ver=4.9.13'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/wp-embed.min.js?ver=4.9.13'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/plugins/soliloquy-lite/assets/js/min/soliloquy-min.js?ver=2.5.7'></script>

<!-- JS generated by theme -->

<script>
    


            

	            // if the theme has tdBackstr support, it means this already uses it
                if ( 'undefined' !== typeof window.tdBackstr ) {

                    (function(){
                        // the site background td-backstretch jquery object is dynamically added in DOM, and after any translation effects are applied over td-backstretch
                        var wrapper_image_jquery_obj = jQuery( '<div class=\'backstretch\'></div>' );
                        var image_jquery_obj = jQuery( '<img class=\'td-backstretch not-parallax\' src=\'http://weuponithiphop.info/wp-content/uploads/20-black-paper-different-texture-types-a4-sandgrain-.jpg\'>' );

                        wrapper_image_jquery_obj.append( image_jquery_obj );

                        jQuery( 'body' ).prepend( wrapper_image_jquery_obj );

                        var td_backstr_item = new tdBackstr.item();

                        td_backstr_item.wrapper_image_jquery_obj = wrapper_image_jquery_obj;
                        td_backstr_item.image_jquery_obj = image_jquery_obj;

	                    tdBackstr.add_item( td_backstr_item );

                    })();
                }

            
            
jQuery(window).ready(function() {
(function(){
var td_backstr_item = new tdBackstr.item();
td_backstr_item.wrapper_image_jquery_obj = jQuery( "#td-full-screen-header-image" );
td_backstr_item.image_jquery_obj = td_backstr_item.wrapper_image_jquery_obj.find( 'img:first' );
tdBackstr.add_item( td_backstr_item );
jQuery('.td-read-down a').click(function(event){
event.preventDefault();
var header_wrap = jQuery( '.td-full-screen-header-image-wrap:first' )
if ( 1 === header_wrap.length ) {
tdUtil.scrollToPosition(header_wrap.height() + header_wrap.offset().top, 1200);
}
});
})();
});

                jQuery().ready(function jQuery_ready() {
                    tdAjaxCount.tdGetViewsCountsAjax("post","[37520]");
                });
            

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'http://weuponithiphop.info/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'http://weuponithiphop.info/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>

			<script type="text/javascript">
			if ( typeof soliloquy_slider === 'undefined' || false === soliloquy_slider ) {soliloquy_slider = {};}jQuery('#soliloquy-container-30342').css('height', Math.round(jQuery('#soliloquy-container-30342').width()/(960/300)));jQuery(window).load(function(){var $ = jQuery;var soliloquy_container_30342 = $('#soliloquy-container-30342'),soliloquy_30342 = $('#soliloquy-30342');soliloquy_slider['30342'] = soliloquy_30342.soliloquy({slideSelector: '.soliloquy-item',speed: 0,pause: 2000,auto: 1,useCSS: 0,keyboard: true,adaptiveHeight: 1,adaptiveHeightSpeed: 400,infiniteLoop: 1,mode: 'fade',pager: 1,controls: 1,nextText: '',prevText: '',startText: '',stopText: '',onSliderLoad: function(currentIndex){soliloquy_container_30342.find('.soliloquy-active-slide').removeClass('soliloquy-active-slide').attr('aria-hidden','true');soliloquy_container_30342.css({'height':'auto','background-image':'none'});if ( soliloquy_container_30342.find('.soliloquy-slider li').length > 1 ) {soliloquy_container_30342.find('.soliloquy-controls').fadeTo(300, 1);}soliloquy_30342.find('.soliloquy-item:not(.soliloquy-clone):eq(' + currentIndex + ')').addClass('soliloquy-active-slide').attr('aria-hidden','false');soliloquy_container_30342.find('.soliloquy-clone').find('*').removeAttr('id');soliloquy_container_30342.find('.soliloquy-controls-direction').attr('aria-label','carousel buttons').attr('aria-controls', 'soliloquy-container-30342');soliloquy_container_30342.find('.soliloquy-controls-direction a.soliloquy-prev').attr('aria-label','previous');soliloquy_container_30342.find('.soliloquy-controls-direction a.soliloquy-next').attr('aria-label','next');},onSlideBefore: function(element, oldIndex, newIndex){soliloquy_container_30342.find('.soliloquy-active-slide').removeClass('soliloquy-active-slide').attr('aria-hidden','true');$(element).addClass('soliloquy-active-slide').attr('aria-hidden','false');},onSlideAfter: function(element, oldIndex, newIndex){},});});			</script>
			
</body>
</html>