<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>Music Video: The LOX – Loyalty &amp; Love</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="http://weuponithiphop.info/xmlrpc.php" />
    <meta property="og:image" content="https://lh3.googleusercontent.com/fDkUzqhhzl8jHzDcZ5Jz8lhJOECSDqi6yZzcwqNlAhOdmmpvvgdnfAdmKrKe5l69Vuz4VjOCveEVDuNCCPhnJp877XOz55_DgnuCrJPji9ITQs9PEiPergrI3btHxYiz1L4COAopi9EA5guW3HWX_GhjzTr1ohWidefJ9rdhEQLaqPYpIsrwDJuLtYT5kOyw0pPiB9FwxNEDq3QJwtOwMIW33AyJoqKEFMVW-KofLyPb1mz9c4Dlrp_qnIhnxh4Md0pmyJNRujRG4AM3Tt0pjW7hbPfPCttUaWfH-Jcqlu_bQ7mj8AhE1Tg61HVBZ3gTrYb_UjS10xbqzUJ4Zd0PxOHPA_jAelnuJ0m6FRR1iOjy2rs4i6xgKOQi7HshMCnFbKjwEegtHQyat-Cd3ISOpKrH_1doOmkSV0S10U0blMuAzDfUKq6vOmBvLGnUeT8hTyD7zA-AtDQRDzBmdmxFG1HRFjMj3OyBduKx4d3Ba58zRHCYw1fbTL2BwQrA-FU8vQvgeLCUQg5KNNDvdzKOIA9fa5OJuTrV8tz9GkwsNOzKzFNfuH5twFovIIiHWAnFvNUvUJ3xRu_tHG6f1PktqzrbRlnb4_0x9H4aGMhLk6qEesTlxJ7suESEhlMeXZAryh5CdWdTD4QIfk00ZZjNDkAl_Op7f4imb19u71THdOXbPiaPxVsLJ6ba0BgFaQ=w1055-h758-no" /><meta name="author" content="cyclone">
<link rel="icon" type="image/png" href="http://weuponithiphop.info/wp-content/uploads/weuponitlogoCAP-500x457.png">
<!-- All in One SEO Pack 3.3.4 by Michael Torbert of Semper Fi Web Design[208,274] -->
<script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"http://weuponithiphop.info/#organization","url":"http://weuponithiphop.info/","name":"WeUpOnIt","sameAs":[]},{"@type":"WebSite","@id":"http://weuponithiphop.info/#website","url":"http://weuponithiphop.info/","name":"WeUpOnIt","publisher":{"@id":"http://weuponithiphop.info/#organization"}},{"@type":"WebPage","@id":"http://weuponithiphop.info/2020/05/04/music-video-the-lox-loyalty-love/#webpage","url":"http://weuponithiphop.info/2020/05/04/music-video-the-lox-loyalty-love/","inLanguage":"en-US","name":"Music Video: The LOX &#8211; Loyalty &#038; Love","isPartOf":{"@id":"http://weuponithiphop.info/#website"},"datePublished":"2020-05-04T20:29:13+00:00","dateModified":"2020-05-04T20:29:13+00:00"},{"@type":"Article","@id":"http://weuponithiphop.info/2020/05/04/music-video-the-lox-loyalty-love/#article","isPartOf":{"@id":"http://weuponithiphop.info/2020/05/04/music-video-the-lox-loyalty-love/#webpage"},"author":{"@id":"http://weuponithiphop.info/author/cyclone/#author"},"headline":"Music Video: The LOX &#8211; Loyalty &#038; Love","datePublished":"2020-05-04T20:29:13+00:00","dateModified":"2020-05-04T20:29:13+00:00","commentCount":0,"mainEntityOfPage":{"@id":"http://weuponithiphop.info/2020/05/04/music-video-the-lox-loyalty-love/#webpage"},"publisher":{"@id":"http://weuponithiphop.info/#organization"},"articleSection":"Music Video, Jadakiss, Sheek Louch, Styles P, The Lox"},{"@type":"Person","@id":"http://weuponithiphop.info/author/cyclone/#author","name":"cyclone","sameAs":[],"image":{"@type":"ImageObject","@id":"http://weuponithiphop.info/#personlogo","url":"http://0.gravatar.com/avatar/6a747aaba64ebc36f309e25ac7e460e6?s=96&d=mm&r=g","width":96,"height":96,"caption":"cyclone"}}]}</script>
<link rel="canonical" href="http://weuponithiphop.info/2020/05/04/music-video-the-lox-loyalty-love/" />
<!-- All in One SEO Pack -->
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Feed" href="http://weuponithiphop.info/feed/" />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Comments Feed" href="http://weuponithiphop.info/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Music Video: The LOX &#8211; Loyalty &#038; Love Comments Feed" href="http://weuponithiphop.info/2020/05/04/music-video-the-lox-loyalty-love/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/weuponithiphop.info\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.14"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='google_font_open_sans-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;ver=4.9.14' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_roboto-css'  href='http://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C900%2C500italic%2C400%2C300&#038;ver=4.9.14' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='http://fonts.googleapis.com/css?family=Roboto+Condensed%3A400%2C700&#038;ver=4.9.14' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='http://weuponithiphop.info/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=4.12' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='http://weuponithiphop.info/wp-content/themes/Newspaper/style.css?ver=7.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css'  href='http://weuponithiphop.info/wp-content/themes/Newspaper/includes/demos/what/demo_style.css?ver=7.2' type='text/css' media='all' />
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1'></script>
<link rel='https://api.w.org/' href='http://weuponithiphop.info/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://weuponithiphop.info/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://weuponithiphop.info/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Video: Doja Cat &#8211; Say So (Live On Vevo Lift)' href='http://weuponithiphop.info/2020/05/04/video-doja-cat-say-so-live-on-vevo-lift/' />
<link rel='next' title='Music Video: Young M.A &#8211; RNID' href='http://weuponithiphop.info/2020/05/04/music-video-young-m-a-rnid/' />
<meta name="generator" content="WordPress 4.9.14" />
<link rel='shortlink' href='http://weuponithiphop.info/?p=38207' />
<link rel="alternate" type="application/json+oembed" href="http://weuponithiphop.info/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fweuponithiphop.info%2F2020%2F05%2F04%2Fmusic-video-the-lox-loyalty-love%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://weuponithiphop.info/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fweuponithiphop.info%2F2020%2F05%2F04%2Fmusic-video-the-lox-loyalty-love%2F&#038;format=xml" />

<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>
<script id="wpcp_disable_selection" type="text/javascript">
//<![CDATA[
var image_save_msg='You Can Not Save images!';
	var no_menu_msg='Context Menu disabled!';
	var smessage = "Not Prohibited. ✌️";

function disableEnterKey(e)
{
	if (e.ctrlKey){
     var key;
     if(window.event)
          key = window.event.keyCode;     //IE
     else
          key = e.which;     //firefox (97)
    //if (key != 17) alert(key);
     if (key == 97 || key == 65 || key == 67 || key == 99 || key == 88 || key == 120 || key == 26 || key == 85  || key == 86 || key == 83 || key == 43)
     {
          show_wpcp_message('You are not allowed to copy content or view source');
          return false;
     }else
     	return true;
     }
}

function disable_copy(e)
{	
	var elemtype = e.target.nodeName;
	var isSafari = /Safari/.test(navigator.userAgent) && /Apple Computer/.test(navigator.vendor);
	elemtype = elemtype.toUpperCase();
	var checker_IMG = '';
	if (elemtype == "IMG" && checker_IMG == 'checked' && e.detail >= 2) {show_wpcp_message(alertMsg_IMG);return false;}
	if (elemtype != "TEXT" && elemtype != "TEXTAREA" && elemtype != "INPUT" && elemtype != "PASSWORD" && elemtype != "SELECT" && elemtype != "OPTION" && elemtype != "EMBED")
	{
		if (smessage !== "" && e.detail == 2)
			show_wpcp_message(smessage);
		
		if (isSafari)
			return true;
		else
			return false;
	}	
}
function disable_copy_ie()
{
	var elemtype = window.event.srcElement.nodeName;
	elemtype = elemtype.toUpperCase();
	if (elemtype == "IMG") {show_wpcp_message(alertMsg_IMG);return false;}
	if (elemtype != "TEXT" && elemtype != "TEXTAREA" && elemtype != "INPUT" && elemtype != "PASSWORD" && elemtype != "SELECT" && elemtype != "OPTION" && elemtype != "EMBED")
	{
		//alert(navigator.userAgent.indexOf('MSIE'));
			//if (smessage !== "") show_wpcp_message(smessage);
		return false;
	}
}	
function reEnable()
{
	return true;
}
document.onkeydown = disableEnterKey;
document.onselectstart = disable_copy_ie;
if(navigator.userAgent.indexOf('MSIE')==-1)
{
	document.onmousedown = disable_copy;
	document.onclick = reEnable;
}
function disableSelection(target)
{
    //For IE This code will work
    if (typeof target.onselectstart!="undefined")
    target.onselectstart = disable_copy_ie;
    
    //For Firefox This code will work
    else if (typeof target.style.MozUserSelect!="undefined")
    {target.style.MozUserSelect="none";}
    
    //All other  (ie: Opera) This code will work
    else
    target.onmousedown=function(){return false}
    target.style.cursor = "default";
}
//Calling the JS function directly just after body load
window.onload = function(){disableSelection(document.body);};
//]]>
</script>
	<script id="wpcp_disable_Right_Click" type="text/javascript">
	//<![CDATA[
	document.ondragstart = function() { return false;}
	/* ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
	Disable context menu on images by GreenLava Version 1.0
	^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ */
	    function nocontext(e) {
	       return false;
	    }
	    document.oncontextmenu = nocontext;
	//]]>
	</script>
<!-- Analytics by WP-Statistics v12.6.12 - https://wp-statistics.com/ -->
<!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="http://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]-->
<!-- JS generated by theme -->

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var tds_login_sing_in_widget="show";
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_ajax_url="http:\/\/weuponithiphop.info\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=7.2";
var td_get_template_directory_uri="http:\/\/weuponithiphop.info\/wp-content\/themes\/Newspaper";
var tds_snap_menu="snap";
var tds_logo_on_sticky="show_header_logo";
var tds_header_style="5";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#dd3333";
var tds_smart_sidebar="enabled";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>


<!-- Header style compiled by theme -->

<style>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</style>

<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>

<body class="post-template-default single single-post postid-38207 single-format-standard unselectable music-video-the-lox-loyalty-love td-what single_template_7 wpb-js-composer js-comp-ver-4.12 vc_responsive td-boxed-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
                    <div class="td-menu-login-section">
                
    <div class="td-guest-wrap">
        <div class="td-menu-avatar"><div class="td-avatar-container"><img alt='' src='http://1.gravatar.com/avatar/?s=80&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo avatar-default' height='80' width='80' /></div></div>
        <div class="td-menu-login"><a id="login-link-mob">Sign in</a></div>
    </div>
            </div>
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-top-menu-container"><ul id="menu-top-menu" class="td-mobile-main-menu"><li id="menu-item-317" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a></li>
<li id="menu-item-706" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a></li>
<li id="menu-item-314" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a></li>
<li id="menu-item-316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-0" class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a></li>
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></li>
</ul>
</li>
<li id="menu-item-705" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li class="menu-item-0"><a href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></li>
</ul>
</li>
<li id="menu-item-18581" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li id="menu-item-3199" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
            <div id="login-form-mobile" class="td-register-section">
            
            <div id="td-login-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-login-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign in</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
	                <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
	                <div class="td-login-info-text"><a href="#" id="forgot-pass-link-mob">Forgot your password?</a></div>
                </div>
            </div>

            

            <div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
                <!-- close button -->
	            <div class="td-forgot-pass-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Password recovery</div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title">Recover your password</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
	                <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
                </div>
            </div>
        </div>
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="http://weuponithiphop.info/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap">
    
        <!--
Header style 5
-->

<div class="td-header-wrap td-header-style-5">

    <div class="td-header-top-menu-full">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div >

                Monday, May 4, 2020
            </div>
        </div>
    <ul class="top-header-menu td_ul_login"><li class="menu-item"><a class="td-login-modal-js menu-item" href="#login-form" data-effect="mpf-td-login-effect">Sign in / Join</a><span class="td-sp-ico-login td_sp_login_ico_style"></span></li></ul><div class="menu-top-container"><ul id="menu-main" class="top-header-menu"><li id="menu-item-79" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-79"><a href="http://weuponithiphop.info">Home</a></li>
<li id="menu-item-81" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-81"><a target="_blank" href="http://weuponitradio.com">Power 105.1 WeUpOnIt Radio</a></li>
<li id="menu-item-80" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-80"><a target="_blank" href="https://shop.spreadshirt.com/freshandcleantees/">Shop</a></li>
<li id="menu-item-18582" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18582"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li id="menu-item-18583" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18583"><a href="http://weuponithiphop.info/privacy-policy-2/">Privacy Policy</a></li>
</ul></div></div>
        <div class="td-header-sp-top-widget">
    
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div>
    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <ul class="td-login-tabs">
                        <li><a id="login-link" class="td_login_tab_focus">LOG IN</a></li>
                    </ul>



                    <div class="td-login-wrap">
                        <div class="td_display_err"></div>

                        <div id="td-login-div" class="">
                            <div class="td-login-panel-title">Welcome! Log into your account</div>
                            <input class="td-login-input" type="text" name="login_email" id="login_email" placeholder="your username" value="" required>
                            <input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" placeholder="your password" required>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Log In">


                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password?</a></div>


                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-display-none">
                            <div class="td-login-panel-title">Recover your password</div>
                            <input class="td-login-input" type="text" name="forgot_email" id="forgot_email" placeholder="your email" value="" required>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Pass">
                        </div>




                    </div>
                </div>
                        </div>
    </div>

    <div class="td-header-menu-wrap-full">
        <div class="td-header-menu-wrap">
            <div class="td-container td-header-row td-header-main-menu black-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-menu">
        		<a class="td-mobile-logo td-sticky-header" href="http://weuponithiphop.info/">
			<img class="td-retina-data" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-5.png" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-5.png" alt=""/>
		</a>
			<a class="td-header-logo td-sticky-header" href="http://weuponithiphop.info/">
			<img class="td-retina-data" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" alt=""/>
			<span class="td-visual-hidden">WeUpOnIt</span>
		</a>
	    </div>
    <div class="menu-top-menu-container"><ul id="menu-top-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-mega-menu menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_1_5eb099e40cbc2_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_1_5eb099e40cbc2" ><script>var block_td_uid_1_5eb099e40cbc2 = new tdBlock();
block_td_uid_1_5eb099e40cbc2.id = "td_uid_1_5eb099e40cbc2";
block_td_uid_1_5eb099e40cbc2.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"43","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_1_5eb099e40cbc2_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_1_5eb099e40cbc2.td_column_number = "3";
block_td_uid_1_5eb099e40cbc2.block_type = "td_block_mega_menu";
block_td_uid_1_5eb099e40cbc2.post_count = "5";
block_td_uid_1_5eb099e40cbc2.found_posts = "2986";
block_td_uid_1_5eb099e40cbc2.header_color = "";
block_td_uid_1_5eb099e40cbc2.ajax_pagination_infinite_stop = "";
block_td_uid_1_5eb099e40cbc2.max_num_pages = "598";
tdBlocksArray.push(block_td_uid_1_5eb099e40cbc2);
</script><div id=td_uid_1_5eb099e40cbc2 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/05/04/new-music-rob-markman-ft-listentosin-saint-pat-beatz-who-do-i-trust/" rel="bookmark" title="New Music: Rob Markman ft. ListenToSin &#038; Saint Pat Beatz &#8211; Who Do I Trust"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/GxrgktroLSpv3y0DQ-Erh2jntgltZgio9wXKVWL2X-Z4KeuPDAuvLNbEQpfkK_GzZ59d_gsgd7nq4HqKF_DeSa_jkB_ikLXXSWtgp830pBlNyn5be2rAoWdeb5IVzoDHG9IXy_2n2MPKFSL-miUyYczuGMKl3bTaM9rgIdBceK4jgEzfFaDpSAI8IGJueEAPZRjlSZ1NAbcAu3vwxnEmVfoq_en06UheXoe2U2vkxKPCgei-Mv8uVtVtOJcR7xErtfM-ESir3tfef4kqQ2iipqb3kUXt0MN76eTxkLk1maEjFeaIZab1N5SxEln_CCvW0WLn7kYOVT8gzFpZrnQUFsWT5iNYvayk7bOxWDKHSTIRqcCZ06gHXdVMz6e_ZKmK3SMiUfgYpeqrEDz-fqErkMUUoc1_jn7S3dRAD1Y-8yc41SwdCvdX4GocUaTxYh9x9C9yItx-tntzF1uZcq0StJuRAt7w-15mJzF6m_ce3LrUojQiwPKfUCNSRm5PUWLQ-IJ5I_7Is2hj7D9UdEfVniInb8FvkCGK1Ah1dR9mo11rChn4EhtblNtzt-QFmHIo6FR-xn3UvWw-MHiPj5TyV-2GD_h7wRjSroSXEvq-LSO5KcRYyWVN-HCO0RMibqkRcBao6bR4MFQGCWlQ8YxbjVN8vyUA2MkGa1DzgTTSM2b65GrQgXjyOK-ZUTJ49w=w754-h758-no" alt="" title="New Music: Rob Markman ft. ListenToSin &#038; Saint Pat Beatz &#8211; Who Do I Trust"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/05/04/new-music-rob-markman-ft-listentosin-saint-pat-beatz-who-do-i-trust/" rel="bookmark" title="New Music: Rob Markman ft. ListenToSin &#038; Saint Pat Beatz &#8211; Who Do I Trust">New Music: Rob Markman ft. ListenToSin &#038; Saint Pat Beatz &#8211;&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/05/03/new-single-kota-the-friend-ft-joey-bada-bas-bqe/" rel="bookmark" title="New Single: KOTA the Friend ft. Joey Bada$$ &#038; Bas &#8211; BQE"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/hH0WO5IA7sIjeNkWydMwOkaeiPvPVbnrxMJWXDoOVPUCFEpviUYETsxDrm9jzJXoKDxsrpRZdn2YMSKkHtPiYRIR-UEcp-ghzGEmYukDGD6tuHb8bu1FjgGfr91tP8zDhK1STBbB6FSiGYMTRTV-lqrnDX93UUVEgewz86yaoaHF7VbKJh9YHfIEHQhO_rB53Gotob6hknFbtKdlH_Bezte7dgNA_5XNYSai0dQprmU-A3aATCn30sw6ZIZafQJZugGIKkdd3Jx9Y66lheeh1tPAiQUvdXOUsse5lTYNMuxQvdPQWTLM98Do0JGlQYtJPOWdz10inEhWpFXqpXkUSUkwQHE3qXc_LXDo4sKyJsZTRSi0M6vZfF4923IbFXyt0qaKNyhqnm3Y-vjWKhwaW0qTebpUsGfkySWnWRwv8evaUvrIcfbCavIV7_3U-Qr5pHizCcznoirYoqjECIqCJ9xoq2H7ngSJYI5W0YuY6DMoqMnIuFgPPZhyu-VHWmqCPFSnP_xoSQc5nyt5lBjfGimfB2DM7Kh8mUtJxadXxrxEpftLRZXRmLBDysFxATIXt-3Trl7Rn4nCubHx2fvaU_U-_y6u4s5HX1AEjp0u-g_mkrBTr85B0VkSCcHQ-8e8l0aKdXVNyOCTpDAQaTpjLRJf3AKQ4r7j01arbsgXz7tfahff4KWv0imuhErH0Q=w754-h758-no" alt="" title="New Single: KOTA the Friend ft. Joey Bada$$ &#038; Bas &#8211; BQE"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/05/03/new-single-kota-the-friend-ft-joey-bada-bas-bqe/" rel="bookmark" title="New Single: KOTA the Friend ft. Joey Bada$$ &#038; Bas &#8211; BQE">New Single: KOTA the Friend ft. Joey Bada$$ &#038; Bas &#8211;&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/05/03/new-music-lion-babe-cant-get-enough/" rel="bookmark" title="New Music: Lion Babe &#8211; Can’t Get Enough"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/tWVgEtWwzjKsCdfWmkPfNo5ENjIHohUhCJ3fPgQGq9fU5pBKCN9OmYuRqdTcFlIes_StGJh9fVTBIsM-WjpG8fc5H_e4f823AMCx6JkEu041yiNY02n2ekTZb__xHXJWpq3bnG6TLrltRQEBH-7E1cSy40Q3ut4sVpo93M709fgHcQg1adBNVn762Eb5CagtUckURychuYSeHJDTHtmukzbaRvR8NBx1jTrM2Zg5bemsHNXyxUvVEbYK_SUPmnZnlnybBGUWSfY5fMeUw2X3ZZ50fXu3I6mVl_T1_mlEjRLUadaonzRH-hVsAT3pew6CSrecwTCGkgK6t2ufUMapxMsgF5m9TDpGf7D0msd2019sD118-78F8eMeSR5nHzuIlWEoE3hCaatA8Vh10oNGMAVJgz8jKx5qh7ZLUnLlqF6SDLTSbJqdG8xup-ATtOCeT0ZU-xGQzj_Vnt-lbvxR1LraVz6AqjAByaZUNi_cSn3dtAZ1zwxeHH47T7hoMCtn8Aby9xqdeuZnlGqBnywJklrlJM5aJTr_v_t5aG465AalzCyrRwq_cUcw-1S3ZVGxRgSaddIkXfuc-YRcvnI9LXq0T2NkwFp1iMErf7P8xsfPBLYfnmNbb14Vn64bfcnRiW9XycMpAVgIVI-YBmezPSwes_HG4KvhXmItTr5Mak83SPJTNhly3IbE0zBpvw=w764-h758-no" alt="" title="New Music: Lion Babe &#8211; Can’t Get Enough"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/05/03/new-music-lion-babe-cant-get-enough/" rel="bookmark" title="New Music: Lion Babe &#8211; Can’t Get Enough">New Music: Lion Babe &#8211; Can’t Get Enough</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/05/02/new-music-french-montana-ft-tory-lanez-cold/" rel="bookmark" title="New Music: French Montana ft. Tory Lanez &#8211; Cold"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/DkpDHJrtHKpfjQ3J6gikKSQQfIYv9-haBEcr4o8Qaj_i8s4yWxot-ioZ2goI9wFYMrq3vUyXFQvTx78eljPzpEh7CbkOsDUHykRJicM6-IphvPWQ3kgXmit2q8L8C3sEaIhq_rd0jW3DXLsYMfnXsCH27aebSOG3tqDJu1dkcQn-u2XsqecBxjDYMSXAcP9rtJMlU2JKjFSpVbhQzuQnrouxLB7DX2LzGHnDS8Er1RE67l8uA_W38sqno1TDMU0xsr7eGb4XDkFF86ePvLFImMTBI-uHgF1TYLXx1JP62yQ3aA9ZVZ2DkX2qK5DCTSRmFfxPnleGB0goZWAAezFi2EWvtC_qoG59cIVVNDFqvXQ9ONc_RwjfXo7S3niBnn1x2ZYHUYeoxqxuELd6irg6Aqltkk_1fdMRc98O2UVSXpVdQS-CnbynhdDrVV5X7gTXibK6-kIzHQexDI9zyamy-QK6zy6SOYcWKc1_jeQZpm3b_wKbYQf1CtSkcIcU757Tf-b9mu_Sly1QF4lQ-rMpAvKqQ9ozQGs_z0Giy_DqgMvlfgO8n1d7Anj9y5Nx1Ps5Ux6mhVkp9DtQ4nJtgCEwJHFkbA8pjrcOjE1Mv1kBM4qiE-y8JqkkojA_F_C2UqFlOqurRySTDtbxOFPi7C_sZfPNM_OJ1xofWo98jVCBvN6dK6TdLiRrQy_0XrJO-g=w755-h758-no" alt="" title="New Music: French Montana ft. Tory Lanez &#8211; Cold"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/05/02/new-music-french-montana-ft-tory-lanez-cold/" rel="bookmark" title="New Music: French Montana ft. Tory Lanez &#8211; Cold">New Music: French Montana ft. Tory Lanez &#8211; Cold</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/05/02/new-music-hit-boy-ft-dom-kennedy-nominated-prod-by-jansport-j/" rel="bookmark" title="New Music: Hit-Boy ft. Dom Kennedy &#8211; Nominated (Prod. by Jansport J)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/lExN5pOZq4xsZsUEcFqFN1whAHRUb9pQLtGZBYEc4acUEJw0UuPLQOIrb08r5AE9z3zXiPSS4HcgGarA_diQ9FMQiyn3qw_HnGLee576P2ZQCFu3VB9Ux4sV5TGF2VmhBxOXTZ0rBi_9TTSPxYuz8v-bgaN5J2EzPmiUpDrxH1kHcNXgHQ5PTeu3v1MRH46xvzEpqWU5gQFOyw768bT7TMmasUOALIEA1jV3I8iZKABuxyvEEgI4GqvSs3K1tGiEt3I4idbiUOevPbAd2m4OddHRs4r9dixmcH9V69S95mvtjpwbMbuCuJdNKzYZuepQQHVjcT97YWR65SyP77q_XB9ATdZL7yiNVZHC3TkTquKLNxpil8NHI3LuMuRbJvbyNebtjh6rEV1jlapVQ0vDpl85k9v7YqTOPuCqd8V6aGwM4YZ30FguSKSBiJ_4DSI7sTYS2Y59R8w_Ib5pbiQPlfvEGDwP0j3MjFWw8LPTtdcP6gdSXd_P1T00Z4CfxoMi9Fks4msoSzi9gark2wlo7rVORedt0ZhXA_doDqGXcKZAERVFuE5A5p7wfeZFnjq7QzNP0ZNP0J2drZ1xdyKUCj-0VFpr15rplc50wunkazgDLCLnIn1Cg4qnsM4WoHMx-XOJ0VwqXbB4cMdi0iojthvm18hOxeISNOEcMaMrSqVgVcgkJkMs1d9ZRp4bWQ=w779-h758-no" alt="" title="New Music: Hit-Boy ft. Dom Kennedy &#8211; Nominated (Prod. by Jansport J)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/05/02/new-music-hit-boy-ft-dom-kennedy-nominated-prod-by-jansport-j/" rel="bookmark" title="New Music: Hit-Boy ft. Dom Kennedy &#8211; Nominated (Prod. by Jansport J)">New Music: Hit-Boy ft. Dom Kennedy &#8211; Nominated (Prod. by Jansport&#8230;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_5eb099e40cbc2" data-td_block_id="td_uid_1_5eb099e40cbc2"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_1_5eb099e40cbc2" data-td_block_id="td_uid_1_5eb099e40cbc2"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_2_5eb099e410fe1_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_2_5eb099e410fe1" ><script>var block_td_uid_2_5eb099e410fe1 = new tdBlock();
block_td_uid_2_5eb099e410fe1.id = "td_uid_2_5eb099e410fe1";
block_td_uid_2_5eb099e410fe1.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"97","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_2_5eb099e410fe1_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_2_5eb099e410fe1.td_column_number = "3";
block_td_uid_2_5eb099e410fe1.block_type = "td_block_mega_menu";
block_td_uid_2_5eb099e410fe1.post_count = "5";
block_td_uid_2_5eb099e410fe1.found_posts = "1053";
block_td_uid_2_5eb099e410fe1.header_color = "";
block_td_uid_2_5eb099e410fe1.ajax_pagination_infinite_stop = "";
block_td_uid_2_5eb099e410fe1.max_num_pages = "211";
tdBlocksArray.push(block_td_uid_2_5eb099e410fe1);
</script><div id=td_uid_2_5eb099e410fe1 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/05/03/ep-stream-mahalia-isolation-tapes/" rel="bookmark" title="EP Stream: Mahalia &#8211; Isolation Tapes"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/H-J-r-7N1JvZEmNtPVtEaCru2Ld84hDgSXAFQcejlvAzcSJzTkQSThW3A6tfIX0IGEaJvDRIbqHLEgnbL74T-t71HnfsoprOtA6sRoE04G8jlaBM2DIpBF2bEW4G0rM9IlMK2PWJcPX9OzKumeQYIQj8hv0FgSxuEEbi0ZQ4Ou_iwsO3k-9ZxwN9YGSh-08zjh8oIC8-8l_BwK4LHB_WJ0cMBItkYnZ9uAEJRNBHeWhBEuUOlebySXLNHUaSOlfUewoHLeuyE_o4I6tp3SAivW3p90A8kZ-jL9bsbgt8b7N2gtxC8bzSHFDHMYbFK6kZZsoIpMQ7ArVIaiuCL50TL-5ks5en6Q18R_yL95o1KTlzG2y0kefamgAzksy9DMGJ3BYCU9kpDekMBYWAxK50layLKZWAfd4aGP2ljOdnLLBkx5Pdd07kLqHA96yIr8EzV81oRVOVO5EYfgvs5cbeD7mmg5MjqraaIqIRdaX1uz_EInks-LRIh863ZXlg6A6MOsjcoXi2H6hdbCi9AnIKuTvGg7cKAxJOSrC85lBCnZuII4xqqzQ3C5nXeUMLEdppuF3rZE7WMF1VgTvwjw7BHc43TSXZQuPDW89x1H-wcjOGefQpeMMrvFohcukO-fL3sqzTz6uUkE8EtzhuZXyTdsusBpGRmT5nqqufbFaCJwIxqIsCQGES1ms5pgM4-Q=w755-h758-no" alt="" title="EP Stream: Mahalia &#8211; Isolation Tapes"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/05/03/ep-stream-mahalia-isolation-tapes/" rel="bookmark" title="EP Stream: Mahalia &#8211; Isolation Tapes">EP Stream: Mahalia &#8211; Isolation Tapes</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/05/02/ep-stream-jay-worthy-x-harry-fraud-eat-when-youre-hungry-sleep-when-youre-tired/" rel="bookmark" title="EP Stream: Jay Worthy x Harry Fraud &#8211; Eat When You’re Hungry Sleep When You’re Tired"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/m20zZrypjC84Yctw2Puq2S-fCpDU13GARztTJ4BzF9imyiljkZw-3eiyRC2nBoKJWRtcUzwTwGwjvYI5FerVgdbpICGkoldoubWEECySJyBcvyqUhA-E1bwDPyYOmQuiVRtIjJD7-b8B1FPmSBtuQE-pNX_Nea6_-VA7uj-d_VHvxJnbAoAkqCJlzRj0wGVT3Q9GYqCcEYShiwZS7RFMZKw0D1zyF1wfEIJ9RwE3bnzlTwKytNMBh7ljZw6hXWYNBYjlLtgt3cp4VbXy9Z1L4-rtidEvIyWMd7-GwxvRPBxMHgqIZ5VGiVjESaRNntrB8PQGZcaC8XUv8g6G2oS5PNxLd1dBo90nBdK53NBdBsBXm5gaJg8BepZsrdnUnV5PP4TV9ZlO663PHuU5-7Zyhyf8fo85313MfmYmb-Vv-ij9M9Es1ngwnvc_jmghYrpPlvs9fMeJh7BR5EMXjhJyWS5VrrqkkSS5q1yC-AIGxb-vI127rhcX8h5yj_ERMQyO7KvckYh-a6nhYGlU3IE3QW4mnogCXwbPMbGP4yuxlVeVH6MyeiS5mtr_O0JLBn5dnGr-bVtRCGzIlWANMYN2sSrMWR9O2QdiN3g1NkqkQNHW2jBGNG33iLdZpjYddxjFtQeCjZSAzBa4_MDoYQInbVb7Stg-DMsQ4iKqQHV4rI_HIQnzi-1zJQlzbL98Dw=w754-h758-no" alt="" title="EP Stream: Jay Worthy x Harry Fraud &#8211; Eat When You’re Hungry Sleep When You’re Tired"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/05/02/ep-stream-jay-worthy-x-harry-fraud-eat-when-youre-hungry-sleep-when-youre-tired/" rel="bookmark" title="EP Stream: Jay Worthy x Harry Fraud &#8211; Eat When You’re Hungry Sleep When You’re Tired">EP Stream: Jay Worthy x Harry Fraud &#8211; Eat When You’re&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/05/01/album-stream-drake-dark-lane-demo-tapes/" rel="bookmark" title="Album Stream: Drake &#8211; Dark Lane Demo Tapes"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/dEZy1rfXUaDAlxp87uVxpVEF2UeaYOwTRZLfkDE92ZmdZdcDifVz4PWB500FJbl_dLF2FyTGg8t6UDePs0sFm-b8_a14sQpO4pEu3NxeM926D7GiCRa4-48amNNbapfYcSBqZ-jodvYtycnvWAlrg4166onH9M6ENeP8LO_xNVPCgwZT_KDflHSeGRGBBOs9iRv3k-FWIoG_MCuaCykF7R2MGfNnLyfOlkH_6fge1Qe34kprLJI3oSGyksEym1nkM0Td36eFcZ2wzumIrViIh_ubk4ZjrWisf-2C-qZpYu39-SbMlqdHNDEMjqZrHSXesfUJoQmq4gq-Cqakbb-DxquSz3CDuAnDtzHjNSe0sYFhHPWtpQqZl2V3AnkNkppG05Ka7wo1pUssv9eic4_kxo4Bweqn3gXdPwKdWutOcr1RH0Qol8nrzpXdFwzWM-7ZOvCyktQamadMF6eytIXlQmhwLjP7jhkZa6aXT6lYQMfcecZzlD5UcVJDRFnj42NU6FW7RK522mGRQ4t10p8OuQ2FWYvg9lMkZhVEnSKckh6s5Yxy0xO2xbolXho-Z6wxguVw9Wf8LTWvbjzSfZ6K2LKqxviRpLXCmpRJFG6b6x8AUQcPA_lyN-k40Bq-KcHkEKXCNNv8zlrbUf7TUy8Ewu7IBb2gkd3dZmEItfZ5bTuxRzzFzFSU3uv4FbAcO5OTI2Y=s758-w756-h758-no" alt="" title="Album Stream: Drake &#8211; Dark Lane Demo Tapes"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/05/01/album-stream-drake-dark-lane-demo-tapes/" rel="bookmark" title="Album Stream: Drake &#8211; Dark Lane Demo Tapes">Album Stream: Drake &#8211; Dark Lane Demo Tapes</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/04/28/ep-stream-terrace-martin-conscious-conversations/" rel="bookmark" title="EP Stream: Terrace Martin &#8211; Conscious Conversations"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/9oIzqmJcAZRcTwtzaONtU54msHkveUb0s0XB5zF20LAJPmfSdmHlAzqHXd57rcvVMmuwpv1A9nJpx1mWNRkYZr_-n8non0IN1is-n03bV8xiXzVNY0cDZM7dCLwz6mVcLPyel0Ptku54Rc_5oYp8UhUNpC92MnWRo6GtTbdjE5tHgezhMfzo4zmmgk8jPNNrTPcbbtuNzwEs3Nhkat8xB4Q8rS9BRre51oerg3Hiz6hCaCr_WC8o5PURu3MKHP_lDZG9Rxkag1vr7L7AakuMdLh0SxUx_oy2WX-S7TQMB7UhBpi1hySEkTEqRxzpEuxXKAkenVQNJZRU6sedmVlOJVj9ft92IK3osndAVpXD55iKHOVZhyDUlfzrrBFT8pm64iqkATwwY9UMLoXzc6xOtzjWqpyZx_lLJwCmB2yycB4A07IpHuWtRGSPtBm2khYLYcX1bJK8Fr_yqGXNP3lsXeB_Nj4mx0yQssDnbTiUaR49YHiLUkym-wP0JSVStXtjCJdAjM4-psZblxFYAZk49YFJXfYYDc1z_hRfk8S4XHIdAf7IIs34-o96cEK0foHTCOR1oAqmiBpnpEb7nHT5d3O9aMBBn2wnXcDdK8FScazBA-oI5KkGaq1yrOHKiD3GHbEKS05uxU1Xr3VtNKoYTnYhleTNdsV2i7-yaS7nBmOVOXeolI1gTVvzdP3aOQ=w754-h758-no" alt="" title="EP Stream: Terrace Martin &#8211; Conscious Conversations"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/04/28/ep-stream-terrace-martin-conscious-conversations/" rel="bookmark" title="EP Stream: Terrace Martin &#8211; Conscious Conversations">EP Stream: Terrace Martin &#8211; Conscious Conversations</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/04/28/mixtape-waka-flocka-salute-me-or-shoot-me-7/" rel="bookmark" title="Mixtape: Waka Flocka &#8211; Salute Me Or Shoot Me 7"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/dyyI_BCXVMY4OdIQaKlhbvOXYhhR0m9-PyMJ1micyMDvYJzBjBpej6K_MFJcz6t6-_QWKLmaEdgDRkpS8bJOe2fml-ywEVge_I5u3sw0uvKAUsEf8Z-4bO7EajbPCb2479Ps5o6o8LCmQIUzH-P6iyFj-lkuaBRVOsQA-Yvf2qnRz4aIhOb6rQg7wfKfcdkSkfZUZ9Fx0oneP74fPS5x4W6qUcg8nrnuPOvjTOUHosCDVcHnM6DxW1GztRI8SbMfrNxzfYqHX4tzv_vNJwKeXGyKF-Va6R_TvdSJMkewHwDeeGQDETMnGORLn6CV3OER4qt847Am-RuD4sEW45vAe9DwNRygvDwIB_G80uVvaub-XqgePTDJejX0lSWyFipDBw-L-OuXdJpxuU9tfkRYCJVHZKkMiBaxMXGRnpe5-jXutPSd79jGUdvcleXgdyh_tjEeoGZmWWkVr7mn84JzcPN21h0-uCVKA6aO8Iu8KToIH5tnZ7PONolnKri0ZWfvD3aefm-nIFnJcXk5woUBhXoW7eJqz88juWiEIIOWxrqMv1UodXk42632ZFezaKT4306TbGkfSsqQ8kWsLaQVCSIMQC8PbizYzkeixpl8tP4FdGV6TTTHmQfzES1tXWIiBH81YWrf56phZC2RfaYoYOz1Mg7rW4q0g_4VzpufluMjYm7_QX2ky4gdKH2pIg=w756-h758-no" alt="" title="Mixtape: Waka Flocka &#8211; Salute Me Or Shoot Me 7"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/04/28/mixtape-waka-flocka-salute-me-or-shoot-me-7/" rel="bookmark" title="Mixtape: Waka Flocka &#8211; Salute Me Or Shoot Me 7">Mixtape: Waka Flocka &#8211; Salute Me Or Shoot Me 7</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_5eb099e410fe1" data-td_block_id="td_uid_2_5eb099e410fe1"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_2_5eb099e410fe1" data-td_block_id="td_uid_2_5eb099e410fe1"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_3_5eb099e415010_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_3_5eb099e415010" ><script>var block_td_uid_3_5eb099e415010 = new tdBlock();
block_td_uid_3_5eb099e415010.id = "td_uid_3_5eb099e415010";
block_td_uid_3_5eb099e415010.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_3_5eb099e415010_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_3_5eb099e415010.td_column_number = "3";
block_td_uid_3_5eb099e415010.block_type = "td_block_mega_menu";
block_td_uid_3_5eb099e415010.post_count = "5";
block_td_uid_3_5eb099e415010.found_posts = "2939";
block_td_uid_3_5eb099e415010.header_color = "";
block_td_uid_3_5eb099e415010.ajax_pagination_infinite_stop = "";
block_td_uid_3_5eb099e415010.max_num_pages = "588";
tdBlocksArray.push(block_td_uid_3_5eb099e415010);
</script><div id=td_uid_3_5eb099e415010 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/05/04/new-music-brandy-ft-chance-the-rapper-baby-mama/" rel="bookmark" title="Music Video: Brandy ft. Chance The Rapper &#8211; Baby Mama"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/n5PFGB8RVaovm26UqNDqt4fCirKYK2wPIIKVBlttdtFSfjL07LcE7V8vN-hP2SYBDRpZPatvpKxQgWS1BrvnxcsCYKiLbfwGmnHYiKKzmAsJmsJ4rj5L5jDl9BGzon9uKPMPNYWY2VEpeiPYYWH4q9Yp0gh5iXpujQqPiNs_Go6TevcWYG6z0fQjoR0V8sgAXdZQaRmxPWQOFEMChRfcXeqVv9mS3bHfrmlxORqms_iJXgIvJH9j3zT2uM6aLASaCEEZdnldaS9-zihIFz1sZy5ZjqHTM_juj7KHqMkRnUaYIrC4mZXbF9AK5lX1GyNohROy9BZT5DRUShpUKpVDZ7HXGtRNHwRoBY-NXK_Fd0Hh9kzIGs03clXl_ikvhPADLLsRADXzBWDdzS44uS2whX6ghPG-YiCT6zmZfGgcZRiCMCp-sG5Ah70G6HaRh99beLOnvLMTlHb9jQG7qeHHTQZhKTTG4gpdvAgaA2QimPIVnrUboA84uzrMpP37akEuiG9IsiFA-xROwD4Y3ExgwVZslTCaOuCkw71bj89Y8h0pipPAk14jDNMT7zLxdDysdnfKJvjdcZGcwEucJblzvSYgv18m1RFSwjvASKNuWq3JijhnZ0NJSGPSLp2Rh1ZW8njCZRKhpPK890bN-LqAf_Cv_INcHsefy5toPF32KCGLmJO--6g5Zv6fxEyQVg=w1077-h564-no" alt="" title="Music Video: Brandy ft. Chance The Rapper &#8211; Baby Mama"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/05/04/new-music-brandy-ft-chance-the-rapper-baby-mama/" rel="bookmark" title="Music Video: Brandy ft. Chance The Rapper &#8211; Baby Mama">Music Video: Brandy ft. Chance The Rapper &#8211; Baby Mama</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/05/04/music-video-young-m-a-rnid/" rel="bookmark" title="Music Video: Young M.A &#8211; RNID"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/J6Vkh4bXQxb_Ky483hsC_5dQk_eiDG4ZWbzH23fzcVzwuC5Gxhpy2HBfybqYr_7dalBmznmfQS7s6kciFbeE9gZ7xZB9sQVNuzhwcp5dlYyZxkwaWa044_YqspNEGdXaEX4wfvywVWoDjNisJ44ET9pgTikuwXKzYVr2FbB_0HuMVrgU3xvURAGVWjdSI_gRiAeeBgIyE-bXhs3t6yogh5wtCFCo0GOSpvKCTlJeesdMUrWe3keXglkDDje0DEwgvB-Y5Lny_ibTPn6vAZiWylDwL_xmAbfq_bcVw_SsgNY1tLHcGSYYb7CvU4xdtabDQGTg-8jV-npw4a3ZHYG6ouubDOWZEBHF_jlhkAWO2Z5uFw9Pwtu6zvK936W-86G4FtAFxAud4bA7h9T7a4zAFtbroHabSnBsFChstDMsYPS7M0P71CO_W134ri5mXXTBx90YVSHjpunklz4wu5VUgSMYlBJc6y7vP5VKIUAJIru35ra0qovqaJlgvmZKMBxNlrgKJy-MU9y2zXFwfiQWt_AjL0S9iLaYYdCKTtCinCpIamvnyDffFEvbsrosB06hR1yraibSfzgHShN7k_kElmt6inbsLydK1WkyW3KcopyA9OOQDPOid41z6558mGZvn9zIVp2VqS_l3d9kg6QkKNWnH4pdejxu0OV3juW3i1szTpreHfH2UJdcOF0_HA=w1077-h637-no" alt="" title="Music Video: Young M.A &#8211; RNID"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/05/04/music-video-young-m-a-rnid/" rel="bookmark" title="Music Video: Young M.A &#8211; RNID">Music Video: Young M.A &#8211; RNID</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/05/04/music-video-the-lox-loyalty-love/" rel="bookmark" title="Music Video: The LOX &#8211; Loyalty &#038; Love"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/fDkUzqhhzl8jHzDcZ5Jz8lhJOECSDqi6yZzcwqNlAhOdmmpvvgdnfAdmKrKe5l69Vuz4VjOCveEVDuNCCPhnJp877XOz55_DgnuCrJPji9ITQs9PEiPergrI3btHxYiz1L4COAopi9EA5guW3HWX_GhjzTr1ohWidefJ9rdhEQLaqPYpIsrwDJuLtYT5kOyw0pPiB9FwxNEDq3QJwtOwMIW33AyJoqKEFMVW-KofLyPb1mz9c4Dlrp_qnIhnxh4Md0pmyJNRujRG4AM3Tt0pjW7hbPfPCttUaWfH-Jcqlu_bQ7mj8AhE1Tg61HVBZ3gTrYb_UjS10xbqzUJ4Zd0PxOHPA_jAelnuJ0m6FRR1iOjy2rs4i6xgKOQi7HshMCnFbKjwEegtHQyat-Cd3ISOpKrH_1doOmkSV0S10U0blMuAzDfUKq6vOmBvLGnUeT8hTyD7zA-AtDQRDzBmdmxFG1HRFjMj3OyBduKx4d3Ba58zRHCYw1fbTL2BwQrA-FU8vQvgeLCUQg5KNNDvdzKOIA9fa5OJuTrV8tz9GkwsNOzKzFNfuH5twFovIIiHWAnFvNUvUJ3xRu_tHG6f1PktqzrbRlnb4_0x9H4aGMhLk6qEesTlxJ7suESEhlMeXZAryh5CdWdTD4QIfk00ZZjNDkAl_Op7f4imb19u71THdOXbPiaPxVsLJ6ba0BgFaQ=w1055-h758-no" alt="" title="Music Video: The LOX &#8211; Loyalty &#038; Love"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/05/04/music-video-the-lox-loyalty-love/" rel="bookmark" title="Music Video: The LOX &#8211; Loyalty &#038; Love">Music Video: The LOX &#8211; Loyalty &#038; Love</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/05/04/video-doja-cat-say-so-live-on-vevo-lift/" rel="bookmark" title="Video: Doja Cat &#8211; Say So (Live On Vevo Lift)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/IPgBvf2VZJEds6CbT6mtX98c_22UQw1PVvBd4-YUI9Roa090rrsiS6SHvBogUntoK585chHUH7B5hBS33yRQpAomPqqYg9M0TfgckqIj4b4gVAS4b4KWovzef7aIHcjQ3NngnvW6gzDnC-RVJZS79JwV_sVPC4aXNb7B_W8wqwKoba1762nEiV_OlM1iyQIBTTFvf0CM_F-bOCQ34IuX_r8W0QJySlFzENBO5weLRns_1XoJiiqwev8ihxJXch2p1mNG_62-GPooJiHQXNKRY58HvwWf8TLZbWe8RG1MtMcVQxftBJR5a7sjrdGP-ssKxSqFRMy9xTtz6AmZxtI-VwqtTyMlRcdO8j9D4O8vOjw6ASrIjzy7D2-u6cd81WfKYf26ytTXpHipUg53GQorkQDuVwx57YIFgor_6FYQOjF-uELM5kG6Ur001VJxIBN6EgRsepJ_QKeU39YBffV_fMIfSvCXkkEtg-cUUiratSqmXgXuCMIbnIaz-TveODzgDGxtlZX_2HECQkgvnemvmorF5tqKwcli3GMJsV0t45gk85PpZ0wvUhJcrA0s7GFwB9fKUeHISA9fnGO0mUtpK5NMg695Nt6qL2h-aI6-Aq7iaheyo6YzPLx9MnAvYiZ6yescMZ643GFAbZNwvYM6zZuQ5rKGaBOgSpJpKbCQg_7n-iuOmnOKf2GXl-s-0w=w1030-h758-no" alt="" title="Video: Doja Cat &#8211; Say So (Live On Vevo Lift)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/05/04/video-doja-cat-say-so-live-on-vevo-lift/" rel="bookmark" title="Video: Doja Cat &#8211; Say So (Live On Vevo Lift)">Video: Doja Cat &#8211; Say So (Live On Vevo Lift)</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/05/04/music-video-tee-grizzley-i-spy/" rel="bookmark" title="Music Video: Tee Grizzley &#8211; I Spy"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4e7BtRmJyn8B4HLjD5ir-9X48nI8SVc00D7jstYq-bjASbbsRgPq1sFrsFEMFWX33lAXrSRbKixS2s2po2MOUXSOatMFZDt1IcT_JlPLUq5lBgm1r-xPmbt_fb-FEnJ5mflBh74-t4Cnux8jR3jU69JhCx4eKhPkK1pDbQyeQn7yEWQ4rsRwClXc52lH2OqesV4JSinj60M3HkJ1e--B0mNZn5XEcWbfPP_pBmfMv0mbaZiBhmQtjdHG6BMcLQGDZmPWzsxRBEdQPMgjXpuLR8MQFGKgsk3DsIcZU1-B-klvUshdOrjCNMbdnRCmYyEZaevfhYv60_vxDv8P0X9Lay5-X1bQ4Vw3TJ_1dWFhyXNq3vYUyv-3V46aMmDaeHlti20tD50cr3QLFVHPELaN4_77hAr519V6FGifDadpFtOBPzEW15WLWoN3uDTEJ4BqUQRvmaYsFR8KEb0sOEZJ3GgncB4E52YYOepj2yL_ImZVJ43PqfDBwwpbs9OnPnP_bx7CySprDW7Sm21bMxdAVSV_LuUFOThNndUoqa4D6fUK-TVo__4E0nubZs5Xq9L01zbPcKU21JZO6yJKqQIRJHW7eH6JHxTaY9EZpcOj57ZA59FlpPB6qIXkpkPh8iTgqPSTeFRO8TOwIv7bmXh77KK1GBjzxPxlmS4SVmqTgRQROKvtmfvJGewAeTCsCA=w1077-h619-no" alt="" title="Music Video: Tee Grizzley &#8211; I Spy"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/05/04/music-video-tee-grizzley-i-spy/" rel="bookmark" title="Music Video: Tee Grizzley &#8211; I Spy">Music Video: Tee Grizzley &#8211; I Spy</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_5eb099e415010" data-td_block_id="td_uid_3_5eb099e415010"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_3_5eb099e415010" data-td_block_id="td_uid_3_5eb099e415010"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_4_5eb099e41c48d_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_4_5eb099e41c48d" ><script>var block_td_uid_4_5eb099e41c48d = new tdBlock();
block_td_uid_4_5eb099e41c48d.id = "td_uid_4_5eb099e41c48d";
block_td_uid_4_5eb099e41c48d.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"29","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_4_5eb099e41c48d_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_4_5eb099e41c48d.td_column_number = "3";
block_td_uid_4_5eb099e41c48d.block_type = "td_block_mega_menu";
block_td_uid_4_5eb099e41c48d.post_count = "4";
block_td_uid_4_5eb099e41c48d.found_posts = "1000";
block_td_uid_4_5eb099e41c48d.header_color = "";
block_td_uid_4_5eb099e41c48d.ajax_pagination_infinite_stop = "";
block_td_uid_4_5eb099e41c48d.max_num_pages = "250";
tdBlocksArray.push(block_td_uid_4_5eb099e41c48d);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_4_5eb099e41c48d" id="td_uid_5_5eb099e41f43a" data-td_block_id="td_uid_4_5eb099e41c48d" data-td_filter_value="" href="http://weuponithiphop.info/category/latest-news/">All</a><a class="mega-menu-sub-cat-td_uid_4_5eb099e41c48d"  id="td_uid_6_5eb099e41f5df" data-td_block_id="td_uid_4_5eb099e41c48d" data-td_filter_value="69" href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a><a class="mega-menu-sub-cat-td_uid_4_5eb099e41c48d"  id="td_uid_7_5eb099e41f7fa" data-td_block_id="td_uid_4_5eb099e41c48d" data-td_filter_value="80" href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a><a class="mega-menu-sub-cat-td_uid_4_5eb099e41c48d"  id="td_uid_8_5eb099e41fa0a" data-td_block_id="td_uid_4_5eb099e41c48d" data-td_filter_value="2189" href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a><a class="mega-menu-sub-cat-td_uid_4_5eb099e41c48d"  id="td_uid_9_5eb099e41fc1d" data-td_block_id="td_uid_4_5eb099e41c48d" data-td_filter_value="10" href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a><a class="mega-menu-sub-cat-td_uid_4_5eb099e41c48d"  id="td_uid_10_5eb099e41fe2c" data-td_block_id="td_uid_4_5eb099e41c48d" data-td_filter_value="130" href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></div></div><div id=td_uid_4_5eb099e41c48d class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/04/30/video-guapdad4000-ft-sir-boogie-bjrnck-rona-raps-episode-7/" rel="bookmark" title="Video: Guapdad4000 ft. SiR, Boogie &#038; BJRNCK &#8211; Rona Raps (Episode 7)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/XNBht5pilto-HlrtlvS94T-pC739XcPuRGJYURCUHGa1jKwwFZPWCs3TVD6H8tza7igUNJ8CYmslG3GWUUbrsHTMX4PCKrZRh0r3qegFe-aDrdlQ2XshNANJS2u0i1ya1nJWkdT1wIJxqBuFFG1azQyELU2pTTC0BzE_SCEtrQYlPW-N_DWxlYnUPi0O9aqr8TCZDvuBT02EiHZy55hJjNJvsLEipX39IMpSd22YiGb1ajPFJK3P-UZD3-Y8iGTC8xasDZO9inisLVHdbtYsBAHinpifD-CP0OjGUs_d4cQkJM63EdLeWj-RfgGM2GTpxvQrpFzq1HQ7cB3I1BqJeWxkGptG2iynOYYnQFvJpA198D7hkR9hz2ZAuYV_ieu-G9a4Ug9HmXMWCHdEQnwJT_Weik49hyM-B9kb0-K6UEXstSe9L3FFw9_FDuSs8Qd8y8W1kKj1BMU-gLEp_Viy7SLrjXO1gFi1o2H3XS1ngrLtn4xljwpGlEDLOBKmgmC7RBwWF0VCxxsEUusIL0Bma_syWXOJ8fkIWcNpAB5BsMbPw6gRGaNG2DoDOfTuma49POpqYJNieBMilniznoNuvm0wbZmnS2cywxyIfDKf1zHOh8ZhmUZUsKBEesP6HC_ZGMAmmYcg5-qso0XL0hGwZnGWtTuH0Uz7gzoF4SqZnqcT0ShNO8AQu9RFWVz3Kg=w500-h758-no" alt="" title="Video: Guapdad4000 ft. SiR, Boogie &#038; BJRNCK &#8211; Rona Raps (Episode 7)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/04/30/video-guapdad4000-ft-sir-boogie-bjrnck-rona-raps-episode-7/" rel="bookmark" title="Video: Guapdad4000 ft. SiR, Boogie &#038; BJRNCK &#8211; Rona Raps (Episode 7)">Video: Guapdad4000 ft. SiR, Boogie &#038; BJRNCK &#8211; Rona Raps (Episode&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/04/23/video-guapdad-4000-ft-kota-the-friend-wowgr8-ramriddlz-murs-rona-raps-ep-6/" rel="bookmark" title="Video: Guapdad 4000 ft. Kota The Friend, Wowgr8, Ramriddlz &#038; Murs &#8211; Rona Raps Ep. 6"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/mctRETI9ZkYBhJ6maBMIqUlfQyW841mKYmdWjpS6ASrudAei2zXEkZRL9cR8KrtYem_qC3TCDMZRoL_0jU-Mt862IWCvgzksreuf7pfkPeByor4jyXGJVOh_85w6rmkBEdjCdMNYvArSR8GDN5RSG3xFLk1mQtHPdvW1xGYs-kxeR8pddd5wpLz8Tlm4oQO9iGjwRaC1sSabDtLyXqF0rcz8jmtkLlUDqx3--4z898e6HZ-xbuStuk1BtWwK4F-K1111dCmTA0PT1toHmf4DzbWnQD6eAfZBjFvRcsdeArYEU2A_JsyvKMD_NR0KqOhx-jU3lYDZkr3S5Ks3EXnmIsIvhj38exSxWz-IoompEBQixXAqajV78NgWTl_LUNMy5Y3PVZpSZ8Mz1mkkEtMV2CrRPVB7jjw6O8kOwB5ZTXNTW931mN5zb0GvOguF_GWKV6Lm3mDD0ABWmsmLGXbWmtL1Z89u21HuIdlpED-_nCouEAQizxx3FfRJWBna88-BsEvotqxQGk6ByLQSye4-Q1F1CBu4HuHZXoFULE5kxNOOy0xxrxfuXn5tABPr_hoALWksni827IT5aWY5mEj1lW-FzsDYNjb7iSPLCKINI9-OcEaVDLVcNM5Y8z7E3B7yIj1C_e-QjKEAWY5jgjoUWDFEYfYNl7NM9U6sFhpRKBOaqYOjvD9zU31R3t_GJg=w594-h758-no" alt="" title="Video: Guapdad 4000 ft. Kota The Friend, Wowgr8, Ramriddlz &#038; Murs &#8211; Rona Raps Ep. 6"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/04/23/video-guapdad-4000-ft-kota-the-friend-wowgr8-ramriddlz-murs-rona-raps-ep-6/" rel="bookmark" title="Video: Guapdad 4000 ft. Kota The Friend, Wowgr8, Ramriddlz &#038; Murs &#8211; Rona Raps Ep. 6">Video: Guapdad 4000 ft. Kota The Friend, Wowgr8, Ramriddlz &#038; Murs&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/04/20/video-lute-gold-mouf-chronicles-episode-3/" rel="bookmark" title="Video: Lute &#8211; Gold Mouf Chronicles (Episode 3)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/lCFE6visT_3XAc03UscQrnn8ucTk8ck1g9kZDKLpFK5FngUUb6g1V3K8zPlzvGXHSNtf-I9l3xavRI7kboaOzZzmCFEluCoVg1M4b8Rbxbxr6EfTvw5RpdfVPoqTSGpotaHPXT2Az5aKUPBuONFixO_1lOdkMG27wBVhFdYFoBthNIyVwUtNChWySIVxyl6cqL0uP3vo2zfMdbwWecvJdSGIwJBSXeCJscIrvO_E6QWJAVd8a1JPckZFyP1X3efFDnfHK2ZsWE6fXGmRjbu0q03tA0C2KPPFIwSeVej0cgK9f5c4xnKp3xwie1v9CS0HcmCGAdfFSl86Xx3ie6XbVJdbEV3gDPCvTv3fSdfJ0Si7-oOJUVj-ZqKLi2bMZL6txpPOesWp4TPl2fmh4IJbLy-6SMJhOfA7VaFKVKKABubqf2Ehz10s-xtGRUefZ28ZisXZPp2xwx_kWhHfm5KjXfCSQE7lzMPKWLC7OZjgk79kCK4xhUh9zR0swdGVjLKM10Bh_79dGjZisFQD8hAJrDTiAUB6JgKfPPAk1ry88eoe6S8xL0zV0fWFAIpALVxW2VeQvDU_iq9Z6zh4nGKNjt6zhaC8f1AbdNvmbmE5xICr_6aTh-98yfB4mdzW9SWJ5fTkKtmxpphD8Im7x8O_omT0CoZ5JmYyz98KjkNVNYrNyalzc48unVDXSd_w0A=w1080-h607-no" alt="" title="Video: Lute &#8211; Gold Mouf Chronicles (Episode 3)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/04/20/video-lute-gold-mouf-chronicles-episode-3/" rel="bookmark" title="Video: Lute &#8211; Gold Mouf Chronicles (Episode 3)">Video: Lute &#8211; Gold Mouf Chronicles (Episode 3)</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/04/19/dababy-blame-in-on-baby-projected-to-sell-150k-first-week/" rel="bookmark" title="DaBaby &#8216;Blame In On Baby&#8217; Projected To Sell 150k First Week"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/nAZ5q9wi8PRAqy22gIlcwdF6DR_9B0xBG6LDSOwfgAbNtSr-LUtxRy0zbMBg_8mJGrEKPn19pz9H7tmQUwbLGYsfB-3yu19KqBoLcH194qa8xveNnRAkCTH-d0goBkt4O3xvCAavAdLbq_deJrIQ_-T45lJHEkSXwJyE3drxOptvKvmXqCuLGzq34dkGr84t_HQYJ8NPgF5u_1hoipQ-T4vi56tgE9TDJUvAKE9J9ngcFV2GwH4_gHAx5vk9iFWpwBYNEH5l_OwbObnvzU7WBJzqdH0FeWg9G8Tz_dimXJlqllY9YDk1b8m9GpPawzevP4c9ALjem5_dBp9a8d2kQuHk91t3hOL4w3GkDRa3hrXIcgXi9aMPN3RDeqej46Jl21wKNUHoFBDxmXi5jkcRiPFhWJ14QaimJCS9FFlUai83_4Tpue27JspKflI4tsspXdvEd-biiI6_21rkP6Hpc53xSU6sm0Aq-fOSMyBoT1-zHWXAiQQy-YSgHjAIt78dD-lr8l39_xMQFWXcGnS1RPrwvaI6VHFFOGRWrjLdlsNowsRZdMOdFHXQBE5fV_wYvclHDxEmmcDwrRazlxgyACr_SalzrEWCaAIiNMbTWiAVDTICMpiaBGl78khN7ugvJOImXyiKASpqVzxXoqwdZbMrJIiJBCliedYuH-VTXkAHgU3K3stZitMUc2BoCg=w767-h758-no" alt="" title="DaBaby &#8216;Blame In On Baby&#8217; Projected To Sell 150k First Week"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/04/19/dababy-blame-in-on-baby-projected-to-sell-150k-first-week/" rel="bookmark" title="DaBaby &#8216;Blame In On Baby&#8217; Projected To Sell 150k First Week">DaBaby &#8216;Blame In On Baby&#8217; Projected To Sell 150k First Week</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_4_5eb099e41c48d" data-td_block_id="td_uid_4_5eb099e41c48d"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_4_5eb099e41c48d" data-td_block_id="td_uid_4_5eb099e41c48d"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_11_5eb099e43bd0f_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_11_5eb099e43bd0f" ><script>var block_td_uid_11_5eb099e43bd0f = new tdBlock();
block_td_uid_11_5eb099e43bd0f.id = "td_uid_11_5eb099e43bd0f";
block_td_uid_11_5eb099e43bd0f.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"77","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_11_5eb099e43bd0f_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_11_5eb099e43bd0f.td_column_number = "3";
block_td_uid_11_5eb099e43bd0f.block_type = "td_block_mega_menu";
block_td_uid_11_5eb099e43bd0f.post_count = "4";
block_td_uid_11_5eb099e43bd0f.found_posts = "158";
block_td_uid_11_5eb099e43bd0f.header_color = "";
block_td_uid_11_5eb099e43bd0f.ajax_pagination_infinite_stop = "";
block_td_uid_11_5eb099e43bd0f.max_num_pages = "40";
tdBlocksArray.push(block_td_uid_11_5eb099e43bd0f);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_11_5eb099e43bd0f" id="td_uid_12_5eb099e448040" data-td_block_id="td_uid_11_5eb099e43bd0f" data-td_filter_value="" href="http://weuponithiphop.info/category/fashion/">All</a><a class="mega-menu-sub-cat-td_uid_11_5eb099e43bd0f"  id="td_uid_13_5eb099e44813a" data-td_block_id="td_uid_11_5eb099e43bd0f" data-td_filter_value="76" href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></div></div><div id=td_uid_11_5eb099e43bd0f class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/LVT4Mid8WL4wHUdO9X2OZmZxxgbREs2lVtszOdEBaO6hJB0JS3yQOAyhNSdCyPmv0amBDTgNGpOlRPXPjKCl6yIlo2joyH3rQRI7CUdX09BJtQI1r5jy1_7BQtDhw4AxUhpUwIh35rNS3lTy7uq-FdPff10JN6srr9mwZ7zr04GQFxBVEXwCfC5rNVehXhY_wGCRVsmevYmdkBWEmB8dvOzBHY78NBBjcHNArS_S-2M0FJgDh8v9m9vEh78k_XmZg-AERctsf0bkODuPi1EcNJq_RnJIV6b0GG-VtKjo-OVPmYghWJYf1HiP9c58cQ98oABU8BDFdLqsBtNt4K0NmyHYQlX39W9k_d83wEHZ1-EacQa2o01VrYSn12HnZ1l88fMzu9PKv6EGmcRZNwpepycW7_9EQnhxIPDdVCmRLXUasUED9OXr-zJmnBcnSnLCa06k1ZymQym1LiSFEv1c3aPHnmnD3GY8nL7q5jPJr4HsABR0WCqMebcF3HF_0deNd0zgRBCGMxW-VzlIIHZiHuBeSPEPvUL149GJ5swSSvKm1uGEi1HlLBj9omJSU7mDWzO0p_7l-l7-4_ureEsGsgB8cX1t8t2TQcFeRgqqF1CXlZFYYC2K0iMb4jPsijsw_rtO7pmKvbngqHfgYpGeh_qLmDWeicR7=w1195-h796-no" alt="" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch">Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/fHEwwMf8DoiXlqkfibQS1Z1XXbviORbV9raaI44tOTXrWo7GgqM3gA-vswE10gFtTQUGGwNG7nWAACwHjxPuiubliYBN_dqtBZh2WIpxvumiJ-hSLK0TNWB2cB8Iw2STT5gcp_KqlDh_e4xng1vidI8EXdp_ooh5uDI-JV1HQ9dGnM5nxl_b-v8znqj-Rl_mGB7y4Lu9zsFNWHU7SriqQQJaKrKEEnb9T8zxmGLaL0zq7ilYpnUEhWulDDr9xc82wdr__WzRBm5YEskVpDAnGM2NDZwTZpjbe4QDdxeixWnSXNK_oDzaL7WTbCpkD33OK88BlI5JmFRQ5VmD11UQ2htB7-9WoahHvb4XmBsbLXpEMl1JmEP4sPx06VduzFnBNo-J90WI0n1AEIIcEYVbRywrkGJXbzmH__In9ZIg0EV24OcGGbeKl12HxTdZwucqsNnuZeNjiMHISQ7i8cfzm3N7X7Zenl74zsKIKeKWoIGxh6MTlVADvgHcrHebnjcSgil2vBeFyz_AP45aOv9SOwbzfVLGS0CNfe1s9b2J7qZgjcBk9QPEXCl2kygvzmGXFvU_3xBuW6S0i3Vkh3Ha_3hPBtvIAy3WoTK2yiqS41HzSK7yk3FRAlBtpIEib338fdkTiosBxtdu36SdNUVM75zl6CVIFhTu=w681-h470-no" alt="" title="Air Jordan 14 Rip Hamilton"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton">Air Jordan 14 Rip Hamilton</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/kUjaOYxjEkAh34S-Ub2QSZwdOwHyFnGFLBZULta3_bn1_myPMAwJXiEEsAAtc1ktCQwHCuKhSqSYsWXFBEIZxdfKuykoDEZWwO-dDI3_JeAshbYvyILEHUu0XaUpRn0mj7gOx10V52t8gRGYPCW7QXGImkPGGhvBPzBDVVqh9lKGtkuPeePmTnpRSmwp0LG1WHcIzUWnMqPBWQeHAat6Q-Tq7niXNb96ddEZsMEdHK1nmHVlNaeqFBNtTxk6yYRkFNCvtfBayqy-Rqt4CPU5tThxbTI4AIUCI6JLxJd_VJizrVNDEe2xZ_tiQdkC5ASIoHpX8sfvAB8zRUsMVJ6oMUt5FH_4GBNXDCtFRmr65Qt0JV1h4bBJffu2L272Q_vpD76wn-YNGW8VCtZcheHu_X-A4gdYQEC0HN0BenY-MOuUBqKEjXAc0SxWeP7W9RN55jlqUFK0nzEYydVjec2stdQIngVfg_FvKxvHXfM4XdtMpqeJnp3Pzyk8xjz30sAZd0f2HQ6zfdPjk-OkV2-WrC0_qW0L8Rq3zrUbq52n3BN7gm7sctU_CUlBmoQIgJDQBYk1Siv4tfSq9pL1R4GdaOlWQdxEuhZi8bTYC8GGAgNGl3SMAZGvk7nu6QnnwEZjZ7mZwbcqgyRKa89cOREMUvIkVJ8Q8lZu=w926-h672-no" alt="" title="Jordan Proto React Triple White"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White">Jordan Proto React Triple White</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4cDUjSODZSaXWfHyZKb9q3Fn7FHA4uB0KSBs0MtFHC0dc6AJb1zeAl_X2LOKalK9C7VBFhTqRQ9fw1ESgUr9ZUKFbOzD94i_s96nvkICOqrsYnzrE2nEAQHoEaGOF4O8GAI6T4CGFbgcQhNzjpRlSY60NyPu5Cmq81FRpEOFRzTOtSa_NnWzMmfwO0yxtPbcg5U6YBUsus8shv3SA7CjULLfaP38nZAuWVgq8PMaaeCQ_eSrK8NJSEVQjyyxmqb-1I7zO8Kvvzvwi--ibMr52CF8h-GusBzSq5ZuzvZRCGu_u8CyfoXw7pwWbOmHnLOdcQ9d2PCSW_IxEMGfmEuU7NxMSsW3Ga4r35_wLB7cjvlPC9OjCV50tfekXjZBS_476mzlf4G9jR7Ju1GqgjXah9Uqc_0Y8N-Br8_JCtIlRSuLxAiebwd7AvFVlgWId9MYxBWnRT3cTyD8SH7q5WwO-CIbKAOSKsNcrrTgFxQvqn9yklBU1u5X5fdTlTBk4WSYorsWZAug0z9BOymRLnrhTbnA0vpBPFROWD-aL1glg-eUpFSfgD4xhWsOqJNY9krQ2UbLSGXQ5gYWj0ovLS7Yz3UKFY2qrVWpqkpbfyN98es9NJ-7LTUs2MLq1rX_2FaQmyq5mVndd7VGzQOHy9hDULG-5H-0LvGd=w900-h566-no" alt="" title="adidas Yeezy Boost 350 V2 Hyperspace"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace">adidas Yeezy Boost 350 V2 Hyperspace</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_11_5eb099e43bd0f" data-td_block_id="td_uid_11_5eb099e43bd0f"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_11_5eb099e43bd0f" data-td_block_id="td_uid_11_5eb099e43bd0f"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div></div>


<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form method="get" class="td-search-form" action="http://weuponithiphop.info/">
				<div role="search" class="td-head-form-search-wrap">
					<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>            </div>
        </div>
    </div>

    <div class="td-banner-wrap-full">
        <div class="td-header-container td-header-row td-header-header">
            <div class="td-header-sp-recs">
                <div class="td-header-rec-wrap">
    
</div>            </div>
        </div>
    </div>

</div>
<article id="post-38207" class="td-post-template-7 post-38207 post type-post status-publish format-standard has-post-thumbnail hentry category-music-video tag-jadakiss tag-sheek-louch tag-styles-p tag-the-lox" itemscope itemtype="http://schema.org/Article">

    <div class="td-full-screen-header-image-wrap">

        <div class="td-container td-post-header">
            <div class="td-crumb-container"><div class="entry-crumbs"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="" class="entry-crumb" itemprop="url" href="http://weuponithiphop.info/"><span itemprop="title">Home</span></a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="View all posts in Music Video" class="entry-crumb" itemprop="url" href="http://weuponithiphop.info/category/music-video/"><span itemprop="title">Music Video</span></a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last" itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><meta itemprop="title" content = "Music Video: The LOX &#8211; Loyalty &#038; Love"><meta itemprop="url" content = "http://weuponithiphop.info/2020/05/04/music-video-the-lox-loyalty-love/">Music Video: The LOX &#8211; Loyalty &#038; Love</span></div></div>

	        <div class="td-post-header-holder">

		        <div class="td-parallax-header">

	                <header class="td-post-title">

	                    <ul class="td-category"><li class="entry-category"><a  href="http://weuponithiphop.info/category/music-video/">Music Video</a></li></ul>	                    <h1 class="entry-title">Music Video: The LOX &#8211; Loyalty &#038; Love</h1>

	                    
	                    <div class="td-module-meta-info">
	                        <div class="td-post-author-name">By <a href="http://weuponithiphop.info/author/cyclone/">cyclone</a> - </div>	                        <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-05-04T16:29:13+00:00" >May 4, 2020</time></span>	                        	                        <div class="td-post-comments"><a href="http://weuponithiphop.info/2020/05/04/music-video-the-lox-loyalty-love/#respond"><i class="td-icon-comments"></i>0</a></div>	                    </div>

	                </header>

		            <div class="td-read-down"><a href="#"><i class="td-icon-read-down"></i></a></div>
		        </div>
            </div>

        </div>

        <div id="td-full-screen-header-image" class="td-image-gradient-style7">
            <img class="td-backstretch" src="https://lh3.googleusercontent.com/fDkUzqhhzl8jHzDcZ5Jz8lhJOECSDqi6yZzcwqNlAhOdmmpvvgdnfAdmKrKe5l69Vuz4VjOCveEVDuNCCPhnJp877XOz55_DgnuCrJPji9ITQs9PEiPergrI3btHxYiz1L4COAopi9EA5guW3HWX_GhjzTr1ohWidefJ9rdhEQLaqPYpIsrwDJuLtYT5kOyw0pPiB9FwxNEDq3QJwtOwMIW33AyJoqKEFMVW-KofLyPb1mz9c4Dlrp_qnIhnxh4Md0pmyJNRujRG4AM3Tt0pjW7hbPfPCttUaWfH-Jcqlu_bQ7mj8AhE1Tg61HVBZ3gTrYb_UjS10xbqzUJ4Zd0PxOHPA_jAelnuJ0m6FRR1iOjy2rs4i6xgKOQi7HshMCnFbKjwEegtHQyat-Cd3ISOpKrH_1doOmkSV0S10U0blMuAzDfUKq6vOmBvLGnUeT8hTyD7zA-AtDQRDzBmdmxFG1HRFjMj3OyBduKx4d3Ba58zRHCYw1fbTL2BwQrA-FU8vQvgeLCUQg5KNNDvdzKOIA9fa5OJuTrV8tz9GkwsNOzKzFNfuH5twFovIIiHWAnFvNUvUJ3xRu_tHG6f1PktqzrbRlnb4_0x9H4aGMhLk6qEesTlxJ7suESEhlMeXZAryh5CdWdTD4QIfk00ZZjNDkAl_Op7f4imb19u71THdOXbPiaPxVsLJ6ba0BgFaQ=w1055-h758-no">
        </div>
    </div>

    <div class="td-container">
        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    

    <div class="td-post-content">
        <p><img class="aligncenter size-full" src="https://lh3.googleusercontent.com/fDkUzqhhzl8jHzDcZ5Jz8lhJOECSDqi6yZzcwqNlAhOdmmpvvgdnfAdmKrKe5l69Vuz4VjOCveEVDuNCCPhnJp877XOz55_DgnuCrJPji9ITQs9PEiPergrI3btHxYiz1L4COAopi9EA5guW3HWX_GhjzTr1ohWidefJ9rdhEQLaqPYpIsrwDJuLtYT5kOyw0pPiB9FwxNEDq3QJwtOwMIW33AyJoqKEFMVW-KofLyPb1mz9c4Dlrp_qnIhnxh4Md0pmyJNRujRG4AM3Tt0pjW7hbPfPCttUaWfH-Jcqlu_bQ7mj8AhE1Tg61HVBZ3gTrYb_UjS10xbqzUJ4Zd0PxOHPA_jAelnuJ0m6FRR1iOjy2rs4i6xgKOQi7HshMCnFbKjwEegtHQyat-Cd3ISOpKrH_1doOmkSV0S10U0blMuAzDfUKq6vOmBvLGnUeT8hTyD7zA-AtDQRDzBmdmxFG1HRFjMj3OyBduKx4d3Ba58zRHCYw1fbTL2BwQrA-FU8vQvgeLCUQg5KNNDvdzKOIA9fa5OJuTrV8tz9GkwsNOzKzFNfuH5twFovIIiHWAnFvNUvUJ3xRu_tHG6f1PktqzrbRlnb4_0x9H4aGMhLk6qEesTlxJ7suESEhlMeXZAryh5CdWdTD4QIfk00ZZjNDkAl_Op7f4imb19u71THdOXbPiaPxVsLJ6ba0BgFaQ=w1055-h758-no" width="1055" height="758" /></p>
<p>As they celebrate 25 years in the game, <strong>Jadakiss</strong>, <strong>Sheek Louch</strong> and <strong>Styles P</strong> premiere the official video for their single <strong>“Loyalty &amp; Love”</strong>. Off of their upcoming album also titled <em><strong>Loyalty and Love</strong></em>,</p>
<p><iframe src="https://www.youtube.com/embed/O_KeW-JXktY" width="700" height="400" frameborder="0" allowfullscreen="allowfullscreen"></iframe></p>
<div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="http://weuponithiphop.info/2020/05/04/music-video-the-lox-loyalty-love/" data-a2a-title="Music Video: The LOX – Loyalty &amp; Love"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2020%2F05%2F04%2Fmusic-video-the-lox-loyalty-love%2F&amp;linkname=Music%20Video%3A%20The%20LOX%20%E2%80%93%20Loyalty%20%26%20Love" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2020%2F05%2F04%2Fmusic-video-the-lox-loyalty-love%2F&amp;linkname=Music%20Video%3A%20The%20LOX%20%E2%80%93%20Loyalty%20%26%20Love" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2020%2F05%2F04%2Fmusic-video-the-lox-loyalty-love%2F&amp;linkname=Music%20Video%3A%20The%20LOX%20%E2%80%93%20Loyalty%20%26%20Love" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2020%2F05%2F04%2Fmusic-video-the-lox-loyalty-love%2F&amp;linkname=Music%20Video%3A%20The%20LOX%20%E2%80%93%20Loyalty%20%26%20Love" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_tumblr" href="https://www.addtoany.com/add_to/tumblr?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2020%2F05%2F04%2Fmusic-video-the-lox-loyalty-love%2F&amp;linkname=Music%20Video%3A%20The%20LOX%20%E2%80%93%20Loyalty%20%26%20Love" title="Tumblr" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_reddit" href="https://www.addtoany.com/add_to/reddit?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2020%2F05%2F04%2Fmusic-video-the-lox-loyalty-love%2F&amp;linkname=Music%20Video%3A%20The%20LOX%20%E2%80%93%20Loyalty%20%26%20Love" title="Reddit" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_flipboard" href="https://www.addtoany.com/add_to/flipboard?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2020%2F05%2F04%2Fmusic-video-the-lox-loyalty-love%2F&amp;linkname=Music%20Video%3A%20The%20LOX%20%E2%80%93%20Loyalty%20%26%20Love" title="Flipboard" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=http%3A%2F%2Fweuponithiphop.info%2F2020%2F05%2F04%2Fmusic-video-the-lox-loyalty-love%2F&amp;linkname=Music%20Video%3A%20The%20LOX%20%E2%80%93%20Loyalty%20%26%20Love" title="Copy Link" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div>    </div>


    <footer>
                
        <div class="td-post-source-tags">
                        <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="http://weuponithiphop.info/tag/jadakiss/">Jadakiss</a></li><li><a href="http://weuponithiphop.info/tag/sheek-louch/">Sheek Louch</a></li><li><a href="http://weuponithiphop.info/tag/styles-p/">Styles P</a></li><li><a href="http://weuponithiphop.info/tag/the-lox/">The Lox</a></li></ul>        </div>

                <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="http://weuponithiphop.info/2020/05/04/video-doja-cat-say-so-live-on-vevo-lift/">Video: Doja Cat &#8211; Say So (Live On Vevo Lift)</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="http://weuponithiphop.info/2020/05/04/music-video-young-m-a-rnid/">Music Video: Young M.A &#8211; RNID</a></div></div></div>        <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="http://weuponithiphop.info/author/cyclone/">cyclone</a></span></div>        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="cyclone"></span><meta itemprop="datePublished" content="2020-05-04T16:29:13+00:00"><meta itemprop="dateModified" content="2020-05-04T16:29:13+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://weuponithiphop.info/2020/05/04/music-video-the-lox-loyalty-love/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png"></span><meta itemprop="name" content="WeUpOnIt"></span><meta itemprop="headline " content="Music Video: The LOX - Loyalty &amp; Love"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://lh3.googleusercontent.com/fDkUzqhhzl8jHzDcZ5Jz8lhJOECSDqi6yZzcwqNlAhOdmmpvvgdnfAdmKrKe5l69Vuz4VjOCveEVDuNCCPhnJp877XOz55_DgnuCrJPji9ITQs9PEiPergrI3btHxYiz1L4COAopi9EA5guW3HWX_GhjzTr1ohWidefJ9rdhEQLaqPYpIsrwDJuLtYT5kOyw0pPiB9FwxNEDq3QJwtOwMIW33AyJoqKEFMVW-KofLyPb1mz9c4Dlrp_qnIhnxh4Md0pmyJNRujRG4AM3Tt0pjW7hbPfPCttUaWfH-Jcqlu_bQ7mj8AhE1Tg61HVBZ3gTrYb_UjS10xbqzUJ4Zd0PxOHPA_jAelnuJ0m6FRR1iOjy2rs4i6xgKOQi7HshMCnFbKjwEegtHQyat-Cd3ISOpKrH_1doOmkSV0S10U0blMuAzDfUKq6vOmBvLGnUeT8hTyD7zA-AtDQRDzBmdmxFG1HRFjMj3OyBduKx4d3Ba58zRHCYw1fbTL2BwQrA-FU8vQvgeLCUQg5KNNDvdzKOIA9fa5OJuTrV8tz9GkwsNOzKzFNfuH5twFovIIiHWAnFvNUvUJ3xRu_tHG6f1PktqzrbRlnb4_0x9H4aGMhLk6qEesTlxJ7suESEhlMeXZAryh5CdWdTD4QIfk00ZZjNDkAl_Op7f4imb19u71THdOXbPiaPxVsLJ6ba0BgFaQ=w1055-h758-no"><meta itemprop="width" content="800"><meta itemprop="height" content="600"></span>    </footer>

    <div class="td_block_wrap td_block_related_posts td_uid_15_5eb099e454b42_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_15_5eb099e454b42" ><script>var block_td_uid_15_5eb099e454b42 = new tdBlock();
block_td_uid_15_5eb099e454b42.id = "td_uid_15_5eb099e454b42";
block_td_uid_15_5eb099e454b42.atts = '{"limit":6,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_custom_related","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_15_5eb099e454b42_rand","offset":"","css":"","live_filter":"cur_post_same_tags","live_filter_cur_post_id":38207,"live_filter_cur_post_author":"1"}';
block_td_uid_15_5eb099e454b42.td_column_number = "3";
block_td_uid_15_5eb099e454b42.block_type = "td_block_related_posts";
block_td_uid_15_5eb099e454b42.post_count = "6";
block_td_uid_15_5eb099e454b42.found_posts = "58";
block_td_uid_15_5eb099e454b42.header_color = "";
block_td_uid_15_5eb099e454b42.ajax_pagination_infinite_stop = "";
block_td_uid_15_5eb099e454b42.max_num_pages = "10";
tdBlocksArray.push(block_td_uid_15_5eb099e454b42);
</script><h4 class="td-related-title"><a id="td_uid_16_5eb099e457a3a" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_15_5eb099e454b42" href="#">RELATED ARTICLES</a><a id="td_uid_17_5eb099e457a78" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_15_5eb099e454b42" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_15_5eb099e454b42 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/05/02/new-music-styles-p-mind-power/" rel="bookmark" title="New Music: Styles P &#8211; Mind Power"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/_YCFMqA4DAEG82BRxuWdRlQ033_L7wA2c9cdKsPFsHzOVnRELrnR13wtv93ObbRNo4LSt3qhtn2YloBtJqr8oRepsEKAr7KRkLOpvN7V8elfwGLa-9MTpeXs7Hklzs-Oz7kjdYcb1ATtAd_zYSvAgfwt-Vgy9QULVBNfhLUX4eigNVe71wGU9sMUZjHtpelBCSfxI4xXwPE1A5KC09VeBGMJ-BuiHdUOWSgQNzxPkdN7-BnsaI8dIXkXyHtLmUPhh0u6ngQY5C26Rcbk6f6_HvfZQu_pq6JGQBFIgf7tGeZcLQmxli7cu9ZwLC2qM-w7X5L8QIK1BwdiabTYAiq2EfMLMKsWf_JCDYIfEA2nMnpPsl0FIfKV5YGYxOZIU8ObWTc-LhAqYsDgq-gVp9fDxARCKbktgKrBai28fLoraySCHJgjR2tD0AhGU3jF_UWr9Smq0KG1cLJY5Hx28y8XC048AyQePzgonjURLXFqH4M3JqRzhWuRWBSR31kp1rS6qX176UOhGngO_YMP71Bf_A_Sh3GEn7kq97wlofUbLzDAzvb6A6EWFd2StLHdLrIezjJJegR85sSueVSx7NEHdNoMG982renY0UT75xp3riXc34YYide-gj4847LNk38s8uf-Fg6F4rABlfPD5DQ8sXabzr00RUwXASN5MlXwEPmULy4AkrttqLOTOUiH5w=w756-h758-no" alt="" title="New Music: Styles P &#8211; Mind Power"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/05/02/new-music-styles-p-mind-power/" rel="bookmark" title="New Music: Styles P &#8211; Mind Power">New Music: Styles P &#8211; Mind Power</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/04/04/new-music-the-lox-loyalty-love/" rel="bookmark" title="New Music: The LOX &#8211; Loyalty &#038; Love"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/_0ZO-dl_s1uWRF1CeHK_hX8HuJSjhNj0ApudosMehyzWoxbW9JE1htu2z4MYh23Cze9XuMlBZXkaBJugp9k_JAVjQ8uclD8P-dqec3HshYVDLLc-Fd6QLhvKGgfRNzi2EkhTZaOSzLQ14iPoscwfLo4tc_9GPVaJdHDULTurDE1S2lGpTgG5BsFRKujCMbFfpZ6vsoTV0m80ciR8ijVHqsiVU0y9vF4i62TBRdXa90vkWewwxZRYmKFMrC2kyHScrbUKsgPQdWnR3ZN1xp8W6YyBuJ3hhKPItdPO4N4F89jkabuZQPQtyaaRVX0Pc-HkipVKt1jpXWurquEPtX0gmubN41RmjFHqUQwMnbrCimlih5diRhto7s1w7eGxU9TvjAxkBdZeb833McPPoia9kDpqJSt9SCdRwR5OXrKGcSGhS2yt-sFmZAUkrioO9kQUbVeS8actvJ-T3ZPLgvnIFenGngpJ9_iksKrAKynkWoMbRZ8OQmBTDLWLS3ILb3Wwi_kA3kMD13QH4WT4gSWYbnm9OHLowSsizXvHpDKBaJ-giuTII_g9ETQcl8nv1oHEsUjExYAcgtcD946GfaxoNolyBoqrcJQOzZfDkaNlBXDgE7OUruU1XwQEzxZSdDE_Y1dchJtXozj0cV6_TY6e3bguDs_SE9Yy7upsoFVd8d3zFtHigLBOGGdwaElHEw=w753-h758-no" alt="" title="New Music: The LOX &#8211; Loyalty &#038; Love"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/04/04/new-music-the-lox-loyalty-love/" rel="bookmark" title="New Music: The LOX &#8211; Loyalty &#038; Love">New Music: The LOX &#8211; Loyalty &#038; Love</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/13/music-video-dj-kay-slay-ft-jadakiss-queen-latifah-bun-b-living-legend/" rel="bookmark" title="Music Video: DJ Kay Slay ft. Jadakiss, Queen Latifah &#038; Bun B &#8211; Living Legend"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/iC9mJOHAeK7stPF6nmLvzEBSKdeixHzXCyGIyhaBArmib0yYYuCzqcL_q7TiYk2DadqKvIAZHKB13VDAFEkw01osJTSUpSHIVg_f35iCbaRwat9wXkZv8iBqJtfXG0TVCC_-RO0wXEqSP2REarnvU-K6rYkfvwn5hBWUlZjzn_d0aJDpVx1s2s3zzq5Q6LhU32r7slV6UWvCWYNIT-RXd52EOYSgSVUyWlaDBKB8QtgsgL9fooQlMKfFcs_FeHUBh_wzfkP3MnTyBBIAdWaHA7zIaR6PYXnmnvXKtMESDXiPLs_4grqaplUKQWnC2V9tGVRTCPfzWGFOIwiJ4UvA7_foHYyiEDZ5JzXYIzPWmcsmTqFDBZfA99tk3791r7QZWO_65Ywbvbkmrd6rOuh7RQyMssAusRGMyAtE1DTEFW34OEROk1_zAk6bc0VFYiJ0UWrC_eNltqy03Ke0ijMHrTxculmU3nQrOj9RJvjA5lrzt__TpOMDMhSx9BRarTJwGiwwrU7EyK4TAv0dsvpNghH4ycZl69rOCG6YHhnPmqDe2av9KKmMrywytQacV_3nbfIiQ58vvdwVdQbXdl_h-7W07h44oDVL9mU6h9bG1Zh7X9y9MuYuPjcPJBOfV8wrvAZzIq36grI6XuuK20g5jWrFQcPNCNPZXoEULZChAUzkHkZ841kYgMxJ=w776-h478-no" alt="" title="Music Video: DJ Kay Slay ft. Jadakiss, Queen Latifah &#038; Bun B &#8211; Living Legend"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/13/music-video-dj-kay-slay-ft-jadakiss-queen-latifah-bun-b-living-legend/" rel="bookmark" title="Music Video: DJ Kay Slay ft. Jadakiss, Queen Latifah &#038; Bun B &#8211; Living Legend">Music Video: DJ Kay Slay ft. Jadakiss, Queen Latifah &#038; Bun B &#8211; Living Legend</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid-->

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/12/music-video-jadakiss-ft-pusha-t-huntin-season/" rel="bookmark" title="Music Video: Jadakiss ft. Pusha T &#8211; Huntin Season"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/KXVowcYouYU0Bt23YGpXK2HPwqiL-PjZwYGCwf8O9UN1k9Bm3yvI57Wb2ruTyVn-1oRK0iK6pY7FUsL_BgByNjDfH1TgXxDyiH3S0Nm--Rwj8Mqn2QiI3yuZyJ7tVlQr1Mx1yBe3ACJ6CrGACm9GnVDGtZuUvSJVZGpem4d7TaVdPLal2QjRtB4r1EaTRHkuCjRdfGjIN7CutuGAE6up_psx7iqqC8Ej9Bs_h5GIwG6-8AJpYCerPBq8neZKpUZEcC0-pdy_ujtf-lyJ2tRz7EPgyN_8iTlqBPz9FW1IROjJ-bbPteuKg4a7XwQtMnhf2GOeRgXYhpVah2i2cX22zOA8AJZn7-OPeSCkV9rTw82jZkjZnErRFxRQx7poTdmsY-a1E-lIrJnmS9KlGNRxvN8y3aMn03DAlPnf4ymp7UYbvwshy4kv4QSZWVD-qpzo5mFpJqdSIra_D-gJkKQfMCsACYdriU7GYnjiA-KJCWQItOP93S7VErbp4F1-vtx0DZvvxg6Abrh_R69DivdOTpg412DFxgMtbj6ofkRjSf9kALwfDTiVR-0DZV40sW_CLbAQX9ONdlGc8-NzCa4gHtEBClA6K3ED4IAX-nk-LnqVYurg76RXvBvgnQ_kk4RXoT4ONCZ9UPAT4p6Fa20UTycQL2W6OG1W81QveDMGh3ILBeG1O3c_tpV5=w800-h400-no" alt="" title="Music Video: Jadakiss ft. Pusha T &#8211; Huntin Season"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/12/music-video-jadakiss-ft-pusha-t-huntin-season/" rel="bookmark" title="Music Video: Jadakiss ft. Pusha T &#8211; Huntin Season">Music Video: Jadakiss ft. Pusha T &#8211; Huntin Season</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/06/album-stream-jadakiss-ignatius/" rel="bookmark" title="Album Stream: Jadakiss &#8211; Ignatius"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/IFDXmd0kxYBMBWxWNmjOWHVP5wpvCSguULsPZPSuo9Cub9YJa2WFxWMqsrbXgvihbC92BksAqz1eau-jJWE5SQ7bKH2UdKhV9kOftVUfIsBUStRDcA94uEGjRbBBhm4sIVaAsrsQe8Q503nBuj1z6w-P4VQh-uOD7FnZrZ-rxzXluqDmGruO0HqFoI9zXOwZE1ZqKVo_oMngPg7iUeaOkF_UsVRSZIWvfP77CUc6Df74IvHhjyuPu4K5tpAzQM6UMihGDdEUrZdB_L0q4XJPJ40qBDPHxOY7Efy77oUQwk4CpZxJvEgI5xvAxOFduBwfJ7y_gZo8mYdKTM3MpqyOVwbzdYGbPwF6PBoDtIHNYftOAJ7G1bVFXlWR0hQGOag2xRWGhEgg2lHPx8RuH_XgHTIOSZ7dvdtDBhXqQ6neKka4BVRWxe6QWs8yK3HR25vSL_IhChZRnQmVNVHB72n9jYIU2J13LFbvso3Ij8Zd13tT6tJ3e5EBlmf48w7lEzQmBPBJDvqySykHgaGCnxO5GPQM7attXZhqJElBXO1l_Vori0mA8OO5Q4sYspWwmgXMWNAgwmIxXQzHOTcI0j7upyT2fYcz04pH-o1YFq4QOd7lQUiFLXlEumjiBi4zdHveWMMqAFHR0cdJ8J1arX-ycjMdyaW-Zuxs_1ol2eOwnXSQtUhxq_3WgNYx=s500-no" alt="" title="Album Stream: Jadakiss &#8211; Ignatius"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/06/album-stream-jadakiss-ignatius/" rel="bookmark" title="Album Stream: Jadakiss &#8211; Ignatius">Album Stream: Jadakiss &#8211; Ignatius</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/03/05/jadakiss-ignatius-tracklist/" rel="bookmark" title="Jadakiss &#8211; Ignatius (Tracklist)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/7OjWRyMdHVtDohfEDq-LGcuG3jZ8evieILWHWHYDuADUUJmSBdPyuTPcDrhXYbPa5uM6C27KThmUvfh4NgjIiaDo7Eyh6Di2Ve-3JlR75wAn1Jkrqva_EAz8LX06IovvumZj1olhiozaijUmHCG1c86LtM-1-mv-z-6cmXENdvLptL8FFTQdI2dxrEviEI6HgMNVZ8M46REUHZBWN3_GX_d8yOr1baunjUnDiK_tGKa3kz5_sUxyheXjVrGkQXjGdm1H-up1W6UbN15tvWGZHx893nC2YZ1uusrBLmHU4xBNVmmacMKMG5Ef1fmNRv7n4ZxyGbnsch-v5JT8Nw711TI8_pS1pc5FhXRvvJjixvdeXS-Fj6xC0YHYWsC_ltvX0Vfx6r9xGuV6GoN4XLJJOaOW4CFLA0N1iAsY2ELEDd5rboPmHFMwjUDYk1WrzitQn9pBSP0Rwdkn4z-4fAKikNoUIu_BoUyCa79bYD5uC2VOpGabrvsSztPGvD4yhHDscDmqfUWI4kqC2-yL_IBOgPsm6uijcGMVqHiTA7yFOnTSswGApxZQKnspqXKcjT3RxUi_hjrVpCYZH8DvG_PRdQoami9iwpiOV4t8lwnKy0Exc7BNbYf_bR6qf9rXzgxHDkrkl9N9a-QsxvubmK6B-FB-E9f9oYU3t9HB0Jcopyr33Zc9f1v75L43=s500-no" alt="" title="Jadakiss &#8211; Ignatius (Tracklist)"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/03/05/jadakiss-ignatius-tracklist/" rel="bookmark" title="Jadakiss &#8211; Ignatius (Tracklist)">Jadakiss &#8211; Ignatius (Tracklist)</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_15_5eb099e454b42" data-td_block_id="td_uid_15_5eb099e454b42"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_15_5eb099e454b42" data-td_block_id="td_uid_15_5eb099e454b42"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->

	<div class="comments" id="comments">
            </div> <!-- /.content -->
                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <aside class="widget widget_search"><form method="get" class="td-search-form-widget" action="http://weuponithiphop.info/">
    <div role="search">
        <input class="td-widget-search-input" type="text" value="" name="s" id="s" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit" value="Search" />
    </div>
</form></aside><aside class="widget widget_text">			<div class="textwidget"><h4><strong><span style="color: #8224e3;"><span style="color: #000000;">Listen to</span> <span style="color: #c60000;">WeUpOnItRadio</span> <span style="color: #000000;">Live!</span></span></strong></h4>
<p><span class="cc_streaminfo" data-type="song" data-username="cyclone777">Loading &#8230;</span><br />
<script language="javascript" type="text/javascript" src="https://control.internet-radio.com:2199/system/streaminfo.js"></script><br />
<iframe src="https://tunein.com/embed/player/s292400/" style="width:100%; height:100px;" scrolling="no" frameborder="no"></iframe></p>
</div>
		</aside>
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-sidebar ">
<script type="text/javascript">
var td_screen_width = document.body.clientWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 

<aside class="widget widget_text"><div class="block-title"><span>ILLPO &#8211; MIDTRO / THE CRUX</span></div>			<div class="textwidget"><p><iframe src="https://www.youtube.com/embed/KCTy7PPuMTU" frameborder="0" allowfullscreen="allowfullscreen"></iframe></p>
</div>
		</aside><aside class="widget widget_text"><div class="block-title"><span>Philly Blocks &#8211; CEO</span></div>			<div class="textwidget"><p><iframe src="https://www.youtube.com/embed/nB95PzI0ps0" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
</div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><div aria-live="polite" id="soliloquy-container-30342" class="soliloquy-container soliloquy-transition-fade  soliloquy-theme-classic" style="max-width:960px;max-height:300px;"><ul id="soliloquy-30342" class="soliloquy-slider soliloquy-slides soliloquy-wrap soliloquy-clear"><li aria-hidden="true" class="soliloquy-item soliloquy-item-1 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109673710?productType=812&#038;appearance=1" class="soliloquy-link" title="Revolt Tee" target="_blank"><img id="soliloquy-image-30349" class="soliloquy-image soliloquy-image-1" src="http://weuponithiphop.info/wp-content/uploads/Revolt-Tee.jpg" alt="Revolt Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-2 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/youngongetthiswork?q=I12154011" class="soliloquy-link" title="You Gon Get This Work" target="_blank"><img id="soliloquy-image-30344" class="soliloquy-image soliloquy-image-2" src="http://weuponithiphop.info/wp-content/uploads/You-Gon-Get-This-Work.jpg" alt="You Gon Get This Work" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-3 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/savage+bloody?q=I1014473415" class="soliloquy-link" title="Savage Bloody" target="_blank"><img id="soliloquy-image-30343" class="soliloquy-image soliloquy-image-3" src="http://weuponithiphop.info/wp-content/uploads/Savage-Bloody.jpg" alt="Savage Bloody" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-4 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/can?q=I1011767996" class="soliloquy-link" title="spray" target="_blank"><img id="soliloquy-image-30345" class="soliloquy-image soliloquy-image-4" src="http://weuponithiphop.info/wp-content/uploads/spray.jpg" alt="spray" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-5 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814012" class="soliloquy-link" title="Good Vibes Only 1" target="_blank"><img id="soliloquy-image-30346" class="soliloquy-image soliloquy-image-5" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-1.jpg" alt="Good Vibes Only 1" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-6 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/blessed?q=I12044252" class="soliloquy-link" title="Blessed Tee" target="_blank"><img id="soliloquy-image-30347" class="soliloquy-image soliloquy-image-6" src="http://weuponithiphop.info/wp-content/uploads/Blessed-Tee.jpg" alt="Blessed Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-7 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/trap?q=I1009984243" class="soliloquy-link" title="Trap Tee" target="_blank"><img id="soliloquy-image-30348" class="soliloquy-image soliloquy-image-7" src="http://weuponithiphop.info/wp-content/uploads/Trap-Tee.jpg" alt="Trap Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-8 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/good+vibes+only+birds?q=I1014476779" class="soliloquy-link" title="Good Vibes Only 2" target="_blank"><img id="soliloquy-image-30350" class="soliloquy-image soliloquy-image-8" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-2.jpg" alt="Good Vibes Only 2" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-9 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/all+seeing+eye?q=I11739019" class="soliloquy-link" title="ILLuminati" target="_blank"><img id="soliloquy-image-30351" class="soliloquy-image soliloquy-image-9" src="http://weuponithiphop.info/wp-content/uploads/ILLuminati.jpg" alt="ILLuminati" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-10 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/diamond_skull_1?q=I12527492" class="soliloquy-link" title="Diamond Skull" target="_blank"><img id="soliloquy-image-30352" class="soliloquy-image soliloquy-image-10" src="http://weuponithiphop.info/wp-content/uploads/Diamond-Skull.jpg" alt="Diamond Skull" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-11 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/donuts+doom-A109792920" class="soliloquy-link" title="donunts" target="_blank"><img id="soliloquy-image-30353" class="soliloquy-image soliloquy-image-11" src="http://weuponithiphop.info/wp-content/uploads/donunts.jpg" alt="donunts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-12 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/crime+pays?q=I12067735" class="soliloquy-link" title="Crime Pays" target="_blank"><img id="soliloquy-image-30434" class="soliloquy-image soliloquy-image-12" src="http://weuponithiphop.info/wp-content/uploads/Crime-Pays.jpg" alt="Crime Pays" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-13 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/fuckyoupayme?q=I11550361" class="soliloquy-link" title="Fuck You Pay Me" target="_blank"><img id="soliloquy-image-30436" class="soliloquy-image soliloquy-image-13" src="http://weuponithiphop.info/wp-content/uploads/Fuck-You-Pay-Me.jpg" alt="Fuck You Pay Me" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-14 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814011" class="soliloquy-link" title="savage gold tee" target="_blank"><img id="soliloquy-image-30354" class="soliloquy-image soliloquy-image-14" src="http://weuponithiphop.info/wp-content/uploads/savage-gold-tee.jpg" alt="savage gold tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-15 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/?page=2" class="soliloquy-link" title="fresh-clean-signature-" target="_blank"><img id="soliloquy-image-30437" class="soliloquy-image soliloquy-image-15" src="http://weuponithiphop.info/wp-content/uploads/fresh-clean-signature-.jpg" alt="fresh-clean-signature-" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-16 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/%24teez?q=I1001415610" class="soliloquy-link" title="gold fronts" target="_blank"><img id="soliloquy-image-30355" class="soliloquy-image soliloquy-image-16" src="http://weuponithiphop.info/wp-content/uploads/gold-fronts.jpg" alt="gold fronts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-17 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/soldier?q=I11611241" class="soliloquy-link" title="Swag Soldier" target="_blank"><img id="soliloquy-image-30435" class="soliloquy-image soliloquy-image-17" src="http://weuponithiphop.info/wp-content/uploads/Swag-Soldier.jpg" alt="Swag Soldier" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-18 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/gamer-A7923028?productType=210&#038;appearance=22" class="soliloquy-link" title="gamer" target="_blank"><img id="soliloquy-image-30438" class="soliloquy-image soliloquy-image-18" src="http://weuponithiphop.info/wp-content/uploads/gamer.jpg" alt="gamer" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-19 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/" class="soliloquy-link" title="freshandlogo Square" target="_blank"><img id="soliloquy-image-30356" class="soliloquy-image soliloquy-image-19" src="http://weuponithiphop.info/wp-content/uploads/freshandlogo-Square.jpg" alt="freshandlogo Square" /></a></li></ul></div><noscript><style type="text/css">#soliloquy-container-30342{opacity:1}</style></noscript>
</div>
		</aside>                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</article> <!-- /.post -->


<!-- Instagram -->



<!-- Footer -->
<div class="td-footer-wrapper td-footer-template-3">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
			    		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span4">
                <div class="td-footer-info"><div class="footer-logo-wrap"><a href="http://weuponithiphop.info/"><img class="td-retina-data" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" alt="" title=""/></a></div><div class="footer-text-wrap"></div><div class="footer-social-wrap td-social-style-2">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponitdotcom1" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div></div>            </div>

            <div class="td-pb-span4">
                <aside class="widget widget_calendar"><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar">
	<caption>May 2020</caption>
	<thead>
	<tr>
		<th scope="col" title="Sunday">S</th>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
	</tr>
	</thead>

	<tfoot>
	<tr>
		<td colspan="3" id="prev"><a href="http://weuponithiphop.info/2020/04/">&laquo; Apr</a></td>
		<td class="pad">&nbsp;</td>
		<td colspan="3" id="next" class="pad">&nbsp;</td>
	</tr>
	</tfoot>

	<tbody>
	<tr>
		<td colspan="5" class="pad">&nbsp;</td><td><a href="http://weuponithiphop.info/2020/05/01/" aria-label="Posts published on May 1, 2020">1</a></td><td><a href="http://weuponithiphop.info/2020/05/02/" aria-label="Posts published on May 2, 2020">2</a></td>
	</tr>
	<tr>
		<td><a href="http://weuponithiphop.info/2020/05/03/" aria-label="Posts published on May 3, 2020">3</a></td><td id="today"><a href="http://weuponithiphop.info/2020/05/04/" aria-label="Posts published on May 4, 2020">4</a></td><td>5</td><td>6</td><td>7</td><td>8</td><td>9</td>
	</tr>
	<tr>
		<td>10</td><td>11</td><td>12</td><td>13</td><td>14</td><td>15</td><td>16</td>
	</tr>
	<tr>
		<td>17</td><td>18</td><td>19</td><td>20</td><td>21</td><td>22</td><td>23</td>
	</tr>
	<tr>
		<td>24</td><td>25</td><td>26</td><td>27</td><td>28</td><td>29</td><td>30</td>
	</tr>
	<tr>
		<td>31</td>
		<td class="pad" colspan="6">&nbsp;</td>
	</tr>
	</tbody>
	</table></div></aside>            </div>

            <div class="td-pb-span4">
                <aside class="widget widget_text">			<div class="textwidget"><div aria-live="polite" id="soliloquy-container-30342" class="soliloquy-container soliloquy-transition-fade  soliloquy-theme-classic" style="max-width:960px;max-height:300px;"><ul id="soliloquy-30342" class="soliloquy-slider soliloquy-slides soliloquy-wrap soliloquy-clear"><li aria-hidden="true" class="soliloquy-item soliloquy-item-1 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109673710?productType=812&#038;appearance=1" class="soliloquy-link" title="Revolt Tee" target="_blank"><img id="soliloquy-image-30349" class="soliloquy-image soliloquy-image-1" src="http://weuponithiphop.info/wp-content/uploads/Revolt-Tee.jpg" alt="Revolt Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-2 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/youngongetthiswork?q=I12154011" class="soliloquy-link" title="You Gon Get This Work" target="_blank"><img id="soliloquy-image-30344" class="soliloquy-image soliloquy-image-2" src="http://weuponithiphop.info/wp-content/uploads/You-Gon-Get-This-Work.jpg" alt="You Gon Get This Work" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-3 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/savage+bloody?q=I1014473415" class="soliloquy-link" title="Savage Bloody" target="_blank"><img id="soliloquy-image-30343" class="soliloquy-image soliloquy-image-3" src="http://weuponithiphop.info/wp-content/uploads/Savage-Bloody.jpg" alt="Savage Bloody" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-4 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/can?q=I1011767996" class="soliloquy-link" title="spray" target="_blank"><img id="soliloquy-image-30345" class="soliloquy-image soliloquy-image-4" src="http://weuponithiphop.info/wp-content/uploads/spray.jpg" alt="spray" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-5 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814012" class="soliloquy-link" title="Good Vibes Only 1" target="_blank"><img id="soliloquy-image-30346" class="soliloquy-image soliloquy-image-5" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-1.jpg" alt="Good Vibes Only 1" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-6 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/blessed?q=I12044252" class="soliloquy-link" title="Blessed Tee" target="_blank"><img id="soliloquy-image-30347" class="soliloquy-image soliloquy-image-6" src="http://weuponithiphop.info/wp-content/uploads/Blessed-Tee.jpg" alt="Blessed Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-7 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/trap?q=I1009984243" class="soliloquy-link" title="Trap Tee" target="_blank"><img id="soliloquy-image-30348" class="soliloquy-image soliloquy-image-7" src="http://weuponithiphop.info/wp-content/uploads/Trap-Tee.jpg" alt="Trap Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-8 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/good+vibes+only+birds?q=I1014476779" class="soliloquy-link" title="Good Vibes Only 2" target="_blank"><img id="soliloquy-image-30350" class="soliloquy-image soliloquy-image-8" src="http://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-2.jpg" alt="Good Vibes Only 2" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-9 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/all+seeing+eye?q=I11739019" class="soliloquy-link" title="ILLuminati" target="_blank"><img id="soliloquy-image-30351" class="soliloquy-image soliloquy-image-9" src="http://weuponithiphop.info/wp-content/uploads/ILLuminati.jpg" alt="ILLuminati" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-10 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/diamond_skull_1?q=I12527492" class="soliloquy-link" title="Diamond Skull" target="_blank"><img id="soliloquy-image-30352" class="soliloquy-image soliloquy-image-10" src="http://weuponithiphop.info/wp-content/uploads/Diamond-Skull.jpg" alt="Diamond Skull" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-11 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/donuts+doom-A109792920" class="soliloquy-link" title="donunts" target="_blank"><img id="soliloquy-image-30353" class="soliloquy-image soliloquy-image-11" src="http://weuponithiphop.info/wp-content/uploads/donunts.jpg" alt="donunts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-12 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/crime+pays?q=I12067735" class="soliloquy-link" title="Crime Pays" target="_blank"><img id="soliloquy-image-30434" class="soliloquy-image soliloquy-image-12" src="http://weuponithiphop.info/wp-content/uploads/Crime-Pays.jpg" alt="Crime Pays" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-13 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/fuckyoupayme?q=I11550361" class="soliloquy-link" title="Fuck You Pay Me" target="_blank"><img id="soliloquy-image-30436" class="soliloquy-image soliloquy-image-13" src="http://weuponithiphop.info/wp-content/uploads/Fuck-You-Pay-Me.jpg" alt="Fuck You Pay Me" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-14 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814011" class="soliloquy-link" title="savage gold tee" target="_blank"><img id="soliloquy-image-30354" class="soliloquy-image soliloquy-image-14" src="http://weuponithiphop.info/wp-content/uploads/savage-gold-tee.jpg" alt="savage gold tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-15 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/?page=2" class="soliloquy-link" title="fresh-clean-signature-" target="_blank"><img id="soliloquy-image-30437" class="soliloquy-image soliloquy-image-15" src="http://weuponithiphop.info/wp-content/uploads/fresh-clean-signature-.jpg" alt="fresh-clean-signature-" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-16 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/%24teez?q=I1001415610" class="soliloquy-link" title="gold fronts" target="_blank"><img id="soliloquy-image-30355" class="soliloquy-image soliloquy-image-16" src="http://weuponithiphop.info/wp-content/uploads/gold-fronts.jpg" alt="gold fronts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-17 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/soldier?q=I11611241" class="soliloquy-link" title="Swag Soldier" target="_blank"><img id="soliloquy-image-30435" class="soliloquy-image soliloquy-image-17" src="http://weuponithiphop.info/wp-content/uploads/Swag-Soldier.jpg" alt="Swag Soldier" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-18 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/gamer-A7923028?productType=210&#038;appearance=22" class="soliloquy-link" title="gamer" target="_blank"><img id="soliloquy-image-30438" class="soliloquy-image soliloquy-image-18" src="http://weuponithiphop.info/wp-content/uploads/gamer.jpg" alt="gamer" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-19 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/" class="soliloquy-link" title="freshandlogo Square" target="_blank"><img id="soliloquy-image-30356" class="soliloquy-image soliloquy-image-19" src="http://weuponithiphop.info/wp-content/uploads/freshandlogo-Square.jpg" alt="freshandlogo Square" /></a></li></ul></div><noscript><style type="text/css">#soliloquy-container-30342{opacity:1}</style></noscript>
</div>
		</aside>            </div>
        </div>
    </div>
</div>

<!-- Sub Footer -->
    <div class="td-sub-footer-container">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span7 td-sub-footer-menu">
                        <div class="menu-top-menu-container"><ul id="menu-top-menu-2" class="td-subfooter-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-mega-menu menu-item-317"><a href="http://weuponithiphop.info/category/new-music/">New Music</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_20_5eb099e46ddaf_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_20_5eb099e46ddaf" ><script>var block_td_uid_20_5eb099e46ddaf = new tdBlock();
block_td_uid_20_5eb099e46ddaf.id = "td_uid_20_5eb099e46ddaf";
block_td_uid_20_5eb099e46ddaf.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"43","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_20_5eb099e46ddaf_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_20_5eb099e46ddaf.td_column_number = "3";
block_td_uid_20_5eb099e46ddaf.block_type = "td_block_mega_menu";
block_td_uid_20_5eb099e46ddaf.post_count = "5";
block_td_uid_20_5eb099e46ddaf.found_posts = "2986";
block_td_uid_20_5eb099e46ddaf.header_color = "";
block_td_uid_20_5eb099e46ddaf.ajax_pagination_infinite_stop = "";
block_td_uid_20_5eb099e46ddaf.max_num_pages = "598";
tdBlocksArray.push(block_td_uid_20_5eb099e46ddaf);
</script><div id=td_uid_20_5eb099e46ddaf class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/05/04/new-music-rob-markman-ft-listentosin-saint-pat-beatz-who-do-i-trust/" rel="bookmark" title="New Music: Rob Markman ft. ListenToSin &#038; Saint Pat Beatz &#8211; Who Do I Trust"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/GxrgktroLSpv3y0DQ-Erh2jntgltZgio9wXKVWL2X-Z4KeuPDAuvLNbEQpfkK_GzZ59d_gsgd7nq4HqKF_DeSa_jkB_ikLXXSWtgp830pBlNyn5be2rAoWdeb5IVzoDHG9IXy_2n2MPKFSL-miUyYczuGMKl3bTaM9rgIdBceK4jgEzfFaDpSAI8IGJueEAPZRjlSZ1NAbcAu3vwxnEmVfoq_en06UheXoe2U2vkxKPCgei-Mv8uVtVtOJcR7xErtfM-ESir3tfef4kqQ2iipqb3kUXt0MN76eTxkLk1maEjFeaIZab1N5SxEln_CCvW0WLn7kYOVT8gzFpZrnQUFsWT5iNYvayk7bOxWDKHSTIRqcCZ06gHXdVMz6e_ZKmK3SMiUfgYpeqrEDz-fqErkMUUoc1_jn7S3dRAD1Y-8yc41SwdCvdX4GocUaTxYh9x9C9yItx-tntzF1uZcq0StJuRAt7w-15mJzF6m_ce3LrUojQiwPKfUCNSRm5PUWLQ-IJ5I_7Is2hj7D9UdEfVniInb8FvkCGK1Ah1dR9mo11rChn4EhtblNtzt-QFmHIo6FR-xn3UvWw-MHiPj5TyV-2GD_h7wRjSroSXEvq-LSO5KcRYyWVN-HCO0RMibqkRcBao6bR4MFQGCWlQ8YxbjVN8vyUA2MkGa1DzgTTSM2b65GrQgXjyOK-ZUTJ49w=w754-h758-no" alt="" title="New Music: Rob Markman ft. ListenToSin &#038; Saint Pat Beatz &#8211; Who Do I Trust"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/05/04/new-music-rob-markman-ft-listentosin-saint-pat-beatz-who-do-i-trust/" rel="bookmark" title="New Music: Rob Markman ft. ListenToSin &#038; Saint Pat Beatz &#8211; Who Do I Trust">New Music: Rob Markman ft. ListenToSin &#038; Saint Pat Beatz &#8211;&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/05/03/new-single-kota-the-friend-ft-joey-bada-bas-bqe/" rel="bookmark" title="New Single: KOTA the Friend ft. Joey Bada$$ &#038; Bas &#8211; BQE"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/hH0WO5IA7sIjeNkWydMwOkaeiPvPVbnrxMJWXDoOVPUCFEpviUYETsxDrm9jzJXoKDxsrpRZdn2YMSKkHtPiYRIR-UEcp-ghzGEmYukDGD6tuHb8bu1FjgGfr91tP8zDhK1STBbB6FSiGYMTRTV-lqrnDX93UUVEgewz86yaoaHF7VbKJh9YHfIEHQhO_rB53Gotob6hknFbtKdlH_Bezte7dgNA_5XNYSai0dQprmU-A3aATCn30sw6ZIZafQJZugGIKkdd3Jx9Y66lheeh1tPAiQUvdXOUsse5lTYNMuxQvdPQWTLM98Do0JGlQYtJPOWdz10inEhWpFXqpXkUSUkwQHE3qXc_LXDo4sKyJsZTRSi0M6vZfF4923IbFXyt0qaKNyhqnm3Y-vjWKhwaW0qTebpUsGfkySWnWRwv8evaUvrIcfbCavIV7_3U-Qr5pHizCcznoirYoqjECIqCJ9xoq2H7ngSJYI5W0YuY6DMoqMnIuFgPPZhyu-VHWmqCPFSnP_xoSQc5nyt5lBjfGimfB2DM7Kh8mUtJxadXxrxEpftLRZXRmLBDysFxATIXt-3Trl7Rn4nCubHx2fvaU_U-_y6u4s5HX1AEjp0u-g_mkrBTr85B0VkSCcHQ-8e8l0aKdXVNyOCTpDAQaTpjLRJf3AKQ4r7j01arbsgXz7tfahff4KWv0imuhErH0Q=w754-h758-no" alt="" title="New Single: KOTA the Friend ft. Joey Bada$$ &#038; Bas &#8211; BQE"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/05/03/new-single-kota-the-friend-ft-joey-bada-bas-bqe/" rel="bookmark" title="New Single: KOTA the Friend ft. Joey Bada$$ &#038; Bas &#8211; BQE">New Single: KOTA the Friend ft. Joey Bada$$ &#038; Bas &#8211;&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/05/03/new-music-lion-babe-cant-get-enough/" rel="bookmark" title="New Music: Lion Babe &#8211; Can’t Get Enough"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/tWVgEtWwzjKsCdfWmkPfNo5ENjIHohUhCJ3fPgQGq9fU5pBKCN9OmYuRqdTcFlIes_StGJh9fVTBIsM-WjpG8fc5H_e4f823AMCx6JkEu041yiNY02n2ekTZb__xHXJWpq3bnG6TLrltRQEBH-7E1cSy40Q3ut4sVpo93M709fgHcQg1adBNVn762Eb5CagtUckURychuYSeHJDTHtmukzbaRvR8NBx1jTrM2Zg5bemsHNXyxUvVEbYK_SUPmnZnlnybBGUWSfY5fMeUw2X3ZZ50fXu3I6mVl_T1_mlEjRLUadaonzRH-hVsAT3pew6CSrecwTCGkgK6t2ufUMapxMsgF5m9TDpGf7D0msd2019sD118-78F8eMeSR5nHzuIlWEoE3hCaatA8Vh10oNGMAVJgz8jKx5qh7ZLUnLlqF6SDLTSbJqdG8xup-ATtOCeT0ZU-xGQzj_Vnt-lbvxR1LraVz6AqjAByaZUNi_cSn3dtAZ1zwxeHH47T7hoMCtn8Aby9xqdeuZnlGqBnywJklrlJM5aJTr_v_t5aG465AalzCyrRwq_cUcw-1S3ZVGxRgSaddIkXfuc-YRcvnI9LXq0T2NkwFp1iMErf7P8xsfPBLYfnmNbb14Vn64bfcnRiW9XycMpAVgIVI-YBmezPSwes_HG4KvhXmItTr5Mak83SPJTNhly3IbE0zBpvw=w764-h758-no" alt="" title="New Music: Lion Babe &#8211; Can’t Get Enough"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/05/03/new-music-lion-babe-cant-get-enough/" rel="bookmark" title="New Music: Lion Babe &#8211; Can’t Get Enough">New Music: Lion Babe &#8211; Can’t Get Enough</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/05/02/new-music-french-montana-ft-tory-lanez-cold/" rel="bookmark" title="New Music: French Montana ft. Tory Lanez &#8211; Cold"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/DkpDHJrtHKpfjQ3J6gikKSQQfIYv9-haBEcr4o8Qaj_i8s4yWxot-ioZ2goI9wFYMrq3vUyXFQvTx78eljPzpEh7CbkOsDUHykRJicM6-IphvPWQ3kgXmit2q8L8C3sEaIhq_rd0jW3DXLsYMfnXsCH27aebSOG3tqDJu1dkcQn-u2XsqecBxjDYMSXAcP9rtJMlU2JKjFSpVbhQzuQnrouxLB7DX2LzGHnDS8Er1RE67l8uA_W38sqno1TDMU0xsr7eGb4XDkFF86ePvLFImMTBI-uHgF1TYLXx1JP62yQ3aA9ZVZ2DkX2qK5DCTSRmFfxPnleGB0goZWAAezFi2EWvtC_qoG59cIVVNDFqvXQ9ONc_RwjfXo7S3niBnn1x2ZYHUYeoxqxuELd6irg6Aqltkk_1fdMRc98O2UVSXpVdQS-CnbynhdDrVV5X7gTXibK6-kIzHQexDI9zyamy-QK6zy6SOYcWKc1_jeQZpm3b_wKbYQf1CtSkcIcU757Tf-b9mu_Sly1QF4lQ-rMpAvKqQ9ozQGs_z0Giy_DqgMvlfgO8n1d7Anj9y5Nx1Ps5Ux6mhVkp9DtQ4nJtgCEwJHFkbA8pjrcOjE1Mv1kBM4qiE-y8JqkkojA_F_C2UqFlOqurRySTDtbxOFPi7C_sZfPNM_OJ1xofWo98jVCBvN6dK6TdLiRrQy_0XrJO-g=w755-h758-no" alt="" title="New Music: French Montana ft. Tory Lanez &#8211; Cold"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/05/02/new-music-french-montana-ft-tory-lanez-cold/" rel="bookmark" title="New Music: French Montana ft. Tory Lanez &#8211; Cold">New Music: French Montana ft. Tory Lanez &#8211; Cold</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/05/02/new-music-hit-boy-ft-dom-kennedy-nominated-prod-by-jansport-j/" rel="bookmark" title="New Music: Hit-Boy ft. Dom Kennedy &#8211; Nominated (Prod. by Jansport J)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/lExN5pOZq4xsZsUEcFqFN1whAHRUb9pQLtGZBYEc4acUEJw0UuPLQOIrb08r5AE9z3zXiPSS4HcgGarA_diQ9FMQiyn3qw_HnGLee576P2ZQCFu3VB9Ux4sV5TGF2VmhBxOXTZ0rBi_9TTSPxYuz8v-bgaN5J2EzPmiUpDrxH1kHcNXgHQ5PTeu3v1MRH46xvzEpqWU5gQFOyw768bT7TMmasUOALIEA1jV3I8iZKABuxyvEEgI4GqvSs3K1tGiEt3I4idbiUOevPbAd2m4OddHRs4r9dixmcH9V69S95mvtjpwbMbuCuJdNKzYZuepQQHVjcT97YWR65SyP77q_XB9ATdZL7yiNVZHC3TkTquKLNxpil8NHI3LuMuRbJvbyNebtjh6rEV1jlapVQ0vDpl85k9v7YqTOPuCqd8V6aGwM4YZ30FguSKSBiJ_4DSI7sTYS2Y59R8w_Ib5pbiQPlfvEGDwP0j3MjFWw8LPTtdcP6gdSXd_P1T00Z4CfxoMi9Fks4msoSzi9gark2wlo7rVORedt0ZhXA_doDqGXcKZAERVFuE5A5p7wfeZFnjq7QzNP0ZNP0J2drZ1xdyKUCj-0VFpr15rplc50wunkazgDLCLnIn1Cg4qnsM4WoHMx-XOJ0VwqXbB4cMdi0iojthvm18hOxeISNOEcMaMrSqVgVcgkJkMs1d9ZRp4bWQ=w779-h758-no" alt="" title="New Music: Hit-Boy ft. Dom Kennedy &#8211; Nominated (Prod. by Jansport J)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/05/02/new-music-hit-boy-ft-dom-kennedy-nominated-prod-by-jansport-j/" rel="bookmark" title="New Music: Hit-Boy ft. Dom Kennedy &#8211; Nominated (Prod. by Jansport J)">New Music: Hit-Boy ft. Dom Kennedy &#8211; Nominated (Prod. by Jansport&#8230;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_20_5eb099e46ddaf" data-td_block_id="td_uid_20_5eb099e46ddaf"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_20_5eb099e46ddaf" data-td_block_id="td_uid_20_5eb099e46ddaf"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-706"><a href="http://weuponithiphop.info/category/mixtapes/">Mixtapes</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_21_5eb099e472cd2_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_21_5eb099e472cd2" ><script>var block_td_uid_21_5eb099e472cd2 = new tdBlock();
block_td_uid_21_5eb099e472cd2.id = "td_uid_21_5eb099e472cd2";
block_td_uid_21_5eb099e472cd2.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"97","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_21_5eb099e472cd2_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_21_5eb099e472cd2.td_column_number = "3";
block_td_uid_21_5eb099e472cd2.block_type = "td_block_mega_menu";
block_td_uid_21_5eb099e472cd2.post_count = "5";
block_td_uid_21_5eb099e472cd2.found_posts = "1053";
block_td_uid_21_5eb099e472cd2.header_color = "";
block_td_uid_21_5eb099e472cd2.ajax_pagination_infinite_stop = "";
block_td_uid_21_5eb099e472cd2.max_num_pages = "211";
tdBlocksArray.push(block_td_uid_21_5eb099e472cd2);
</script><div id=td_uid_21_5eb099e472cd2 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/05/03/ep-stream-mahalia-isolation-tapes/" rel="bookmark" title="EP Stream: Mahalia &#8211; Isolation Tapes"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/H-J-r-7N1JvZEmNtPVtEaCru2Ld84hDgSXAFQcejlvAzcSJzTkQSThW3A6tfIX0IGEaJvDRIbqHLEgnbL74T-t71HnfsoprOtA6sRoE04G8jlaBM2DIpBF2bEW4G0rM9IlMK2PWJcPX9OzKumeQYIQj8hv0FgSxuEEbi0ZQ4Ou_iwsO3k-9ZxwN9YGSh-08zjh8oIC8-8l_BwK4LHB_WJ0cMBItkYnZ9uAEJRNBHeWhBEuUOlebySXLNHUaSOlfUewoHLeuyE_o4I6tp3SAivW3p90A8kZ-jL9bsbgt8b7N2gtxC8bzSHFDHMYbFK6kZZsoIpMQ7ArVIaiuCL50TL-5ks5en6Q18R_yL95o1KTlzG2y0kefamgAzksy9DMGJ3BYCU9kpDekMBYWAxK50layLKZWAfd4aGP2ljOdnLLBkx5Pdd07kLqHA96yIr8EzV81oRVOVO5EYfgvs5cbeD7mmg5MjqraaIqIRdaX1uz_EInks-LRIh863ZXlg6A6MOsjcoXi2H6hdbCi9AnIKuTvGg7cKAxJOSrC85lBCnZuII4xqqzQ3C5nXeUMLEdppuF3rZE7WMF1VgTvwjw7BHc43TSXZQuPDW89x1H-wcjOGefQpeMMrvFohcukO-fL3sqzTz6uUkE8EtzhuZXyTdsusBpGRmT5nqqufbFaCJwIxqIsCQGES1ms5pgM4-Q=w755-h758-no" alt="" title="EP Stream: Mahalia &#8211; Isolation Tapes"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/05/03/ep-stream-mahalia-isolation-tapes/" rel="bookmark" title="EP Stream: Mahalia &#8211; Isolation Tapes">EP Stream: Mahalia &#8211; Isolation Tapes</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/05/02/ep-stream-jay-worthy-x-harry-fraud-eat-when-youre-hungry-sleep-when-youre-tired/" rel="bookmark" title="EP Stream: Jay Worthy x Harry Fraud &#8211; Eat When You’re Hungry Sleep When You’re Tired"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/m20zZrypjC84Yctw2Puq2S-fCpDU13GARztTJ4BzF9imyiljkZw-3eiyRC2nBoKJWRtcUzwTwGwjvYI5FerVgdbpICGkoldoubWEECySJyBcvyqUhA-E1bwDPyYOmQuiVRtIjJD7-b8B1FPmSBtuQE-pNX_Nea6_-VA7uj-d_VHvxJnbAoAkqCJlzRj0wGVT3Q9GYqCcEYShiwZS7RFMZKw0D1zyF1wfEIJ9RwE3bnzlTwKytNMBh7ljZw6hXWYNBYjlLtgt3cp4VbXy9Z1L4-rtidEvIyWMd7-GwxvRPBxMHgqIZ5VGiVjESaRNntrB8PQGZcaC8XUv8g6G2oS5PNxLd1dBo90nBdK53NBdBsBXm5gaJg8BepZsrdnUnV5PP4TV9ZlO663PHuU5-7Zyhyf8fo85313MfmYmb-Vv-ij9M9Es1ngwnvc_jmghYrpPlvs9fMeJh7BR5EMXjhJyWS5VrrqkkSS5q1yC-AIGxb-vI127rhcX8h5yj_ERMQyO7KvckYh-a6nhYGlU3IE3QW4mnogCXwbPMbGP4yuxlVeVH6MyeiS5mtr_O0JLBn5dnGr-bVtRCGzIlWANMYN2sSrMWR9O2QdiN3g1NkqkQNHW2jBGNG33iLdZpjYddxjFtQeCjZSAzBa4_MDoYQInbVb7Stg-DMsQ4iKqQHV4rI_HIQnzi-1zJQlzbL98Dw=w754-h758-no" alt="" title="EP Stream: Jay Worthy x Harry Fraud &#8211; Eat When You’re Hungry Sleep When You’re Tired"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/05/02/ep-stream-jay-worthy-x-harry-fraud-eat-when-youre-hungry-sleep-when-youre-tired/" rel="bookmark" title="EP Stream: Jay Worthy x Harry Fraud &#8211; Eat When You’re Hungry Sleep When You’re Tired">EP Stream: Jay Worthy x Harry Fraud &#8211; Eat When You’re&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/05/01/album-stream-drake-dark-lane-demo-tapes/" rel="bookmark" title="Album Stream: Drake &#8211; Dark Lane Demo Tapes"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/dEZy1rfXUaDAlxp87uVxpVEF2UeaYOwTRZLfkDE92ZmdZdcDifVz4PWB500FJbl_dLF2FyTGg8t6UDePs0sFm-b8_a14sQpO4pEu3NxeM926D7GiCRa4-48amNNbapfYcSBqZ-jodvYtycnvWAlrg4166onH9M6ENeP8LO_xNVPCgwZT_KDflHSeGRGBBOs9iRv3k-FWIoG_MCuaCykF7R2MGfNnLyfOlkH_6fge1Qe34kprLJI3oSGyksEym1nkM0Td36eFcZ2wzumIrViIh_ubk4ZjrWisf-2C-qZpYu39-SbMlqdHNDEMjqZrHSXesfUJoQmq4gq-Cqakbb-DxquSz3CDuAnDtzHjNSe0sYFhHPWtpQqZl2V3AnkNkppG05Ka7wo1pUssv9eic4_kxo4Bweqn3gXdPwKdWutOcr1RH0Qol8nrzpXdFwzWM-7ZOvCyktQamadMF6eytIXlQmhwLjP7jhkZa6aXT6lYQMfcecZzlD5UcVJDRFnj42NU6FW7RK522mGRQ4t10p8OuQ2FWYvg9lMkZhVEnSKckh6s5Yxy0xO2xbolXho-Z6wxguVw9Wf8LTWvbjzSfZ6K2LKqxviRpLXCmpRJFG6b6x8AUQcPA_lyN-k40Bq-KcHkEKXCNNv8zlrbUf7TUy8Ewu7IBb2gkd3dZmEItfZ5bTuxRzzFzFSU3uv4FbAcO5OTI2Y=s758-w756-h758-no" alt="" title="Album Stream: Drake &#8211; Dark Lane Demo Tapes"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/05/01/album-stream-drake-dark-lane-demo-tapes/" rel="bookmark" title="Album Stream: Drake &#8211; Dark Lane Demo Tapes">Album Stream: Drake &#8211; Dark Lane Demo Tapes</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/04/28/ep-stream-terrace-martin-conscious-conversations/" rel="bookmark" title="EP Stream: Terrace Martin &#8211; Conscious Conversations"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/9oIzqmJcAZRcTwtzaONtU54msHkveUb0s0XB5zF20LAJPmfSdmHlAzqHXd57rcvVMmuwpv1A9nJpx1mWNRkYZr_-n8non0IN1is-n03bV8xiXzVNY0cDZM7dCLwz6mVcLPyel0Ptku54Rc_5oYp8UhUNpC92MnWRo6GtTbdjE5tHgezhMfzo4zmmgk8jPNNrTPcbbtuNzwEs3Nhkat8xB4Q8rS9BRre51oerg3Hiz6hCaCr_WC8o5PURu3MKHP_lDZG9Rxkag1vr7L7AakuMdLh0SxUx_oy2WX-S7TQMB7UhBpi1hySEkTEqRxzpEuxXKAkenVQNJZRU6sedmVlOJVj9ft92IK3osndAVpXD55iKHOVZhyDUlfzrrBFT8pm64iqkATwwY9UMLoXzc6xOtzjWqpyZx_lLJwCmB2yycB4A07IpHuWtRGSPtBm2khYLYcX1bJK8Fr_yqGXNP3lsXeB_Nj4mx0yQssDnbTiUaR49YHiLUkym-wP0JSVStXtjCJdAjM4-psZblxFYAZk49YFJXfYYDc1z_hRfk8S4XHIdAf7IIs34-o96cEK0foHTCOR1oAqmiBpnpEb7nHT5d3O9aMBBn2wnXcDdK8FScazBA-oI5KkGaq1yrOHKiD3GHbEKS05uxU1Xr3VtNKoYTnYhleTNdsV2i7-yaS7nBmOVOXeolI1gTVvzdP3aOQ=w754-h758-no" alt="" title="EP Stream: Terrace Martin &#8211; Conscious Conversations"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/04/28/ep-stream-terrace-martin-conscious-conversations/" rel="bookmark" title="EP Stream: Terrace Martin &#8211; Conscious Conversations">EP Stream: Terrace Martin &#8211; Conscious Conversations</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/04/28/mixtape-waka-flocka-salute-me-or-shoot-me-7/" rel="bookmark" title="Mixtape: Waka Flocka &#8211; Salute Me Or Shoot Me 7"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/dyyI_BCXVMY4OdIQaKlhbvOXYhhR0m9-PyMJ1micyMDvYJzBjBpej6K_MFJcz6t6-_QWKLmaEdgDRkpS8bJOe2fml-ywEVge_I5u3sw0uvKAUsEf8Z-4bO7EajbPCb2479Ps5o6o8LCmQIUzH-P6iyFj-lkuaBRVOsQA-Yvf2qnRz4aIhOb6rQg7wfKfcdkSkfZUZ9Fx0oneP74fPS5x4W6qUcg8nrnuPOvjTOUHosCDVcHnM6DxW1GztRI8SbMfrNxzfYqHX4tzv_vNJwKeXGyKF-Va6R_TvdSJMkewHwDeeGQDETMnGORLn6CV3OER4qt847Am-RuD4sEW45vAe9DwNRygvDwIB_G80uVvaub-XqgePTDJejX0lSWyFipDBw-L-OuXdJpxuU9tfkRYCJVHZKkMiBaxMXGRnpe5-jXutPSd79jGUdvcleXgdyh_tjEeoGZmWWkVr7mn84JzcPN21h0-uCVKA6aO8Iu8KToIH5tnZ7PONolnKri0ZWfvD3aefm-nIFnJcXk5woUBhXoW7eJqz88juWiEIIOWxrqMv1UodXk42632ZFezaKT4306TbGkfSsqQ8kWsLaQVCSIMQC8PbizYzkeixpl8tP4FdGV6TTTHmQfzES1tXWIiBH81YWrf56phZC2RfaYoYOz1Mg7rW4q0g_4VzpufluMjYm7_QX2ky4gdKH2pIg=w756-h758-no" alt="" title="Mixtape: Waka Flocka &#8211; Salute Me Or Shoot Me 7"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/04/28/mixtape-waka-flocka-salute-me-or-shoot-me-7/" rel="bookmark" title="Mixtape: Waka Flocka &#8211; Salute Me Or Shoot Me 7">Mixtape: Waka Flocka &#8211; Salute Me Or Shoot Me 7</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_21_5eb099e472cd2" data-td_block_id="td_uid_21_5eb099e472cd2"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_21_5eb099e472cd2" data-td_block_id="td_uid_21_5eb099e472cd2"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-314"><a href="http://weuponithiphop.info/category/music-video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_22_5eb099e476f22_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_22_5eb099e476f22" ><script>var block_td_uid_22_5eb099e476f22 = new tdBlock();
block_td_uid_22_5eb099e476f22.id = "td_uid_22_5eb099e476f22";
block_td_uid_22_5eb099e476f22.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_22_5eb099e476f22_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_22_5eb099e476f22.td_column_number = "3";
block_td_uid_22_5eb099e476f22.block_type = "td_block_mega_menu";
block_td_uid_22_5eb099e476f22.post_count = "5";
block_td_uid_22_5eb099e476f22.found_posts = "2939";
block_td_uid_22_5eb099e476f22.header_color = "";
block_td_uid_22_5eb099e476f22.ajax_pagination_infinite_stop = "";
block_td_uid_22_5eb099e476f22.max_num_pages = "588";
tdBlocksArray.push(block_td_uid_22_5eb099e476f22);
</script><div id=td_uid_22_5eb099e476f22 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/05/04/new-music-brandy-ft-chance-the-rapper-baby-mama/" rel="bookmark" title="Music Video: Brandy ft. Chance The Rapper &#8211; Baby Mama"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/n5PFGB8RVaovm26UqNDqt4fCirKYK2wPIIKVBlttdtFSfjL07LcE7V8vN-hP2SYBDRpZPatvpKxQgWS1BrvnxcsCYKiLbfwGmnHYiKKzmAsJmsJ4rj5L5jDl9BGzon9uKPMPNYWY2VEpeiPYYWH4q9Yp0gh5iXpujQqPiNs_Go6TevcWYG6z0fQjoR0V8sgAXdZQaRmxPWQOFEMChRfcXeqVv9mS3bHfrmlxORqms_iJXgIvJH9j3zT2uM6aLASaCEEZdnldaS9-zihIFz1sZy5ZjqHTM_juj7KHqMkRnUaYIrC4mZXbF9AK5lX1GyNohROy9BZT5DRUShpUKpVDZ7HXGtRNHwRoBY-NXK_Fd0Hh9kzIGs03clXl_ikvhPADLLsRADXzBWDdzS44uS2whX6ghPG-YiCT6zmZfGgcZRiCMCp-sG5Ah70G6HaRh99beLOnvLMTlHb9jQG7qeHHTQZhKTTG4gpdvAgaA2QimPIVnrUboA84uzrMpP37akEuiG9IsiFA-xROwD4Y3ExgwVZslTCaOuCkw71bj89Y8h0pipPAk14jDNMT7zLxdDysdnfKJvjdcZGcwEucJblzvSYgv18m1RFSwjvASKNuWq3JijhnZ0NJSGPSLp2Rh1ZW8njCZRKhpPK890bN-LqAf_Cv_INcHsefy5toPF32KCGLmJO--6g5Zv6fxEyQVg=w1077-h564-no" alt="" title="Music Video: Brandy ft. Chance The Rapper &#8211; Baby Mama"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/05/04/new-music-brandy-ft-chance-the-rapper-baby-mama/" rel="bookmark" title="Music Video: Brandy ft. Chance The Rapper &#8211; Baby Mama">Music Video: Brandy ft. Chance The Rapper &#8211; Baby Mama</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/05/04/music-video-young-m-a-rnid/" rel="bookmark" title="Music Video: Young M.A &#8211; RNID"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/J6Vkh4bXQxb_Ky483hsC_5dQk_eiDG4ZWbzH23fzcVzwuC5Gxhpy2HBfybqYr_7dalBmznmfQS7s6kciFbeE9gZ7xZB9sQVNuzhwcp5dlYyZxkwaWa044_YqspNEGdXaEX4wfvywVWoDjNisJ44ET9pgTikuwXKzYVr2FbB_0HuMVrgU3xvURAGVWjdSI_gRiAeeBgIyE-bXhs3t6yogh5wtCFCo0GOSpvKCTlJeesdMUrWe3keXglkDDje0DEwgvB-Y5Lny_ibTPn6vAZiWylDwL_xmAbfq_bcVw_SsgNY1tLHcGSYYb7CvU4xdtabDQGTg-8jV-npw4a3ZHYG6ouubDOWZEBHF_jlhkAWO2Z5uFw9Pwtu6zvK936W-86G4FtAFxAud4bA7h9T7a4zAFtbroHabSnBsFChstDMsYPS7M0P71CO_W134ri5mXXTBx90YVSHjpunklz4wu5VUgSMYlBJc6y7vP5VKIUAJIru35ra0qovqaJlgvmZKMBxNlrgKJy-MU9y2zXFwfiQWt_AjL0S9iLaYYdCKTtCinCpIamvnyDffFEvbsrosB06hR1yraibSfzgHShN7k_kElmt6inbsLydK1WkyW3KcopyA9OOQDPOid41z6558mGZvn9zIVp2VqS_l3d9kg6QkKNWnH4pdejxu0OV3juW3i1szTpreHfH2UJdcOF0_HA=w1077-h637-no" alt="" title="Music Video: Young M.A &#8211; RNID"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/05/04/music-video-young-m-a-rnid/" rel="bookmark" title="Music Video: Young M.A &#8211; RNID">Music Video: Young M.A &#8211; RNID</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/05/04/music-video-the-lox-loyalty-love/" rel="bookmark" title="Music Video: The LOX &#8211; Loyalty &#038; Love"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/fDkUzqhhzl8jHzDcZ5Jz8lhJOECSDqi6yZzcwqNlAhOdmmpvvgdnfAdmKrKe5l69Vuz4VjOCveEVDuNCCPhnJp877XOz55_DgnuCrJPji9ITQs9PEiPergrI3btHxYiz1L4COAopi9EA5guW3HWX_GhjzTr1ohWidefJ9rdhEQLaqPYpIsrwDJuLtYT5kOyw0pPiB9FwxNEDq3QJwtOwMIW33AyJoqKEFMVW-KofLyPb1mz9c4Dlrp_qnIhnxh4Md0pmyJNRujRG4AM3Tt0pjW7hbPfPCttUaWfH-Jcqlu_bQ7mj8AhE1Tg61HVBZ3gTrYb_UjS10xbqzUJ4Zd0PxOHPA_jAelnuJ0m6FRR1iOjy2rs4i6xgKOQi7HshMCnFbKjwEegtHQyat-Cd3ISOpKrH_1doOmkSV0S10U0blMuAzDfUKq6vOmBvLGnUeT8hTyD7zA-AtDQRDzBmdmxFG1HRFjMj3OyBduKx4d3Ba58zRHCYw1fbTL2BwQrA-FU8vQvgeLCUQg5KNNDvdzKOIA9fa5OJuTrV8tz9GkwsNOzKzFNfuH5twFovIIiHWAnFvNUvUJ3xRu_tHG6f1PktqzrbRlnb4_0x9H4aGMhLk6qEesTlxJ7suESEhlMeXZAryh5CdWdTD4QIfk00ZZjNDkAl_Op7f4imb19u71THdOXbPiaPxVsLJ6ba0BgFaQ=w1055-h758-no" alt="" title="Music Video: The LOX &#8211; Loyalty &#038; Love"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/05/04/music-video-the-lox-loyalty-love/" rel="bookmark" title="Music Video: The LOX &#8211; Loyalty &#038; Love">Music Video: The LOX &#8211; Loyalty &#038; Love</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/05/04/video-doja-cat-say-so-live-on-vevo-lift/" rel="bookmark" title="Video: Doja Cat &#8211; Say So (Live On Vevo Lift)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/IPgBvf2VZJEds6CbT6mtX98c_22UQw1PVvBd4-YUI9Roa090rrsiS6SHvBogUntoK585chHUH7B5hBS33yRQpAomPqqYg9M0TfgckqIj4b4gVAS4b4KWovzef7aIHcjQ3NngnvW6gzDnC-RVJZS79JwV_sVPC4aXNb7B_W8wqwKoba1762nEiV_OlM1iyQIBTTFvf0CM_F-bOCQ34IuX_r8W0QJySlFzENBO5weLRns_1XoJiiqwev8ihxJXch2p1mNG_62-GPooJiHQXNKRY58HvwWf8TLZbWe8RG1MtMcVQxftBJR5a7sjrdGP-ssKxSqFRMy9xTtz6AmZxtI-VwqtTyMlRcdO8j9D4O8vOjw6ASrIjzy7D2-u6cd81WfKYf26ytTXpHipUg53GQorkQDuVwx57YIFgor_6FYQOjF-uELM5kG6Ur001VJxIBN6EgRsepJ_QKeU39YBffV_fMIfSvCXkkEtg-cUUiratSqmXgXuCMIbnIaz-TveODzgDGxtlZX_2HECQkgvnemvmorF5tqKwcli3GMJsV0t45gk85PpZ0wvUhJcrA0s7GFwB9fKUeHISA9fnGO0mUtpK5NMg695Nt6qL2h-aI6-Aq7iaheyo6YzPLx9MnAvYiZ6yescMZ643GFAbZNwvYM6zZuQ5rKGaBOgSpJpKbCQg_7n-iuOmnOKf2GXl-s-0w=w1030-h758-no" alt="" title="Video: Doja Cat &#8211; Say So (Live On Vevo Lift)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/05/04/video-doja-cat-say-so-live-on-vevo-lift/" rel="bookmark" title="Video: Doja Cat &#8211; Say So (Live On Vevo Lift)">Video: Doja Cat &#8211; Say So (Live On Vevo Lift)</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/05/04/music-video-tee-grizzley-i-spy/" rel="bookmark" title="Music Video: Tee Grizzley &#8211; I Spy"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4e7BtRmJyn8B4HLjD5ir-9X48nI8SVc00D7jstYq-bjASbbsRgPq1sFrsFEMFWX33lAXrSRbKixS2s2po2MOUXSOatMFZDt1IcT_JlPLUq5lBgm1r-xPmbt_fb-FEnJ5mflBh74-t4Cnux8jR3jU69JhCx4eKhPkK1pDbQyeQn7yEWQ4rsRwClXc52lH2OqesV4JSinj60M3HkJ1e--B0mNZn5XEcWbfPP_pBmfMv0mbaZiBhmQtjdHG6BMcLQGDZmPWzsxRBEdQPMgjXpuLR8MQFGKgsk3DsIcZU1-B-klvUshdOrjCNMbdnRCmYyEZaevfhYv60_vxDv8P0X9Lay5-X1bQ4Vw3TJ_1dWFhyXNq3vYUyv-3V46aMmDaeHlti20tD50cr3QLFVHPELaN4_77hAr519V6FGifDadpFtOBPzEW15WLWoN3uDTEJ4BqUQRvmaYsFR8KEb0sOEZJ3GgncB4E52YYOepj2yL_ImZVJ43PqfDBwwpbs9OnPnP_bx7CySprDW7Sm21bMxdAVSV_LuUFOThNndUoqa4D6fUK-TVo__4E0nubZs5Xq9L01zbPcKU21JZO6yJKqQIRJHW7eH6JHxTaY9EZpcOj57ZA59FlpPB6qIXkpkPh8iTgqPSTeFRO8TOwIv7bmXh77KK1GBjzxPxlmS4SVmqTgRQROKvtmfvJGewAeTCsCA=w1077-h619-no" alt="" title="Music Video: Tee Grizzley &#8211; I Spy"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/05/04/music-video-tee-grizzley-i-spy/" rel="bookmark" title="Music Video: Tee Grizzley &#8211; I Spy">Music Video: Tee Grizzley &#8211; I Spy</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_22_5eb099e476f22" data-td_block_id="td_uid_22_5eb099e476f22"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_22_5eb099e476f22" data-td_block_id="td_uid_22_5eb099e476f22"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-316"><a href="http://weuponithiphop.info/category/latest-news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_23_5eb099e479fc4_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_23_5eb099e479fc4" ><script>var block_td_uid_23_5eb099e479fc4 = new tdBlock();
block_td_uid_23_5eb099e479fc4.id = "td_uid_23_5eb099e479fc4";
block_td_uid_23_5eb099e479fc4.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"29","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_23_5eb099e479fc4_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_23_5eb099e479fc4.td_column_number = "3";
block_td_uid_23_5eb099e479fc4.block_type = "td_block_mega_menu";
block_td_uid_23_5eb099e479fc4.post_count = "4";
block_td_uid_23_5eb099e479fc4.found_posts = "1000";
block_td_uid_23_5eb099e479fc4.header_color = "";
block_td_uid_23_5eb099e479fc4.ajax_pagination_infinite_stop = "";
block_td_uid_23_5eb099e479fc4.max_num_pages = "250";
tdBlocksArray.push(block_td_uid_23_5eb099e479fc4);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_23_5eb099e479fc4" id="td_uid_24_5eb099e47aeb6" data-td_block_id="td_uid_23_5eb099e479fc4" data-td_filter_value="" href="http://weuponithiphop.info/category/latest-news/">All</a><a class="mega-menu-sub-cat-td_uid_23_5eb099e479fc4"  id="td_uid_25_5eb099e47afaf" data-td_block_id="td_uid_23_5eb099e479fc4" data-td_filter_value="69" href="http://weuponithiphop.info/category/latest-news/album-news/">Album News</a><a class="mega-menu-sub-cat-td_uid_23_5eb099e479fc4"  id="td_uid_26_5eb099e47b0cb" data-td_block_id="td_uid_23_5eb099e479fc4" data-td_filter_value="80" href="http://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a><a class="mega-menu-sub-cat-td_uid_23_5eb099e479fc4"  id="td_uid_27_5eb099e47b1d9" data-td_block_id="td_uid_23_5eb099e479fc4" data-td_filter_value="2189" href="http://weuponithiphop.info/category/latest-news/flashback/">Flashback</a><a class="mega-menu-sub-cat-td_uid_23_5eb099e479fc4"  id="td_uid_28_5eb099e47b2e6" data-td_block_id="td_uid_23_5eb099e479fc4" data-td_filter_value="10" href="http://weuponithiphop.info/category/latest-news/interviews/">Interviews</a><a class="mega-menu-sub-cat-td_uid_23_5eb099e479fc4"  id="td_uid_29_5eb099e47b439" data-td_block_id="td_uid_23_5eb099e479fc4" data-td_filter_value="130" href="http://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></div></div><div id=td_uid_23_5eb099e479fc4 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/04/30/video-guapdad4000-ft-sir-boogie-bjrnck-rona-raps-episode-7/" rel="bookmark" title="Video: Guapdad4000 ft. SiR, Boogie &#038; BJRNCK &#8211; Rona Raps (Episode 7)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/XNBht5pilto-HlrtlvS94T-pC739XcPuRGJYURCUHGa1jKwwFZPWCs3TVD6H8tza7igUNJ8CYmslG3GWUUbrsHTMX4PCKrZRh0r3qegFe-aDrdlQ2XshNANJS2u0i1ya1nJWkdT1wIJxqBuFFG1azQyELU2pTTC0BzE_SCEtrQYlPW-N_DWxlYnUPi0O9aqr8TCZDvuBT02EiHZy55hJjNJvsLEipX39IMpSd22YiGb1ajPFJK3P-UZD3-Y8iGTC8xasDZO9inisLVHdbtYsBAHinpifD-CP0OjGUs_d4cQkJM63EdLeWj-RfgGM2GTpxvQrpFzq1HQ7cB3I1BqJeWxkGptG2iynOYYnQFvJpA198D7hkR9hz2ZAuYV_ieu-G9a4Ug9HmXMWCHdEQnwJT_Weik49hyM-B9kb0-K6UEXstSe9L3FFw9_FDuSs8Qd8y8W1kKj1BMU-gLEp_Viy7SLrjXO1gFi1o2H3XS1ngrLtn4xljwpGlEDLOBKmgmC7RBwWF0VCxxsEUusIL0Bma_syWXOJ8fkIWcNpAB5BsMbPw6gRGaNG2DoDOfTuma49POpqYJNieBMilniznoNuvm0wbZmnS2cywxyIfDKf1zHOh8ZhmUZUsKBEesP6HC_ZGMAmmYcg5-qso0XL0hGwZnGWtTuH0Uz7gzoF4SqZnqcT0ShNO8AQu9RFWVz3Kg=w500-h758-no" alt="" title="Video: Guapdad4000 ft. SiR, Boogie &#038; BJRNCK &#8211; Rona Raps (Episode 7)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/04/30/video-guapdad4000-ft-sir-boogie-bjrnck-rona-raps-episode-7/" rel="bookmark" title="Video: Guapdad4000 ft. SiR, Boogie &#038; BJRNCK &#8211; Rona Raps (Episode 7)">Video: Guapdad4000 ft. SiR, Boogie &#038; BJRNCK &#8211; Rona Raps (Episode&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/04/23/video-guapdad-4000-ft-kota-the-friend-wowgr8-ramriddlz-murs-rona-raps-ep-6/" rel="bookmark" title="Video: Guapdad 4000 ft. Kota The Friend, Wowgr8, Ramriddlz &#038; Murs &#8211; Rona Raps Ep. 6"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/mctRETI9ZkYBhJ6maBMIqUlfQyW841mKYmdWjpS6ASrudAei2zXEkZRL9cR8KrtYem_qC3TCDMZRoL_0jU-Mt862IWCvgzksreuf7pfkPeByor4jyXGJVOh_85w6rmkBEdjCdMNYvArSR8GDN5RSG3xFLk1mQtHPdvW1xGYs-kxeR8pddd5wpLz8Tlm4oQO9iGjwRaC1sSabDtLyXqF0rcz8jmtkLlUDqx3--4z898e6HZ-xbuStuk1BtWwK4F-K1111dCmTA0PT1toHmf4DzbWnQD6eAfZBjFvRcsdeArYEU2A_JsyvKMD_NR0KqOhx-jU3lYDZkr3S5Ks3EXnmIsIvhj38exSxWz-IoompEBQixXAqajV78NgWTl_LUNMy5Y3PVZpSZ8Mz1mkkEtMV2CrRPVB7jjw6O8kOwB5ZTXNTW931mN5zb0GvOguF_GWKV6Lm3mDD0ABWmsmLGXbWmtL1Z89u21HuIdlpED-_nCouEAQizxx3FfRJWBna88-BsEvotqxQGk6ByLQSye4-Q1F1CBu4HuHZXoFULE5kxNOOy0xxrxfuXn5tABPr_hoALWksni827IT5aWY5mEj1lW-FzsDYNjb7iSPLCKINI9-OcEaVDLVcNM5Y8z7E3B7yIj1C_e-QjKEAWY5jgjoUWDFEYfYNl7NM9U6sFhpRKBOaqYOjvD9zU31R3t_GJg=w594-h758-no" alt="" title="Video: Guapdad 4000 ft. Kota The Friend, Wowgr8, Ramriddlz &#038; Murs &#8211; Rona Raps Ep. 6"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/04/23/video-guapdad-4000-ft-kota-the-friend-wowgr8-ramriddlz-murs-rona-raps-ep-6/" rel="bookmark" title="Video: Guapdad 4000 ft. Kota The Friend, Wowgr8, Ramriddlz &#038; Murs &#8211; Rona Raps Ep. 6">Video: Guapdad 4000 ft. Kota The Friend, Wowgr8, Ramriddlz &#038; Murs&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/04/20/video-lute-gold-mouf-chronicles-episode-3/" rel="bookmark" title="Video: Lute &#8211; Gold Mouf Chronicles (Episode 3)"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/lCFE6visT_3XAc03UscQrnn8ucTk8ck1g9kZDKLpFK5FngUUb6g1V3K8zPlzvGXHSNtf-I9l3xavRI7kboaOzZzmCFEluCoVg1M4b8Rbxbxr6EfTvw5RpdfVPoqTSGpotaHPXT2Az5aKUPBuONFixO_1lOdkMG27wBVhFdYFoBthNIyVwUtNChWySIVxyl6cqL0uP3vo2zfMdbwWecvJdSGIwJBSXeCJscIrvO_E6QWJAVd8a1JPckZFyP1X3efFDnfHK2ZsWE6fXGmRjbu0q03tA0C2KPPFIwSeVej0cgK9f5c4xnKp3xwie1v9CS0HcmCGAdfFSl86Xx3ie6XbVJdbEV3gDPCvTv3fSdfJ0Si7-oOJUVj-ZqKLi2bMZL6txpPOesWp4TPl2fmh4IJbLy-6SMJhOfA7VaFKVKKABubqf2Ehz10s-xtGRUefZ28ZisXZPp2xwx_kWhHfm5KjXfCSQE7lzMPKWLC7OZjgk79kCK4xhUh9zR0swdGVjLKM10Bh_79dGjZisFQD8hAJrDTiAUB6JgKfPPAk1ry88eoe6S8xL0zV0fWFAIpALVxW2VeQvDU_iq9Z6zh4nGKNjt6zhaC8f1AbdNvmbmE5xICr_6aTh-98yfB4mdzW9SWJ5fTkKtmxpphD8Im7x8O_omT0CoZ5JmYyz98KjkNVNYrNyalzc48unVDXSd_w0A=w1080-h607-no" alt="" title="Video: Lute &#8211; Gold Mouf Chronicles (Episode 3)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/04/20/video-lute-gold-mouf-chronicles-episode-3/" rel="bookmark" title="Video: Lute &#8211; Gold Mouf Chronicles (Episode 3)">Video: Lute &#8211; Gold Mouf Chronicles (Episode 3)</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2020/04/19/dababy-blame-in-on-baby-projected-to-sell-150k-first-week/" rel="bookmark" title="DaBaby &#8216;Blame In On Baby&#8217; Projected To Sell 150k First Week"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/nAZ5q9wi8PRAqy22gIlcwdF6DR_9B0xBG6LDSOwfgAbNtSr-LUtxRy0zbMBg_8mJGrEKPn19pz9H7tmQUwbLGYsfB-3yu19KqBoLcH194qa8xveNnRAkCTH-d0goBkt4O3xvCAavAdLbq_deJrIQ_-T45lJHEkSXwJyE3drxOptvKvmXqCuLGzq34dkGr84t_HQYJ8NPgF5u_1hoipQ-T4vi56tgE9TDJUvAKE9J9ngcFV2GwH4_gHAx5vk9iFWpwBYNEH5l_OwbObnvzU7WBJzqdH0FeWg9G8Tz_dimXJlqllY9YDk1b8m9GpPawzevP4c9ALjem5_dBp9a8d2kQuHk91t3hOL4w3GkDRa3hrXIcgXi9aMPN3RDeqej46Jl21wKNUHoFBDxmXi5jkcRiPFhWJ14QaimJCS9FFlUai83_4Tpue27JspKflI4tsspXdvEd-biiI6_21rkP6Hpc53xSU6sm0Aq-fOSMyBoT1-zHWXAiQQy-YSgHjAIt78dD-lr8l39_xMQFWXcGnS1RPrwvaI6VHFFOGRWrjLdlsNowsRZdMOdFHXQBE5fV_wYvclHDxEmmcDwrRazlxgyACr_SalzrEWCaAIiNMbTWiAVDTICMpiaBGl78khN7ugvJOImXyiKASpqVzxXoqwdZbMrJIiJBCliedYuH-VTXkAHgU3K3stZitMUc2BoCg=w767-h758-no" alt="" title="DaBaby &#8216;Blame In On Baby&#8217; Projected To Sell 150k First Week"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2020/04/19/dababy-blame-in-on-baby-projected-to-sell-150k-first-week/" rel="bookmark" title="DaBaby &#8216;Blame In On Baby&#8217; Projected To Sell 150k First Week">DaBaby &#8216;Blame In On Baby&#8217; Projected To Sell 150k First Week</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_23_5eb099e479fc4" data-td_block_id="td_uid_23_5eb099e479fc4"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_23_5eb099e479fc4" data-td_block_id="td_uid_23_5eb099e479fc4"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-705"><a href="http://weuponithiphop.info/category/fashion/">Fashion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_30_5eb099e492906_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_30_5eb099e492906" ><script>var block_td_uid_30_5eb099e492906 = new tdBlock();
block_td_uid_30_5eb099e492906.id = "td_uid_30_5eb099e492906";
block_td_uid_30_5eb099e492906.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"77","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_30_5eb099e492906_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_30_5eb099e492906.td_column_number = "3";
block_td_uid_30_5eb099e492906.block_type = "td_block_mega_menu";
block_td_uid_30_5eb099e492906.post_count = "4";
block_td_uid_30_5eb099e492906.found_posts = "158";
block_td_uid_30_5eb099e492906.header_color = "";
block_td_uid_30_5eb099e492906.ajax_pagination_infinite_stop = "";
block_td_uid_30_5eb099e492906.max_num_pages = "40";
tdBlocksArray.push(block_td_uid_30_5eb099e492906);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_30_5eb099e492906" id="td_uid_31_5eb099e49342c" data-td_block_id="td_uid_30_5eb099e492906" data-td_filter_value="" href="http://weuponithiphop.info/category/fashion/">All</a><a class="mega-menu-sub-cat-td_uid_30_5eb099e492906"  id="td_uid_32_5eb099e493521" data-td_block_id="td_uid_30_5eb099e492906" data-td_filter_value="76" href="http://weuponithiphop.info/category/fashion/kicks/">Kicks</a></div></div><div id=td_uid_30_5eb099e492906 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/LVT4Mid8WL4wHUdO9X2OZmZxxgbREs2lVtszOdEBaO6hJB0JS3yQOAyhNSdCyPmv0amBDTgNGpOlRPXPjKCl6yIlo2joyH3rQRI7CUdX09BJtQI1r5jy1_7BQtDhw4AxUhpUwIh35rNS3lTy7uq-FdPff10JN6srr9mwZ7zr04GQFxBVEXwCfC5rNVehXhY_wGCRVsmevYmdkBWEmB8dvOzBHY78NBBjcHNArS_S-2M0FJgDh8v9m9vEh78k_XmZg-AERctsf0bkODuPi1EcNJq_RnJIV6b0GG-VtKjo-OVPmYghWJYf1HiP9c58cQ98oABU8BDFdLqsBtNt4K0NmyHYQlX39W9k_d83wEHZ1-EacQa2o01VrYSn12HnZ1l88fMzu9PKv6EGmcRZNwpepycW7_9EQnhxIPDdVCmRLXUasUED9OXr-zJmnBcnSnLCa06k1ZymQym1LiSFEv1c3aPHnmnD3GY8nL7q5jPJr4HsABR0WCqMebcF3HF_0deNd0zgRBCGMxW-VzlIIHZiHuBeSPEPvUL149GJ5swSSvKm1uGEi1HlLBj9omJSU7mDWzO0p_7l-l7-4_ureEsGsgB8cX1t8t2TQcFeRgqqF1CXlZFYYC2K0iMb4jPsijsw_rtO7pmKvbngqHfgYpGeh_qLmDWeicR7=w1195-h796-no" alt="" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch">Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/fHEwwMf8DoiXlqkfibQS1Z1XXbviORbV9raaI44tOTXrWo7GgqM3gA-vswE10gFtTQUGGwNG7nWAACwHjxPuiubliYBN_dqtBZh2WIpxvumiJ-hSLK0TNWB2cB8Iw2STT5gcp_KqlDh_e4xng1vidI8EXdp_ooh5uDI-JV1HQ9dGnM5nxl_b-v8znqj-Rl_mGB7y4Lu9zsFNWHU7SriqQQJaKrKEEnb9T8zxmGLaL0zq7ilYpnUEhWulDDr9xc82wdr__WzRBm5YEskVpDAnGM2NDZwTZpjbe4QDdxeixWnSXNK_oDzaL7WTbCpkD33OK88BlI5JmFRQ5VmD11UQ2htB7-9WoahHvb4XmBsbLXpEMl1JmEP4sPx06VduzFnBNo-J90WI0n1AEIIcEYVbRywrkGJXbzmH__In9ZIg0EV24OcGGbeKl12HxTdZwucqsNnuZeNjiMHISQ7i8cfzm3N7X7Zenl74zsKIKeKWoIGxh6MTlVADvgHcrHebnjcSgil2vBeFyz_AP45aOv9SOwbzfVLGS0CNfe1s9b2J7qZgjcBk9QPEXCl2kygvzmGXFvU_3xBuW6S0i3Vkh3Ha_3hPBtvIAy3WoTK2yiqS41HzSK7yk3FRAlBtpIEib338fdkTiosBxtdu36SdNUVM75zl6CVIFhTu=w681-h470-no" alt="" title="Air Jordan 14 Rip Hamilton"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton">Air Jordan 14 Rip Hamilton</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/kUjaOYxjEkAh34S-Ub2QSZwdOwHyFnGFLBZULta3_bn1_myPMAwJXiEEsAAtc1ktCQwHCuKhSqSYsWXFBEIZxdfKuykoDEZWwO-dDI3_JeAshbYvyILEHUu0XaUpRn0mj7gOx10V52t8gRGYPCW7QXGImkPGGhvBPzBDVVqh9lKGtkuPeePmTnpRSmwp0LG1WHcIzUWnMqPBWQeHAat6Q-Tq7niXNb96ddEZsMEdHK1nmHVlNaeqFBNtTxk6yYRkFNCvtfBayqy-Rqt4CPU5tThxbTI4AIUCI6JLxJd_VJizrVNDEe2xZ_tiQdkC5ASIoHpX8sfvAB8zRUsMVJ6oMUt5FH_4GBNXDCtFRmr65Qt0JV1h4bBJffu2L272Q_vpD76wn-YNGW8VCtZcheHu_X-A4gdYQEC0HN0BenY-MOuUBqKEjXAc0SxWeP7W9RN55jlqUFK0nzEYydVjec2stdQIngVfg_FvKxvHXfM4XdtMpqeJnp3Pzyk8xjz30sAZd0f2HQ6zfdPjk-OkV2-WrC0_qW0L8Rq3zrUbq52n3BN7gm7sctU_CUlBmoQIgJDQBYk1Siv4tfSq9pL1R4GdaOlWQdxEuhZi8bTYC8GGAgNGl3SMAZGvk7nu6QnnwEZjZ7mZwbcqgyRKa89cOREMUvIkVJ8Q8lZu=w926-h672-no" alt="" title="Jordan Proto React Triple White"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White">Jordan Proto React Triple White</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4cDUjSODZSaXWfHyZKb9q3Fn7FHA4uB0KSBs0MtFHC0dc6AJb1zeAl_X2LOKalK9C7VBFhTqRQ9fw1ESgUr9ZUKFbOzD94i_s96nvkICOqrsYnzrE2nEAQHoEaGOF4O8GAI6T4CGFbgcQhNzjpRlSY60NyPu5Cmq81FRpEOFRzTOtSa_NnWzMmfwO0yxtPbcg5U6YBUsus8shv3SA7CjULLfaP38nZAuWVgq8PMaaeCQ_eSrK8NJSEVQjyyxmqb-1I7zO8Kvvzvwi--ibMr52CF8h-GusBzSq5ZuzvZRCGu_u8CyfoXw7pwWbOmHnLOdcQ9d2PCSW_IxEMGfmEuU7NxMSsW3Ga4r35_wLB7cjvlPC9OjCV50tfekXjZBS_476mzlf4G9jR7Ju1GqgjXah9Uqc_0Y8N-Br8_JCtIlRSuLxAiebwd7AvFVlgWId9MYxBWnRT3cTyD8SH7q5WwO-CIbKAOSKsNcrrTgFxQvqn9yklBU1u5X5fdTlTBk4WSYorsWZAug0z9BOymRLnrhTbnA0vpBPFROWD-aL1glg-eUpFSfgD4xhWsOqJNY9krQ2UbLSGXQ5gYWj0ovLS7Yz3UKFY2qrVWpqkpbfyN98es9NJ-7LTUs2MLq1rX_2FaQmyq5mVndd7VGzQOHy9hDULG-5H-0LvGd=w900-h566-no" alt="" title="adidas Yeezy Boost 350 V2 Hyperspace"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace">adidas Yeezy Boost 350 V2 Hyperspace</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_30_5eb099e492906" data-td_block_id="td_uid_30_5eb099e492906"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_30_5eb099e492906" data-td_block_id="td_uid_30_5eb099e492906"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18581"><a href="http://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div>                </div>

                <div class="td-pb-span5 td-sub-footer-copy">
                    &copy; 2018 The Hip Hop Chronicles Media Group                </div>
            </div>
        </div>
    </div>
</div><!--close td-outer-wrap-->

	<div id="wpcp-error-message" class="msgmsg-box-wpcp warning-wpcp hideme"><span>error: </span>Not Prohibited. ✌️</div>
	<script>
	var timeout_result;
	function show_wpcp_message(smessage)
	{
		if (smessage !== "")
			{
			var smessage_text = '<span>Alert: </span>'+smessage;
			document.getElementById("wpcp-error-message").innerHTML = smessage_text;
			document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp showme";
			clearTimeout(timeout_result);
			timeout_result = setTimeout(hide_message, 3000);
			}
	}
	function hide_message()
	{
		document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp hideme";
	}
	</script>
		<style type="text/css">
	#wpcp-error-message {
	    direction: ltr;
	    text-align: center;
	    transition: opacity 900ms ease 0s;
	    z-index: 99999999;
	}
	.hideme {
    	opacity:0;
    	visibility: hidden;
	}
	.showme {
    	opacity:1;
    	visibility: visible;
	}
	.msgmsg-box-wpcp {
		border-radius: 10px;
		color: #555;
		font-family: Tahoma;
		font-size: 11px;
		margin: 10px;
		padding: 10px 36px;
		position: fixed;
		width: 255px;
		top: 50%;
  		left: 50%;
  		margin-top: -10px;
  		margin-left: -130px;
  		-webkit-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
		-moz-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
		box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
	}
	.msgmsg-box-wpcp span {
		font-weight:bold;
		text-transform:uppercase;
	}
	.error-wpcp {		background:#ffecec url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/error.png') no-repeat 10px 50%;
		border:1px solid #f5aca6;
	}
	.success {
		background:#e9ffd9 url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/success.png') no-repeat 10px 50%;
		border:1px solid #a6ca8a;
	}
	.warning-wpcp {
		background:#ffecec url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/warning.png') no-repeat 10px 50%;
		border:1px solid #f5aca6;
	}
	.notice {
		background:#e3f7fc url('http://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/notice.png') no-repeat 10px 50%;
		border:1px solid #8ed9f6;
	}
    </style>


    <!--

        Theme: Newspaper by tagDiv 2016
        Version: 7.2 (rara)
        Deploy mode: deploy
        
        uid: 5eb099e49c7ba
    -->

    <link rel='stylesheet' id='so-css-Newspaper-css'  href='http://weuponithiphop.info/wp-content/uploads/so-css/so-css-Newspaper.css?ver=1528674688' type='text/css' media='all' />
<link rel='stylesheet' id='soliloquy-lite-style-css'  href='http://weuponithiphop.info/wp-content/plugins/soliloquy-lite/assets/css/soliloquy.css?ver=2.5.7' type='text/css' media='all' />
<link rel='stylesheet' id='soliloquy-liteclassic-theme-css'  href='http://weuponithiphop.info/wp-content/plugins/soliloquy-lite/themes/classic/style.css?ver=2.5.7' type='text/css' media='all' />
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/themes/Newspaper/js/tagdiv_theme.js?ver=7.2'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/comment-reply.min.js?ver=4.9.14'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-includes/js/wp-embed.min.js?ver=4.9.14'></script>
<script type='text/javascript' src='http://weuponithiphop.info/wp-content/plugins/soliloquy-lite/assets/js/min/soliloquy-min.js?ver=2.5.7'></script>

<!-- JS generated by theme -->

<script>
    


            

	            // if the theme has tdBackstr support, it means this already uses it
                if ( 'undefined' !== typeof window.tdBackstr ) {

                    (function(){
                        // the site background td-backstretch jquery object is dynamically added in DOM, and after any translation effects are applied over td-backstretch
                        var wrapper_image_jquery_obj = jQuery( '<div class=\'backstretch\'></div>' );
                        var image_jquery_obj = jQuery( '<img class=\'td-backstretch not-parallax\' src=\'http://weuponithiphop.info/wp-content/uploads/20-black-paper-different-texture-types-a4-sandgrain-.jpg\'>' );

                        wrapper_image_jquery_obj.append( image_jquery_obj );

                        jQuery( 'body' ).prepend( wrapper_image_jquery_obj );

                        var td_backstr_item = new tdBackstr.item();

                        td_backstr_item.wrapper_image_jquery_obj = wrapper_image_jquery_obj;
                        td_backstr_item.image_jquery_obj = image_jquery_obj;

	                    tdBackstr.add_item( td_backstr_item );

                    })();
                }

            
            
jQuery(window).ready(function() {
(function(){
var td_backstr_item = new tdBackstr.item();
td_backstr_item.wrapper_image_jquery_obj = jQuery( "#td-full-screen-header-image" );
td_backstr_item.image_jquery_obj = td_backstr_item.wrapper_image_jquery_obj.find( 'img:first' );
tdBackstr.add_item( td_backstr_item );
jQuery('.td-read-down a').click(function(event){
event.preventDefault();
var header_wrap = jQuery( '.td-full-screen-header-image-wrap:first' )
if ( 1 === header_wrap.length ) {
tdUtil.scrollToPosition(header_wrap.height() + header_wrap.offset().top, 1200);
}
});
})();
});

                jQuery().ready(function jQuery_ready() {
                    tdAjaxCount.tdGetViewsCountsAjax("post","[38207]");
                });
            

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'http://weuponithiphop.info/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'http://weuponithiphop.info/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>

			<script type="text/javascript">
			if ( typeof soliloquy_slider === 'undefined' || false === soliloquy_slider ) {soliloquy_slider = {};}jQuery('#soliloquy-container-30342').css('height', Math.round(jQuery('#soliloquy-container-30342').width()/(960/300)));jQuery(window).load(function(){var $ = jQuery;var soliloquy_container_30342 = $('#soliloquy-container-30342'),soliloquy_30342 = $('#soliloquy-30342');soliloquy_slider['30342'] = soliloquy_30342.soliloquy({slideSelector: '.soliloquy-item',speed: 0,pause: 2000,auto: 1,useCSS: 0,keyboard: true,adaptiveHeight: 1,adaptiveHeightSpeed: 400,infiniteLoop: 1,mode: 'fade',pager: 1,controls: 1,nextText: '',prevText: '',startText: '',stopText: '',onSliderLoad: function(currentIndex){soliloquy_container_30342.find('.soliloquy-active-slide').removeClass('soliloquy-active-slide').attr('aria-hidden','true');soliloquy_container_30342.css({'height':'auto','background-image':'none'});if ( soliloquy_container_30342.find('.soliloquy-slider li').length > 1 ) {soliloquy_container_30342.find('.soliloquy-controls').fadeTo(300, 1);}soliloquy_30342.find('.soliloquy-item:not(.soliloquy-clone):eq(' + currentIndex + ')').addClass('soliloquy-active-slide').attr('aria-hidden','false');soliloquy_container_30342.find('.soliloquy-clone').find('*').removeAttr('id');soliloquy_container_30342.find('.soliloquy-controls-direction').attr('aria-label','carousel buttons').attr('aria-controls', 'soliloquy-container-30342');soliloquy_container_30342.find('.soliloquy-controls-direction a.soliloquy-prev').attr('aria-label','previous');soliloquy_container_30342.find('.soliloquy-controls-direction a.soliloquy-next').attr('aria-label','next');},onSlideBefore: function(element, oldIndex, newIndex){soliloquy_container_30342.find('.soliloquy-active-slide').removeClass('soliloquy-active-slide').attr('aria-hidden','true');$(element).addClass('soliloquy-active-slide').attr('aria-hidden','false');},onSlideAfter: function(element, oldIndex, newIndex){},});});			</script>
			
</body>
</html>