<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"
	prefix="og: https://ogp.me/ns#" > <!--<![endif]-->
<head>
    
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://weuponithiphop.info/xmlrpc.php" />
    		<style>
		#wpadminbar #wp-admin-bar-cp_plugins_top_button .ab-icon:before {
			content: "\f533";
			top: 3px;
		}
		#wpadminbar #wp-admin-bar-cp_plugins_top_button .ab-icon {
			transform: rotate(45deg);
		}
		</style>
	<style>
#wpadminbar #wp-admin-bar-wccp_free_top_button .ab-icon:before {
	content: "\f160";
	color: #02CA02;
	top: 3px;
}
#wpadminbar #wp-admin-bar-wccp_free_top_button .ab-icon {
	transform: rotate(45deg);
}
</style>

		<!-- All in One SEO 4.0.15 -->
		<title>Music Video: Juice WRLD – Conversations</title>
		<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
		<link rel="canonical" href="https://weuponithiphop.info/2021/02/23/music-video-juice-wrld-conversations/" />
		<meta property="og:site_name" content="WeUpOnIt | The #1 New Source For Hip Hop &amp; R&amp;B" />
		<meta property="og:type" content="article" />
		<meta property="og:title" content="Music Video: Juice WRLD – Conversations" />
		<meta property="og:url" content="https://weuponithiphop.info/2021/02/23/music-video-juice-wrld-conversations/" />
		<meta property="article:published_time" content="2021-02-23T10:22:26Z" />
		<meta property="article:modified_time" content="2021-02-23T10:22:26Z" />
		<meta property="twitter:card" content="summary" />
		<meta property="twitter:domain" content="weuponithiphop.info" />
		<meta property="twitter:title" content="Music Video: Juice WRLD – Conversations" />
		<meta name="google" content="nositelinkssearchbox" />
		<script type="application/ld+json" class="aioseo-schema">
			{"@context":"https:\/\/schema.org","@graph":[{"@type":"WebSite","@id":"https:\/\/weuponithiphop.info\/#website","url":"https:\/\/weuponithiphop.info\/","name":"WeUpOnIt","description":"The #1 New Source For Hip Hop & R&B","publisher":{"@id":"https:\/\/weuponithiphop.info\/#organization"}},{"@type":"Organization","@id":"https:\/\/weuponithiphop.info\/#organization","name":"WeUpOnIt","url":"https:\/\/weuponithiphop.info\/"},{"@type":"BreadcrumbList","@id":"https:\/\/weuponithiphop.info\/2021\/02\/23\/music-video-juice-wrld-conversations\/#breadcrumblist","itemListElement":[{"@type":"ListItem","@id":"https:\/\/weuponithiphop.info\/#listItem","position":"1","item":{"@id":"https:\/\/weuponithiphop.info\/#item","name":"Home","description":"The #1 New Source For Hip Hop & R&B","url":"https:\/\/weuponithiphop.info\/"},"nextItem":"https:\/\/weuponithiphop.info\/2021\/#listItem"},{"@type":"ListItem","@id":"https:\/\/weuponithiphop.info\/2021\/#listItem","position":"2","item":{"@id":"https:\/\/weuponithiphop.info\/2021\/#item","name":"2021","url":"https:\/\/weuponithiphop.info\/2021\/"},"nextItem":"https:\/\/weuponithiphop.info\/2021\/02\/#listItem","previousItem":"https:\/\/weuponithiphop.info\/#listItem"},{"@type":"ListItem","@id":"https:\/\/weuponithiphop.info\/2021\/02\/#listItem","position":"3","item":{"@id":"https:\/\/weuponithiphop.info\/2021\/02\/#item","name":"February","url":"https:\/\/weuponithiphop.info\/2021\/02\/"},"nextItem":"https:\/\/weuponithiphop.info\/2021\/02\/23\/#listItem","previousItem":"https:\/\/weuponithiphop.info\/2021\/#listItem"},{"@type":"ListItem","@id":"https:\/\/weuponithiphop.info\/2021\/02\/23\/#listItem","position":"4","item":{"@id":"https:\/\/weuponithiphop.info\/2021\/02\/23\/#item","name":"23","url":"https:\/\/weuponithiphop.info\/2021\/02\/23\/"},"nextItem":"https:\/\/weuponithiphop.info\/2021\/02\/23\/music-video-juice-wrld-conversations\/#listItem","previousItem":"https:\/\/weuponithiphop.info\/2021\/02\/#listItem"},{"@type":"ListItem","@id":"https:\/\/weuponithiphop.info\/2021\/02\/23\/music-video-juice-wrld-conversations\/#listItem","position":"5","item":{"@id":"https:\/\/weuponithiphop.info\/2021\/02\/23\/music-video-juice-wrld-conversations\/#item","name":"Music Video: Juice WRLD - Conversations","url":"https:\/\/weuponithiphop.info\/2021\/02\/23\/music-video-juice-wrld-conversations\/"},"previousItem":"https:\/\/weuponithiphop.info\/2021\/02\/23\/#listItem"}]},{"@type":"Person","@id":"https:\/\/weuponithiphop.info\/author\/cyclone\/#author","url":"https:\/\/weuponithiphop.info\/author\/cyclone\/","name":"cyclone","image":{"@type":"ImageObject","@id":"https:\/\/weuponithiphop.info\/2021\/02\/23\/music-video-juice-wrld-conversations\/#authorImage","url":"https:\/\/secure.gravatar.com\/avatar\/6a747aaba64ebc36f309e25ac7e460e6?s=96&d=mm&r=g","width":"96","height":"96","caption":"cyclone"}},{"@type":"WebPage","@id":"https:\/\/weuponithiphop.info\/2021\/02\/23\/music-video-juice-wrld-conversations\/#webpage","url":"https:\/\/weuponithiphop.info\/2021\/02\/23\/music-video-juice-wrld-conversations\/","name":"Music Video: Juice WRLD \u2013 Conversations","inLanguage":"en-US","isPartOf":{"@id":"https:\/\/weuponithiphop.info\/#website"},"breadcrumb":{"@id":"https:\/\/weuponithiphop.info\/2021\/02\/23\/music-video-juice-wrld-conversations\/#breadcrumblist"},"author":"https:\/\/weuponithiphop.info\/2021\/02\/23\/music-video-juice-wrld-conversations\/#author","creator":"https:\/\/weuponithiphop.info\/2021\/02\/23\/music-video-juice-wrld-conversations\/#author","image":{"@type":"ImageObject","@id":"https:\/\/weuponithiphop.info\/#mainImage","url":"https:\/\/i.imgur.com\/Mt8TkFH.jpg"},"primaryImageOfPage":{"@id":"https:\/\/weuponithiphop.info\/2021\/02\/23\/music-video-juice-wrld-conversations\/#mainImage"},"datePublished":"2021-02-23T10:22:26+00:00","dateModified":"2021-02-23T10:22:26+00:00"},{"@type":"Article","@id":"https:\/\/weuponithiphop.info\/2021\/02\/23\/music-video-juice-wrld-conversations\/#article","name":"Music Video: Juice WRLD \u2013 Conversations","headline":"Music Video: Juice WRLD - Conversations","author":{"@id":"https:\/\/weuponithiphop.info\/author\/cyclone\/#author"},"publisher":{"@id":"https:\/\/weuponithiphop.info\/#organization"},"datePublished":"2021-02-23T10:22:26+00:00","dateModified":"2021-02-23T10:22:26+00:00","articleSection":"Music Video, Juice WRLD","mainEntityOfPage":{"@id":"https:\/\/weuponithiphop.info\/2021\/02\/23\/music-video-juice-wrld-conversations\/#webpage"},"isPartOf":{"@id":"https:\/\/weuponithiphop.info\/2021\/02\/23\/music-video-juice-wrld-conversations\/#webpage"},"image":{"@type":"ImageObject","@id":"https:\/\/weuponithiphop.info\/#articleImage","url":"https:\/\/i.imgur.com\/Mt8TkFH.jpg"}}]}
		</script>
		<!-- All in One SEO -->

<meta property="og:image" content="https://i.imgur.com/Mt8TkFH.jpg" /><meta name="author" content="cyclone">
<link rel="icon" type="image/png" href="http://weuponithiphop.info/wp-content/uploads/weuponitlogoCAP-500x457.png"><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Feed" href="https://weuponithiphop.info/feed/" />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Comments Feed" href="https://weuponithiphop.info/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Music Video: Juice WRLD &#8211; Conversations Comments Feed" href="https://weuponithiphop.info/2021/02/23/music-video-juice-wrld-conversations/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/weuponithiphop.info\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.16"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='google_font_open_sans-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;ver=4.9.16' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_roboto-css'  href='https://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C900%2C500italic%2C400%2C300&#038;ver=4.9.16' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Roboto+Condensed%3A400%2C700&#038;ver=4.9.16' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='https://weuponithiphop.info/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='https://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=4.12' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://weuponithiphop.info/wp-content/themes/Newspaper/style.css?ver=7.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css'  href='https://weuponithiphop.info/wp-content/themes/Newspaper/includes/demos/what/demo_style.css?ver=7.2' type='text/css' media='all' />
<script type='text/javascript' src='https://weuponithiphop.info/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://weuponithiphop.info/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://weuponithiphop.info/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1'></script>
<link rel='https://api.w.org/' href='https://weuponithiphop.info/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://weuponithiphop.info/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://weuponithiphop.info/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Album Stream: SmooVth &#038; Giallo Point &#8211; Amongst Wolves' href='https://weuponithiphop.info/2021/02/22/album-stream-smoovth-giallo-point-amongst-wolves/' />
<link rel='next' title='New Music: K Camp &#8211; No More Parties Freestyle' href='https://weuponithiphop.info/2021/02/23/new-music-k-camp-no-more-parties-freestyle/' />
<meta name="generator" content="WordPress 4.9.16" />
<link rel='shortlink' href='https://weuponithiphop.info/?p=43791' />
<link rel="alternate" type="application/json+oembed" href="https://weuponithiphop.info/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fweuponithiphop.info%2F2021%2F02%2F23%2Fmusic-video-juice-wrld-conversations%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://weuponithiphop.info/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fweuponithiphop.info%2F2021%2F02%2F23%2Fmusic-video-juice-wrld-conversations%2F&#038;format=xml" />

<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>
<script id="wpcp_disable_selection" type="text/javascript">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</script>
<script id="wpcp_disable_Right_Click" type="text/javascript">
document.ondragstart = function() { return false;}
	function nocontext(e) {
	   return false;
	}
	document.oncontextmenu = nocontext;
</script>
<!-- Analytics by WP-Statistics v13.0.6 - https://wp-statistics.com/ -->
<!--[if lt IE 9]><script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="https://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]-->
<!-- JS generated by theme -->

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var tds_login_sing_in_widget="show";
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_ajax_url="https:\/\/weuponithiphop.info\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=7.2";
var td_get_template_directory_uri="https:\/\/weuponithiphop.info\/wp-content\/themes\/Newspaper";
var tds_snap_menu="snap";
var tds_logo_on_sticky="show_header_logo";
var tds_header_style="5";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#dd3333";
var tds_smart_sidebar="enabled";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>


<!-- Header style compiled by theme -->

<style>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</style>

<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>

<body class="post-template-default single single-post postid-43791 single-format-standard unselectable music-video-juice-wrld-conversations td-what wpb-js-composer js-comp-ver-4.12 vc_responsive td-boxed-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponit_com" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
                    <div class="td-menu-login-section">
                
    <div class="td-guest-wrap">
        <div class="td-menu-avatar"><div class="td-avatar-container"><img alt='' src='https://secure.gravatar.com/avatar/?s=80&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo avatar-default' height='80' width='80' /></div></div>
        <div class="td-menu-login"><a id="login-link-mob">Sign in</a></div>
    </div>
            </div>
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-top-menu-container"><ul id="menu-top-menu" class="td-mobile-main-menu"><li id="menu-item-317" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-317"><a href="https://weuponithiphop.info/category/new-music/">New Music</a></li>
<li id="menu-item-706" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-706"><a href="https://weuponithiphop.info/category/album-stream-mixtapes/">Album Stream</a></li>
<li id="menu-item-314" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-314"><a href="https://weuponithiphop.info/category/music-video/">Videos</a></li>
<li id="menu-item-316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-316"><a href="https://weuponithiphop.info/category/latest-news/">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-0" class="menu-item-0"><a href="https://weuponithiphop.info/category/latest-news/album-news/">Album News</a></li>
	<li class="menu-item-0"><a href="https://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a></li>
	<li class="menu-item-0"><a href="https://weuponithiphop.info/category/latest-news/flashback/">Flashback</a></li>
	<li class="menu-item-0"><a href="https://weuponithiphop.info/category/latest-news/interviews/">Interviews</a></li>
	<li class="menu-item-0"><a href="https://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></li>
</ul>
</li>
<li id="menu-item-705" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-705"><a href="https://weuponithiphop.info/category/fashion/">Fashion<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li class="menu-item-0"><a href="https://weuponithiphop.info/category/fashion/kicks/">Kicks</a></li>
</ul>
</li>
<li id="menu-item-18581" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18581"><a href="https://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li id="menu-item-3199" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
            <div id="login-form-mobile" class="td-register-section">
            
            <div id="td-login-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-login-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign in</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
	                <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
	                <div class="td-login-info-text"><a href="#" id="forgot-pass-link-mob">Forgot your password?</a></div>
                </div>
            </div>

            

            <div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
                <!-- close button -->
	            <div class="td-forgot-pass-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Password recovery</div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title">Recover your password</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
	                <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
                </div>
            </div>
        </div>
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="https://weuponithiphop.info/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap">
    
        <!--
Header style 5
-->

<div class="td-header-wrap td-header-style-5">

    <div class="td-header-top-menu-full">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div >

                Tuesday, February 23, 2021
            </div>
        </div>
    <ul class="top-header-menu td_ul_login"><li class="menu-item"><a class="td-login-modal-js menu-item" href="#login-form" data-effect="mpf-td-login-effect">Sign in / Join</a><span class="td-sp-ico-login td_sp_login_ico_style"></span></li></ul><div class="menu-top-container"><ul id="menu-main" class="top-header-menu"><li id="menu-item-79" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-79"><a href="http://weuponithiphop.info">Home</a></li>
<li id="menu-item-81" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-81"><a target="_blank" href="http://weuponitradio.com">Power 105.1 WeUpOnIt Radio</a></li>
<li id="menu-item-80" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-80"><a target="_blank" href="https://shop.spreadshirt.com/freshandcleantees/">Shop</a></li>
<li id="menu-item-18582" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18582"><a href="https://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li id="menu-item-18583" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18583"><a href="https://weuponithiphop.info/privacy-policy-2/">Privacy Policy</a></li>
</ul></div></div>
        <div class="td-header-sp-top-widget">
    
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponit_com" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div>
    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <ul class="td-login-tabs">
                        <li><a id="login-link" class="td_login_tab_focus">LOG IN</a></li>
                    </ul>



                    <div class="td-login-wrap">
                        <div class="td_display_err"></div>

                        <div id="td-login-div" class="">
                            <div class="td-login-panel-title">Welcome! Log into your account</div>
                            <input class="td-login-input" type="text" name="login_email" id="login_email" placeholder="your username" value="" required>
                            <input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" placeholder="your password" required>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Log In">


                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password?</a></div>


                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-display-none">
                            <div class="td-login-panel-title">Recover your password</div>
                            <input class="td-login-input" type="text" name="forgot_email" id="forgot_email" placeholder="your email" value="" required>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Pass">
                        </div>




                    </div>
                </div>
                        </div>
    </div>

    <div class="td-header-menu-wrap-full">
        <div class="td-header-menu-wrap">
            <div class="td-container td-header-row td-header-main-menu black-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-menu">
        		<a class="td-mobile-logo td-sticky-header" href="https://weuponithiphop.info/">
			<img class="td-retina-data" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-5.png" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-5.png" alt=""/>
		</a>
			<a class="td-header-logo td-sticky-header" href="https://weuponithiphop.info/">
			<img class="td-retina-data" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" alt=""/>
			<span class="td-visual-hidden">WeUpOnIt</span>
		</a>
	    </div>
    <div class="menu-top-menu-container"><ul id="menu-top-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-mega-menu menu-item-317"><a href="https://weuponithiphop.info/category/new-music/">New Music</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_1_60352cd891e97_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_1_60352cd891e97" ><script>var block_td_uid_1_60352cd891e97 = new tdBlock();
block_td_uid_1_60352cd891e97.id = "td_uid_1_60352cd891e97";
block_td_uid_1_60352cd891e97.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"43","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_1_60352cd891e97_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_1_60352cd891e97.td_column_number = "3";
block_td_uid_1_60352cd891e97.block_type = "td_block_mega_menu";
block_td_uid_1_60352cd891e97.post_count = "5";
block_td_uid_1_60352cd891e97.found_posts = "3740";
block_td_uid_1_60352cd891e97.header_color = "";
block_td_uid_1_60352cd891e97.ajax_pagination_infinite_stop = "";
block_td_uid_1_60352cd891e97.max_num_pages = "748";
tdBlocksArray.push(block_td_uid_1_60352cd891e97);
</script><div id=td_uid_1_60352cd891e97 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/23/new-music-k-camp-no-more-parties-freestyle/" rel="bookmark" title="New Music: K Camp &#8211; No More Parties Freestyle"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/sUJtm1b.jpg" alt="" title="New Music: K Camp &#8211; No More Parties Freestyle"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/23/new-music-k-camp-no-more-parties-freestyle/" rel="bookmark" title="New Music: K Camp &#8211; No More Parties Freestyle">New Music: K Camp &#8211; No More Parties Freestyle</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/22/new-music-duke-deuce-foogiano-spin/" rel="bookmark" title="New Music: Duke Deuce &#038; Foogiano &#8211; Spin"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/rL9k1Dm.jpg" alt="" title="New Music: Duke Deuce &#038; Foogiano &#8211; Spin"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/22/new-music-duke-deuce-foogiano-spin/" rel="bookmark" title="New Music: Duke Deuce &#038; Foogiano &#8211; Spin">New Music: Duke Deuce &#038; Foogiano &#8211; Spin</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/22/new-music-becky-g-burna-boy-rotate/" rel="bookmark" title="New Music: Becky G &#038; Burna Boy &#8211; Rotate"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/dVpzsd2.jpg" alt="" title="New Music: Becky G &#038; Burna Boy &#8211; Rotate"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/22/new-music-becky-g-burna-boy-rotate/" rel="bookmark" title="New Music: Becky G &#038; Burna Boy &#8211; Rotate">New Music: Becky G &#038; Burna Boy &#8211; Rotate</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/21/new-music-the-yutes-ft-stove-god-cooks-in-the-kitchen/" rel="bookmark" title="New Music: The Yutes ft. Stove God Cooks &#8211; In The Kitchen"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/sucpxhg.jpg" alt="" title="New Music: The Yutes ft. Stove God Cooks &#8211; In The Kitchen"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/21/new-music-the-yutes-ft-stove-god-cooks-in-the-kitchen/" rel="bookmark" title="New Music: The Yutes ft. Stove God Cooks &#8211; In The Kitchen">New Music: The Yutes ft. Stove God Cooks &#8211; In The&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/21/new-music-rockie-fresh-ft-tobi-lou-jeff-kaale-gucci/" rel="bookmark" title="New Music: Rockie Fresh ft. Tobi Lou &#038; Jeff Kaale &#8211; Gucci"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/lYJ3ctT.jpg" alt="" title="New Music: Rockie Fresh ft. Tobi Lou &#038; Jeff Kaale &#8211; Gucci"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/21/new-music-rockie-fresh-ft-tobi-lou-jeff-kaale-gucci/" rel="bookmark" title="New Music: Rockie Fresh ft. Tobi Lou &#038; Jeff Kaale &#8211; Gucci">New Music: Rockie Fresh ft. Tobi Lou &#038; Jeff Kaale &#8211;&#8230;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_60352cd891e97" data-td_block_id="td_uid_1_60352cd891e97"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_1_60352cd891e97" data-td_block_id="td_uid_1_60352cd891e97"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-706"><a href="https://weuponithiphop.info/category/album-stream-mixtapes/">Album Stream</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_2_60352cd89836e_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_2_60352cd89836e" ><script>var block_td_uid_2_60352cd89836e = new tdBlock();
block_td_uid_2_60352cd89836e.id = "td_uid_2_60352cd89836e";
block_td_uid_2_60352cd89836e.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"97","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_2_60352cd89836e_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_2_60352cd89836e.td_column_number = "3";
block_td_uid_2_60352cd89836e.block_type = "td_block_mega_menu";
block_td_uid_2_60352cd89836e.post_count = "5";
block_td_uid_2_60352cd89836e.found_posts = "1369";
block_td_uid_2_60352cd89836e.header_color = "";
block_td_uid_2_60352cd89836e.ajax_pagination_infinite_stop = "";
block_td_uid_2_60352cd89836e.max_num_pages = "274";
tdBlocksArray.push(block_td_uid_2_60352cd89836e);
</script><div id=td_uid_2_60352cd89836e class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/22/album-stream-smoovth-giallo-point-amongst-wolves/" rel="bookmark" title="Album Stream: SmooVth &#038; Giallo Point &#8211; Amongst Wolves"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/x0cjn8X.jpg" alt="" title="Album Stream: SmooVth &#038; Giallo Point &#8211; Amongst Wolves"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/22/album-stream-smoovth-giallo-point-amongst-wolves/" rel="bookmark" title="Album Stream: SmooVth &#038; Giallo Point &#8211; Amongst Wolves">Album Stream: SmooVth &#038; Giallo Point &#8211; Amongst Wolves</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/22/album-stream-demrick-payday/" rel="bookmark" title="Album Stream: Demrick &#8211; Payday"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/lHRfA4j.jpg" alt="" title="Album Stream: Demrick &#8211; Payday"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/22/album-stream-demrick-payday/" rel="bookmark" title="Album Stream: Demrick &#8211; Payday">Album Stream: Demrick &#8211; Payday</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/21/mixtape-taylor-gang-taylor-nights/" rel="bookmark" title="Mixtape: Taylor Gang &#8211; Taylor Nights"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/WugBoWN.jpg" alt="" title="Mixtape: Taylor Gang &#8211; Taylor Nights"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/21/mixtape-taylor-gang-taylor-nights/" rel="bookmark" title="Mixtape: Taylor Gang &#8211; Taylor Nights">Mixtape: Taylor Gang &#8211; Taylor Nights</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/19/ep-stream-cj-loyalty-over-royalty/" rel="bookmark" title="EP Stream: CJ &#8211; Loyalty Over Royalty"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/t8puHY4.png" alt="" title="EP Stream: CJ &#8211; Loyalty Over Royalty"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/19/ep-stream-cj-loyalty-over-royalty/" rel="bookmark" title="EP Stream: CJ &#8211; Loyalty Over Royalty">EP Stream: CJ &#8211; Loyalty Over Royalty</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/19/ep-stream-kelly-rowland-k/" rel="bookmark" title="EP Stream: Kelly Rowland &#8211; K"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/324LvpK.jpg" alt="" title="EP Stream: Kelly Rowland &#8211; K"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/19/ep-stream-kelly-rowland-k/" rel="bookmark" title="EP Stream: Kelly Rowland &#8211; K">EP Stream: Kelly Rowland &#8211; K</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_60352cd89836e" data-td_block_id="td_uid_2_60352cd89836e"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_2_60352cd89836e" data-td_block_id="td_uid_2_60352cd89836e"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-314"><a href="https://weuponithiphop.info/category/music-video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_3_60352cd89e037_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_3_60352cd89e037" ><script>var block_td_uid_3_60352cd89e037 = new tdBlock();
block_td_uid_3_60352cd89e037.id = "td_uid_3_60352cd89e037";
block_td_uid_3_60352cd89e037.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_3_60352cd89e037_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_3_60352cd89e037.td_column_number = "3";
block_td_uid_3_60352cd89e037.block_type = "td_block_mega_menu";
block_td_uid_3_60352cd89e037.post_count = "5";
block_td_uid_3_60352cd89e037.found_posts = "4163";
block_td_uid_3_60352cd89e037.header_color = "";
block_td_uid_3_60352cd89e037.ajax_pagination_infinite_stop = "";
block_td_uid_3_60352cd89e037.max_num_pages = "833";
tdBlocksArray.push(block_td_uid_3_60352cd89e037);
</script><div id=td_uid_3_60352cd89e037 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/23/music-video-juice-wrld-conversations/" rel="bookmark" title="Music Video: Juice WRLD &#8211; Conversations"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/Mt8TkFH.jpg" alt="" title="Music Video: Juice WRLD &#8211; Conversations"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/23/music-video-juice-wrld-conversations/" rel="bookmark" title="Music Video: Juice WRLD &#8211; Conversations">Music Video: Juice WRLD &#8211; Conversations</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/22/music-video-kito-vanjess-channel-tres-recap/" rel="bookmark" title="Music Video: Kito, VanJess &#038; Channel Tres &#8211; Recap"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/wSxs6uT.jpg" alt="" title="Music Video: Kito, VanJess &#038; Channel Tres &#8211; Recap"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/22/music-video-kito-vanjess-channel-tres-recap/" rel="bookmark" title="Music Video: Kito, VanJess &#038; Channel Tres &#8211; Recap">Music Video: Kito, VanJess &#038; Channel Tres &#8211; Recap</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/22/music-video-trae-tha-truth-mysonne-i-gotta-win/" rel="bookmark" title="Music Video: Trae Tha Truth &#038; Mysonne &#8211; I Gotta Win"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/oNUIhRC.jpg" alt="" title="Music Video: Trae Tha Truth &#038; Mysonne &#8211; I Gotta Win"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/22/music-video-trae-tha-truth-mysonne-i-gotta-win/" rel="bookmark" title="Music Video: Trae Tha Truth &#038; Mysonne &#8211; I Gotta Win">Music Video: Trae Tha Truth &#038; Mysonne &#8211; I Gotta Win</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/22/music-video-stunna-4-vegas-hard/" rel="bookmark" title="Music Video: Stunna 4 Vegas &#8211; Hard"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/V2UrH6u.jpg" alt="" title="Music Video: Stunna 4 Vegas &#8211; Hard"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/22/music-video-stunna-4-vegas-hard/" rel="bookmark" title="Music Video: Stunna 4 Vegas &#8211; Hard">Music Video: Stunna 4 Vegas &#8211; Hard</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/21/music-video-philthy-rich-january-30th-crown-the-king/" rel="bookmark" title="Music Video: Philthy Rich &#8211; January 30th: Crown The King"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/CRejbl6.jpg" alt="" title="Music Video: Philthy Rich &#8211; January 30th: Crown The King"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/21/music-video-philthy-rich-january-30th-crown-the-king/" rel="bookmark" title="Music Video: Philthy Rich &#8211; January 30th: Crown The King">Music Video: Philthy Rich &#8211; January 30th: Crown The King</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_60352cd89e037" data-td_block_id="td_uid_3_60352cd89e037"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_3_60352cd89e037" data-td_block_id="td_uid_3_60352cd89e037"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-316"><a href="https://weuponithiphop.info/category/latest-news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_4_60352cd8a360a_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_4_60352cd8a360a" ><script>var block_td_uid_4_60352cd8a360a = new tdBlock();
block_td_uid_4_60352cd8a360a.id = "td_uid_4_60352cd8a360a";
block_td_uid_4_60352cd8a360a.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"29","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_4_60352cd8a360a_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_4_60352cd8a360a.td_column_number = "3";
block_td_uid_4_60352cd8a360a.block_type = "td_block_mega_menu";
block_td_uid_4_60352cd8a360a.post_count = "4";
block_td_uid_4_60352cd8a360a.found_posts = "1082";
block_td_uid_4_60352cd8a360a.header_color = "";
block_td_uid_4_60352cd8a360a.ajax_pagination_infinite_stop = "";
block_td_uid_4_60352cd8a360a.max_num_pages = "271";
tdBlocksArray.push(block_td_uid_4_60352cd8a360a);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_4_60352cd8a360a" id="td_uid_5_60352cd8a50a3" data-td_block_id="td_uid_4_60352cd8a360a" data-td_filter_value="" href="https://weuponithiphop.info/category/latest-news/">All</a><a class="mega-menu-sub-cat-td_uid_4_60352cd8a360a"  id="td_uid_6_60352cd8a51f8" data-td_block_id="td_uid_4_60352cd8a360a" data-td_filter_value="69" href="https://weuponithiphop.info/category/latest-news/album-news/">Album News</a><a class="mega-menu-sub-cat-td_uid_4_60352cd8a360a"  id="td_uid_7_60352cd8a538a" data-td_block_id="td_uid_4_60352cd8a360a" data-td_filter_value="80" href="https://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a><a class="mega-menu-sub-cat-td_uid_4_60352cd8a360a"  id="td_uid_8_60352cd8a550e" data-td_block_id="td_uid_4_60352cd8a360a" data-td_filter_value="2189" href="https://weuponithiphop.info/category/latest-news/flashback/">Flashback</a><a class="mega-menu-sub-cat-td_uid_4_60352cd8a360a"  id="td_uid_9_60352cd8a5691" data-td_block_id="td_uid_4_60352cd8a360a" data-td_filter_value="10" href="https://weuponithiphop.info/category/latest-news/interviews/">Interviews</a><a class="mega-menu-sub-cat-td_uid_4_60352cd8a360a"  id="td_uid_10_60352cd8a5831" data-td_block_id="td_uid_4_60352cd8a360a" data-td_filter_value="130" href="https://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></div></div><div id=td_uid_4_60352cd8a360a class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/22/video-tyler-the-creators-coca-cola-ad/" rel="bookmark" title="Video: Tyler, The Creator&#8217;s Coca-Cola Ad"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/5psm8fC.jpg" alt="" title="Video: Tyler, The Creator&#8217;s Coca-Cola Ad"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/22/video-tyler-the-creators-coca-cola-ad/" rel="bookmark" title="Video: Tyler, The Creator&#8217;s Coca-Cola Ad">Video: Tyler, The Creator&#8217;s Coca-Cola Ad</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/10/jay-z-mary-j-blige-ll-cool-j-nominated-for-2021-rock-roll-hall-of-fame/" rel="bookmark" title="JAY-Z, Mary J. Blige, LL Cool J Nominated For 2021 Rock &#038; Roll Hall Of Fame"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/DTwXuX8.jpg" alt="" title="JAY-Z, Mary J. Blige, LL Cool J Nominated For 2021 Rock &#038; Roll Hall Of Fame"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/10/jay-z-mary-j-blige-ll-cool-j-nominated-for-2021-rock-roll-hall-of-fame/" rel="bookmark" title="JAY-Z, Mary J. Blige, LL Cool J Nominated For 2021 Rock &#038; Roll Hall Of Fame">JAY-Z, Mary J. Blige, LL Cool J Nominated For 2021 Rock&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/08/video-drake-stars-in-state-farm-super-bowl-lv-ad/" rel="bookmark" title="Video: Drake Stars In State Farm Super Bowl LV Ad"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/1VkSF6x.jpg" alt="" title="Video: Drake Stars In State Farm Super Bowl LV Ad"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/08/video-drake-stars-in-state-farm-super-bowl-lv-ad/" rel="bookmark" title="Video: Drake Stars In State Farm Super Bowl LV Ad">Video: Drake Stars In State Farm Super Bowl LV Ad</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/01/19/video-the-late-pop-smoke-to-appear-in-eddie-huangs-directorial-debut-boogie/" rel="bookmark" title="Video: The Late Pop Smoke To Appear In Eddie Huang’s Directorial Debut, ‘BOOGIE’"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/t6Tym08.jpg" alt="" title="Video: The Late Pop Smoke To Appear In Eddie Huang’s Directorial Debut, ‘BOOGIE’"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/01/19/video-the-late-pop-smoke-to-appear-in-eddie-huangs-directorial-debut-boogie/" rel="bookmark" title="Video: The Late Pop Smoke To Appear In Eddie Huang’s Directorial Debut, ‘BOOGIE’">Video: The Late Pop Smoke To Appear In Eddie Huang’s Directorial&#8230;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_4_60352cd8a360a" data-td_block_id="td_uid_4_60352cd8a360a"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_4_60352cd8a360a" data-td_block_id="td_uid_4_60352cd8a360a"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-705"><a href="https://weuponithiphop.info/category/fashion/">Fashion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_11_60352cd8bf803_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_11_60352cd8bf803" ><script>var block_td_uid_11_60352cd8bf803 = new tdBlock();
block_td_uid_11_60352cd8bf803.id = "td_uid_11_60352cd8bf803";
block_td_uid_11_60352cd8bf803.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"77","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_11_60352cd8bf803_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_11_60352cd8bf803.td_column_number = "3";
block_td_uid_11_60352cd8bf803.block_type = "td_block_mega_menu";
block_td_uid_11_60352cd8bf803.post_count = "4";
block_td_uid_11_60352cd8bf803.found_posts = "158";
block_td_uid_11_60352cd8bf803.header_color = "";
block_td_uid_11_60352cd8bf803.ajax_pagination_infinite_stop = "";
block_td_uid_11_60352cd8bf803.max_num_pages = "40";
tdBlocksArray.push(block_td_uid_11_60352cd8bf803);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_11_60352cd8bf803" id="td_uid_12_60352cd8c1007" data-td_block_id="td_uid_11_60352cd8bf803" data-td_filter_value="" href="https://weuponithiphop.info/category/fashion/">All</a><a class="mega-menu-sub-cat-td_uid_11_60352cd8bf803"  id="td_uid_13_60352cd8c10fc" data-td_block_id="td_uid_11_60352cd8bf803" data-td_filter_value="76" href="https://weuponithiphop.info/category/fashion/kicks/">Kicks</a></div></div><div id=td_uid_11_60352cd8bf803 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/LVT4Mid8WL4wHUdO9X2OZmZxxgbREs2lVtszOdEBaO6hJB0JS3yQOAyhNSdCyPmv0amBDTgNGpOlRPXPjKCl6yIlo2joyH3rQRI7CUdX09BJtQI1r5jy1_7BQtDhw4AxUhpUwIh35rNS3lTy7uq-FdPff10JN6srr9mwZ7zr04GQFxBVEXwCfC5rNVehXhY_wGCRVsmevYmdkBWEmB8dvOzBHY78NBBjcHNArS_S-2M0FJgDh8v9m9vEh78k_XmZg-AERctsf0bkODuPi1EcNJq_RnJIV6b0GG-VtKjo-OVPmYghWJYf1HiP9c58cQ98oABU8BDFdLqsBtNt4K0NmyHYQlX39W9k_d83wEHZ1-EacQa2o01VrYSn12HnZ1l88fMzu9PKv6EGmcRZNwpepycW7_9EQnhxIPDdVCmRLXUasUED9OXr-zJmnBcnSnLCa06k1ZymQym1LiSFEv1c3aPHnmnD3GY8nL7q5jPJr4HsABR0WCqMebcF3HF_0deNd0zgRBCGMxW-VzlIIHZiHuBeSPEPvUL149GJ5swSSvKm1uGEi1HlLBj9omJSU7mDWzO0p_7l-l7-4_ureEsGsgB8cX1t8t2TQcFeRgqqF1CXlZFYYC2K0iMb4jPsijsw_rtO7pmKvbngqHfgYpGeh_qLmDWeicR7=w1195-h796-no" alt="" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch">Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/fHEwwMf8DoiXlqkfibQS1Z1XXbviORbV9raaI44tOTXrWo7GgqM3gA-vswE10gFtTQUGGwNG7nWAACwHjxPuiubliYBN_dqtBZh2WIpxvumiJ-hSLK0TNWB2cB8Iw2STT5gcp_KqlDh_e4xng1vidI8EXdp_ooh5uDI-JV1HQ9dGnM5nxl_b-v8znqj-Rl_mGB7y4Lu9zsFNWHU7SriqQQJaKrKEEnb9T8zxmGLaL0zq7ilYpnUEhWulDDr9xc82wdr__WzRBm5YEskVpDAnGM2NDZwTZpjbe4QDdxeixWnSXNK_oDzaL7WTbCpkD33OK88BlI5JmFRQ5VmD11UQ2htB7-9WoahHvb4XmBsbLXpEMl1JmEP4sPx06VduzFnBNo-J90WI0n1AEIIcEYVbRywrkGJXbzmH__In9ZIg0EV24OcGGbeKl12HxTdZwucqsNnuZeNjiMHISQ7i8cfzm3N7X7Zenl74zsKIKeKWoIGxh6MTlVADvgHcrHebnjcSgil2vBeFyz_AP45aOv9SOwbzfVLGS0CNfe1s9b2J7qZgjcBk9QPEXCl2kygvzmGXFvU_3xBuW6S0i3Vkh3Ha_3hPBtvIAy3WoTK2yiqS41HzSK7yk3FRAlBtpIEib338fdkTiosBxtdu36SdNUVM75zl6CVIFhTu=w681-h470-no" alt="" title="Air Jordan 14 Rip Hamilton"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton">Air Jordan 14 Rip Hamilton</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/kUjaOYxjEkAh34S-Ub2QSZwdOwHyFnGFLBZULta3_bn1_myPMAwJXiEEsAAtc1ktCQwHCuKhSqSYsWXFBEIZxdfKuykoDEZWwO-dDI3_JeAshbYvyILEHUu0XaUpRn0mj7gOx10V52t8gRGYPCW7QXGImkPGGhvBPzBDVVqh9lKGtkuPeePmTnpRSmwp0LG1WHcIzUWnMqPBWQeHAat6Q-Tq7niXNb96ddEZsMEdHK1nmHVlNaeqFBNtTxk6yYRkFNCvtfBayqy-Rqt4CPU5tThxbTI4AIUCI6JLxJd_VJizrVNDEe2xZ_tiQdkC5ASIoHpX8sfvAB8zRUsMVJ6oMUt5FH_4GBNXDCtFRmr65Qt0JV1h4bBJffu2L272Q_vpD76wn-YNGW8VCtZcheHu_X-A4gdYQEC0HN0BenY-MOuUBqKEjXAc0SxWeP7W9RN55jlqUFK0nzEYydVjec2stdQIngVfg_FvKxvHXfM4XdtMpqeJnp3Pzyk8xjz30sAZd0f2HQ6zfdPjk-OkV2-WrC0_qW0L8Rq3zrUbq52n3BN7gm7sctU_CUlBmoQIgJDQBYk1Siv4tfSq9pL1R4GdaOlWQdxEuhZi8bTYC8GGAgNGl3SMAZGvk7nu6QnnwEZjZ7mZwbcqgyRKa89cOREMUvIkVJ8Q8lZu=w926-h672-no" alt="" title="Jordan Proto React Triple White"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White">Jordan Proto React Triple White</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4cDUjSODZSaXWfHyZKb9q3Fn7FHA4uB0KSBs0MtFHC0dc6AJb1zeAl_X2LOKalK9C7VBFhTqRQ9fw1ESgUr9ZUKFbOzD94i_s96nvkICOqrsYnzrE2nEAQHoEaGOF4O8GAI6T4CGFbgcQhNzjpRlSY60NyPu5Cmq81FRpEOFRzTOtSa_NnWzMmfwO0yxtPbcg5U6YBUsus8shv3SA7CjULLfaP38nZAuWVgq8PMaaeCQ_eSrK8NJSEVQjyyxmqb-1I7zO8Kvvzvwi--ibMr52CF8h-GusBzSq5ZuzvZRCGu_u8CyfoXw7pwWbOmHnLOdcQ9d2PCSW_IxEMGfmEuU7NxMSsW3Ga4r35_wLB7cjvlPC9OjCV50tfekXjZBS_476mzlf4G9jR7Ju1GqgjXah9Uqc_0Y8N-Br8_JCtIlRSuLxAiebwd7AvFVlgWId9MYxBWnRT3cTyD8SH7q5WwO-CIbKAOSKsNcrrTgFxQvqn9yklBU1u5X5fdTlTBk4WSYorsWZAug0z9BOymRLnrhTbnA0vpBPFROWD-aL1glg-eUpFSfgD4xhWsOqJNY9krQ2UbLSGXQ5gYWj0ovLS7Yz3UKFY2qrVWpqkpbfyN98es9NJ-7LTUs2MLq1rX_2FaQmyq5mVndd7VGzQOHy9hDULG-5H-0LvGd=w900-h566-no" alt="" title="adidas Yeezy Boost 350 V2 Hyperspace"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace">adidas Yeezy Boost 350 V2 Hyperspace</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_11_60352cd8bf803" data-td_block_id="td_uid_11_60352cd8bf803"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_11_60352cd8bf803" data-td_block_id="td_uid_11_60352cd8bf803"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18581"><a href="https://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div></div>


<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form method="get" class="td-search-form" action="https://weuponithiphop.info/">
				<div role="search" class="td-head-form-search-wrap">
					<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>            </div>
        </div>
    </div>

    <div class="td-banner-wrap-full">
        <div class="td-header-container td-header-row td-header-header">
            <div class="td-header-sp-recs">
                <div class="td-header-rec-wrap">
    
</div>            </div>
        </div>
    </div>

</div><div class="td-main-content-wrap">

    <div class="td-container td-post-template-default ">
        <div class="td-crumb-container"><div class="entry-crumbs"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="" class="entry-crumb" itemprop="url" href="https://weuponithiphop.info/"><span itemprop="title">Home</span></a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="View all posts in Music Video" class="entry-crumb" itemprop="url" href="https://weuponithiphop.info/category/music-video/"><span itemprop="title">Music Video</span></a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last" itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><meta itemprop="title" content = "Music Video: Juice WRLD &#8211; Conversations"><meta itemprop="url" content = "https://weuponithiphop.info/2021/02/23/music-video-juice-wrld-conversations/">Music Video: Juice WRLD &#8211; Conversations</span></div></div>

        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-43791" class="post-43791 post type-post status-publish format-standard has-post-thumbnail hentry category-music-video tag-juice-wrld" itemscope itemtype="https://schema.org/Article">
        <div class="td-post-header">

            <ul class="td-category"><li class="entry-category"><a  href="https://weuponithiphop.info/category/music-video/">Music Video</a></li></ul>
            <header class="td-post-title">
                <h1 class="entry-title">Music Video: Juice WRLD &#8211; Conversations</h1>

                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name">By <a href="https://weuponithiphop.info/author/cyclone/">cyclone</a> - </div>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-02-23T05:22:26+00:00" >February 23, 2021</time></span>                    <div class="td-post-comments"><a href="https://weuponithiphop.info/2021/02/23/music-video-juice-wrld-conversations/#respond"><i class="td-icon-comments"></i>0</a></div>                                    </div>

            </header>

        </div>

        

        <div class="td-post-content">

        
        <p><img class="aligncenter size-medium" src="https://i.imgur.com/Mt8TkFH.jpg" width="1280" height="720" /><br />
Here&#8217;s another new video from <strong>Juice WRLD’s</strong> posthumous album, <em><strong>Legends Never Die</strong></em>. This one is for his track <strong>&#8220;Conversations&#8221;</strong>. Directed by <strong>Steve Cannon</strong>. The visual is a collage of random clips of the late rapper which includes him on his BMX bike, time on tour, live performances, and working in the studio.</p>
<p>Watch the <strong>&#8220;Conversations&#8221;</strong> video below.<br />
<iframe src="https://www.youtube.com/embed/OcQ71ubUXAE" width="590" height="332" frameborder="0" allowfullscreen="allowfullscreen"></iframe></p>
<div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://weuponithiphop.info/2021/02/23/music-video-juice-wrld-conversations/" data-a2a-title="Music Video: Juice WRLD – Conversations"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fweuponithiphop.info%2F2021%2F02%2F23%2Fmusic-video-juice-wrld-conversations%2F&amp;linkname=Music%20Video%3A%20Juice%20WRLD%20%E2%80%93%20Conversations" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fweuponithiphop.info%2F2021%2F02%2F23%2Fmusic-video-juice-wrld-conversations%2F&amp;linkname=Music%20Video%3A%20Juice%20WRLD%20%E2%80%93%20Conversations" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=https%3A%2F%2Fweuponithiphop.info%2F2021%2F02%2F23%2Fmusic-video-juice-wrld-conversations%2F&amp;linkname=Music%20Video%3A%20Juice%20WRLD%20%E2%80%93%20Conversations" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fweuponithiphop.info%2F2021%2F02%2F23%2Fmusic-video-juice-wrld-conversations%2F&amp;linkname=Music%20Video%3A%20Juice%20WRLD%20%E2%80%93%20Conversations" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_tumblr" href="https://www.addtoany.com/add_to/tumblr?linkurl=https%3A%2F%2Fweuponithiphop.info%2F2021%2F02%2F23%2Fmusic-video-juice-wrld-conversations%2F&amp;linkname=Music%20Video%3A%20Juice%20WRLD%20%E2%80%93%20Conversations" title="Tumblr" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_reddit" href="https://www.addtoany.com/add_to/reddit?linkurl=https%3A%2F%2Fweuponithiphop.info%2F2021%2F02%2F23%2Fmusic-video-juice-wrld-conversations%2F&amp;linkname=Music%20Video%3A%20Juice%20WRLD%20%E2%80%93%20Conversations" title="Reddit" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_flipboard" href="https://www.addtoany.com/add_to/flipboard?linkurl=https%3A%2F%2Fweuponithiphop.info%2F2021%2F02%2F23%2Fmusic-video-juice-wrld-conversations%2F&amp;linkname=Music%20Video%3A%20Juice%20WRLD%20%E2%80%93%20Conversations" title="Flipboard" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Fweuponithiphop.info%2F2021%2F02%2F23%2Fmusic-video-juice-wrld-conversations%2F&amp;linkname=Music%20Video%3A%20Juice%20WRLD%20%E2%80%93%20Conversations" title="Copy Link" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div>        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://weuponithiphop.info/tag/juice-wrld/">Juice WRLD</a></li></ul>            </div>

                        <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://weuponithiphop.info/2021/02/22/album-stream-smoovth-giallo-point-amongst-wolves/">Album Stream: SmooVth &#038; Giallo Point &#8211; Amongst Wolves</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="https://weuponithiphop.info/2021/02/23/new-music-k-camp-no-more-parties-freestyle/">New Music: K Camp &#8211; No More Parties Freestyle</a></div></div></div>            <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://weuponithiphop.info/author/cyclone/">cyclone</a></span></div>	        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="cyclone"></span><meta itemprop="datePublished" content="2021-02-23T05:22:26+00:00"><meta itemprop="dateModified" content="2021-02-23T05:22:26+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://weuponithiphop.info/2021/02/23/music-video-juice-wrld-conversations/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png"></span><meta itemprop="name" content="WeUpOnIt"></span><meta itemprop="headline " content="Music Video: Juice WRLD - Conversations"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://i.imgur.com/Mt8TkFH.jpg"><meta itemprop="width" content="800"><meta itemprop="height" content="600"></span>        </footer>

    </article> <!-- /.post -->

    <div class="td_block_wrap td_block_related_posts td_uid_15_60352cd8cf858_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_15_60352cd8cf858" ><script>var block_td_uid_15_60352cd8cf858 = new tdBlock();
block_td_uid_15_60352cd8cf858.id = "td_uid_15_60352cd8cf858";
block_td_uid_15_60352cd8cf858.atts = '{"limit":6,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_custom_related","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_15_60352cd8cf858_rand","offset":"","css":"","live_filter":"cur_post_same_tags","live_filter_cur_post_id":43791,"live_filter_cur_post_author":"1"}';
block_td_uid_15_60352cd8cf858.td_column_number = "3";
block_td_uid_15_60352cd8cf858.block_type = "td_block_related_posts";
block_td_uid_15_60352cd8cf858.post_count = "6";
block_td_uid_15_60352cd8cf858.found_posts = "52";
block_td_uid_15_60352cd8cf858.header_color = "";
block_td_uid_15_60352cd8cf858.ajax_pagination_infinite_stop = "";
block_td_uid_15_60352cd8cf858.max_num_pages = "9";
tdBlocksArray.push(block_td_uid_15_60352cd8cf858);
</script><h4 class="td-related-title"><a id="td_uid_16_60352cd8d3372" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_15_60352cd8cf858" href="#">RELATED ARTICLES</a><a id="td_uid_17_60352cd8d33b6" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_15_60352cd8cf858" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_15_60352cd8cf858 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/06/music-video-internet-money-ft-juice-wrld-trippie-redd-blast-off/" rel="bookmark" title="Music Video: Internet Money ft. Juice WRLD &#038; Trippie Redd &#8211; Blast Off"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/e0GYe5P.jpg" alt="" title="Music Video: Internet Money ft. Juice WRLD &#038; Trippie Redd &#8211; Blast Off"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/06/music-video-internet-money-ft-juice-wrld-trippie-redd-blast-off/" rel="bookmark" title="Music Video: Internet Money ft. Juice WRLD &#038; Trippie Redd &#8211; Blast Off">Music Video: Internet Money ft. Juice WRLD &#038; Trippie Redd &#8211; Blast Off</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/01/15/music-video-juice-wrld-young-thug-bad-boy/" rel="bookmark" title="Music Video: Juice WRLD &#038; Young Thug &#8211; Bad Boy"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/V9VLAHp.jpg" alt="" title="Music Video: Juice WRLD &#038; Young Thug &#8211; Bad Boy"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/01/15/music-video-juice-wrld-young-thug-bad-boy/" rel="bookmark" title="Music Video: Juice WRLD &#038; Young Thug &#8211; Bad Boy">Music Video: Juice WRLD &#038; Young Thug &#8211; Bad Boy</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2020/12/08/new-music-juice-wrld-the-kid-laroi-remind-me-of-you/" rel="bookmark" title="New Music: Juice WRLD &#038; The Kid Laroi &#8211; Remind Me Of You"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/DtinYld.jpg" alt="" title="New Music: Juice WRLD &#038; The Kid Laroi &#8211; Remind Me Of You"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2020/12/08/new-music-juice-wrld-the-kid-laroi-remind-me-of-you/" rel="bookmark" title="New Music: Juice WRLD &#038; The Kid Laroi &#8211; Remind Me Of You">New Music: Juice WRLD &#038; The Kid Laroi &#8211; Remind Me Of You</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid-->

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2020/12/02/new-music-juice-wrld-ft-benny-blanco-real-shit/" rel="bookmark" title="New Music: Juice WRLD ft. Benny Blanco &#8211; Real Shit"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/Pr7zayq.jpg" alt="" title="New Music: Juice WRLD ft. Benny Blanco &#8211; Real Shit"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2020/12/02/new-music-juice-wrld-ft-benny-blanco-real-shit/" rel="bookmark" title="New Music: Juice WRLD ft. Benny Blanco &#8211; Real Shit">New Music: Juice WRLD ft. Benny Blanco &#8211; Real Shit</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2020/08/12/music-video-juice-wrld-the-weeknd-smile/" rel="bookmark" title="Music Video: Juice WRLD &#038; The Weeknd &#8211; Smile"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/qkkIs1B.png" alt="" title="Music Video: Juice WRLD &#038; The Weeknd &#8211; Smile"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2020/08/12/music-video-juice-wrld-the-weeknd-smile/" rel="bookmark" title="Music Video: Juice WRLD &#038; The Weeknd &#8211; Smile">Music Video: Juice WRLD &#038; The Weeknd &#8211; Smile</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2020/07/13/music-video-juice-wrld-wishing-well/" rel="bookmark" title="Music Video: Juice WRLD &#8211; Wishing Well"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/e8R3LPJ.jpg" alt="" title="Music Video: Juice WRLD &#8211; Wishing Well"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2020/07/13/music-video-juice-wrld-wishing-well/" rel="bookmark" title="Music Video: Juice WRLD &#8211; Wishing Well">Music Video: Juice WRLD &#8211; Wishing Well</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_15_60352cd8cf858" data-td_block_id="td_uid_15_60352cd8cf858"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_15_60352cd8cf858" data-td_block_id="td_uid_15_60352cd8cf858"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->

	<div class="comments" id="comments">
            </div> <!-- /.content -->
                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <aside class="widget widget_search"><form method="get" class="td-search-form-widget" action="https://weuponithiphop.info/">
    <div role="search">
        <input class="td-widget-search-input" type="text" value="" name="s" id="s" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit" value="Search" />
    </div>
</form></aside><aside class="widget widget_text">			<div class="textwidget"><h4><strong><span style="color: #8224e3;"><span style="color: #000000;">Listen to</span> <span style="color: #c60000;">WeUpOnItRadio</span> <span style="color: #000000;">Live!</span></span></strong></h4>
<p><span class="cc_streaminfo" data-type="song" data-username="cyclone777">Loading &#8230;</span><br />
<script language="javascript" type="text/javascript" src="https://control.internet-radio.com:2199/system/streaminfo.js"></script><br />
<iframe src="https://tunein.com/embed/player/s292400/" style="width:100%; height:100px;" scrolling="no" frameborder="no"></iframe></p>
</div>
		</aside>
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-sidebar ">
<script type="text/javascript">
var td_screen_width = document.body.clientWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 

<aside class="widget widget_text"><div class="block-title"><span>ETheMadAssassin &#8211; Shine The Shottie (God&#8217;s Work)</span></div>			<div class="textwidget"><p><iframe src="https://www.youtube.com/embed/yFUENFl1GiY" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
</div>
		</aside><aside class="widget widget_text"><div class="block-title"><span>OC From NC ft. Chaundon &#038; Big Remo &#8211; Dope Sell Itself</span></div>			<div class="textwidget"><p><iframe src="https://www.youtube.com/embed/zHCQRcmjnVw" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
</div>
		</aside><aside class="widget widget_text">			<div class="textwidget"><div aria-live="polite" id="soliloquy-container-30342" class="soliloquy-container soliloquy-transition-fade  soliloquy-theme-classic" style="max-width:960px;max-height:300px;"><ul id="soliloquy-30342" class="soliloquy-slider soliloquy-slides soliloquy-wrap soliloquy-clear"><li aria-hidden="true" class="soliloquy-item soliloquy-item-1 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109673710?productType=812&#038;appearance=1" class="soliloquy-link" title="Revolt Tee" target="_blank"><img id="soliloquy-image-30349" class="soliloquy-image soliloquy-image-1" src="https://weuponithiphop.info/wp-content/uploads/Revolt-Tee.jpg" alt="Revolt Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-2 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/youngongetthiswork?q=I12154011" class="soliloquy-link" title="You Gon Get This Work" target="_blank"><img id="soliloquy-image-30344" class="soliloquy-image soliloquy-image-2" src="https://weuponithiphop.info/wp-content/uploads/You-Gon-Get-This-Work.jpg" alt="You Gon Get This Work" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-3 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/savage+bloody?q=I1014473415" class="soliloquy-link" title="Savage Bloody" target="_blank"><img id="soliloquy-image-30343" class="soliloquy-image soliloquy-image-3" src="https://weuponithiphop.info/wp-content/uploads/Savage-Bloody.jpg" alt="Savage Bloody" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-4 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/can?q=I1011767996" class="soliloquy-link" title="spray" target="_blank"><img id="soliloquy-image-30345" class="soliloquy-image soliloquy-image-4" src="https://weuponithiphop.info/wp-content/uploads/spray.jpg" alt="spray" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-5 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814012" class="soliloquy-link" title="Good Vibes Only 1" target="_blank"><img id="soliloquy-image-30346" class="soliloquy-image soliloquy-image-5" src="https://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-1.jpg" alt="Good Vibes Only 1" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-6 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/blessed?q=I12044252" class="soliloquy-link" title="Blessed Tee" target="_blank"><img id="soliloquy-image-30347" class="soliloquy-image soliloquy-image-6" src="https://weuponithiphop.info/wp-content/uploads/Blessed-Tee.jpg" alt="Blessed Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-7 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/trap?q=I1009984243" class="soliloquy-link" title="Trap Tee" target="_blank"><img id="soliloquy-image-30348" class="soliloquy-image soliloquy-image-7" src="https://weuponithiphop.info/wp-content/uploads/Trap-Tee.jpg" alt="Trap Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-8 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/good+vibes+only+birds?q=I1014476779" class="soliloquy-link" title="Good Vibes Only 2" target="_blank"><img id="soliloquy-image-30350" class="soliloquy-image soliloquy-image-8" src="https://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-2.jpg" alt="Good Vibes Only 2" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-9 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/all+seeing+eye?q=I11739019" class="soliloquy-link" title="ILLuminati" target="_blank"><img id="soliloquy-image-30351" class="soliloquy-image soliloquy-image-9" src="https://weuponithiphop.info/wp-content/uploads/ILLuminati.jpg" alt="ILLuminati" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-10 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/diamond_skull_1?q=I12527492" class="soliloquy-link" title="Diamond Skull" target="_blank"><img id="soliloquy-image-30352" class="soliloquy-image soliloquy-image-10" src="https://weuponithiphop.info/wp-content/uploads/Diamond-Skull.jpg" alt="Diamond Skull" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-11 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/donuts+doom-A109792920" class="soliloquy-link" title="donunts" target="_blank"><img id="soliloquy-image-30353" class="soliloquy-image soliloquy-image-11" src="https://weuponithiphop.info/wp-content/uploads/donunts.jpg" alt="donunts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-12 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/crime+pays?q=I12067735" class="soliloquy-link" title="Crime Pays" target="_blank"><img id="soliloquy-image-30434" class="soliloquy-image soliloquy-image-12" src="https://weuponithiphop.info/wp-content/uploads/Crime-Pays.jpg" alt="Crime Pays" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-13 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/fuckyoupayme?q=I11550361" class="soliloquy-link" title="Fuck You Pay Me" target="_blank"><img id="soliloquy-image-30436" class="soliloquy-image soliloquy-image-13" src="https://weuponithiphop.info/wp-content/uploads/Fuck-You-Pay-Me.jpg" alt="Fuck You Pay Me" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-14 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814011" class="soliloquy-link" title="savage gold tee" target="_blank"><img id="soliloquy-image-30354" class="soliloquy-image soliloquy-image-14" src="https://weuponithiphop.info/wp-content/uploads/savage-gold-tee.jpg" alt="savage gold tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-15 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/?page=2" class="soliloquy-link" title="fresh-clean-signature-" target="_blank"><img id="soliloquy-image-30437" class="soliloquy-image soliloquy-image-15" src="https://weuponithiphop.info/wp-content/uploads/fresh-clean-signature-.jpg" alt="fresh-clean-signature-" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-16 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/%24teez?q=I1001415610" class="soliloquy-link" title="gold fronts" target="_blank"><img id="soliloquy-image-30355" class="soliloquy-image soliloquy-image-16" src="https://weuponithiphop.info/wp-content/uploads/gold-fronts.jpg" alt="gold fronts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-17 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/soldier?q=I11611241" class="soliloquy-link" title="Swag Soldier" target="_blank"><img id="soliloquy-image-30435" class="soliloquy-image soliloquy-image-17" src="https://weuponithiphop.info/wp-content/uploads/Swag-Soldier.jpg" alt="Swag Soldier" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-18 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/gamer-A7923028?productType=210&#038;appearance=22" class="soliloquy-link" title="gamer" target="_blank"><img id="soliloquy-image-30438" class="soliloquy-image soliloquy-image-18" src="https://weuponithiphop.info/wp-content/uploads/gamer.jpg" alt="gamer" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-19 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/" class="soliloquy-link" title="freshandlogo Square" target="_blank"><img id="soliloquy-image-30356" class="soliloquy-image soliloquy-image-19" src="https://weuponithiphop.info/wp-content/uploads/freshandlogo-Square.jpg" alt="freshandlogo Square" /></a></li></ul></div><noscript><style type="text/css">#soliloquy-container-30342{opacity:1}</style></noscript>
</div>
		</aside>                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->


<!-- Instagram -->



<!-- Footer -->
<div class="td-footer-wrapper td-footer-template-3">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
			    		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span4">
                <div class="td-footer-info"><div class="footer-logo-wrap"><a href="https://weuponithiphop.info/"><img class="td-retina-data" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" alt="" title=""/></a></div><div class="footer-text-wrap"></div><div class="footer-social-wrap td-social-style-2">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponit_com" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div></div>            </div>

            <div class="td-pb-span4">
                <aside class="widget widget_calendar"><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar">
	<caption>February 2021</caption>
	<thead>
	<tr>
		<th scope="col" title="Sunday">S</th>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
	</tr>
	</thead>

	<tfoot>
	<tr>
		<td colspan="3" id="prev"><a href="https://weuponithiphop.info/2021/01/">&laquo; Jan</a></td>
		<td class="pad">&nbsp;</td>
		<td colspan="3" id="next" class="pad">&nbsp;</td>
	</tr>
	</tfoot>

	<tbody>
	<tr>
		<td colspan="1" class="pad">&nbsp;</td><td><a href="https://weuponithiphop.info/2021/02/01/" aria-label="Posts published on February 1, 2021">1</a></td><td><a href="https://weuponithiphop.info/2021/02/02/" aria-label="Posts published on February 2, 2021">2</a></td><td><a href="https://weuponithiphop.info/2021/02/03/" aria-label="Posts published on February 3, 2021">3</a></td><td><a href="https://weuponithiphop.info/2021/02/04/" aria-label="Posts published on February 4, 2021">4</a></td><td><a href="https://weuponithiphop.info/2021/02/05/" aria-label="Posts published on February 5, 2021">5</a></td><td><a href="https://weuponithiphop.info/2021/02/06/" aria-label="Posts published on February 6, 2021">6</a></td>
	</tr>
	<tr>
		<td><a href="https://weuponithiphop.info/2021/02/07/" aria-label="Posts published on February 7, 2021">7</a></td><td><a href="https://weuponithiphop.info/2021/02/08/" aria-label="Posts published on February 8, 2021">8</a></td><td><a href="https://weuponithiphop.info/2021/02/09/" aria-label="Posts published on February 9, 2021">9</a></td><td><a href="https://weuponithiphop.info/2021/02/10/" aria-label="Posts published on February 10, 2021">10</a></td><td><a href="https://weuponithiphop.info/2021/02/11/" aria-label="Posts published on February 11, 2021">11</a></td><td><a href="https://weuponithiphop.info/2021/02/12/" aria-label="Posts published on February 12, 2021">12</a></td><td><a href="https://weuponithiphop.info/2021/02/13/" aria-label="Posts published on February 13, 2021">13</a></td>
	</tr>
	<tr>
		<td><a href="https://weuponithiphop.info/2021/02/14/" aria-label="Posts published on February 14, 2021">14</a></td><td><a href="https://weuponithiphop.info/2021/02/15/" aria-label="Posts published on February 15, 2021">15</a></td><td><a href="https://weuponithiphop.info/2021/02/16/" aria-label="Posts published on February 16, 2021">16</a></td><td><a href="https://weuponithiphop.info/2021/02/17/" aria-label="Posts published on February 17, 2021">17</a></td><td><a href="https://weuponithiphop.info/2021/02/18/" aria-label="Posts published on February 18, 2021">18</a></td><td><a href="https://weuponithiphop.info/2021/02/19/" aria-label="Posts published on February 19, 2021">19</a></td><td><a href="https://weuponithiphop.info/2021/02/20/" aria-label="Posts published on February 20, 2021">20</a></td>
	</tr>
	<tr>
		<td><a href="https://weuponithiphop.info/2021/02/21/" aria-label="Posts published on February 21, 2021">21</a></td><td><a href="https://weuponithiphop.info/2021/02/22/" aria-label="Posts published on February 22, 2021">22</a></td><td id="today"><a href="https://weuponithiphop.info/2021/02/23/" aria-label="Posts published on February 23, 2021">23</a></td><td>24</td><td>25</td><td>26</td><td>27</td>
	</tr>
	<tr>
		<td>28</td>
		<td class="pad" colspan="6">&nbsp;</td>
	</tr>
	</tbody>
	</table></div></aside>            </div>

            <div class="td-pb-span4">
                <aside class="widget widget_text">			<div class="textwidget"><div aria-live="polite" id="soliloquy-container-30342" class="soliloquy-container soliloquy-transition-fade  soliloquy-theme-classic" style="max-width:960px;max-height:300px;"><ul id="soliloquy-30342" class="soliloquy-slider soliloquy-slides soliloquy-wrap soliloquy-clear"><li aria-hidden="true" class="soliloquy-item soliloquy-item-1 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109673710?productType=812&#038;appearance=1" class="soliloquy-link" title="Revolt Tee" target="_blank"><img id="soliloquy-image-30349" class="soliloquy-image soliloquy-image-1" src="https://weuponithiphop.info/wp-content/uploads/Revolt-Tee.jpg" alt="Revolt Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-2 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/youngongetthiswork?q=I12154011" class="soliloquy-link" title="You Gon Get This Work" target="_blank"><img id="soliloquy-image-30344" class="soliloquy-image soliloquy-image-2" src="https://weuponithiphop.info/wp-content/uploads/You-Gon-Get-This-Work.jpg" alt="You Gon Get This Work" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-3 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/savage+bloody?q=I1014473415" class="soliloquy-link" title="Savage Bloody" target="_blank"><img id="soliloquy-image-30343" class="soliloquy-image soliloquy-image-3" src="https://weuponithiphop.info/wp-content/uploads/Savage-Bloody.jpg" alt="Savage Bloody" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-4 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/can?q=I1011767996" class="soliloquy-link" title="spray" target="_blank"><img id="soliloquy-image-30345" class="soliloquy-image soliloquy-image-4" src="https://weuponithiphop.info/wp-content/uploads/spray.jpg" alt="spray" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-5 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814012" class="soliloquy-link" title="Good Vibes Only 1" target="_blank"><img id="soliloquy-image-30346" class="soliloquy-image soliloquy-image-5" src="https://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-1.jpg" alt="Good Vibes Only 1" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-6 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/blessed?q=I12044252" class="soliloquy-link" title="Blessed Tee" target="_blank"><img id="soliloquy-image-30347" class="soliloquy-image soliloquy-image-6" src="https://weuponithiphop.info/wp-content/uploads/Blessed-Tee.jpg" alt="Blessed Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-7 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/trap?q=I1009984243" class="soliloquy-link" title="Trap Tee" target="_blank"><img id="soliloquy-image-30348" class="soliloquy-image soliloquy-image-7" src="https://weuponithiphop.info/wp-content/uploads/Trap-Tee.jpg" alt="Trap Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-8 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/good+vibes+only+birds?q=I1014476779" class="soliloquy-link" title="Good Vibes Only 2" target="_blank"><img id="soliloquy-image-30350" class="soliloquy-image soliloquy-image-8" src="https://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-2.jpg" alt="Good Vibes Only 2" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-9 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/all+seeing+eye?q=I11739019" class="soliloquy-link" title="ILLuminati" target="_blank"><img id="soliloquy-image-30351" class="soliloquy-image soliloquy-image-9" src="https://weuponithiphop.info/wp-content/uploads/ILLuminati.jpg" alt="ILLuminati" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-10 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/diamond_skull_1?q=I12527492" class="soliloquy-link" title="Diamond Skull" target="_blank"><img id="soliloquy-image-30352" class="soliloquy-image soliloquy-image-10" src="https://weuponithiphop.info/wp-content/uploads/Diamond-Skull.jpg" alt="Diamond Skull" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-11 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/donuts+doom-A109792920" class="soliloquy-link" title="donunts" target="_blank"><img id="soliloquy-image-30353" class="soliloquy-image soliloquy-image-11" src="https://weuponithiphop.info/wp-content/uploads/donunts.jpg" alt="donunts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-12 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/crime+pays?q=I12067735" class="soliloquy-link" title="Crime Pays" target="_blank"><img id="soliloquy-image-30434" class="soliloquy-image soliloquy-image-12" src="https://weuponithiphop.info/wp-content/uploads/Crime-Pays.jpg" alt="Crime Pays" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-13 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/fuckyoupayme?q=I11550361" class="soliloquy-link" title="Fuck You Pay Me" target="_blank"><img id="soliloquy-image-30436" class="soliloquy-image soliloquy-image-13" src="https://weuponithiphop.info/wp-content/uploads/Fuck-You-Pay-Me.jpg" alt="Fuck You Pay Me" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-14 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814011" class="soliloquy-link" title="savage gold tee" target="_blank"><img id="soliloquy-image-30354" class="soliloquy-image soliloquy-image-14" src="https://weuponithiphop.info/wp-content/uploads/savage-gold-tee.jpg" alt="savage gold tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-15 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/?page=2" class="soliloquy-link" title="fresh-clean-signature-" target="_blank"><img id="soliloquy-image-30437" class="soliloquy-image soliloquy-image-15" src="https://weuponithiphop.info/wp-content/uploads/fresh-clean-signature-.jpg" alt="fresh-clean-signature-" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-16 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/%24teez?q=I1001415610" class="soliloquy-link" title="gold fronts" target="_blank"><img id="soliloquy-image-30355" class="soliloquy-image soliloquy-image-16" src="https://weuponithiphop.info/wp-content/uploads/gold-fronts.jpg" alt="gold fronts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-17 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/soldier?q=I11611241" class="soliloquy-link" title="Swag Soldier" target="_blank"><img id="soliloquy-image-30435" class="soliloquy-image soliloquy-image-17" src="https://weuponithiphop.info/wp-content/uploads/Swag-Soldier.jpg" alt="Swag Soldier" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-18 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/gamer-A7923028?productType=210&#038;appearance=22" class="soliloquy-link" title="gamer" target="_blank"><img id="soliloquy-image-30438" class="soliloquy-image soliloquy-image-18" src="https://weuponithiphop.info/wp-content/uploads/gamer.jpg" alt="gamer" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-19 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/" class="soliloquy-link" title="freshandlogo Square" target="_blank"><img id="soliloquy-image-30356" class="soliloquy-image soliloquy-image-19" src="https://weuponithiphop.info/wp-content/uploads/freshandlogo-Square.jpg" alt="freshandlogo Square" /></a></li></ul></div><noscript><style type="text/css">#soliloquy-container-30342{opacity:1}</style></noscript>
</div>
		</aside>            </div>
        </div>
    </div>
</div>

<!-- Sub Footer -->
    <div class="td-sub-footer-container">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span7 td-sub-footer-menu">
                        <div class="menu-top-menu-container"><ul id="menu-top-menu-2" class="td-subfooter-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-mega-menu menu-item-317"><a href="https://weuponithiphop.info/category/new-music/">New Music</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_20_60352cd8e6105_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_20_60352cd8e6105" ><script>var block_td_uid_20_60352cd8e6105 = new tdBlock();
block_td_uid_20_60352cd8e6105.id = "td_uid_20_60352cd8e6105";
block_td_uid_20_60352cd8e6105.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"43","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_20_60352cd8e6105_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_20_60352cd8e6105.td_column_number = "3";
block_td_uid_20_60352cd8e6105.block_type = "td_block_mega_menu";
block_td_uid_20_60352cd8e6105.post_count = "5";
block_td_uid_20_60352cd8e6105.found_posts = "3740";
block_td_uid_20_60352cd8e6105.header_color = "";
block_td_uid_20_60352cd8e6105.ajax_pagination_infinite_stop = "";
block_td_uid_20_60352cd8e6105.max_num_pages = "748";
tdBlocksArray.push(block_td_uid_20_60352cd8e6105);
</script><div id=td_uid_20_60352cd8e6105 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/23/new-music-k-camp-no-more-parties-freestyle/" rel="bookmark" title="New Music: K Camp &#8211; No More Parties Freestyle"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/sUJtm1b.jpg" alt="" title="New Music: K Camp &#8211; No More Parties Freestyle"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/23/new-music-k-camp-no-more-parties-freestyle/" rel="bookmark" title="New Music: K Camp &#8211; No More Parties Freestyle">New Music: K Camp &#8211; No More Parties Freestyle</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/22/new-music-duke-deuce-foogiano-spin/" rel="bookmark" title="New Music: Duke Deuce &#038; Foogiano &#8211; Spin"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/rL9k1Dm.jpg" alt="" title="New Music: Duke Deuce &#038; Foogiano &#8211; Spin"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/22/new-music-duke-deuce-foogiano-spin/" rel="bookmark" title="New Music: Duke Deuce &#038; Foogiano &#8211; Spin">New Music: Duke Deuce &#038; Foogiano &#8211; Spin</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/22/new-music-becky-g-burna-boy-rotate/" rel="bookmark" title="New Music: Becky G &#038; Burna Boy &#8211; Rotate"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/dVpzsd2.jpg" alt="" title="New Music: Becky G &#038; Burna Boy &#8211; Rotate"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/22/new-music-becky-g-burna-boy-rotate/" rel="bookmark" title="New Music: Becky G &#038; Burna Boy &#8211; Rotate">New Music: Becky G &#038; Burna Boy &#8211; Rotate</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/21/new-music-the-yutes-ft-stove-god-cooks-in-the-kitchen/" rel="bookmark" title="New Music: The Yutes ft. Stove God Cooks &#8211; In The Kitchen"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/sucpxhg.jpg" alt="" title="New Music: The Yutes ft. Stove God Cooks &#8211; In The Kitchen"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/21/new-music-the-yutes-ft-stove-god-cooks-in-the-kitchen/" rel="bookmark" title="New Music: The Yutes ft. Stove God Cooks &#8211; In The Kitchen">New Music: The Yutes ft. Stove God Cooks &#8211; In The&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/21/new-music-rockie-fresh-ft-tobi-lou-jeff-kaale-gucci/" rel="bookmark" title="New Music: Rockie Fresh ft. Tobi Lou &#038; Jeff Kaale &#8211; Gucci"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/lYJ3ctT.jpg" alt="" title="New Music: Rockie Fresh ft. Tobi Lou &#038; Jeff Kaale &#8211; Gucci"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/21/new-music-rockie-fresh-ft-tobi-lou-jeff-kaale-gucci/" rel="bookmark" title="New Music: Rockie Fresh ft. Tobi Lou &#038; Jeff Kaale &#8211; Gucci">New Music: Rockie Fresh ft. Tobi Lou &#038; Jeff Kaale &#8211;&#8230;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_20_60352cd8e6105" data-td_block_id="td_uid_20_60352cd8e6105"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_20_60352cd8e6105" data-td_block_id="td_uid_20_60352cd8e6105"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-706"><a href="https://weuponithiphop.info/category/album-stream-mixtapes/">Album Stream</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_21_60352cd8e9c21_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_21_60352cd8e9c21" ><script>var block_td_uid_21_60352cd8e9c21 = new tdBlock();
block_td_uid_21_60352cd8e9c21.id = "td_uid_21_60352cd8e9c21";
block_td_uid_21_60352cd8e9c21.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"97","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_21_60352cd8e9c21_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_21_60352cd8e9c21.td_column_number = "3";
block_td_uid_21_60352cd8e9c21.block_type = "td_block_mega_menu";
block_td_uid_21_60352cd8e9c21.post_count = "5";
block_td_uid_21_60352cd8e9c21.found_posts = "1369";
block_td_uid_21_60352cd8e9c21.header_color = "";
block_td_uid_21_60352cd8e9c21.ajax_pagination_infinite_stop = "";
block_td_uid_21_60352cd8e9c21.max_num_pages = "274";
tdBlocksArray.push(block_td_uid_21_60352cd8e9c21);
</script><div id=td_uid_21_60352cd8e9c21 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/22/album-stream-smoovth-giallo-point-amongst-wolves/" rel="bookmark" title="Album Stream: SmooVth &#038; Giallo Point &#8211; Amongst Wolves"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/x0cjn8X.jpg" alt="" title="Album Stream: SmooVth &#038; Giallo Point &#8211; Amongst Wolves"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/22/album-stream-smoovth-giallo-point-amongst-wolves/" rel="bookmark" title="Album Stream: SmooVth &#038; Giallo Point &#8211; Amongst Wolves">Album Stream: SmooVth &#038; Giallo Point &#8211; Amongst Wolves</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/22/album-stream-demrick-payday/" rel="bookmark" title="Album Stream: Demrick &#8211; Payday"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/lHRfA4j.jpg" alt="" title="Album Stream: Demrick &#8211; Payday"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/22/album-stream-demrick-payday/" rel="bookmark" title="Album Stream: Demrick &#8211; Payday">Album Stream: Demrick &#8211; Payday</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/21/mixtape-taylor-gang-taylor-nights/" rel="bookmark" title="Mixtape: Taylor Gang &#8211; Taylor Nights"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/WugBoWN.jpg" alt="" title="Mixtape: Taylor Gang &#8211; Taylor Nights"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/21/mixtape-taylor-gang-taylor-nights/" rel="bookmark" title="Mixtape: Taylor Gang &#8211; Taylor Nights">Mixtape: Taylor Gang &#8211; Taylor Nights</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/19/ep-stream-cj-loyalty-over-royalty/" rel="bookmark" title="EP Stream: CJ &#8211; Loyalty Over Royalty"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/t8puHY4.png" alt="" title="EP Stream: CJ &#8211; Loyalty Over Royalty"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/19/ep-stream-cj-loyalty-over-royalty/" rel="bookmark" title="EP Stream: CJ &#8211; Loyalty Over Royalty">EP Stream: CJ &#8211; Loyalty Over Royalty</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/19/ep-stream-kelly-rowland-k/" rel="bookmark" title="EP Stream: Kelly Rowland &#8211; K"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/324LvpK.jpg" alt="" title="EP Stream: Kelly Rowland &#8211; K"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/19/ep-stream-kelly-rowland-k/" rel="bookmark" title="EP Stream: Kelly Rowland &#8211; K">EP Stream: Kelly Rowland &#8211; K</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_21_60352cd8e9c21" data-td_block_id="td_uid_21_60352cd8e9c21"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_21_60352cd8e9c21" data-td_block_id="td_uid_21_60352cd8e9c21"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-314"><a href="https://weuponithiphop.info/category/music-video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_22_60352cd8ed860_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_22_60352cd8ed860" ><script>var block_td_uid_22_60352cd8ed860 = new tdBlock();
block_td_uid_22_60352cd8ed860.id = "td_uid_22_60352cd8ed860";
block_td_uid_22_60352cd8ed860.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_22_60352cd8ed860_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_22_60352cd8ed860.td_column_number = "3";
block_td_uid_22_60352cd8ed860.block_type = "td_block_mega_menu";
block_td_uid_22_60352cd8ed860.post_count = "5";
block_td_uid_22_60352cd8ed860.found_posts = "4163";
block_td_uid_22_60352cd8ed860.header_color = "";
block_td_uid_22_60352cd8ed860.ajax_pagination_infinite_stop = "";
block_td_uid_22_60352cd8ed860.max_num_pages = "833";
tdBlocksArray.push(block_td_uid_22_60352cd8ed860);
</script><div id=td_uid_22_60352cd8ed860 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/23/music-video-juice-wrld-conversations/" rel="bookmark" title="Music Video: Juice WRLD &#8211; Conversations"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/Mt8TkFH.jpg" alt="" title="Music Video: Juice WRLD &#8211; Conversations"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/23/music-video-juice-wrld-conversations/" rel="bookmark" title="Music Video: Juice WRLD &#8211; Conversations">Music Video: Juice WRLD &#8211; Conversations</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/22/music-video-kito-vanjess-channel-tres-recap/" rel="bookmark" title="Music Video: Kito, VanJess &#038; Channel Tres &#8211; Recap"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/wSxs6uT.jpg" alt="" title="Music Video: Kito, VanJess &#038; Channel Tres &#8211; Recap"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/22/music-video-kito-vanjess-channel-tres-recap/" rel="bookmark" title="Music Video: Kito, VanJess &#038; Channel Tres &#8211; Recap">Music Video: Kito, VanJess &#038; Channel Tres &#8211; Recap</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/22/music-video-trae-tha-truth-mysonne-i-gotta-win/" rel="bookmark" title="Music Video: Trae Tha Truth &#038; Mysonne &#8211; I Gotta Win"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/oNUIhRC.jpg" alt="" title="Music Video: Trae Tha Truth &#038; Mysonne &#8211; I Gotta Win"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/22/music-video-trae-tha-truth-mysonne-i-gotta-win/" rel="bookmark" title="Music Video: Trae Tha Truth &#038; Mysonne &#8211; I Gotta Win">Music Video: Trae Tha Truth &#038; Mysonne &#8211; I Gotta Win</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/22/music-video-stunna-4-vegas-hard/" rel="bookmark" title="Music Video: Stunna 4 Vegas &#8211; Hard"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/V2UrH6u.jpg" alt="" title="Music Video: Stunna 4 Vegas &#8211; Hard"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/22/music-video-stunna-4-vegas-hard/" rel="bookmark" title="Music Video: Stunna 4 Vegas &#8211; Hard">Music Video: Stunna 4 Vegas &#8211; Hard</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/21/music-video-philthy-rich-january-30th-crown-the-king/" rel="bookmark" title="Music Video: Philthy Rich &#8211; January 30th: Crown The King"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/CRejbl6.jpg" alt="" title="Music Video: Philthy Rich &#8211; January 30th: Crown The King"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/21/music-video-philthy-rich-january-30th-crown-the-king/" rel="bookmark" title="Music Video: Philthy Rich &#8211; January 30th: Crown The King">Music Video: Philthy Rich &#8211; January 30th: Crown The King</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_22_60352cd8ed860" data-td_block_id="td_uid_22_60352cd8ed860"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_22_60352cd8ed860" data-td_block_id="td_uid_22_60352cd8ed860"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-316"><a href="https://weuponithiphop.info/category/latest-news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_23_60352cd8f14a7_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_23_60352cd8f14a7" ><script>var block_td_uid_23_60352cd8f14a7 = new tdBlock();
block_td_uid_23_60352cd8f14a7.id = "td_uid_23_60352cd8f14a7";
block_td_uid_23_60352cd8f14a7.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"29","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_23_60352cd8f14a7_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_23_60352cd8f14a7.td_column_number = "3";
block_td_uid_23_60352cd8f14a7.block_type = "td_block_mega_menu";
block_td_uid_23_60352cd8f14a7.post_count = "4";
block_td_uid_23_60352cd8f14a7.found_posts = "1082";
block_td_uid_23_60352cd8f14a7.header_color = "";
block_td_uid_23_60352cd8f14a7.ajax_pagination_infinite_stop = "";
block_td_uid_23_60352cd8f14a7.max_num_pages = "271";
tdBlocksArray.push(block_td_uid_23_60352cd8f14a7);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_23_60352cd8f14a7" id="td_uid_24_60352cd8f2314" data-td_block_id="td_uid_23_60352cd8f14a7" data-td_filter_value="" href="https://weuponithiphop.info/category/latest-news/">All</a><a class="mega-menu-sub-cat-td_uid_23_60352cd8f14a7"  id="td_uid_25_60352cd8f2409" data-td_block_id="td_uid_23_60352cd8f14a7" data-td_filter_value="69" href="https://weuponithiphop.info/category/latest-news/album-news/">Album News</a><a class="mega-menu-sub-cat-td_uid_23_60352cd8f14a7"  id="td_uid_26_60352cd8f252b" data-td_block_id="td_uid_23_60352cd8f14a7" data-td_filter_value="80" href="https://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a><a class="mega-menu-sub-cat-td_uid_23_60352cd8f14a7"  id="td_uid_27_60352cd8f264b" data-td_block_id="td_uid_23_60352cd8f14a7" data-td_filter_value="2189" href="https://weuponithiphop.info/category/latest-news/flashback/">Flashback</a><a class="mega-menu-sub-cat-td_uid_23_60352cd8f14a7"  id="td_uid_28_60352cd8f275e" data-td_block_id="td_uid_23_60352cd8f14a7" data-td_filter_value="10" href="https://weuponithiphop.info/category/latest-news/interviews/">Interviews</a><a class="mega-menu-sub-cat-td_uid_23_60352cd8f14a7"  id="td_uid_29_60352cd8f2870" data-td_block_id="td_uid_23_60352cd8f14a7" data-td_filter_value="130" href="https://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></div></div><div id=td_uid_23_60352cd8f14a7 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/22/video-tyler-the-creators-coca-cola-ad/" rel="bookmark" title="Video: Tyler, The Creator&#8217;s Coca-Cola Ad"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/5psm8fC.jpg" alt="" title="Video: Tyler, The Creator&#8217;s Coca-Cola Ad"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/22/video-tyler-the-creators-coca-cola-ad/" rel="bookmark" title="Video: Tyler, The Creator&#8217;s Coca-Cola Ad">Video: Tyler, The Creator&#8217;s Coca-Cola Ad</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/10/jay-z-mary-j-blige-ll-cool-j-nominated-for-2021-rock-roll-hall-of-fame/" rel="bookmark" title="JAY-Z, Mary J. Blige, LL Cool J Nominated For 2021 Rock &#038; Roll Hall Of Fame"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/DTwXuX8.jpg" alt="" title="JAY-Z, Mary J. Blige, LL Cool J Nominated For 2021 Rock &#038; Roll Hall Of Fame"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/10/jay-z-mary-j-blige-ll-cool-j-nominated-for-2021-rock-roll-hall-of-fame/" rel="bookmark" title="JAY-Z, Mary J. Blige, LL Cool J Nominated For 2021 Rock &#038; Roll Hall Of Fame">JAY-Z, Mary J. Blige, LL Cool J Nominated For 2021 Rock&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/08/video-drake-stars-in-state-farm-super-bowl-lv-ad/" rel="bookmark" title="Video: Drake Stars In State Farm Super Bowl LV Ad"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/1VkSF6x.jpg" alt="" title="Video: Drake Stars In State Farm Super Bowl LV Ad"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/08/video-drake-stars-in-state-farm-super-bowl-lv-ad/" rel="bookmark" title="Video: Drake Stars In State Farm Super Bowl LV Ad">Video: Drake Stars In State Farm Super Bowl LV Ad</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/01/19/video-the-late-pop-smoke-to-appear-in-eddie-huangs-directorial-debut-boogie/" rel="bookmark" title="Video: The Late Pop Smoke To Appear In Eddie Huang’s Directorial Debut, ‘BOOGIE’"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/t6Tym08.jpg" alt="" title="Video: The Late Pop Smoke To Appear In Eddie Huang’s Directorial Debut, ‘BOOGIE’"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/01/19/video-the-late-pop-smoke-to-appear-in-eddie-huangs-directorial-debut-boogie/" rel="bookmark" title="Video: The Late Pop Smoke To Appear In Eddie Huang’s Directorial Debut, ‘BOOGIE’">Video: The Late Pop Smoke To Appear In Eddie Huang’s Directorial&#8230;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_23_60352cd8f14a7" data-td_block_id="td_uid_23_60352cd8f14a7"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_23_60352cd8f14a7" data-td_block_id="td_uid_23_60352cd8f14a7"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-705"><a href="https://weuponithiphop.info/category/fashion/">Fashion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_30_60352cd91623c_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_30_60352cd91623c" ><script>var block_td_uid_30_60352cd91623c = new tdBlock();
block_td_uid_30_60352cd91623c.id = "td_uid_30_60352cd91623c";
block_td_uid_30_60352cd91623c.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"77","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_30_60352cd91623c_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_30_60352cd91623c.td_column_number = "3";
block_td_uid_30_60352cd91623c.block_type = "td_block_mega_menu";
block_td_uid_30_60352cd91623c.post_count = "4";
block_td_uid_30_60352cd91623c.found_posts = "158";
block_td_uid_30_60352cd91623c.header_color = "";
block_td_uid_30_60352cd91623c.ajax_pagination_infinite_stop = "";
block_td_uid_30_60352cd91623c.max_num_pages = "40";
tdBlocksArray.push(block_td_uid_30_60352cd91623c);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_30_60352cd91623c" id="td_uid_31_60352cd916d49" data-td_block_id="td_uid_30_60352cd91623c" data-td_filter_value="" href="https://weuponithiphop.info/category/fashion/">All</a><a class="mega-menu-sub-cat-td_uid_30_60352cd91623c"  id="td_uid_32_60352cd916e44" data-td_block_id="td_uid_30_60352cd91623c" data-td_filter_value="76" href="https://weuponithiphop.info/category/fashion/kicks/">Kicks</a></div></div><div id=td_uid_30_60352cd91623c class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/LVT4Mid8WL4wHUdO9X2OZmZxxgbREs2lVtszOdEBaO6hJB0JS3yQOAyhNSdCyPmv0amBDTgNGpOlRPXPjKCl6yIlo2joyH3rQRI7CUdX09BJtQI1r5jy1_7BQtDhw4AxUhpUwIh35rNS3lTy7uq-FdPff10JN6srr9mwZ7zr04GQFxBVEXwCfC5rNVehXhY_wGCRVsmevYmdkBWEmB8dvOzBHY78NBBjcHNArS_S-2M0FJgDh8v9m9vEh78k_XmZg-AERctsf0bkODuPi1EcNJq_RnJIV6b0GG-VtKjo-OVPmYghWJYf1HiP9c58cQ98oABU8BDFdLqsBtNt4K0NmyHYQlX39W9k_d83wEHZ1-EacQa2o01VrYSn12HnZ1l88fMzu9PKv6EGmcRZNwpepycW7_9EQnhxIPDdVCmRLXUasUED9OXr-zJmnBcnSnLCa06k1ZymQym1LiSFEv1c3aPHnmnD3GY8nL7q5jPJr4HsABR0WCqMebcF3HF_0deNd0zgRBCGMxW-VzlIIHZiHuBeSPEPvUL149GJ5swSSvKm1uGEi1HlLBj9omJSU7mDWzO0p_7l-l7-4_ureEsGsgB8cX1t8t2TQcFeRgqqF1CXlZFYYC2K0iMb4jPsijsw_rtO7pmKvbngqHfgYpGeh_qLmDWeicR7=w1195-h796-no" alt="" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch">Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/fHEwwMf8DoiXlqkfibQS1Z1XXbviORbV9raaI44tOTXrWo7GgqM3gA-vswE10gFtTQUGGwNG7nWAACwHjxPuiubliYBN_dqtBZh2WIpxvumiJ-hSLK0TNWB2cB8Iw2STT5gcp_KqlDh_e4xng1vidI8EXdp_ooh5uDI-JV1HQ9dGnM5nxl_b-v8znqj-Rl_mGB7y4Lu9zsFNWHU7SriqQQJaKrKEEnb9T8zxmGLaL0zq7ilYpnUEhWulDDr9xc82wdr__WzRBm5YEskVpDAnGM2NDZwTZpjbe4QDdxeixWnSXNK_oDzaL7WTbCpkD33OK88BlI5JmFRQ5VmD11UQ2htB7-9WoahHvb4XmBsbLXpEMl1JmEP4sPx06VduzFnBNo-J90WI0n1AEIIcEYVbRywrkGJXbzmH__In9ZIg0EV24OcGGbeKl12HxTdZwucqsNnuZeNjiMHISQ7i8cfzm3N7X7Zenl74zsKIKeKWoIGxh6MTlVADvgHcrHebnjcSgil2vBeFyz_AP45aOv9SOwbzfVLGS0CNfe1s9b2J7qZgjcBk9QPEXCl2kygvzmGXFvU_3xBuW6S0i3Vkh3Ha_3hPBtvIAy3WoTK2yiqS41HzSK7yk3FRAlBtpIEib338fdkTiosBxtdu36SdNUVM75zl6CVIFhTu=w681-h470-no" alt="" title="Air Jordan 14 Rip Hamilton"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton">Air Jordan 14 Rip Hamilton</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/kUjaOYxjEkAh34S-Ub2QSZwdOwHyFnGFLBZULta3_bn1_myPMAwJXiEEsAAtc1ktCQwHCuKhSqSYsWXFBEIZxdfKuykoDEZWwO-dDI3_JeAshbYvyILEHUu0XaUpRn0mj7gOx10V52t8gRGYPCW7QXGImkPGGhvBPzBDVVqh9lKGtkuPeePmTnpRSmwp0LG1WHcIzUWnMqPBWQeHAat6Q-Tq7niXNb96ddEZsMEdHK1nmHVlNaeqFBNtTxk6yYRkFNCvtfBayqy-Rqt4CPU5tThxbTI4AIUCI6JLxJd_VJizrVNDEe2xZ_tiQdkC5ASIoHpX8sfvAB8zRUsMVJ6oMUt5FH_4GBNXDCtFRmr65Qt0JV1h4bBJffu2L272Q_vpD76wn-YNGW8VCtZcheHu_X-A4gdYQEC0HN0BenY-MOuUBqKEjXAc0SxWeP7W9RN55jlqUFK0nzEYydVjec2stdQIngVfg_FvKxvHXfM4XdtMpqeJnp3Pzyk8xjz30sAZd0f2HQ6zfdPjk-OkV2-WrC0_qW0L8Rq3zrUbq52n3BN7gm7sctU_CUlBmoQIgJDQBYk1Siv4tfSq9pL1R4GdaOlWQdxEuhZi8bTYC8GGAgNGl3SMAZGvk7nu6QnnwEZjZ7mZwbcqgyRKa89cOREMUvIkVJ8Q8lZu=w926-h672-no" alt="" title="Jordan Proto React Triple White"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White">Jordan Proto React Triple White</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4cDUjSODZSaXWfHyZKb9q3Fn7FHA4uB0KSBs0MtFHC0dc6AJb1zeAl_X2LOKalK9C7VBFhTqRQ9fw1ESgUr9ZUKFbOzD94i_s96nvkICOqrsYnzrE2nEAQHoEaGOF4O8GAI6T4CGFbgcQhNzjpRlSY60NyPu5Cmq81FRpEOFRzTOtSa_NnWzMmfwO0yxtPbcg5U6YBUsus8shv3SA7CjULLfaP38nZAuWVgq8PMaaeCQ_eSrK8NJSEVQjyyxmqb-1I7zO8Kvvzvwi--ibMr52CF8h-GusBzSq5ZuzvZRCGu_u8CyfoXw7pwWbOmHnLOdcQ9d2PCSW_IxEMGfmEuU7NxMSsW3Ga4r35_wLB7cjvlPC9OjCV50tfekXjZBS_476mzlf4G9jR7Ju1GqgjXah9Uqc_0Y8N-Br8_JCtIlRSuLxAiebwd7AvFVlgWId9MYxBWnRT3cTyD8SH7q5WwO-CIbKAOSKsNcrrTgFxQvqn9yklBU1u5X5fdTlTBk4WSYorsWZAug0z9BOymRLnrhTbnA0vpBPFROWD-aL1glg-eUpFSfgD4xhWsOqJNY9krQ2UbLSGXQ5gYWj0ovLS7Yz3UKFY2qrVWpqkpbfyN98es9NJ-7LTUs2MLq1rX_2FaQmyq5mVndd7VGzQOHy9hDULG-5H-0LvGd=w900-h566-no" alt="" title="adidas Yeezy Boost 350 V2 Hyperspace"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace">adidas Yeezy Boost 350 V2 Hyperspace</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_30_60352cd91623c" data-td_block_id="td_uid_30_60352cd91623c"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_30_60352cd91623c" data-td_block_id="td_uid_30_60352cd91623c"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18581"><a href="https://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div>                </div>

                <div class="td-pb-span5 td-sub-footer-copy">
                    &copy; 2018 The Hip Hop Chronicles Media Group                </div>
            </div>
        </div>
    </div>
</div><!--close td-outer-wrap-->

	<div id="wpcp-error-message" class="msgmsg-box-wpcp hideme"><span>error: </span>Not Prohibited. ✌️</div>
	<script>
	var timeout_result;
	function show_wpcp_message(smessage)
	{
		if (smessage !== "")
			{
			var smessage_text = '<span>Alert: </span>'+smessage;
			document.getElementById("wpcp-error-message").innerHTML = smessage_text;
			document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp showme";
			clearTimeout(timeout_result);
			timeout_result = setTimeout(hide_message, 3000);
			}
	}
	function hide_message()
	{
		document.getElementById("wpcp-error-message").className = "msgmsg-box-wpcp warning-wpcp hideme";
	}
	</script>
		<style>
	@media print {
	body * {display: none !important;}
		body:after {
		content: "You are not allowed to print preview this page, Thank you"; }
	}
	</style>
		<style type="text/css">
	#wpcp-error-message {
	    direction: ltr;
	    text-align: center;
	    transition: opacity 900ms ease 0s;
	    z-index: 99999999;
	}
	.hideme {
    	opacity:0;
    	visibility: hidden;
	}
	.showme {
    	opacity:1;
    	visibility: visible;
	}
	.msgmsg-box-wpcp {
		border:1px solid #f5aca6;
		border-radius: 10px;
		color: #555;
		font-family: Tahoma;
		font-size: 11px;
		margin: 10px;
		padding: 10px 36px;
		position: fixed;
		width: 255px;
		top: 50%;
  		left: 50%;
  		margin-top: -10px;
  		margin-left: -130px;
  		-webkit-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
		-moz-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
		box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
	}
	.msgmsg-box-wpcp span {
		font-weight:bold;
		text-transform:uppercase;
	}
		.warning-wpcp {
		background:#ffecec url('https://weuponithiphop.info/wp-content/plugins/wp-content-copy-protector/images/warning.png') no-repeat 10px 50%;
	}
    </style>


    <!--

        Theme: Newspaper by tagDiv 2016
        Version: 7.2 (rara)
        Deploy mode: deploy
        
        uid: 60352cd923a88
    -->

    <link rel='stylesheet' id='so-css-Newspaper-css'  href='https://weuponithiphop.info/wp-content/uploads/so-css/so-css-Newspaper.css?ver=1528674688' type='text/css' media='all' />
<link rel='stylesheet' id='soliloquy-lite-style-css'  href='https://weuponithiphop.info/wp-content/plugins/soliloquy-lite/assets/css/soliloquy.css?ver=2.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='soliloquy-liteclassic-theme-css'  href='https://weuponithiphop.info/wp-content/plugins/soliloquy-lite/themes/classic/style.css?ver=2.6.1' type='text/css' media='all' />
<script type='text/javascript' src='https://weuponithiphop.info/wp-content/themes/Newspaper/js/tagdiv_theme.js?ver=7.2'></script>
<script type='text/javascript' src='https://weuponithiphop.info/wp-includes/js/comment-reply.min.js?ver=4.9.16'></script>
<script type='text/javascript' src='https://weuponithiphop.info/wp-includes/js/wp-embed.min.js?ver=4.9.16'></script>
<script type='text/javascript' src='https://weuponithiphop.info/wp-content/plugins/soliloquy-lite/assets/js/min/soliloquy-min.js?ver=2.6.1'></script>

<!-- JS generated by theme -->

<script>
    


            

	            // if the theme has tdBackstr support, it means this already uses it
                if ( 'undefined' !== typeof window.tdBackstr ) {

                    (function(){
                        // the site background td-backstretch jquery object is dynamically added in DOM, and after any translation effects are applied over td-backstretch
                        var wrapper_image_jquery_obj = jQuery( '<div class=\'backstretch\'></div>' );
                        var image_jquery_obj = jQuery( '<img class=\'td-backstretch not-parallax\' src=\'http://weuponithiphop.info/wp-content/uploads/20-black-paper-different-texture-types-a4-sandgrain-.jpg\'>' );

                        wrapper_image_jquery_obj.append( image_jquery_obj );

                        jQuery( 'body' ).prepend( wrapper_image_jquery_obj );

                        var td_backstr_item = new tdBackstr.item();

                        td_backstr_item.wrapper_image_jquery_obj = wrapper_image_jquery_obj;
                        td_backstr_item.image_jquery_obj = image_jquery_obj;

	                    tdBackstr.add_item( td_backstr_item );

                    })();
                }

            
            

                jQuery().ready(function jQuery_ready() {
                    tdAjaxCount.tdGetViewsCountsAjax("post","[43791]");
                });
            

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://weuponithiphop.info/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://weuponithiphop.info/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>

			<script type="text/javascript">
			if ( typeof soliloquy_slider === 'undefined' || false === soliloquy_slider ) {soliloquy_slider = {};}jQuery('#soliloquy-container-30342').css('height', Math.round(jQuery('#soliloquy-container-30342').width()/(960/300)));jQuery(window).load(function(){var $ = jQuery;var soliloquy_container_30342 = $('#soliloquy-container-30342'),soliloquy_30342 = $('#soliloquy-30342');soliloquy_slider['30342'] = soliloquy_30342.soliloquy({slideSelector: '.soliloquy-item',speed: 0,pause: 2000,auto: 1,useCSS: 0,keyboard: true,adaptiveHeight: 1,adaptiveHeightSpeed: 400,infiniteLoop: 1,mode: 'fade',pager: 1,controls: 1,nextText: '',prevText: '',startText: '',stopText: '',onSliderLoad: function(currentIndex){soliloquy_container_30342.find('.soliloquy-active-slide').removeClass('soliloquy-active-slide').attr('aria-hidden','true');soliloquy_container_30342.css({'height':'auto','background-image':'none'});if ( soliloquy_container_30342.find('.soliloquy-slider li').length > 1 ) {soliloquy_container_30342.find('.soliloquy-controls').fadeTo(300, 1);}soliloquy_30342.find('.soliloquy-item:not(.soliloquy-clone):eq(' + currentIndex + ')').addClass('soliloquy-active-slide').attr('aria-hidden','false');soliloquy_container_30342.find('.soliloquy-clone').find('*').removeAttr('id');soliloquy_container_30342.find('.soliloquy-controls-direction').attr('aria-label','carousel buttons').attr('aria-controls', 'soliloquy-container-30342');soliloquy_container_30342.find('.soliloquy-controls-direction a.soliloquy-prev').attr('aria-label','previous');soliloquy_container_30342.find('.soliloquy-controls-direction a.soliloquy-next').attr('aria-label','next');},onSlideBefore: function(element, oldIndex, newIndex){soliloquy_container_30342.find('.soliloquy-active-slide').removeClass('soliloquy-active-slide').attr('aria-hidden','true');$(element).addClass('soliloquy-active-slide').attr('aria-hidden','false');},onSlideAfter: function(element, oldIndex, newIndex){},});});			</script>
			
</body>
</html>