<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>Music Video: Sevyn Streeter ft. Jeremih &#8211; Wet Dreamz | WeUpOnIt</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://weuponithiphop.info/xmlrpc.php" />
    <meta property="og:image" content="https://i.imgur.com/87JkA0w.jpg" /><meta name="author" content="cyclone">
<link rel="icon" type="image/png" href="http://weuponithiphop.info/wp-content/uploads/weuponitlogoCAP-500x457.png"><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Feed" href="https://weuponithiphop.info/feed/" />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Comments Feed" href="https://weuponithiphop.info/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Music Video: Sevyn Streeter ft. Jeremih &#8211; Wet Dreamz Comments Feed" href="https://weuponithiphop.info/2021/09/28/music-video-sevyn-streeter-ft-jeremih-wet-dreamz/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/weuponithiphop.info\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.18"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])?!1:!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55358,56760,9792,65039],[55358,56760,8203,9792,65039])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='google_font_open_sans-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;ver=4.9.18' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_roboto-css'  href='https://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C900%2C500italic%2C400%2C300&#038;ver=4.9.18' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Roboto+Condensed%3A400%2C700&#038;ver=4.9.18' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='https://weuponithiphop.info/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='https://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=4.12' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://weuponithiphop.info/wp-content/themes/Newspaper/style.css?ver=7.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css'  href='https://weuponithiphop.info/wp-content/themes/Newspaper/includes/demos/what/demo_style.css?ver=7.2' type='text/css' media='all' />
<script type='text/javascript' src='https://weuponithiphop.info/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://weuponithiphop.info/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://weuponithiphop.info/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1'></script>
<link rel='https://api.w.org/' href='https://weuponithiphop.info/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://weuponithiphop.info/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://weuponithiphop.info/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Dreamville Festival 2022 Announced' href='https://weuponithiphop.info/2021/09/28/dreamville-festival-2022-announced/' />
<meta name="generator" content="WordPress 4.9.18" />
<link rel="canonical" href="https://weuponithiphop.info/2021/09/28/music-video-sevyn-streeter-ft-jeremih-wet-dreamz/" />
<link rel='shortlink' href='https://weuponithiphop.info/?p=46605' />
<link rel="alternate" type="application/json+oembed" href="https://weuponithiphop.info/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fweuponithiphop.info%2F2021%2F09%2F28%2Fmusic-video-sevyn-streeter-ft-jeremih-wet-dreamz%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://weuponithiphop.info/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fweuponithiphop.info%2F2021%2F09%2F28%2Fmusic-video-sevyn-streeter-ft-jeremih-wet-dreamz%2F&#038;format=xml" />

<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>
<!-- Analytics by WP-Statistics v13.0.8 - https://wp-statistics.com/ -->
<!--[if lt IE 9]><script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="https://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]-->
<!-- JS generated by theme -->

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var tds_login_sing_in_widget="show";
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_ajax_url="https:\/\/weuponithiphop.info\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=7.2";
var td_get_template_directory_uri="https:\/\/weuponithiphop.info\/wp-content\/themes\/Newspaper";
var tds_snap_menu="snap";
var tds_logo_on_sticky="show_header_logo";
var tds_header_style="5";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#dd3333";
var tds_smart_sidebar="enabled";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>


<!-- Header style compiled by theme -->

<style>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</style>

<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>

<body class="post-template-default single single-post postid-46605 single-format-standard music-video-sevyn-streeter-ft-jeremih-wet-dreamz td-what wpb-js-composer js-comp-ver-4.12 vc_responsive td-boxed-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponit_com" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
                    <div class="td-menu-login-section">
                
    <div class="td-guest-wrap">
        <div class="td-menu-avatar"><div class="td-avatar-container"><img alt='' src='https://secure.gravatar.com/avatar/?s=80&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo avatar-default' height='80' width='80' /></div></div>
        <div class="td-menu-login"><a id="login-link-mob">Sign in</a></div>
    </div>
            </div>
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-top-menu-container"><ul id="menu-top-menu" class="td-mobile-main-menu"><li id="menu-item-317" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-317"><a href="https://weuponithiphop.info/category/new-music/">New Music</a></li>
<li id="menu-item-706" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-706"><a href="https://weuponithiphop.info/category/album-stream-mixtapes/">Album Stream</a></li>
<li id="menu-item-314" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-314"><a href="https://weuponithiphop.info/category/music-video/">Videos</a></li>
<li id="menu-item-316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-316"><a href="https://weuponithiphop.info/category/latest-news/">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-0" class="menu-item-0"><a href="https://weuponithiphop.info/category/latest-news/album-news/">Album News</a></li>
	<li class="menu-item-0"><a href="https://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a></li>
	<li class="menu-item-0"><a href="https://weuponithiphop.info/category/latest-news/flashback/">Flashback</a></li>
	<li class="menu-item-0"><a href="https://weuponithiphop.info/category/latest-news/interviews/">Interviews</a></li>
	<li class="menu-item-0"><a href="https://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></li>
</ul>
</li>
<li id="menu-item-705" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-705"><a href="https://weuponithiphop.info/category/fashion/">Fashion<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li class="menu-item-0"><a href="https://weuponithiphop.info/category/fashion/kicks/">Kicks</a></li>
</ul>
</li>
<li id="menu-item-18581" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18581"><a href="https://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li id="menu-item-3199" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
            <div id="login-form-mobile" class="td-register-section">
            
            <div id="td-login-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-login-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign in</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
	                <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
	                <div class="td-login-info-text"><a href="#" id="forgot-pass-link-mob">Forgot your password?</a></div>
                </div>
            </div>

            

            <div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
                <!-- close button -->
	            <div class="td-forgot-pass-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Password recovery</div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title">Recover your password</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
	                <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
                </div>
            </div>
        </div>
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="https://weuponithiphop.info/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap">
    
        <!--
Header style 5
-->

<div class="td-header-wrap td-header-style-5">

    <div class="td-header-top-menu-full">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div >

                Tuesday, September 28, 2021
            </div>
        </div>
    <ul class="top-header-menu td_ul_login"><li class="menu-item"><a class="td-login-modal-js menu-item" href="#login-form" data-effect="mpf-td-login-effect">Sign in / Join</a><span class="td-sp-ico-login td_sp_login_ico_style"></span></li></ul><div class="menu-top-container"><ul id="menu-main" class="top-header-menu"><li id="menu-item-79" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-79"><a href="http://weuponithiphop.info">Home</a></li>
<li id="menu-item-81" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-81"><a target="_blank" href="http://weuponitradio.com">Power 105.1 WeUpOnIt Radio</a></li>
<li id="menu-item-80" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-80"><a target="_blank" href="https://shop.spreadshirt.com/freshandcleantees/">Shop</a></li>
<li id="menu-item-18582" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18582"><a href="https://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li id="menu-item-18583" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18583"><a href="https://weuponithiphop.info/privacy-policy-2/">Privacy Policy</a></li>
</ul></div></div>
        <div class="td-header-sp-top-widget">
    
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponit_com" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div>
    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <ul class="td-login-tabs">
                        <li><a id="login-link" class="td_login_tab_focus">LOG IN</a></li>
                    </ul>



                    <div class="td-login-wrap">
                        <div class="td_display_err"></div>

                        <div id="td-login-div" class="">
                            <div class="td-login-panel-title">Welcome! Log into your account</div>
                            <input class="td-login-input" type="text" name="login_email" id="login_email" placeholder="your username" value="" required>
                            <input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" placeholder="your password" required>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Log In">


                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password?</a></div>


                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-display-none">
                            <div class="td-login-panel-title">Recover your password</div>
                            <input class="td-login-input" type="text" name="forgot_email" id="forgot_email" placeholder="your email" value="" required>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Pass">
                        </div>




                    </div>
                </div>
                        </div>
    </div>

    <div class="td-header-menu-wrap-full">
        <div class="td-header-menu-wrap">
            <div class="td-container td-header-row td-header-main-menu black-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-menu">
        		<a class="td-mobile-logo td-sticky-header" href="https://weuponithiphop.info/">
			<img class="td-retina-data" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-5.png" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-5.png" alt=""/>
		</a>
			<a class="td-header-logo td-sticky-header" href="https://weuponithiphop.info/">
			<img class="td-retina-data" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" alt=""/>
			<span class="td-visual-hidden">WeUpOnIt</span>
		</a>
	    </div>
    <div class="menu-top-menu-container"><ul id="menu-top-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-mega-menu menu-item-317"><a href="https://weuponithiphop.info/category/new-music/">New Music</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_1_6152d307ae067_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_1_6152d307ae067" ><script>var block_td_uid_1_6152d307ae067 = new tdBlock();
block_td_uid_1_6152d307ae067.id = "td_uid_1_6152d307ae067";
block_td_uid_1_6152d307ae067.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"43","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_1_6152d307ae067_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_1_6152d307ae067.td_column_number = "3";
block_td_uid_1_6152d307ae067.block_type = "td_block_mega_menu";
block_td_uid_1_6152d307ae067.post_count = "5";
block_td_uid_1_6152d307ae067.found_posts = "4064";
block_td_uid_1_6152d307ae067.header_color = "";
block_td_uid_1_6152d307ae067.ajax_pagination_infinite_stop = "";
block_td_uid_1_6152d307ae067.max_num_pages = "813";
tdBlocksArray.push(block_td_uid_1_6152d307ae067);
</script><div id=td_uid_1_6152d307ae067 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/27/new-music-amber-mark-what-it-is/" rel="bookmark" title="New Music: Amber Mark &#8211; What It Is"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/QsDgtF2.jpg" alt="" title="New Music: Amber Mark &#8211; What It Is"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/27/new-music-amber-mark-what-it-is/" rel="bookmark" title="New Music: Amber Mark &#8211; What It Is">New Music: Amber Mark &#8211; What It Is</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/27/new-music-russ-ft-capella-grey-seduce/" rel="bookmark" title="New Music: Russ ft. Capella Grey &#8211; Seduce"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/HSNyNjK.png" alt="" title="New Music: Russ ft. Capella Grey &#8211; Seduce"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/27/new-music-russ-ft-capella-grey-seduce/" rel="bookmark" title="New Music: Russ ft. Capella Grey &#8211; Seduce">New Music: Russ ft. Capella Grey &#8211; Seduce</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/27/new-music-gunna-ft-future-too-easy/" rel="bookmark" title="New Music: Gunna Ft. Future &#8211; Too Easy"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/VKqVrRU.jpg" alt="" title="New Music: Gunna Ft. Future &#8211; Too Easy"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/27/new-music-gunna-ft-future-too-easy/" rel="bookmark" title="New Music: Gunna Ft. Future &#8211; Too Easy">New Music: Gunna Ft. Future &#8211; Too Easy</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/25/new-music-logic-ft-aap-ferg-lil-wayne-perfect-remix/" rel="bookmark" title="New Music: Logic ft. A$AP Ferg &#038; Lil Wayne &#8211; Perfect (Remix)"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/S9OmjzF.jpg" alt="" title="New Music: Logic ft. A$AP Ferg &#038; Lil Wayne &#8211; Perfect (Remix)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/25/new-music-logic-ft-aap-ferg-lil-wayne-perfect-remix/" rel="bookmark" title="New Music: Logic ft. A$AP Ferg &#038; Lil Wayne &#8211; Perfect (Remix)">New Music: Logic ft. A$AP Ferg &#038; Lil Wayne &#8211; Perfect&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/25/new-music-50-cent-ft-snoop-dogg-moneybagg-yo-charlie-wilson-wish-me-luck/" rel="bookmark" title="New Music: 50 Cent ft. Snoop Dogg, Moneybagg Yo &#038; Charlie Wilson &#8211; Wish Me Luck"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/ZQBRu4t.jpg" alt="" title="New Music: 50 Cent ft. Snoop Dogg, Moneybagg Yo &#038; Charlie Wilson &#8211; Wish Me Luck"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/25/new-music-50-cent-ft-snoop-dogg-moneybagg-yo-charlie-wilson-wish-me-luck/" rel="bookmark" title="New Music: 50 Cent ft. Snoop Dogg, Moneybagg Yo &#038; Charlie Wilson &#8211; Wish Me Luck">New Music: 50 Cent ft. Snoop Dogg, Moneybagg Yo &#038; Charlie&#8230;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_6152d307ae067" data-td_block_id="td_uid_1_6152d307ae067"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_1_6152d307ae067" data-td_block_id="td_uid_1_6152d307ae067"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-706"><a href="https://weuponithiphop.info/category/album-stream-mixtapes/">Album Stream</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_2_6152d307c81ac_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_2_6152d307c81ac" ><script>var block_td_uid_2_6152d307c81ac = new tdBlock();
block_td_uid_2_6152d307c81ac.id = "td_uid_2_6152d307c81ac";
block_td_uid_2_6152d307c81ac.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"97","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_2_6152d307c81ac_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_2_6152d307c81ac.td_column_number = "3";
block_td_uid_2_6152d307c81ac.block_type = "td_block_mega_menu";
block_td_uid_2_6152d307c81ac.post_count = "5";
block_td_uid_2_6152d307c81ac.found_posts = "1496";
block_td_uid_2_6152d307c81ac.header_color = "";
block_td_uid_2_6152d307c81ac.ajax_pagination_infinite_stop = "";
block_td_uid_2_6152d307c81ac.max_num_pages = "300";
tdBlocksArray.push(block_td_uid_2_6152d307c81ac);
</script><div id=td_uid_2_6152d307c81ac class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/24/album-stream-d-smoke-war-wonders/" rel="bookmark" title="Album Stream: D Smoke &#8211; War &#038; Wonders"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/ZUnu7Tx.jpg" alt="" title="Album Stream: D Smoke &#8211; War &#038; Wonders"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/24/album-stream-d-smoke-war-wonders/" rel="bookmark" title="Album Stream: D Smoke &#8211; War &#038; Wonders">Album Stream: D Smoke &#8211; War &#038; Wonders</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/24/album-stream-run-the-jewels-rtj4-deluxe/" rel="bookmark" title="Album Stream: Run the Jewels &#8211; RTJ4 (Deluxe)"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/ZJIIElu.jpg" alt="" title="Album Stream: Run the Jewels &#8211; RTJ4 (Deluxe)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/24/album-stream-run-the-jewels-rtj4-deluxe/" rel="bookmark" title="Album Stream: Run the Jewels &#8211; RTJ4 (Deluxe)">Album Stream: Run the Jewels &#8211; RTJ4 (Deluxe)</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/24/album-stream-westside-gunn-hitler-wears-hermes-8-side-b/" rel="bookmark" title="Album Stream: Westside Gunn &#8211; Hitler Wears Hermes 8 (Side B)"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/gFFubvq.jpg" alt="" title="Album Stream: Westside Gunn &#8211; Hitler Wears Hermes 8 (Side B)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/24/album-stream-westside-gunn-hitler-wears-hermes-8-side-b/" rel="bookmark" title="Album Stream: Westside Gunn &#8211; Hitler Wears Hermes 8 (Side B)">Album Stream: Westside Gunn &#8211; Hitler Wears Hermes 8 (Side B)</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/20/album-stream-vanjess-homegrown-deluxe/" rel="bookmark" title="Album Stream: VanJess &#8211; Homegrown (Deluxe)"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/mlqgxRh.jpg" alt="" title="Album Stream: VanJess &#8211; Homegrown (Deluxe)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/20/album-stream-vanjess-homegrown-deluxe/" rel="bookmark" title="Album Stream: VanJess &#8211; Homegrown (Deluxe)">Album Stream: VanJess &#8211; Homegrown (Deluxe)</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/20/album-stream-mozzy-untreated-trauma/" rel="bookmark" title="Album Stream: Mozzy &#8211; Untreated Trauma"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/2qErfXE.jpg" alt="" title="Album Stream: Mozzy &#8211; Untreated Trauma"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/20/album-stream-mozzy-untreated-trauma/" rel="bookmark" title="Album Stream: Mozzy &#8211; Untreated Trauma">Album Stream: Mozzy &#8211; Untreated Trauma</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_6152d307c81ac" data-td_block_id="td_uid_2_6152d307c81ac"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_2_6152d307c81ac" data-td_block_id="td_uid_2_6152d307c81ac"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-314"><a href="https://weuponithiphop.info/category/music-video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_3_6152d307d2d40_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_3_6152d307d2d40" ><script>var block_td_uid_3_6152d307d2d40 = new tdBlock();
block_td_uid_3_6152d307d2d40.id = "td_uid_3_6152d307d2d40";
block_td_uid_3_6152d307d2d40.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_3_6152d307d2d40_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_3_6152d307d2d40.td_column_number = "3";
block_td_uid_3_6152d307d2d40.block_type = "td_block_mega_menu";
block_td_uid_3_6152d307d2d40.post_count = "5";
block_td_uid_3_6152d307d2d40.found_posts = "4823";
block_td_uid_3_6152d307d2d40.header_color = "";
block_td_uid_3_6152d307d2d40.ajax_pagination_infinite_stop = "";
block_td_uid_3_6152d307d2d40.max_num_pages = "965";
tdBlocksArray.push(block_td_uid_3_6152d307d2d40);
</script><div id=td_uid_3_6152d307d2d40 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/28/music-video-sevyn-streeter-ft-jeremih-wet-dreamz/" rel="bookmark" title="Music Video: Sevyn Streeter ft. Jeremih &#8211; Wet Dreamz"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/87JkA0w.jpg" alt="" title="Music Video: Sevyn Streeter ft. Jeremih &#8211; Wet Dreamz"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/28/music-video-sevyn-streeter-ft-jeremih-wet-dreamz/" rel="bookmark" title="Music Video: Sevyn Streeter ft. Jeremih &#8211; Wet Dreamz">Music Video: Sevyn Streeter ft. Jeremih &#8211; Wet Dreamz</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/27/music-video-lakeyah-reason/" rel="bookmark" title="Music Video: Lakeyah &#8211; Reason"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/kCM8unr.jpg" alt="" title="Music Video: Lakeyah &#8211; Reason"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/27/music-video-lakeyah-reason/" rel="bookmark" title="Music Video: Lakeyah &#8211; Reason">Music Video: Lakeyah &#8211; Reason</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/26/music-video-larry-june-cardo-dont-try-it/" rel="bookmark" title="Music Video: Larry June &#038; Cardo &#8211; Don’t Try It"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/sDQLPcS.jpg" alt="" title="Music Video: Larry June &#038; Cardo &#8211; Don’t Try It"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/26/music-video-larry-june-cardo-dont-try-it/" rel="bookmark" title="Music Video: Larry June &#038; Cardo &#8211; Don’t Try It">Music Video: Larry June &#038; Cardo &#8211; Don’t Try It</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/26/music-video-morray-bad-situations/" rel="bookmark" title="Music Video: Morray &#8211; Bad Situations"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/2QMYzsl.jpg" alt="" title="Music Video: Morray &#8211; Bad Situations"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/26/music-video-morray-bad-situations/" rel="bookmark" title="Music Video: Morray &#8211; Bad Situations">Music Video: Morray &#8211; Bad Situations</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/26/music-video-latto-big-energy/" rel="bookmark" title="Music Video: Latto &#8211; Big Energy"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/QCMq9eF.jpg" alt="" title="Music Video: Latto &#8211; Big Energy"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/26/music-video-latto-big-energy/" rel="bookmark" title="Music Video: Latto &#8211; Big Energy">Music Video: Latto &#8211; Big Energy</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_6152d307d2d40" data-td_block_id="td_uid_3_6152d307d2d40"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_3_6152d307d2d40" data-td_block_id="td_uid_3_6152d307d2d40"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-316"><a href="https://weuponithiphop.info/category/latest-news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_4_6152d307e4e46_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_4_6152d307e4e46" ><script>var block_td_uid_4_6152d307e4e46 = new tdBlock();
block_td_uid_4_6152d307e4e46.id = "td_uid_4_6152d307e4e46";
block_td_uid_4_6152d307e4e46.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"29","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_4_6152d307e4e46_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_4_6152d307e4e46.td_column_number = "3";
block_td_uid_4_6152d307e4e46.block_type = "td_block_mega_menu";
block_td_uid_4_6152d307e4e46.post_count = "4";
block_td_uid_4_6152d307e4e46.found_posts = "1121";
block_td_uid_4_6152d307e4e46.header_color = "";
block_td_uid_4_6152d307e4e46.ajax_pagination_infinite_stop = "";
block_td_uid_4_6152d307e4e46.max_num_pages = "281";
tdBlocksArray.push(block_td_uid_4_6152d307e4e46);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_4_6152d307e4e46" id="td_uid_5_6152d307ecea6" data-td_block_id="td_uid_4_6152d307e4e46" data-td_filter_value="" href="https://weuponithiphop.info/category/latest-news/">All</a><a class="mega-menu-sub-cat-td_uid_4_6152d307e4e46"  id="td_uid_6_6152d307ecfed" data-td_block_id="td_uid_4_6152d307e4e46" data-td_filter_value="69" href="https://weuponithiphop.info/category/latest-news/album-news/">Album News</a><a class="mega-menu-sub-cat-td_uid_4_6152d307e4e46"  id="td_uid_7_6152d307ed115" data-td_block_id="td_uid_4_6152d307e4e46" data-td_filter_value="80" href="https://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a><a class="mega-menu-sub-cat-td_uid_4_6152d307e4e46"  id="td_uid_8_6152d307ed295" data-td_block_id="td_uid_4_6152d307e4e46" data-td_filter_value="2189" href="https://weuponithiphop.info/category/latest-news/flashback/">Flashback</a><a class="mega-menu-sub-cat-td_uid_4_6152d307e4e46"  id="td_uid_9_6152d307ed422" data-td_block_id="td_uid_4_6152d307e4e46" data-td_filter_value="10" href="https://weuponithiphop.info/category/latest-news/interviews/">Interviews</a><a class="mega-menu-sub-cat-td_uid_4_6152d307e4e46"  id="td_uid_10_6152d307ed5b7" data-td_block_id="td_uid_4_6152d307e4e46" data-td_filter_value="130" href="https://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></div></div><div id=td_uid_4_6152d307e4e46 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_module_no_thumb td_mod_mega_menu">
            <div class="td-module-image">
                                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/28/dreamville-festival-2022-announced/" rel="bookmark" title="Dreamville Festival 2022 Announced">Dreamville Festival 2022 Announced</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/27/video-kanye-wests-netflix-documentary-jeen-yuhs/" rel="bookmark" title="Video: Kanye West’s Netflix Documentary, ‘JEEN-YUHS&#8217;"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/RTVeKuE.jpg" alt="" title="Video: Kanye West’s Netflix Documentary, ‘JEEN-YUHS&#8217;"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/27/video-kanye-wests-netflix-documentary-jeen-yuhs/" rel="bookmark" title="Video: Kanye West’s Netflix Documentary, ‘JEEN-YUHS&#8217;">Video: Kanye West’s Netflix Documentary, ‘JEEN-YUHS&#8217;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/23/video-megan-thee-stallion-new-hotties-nike-commercial/" rel="bookmark" title="Video: Megan Thee Stallion “New Hotties” Nike Commercial"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/1Mz8ewG.jpg" alt="" title="Video: Megan Thee Stallion “New Hotties” Nike Commercial"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/23/video-megan-thee-stallion-new-hotties-nike-commercial/" rel="bookmark" title="Video: Megan Thee Stallion “New Hotties” Nike Commercial">Video: Megan Thee Stallion “New Hotties” Nike Commercial</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/21/video-janet-jackson-janet-documentary-trailer/" rel="bookmark" title="Video: Janet Jackson &#8211; JANET (Documentary Trailer)"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/ykpIX0Y.jpg" alt="" title="Video: Janet Jackson &#8211; JANET (Documentary Trailer)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/21/video-janet-jackson-janet-documentary-trailer/" rel="bookmark" title="Video: Janet Jackson &#8211; JANET (Documentary Trailer)">Video: Janet Jackson &#8211; JANET (Documentary Trailer)</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_4_6152d307e4e46" data-td_block_id="td_uid_4_6152d307e4e46"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_4_6152d307e4e46" data-td_block_id="td_uid_4_6152d307e4e46"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-705"><a href="https://weuponithiphop.info/category/fashion/">Fashion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_11_6152d308255bb_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_11_6152d308255bb" ><script>var block_td_uid_11_6152d308255bb = new tdBlock();
block_td_uid_11_6152d308255bb.id = "td_uid_11_6152d308255bb";
block_td_uid_11_6152d308255bb.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"77","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_11_6152d308255bb_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_11_6152d308255bb.td_column_number = "3";
block_td_uid_11_6152d308255bb.block_type = "td_block_mega_menu";
block_td_uid_11_6152d308255bb.post_count = "4";
block_td_uid_11_6152d308255bb.found_posts = "158";
block_td_uid_11_6152d308255bb.header_color = "";
block_td_uid_11_6152d308255bb.ajax_pagination_infinite_stop = "";
block_td_uid_11_6152d308255bb.max_num_pages = "40";
tdBlocksArray.push(block_td_uid_11_6152d308255bb);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_11_6152d308255bb" id="td_uid_12_6152d30828b23" data-td_block_id="td_uid_11_6152d308255bb" data-td_filter_value="" href="https://weuponithiphop.info/category/fashion/">All</a><a class="mega-menu-sub-cat-td_uid_11_6152d308255bb"  id="td_uid_13_6152d30828ca5" data-td_block_id="td_uid_11_6152d308255bb" data-td_filter_value="76" href="https://weuponithiphop.info/category/fashion/kicks/">Kicks</a></div></div><div id=td_uid_11_6152d308255bb class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/LVT4Mid8WL4wHUdO9X2OZmZxxgbREs2lVtszOdEBaO6hJB0JS3yQOAyhNSdCyPmv0amBDTgNGpOlRPXPjKCl6yIlo2joyH3rQRI7CUdX09BJtQI1r5jy1_7BQtDhw4AxUhpUwIh35rNS3lTy7uq-FdPff10JN6srr9mwZ7zr04GQFxBVEXwCfC5rNVehXhY_wGCRVsmevYmdkBWEmB8dvOzBHY78NBBjcHNArS_S-2M0FJgDh8v9m9vEh78k_XmZg-AERctsf0bkODuPi1EcNJq_RnJIV6b0GG-VtKjo-OVPmYghWJYf1HiP9c58cQ98oABU8BDFdLqsBtNt4K0NmyHYQlX39W9k_d83wEHZ1-EacQa2o01VrYSn12HnZ1l88fMzu9PKv6EGmcRZNwpepycW7_9EQnhxIPDdVCmRLXUasUED9OXr-zJmnBcnSnLCa06k1ZymQym1LiSFEv1c3aPHnmnD3GY8nL7q5jPJr4HsABR0WCqMebcF3HF_0deNd0zgRBCGMxW-VzlIIHZiHuBeSPEPvUL149GJ5swSSvKm1uGEi1HlLBj9omJSU7mDWzO0p_7l-l7-4_ureEsGsgB8cX1t8t2TQcFeRgqqF1CXlZFYYC2K0iMb4jPsijsw_rtO7pmKvbngqHfgYpGeh_qLmDWeicR7=w1195-h796-no" alt="" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch">Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/fHEwwMf8DoiXlqkfibQS1Z1XXbviORbV9raaI44tOTXrWo7GgqM3gA-vswE10gFtTQUGGwNG7nWAACwHjxPuiubliYBN_dqtBZh2WIpxvumiJ-hSLK0TNWB2cB8Iw2STT5gcp_KqlDh_e4xng1vidI8EXdp_ooh5uDI-JV1HQ9dGnM5nxl_b-v8znqj-Rl_mGB7y4Lu9zsFNWHU7SriqQQJaKrKEEnb9T8zxmGLaL0zq7ilYpnUEhWulDDr9xc82wdr__WzRBm5YEskVpDAnGM2NDZwTZpjbe4QDdxeixWnSXNK_oDzaL7WTbCpkD33OK88BlI5JmFRQ5VmD11UQ2htB7-9WoahHvb4XmBsbLXpEMl1JmEP4sPx06VduzFnBNo-J90WI0n1AEIIcEYVbRywrkGJXbzmH__In9ZIg0EV24OcGGbeKl12HxTdZwucqsNnuZeNjiMHISQ7i8cfzm3N7X7Zenl74zsKIKeKWoIGxh6MTlVADvgHcrHebnjcSgil2vBeFyz_AP45aOv9SOwbzfVLGS0CNfe1s9b2J7qZgjcBk9QPEXCl2kygvzmGXFvU_3xBuW6S0i3Vkh3Ha_3hPBtvIAy3WoTK2yiqS41HzSK7yk3FRAlBtpIEib338fdkTiosBxtdu36SdNUVM75zl6CVIFhTu=w681-h470-no" alt="" title="Air Jordan 14 Rip Hamilton"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton">Air Jordan 14 Rip Hamilton</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/kUjaOYxjEkAh34S-Ub2QSZwdOwHyFnGFLBZULta3_bn1_myPMAwJXiEEsAAtc1ktCQwHCuKhSqSYsWXFBEIZxdfKuykoDEZWwO-dDI3_JeAshbYvyILEHUu0XaUpRn0mj7gOx10V52t8gRGYPCW7QXGImkPGGhvBPzBDVVqh9lKGtkuPeePmTnpRSmwp0LG1WHcIzUWnMqPBWQeHAat6Q-Tq7niXNb96ddEZsMEdHK1nmHVlNaeqFBNtTxk6yYRkFNCvtfBayqy-Rqt4CPU5tThxbTI4AIUCI6JLxJd_VJizrVNDEe2xZ_tiQdkC5ASIoHpX8sfvAB8zRUsMVJ6oMUt5FH_4GBNXDCtFRmr65Qt0JV1h4bBJffu2L272Q_vpD76wn-YNGW8VCtZcheHu_X-A4gdYQEC0HN0BenY-MOuUBqKEjXAc0SxWeP7W9RN55jlqUFK0nzEYydVjec2stdQIngVfg_FvKxvHXfM4XdtMpqeJnp3Pzyk8xjz30sAZd0f2HQ6zfdPjk-OkV2-WrC0_qW0L8Rq3zrUbq52n3BN7gm7sctU_CUlBmoQIgJDQBYk1Siv4tfSq9pL1R4GdaOlWQdxEuhZi8bTYC8GGAgNGl3SMAZGvk7nu6QnnwEZjZ7mZwbcqgyRKa89cOREMUvIkVJ8Q8lZu=w926-h672-no" alt="" title="Jordan Proto React Triple White"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White">Jordan Proto React Triple White</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4cDUjSODZSaXWfHyZKb9q3Fn7FHA4uB0KSBs0MtFHC0dc6AJb1zeAl_X2LOKalK9C7VBFhTqRQ9fw1ESgUr9ZUKFbOzD94i_s96nvkICOqrsYnzrE2nEAQHoEaGOF4O8GAI6T4CGFbgcQhNzjpRlSY60NyPu5Cmq81FRpEOFRzTOtSa_NnWzMmfwO0yxtPbcg5U6YBUsus8shv3SA7CjULLfaP38nZAuWVgq8PMaaeCQ_eSrK8NJSEVQjyyxmqb-1I7zO8Kvvzvwi--ibMr52CF8h-GusBzSq5ZuzvZRCGu_u8CyfoXw7pwWbOmHnLOdcQ9d2PCSW_IxEMGfmEuU7NxMSsW3Ga4r35_wLB7cjvlPC9OjCV50tfekXjZBS_476mzlf4G9jR7Ju1GqgjXah9Uqc_0Y8N-Br8_JCtIlRSuLxAiebwd7AvFVlgWId9MYxBWnRT3cTyD8SH7q5WwO-CIbKAOSKsNcrrTgFxQvqn9yklBU1u5X5fdTlTBk4WSYorsWZAug0z9BOymRLnrhTbnA0vpBPFROWD-aL1glg-eUpFSfgD4xhWsOqJNY9krQ2UbLSGXQ5gYWj0ovLS7Yz3UKFY2qrVWpqkpbfyN98es9NJ-7LTUs2MLq1rX_2FaQmyq5mVndd7VGzQOHy9hDULG-5H-0LvGd=w900-h566-no" alt="" title="adidas Yeezy Boost 350 V2 Hyperspace"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace">adidas Yeezy Boost 350 V2 Hyperspace</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_11_6152d308255bb" data-td_block_id="td_uid_11_6152d308255bb"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_11_6152d308255bb" data-td_block_id="td_uid_11_6152d308255bb"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18581"><a href="https://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div></div>


<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form method="get" class="td-search-form" action="https://weuponithiphop.info/">
				<div role="search" class="td-head-form-search-wrap">
					<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>            </div>
        </div>
    </div>

    <div class="td-banner-wrap-full">
        <div class="td-header-container td-header-row td-header-header">
            <div class="td-header-sp-recs">
                <div class="td-header-rec-wrap">
    
</div>            </div>
        </div>
    </div>

</div><div class="td-main-content-wrap">

    <div class="td-container td-post-template-default ">
        <div class="td-crumb-container"><div class="entry-crumbs"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="" class="entry-crumb" itemprop="url" href="https://weuponithiphop.info/"><span itemprop="title">Home</span></a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="View all posts in Music Video" class="entry-crumb" itemprop="url" href="https://weuponithiphop.info/category/music-video/"><span itemprop="title">Music Video</span></a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last" itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><meta itemprop="title" content = "Music Video: Sevyn Streeter ft. Jeremih &#8211; Wet Dreamz"><meta itemprop="url" content = "https://weuponithiphop.info/2021/09/28/music-video-sevyn-streeter-ft-jeremih-wet-dreamz/">Music Video: Sevyn Streeter ft. Jeremih &#8211; Wet Dreamz</span></div></div>

        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-46605" class="post-46605 post type-post status-publish format-standard has-post-thumbnail hentry category-music-video tag-jeremih tag-sevyn-streeter" itemscope itemtype="https://schema.org/Article">
        <div class="td-post-header">

            <ul class="td-category"><li class="entry-category"><a  href="https://weuponithiphop.info/category/music-video/">Music Video</a></li></ul>
            <header class="td-post-title">
                <h1 class="entry-title">Music Video: Sevyn Streeter ft. Jeremih &#8211; Wet Dreamz</h1>

                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name">By <a href="https://weuponithiphop.info/author/cyclone/">cyclone</a> - </div>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-09-28T04:32:03+00:00" >September 28, 2021</time></span>                    <div class="td-post-comments"><a href="https://weuponithiphop.info/2021/09/28/music-video-sevyn-streeter-ft-jeremih-wet-dreamz/#respond"><i class="td-icon-comments"></i>0</a></div>                                    </div>

            </header>

        </div>

        

        <div class="td-post-content">

        
        <p><img class="aligncenter size-medium" src="https://i.imgur.com/87JkA0w.jpg" width="838" height="477" /></p>
<p><strong>Sevyn Streeter</strong> and <strong>Jeremih</strong> get spicy in the sheets for the latest collab <strong>&#8220;Wet Dreamz&#8221;</strong>. Off of <strong>Sevyn’s</strong> new album <em><strong>Drunken Wordz, Sober Thoughtz</strong></em>. Directed by <strong>Bobby Hanaford</strong> and <strong>Sebastian Sdaigui</strong>. The racy visual finds the two out in the desert getting intimate in the hot desert sun and also in pouring rain.</p>
<p>Watch the <strong>&#8220;Wet Dreamz&#8221;</strong> video below.</p>
<p><iframe title="YouTube video player" src="https://www.youtube.com/embed/ctpwaCCbX1Y" width="590" height="332" frameborder="0" allowfullscreen="allowfullscreen"></iframe></p>
<div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://weuponithiphop.info/2021/09/28/music-video-sevyn-streeter-ft-jeremih-wet-dreamz/" data-a2a-title="Music Video: Sevyn Streeter ft. Jeremih – Wet Dreamz"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fweuponithiphop.info%2F2021%2F09%2F28%2Fmusic-video-sevyn-streeter-ft-jeremih-wet-dreamz%2F&amp;linkname=Music%20Video%3A%20Sevyn%20Streeter%20ft.%20Jeremih%20%E2%80%93%20Wet%20Dreamz" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fweuponithiphop.info%2F2021%2F09%2F28%2Fmusic-video-sevyn-streeter-ft-jeremih-wet-dreamz%2F&amp;linkname=Music%20Video%3A%20Sevyn%20Streeter%20ft.%20Jeremih%20%E2%80%93%20Wet%20Dreamz" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=https%3A%2F%2Fweuponithiphop.info%2F2021%2F09%2F28%2Fmusic-video-sevyn-streeter-ft-jeremih-wet-dreamz%2F&amp;linkname=Music%20Video%3A%20Sevyn%20Streeter%20ft.%20Jeremih%20%E2%80%93%20Wet%20Dreamz" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fweuponithiphop.info%2F2021%2F09%2F28%2Fmusic-video-sevyn-streeter-ft-jeremih-wet-dreamz%2F&amp;linkname=Music%20Video%3A%20Sevyn%20Streeter%20ft.%20Jeremih%20%E2%80%93%20Wet%20Dreamz" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_tumblr" href="https://www.addtoany.com/add_to/tumblr?linkurl=https%3A%2F%2Fweuponithiphop.info%2F2021%2F09%2F28%2Fmusic-video-sevyn-streeter-ft-jeremih-wet-dreamz%2F&amp;linkname=Music%20Video%3A%20Sevyn%20Streeter%20ft.%20Jeremih%20%E2%80%93%20Wet%20Dreamz" title="Tumblr" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_reddit" href="https://www.addtoany.com/add_to/reddit?linkurl=https%3A%2F%2Fweuponithiphop.info%2F2021%2F09%2F28%2Fmusic-video-sevyn-streeter-ft-jeremih-wet-dreamz%2F&amp;linkname=Music%20Video%3A%20Sevyn%20Streeter%20ft.%20Jeremih%20%E2%80%93%20Wet%20Dreamz" title="Reddit" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_flipboard" href="https://www.addtoany.com/add_to/flipboard?linkurl=https%3A%2F%2Fweuponithiphop.info%2F2021%2F09%2F28%2Fmusic-video-sevyn-streeter-ft-jeremih-wet-dreamz%2F&amp;linkname=Music%20Video%3A%20Sevyn%20Streeter%20ft.%20Jeremih%20%E2%80%93%20Wet%20Dreamz" title="Flipboard" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Fweuponithiphop.info%2F2021%2F09%2F28%2Fmusic-video-sevyn-streeter-ft-jeremih-wet-dreamz%2F&amp;linkname=Music%20Video%3A%20Sevyn%20Streeter%20ft.%20Jeremih%20%E2%80%93%20Wet%20Dreamz" title="Copy Link" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div>        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://weuponithiphop.info/tag/jeremih/">Jeremih</a></li><li><a href="https://weuponithiphop.info/tag/sevyn-streeter/">Sevyn Streeter</a></li></ul>            </div>

                        <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://weuponithiphop.info/2021/09/28/dreamville-festival-2022-announced/">Dreamville Festival 2022 Announced</a></div></div><div class="td-next-prev-separator"></div></div>            <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://weuponithiphop.info/author/cyclone/">cyclone</a></span></div>	        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="cyclone"></span><meta itemprop="datePublished" content="2021-09-28T04:32:03+00:00"><meta itemprop="dateModified" content="2021-09-28T04:32:03+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://weuponithiphop.info/2021/09/28/music-video-sevyn-streeter-ft-jeremih-wet-dreamz/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png"></span><meta itemprop="name" content="WeUpOnIt"></span><meta itemprop="headline " content="Music Video: Sevyn Streeter ft. Jeremih - Wet Dreamz"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://i.imgur.com/87JkA0w.jpg"><meta itemprop="width" content="800"><meta itemprop="height" content="600"></span>        </footer>

    </article> <!-- /.post -->

    <div class="td_block_wrap td_block_related_posts td_uid_15_6152d3083ce65_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_15_6152d3083ce65" ><script>var block_td_uid_15_6152d3083ce65 = new tdBlock();
block_td_uid_15_6152d3083ce65.id = "td_uid_15_6152d3083ce65";
block_td_uid_15_6152d3083ce65.atts = '{"limit":6,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_custom_related","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_15_6152d3083ce65_rand","offset":"","css":"","live_filter":"cur_post_same_tags","live_filter_cur_post_id":46605,"live_filter_cur_post_author":"1"}';
block_td_uid_15_6152d3083ce65.td_column_number = "3";
block_td_uid_15_6152d3083ce65.block_type = "td_block_related_posts";
block_td_uid_15_6152d3083ce65.post_count = "6";
block_td_uid_15_6152d3083ce65.found_posts = "46";
block_td_uid_15_6152d3083ce65.header_color = "";
block_td_uid_15_6152d3083ce65.ajax_pagination_infinite_stop = "";
block_td_uid_15_6152d3083ce65.max_num_pages = "8";
tdBlocksArray.push(block_td_uid_15_6152d3083ce65);
</script><h4 class="td-related-title"><a id="td_uid_16_6152d3083fd87" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_15_6152d3083ce65" href="#">RELATED ARTICLES</a><a id="td_uid_17_6152d3083fdd2" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_15_6152d3083ce65" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_15_6152d3083ce65 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/17/album-stream-sevyn-streeter-drunken-wordz-sober-thoughtz/" rel="bookmark" title="Album Stream: Sevyn Streeter &#8211; Drunken Wordz Sober Thoughtz"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/lWarom4.jpg" alt="" title="Album Stream: Sevyn Streeter &#8211; Drunken Wordz Sober Thoughtz"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/17/album-stream-sevyn-streeter-drunken-wordz-sober-thoughtz/" rel="bookmark" title="Album Stream: Sevyn Streeter &#8211; Drunken Wordz Sober Thoughtz">Album Stream: Sevyn Streeter &#8211; Drunken Wordz Sober Thoughtz</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/12/music-video-eric-bellinger-ft-sevyn-streeter-what-about-us/" rel="bookmark" title="Music Video: Eric Bellinger ft. Sevyn Streeter &#8211; What About Us"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/56VnhIO.jpg" alt="" title="Music Video: Eric Bellinger ft. Sevyn Streeter &#8211; What About Us"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/12/music-video-eric-bellinger-ft-sevyn-streeter-what-about-us/" rel="bookmark" title="Music Video: Eric Bellinger ft. Sevyn Streeter &#8211; What About Us">Music Video: Eric Bellinger ft. Sevyn Streeter &#8211; What About Us</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/08/27/new-music-sevyn-streeter-ft-bia-nasty-girl/" rel="bookmark" title="New Music: Sevyn Streeter ft. BIA &#8211; Nasty Girl"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/DMVhKJ9.jpg" alt="" title="New Music: Sevyn Streeter ft. BIA &#8211; Nasty Girl"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/08/27/new-music-sevyn-streeter-ft-bia-nasty-girl/" rel="bookmark" title="New Music: Sevyn Streeter ft. BIA &#8211; Nasty Girl">New Music: Sevyn Streeter ft. BIA &#8211; Nasty Girl</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid-->

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/06/17/music-video-sevyn-streeter-ft-chris-brown-aap-ferg-guilty-458484yu/" rel="bookmark" title="Music Video: Sevyn Streeter ft. Chris Brown &#038; A$AP Ferg &#8211; Guilty"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/rc3XxAx.jpg" alt="" title="Music Video: Sevyn Streeter ft. Chris Brown &#038; A$AP Ferg &#8211; Guilty"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/06/17/music-video-sevyn-streeter-ft-chris-brown-aap-ferg-guilty-458484yu/" rel="bookmark" title="Music Video: Sevyn Streeter ft. Chris Brown &#038; A$AP Ferg &#8211; Guilty">Music Video: Sevyn Streeter ft. Chris Brown &#038; A$AP Ferg &#8211; Guilty</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/05/04/music-video-dj-khaled-ft-lil-wayne-jeremih-thankful/" rel="bookmark" title="Music Video: DJ Khaled ft. Lil Wayne &#038; Jeremih &#8211; Thankful"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/afDptqV.jpg" alt="" title="Music Video: DJ Khaled ft. Lil Wayne &#038; Jeremih &#8211; Thankful"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/05/04/music-video-dj-khaled-ft-lil-wayne-jeremih-thankful/" rel="bookmark" title="Music Video: DJ Khaled ft. Lil Wayne &#038; Jeremih &#8211; Thankful">Music Video: DJ Khaled ft. Lil Wayne &#038; Jeremih &#8211; Thankful</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/12/new-music-sevyn-streeter-ft-chris-brown-aap-ferg-guilty/" rel="bookmark" title="New Music: Sevyn Streeter ft. Chris Brown &#038; A$AP Ferg &#8211; Guilty"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/d6kLFzE.png" alt="" title="New Music: Sevyn Streeter ft. Chris Brown &#038; A$AP Ferg &#8211; Guilty"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/12/new-music-sevyn-streeter-ft-chris-brown-aap-ferg-guilty/" rel="bookmark" title="New Music: Sevyn Streeter ft. Chris Brown &#038; A$AP Ferg &#8211; Guilty">New Music: Sevyn Streeter ft. Chris Brown &#038; A$AP Ferg &#8211; Guilty</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_15_6152d3083ce65" data-td_block_id="td_uid_15_6152d3083ce65"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_15_6152d3083ce65" data-td_block_id="td_uid_15_6152d3083ce65"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->

	<div class="comments" id="comments">
            </div> <!-- /.content -->
                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <aside class="widget widget_search"><form method="get" class="td-search-form-widget" action="https://weuponithiphop.info/">
    <div role="search">
        <input class="td-widget-search-input" type="text" value="" name="s" id="s" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit" value="Search" />
    </div>
</form></aside><aside class="widget widget_text">			<div class="textwidget"><h4><strong><span style="color: #8224e3;"><span style="color: #000000;">Listen to</span> <span style="color: #c60000;">WeUpOnItRadio</span> <span style="color: #000000;">Live!</span></span></strong></h4>
<p><span class="cc_streaminfo" data-type="song" data-username="cyclone777">Loading &#8230;</span><br />
<script language="javascript" type="text/javascript" src="https://control.internet-radio.com:2199/system/streaminfo.js"></script><br />
<iframe src="//player.radioforge.com/v2/shoutcast.html?radiolink=http%3A%2F%2Fus5.internet-radio.com%3A8170%2Fstream&amp;radiotype=shoutcast&amp;bcolor=000000&amp;image=https://i.imgur.com/r3e2qyB.png&amp;facebook=http://www.facebook.com/weuponitradio&amp;twitter=http://twitter.com/weuponitradio&amp;title=Power 105 WeUpOnIt Radio (WUOI)&amp;artist=" frameborder="0" marginwidth="0" marginheight="0" scrolling="no"></iframe></p>
</div>
		</aside>
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-sidebar ">
<script type="text/javascript">
var td_screen_width = document.body.clientWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 

<aside class="widget widget_text"><div class="block-title"><span>ILLPO – Off The Roof</span></div>			<div class="textwidget"><p><iframe src="https://www.youtube.com/embed/QXrFbuM4BCU" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
</div>
		</aside><aside class="widget widget_text"><div class="block-title"><span>ethemadassassin &#038; Seven Da Pantha &#8211; Greatness</span></div>			<div class="textwidget"><p><iframe src="https://www.youtube.com/embed/CR5CaRxLztY" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
</div>
		</aside><aside class="widget widget_text"><div class="block-title"><span>OC FROM NC &#038; B SQUARED &#8211; Wrong Shit</span></div>			<div class="textwidget"><p><iframe src="https://www.facebook.com/plugins/video.php?height=314&#038;href=https%3A%2F%2Fwww.facebook.com%2Focfromnc%2Fvideos%2F589477165734756%2F&#038;show_text=false&#038;width=560&#038;t=0" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowfullscreen="true" allow="autoplay; clipboard-write; encrypted-media; picture-in-picture; web-share" allowFullScreen="true"></iframe></p>
</div>
		</aside><aside class="widget widget_text"><div class="block-title"><span>Mundae Boones ft Apostle &#8211; 100K LBS</span></div>			<div class="textwidget"><p><iframe src="https://www.facebook.com/plugins/video.php?height=316&#038;href=https%3A%2F%2Fwww.facebook.com%2FILLPO%2Fvideos%2F3031482840464289%2F&#038;show_text=false&#038;width=560&#038;t=0" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowfullscreen="true" allow="autoplay; clipboard-write; encrypted-media; picture-in-picture; web-share" allowFullScreen="true"></iframe></p>
</div>
		</aside>                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->


<!-- Instagram -->



<!-- Footer -->
<div class="td-footer-wrapper td-footer-template-3">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
			    		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span4">
                <div class="td-footer-info"><div class="footer-logo-wrap"><a href="https://weuponithiphop.info/"><img class="td-retina-data" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" alt="" title=""/></a></div><div class="footer-text-wrap"></div><div class="footer-social-wrap td-social-style-2">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponit_com" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div></div><aside class="widget widget_text">			<div class="textwidget"><div aria-live="polite" id="soliloquy-container-30342" class="soliloquy-container soliloquy-transition-fade  soliloquy-theme-classic" style="max-width:960px;max-height:300px;"><ul id="soliloquy-30342" class="soliloquy-slider soliloquy-slides soliloquy-wrap soliloquy-clear"><li aria-hidden="true" class="soliloquy-item soliloquy-item-1 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109673710?productType=812&#038;appearance=1" class="soliloquy-link" title="Revolt Tee" target="_blank"><img id="soliloquy-image-30349" class="soliloquy-image soliloquy-image-1" src="https://weuponithiphop.info/wp-content/uploads/Revolt-Tee.jpg" alt="Revolt Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-2 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/youngongetthiswork?q=I12154011" class="soliloquy-link" title="You Gon Get This Work" target="_blank"><img id="soliloquy-image-30344" class="soliloquy-image soliloquy-image-2" src="https://weuponithiphop.info/wp-content/uploads/You-Gon-Get-This-Work.jpg" alt="You Gon Get This Work" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-3 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/savage+bloody?q=I1014473415" class="soliloquy-link" title="Savage Bloody" target="_blank"><img id="soliloquy-image-30343" class="soliloquy-image soliloquy-image-3" src="https://weuponithiphop.info/wp-content/uploads/Savage-Bloody.jpg" alt="Savage Bloody" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-4 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/can?q=I1011767996" class="soliloquy-link" title="spray" target="_blank"><img id="soliloquy-image-30345" class="soliloquy-image soliloquy-image-4" src="https://weuponithiphop.info/wp-content/uploads/spray.jpg" alt="spray" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-5 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814012" class="soliloquy-link" title="Good Vibes Only 1" target="_blank"><img id="soliloquy-image-30346" class="soliloquy-image soliloquy-image-5" src="https://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-1.jpg" alt="Good Vibes Only 1" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-6 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/blessed?q=I12044252" class="soliloquy-link" title="Blessed Tee" target="_blank"><img id="soliloquy-image-30347" class="soliloquy-image soliloquy-image-6" src="https://weuponithiphop.info/wp-content/uploads/Blessed-Tee.jpg" alt="Blessed Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-7 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/trap?q=I1009984243" class="soliloquy-link" title="Trap Tee" target="_blank"><img id="soliloquy-image-30348" class="soliloquy-image soliloquy-image-7" src="https://weuponithiphop.info/wp-content/uploads/Trap-Tee.jpg" alt="Trap Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-8 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/good+vibes+only+birds?q=I1014476779" class="soliloquy-link" title="Good Vibes Only 2" target="_blank"><img id="soliloquy-image-30350" class="soliloquy-image soliloquy-image-8" src="https://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-2.jpg" alt="Good Vibes Only 2" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-9 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/all+seeing+eye?q=I11739019" class="soliloquy-link" title="ILLuminati" target="_blank"><img id="soliloquy-image-30351" class="soliloquy-image soliloquy-image-9" src="https://weuponithiphop.info/wp-content/uploads/ILLuminati.jpg" alt="ILLuminati" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-10 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/diamond_skull_1?q=I12527492" class="soliloquy-link" title="Diamond Skull" target="_blank"><img id="soliloquy-image-30352" class="soliloquy-image soliloquy-image-10" src="https://weuponithiphop.info/wp-content/uploads/Diamond-Skull.jpg" alt="Diamond Skull" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-11 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/donuts+doom-A109792920" class="soliloquy-link" title="donunts" target="_blank"><img id="soliloquy-image-30353" class="soliloquy-image soliloquy-image-11" src="https://weuponithiphop.info/wp-content/uploads/donunts.jpg" alt="donunts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-12 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/crime+pays?q=I12067735" class="soliloquy-link" title="Crime Pays" target="_blank"><img id="soliloquy-image-30434" class="soliloquy-image soliloquy-image-12" src="https://weuponithiphop.info/wp-content/uploads/Crime-Pays.jpg" alt="Crime Pays" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-13 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/fuckyoupayme?q=I11550361" class="soliloquy-link" title="Fuck You Pay Me" target="_blank"><img id="soliloquy-image-30436" class="soliloquy-image soliloquy-image-13" src="https://weuponithiphop.info/wp-content/uploads/Fuck-You-Pay-Me.jpg" alt="Fuck You Pay Me" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-14 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814011" class="soliloquy-link" title="savage gold tee" target="_blank"><img id="soliloquy-image-30354" class="soliloquy-image soliloquy-image-14" src="https://weuponithiphop.info/wp-content/uploads/savage-gold-tee.jpg" alt="savage gold tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-15 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/?page=2" class="soliloquy-link" title="fresh-clean-signature-" target="_blank"><img id="soliloquy-image-30437" class="soliloquy-image soliloquy-image-15" src="https://weuponithiphop.info/wp-content/uploads/fresh-clean-signature-.jpg" alt="fresh-clean-signature-" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-16 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/%24teez?q=I1001415610" class="soliloquy-link" title="gold fronts" target="_blank"><img id="soliloquy-image-30355" class="soliloquy-image soliloquy-image-16" src="https://weuponithiphop.info/wp-content/uploads/gold-fronts.jpg" alt="gold fronts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-17 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/soldier?q=I11611241" class="soliloquy-link" title="Swag Soldier" target="_blank"><img id="soliloquy-image-30435" class="soliloquy-image soliloquy-image-17" src="https://weuponithiphop.info/wp-content/uploads/Swag-Soldier.jpg" alt="Swag Soldier" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-18 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/gamer-A7923028?productType=210&#038;appearance=22" class="soliloquy-link" title="gamer" target="_blank"><img id="soliloquy-image-30438" class="soliloquy-image soliloquy-image-18" src="https://weuponithiphop.info/wp-content/uploads/gamer.jpg" alt="gamer" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-19 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/" class="soliloquy-link" title="freshandlogo Square" target="_blank"><img id="soliloquy-image-30356" class="soliloquy-image soliloquy-image-19" src="https://weuponithiphop.info/wp-content/uploads/freshandlogo-Square.jpg" alt="freshandlogo Square" /></a></li></ul></div><noscript><style type="text/css">#soliloquy-container-30342{opacity:1}</style></noscript>
</div>
		</aside>            </div>

            <div class="td-pb-span4">
                <aside class="widget widget_calendar"><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar">
	<caption>September 2021</caption>
	<thead>
	<tr>
		<th scope="col" title="Sunday">S</th>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
	</tr>
	</thead>

	<tfoot>
	<tr>
		<td colspan="3" id="prev"><a href="https://weuponithiphop.info/2021/08/">&laquo; Aug</a></td>
		<td class="pad">&nbsp;</td>
		<td colspan="3" id="next" class="pad">&nbsp;</td>
	</tr>
	</tfoot>

	<tbody>
	<tr>
		<td colspan="3" class="pad">&nbsp;</td><td><a href="https://weuponithiphop.info/2021/09/01/" aria-label="Posts published on September 1, 2021">1</a></td><td><a href="https://weuponithiphop.info/2021/09/02/" aria-label="Posts published on September 2, 2021">2</a></td><td><a href="https://weuponithiphop.info/2021/09/03/" aria-label="Posts published on September 3, 2021">3</a></td><td><a href="https://weuponithiphop.info/2021/09/04/" aria-label="Posts published on September 4, 2021">4</a></td>
	</tr>
	<tr>
		<td><a href="https://weuponithiphop.info/2021/09/05/" aria-label="Posts published on September 5, 2021">5</a></td><td><a href="https://weuponithiphop.info/2021/09/06/" aria-label="Posts published on September 6, 2021">6</a></td><td><a href="https://weuponithiphop.info/2021/09/07/" aria-label="Posts published on September 7, 2021">7</a></td><td><a href="https://weuponithiphop.info/2021/09/08/" aria-label="Posts published on September 8, 2021">8</a></td><td><a href="https://weuponithiphop.info/2021/09/09/" aria-label="Posts published on September 9, 2021">9</a></td><td><a href="https://weuponithiphop.info/2021/09/10/" aria-label="Posts published on September 10, 2021">10</a></td><td><a href="https://weuponithiphop.info/2021/09/11/" aria-label="Posts published on September 11, 2021">11</a></td>
	</tr>
	<tr>
		<td><a href="https://weuponithiphop.info/2021/09/12/" aria-label="Posts published on September 12, 2021">12</a></td><td><a href="https://weuponithiphop.info/2021/09/13/" aria-label="Posts published on September 13, 2021">13</a></td><td><a href="https://weuponithiphop.info/2021/09/14/" aria-label="Posts published on September 14, 2021">14</a></td><td><a href="https://weuponithiphop.info/2021/09/15/" aria-label="Posts published on September 15, 2021">15</a></td><td><a href="https://weuponithiphop.info/2021/09/16/" aria-label="Posts published on September 16, 2021">16</a></td><td><a href="https://weuponithiphop.info/2021/09/17/" aria-label="Posts published on September 17, 2021">17</a></td><td><a href="https://weuponithiphop.info/2021/09/18/" aria-label="Posts published on September 18, 2021">18</a></td>
	</tr>
	<tr>
		<td><a href="https://weuponithiphop.info/2021/09/19/" aria-label="Posts published on September 19, 2021">19</a></td><td><a href="https://weuponithiphop.info/2021/09/20/" aria-label="Posts published on September 20, 2021">20</a></td><td><a href="https://weuponithiphop.info/2021/09/21/" aria-label="Posts published on September 21, 2021">21</a></td><td><a href="https://weuponithiphop.info/2021/09/22/" aria-label="Posts published on September 22, 2021">22</a></td><td><a href="https://weuponithiphop.info/2021/09/23/" aria-label="Posts published on September 23, 2021">23</a></td><td><a href="https://weuponithiphop.info/2021/09/24/" aria-label="Posts published on September 24, 2021">24</a></td><td><a href="https://weuponithiphop.info/2021/09/25/" aria-label="Posts published on September 25, 2021">25</a></td>
	</tr>
	<tr>
		<td><a href="https://weuponithiphop.info/2021/09/26/" aria-label="Posts published on September 26, 2021">26</a></td><td><a href="https://weuponithiphop.info/2021/09/27/" aria-label="Posts published on September 27, 2021">27</a></td><td id="today"><a href="https://weuponithiphop.info/2021/09/28/" aria-label="Posts published on September 28, 2021">28</a></td><td>29</td><td>30</td>
		<td class="pad" colspan="2">&nbsp;</td>
	</tr>
	</tbody>
	</table></div></aside>            </div>

            <div class="td-pb-span4">
                <aside class="widget widget_text">			<div class="textwidget"><div aria-live="polite" id="soliloquy-container-30342" class="soliloquy-container soliloquy-transition-fade  soliloquy-theme-classic" style="max-width:960px;max-height:300px;"><ul id="soliloquy-30342" class="soliloquy-slider soliloquy-slides soliloquy-wrap soliloquy-clear"><li aria-hidden="true" class="soliloquy-item soliloquy-item-1 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109673710?productType=812&#038;appearance=1" class="soliloquy-link" title="Revolt Tee" target="_blank"><img id="soliloquy-image-30349" class="soliloquy-image soliloquy-image-1" src="https://weuponithiphop.info/wp-content/uploads/Revolt-Tee.jpg" alt="Revolt Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-2 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/youngongetthiswork?q=I12154011" class="soliloquy-link" title="You Gon Get This Work" target="_blank"><img id="soliloquy-image-30344" class="soliloquy-image soliloquy-image-2" src="https://weuponithiphop.info/wp-content/uploads/You-Gon-Get-This-Work.jpg" alt="You Gon Get This Work" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-3 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/savage+bloody?q=I1014473415" class="soliloquy-link" title="Savage Bloody" target="_blank"><img id="soliloquy-image-30343" class="soliloquy-image soliloquy-image-3" src="https://weuponithiphop.info/wp-content/uploads/Savage-Bloody.jpg" alt="Savage Bloody" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-4 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/can?q=I1011767996" class="soliloquy-link" title="spray" target="_blank"><img id="soliloquy-image-30345" class="soliloquy-image soliloquy-image-4" src="https://weuponithiphop.info/wp-content/uploads/spray.jpg" alt="spray" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-5 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814012" class="soliloquy-link" title="Good Vibes Only 1" target="_blank"><img id="soliloquy-image-30346" class="soliloquy-image soliloquy-image-5" src="https://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-1.jpg" alt="Good Vibes Only 1" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-6 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/blessed?q=I12044252" class="soliloquy-link" title="Blessed Tee" target="_blank"><img id="soliloquy-image-30347" class="soliloquy-image soliloquy-image-6" src="https://weuponithiphop.info/wp-content/uploads/Blessed-Tee.jpg" alt="Blessed Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-7 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/trap?q=I1009984243" class="soliloquy-link" title="Trap Tee" target="_blank"><img id="soliloquy-image-30348" class="soliloquy-image soliloquy-image-7" src="https://weuponithiphop.info/wp-content/uploads/Trap-Tee.jpg" alt="Trap Tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-8 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/good+vibes+only+birds?q=I1014476779" class="soliloquy-link" title="Good Vibes Only 2" target="_blank"><img id="soliloquy-image-30350" class="soliloquy-image soliloquy-image-8" src="https://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-2.jpg" alt="Good Vibes Only 2" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-9 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/all+seeing+eye?q=I11739019" class="soliloquy-link" title="ILLuminati" target="_blank"><img id="soliloquy-image-30351" class="soliloquy-image soliloquy-image-9" src="https://weuponithiphop.info/wp-content/uploads/ILLuminati.jpg" alt="ILLuminati" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-10 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/diamond_skull_1?q=I12527492" class="soliloquy-link" title="Diamond Skull" target="_blank"><img id="soliloquy-image-30352" class="soliloquy-image soliloquy-image-10" src="https://weuponithiphop.info/wp-content/uploads/Diamond-Skull.jpg" alt="Diamond Skull" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-11 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/donuts+doom-A109792920" class="soliloquy-link" title="donunts" target="_blank"><img id="soliloquy-image-30353" class="soliloquy-image soliloquy-image-11" src="https://weuponithiphop.info/wp-content/uploads/donunts.jpg" alt="donunts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-12 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/crime+pays?q=I12067735" class="soliloquy-link" title="Crime Pays" target="_blank"><img id="soliloquy-image-30434" class="soliloquy-image soliloquy-image-12" src="https://weuponithiphop.info/wp-content/uploads/Crime-Pays.jpg" alt="Crime Pays" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-13 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/fuckyoupayme?q=I11550361" class="soliloquy-link" title="Fuck You Pay Me" target="_blank"><img id="soliloquy-image-30436" class="soliloquy-image soliloquy-image-13" src="https://weuponithiphop.info/wp-content/uploads/Fuck-You-Pay-Me.jpg" alt="Fuck You Pay Me" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-14 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814011" class="soliloquy-link" title="savage gold tee" target="_blank"><img id="soliloquy-image-30354" class="soliloquy-image soliloquy-image-14" src="https://weuponithiphop.info/wp-content/uploads/savage-gold-tee.jpg" alt="savage gold tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-15 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/?page=2" class="soliloquy-link" title="fresh-clean-signature-" target="_blank"><img id="soliloquy-image-30437" class="soliloquy-image soliloquy-image-15" src="https://weuponithiphop.info/wp-content/uploads/fresh-clean-signature-.jpg" alt="fresh-clean-signature-" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-16 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/%24teez?q=I1001415610" class="soliloquy-link" title="gold fronts" target="_blank"><img id="soliloquy-image-30355" class="soliloquy-image soliloquy-image-16" src="https://weuponithiphop.info/wp-content/uploads/gold-fronts.jpg" alt="gold fronts" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-17 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/soldier?q=I11611241" class="soliloquy-link" title="Swag Soldier" target="_blank"><img id="soliloquy-image-30435" class="soliloquy-image soliloquy-image-17" src="https://weuponithiphop.info/wp-content/uploads/Swag-Soldier.jpg" alt="Swag Soldier" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-18 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/gamer-A7923028?productType=210&#038;appearance=22" class="soliloquy-link" title="gamer" target="_blank"><img id="soliloquy-image-30438" class="soliloquy-image soliloquy-image-18" src="https://weuponithiphop.info/wp-content/uploads/gamer.jpg" alt="gamer" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-19 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/" class="soliloquy-link" title="freshandlogo Square" target="_blank"><img id="soliloquy-image-30356" class="soliloquy-image soliloquy-image-19" src="https://weuponithiphop.info/wp-content/uploads/freshandlogo-Square.jpg" alt="freshandlogo Square" /></a></li></ul></div><noscript><style type="text/css">#soliloquy-container-30342{opacity:1}</style></noscript>
</div>
		</aside>            </div>
        </div>
    </div>
</div>

<!-- Sub Footer -->
    <div class="td-sub-footer-container">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span7 td-sub-footer-menu">
                        <div class="menu-top-menu-container"><ul id="menu-top-menu-2" class="td-subfooter-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-mega-menu menu-item-317"><a href="https://weuponithiphop.info/category/new-music/">New Music</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_20_6152d30855776_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_20_6152d30855776" ><script>var block_td_uid_20_6152d30855776 = new tdBlock();
block_td_uid_20_6152d30855776.id = "td_uid_20_6152d30855776";
block_td_uid_20_6152d30855776.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"43","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_20_6152d30855776_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_20_6152d30855776.td_column_number = "3";
block_td_uid_20_6152d30855776.block_type = "td_block_mega_menu";
block_td_uid_20_6152d30855776.post_count = "5";
block_td_uid_20_6152d30855776.found_posts = "4064";
block_td_uid_20_6152d30855776.header_color = "";
block_td_uid_20_6152d30855776.ajax_pagination_infinite_stop = "";
block_td_uid_20_6152d30855776.max_num_pages = "813";
tdBlocksArray.push(block_td_uid_20_6152d30855776);
</script><div id=td_uid_20_6152d30855776 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/27/new-music-amber-mark-what-it-is/" rel="bookmark" title="New Music: Amber Mark &#8211; What It Is"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/QsDgtF2.jpg" alt="" title="New Music: Amber Mark &#8211; What It Is"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/27/new-music-amber-mark-what-it-is/" rel="bookmark" title="New Music: Amber Mark &#8211; What It Is">New Music: Amber Mark &#8211; What It Is</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/27/new-music-russ-ft-capella-grey-seduce/" rel="bookmark" title="New Music: Russ ft. Capella Grey &#8211; Seduce"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/HSNyNjK.png" alt="" title="New Music: Russ ft. Capella Grey &#8211; Seduce"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/27/new-music-russ-ft-capella-grey-seduce/" rel="bookmark" title="New Music: Russ ft. Capella Grey &#8211; Seduce">New Music: Russ ft. Capella Grey &#8211; Seduce</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/27/new-music-gunna-ft-future-too-easy/" rel="bookmark" title="New Music: Gunna Ft. Future &#8211; Too Easy"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/VKqVrRU.jpg" alt="" title="New Music: Gunna Ft. Future &#8211; Too Easy"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/27/new-music-gunna-ft-future-too-easy/" rel="bookmark" title="New Music: Gunna Ft. Future &#8211; Too Easy">New Music: Gunna Ft. Future &#8211; Too Easy</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/25/new-music-logic-ft-aap-ferg-lil-wayne-perfect-remix/" rel="bookmark" title="New Music: Logic ft. A$AP Ferg &#038; Lil Wayne &#8211; Perfect (Remix)"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/S9OmjzF.jpg" alt="" title="New Music: Logic ft. A$AP Ferg &#038; Lil Wayne &#8211; Perfect (Remix)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/25/new-music-logic-ft-aap-ferg-lil-wayne-perfect-remix/" rel="bookmark" title="New Music: Logic ft. A$AP Ferg &#038; Lil Wayne &#8211; Perfect (Remix)">New Music: Logic ft. A$AP Ferg &#038; Lil Wayne &#8211; Perfect&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/25/new-music-50-cent-ft-snoop-dogg-moneybagg-yo-charlie-wilson-wish-me-luck/" rel="bookmark" title="New Music: 50 Cent ft. Snoop Dogg, Moneybagg Yo &#038; Charlie Wilson &#8211; Wish Me Luck"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/ZQBRu4t.jpg" alt="" title="New Music: 50 Cent ft. Snoop Dogg, Moneybagg Yo &#038; Charlie Wilson &#8211; Wish Me Luck"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/25/new-music-50-cent-ft-snoop-dogg-moneybagg-yo-charlie-wilson-wish-me-luck/" rel="bookmark" title="New Music: 50 Cent ft. Snoop Dogg, Moneybagg Yo &#038; Charlie Wilson &#8211; Wish Me Luck">New Music: 50 Cent ft. Snoop Dogg, Moneybagg Yo &#038; Charlie&#8230;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_20_6152d30855776" data-td_block_id="td_uid_20_6152d30855776"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_20_6152d30855776" data-td_block_id="td_uid_20_6152d30855776"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-706"><a href="https://weuponithiphop.info/category/album-stream-mixtapes/">Album Stream</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_21_6152d3085b225_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_21_6152d3085b225" ><script>var block_td_uid_21_6152d3085b225 = new tdBlock();
block_td_uid_21_6152d3085b225.id = "td_uid_21_6152d3085b225";
block_td_uid_21_6152d3085b225.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"97","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_21_6152d3085b225_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_21_6152d3085b225.td_column_number = "3";
block_td_uid_21_6152d3085b225.block_type = "td_block_mega_menu";
block_td_uid_21_6152d3085b225.post_count = "5";
block_td_uid_21_6152d3085b225.found_posts = "1496";
block_td_uid_21_6152d3085b225.header_color = "";
block_td_uid_21_6152d3085b225.ajax_pagination_infinite_stop = "";
block_td_uid_21_6152d3085b225.max_num_pages = "300";
tdBlocksArray.push(block_td_uid_21_6152d3085b225);
</script><div id=td_uid_21_6152d3085b225 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/24/album-stream-d-smoke-war-wonders/" rel="bookmark" title="Album Stream: D Smoke &#8211; War &#038; Wonders"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/ZUnu7Tx.jpg" alt="" title="Album Stream: D Smoke &#8211; War &#038; Wonders"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/24/album-stream-d-smoke-war-wonders/" rel="bookmark" title="Album Stream: D Smoke &#8211; War &#038; Wonders">Album Stream: D Smoke &#8211; War &#038; Wonders</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/24/album-stream-run-the-jewels-rtj4-deluxe/" rel="bookmark" title="Album Stream: Run the Jewels &#8211; RTJ4 (Deluxe)"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/ZJIIElu.jpg" alt="" title="Album Stream: Run the Jewels &#8211; RTJ4 (Deluxe)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/24/album-stream-run-the-jewels-rtj4-deluxe/" rel="bookmark" title="Album Stream: Run the Jewels &#8211; RTJ4 (Deluxe)">Album Stream: Run the Jewels &#8211; RTJ4 (Deluxe)</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/24/album-stream-westside-gunn-hitler-wears-hermes-8-side-b/" rel="bookmark" title="Album Stream: Westside Gunn &#8211; Hitler Wears Hermes 8 (Side B)"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/gFFubvq.jpg" alt="" title="Album Stream: Westside Gunn &#8211; Hitler Wears Hermes 8 (Side B)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/24/album-stream-westside-gunn-hitler-wears-hermes-8-side-b/" rel="bookmark" title="Album Stream: Westside Gunn &#8211; Hitler Wears Hermes 8 (Side B)">Album Stream: Westside Gunn &#8211; Hitler Wears Hermes 8 (Side B)</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/20/album-stream-vanjess-homegrown-deluxe/" rel="bookmark" title="Album Stream: VanJess &#8211; Homegrown (Deluxe)"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/mlqgxRh.jpg" alt="" title="Album Stream: VanJess &#8211; Homegrown (Deluxe)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/20/album-stream-vanjess-homegrown-deluxe/" rel="bookmark" title="Album Stream: VanJess &#8211; Homegrown (Deluxe)">Album Stream: VanJess &#8211; Homegrown (Deluxe)</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/20/album-stream-mozzy-untreated-trauma/" rel="bookmark" title="Album Stream: Mozzy &#8211; Untreated Trauma"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/2qErfXE.jpg" alt="" title="Album Stream: Mozzy &#8211; Untreated Trauma"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/20/album-stream-mozzy-untreated-trauma/" rel="bookmark" title="Album Stream: Mozzy &#8211; Untreated Trauma">Album Stream: Mozzy &#8211; Untreated Trauma</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_21_6152d3085b225" data-td_block_id="td_uid_21_6152d3085b225"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_21_6152d3085b225" data-td_block_id="td_uid_21_6152d3085b225"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-314"><a href="https://weuponithiphop.info/category/music-video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_22_6152d30862eda_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_22_6152d30862eda" ><script>var block_td_uid_22_6152d30862eda = new tdBlock();
block_td_uid_22_6152d30862eda.id = "td_uid_22_6152d30862eda";
block_td_uid_22_6152d30862eda.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_22_6152d30862eda_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_22_6152d30862eda.td_column_number = "3";
block_td_uid_22_6152d30862eda.block_type = "td_block_mega_menu";
block_td_uid_22_6152d30862eda.post_count = "5";
block_td_uid_22_6152d30862eda.found_posts = "4823";
block_td_uid_22_6152d30862eda.header_color = "";
block_td_uid_22_6152d30862eda.ajax_pagination_infinite_stop = "";
block_td_uid_22_6152d30862eda.max_num_pages = "965";
tdBlocksArray.push(block_td_uid_22_6152d30862eda);
</script><div id=td_uid_22_6152d30862eda class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/28/music-video-sevyn-streeter-ft-jeremih-wet-dreamz/" rel="bookmark" title="Music Video: Sevyn Streeter ft. Jeremih &#8211; Wet Dreamz"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/87JkA0w.jpg" alt="" title="Music Video: Sevyn Streeter ft. Jeremih &#8211; Wet Dreamz"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/28/music-video-sevyn-streeter-ft-jeremih-wet-dreamz/" rel="bookmark" title="Music Video: Sevyn Streeter ft. Jeremih &#8211; Wet Dreamz">Music Video: Sevyn Streeter ft. Jeremih &#8211; Wet Dreamz</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/27/music-video-lakeyah-reason/" rel="bookmark" title="Music Video: Lakeyah &#8211; Reason"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/kCM8unr.jpg" alt="" title="Music Video: Lakeyah &#8211; Reason"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/27/music-video-lakeyah-reason/" rel="bookmark" title="Music Video: Lakeyah &#8211; Reason">Music Video: Lakeyah &#8211; Reason</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/26/music-video-larry-june-cardo-dont-try-it/" rel="bookmark" title="Music Video: Larry June &#038; Cardo &#8211; Don’t Try It"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/sDQLPcS.jpg" alt="" title="Music Video: Larry June &#038; Cardo &#8211; Don’t Try It"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/26/music-video-larry-june-cardo-dont-try-it/" rel="bookmark" title="Music Video: Larry June &#038; Cardo &#8211; Don’t Try It">Music Video: Larry June &#038; Cardo &#8211; Don’t Try It</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/26/music-video-morray-bad-situations/" rel="bookmark" title="Music Video: Morray &#8211; Bad Situations"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/2QMYzsl.jpg" alt="" title="Music Video: Morray &#8211; Bad Situations"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/26/music-video-morray-bad-situations/" rel="bookmark" title="Music Video: Morray &#8211; Bad Situations">Music Video: Morray &#8211; Bad Situations</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/26/music-video-latto-big-energy/" rel="bookmark" title="Music Video: Latto &#8211; Big Energy"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/QCMq9eF.jpg" alt="" title="Music Video: Latto &#8211; Big Energy"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/26/music-video-latto-big-energy/" rel="bookmark" title="Music Video: Latto &#8211; Big Energy">Music Video: Latto &#8211; Big Energy</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_22_6152d30862eda" data-td_block_id="td_uid_22_6152d30862eda"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_22_6152d30862eda" data-td_block_id="td_uid_22_6152d30862eda"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-316"><a href="https://weuponithiphop.info/category/latest-news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_23_6152d3086720b_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_23_6152d3086720b" ><script>var block_td_uid_23_6152d3086720b = new tdBlock();
block_td_uid_23_6152d3086720b.id = "td_uid_23_6152d3086720b";
block_td_uid_23_6152d3086720b.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"29","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_23_6152d3086720b_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_23_6152d3086720b.td_column_number = "3";
block_td_uid_23_6152d3086720b.block_type = "td_block_mega_menu";
block_td_uid_23_6152d3086720b.post_count = "4";
block_td_uid_23_6152d3086720b.found_posts = "1121";
block_td_uid_23_6152d3086720b.header_color = "";
block_td_uid_23_6152d3086720b.ajax_pagination_infinite_stop = "";
block_td_uid_23_6152d3086720b.max_num_pages = "281";
tdBlocksArray.push(block_td_uid_23_6152d3086720b);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_23_6152d3086720b" id="td_uid_24_6152d30867d48" data-td_block_id="td_uid_23_6152d3086720b" data-td_filter_value="" href="https://weuponithiphop.info/category/latest-news/">All</a><a class="mega-menu-sub-cat-td_uid_23_6152d3086720b"  id="td_uid_25_6152d30867e40" data-td_block_id="td_uid_23_6152d3086720b" data-td_filter_value="69" href="https://weuponithiphop.info/category/latest-news/album-news/">Album News</a><a class="mega-menu-sub-cat-td_uid_23_6152d3086720b"  id="td_uid_26_6152d30867f4b" data-td_block_id="td_uid_23_6152d3086720b" data-td_filter_value="80" href="https://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a><a class="mega-menu-sub-cat-td_uid_23_6152d3086720b"  id="td_uid_27_6152d30868066" data-td_block_id="td_uid_23_6152d3086720b" data-td_filter_value="2189" href="https://weuponithiphop.info/category/latest-news/flashback/">Flashback</a><a class="mega-menu-sub-cat-td_uid_23_6152d3086720b"  id="td_uid_28_6152d30868185" data-td_block_id="td_uid_23_6152d3086720b" data-td_filter_value="10" href="https://weuponithiphop.info/category/latest-news/interviews/">Interviews</a><a class="mega-menu-sub-cat-td_uid_23_6152d3086720b"  id="td_uid_29_6152d3086829f" data-td_block_id="td_uid_23_6152d3086720b" data-td_filter_value="130" href="https://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></div></div><div id=td_uid_23_6152d3086720b class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_module_no_thumb td_mod_mega_menu">
            <div class="td-module-image">
                                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/28/dreamville-festival-2022-announced/" rel="bookmark" title="Dreamville Festival 2022 Announced">Dreamville Festival 2022 Announced</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/27/video-kanye-wests-netflix-documentary-jeen-yuhs/" rel="bookmark" title="Video: Kanye West’s Netflix Documentary, ‘JEEN-YUHS&#8217;"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/RTVeKuE.jpg" alt="" title="Video: Kanye West’s Netflix Documentary, ‘JEEN-YUHS&#8217;"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/27/video-kanye-wests-netflix-documentary-jeen-yuhs/" rel="bookmark" title="Video: Kanye West’s Netflix Documentary, ‘JEEN-YUHS&#8217;">Video: Kanye West’s Netflix Documentary, ‘JEEN-YUHS&#8217;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/23/video-megan-thee-stallion-new-hotties-nike-commercial/" rel="bookmark" title="Video: Megan Thee Stallion “New Hotties” Nike Commercial"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/1Mz8ewG.jpg" alt="" title="Video: Megan Thee Stallion “New Hotties” Nike Commercial"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/23/video-megan-thee-stallion-new-hotties-nike-commercial/" rel="bookmark" title="Video: Megan Thee Stallion “New Hotties” Nike Commercial">Video: Megan Thee Stallion “New Hotties” Nike Commercial</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/09/21/video-janet-jackson-janet-documentary-trailer/" rel="bookmark" title="Video: Janet Jackson &#8211; JANET (Documentary Trailer)"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/ykpIX0Y.jpg" alt="" title="Video: Janet Jackson &#8211; JANET (Documentary Trailer)"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/09/21/video-janet-jackson-janet-documentary-trailer/" rel="bookmark" title="Video: Janet Jackson &#8211; JANET (Documentary Trailer)">Video: Janet Jackson &#8211; JANET (Documentary Trailer)</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_23_6152d3086720b" data-td_block_id="td_uid_23_6152d3086720b"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_23_6152d3086720b" data-td_block_id="td_uid_23_6152d3086720b"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-705"><a href="https://weuponithiphop.info/category/fashion/">Fashion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_30_6152d30880025_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_30_6152d30880025" ><script>var block_td_uid_30_6152d30880025 = new tdBlock();
block_td_uid_30_6152d30880025.id = "td_uid_30_6152d30880025";
block_td_uid_30_6152d30880025.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"77","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_30_6152d30880025_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_30_6152d30880025.td_column_number = "3";
block_td_uid_30_6152d30880025.block_type = "td_block_mega_menu";
block_td_uid_30_6152d30880025.post_count = "4";
block_td_uid_30_6152d30880025.found_posts = "158";
block_td_uid_30_6152d30880025.header_color = "";
block_td_uid_30_6152d30880025.ajax_pagination_infinite_stop = "";
block_td_uid_30_6152d30880025.max_num_pages = "40";
tdBlocksArray.push(block_td_uid_30_6152d30880025);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_30_6152d30880025" id="td_uid_31_6152d30880c03" data-td_block_id="td_uid_30_6152d30880025" data-td_filter_value="" href="https://weuponithiphop.info/category/fashion/">All</a><a class="mega-menu-sub-cat-td_uid_30_6152d30880025"  id="td_uid_32_6152d30880d2b" data-td_block_id="td_uid_30_6152d30880025" data-td_filter_value="76" href="https://weuponithiphop.info/category/fashion/kicks/">Kicks</a></div></div><div id=td_uid_30_6152d30880025 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/LVT4Mid8WL4wHUdO9X2OZmZxxgbREs2lVtszOdEBaO6hJB0JS3yQOAyhNSdCyPmv0amBDTgNGpOlRPXPjKCl6yIlo2joyH3rQRI7CUdX09BJtQI1r5jy1_7BQtDhw4AxUhpUwIh35rNS3lTy7uq-FdPff10JN6srr9mwZ7zr04GQFxBVEXwCfC5rNVehXhY_wGCRVsmevYmdkBWEmB8dvOzBHY78NBBjcHNArS_S-2M0FJgDh8v9m9vEh78k_XmZg-AERctsf0bkODuPi1EcNJq_RnJIV6b0GG-VtKjo-OVPmYghWJYf1HiP9c58cQ98oABU8BDFdLqsBtNt4K0NmyHYQlX39W9k_d83wEHZ1-EacQa2o01VrYSn12HnZ1l88fMzu9PKv6EGmcRZNwpepycW7_9EQnhxIPDdVCmRLXUasUED9OXr-zJmnBcnSnLCa06k1ZymQym1LiSFEv1c3aPHnmnD3GY8nL7q5jPJr4HsABR0WCqMebcF3HF_0deNd0zgRBCGMxW-VzlIIHZiHuBeSPEPvUL149GJ5swSSvKm1uGEi1HlLBj9omJSU7mDWzO0p_7l-l7-4_ureEsGsgB8cX1t8t2TQcFeRgqqF1CXlZFYYC2K0iMb4jPsijsw_rtO7pmKvbngqHfgYpGeh_qLmDWeicR7=w1195-h796-no" alt="" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch">Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/fHEwwMf8DoiXlqkfibQS1Z1XXbviORbV9raaI44tOTXrWo7GgqM3gA-vswE10gFtTQUGGwNG7nWAACwHjxPuiubliYBN_dqtBZh2WIpxvumiJ-hSLK0TNWB2cB8Iw2STT5gcp_KqlDh_e4xng1vidI8EXdp_ooh5uDI-JV1HQ9dGnM5nxl_b-v8znqj-Rl_mGB7y4Lu9zsFNWHU7SriqQQJaKrKEEnb9T8zxmGLaL0zq7ilYpnUEhWulDDr9xc82wdr__WzRBm5YEskVpDAnGM2NDZwTZpjbe4QDdxeixWnSXNK_oDzaL7WTbCpkD33OK88BlI5JmFRQ5VmD11UQ2htB7-9WoahHvb4XmBsbLXpEMl1JmEP4sPx06VduzFnBNo-J90WI0n1AEIIcEYVbRywrkGJXbzmH__In9ZIg0EV24OcGGbeKl12HxTdZwucqsNnuZeNjiMHISQ7i8cfzm3N7X7Zenl74zsKIKeKWoIGxh6MTlVADvgHcrHebnjcSgil2vBeFyz_AP45aOv9SOwbzfVLGS0CNfe1s9b2J7qZgjcBk9QPEXCl2kygvzmGXFvU_3xBuW6S0i3Vkh3Ha_3hPBtvIAy3WoTK2yiqS41HzSK7yk3FRAlBtpIEib338fdkTiosBxtdu36SdNUVM75zl6CVIFhTu=w681-h470-no" alt="" title="Air Jordan 14 Rip Hamilton"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton">Air Jordan 14 Rip Hamilton</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/kUjaOYxjEkAh34S-Ub2QSZwdOwHyFnGFLBZULta3_bn1_myPMAwJXiEEsAAtc1ktCQwHCuKhSqSYsWXFBEIZxdfKuykoDEZWwO-dDI3_JeAshbYvyILEHUu0XaUpRn0mj7gOx10V52t8gRGYPCW7QXGImkPGGhvBPzBDVVqh9lKGtkuPeePmTnpRSmwp0LG1WHcIzUWnMqPBWQeHAat6Q-Tq7niXNb96ddEZsMEdHK1nmHVlNaeqFBNtTxk6yYRkFNCvtfBayqy-Rqt4CPU5tThxbTI4AIUCI6JLxJd_VJizrVNDEe2xZ_tiQdkC5ASIoHpX8sfvAB8zRUsMVJ6oMUt5FH_4GBNXDCtFRmr65Qt0JV1h4bBJffu2L272Q_vpD76wn-YNGW8VCtZcheHu_X-A4gdYQEC0HN0BenY-MOuUBqKEjXAc0SxWeP7W9RN55jlqUFK0nzEYydVjec2stdQIngVfg_FvKxvHXfM4XdtMpqeJnp3Pzyk8xjz30sAZd0f2HQ6zfdPjk-OkV2-WrC0_qW0L8Rq3zrUbq52n3BN7gm7sctU_CUlBmoQIgJDQBYk1Siv4tfSq9pL1R4GdaOlWQdxEuhZi8bTYC8GGAgNGl3SMAZGvk7nu6QnnwEZjZ7mZwbcqgyRKa89cOREMUvIkVJ8Q8lZu=w926-h672-no" alt="" title="Jordan Proto React Triple White"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White">Jordan Proto React Triple White</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4cDUjSODZSaXWfHyZKb9q3Fn7FHA4uB0KSBs0MtFHC0dc6AJb1zeAl_X2LOKalK9C7VBFhTqRQ9fw1ESgUr9ZUKFbOzD94i_s96nvkICOqrsYnzrE2nEAQHoEaGOF4O8GAI6T4CGFbgcQhNzjpRlSY60NyPu5Cmq81FRpEOFRzTOtSa_NnWzMmfwO0yxtPbcg5U6YBUsus8shv3SA7CjULLfaP38nZAuWVgq8PMaaeCQ_eSrK8NJSEVQjyyxmqb-1I7zO8Kvvzvwi--ibMr52CF8h-GusBzSq5ZuzvZRCGu_u8CyfoXw7pwWbOmHnLOdcQ9d2PCSW_IxEMGfmEuU7NxMSsW3Ga4r35_wLB7cjvlPC9OjCV50tfekXjZBS_476mzlf4G9jR7Ju1GqgjXah9Uqc_0Y8N-Br8_JCtIlRSuLxAiebwd7AvFVlgWId9MYxBWnRT3cTyD8SH7q5WwO-CIbKAOSKsNcrrTgFxQvqn9yklBU1u5X5fdTlTBk4WSYorsWZAug0z9BOymRLnrhTbnA0vpBPFROWD-aL1glg-eUpFSfgD4xhWsOqJNY9krQ2UbLSGXQ5gYWj0ovLS7Yz3UKFY2qrVWpqkpbfyN98es9NJ-7LTUs2MLq1rX_2FaQmyq5mVndd7VGzQOHy9hDULG-5H-0LvGd=w900-h566-no" alt="" title="adidas Yeezy Boost 350 V2 Hyperspace"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace">adidas Yeezy Boost 350 V2 Hyperspace</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_30_6152d30880025" data-td_block_id="td_uid_30_6152d30880025"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_30_6152d30880025" data-td_block_id="td_uid_30_6152d30880025"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18581"><a href="https://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div>                </div>

                <div class="td-pb-span5 td-sub-footer-copy">
                    &copy; 2018 The Hip Hop Chronicles Media Group                </div>
            </div>
        </div>
    </div>
</div><!--close td-outer-wrap-->



    <!--

        Theme: Newspaper by tagDiv 2016
        Version: 7.2 (rara)
        Deploy mode: deploy
        
        uid: 6152d3088dc2c
    -->

    <link rel='stylesheet' id='soliloquy-lite-style-css'  href='https://weuponithiphop.info/wp-content/plugins/soliloquy-lite/assets/css/soliloquy.css?ver=2.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='soliloquy-liteclassic-theme-css'  href='https://weuponithiphop.info/wp-content/plugins/soliloquy-lite/themes/classic/style.css?ver=2.6.1' type='text/css' media='all' />
<script type='text/javascript' src='https://weuponithiphop.info/wp-content/themes/Newspaper/js/tagdiv_theme.js?ver=7.2'></script>
<script type='text/javascript' src='https://weuponithiphop.info/wp-includes/js/comment-reply.min.js?ver=4.9.18'></script>
<script type='text/javascript' src='https://weuponithiphop.info/wp-includes/js/wp-embed.min.js?ver=4.9.18'></script>
<script type='text/javascript' src='https://weuponithiphop.info/wp-content/plugins/soliloquy-lite/assets/js/min/soliloquy-min.js?ver=2.6.1'></script>

<!-- JS generated by theme -->

<script>
    


            

	            // if the theme has tdBackstr support, it means this already uses it
                if ( 'undefined' !== typeof window.tdBackstr ) {

                    (function(){
                        // the site background td-backstretch jquery object is dynamically added in DOM, and after any translation effects are applied over td-backstretch
                        var wrapper_image_jquery_obj = jQuery( '<div class=\'backstretch\'></div>' );
                        var image_jquery_obj = jQuery( '<img class=\'td-backstretch not-parallax\' src=\'http://weuponithiphop.info/wp-content/uploads/20-black-paper-different-texture-types-a4-sandgrain-.jpg\'>' );

                        wrapper_image_jquery_obj.append( image_jquery_obj );

                        jQuery( 'body' ).prepend( wrapper_image_jquery_obj );

                        var td_backstr_item = new tdBackstr.item();

                        td_backstr_item.wrapper_image_jquery_obj = wrapper_image_jquery_obj;
                        td_backstr_item.image_jquery_obj = image_jquery_obj;

	                    tdBackstr.add_item( td_backstr_item );

                    })();
                }

            
            

                jQuery().ready(function jQuery_ready() {
                    tdAjaxCount.tdGetViewsCountsAjax("post","[46605]");
                });
            

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://weuponithiphop.info/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://weuponithiphop.info/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>

			<script type="text/javascript">
			if ( typeof soliloquy_slider === 'undefined' || false === soliloquy_slider ) {soliloquy_slider = {};}jQuery('#soliloquy-container-30342').css('height', Math.round(jQuery('#soliloquy-container-30342').width()/(960/300)));jQuery(window).load(function(){var $ = jQuery;var soliloquy_container_30342 = $('#soliloquy-container-30342'),soliloquy_30342 = $('#soliloquy-30342');soliloquy_slider['30342'] = soliloquy_30342.soliloquy({slideSelector: '.soliloquy-item',speed: 0,pause: 2000,auto: 1,useCSS: 0,keyboard: true,adaptiveHeight: 1,adaptiveHeightSpeed: 400,infiniteLoop: 1,mode: 'fade',pager: 1,controls: 1,nextText: '',prevText: '',startText: '',stopText: '',onSliderLoad: function(currentIndex){soliloquy_container_30342.find('.soliloquy-active-slide').removeClass('soliloquy-active-slide').attr('aria-hidden','true');soliloquy_container_30342.css({'height':'auto','background-image':'none'});if ( soliloquy_container_30342.find('.soliloquy-slider li').length > 1 ) {soliloquy_container_30342.find('.soliloquy-controls').fadeTo(300, 1);}soliloquy_30342.find('.soliloquy-item:not(.soliloquy-clone):eq(' + currentIndex + ')').addClass('soliloquy-active-slide').attr('aria-hidden','false');soliloquy_container_30342.find('.soliloquy-clone').find('*').removeAttr('id');soliloquy_container_30342.find('.soliloquy-controls-direction').attr('aria-label','carousel buttons').attr('aria-controls', 'soliloquy-container-30342');soliloquy_container_30342.find('.soliloquy-controls-direction a.soliloquy-prev').attr('aria-label','previous');soliloquy_container_30342.find('.soliloquy-controls-direction a.soliloquy-next').attr('aria-label','next');},onSlideBefore: function(element, oldIndex, newIndex){soliloquy_container_30342.find('.soliloquy-active-slide').removeClass('soliloquy-active-slide').attr('aria-hidden','true');$(element).addClass('soliloquy-active-slide').attr('aria-hidden','false');},onSlideAfter: function(element, oldIndex, newIndex){},});});			</script>
			
</body>
</html>
<!-- Page generated by LiteSpeed Cache 3.6.4 on 2021-09-28 04:32:08 -->