<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>Music Video: Bun B &#038; Cory Mo ft. Z-Ro &#8211; The Geto | WeUpOnIt</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://weuponithiphop.info/xmlrpc.php" />
    		<style type="text/css">
					.heateor_sss_button_instagram span.heateor_sss_svg,a.heateor_sss_instagram span.heateor_sss_svg{background:radial-gradient(circle at 30% 107%,#fdf497 0,#fdf497 5%,#fd5949 45%,#d6249f 60%,#285aeb 90%)}
											.heateor_sss_horizontal_sharing .heateor_sss_svg,.heateor_sss_standard_follow_icons_container .heateor_sss_svg{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
					.heateor_sss_horizontal_sharing .heateorSssTCBackground{
				color:#666;
			}
					.heateor_sss_horizontal_sharing span.heateor_sss_svg:hover,.heateor_sss_standard_follow_icons_container span.heateor_sss_svg:hover{
						border-color: transparent;
		}
		.heateor_sss_vertical_sharing span.heateor_sss_svg,.heateor_sss_floating_follow_icons_container span.heateor_sss_svg{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
				.heateor_sss_vertical_sharing .heateorSssTCBackground{
			color:#666;
		}
						.heateor_sss_vertical_sharing span.heateor_sss_svg:hover,.heateor_sss_floating_follow_icons_container span.heateor_sss_svg:hover{
						border-color: transparent;
		}
		@media screen and (max-width:783px) {.heateor_sss_vertical_sharing{display:none!important}}		</style>
		<meta property="og:image" content="https://i.imgur.com/t0kad81.jpg" /><meta name="author" content="cyclone">
<link rel="icon" type="image/png" href="http://weuponithiphop.info/wp-content/uploads/weuponitlogoCAP-500x457.png"><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Feed" href="https://weuponithiphop.info/feed/" />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Comments Feed" href="https://weuponithiphop.info/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="WeUpOnIt &raquo; Music Video: Bun B &#038; Cory Mo ft. Z-Ro &#8211; The Geto Comments Feed" href="https://weuponithiphop.info/2022/10/22/music-video-bun-b-cory-mo-ft-z-ro-the-geto/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/weuponithiphop.info\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.22"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])?!1:!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55358,56760,9792,65039],[55358,56760,8203,9792,65039])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='google_font_open_sans-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;ver=4.9.22' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_roboto-css'  href='https://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C900%2C500italic%2C400%2C300&#038;ver=4.9.22' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Roboto+Condensed%3A400%2C700&#038;ver=4.9.22' type='text/css' media='all' />
<link rel='stylesheet' id='heateor_sss_frontend_css-css'  href='https://weuponithiphop.info/wp-content/plugins/sassy-social-share/public/css/sassy-social-share-public.css?ver=3.3.43' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='https://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=4.12' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://weuponithiphop.info/wp-content/themes/Newspaper/style.css?ver=7.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css'  href='https://weuponithiphop.info/wp-content/themes/Newspaper/includes/demos/what/demo_style.css?ver=7.2' type='text/css' media='all' />
<script type='text/javascript' src='https://weuponithiphop.info/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://weuponithiphop.info/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://weuponithiphop.info/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://weuponithiphop.info/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://weuponithiphop.info/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='New Music: French Montana ft. NAV &#8211; Fenty' href='https://weuponithiphop.info/2022/10/21/new-music-french-montana-ft-nav-fenty/' />
<link rel='next' title='Music Video: Icewear Vezzo ft. Babyface Ray &#8211; God Bless The 6' href='https://weuponithiphop.info/2022/10/22/music-video-icewear-vezzo-ft-babyface-ray-god-bless-the-6/' />
<meta name="generator" content="WordPress 4.9.22" />
<link rel="canonical" href="https://weuponithiphop.info/2022/10/22/music-video-bun-b-cory-mo-ft-z-ro-the-geto/" />
<link rel='shortlink' href='https://weuponithiphop.info/?p=50777' />
<link rel="alternate" type="application/json+oembed" href="https://weuponithiphop.info/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fweuponithiphop.info%2F2022%2F10%2F22%2Fmusic-video-bun-b-cory-mo-ft-z-ro-the-geto%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://weuponithiphop.info/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fweuponithiphop.info%2F2022%2F10%2F22%2Fmusic-video-bun-b-cory-mo-ft-z-ro-the-geto%2F&#038;format=xml" />
<!-- Analytics by WP Statistics v13.2.6 - https://wp-statistics.com/ -->
<!--[if lt IE 9]><script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="https://weuponithiphop.info/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]-->
<!-- JS generated by theme -->

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var tds_login_sing_in_widget="show";
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_ajax_url="https:\/\/weuponithiphop.info\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=7.2";
var td_get_template_directory_uri="https:\/\/weuponithiphop.info\/wp-content\/themes\/Newspaper";
var tds_snap_menu="snap";
var tds_logo_on_sticky="show_header_logo";
var tds_header_style="5";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#dd3333";
var tds_smart_sidebar="enabled";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>


<!-- Header style compiled by theme -->

<style>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</style>

<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>

<body class="post-template-default single single-post postid-50777 single-format-standard music-video-bun-b-cory-mo-ft-z-ro-the-geto td-what wpb-js-composer js-comp-ver-4.12 vc_responsive td-boxed-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponit_com" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
                    <div class="td-menu-login-section">
                
    <div class="td-guest-wrap">
        <div class="td-menu-avatar"><div class="td-avatar-container"><img alt='' src='https://secure.gravatar.com/avatar/?s=80&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo avatar-default' height='80' width='80' /></div></div>
        <div class="td-menu-login"><a id="login-link-mob">Sign in</a></div>
    </div>
            </div>
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-top-menu-container"><ul id="menu-top-menu" class="td-mobile-main-menu"><li id="menu-item-317" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-317"><a href="https://weuponithiphop.info/category/new-music/">New Music</a></li>
<li id="menu-item-706" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-706"><a href="https://weuponithiphop.info/category/album-stream-mixtapes/">Album Stream</a></li>
<li id="menu-item-314" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-314"><a href="https://weuponithiphop.info/category/music-video/">Videos</a></li>
<li id="menu-item-316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-316"><a href="https://weuponithiphop.info/category/latest-news/">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-0" class="menu-item-0"><a href="https://weuponithiphop.info/category/latest-news/album-news/">Album News</a></li>
	<li class="menu-item-0"><a href="https://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a></li>
	<li class="menu-item-0"><a href="https://weuponithiphop.info/category/latest-news/flashback/">Flashback</a></li>
	<li class="menu-item-0"><a href="https://weuponithiphop.info/category/latest-news/interviews/">Interviews</a></li>
	<li class="menu-item-0"><a href="https://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></li>
</ul>
</li>
<li id="menu-item-705" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-705"><a href="https://weuponithiphop.info/category/fashion/">Fashion<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li class="menu-item-0"><a href="https://weuponithiphop.info/category/fashion/kicks/">Kicks</a></li>
</ul>
</li>
<li id="menu-item-18581" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18581"><a href="https://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li id="menu-item-3199" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
            <div id="login-form-mobile" class="td-register-section">
            
            <div id="td-login-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-login-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign in</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
	                <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
	                <div class="td-login-info-text"><a href="#" id="forgot-pass-link-mob">Forgot your password?</a></div>
                </div>
            </div>

            

            <div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
                <!-- close button -->
	            <div class="td-forgot-pass-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Password recovery</div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title">Recover your password</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
	                <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
                </div>
            </div>
        </div>
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="https://weuponithiphop.info/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap">
    
        <!--
Header style 5
-->

<div class="td-header-wrap td-header-style-5">

    <div class="td-header-top-menu-full">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div >

                Saturday, October 22, 2022
            </div>
        </div>
    <ul class="top-header-menu td_ul_login"><li class="menu-item"><a class="td-login-modal-js menu-item" href="#login-form" data-effect="mpf-td-login-effect">Sign in / Join</a><span class="td-sp-ico-login td_sp_login_ico_style"></span></li></ul><div class="menu-top-container"><ul id="menu-main" class="top-header-menu"><li id="menu-item-79" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-79"><a href="http://weuponithiphop.info">Home</a></li>
<li id="menu-item-81" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-81"><a target="_blank" href="http://weuponitradio.com">Power 105.1 WeUpOnIt Radio</a></li>
<li id="menu-item-80" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-80"><a target="_blank" href="https://shop.spreadshirt.com/freshandcleantees/">Shop</a></li>
<li id="menu-item-18582" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18582"><a href="https://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li id="menu-item-18583" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18583"><a href="https://weuponithiphop.info/privacy-policy-2/">Privacy Policy</a></li>
</ul></div></div>
        <div class="td-header-sp-top-widget">
    
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponit_com" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div>
    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <ul class="td-login-tabs">
                        <li><a id="login-link" class="td_login_tab_focus">LOG IN</a></li>
                    </ul>



                    <div class="td-login-wrap">
                        <div class="td_display_err"></div>

                        <div id="td-login-div" class="">
                            <div class="td-login-panel-title">Welcome! Log into your account</div>
                            <input class="td-login-input" type="text" name="login_email" id="login_email" placeholder="your username" value="" required>
                            <input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" placeholder="your password" required>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Log In">


                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password?</a></div>


                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-display-none">
                            <div class="td-login-panel-title">Recover your password</div>
                            <input class="td-login-input" type="text" name="forgot_email" id="forgot_email" placeholder="your email" value="" required>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Pass">
                        </div>




                    </div>
                </div>
                        </div>
    </div>

    <div class="td-header-menu-wrap-full">
        <div class="td-header-menu-wrap">
            <div class="td-container td-header-row td-header-main-menu black-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-menu">
        		<a class="td-mobile-logo td-sticky-header" href="https://weuponithiphop.info/">
			<img class="td-retina-data" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-5.png" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-5.png" alt=""/>
		</a>
			<a class="td-header-logo td-sticky-header" href="https://weuponithiphop.info/">
			<img class="td-retina-data" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" alt=""/>
			<span class="td-visual-hidden">WeUpOnIt</span>
		</a>
	    </div>
    <div class="menu-top-menu-container"><ul id="menu-top-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-mega-menu menu-item-317"><a href="https://weuponithiphop.info/category/new-music/">New Music</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_1_6353a8588178f_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_1_6353a8588178f" ><script>var block_td_uid_1_6353a8588178f = new tdBlock();
block_td_uid_1_6353a8588178f.id = "td_uid_1_6353a8588178f";
block_td_uid_1_6353a8588178f.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"43","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_1_6353a8588178f_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_1_6353a8588178f.td_column_number = "3";
block_td_uid_1_6353a8588178f.block_type = "td_block_mega_menu";
block_td_uid_1_6353a8588178f.post_count = "5";
block_td_uid_1_6353a8588178f.found_posts = "4492";
block_td_uid_1_6353a8588178f.header_color = "";
block_td_uid_1_6353a8588178f.ajax_pagination_infinite_stop = "";
block_td_uid_1_6353a8588178f.max_num_pages = "899";
tdBlocksArray.push(block_td_uid_1_6353a8588178f);
</script><div id=td_uid_1_6353a8588178f class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/21/new-music-french-montana-ft-nav-fenty/" rel="bookmark" title="New Music: French Montana ft. NAV &#8211; Fenty"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/tKNqW5u.jpg" alt="" title="New Music: French Montana ft. NAV &#8211; Fenty"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/21/new-music-french-montana-ft-nav-fenty/" rel="bookmark" title="New Music: French Montana ft. NAV &#8211; Fenty">New Music: French Montana ft. NAV &#8211; Fenty</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/21/new-music-a-boogie-wit-da-hoodie-ft-tory-lanez-take-shots/" rel="bookmark" title="New Music: A Boogie Wit Da Hoodie ft. Tory Lanez &#8211; Take Shots"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/amE1LE6.jpg" alt="" title="New Music: A Boogie Wit Da Hoodie ft. Tory Lanez &#8211; Take Shots"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/21/new-music-a-boogie-wit-da-hoodie-ft-tory-lanez-take-shots/" rel="bookmark" title="New Music: A Boogie Wit Da Hoodie ft. Tory Lanez &#8211; Take Shots">New Music: A Boogie Wit Da Hoodie ft. Tory Lanez &#8211;&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/20/new-music-smino-matinee/" rel="bookmark" title="New Music: Smino &#8211; Matinee"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/zEKt1Rq.jpg" alt="" title="New Music: Smino &#8211; Matinee"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/20/new-music-smino-matinee/" rel="bookmark" title="New Music: Smino &#8211; Matinee">New Music: Smino &#8211; Matinee</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/20/new-music-pivot-gang-aang/" rel="bookmark" title="New Music: Pivot Gang &#8211; Aang"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/Mw7qAqm.jpg" alt="" title="New Music: Pivot Gang &#8211; Aang"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/20/new-music-pivot-gang-aang/" rel="bookmark" title="New Music: Pivot Gang &#8211; Aang">New Music: Pivot Gang &#8211; Aang</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/19/new-music-armani-caesar-ft-kodak-black-diana/" rel="bookmark" title="New Music: Armani Caesar ft. Kodak Black &#8211; Diana"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/QcrlzKE.jpg" alt="" title="New Music: Armani Caesar ft. Kodak Black &#8211; Diana"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/19/new-music-armani-caesar-ft-kodak-black-diana/" rel="bookmark" title="New Music: Armani Caesar ft. Kodak Black &#8211; Diana">New Music: Armani Caesar ft. Kodak Black &#8211; Diana</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_6353a8588178f" data-td_block_id="td_uid_1_6353a8588178f"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_1_6353a8588178f" data-td_block_id="td_uid_1_6353a8588178f"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-706"><a href="https://weuponithiphop.info/category/album-stream-mixtapes/">Album Stream</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_2_6353a8589132e_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_2_6353a8589132e" ><script>var block_td_uid_2_6353a8589132e = new tdBlock();
block_td_uid_2_6353a8589132e.id = "td_uid_2_6353a8589132e";
block_td_uid_2_6353a8589132e.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"97","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_2_6353a8589132e_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_2_6353a8589132e.td_column_number = "3";
block_td_uid_2_6353a8589132e.block_type = "td_block_mega_menu";
block_td_uid_2_6353a8589132e.post_count = "5";
block_td_uid_2_6353a8589132e.found_posts = "1709";
block_td_uid_2_6353a8589132e.header_color = "";
block_td_uid_2_6353a8589132e.ajax_pagination_infinite_stop = "";
block_td_uid_2_6353a8589132e.max_num_pages = "342";
tdBlocksArray.push(block_td_uid_2_6353a8589132e);
</script><div id=td_uid_2_6353a8589132e class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/21/album-stream-nba-youngboy-ma-i-got-a-family/" rel="bookmark" title="Album Stream: NBA YoungBoy &#8211; Ma’ I Got A Family"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/AO1i9uf.jpg" alt="" title="Album Stream: NBA YoungBoy &#8211; Ma’ I Got A Family"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/21/album-stream-nba-youngboy-ma-i-got-a-family/" rel="bookmark" title="Album Stream: NBA YoungBoy &#8211; Ma’ I Got A Family">Album Stream: NBA YoungBoy &#8211; Ma’ I Got A Family</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/21/album-stream-armani-caesar-the-liz-2/" rel="bookmark" title="Album Stream: Armani Caesar &#8211; The Liz 2"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/QAauC5D.jpg" alt="" title="Album Stream: Armani Caesar &#8211; The Liz 2"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/21/album-stream-armani-caesar-the-liz-2/" rel="bookmark" title="Album Stream: Armani Caesar &#8211; The Liz 2">Album Stream: Armani Caesar &#8211; The Liz 2</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/21/album-stream-jeezy-dj-drama-snofall/" rel="bookmark" title="Album Stream: Jeezy &#038; DJ Drama &#8211; SNOFALL"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/F0Zo3Oq.jpg" alt="" title="Album Stream: Jeezy &#038; DJ Drama &#8211; SNOFALL"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/21/album-stream-jeezy-dj-drama-snofall/" rel="bookmark" title="Album Stream: Jeezy &#038; DJ Drama &#8211; SNOFALL">Album Stream: Jeezy &#038; DJ Drama &#8211; SNOFALL</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/20/mixtape-snoop-dogg-i-still-got-it/" rel="bookmark" title="Mixtape: Snoop Dogg &#8211; I Still Got It"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/uyq601a.png" alt="" title="Mixtape: Snoop Dogg &#8211; I Still Got It"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/20/mixtape-snoop-dogg-i-still-got-it/" rel="bookmark" title="Mixtape: Snoop Dogg &#8211; I Still Got It">Mixtape: Snoop Dogg &#8211; I Still Got It</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/16/ep-stream-day-sulan-crazy-girls/" rel="bookmark" title="EP Stream: Day Sulan &#8211; Crazy Girls"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/MQWCpbx.jpg" alt="" title="EP Stream: Day Sulan &#8211; Crazy Girls"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/16/ep-stream-day-sulan-crazy-girls/" rel="bookmark" title="EP Stream: Day Sulan &#8211; Crazy Girls">EP Stream: Day Sulan &#8211; Crazy Girls</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_6353a8589132e" data-td_block_id="td_uid_2_6353a8589132e"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_2_6353a8589132e" data-td_block_id="td_uid_2_6353a8589132e"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-314"><a href="https://weuponithiphop.info/category/music-video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_3_6353a8589ba31_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_3_6353a8589ba31" ><script>var block_td_uid_3_6353a8589ba31 = new tdBlock();
block_td_uid_3_6353a8589ba31.id = "td_uid_3_6353a8589ba31";
block_td_uid_3_6353a8589ba31.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_3_6353a8589ba31_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_3_6353a8589ba31.td_column_number = "3";
block_td_uid_3_6353a8589ba31.block_type = "td_block_mega_menu";
block_td_uid_3_6353a8589ba31.post_count = "5";
block_td_uid_3_6353a8589ba31.found_posts = "5748";
block_td_uid_3_6353a8589ba31.header_color = "";
block_td_uid_3_6353a8589ba31.ajax_pagination_infinite_stop = "";
block_td_uid_3_6353a8589ba31.max_num_pages = "1150";
tdBlocksArray.push(block_td_uid_3_6353a8589ba31);
</script><div id=td_uid_3_6353a8589ba31 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/22/music-video-icewear-vezzo-ft-babyface-ray-god-bless-the-6/" rel="bookmark" title="Music Video: Icewear Vezzo ft. Babyface Ray &#8211; God Bless The 6"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/J2kskOI.jpg" alt="" title="Music Video: Icewear Vezzo ft. Babyface Ray &#8211; God Bless The 6"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/22/music-video-icewear-vezzo-ft-babyface-ray-god-bless-the-6/" rel="bookmark" title="Music Video: Icewear Vezzo ft. Babyface Ray &#8211; God Bless The 6">Music Video: Icewear Vezzo ft. Babyface Ray &#8211; God Bless The&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/22/music-video-bun-b-cory-mo-ft-z-ro-the-geto/" rel="bookmark" title="Music Video: Bun B &#038; Cory Mo ft. Z-Ro &#8211; The Geto"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/t0kad81.jpg" alt="" title="Music Video: Bun B &#038; Cory Mo ft. Z-Ro &#8211; The Geto"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/22/music-video-bun-b-cory-mo-ft-z-ro-the-geto/" rel="bookmark" title="Music Video: Bun B &#038; Cory Mo ft. Z-Ro &#8211; The Geto">Music Video: Bun B &#038; Cory Mo ft. Z-Ro &#8211; The&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/21/music-video-roddy-ricch-aston-martin-truck/" rel="bookmark" title="Music Video: Roddy Ricch &#8211; Aston Martin Truck"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/uUkdrLr.jpg" alt="" title="Music Video: Roddy Ricch &#8211; Aston Martin Truck"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/21/music-video-roddy-ricch-aston-martin-truck/" rel="bookmark" title="Music Video: Roddy Ricch &#8211; Aston Martin Truck">Music Video: Roddy Ricch &#8211; Aston Martin Truck</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/21/music-video-ab-soul-ft-zacari-do-better/" rel="bookmark" title="Music Video: Ab-Soul ft. Zacari &#8211; Do Better"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/vsOPSJQ.jpg" alt="" title="Music Video: Ab-Soul ft. Zacari &#8211; Do Better"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/21/music-video-ab-soul-ft-zacari-do-better/" rel="bookmark" title="Music Video: Ab-Soul ft. Zacari &#8211; Do Better">Music Video: Ab-Soul ft. Zacari &#8211; Do Better</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/20/music-video-hit-boy-ft-curreny-tony-fontana-iii/" rel="bookmark" title="Music Video: Hit-Boy ft. Curren$y &#8211; Tony Fontana III"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/IW2LiIR.jpg" alt="" title="Music Video: Hit-Boy ft. Curren$y &#8211; Tony Fontana III"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/20/music-video-hit-boy-ft-curreny-tony-fontana-iii/" rel="bookmark" title="Music Video: Hit-Boy ft. Curren$y &#8211; Tony Fontana III">Music Video: Hit-Boy ft. Curren$y &#8211; Tony Fontana III</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_6353a8589ba31" data-td_block_id="td_uid_3_6353a8589ba31"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_3_6353a8589ba31" data-td_block_id="td_uid_3_6353a8589ba31"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-316"><a href="https://weuponithiphop.info/category/latest-news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_4_6353a858aacaa_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_4_6353a858aacaa" ><script>var block_td_uid_4_6353a858aacaa = new tdBlock();
block_td_uid_4_6353a858aacaa.id = "td_uid_4_6353a858aacaa";
block_td_uid_4_6353a858aacaa.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"29","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_4_6353a858aacaa_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_4_6353a858aacaa.td_column_number = "3";
block_td_uid_4_6353a858aacaa.block_type = "td_block_mega_menu";
block_td_uid_4_6353a858aacaa.post_count = "4";
block_td_uid_4_6353a858aacaa.found_posts = "1172";
block_td_uid_4_6353a858aacaa.header_color = "";
block_td_uid_4_6353a858aacaa.ajax_pagination_infinite_stop = "";
block_td_uid_4_6353a858aacaa.max_num_pages = "293";
tdBlocksArray.push(block_td_uid_4_6353a858aacaa);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_4_6353a858aacaa" id="td_uid_5_6353a858b0ff5" data-td_block_id="td_uid_4_6353a858aacaa" data-td_filter_value="" href="https://weuponithiphop.info/category/latest-news/">All</a><a class="mega-menu-sub-cat-td_uid_4_6353a858aacaa"  id="td_uid_6_6353a858b117a" data-td_block_id="td_uid_4_6353a858aacaa" data-td_filter_value="69" href="https://weuponithiphop.info/category/latest-news/album-news/">Album News</a><a class="mega-menu-sub-cat-td_uid_4_6353a858aacaa"  id="td_uid_7_6353a858b1333" data-td_block_id="td_uid_4_6353a858aacaa" data-td_filter_value="80" href="https://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a><a class="mega-menu-sub-cat-td_uid_4_6353a858aacaa"  id="td_uid_8_6353a858b14b3" data-td_block_id="td_uid_4_6353a858aacaa" data-td_filter_value="2189" href="https://weuponithiphop.info/category/latest-news/flashback/">Flashback</a><a class="mega-menu-sub-cat-td_uid_4_6353a858aacaa"  id="td_uid_9_6353a858b167b" data-td_block_id="td_uid_4_6353a858aacaa" data-td_filter_value="10" href="https://weuponithiphop.info/category/latest-news/interviews/">Interviews</a><a class="mega-menu-sub-cat-td_uid_4_6353a858aacaa"  id="td_uid_10_6353a858b17fe" data-td_block_id="td_uid_4_6353a858aacaa" data-td_filter_value="130" href="https://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></div></div><div id=td_uid_4_6353a858aacaa class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/20/video-freddie-gibbs-l-a-leakers-freestyle-2/" rel="bookmark" title="Video: Freddie Gibbs &#8211; L.A. Leakers Freestyle"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/1eKuThs.jpg" alt="" title="Video: Freddie Gibbs &#8211; L.A. Leakers Freestyle"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/20/video-freddie-gibbs-l-a-leakers-freestyle-2/" rel="bookmark" title="Video: Freddie Gibbs &#8211; L.A. Leakers Freestyle">Video: Freddie Gibbs &#8211; L.A. Leakers Freestyle</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/13/video-lil-baby-funkmaster-flex-freestyle/" rel="bookmark" title="Video: Lil Baby &#8211; Funkmaster Flex Freestyle"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/6bjOjrU.jpg" alt="" title="Video: Lil Baby &#8211; Funkmaster Flex Freestyle"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/13/video-lil-baby-funkmaster-flex-freestyle/" rel="bookmark" title="Video: Lil Baby &#8211; Funkmaster Flex Freestyle">Video: Lil Baby &#8211; Funkmaster Flex Freestyle</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/05/bet-hip-hop-awards-2022-winners-performances/" rel="bookmark" title="BET Hip Hop Awards 2022 Winners &#038; Performances"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/vmClh9C.jpg" alt="" title="BET Hip Hop Awards 2022 Winners &#038; Performances"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/05/bet-hip-hop-awards-2022-winners-performances/" rel="bookmark" title="BET Hip Hop Awards 2022 Winners &#038; Performances">BET Hip Hop Awards 2022 Winners &#038; Performances</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/03/video-beyonce-tiffany-co-lose-yourself-in-love-with-summer-renaissance-ad/" rel="bookmark" title="Video: Beyonce &#038; Tiffany &#038; Co. &#8211; Lose Yourself In Love with Summer Renaissance Ad"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/mIVSQhq.jpg" alt="" title="Video: Beyonce &#038; Tiffany &#038; Co. &#8211; Lose Yourself In Love with Summer Renaissance Ad"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/03/video-beyonce-tiffany-co-lose-yourself-in-love-with-summer-renaissance-ad/" rel="bookmark" title="Video: Beyonce &#038; Tiffany &#038; Co. &#8211; Lose Yourself In Love with Summer Renaissance Ad">Video: Beyonce &#038; Tiffany &#038; Co. &#8211; Lose Yourself In Love&#8230;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_4_6353a858aacaa" data-td_block_id="td_uid_4_6353a858aacaa"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_4_6353a858aacaa" data-td_block_id="td_uid_4_6353a858aacaa"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-705"><a href="https://weuponithiphop.info/category/fashion/">Fashion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_11_6353a858d9df4_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_11_6353a858d9df4" ><script>var block_td_uid_11_6353a858d9df4 = new tdBlock();
block_td_uid_11_6353a858d9df4.id = "td_uid_11_6353a858d9df4";
block_td_uid_11_6353a858d9df4.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"77","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_11_6353a858d9df4_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_11_6353a858d9df4.td_column_number = "3";
block_td_uid_11_6353a858d9df4.block_type = "td_block_mega_menu";
block_td_uid_11_6353a858d9df4.post_count = "4";
block_td_uid_11_6353a858d9df4.found_posts = "158";
block_td_uid_11_6353a858d9df4.header_color = "";
block_td_uid_11_6353a858d9df4.ajax_pagination_infinite_stop = "";
block_td_uid_11_6353a858d9df4.max_num_pages = "40";
tdBlocksArray.push(block_td_uid_11_6353a858d9df4);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_11_6353a858d9df4" id="td_uid_12_6353a858dd439" data-td_block_id="td_uid_11_6353a858d9df4" data-td_filter_value="" href="https://weuponithiphop.info/category/fashion/">All</a><a class="mega-menu-sub-cat-td_uid_11_6353a858d9df4"  id="td_uid_13_6353a858dd5c9" data-td_block_id="td_uid_11_6353a858d9df4" data-td_filter_value="76" href="https://weuponithiphop.info/category/fashion/kicks/">Kicks</a></div></div><div id=td_uid_11_6353a858d9df4 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/LVT4Mid8WL4wHUdO9X2OZmZxxgbREs2lVtszOdEBaO6hJB0JS3yQOAyhNSdCyPmv0amBDTgNGpOlRPXPjKCl6yIlo2joyH3rQRI7CUdX09BJtQI1r5jy1_7BQtDhw4AxUhpUwIh35rNS3lTy7uq-FdPff10JN6srr9mwZ7zr04GQFxBVEXwCfC5rNVehXhY_wGCRVsmevYmdkBWEmB8dvOzBHY78NBBjcHNArS_S-2M0FJgDh8v9m9vEh78k_XmZg-AERctsf0bkODuPi1EcNJq_RnJIV6b0GG-VtKjo-OVPmYghWJYf1HiP9c58cQ98oABU8BDFdLqsBtNt4K0NmyHYQlX39W9k_d83wEHZ1-EacQa2o01VrYSn12HnZ1l88fMzu9PKv6EGmcRZNwpepycW7_9EQnhxIPDdVCmRLXUasUED9OXr-zJmnBcnSnLCa06k1ZymQym1LiSFEv1c3aPHnmnD3GY8nL7q5jPJr4HsABR0WCqMebcF3HF_0deNd0zgRBCGMxW-VzlIIHZiHuBeSPEPvUL149GJ5swSSvKm1uGEi1HlLBj9omJSU7mDWzO0p_7l-l7-4_ureEsGsgB8cX1t8t2TQcFeRgqqF1CXlZFYYC2K0iMb4jPsijsw_rtO7pmKvbngqHfgYpGeh_qLmDWeicR7=w1195-h796-no" alt="" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch">Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/fHEwwMf8DoiXlqkfibQS1Z1XXbviORbV9raaI44tOTXrWo7GgqM3gA-vswE10gFtTQUGGwNG7nWAACwHjxPuiubliYBN_dqtBZh2WIpxvumiJ-hSLK0TNWB2cB8Iw2STT5gcp_KqlDh_e4xng1vidI8EXdp_ooh5uDI-JV1HQ9dGnM5nxl_b-v8znqj-Rl_mGB7y4Lu9zsFNWHU7SriqQQJaKrKEEnb9T8zxmGLaL0zq7ilYpnUEhWulDDr9xc82wdr__WzRBm5YEskVpDAnGM2NDZwTZpjbe4QDdxeixWnSXNK_oDzaL7WTbCpkD33OK88BlI5JmFRQ5VmD11UQ2htB7-9WoahHvb4XmBsbLXpEMl1JmEP4sPx06VduzFnBNo-J90WI0n1AEIIcEYVbRywrkGJXbzmH__In9ZIg0EV24OcGGbeKl12HxTdZwucqsNnuZeNjiMHISQ7i8cfzm3N7X7Zenl74zsKIKeKWoIGxh6MTlVADvgHcrHebnjcSgil2vBeFyz_AP45aOv9SOwbzfVLGS0CNfe1s9b2J7qZgjcBk9QPEXCl2kygvzmGXFvU_3xBuW6S0i3Vkh3Ha_3hPBtvIAy3WoTK2yiqS41HzSK7yk3FRAlBtpIEib338fdkTiosBxtdu36SdNUVM75zl6CVIFhTu=w681-h470-no" alt="" title="Air Jordan 14 Rip Hamilton"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton">Air Jordan 14 Rip Hamilton</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/kUjaOYxjEkAh34S-Ub2QSZwdOwHyFnGFLBZULta3_bn1_myPMAwJXiEEsAAtc1ktCQwHCuKhSqSYsWXFBEIZxdfKuykoDEZWwO-dDI3_JeAshbYvyILEHUu0XaUpRn0mj7gOx10V52t8gRGYPCW7QXGImkPGGhvBPzBDVVqh9lKGtkuPeePmTnpRSmwp0LG1WHcIzUWnMqPBWQeHAat6Q-Tq7niXNb96ddEZsMEdHK1nmHVlNaeqFBNtTxk6yYRkFNCvtfBayqy-Rqt4CPU5tThxbTI4AIUCI6JLxJd_VJizrVNDEe2xZ_tiQdkC5ASIoHpX8sfvAB8zRUsMVJ6oMUt5FH_4GBNXDCtFRmr65Qt0JV1h4bBJffu2L272Q_vpD76wn-YNGW8VCtZcheHu_X-A4gdYQEC0HN0BenY-MOuUBqKEjXAc0SxWeP7W9RN55jlqUFK0nzEYydVjec2stdQIngVfg_FvKxvHXfM4XdtMpqeJnp3Pzyk8xjz30sAZd0f2HQ6zfdPjk-OkV2-WrC0_qW0L8Rq3zrUbq52n3BN7gm7sctU_CUlBmoQIgJDQBYk1Siv4tfSq9pL1R4GdaOlWQdxEuhZi8bTYC8GGAgNGl3SMAZGvk7nu6QnnwEZjZ7mZwbcqgyRKa89cOREMUvIkVJ8Q8lZu=w926-h672-no" alt="" title="Jordan Proto React Triple White"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White">Jordan Proto React Triple White</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4cDUjSODZSaXWfHyZKb9q3Fn7FHA4uB0KSBs0MtFHC0dc6AJb1zeAl_X2LOKalK9C7VBFhTqRQ9fw1ESgUr9ZUKFbOzD94i_s96nvkICOqrsYnzrE2nEAQHoEaGOF4O8GAI6T4CGFbgcQhNzjpRlSY60NyPu5Cmq81FRpEOFRzTOtSa_NnWzMmfwO0yxtPbcg5U6YBUsus8shv3SA7CjULLfaP38nZAuWVgq8PMaaeCQ_eSrK8NJSEVQjyyxmqb-1I7zO8Kvvzvwi--ibMr52CF8h-GusBzSq5ZuzvZRCGu_u8CyfoXw7pwWbOmHnLOdcQ9d2PCSW_IxEMGfmEuU7NxMSsW3Ga4r35_wLB7cjvlPC9OjCV50tfekXjZBS_476mzlf4G9jR7Ju1GqgjXah9Uqc_0Y8N-Br8_JCtIlRSuLxAiebwd7AvFVlgWId9MYxBWnRT3cTyD8SH7q5WwO-CIbKAOSKsNcrrTgFxQvqn9yklBU1u5X5fdTlTBk4WSYorsWZAug0z9BOymRLnrhTbnA0vpBPFROWD-aL1glg-eUpFSfgD4xhWsOqJNY9krQ2UbLSGXQ5gYWj0ovLS7Yz3UKFY2qrVWpqkpbfyN98es9NJ-7LTUs2MLq1rX_2FaQmyq5mVndd7VGzQOHy9hDULG-5H-0LvGd=w900-h566-no" alt="" title="adidas Yeezy Boost 350 V2 Hyperspace"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace">adidas Yeezy Boost 350 V2 Hyperspace</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_11_6353a858d9df4" data-td_block_id="td_uid_11_6353a858d9df4"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_11_6353a858d9df4" data-td_block_id="td_uid_11_6353a858d9df4"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18581"><a href="https://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div></div>


<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form method="get" class="td-search-form" action="https://weuponithiphop.info/">
				<div role="search" class="td-head-form-search-wrap">
					<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>            </div>
        </div>
    </div>

    <div class="td-banner-wrap-full">
        <div class="td-header-container td-header-row td-header-header">
            <div class="td-header-sp-recs">
                <div class="td-header-rec-wrap">
    
</div>            </div>
        </div>
    </div>

</div><div class="td-main-content-wrap">

    <div class="td-container td-post-template-default ">
        <div class="td-crumb-container"><div class="entry-crumbs"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="" class="entry-crumb" itemprop="url" href="https://weuponithiphop.info/"><span itemprop="title">Home</span></a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="View all posts in Music Video" class="entry-crumb" itemprop="url" href="https://weuponithiphop.info/category/music-video/"><span itemprop="title">Music Video</span></a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last" itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><meta itemprop="title" content = "Music Video: Bun B &#038; Cory Mo ft. Z-Ro &#8211; The Geto"><meta itemprop="url" content = "https://weuponithiphop.info/2022/10/22/music-video-bun-b-cory-mo-ft-z-ro-the-geto/">Music Video: Bun B &#038; Cory Mo ft. Z-Ro &#8211; The Geto</span></div></div>

        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-50777" class="post-50777 post type-post status-publish format-standard has-post-thumbnail hentry category-music-video tag-bun-b tag-cory-mo tag-z-ro" itemscope itemtype="https://schema.org/Article">
        <div class="td-post-header">

            <ul class="td-category"><li class="entry-category"><a  href="https://weuponithiphop.info/category/music-video/">Music Video</a></li></ul>
            <header class="td-post-title">
                <h1 class="entry-title">Music Video: Bun B &#038; Cory Mo ft. Z-Ro &#8211; The Geto</h1>

                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name">By <a href="https://weuponithiphop.info/author/cyclone/">cyclone</a> - </div>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-10-22T03:55:10+00:00" >October 22, 2022</time></span>                    <div class="td-post-comments"><a href="https://weuponithiphop.info/2022/10/22/music-video-bun-b-cory-mo-ft-z-ro-the-geto/#respond"><i class="td-icon-comments"></i>0</a></div>                                    </div>

            </header>

        </div>

        

        <div class="td-post-content">

        
        <p><img class="aligncenter size-medium" src="https://i.imgur.com/t0kad81.jpg" width="1279" height="622" /></p>
<p><strong>Bun B</strong> and <strong>Z-Ro</strong> take a trip to <strong>“The Geto”</strong>  in their new video. Directed by <strong>Orbit Didit Films</strong>, <strong>Bun</strong> &amp; <strong>Z-Ro</strong> hit up Houston’s Garden City Apartments with projected images of poverty and crime as they speak on their rough upbringing. <strong>“The Geto”</strong> is off <strong>Bun B</strong> and producer <strong>Cory Mo’s</strong> project <em><strong>Mo Trill</strong></em>.</p>
<p>Watch <strong>“The Geto” video</strong> below.</p>
<p><iframe title="Bun B &amp; Cory Mo - The Geto ft. Z-Ro" src="https://www.youtube.com/embed/576ogRGtWfU" width="590" height="332" frameborder="0" allowfullscreen="allowfullscreen"></iframe></p>
<div class='heateorSssClear'></div><div  class='heateor_sss_sharing_container heateor_sss_horizontal_sharing' data-heateor-sss-href='https://weuponithiphop.info/2022/10/22/music-video-bun-b-cory-mo-ft-z-ro-the-geto/'><div class='heateor_sss_sharing_title' style="font-weight:bold" >Spread the love</div><div class="heateor_sss_sharing_ul"><a class="heateor_sss_facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fweuponithiphop.info%2F2022%2F10%2F22%2Fmusic-video-bun-b-cory-mo-ft-z-ro-the-geto%2F" title="Facebook" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg" style="background-color:#3c589a;width:35px;height:35px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-5 -5 42 42"><path d="M17.78 27.5V17.008h3.522l.527-4.09h-4.05v-2.61c0-1.182.33-1.99 2.023-1.99h2.166V4.66c-.375-.05-1.66-.16-3.155-.16-3.123 0-5.26 1.905-5.26 5.405v3.016h-3.53v4.09h3.53V27.5h4.223z" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_twitter" href="http://twitter.com/intent/tweet?text=Music%20Video%3A%20Bun%20B%20%26%20Cory%20Mo%20ft.%20Z-Ro%20-%20The%20Geto&url=https%3A%2F%2Fweuponithiphop.info%2F2022%2F10%2F22%2Fmusic-video-bun-b-cory-mo-ft-z-ro-the-geto%2F" title="Twitter" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_twitter" style="background-color:#55acee;width:35px;height:35px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-4 -4 39 39"><path d="M28 8.557a9.913 9.913 0 0 1-2.828.775 4.93 4.93 0 0 0 2.166-2.725 9.738 9.738 0 0 1-3.13 1.194 4.92 4.92 0 0 0-3.593-1.55 4.924 4.924 0 0 0-4.794 6.049c-4.09-.21-7.72-2.17-10.15-5.15a4.942 4.942 0 0 0-.665 2.477c0 1.71.87 3.214 2.19 4.1a4.968 4.968 0 0 1-2.23-.616v.06c0 2.39 1.7 4.38 3.952 4.83-.414.115-.85.174-1.297.174-.318 0-.626-.03-.928-.086a4.935 4.935 0 0 0 4.6 3.42 9.893 9.893 0 0 1-6.114 2.107c-.398 0-.79-.023-1.175-.068a13.953 13.953 0 0 0 7.55 2.213c9.056 0 14.01-7.507 14.01-14.013 0-.213-.005-.426-.015-.637.96-.695 1.795-1.56 2.455-2.55z" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_pinterest" onclick="javascript:void( (function() {var e=document.createElement('script' );e.setAttribute('type','text/javascript' );e.setAttribute('charset','UTF-8' );e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e)})());" title="Pinterest" rel="nofollow noopener" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_pinterest" style="background-color:#cc2329;width:35px;height:35px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-2 -2 35 35"><path fill="#fff" d="M16.539 4.5c-6.277 0-9.442 4.5-9.442 8.253 0 2.272.86 4.293 2.705 5.046.303.125.574.005.662-.33.061-.231.205-.816.27-1.06.088-.331.053-.447-.191-.736-.532-.627-.873-1.439-.873-2.591 0-3.338 2.498-6.327 6.505-6.327 3.548 0 5.497 2.168 5.497 5.062 0 3.81-1.686 7.025-4.188 7.025-1.382 0-2.416-1.142-2.085-2.545.397-1.674 1.166-3.48 1.166-4.689 0-1.081-.581-1.983-1.782-1.983-1.413 0-2.548 1.462-2.548 3.419 0 1.247.421 2.091.421 2.091l-1.699 7.199c-.505 2.137-.076 4.755-.039 5.019.021.158.223.196.314.077.13-.17 1.813-2.247 2.384-4.324.162-.587.929-3.631.929-3.631.46.876 1.801 1.646 3.227 1.646 4.247 0 7.128-3.871 7.128-9.053.003-3.918-3.317-7.568-8.361-7.568z"/></svg></span></a><a class="heateor_sss_button_flipboard" href="https://share.flipboard.com/bookmarklet/popout?v=2&url=https%3A%2F%2Fweuponithiphop.info%2F2022%2F10%2F22%2Fmusic-video-bun-b-cory-mo-ft-z-ro-the-geto%2F&title=Music%20Video%3A%20Bun%20B%20%26%20Cory%20Mo%20ft.%20Z-Ro%20-%20The%20Geto" title="Flipboard" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_flipboard" style="background-color:#c00;width:35px;height:35px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="0 0 32 32"><path fill="#fff" d="M19 19H7V7h12v12z"/><path fill="#fff" d="M25 13H7V7h18v6z"/><path fill="#fff" d="M13 25H7V7h6v18z"/></svg></span></a><a class="heateor_sss_button_reddit" href="http://reddit.com/submit?url=https%3A%2F%2Fweuponithiphop.info%2F2022%2F10%2F22%2Fmusic-video-bun-b-cory-mo-ft-z-ro-the-geto%2F&title=Music%20Video%3A%20Bun%20B%20%26%20Cory%20Mo%20ft.%20Z-Ro%20-%20The%20Geto" title="Reddit" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_reddit" style="background-color:#ff5700;width:35px;height:35px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-3.5 -3.5 39 39"><path d="M28.543 15.774a2.953 2.953 0 0 0-2.951-2.949 2.882 2.882 0 0 0-1.9.713 14.075 14.075 0 0 0-6.85-2.044l1.38-4.349 3.768.884a2.452 2.452 0 1 0 .24-1.176l-4.274-1a.6.6 0 0 0-.709.4l-1.659 5.224a14.314 14.314 0 0 0-7.316 2.029 2.908 2.908 0 0 0-1.872-.681 2.942 2.942 0 0 0-1.618 5.4 5.109 5.109 0 0 0-.062.765c0 4.158 5.037 7.541 11.229 7.541s11.22-3.383 11.22-7.541a5.2 5.2 0 0 0-.053-.706 2.963 2.963 0 0 0 1.427-2.51zm-18.008 1.88a1.753 1.753 0 0 1 1.73-1.74 1.73 1.73 0 0 1 1.709 1.74 1.709 1.709 0 0 1-1.709 1.711 1.733 1.733 0 0 1-1.73-1.711zm9.565 4.968a5.573 5.573 0 0 1-4.081 1.272h-.032a5.576 5.576 0 0 1-4.087-1.272.6.6 0 0 1 .844-.854 4.5 4.5 0 0 0 3.238.927h.032a4.5 4.5 0 0 0 3.237-.927.6.6 0 1 1 .844.854zm-.331-3.256a1.726 1.726 0 1 1 1.709-1.712 1.717 1.717 0 0 1-1.712 1.712z" fill="#fff"/></svg></span></a><a class="heateor_sss_button_linkedin" href="http://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fweuponithiphop.info%2F2022%2F10%2F22%2Fmusic-video-bun-b-cory-mo-ft-z-ro-the-geto%2F&title=Music%20Video%3A%20Bun%20B%20%26%20Cory%20Mo%20ft.%20Z-Ro%20-%20The%20Geto" title="Linkedin" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_linkedin" style="background-color:#0077b5;width:35px;height:35px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="0 0 32 32"><path d="M6.227 12.61h4.19v13.48h-4.19V12.61zm2.095-6.7a2.43 2.43 0 0 1 0 4.86c-1.344 0-2.428-1.09-2.428-2.43s1.084-2.43 2.428-2.43m4.72 6.7h4.02v1.84h.058c.56-1.058 1.927-2.176 3.965-2.176 4.238 0 5.02 2.792 5.02 6.42v7.395h-4.183v-6.56c0-1.564-.03-3.574-2.178-3.574-2.18 0-2.514 1.7-2.514 3.46v6.668h-4.187V12.61z" fill="#fff"></path></svg></span></a><a class="heateor_sss_MeWe" href="https://mewe.com/share?link=https%3A%2F%2Fweuponithiphop.info%2F2022%2F10%2F22%2Fmusic-video-bun-b-cory-mo-ft-z-ro-the-geto%2F" title="MeWe" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg" style="background-color:#007da1;width:35px;height:35px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-4 -3 38 38"><g fill="#fff"><path d="M9.636 10.427a1.22 1.22 0 1 1-2.44 0 1.22 1.22 0 1 1 2.44 0zM15.574 10.431a1.22 1.22 0 0 1-2.438 0 1.22 1.22 0 1 1 2.438 0zM22.592 10.431a1.221 1.221 0 1 1-2.443 0 1.221 1.221 0 0 1 2.443 0zM29.605 10.431a1.221 1.221 0 1 1-2.442 0 1.221 1.221 0 0 1 2.442 0zM3.605 13.772c0-.471.374-.859.859-.859h.18c.374 0 .624.194.789.457l2.935 4.597 2.95-4.611c.18-.291.43-.443.774-.443h.18c.485 0 .859.387.859.859v8.113a.843.843 0 0 1-.859.845.857.857 0 0 1-.845-.845V16.07l-2.366 3.559c-.18.276-.402.443-.72.443-.304 0-.526-.167-.706-.443l-2.354-3.53V21.9c0 .471-.374.83-.845.83a.815.815 0 0 1-.83-.83v-8.128h-.001zM14.396 14.055a.9.9 0 0 1-.069-.333c0-.471.402-.83.872-.83.415 0 .735.263.845.624l2.23 6.66 2.187-6.632c.139-.402.428-.678.859-.678h.124c.428 0 .735.278.859.678l2.187 6.632 2.23-6.675c.126-.346.415-.609.83-.609.457 0 .845.361.845.817a.96.96 0 0 1-.083.346l-2.867 8.032c-.152.43-.471.706-.887.706h-.165c-.415 0-.721-.263-.872-.706l-2.161-6.328-2.16 6.328c-.152.443-.47.706-.887.706h-.165c-.415 0-.72-.263-.887-.706l-2.865-8.032z"></path></g></svg></span></a><a class="heateor_sss_whatsapp" href="https://api.whatsapp.com/send?text=Music%20Video%3A%20Bun%20B%20%26%20Cory%20Mo%20ft.%20Z-Ro%20-%20The%20Geto https%3A%2F%2Fweuponithiphop.info%2F2022%2F10%2F22%2Fmusic-video-bun-b-cory-mo-ft-z-ro-the-geto%2F" title="Whatsapp" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg" style="background-color:#55eb4c;width:35px;height:35px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-6 -5 40 40"><path class="heateor_sss_svg_stroke heateor_sss_no_fill" stroke="#fff" stroke-width="2" fill="none" d="M 11.579798566743314 24.396926207859085 A 10 10 0 1 0 6.808479557110079 20.73576436351046"></path><path d="M 7 19 l -1 6 l 6 -1" class="heateor_sss_no_fill heateor_sss_svg_stroke" stroke="#fff" stroke-width="2" fill="none"></path><path d="M 10 10 q -1 8 8 11 c 5 -1 0 -6 -1 -3 q -4 -3 -5 -5 c 4 -2 -1 -5 -1 -4" fill="#fff"></path></svg></span></a><a class="heateor_sss_email" onclick="window.open('mailto:?subject=' + decodeURIComponent('Music%20Video%3A%20Bun%20B%20%26%20Cory%20Mo%20ft.%20Z-Ro%20-%20The%20Geto' ).replace('&', '%26') + '&body=' + decodeURIComponent('https%3A%2F%2Fweuponithiphop.info%2F2022%2F10%2F22%2Fmusic-video-bun-b-cory-mo-ft-z-ro-the-geto%2F' ), '_blank')" title="Email" rel="nofollow noopener" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg" style="background-color:#649a3f;width:35px;height:35px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-4 -4 43 43"><path d="M 5.5 11 h 23 v 1 l -11 6 l -11 -6 v -1 m 0 2 l 11 6 l 11 -6 v 11 h -22 v -11" stroke-width="1" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_google_gmail" href="https://mail.google.com/mail/?ui=2&view=cm&fs=1&tf=1&su=Music%20Video%3A%20Bun%20B%20%26%20Cory%20Mo%20ft.%20Z-Ro%20-%20The%20Geto&body=Link:https%3A%2F%2Fweuponithiphop.info%2F2022%2F10%2F22%2Fmusic-video-bun-b-cory-mo-ft-z-ro-the-geto%2F" title="Google Gmail" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_Google_Gmail" style="background-color:#e5e5e5;width:35px;height:35px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="0 0 32 32"><path fill="#fff" d="M2.902 6.223h26.195v19.554H2.902z"></path><path fill="#E14C41" class="heateor_sss_no_fill" d="M2.902 25.777h26.195V6.223H2.902v19.554zm22.44-4.007v3.806H6.955v-3.6h.032l.093-.034 6.9-5.558 2.09 1.77 1.854-1.63 7.42 5.246zm0-.672l-7.027-4.917 7.028-6.09V21.1zm-1.17-14.67l-.947.905c-2.356 2.284-4.693 4.75-7.17 6.876l-.078.06L8.062 6.39l16.11.033zm-10.597 9.61l-6.62 5.294.016-10.914 6.607 5.62"></path></svg></span></a><a class="heateor_sss_pinboard" href="https://pinboard.in/popup_login/?url=https%3A%2F%2Fweuponithiphop.info%2F2022%2F10%2F22%2Fmusic-video-bun-b-cory-mo-ft-z-ro-the-geto%2F&title=Music%20Video%3A%20Bun%20B%20%26%20Cory%20Mo%20ft.%20Z-Ro%20-%20The%20Geto&later=&description=&next=same" title="Pinboard" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg" style="background-color:#1341de;width:35px;height:35px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="0 0 32 32"><path fill="#fff" d="M17.357 18.913l-5.01 5.014.88-4.5-6.588-8.075-3.48.044 4.314-4.313 4.035-4.04V6.85l7.795 6.403 4.502-.786-4.876 4.87 9.908 11.62"></path></svg></span></a><a class="heateor_sss_more" title="More" rel="nofollow noopener" style="font-size: 32px!important;border:0;box-shadow:none;display:inline-block!important;font-size:16px;padding:0 4px;vertical-align: middle;display:inline;" href="https://weuponithiphop.info/2022/10/22/music-video-bun-b-cory-mo-ft-z-ro-the-geto/" onclick="event.preventDefault()"><span class="heateor_sss_svg" style="background-color:#ee8e2d;width:35px;height:35px;display:inline-block!important;opacity:1;float:left;font-size:32px!important;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;display:inline;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box;" onclick="heateorSssMoreSharingPopup(this, 'https://weuponithiphop.info/2022/10/22/music-video-bun-b-cory-mo-ft-z-ro-the-geto/', 'Music%20Video%3A%20Bun%20B%20%26%20Cory%20Mo%20ft.%20Z-Ro%20-%20The%20Geto', '' )"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" viewBox="-.3 0 32 32" version="1.1" width="100%" height="100%" style="display:block;" xml:space="preserve"><g><path fill="#fff" d="M18 14V8h-4v6H8v4h6v6h4v-6h6v-4h-6z" fill-rule="evenodd"></path></g></svg></span></a></div><div class="heateorSssClear"></div></div><div class='heateorSssClear'></div>        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://weuponithiphop.info/tag/bun-b/">Bun B</a></li><li><a href="https://weuponithiphop.info/tag/cory-mo/">Cory Mo</a></li><li><a href="https://weuponithiphop.info/tag/z-ro/">Z-Ro</a></li></ul>            </div>

                        <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://weuponithiphop.info/2022/10/21/new-music-french-montana-ft-nav-fenty/">New Music: French Montana ft. NAV &#8211; Fenty</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="https://weuponithiphop.info/2022/10/22/music-video-icewear-vezzo-ft-babyface-ray-god-bless-the-6/">Music Video: Icewear Vezzo ft. Babyface Ray &#8211; God Bless The 6</a></div></div></div>            <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://weuponithiphop.info/author/cyclone/">cyclone</a></span></div>	        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="cyclone"></span><meta itemprop="datePublished" content="2022-10-22T03:55:10+00:00"><meta itemprop="dateModified" content="2022-10-22T03:55:10+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://weuponithiphop.info/2022/10/22/music-video-bun-b-cory-mo-ft-z-ro-the-geto/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png"></span><meta itemprop="name" content="WeUpOnIt"></span><meta itemprop="headline " content="Music Video: Bun B &amp; Cory Mo ft. Z-Ro - The Geto"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://i.imgur.com/t0kad81.jpg"><meta itemprop="width" content="800"><meta itemprop="height" content="600"></span>        </footer>

    </article> <!-- /.post -->

    <div class="td_block_wrap td_block_related_posts td_uid_15_6353a858f0a50_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_15_6353a858f0a50" ><script>var block_td_uid_15_6353a858f0a50 = new tdBlock();
block_td_uid_15_6353a858f0a50.id = "td_uid_15_6353a858f0a50";
block_td_uid_15_6353a858f0a50.atts = '{"limit":6,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_custom_related","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_15_6353a858f0a50_rand","offset":"","css":"","live_filter":"cur_post_same_tags","live_filter_cur_post_id":50777,"live_filter_cur_post_author":"1"}';
block_td_uid_15_6353a858f0a50.td_column_number = "3";
block_td_uid_15_6353a858f0a50.block_type = "td_block_related_posts";
block_td_uid_15_6353a858f0a50.post_count = "6";
block_td_uid_15_6353a858f0a50.found_posts = "27";
block_td_uid_15_6353a858f0a50.header_color = "";
block_td_uid_15_6353a858f0a50.ajax_pagination_infinite_stop = "";
block_td_uid_15_6353a858f0a50.max_num_pages = "5";
tdBlocksArray.push(block_td_uid_15_6353a858f0a50);
</script><h4 class="td-related-title"><a id="td_uid_16_6353a858f3bed" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_15_6353a858f0a50" href="#">RELATED ARTICLES</a><a id="td_uid_17_6353a858f3c4a" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_15_6353a858f0a50" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_15_6353a858f0a50 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/03/13/album-stream-bun-b-cory-mo-mo-trill/" rel="bookmark" title="Album Stream: Bun B &#038; Cory Mo &#8211; Mo Trill"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/PkW7ZOl.jpg" alt="" title="Album Stream: Bun B &#038; Cory Mo &#8211; Mo Trill"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/03/13/album-stream-bun-b-cory-mo-mo-trill/" rel="bookmark" title="Album Stream: Bun B &#038; Cory Mo &#8211; Mo Trill">Album Stream: Bun B &#038; Cory Mo &#8211; Mo Trill</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/12/12/music-video-lil-keke-ft-sauce-walka-slim-thug-z-ro-we-from-texas/" rel="bookmark" title="Music Video: Lil’ Keke ft. Sauce Walka, Slim Thug &#038; Z-Ro &#8211; We From Texas"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/mpFoIon.png" alt="" title="Music Video: Lil’ Keke ft. Sauce Walka, Slim Thug &#038; Z-Ro &#8211; We From Texas"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/12/12/music-video-lil-keke-ft-sauce-walka-slim-thug-z-ro-we-from-texas/" rel="bookmark" title="Music Video: Lil’ Keke ft. Sauce Walka, Slim Thug &#038; Z-Ro &#8211; We From Texas">Music Video: Lil’ Keke ft. Sauce Walka, Slim Thug &#038; Z-Ro &#8211; We From Texas</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/06/30/music-video-statik-selektah-termanology-ft-bun-b-stay-fly/" rel="bookmark" title="Music Video: Statik Selektah &#038; Termanology ft. Bun B &#8211; Stay Fly"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/kRE8SxM.jpg" alt="" title="Music Video: Statik Selektah &#038; Termanology ft. Bun B &#8211; Stay Fly"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/06/30/music-video-statik-selektah-termanology-ft-bun-b-stay-fly/" rel="bookmark" title="Music Video: Statik Selektah &#038; Termanology ft. Bun B &#8211; Stay Fly">Music Video: Statik Selektah &#038; Termanology ft. Bun B &#8211; Stay Fly</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid-->

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/05/25/music-video-bun-b-ft-big-k-r-i-t-trae-tha-truth-raheem-devaughn-this-world/" rel="bookmark" title="Music Video: Bun B ft Big K.R.I.T., Trae Tha Truth &#038; Raheem DeVaughn &#8211; This World"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/JAns7c6.jpg" alt="" title="Music Video: Bun B ft Big K.R.I.T., Trae Tha Truth &#038; Raheem DeVaughn &#8211; This World"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/05/25/music-video-bun-b-ft-big-k-r-i-t-trae-tha-truth-raheem-devaughn-this-world/" rel="bookmark" title="Music Video: Bun B ft Big K.R.I.T., Trae Tha Truth &#038; Raheem DeVaughn &#8211; This World">Music Video: Bun B ft Big K.R.I.T., Trae Tha Truth &#038; Raheem DeVaughn &#8211; This World</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/02/09/music-video-z-ro-make-it-bacc-home/" rel="bookmark" title="Music Video: Z-Ro &#8211; Make It Bacc Home"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/1cSNB1N.jpg" alt="" title="Music Video: Z-Ro &#8211; Make It Bacc Home"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/02/09/music-video-z-ro-make-it-bacc-home/" rel="bookmark" title="Music Video: Z-Ro &#8211; Make It Bacc Home">Music Video: Z-Ro &#8211; Make It Bacc Home</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2021/01/18/music-video-tobe-nwigwe-ft-bun-b-cyhi-pistol/" rel="bookmark" title="Music Video: Tobe Nwigwe ft. Bun B &#038; CyHi &#8211; Pistol"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/FGgfwrr.jpg" alt="" title="Music Video: Tobe Nwigwe ft. Bun B &#038; CyHi &#8211; Pistol"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2021/01/18/music-video-tobe-nwigwe-ft-bun-b-cyhi-pistol/" rel="bookmark" title="Music Video: Tobe Nwigwe ft. Bun B &#038; CyHi &#8211; Pistol">Music Video: Tobe Nwigwe ft. Bun B &#038; CyHi &#8211; Pistol</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_15_6353a858f0a50" data-td_block_id="td_uid_15_6353a858f0a50"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_15_6353a858f0a50" data-td_block_id="td_uid_15_6353a858f0a50"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->

	<div class="comments" id="comments">
            </div> <!-- /.content -->
                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <aside class="widget widget_search"><form method="get" class="td-search-form-widget" action="https://weuponithiphop.info/">
    <div role="search">
        <input class="td-widget-search-input" type="text" value="" name="s" id="s" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit" value="Search" />
    </div>
</form></aside><aside class="widget widget_text">			<div class="textwidget"><h4><strong><span style="color: #8224e3;"><span style="color: #000000;">Listen to</span> <span style="color: #c60000;">WeUpOnItRadio</span> <span style="color: #000000;">Live!</span></span></strong></h4>
<p><span class="cc_streaminfo" data-type="song" data-username="cyclone777">Loading &#8230;</span><br />
<script language="javascript" type="text/javascript" src="https://control.internet-radio.com:2199/system/streaminfo.js"></script></p>
<h3><a href="http://us5.internet-radio.com:8170/stream">Click to <span style="color: #ff0000;"> Listen</span> Live</a></h3>
</div>
		</aside>
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-sidebar ">
<script type="text/javascript">
var td_screen_width = document.body.clientWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6982270743726363" data-ad-slot="6593969875"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 

<aside class="widget widget_text"><div class="block-title"><span>DJ FLASH X OC FROM NC &#8211; ZION</span></div>			<div class="textwidget"><p><iframe title="DJ FLASH X OC FROM NC//" src="https://www.youtube.com/embed/SUSnJbfwDgM" frameborder="0" allowfullscreen=""></iframe></p>
</div>
		</aside><aside class="widget widget_text"><div class="block-title"><span>ethemadassassin &#8211; Jack Mack</span></div>			<div class="textwidget"><p><iframe src="https://www.youtube.com/embed/it2rU-hIIdA" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
</div>
		</aside>                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->


<!-- Instagram -->



<!-- Footer -->
<div class="td-footer-wrapper td-footer-template-3">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
			    		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span4">
                <div class="td-footer-info"><div class="footer-logo-wrap"><a href="https://weuponithiphop.info/"><img class="td-retina-data" src="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" data-retina="http://weuponithiphop.info/wp-content/uploads/weuponit-glow-logo-6.png" alt="" title=""/></a></div><div class="footer-text-wrap"></div><div class="footer-social-wrap td-social-style-2">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/weuponit" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://instagram.com/weuponit_com" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://pinterest.com/cycloneweuponit" title="Pinterest">
                <i class="td-icon-font td-icon-pinterest"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/weuponitdotcom" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div></div><aside class="widget widget_text">			<div class="textwidget"><div aria-live="polite" id="soliloquy-container-30342" class="soliloquy-container soliloquy-transition-fade  soliloquy-theme-classic" style="max-width:960px;max-height:300px;"><ul id="soliloquy-30342" class="soliloquy-slider soliloquy-slides soliloquy-wrap soliloquy-clear"><li aria-hidden="true" class="soliloquy-item soliloquy-item-1 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/youngongetthiswork?q=I12154011" class="soliloquy-link" title="You Gon Get This Work" target="_blank"><img id="soliloquy-image-30344" class="soliloquy-image soliloquy-image-1" src="https://weuponithiphop.info/wp-content/uploads/You-Gon-Get-This-Work.jpg" alt="You Gon Get This Work" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-2 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/savage+bloody?q=I1014473415" class="soliloquy-link" title="Savage Bloody" target="_blank"><img id="soliloquy-image-30343" class="soliloquy-image soliloquy-image-2" src="https://weuponithiphop.info/wp-content/uploads/Savage-Bloody.jpg" alt="Savage Bloody" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-3 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://freshandcleantees.myspreadshop.com/stacks?idea=5d89dcd713615160bf784eb2" class="soliloquy-link" title="stacks" target="_blank"><img id="soliloquy-image-49354" class="soliloquy-image soliloquy-image-3" src="https://weuponithiphop.info/wp-content/uploads/stacks.jpg" alt="stacks" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-4 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814012" class="soliloquy-link" title="Good Vibes Only 1" target="_blank"><img id="soliloquy-image-30346" class="soliloquy-image soliloquy-image-4" src="https://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-1.jpg" alt="Good Vibes Only 1" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-5 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://freshandcleantees.myspreadshop.com/hennythingispossible?idea=5d89dce76bbdbb2e6a508c03" class="soliloquy-link" title="henny thing" target="_blank"><img id="soliloquy-image-49353" class="soliloquy-image soliloquy-image-5" src="https://weuponithiphop.info/wp-content/uploads/henny-thing.jpg" alt="henny thing" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-6 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/good+vibes+only+birds?q=I1014476779" class="soliloquy-link" title="Good Vibes Only 2" target="_blank"><img id="soliloquy-image-30350" class="soliloquy-image soliloquy-image-6" src="https://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-2.jpg" alt="Good Vibes Only 2" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-7 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/diamond_skull_1?q=I12527492" class="soliloquy-link" title="Diamond Skull" target="_blank"><img id="soliloquy-image-30352" class="soliloquy-image soliloquy-image-7" src="https://weuponithiphop.info/wp-content/uploads/Diamond-Skull.jpg" alt="Diamond Skull" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-8 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://freshandcleantees.myspreadshop.com/double+cup+lyfe?idea=5d89dcd9b4b8c76e39206ce1" class="soliloquy-link" title="double cup" target="_blank"><img id="soliloquy-image-49352" class="soliloquy-image soliloquy-image-8" src="https://weuponithiphop.info/wp-content/uploads/double-cup.jpg" alt="double cup" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-9 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/crime+pays?q=I12067735" class="soliloquy-link" title="Crime Pays" target="_blank"><img id="soliloquy-image-30434" class="soliloquy-image soliloquy-image-9" src="https://weuponithiphop.info/wp-content/uploads/Crime-Pays.jpg" alt="Crime Pays" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-10 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/fuckyoupayme?q=I11550361" class="soliloquy-link" title="Fuck You Pay Me" target="_blank"><img id="soliloquy-image-30436" class="soliloquy-image soliloquy-image-10" src="https://weuponithiphop.info/wp-content/uploads/Fuck-You-Pay-Me.jpg" alt="Fuck You Pay Me" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-11 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814011" class="soliloquy-link" title="savage gold tee" target="_blank"><img id="soliloquy-image-30354" class="soliloquy-image soliloquy-image-11" src="https://weuponithiphop.info/wp-content/uploads/savage-gold-tee.jpg" alt="savage gold tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-12 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/?page=2" class="soliloquy-link" title="fresh-clean-signature-" target="_blank"><img id="soliloquy-image-30437" class="soliloquy-image soliloquy-image-12" src="https://weuponithiphop.info/wp-content/uploads/fresh-clean-signature-.jpg" alt="fresh-clean-signature-" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-13 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://freshandcleantees.myspreadshop.com/skull+%26+cross+bones+blue+plaid?idea=5d89dce7b4b8c76e39207181" class="soliloquy-link" title="blue skull and cross bones" target="_blank"><img id="soliloquy-image-49355" class="soliloquy-image soliloquy-image-13" src="https://weuponithiphop.info/wp-content/uploads/blue-skull-and-cross-bones.jpg" alt="blue skull and cross bones" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-14 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/soldier?q=I11611241" class="soliloquy-link" title="Swag Soldier" target="_blank"><img id="soliloquy-image-30435" class="soliloquy-image soliloquy-image-14" src="https://weuponithiphop.info/wp-content/uploads/Swag-Soldier.jpg" alt="Swag Soldier" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-15 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/gamer-A7923028?productType=210&#038;appearance=22" class="soliloquy-link" title="gamer" target="_blank"><img id="soliloquy-image-30438" class="soliloquy-image soliloquy-image-15" src="https://weuponithiphop.info/wp-content/uploads/gamer.jpg" alt="gamer" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-16 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://freshandcleantees.myspreadshop.com/peace?idea=5d89dcd82051762642177144" class="soliloquy-link" title="peace" target="_blank"><img id="soliloquy-image-49356" class="soliloquy-image soliloquy-image-16" src="https://weuponithiphop.info/wp-content/uploads/peace.jpg" alt="peace" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-17 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/" class="soliloquy-link" title="freshandlogo Square" target="_blank"><img id="soliloquy-image-30356" class="soliloquy-image soliloquy-image-17" src="https://weuponithiphop.info/wp-content/uploads/freshandlogo-Square.jpg" alt="freshandlogo Square" /></a></li></ul></div><noscript><style type="text/css">#soliloquy-container-30342{opacity:1}</style></noscript>
</div>
		</aside>            </div>

            <div class="td-pb-span4">
                <aside class="widget widget_calendar"><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar">
	<caption>October 2022</caption>
	<thead>
	<tr>
		<th scope="col" title="Sunday">S</th>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
	</tr>
	</thead>

	<tfoot>
	<tr>
		<td colspan="3" id="prev"><a href="https://weuponithiphop.info/2022/09/">&laquo; Sep</a></td>
		<td class="pad">&nbsp;</td>
		<td colspan="3" id="next" class="pad">&nbsp;</td>
	</tr>
	</tfoot>

	<tbody>
	<tr>
		<td colspan="6" class="pad">&nbsp;</td><td><a href="https://weuponithiphop.info/2022/10/01/" aria-label="Posts published on October 1, 2022">1</a></td>
	</tr>
	<tr>
		<td><a href="https://weuponithiphop.info/2022/10/02/" aria-label="Posts published on October 2, 2022">2</a></td><td><a href="https://weuponithiphop.info/2022/10/03/" aria-label="Posts published on October 3, 2022">3</a></td><td><a href="https://weuponithiphop.info/2022/10/04/" aria-label="Posts published on October 4, 2022">4</a></td><td><a href="https://weuponithiphop.info/2022/10/05/" aria-label="Posts published on October 5, 2022">5</a></td><td><a href="https://weuponithiphop.info/2022/10/06/" aria-label="Posts published on October 6, 2022">6</a></td><td><a href="https://weuponithiphop.info/2022/10/07/" aria-label="Posts published on October 7, 2022">7</a></td><td><a href="https://weuponithiphop.info/2022/10/08/" aria-label="Posts published on October 8, 2022">8</a></td>
	</tr>
	<tr>
		<td><a href="https://weuponithiphop.info/2022/10/09/" aria-label="Posts published on October 9, 2022">9</a></td><td><a href="https://weuponithiphop.info/2022/10/10/" aria-label="Posts published on October 10, 2022">10</a></td><td><a href="https://weuponithiphop.info/2022/10/11/" aria-label="Posts published on October 11, 2022">11</a></td><td><a href="https://weuponithiphop.info/2022/10/12/" aria-label="Posts published on October 12, 2022">12</a></td><td><a href="https://weuponithiphop.info/2022/10/13/" aria-label="Posts published on October 13, 2022">13</a></td><td><a href="https://weuponithiphop.info/2022/10/14/" aria-label="Posts published on October 14, 2022">14</a></td><td><a href="https://weuponithiphop.info/2022/10/15/" aria-label="Posts published on October 15, 2022">15</a></td>
	</tr>
	<tr>
		<td><a href="https://weuponithiphop.info/2022/10/16/" aria-label="Posts published on October 16, 2022">16</a></td><td><a href="https://weuponithiphop.info/2022/10/17/" aria-label="Posts published on October 17, 2022">17</a></td><td><a href="https://weuponithiphop.info/2022/10/18/" aria-label="Posts published on October 18, 2022">18</a></td><td><a href="https://weuponithiphop.info/2022/10/19/" aria-label="Posts published on October 19, 2022">19</a></td><td><a href="https://weuponithiphop.info/2022/10/20/" aria-label="Posts published on October 20, 2022">20</a></td><td><a href="https://weuponithiphop.info/2022/10/21/" aria-label="Posts published on October 21, 2022">21</a></td><td id="today"><a href="https://weuponithiphop.info/2022/10/22/" aria-label="Posts published on October 22, 2022">22</a></td>
	</tr>
	<tr>
		<td>23</td><td>24</td><td>25</td><td>26</td><td>27</td><td>28</td><td>29</td>
	</tr>
	<tr>
		<td>30</td><td>31</td>
		<td class="pad" colspan="5">&nbsp;</td>
	</tr>
	</tbody>
	</table></div></aside>            </div>

            <div class="td-pb-span4">
                <aside class="widget widget_text">			<div class="textwidget"><div aria-live="polite" id="soliloquy-container-30342" class="soliloquy-container soliloquy-transition-fade  soliloquy-theme-classic" style="max-width:960px;max-height:300px;"><ul id="soliloquy-30342" class="soliloquy-slider soliloquy-slides soliloquy-wrap soliloquy-clear"><li aria-hidden="true" class="soliloquy-item soliloquy-item-1 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/youngongetthiswork?q=I12154011" class="soliloquy-link" title="You Gon Get This Work" target="_blank"><img id="soliloquy-image-30344" class="soliloquy-image soliloquy-image-1" src="https://weuponithiphop.info/wp-content/uploads/You-Gon-Get-This-Work.jpg" alt="You Gon Get This Work" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-2 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/savage+bloody?q=I1014473415" class="soliloquy-link" title="Savage Bloody" target="_blank"><img id="soliloquy-image-30343" class="soliloquy-image soliloquy-image-2" src="https://weuponithiphop.info/wp-content/uploads/Savage-Bloody.jpg" alt="Savage Bloody" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-3 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://freshandcleantees.myspreadshop.com/stacks?idea=5d89dcd713615160bf784eb2" class="soliloquy-link" title="stacks" target="_blank"><img id="soliloquy-image-49354" class="soliloquy-image soliloquy-image-3" src="https://weuponithiphop.info/wp-content/uploads/stacks.jpg" alt="stacks" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-4 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814012" class="soliloquy-link" title="Good Vibes Only 1" target="_blank"><img id="soliloquy-image-30346" class="soliloquy-image soliloquy-image-4" src="https://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-1.jpg" alt="Good Vibes Only 1" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-5 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://freshandcleantees.myspreadshop.com/hennythingispossible?idea=5d89dce76bbdbb2e6a508c03" class="soliloquy-link" title="henny thing" target="_blank"><img id="soliloquy-image-49353" class="soliloquy-image soliloquy-image-5" src="https://weuponithiphop.info/wp-content/uploads/henny-thing.jpg" alt="henny thing" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-6 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/good+vibes+only+birds?q=I1014476779" class="soliloquy-link" title="Good Vibes Only 2" target="_blank"><img id="soliloquy-image-30350" class="soliloquy-image soliloquy-image-6" src="https://weuponithiphop.info/wp-content/uploads/Good-Vibes-Only-2.jpg" alt="Good Vibes Only 2" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-7 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/diamond_skull_1?q=I12527492" class="soliloquy-link" title="Diamond Skull" target="_blank"><img id="soliloquy-image-30352" class="soliloquy-image soliloquy-image-7" src="https://weuponithiphop.info/wp-content/uploads/Diamond-Skull.jpg" alt="Diamond Skull" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-8 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://freshandcleantees.myspreadshop.com/double+cup+lyfe?idea=5d89dcd9b4b8c76e39206ce1" class="soliloquy-link" title="double cup" target="_blank"><img id="soliloquy-image-49352" class="soliloquy-image soliloquy-image-8" src="https://weuponithiphop.info/wp-content/uploads/double-cup.jpg" alt="double cup" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-9 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/crime+pays?q=I12067735" class="soliloquy-link" title="Crime Pays" target="_blank"><img id="soliloquy-image-30434" class="soliloquy-image soliloquy-image-9" src="https://weuponithiphop.info/wp-content/uploads/Crime-Pays.jpg" alt="Crime Pays" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-10 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/fuckyoupayme?q=I11550361" class="soliloquy-link" title="Fuck You Pay Me" target="_blank"><img id="soliloquy-image-30436" class="soliloquy-image soliloquy-image-10" src="https://weuponithiphop.info/wp-content/uploads/Fuck-You-Pay-Me.jpg" alt="Fuck You Pay Me" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-11 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/-A109814011" class="soliloquy-link" title="savage gold tee" target="_blank"><img id="soliloquy-image-30354" class="soliloquy-image soliloquy-image-11" src="https://weuponithiphop.info/wp-content/uploads/savage-gold-tee.jpg" alt="savage gold tee" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-12 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/?page=2" class="soliloquy-link" title="fresh-clean-signature-" target="_blank"><img id="soliloquy-image-30437" class="soliloquy-image soliloquy-image-12" src="https://weuponithiphop.info/wp-content/uploads/fresh-clean-signature-.jpg" alt="fresh-clean-signature-" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-13 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://freshandcleantees.myspreadshop.com/skull+%26+cross+bones+blue+plaid?idea=5d89dce7b4b8c76e39207181" class="soliloquy-link" title="blue skull and cross bones" target="_blank"><img id="soliloquy-image-49355" class="soliloquy-image soliloquy-image-13" src="https://weuponithiphop.info/wp-content/uploads/blue-skull-and-cross-bones.jpg" alt="blue skull and cross bones" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-14 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/soldier?q=I11611241" class="soliloquy-link" title="Swag Soldier" target="_blank"><img id="soliloquy-image-30435" class="soliloquy-image soliloquy-image-14" src="https://weuponithiphop.info/wp-content/uploads/Swag-Soldier.jpg" alt="Swag Soldier" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-15 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/gamer-A7923028?productType=210&#038;appearance=22" class="soliloquy-link" title="gamer" target="_blank"><img id="soliloquy-image-30438" class="soliloquy-image soliloquy-image-15" src="https://weuponithiphop.info/wp-content/uploads/gamer.jpg" alt="gamer" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-16 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://freshandcleantees.myspreadshop.com/peace?idea=5d89dcd82051762642177144" class="soliloquy-link" title="peace" target="_blank"><img id="soliloquy-image-49356" class="soliloquy-image soliloquy-image-16" src="https://weuponithiphop.info/wp-content/uploads/peace.jpg" alt="peace" /></a></li><li aria-hidden="true" class="soliloquy-item soliloquy-item-17 soliloquy-image-slide" draggable="false" style="list-style:none"><a href="https://shop.spreadshirt.com/freshandcleantees/" class="soliloquy-link" title="freshandlogo Square" target="_blank"><img id="soliloquy-image-30356" class="soliloquy-image soliloquy-image-17" src="https://weuponithiphop.info/wp-content/uploads/freshandlogo-Square.jpg" alt="freshandlogo Square" /></a></li></ul></div><noscript><style type="text/css">#soliloquy-container-30342{opacity:1}</style></noscript>
</div>
		</aside>            </div>
        </div>
    </div>
</div>

<!-- Sub Footer -->
    <div class="td-sub-footer-container">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span7 td-sub-footer-menu">
                        <div class="menu-top-menu-container"><ul id="menu-top-menu-2" class="td-subfooter-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-mega-menu menu-item-317"><a href="https://weuponithiphop.info/category/new-music/">New Music</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_20_6353a85916b8b_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_20_6353a85916b8b" ><script>var block_td_uid_20_6353a85916b8b = new tdBlock();
block_td_uid_20_6353a85916b8b.id = "td_uid_20_6353a85916b8b";
block_td_uid_20_6353a85916b8b.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"43","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_20_6353a85916b8b_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_20_6353a85916b8b.td_column_number = "3";
block_td_uid_20_6353a85916b8b.block_type = "td_block_mega_menu";
block_td_uid_20_6353a85916b8b.post_count = "5";
block_td_uid_20_6353a85916b8b.found_posts = "4492";
block_td_uid_20_6353a85916b8b.header_color = "";
block_td_uid_20_6353a85916b8b.ajax_pagination_infinite_stop = "";
block_td_uid_20_6353a85916b8b.max_num_pages = "899";
tdBlocksArray.push(block_td_uid_20_6353a85916b8b);
</script><div id=td_uid_20_6353a85916b8b class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/21/new-music-french-montana-ft-nav-fenty/" rel="bookmark" title="New Music: French Montana ft. NAV &#8211; Fenty"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/tKNqW5u.jpg" alt="" title="New Music: French Montana ft. NAV &#8211; Fenty"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/21/new-music-french-montana-ft-nav-fenty/" rel="bookmark" title="New Music: French Montana ft. NAV &#8211; Fenty">New Music: French Montana ft. NAV &#8211; Fenty</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/21/new-music-a-boogie-wit-da-hoodie-ft-tory-lanez-take-shots/" rel="bookmark" title="New Music: A Boogie Wit Da Hoodie ft. Tory Lanez &#8211; Take Shots"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/amE1LE6.jpg" alt="" title="New Music: A Boogie Wit Da Hoodie ft. Tory Lanez &#8211; Take Shots"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/21/new-music-a-boogie-wit-da-hoodie-ft-tory-lanez-take-shots/" rel="bookmark" title="New Music: A Boogie Wit Da Hoodie ft. Tory Lanez &#8211; Take Shots">New Music: A Boogie Wit Da Hoodie ft. Tory Lanez &#8211;&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/20/new-music-smino-matinee/" rel="bookmark" title="New Music: Smino &#8211; Matinee"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/zEKt1Rq.jpg" alt="" title="New Music: Smino &#8211; Matinee"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/20/new-music-smino-matinee/" rel="bookmark" title="New Music: Smino &#8211; Matinee">New Music: Smino &#8211; Matinee</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/20/new-music-pivot-gang-aang/" rel="bookmark" title="New Music: Pivot Gang &#8211; Aang"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/Mw7qAqm.jpg" alt="" title="New Music: Pivot Gang &#8211; Aang"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/20/new-music-pivot-gang-aang/" rel="bookmark" title="New Music: Pivot Gang &#8211; Aang">New Music: Pivot Gang &#8211; Aang</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/19/new-music-armani-caesar-ft-kodak-black-diana/" rel="bookmark" title="New Music: Armani Caesar ft. Kodak Black &#8211; Diana"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/QcrlzKE.jpg" alt="" title="New Music: Armani Caesar ft. Kodak Black &#8211; Diana"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/19/new-music-armani-caesar-ft-kodak-black-diana/" rel="bookmark" title="New Music: Armani Caesar ft. Kodak Black &#8211; Diana">New Music: Armani Caesar ft. Kodak Black &#8211; Diana</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_20_6353a85916b8b" data-td_block_id="td_uid_20_6353a85916b8b"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_20_6353a85916b8b" data-td_block_id="td_uid_20_6353a85916b8b"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-706"><a href="https://weuponithiphop.info/category/album-stream-mixtapes/">Album Stream</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_21_6353a8592427d_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_21_6353a8592427d" ><script>var block_td_uid_21_6353a8592427d = new tdBlock();
block_td_uid_21_6353a8592427d.id = "td_uid_21_6353a8592427d";
block_td_uid_21_6353a8592427d.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"97","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_21_6353a8592427d_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_21_6353a8592427d.td_column_number = "3";
block_td_uid_21_6353a8592427d.block_type = "td_block_mega_menu";
block_td_uid_21_6353a8592427d.post_count = "5";
block_td_uid_21_6353a8592427d.found_posts = "1709";
block_td_uid_21_6353a8592427d.header_color = "";
block_td_uid_21_6353a8592427d.ajax_pagination_infinite_stop = "";
block_td_uid_21_6353a8592427d.max_num_pages = "342";
tdBlocksArray.push(block_td_uid_21_6353a8592427d);
</script><div id=td_uid_21_6353a8592427d class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/21/album-stream-nba-youngboy-ma-i-got-a-family/" rel="bookmark" title="Album Stream: NBA YoungBoy &#8211; Ma’ I Got A Family"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/AO1i9uf.jpg" alt="" title="Album Stream: NBA YoungBoy &#8211; Ma’ I Got A Family"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/21/album-stream-nba-youngboy-ma-i-got-a-family/" rel="bookmark" title="Album Stream: NBA YoungBoy &#8211; Ma’ I Got A Family">Album Stream: NBA YoungBoy &#8211; Ma’ I Got A Family</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/21/album-stream-armani-caesar-the-liz-2/" rel="bookmark" title="Album Stream: Armani Caesar &#8211; The Liz 2"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/QAauC5D.jpg" alt="" title="Album Stream: Armani Caesar &#8211; The Liz 2"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/21/album-stream-armani-caesar-the-liz-2/" rel="bookmark" title="Album Stream: Armani Caesar &#8211; The Liz 2">Album Stream: Armani Caesar &#8211; The Liz 2</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/21/album-stream-jeezy-dj-drama-snofall/" rel="bookmark" title="Album Stream: Jeezy &#038; DJ Drama &#8211; SNOFALL"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/F0Zo3Oq.jpg" alt="" title="Album Stream: Jeezy &#038; DJ Drama &#8211; SNOFALL"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/21/album-stream-jeezy-dj-drama-snofall/" rel="bookmark" title="Album Stream: Jeezy &#038; DJ Drama &#8211; SNOFALL">Album Stream: Jeezy &#038; DJ Drama &#8211; SNOFALL</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/20/mixtape-snoop-dogg-i-still-got-it/" rel="bookmark" title="Mixtape: Snoop Dogg &#8211; I Still Got It"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/uyq601a.png" alt="" title="Mixtape: Snoop Dogg &#8211; I Still Got It"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/20/mixtape-snoop-dogg-i-still-got-it/" rel="bookmark" title="Mixtape: Snoop Dogg &#8211; I Still Got It">Mixtape: Snoop Dogg &#8211; I Still Got It</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/16/ep-stream-day-sulan-crazy-girls/" rel="bookmark" title="EP Stream: Day Sulan &#8211; Crazy Girls"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/MQWCpbx.jpg" alt="" title="EP Stream: Day Sulan &#8211; Crazy Girls"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/16/ep-stream-day-sulan-crazy-girls/" rel="bookmark" title="EP Stream: Day Sulan &#8211; Crazy Girls">EP Stream: Day Sulan &#8211; Crazy Girls</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_21_6353a8592427d" data-td_block_id="td_uid_21_6353a8592427d"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_21_6353a8592427d" data-td_block_id="td_uid_21_6353a8592427d"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-314"><a href="https://weuponithiphop.info/category/music-video/">Videos</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_22_6353a8592d00b_rand td-no-subcats td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_22_6353a8592d00b" ><script>var block_td_uid_22_6353a8592d00b = new tdBlock();
block_td_uid_22_6353a8592d00b.id = "td_uid_22_6353a8592d00b";
block_td_uid_22_6353a8592d00b.atts = '{"limit":"5","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"2","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_22_6353a8592d00b_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_22_6353a8592d00b.td_column_number = "3";
block_td_uid_22_6353a8592d00b.block_type = "td_block_mega_menu";
block_td_uid_22_6353a8592d00b.post_count = "5";
block_td_uid_22_6353a8592d00b.found_posts = "5748";
block_td_uid_22_6353a8592d00b.header_color = "";
block_td_uid_22_6353a8592d00b.ajax_pagination_infinite_stop = "";
block_td_uid_22_6353a8592d00b.max_num_pages = "1150";
tdBlocksArray.push(block_td_uid_22_6353a8592d00b);
</script><div id=td_uid_22_6353a8592d00b class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/22/music-video-icewear-vezzo-ft-babyface-ray-god-bless-the-6/" rel="bookmark" title="Music Video: Icewear Vezzo ft. Babyface Ray &#8211; God Bless The 6"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/J2kskOI.jpg" alt="" title="Music Video: Icewear Vezzo ft. Babyface Ray &#8211; God Bless The 6"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/22/music-video-icewear-vezzo-ft-babyface-ray-god-bless-the-6/" rel="bookmark" title="Music Video: Icewear Vezzo ft. Babyface Ray &#8211; God Bless The 6">Music Video: Icewear Vezzo ft. Babyface Ray &#8211; God Bless The&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/22/music-video-bun-b-cory-mo-ft-z-ro-the-geto/" rel="bookmark" title="Music Video: Bun B &#038; Cory Mo ft. Z-Ro &#8211; The Geto"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/t0kad81.jpg" alt="" title="Music Video: Bun B &#038; Cory Mo ft. Z-Ro &#8211; The Geto"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/22/music-video-bun-b-cory-mo-ft-z-ro-the-geto/" rel="bookmark" title="Music Video: Bun B &#038; Cory Mo ft. Z-Ro &#8211; The Geto">Music Video: Bun B &#038; Cory Mo ft. Z-Ro &#8211; The&#8230;</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/21/music-video-roddy-ricch-aston-martin-truck/" rel="bookmark" title="Music Video: Roddy Ricch &#8211; Aston Martin Truck"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/uUkdrLr.jpg" alt="" title="Music Video: Roddy Ricch &#8211; Aston Martin Truck"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/21/music-video-roddy-ricch-aston-martin-truck/" rel="bookmark" title="Music Video: Roddy Ricch &#8211; Aston Martin Truck">Music Video: Roddy Ricch &#8211; Aston Martin Truck</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/21/music-video-ab-soul-ft-zacari-do-better/" rel="bookmark" title="Music Video: Ab-Soul ft. Zacari &#8211; Do Better"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/vsOPSJQ.jpg" alt="" title="Music Video: Ab-Soul ft. Zacari &#8211; Do Better"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/21/music-video-ab-soul-ft-zacari-do-better/" rel="bookmark" title="Music Video: Ab-Soul ft. Zacari &#8211; Do Better">Music Video: Ab-Soul ft. Zacari &#8211; Do Better</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/20/music-video-hit-boy-ft-curreny-tony-fontana-iii/" rel="bookmark" title="Music Video: Hit-Boy ft. Curren$y &#8211; Tony Fontana III"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/IW2LiIR.jpg" alt="" title="Music Video: Hit-Boy ft. Curren$y &#8211; Tony Fontana III"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/20/music-video-hit-boy-ft-curreny-tony-fontana-iii/" rel="bookmark" title="Music Video: Hit-Boy ft. Curren$y &#8211; Tony Fontana III">Music Video: Hit-Boy ft. Curren$y &#8211; Tony Fontana III</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_22_6353a8592d00b" data-td_block_id="td_uid_22_6353a8592d00b"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_22_6353a8592d00b" data-td_block_id="td_uid_22_6353a8592d00b"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-316"><a href="https://weuponithiphop.info/category/latest-news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_23_6353a8593ac87_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_23_6353a8593ac87" ><script>var block_td_uid_23_6353a8593ac87 = new tdBlock();
block_td_uid_23_6353a8593ac87.id = "td_uid_23_6353a8593ac87";
block_td_uid_23_6353a8593ac87.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"29","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_23_6353a8593ac87_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_23_6353a8593ac87.td_column_number = "3";
block_td_uid_23_6353a8593ac87.block_type = "td_block_mega_menu";
block_td_uid_23_6353a8593ac87.post_count = "4";
block_td_uid_23_6353a8593ac87.found_posts = "1172";
block_td_uid_23_6353a8593ac87.header_color = "";
block_td_uid_23_6353a8593ac87.ajax_pagination_infinite_stop = "";
block_td_uid_23_6353a8593ac87.max_num_pages = "293";
tdBlocksArray.push(block_td_uid_23_6353a8593ac87);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_23_6353a8593ac87" id="td_uid_24_6353a8593fbb4" data-td_block_id="td_uid_23_6353a8593ac87" data-td_filter_value="" href="https://weuponithiphop.info/category/latest-news/">All</a><a class="mega-menu-sub-cat-td_uid_23_6353a8593ac87"  id="td_uid_25_6353a8593fd33" data-td_block_id="td_uid_23_6353a8593ac87" data-td_filter_value="69" href="https://weuponithiphop.info/category/latest-news/album-news/">Album News</a><a class="mega-menu-sub-cat-td_uid_23_6353a8593ac87"  id="td_uid_26_6353a8593ffbc" data-td_block_id="td_uid_23_6353a8593ac87" data-td_filter_value="80" href="https://weuponithiphop.info/category/latest-news/behind-the-scenes/">Behind The Scenes</a><a class="mega-menu-sub-cat-td_uid_23_6353a8593ac87"  id="td_uid_27_6353a859401d8" data-td_block_id="td_uid_23_6353a8593ac87" data-td_filter_value="2189" href="https://weuponithiphop.info/category/latest-news/flashback/">Flashback</a><a class="mega-menu-sub-cat-td_uid_23_6353a8593ac87"  id="td_uid_28_6353a85940443" data-td_block_id="td_uid_23_6353a8593ac87" data-td_filter_value="10" href="https://weuponithiphop.info/category/latest-news/interviews/">Interviews</a><a class="mega-menu-sub-cat-td_uid_23_6353a8593ac87"  id="td_uid_29_6353a8594062c" data-td_block_id="td_uid_23_6353a8593ac87" data-td_filter_value="130" href="https://weuponithiphop.info/category/latest-news/tour-info/">Tour Info</a></div></div><div id=td_uid_23_6353a8593ac87 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/20/video-freddie-gibbs-l-a-leakers-freestyle-2/" rel="bookmark" title="Video: Freddie Gibbs &#8211; L.A. Leakers Freestyle"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/1eKuThs.jpg" alt="" title="Video: Freddie Gibbs &#8211; L.A. Leakers Freestyle"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/20/video-freddie-gibbs-l-a-leakers-freestyle-2/" rel="bookmark" title="Video: Freddie Gibbs &#8211; L.A. Leakers Freestyle">Video: Freddie Gibbs &#8211; L.A. Leakers Freestyle</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/13/video-lil-baby-funkmaster-flex-freestyle/" rel="bookmark" title="Video: Lil Baby &#8211; Funkmaster Flex Freestyle"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/6bjOjrU.jpg" alt="" title="Video: Lil Baby &#8211; Funkmaster Flex Freestyle"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/13/video-lil-baby-funkmaster-flex-freestyle/" rel="bookmark" title="Video: Lil Baby &#8211; Funkmaster Flex Freestyle">Video: Lil Baby &#8211; Funkmaster Flex Freestyle</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/05/bet-hip-hop-awards-2022-winners-performances/" rel="bookmark" title="BET Hip Hop Awards 2022 Winners &#038; Performances"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/vmClh9C.jpg" alt="" title="BET Hip Hop Awards 2022 Winners &#038; Performances"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/05/bet-hip-hop-awards-2022-winners-performances/" rel="bookmark" title="BET Hip Hop Awards 2022 Winners &#038; Performances">BET Hip Hop Awards 2022 Winners &#038; Performances</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2022/10/03/video-beyonce-tiffany-co-lose-yourself-in-love-with-summer-renaissance-ad/" rel="bookmark" title="Video: Beyonce &#038; Tiffany &#038; Co. &#8211; Lose Yourself In Love with Summer Renaissance Ad"><img width="218" height="150" class="entry-thumb" src="https://i.imgur.com/mIVSQhq.jpg" alt="" title="Video: Beyonce &#038; Tiffany &#038; Co. &#8211; Lose Yourself In Love with Summer Renaissance Ad"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2022/10/03/video-beyonce-tiffany-co-lose-yourself-in-love-with-summer-renaissance-ad/" rel="bookmark" title="Video: Beyonce &#038; Tiffany &#038; Co. &#8211; Lose Yourself In Love with Summer Renaissance Ad">Video: Beyonce &#038; Tiffany &#038; Co. &#8211; Lose Yourself In Love&#8230;</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_23_6353a8593ac87" data-td_block_id="td_uid_23_6353a8593ac87"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_23_6353a8593ac87" data-td_block_id="td_uid_23_6353a8593ac87"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-705"><a href="https://weuponithiphop.info/category/fashion/">Fashion</a>
<ul class="sub-menu">
	<li class="menu-item-0"><a><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_30_6353a8595ddb2_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_30_6353a8595ddb2" ><script>var block_td_uid_30_6353a8595ddb2 = new tdBlock();
block_td_uid_30_6353a8595ddb2.id = "td_uid_30_6353a8595ddb2";
block_td_uid_30_6353a8595ddb2.atts = '{"limit":4,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"77","category_ids":"","custom_title":"","custom_url":"","show_child_cat":30,"sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"preload","td_ajax_filter_type":"td_category_ids_filter","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_30_6353a8595ddb2_rand","offset":"","css":"","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_30_6353a8595ddb2.td_column_number = "3";
block_td_uid_30_6353a8595ddb2.block_type = "td_block_mega_menu";
block_td_uid_30_6353a8595ddb2.post_count = "4";
block_td_uid_30_6353a8595ddb2.found_posts = "158";
block_td_uid_30_6353a8595ddb2.header_color = "";
block_td_uid_30_6353a8595ddb2.ajax_pagination_infinite_stop = "";
block_td_uid_30_6353a8595ddb2.max_num_pages = "40";
tdBlocksArray.push(block_td_uid_30_6353a8595ddb2);
</script>            <script>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</script>
            <div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_30_6353a8595ddb2" id="td_uid_31_6353a8595f92a" data-td_block_id="td_uid_30_6353a8595ddb2" data-td_filter_value="" href="https://weuponithiphop.info/category/fashion/">All</a><a class="mega-menu-sub-cat-td_uid_30_6353a8595ddb2"  id="td_uid_32_6353a8595fab0" data-td_block_id="td_uid_30_6353a8595ddb2" data-td_filter_value="76" href="https://weuponithiphop.info/category/fashion/kicks/">Kicks</a></div></div><div id=td_uid_30_6353a8595ddb2 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/LVT4Mid8WL4wHUdO9X2OZmZxxgbREs2lVtszOdEBaO6hJB0JS3yQOAyhNSdCyPmv0amBDTgNGpOlRPXPjKCl6yIlo2joyH3rQRI7CUdX09BJtQI1r5jy1_7BQtDhw4AxUhpUwIh35rNS3lTy7uq-FdPff10JN6srr9mwZ7zr04GQFxBVEXwCfC5rNVehXhY_wGCRVsmevYmdkBWEmB8dvOzBHY78NBBjcHNArS_S-2M0FJgDh8v9m9vEh78k_XmZg-AERctsf0bkODuPi1EcNJq_RnJIV6b0GG-VtKjo-OVPmYghWJYf1HiP9c58cQ98oABU8BDFdLqsBtNt4K0NmyHYQlX39W9k_d83wEHZ1-EacQa2o01VrYSn12HnZ1l88fMzu9PKv6EGmcRZNwpepycW7_9EQnhxIPDdVCmRLXUasUED9OXr-zJmnBcnSnLCa06k1ZymQym1LiSFEv1c3aPHnmnD3GY8nL7q5jPJr4HsABR0WCqMebcF3HF_0deNd0zgRBCGMxW-VzlIIHZiHuBeSPEPvUL149GJ5swSSvKm1uGEi1HlLBj9omJSU7mDWzO0p_7l-l7-4_ureEsGsgB8cX1t8t2TQcFeRgqqF1CXlZFYYC2K0iMb4jPsijsw_rtO7pmKvbngqHfgYpGeh_qLmDWeicR7=w1195-h796-no" alt="" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2019/05/05/will-smith-to-release-limited-fresh-prince-of-bel-air-merch/" rel="bookmark" title="Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch">Will Smith To Release Limited &#8216;Fresh Prince of Bel-Air&#8217; Merch</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/fHEwwMf8DoiXlqkfibQS1Z1XXbviORbV9raaI44tOTXrWo7GgqM3gA-vswE10gFtTQUGGwNG7nWAACwHjxPuiubliYBN_dqtBZh2WIpxvumiJ-hSLK0TNWB2cB8Iw2STT5gcp_KqlDh_e4xng1vidI8EXdp_ooh5uDI-JV1HQ9dGnM5nxl_b-v8znqj-Rl_mGB7y4Lu9zsFNWHU7SriqQQJaKrKEEnb9T8zxmGLaL0zq7ilYpnUEhWulDDr9xc82wdr__WzRBm5YEskVpDAnGM2NDZwTZpjbe4QDdxeixWnSXNK_oDzaL7WTbCpkD33OK88BlI5JmFRQ5VmD11UQ2htB7-9WoahHvb4XmBsbLXpEMl1JmEP4sPx06VduzFnBNo-J90WI0n1AEIIcEYVbRywrkGJXbzmH__In9ZIg0EV24OcGGbeKl12HxTdZwucqsNnuZeNjiMHISQ7i8cfzm3N7X7Zenl74zsKIKeKWoIGxh6MTlVADvgHcrHebnjcSgil2vBeFyz_AP45aOv9SOwbzfVLGS0CNfe1s9b2J7qZgjcBk9QPEXCl2kygvzmGXFvU_3xBuW6S0i3Vkh3Ha_3hPBtvIAy3WoTK2yiqS41HzSK7yk3FRAlBtpIEib338fdkTiosBxtdu36SdNUVM75zl6CVIFhTu=w681-h470-no" alt="" title="Air Jordan 14 Rip Hamilton"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2019/03/18/air-jordan-14-rip-hamilton/" rel="bookmark" title="Air Jordan 14 Rip Hamilton">Air Jordan 14 Rip Hamilton</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/kUjaOYxjEkAh34S-Ub2QSZwdOwHyFnGFLBZULta3_bn1_myPMAwJXiEEsAAtc1ktCQwHCuKhSqSYsWXFBEIZxdfKuykoDEZWwO-dDI3_JeAshbYvyILEHUu0XaUpRn0mj7gOx10V52t8gRGYPCW7QXGImkPGGhvBPzBDVVqh9lKGtkuPeePmTnpRSmwp0LG1WHcIzUWnMqPBWQeHAat6Q-Tq7niXNb96ddEZsMEdHK1nmHVlNaeqFBNtTxk6yYRkFNCvtfBayqy-Rqt4CPU5tThxbTI4AIUCI6JLxJd_VJizrVNDEe2xZ_tiQdkC5ASIoHpX8sfvAB8zRUsMVJ6oMUt5FH_4GBNXDCtFRmr65Qt0JV1h4bBJffu2L272Q_vpD76wn-YNGW8VCtZcheHu_X-A4gdYQEC0HN0BenY-MOuUBqKEjXAc0SxWeP7W9RN55jlqUFK0nzEYydVjec2stdQIngVfg_FvKxvHXfM4XdtMpqeJnp3Pzyk8xjz30sAZd0f2HQ6zfdPjk-OkV2-WrC0_qW0L8Rq3zrUbq52n3BN7gm7sctU_CUlBmoQIgJDQBYk1Siv4tfSq9pL1R4GdaOlWQdxEuhZi8bTYC8GGAgNGl3SMAZGvk7nu6QnnwEZjZ7mZwbcqgyRKa89cOREMUvIkVJ8Q8lZu=w926-h672-no" alt="" title="Jordan Proto React Triple White"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2019/03/18/jordan-proto-react-triple-white/" rel="bookmark" title="Jordan Proto React Triple White">Jordan Proto React Triple White</a></h3>            </div>
        </div>
        </div><div class="td-mega-span">
        <div class="td_module_mega_menu td_mod_mega_menu">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace"><img width="218" height="150" class="entry-thumb" src="https://lh3.googleusercontent.com/4cDUjSODZSaXWfHyZKb9q3Fn7FHA4uB0KSBs0MtFHC0dc6AJb1zeAl_X2LOKalK9C7VBFhTqRQ9fw1ESgUr9ZUKFbOzD94i_s96nvkICOqrsYnzrE2nEAQHoEaGOF4O8GAI6T4CGFbgcQhNzjpRlSY60NyPu5Cmq81FRpEOFRzTOtSa_NnWzMmfwO0yxtPbcg5U6YBUsus8shv3SA7CjULLfaP38nZAuWVgq8PMaaeCQ_eSrK8NJSEVQjyyxmqb-1I7zO8Kvvzvwi--ibMr52CF8h-GusBzSq5ZuzvZRCGu_u8CyfoXw7pwWbOmHnLOdcQ9d2PCSW_IxEMGfmEuU7NxMSsW3Ga4r35_wLB7cjvlPC9OjCV50tfekXjZBS_476mzlf4G9jR7Ju1GqgjXah9Uqc_0Y8N-Br8_JCtIlRSuLxAiebwd7AvFVlgWId9MYxBWnRT3cTyD8SH7q5WwO-CIbKAOSKsNcrrTgFxQvqn9yklBU1u5X5fdTlTBk4WSYorsWZAug0z9BOymRLnrhTbnA0vpBPFROWD-aL1glg-eUpFSfgD4xhWsOqJNY9krQ2UbLSGXQ5gYWj0ovLS7Yz3UKFY2qrVWpqkpbfyN98es9NJ-7LTUs2MLq1rX_2FaQmyq5mVndd7VGzQOHy9hDULG-5H-0LvGd=w900-h566-no" alt="" title="adidas Yeezy Boost 350 V2 Hyperspace"/></a></div>                            </div>

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://weuponithiphop.info/2019/03/11/adidas-yeezy-boost-350-v2-hyperspace-9495689/" rel="bookmark" title="adidas Yeezy Boost 350 V2 Hyperspace">adidas Yeezy Boost 350 V2 Hyperspace</a></h3>            </div>
        </div>
        </div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_30_6353a8595ddb2" data-td_block_id="td_uid_30_6353a8595ddb2"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_30_6353a8595ddb2" data-td_block_id="td_uid_30_6353a8595ddb2"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div> <!-- ./block1 --></div></div></a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-18581"><a href="https://weuponithiphop.info/artists-promotion/">Artists Promotion</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3199"><a href="https://shop.spreadshirt.com/freshandcleantees">Shop</a></li>
</ul></div>                </div>

                <div class="td-pb-span5 td-sub-footer-copy">
                    &copy; 2018 The Hip Hop Chronicles Media Group                </div>
            </div>
        </div>
    </div>
</div><!--close td-outer-wrap-->



    <!--

        Theme: Newspaper by tagDiv 2016
        Version: 7.2 (rara)
        Deploy mode: deploy
        
        uid: 6353a8596aaba
    -->

    <link rel='stylesheet' id='soliloquy-lite-style-css'  href='https://weuponithiphop.info/wp-content/plugins/soliloquy-lite/assets/css/soliloquy.css?ver=2.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='soliloquy-liteclassic-theme-css'  href='https://weuponithiphop.info/wp-content/plugins/soliloquy-lite/themes/classic/style.css?ver=2.6.2' type='text/css' media='all' />
<script type='text/javascript' src='https://weuponithiphop.info/wp-content/themes/Newspaper/js/tagdiv_theme.js?ver=7.2'></script>
<script type='text/javascript' src='https://weuponithiphop.info/wp-includes/js/comment-reply.min.js?ver=4.9.22'></script>
<script type='text/javascript'>
function heateorSssLoadEvent(e) {var t=window.onload;if (typeof window.onload!="function") {window.onload=e}else{window.onload=function() {t();e()}}};	var heateorSssSharingAjaxUrl = 'https://weuponithiphop.info/wp-admin/admin-ajax.php', heateorSssCloseIconPath = 'https://weuponithiphop.info/wp-content/plugins/sassy-social-share/public/../images/close.png', heateorSssPluginIconPath = 'https://weuponithiphop.info/wp-content/plugins/sassy-social-share/public/../images/logo.png', heateorSssHorizontalSharingCountEnable = 0, heateorSssVerticalSharingCountEnable = 0, heateorSssSharingOffset = -10; var heateorSssMobileStickySharingEnabled = 0;var heateorSssCopyLinkMessage = "Link copied.";var heateorSssUrlCountFetched = [], heateorSssSharesText = 'Shares', heateorSssShareText = 'Share';function heateorSssPopup(e) {window.open(e,"popUpWindow","height=400,width=600,left=400,top=100,resizable,scrollbars,toolbar=0,personalbar=0,menubar=no,location=no,directories=no,status")}
</script>
<script type='text/javascript' src='https://weuponithiphop.info/wp-content/plugins/sassy-social-share/public/js/sassy-social-share-public.js?ver=3.3.43'></script>
<script type='text/javascript' src='https://weuponithiphop.info/wp-includes/js/wp-embed.min.js?ver=4.9.22'></script>
<script type='text/javascript' src='https://weuponithiphop.info/wp-content/plugins/soliloquy-lite/assets/js/min/soliloquy-min.js?ver=2.6.2'></script>

<!-- JS generated by theme -->

<script>
    


            

	            // if the theme has tdBackstr support, it means this already uses it
                if ( 'undefined' !== typeof window.tdBackstr ) {

                    (function(){
                        // the site background td-backstretch jquery object is dynamically added in DOM, and after any translation effects are applied over td-backstretch
                        var wrapper_image_jquery_obj = jQuery( '<div class=\'backstretch\'></div>' );
                        var image_jquery_obj = jQuery( '<img class=\'td-backstretch not-parallax\' src=\'http://weuponithiphop.info/wp-content/uploads/20-black-paper-different-texture-types-a4-sandgrain-.jpg\'>' );

                        wrapper_image_jquery_obj.append( image_jquery_obj );

                        jQuery( 'body' ).prepend( wrapper_image_jquery_obj );

                        var td_backstr_item = new tdBackstr.item();

                        td_backstr_item.wrapper_image_jquery_obj = wrapper_image_jquery_obj;
                        td_backstr_item.image_jquery_obj = image_jquery_obj;

	                    tdBackstr.add_item( td_backstr_item );

                    })();
                }

            
            

                jQuery().ready(function jQuery_ready() {
                    tdAjaxCount.tdGetViewsCountsAjax("post","[50777]");
                });
            

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://weuponithiphop.info/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://weuponithiphop.info/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>

			<script type="text/javascript">
			if ( typeof soliloquy_slider === 'undefined' || false === soliloquy_slider ) {soliloquy_slider = {};}jQuery('#soliloquy-container-30342').css('height', Math.round(jQuery('#soliloquy-container-30342').width()/(960/300)));jQuery(window).load(function(){var $ = jQuery;var soliloquy_container_30342 = $('#soliloquy-container-30342'),soliloquy_30342 = $('#soliloquy-30342');soliloquy_slider['30342'] = soliloquy_30342.soliloquy({slideSelector: '.soliloquy-item',speed: 0,pause: 2000,auto: 1,useCSS: 0,keyboard: true,adaptiveHeight: 1,adaptiveHeightSpeed: 400,infiniteLoop: 1,mode: 'fade',pager: 1,controls: 1,nextText: '',prevText: '',startText: '',stopText: '',onSliderLoad: function(currentIndex){soliloquy_container_30342.find('.soliloquy-active-slide').removeClass('soliloquy-active-slide').attr('aria-hidden','true');soliloquy_container_30342.css({'height':'auto','background-image':'none'});if ( soliloquy_container_30342.find('.soliloquy-slider li').length > 1 ) {soliloquy_container_30342.find('.soliloquy-controls').fadeTo(300, 1);}soliloquy_30342.find('.soliloquy-item:not(.soliloquy-clone):eq(' + currentIndex + ')').addClass('soliloquy-active-slide').attr('aria-hidden','false');soliloquy_container_30342.find('.soliloquy-clone').find('*').removeAttr('id');soliloquy_container_30342.find('.soliloquy-controls-direction').attr('aria-label','carousel buttons').attr('aria-controls', 'soliloquy-container-30342');soliloquy_container_30342.find('.soliloquy-controls-direction a.soliloquy-prev').attr('aria-label','previous');soliloquy_container_30342.find('.soliloquy-controls-direction a.soliloquy-next').attr('aria-label','next');},onSlideBefore: function(element, oldIndex, newIndex){soliloquy_container_30342.find('.soliloquy-active-slide').removeClass('soliloquy-active-slide').attr('aria-hidden','true');$(element).addClass('soliloquy-active-slide').attr('aria-hidden','false');},onSlideAfter: function(element, oldIndex, newIndex){},});});			</script>
			
</body>
</html>